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DISTORTING OBJECTS
WITH THE PUPPET TOOLS
Lesson overview
In this lesson, you’ll learn how to do the following:

• Place Deform pins using the Puppet Pin tool.
• Define areas of overlap using the Puppet Overlap tool.
• Stiffen parts of an image using the Puppet Starch tool.
• Animate the position of Deform pins.
• Record animation using the Puppet Sketch tool.
• Animate facial expressions with Character Animator.
This lesson will take approximately an hour to complete. Download the
project files for this lesson, following the instructions in the Getting

Started section under “Accessing the lesson files and Web Edition,” if
you haven’t already done so. As you work on this lesson, you’ll preserve
the start files. If you need to restore the start files, download them from
your Account page.
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PROJECT: ANIMATED ILLUSTRATION

Pull, squash, stretch, and otherwise deform objects
on the screen using the Puppet tools. Whether you’re
creating realistic animations, fantastic scenarios,
or modern art, the Puppet tools will expand your
creative freedom.
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Getting started
Using the Puppet tools in After Effects, you can add natural motion to raster
images and vector graphics. Three tools create pins to define the point of deformation, areas of overlap, and areas that should remain more rigid. An additional tool,
the Puppet Sketch tool, lets you record animation in real time. In this lesson, you’ll
use the Puppet tools to animate a crab’s pincers in an advertisement.
Start by previewing the final movie and then setting up the project.
1 Make sure the following files are in the Lessons/Lesson08 folder on your hard
disk, or download them from your Account page at www.peachpit.com now:

• In the Assets folder: crab.psd, text.psd, water_background.mov
• In the Sample_Movies folder: Lesson08.avi, Lesson08.mov
2 Open and play the Lesson08.avi sample movie in Windows Media Player or the
Lesson08.mov sample movie in QuickTime Player to see what you will create
in this lesson. When you are done, close Windows Media Player or QuickTime
Player. You may delete the sample movies from your hard disk if you have limited
storage space.
When you begin this lesson, restore the default application settings for After Effects.
See “Restoring default preferences” on page 2.
3 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows)
or Command+Option+Shift (Mac OS). When prompted, click OK to delete your
preferences. Close the Start window.
After Effects opens to display a blank, untitled project.
4 Choose File > Save As > Save As.
5 In the Save As dialog box, navigate to the Lessons/Lesson08/
Finished_Project folder.
6 Name the project Lesson08_Finished.aep, and then click Save.

Importing footage
You’ll import two Adobe Photoshop files and a background movie.
1 Choose File > Import > File.
2 Navigate to the Lessons/Lesson08/Assets folder. Press Ctrl or Command to
select the crab.psd and water_background.mov files. Then click Import or
Open. The assets appear in the Project panel.

200

LESSON 8

Distorting Objects with the Puppet Tools

3 Double-click an empty area in the Project panel to open the Import File dialog
box again. Select the text.psd file in the Lessons/Lesson08/Assets folder.
4 Choose Composition – Retain Layer Sizes from the Import As menu. (In Mac
OS, you may need to click Options to see the Import As menu.) Then click
Import or Open.
5 In the Text.psd dialog box, select Editable Layer Styles, and click OK. The
imported file is added as a composition to the Project panel; its layers are added
in a separate folder.

Creating the composition
As with any project, you need to create a new composition.
1 Click New Composition in the Composition panel.

2 Name the composition Blue Crab.
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3 Choose NTSC DV from the Preset pop-up menu. The preset automatically
sets the width, height, pixel aspect ratio, and frame rate for the composition.
4 In the Duration field, type 1000 to specify 10 seconds.
5 Change the Background Color to a deep cyan color. Then click OK to close the
New Composition dialog box.

After Effects opens the new composition in the Timeline and Composition panels.

Adding the background
It’s easier to animate the image in context, so first you’ll add the background
to the composition.
1 Press the Home key, or move the current-time indicator to the beginning
of the composition.
2 Drag the water_background.mov file to the Timeline panel.
3 Click the Lock icon ( ) for the layer to prevent accidental changes to it.
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Animating imported text
The final movie includes two lines of animated text. Because you imported the
text.psd file as a composition with layers intact, you can work on it in its own
Timeline panel, editing and animating its layers independently. You’ll add an animation preset to each layer.
1 Drag the text composition from the Project panel into the Timeline panel,
placing it at the top of the layer stack.

2 Double-click the text composition to open it in its own Timeline panel.
3 Shift-click to select both layers in the text Timeline panel, and choose Layer >
Convert to Editable Text. (Click OK if you see a warning about missing fonts.)

Now the text layers can be edited, so you can apply animation presets.
4 Go to 3:00. Then deselect both layers, and select only the BLUE CRAB layer.
5 In the Effects and Presets panel, search for the Fly In With A Twist animation
preset. Then drag it onto the BLUE CRAB layer.

The text will begin to fly in at 3:00 and finish at 5:16. After Effects adds the keyframes for the effect.
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6 Go to 5:21, and select the charter services layer.
7 In the Effects and Presets panel, search for the Slow Fade On animation preset.
Then drag it onto the charter services layer.
8 Return to the Blue Crab Timeline panel, and move the current-time indicator
to the beginning of the time ruler. Press the spacebar to preview the animation.
Press the spacebar again to stop playback.

9 Choose File > Save to save your work so far.

Scaling an object
Next, you’ll add the crab. You’ll animate it so that it fills the screen at the beginning
of the movie, then quickly shrinks and moves into position above the area where
the text will appear.
1 Drag the crab.psd file from the Project panel to the top layer in the
Timeline panel.
2 Press the Home key to move the current-time indicator to the beginning of the
time ruler.
3 Select the crab.psd layer in the Timeline panel, and press S to display its Scale
property.

4 Change the Scale value to 400%.
5 Click the stopwatch icon ( ) next to Scale to create an initial keyframe.
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6 Move to 2:00, and change the Scale to 75%.

The crab will scale appropriately, but its position isn’t quite right.
7 Press the Home key to return to the beginning of the time ruler.
8 Press P to display the layer’s Position property, and change the Position to
360, 82. The crab moves up to fill the composition.
9 Click the stopwatch icon next to Position to create an initial keyframe.
10 Go to 1:15, and change the Position to 360, 228.
11 Go to 2:00, and change the Position to 360,182.
12 Drag the current-time indicator across the first two seconds of the time ruler to
see the crab animation.

13 Hide the properties for the crab.psd layer, and choose File > Save.

About the Puppet tools
The Puppet tools turn raster and vector images into virtual marionettes. When
you move the string of a marionette, the body part attached to that string moves;
pull the string attached to the hand, and the hand goes up. The Puppet tools use
pins to indicate where strings would be attached.
The Puppet effect deforms parts of an image based on the positions of pins that
you place and animate. These pins determine which parts of the image should
move, which parts should remain rigid, and which parts should be in front when
areas overlap.
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There are three kinds of pins, each placed by a different tool:

• The Puppet Pin tool ( ) places and moves Deform pins, which deform a layer.
• The Puppet Overlap tool ( ) places Overlap pins, which indicate the parts
of an image that should be in the front when areas overlap.

• The Puppet Starch tool ( ) places Starch pins, which stiffen parts of the image
so that they are distorted less.

 Note: The mesh is

calculated at the frame
where the Deform pins
are applied. If you add
more pins anywhere
in the timeline, they
are placed based on
the original position
of the mesh.

As soon as you place a pin, the area within an outline is automatically divided into
a mesh of triangles. Each part of the mesh is associated with the pixels of the image,
so as the mesh moves, so do the pixels. When you animate a Deform pin, the mesh
deforms more in the area closest to the pin, while keeping the overall shape as rigid
as possible. For example, if you animate a pin in a character’s hand, the hand and
arm will be deformed, but most of the character will remain in place.

Adding Deform pins
Deform pins are the main component of the Puppet effect. Where you place these
pins and how you position them determine how the objects move on the screen.
You’ll place Deform pins and display the mesh that After Effects creates to determine the area of influence for each pin.
When you select the Puppet Pin tool, the Tools panel displays the Puppet tool
options. Each pin has its own properties in the Timeline panel, and After Effects
automatically creates an initial keyframe for each pin.
1 Select the Puppet Pin tool ( ) in the Tools panel.

2 Go to 1:27, just before the crab scales down to its final size.
3 In the Composition panel, place a Deform pin of the crab’s left pincer.
A yellow dot representing the Deform pin appears in the Composition panel. If at
this point you were to use the Selection tool ( ) to move the Deform pin, the entire
crab would move with it. You need more pins to keep the other parts of the mesh
in place.
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4 Using the Puppet Pin tool, place another Deform pin in the middle of the
right pincer.

Now you can move a pincer with the Selection tool. The more pins you place, the
smaller the area of influence for each pin, and the less each area will stretch.
5 Select the Selection tool ( ), and drag one of the Deform pins to see its effect.
Then return it to its original position by pressing Ctrl+Z (Windows) or
Command+Z (Mac OS).

6 Place additional Deform pins at the top of each antenna, at the end of each side
leg, and at the tip of each of the crab’s swimming legs.

7 In the Timeline panel, expand the Mesh 1 > Deform properties. Each Deform
pin is listed.
Depending on the type of animation you’re performing, you may want to name the
pins. In this case, you’ll name just the pincer and antenna pins.
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8 Select Puppet Pin 1, press Enter or Return, and rename the pin Left Pincer.
Press Enter or Return again to accept the new name.
9 Rename the corresponding pins Right Pincer, Left Antenna, and Right
Antenna. Which pins you rename depends on the order in which you placed
them. You do not need to name the pins on the legs unless you want to.

10 Select Show in the options section of the Tools panel to display the
distortion mesh.
The crab is nearly the same color as the triangles in the mesh, so you’ll need to look
closely to see the mesh.
E Tip: You can extend

the mesh beyond the
outline of the layer
in order to ensure a
stroke is included in the
deformation. To expand
the mesh, increase the
Expansion property in
the options section of
the Tools panel.

11 Change the Triangles value in the options section of the Tools panel to 300.
The Triangles setting determines how many triangles are included in the mesh.
Increasing the number of triangles results in a smoother animation, but also
increases rendering time.

12 Choose File > Save to save your work so far.
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Defining areas of overlap
If your animation requires part of the object or character to pass in front of another,
use the Puppet Overlap tool to define the areas that should appear in front when
areas overlap. Select the Puppet Overlap tool, which is hidden behind the Puppet
Pin tool in the Tools panel, click Show to display the mesh, and then click intersections in the mesh to place Overlap pins in the areas that should always remain
in front.

You can adjust the effect of the Overlap pins in the optoins area of the Tools panel.
The In Front value determines the apparent proximity to the viewer; setting the
value to 100% prevents those parts of the body that are overlapped from showing
through. The Extent value determines how far the overlap influence extends for the
pin; the affected area appears lighter in the Composition panel.

Stiffening an area
The pincers, legs, and antennae of the crab will move in the animation, but the carapace should stay firm. You’ll use the Puppet Starch tool to add Starch pins to ensure
the carapace isn’t affected by the pins’ movements.
1 Select the Puppet Starch tool (
in the Tools panel.

), which is hidden behind the Puppet Pin tool

2 Select Show in the options area of the Tools panel to display the distortion mesh.
3 Place Starch pins at the base of each pincer, leg, and antenna to stiffen the entire
carapace, as in the image below.

 Note: The Amount

value determines how
rigid the area will be.
Typically, a low value is
fine; higher values make
the area more rigid. You
can also use negative
numbers to reduce the
rigidity of another pin.

 Note: You must

4 Hide the properties for the crab.psd layer in the Timeline panel.

select the Show option
separately for each
Puppet tool. You can
also place pins without
viewing the mesh.

5 Choose File > Save to save your work so far.
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Squash and stretch
Squash and stretch is a traditional animation technique that adds realism and
weight to objects. It’s an exaggeration of the effect that occurs in real life when a
moving object comes into contact with a stationary object, such as the ground.
When squashing and stretching are applied correctly, the volume of the character
doesn’t change. If you use the Puppet tools to animate cartoon characters or similar
objects, consider how they interact with other objects.
The easiest way to understand the principle of squash and stretch is to view an
animation of a bouncing ball. As the ball lands, it partially flattens, or squashes.
As it bounces up, it stretches.

Animating pin positions
The Deform and Starch pins are in place. Now you can change the Deform pin
positions to animate the crab. The Starch pins keep specific areas (in this case, the
carapace) from moving too much.
When you placed the pins, After Effects created initial keyframes for each pin at
1:27. You’ll animate the pins so that the crab waves its pincers, legs, and antennae,
and then returns to its original position.
1 Select the crab.psd layer in the Timeline panel, and then press U to display all the
keyframes for the layer.
2 Go to 4:00, and then move the pins in both pincers so that they’re almost vertical.
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3 Go to 5:00, and move the Left Pincer and Right Pincer pins so that the pincers
are further apart.
4 At 6:19, turn the pincers back inward. Then, at 8:19, position them so that
they’re roughly vertical again. At 9:29, move the pincers so that they’re fully
turned inward.
5 Move the current-time indicator across the time ruler to see the pincers wave.

Next, you’ll move the antennae closer together. The first keyframe already exists, so
you need only to create one more.
6 Go to 7:14, and pull the pins on the antennae closer to each other.
Now you can animate all the legs. You want them to start moving even before the
pincers do, and they should wave around a bit.
8 Go to 1:19, and move the pin on each leg so that each leg is slightly longer and
curved outward.
9 Make changes to each leg at 2:01, 4:00, 6:17, and 8:10 so that the legs move
slightly upward or downward, in and out as the video progresses. Move each pin
about the same amount each time, in whatever direction you choose.
10 Press F2 or click an empty area of the Timeline panel to deselect all layers. Then,
press the Home key or move the current-time indicator to the beginning of the
time ruler.
11 Press the spacebar to preview your animation. Press the spacebar again to stop
playback. If you want to change the animation, adjust pins at each keyframe.

11 Choose File > Save to save your animation.
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Recording animation
Changing the position of each pin at each keyframe worked, but you probably found
the process to be slow and tedious. Instead of manually animating keyframes, you
can use the Puppet Sketch tool to drag the pins into position in real time. After
Effects starts recording the motion as soon as you begin dragging a pin, and it stops
recording when you release the mouse button. The composition moves forward
through time as you move the pin. When you stop recording, the current-time indicator returns to the point at which you began recording, so that you can record the
path for another pin during the same time period.
Experiment with this method of animation as you re-create the pincers’ movement
using the Puppet Sketch tool.
E Tip: By default,

the motion is played
back at the speed at
which it was recorded.
To change the ratio
of recording speed to
playback speed, click
Record Options in
the Tools panel, and
change the Speed value
before recording.

1 Choose File > Save As > Save As, and name the project Motionsketch.aep.
Save it in the Lesson08/Finished_Project folder.
2 Move the current-time indicator to 1:27.
3 In the Timeline panel, select the crab.psd layer and press U to display all the
keyframes for the layer.
4 Scroll down to the Left Pincer and Right Pincer pins. Drag to select all
keyframes for those pins after 2:08, and then delete the keyframes.

The animation for the other pins remains, but you’ve removed the keyframes that
animate the pincers. Depending on where you placed Starch pins, the pincers may
move slightly in response to other pins’ movements.
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5 Select the Puppet Pin tool ( ) in the Tools panel.
6 In the Timeline panel, select Puppet to see the pins in the Composition panel.

7 Select a pin in the Composition panel, and press Ctrl (Windows) or Command
(Mac OS) to activate the Puppet Sketch tool. (A clock icon appears next to
the pointer).
8 Continue to hold down Ctrl or Command as you drag the Left Pincer pin into
different positions for the length of the video. Release the mouse button when
you’ve finished. The current-time indicator returns to 1:27.
9 Press Ctrl or Command, and drag the Right Pincer pin into different positions.
Use the outline of the crab and the other pincer’s movements to guide you.
Release the mouse button to stop recording.

10 Preview the final animation.
You’ve used the Puppet tools to create a realistic, engaging animation. Remember
that you can use the Puppet tools to deform and manipulate many kinds of objects.
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Act it out with Adobe Character Animator
If you identify strongly with your characters, you might want to use Adobe Character Animator
instead of creating cumbersome keyframes. It’s especially useful if you’re creating a long scene or you
need to match the character’s mouth to speech. It’s also a lot of fun.
Character Animator is included in an Adobe Creative Cloud membership. With it, you can import a
character you’ve created in Photoshop or Illustrator, and then act out facial gestures and head movements in front of your webcam; your character mirrors your gestures on the screen. If you speak, the
character’s mouth moves to match your words.
You can move other body parts, such as legs and arms, using keyboard shortcuts or your mouse or
tablet. And you can set up dangling behavior so that, for example, if a rabbit’s head moves to the left,
its ears dangle with it.
Character Animator includes some entertaining interactive tutorials to help you get started. To learn
more, go to https://www.adobe.com/products/character-animator.html.

Tips for a smooth animation experience:
•

Create different layers for different moving
parts: draw the mouth on one layer, the right
eye on another, and so on.

•

Name layers so Character Animator will
recognize them. Certain words, such as
“pupil,” help map the character to the image
in the camera.

•
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Practice facial and other gestures before
recording. Once you’ve set your Rest Pose, try
different mouth shapes, eyebrow raises, head
waggles, and other movements to see how
subtle or exaggerated movements translate
for your character.
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•

Speak into the microphone as you record.
Many mouth shapes are triggered by audio
cues, such as “uh-oh,” and the character’s
mouth movements will be synced to your
words automatically.

•

Especially at first, consider using an existing
character file as a template. It’ll be easier to
get the layer names right.

•

Try animating objects that don’t have
faces and bodies. For example, you can
use Character Animator to animate clouds
floating, a flag waving, or flowers opening. Be
creative and have fun!

Review questions
1 What’s the difference between the Puppet Pin tool and the Puppet Overlap tool?
2 When would you use the Puppet Starch tool?
3 Describe two methods of animating pin positions.

Review answers
1 The Puppet Pin tool creates Deform pins, which define the position of a portion of the
image as the image is deformed. The Puppet Overlap tool creates Overlap pins, which
determine which areas of an object remain in front when two areas overlap.
2 Use the Puppet Starch tool to add Starch pins to an area that you want to remain more
rigid while other areas of the object are distorted.
3 You can manually animate pin positions by changing the position for each pin in the
Timeline panel. To animate pin positions more quickly, use the Puppet Sketch tool:
With the Puppet Pin tool selected, press Ctrl or Command, and drag a pin to record
its movement.
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