
ColdFusion applications are made up of files—lots and lots of files. These files are plain text files 
containing CFML, HTML, SQL, JavaScript, CSS, and more. Because they are plain text files, 
ColdFusion developers are free to use any editor they like to write and edit their applications.

caution

Although you can indeed use any editor, you must use editors that save files as plain text. This means that you should not use word 
processors (like Microsoft Word) to edit source code.

One of the most exciting and eagerly anticipated additions in ColdFusion 9 is the ColdFusion 
Builder, a new development environment designed specifically for us ColdFusion developers.

note

You’ll need to have ColdFusion Builder installed before working through this chapter. For installation instructions and notes, see 
Appendix A, “Installing ColdFusion and Development Environments.”

The Relationship Between ColdFusion Builder and Eclipse
ColdFusion Builder is an integrated development environment, or IDE. That’s important. Cold­
Fusion Builder is more than a text editor. Rather, it is a complete workspace for ColdFusion devel­
opment, supporting ColdFusion itself and lots of related and supported products and technologies.

ColdFusion is built on top of Eclipse. Eclipse is an open source, Java­based application development 
environment, and it is used by millions of developers working in all sorts of programming languages. 
ColdFusion development using Eclipse has long been supported by the ColdFusion community, and 
now ColdFusion Builder provides an official ColdFusion development environment built on this same 
trusted platform.
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note

Eclipse is not an Adobe product: it is an open source technology supported by Adobe and many other organizations and 
 individuals. To learn more about Eclipse, visit http://eclipse.org/.

ColdFusion Builder is designed to be installed and used in either of two ways:

If you have no prior experience with Eclipse and do not have an existing Eclipse instal­■■

lation, then you can just install and use ColdFusion Builder as a standalone application 
without paying any attention to the Eclipse internals until you are ready to do so.

If you already use Eclipse (or other Eclipse­based tools, such as Adobe Flash Builder), ■■

then ColdFusion Builder can be installed as a plug­in inside that existing Eclipse 
application. This way, you’ll have a single integrated development environment for all 
projects.

Eclipse is a code­centric tool, and it is designed for experienced coders. Eclipse lacks the design 
tools that many users love in Adobe Dreamweaver, but by concentrating on just what hard­core 
coders need, it does a better job of addressing this group’s unique requirements.

note

Adobe Flash Builder is also built on Eclipse. Many ColdFusion developers also write Flex applications, and so Adobe Flash 
Builder and ColdFusion Builder, both built on Eclipse, can provide a single environment to work on both.

Getting Started with ColdFusion Builder
When you launch ColdFusion Builder, you will see a screen similar to the one in Figure 3.1. (The 
exact screen layout may differ depending on the operating system you’re using and the plug­ins 
that you have installed.)

note

Not seeing a screen like the one in Figure 3.1? Depending on how ColdFusion Builder and Eclipse are configured, you may be 
presented with an Eclipse splash screen. If this is the case, just click the X button in the tab above the splash screen.

A Note About Perspectives
As already noted, ColdFusion Builder is built on Eclipse, and Eclipse can be used for many types 
of languages and development, and each language has different editor needs. To address all the 
different requirements of different languages, Eclipse supports a feature called perspectives.

A perspective is a simply a group of configuration settings that you can activate as needed. As a rule, 
when writing ColdFusion code, you’ll want to use the ColdFusion perspective. When you start 
ColdFusion Builder you should automatically be in the ColdFusion perspective, and so more often 
than not, you can ignore perspectives altogether. But just in case, here’s what you need to know.
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Figure 3.1

The ColdFusion 
Builder screen 
features the editor and 
supporting panels.

 

The current perspective is displayed at the top right of the ColdFusion Builder screen. If you see 
a little CF icon with the word ColdFusion next to it, then you should be good to go. If you need to 
change the current perspective, use the Window > Open Perspective menu options. The Cold­
Fusion perspective will be listed under Other. In addition, recently used perspectives are usually 
displayed at the top right of the screen for easy selection.

The ColdFusion Builder Screen
The ColdFusion Builder screen, seen in Figure 3.1, is divided into paneled sections:

The Navigator panel (shown on the left in Figure 3.1, though it can be moved elsewhere) ■■

is used to browse and open projects and files.

Beneath the Navigator panel is the File panel, which provides access to folders, files, ■■

FTP, and more.

The top­right side of the screen is a window containing three panels that can be selected ■■

by their named tabs. The Outline panel shows the code outline for the open and 
selected file (and is therefore empty if no file is open). The RDS Dataview panel provides 
access to all ColdFusion data sources. The RDS Fileview panel provides access to files 
and folders on the ColdFusion server (this panel is only really of use when you’re work­
ing with a remote ColdFusion server).

At the bottom right is the Snippets panel, which can be used to store and access reusable ■■

chunks of code.
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The large area in the middle of the screen is the actual ColdFusion Builder editor win­■■

dow. When you are working in a file, CFML toolbars and buttons will be displayed at 
the top of this area.

Beneath the editor area is a block containing a series of very important tabs. We’ll use ■■

the Servers tab in a moment, and others in later chapters.

At the top of the screen are toolbars and buttons used to open and save files, and more.■■

tip

Panels can be moved around and repositioned as desired. For example, I personally like my editor window to be as big as pos-
sible, so I moved my Outline and Snippets panels into tabs alongside my File panel, and my two RDS panels into tabs below the 
editor. Feel free to move panels as you see fit.

Defining the ColdFusion Server
For many ColdFusion Builder features to work, the tool needs to know how to connect to your 
ColdFusion Server. Thus, the first thing you should do is define your ColdFusion Server.

Here are the steps to define your local ColdFusion Server:

 1. Click the Servers tab beneath the editor area. This tab displays a list of defined servers 
and will initially be empty.

 2. Locate the Add Server button in the toolbar right below the tabs; it’s the one with a pic­
ture of a computer with a yellow + sign on it. Click the Add Server button to display the 
Add Server window.

 3. Select ColdFusion and click OK to display the New ColdFusion Server Setup window 
(shown in Figure 3.2).

 4. Some of the fields in the New ColdFusion Server Setup window apply only to J2EE con­
figuration installations. For typical local ColdFusion development installations, specify 
the following:

Server Name: localhost

Host Name: localhost

WebServer Port: 8500

RDS Password: The RDS password provided at ColdFusion installation time

 5. Click Next to display the Local Server Settings window.

 6. In the Server Home field, enter the root of the ColdFusion installation. On Windows 
computers, the root will usually be C:\ColdFusion9. The Document Root field should be 
filled in automatically (if the Server Home specification is correct). Set the version to 9 
(or 9.0.x).
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Figure 3.2

The first thing you 
should do upon 
running ColdFusion 
Builder is define your 
ColdFusion Server 
connection.

 

 7. Click Next to display the Install Extensions window.

 8. Make sure Install Extensions is checked and click Finish.

You should see your localhost server now listed on the Servers tab, and the Status area 
should say Running (indicating that ColdFusion Server is running and ColdFusion 
Builder can connect to it).

You can verify that ColdFusion Builder is communicating with ColdFusion Server by opening the 
RDS Dataview tab and expanding the localhost data source entered there. If that data source is 
present, and if you can expand it to see the tables and their contents, then all is well.

tip

You can right-click servers listed on the Servers tab to quickly access the ColdFusion Administrator, stop and start ColdFusion, 
and more.

note

If you develop on multiple ColdFusion servers (perhaps one local, one for testing, and others), you can define each of those 
 ColdFusion servers within ColdFusion Builder. This way, you can write and test using them all.

Creating a Project
ColdFusion development almost never involves a single file. Rather, ColdFusion applications are 
usually large (and ever growing) collections of files and folders. In ColdFusion Builder, each appli­
cation you work on is defined as a project, and you can define as many projects as you need.
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All the lessons in these books build parts of an application for Orange Whip Studios, or OWS. 
Therefore, we’ll create a project named ows. Here are the steps:

 1. Locate the ColdFusion Builder File menu and choose File > New > ColdFusion Project 
to display the New ColdFusion Project window. (You can also right­click in the Naviga­
tor panel and choose New > ColdFusion Project.)

 2. Specify OWS as the project name.

 3. Uncheck the Use Default Location option, and for the Project Location specify the 
application path (on a Windows computer with the default configuration, the path 
should be C:\ColdFusion9\wwwroot\OWS). Then click Next.

 4. You now need to specify the ColdFusion Server to use for this project. Select Localhost 
(the server you just defined) from the Servers drop­down list. Then click Next.

 5. The final screen will ask you about additional sources and applications. Leave these all 
as set and click Finish.

You now have a project set up for use with the applications in this book. The new project will 
automatically be opened in the Navigator panel. If ever the project is not opened, you can open it 
by right­clicking it in the Navigator panel and choosing Open Project, or by double­clicking it.

Working with Files
Now that you’ve successfully defined the ows project, here are a few basic file access techniques 
that you should know.

Creating Folders

To create new folders in ColdFusion Builder, select the folder to contain the new folder, right­click 
(Windows) or Control­click (Mac), and choose New > Folder. You’ll be prompted for the folder 
name; enter it and then click Finish.

Creating Files

To create new files in ColdFusion Builder, select the folder to contain the new file, right­click 
(Windows) or Control­click (Mac), and choose New > ColdFusion Page. You’ll be prompted for 
the file name; enter it and then click Finish.

tip

As explained in Chapter 1, ColdFusion files need a .cfm extension. However, when you enter the file name, you can omit the 
extension and ColdFusion Builder will add it for you.

Saving, Closing, and Opening Files

To save a file, do one of the following:

Press Ctrl­S (Windows) or Command­S (Mac).■■
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Choose Save from the File menu.■■

Click the Save button on the toolbar (it is a picture of a diskette).■■

To close a file, do one of the following:

Press Ctrl­W (Windows) or Command­W (Mac).■■

Choose Close from the File menu.■■

tip

Windows users can press Ctrl-F4 to close an open file.

To open a file, do one of the following:

Choose Open from the File menu.■■

Double­click the file in the Navigator panel.■■

And with that, you’re ready to begin ColdFusion development using ColdFusion Builder.




