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Instructor notes

Getting started
The Adobe® Muse® CC Classroom in a Book® course presents students with tips, 
techniques, and solutions for using the Adobe Muse software.

The Instructor Notes are intended to complement the information in the Adobe® 
Muse® CC Classroom in a Book® (2014 release). The information is organized to fol-
low the sequence of instruction in each lesson. These notes are not a play-by-play 
of each subsection of the book; rather, they point out specific areas where we feel 
you can expand on the lesson or perhaps introduce tangential subjects that may not 
be covered in the text.

course strategy
Adobe Muse CC Classroom in a Book (2014 release) contains eleven lessons, so you 
can cover approximately one per session if you’re teaching a ten-session class. Keep 
in mind, however, that some lessons may take a while to complete; your class and 
the lessons may not map exactly one-to-one. 

Suggestions for combining some of the lessons into a single class if you have fewer 
sessions are below:

• Lesson 1 teaches the elements of the Adobe Muse user interface.

• Lesson 2 covers site creation and working with pages in Plan mode. Lesson 3 
focuses on working with a key feature of Muse: master pages. With master 
pages and their guides, for example, you can easily specify and change elements 
common to all your pages, such as header and footer areas.

Because Lessons 2 and 3 cover Plan mode, you may wish to combine them into 
a single session, depending on the course length.

• Lesson 4 covers working with text and formatting properties.

• Lesson 5 covers aspects of working with shapes, color, and images. Students can 
handle many basic transforming issues within Muse without the need to switch 
to another editor like Adobe Photoshop. This lesson is longer and should stand 
on its own.

• Lesson 6 discusses creating links and buttons. This lesson is an important one 
and should be covered in detail, because linking is a skill that students will use 
in every site they create. 
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• Lesson 7 focuses on inserting, formatting, and adding content to several types 
of widgets. We cover at least one example of each type of widget, resulting in a 
very long chapter. You may wish to either split up the chapter into lessons, or 
focus specifically on a few of the widgets to give the idea of how they work.

• Lesson 8 shows how to incorporate creative content: adding effects (shadows, 
glows, and bevels), changing opacity, and rounding corners. It also discusses 
working with graphic styles, which can save students a lot of time. 

You could combine lessons 6 and 8 and simply pare down the number of 
examples shown.

• Lesson 9 covers working with the Library panel and inserting HTML, which can 
add a lot more functionality to a site than even Muse has to offer.

• Lesson 10 shows you how to optimize the content of the site for mobile devices 
using alternate layouts. Although most students will be interested in learning 
this content, this lesson can be skipped if it’s outside of the focus of the class or 
time is limited.

• Lesson 11, the final lesson, shows you how to publish your site to Business Catalyst 
or export your site so that you can host the site using your service provider.

Managing student projects
One way to simplify file storage and retrieval in classroom situations is to ask stu-
dents each to create a folder on their hard disks, name it [student’s name] Lessons, 
and then copy each project folder into the main Lessons folder. Having students 
keep all their working files in their own Lessons folders makes it easy for you to 
clean up files when a class is over. Encourage students to save their work to their 
own media as well.

Fonts to be installed
To ensure that the lesson files work properly, make sure to install the fonts found 
in the Lessons folder you download. You can install these required fonts on either 
Mac OS or Windows. There is only one font that is used and it is not crucial that it 
is installed. It is used in Lesson 4, “Adding and Styling Text,” when applying fonts. 
You could skip the installation and simply have students choose another font.
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Lesson 1: An Introduction to Adobe Muse
The first lesson presents an introduction to the Adobe Muse CC software. Using 
the basic commands, tools, and panels, your students will learn general techniques 
for using the work area efficiently, obtaining information about the image in front 
of them, and selecting tools or entering values to change content on pages.

Goals for this lesson
This is a foundation section for all students who are new to Adobe Muse, even if 
they are already familiar with other Adobe applications, such as Adobe InDesign. 
The overall objective for Lesson 1 is to make students sufficiently familiar with the 
modes and user interface of Muse so that they can locate the controls they need for 
the rest of the lessons. Additionally, by learning how to help themselves, students 
gain confidence and independence. In general, they should be able to

• Understand the different modes (Plan, Design, and Preview)

• Identify and name the key areas of the interface, including the Toolbar and the 
Control panel

• Open the main menus and submenus across the top of the work area (File, Edit, 
and so forth), context menus, and panel menus

• Edit and reset components of the workspace 

the Muse workflow 
The initial section describes the typical Muse workflow for building a website. 
Although this workflow scenario is not the only one that you can use with Muse, 
it is an important one. More experienced web designers and developers may skim 
this section. Novices, however, will benefit from it as well as the file named client_
questions.pdf found in the Lessons folder, which lists the types of questions to ask 
of a client when building her website.

As a side note, you may wish to point out that Adobe Muse has a lot of potential 
uses beyond just creating websites. For example, a web designer could express site 
design and functionality to a development team using Muse by “wireframing” the 
site functionality in Muse. This would allow the designer to flesh out his design and 
navigation ideas more fully to the development team.

Also, the introduction section on a typical Muse workflow mentions the possibil-
ity of mobile optimization. Throughout the lessons, the focus will be on desktop 
design. When students get to Lesson 10, they will create alternate layouts for the 
different mobile devices.
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touring the workspace
One thing to mention here: the Welcome Screen that appears when Muse is 
launched may not have the same content or look the same on everyone’s machine. 
Some users will see expanded learning content, while others will see a more typical 
Welcome Screen. That’s okay and is expected.

understanding modes
While working in Adobe Muse, students will be jumping between the different 
modes frequently. When students first create a .muse site file, for example, they 
begin in Plan mode. Quite often I compare working in Plan mode to using the 
Pages panel in Adobe InDesign to determine the site map (number and structure 
of the pages). This comparison works well for students currently using InDesign.

Remind students that there are keyboard shortcuts for accessing the different 
modes found at the top of the View menu.

Working in Design mode
You may want to introduce students to the Design mode environment by provid-
ing a general tour of the work area. This helps orient the students and provides a 
review of the names of the elements on the screen. For example, you may point out 
the mode buttons and remind students that these indicate which mode is currently 
active. Then point out the menu bar, the Toolbar, the Control panel, and the other 
panels. Since Muse now has a “dark UI” and has a very similar workspace to other 
Adobe applications like Adobe InDesign, including a similar method for managing 
panels, students should feel right at home.

To enter Design mode, students can double-click a page thumbnail in the site 
map of Plan mode, or choose View > Design, or click the Design mode link. If you 
don’t already have a page open, entering Design mode opens your site’s first page 
(the Home page).

Students may already be used to keyboard shortcuts as a simple alternative to using 
the mouse. Adobe Muse and other Adobe products allow you to combine keys with 
mouse clicks to perform tasks quickly. Also, a lot of the keyboard shortcuts in other 
Adobe applications like InDesign are shared with Adobe Muse.

the control panel
Like other Adobe applications (InDesign and Illustrator, for example), Adobe Muse 
has a Control panel at the top of the Application window in Design mode. The 
Control panel changes display information depending on what is selected. Remind 
students that the Selection Indicator is a very useful tool to help them determine 
what is selected in Muse and that they can find it at the left end of the Control 
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panel in the form of a word or words. Make sure that students use the Selection 
Indicator, especially when working with widgets much later in the lessons. It is too 
easy to apply formatting to the wrong selection.

the toolbar
Similar to other Adobe applications, the Toolbar is visible and can be moved within 
the workspace. For students with experience in other Adobe applications like 
InDesign, the Toolbar in Muse will seem much simpler, containing only the most 
essential tools. Students will quickly find that each of the tools can perform mul-
tiple functions in Adobe Muse. For instance, the Rectangle tool is used to create 
squares, rectangles, rounded rectangles, lines, and in some cases, circles.

Viewing in Design mode
Point out that students can change magnification of a design by choosing a zoom 
level (to the right of the Toolbar). Many users are unaware that the monitor resolu-
tion can be changed, so you may want to demonstrate this. Increasing the resolu-
tion makes more room for panels, content in the Control panel, and page area on 
the screen, but with the trade-off of making everything smaller.

Remind students that their pages (images) will look best in Design mode in Muse at 
a zoom level of 100%. Most browsers, by default, view content at 100% (to start).

configuring panels and the panel dock
If students are used to working in the workspace of InDesign, Photoshop, or 
Illustrator, they will feel right at home with the workspace in Muse. Show students 
how easy it is to collapse panels to icons, and then expand the panels again with 
a click. In this section, students will customize a workspace. Make sure to show 
students that they can (and should) reset the workspace by choosing Window > 
Reset Panels.

using a context menu
Although it isn’t covered in a specific section, demonstrate how context menus change 
depending on the content under the pointer. Right-click the following examples:

• The blank area of a page

• An active object in the page area

• Text with an insertion point

• Any list panel

If your students use graphics tablets, encourage them to program their stylus but-
ton to display context menus.



8 instruCtor notes

using Preview mode
The last mode discussed is Preview mode. Many students ask why it is necessary to 
preview the pages of the site if they are just “going to work” in browsers. Preview 
mode is necessary to test links, show the full functionality of widgets like slide-
shows, and more.

Later in the lessons, students will discover that they can also preview either a page 
or the entire Muse site in the default browser installed on their machine as well.

The Preview mode in Muse is now open as a tab in the workspace. This may 
confuse students. Whenever you preview a page in Preview mode, the same 
Preview window is used. You could leave it open and even press the Refresh button 
to refresh to the latest version of the page showing in it. Students can leave the 
Preview window open if they wish.

using Adobe Muse Help
Choosing Help > Adobe Muse CC Help opens the Adobe Muse Help web page, 
which includes most of the official Muse support resources, as well as links to other 
online resources. Show students that Muse Help includes access to a variety of 
tutorials, both written and in video format.

Questions
The following questions are not in the student’s Classroom in a Book:

1 When you choose View > Design Mode or click the Design mode link, which 
page appears in Design mode?

2 How can you find the keyboard shortcut for a tool?

3 How can you instantly hide or show all panels?

4 What magnification is the best visual representation of the web page in 
Adobe Muse?

Answers
1 The Home page appears when you enter Design mode using the methods in 

the question.

2 Hold the pointer over the tool until the tooltip appears containing the keyboard 
shortcut for that tool.

3 Choose Window > Hide Panels to hide the dock of panels, and then choose 
Window > Show Panels to show them again.

4 The optimum magnification is 100%.
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Lesson 2: creating Your site
This is the first lesson where students begin creating in Adobe Muse. First, they 
create their site file, and then they spend most of their time in Plan mode working 
with the pages area of the site map.

Goals for this lesson
In Lesson 2, students will create their first .muse site file and explore the pages sec-
tion of Plan mode. (If they ask, Lesson 3 covers master pages in depth.)

In this lesson, students will learn

• How to create a .muse site file

• Why the organization of the site map in Plan mode can be so important

• How to add, delete, duplicate, and organize pages in Plan mode

• How to add metadata

creating a new site
Creating a .muse site file in Abode Muse is similar to creating an InDesign file 
(.indd) in Adobe InDesign. The .muse file in Muse contains all of the format-
ting, pages, and master pages for the site; any content, such as images or video 
(for instance), will be linked to by default. This means that students will need to 
be organized. Although Muse will “collect” any linked content when the site is 
previewed, published, or exported, it is better not to rely on Muse to track linked 
content. Rather, encourage students to keep all site content within a single site 
folder (in web developer terms called a “root folder”).

Because .muse files are cross platform, they can be opened on either the Mac OS 
or Windows version of Muse. If students plan on sharing the .muse file with others, 
they will need to gather everything into a single folder to send the site contents. 
That’s one way being organized as you work with Muse pays off.

When students open the New Site dialog box (File > New Site), the Initial Layout 
appears. This is an option that most beginners will not use initially, because you 
can add the other layouts later on after you design the initial layout. We will cover 
layouts in Lesson 10.

In the New Site dialog box, the Resolution option is something that we describe but 
do not use in the book. Know that setting the Resolution option to HiDPI (2x) will 
require that students make their images double the pixel dimensions in a program 
like Photoshop before saving them. That means that for an image to show at 100 
pixels wide in Muse, the image will need to be 200 pixels wide in Photoshop (for 
instance). This type of image is referred to as a retina image. We decided against 
using the Resolution option in the book, because it can be confusing to a beginner.
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creating and editing your site map
In this section, the students set up the site map and determine the number and 
organization of pages in the site before they begin adding design elements. Stress 
to students that they can jump right into the first page of their site in Design mode 
and start creating, adding, deleting, and organizing. They don’t have to follow the 
process in the book. If, however, they explore on their own, the default page names 
that they see may not match what is shown in the figures of the book. That’s okay. 
As new pages are added, Muse automatically gives them sequentially numbered 
names like Untitled 10, Untitled 11, and so on. As long as the students’ final names 
for their pages match what is listed in the book, they’ll be fine.

In Lesson 2, students will see how to add pages to their site map by adding sibling 
pages. It really is not critical that students memorize such terms as “sibling” or 
“parent/child,” as long as they understand the concepts. The terms simply provide a 
common language for speaking about the site map. 

Page metadata
This section covers metadata, which some students may purposefully overlook 
when building their own sites because it is not directly “seen” on their pages. Stress 
to them that page metadata can be useful not only for search engine optimization 
(SEO), but can also be useful in marketing their websites because the page meta-
data can appear in the search engine results.

In the “Adding page metadata” section, we instruct the user to “skip over the HTML 
for the <head> field.” You may wish to explain what they’re skipping: This sec-
tion of the Page Properties metadata can be very useful for adding such content 
as JavaScript libraries, other style sheets, additional meta tags, and much more to 
the <head> section of the HTML that is generated by Adobe Muse when the site is 
previewed, exported, or published. For instance, if a student finds code for a jQuery 
widget and wants to add it to their page, some of that code may link to a library. 
The HTML for <head> section of the Page Properties dialog box is where they may 
add the link to that script library.
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Questions
The following questions are not in the student’s Classroom in a Book:

1 In which file format is a Muse site file saved?

2 Where in Muse can you add a favicon to your pages?

3 Why can it be important to name the pages in the site map?

4 Child pages become what part of a menu widget added to a page?

5 What is one way adding metadata like title, description, and keywords to your 
pages can be beneficial to your website?

Answers
1 An Adobe Muse site file is saved in the .muse file format.

2 A favicon image can be added to your site pages by choosing File > Site 
Properties. In the Site Properties dialog box, with the Layout options selected, 
you can browse to the location of your favicon image to add it to your pages.

3 If you add a menu widget to your pages, the names of the top-level pages are 
added to the menu automatically.

4 Child pages in the site map will become submenu items in the menu widget that 
is dragged onto a page. Although submenu pages won’t appear by default, the 
menu options can be changed so that they do.

5 Adding metadata to your pages can help to improve the visibility of a website in 
search engines, as well as possibly give more information to users when they see 
the search results in some search engines.
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Lesson 3: Working With Master Pages
This lesson continues the discussion of Plan mode by focusing on working with 
and editing master pages. Master pages can be overlooked in a program like Adobe 
InDesign, but are very useful in setting up a Muse site.

Goals for this lesson
Aside from creating master pages, students will add content that appears consis-
tently on most of the pages in the header and footer of the site. 

In this lesson, students will learn how to

• Create, delete, duplicate, and rename master pages

• Edit the page area and browser fill

• Edit the page guides associated with a master page

• Add header and footer content

• Test pages in a browser

Web design versus print design
This section is a web concept overview for those students who are new to web 
design or who simply want a refresher on concepts like resolution, design tips, 
and more. If class time is tight, you easily could assign this section for students 
to review as homework before you embark on Lesson 3. Note that the actual 
content for the section is in the Lessons > Lesson03 folder in a document called 
“print_vs_web.pdf.”

editing the page area and browser fill
In previous versions of Adobe Muse, the page area and browser fill had different 
default color backgrounds. In Muse CC, the background between the two is seam-
less. Make sure that students understand that there really is no “page” on the web—
only a guide to work with. To help them, you can apply a browser fill background 
color and preview the page in the browser (File > Preview Page In Browser) to dem-
onstrate the area that the browser fill covers. 

When nothing is selected on the page, the page area is selected. Point out to stu-
dents that with nothing selected, the word “Page” appears in the Selection Indicator 
on the left side of the Control panel. If any formatting properties are changed (like 
background color), it will affect the page area.

Remind students of a major difference between print and web design—file size. 
Many a student will create designs that are difficult to implement and contain back-
ground imagery with very large file sizes. Remind them that previewing their pages 
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on their own machines is not the same as viewing the site on a host where the 
images have to download to a visitor’s computer.

editing the master page guides
The master page guides (header and footer) can only be edited on a master page, 
but each page can have different padding, minimum height, columns, and more. 
When a student is viewing a page (not a master page), he can click the blue header 
guide arrow or blue footer guide arrow on the left side of the Document window to 
view a tip on where to edit those guides.

You may wish to clarify that students can choose View > Hide Header And Footer 
to hide the header and footer guides that appear on the pages. The way the menu 
item is worded, they might mistakenly think that menu option hides the header 
and footer areas.

Adding content to the footer
If students create content below the footer guide, like a rectangle, then it is auto-
matically assigned to the footer. There is no need to set the option. Content that is 
dragged below the footer guide, from above the footer guide, needs to be assigned 
to the footer first (Object > Footer Item).

Make sure students understand the benefit of assigning content to the footer: 
Content is assigned to the footer so that if page content expands, the footer content 
is pushed down.

Applying master pages
Working with multiple master pages in Muse is not necessary, but it can be benefi-
cial. Ensure that students fully understand the intention of basing master pages on 
one another. In the book we use a simple example, but the more complex the site 
and the more layering of content that happens, the more cumbersome editing and 
selecting content can become. Also, all content that is on a master page is locked 
on a page with that master page applied. Unlike Adobe InDesign, you cannot 
unlock master content on a page.

testing your pages
Testing pages outside of Muse in the browser is not always necessary, but some-
times it can be useful for visualizing the browser content like a favicon, and the 
appearance of the page within the chrome (scrollbars, buttons, and so on) of the 
browser. Remind students that if they choose File > Preview Page In Browser, links 
to other pages within their site will not work. Choosing File > Preview Site In 
Browser allows the site to function fully, but it does take longer.
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Questions
The following questions are not in the student’s Classroom in a Book:

1 What is meant by a fixed-width page design?

2 What is the difference between the page area and the browser fill of a page?

3 What is the major difference between previewing the page in the browser versus 
previewing the site in the browser?

Answers
1 A fixed-width page design means that your pages are a set width and are 

centered in the browser window.

2 With a page open in Muse, the blue page guides that frame an area in the 
Document window is the page area, which is a guide for containing the content 
for your page. The browser fill area can contain a color, an image, or both, 
which appear behind the page area’s contents. The browser fill is the area that 
surrounds your page when a visitor’s browser window’s width exceeds the width 
you specified for your page.

3 Preview Site In Browser allows you to navigate between pages for an overview 
of the site. Choosing Preview Page In Browser, the other alternative, allows you 
to see only the current page in the Document window or the first page of the 
site if there are no open pages. If you click any of the links in the page, they will 
not work because you are only previewing the appearance of that single page.
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Lesson 4: Adding and styling text
This lesson introduces students to working with type in Muse. It covers multiple 
methods of adding text, formatting text in Muse, and preserving text formatting 
using two types of text styles.

Goals for this lesson
There are several benefits to adding text to your pages versus adding that content 
as an image. The first relates to SEO: Search engines can read text and use that con-
tent for ranking, whereas they can’t read images as easily. Also, text can be smaller 
in file size compared to images. 

As students begin formatting text, however, remind them that Muse generates code 
for every formatting option that they apply to their text. Adjusting the letter spac-
ing between every letter in a paragraph, for instance, can add a lot of code, which in 
turn adds to download time and time for the page to load. Another best practice in 
Muse to use styles for text, rather than simply selecting text and applying the same 
formatting in multiple locations, which also adds unnecessary bulk to a file. These 
two tips point out a difference between print and web design that students should 
always keep in mind.

In this lesson, students will learn how to

• Work with layers

• Type and place text

• Change text attributes

• Work with fonts

• Create and edit styles

• Work with Dynamic Spelling and dictionaries

setting up layers
Layers are a newer feature in Muse and work just like other Adobe applications. 
Layers should not be an afterthought for students. Not only can they help organize 
page content, but they also make it much easier to control the stacking order of 
content—especially content on master pages. A sticking point so many students 
have is remembering to continue paying attention to layers. So many times students 
will set up layers and as they design (adding content), they will not ensure that the 
content is on the proper layers.
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Inserting and placing text
Students familiar with Adobe InDesign will feel at home in Muse when adding text 
to their pages. Many keyboard shortcuts from InDesign and other Adobe appli-
cations work in Muse as well. For instance, double-clicking a text frame in Muse 
switches to the Text tool. 

You cannot place text into an existing text frame; rather, you need to place the 
text in a new text frame, then cut (or copy) and paste that text into the existing 
test frame.

Warn students that copying and pasting text from a program like Microsoft Word 
or Adobe InDesign will strip the formatting of the text.

Adjusting font size
Press Cmd+Shift+< or > (Mac OS) or Control+Shift+< or > (Windows) to change 
the text size of selected text.

At the end of the “Adjusting font size” section, there is mention of the minimum 
height value for a text frame (shown as “Min H” in the tooltip that appears when 
resizing a frame). Most of the time, this setting can be ignored. It is best practice, 
however, to ensure that text frames are at least the height of the text inside.

selecting a font
This is one of the more important sections in terms of formatting text. You cannot 
overstress the importance of understanding the difference between web fonts, web 
safe fonts, and system fonts. Remind students that Muse turns text formatted with 
a system font into an image when the site is previewed, exported, or published, but 
that means text is still completely editable in Design mode. System fonts should be 
applied sparingly and should not be used for body copy, because the text will be 
converted to an image, which will be difficult for search engines to read.

Working with the web fonts category allows the students to apply fonts using 
Adobe Typekit. Students tend to gravitate toward these fonts, because they allow 
for more creative expression. The first time students access this category of fonts, 
they’ll need an Internet connection. Students can also select these fonts without 
selecting text by choosing File > Add/Remove Web Fonts and selecting fonts. The 
web fonts that are chosen for a particular design do not need to be “collected” if the 
student sends the .muse file to someone else. When someone else opens the .muse 
site file on another machine, Muse downloads the applied fonts behind the scenes, 
assuming it finds an Internet connection.
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changing alignment, leading, and letter spacing
Adobe Muse has some pretty advanced text attributes to help designers make the 
most of text in a web design. Text formatting options can be found in the Text 
panel (if a text frame or text is selected) or in the Control panel (if text is selected).

Once again, be certain to point out that every formatting option applied to text is 
written into the code that is downloaded by visitors when they view the website 
in a browser. This is especially important to consider when applying the Tracking 
formatting option.

Most of the keyboard shortcuts that students use in Adobe InDesign or Adobe 
Illustrator will work in Adobe Muse as well. To adjust the leading, for example, 
select the text and press Option+Up Arrow/Down Arrow (Mac OS) or Alt+Up 
Arrow/Down Arrow (Windows). To adjust letter spacing, select the text and 
press Option+Right Arrow/Left Arrow (Mac OS) or Alt+Right Arrow/Left Arrow 
(Windows).

creating and applying paragraph styles
Take the time to show how styles can save time for your students and improve 
design consistency. Styles are a way to quickly, reliably, and consistently apply spe-
cific typographic styling to text. For example, imagine you need to create a headline 
with a consistent look and feel that will appear on multiple pages. When you use 
styles, you can make changes to the styles of text on one page, then cascade those 
changes through the entire site.

Paragraph styles in Muse work similarly to paragraph styles in Adobe InDesign. In 
InDesign, there are several ways to accomplish each style task, whereas in Muse 
there is typically only one way to create a paragraph style or edit a paragraph style.

Students familiar with InDesign style formatting will attempt to double-click the 
style name in the Paragraph Styles panel to edit the formatting. In Muse, the only 
way to edit a paragraph style formatting is to redefine the style.

Pasting text between Muse sites
As a side note, when pasting text from one Muse site to another, if the names of 
the styles applied to the copied text are the same as those of styles found in the 
destination site, the formatting from the destination site overrides the copied 
text’s formatting.
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Questions
The following questions are not in the student’s Classroom in a Book:

1 What type of text file format can you place in Adobe Muse?

2 What unit is used for font sizing in Muse by default?

3 What happens to text formatting when it is pasted into Muse from a program 
like Adobe InDesign?

4 When a system font is applied to text, what happens to that text when the site is 
previewed, exported, or published?

5 What is meant by a style override?

Answers
1 Currently, in Adobe Muse, you can place .txt (plain text) files that contain no 

formatting options.

2 The default unit for sizing text in Muse is pixels.

3 Muse strips any text formatting that was applied in another program, such as 
Microsoft Word or Adobe InDesign, and pastes the text with default Muse text 
formatting.

4 When a system font is applied to text, the text is rasterized (converted to an 
image) when the site is previewed, exported, or published.

5 Formatting options applied to text that are not a part of an applied paragraph 
style are referred to as style overrides.



Adobe Muse CC ClAssrooM in A book (2014 releAse) 19

Lesson 5: Working With shapes, 
color, and Images
In this information-packed lesson, students will spice up their website designs and 
learn how to create different types of shapes, apply background images to frames, 
apply fills and strokes, create gradients, work with images, and much more. This 
chapter is one of the longest in the book and can be split up if necessary. A way to 
divide the content, if necessary, would be to have shapes and color in one lesson 
and images in another.

Although Muse has only one shape tool (the Rectangle tool), you can use it to 
create a variety of shapes, including a rounded corner rectangle (in conjunction 
with corner radius) and a line. Point out to students, however, that shapes they 
create with the Rectangle tool cannot contain text or images. The Rectangle tool 
is intended to create page content such as buttons, color fill areas, and more.

Goals for this lesson
In this lesson, students will learn how to

• Create and edit shapes

• Apply background images to shapes

•  Create 100% width content

• Create and edit color, swatches, and gradients

• Place and transform images

• Wrap text around an image

• Align, group, arrange, and lock content

• Fix missing and modified links

• Add alternative text and a tooltip to images 

Drawing with the rectangle tool
When working with the Rectangle tool to create shapes, students can use several 
keyboard commands. To create a perfect square, show them how to select the 
Rectangle tool, press the Shift key, and drag in the page area. You can also edit the 
dimensions (width and height) of a rectangle in the Transform panel to create a 
square (a rectangle with the same width and height values).

In the “Drawing with the Rectangle tool” section, step 3, students will drag the 
bottom-middle bounding point of the rectangle down to snap to the bottom of 
browser guide. Although this snaps the rectangle to the guide, the rectangle will 
not change height if the bottom of browser guide is dragged up or down.



20 instruCtor notes

creating 100% width content
Although 100% width content can be inserted in the header, the body (page area), 
or footer of a page, only rectangles and text frames can be 100% width. Images stay 
the same width as they are in the Muse page area. To get around that, you can add 
a rectangle to the page at 100% width, add a background image, and set the fitting 
to “Scale To Fill.” 

Also, if a rectangle does not stretch to fit the browser window width, remind 
students to check that both the right and left sides are snapped to the edge of the 
browser fill in Design mode.

Applying a background image to a frame
Background images are widely used on the web. In Adobe Muse, you can apply 
a background image to almost any type of content. Using either .jpg, .gif, .png,  
or .psd files allows you to create a background image with transparency.

Students should be made aware that there are no real resizing options for back-
ground images aside from the six Fitting options. Background images should be 
created in a program like Adobe Photoshop at 100% of the size they will be used 
in Muse.

Because background images are just that—images—students must take download 
times into account when creating them.

saving and editing a swatch
Swatches created in one .muse site are saved within that site only. To move swatches 
from one site to another, students can copy and paste content with a swatch 
applied from one site to another.

The context menus for swatches, which contain such commands as Duplicate 
Swatch and New Color Swatch, are found by right-clicking the swatches in the 
Swatches panel. Another way to duplicate a swatch is by selecting a swatch in 
the Swatches panel or the Color Picker and clicking the Add Swatch button.

sampling color and saving it as a swatch
When nothing is selected on the page, remind students that if properties such as fill 
color and stroke color are selected, or a new swatch is made, it will affect the page.

creating gradients
Students will have an opportunity to not only work with gradient fills, but also to cre-
ate their own custom gradient. Point out that they are limited only by their imagina-
tion when creating gradient effects, and show how the Gradient panel has several 
precise controls for altering a gradient, such as the Focal Point and Direction.
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Gradients cannot be saved as swatches in Muse, but if students would like to trans-
fer a gradient from one .muse site to another, they can copy and paste content with 
the gradient applied. After the content with the gradient is pasted into the site, they 
can create a graphic style from that content and later apply the style to other content.

As a side note, gradients are not usually saved as an image when the site is pub-
lished or exported. CSS is used to create the gradient in the browser.

Web image basics
Up to this point, students have placed several images without regard to linking or 
transforming the content. In this lesson, students will import images in various 
formats, including JPEG, GIF, PNG, and PSD (native Photoshop files). Students will 
explore placing images and their relationship to the image frame. They will also 
investigate in-depth transforming, linking, and the Assets panel.

This section points to the PDF named “web_images.pdf,” which explains why 
optimizing graphics is so important for websites (download speed) and discusses 
in detail the different formats available for use on the Web. It can be easy to forget 
that not everyone has a high-speed Internet connection, but as professionals, web 
designers must take into account that people can be viewing a website at very dif-
ferent bandwidths.

The lesson spends a fair amount of time up front discussing the basic concepts of 
working with web images. This background information is not vital to completing 
the lesson, but is important for students who wish to create their own imagery later 
on. If class time is at a premium, you could instruct students to review the PDF on 
their own, then jump into the main lesson.

Importing images
If students place images that are greater than 72ppi (say a print-ready image that is 
300ppi), the image will be downsampled to 72ppi without removing pixel data. In 
Photoshop terms, they won’t be resampled.

When it comes to HiDPI sites, the images are typically 2 times the pixel dimension 
compared with non-HiDPI sites. This can either mean that the images are 72ppi, 
but twice the pixel dimension as they will be in Muse, or 144ppi at the same pixel 
dimension as they will be in Muse.

Images that are placed into Muse using the File > Place command need to be in 
either the RGB or the Grayscale color space. If a student attempts to place an image 
in the CMYK color space, a warning dialog box will appear, preventing them from 
placing it.

Images that are placed into Muse cannot have a width or height that exceeds 50,000 
pixels or a total image size that is larger than 75,000,000 pixels. A warning dialog 
box appears if students attempt to place an image outside of those parameters.
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Placing an image
Placing images into Muse uses the same command (File > Place) as Adobe 
InDesign, as well as the same keyboard shortcut. When placing images, a link is 
created to the original that can be seen in the Assets panel. Images can be in JPEG, 
GIF, or PNG format to be placed in Muse.

Something important to bring to the attention of students: when an image is 
placed, an optimized copy is saved within the Muse file (embedded). The file is 
also linked to the original image file on your hard drive. The link for images (.jpg, 
.gif, .png, .psd) is only used for editing the image outside of Muse and updating the 
image in Muse. Students could send a .muse file to someone else without sending 
the image files. Muse would not show an error dialog box when the .muse file was 
opened. The site could then be published or exported as is. Only if an image needs 
to be edited will the link be called into play.

For images, it is best practice to place the image at either 100% or smaller. Avoid 
scaling images larger than 100% in Muse as the image quality may suffer.

Placing a Photoshop file
Placing native Photoshop (.psd) files can be a great time saver. When you place 
Photoshop files, Muse optimizes the image data and creates an image file when the 
site is previewed, published, or exported.

A great workflow that students may well fall into is to create an entire page design 
in Photoshop, matching the page dimensions, resolution, color mode, and so on. 
Students can then organize the content in layers in Photoshop (such as by placing a 
logo on its own layer). When the design is placed as a single file into Muse, students 
can place individual layers of content (like the logo) by themselves. For content 
that resides on more than one layer, that is sliced, students can copy and paste the 
selected slice from Photoshop into Muse, creating embedded image content that is 
flattened. There are many ways to work with Photoshop files in Muse.

Note that if you select more than one of the layers in the Image Import Options 
dialog box, those layers will not be flattened into a single image, but rather, each 
layer will become a new image layered on top of the previous in the same position 
as they were in Photoshop.

If there are multiple layers that students wish to place as a single flattened image, 
they can select those layers in the Layers panel in Photoshop and choose Layer > 
Smart Objects > Convert To Smart Objects. A Smart Object in Muse is regarded as 
a single layer.

Note that any layers in Photoshop that are blank or empty will not appear in the 
layers list. Also, if you place a flattened Photoshop .psd file, the Image Import 
Options dialog box will not appear.
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transforming images
Transforming is an important feature in Muse. Getting comfortable with the vari-
ous ways to transform images opens up many options for students.

There are several ways to achieve the same transformations in Muse using the 
Selection tool or the Crop tool. This lesson focuses more on using the Selection 
tool and keyboard commands versus switching tools, but both methods are shown.

One tricky bit for students is being able to tell if an image has been scaled in Muse. 
There are two main methods for that: Resize the image to see the size in the tooltip 
that appears, or hover the cursor over an image in the Assets panel to see the 
Original Asset Size (size it was before being placed) and the Resampled Asset Size 
(size it is in Muse).

About resizing and cropping in Muse (sidebar)

Explain to students that resizing images can be a destructive process; as an image is 
increased in size beyond 100% of its original size, the resolution drops below 72ppi. 
This means that if the image is resized larger, the image quality will suffer.

If an image is resized beyond 100%, a warning icon appears in the status column of 
the Assets panel that indicates that the image may not look good when previewed, 
published, or exported. Also, a dialog box will appear if images are larger than 
100% in the site when the student first opens the .muse file.

The moral of the image-sizing story is to try and place images at 100%. If resizing 
needs to occur, better smaller than larger.

transforming images

This section is one of the most important in this book, because students will be 
transforming content (not just images) using the tools and commands in this sec-
tion. Have students take it slow. The idea is to understand what each keyboard 
command does in the transforming process. A student can always re-place the 
image if the transforming gets out of hand.

Fitting commands

Fitting commands can be very useful in an application like Adobe InDesign, but 
you need to be wary of them in Adobe Muse. Filling or fitting can resize an image 
to larger than 100% easily (depending on the size of the image frame). As was stated 
previously, resizing images larger than 100% in Muse is not a best practice and 
should be avoided. 



24 instruCtor notes

the crop tool

The Crop tool is a specialty tool that students may never use, because they’re using 
the Selection tool and keyboard commands instead. The Crop tool offers familiar 
features for those students who use InDesign CS5 or later and are familiar with the 
Content Grabber.

Locking and grouping content

Locked content in Muse is completely locked, which means it cannot be selected. 
Unfortunately, in Muse there is no lock indicator to show which items on a page are 
locked. Also, you can lock individual objects, but you either unlock all content or 
none using the Object > Unlock All On Page command.

Grouping content is something that students using other Adobe applications will 
most likely already understand, although selecting content in a group in Muse 
is a bit different from other Adobe applications. After selecting a group with the 
Selection tool, point out that students can single-click again to select a single object 
in the group. Pressing the Escape key selects the group again. This may trip up 
some students, because InDesign and Illustrator require a double-click of the group 
to select individual objects in the group.

rotating images

Rotating images in Muse is similar to doing so in other Adobe applications. 
Entering a positive rotation value rotates the content counter-clockwise, whereas 
a negative value rotates the content in a clockwise direction. Remind students that 
they can always remove rotation by setting the rotation value in the Transform 
panel or in the Control panel (if their screen resolution is high enough to fit it) 
to 0 (zero).

Wrapping text around content

Wrapping text around content like an image in Muse requires that the content be 
pasted inline in the text. For those students familiar with text wrapping in InDesign, 
this will be a bit of a shock. (Don’t be surprised if you hear a little complaining.) 

Make sure that when students paste the image into the text that they insert the cur-
sor before the first character in the first paragraph. Also, they can paste groups of 
content into text and apply text wrap using the Wrap panel.

the Assets panel
The Assets panel is critical when working in Adobe Muse. Much like the Links 
panel in Adobe InDesign, the Assets panel lists all of the linked content (images, 
PDF, and so on).
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In Muse, the assets are listed alphabetically. One of our favorite commands is the 
Go To Asset command. Right-click almost any image name listed in the panel, and 
choose Go To Asset (background images listed in the Assets panel won’t show a 
Go To Asset option). The page that the asset is on opens in Design mode with the 
image selected. Point out that this is great for seeing an image that has a missing 
icon or modified icon in the status column and determining where it is being used.

Remind students they can find a lot of information in the yellow tooltips that 
appear when the pointer is positioned over a name in the list in the Assets panel, 
including the location of the original image. Those yellow tooltips can be a little 
touchy, though, not always showing or showing all of the image information (some-
times just the file name).

In the “Editing Original” section, step 1 instructs students to choose the Edit 
Original command to edit the original image in Photoshop. If the image does not 
open in Photoshop, make sure students read the note to the right of step 1, which 
discusses the file association. You can set file associations in your operating system 
(Mac OS or Windows).

Fixing broken and modified links
As was mentioned previously, if images that have been placed on a page in Muse 
have been modified outside of Muse, you will see a warning dialog box when the 
site is later opened. If an image file is missing, there will be no warning dialog box. 
That is because there is an optimized copy of the image that lives in the .muse file 
by default. The only missing dialog box you might see would be for a missing asset 
like a PDF file that is linked to and meant to be uploaded to the server.

editing image properties
As students will learn in the lesson, alternative text and tooltips can be very impor-
tant for a lot of reasons, as explained at the beginning of the “Editing image proper-
ties” section. Make sure that they read and understand this section.

Get students in the practice of adding this alternative content at least to the impor-
tant images in their sites, such as the logo and key images. Another good habit is to 
add the alternative content as they place the images. If they leave it until last, the 
relatively simple task will feel like a rather large chore. Google has gone so far as to 
publish image publishing guidelines that spell out why this type of content can be a 
good thing for your site.

Questions
The following questions are not in the student’s Classroom in a Book:

1 What is the process for creating 100% width content?
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2 How can you bring a gradient from one .muse site to another and apply it to 
other content?

3 What is the resolution of images used on the web?

4 When you place a layered Photoshop file, what does the Clip To Layer Contents 
option do?

5 How can you select the image within the frame with the Selection tool?

6 Name two ways to select multiple objects on the page.

7 What happens if you choose the Embed Link command in the Assets panel 
context menu?

Answers
1 With either a rectangle shape or text frame selected on the page, you can either 

click the 100% Width button in the Control panel or Transform panel, or drag 
the right-middle bounding point to the right edge of the browser fill until the 
red Smart Guide appears, indicating that it is snapped. Repeat the process for 
the left side of the object as well.

2 Gradients cannot be saved as swatches in Muse, but if students would like to 
transfer a gradient from one .muse site to another, they can copy and paste 
content with the gradient applied. After the content with the gradient is pasted 
into the site, a graphic style can be created from that content and later applied 
to other content.

3 The resolution of images used on a website is 72ppi.

4 Selecting Clip To Layer Contents crops the placed image to the size of the 
selected layer content instead of making it the size of the entire design. The 
original .psd file remains unchanged.

5 If you double-click an image with the Selection tool, the once-blue rectangle 
with eight bounding points turns into a brown rectangle with smaller points. 
The pointer also changes from a black arrow to a hand when the pointer is 
positioned over the image. The lighter area of the image at the bottom is the 
part of the image that may be cropped. These indicators will help you resize the 
image within the frame and reposition it.

6 To select multiple objects with the Selection tool, you can either drag a selection 
marquee across the objects, or press the Shift key and then click each of the 
objects you wish to select.

7 If you right-click an image listed in the Assets panel and choose Embed Link, 
Muse will embed the image in the .muse site file and remove the link to the 
original image.
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Lesson 6: Working with Links and Buttons
Adding links to a web page is essential to creating a website with more than one 
page. Muse supports many different types of links—emails, pages, phone numbers, 
sites, and others that most of us may never use. In this lesson, students will focus 
on creating and styling their links. Styling links tends to be one of those formatting 
options that everyone wants to discover as soon as they create their first links.

Which should students use: links or buttons? Offer them the guideline that links 
are for navigation and buttons are for actions like signing up, submitting, or learn-
ing more. Of course, in the real world this general guideline isn’t always followed.

Goals for this lesson
In this lesson, students will learn how to

• Create different types of links

• Link to a file

• Edit link properties

• Style links

• Create a button in Muse

• Work with states

• Place an Adobe Photoshop button 

• Create and link to anchors

• Pin content

Working with links
This section contains general web-link information that everyone already knows 
to some degree. Nevertheless, do point out that typing in external links can lead to 
mistakes, and email links are not foolproof (they won’t work on all systems). Email 
links rely on email software that is associated with the browser.

Links cannot be tested in Design mode. To test, students can either go to Preview 
mode or choose File > Preview Site In Browser. Remind them that they cannot 
choose File > Preview Page In Browser and test links between pages.

creating an internal link

Internal links are the easiest and most foolproof type you can create. These simply 
involve selecting content (an image, text, and so on) and then choosing the page or 
anchor to which you want the link to point. If the name of the page changes, Muse 
automatically updates the links to that page throughout the site. 
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Remind students that whatever text is selected when they apply a link has the link 
applied to it. If they select spaces after some text, for example, then the link is also 
applied to the spaces.

creating an external link

External links need to be tested in Preview mode or in a browser, because they 
rely on copying and pasting a link into Muse or directly typing in that link. Also, 
students do not have to type in the http:// typically associated with a site. Muse will 
add that for them.

creating an email link

Email links only require typing the email address into the Hyperlinks field and 
pressing Enter or Return so that Muse can add mailto: to the beginning of the link. 
The mailto URI scheme is how the browser knows to open the email software asso-
ciated with the browser.

If you want to add multiple email addresses, just type them in, separated by 
commas. If you want to add a subject line to the generated email, just add 
?subject=what you want to say here after the last email address, as in 

mailto:brian@brian.com,wyndham@wyndham.com?subject=Our Party

If you add the ?subject information, make sure that Muse does not add http:// 
before the mailto! 

You can also add ?cc=emailaddress for a CC or ?bcc=emailaddress for a BCC. 
Once again, if you add any of these, make sure that Muse does not add http:// 
before the mailto.

Linking to a file

This is a great option for supplying files like PDF or .zip for users to download. 
Make it clear to students that the link to the file can be tracked through the Assets 
panel. It is very important to ensure that the file is properly linked to the .muse file; 
otherwise, the linked file will not go with the site files when the site is published 
or exported.

editing link properties

The link property Open The Link In A New Window Or Tab can be useful when 
linking to other sites from your own. This way the new site does not replace your 
page—your site stays open.

styling text links

Links, by default, are blue and underlined, and your students instantly will want 
to change this styling. To do so, they either can edit the default link style or create 
new link styles and apply them. The second option allows students to have links 
that look different, while the first keeps the look consistent across all links. When 
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changing the link style formatting, students don’t have that many options. Basically, 
they can change text color, bold, italic, and underline.

Students can apply link styles by clicking the word Hyperlink in the Control panel 
or going to the Text panel with text selected and applying them there.

Make sure students test the links in Preview mode or in the browser, because they 
cannot fully test links or link states in Design mode. If they test in the browser, you 
may want to have them clear the browser cache because the links may appear as 
the visited state, because that site had already been cached at some point in their 
browsing career.

Working with buttons
Students can (and probably will) create buttons from anything in Muse—shapes, 
text frames, images, and more. What makes a button a button is that it has a link as 
a call to action or to another page or site and, more often than not, that it has states 
that change the appearance when the user interacts with it.

creating a button in Muse

If you want, you can have students create a button from a placed image. Suggest 
they add a link to the image, then change the appearance of the states in the States 
panel by adding a shadow, or changing the opacity, for instance.

You can create buttons from grouped content as well. Each object in the group 
would have its own states that you could change in the States panel.

using the states panel to add button states

Even though it’s not discussed at this point in the book, mention that students can 
select states, like the Rollover state, and click the Reset To Default button at the 
bottom of the States panel to make the Rollover state look like the Normal state.

setting up a Photoshop button

The supplied Photoshop button is a simple button with two layers. Students can 
create their own button, if time allows, even adding other states by naming the lay-
ers the same as the states you see in the Photoshop Import Options dialog box.

For a button to be a button, it needs only one layer. If you want states to contain the 
content from more than one layer, you can have the students select a series of layers 
in the Layers panel in Photoshop and turn them into a Smart Object by choosing 
Layer > Smart Objects > Convert To Smart Objects. Each Smart Object can be 
named according to one of the states.

Placing a Photoshop button

Make sure that students don’t place the button using the File > Place command; 
they should use the File > Place Photoshop Button command instead.
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After placing the Photoshop button, each of the states (layers in Photoshop) is 
converted to a new image when the site is previewed, published, or exported. If you 
were to select a button and open the Assets panel, you would see the same num-
ber of images listed as original states. Each of the images listed would have their 
respective state to the right of the name. For example, the Photoshop button that 
was placed in the lesson would have multiple images listed in the Assets panel with 
a file name and (normal), (rollover), (active), and (mouse down) listed.

Working with anchors
This section describes in detail how to insert anchors into a page and link to them. 
Invisible to visitors that browse the site, anchors are meant to allow you to create a 
link to a part of a page. This can mean that you could click a link and scroll down 
the page or even create a really wide page that scrolls horizontally when a link to an 
anchor is clicked.

Muse employs JavaScript smooth scrolling when linking to anchors. This means 
that the page doesn’t jump to anchors, but rather, the page scrolls smoothly and 
stops when the anchor is at the top of the page or aligned to the left edge (in the 
case of an anchor to the right on a wide page).

Pinning content
Pinning content is something that typically gets the creative juices of students flow-
ing. You can pin almost any content you like to the browser window. Some good 
examples include a Twitter follow button, the secondary navigation of a page, and 
more. Have students try multiple pinning options, and make sure that they preview 
the page in the browser or Preview mode and resize the application or browser 
window to see the effect.
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Questions
The following questions are not in the student’s Classroom in a Book:

1 What are the four states for link styles that you can affect?

2 How do you place multiple anchors on a page quickly?

3 How can you change the appearance of different text links on your pages?

4 Where in Muse can you change the Title text for a text link?

5 If you were to see “Top” listed as a subset of the Home page in the Hyperlinks 
menu, what would that indicate?

Answers
1 The four states found in the link styles are Normal, Rollover, Visited, and Active.

2 To place a single anchor, you click the Anchor button in the Control panel to 
load one anchor into the Place Gun. To load multiple anchors into the Place 
Gun, click the same number of times as the number of anchors you need. This 
loads multiple anchors in the Place Gun and a number appears next to the Place 
Gun icon on the page.

3 To create multiple link appearances, you can create and apply multiple link 
styles in the Site Properties dialog box.

4 Click the word “Hyperlink” in the Control panel to see the Hyperlink options. In 
the Title field, type the title text that you want.

5 This would indicate that you would be creating a link to the anchor named Top 
on the Home page.
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Lesson 7: Working with Widgets
Widgets in Adobe Muse are a large set of features that most students will gravitate 
toward, because widgets can add powerful interactivity to pages. Widgets supplied 
with Muse are based on the jQuery libraries. Throughout this lesson, students will 
explore adding widgets to their pages, selecting widget parts, modifying widget 
options, changing widget appearances, and adding content to widgets.

Goals for this lesson
In this lesson, students will learn how to

• Understand Button widgets

• Insert and edit a Composition widget

• Add a form

• Insert a menu

• Add an Accordion widget

• Insert and edit a Slideshow widget

• Insert a Social widget

About widgets
As described earlier and in the lesson, widgets are reusable building blocks that 
can be dragged into pages within a site. There are seven main categories of widgets 
within the Widgets panel. In this lesson, which is the longest in the book, students 
will be exposed to an example of each type of widget available.

understanding Buttons widgets
The State Button widget is pretty much the same thing we created earlier in the 
book when we created a button. It does contain a button with multiple objects that 
is treated as a single unit. All of the same formatting options are available for these 
types of buttons as were available for those you create yourself.

The HiDPI (on/off) button, which was not used in the book, works when the reso-
lution is set to HiDPI (2x) in the Site Properties dialog box (File > Site Properties). 
It is useful for switching between HiDPI images and regular images. This can be 
useful for testing on high DPI devices.

Inserting a composition widget and editing the options
It is important to understand the different widget categories and when to choose to 
insert one type over another. Stress to the students that composition widgets can 
contain almost any type of content (images, text, video, other widgets), whereas 
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slideshow widgets are intended only to display images (and captions, if you opt 
to do so).

Also, when students drag a widget from the Widgets panel and they select it on 
the page, the Selection Indicator on the left end of the Control panel will show the 
specific type of widget.

Students can set the options for a composition widget at any time—even after 
content is added to the widget—but we suggest setting them first. That way, the 
main widget functionality is set, and students can then add content and adjust the 
appearance, previewing as they go.

Some options in the widget options may or may not be available depending on 
what other options are selected. For instance, if Lightbox is not chosen in the 
Position menu, the Show Lightbox Parts While Editing option will be dimmed.

editing the triggers

Note that it may take a little patience and practice to select the parts of a widget at 
first. Always stress to the students that they need to look at the Selection Indicator 
in the Control panel to see what is currently selected.

A composition widget must have at least one trigger and target. Stress to students 
that they can delete the trigger area just as easily as the target. Deleting either the 
trigger or target will delete both the trigger and target.

Adding content to the target areas

Content like text frames or images can either be created (text) or placed (image) 
directly in the target area or dragged in. When you drag content into a target area, 
the brown outline around the container indicates when the content is inside of the 
target area. You can also tell if content is in the target area when the options arrow 
appears in the upper-right corner of the content when selected.

In this section, students will paste the content from the Composition.muse site. 
When they paste, the content may automatically paste into the target area, so there 
may be no need to drag the content in. Once again, you can tell if it is in the target 
area because of the options menu arrow.

If students wish to edit the content within the group that they pasted, they can 
click on any of the grouped content until selected.

Adding a form
Several updates back, forms for all hosts that support PHP were introduced. Muse 
will check to see if a host supports Muse forms if you use the File > Upload To FTP 
Host. If you export the files from Muse and upload to a host outside of Muse, you 
will need to check and see if the forms are supported by testing.
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Currently, CAPTCHAs are only supported when you host the site with Adobe 
hosting, which you’ll learn about in Lesson 11.

In step 12, we mention that the bounding box around the form may be larger than 
you expect, especially since the form fields visible are not that wide. The forms in 
Muse are composed of a series of elements—some showing and some hidden. The 
hidden elements are those that appear when the form is submitted. When you edit 
the states of the form, you can edit the position of the hidden content.

Adding a navigation menu
The menu widgets in the Widgets panel are based on the same widget, but each has 
different options and formatting set. You cannot currently edit the default widgets 
in the Widgets panel. You can, however, create a Muse site (.muse) that contains 
menu widgets that you’ve customized. You can then either copy and paste menu 
widgets between .muse sites or save the menu in the Library panel for later use 
in any site.

editing the menu widget options
Students can set many options for the menus. For a more thorough understanding 
of the these options, point students to the tip at the end of this section, which refers 
you to a file named menu_bar_options.pdf in the Lessons folder.

Encourage students to set the menu options first, before editing the menu design. 
Different appearance options may work better depending on the menu options set.

Formatting the Menu widget text
In this section, step 1, students are asked to select the menu item, not the label. 
Know that students can select either, but you can apply different fonts to both, 
which can be confusing. Applying a font to the menu item applies to the text label 
in the menu as well. If you then apply a different font to the label, that new font will 
override the font applied to the menu item object.

editing the appearance of the menu bar
One of the trickier parts of editing a menu widget is selecting the various parts of 
the menu. Spend a little time on menu selection and encourage students to look at 
the Selection Indicator in the Control panel as an aid.

When students edit the menu bar sizing on the page, remind them that they can 
also set width and height options in the Transform panel or in the Control panel if 
the resolution of their screen allows it. Ensure that students have chosen Uniform 
Spacing from the Item Size menu; otherwise, text in some of the menu items may 
not fit properly.
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With menus, students will find that properties like backgrounds can be applied to 
the entire menu widget or each menu item but do not need to be applied to both. 
Doing so simply would add unnecessary code, although the menu would still func-
tion properly.

editing the menu item states
Point out that states are an important part of a Muse workflow that students can 
use to indicate interaction (buttons, menus, widgets, and so on).

In order to edit states in the menu widget, a single menu item needs to be selected. 
Make sure that students have the Edit Together option in the menu options 
selected before changing states in the States panel. Otherwise, only the selected 
menu item will be affected.

editing the appearance of a submenu (sidebar)
Submenus are not styled when the top-level menu items are styled. You can create a 
graphic style from the top-level menu items and apply that graphic style to the sub-
menu items to speed up the formatting process and maintain consistency. Graphic 
styles are covered in detail in Lesson 8.

Adding an Accordion Panel widget
Accordion panel widgets and Tabbed panel widgets are very similar in what they 
do: allow a large amount of information to be shown in a small amount of space. 
Accordion panels can also be rotated so that the panels slide horizontally instead of 
vertically. Just know that the content in the panel will be rotated as well.

Working with slideshows
Slideshows are a mainstay on websites these days and are meant to contain images 
and possibly captions (among other features). As with all other image content in 
Muse, remind students that the larger the file size of images, the longer the pages 
will take to load and the slower widgets like a slideshow may run.

In the book, we don’t have the students insert a fullscreen slideshow. Fullscreen 
slideshows can be a great way to add a slideshow that covers the browser window. 
In Muse, a fullscreen slideshow will cover the entire page area, which may not rep-
resent what it will actually look like in the browser. I suggest testing any page that 
has a fullscreen slideshow in the browser to see the final effect.

Adding a Blank slideshow widget 
A Blank Slideshow widget is almost identical to the Basic Slideshow widget, except 
the Basic Slideshow widget has several placeholder images already loaded into the 
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slideshow. Students can use either for this part of the lesson, but realize that stu-
dents will need to remove or replace the existing placeholder images. 

You can drag the Blank Slideshow widget onto a page and preview the page to 
show a demonstration, if you like, and then discuss why you would start with a 
Blank Slideshow.

In the slideshow widget options, the Hero and Thumbnail image settings are set to 
Fill Frame Proportionally. This means that images will fill the larger image con-
tainer. It also means that when students drag the image container or set the con-
tainer to 100% width (like they do in the lesson), the image that fills the frame may 
become larger than 100% its original size. Ensure that you relay to students that 
they should size their images in Photoshop or other applications to the exact size 
or larger than the image container in the slideshow. They don’t want images getting 
larger than 100% because of pixelization.

If Thumbnails are selected, the thumbnails are auto-generated from the images that 
students insert into the slideshow. If the students want something else to appear 
in the thumbnails, they need to drag a Composition widget onto the page instead, 
because Composition triggers and targets can contain different content.

After adding the images and setting the options, students may want to explore the 
options a bit more. In Design mode, most widgets will not preview with their full 
functionality. For instance, the Blank Slideshow will fade between images when 
in Preview mode or previewing in the browser, but will not in Design mode. The 
images will simply change without a fade in Design mode.

editing the appearance of the Blank slideshow widget 

Allow the students to explore all sorts of different formatting options—the sky is 
almost the limit. One thing that may be frustrating is selecting the caption. To see 
where the caption is, if it is proving difficult, ask the student to deselect all content, 
then click twice on the larger image to select it. Then choose Edit > Select All to at 
least see where the caption text frame is.

Working with social widgets
Social widgets are a newer category in Muse and a very welcome addition to the 
program. In the past, in order to add YouTube videos, Twitter content, or even 
PayPal buttons, you would have to paste code you find elsewhere into the pages. 
Social widgets make it much easier to work with this type of content. Know that 
there is only so much formatting that can be done to these default widgets. If a stu-
dent wishes to take the formatting of a certain social widget further, they can copy 
and paste their own code from the social media website into Muse.



Adobe Muse CC ClAssrooM in A book (2014 releAse) 37

Questions
The following questions are not in the student’s Classroom in a Book:

1 What is a lightbox?

2 In a Composition widget, what can the target (larger content area) contain?

3 By default, what appears in a menu widget that is dragged onto a page?

4 What purpose does excluding pages from a menu serve?

5 What is meant by a Hero image in a slideshow widget?

6 Which of the composition widgets has target areas set to Staggered by default?

Answers
1 A lightbox, like the Lightbox Display widget, dims the rest of the page while the 

content area element display is active. Using a lightbox can be a great way to 
draw focus to content.

2 In a composition widget, the target (larger content area) can contain almost any 
type of content, including images, HTML, text, other widgets, and more.

3 A Hero image is the large image that appears in the larger content area of a 
Slideshow widget.

4 With the menu widget on the page, Muse automatically fills in the names of 
your pages in the menu, following the same order as the page thumbnails in 
Plan mode. Muse creates the menu bar with links to all of the top-level pages in 
your site map.

5 Excluding pages from a menu allows them to be in the site map without 
showing in a menu widget. This can be useful for testing a page, creating an 
alternative layout, creating a page for an upcoming sale (for instance), and more.

6 The Tooltip Composition widget is the only Composition widget that has the 
target areas set to Scattered by default.
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Lesson 8: Applying effects and Graphic styles
In this lesson students can really start to add some creative flair to their design 
projects. Besides adding effects like shadows and transparency changes to their 
content, they will work with graphic styles.

This is one lesson where you will most likely see the train come off the rails, so to 
speak. Students have more of a tendency to want to jump ahead in this lesson and 
try their own formatting options, which keeps us on our toes.

Goals for this lesson
In this lesson, students will learn how to 

• Round the corners of frames

• Apply such effects as drop shadows, glows, and bevels

• Make opacity (transparency) changes

• Work with scroll effects

• Save and apply graphic styles

Working with rounded corners, effects, and opacity 
Adobe Muse categorizes shadows, bevels, and glows as effects. So when we refer 
to “effects,” it’s to one of those three options. Rounded corners (also referred to as 
corner radius) and transparency are other options that complement effects (when 
used properly).

Encourage students to try applying all kinds of combinations of effects. In Muse, 
most of the effects applied to content will be translated into CSS when the site is 
previewed, published, or exported.

Any of the effects, rounded corners, or opacity changes applied to content can be 
saved in a graphic style. The graphic style captures not only the fact that the for-
matting is applied, but what options were set. This can be a quick way to apply lots 
of formatting and ensure consistency.

rounding the corners of a frame

You will find that rounding the corners of content is pretty straightforward. One 
thing to mention is that a frame or rectangle needs some sort or background color, 
image, or stroke in order for the rounded corners to appear.

If students want to remove the rounded corners of selected content, the fastest way 
is to select the content and set the rounded corner value to 0.
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Applying a shadow effect

Most students that use other Adobe applications like Photoshop will be familiar 
with applying shadows to content. Applying a Muse shadow is very similar, except 
in Muse the effect is applied in the Control panel.

Encourage students to explore the shadow options. Suggest they set the Distance 
value to 0 and increase the Blur to a larger value like 100 to see that they can create 
an outer glow directly beneath the object. Setting the options using these values 
can make the shadow appear to be more like a glow than a shadow.

Applying a Glow effect

In this lesson, students will discover the two main types of glows that can be 
applied to content: inner or outer. Applying an outer glow and a shadow at the 
same time can create some interesting effects. Adding an inner glow and changing 
the Blur to a much larger amount can give the students the ability to create what 
appears to be a simple radial gradient. If they set the color of the glow to one color 
and the fill of the shape to another, they can control the color of the “gradient.”

Applying a glow effect in a certain color can be a way to colorize black and white 
icons as well.

Adjusting opacity

Opacity (transparency) can be applied to almost anything in a Muse site. It can also 
be overused. Ensure that students know they cannot discern which parts of content 
have opacity changes applied. For instance, if you create a text frame with a color 
fill in the background, and then apply an opacity change, the text and the frame will 
both have the opacity changes applied. If students want to overlay text on other 
content with a transparent rectangle between the text and content, they will create 
separate objects.

Applying opacity to content applies the CSS3 property called opacity to the 
styling when the page is previewed, published, or exported. A separate filter for 
Microsoft Internet Explorer is applied as well to the code to allow the opacity to 
work in Internet Explorer.

Working with scroll effects

In this section, students get a chance to work with some of the more exciting 
and over-utilized effects in Muse. Formerly called “parallax scrolling,” this set of 
effects covers a range of options from scrolling background images to adjusting 
the opacity and position of content as the page is scrolled. While we don’t cover it 
in the book, scroll effects in the Scroll Effects panel can also be used to control the 
playback of an Edge Animate object or a slideshow. The fullscreen slideshow is best 
suited to work with the Slideshow options in the Scroll Effects panel.
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Applying a Motion scroll effect to a browser fill image

The key concepts in this section will carry students through the rest of the scroll 
effects sections. I find that a visual example of how scroll effects work is best. They 
can then see how the motion before, key position, and final motion all play into 
working with scroll effects in Muse.

When students attempt to preview the Motion scroll effect in Preview mode, they 
may see that the background is jittery as the page is scrolled. To get a better pre-
view, have them choose File > Preview Page In Browser. In the browser, they should 
see the smooth scrolling.

Working with Graphic styles

Graphic styles are a feature that should be a part of every student’s toolkit. Graphic 
styles are similar to object styles in Adobe InDesign and preserve formatting that is 
applied to the containers (frames, rectangles). When you create graphic styles for a 
site, they appear in the Graphic Styles panel and appear only for that particular site. 
If the student opens a page in another site, the newly created graphic styles will no 
longer appear in the panel.

Because students have already been exposed to paragraph styles and character 
styles in Lesson 4, “Adding and Styling Text,” graphic styles will be easy to grasp. 
They work in a very similar way, with many of the same options found in the 
Graphic Styles panel.

Graphic styles currently cannot be exported and shared with others. You can, how-
ever, copy content with a graphic style applied and paste that content into another 
site, bringing the graphic style with the content into the other site.
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Questions
The following questions are not in the student’s Classroom in a Book:

1 How do you round just the upper-right corner of a rectangle?

2 What does the Bevel effect do?

3 What does the Clear Style Overrides button do in the Graphic Styles panel?

4 What does the Glow effect do?

Answers
1 Select the rectangle with the Selection tool. In the Control panel, click the 

Enable/Disable Top Right Corner Radius button. Change the Corner Radius 
value in the field to the right of the button.

2 The Bevel effect adds a beveling to the edge of an object, such as an image or 
frame filled with color. You can apply the Bevel effect to give objects a more 
realistic, three-dimensional look.

3 Clicking the Clear Style Overrides button in the Graphic Styles panel removes any 
local formatting from the selected object. Local formatting is formatting applied 
to the selected object that is different from the graphic style applied to it.

4 The Glow effect causes a glow to emanate from under the object, but you can 
also apply a glow to the inside of an object. You can apply a glow to a rectangle, 
image frame, or rasterized text.
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Lesson 9: Inserting HtML and 
Working with the Library Panel
In this lesson students will see how to work with HTML that they get from outside 
of Muse. They will also explore the Library panel and see what it has to offer. One 
thing that we do not do in this chapter, but that I would suggest you take them 
through, is visit the Adobe Add-ons site (https://creative.adobe.com/addons) and 
explore the different add-ons available and how they can be used. They can add a 
lot of extra functionality to your Muse site and are simple to download and install 
in the Library panel.

Goals for this lesson
In this lesson, students will learn how to 

• Embed and edit HTML from other sites

• Work with the Library panel

embedding HtML
Embedding HTML (also called “arbitrary HTML”) is a way to expand the capa-
bilities of Muse beyond the supplied tools and functionality. This is also one area 
where the embedded HTML will work only if the pasted code works—sort of a 
garbage in, garbage out principle. 

You may struggle a bit with code that students “find” and paste into their pages. It’s 
difficult to determine why something isn’t working if you don’t know where it came 
from. Also, with the explosion of jQuery and other JavaScript libraries, students 
will find a great new widget (say, a slideshow) and paste the HTML into their Muse 
page only to find that it doesn’t work. More often than not, jQuery content requires 
not only the HTML content, but also CSS and links to at least one JavaScript 
library. It’s important to set expectations with students in the beginning. That’s one 
reason we chose to showcase HTML content from trusted sites like Google and 
Twitter. The code is self-contained and doesn’t require the student to link to any 
other content.

There are also two main methods for inserting HTML into a Muse page. After 
copying the code, choose Object > Insert HTML to reveal the HTML dialog box, 
or paste the code directly into a page in Design mode by choosing Edit > Paste. 
The second method is quicker, but demonstrate the first method listed to get 
students started.

If the students embed HTML by choosing Object > Insert HTML, the content 
will appear on the page in a frame that most likely will not match the size of the 
content. That’s okay, unless you want to apply a stroke to the border. If you paste 

https://creative.adobe.com/addons
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HTML content directly onto the page by choosing Edit > Paste, the size of the con-
tent’s frame will match the size of the content.

Inserting HtML

Fortunately and unfortunately, the web changes all the time. The example we use in 
the book, I assume, at some point will no longer be available. In that case, you can 
use any HTML found that works.

the Library panel
Working with the Library panel is pretty straightforward. Like we suggested in the 
beginning of this section, have students explore the Add-ons site by clicking the 
“online” link in the “Find more library items online” text in the panel preview (with 
nothing selected in the panel). Have them select a free add-on and go through the 
process of downloading it (if your admin settings allow it). They can then get the 
downloaded file from their Downloads folder. The Add-ons site currently offers 
this explanation: 

Where to find it

Please find the file in your Downloads folder.

Muse toolkit and widgets are provided in a single .mulib file. Double clicking the file 
will open the library directly in Muse, and widgets are instantly available to drag on 
to the design canvas.

Content saved in the Library panel can be reused over and over. It’s also a great way 
to save and reuse design content that you create—even colors and formatted text 
that contains styles.

Questions
The following questions are not in the student’s Classroom in a Book:

1 How would you edit HTML code that you embedded into Muse?

2 What is the Adobe Add-ons site?

Answers
1 With the Selection tool, right-click the object on the page. Choose Edit HTML 

from the context menu that appears. In the Edit HTML dialog box, you can edit 
the code directly.

2 The Adobe Add-ons website is a place where you can upload, search for, 
discover, and install plug-ins, extensions, and more for Adobe Muse and other 
Adobe products. Those extensions can easily be brought into the Adobe Muse 
Library panel to be used within your sites.
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Lesson 10: Designing for Mobile Devices
In this lesson students will see how they can optimize their design content for 
different devices. One thing that I hear all the time when talking about Muse and 
“mobile” is the term “responsive design.” Muse does not create a responsive design; 
rather, you create web pages for phone, tablet, and or desktop that are served to 
the proper device when the user goes to visit the site on that device. This method is 
somewhat similar to an adaptive design. This means that, if you decide to optimize 
the content, which in Muse means creating alternate layouts, you will have a bit of 
work ahead of you. A good section in this lesson is devoted purely to the copy and 
paste of content from one layout to the other, as you’ll see.

To be clear, the Desktop site you create will work on devices as well. It will just be 
scaled like any other website.

Goals for this lesson
In this lesson, students will learn how to 

• Add and edit alternate layouts in the Muse project

• Create mobile navigation for a Phone layout

• Copy assets and page content between layouts

• Add tel: links that call a phone number when tapped

Working with alternate layouts
In the first section of the lesson, we discuss what alternate layouts are. Tell students 
that code is supplied behind the scenes that will detect the generic type (size) of 
device that the site is going to be viewed on. The code will grab the correct layout 
(phone, tablet, or desktop) and serve it to the device. If the page is a bit too large or 
too small, it will be scaled.

Have students explore the mobile site at the beginning of the lesson. If possible, 
have them type in the URL on their device as well to see how the site works.

Adding an alternate layout
At the beginning of this section, discuss why they would start with either a Desktop 
layout or Phone layout when first creating their site. If they decide to go with 
“mobile-first” design, this generically means designing for the smaller devices first 
and then progressively enhancing the design and features for the two larger layouts 
(tablet and desktop).

Adding an alternate layout really just copies the pages from the layout you choose 
(in this case, the Desktop layout) and sizes them. It also adds generic page attri-
butes and the browser fill if you choose. None of the content is copied over. 
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Honestly, it would make a bit of a mess if you copied desktop content over to a 
phone layout and be more work in the process.

Going forward, students need to really pay attention to what page they are looking 
at in Design mode. It should be pretty obvious based on the page size and the name 
of the page in the tab.

Have students read the “Mobile design considerations” sidebar. This can be helpful 
information for starting down the road to mobile optimization. Students can also 
visit websites like the following (if they are still there!):

• http://www.onextrapixel.com/2012/01/02/
design-best-practices-for-the-mobile-web/

• http://www.webdesignerdepot.com/2012/11/
best-practices-for-navigation-on-the-mobile-web/

• http://www.adobe.com/inspire/2011/11/ten-best-practices-designing-mobile-
websites.html

Adding a mobile menu to the Phone layout master page
There are so many methods for adding a mobile menu to a Muse site. The method 
introduced in the book is clever and mirrors more of a type of mobile menu you 
might find on sites today. To help explain how the menu works, have students look 
at the figure in step 13. The menu is just a vertical menu widget stuck inside of an 
Accordion widget with only one panel. 

There are tons of resources for finding other menu systems, including: 

• http://musesuperwidgets.businesscatalyst.com/index.html

• https://blogs.adobe.com/muse/

Here is a more in-depth look at how a menu similar to what we use in the lesson 
is built: 

• http://www.adobe.com/inspire/2013/09/mobile-navigation-muse.html

copying content between layouts
There are a bunch pages devoted to simply copying and pasting content from the 
Desktop layout to the Phone layout. If you are in a time crunch, you can skip some 
of this and just focus on a single page to give students the idea of the process.

Here are a few things to keep in mind when copying/sharing content between 
alternate layouts:

• Use styles whenever possible since they are shared between layouts

• 100% width content will automatically fit to the browser area in any 
alternate layout

http://www.onextrapixel.com/2012/01/02/design-best-practices-for-the-mobile-web/
http://www.onextrapixel.com/2012/01/02/design-best-practices-for-the-mobile-web/
http://www.webdesignerdepot.com/2012/11/best-practices-for-navigation-on-the-mobile-web/
http://www.webdesignerdepot.com/2012/11/best-practices-for-navigation-on-the-mobile-web/
http://www.adobe.com/inspire/2011/11/ten-best-practices-designing-mobile-websites.html
http://www.adobe.com/inspire/2011/11/ten-best-practices-designing-mobile-websites.html
http://musesuperwidgets.businesscatalyst.com/index.html
https://blogs.adobe.com/muse/
http://www.adobe.com/inspire/2013/09/mobile-navigation-muse.html
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• Widgets are already set to accept swipe input on touch devices

• Mobile (Phone) is usually a single column layout

• Use the Page > Matching Page and other methods for jumping between 
pages quickly

• Make sure that the images you use are optimized for large and small devices. 
This may mean replacing larger images on the Phone alternate layout, 
for instance.

• Test your layouts using Adobe Edge Inspect CC from the Chrome browser 
(if that is your default browser)

Working with assets
Make sure students understand that the images that came from and worked in the 
Desktop layout will be optimized by Muse to download faster on a mobile device 
by default. Sometimes the way Muse optimizes the image may not be exactly what 
you want the image to look like. In that case, you can follow step 6 in this section to 
relink to an asset that you optimized in a program like Photoshop.

Previewing Phone and tablet layouts
Previewing in Muse is no substitute for previewing directly on a device. I usually 
suggest students publish a trial site in Muse and open that temporary URL on their 
device to see what it will look and act like. Previewing in Muse is not true emulation; 
rather, it just fits the content from that layout into a size that matches the device size.

Questions
The following questions are not in the student’s Classroom in a Book:

1 In order to link to a phone number, what must you type in before the actual 
number in the Hyperlinks field?

2 When linking in Muse, how will you be sure that you are linking to the correct 
page in the correct layout?

3 How many columns are in a typical Phone layout by default?

Answers
1 In order to have a user tap a link and have it dial on the phone, you must type 

“tel:+” before the actual phone number.

2 The links in the Hyperlinks menu are organized by layout. So all of the links and 
pages that are available in the Desktop, Phone, or Tablet layouts will appear in 
the menu, organized by layout.

3 Phone layouts have one column by default.
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Lesson 11: Publishing and exporting Your site
Lesson 11 is a very important topic when it comes to the web. There are three 
methods for getting the HTML content out of Muse to either publish or share with 
others. It is important for this lesson that students understand the fundamental 
difference between publishing to Adobe hosting, uploading to your own host, and 
simply exporting the website content.

All students will be able to publish a trial site (assuming the classroom has an 
Internet connection). When it comes to launching the trial site, students will either 
need to pay a monthly fee at that point or, if there is a membership to the Creative 
Cloud service, use the included hosting.

When students publish to Adobe hosting, they can easily update and manage the 
site process directly from within Muse—making it seamless. As you will learn 
later in the lesson, exporting to HTML breaks the tie to the .muse site currently, so 
after the site is exported, any changes made to the .muse site will not update the 
exported content. The site content will need to be exported again.

Goals for this lesson
In this lesson, students will learn how to

• Exclude pages from export

• Publish a site as a temporary (trial) site

• Publish changes

• Convert a temporary site to a live site

• Publish a site to a host of their choice

• Export a site as HTML 

understanding Muse publishing
This section explains the two different output options: publishing directly to 
Business Catalyst and exporting to HTML. Take the time to make sure students 
understand the differences between publishing and exporting; this area can trip up 
new users. Ideally, walk them through different scenarios, demonstrating when you 
would publish a site versus when you would export a site.

excluding pages from export
This section could easily have been in Lesson 3, “Working with Master Pages,” but 
we felt that because we are discussing publishing and exporting, it would make 
some sense to place these topics together. 
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Students need to be careful when choosing not to export a page. If the page is 
linked to from another page or included in the menu, a Page Not Found error will 
occur on the site when previewed, published, or exported. If the page is also a part 
of a menu widget, they may wish to also exclude the page from the menu widget 
by right-clicking the page thumbnail in Plan mode and choosing Menu Options > 
Exclude Page From Menus.

Some reasons for not wishing to export a page include: creating a sales page for a 
sales event in the future, creating a version of a page for testing, using the page as a 
“wireframe” proof of concept to refer back to, and many more.

Publishing your site
The publishing process begins by having either the L11_start.muse file from the 
Lesson11 folder open or the student’s .muse site file open. The process of publish-
ing a trial (some call it a testing site) is described in the “Publishing a temporary 
site” section. Students can create a temporary site even if their site is not finished. 
This can be a way to preview what has been accomplished thus far in a browser and 
to share that content with someone else who has a browser and Internet access.

In rare cases, the Upgrade To Adobe ID dialog box may appear when the Publish 
link has been clicked. Students most likely will not see this. This dialog box appears 
only if the student has previously created a Business Catalyst account and has used 
the same email address as the Adobe ID they used for Muse. In most cases, the 
Publish dialog box will open instead.

When students are asked to enter a site name, stress to them that this is only for 
testing purposes. Later, when the site has been pushed live (is paid or uses one of 
the hosting accounts supplied with the Creative Cloud membership), they can asso-
ciate their own domain name (site name).

When a student clicks OK in the Publish dialog box to publish the site files (see 
step 4), Muse creates the HTML, CSS (styling), and scripts (JavaScript for things 
like the widgets to work); optimizes the images (if necessary); and more. This pro-
cess may take a little while the first time the site is published, because it also has to 
be uploaded to the Adobe hosting server. The upload time can vary greatly depend-
ing on how much content is in the site and the Internet connection speed.

Making changes and republishing

The uploading edit process is a simple one when the site is hosted with Adobe 
hosting. With edits made and the site saved (File > Save Site), students can click the 
Publish link to upload any changes. Muse will not re-upload the entire site; rather, 
it will upload only files that have changed. Sometimes this may mean that depen-
dent files that Muse generates like JavaScript files will need to be uploaded as well, 
and that’s okay.
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Stress that students simply click the Publish link, then click OK in the Publish 
dialog box when attempting to upload changes. Any options that they change in the 
Publish dialog box may result in the changes not affecting the site. If they change 
options in the Publish dialog box, they can always click Cancel and try again.

Launching a temporary (trial) site

Some students wonder why they should bother upgrading a temporary site to a 
paid site. Upgrading your trial Muse site to a paid site has many benefits, including 
that a paid site doesn’t expire, you can use your own domain name, and you can 
add other admin users who can also access the site’s Dashboard to view site statis-
tics (reports) or help manage the website settings, to name a few.

Also, a temporary site needs to have been created in order to upgrade it. That 
sounds ridiculous, but we have had students who rightfully assume that they can 
publish to a paid site from within Muse in one step. While it is easy to push a tem-
porary site live, it requires a few steps.

The Important! paragraph in the “Launching a temporary site using a Creative 
Cloud hosting credit” section states that the following steps will, at one point, 
require you to use a hosting credit. Students can get the hosting credit back as seen 
in the next section.

In the “Associating a domain with your site after it’s launched” section, step 1 
discusses adding a domain on the Adobe hosting Admin website. This can only be 
completed if a domain name was purchased through a third-party registrar like 
GoDaddy.com or other. Also, purchasing one domain name and attempting to 
“share it” with other students may not work.

In step 4, in order to associate the domain name with your Muse site, you need to go 
to the registrar (like GoDaddy.com) and change the DNS information for the domain 
name. Typically, when you purchase a domain name from a registrar, you are sent an 
email that contains a link with a username and password. This link grants you access 
to an admin area on their site where you can manage your domains. After logging in 
to the registrar, you can then make your way to the DNS information for the domain 
name and update it. You can contact the registrar or search the FAQ for the registrar 
to find information on how to edit the DNS for a domain.

uploading your site to a third-party host
This is a section that you may not be able to go through in class. This section 
requires that you have hosting credentials.
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exporting your site as HtML
Exporting to HTML is a simple process with no options to set. Exporting to HTML 
can be a great way to get optimized images that can be used in other projects. Also, 
the files that are generated will live in a folder outside of Muse. That is the entire 
Muse site you designed and can now be published to the host of your choice.

Some students who have Dreamweaver experience may ask if they can open the 
exported files in Dreamweaver and edit them further. While they can, it isn’t 
advised. The code that is generated is meant to work in all supported browsers, but 
it may not be the code that they would create.

Questions
The following questions are not in the student’s Classroom in a Book:

1 What is the process for publishing changed content to Adobe hosting?

2 Within Muse, how do you access the Adobe hosting admin website?

3 What must be done to a temporary site to associate a domain of your choice 
with the site?

4 Where in Muse can you change the publish account associated with Muse?

5 What benefit does having a Creative Cloud membership carry for those of us 
working with Muse?

Answers
1 With the site published and new site changes made, you can click the Publish 

link (or choose File > Publish) and then click OK in the Publish dialog box to 
publish only modified files.

2 With a .muse site file open and the site already published as a temporary site, 
click the Manage button to access the Business Catalyst Admin website.

3 In order to associate a domain name that you purchase separately, the 
temporary site must be pushed live. This is accomplished by clicking the Push 
Site Live button in the Adobe Hosting Admin Console website.

4 In order to change the publish account associated with Muse, choose Adobe 
Muse > Preferences. In the Preferences dialog box, choose Switch Accounts 
from the Publish With Account menu and click OK.

5 Having a Creative Cloud membership includes hosting for five websites at the 
webBasics level. You also can track websites (temporary or paid) through the 
Creative Cloud admin area.
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enjoy the book!
I truly hope you find this Adobe Muse CC Classroom in a Book (2014 release) useful 
and helpful in your classes. As it says at the beginning of the text, this book is not 
meant as a replacement to the official documentation. Although it doesn’t include 
everything Adobe Muse can do, we picked many of the most important aspects and 
workflows of a program that are useful. 

My editing team and I worked very hard to make the book the best it could be, but 
there’s always the chance something doesn’t work the way we expect. 

If you find yourself stuck or needing clarification on a lesson, feel free to reach out 
to me on twitter (@AskBrianWood) or by email (brian@brianwoodtraining.com).

Wishing you all the best in the classroom and out,

Brian Wood

mailto:brian@brianwoodtraining.com

