INSTRUCTOR NOTES

Getting Started

The Adobe® Fireworks® CS4 Classroom in a Book® course presents students with tips, techniques, and solutions for using the Adobe Fireworks CS4 software.

The Instructor Notes are intended to complement the information in the Adobe Fireworks CS4 Classroom in a Book®. The information is organized to follow the sequence of instruction in each lesson. These notes are not a play-by-play of each subsection of the book; rather they point out specific areas where we feel you can expand on the lesson, or perhaps introduce tangential subjects that may not be covered in the text.

Course strategy

If you’re teaching a 15-session class, you can teach approximately one chapter of this book per class. The book contains 11 lessons, plus two supplemental lessons on the companion disc, some of which may take a while to complete. If you are teaching a 10-session class, you may want to combine some of the lessons in a single class. For example:

- Lesson 1 is focused on learning about the Fireworks user Interface.
- Lesson 5 covers the Layers panel in detail. This is a very important panel in Fireworks and crucial to almost any but the most basic work in Fireworks.
- Lessons 2 and 3 cover related aspects of photo retouching and bitmap selections.
- Lesson 4 is about working with and creating vector objects. Also, Lesson 6 covers effects that are based on masking using both vector objects and bitmap selections. Lesson 7 focuses on working with text.
- Lessons 4 and 9 deal specifically with layers, although layering is a crucial element in almost every lesson following Lesson 4.
- Lesson 8 is an in-depth introduction to creating web objects, optimizing images for web use, and exporting files for use in HTML-based prototypes.
- Lesson 9 is focused on the three different types of symbols you can create within Fireworks. Symbols can save you time and file size because they can be used over and over again within a file, and because editing symbols affects all children (instances) of a symbol that are in a design.
- Lessons 10 and 11 are focused on creating interactive prototypes. Lesson 10 begins with an in-depth discussion of the Pages feature in Fireworks and ends with the student exporting an interactive PDF file. Lesson 8 should definitely be covered before moving to these lessons, as web objects are used in both lessons 10 and 11.
Lessons 12 and 13 (found on the companion disc) take the student beyond the basic functionality of Fireworks and cover topics such as using Adobe Bridge, batch processing, adding metadata to files, and working with other applications such as Photoshop, Flash, Dreamweaver, AIR, and Flex.

Managing student projects

One way to simplify file storage and retrieval in classroom situations is to ask students to create a folder on their hard disks, name it [Student’s, for the student’s name] Lessons, and then copy each project folder into the main Lessons folder. Having students keep all their working files in their own Lessons folder makes it easy for you to clean up files when a class is over.

Lesson 1: Getting to Know the Workspace

The first lesson presents an introduction to the Adobe Fireworks CS4 software. Using the basic commands, tools, and panels, your students will learn general techniques for using the work area efficiently, obtaining information about the image in front of them, and selecting tools or entering values to change the image. This lesson also introduces students to the History panel, a valuable tool in undoing and stepping backwards in their work.

Goals for this lesson

How much time you should schedule for this lesson depends on whether your students already have any knowledge of Fireworks and on their computer skills in general. The overall objective for Lesson 1 is to make them sufficiently familiar with the user interface so that they can locate the controls they need to do the procedures in the rest of the lessons. Additionally, by learning how to help themselves, they gain confidence and independence. In general, they should be able to do the following:

- Identify and name the key areas of the interface, including the Tools panel, panels (in general), document windows, and the Property inspector.
- Open the main menus and submenus across the top of the work area (File, Edit, and so forth), context menus, and panel menus.
- Access and search Adobe Community Help, which includes the full Fireworks CS4 Help, as well as links to other Adobe and third-party Fireworks resources online.

Finding tools in the work area

You may want to introduce students to the Fireworks environment by providing a general tour of the work area. This helps orient the students and provides a review of the names of the elements on the screen. For example, you may point out the title
bar and remind students that it indicates which document is currently active. Then point out the menu bar, the rulers, the page icons, the panels, and the Tools panel.

Students may already be used to keyboard shortcuts as a simple alternative to using the mouse. Fireworks and other Adobe products allow you to combine keys with mouse clicks to perform tasks quickly.

Many Fireworks professionals keep one hand on the mouse and the other over the keyboard to switch tools and modes. You may want to demonstrate how this method allows you to keep the pointer directly over the part of the image that you’re editing.

Encourage students to use commands at first, so they understand what they’re doing and how it relates to the application. As they become more comfortable with the tools and concepts, remind them that shortcuts can help them accomplish tasks more quickly.

Using the application frame and the application bar

New to Adobe Creative Suite 4 are the application bar and, in Mac OS, the application frame. By default, the application bar is enabled and the application frame is not. Some lessons include steps that use the application bar, so it’s best for students to leave it visible, though they may prefer to hide it when they work on their own.

If your students are working in Mac OS, suggest that they enable the application frame to minimize distractions from other applications and items on the desktop. If you reset preferences at the beginning of each lesson, you’ll need to enable the application frame each time.

Viewing designs

Double-clicking the Zoom tool displays one image pixel for each monitor pixel. This magnification displays an image at exactly the same size as it will appear in a web browser. But because monitors can be set to different resolutions, the real size of an image viewed in Actual Pixels view or in a web browser will vary depending on the monitor in use.

Point out that you can also change magnification of a design by choosing a Zoom level in the Application bar or from the Zoom level in the document window at the lower-right corner.

Many users are unaware that the monitor resolution can be changed so you may want to demonstrate this. Increasing the resolution makes more room for panels and images on the screen, but with the trade-off of making everything smaller.

Finally, you may want to demonstrate how to see a single image at two magnifications simultaneously. To do so, choose Window > Duplicate Window and then drag the tab of the new window to the left or right side of the document area to show
both views at the same time. You can zoom into one view to make detailed changes while viewing the full image in another window to see the changes in context.

**Using the Property inspector and panels**

Students should understand that the Property inspector is not the same as the toolbar (or button bar) found in products such as Microsoft Office. In Fireworks, the controls that appear on the Property inspector change depending on the selected tool. Similarly, the Property inspector cannot be customized because it always represents options for the current tool. Take care to refer to the Property inspector by its complete name and not as a “toolbar” or “button bar”.

**Using the History panel**

You can use the History panel simply to undo steps, or to automate certain workflows by replaying history steps. Make sure students understand that history states aren’t saved with the document. You can suggest that if students want to keep different versions across sessions, they should set up a design as separate pages or documents instead.

To supplement the information in this section of the book, you can tell students about the Save Steps as a Command feature in the History panel menu. This lets the student save a series of history steps as a JavaScript command, which they can invoke from the main Commands menu any time they wish. Point out that they can use this feature by selecting a series of history steps generated from menu or keyboard commands (steps such as moving objects on the canvas with the mouse cannot be saved as part of a custom command) and then choosing the Save steps as a Command icon.

**Configuring panels and the panel dock**

The Tab keyboard shortcut lets you hide all panels instantly, so that you can quickly evaluate designs without distraction. When you’re working on a small screen, it also lets you use the entire screen to edit images. The Tab key returns the panels just as quickly.

The F key will cycle between different workspace views (Standard view, Full screen with menus and panels, and Full screen). In Full screen view, mousing over any of the four sides of the workspace will reveal the panels in that area.

Show students how easy it is to collapse panels to icons, and then expand the panels again with a click. In this lesson, students will look at customizing a workspace. They will define a custom workspace in Fireworks that shows and hides specific panels, based on the type of task they are performing.

You do not need to go into this feature in-depth now, to avoid the risk of information overload in the first lesson.
Using a context menu

While not covered as a specific section in this lesson, demonstrate how context menus change depending on the content under the pointer. Right-click (Windows) or Control-click (Mac) the following examples:

- Different layers
- An active object on the canvas
- Text with an insertion point
- In any list panel

If your students use graphics tablets, encourage them to program their stylus button to display context menus.

Using Fireworks Help

Choosing Help > Fireworks Help opens Adobe Community Help, which includes the entire Fireworks Help, as well as links to other online resources. Show students that Fireworks Help includes access to a variety of tutorials, both written and in video format.

Using Adobe Online services

Students may inquire about privacy concerns related to the Adobe Online service. You can reassure them that no personal or configuration-related information is sent from their computer, except that which is explicitly typed in by the user as part of the voluntary online registration process.

Questions

The following questions are not in the student’s Classroom in a Book.

1. What do you do if you can’t find a tool that you know exists?
2. How can you find the keyboard shortcut for a tool?
3. How can you instantly hide or show all panels?
4. What are other ways to switch to a specific preset zoom percentage?
5. What magnification is the best representation of an image’s size on a web page?
6. How do you view multiple documents at the same time?
7. What is the difference between a panel and a document window?
Answers

1. Look in the Tools panel for a related tool with a small black triangle. That triangle symbol indicates that holding down the mouse button on that tool opens a list of hidden tools at that location.

2. Hold the pointer over the tool until the tool tip appears containing the keyboard shortcut for that tool.

3. Press the Tab key (when you’re not editing text).

4. Choose the zoom level from the Application bar or from the lower-right corner of the document window.

5. 100%

6. Undock a document by dragging its tab away from the tab bar. Then drag the title bar of the document to any of the four sides of the main document window. When a blue highlight appears, release the title bar.

7. A panel contains a set of related controls that you select and use to work on your document. You can have many panels open, group them, hide them, and separate them. The document window displays your design. If you close a document window, you close that file.

Lesson 2: Working with Bitmap Images

This lesson introduces learners to working with and editing bitmap images. Fireworks works equally well with vectors and bitmaps, and becoming aware of this flexibility is important to realizing the full potential of Fireworks.

The basics of opening, importing, cropping, and retouching images will be covered in this lesson.

Goals for this lesson

With the solid set of Bitmap tools in Fireworks, there will be many situations where the user can work entirely within Fireworks without having to switch to other applications. The overall objective of this lesson is to familiarize users with these tools and give them insight into how images can be retouched using bitmap tools such as Dodge and burn or the Rubber Stamps, or in a non-destructive manner using Live Filters.

In general, they should be able to do the following:

- Identify and name the key bitmap tools
- Import images into an existing design
- Non-destructively alter an image using Live Filters
Repair images using the Rubber Stamp
Resize images

In addition, there is an exercise that introduces the new 9-slice scaling tool where you can show users how to scale certain types of bitmap images in one direction with no distortion. This feature was previously only available for symbols in Fireworks CS3.

Resolution and image size
Point out the relationship between image resolution and file size, and also how a high-resolution image does not necessarily mean a high quality image. Cheap digital cameras, poor quality scans, or highly compressed images can produce a high-resolution, yet poor quality image.
Encourage the students to resample images and see what happens to file sizes.

Cropping
Fireworks can crop an entire design or specific bitmaps within a design. Show how to quickly apply the cropping marquee to an entire image by double-clicking on the tool.
Point out that cropping a design does not have to be destructive; you can set cropping preferences within the Preferences panel.

Managing images on the canvas
Complex designs tend to contain multiple images. Point out that Guides, tool tips, Smart Guides, the keyboard, Pointer tool, and the Property inspector can all be used to help position objects precisely on the canvas.
While not mentioned in the book, users can also set up a Grid to help align objects.
Demonstrate how to activate tool tips and how Smart Guides can help align objects to each other or to the canvas. Point out that snapping can be activated for Smart Guides, Grids, and Guides, and that the snapping distance can be adjusted within the Preferences panel.

Importing an image
Importing images is an often overlooked but powerful feature. The exercise on importing images demonstrates how you can quickly add a file to a currently open document and throughout the book your students will call on the Import feature regularly.
Mentioned in the book is the importance of not scaling an imported bitmap larger than its original size. While there is no specific exercise to demonstrate this, have the students import the watch_colors.png file and scale it wider than the currently open document to show how bitmap images will be affected when enlarged.
Encourage students to import other files to the document and experiment with scaling.
Distortion-free bitmap scaling with the 9-Slice scaling tool

The 9-slice scaling tool is new to Fireworks CS4 and gives you the ability to scale rectangular vectors and certain bitmaps without having to convert them to symbols. In this lesson, the students scale a photograph to widen the image.

9-slice scaling is only effective on bitmaps that have areas that will not be affected by scaling in a single direction. The exercise provides the students with a photograph to scale, but a more common use would be for scaling screen grabs of interface elements such as dialog boxes or panels.

Supply the students with such an image and have them use the 9-slice scaling tool to alter the image size in a single direction.

Adjusting the tonal range

Photoshop may be the king of bitmap editors, but Fireworks has a wide range of features to help you correct bitmap images, including some non-destructive ones.

Point out that several corrective tools are available in the Live Filters > Adjust color menu, including Auto Levels, Levels, Curves, Brightness/Contrast, and Hue/Saturation.

All Live Filters remain editable during the current session and remain so if the file is saved as a Fireworks PNG file.

Point out that Live Filters must be applied to an entire selected object. To apply corrective filters to a specific area of a bitmap, a bitmap selection must first be made and then the filter is applied from the main Filters menu. Unlike Live Filters, these adjustments permanently alter the selected area.

Live Filters are also used when applying the Unsharp mask in a later exercise in this lesson.

Using the Align panel

Smart Guides are a new alignment feature in Fireworks, but the old standby, the Align panel, has also been updated in Fireworks CS4.

Point out that you can align images to each other whether they are bitmap, vector, text or groups, or to the canvas.

Adjusting brightness with the Dodge and Burn tools

This exercise and the Rubber Stamp exercise both rely on permanently altering pixels. Demonstrate what this means in a workflow to preserve original image information, from working on a duplicate bitmap image to opening a file as untitled document.
Repairing areas with the Rubber Stamp tool

Point out that for accurate retouching, it’s a good idea to zoom into the area to be fixed. In many cases, soft-edged brushes make for a more realistic effect because the edge of the Rubber stamp blends better with the surrounding area.

Using the Rubber Stamp requires that you sample an area first. Point out that you can resample as often as you feel is necessary to produce a satisfactory result.

Retouching on a separate bitmap object

This is the prep work for the instant facelift exercise. It discusses why retouching on a separate bitmap object is good professional practice and shows the steps needed to add the new bitmap object.

In this scenario, an empty bitmap object is used, rather than duplicating the original bitmap object, but either workflow is useful and preserves the original bitmap. Another advantage of retouching in a separate bitmap object is that the opacity of the entire object can be reduced for a more subtle effect, or the retouching can even be deleted or hidden if it is no longer desired.

Instant facelift

This exercise combines the use of a separate bitmap layer, bitmap selection tools, and the Rubber stamp to correct overexposed skin tones while retaining the original bitmap information.

Because the students will be applying the retouching to a separate bitmap object, sampling options in the Property inspector will need to be altered.

Point out that the opacity of the Rubber Stamp can be altered as well, which can create a more subtle result.

Questions

The following questions are not in the student's Classroom in a Book.

1. Why would you use the Unsharp Mask Live Filter?
2. What tool can be used to brighten a specific area in a photo?
3. What tool can be used to darken a specific area in a photo?
4. Why would you group objects together and how do you do it?
Answers

1. Images that have been resized smaller tend to also become softer in appearance due to the reduction in pixels, but you can gain back some of the original crispness of the photo by applying a filter called Unsharp Mask. Unsharp Mask can be applied as either a permanent filter or as a Live Filter. For the greatest flexibility, Live Filters are a better option.

2. The Dodge tool can be used on photos or other bitmap objects to lighten an area by painting over it. You can adjust the brush (tool) size, softness, shape, exposure (degree of effect), and the tonal range (shadows, midtones, highlights) you want to alter.

3. The Burn tool does the opposite of the Dodge tool, darkening areas where the tool is applied. The same tool attributes as the Dodge tool can be adjusted in the Property inspector.

4. Grouping related objects (a navigation bar, for example) makes it easier to reposition all the related objects in a single action. Grouping also simplifies the Layers panel, because grouped objects only show as a single object. You can group two or more objects by Shift-clicking on the objects and then choosing Modify > Group or pressing Ctrl+G (Windows) or Command+G (Mac).

Lesson 3: Working with Selections

This lesson introduces learners to working with bitmap selections. In order to limit bitmap effects to a specific area of an image, a bitmap selection must first be made. Point out to students that anything outside the selection will remain unaltered.

Fireworks works equally well with vectors and bitmaps, and becoming aware of this flexibility is important to realizing the full potential of Fireworks.

The basics of opening, importing, cropping, and retouching images will be covered in this lesson.

Goals for this lesson

With the solid set of Bitmap tools in Fireworks, there will be many situations where the user can work entirely within Fireworks without having to switch to other applications. The overall objective of this lesson is to familiarize users with these tools and give them insight into how images can be retouched using bitmap tools such as Dodge and Burn or the Rubber Stamps, or in a non-destructive manner using Live Filters.

After completing the lesson, they should be able to do the following:

- Make specific areas of an image active using selection tools
• Create a selection with the Magic Wand
• Adjust the edge of a bitmap selection
• Apply corrective filters to a selection
• Make complex selections using the Lasso tool and Magic Wand tool
• Modify a bitmap selection
• Save a bitmap selection for future use
• Deselect a selection
• Convert a bitmap selection to a path

About selecting objects and selection tools
This section gives an overview of the bitmap selection tools and discusses their various features. Point out to students that when making selections, you can switch back and forth between the tools, using whatever tool is most suitable for the work. Combined with the sidebar called Bitmap selection tool primer, learners will quickly get a sense of the options available.

Selecting and modifying with the Magic Wand tool
Selecting an area is one of the first steps to altering part of a bitmap. This exercise walks the learner through a tried and true workflow for bitmap editing, including the creation of a duplicate bitmap object.

Using the Magic Wand with keyboard modifiers
While this exercise uses the Magic Wand, point out that all the bitmap selection tools allow you to modify (add to or subtract from) the current selection using the same keyboard modifiers.

Saving bitmap selections
Point out that when creating complex selections, it can be very helpful to save those selections for later use. Multiple selections can be saved with any file, so long as it is saved as a Fireworks PNG file.

Selecting with the Lasso tool
This exercise demonstrates how selection tools can be used interchangeably. They start by using the Magic Wand to select a large area of similar color, then zoom in and use the Lasso tool and modifier keys to further refine the selection.
Converting a selection to a path

Because Fireworks can edit both vectors and bitmaps, it makes sense that bitmap selections can also be converted to vector paths. Point out that paths can be easier to edit than bitmap selections, thanks to the individual control points of a vector. Also, the students aren’t as likely to delete an entire path by accident, something that is easily done with a bitmap selection by forgetting to use the Shift and Alt (Windows) or Option (Mac) modifier keys when adjusting a bitmap selection.

Questions

The following questions are not in the student’s Classroom in a Book.

1. How do you create a soft-edged selection?
2. What does Live Marquee do?
3. How do you save a bitmap selection?
4. How do you convert a bitmap selection to an editable path?
5. Why would you use the Select Inverse command?

Answers

1. You can create soft-edge selection by applying a feather to the selection. Feathering can be applied in three different ways:
   - Select the feathering option in the Property inspector before the selection has been made.
   - Apply the feather afterwards using the Property Inspector and Live Marquee.
   - Choose Select > Feather from the menu.

2. Live Marquee gives you immediate control over the edge of your bitmap selection after it has been drawn. You can choose Hard for an aliased hard-edged selection; Anti-aliased for a softer, slightly blended selection edge; or Feathered for a very soft blend.

3. Once a bitmap selection has been made, choose Select > Save Bitmap Selection. You can name the selection in the dialog box that appears.

4. You create a path from a bitmap selection by choosing Select > Convert Marquee to Path. The bitmap selection is deleted when you do this, but Fireworks also has a command to convert paths to bitmap selections, so the process is easy to reverse.

5. Selecting the unwanted part of the image is sometimes easier. Select Inverse is used to toggle the active selection between the original selection and the non-selected areas.
Let’s say you have a photo of a city scene with a clear sky in the background. You want to do some levels or filter adjustments to the city area. It will be easier (and faster) to use the Magic Wand tool to select the evenly colored sky. Then you can go to Select > Select Inverse to reverse the selected areas, making the city scene the active selection.

**Lesson 4: Working with Vector Objects**

Vectors are a key design element within Fireworks and will be needed in almost any design a user creates. This lesson shows the learner how to create and edit vector graphics and how flexible this graphic format is as a design tool.

Learners will also use the 9-slice scaling tool again, only this time on vector objects. This is a good opportunity for them to practice with this tool and learn about more about the differences between vectors and bitmaps.

If the learners have no previous vector art experience, the Pen tool can prove to be a somewhat intimidating tool. Extra practice creating their own custom shapes, as well as adding additional control points to existing paths, are recommended.

Looking forward, in Lesson 6 (Masking) you will be working with both bitmap selections and vector shapes to create masks for a variety of objects.

While only mentioned briefly in the lesson, we recommend you take time to explore the Path panel. This would be more of an intermediate exercise for you to create, but the Path panel is a very powerful tool.

**Goals for this lesson**

After completing the lesson, the students should be able to do the following:

- Draw simple vector shapes
- Demonstrate the differences between vector and bitmap images
- Use the 9-Slice scaling tool to scale vector shapes
- Demonstrate how to use Auto Shapes
- Create paths with the Pen tool
- Edit paths with the Pen and Subselection tools
- Create a custom shape
- Customize the fill and stroke of a vector shape
Basic vector drawing techniques
In Lesson 1, the learner created their first vector shape – an ellipse. In this exercise, they will delete the ellipse and add a rectangle. Point out how easy it is to round off the corners of the rectangle, either while they are drawing it or later using the Property inspector.

About bitmap images and vector graphics
While introduced a bit later in the lesson, you might want to spend some time up front comparing vectors and bitmaps on screen, showing the differences between the two main graphic formats.

Distortion-free scaling with the 9-Slice scaling tool
Point out that the 9-slice scaling tool is most useful on vectors that are mostly rectangular in shape. 9-slice scaling an ellipse, for example won’t produce a desirable result because the tool needs straight paths in order for the scaling to work.

Adding text to your design
Text is covered in much more detail in its own lesson (Lesson 7), but now is your chance to introduce the Text tool and demonstrate how to change font families, styles, and color.

Working with Auto shapes
We only work with one auto shape in this exercise, but there are many to choose from. Point out that other shapes can be found in the Shapes panel and take time to experiment with them. You might want to consider giving the students an extra credit project to create a logo using Auto shapes.

You may also want to expose them to the Auto Shapes panel, where they can edit the properties of an Auto Shape without having to drag the yellow control diamonds.

Understanding paths and the Pen tool
Be prepared to spend extra time in this area if your students do not have any vector drawing experience. Proficiency with the Pen tool means they are not locked in to using the standard shapes supplied by Fireworks; they can create their own. The Pen tool also is very useful for creating custom mask shapes. Make sure they also take time with the Subselection tool to practice editing the points of a new or existing vector shape.
Other vector tools (sidebar)

No specific exercise was created for the other vector tools, but this can be another opportunity for you to help your students gain confidence and get even more creative with vectors. Each tool’s functionality is outlined in the sidebar.

Editing paths

The real power in vectors is in knowing how to edit them to get the results you want. Your main tool for editing a path is the Subselection tool. Point out that you can edit individual control points by selecting them with this tool, or you can hold down the Shift key to select multiple points and move them at the same time. Give your students time to practice altering a curve by dragging the Bezier curve control arms.

Creating a custom shape

Many things covered in Lesson 4 lead up to this final exercise. We’ve intentionally kept the shape simple (no curves) but feel free to encourage your students to push their newfound skills.

For those having difficulty, we’ve hidden and locked a copy of the custom shape, which they can use as a tracing guide, by revealing the shape in the Layers panel.

Questions

The following questions are not in the student’s Classroom in a Book.

1. How do you create a curved path?
2. What tool is used to edit vector control points?
3. How do you fill a vector shape with a pattern?
4. How do you add additional control points to an existing path?
5. How do you remove extra control points from a path?
6. Other than the Tools panel, where else can you find more vector shapes to use?

Answers

1. You create a curved path by first selecting the Pen tool. Then click and drag an existing control point in a vector shape to pull out the Bezier curve control arms. After a curve has been created, you can further edit it by dragging the control arms or the control point with the Subselection tool.

2. The Subselection tool can be used to move existing control points of a path, or alter the curve of a curved path segment.
3. To fill a vector shape with a pattern, select the shape with the Pointer tool, and then choose Pattern from the Fill Category and select pattern.

4. To add more control points to a path, select the Pen tool, and then click on the path where you want to add a new control point.

5. You can remove a path by hovering the Pen tool over an existing control point. When you see the (-) sign beside the Pen tool cursor, click to remove the point.

6. You can find additional Auto Shapes in the Shapes panel. If you do not see the Shapes panel, select Window > Shapes.

Lesson 5: The Layers Panel

Layers are probably the most important workflow and design tool you have in Fireworks. Simply put, they add structure to your document.

Throughout this lesson, emphasize the importance of naming layers, sublayers and objects as the students work in Fireworks. It’s tempting to just zoom ahead with a design, but if the habit of naming elements can be made early, they—and their associates—will save time down the road, because it will be easier to find what they are looking for in a complex document.

Goals for this lesson

In this lesson, they will learn how to do the following:

- Create new layers
- Create sublayers
- Change the stacking order of layers
- Rename layers
- Protect layers and objects
- Access Layer options

Using the Layers panel

Unlike Photoshop, Fireworks is an object-based application. This means that each layer can contain one or more independent objects, as well as sublayers. Objects can be text, bitmaps, vectors, groups or symbols.

Point out that Layer hierarchy (layers and sublayers) can help from an organizational point of view, but the primary existence of sublayers (at this time, anyway) is to maintain integration with Photoshop and its layer groups capabilities.

A layer containing one or more sublayers becomes a Layer group when the design is saved in Fireworks or as a Photoshop file. Likewise, if a student opens a
Photoshop file that contains layer groups, Fireworks will recognize and maintain this structure using layers and sublayers.

**Rearranging objects within a layer**

Point out how easy it is to drag and drop a selected object from one layer into another.

**Moving objects from one layer to another**

Point out how easy it is to drag and drop a selected object from one layer into another, using the radio button on the right side of each layer name.

When this button is dragged from one layer to another, only the selected objects in the original layer are moved.

**Creating sublayers**

Sublayers are helpful from a structural point of view and for integration with Photoshop’s layer group feature, but they are also limited in many ways. The limits of sublayers are discussed in a sidebar in Lesson 11, so you might want to read ahead a little. Forewarned is forearmed.

While not part of this lesson, you may want to build a simple design using both layers and sublayers ahead of time, and show students briefly how the layer structure appears if the design was saved as a Photoshop file, and then opened in Photoshop.

**Questions**

The following questions are not in the student’s Classroom in a Book.

1. What is the importance of sublayers?
2. How do you protect a layer or an object from accidental editing?
3. Why is it important to name your layers and objects?
4. How do you create a sublayer?
5. How do you rename layers, sublayers or objects?

**Answers**

1. Sublayers help you add structure to your document, allowing you to group related objects within an existing layer. If a Photoshop design is opened within Fireworks, and it contains layer groups, Fireworks maintains this relationship using layers and sublayers.

2. You can protect all the objects in a layer by locking the layer (empty square next to Layer name). You can also protect individual objects in a layer (rather than all the objects in the layer) by locking them independently. Locking a layer will protect all objects, regardless of the lock status of individual objects.
3. Naming Layers can help other members of your design team, because things are easier to locate when they are named. It can help you as well, by aiding you to logically structure the Layers and when you need to locate a specific object on a specific layer.

4. You create a sublayer by first selecting the layer you want to contain the sublayer. Then choose New Sublayer from the bottom of the Layers panel or by right-clicking (Windows) or Control-clicking (Mac) the main layer and choosing New Sublayer from the context menu.

5. You can rename any layer, sublayer or object by double-clicking on the default name (Layer 1, for example).

Lesson 6: Masking

This is where your students really start to work! Lessons 1 – 6 cover the basics of working in Fireworks, but in this lesson they will be building a banner ad practically from scratch and making use of one of Fireworks’ star features: masking. Depending on your group’s skill/comfort level, you might consider breaking this up into two classes.

Students will be importing graphics, working with both vector and bitmap masks, adding some text and learning nifty tricks such as how to paste the attributes of one object onto another object.

There’s even an extra credit assignment. Students get some practice with the Polygon lasso tool to create a selection, which then gets converted to a path. If you feel they need more practice with the Pen tool, this exercise can be easily adapted to working with the Pen tool instead.

Goals for this lesson

In this lesson, they will learn how to do the following:

• Create a bitmap mask from a selection
• Edit a bitmap mask using the Brush tool
• Create a vector mask from a custom vector shape
• Edit the vector mask and change its properties using the Property Inspector
• Use the Auto Vector Mask command

Bitmap masks and vector masks – what’s the difference?

We’ve spent a fair amount of time up front discussing the two main types of masks you can create in Fireworks. You might want to have students try out some simple masking exercises of your own creation before jumping into the main lesson in the book.
While not discussed in this lesson, you can also mask one bitmap object with another, which can create interesting texture and effects. Read through the Help files to learn more about masking one bitmap with another.

**Editing gradient direction and angle**

Gradient fills are a very popular web design element, as well as a visual design element. Extra practice with manipulating gradients is a good idea and using gradients comes up in several lessons.

**Importing assets**

Point out this commonly used technique to save the user a great deal of time. No need to copy and paste, or drag and drop images into a design when you use the Import command.

**Using the Auto Vector mask for quick fades**

If your users have worked in earlier versions of Fireworks, point out that the Auto Vector Mask command was previously named the Fade Image Command. It can be applied to both bitmaps and other vector objects.

**Importing Photoshop images**

The Photoshop files used in this lesson are simple, flat bitmaps, but this does give you the opportunity to go over the Photoshop Import dialog box. At the end of the lesson, you may want to show them how to customize the Photoshop import options using the Preferences panel.

**Creating a vector mask**

The vector mask created in this exercise is a simple one, but point out that custom vector shapes can also be used as masks.

**Converting a bitmap selection to a mask**

The other main type of mask you can create is a bitmap mask. These are similar to Layer masks in Photoshop. Point out you can use any of the bitmap selection tools—or combinations of those tools—to create the selection. It can be easier at times to create a mask using selections, especially if you have an image with a strongly contrasting background. The Magic wand can quickly select the background, and then the selection can be inverted and the mask applied.
Editing a bitmap mask

For those not comfortable with the vector tools (we recommend practice, of course), editing a bitmap mask may be less intimidating because it uses the Brush tool. Paint with white to reveal the image or paint with black to hide the image.

Extra credit: Creating a silhouette vector shape from a bitmap image

The main lesson gives the student a silhouette image to use, but for those who want to know how it was done, this extra credit exercise should help. This exercise has the students use the polygon lasso to create a bitmap selection, which is then converted to an editable path, filled with black.

Final touches

This section covers a variety to exercises to wrap up the design. A good deal of work is done with text, as can be seen from the list below. Point out that on completion, students will have applied many of the core skills they have learned in previous lessons and have built the entire design from the ground up.

- Adding text
- Adding the cast names
- Styling the text
- Creating and applying a custom style
- Styling the first names
- Tweaking the background
- Image positioning

Questions

The following questions are not in the student’s Classroom in a Book.

1. How do you edit a bitmap mask?
2. How do you apply a gradient to a vector shape?
3. How do you edit the colors of a gradient?
4. How do you reposition an object within a mask?
5. How do you convert a bitmap selection to a path?
Answers

1. You edit a bitmap mask using the Brush tool. All the attributes of the Brush tool are available, such as size, stroke category, edge softness, and opacity. Choose black to add to the mask (hiding the object) or white to remove the mask (revealing the object).

2. Select the vector shape and then choose your gradient type from the Fill category.

3. Select the vector that has the gradient fill. Then click on the color swatch in the Property inspector. This launches the gradient editor. You can pick from several color presets, or click on the existing color swatches to open the color picker. You can add additional colors to the gradient by clicking underneath the color ramp.

4. Make sure the object being masked is active. Using the Pointer tool, drag the blue control handle on the canvas to reposition the image within the mask.

5. Once the selection has been created, choose Select > Convert Marquee to Path. The bitmap selection is discarded and replaced with a vector shape.

Lesson 7: Working with Text

This lesson builds on the basic text skills students have been gaining up until now and covers more advanced typography features, as well as some brand-new features such as wrapping text within a path.

Adobe Fireworks CS4 marks the introduction of the Adobe Type Engine. Now Photoshop, Illustrator and Fireworks all use the same text renderer. There are issues, however, with this new integration, especially when opening files created in earlier versions of Fireworks. At this writing, a patch to fix the text problems has been promised by Adobe, so please check with your IT department to keep an eye out for it and to install it as soon as possible. Fireworks engineer Sarthak Singhal’s blog http://blogs.adobe.com/sarthak/will keep you updated on the progress of the patch and give you many other helpful tips on working with Fireworks.

Goals for this lesson

In this lesson, they will learn how to do the following:

- Create both fixed-width and auto-sizing text blocks
- Edit the text properties
- Use Commands to alter text
- Use the transform tools to scale, rotate and distort text
About text

This section, along with Creating a fixed width text box and Editing text give a basic but thorough introduction to adding text to a Fireworks document. Point out to students how you can easily select a text block with the Pointer tool to reposition it, or jump into text edit mode just by double-clicking on the text itself with the Pointer tool.

Flowing text within a vector shape

New to Fireworks CS4 is the ability to attach text in a path. Text can be flowed into any closed vector path—with the exception of composite paths. Point out that this can be a useful visual design technique, and can also be used to mimic how text would wrap around a floated graphic on a web page.

Typography terms (sidebar)

Fireworks has some pretty advanced text attributes to help designers make the most of text in a design. The terms in this sidebar all relate to the attributes available within the Property inspector when the text tool is active.

Anti-aliasing text

The introduction of the Adobe type engine has also had an effect on the Anti-aliasing features of Fireworks. Demonstrate to students how the different anti-aliasing settings can affect the display of text on screen and how, for example, small font sizes are more readable when anti-aliasing is turned off.

Skewing text

Text can be scaled, distorted and even skewed while still remaining editable.

While not covered in this lesson, you can also point out that text can be converted to regular vector paths if the user needs to do special work on the text, or if the file is being passed to someone who does not own the fonts used in the design.

Using text as a mask

Point out that text can mask another vector or even a bitmap image and, as always, the text remains editable. You can combine various techniques such as attaching text to a path and then using it as a mask over a photograph, or adding Live Filters to masked text.
Also point out that at times it may be easier to use the Text menu to make alterations to text. This can be the case when you have combined multiple effects such as masking and attaching text to a path.

Questions

The following questions are not in the student’s Classroom in a Book.

1. What is one method to apply text as a mask?
2. How do you skew or distort text without converting it to paths?
3. What is the best anti-aliasing setting for small type (10 point or below) and why?
4. Where do you find commands such as Lorem Ipsum or Case Uppercase?

Answers

1. Select the text block and cut it. Select the object you want to mask and choose Edit > Paste as Mask.
2. Select the text block and then choose the Skew or Distort tool from the Tools panel. These tools are grouped with the Scale tool. Drag the control handles which appear around the text block to transform the text block.
3. For text 10 points or smaller, the No Anti-alias setting should be used. This makes small text more readable. Anti-alias blurs or blends the text edge with the background color, and this can make the text hard to read with small font sizes.
4. A variety of text commands can be found in the Commands > Text menu.

Lesson 8: Optimizing for the Web

In Lessons 2, 3 and 4, students learned the basics for working with graphics in Fireworks. In this lesson they will apply those skills to creating assets for Web pages and Web page creation itself.

Goals for this lesson

In this lesson, they will learn how to do the following:

* Export a single image to a web-ready format
* Determine the optimal web format for a sliced graphic
* Use the Optimize panel and Preview views to optimize images for web use
* Use the slice tool to slice up graphics in a web page mockup
* Use the slice tool to create a rollover effect
* Use the Hotspot tool to create interactivity
• Preview a web page design in a Web browser
• Export a interactive mockup of a website
• Export a single page as a standards-based CSS and HTML web page

**Image optimization**

This is a very important topic when it comes to the web. It can be easy to forget that not everyone has a high-speed Internet connection, but as professionals, web designers should take into account that people can be viewing a website with a wide variety of technology and at different bandwidths. The first few sections of this lesson cover image optimization in detail, starting with why it’s important, then leading into the different web graphic formats.

**Why optimize images?**

This section and the one following (Web graphic formats) explain why optimizing graphics is so important for websites and discusses in detail the different formats available for use on the web.

We recommend that you again reinforce the difference between Fireworks PNG files and standard, flat PNG files. It’s very important that students understand that Fireworks PNG files should not be part of a final web page design. A discussion of the differences between saving files in Fireworks and exporting them is also a good idea.

**About the Optimize panel**

Point out that like many aspects of Fireworks, the Optimize panel works in conjunction with several other elements of the interface: the preview buttons, the Property inspector and slices.

While not covered in the lesson, take the time to demonstrate other methods of optimizing and exporting files such as the Image Preview command and the Export Wizard. If the students are new to Web design and image optimization, the Export Wizard can be a helpful tool in the beginning.

**Optimizing a single file**

Several sections are dedicated to this exercise—working with previews, choosing optimization settings and exporting the file, building a foundation and explaining a workflow—which students can follow when optimizing single images or a series of image slices.

**Fireworks web tools and slicing**

This is the first real introduction to the web objects in Fireworks. Begin by explaining what slices and hotspots are, and how they are different from each other.
Getting comfortable with slicing a design is an integral part of using Fireworks as a Web design tool. We recommend you keep things simple and only work with rectangular slices. Polygonal slices add an extra level of complexity to a web page because a single polygonal slice becomes several smaller rectangular images, linked together with hotspots in the HTML code. Not a lot of fun for the novice, if they have to edit code.

**Optimizing a sliced image**

This is a short section, essentially telling the students what to do, but we recommend you walk your students in sections through the same previewing process as outlined earlier, beginning with Optimizing a single file. We can’t emphasize enough the importance of becoming proficient with image optimization or its importance to a website.

**Optimizing illustrations**

This section tackles the process of choosing the right file format for non-photographic images. You may be tempted to fall back on the GIF format for this type of image, but in many cases (not all) PNG 8 actually produces a smaller file.

**Creating hotspots**

Hotspots are the other web object available in Fireworks. Unlike slices, hotspots are only suitable for interactivity; they cannot be used to cut up a design into smaller images. But they are powerful nonetheless. Take some time to discuss the strengths of hotspots. You may want to read ahead to lessons 10, 11 and 13, where both Web objects get a real workout, so you can present some examples of advanced interactivity, such as mocking up an Ajax data table or pop-up window.

**Adding interactivity**

This exercise introduces students to the concept of rollover images and how to create them; it’s a bit of foreshadowing of what’s to come in Lesson 11. While the exercise only walks them through the process of creating a single rollover, feel free to expand on this and have them create rollover effects for the other two subheading images in the page design. This will also give them a chance to experiment more with Live Filters.

Caution students on using filters which increase the dimensions of an image; this could become problematic in the final web layout due to size differences. If they want to add an outer glow or drop shadow in the second state, this is a good time to explain that the slice needs to be sized based on the effect used on the rollover image, not the original image in the first state.
Exporting HTML and images

Fireworks has two main workflows for converting designs into web pages: Export as HTML and Images, or Export CSS and Images. The first of these two export workflows has been around since Fireworks began and produces a rigid table-based layout, where everything in the web page (including text) is turned into graphics. While it’s not a good practice to use this option for a real website, it definitely has its advantages when creating interactive prototypes because it is quick and easy.

It’s important to stress that students should never use the HTML and Images export for a final website, and there are many reasons for this: accessibility, search engine indexing, text-based browsers and site maintenance, to name a few.

Exporting states

The export process does have a few kinks in the workflow; a design with multiple states (one with rollover effects for example) is one of them. As soon as you add extra states to a design, Fireworks will export images for the entire design on all states, even when there is no image information. This section describes a workaround that will avoid the creation of multiple unnecessary image files.

Exporting CSS and images

This is the first time true CSS export has been done natively within Fireworks. The Export engine is based on John Wylie’s Smart CSS export, which was available as a plug-in for Fireworks CS3.

The goal behind CSS and Images export is to produce a web page right from Fireworks that meets standards compliance for HTML and CSS. The resulting HTML and CSS documents can be edited within Dreamweaver or any other web editing software.

At this time, you can only export 1 page of your design at a time. The reason behind this is that most web pages in a site have a similar layout, so you would first export the one page that represents your main site. Then you design, edit and tweak within Dreamweaver, and generate new pages within the HTML editor rather than Fireworks.

Point out that states and behaviors are ignored during the export. These features would have to be added back in when you are editing the web page itself.

It’s a good idea to read the following articles ahead of time and make them available to your students.

http://www.adobe.com/devnet/fireworks/articles/export_css_images.html
http://www.adobe.com/devnet/fireworks/articles/standards_compliant_design.html
Questions

The following questions are not in the student's Classroom in a Book.

1. Why are images sliced?
2. What does the Optimize panel do and how do you access it?
3. What options do you have for previewing your optimize settings within Fireworks?
4. What is the best format for optimizing photographs?
5. What are the differences between PNG 8 and GIF?

Answers

1. Generally, images are sliced in order to break up a larger design into smaller, more manageable graphics. Traditionally, these graphics were added to a table-based layout to “rebuild” the design in an HTML page. The common practice now is to slice a design so that only the necessary graphics are exported and those images are used as either foreground or background images within a CSS-based layout.

2. The Optimize panel gives you complete control over the export format and for a selected slice, or over global formatting options for any areas in the design that are not sliced. To access the Optimize panel, select Window > Optimize or press the F6 key.

3. You have three preview options built into the Fireworks interface: Preview (single view), 2-Up (two customizable views), and 4-Up (four customizable views for comparing optimization settings).

4. The best export format for a photograph is JPEG, because it supports photo-realistic (24-bit) color. You can balance the amount of quality loss against the file size when using JPEG as the export format by dragging the quality slider.

5. You can create animated graphics with GIF and set one color (usually the background color) as transparent. PNG-8 does not offer animation, but it does offer a wider range of transparency options and often compresses simple images better than GIF.
Lesson 9: Using Symbols

Symbols are one of the great timesaving features in Fireworks. They’ve been around since the first release of the application. Point out that symbols can contain multiple objects within a single asset and still give you quick access to editing those objects. Symbols can contain text, vectors, and bitmaps, each with their own Live Filter attributes.

As well as being an option for reusing common graphical elements in a design—like a logo, or a button—symbols can also be exported and shared with others.

Goals for this lesson

In this lesson, they will learn how to do the following:

- Create a graphic symbol
- Create an animation symbol
- Create a button symbol
- Edit a graphic symbol
- Edit an animation symbol
- Edit a button symbol
- Save a symbol to the Common Library

What are symbols?

It’s important for students to know that a symbol is really made up of two parts: the symbol itself and the instance on the canvas. If you want to make global changes to all the instances in a design (the color of a button, for example), you need to do this by editing the symbol itself.

Point out that they also have some editing control over individual instances: size, opacity, blending modes and Live Filters can be added directly to individual instances without affecting the original symbol.

There are three main types of symbols, plus an enhanced graphic symbol called a Component symbol. Component symbols have JavaScript functionality built into them and are usually edited with the Symbol Properties panel. As this is a fairly advanced type of symbol, it is not covered in this book. Students will learn how to create each of the three main symbol types.

Lastly, you’re switching visual gears in this lesson, taking a break from the Double Identity assets and working with something completely unrelated.
Graphic symbols

The lesson starts off with converting an existing graphic to a graphic symbol. This is the simplest of all the symbols to work with, but can be very useful. As an example, point out the Common Library to your students. There are several folders (web and applications folder is a favorite of ours) full of graphic symbols, and while your students may be starting off simple, it’s easy to see that graphic symbols can become quite robust.

We recommend pointing out the shortcut key for creating symbols, which is F8.

The Common Library

Point out that the Common Library lets users share symbols across multiple documents in Fireworks. You can add a symbol to the Common Library at the time it is created, but this also removes the artwork from the canvas. A symbol can be added to the Common Library at any time, by selecting it in the Document Library and choosing Save to Common Library from the panel options.

Editing symbols

New in Fireworks CS4 is the ability to edit symbols in-place, as you would in Adobe Flash. Double-clicking on an instance will fade all other elements on the canvas, making the symbol the only editable element on screen. A bread crumb trail appears at the top of the document window, making it easy to navigate back to the main design.

Demonstrate that you can also edit symbols in Isolation Mode by right-clicking (Windows) or Control-click (Mac) the instance and choosing Symbol > Edit Symbol. This editing mode hides all other objects on the canvas and may be helpful if you have a complicated design.

Button symbols

Button symbols take a little more planning than a simple graphic symbol. This can be a good place to talk a bit about site planning and best practices, because button symbols are most useful if they have text labels. It’s important to know what the site architecture will be so that you can plan your button dimensions based on the longest string of text.

The button symbol is designed to export up to four different graphics for each button (up, over, down, over while down). Unlike graphic or animation symbols, Fireworks automatically slices button symbols, because it’s assumed the user will want to create a rollover effect.
While Fireworks can’t directly create CSS-based button rollover effects, you may want to make your students aware of the growing popularity of this technique, and demonstrate how Fireworks can fit into this workflow by creating the background image for the CSS button.

**Editing a button symbol**

Button symbols have special properties that can be accessed after double-clicking on the button instance. While in symbol editing mode, you can also add up to three more states and determine whether you want Fireworks to handle slicing automatically or leave the slicing up to you. Point out that in order to add additional states, make sure nothing is selected on the canvas. Then you will be able to add more button states from the Property inspector.

**Testing the button symbol**

Point out that the Preview options in Fireworks are not just for checking optimization settings; you can test out state-based interactivity as well. Mousing over button symbols will show rollover effects and if there are any on-click events applied, they too will work, so long as it’s just a state change. Preview mode will not let you move to a different page in the design.

Point out that if they want to test hyperlinks, they can choose File > Preview in Browser > Preview all pages in (default browser).

Point out that they will get a more realistic experience if they hide slices and hotspots while in preview.

**Animation symbols**

This exercise exposes the user to the States panel and the basic concept of frame-based animation, including onion-skinning and state delay. Point out that Fireworks animation capabilities are limited to what GIF animation can achieve. Complex animation should be done in a program such as Adobe Flash.

Also point out that because animations require several frames, it may be best to create the animation on a separate page, so that Fireworks does not export out multiple files for the rest of the design.

**Altering animation settings**

While not covered in the exercise, point out that several elements of the animation symbol can be added or altered in the Property inspector. You can change the number of states in the animation, alter opacity, size, and even rotation, after the symbol has been created.
Adding pre-built symbols from the Common Library

To wrap up the design, students will create a mockup of a search field. While there are HTML components in the Common Library for adding text fields, we went with just a simple white rectangle, and focused on dropping in a pre-built symbol for the magnifying glass. If you feel your students are up to the challenge and you want them to get a better handle on Component symbols, feel free to have them drag in a text field from the HTML folder of the Common Library.

Questions

The following questions are not in the student’s Classroom in a Book.

1. What is a symbol?
2. How do you edit a graphic symbol?
3. How do you add a symbol to the Common Library?
4. What is Onion skinning?
5. How do you change the state-delay of an animation state?

Answers

1. Symbols are reusable graphic elements. Fireworks has three types of symbols: graphic, animation, and button. When you edit the original symbol object, the copied instances automatically change to reflect the edited symbol (unless you break the link between the two).

   Symbols are also helpful for creating buttons and animating objects across multiple states.

2. You edit a graphic symbol by double-clicking on the instance on the canvas, or by selecting the instance and then choosing Modify > Symbol > Edit Symbol (isolation mode) or Modify > Symbol > Edit in Place.

3. To add a symbol to the Common Library, select the symbol within the Document Library and choose Save to Common Library from the panel options.

4. Onion skinning is a technique for viewing the contents of states before and after the selected state. When you turn on onion skinning, objects in the preceding and subsequent states are dimmed so that you can distinguish them from objects in the current state. By default, Multi-State Editing is enabled so that you can select and edit dimmed objects in other states without leaving the current state. Use the Select Behind tool to select objects in states in sequential order.

   You can adjust the number of states visible before and after the current one by clicking the Onion Skinning marker to set a range or by clicking the Onion Skinning button and selecting a display option.
5. You change the State delay of a frame by double-clicking the current delay value in the state delay column. You can change the delay of multiple frames by shift-clicking to select a continuous range or control-clicking to select discontinuous states, then double-clicking on any of the delay values.

Lesson 10: Prototyping Basics

Fireworks is not just a graphic design tool for screen images. It has workflows to expedite a variety of professional production needs, from web page design to application interfaces, from rough concepts to fully detailed and interactive design comps. This is an important distinction for Fireworks.

It’s time to demonstrate and emphasize to students this feature set. In this lesson, emphasis is placed on working with the pages panel, shared graphic layers and shared interactive layers. The result at the end is an interactive PDF file that can be e-mailed to a client for review and feedback.

Goals for this lesson

In this lesson, they will learn how to do the following:

- Create a multi-page mockup
- Share layers to multiple pages
- Use the Hotspot tool to create interactivity between pages
- Preview a mockup design in a Web browser
- Export a secure, interactive PDF file

Pages panel

Point out that for prototyping, the Pages panel is extremely important, allowing you to keep an entire design concept within a single file. This makes linking to separate pages very easy, which expedites the process of creating an interactive prototype. The pages panel is where you create new or duplicate pages, and designate a master page.

Master page

Take some time to go over the uses of the master page and its limitations. While not covered in the lesson, you can also demonstrate how to unlink a page from the master page. Each Fireworks file can only contain one master page.
Pages

The generic term *pages* has been used throughout the book, but students may also hear the terms *child pages* when discussing pages that are linked to a master page. Pages linked to a master page take on the same dimensions and canvas, color, and optimization settings as the master page, as well as sharing (by default) the graphic elements from the master page.

Linking to a master page and sharing the master page layer on child pages are mutually exclusive options as well, although that may not be immediately obvious.

By default, if you have a master page, new pages will always have the master page layer added to them on creation.

However, pages do not have to share the master page layer—indeed, individual pages do not have to have anything in common with a master page. This can be quite useful when creating multiple design concepts in one file. Show how to remove the master page layer by choosing Remove Master Page layer from the Layers panel options menu. You can also use the options menu to add the master page layer back into a page.

Creating a multipage mockup

Up until this point in the lesson, students have been manipulating a nearly final mockup. Now you will have them open a less complete version of the file and they will get lots of practice creating new pages as well as setting up a master page.

Sharing layers to pages

This workflow can save the user a lot of time when working on a design, and is not as limiting as a master page can be. Point out that sharing a layer to pages means you can be selective about which pages display the content from the shared layer. This is unlike a master page, where all the layers on a master page are either applied to the page or removed.

This can come in handy if the user wants to include contextual navigation on certain pages, but not on all the pages, in the design. It can also be helpful if you are working with different page dimensions. You could have a footer layer that displays footer information at approximately 400 pixels from the top of the page for shorter pages, and another footer layer that displays the footer info at 900 pixels from the top. Short pages share one layer, long pages share the other.

Adding interactivity

A mockup without interactivity is just a storyboard, no matter how finished it appears. Point out that adding interactivity using a design tool can be a real time-saver. No coding is required, so building the mockup and editing it based on client feedback is quick and easy.
As you build your interactive objects (hotspots, in this lesson), point out that the links in the URL bar of the Property inspector are divided between session history (above the divider) and true links (below the divider). Only the links below the divider will generate functional links, even if there is a matching page name in the history section.

Point out also that PDFs only support rectangular web objects (slice or hotspot). In the case of this file, slices are not even used because individual slice optimization settings would be ignored on the export file.

**Sharing interactive objects**

Point out that sharing web layers to pages has the same advantages as sharing graphic layers, but there is an extra step the user has to perform in order to share a web layer. The creation of a web sublayer is required because the main web layer itself cannot be shared to other pages. Once a web layer is shared, changing the position, size or URL of a hotspot or slice will be reflected on pages sharing the web sublayer.

**Testing the links**

Emphasize the importance of testing interactive elements. Rollovers and state changes can be previewed in the Preview mode, but page linking must be tested by previewing all the pages within a web browser.

Depending on the previous export settings, students may find that their temporary web pages are graphically incomplete. If this occurs, the only workaround is to first export the design as HTML and Images, making sure that Include areas without slices is selected and that Current page is deselected.

The next time they attempt a preview, things should work properly.

While not covered specifically in the lesson, it may be a good idea for students to set their base page optimization settings to JPEG – Better Quality before previewing the work. This can make text a little fuzzy, but on average, it will give better graphical display.

**Emulating state changes**

As mentioned at the beginning, the end goal for this lesson is to produce an interactive PDF. PDF files do not support states or rollover effects, so in order to mimic a change in the stare of the mockup, additional pages—rather than states—are used.

**More hotspots!**

Here you take advantage of the invisibility of hotspots to give the user some control over a few of the buttons on the phone.
Creating a secure, interactive PDF

The steps for exporting an interactive PDF are outlined here. It would be good to have Acrobat Professional installed on the systems your students use, so they can enable commenting for Adobe Reader (this is something that Fireworks is not capable of doing) and test out the password protection for certain tasks.

Questions

The following questions are not in the student’s Classroom in a Book.

1. When you link a page to the master page, what is the result?
2. What elements might be best left out of a master page?
3. What security options are available when creating a secure PDF from Fireworks?
4. Why would you share a layer to other pages in a design?
5. What web objects can be used when creating interactivity for a PDF file?

Answers

1. The linked page takes on the canvas color and dimensions of the Master Page. The master page’s base optimization setting is also applied.

2. Because pages can change in dimension, it is best to only include objects on the master page that can remain in the same physical location on every page. This usually means that elements such as the footer are excluded from the master page.

3. You can set PDF security for file opening and for performing tasks. One password is used to open the file and another is used to enable the following tasks: printing, editing, copying and commenting. If no passwords are set, all tasks listed are available.

4. If you have content that needs to be on some but not all pages in your mockup, you can use Share Layer to Pages to specify to which pages the content should be shared. Updates to the shared layer can be made on any page sharing the layer and these updates will propagate across those pages.

5. The only web objects supported by PDF are rectangular slices or hotspots. Because PDFs do not support rollovers or state changes, it’s safe to use just the rectangular hotspot tool. The exception to this would be if the design is also intended to become a web page mockup, where slicing would be needed for optimization and visual interactivity.
Lesson 11: Advanced Prototyping

This lesson uses new assets and builds upon the concepts learned so far regarding slices, hotspots, states, and sharing layers to pages. In this chapter, they’ll take a closer look at creating effects such as rollovers and emulating pop-up windows (including two ways to create the pop-up window effect).

While much can be done, it is important to remind students that Fireworks is an excellent graphics editor; however, it is not designed to be, nor should you expect it to be, an HTML web page editor or website creation tool.

Goals for this lesson

In this lesson, they will learn how to do the following:

• Create a multi-page website mockup
• Use the Slice tool to slice up graphics in a web page mockup
• Use the Slice tool to create a rollover effect
• Use the Hotspot tool to trigger a disjointed rollover (pop-up window)
• Simulate a Spry data table (disjointed rollovers)
• Preview an interactive web page design in a web browser
• Export an interactive mockup of a website

Prototype orientation

A little repetition never hurt anyone, especially when they are learning something new. The opening exercises in Lesson 11 follow a similar format to Lesson 10: the student gets to explore a completed version of a website prototype. The lesson also shows them what their goals are and how the various elements should work when their version is completed.

Fleshing out the prototype

Having students build the entire prototype from scratch would be a pretty hefty endeavor for a single lesson, so the students will start with a working file that has many assets already added. In this second series of exercises, they will be creating the master page, adding additional pages, slicing the banner area, and adding hotspots for navigation.

Creating rollover effects

After the basic structure has been completed, they move on to creating rollover effects, using slices, states and shared layers. Emphasize the importance of naming slices and recommend options for some standard naming conventions.
Students will have a chance to work with Live Filters again in these exercises, so point out that the various creative features of Fireworks can come into play at any-time during prototype development; they aren’t limited to just the design phase.

While not mentioned in the exercise on creating a new state, take some time to remind them that they can rename states just as easily as they can name objects or layers. And if a great deal of interactivity is required, naming the states that represent that different activity is a good idea. For example, instead of State 1 and State 2, these states could be named Up and Over to represent the different rollover states that are being created.

**Adding rollover behaviors**

This will be their first exposure to Fireworks behaviors, which are prebuilt JavaScript actions, so take some time to introduce the concept, explain what behaviors are and how to take advantage of them. The great thing about Behaviors is that no coding or knowledge of JavaScript is required.

**Emulating pop-up windows**

These two exercises are excellent real-world examples of how a Fireworks prototype can aid the web designer and the client in visualizing the final website.

With the advent of Ajax and Adobe’s Spry framework, dynamic interactivity on a web page is becoming more popular and easier to achieve than ever before. Take some time to discuss Ajax and display some examples of the technology. This will help students see the relevance/connection when they simulate this type of dynamic behavior within Fireworks.

**Simulating a Spry data table**

This exercise is more complex than the pop-up window exercise and not only requires the use of additional states and behaviors, but introduces learners to the Behaviors panel, where they can easily edit various attributes of preset behavior. For example, by default the Swap Image behavior is triggered when the user’s mouse rolls over the hot area. In this exercise, the goal is to swap the image only when the user clicks the hot area. This change is easily made using the Behaviors panel.

Take some time to explain the various JavaScript events and explore the Behaviors panel in more depth. Point out that with a bit of practice, their mockups can become quite interactive, mimicking (short of animation) features such as Spry accordion panels, tab panels, even photo galleries. Utilizing this type of interactivity definitely takes a mockup beyond the basic stage into a more robust and functional prototype. A client can truly get a “feel” for how the final website will look and behave.
Completing the prototype

This final section walks them through two more exercises: importing a couple of prebuilt designs to complete the empty video and fashion pages created much earlier in the design, and exporting the prototype. While placed at the end of the lesson, there is no reason for you not to introduce this page imports earlier, if you desire. Point out that in this case, they aren’t just importing a single graphic, they are importing an entire layered PNG file. Once imported, have them expand the layers panel to see that the layers from the original PNG file have been maintained.

Exporting the prototype

The export workflow used for the prototype is HTML and Images. As mentioned in the book, this produces a series of very rigid, table-based HTML pages. While this end result is fine for prototyping purposes, be sure to stress that this export option is not recommended for a final production website. There are several reasons for this:

• Table-based layouts are no longer considered best practices.
• Multiple unnecessary images are exported in order to allow the table to display the design. Many images are exact copies of each other, created from the other pages in the design.
• All elements in the design are converted to graphics, including text.
• Editing the resulting HTML can be problematic; for example, deleting a graphic slice to replace it with true HTML text can break the entire layout.
• We recommend you run through this workflow yourself before presenting it to the class, to help you anticipate any potential questions.

Questions

The following questions are not in the student’s Classroom in a Book.

1. What are the benefits and limitations to using a master page?
2. How do you change a Swap Image behavior event from being triggered by a mouseover to a mouse click?
3. Should the HTML and Images export be used for a final production website? Why or why not?
4. How are sublayers helpful?
5. What are the current limitations to sublayers?
6. What steps are required to create a simple rollover effect?
Answers

1. Graphic elements common to the entire design can be kept on a master page. So if you need to update those graphics, the editing can be done on the master page and the changes will appear on all pages.

The main limitations to master pages are that you can only have a single master page per file, and that the elements on the master page will appear in the same physical location on all pages, regardless of an individual page’s dimensions.

2. Select the slice where the behavior has been applied and open the Behaviors panel. Choose the appropriate onMouseOver event (there may be more than one, depending on the interactivity applied to the slice) and click on the dropdown menu beside the event name. Select onClick to change the event.

3. HTML and Images export should not be used for a final production website for several reasons:
   - Table-based layouts are no longer considered best practices.
   - Multiple unnecessary images are exported in order to allow the table to display the design. Many images are exact copies of each other, created from the other pages in the design.
   - All elements in the design are converted to graphics, including text.
   - Editing the resulting HTML can be problematic; for example, deleting a graphic slice to replace it with true HTML text can break the entire layout.

4. Sublayers can be a useful tool for structuring a web page design within Fireworks. The Layer and Sublayer relationship is also maintained as Layer groups if the file is saved as a Photoshop file. Likewise, if a Photoshop file is opened within Fireworks, any Layer groups are maintained as a Layer/Sublayer hierarchy.

5. Sublayers do have limitations, at the moment. When you copy a layer that contains sublayers, only the parent layer elements are copied to the clipboard; sublayers are ignored.

If you copy a sublayer, only the objects within the sublayer are copied. So if you were to paste the clipboard contents into a new design, only the objects—and not the actual sublayer that contained them—would be pasted.

If you share a layer to other pages, all sublayers are automatically shared with that page as well. You cannot selectively share certain sublayers with different pages.

6. In order to create a simple rollover effect, you must have two states. Each state must have a graphic of the same size and in the same location. A slice needs to be drawn over the graphic on the first state. The behavior, Add Simple Rollover, must be applied using the behavior handle of the slice.
Lesson 12: Improving Your Workflow

This chapter is located on the companion disc as a PDF, along with accompanying lesson files.

Point out that finding ways to speed up common tasks without sacrificing quality is important to any business. The exercises in this lesson will expose students to a few ways in which they can use Fireworks to expedite their workflow.

Goals for this lesson

In this lesson, they will learn how to do the following:

- Use Bridge to help you locate files
- Use the Batch Process command
- Customize the Batch Process
- Add project information to a file
- Set the base optimization setting for multiple pages
- Add Photoshop Live effects
- Save as a Photoshop file

Getting Started in Adobe Bridge

Point out that Bridge can be a real nerve center for almost all work done with the Creative Suite. You can view files, sort files, stack them into groups, apply keywords and—as seen in the next exercise—launch other CS4 applications to run automated commands such as batch processing. It’s an application that the team used very often during the creation of this book.

For more information on Adobe Bridge, be sure to check out adobe.com.

Batch processing and customizing using Bridge and Fireworks

Batch processing is a very powerful tool in Fireworks. Bridge makes it even more powerful because the user can view files first, before selecting them for batch processing.

Take the time to point out the other automated Fireworks features which can be accessed through Bridge, such as Convert to Grayscale and Convert to Sepia Tone, both of which are applied using Fireworks Live Filters, so they remain completely editable.

While not discussed in the book, point out that running the Batch Processing wizard gives you access to any command available from the Fireworks command menu, including custom commands created by the user. As long as the command does not rely on selecting a specific object in a file, most commands will run successfully from the batch processing wizard.
Cropping individual bitmaps in a design

The ability to further crop a bitmap once it has been imported or pasted into an existing design is very useful, and this usefulness is demonstrated when the learner imports a series of images for a photo gallery, only to find that two of the images are a different dimension from the rest.

Exporting a specific area

Rather than the current design, the Export Area tool lets you drop a crop. And when you commit to the crop, you’re brought to the image preview window where you can save the cropped area as a flattened image that can be e-mailed to a client. As demonstrated in the lesson, this workflow can be helpful if you want a client to focus on a specific area of a design.

While not mentioned in this lesson, point out that users also have options to send an open design directly to e-mail, either as a Fireworks PNG file or a flattened JPEG file.

Future proofing your projects

The exercises in this part of the lesson focus on making your files as useful as possible to others (in terms of project information) and particularly those who prefer to work in Photoshop rather than Fireworks.

Lesson 13 takes this concept even further, with exercises for working with Flash, Flex and AIR.

Adding metadata

Point out that metadata can be added either through Bridge or through the File > File Info menu. At the very least, adding some keywords to each file worked on can greatly speed up searching for files at a later time.

Using Photoshop Live Effects

Photoshop Live Effects were present in Fireworks CS3 as well as the current CS4 version. Nothing has really changed in this area, but it’s worth pointing out that support for Photoshop Layer Styles (Live Effects in Fireworks) makes it easy to maintain certain effects when a PSD file is opened within Fireworks. Likewise, if it is known that an original Fireworks design is destined to be edited in Photoshop, using Photoshop Live Effects guarantees that those effects will remain editable within Photoshop.

The Live Effect used in the exercise — Stroke — is unique in that Fireworks has no native counterpart to it. Regular or masked bitmaps can have a stroke applied to them easily.
Saving as a Photoshop file and customizing Photoshop export options

Just as you can customize how a Photoshop file is imported or opened within Fireworks, you can also control the options for saving any design within Fireworks as a Photoshop file.

This is an important feature because Photoshop does not recognize the enhanced PNG format used by Fireworks. If a Fireworks PNG file is opened within Photoshop, the entire design is flattened into a single bitmap image.

Also point out that only solid color fills within vectors are maintained if you choose to retain the editability of vector objects. The only ways around this are to choose Maintain Fireworks Effects from the save options (this will rasterize all vector objects, including text), or by choosing custom and selecting Maintain appearance for vector category (text will not be rasterized, but all vectors will be converted to bitmaps).

Common blending modes and Live Filters

The charts in this section also highlight the integration between Photoshop and Fireworks. There is a fair amount of common ground between the two applications, and knowing what elements are supported in both can help a user maximize this compatibility.

Questions

The following questions are not in the student's Classroom in a Book.

1. How do you set the base optimization setting for multiple pages?
2. Where are Photoshop Live Effects located?
3. What is the equivalent to Photoshop Live Effects within Photoshop itself?
4. How do you convert a Fireworks design into a Photoshop file?
5. What are some of the limitations of converting a Fireworks PNG file to a Photoshop file?

Answers

1. You can set a common or base optimization by first selecting the pages in the Pages panel. Hold Shift to select a continuous series of pages or hold down the Ctrl (Windows) or Command (Mac) key to select specific pages not in sequence. Then choose the Export format from either the Property inspector or the Optimize panel.

2. Photoshop Live Effects are located in the Live Filters menu in the Property inspector.
3. Photoshop Live Effects are called Layer Styles in Photoshop. While these effects are maintained and can be activated from within Fireworks, the Layer Styles panel within Photoshop is much more robust, giving many more creative options.

4. Select File > Save As and choose Photoshop PSD (*.psd) from the Save copy as field.

5. Photoshop does not support multiple pages, so you must save a multi-page PNG file as a separate PSD file. Vectors containing gradient, texture or pattern fills will have the fill discarded when saved as a PSD file.

**Lesson 13: Going Further**

This chapter is located on the companion disc as a PDF, along with accompanying lesson files.

As the heading indicates, this supplemental lesson will take the learner beyond the basics. They will get a more rounded picture of how Fireworks fits into a variety of workflows: Fireworks to Dreamweaver, Fireworks to Flash, AIR and Flex.

**Goals for this lesson**

In this lesson, they will learn how to do the following:

- Use blending modes to correct images
- Apply AIR event commands to slices and hotspots
- Create an AIR prototype for client review
- Customize a Flex skin for use in an AIR application
- Use Fireworks and Dreamweaver together
- Create graphics for fixed and fluid web-page containers
- Work with native Fireworks PNG files in Flash

**Interaction review**

As in the previous two lessons, we encourage you to review the completed project so that students gain a sense of what they are aiming for, prior to building on the AIR prototype. After the review, students will build on a starting version of the prototype.

**Creative and corrective techniques**

Techniques for image correction and for working with vector strokes are demonstrated in this section.
Blending modes for image correction

Working with a combination of blending modes and Live Filters can improve the quality of an image in simple and non-destructive manner. Take some time to define Blending modes and show examples other than the one demonstrated in this book.

Important Note: This section contains a workflow error. The section on turning two blended images into a symbol will not work as described in the text. When you combine blended images into a symbol, the blending mode is removed. A new workflow, beginning with Step 10 in this exercise, has been posted as errata:


Working with AIR

Fireworks is not just for prototyping websites. This set of detailed exercises on building an AIR prototype discusses in brief what AIR is and shows how Fireworks can save the development team a lot of time, just as it can with website development.

Point out that the same type of interactivity available to a website prototype is also available when building and AIR prototypes, but with the added features of being able to drag, close, minimize and maximize the application prototype on the desktop, using graphic elements within the application itself.

Emphasize that Fireworks only creates a prototype; Firework cannot connect to databases or update anything within the prototype dynamically. All states of the prototype must be planned out and built graphically.

Students will build on the design they started with Lesson 13, adding virtually all the interactivity to make the prototype function.

Creating an AIR prototype

For a simple command, a lot happens when this menu option is chosen. Students will walk through all the settings for the Create AIR package dialog window. Point out that a great deal of the information in this dialog is required.

To minimize any errors when creating the digital signature, please make sure all computers have the latest version of AIR installed.

Point out that while not indicated in the dialog box, ALL fields must be filled out when users create their digital signature.

Installing the prototype

Installing an AIR prototype is a breeze if the package was created correctly. To add a sense of completion, though, we recommend you allow students to install their prototype, if possible.
You should test this process beforehand, logged onto a computer as a student; lab computers may not have the necessary rights to allow for the installation and you may have to talk with your tech support staff to see if any arrangements can be made. During installation, the user can choose where the prototype should be installed. We recommend the Lesson13 folder, so that the files can easily be deleted afterwards.

**Creating a Flex skin**

Before proceeding with this exercise, you should take a few minutes to explain to students what Flex is. The basic description from Adobe is as follows:

Adobe® Flex® is a cross platform, open source framework for creating rich Internet applications that run identically in all major browsers and operating systems, and now on the desktop with Adobe AIR™.

We recommend visiting the Flex Developer Center ahead of time (http://www.adobe.com/devnet/flex/) to locate a couple of examples to show the class. As this exercise indicates, the Nature console prototype could be coded into a true application using Flex.

Point out that from the designer’s perspective, they do not need to understand how to create applications in Flex, but in such a case, discussions with the Flex programmer are strongly recommended. A good rapport between designer and programmer creates a much smoother project flow.

For the purposes of this section in the lesson, students will see how the designer (and Fireworks) fit in with the development team, by bringing his or her visual skills to bear on the creation of assets for a Flex application.

In this section, students will learn how to customize the skin (the graphics) for a specific component (a button), how to add additional states to the button, and how to export the graphics so the programmer can incorporate them into the application.

**Fireworks and Dreamweaver**

Fireworks and Dreamweaver have shared a long history together. This series of exercises demonstrates to the students how this integration can improve their workflow.

Copying and pasting to Dreamweaver is pretty self-explanatory. You may want to point out that this functionality is also available for Photoshop and Dreamweaver, and that the same Image Preview window (a Fireworks feature) is used to allow the conversion and pasting of Photoshop files or layers into Dreamweaver.

Round trip editing with Dreamweaver is a feature that has been with Fireworks since the beginning and as such is useful only for Fireworks prototypes that have been
exported as HTML and Images. The workflow relies on the table-structure of the HTML document matching the layout of the Fireworks PNG file. As a result, this workflow cannot be used reliably if the user exports their design as CSS and Images.

The three-slice technique is a method for creating an expandable container for web page content. It’s a very common design element in a web page and typically the box has rounded corners.

This exercise has the students go through the process of creating the slices necessary for the container, but does not go into detail regarding how the slices are applied to a web page using CSS. You may want to prepare some assets ahead of time, so that the students can go from Fireworks to Dreamweaver. While the technique is a staple skill for a web designer, it is not considered a basic or introductory-level exercise.

**Fireworks and Flash**

With its robust bitmap and vector toolset, Fireworks can be a great starting point for designing graphics for a Flash animation or interface. Point out that a layered Fireworks PNG file can be imported into Flash, as well as flat files such as JPEG or GIF. Flash will maintain the layer hierarchy of a native Fireworks PNG file as well as a variety of effects, but some Fireworks features are not supported in Flash. The common effects and blending modes are listed in two separate tables in this lesson.

If the user needs to make edits to a native Fireworks PNG file that has been imported into Flash, they will have to return to Fireworks, edit and save the file, then **re-import** the PNG file into Flash. There is no round-trip workflow for a native Fireworks PNG file. While this may seem limiting, remind students that they have access to all the layers and objects directly within Flash. Fireworks vector objects, for example, remain completely editable with Flash.

However, round-trip editing is available when a flattened image file is imported into Fireworks. If that flattened file was created from a Fireworks PNG file, the user can edit the PNG directly in Fireworks, click done and both the PNG file and the flattened asset in Flash are updated.

**Questions**

The following questions are not in the student’s Classroom in a Book.

1. How does importing a multilayered Fireworks PNG into Flash differ from importing a flattened image?

2. How do you round trip edit a bitmap image from Flash to Fireworks?

3. When should you not use round trip editing between Dreamweaver and Fireworks?
4. When round trip editing from Flash or Dreamweaver, what is the best format to pick if available?

5. How do you ensure that the background of an AIR prototype does not display when running the prototype as an AIR application?

Answers

1. Importing a native Fireworks PNG file into Flash gives you the most control over the file. All layers and objects are retained as separate elements, vectors and text remain editable and some Fireworks effects can also altered while in Flash. Importing a flattened bitmap gives you the ability to round trip edit the bitmap using Fireworks. If the bitmap was created from a native PNG file, you can choose to open the PNG file in Fireworks for non-destructive editing of the file.

2. To launch round trip editing in Flash, right-click (Windows) or Control-click (Mac) the image in the Library panel and then choose Edit With Fireworks. The Find Source dialog box will appear and you will be asked if you want to edit this image directly, or locate a PNG file to make the edits. When you are finished editing in Fireworks, click the Done button to save the file and update it within Flash.

3. If you web page design is laid out using CSS rather than tables, round trip editing from Dreamweaver to Fireworks will produce undesirable results in the updated web page.

4. If available, choose the original native PNG file for round trip editing. This gives you the most non-destructive flexibility in editing the design.

5. In order to ensure a transparent background in your final functioning AIR prototype, make sure that the entire file is optimized as PNG 32. In the Create AIR package dialog box, make sure the Window option is set to transparent, and add 5 pixels to the height and width of the window to eliminate scroll bars.