INSTRUCTOR NOTES

Getting Started

The Adobe® After Effects® CS4 Classroom in a Book™ course presents students with tips, techniques, and solutions for using the Adobe After Effects CS4 software. The Instructor Notes are intended to complement the information in the Adobe After Effects CS4 Classroom in a Book®.

The information is organized to follow the sequence of instruction in each lesson.

Course strategy

If you’re teaching a 15-session class, you can teach approximately one chapter of this book per class. The book contains 14 lessons, some of which may take a while to complete. If you are teaching a 10-session class, you may want to combine some of the lessons in a single class. For example, Lessons 1 and 2 cover the basic workflow and most fundamental tasks in After Effects. Students begin a 3D project in Lesson 11 that they complete in Lesson 12, so you may be able to cover both lessons in one class.

Managing student projects

One way to simplify file storage and retrieval in classroom situations is to ask students to create a folder on their hard disks, name it [Student’s, for the student’s name] Lessons, and then copy each project folder into the main Lessons folder. Having students keep all their working files in their own Lessons folder makes it easy for you to clean up files when a class is over.
Lesson 1: Getting to Know the Workflow

Lesson 1 uses a sample project to provide an overview of the typical After Effects workflow, from creating a project to importing footage, creating a composition, applying effects, and outputting content. Along the way, students are introduced to the elements of the After Effects workspace, which they'll need to understand as they proceed with the lessons in this book.

About the Adobe workspace

Adobe video and audio applications provide a consistent, customizable workspace. Although each application has its own set of panels (such as Tools, Properties, Timeline, and so on), you move and group panels on your computer screen in the same way across products. The main window of a program is the application window. Panels are organized in this window in an arrangement called a workspace. The default workspace contains groups of panels as well as panels that stand alone. You customize a workspace by arranging the panels, usually by dragging them, in the layout that best suits your style of working. You can create and save several custom workspaces for different tasks—for example, one for editing and one for previewing. You can drag panels to new locations, move panels into or out of a group, place panels alongside each other, and undock a panel so that it floats in a new window above the application window. As you rearrange panels, the other panels resize automatically to fit the window. You can use floating windows to create a workspace more like those in previous versions of Adobe applications, or to place panels on multiple monitors.

Using a scroll-wheel mouse

If your mouse has a wheel for scrolling, you can zoom in the Timeline, Project, Render Queue, Composition, Layer, Footage, Flowchart, Effect Controls, and Effects & Presets panels, and scroll in the Timeline, Project, Render Queue, Flowchart, Effect Controls, and Effects & Presets panels.

Do any of the following:

- To zoom into the center of the panel, or into the feature region when tracking, roll the mouse wheel forward.
- To zoom out of the center of the panel, or out of the feature region when tracking, roll the mouse wheel backward.
- To zoom into the area under the pointer, press Alt (Windows) or Option (Mac OS) as you roll the mouse wheel forward.
- To zoom out of the area under the pointer, press Alt (Windows) or Option (Mac OS) as you roll the mouse wheel backward.
- To scroll vertically, roll the mouse wheel forward or backward.
• To scroll horizontally, press Shift as you roll the mouse wheel backward or forward. When you are in the Timeline panel, rolling backward moves you forward in time and vice versa.

Note: You can scroll in a panel even if it is not currently active as long as you move the pointer over it. For instance, you can scroll in the Composition panel even if the Effect Controls panel is currently active.

**Viewing a RAM preview**

Remind your students to have patience when they create a RAM preview. The status bar appears as After Effects renders the frames, and then the RAM preview plays. The time it takes to render the preview depends on how many frames are included, the complexity of applied effects, and the computer’s processor and RAM. Remember that you can create a RAM preview for a small portion of the project by adjusting the work area in the Timeline panel.

**Questions**

The following questions are not in the student’s Classroom in a Book.

1. How do you add layers to a composition?
2. How can you modify effect settings?
3. Where can you learn more about an After Effects feature or effect?

**Answers**

1. Drag an item (such as a footage item or composition) from the Project panel to the Timeline panel, positioning it where you want it to appear in the layer stack.
2. Change the values in the Effect Controls panel.
3. To learn more about an After Effects feature or effect, enter a search term in the Search Help box in the upper-right corner of the application window, or choose Help > After Effects Help. After Effects launches your web browser application and connects to the Adobe Community Help, which contains After Effects Help, Adobe’s support knowledgebase, and third-party websites and blogs regarding After Effects.

**Lesson 2: Creating a Basic Animation Using Effects and Presets**

After Effects CS4 lets you produce great-looking animations quickly using hundreds of fully customizable animation presets, including presets for animating text, effects, transitions, backgrounds, and behaviors. You can also use included project
templates for DVD motion menus and motion graphics backgrounds. Lesson 2 explores how to create a composition using some of these new presets. At the end of the lesson, students export their animation in Flash format for use on the web. These notes provide additional background about animation presets and Flash export.

**About animation presets**

Animation presets let you save and reuse specific configurations of properties and animations, including keyframes, effects, and expressions. After Effects includes hundreds of animation presets that you can drop into your projects and then modify to suit your needs.

You can apply an entire animation preset to a layer, or you can apply a single effect or property from an animation preset. If a property or effect exists in the animation preset but not in the target layer, the property or effect is added to the target layer.

Many animation presets don’t contain animation; rather, they contain combinations of effects, transform properties, and so on. You can save one or more properties with all of the desired settings to an animation preset without including keyframes. A particularly convenient category of animation presets is behaviors, which you can use to quickly and easily animate without keyframes.

Animation presets can be saved as FFX files and transferred from one computer to another. By default, animation presets are stored in the Presets directory.

For additional information, visit Adobe Community Help on the Adobe website.

**Saving animation presets**

You can save settings of one or more effects as an animation preset. Saving an effect as an animation preset also saves any set keyframes, as well as expressions used in the effect. For example, if you created an explosion using several effects with complex parameter and animation settings within those effects, you can save all those settings as a single animation preset. You can then apply that animation preset to any other footage, or you can apply any single effect from that animation preset to any footage. The 20 most recently saved or applied animation presets appear under Recent Animation Presets in the Animation menu.

Animation presets also appear in the Animation Presets menu in Effect Controls and in Effects & Presets. The Animation Presets menu in the Effect Controls panel lists only those animation presets that contain the current effect. For example, if the Mirror effect is selected, the menu shows only those presets that include the Mirror effect. If the Animation Presets category in Effects & Presets does not appear, choose the Show Animation Presets option from the Effects & Presets panel menu.

Note: When you apply an effect from the Animation Presets pop-up menu, only the current effect from the animation preset is applied.
Exporting SWF files

SWF and FLV are popular formats for producing interactive web content and you can output both formats directly from After Effects CS4.

Note: Though you can generate SWF and FLV files from After Effects, incorporating these files into web content and adding interactivity is typically done through a Flash authoring application.

SWF vs. FLV

SWF files deliver vector graphics (especially animations) and other data types, including video, over the Internet. SWF files also allow viewer interaction, such as following a web link. To view SWF files, you need Adobe Flash Player, a plug-in for your web browser.

FLV files contain only video. They may or may not be part of a larger SWF file, and they don’t allow interactivity themselves. To view FLV files, you need Flash Player 7.0 or later; these files can also be viewed by embedding Flash Video Player code directly into a web page. Several third-party standalone players for FLV files are also available.

FLV output can drastically improve the workflow efficiency for developing animated Flash content in After Effects. You can import FLV files from After Effects directly into your Flash authoring software without having to recompress (encode) the video data. FLV even supports alpha channels, helping to combine multiple files over a consistent background.

Questions

The following questions are not in the student’s Classroom in a Book.

1. How can you preview files more clearly in Adobe Bridge?
2. Name two ways to create a new composition.
3. How can you export a composition for the web?

Answers

1. Drag the thumbnail slider at the bottom of the Adobe Bridge window to enlarge thumbnail previews in the Content panel.
2. To create a new composition, click the Create A New Composition button at the bottom of the Project panel, choose Composition > New Composition, or press Ctrl+N (Windows) or Command+N (Mac OS).
3. Prepare the composition, including the appropriate settings, and then choose File > Export > Adobe Flash Player (SWF).
Lesson 3: Animating Text

Lesson 3 explores the many text options and text animation features in After Effects CS4. The following material provides additional background on formatting and animating text in After Effects.

About text layers

With After Effects, you can add text to layers with flexibility and precision. You can create and edit text directly onscreen in the Composition panel and quickly change the font, style, size, and color of the text. You can apply changes to individual characters and set formatting options for entire paragraphs, including alignment, justification, and word wrapping. In addition to all of these style features, After Effects provides tools for easily animating specific characters and features such as text opacity and hue.

About fonts

A font is a complete set of characters—letters, numbers, and symbols—that share a common weight, width, and style. Most of the projects in Classroom in a Book use fonts included with the After Effects CS4 installation disc, however you can substitute other fonts if you prefer, or if the suggested font is not available on the system. Remind students, however, that if they use a different font, their project’s appearance will differ from the images in the book.

Using smart quotes

Smart quotes, or printer’s quotation marks, use a curved left or right quotation mark instead of straight quotation marks. To apply smart quotes, choose Use Smart Quotes from the Character panel menu.

Editing text in text layers

You can edit text in text layers at any time. If you set the text to follow a path, designate it as a 3D layer, transform it, or animate it, you can still continue to edit it. When the Type tool is selected, move the pointer (an I-beam) directly over a text layer and click to edit the existing text. Click in another area in the Composition panel to create a new text layer. Shift-clicking always creates a new layer.

1. Select the Horizontal Type tool or the Vertical Type tool.
2. In the Timeline panel, double-click the text layer to set the Type tool to editing mode and select the text.
3. Edit the text.
**Blending overlapping characters in a text layer**

For a different effect, you can blend overlapping characters:

1. In the Timeline panel, expand the text layer and the More Options group.
2. Choose a blending mode from the Inter-Character Blending menu.

Note: To blend a text layer with the layers beneath it, specify a blending mode from the Modes column in the Timeline panel.

**Changing the direction of text**

The Vertical Type and Horizontal Type tools create text that flows horizontally or vertically. Horizontal text flows from left to right; multiple lines of horizontal text lie from top to bottom. Vertical text flows from top to bottom; multiple lines of text lie from right to left.

When you convert the vertical or horizontal orientation of a text layer, paragraph text (justifiable text that wraps within a bounding box) behaves differently from point text (independent lines of text) because paragraph text flows relative to its bounding box while point text lies relative to the Composition panel. For example, when you convert paragraph text from horizontal to vertical, or vice versa, the text’s bounding box doesn’t change its orientation, but the flow of text inside the box does.

**About text animation presets**

You can browse and apply text animation presets as you would any other animation presets.

The text animation presets were created in an NTSC DV 720 x 480 composition, and each text layer uses 72-point Myriad Pro. Some preset animations move the text on, off, or through the composition. The animation preset position values may not be appropriate for a composition that is much larger or smaller than 720 x 480; for example, an animation that is supposed to start offscreen may start onscreen. You may need to adjust the text animator’s position values.

If the text isn’t positioned as expected or the text disappears unexpectedly, adjust the text animator’s position values in the Timeline or Composition panel.

The Paths category of text animation presets automatically replaces source text with the preset’s name, changes the font color to white, and may change other character properties.

The Fill And Stroke category of animation presets contains presets that may change the fill color and stroke properties of the preset that you apply. If the animation preset requires a stroke or fill color, the animation works only if you have assigned one to your text.
Animating text with text animator groups

Once you create and format your text layers, use text animator groups to quickly and easily create elaborate animations. A text animator group includes one or more selectors and one or more animator properties. A selector is like a mask—it specifies which characters or section of a text layer you want an animator property to affect. Using a selector, you can define a percentage of the text, specific characters in the text, or a specified range of text.

Using a combination of animator properties and selectors, you can create complex text animations that would otherwise require painstaking keyframing. Most text animations require you to animate only the selector values—not the property values. Consequently, text animators use a small number of keyframes even for complex animations. For example, to animate the opacity gradually from the first character to the last, set the Opacity value (in the Animator group) to 0, and then set the End value (Range Selector property) to 0% at 0 seconds and 100% at the end of the animation.

Text animator groups animate a character’s position, shape, and size-related properties relative to each character’s own anchor point. The text property Anchor Point Grouping lets you reposition each character’s anchor point relative to its word, line, or entire text block. In addition, you can control the alignment of the anchor point relative to the anchor point group and the font with the Grouping Alignment property.

About selectors

Each animator group includes a default Range selector. You can add additional Range selectors to an animator group or add multiple animator properties that use the same Range selector.

In addition to this Range selector, you can add a Wiggly selector. Use the Wiggly selector to create selections that wiggle—vary within a specified amount—over time. You can add one or more Wiggly selectors to an animator group, and that animator group can contain one or more properties.

When you add multiple selectors to an animator group, you can control the way they interact with each other by using each selector’s Mode property. You can set values for the Start and End properties by changing the values in the Timeline panel or by using the selector bars in the Composition panel.

About the Expression selector

The Expression selector lets you dynamically specify how much characters are affected by an animator property through the use of expressions. You can add one or more Expression selectors to an animator group, and that animator group can contain one or more properties.
Questions
The following questions are not in the student’s Classroom in a Book.
1. What is the difference between point text and paragraph text?
2. Which panels do you use to format text?
3. How can you display a grid to help you position objects?
4. What does Easy Ease do?

Answers
1. In point text, each line of text is independent; in paragraph text, the text wraps within the bounding box as you form one or more paragraphs.
2. Use the Character panel to format character-level attributes, such as font and font style. Use the Paragraph panel to format paragraph-level attributes, such as indentation.
3. Choose View > Show Grid.
4. Easy Ease softens animations so that objects ease into and out of starting and stopping places, instead of beginning and ending abruptly.

Lesson 4: Working with Shape Layers
Shape layers are separate layers that contain vector graphics objects called shapes. By default, a shape consists of a path, a stroke, and a fill. Shape layers provide a straightforward way of creating filled shapes in a composition, without having to create a solid layer and then mask it. In Lesson 4, students use shape layers to create the background for the introduction of a reality series. These notes provide additional information about shapes and shape layers.

About shapes
You create a shape layer by drawing in the Composition panel with one of the shape tools (the Rectangle, Rounded Rectangle, Ellipse, Polygon, or Star tool) or the Pen tool. Shape layers are not based on footage items. Layers that are not based on footage items are sometimes called synthetic layers. Text layers are also synthetic layers and are also composed of vector graphics objects, so many of the rules and guidelines that apply to text layers also apply to shape layers. For example, you can’t open a shape layer in a Layer panel, just as you can’t open a text layer in a Layer panel.

There are two varieties of shape paths: parametric shape paths and Bezier shape paths. Parametric shape paths are defined numerically, by properties that you can modify and animate after drawing, in the Timeline panel. Bezier shape paths are defined by a collection of vertices (path points) and segments that you can modify.
in the Composition panel. When you create a shape by dragging with a shape tool in the Composition panel, you create a parametric shape path. To instead create a Bezier shape path, press Alt (Windows) or Option (Mac OS) before you click to begin dragging. You can release the key before you complete the drag operation. You work with Bezier shape paths in the same way that you work with mask paths. All mask paths are Bezier paths.

You can modify a shape path by applying path operations, such as Wiggle Paths and Pucker & Bloat. You apply a stroke to a path or fill the area defined by a path with color by applying paint operations.

Shape paths, paint operations, and path operations for shapes are collectively called shape attributes. You add shape attributes using the Add menu in the Tools panel or in the Timeline panel. Each shape attribute is represented as a property group in the Timeline panel, with properties that you can animate, just as you do with any other layer property.

You can save custom shapes as animation presets.

**Creating shapes and shape layers**

To create a shape layer, draw in the Composition panel with a shape tool or the Pen tool. By default, if you draw in the Composition panel when a shape layer is selected, you create a new shape within that shape layer, above the selected shapes or group of shapes. If you draw in the Composition panel using a shape tool or Pen tool when an image layer other than a shape layer is selected, you create a mask.

To create a new shape layer, first press F2 to deselect all layers, and then draw in the Composition panel. Or, choose Layer > New > Shape Layer. You can draw a shape with the Rectangle, Rounded Rectangle, Ellipse, Polygon, or Star tool. (A polygon is a star without an Inner Radius or Inner Roundness property, so when you create either a polygon or a star, After Effects calls the shape a polystar.)

A new shape’s fill and stroke are determined by the Fill and Stroke settings in the Tools panel when the shape is drawn. To change the fill and stroke, select the shape, and change the Fill and Stroke settings in the Tools panel.

Each shape tool retains the settings of the most recent drawing operation with that tool. For example, if you draw a star and modify the number of points to be 10, the next star you draw will also have 10 points. To reset a tool’s settings and create a shape with the default settings, double-click the tool in the Tools panel.

To draw a mask on a shape layer, select a shape or Pen tool, and then click the Tool Creates Mask button in the Tools panel. Then, draw the mask.

To reposition a shape or mask as you are drawing, hold the spacebar or the middle mouse button while dragging.
To scale a circle, ellipse, square, rounded square, rectangle, or rounded rectangle around its center while drawing, hold the Ctrl (Windows) or Command (Mac OS) key after you begin dragging. Don’t release the key until you have released the mouse button to finish drawing.

To cancel the drawing operation, press Esc.

To create a shape the size of the layer, select an existing shape layer or deselect all layers to create a new layer, and then double-click a shape tool in the Tools panel.

Creating shapes from text characters

You can convert individual text characters into shapes. To create shapes for all the characters in a text layer, select the text layer in the Timeline panel or the Composition panel; to create shapes for specific characters, select only those characters in the Composition panel. Then, choose Layer > Create Outlines.

The Create Outlines command extracts the outlines for each character, creates shapes from the outlines, and puts the shapes on a new shape layer. You can then use these shapes as you would any other shape.

The new shape layer is created at the top of the layer stacking order. The new layer contains one shape group for each selected character, plus fill and stroke properties that match those of the text. When characters consist of compound paths, such as “i” and “e,” multiple paths are created and combined with the Merge Paths path operation. Effects, masks, layer styles, and keyframes and expressions for properties in the text layer’s Transform property group are copied to the new shape layer. The Video switch for the text layer is turned off.

About groups and render order for shapes

Though the default is for a shape to consist of a single path, a single stroke, and a single fill—arranged from top to bottom in the Timeline panel—much of the power and flexibility of shape layers arises from your ability to add and reorder shape attributes and create more complex compound shapes.

A group is a collection of shape attributes: paths, fills, strokes, path operations, and other groups. Each group has its own blending mode and its own set of transform properties. By assembling shapes into groups, you can work with multiple shapes simultaneously—such as scaling all shapes in the group by the same amount or applying the same stroke to each shape. You can even place individual shapes or individual shape attributes within their own groups to isolate transformations.

For example, you can scale a path without scaling its stroke by grouping the path by itself.

When you add a shape attribute using the Add menu in the Tools panel or Timeline panel, the attribute is added within the group that is selected. You can drag groups
and attributes to reorder them in the Timeline panel. By reordering and grouping shapes and shape attributes, you can affect their rendering order with respect to other shapes and shape attributes.

**Questions**

The following questions are not in the student’s Classroom in a Book.

1. How can you add a gradient fill to a shape?
2. How can you alter the shape of a polygon?
3. How can you access blending modes in the Timeline panel?

**Answers**

1. Click the word Fill in the Tools panel to open the Fill Options dialog box, and then select either the Linear Gradient or Radial Gradient option, and click OK. Then, click the Fill Color box to open the Gradient Editor, and assign colors to the color stops.
2. Change its attributes in the Polystar Path section of the Timeline panel. You can change the number of points, Outer Roundness value, and other properties.
3. Click the Toggles Switches/Modes button at the bottom of the Timeline panel to display the Mode menu for each layer.

**Lesson 5: Animating a Multimedia Presentation**

Lesson 5 builds a complex animation involving multiple layers, several types of keyframes, audio, and more. It starts from a layered, imported Photoshop file. These notes provide additional background and teaching material on how After Effects works with Photoshop and Illustrator files.

**Layered files**

You can import Adobe Photoshop, Adobe Illustrator, EPS, and many PDF files directly into an After Effects project.

After Effects imports attributes that were applied in Photoshop, including position, blending modes, opacity, visibility, transparency (alpha channel), layer masks, layer groups (imported as nested compositions), adjustment layers, common layer styles (Drop Shadow, Inner Shadow, Outer Glow, Inner Glow, Bevel and Emboss, and Color Fill), layer clipping paths, vector masks, image guides, and clipping groups.

You can also create a new Photoshop file and add it as the top layer in a composition from within After Effects, or use After Effects to create a new Photoshop file without
adding it to a specific composition. When you import an Illustrator file, After Effects makes all empty areas transparent by converting them into an alpha channel.

After Effects can import Illustrator CMYK files. However, After Effects does not read embedded color profiles from Illustrator files. To ensure color fidelity, assign an input color profile to the Illustrator footage item that matches the color profile with which the Illustrator file was created.

You can import a multilayered Photoshop or Illustrator file in the following ways:

- As a new composition, with each layer in the Photoshop or Illustrator file becoming a separate layer in the composition that keeps its original dimensions. This option, Composition - Cropped, makes it easier to manipulate layers and speeds their rendering time.
- As a new composition, with each layer in the Photoshop or Illustrator file becoming a separate layer in the composition and changing dimensions to match the composition size. This option, Composition, is helpful when you need to align layers manually.
- As a single still-footage item imported from any one layer in the Photoshop or Illustrator file.
- As a single still-footage item merged as you import multiple Photoshop or Illustrator layers.

**Preparing layered Photoshop files**

Importing layers into After Effects makes it possible to prearrange a composition in Photoshop using layers and preserve those layers in After Effects so that they are ready for animation. Preserving layers is also useful if you want to use a single Photoshop file as a source for both print and dynamic media.

Before you import a layered Photoshop file, prepare it thoroughly to reduce preview and rendering time. Avoid problems importing and updating Photoshop layers by naming them properly. Before you import them into After Effects, do the following:

- Organize and name layers. If you change a layer name in a Photoshop file after you have imported it into After Effects, After Effects retains the link to the original layer. However, if you delete a layer, After Effects is unable to find the original layer and lists it as Missing in the Project panel.
- Make sure that each layer has a unique name to avoid confusion.
- If you want to import a composited version of a layered Photoshop file along with a layered version, select Always Maximize Compatibility For Photoshop (PSD) Files in the Photoshop File Handling Preferences dialog box.
Preparing Illustrator files
Before you save an Illustrator file for importing into After Effects, consider doing the following:

• To ensure that Illustrator files appear correctly in After Effects, select Create PDF Compatible File in the Illustrator Options dialog box.

• To copy paths between Illustrator and After Effects, make sure that the AICB and Preserve Paths options are selected in the Files & Clipboard section of the Illustrator Preferences dialog box. If you don’t select AICB in Illustrator, After Effects prompts you when you attempt to paste the path.

• To ensure that files rasterize most faithfully in After Effects, save your file in AI format instead of Illustrator 8.x or 9.x EPS format.

Transparency in Photoshop files
Photoshop supports a transparent area and alpha channels for each layer. You can use these layer masks to specify how different areas within a layer are hidden or revealed. If you import one layer, After Effects combines the layer mask (if present) with the transparent area and imports the layer mask as a straight alpha channel.

If you import a layered Photoshop file as a merged file, After Effects merges the transparent areas and layer masks of all the layers into one alpha channel that is premultiplied with white.

If the layered Photoshop file contains clipping groups, After Effects imports each clipping group as a composition nested within the main composition. After Effects automatically applies its Preserve Underlying Transparency option to each layer in the clipping-group composition, maintaining transparency settings.

When you import a Photoshop file as a composition, any vector masks convert to After Effects masks. You can then modify and animate these masks within After Effects.

After Effects also supports any blending modes applied to the file.

For more details about how After Effects works with transparency in Photoshop files, refer to Adobe Community Help.

Using adjustment layers from Photoshop
Adjustment layers in Photoshop change the color and tonal qualities of an image without permanently modifying the original image. Photoshop adjustment layers affect the appearance of all layers below them. When you import a Photoshop file containing one or more adjustment layers as a composition, After Effects directly converts the Photoshop adjustment layers to After Effects adjustment layers.
• To remove the effect and display the layer as a white solid, turn off the Adjustment Layer switch in After Effects.

• To remove the effect and the white solid, either delete the adjustment layer or turn off the Video switch for the layer.

**Continuously rasterizing an Illustrator file**

When you import a vector file, After Effects automatically rasterizes it. However, if you want to scale a vector file above 100%, you need to continuously rasterize it to maintain image quality. You can continuously rasterize an Illustrator file (or any other vector file) at any time while designing your project. Continuously rasterizing causes After Effects to rasterize the file as needed based on the transformation for each frame. A continuously rasterized file generally produces higher quality results, but it may preview and render slower than a rasterized image.

When you apply an effect to a continuously rasterized layer, the results may be different than when you apply the effect to a nonrasterized layer. This is because the default rendering order for the layer changes. By default, nonrasterized layers are rendered in the following order: masks, effects, and then geometrics (transformations). The default rendering order for a continuously rasterized layer is masks, geometrics (transformations), and then effects. You can change the default rendering order.

For example, if an Illustrator file pictures a dog and if you want to animate the scale of the dog and apply the Bulge effect to the dog’s nose, turn off continuous rasterization so that the bulge stays on the dog’s nose as the picture scales larger and smaller. Make sure to check the results of the effect before continuing to work on your project.

Whether or not you continuously rasterize, if you view and render a composition using Best Quality, After Effects anti-aliases (smoothes) the art. For general information about rasterizing, see Illustrator Help.

Note: You cannot paint interactively on a continuously rasterized layer. However, you can apply a paint effect by copying and pasting or using the Favorites menu.

**Designing an Illustrator CS4 workflow for video production**

When you import Illustrator CS4 files into video production applications, you can save production time by setting up Illustrator CS4 files for maximum efficiency:

• Customize the new document profile—You can customize the default settings for new files by editing the new document profile that Illustrator CS4 uses for video files. You can set the default Artboard Size to match your most frequently used After Effects composition size. In addition, you can customize the contents of any palette. For example, if your shop has a standard set of Illustrator CS4 graphic styles or symbols, you can save them into the new document profile, and
they’ll be available in every Illustrator CS4 document you create. As you create documents using the File > New command, you can adjust the artboard size, orientation, and document color mode in the New Document dialog box.

- Create document templates—A template is a customized Illustrator CS4 document that creates an untitled document when you open it. You can use templates to create frequently used documents that differ from your customized new document profile. There’s only one difference between saving a document as a document or as a template: To save a document as a template, choose Illustrator CS4 Template from the Format menu in the Save As dialog box. Open a template using the same methods you use to open a document.

- To copy paths between Illustrator and After Effects, make sure that the AICB and Preserve Paths options are selected in the Files & Clipboard section of the Illustrator Preferences dialog box. If you don’t select AICB in Illustrator, After Effects prompts you when you attempt to paste the path.

- Control layer dimensions—If you import an Illustrator document into After Effects and the Illustrator document dimensions aren’t what you expect, specify the layer dimensions in the Illustrator CS4 document.

### Editing Illustrator CS4 files within After Effects projects

You can open Illustrator CS4 files in After Effects projects directly from After Effects. To open an Illustrator CS4 file, select it in the Project panel and choose Edit > Edit Original. When you save the file in Illustrator CS4, the file is automatically updated in After Effects

### Questions

The following questions are not in the student’s Classroom in a Book.

1. Define a *parenting relationship*.

2. How can you display the anchor point in the Layer panel?

3. What does an alpha matte do?

### Answers

1. A parenting relationship between layers synchronizes the changes in the parent layer with the corresponding transformation values of the child layers. That is, when you make changes to the parent layer, the child layers also change.

2. To display the anchor point, choose Anchor Point Path from the View menu at the bottom of the Layer panel.

3. An alpha matte uses the alpha channel of one layer to mask another layer.
Lesson 6: Masks and Channels

Lesson 6 introduces students to the Layer panel, which they use to remap time, and to the Graph Editor, where they edit Time Remap keyframes.

About the Graph Editor

To view and manipulate all aspects of effects and animations, including effect property values, keyframes, and interpolation, use the Graph Editor. The Graph Editor represents changes in effects and animations as a two-dimensional graph, with playback time represented horizontally (from left to right). In layer bar mode, on the other hand, the time graph represents only the horizontal time element, without showing a visual representation of changing values.

There are two types of graphs available in the Graph Editor: value graphs, which show property values; and speed graphs, which show rates of change of property values.

Working with the Graph Editor

In the Graph Editor, each property is represented by its own graph. You can view and work on one property at a time, or you can view multiple properties simultaneously. When more than one property is visible in the Graph Editor, each property’s graph has the same color as the property’s value in the layer outline.

Selecting which properties are shown in the Graph Editor

Click the Show Properties button at the bottom of the Graph Editor, and select from the following options:

- Show Selected Properties displays selected properties in the Graph Editor.
- Show Animated Properties displays animated properties of selected layers in the Graph Editor.
- Show Graph Editor Set displays properties that have the Graph Editor toggle selected.

To select Graph Options in the Graph Editor

Click the Graph Options button at the bottom of the Graph Editor, and select from the following options:

- Auto-Select Graph Type automatically selects the appropriate graph type for a property: speed graphs for spatial properties (such as position), and value graphs for other properties.
- Edit Value Graph displays the value graph for all properties.
- Edit Speed Graph displays the speed graph for all properties.
• Show Reference Graph displays the unselected graph type in the background for viewing only. (The gray numbers to the right of the Graph Editor indicate the values for the reference graph.)

• Show Audio Waveforms displays the audio waveform for any layer that has at least one property in the Graph Editor.

• Show Layer In/Out Points displays In and Out points of all layers that have a property in the Graph Editor.

• Show Layer Markers displays layer-time markers in the Graph Editor, if they exist.

• Show Graph Tool Tips toggles the graph tool tips on and off.

• Show Expression Editor shows or hides the expression editor field.

• Allow Keyframes Between Frames allows you to place keyframes between frames for fine-tuning animation.

Using the Snap button

When you drag a keyframe in the Graph editor with the Snap button toggled, the keyframe snaps to the following items:

• Keyframes (both vertically and horizontally)
• Current-time indicator
• In/Out points
• Markers
• Work area start/end
• Composition start/end

When the keyframe snaps to one of these items, an orange line appears in the Graph Editor to indicate the object you’re snapping to. Ctrl-drag (Windows) or Command-drag (Mac OS) to temporarily toggle the Snap button.

Note: Shift-dragging the current-time indicator also snaps to the items in the list above.

Panning and zooming in the Graph Editor

To pan vertically or horizontally, drag with the Hand tool.

To invoke the Hand tool momentarily, press and hold the spacebar.

To pan vertically, spin the mouse scroll wheel.

To pan horizontally, press the Shift key as you spin the mouse scroll wheel.

To zoom in, click with the Zoom tool.
To zoom out, Alt-click (Windows) or Option-click (Mac OS) with the Zoom tool.
To zoom using the mouse scroll wheel, press Alt (Windows) or Option (Mac OS)
while scrolling to zoom horizontally; press Ctrl (Windows) or Command (Mac OS)
to zoom vertically.
To zoom horizontally, Alt-drag (Windows) or Option-drag (Mac OS) with the
Zoom or Hand tool to the left to zoom out or to the right to zoom in.
To zoom vertically, Alt-drag (Windows) or Option-drag (Mac OS) with the Zoom
or Hand tool up to zoom in or down to zoom out.
Note: You cannot pan or zoom vertically when Auto Zoom Height is selected.

Auto Zoom Height and Fit

The Auto Zoom Height, Fit Selection, and Fit All buttons help you adjust the Graph
Editor’s view to focus on relevant portions of your animations.
Auto Zoom Height toggles Auto Zoom Height mode, which automatically scales
the height of the graph so that it fits the height of the Graph Editor. The horizontal
zoom must still be adjusted manually.
Fit Selection adjusts the value (vertical) and time (horizontal) scale of the graph to
fit the selected keyframes in the Graph Editor.
Fit All adjusts the value (vertical) and time (horizontal) scale of the graph to fit all of
the graphs in the Graph Editor.

Questions

The following questions are not in the student’s Classroom in a Book.
1 What does the Solo switch do?
2 What is a traveling matte?
3 How does the Corner Pin effect work?

Answers

1 The Solo switch isolates the layer or layers, making other layers inactive. Soloing
layers can speed animating, previewing, and rendering, as well as ma.
2 A traveling matte is an animated track matte.
3 The Corner Pin effect marks four corners of an object, and then animates those
points over time. You can use it to stretch, shrink, skew, or twist an image, or to
simulate perspective or movement that pivots from the edge of a layer, such as a
door opening.
Lesson 7: Working with Masks

Lesson 7 introduces students to the concept of masks. They learn to create masks in After Effects using the Pen tool. Students can also use Illustrator to help them create and use masks in After Effects.

Enhancing animation

In a video production workflow, Illustrator CS4 has much more to offer than a role as a specialized application for still graphics. The pen tool and Bezier paths that are fundamental to drawing in Illustrator CS4 are also used in video production applications to control motion paths and timelines. You can use Illustrator CS4 paths not just as source graphics, but also as motion paths in After Effects. You can also use the warping, blending, and layer features in Illustrator CS4 to prepare shapes for morphing and tweening.

Creating motion paths in Illustrator CS4

The path-drawing features in Illustrator CS4 are well-suited to any task that involves drawing a path. Motion graphics typically depend on motion paths, and you can draw motion paths more quickly and precisely in Illustrator CS4 than you can in After Effects.

In After Effects, you create a motion path by animating the Position property and setting a different position for each keyframe. You then refine the path by dragging handles on the path. This method works well for freeform paths, but it can be time-consuming to edit a motion path into a regular shape, such as a perfect circle. Instead of building a motion path from two original points, in Illustrator CS4, you can draw a path using the tool that most efficiently creates the shape you want.

For example, consider animating a layer along a perfect semicircular arc. In After Effects, you establish the layer position at the beginning and ending keyframes, and then drag control handles to form the arc; it isn’t easy to form a perfect semicircle in this way. And while it’s possible to animate along an arc using a mathematical expression, not every motion graphics designer is a mathematician. For a quick alternative, draw the shape you want in Illustrator CS4 and copy and paste it into After Effects.

To create an arc in Illustrator CS4 and use the arc as a motion path in After Effects:

1. In Illustrator CS4, draw the arc you need using the Arc tool or by cutting an ellipse with the Scissors or Knife tools.
2. Use the Selection or Direct Selection tool to select the remaining part of the arc, and choose Edit > Copy.
3. Switch to After Effects.
4. In the Timeline panel, select the layer you want to animate.
5 Press P to reveal the Position property, and click the Position property name to highlight it.

6 In the Timeline panel, set the current-time indicator to the time where you want motion to start.

7 Choose Edit > Paste. The path becomes a motion path, and After Effects adds start and end keyframes to the layer in the Timeline panel. (If a motion path was already present, pasting a path replaces the previous motion path.) To change the duration of the animation, drag either keyframe.

8 Preview and edit the composition as needed

Questions

The following questions are not in the student’s Classroom in a Book.

1 What is the default mask mode and how does it affect masks?
2 How can you change the mask mode for a layer?
3 How can you draw a perfect square or circle?

Answers

1 Add is the default mask mode. It combines the transparency values of any masks that overlap on the same layer.

2 Select a different mode from the Mask Mode pop-up menu for the layer in the Timeline panel.

3 To draw a perfect square or circle, press the Shift key as you drag the Rectangle tool or Ellipse tool, respectively.

Lesson 8: Distorting Objects with the Puppet Tools

The Puppet tools let you pull, push, stretch, twist, and otherwise distort objects in a composition. There are four Puppet tools: you use three of the tools to place pins that determine how and where distortion occurs; the remaining tool makes it easier to record the pins’ animation.

In Lesson 8, students use the Puppet tools to animate a character slipping on a banana peel. These notes give you additional information about the Puppet tools and other distortion effects in After Effects CS4.
About the Puppet tools
Use the Puppet tools to quickly add natural motion to raster images and vector graphics, including still images, shapes, and text characters. The Puppet tools actually work within the Puppet effect, but unlike other effects, you don’t need to apply it using the Effect menu or the Effects & Presets panel. Instead, use the Puppet tools in the Tools panel to directly apply and work with the effect in the Layer or Composition panel.

The Puppet effect works by deforming part of an image according to the positions of Deform, Overlap, and Starch pins that you place and move.

About the Puppet Pin tool
With the Puppet Pin tool, you place and move Deform pins, which determine how much deformation takes place in particular areas of an image.

About the Puppet Overlap tool
With the Puppet Overlap tool, you place Overlap pins, which determine which parts of an image appear in front of others when distortion causes parts of the image to overlap each other. You apply Overlap pins to the original outline, not to the deformed image.

Each Overlap pin has the following properties:
In Front—The apparent proximity to the viewer. The influence of Overlap pins is cumulative, meaning that the In Front values are added together for places on the mesh where extents overlap.
Extent—How far from the Overlap pin its influence extends. The influence ends abruptly; it does not decrease gradually.

About the Puppet Starch tool
With the Puppet Starch tool, you place Starch pins, which stiffen parts of the image to reduce the distortion of that area. Apply Starch pins to the original outline, not to the deformed image.

Each Starch pin has the following properties:
Amount—The strength of the stiffening agent. The influence of Starch pins is cumulative, meaning that the Amount values are added together for places on the mesh where extents overlap. If you notice image tearing near a Deform pin, use a Starch pin with a very small Amount value (less than 0.1) near the Deform pin to maintain the image’s integrity.
Extent—How far from the Starch pin its influence extends. The influence ends abruptly; it does not decrease gradually with distance from the pin.
About the Puppet Sketch tool

The Puppet Sketch tool is unlike the other Puppet tools. You do not use it to place pins; instead, you use the Puppet Sketch tool to sketch the motion path of Deform pins in real time, or at a speed that you specify. In fact, if your composition contains audio, you can sketch the motion path of the pins in time with the audio.

To configure settings for recording, click Record Options in the Tools panel. The following options are available:

Speed—The ratio of the speed of the recorded motion to playback speed. If Speed is 100%, the motion is played back at the speed at which it was recorded. If speed is greater than 100%, the motion plays back more slowly than it was recorded.

Smoothness—Determines how smooth the motion is. Set this value higher to remove extraneous keyframes from the motion path as it’s drawn. Creating fewer keyframes makes the motion smoother.

Use Draft Deformation—Ignores Starch pins in the draft distortion displayed during recording. This can improve performance for a complex mesh.

To use the Puppet Sketch tool to record animation, select the Deform pin or pins you want to animate and go to the time at which to begin recording motion. Then, in the Composition or Layer panel, press Ctrl (Windows) or Command (Mac OS) to activate the Puppet Sketch tool, and Ctrl-drag (Windows) or Command-drag (Mac OS) the pins to animate them.

Recording begins when you click to begin dragging, and it ends when you release the mouse button. The color of the outline for the mesh for which motion is being sketched is the same as the color of the pin. Reference outlines for other meshes on the same layer, are the colors of the layer’s label.

When you finish recording, the current-time indicator returns to the time at which recording began so that you can deform other pins for the same time period.

Using the Puppet mesh

When you place the first pin, the area within an outline is automatically divided into a mesh of triangles. Each part of the mesh is associated with the pixels of the image, so the image’s pixels move with the mesh. (To show the mesh, select Show in the Tools panel.)

When you move one or more Deform pins, the mesh changes shape to accommodate this movement, while keeping the overall mesh as rigid as possible. The result is that a movement in one part of the image causes natural, life-like movement in other parts of the image.

For example, if you place Deform pins in a person’s feet and hands, and then move one of the hands to make it wave, the motion in the attached arm will be large, but the motion in the waist will be small, just as in the real world.
You can have multiple meshes on one layer. This is useful for deforming several parts of an image individually—such as text characters—as well as for deforming multiple instances of the same part of an image, each with a different deformation.

The original, undistorted mesh is calculated at the current frame at the time at which you apply the effect. The mesh does not change to accommodate motion in a layer based on motion footage, nor does the mesh update if you replace a layer's source footage item.

When a Puppet mesh is created, its boundaries are determined by an outline, which can be defined by an unlocked mask path, a shape path on a shape layer, or a text character's outline. If a layer has none of these things, the Puppet effect uses Auto-trace to create paths from the alpha channel. These paths are used by the Puppet effect only to determine outlines and do not appear as masks on the layer. If the layer is a raster layer with no alpha channel, the resulting outline is a single rectangular path around the layer's bounds. For a complex image, or to configure Auto-trace settings, use Auto-trace before using the Puppet tools.

A text character that consists of multiple disjointed closed paths (such as the letter “i”) is treated as multiple separate paths.

A shape or character’s stroke is not used in the determination of outlines; only the path is used. To encompass a stroke within a mesh, increase the Expansion value. The default value of 3 pixels encompasses a stroke that extends 3 pixels or less from its path.

If multiple masks, shapes, or characters overlap on the same layer, an outline is created from the union of the overlapping shapes, overlapping characters, or overlapping masks. If a mask overlaps a text character or shape, outlines are created for the entire character or shape, for the portion that is inside the mask, and for the mask itself.

Other distortion effects

In addition to the Puppet effect, After Effects CS4 provides several other distortion effects. Invite students to experiment with some of the following effects:

Bezier Warp—The Bezier Warp effect shapes an image using a closed Bezier curve along the boundary of a layer. The curve consists of four segments. Each segment has three points (a vertex and two tangents).

Bulge—The Bulge effect distorts an image around a specified point, making the image appear to bulge toward or away from the viewer, depending on the options you select.

Displacement Map—The Displacement Map effect distorts a layer by displacing pixels horizontally and vertically based on the color values of pixels in the control layer specified by the Displacement Map Layer property.
Liquify—The Liquify effect lets you push, pull, rotate, enlarge and shrink areas in a layer. Several Liquify tools distort the brush area when you hold down the mouse button or drag. The distortion is concentrated at the center of the brush area, and the effect intensifies as you hold down the mouse button or repeatedly drag over an area.

Magnify—The Magnify effect enlarges all or part of an image. This effect can act like a magnifying glass placed over an area of the image, or you can use it to scale the entire image far beyond 100% while maintaining resolution.

Mesh Warp—The Mesh Warp effect applies a grid of Bezier patches over a layer, which you can manipulate to distort areas of an image. Each corner of a patch includes a vertex and two to four tangents (points that control the curvature of the line segment that makes up the edge of the patch). By moving the vertices and tangents, you can manipulate the shape of the curved line segment.

Mirror—The Mirror effect splits the image along a line and reflects one side onto the other.

Offset—The Offset effect pans the image within a layer. Visual information pushed off one side of the image appears on the opposite side. At Best quality, the offset is performed with subpixel precision.

Polar Coordinates—The Polar Coordinates effect distorts a layer by transposing each pixel in the layer’s (x,y) coordinate system to the corresponding position in the polar coordinate system, or the reverse. This effect produces unusual and surprising distortions that can vary greatly depending on the image and the controls you select.

Reshape—The Reshape effect transforms one shape into another shape on the same layer, dragging the underlying image with it. The image is distorted to fit the shape of the new area.

Ripple—The Ripple effect creates the appearance of ripples in a specified layer, moving away from a center point in concentric circles. The effect is similar to dropping a stone in a pond. You can also specify that ripples move toward the center point.

Smear—Using the Smear effect, you define an area within an image and then move that area to a new location, stretching, or smearing, the surrounding part of the image with it. Use masks to define the area you want to distort.

Spherize—The Spherize effect distorts a layer by wrapping a region of the image onto a sphere. The layer’s quality setting influences the Spherize effect. Best quality samples the displaced pixels to subpixel precision; Draft quality samples to the nearest whole pixel.

Turbulent Displace—The Turbulent Displace effect uses fractal noise to create turbulent distortions in an image. For example, use it to create flowing water, funhouse mirrors, and waving flags.
Twirl—The Twirl effect distorts an image by rotating a layer around its center. The image is distorted more sharply in its center than at the edges, causing a whirlpool result at extreme settings.

Warp—Use Warp to distort or deform layers. The warp styles work much like the Warp effects in Adobe Illustrator and Warp Text in Adobe Photoshop.

Wave Warp—The Wave Warp effect produces the appearance of a wave traveling across an image. You can produce a variety of different wave shapes, including square, circular, and sine waves.

Questions

The following questions are not in the student’s Classroom in a Book.

1. How can you display or hide the Puppet mesh?
2. What does the Triangles value determine?
3. What is the squash and stretch animation technique?

Answers

1. To display or hide the mesh, click Show in the Tools panel.
2. The Triangles value determines how many triangles are included in the mesh. More triangles results in smoother animation, but can also increase rendering time.
3. Squash and stretch is a traditional animation technique that adds realism and weight to objects. It’s an exaggeration of the effect that occurs in real life when a moving object comes into contact with a stationary object, such as the ground. When squashing and stretch-ing are applied correctly, the volume of the character doesn’t change.

Lesson 9: Keying

Lesson 9 introduces students to the process of keying. A common task in video production, keying removes the background of a clip so that you can place the subject in another environment. Keying allows the weather anchor to appear in front of a map or a superhero to fly across the night sky. More prosaically, it allows production artists to prepare video files for compositing in other applications.

You create a key by isolating the background pixels; After Effects uses the keyed pixels to create an alpha channel that defines the transparent background. The alpha channel can be included in certain video formats, such as FLV, for use in other applications. After Effects offers a comprehensive set of keying controls that lets you create seamless compositions.
Using a hold-out matte

In some cases, a portion of the scene includes a color that matches the keyed-out background. To retain the original, opaque color when you key a scene, use a hold-out matte, also known as a hold-back matte, to patch it.

A hold-out matte is a masked-out portion of a duplicate of a layer that you have keyed. The duplicate is masked to include only the area of the image that contains the key color that you want to preserve as opaque. The hold-out matte is then placed directly on top of the keyed layer.

To use a hold-out matte:

1. Duplicate the layer containing the color screen.

Note: Don’t change the Transform properties of only one of the layers after making the duplicate; keep the layers moving together.

2. Apply keying effects and Matte effects to the original layer to create transparency.

3. On the duplicate layer, mask out everything in the image except the area that you want to preserve.

4. Make sure the the duplicate layer (the hold-out matte) is positioned directly on top of the keyed layer and contains exactly the same keyframes with the same values. Then render the movie.

Tips for generating high-quality keys

Keep in mind that generating a high-quality key can require the application of multiple keying effects in sequence and careful modification of their properties, especially if the footage was shot without considering the requirements of the compositor.

To help you view transparency, temporarily change the background color of the composition, or include a background layer behind the layer you are keying out. As you apply the keying effect to the layer in the foreground, the composition background (or a background layer) shows through, making it easy to view transparent areas.

Once you have used a key to create transparency, use Matte effects to remove traces of key color and create clean edges.

Start with the highest-quality materials you can gather, such as film that you scan and digitize.

Use uncompressed footage (or, at least, files with the least possible amount of compression). Many compression algorithms, especially those used in DV and Motion JPEG, discard subtle variations in blue—which may be necessary to create a good key from a bluescreen.
Noise and compression artifacts can cause problems for keying, especially difference keying. Often, applying a slight blur before keying can reduce noise and compression artifacts enough to improve keying results. For example, blurring the blue channel for DV footage can smooth out noise in a bluescreen.

Blurring the alpha channel after keying can soften the edges of the matte, which can improve compositing results.

Light your greenscreen or bluescreen uniformly, and keep it free of wrinkles.

Use a garbage matte to roughly outline your subject so that you don’t have to waste time keying out parts of the background far from the foreground subject.

For evenly lit greenscreen or bluescreen footage, adjust keying controls on only one frame. Choose the most intricate frame of the scene, one involving fine detail such as hair and transparent or semitransparent objects, such as smoke or glass. If the lighting is constant, the same settings you apply to the first frame are applied to all subsequent frames. If lighting changes, you may need to adjust keying controls for other frames. Place keyframes for the first set of keying properties at the start of the bluescreen scene. If you are setting keyframes for one property only, use Linear interpolation. For footage that requires keyframes for multiple interacting properties, use Hold interpolation. If you set keyframes for keying properties, you may want to check the results frame by frame. Intermediate keying values may appear, producing unexpected results.

To key well-lit footage shot against a bluescreen or greenscreen, start with the Color Difference Key. Add the Spill Suppressor to remove traces of the key color, and then use one or more of the other Matte effects, if necessary. If you are not satisfied with the results, try starting again with the Linear Color Key.

To key well-lit footage shot against multiple colors or unevenly lit footage shot against a bluescreen or greenscreen, start with the Color Range key. Add the Spill Suppressor and other effects to refine the matte. If you are not completely satisfied with the results, try starting with or adding the Linear Color Key.

To key dark areas or shadows, use the Extract Key on the Luminance channel.

To make a static background scene transparent, use the Difference Matte Key. Add the Simple Choker and other effects as needed to refine the matte.

Questions

The following questions are not in the student’s Classroom in a Book.

1. Why might you need to animate a garbage mask?
2. How does the Color Difference Key effect work?
Answers

1. If the subject moves in or out of the frame, or if the subject changes position substantially during the movie, you may need to animate the garbage mask to follow the subject.

2. The Color Difference Key effect divides an image into two mattes, Matte Partial A and Matte Partial B. Matte Partial B bases the transparency on the specified key color, and Matte Partial A bases transparency on areas of the image that do not contain a second, different color. By combining the two mattes into a third matte, called the alpha matte, the Color Difference Key creates well-defined transparency values.

Lesson 10: Performing Color Correction

Lesson 10 covers color correction. A strong understanding of color and color management is useful to ensure that color appears on a viewer’s system as video editors see it on theirs.

About color depth

Color depth is the number of bits per channel (bpc) used to represent the color of a pixel. Channels contain color information: RGB images have channels for red, green, and blue. The more bits per channel, the more colors can be represented.

In After Effects, you can work in 8-bpc, 16-bpc or 32-bpc color mode for each project. Many effects support 16 and 32 bits per channel (see Color depth and effects).

Even if your output is 8-bpc (Millions Of Colors), you can obtain better rendering quality by having the project (or render) color depth set at 16-bpc or 32-bpc because of the added precision achieved by calculating color values at higher bit depths.

32-bpc color mode is for working with HDR (high dynamic range) images. After Effects assumes that all HDR footage represents color linearly—in linear light. When you import HDR images, After Effects converts floating-point 32-bit values from linear light to the project’s working color space. If you haven’t chosen a working color space for your project, After Effects converts HDR footage from linear light using a gamma value of 2.2; this value represents the gamma for a typical monitor. Gamma is the exponent used in converting RGB levels. When you render to a 32-bpc output format, After Effects removes the gamma applied on import, converting 32-bit values back to linear light.

16-bpc color-mode frames require half the memory of 32-bpc frames and offer advantages in terms of speed and storage. Use 16-bpc mode when you work with high-resolution images that contain a narrow range of colors, such as when you’re creating subtle gradients for film effects or HDTV output.
Transitions between colors are smoother with less visible banding, and more detail is preserved than with 8-bpc color (though less than with 32-bpc color). You can import 16-bpc images, including those from Adobe Photoshop, and composite and color-correct footage in 16-bpc mode. Take advantage of 16-bpc color when performing most After Effects tasks, including layer adjustment, frame blending, 3D compositing, and Cineon file import. The Info panel displays 16-bpc color values with exact precision.

When rendering to output module depths of Trillions Of Colors, set the project to 16-bpc color depth to take advantage of the output file’s extra color precision.

**Choosing a project color depth**

To choose a project color depth, do one of the following:

- Choose File > Project Settings, and choose a color depth from the Color Depth menu.
- In the Project panel, Alt-click (Windows) or Option-click (Mac OS) the Project Color Depth button.

**Color management**

Color images can look different when viewed with different display devices and in different contexts. For example, an image displayed on a computer monitor may look different from the same image displayed on a video monitor or projected onto a movie screen. Colors shift because different devices use different methods to create color and produce different ranges of colors.

In After Effects, you can compensate for color output between different display devices by first calibrating and profiling your monitor and then specifying color profiles for use with the project. For in-depth information about color management, refer to Adobe Community Help.

**To calibrate and profile your monitor**

When you calibrate your monitor, you’re adjusting it so that it conforms to a known specification. After your monitor is calibrated, the profiling utility lets you save a color profile. The profile describes the color behavior of the monitor—what colors can be reproduced on the monitor and how the color values in an image must be converted so that colors are displayed accurately.

Before you calibrate and profile your monitor, make sure that your work environment provides a consistent light level and color temperature. For example, the color characteristics of sunlight change throughout the day and alter the way colors appear on your screen, so keep shades closed or work in a windowless room.
Make sure your monitor has been turned on for at least half an hour. This gives it sufficient time to warm up and produce more consistent output.

Make sure your monitor is displaying millions of colors or 24-bits-per-pixel or higher.

Remove colorful background patterns on your monitor desktop and set your desktop to display neutral grays. Busy patterns or bright colors surrounding a document interfere with accurate color perception.

Do one of the following to calibrate and profile your monitor:

In Windows, use the Adobe Gamma utility, located in the Control Panel.

Note: Don’t use Adobe Gamma to calibrate an LCD (flat panel) monitor—it doesn’t produce reliable results. Instead, use a hardware calibrator.

In Mac OS, use the Calibrate utility, located in the System Preferences/Displays/Color tab.

For best results, use third-party software and measuring devices. In general, using a measuring device such as a colorimeter along with software can create more accurate profiles because an instrument can measure the colors displayed on a monitor far more accurately than the human eye can.

Note: Monitor performance changes and declines over time; recalibrate and profile your monitor every month or so. If you find it difficult or impossible to calibrate your monitor to a standard, it may be too old and faded.

Most profiling software automatically assigns the new profile as the default monitor profile. For instructions on how to manually assign the monitor profile, refer to the Help system for your operating system

Questions

The following questions are not in the student’s Classroom in a Book.

1. Why should you preview your project on a video monitor, if possible?
2. When would you use the Color Range effect?

Answers

1. The gamma values between a computer monitor and a broadcast monitor vary greatly. What may look good on a computer screen may appear too bright and washed out on a broadcast monitor.

2. The Color Range effect keys out a specific range of colors. It’s especially useful when you need to key an area that was unevenly lit, where the color you need to key varies.
Lesson 11: Building and Animating a 3D Object

Lesson 11 is the first of a two-part project that covers all aspects of 3D animation in After Effects. Here is some additional useful information about 3D editing in After Effects.

Using third-party 3D files

Though After Effects can import some third-party files with depth information and interpret the z-axis information in those files, it cannot animate individual objects within those files. After Effects treats each composited third-party 3D file as a single layer. That layer, as a whole, can be given 3D attributes and treated like any After Effects 3D layer, but the objects contained within that 3D file cannot be manipulated individually.

To access the 3D depth information in these files, use the 3D Channel effects.

About z scale

Usually, scaling a layer's z axis has no effect on the layer because the layer itself has no depth. To add depth, you can change the position of the layer's anchor point or establish a parenting relationship with other layers. Once you add depth, scaling the layer's z scale value appears to change the layer's position.

How After Effects works with 3D image files

After Effects can import 3D image files saved in Softimage PIC, RLA, RPF, and Electric Image EI format. These 3D image files contain red, green, blue, and alpha (RGBA) channels, as well as auxiliary channels with optional information, such as z depth, object IDs, texture coordinates, and more.

You can import 3D objects from Adobe Photoshop Extended. Additionally, when you use the Vanishing Point feature in Photoshop Extended, you can choose File > Export For After Effects CS4 (.vpe) to save the results as a collection of PNG files (one for each plane) and a .vpe file that describes the geometry of the scene. After Effects uses the information in the .vpe file to re-create the scene as a composition containing a camera layer and one perspective-corrected 3D layer for each PNG file. Additionally, you can export one or more frames of a 3D model from Adobe Photoshop Extended as PSD files and then import them into After Effects.

With RLA and RPF files, all of the auxiliary channels are included in a single file. Softimage PIC files have a corresponding ZPIC file that contains the z-depth channel information. Although you can't import a ZPIC file, you can access the additional channel information as long as the ZPIC file is stored in the same folder as the imported PIC file.
Similarly, Electric Image ( EI) files can now have associated EIZ files with z-depth channel data. Just as with ZPIC files, you cannot import EIZ files into After Effects; instead, you simply store them in the same folder as the EI files. For information about creating EIZ files, see your Electric Image documentation.

After Effects can also import baked camera data, including focal length, film size, and transformation data, from Maya project files as a single composition or two compositions.

**To import RLA or RPF data into a camera layer**

After Effects imports camera data saved with RLA or RPF sequence files. That data is incorporated into a camera layer that After Effects creates in the Timeline panel. You can access the camera data of an imported RLA or RPF sequence and create a camera layer containing that data.

1. Place the imported sequence in the Timeline panel, and then select the sequence.
2. Choose Animation > Keyframe Assistant > RPF Camera Import.

Note: To create an RLA or RPF file with the camera data in 3D Studio Max, save your rendering in RPF format with Coverage, Z Depth, and Alpha Channels enabled.

**Questions**

The following questions are not in the student’s Classroom in a Book.

1. What is a guide layer, and how do you create one?
2. What does the Track Z Camera tool do?
3. What does the Orbit Camera tool do?

**Answers**

1. A guide layer appears on your screen as you edit the project, but is not rendered with the movie. To convert a layer to a guide layer, select it in the Timeline panel, and choose Layer > Guide Layer.

2. The Track Z Camera tool moves the camera long the z axis, so that you zoom in or out of a view.

3. The Orbit Camera tool rotates the current 3D view by moving the camera around the point of interest.
Lesson 12: Using 3D Effects

Lesson 12 is the second of a two-part project on using 3D animation in After Effects. It covers 3D effects and using lights and cameras.

Camera settings

You can set up cameras in After Effects to simulate the capabilities of real-world cameras. Use camera settings to configure the camera view to match the settings you use to record video footage or to look at the footage from a new perspective. You can change camera settings at any time by selecting the camera layer and choosing Layer > Camera Settings.

Name—Specifies the name of the camera. By default, After Effects assigns the name Camera 1 to the first camera you create in a composition, and all subsequent cameras are numbered in ascending order. If you delete a camera, and are still using the After Effects default naming convention, After Effects names the next camera you create with the lowest available number. You should choose distinctive names for multiple cameras to make it easier to distinguish them.

Preset—Specifies the type of camera settings you want to use. Cameras come with several presets. The presets are named according to focal lengths. Each preset is meant to represent the behavior of a 35mm camera with a lens of a certain focal length. Therefore, the preset also sets the Angle Of View, Zoom, Focus Distance, Focal Length, and Aperture values. The default preset is 50mm. You can also create a custom camera by specifying new values for any of the settings.

Zoom—Specifies the distance from the position of the camera to the image plane.

Angle Of View—Specifies the width of the scene captured in the image. The Focal Length, Film Size, and Zoom values determine the angle of view. A wider angle of view creates the same effect as a wide-angle lens.

Enable Depth Of Field—Applies custom variables to the Focus Distance, Aperture, F-Stop, and Blur Level settings. Using these variables, you can manipulate the depth of field to create more realistic camera-focusing effects. (The depth of field is the distance range within which the image is in focus. Images outside the distance range are blurred.)

Focus Distance—Specifies the distance from the camera’s position to the plane that is in perfect focus.

Lock To Zoom—Makes the Focus Distance value match the Zoom value.

Note: If you change the settings of the Zoom or Focus Distance options in the Timeline panel, the Focus Distance value becomes unlocked from the Zoom value. If you need to change the values and want the values to remain locked, then use the Camera Settings dialog box instead of the Timeline panel. Alternatively, you can add an expression to the Focus Distance property in the Timeline panel: Select the Focus
Distance property, and choose Animation > Add Expression; then drag the expression pick whip to the Zoom property.

Aperture—Specifies the size of the lens opening. The Aperture setting also affects the depth of field; increasing the aperture increases the depth of field blur. When you specify new values for Aperture, the values for F-Stop change dynamically to match it.

F-Stop—Represents the ratio of the focal length to aperture. Most cameras specify aperture size using the fstop measurement; thus, many photographers prefer to set the aperture size in f-stop units. When you specify new values for F-stop, the values for Aperture change dynamically to match it.

Blur Level—Controls the amount of depth-of-field blur in an image. A setting of 100% creates a natural blur as dictated by the camera settings. Lower values reduce the blur.

Film Size—Specifies the size of the exposed area of film, which is directly related to the composition size. When you specify new values for Film Size, the Zoom value changes to match the perspective of a real camera.

Focal Length—Specifies the distance from the film plane to the camera lens. In After Effects, the camera’s position represents the center of the lens. When you specify new values for Focal Length, the Zoom value changes to match the perspective of a real camera. In addition, the Preset, Angle of View, and Aperture values change accordingly.

Units—Specifies the units of measurement in which the camera setting values are expressed.

Measure Film Size—Specifies the dimensions used to depict the film size. About 3D previews You can speed up preview time for 3D layers by enabling Wireframe mode on the Fast Previews menu or by using Draft 3D mode. These preview modes reduce the amount of data displayed in a 3D layer, so the screen redraws faster. You can also use OpenGL for faster previews of 3D layers.

Questions

The following questions are not in the student’s Classroom in a Book.

1. Which layers are affected by an adjustment layer?
2. How can you change the In point for a layer?
3. What do the Material Options properties determine?

Answers

1. An adjustment layer affects all the layers beneath it in the layer stack.
2 Move to the time for the new In point in the time ruler, then select the layer, and press the [ (left bracket) key to set the In point for the layer.

3 The Material Options properties determine how 3D layers interact with lights and shadows.

Lesson 13: Advanced Editing Techniques

Lesson 13 covers some of the advanced editing techniques available in After Effects CS4. However, it only touches on one important feature: support for HDR color. Here is some additional information to supplement the lesson.

Working with natural light in HDR

It’s a common yet mistaken assumption that the only After Effects users who have any business using 32-bit mode are artists working on big-budget blockbuster films. The reality is that anyone using After Effects CS4 can benefit from the 32-bit HDR pipeline. Not only does 32-bit mode mean more colors and more accuracy than the 8-bit or 16-bit modes, it also means that the behavior of light and color in After Effects is remarkably similar to the behavior in the natural world. 32-pbc images preserve the full range of light data, and the same principals apply whether or not you’re starting with a 32-bit source.

Working with 32-bit input

The most obvious advantage for 32-bit support is that it allows you to work with 32-bit source images. Such images can store light values beyond what your monitor displays as full white. These light values are useful when you want to manipulate the light, such as bringing the light values of your scene down. In 8-bit and 16-bit images, really bright white values are clipped to the color space’s highest value; bringing these clipped colors down turns them gray. However, 32-bit images, which retain the original (non-clipped) values, behave much more like natural light, even through several color corrections.

Taking advantage of HDR without 32-bit source

Even if you don’t have HDR source material available, the ability to work with values that fall outside the range of your monitor can still transform your work.

Going further with HDR

A separate, somewhat more complicated benefit of HDR is the Linear Blending option. To set this option, choose File > Project Settings. Linear Blending changes the way that After Effects works internally with gamma; it combines light levels in a way that’s similar to how they’re combined in the real world. However, to use this
option properly, the source images and the working space of your project must be converted to support an altered gamma. For more information, see After Effects Help.

**What is happening in 32-bit HDR mode?**

32 bpc can calculate and hold values even above the brightest value that your monitor can display. (Monitors display brightness at 1.0 on a decimal scale, or at 255 in 8 bpc color.) But what use are these color values if your monitor can’t display them? Because the bright values aren’t clipped, they’re more realistic. The real world contains brightness values far beyond what your monitor can display. And now you can capture a little bit of that reality in After Effects.

**Questions**

The following question is not in the student’s Classroom in a Book.

1. In the motion tracker, what are the feature and search regions?

**Answers**

1. The feature region identifies the distinctive feature you’re tracking. The search region defines the area within the tracker looks for the feature.

**Lesson 14: Rendering and Outputting**

Lesson 14 covers the topics of rendering and outputting. Following is some additional information about DV and HD output.

**Getting video out of your computer**

Once you have finished assembling and editing clips, it’s time to get your final production out of your computer and on its way to distribution. These days, creative professionals are expected to deliver video that can be used in multiple media. Broadcast and film professionals alike are now creating web-based work, while web designers may need to create animations that are output in video formats. DVDs have also become an extremely popular way to combine high-quality video and audio content with menu-driven interactivity. To address this growing need for flexibility, After Effects offers a wide range of options that enable you to produce high-quality deliverables for any medium.

The project you edited in After Effects does not actually contain the material from which it was pieced together. Rather, it references your source files. Before export, make sure that the project is ready to output at the quality you require. For example,
replace any offline files with high-resolution files suitable for final export. To get your edited program out of your computer in one piece, you can:

- Record the timeline to physical media including videotape or motion picture film, assuming that you have the proper hardware for video or film transfer, or have access to a service provider that offers the appropriate equipment and services.
- Export a video file for viewing from a hard disk, removable cartridge, CD, DVD, or the web.
- Export portions of your timeline as clips.
- Capture stills or sequences of stills.

**Good housekeeping**

In professional production environments, after a video project has been completed, it is typically cleared from the editing system to make room for new work.

Because the multigigabyte storage media that would be needed is costly, and the process of uploading can be very time-consuming, projects and source files are not usually saved in their entirety. If you do want to save your entire project, you can trim unused frames from some or all of your source clips and remove unused clips in their entirety from Project Bins.

Typically, however, a digital master file is exported and archived, the original raw footage is stored on tapes, and an Edit Decision List (EDL) is saved. If the project needs to be revised later, the master file can often be edited. For more extensive repurposing, the EDL can be used to recapture the necessary clips from the original tapes. Files used to develop titles, graphics, and animations, as well as portions of the project that have undergone extreme manipulation to achieve special effects can also be archived.

Today, more and more production professionals are exporting Advanced Authoring Format (AAF) files rather than EDLs to archive or exchange projects. AAF is a widely supported industry standard for high-end exchange of data, such as the information necessary to transfer a video project from one platform to another. An AAF file helps you preserve as much of the project’s integrity as possible when you transfer it to another system. However, not all elements of a project can be successfully transferred using AAF. Also, the application you use to open the AAF file may not support all features. In general, an AAF file dependably translates editing data and commonly used transitions, such as cross-dissolves and wipes, but does not support effects (filters) or audio fade and pan information, including audio transitions.
Exporting to videotape

You can record your edited program onto videotape directly from your computer. This process can be as simple as playing the timeline and recording on a connected device. When you record standard DV video back to standard DV tape, all that is required is an IEEE 1394 connection. However, if you plan to record DV audio and video to an analog format, such as VHS tape, you’ll need a device that can convert DV to analog using the connectors supported by your analog video recorder. Most DV cameras and all DV video tape recorders are capable of this conversion; some DV cameras require you to record the video to DV tape, then copy the DV tape to the analog video recorder.

Exporting to digital files

You can prepare variations of a program or clip for a variety of different uses. For example, you can create separate versions for DVD distribution and web viewing. Adobe Premiere Pro and After Effects both offer built-in support for exporting the following digital video file formats: Microsoft AVI, Animated GIF, QuickTime, MPEG-1 and -2, as well RealMedia and Windows Media files for the web. After Effects also exports SWF files. Several audio-only formats and a variety of still-image and sequence formats are also supported by both applications. Additional file formats may be available if provided with your video capture card or if you add third-party plug-in software.

To start the export process, enter settings that determine the properties of the final file. These settings may include the data rate for playback, the color depth, the frame size and frame rate, the quality, and what type of compression method, or codec, to use. Choosing compression settings is a balancing act that varies depending on the type of video material, the target delivery format, and the intended audience. Often, you discover the optimal compression settings through trial and error. Prior to distribution, you should always test the files you export on the type of platform or equipment you expect your audience to use.

Preparing projects for DVD

Adobe Encore provides creative authoring for professional DVD production in Adobe Creative Suite 4 Production Premium. To learn more about DVD production and Adobe Encore, take a look at the Adobe DVD Primer on the Adobe website at www.adobe.com/motion/primers.html.

Working with high-definition video?

High definition (HD) simply means more than standard definition (SD). The highest resolution SD format is PAL, with 576 lines. Thus, almost any video frame with a vertical size greater than 576 lines is considered HD. If a final video is destined for
playback on a computer monitor or a custom device, you can create your own frame dimensions. However, most HD video is either 1920 x 1080 or 1280 x 720, with a 16:9 aspect ratio.

The myth is that HD is very expensive and difficult to author. The reality is that HD has become cheaper and easier to use than standard definition (SD) was only a few years ago. Today, you can build a complete entry-level HD production system, including storage, software, and camera, for under U.S.$10,000. Higher-end and uncompressed HD editing systems can be much more expensive, but they are also declining in price as more options enter the market.

Post-production for HD is similar to post-production for SD. One difference is that with HD you’re dealing with significantly more data and consequently increasing the load on the CPU and video card. However, if you have worked in Adobe Premiere Pro and After Effects for SD, you can use the same tools and enjoy the same workflow in HD.

A complete HD post-production suite can include a workstation for acquisition and editing, and another for scene-by-scene color correction and effects. With two workstations, an editor and colorist can work on different parts of the production at the same time. One or more videotape playback decks may be located near the editing workstation for acquisition, depending on the formats used in production. To ensure that high quality is maintained throughout the process, a suite should include at least one high-resolution monitor. High performance computers and a RAID array are used for fast processing, and reliable mass storage.

**Choosing an HD monitor**

HD video monitors can be quite expensive, especially models with an HD-SDI input. However, a true professional-grade HD video monitor is essential for any producer working with HD destined for broadcast.

For some tasks, a computer monitor is a less expensive way to view the actual HD output, especially for projects that use progressive scanning. However, computer monitors use a different color temperature from true video monitors, so it’s beneficial to use a video monitor to ensure that you see the true representation of the video as it will be delivered. A number of vendors offer HD-SDI to Digital Video Interface (DVI) converters to drive computer monitors. Because computer monitors are natively progressive, these converters are not a good solution for natively interlaced projects in Adobe Premiere Pro. (Conversion isn’t an issue with After Effects because the preview is progressive.)

Another advantage of using broadcast monitors is calibration. These monitors provide features that easily set them to the canonical 709 color space of HD. While this setting is possible with a computer monitor as well, correctly setting the calibration can be difficult or inaccurate. Even systems with a colorimeter for automatic color configuration don’t always include 709 presets.
HD can be slow!

The additional throughout and processing power required for HD production often exceeds the capabilities of even the fastest computers. A computer that handles SD video simply cannot be expected to provide the same performance with HD, without a little help.

The good news is that modern tools give you a number of techniques to get around these limitations.

Specifying rendering quality and compression

After Effects has several rendering modes. For final output, you should always use the highest quality mode, especially when your final product is to be compressed. High-quality mode can increase compression efficiency, resulting in fewer image artifacts.

Rendering in After Effects

16-bit per channel (bpc) rendering is available in After Effects CS4. The 16-bpc rendering process doubles the number of bits available for each channel, which greatly increases the precision of the video rendering. That extra precision is quite useful, especially in reducing the appearance of banding in an image with subtle gradients. However, such precision has a cost. 16-bpc rendering takes twice the time and requires twice as much RAM as 8-bpc rendering.

16-bit per channel rendering is adequate for most video, and After Effects also features 32-bit rendering for high dynamic range (HDR) footage. Floating-point numeric values allow the same number of bits to describe a much wider range of values than fixed-point values; 32-bits per channel allow for much greater precision than do 8- or 16-bits per channel. This flexibility enables you to work with images that have a very wide range of brightness levels, more like the range of levels found in the real world.

Rendering in 16 or 32 bpc isn't necessary when encoding to an 8-bpc delivery format like Windows Media or MPEG-2. It does, however, provide a very welcome quality boost when going back out to 10-bpc formats like D5.

Questions

The following questions are not in the student’s Classroom in a Book.

1. What is OpenGL?
2. Why would you need pixel aspect ratio correction?
Answers

1 OpenGL is a set of standards for high-performance processing of 2D and 3D graphics. For After Effects users, OpenGL provides fast, high-quality rendering for previews and final output by moving rendering from the CPU to the OpenGL hardware (GPU).

2 If you’re viewing a composition with a nonsquare pixel aspect ratio on a computer monitor, which displays images using square pixels, the image may appear stretched. Pixel aspect ratio correction squeezes the view slightly to display the image as it will appear on a video monitor.