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Preparing the classroom 
To provide the Adobe Premiere Pro CS6 student with the best experience possible, we recommend 
that the college lab or classroom provide the following: 

‣ The appropriate hardware and software described in the following sections 
‣ All software and course materials installed, configured, and tested at least one day prior to the 

start of the class  
‣ A conducive learning environment including projector, whiteboards, and ample space for the 

students 
 
 

Classroom requirements 
‣ A computer workstation for each student enrolled in the class that meets the recommended 

system requirements available at Adobe.com 
(http://www.adobe.com/products/creativesuite/production/tech-specs.html).  The machines must 
have at least 6GB of RAM installed (12GB is highly recommended). 

‣ The student workstations should offer headphones for audio monitoring. Students can also be 
offered the opportunity to use their own. 

‣ A computer workstation for the instructor that meets the recommended system requirements for 
Adobe Premiere Pro CS6 available at Adobe.com. If possible, all workstations should have a 
supported CUDA or Open GL graphics card.  Workstations should have amplified speakers.  The 
teacher’s station should have Internet access to show online resources and administer updates as 
needed. The instructor machines must have at least 8GB of RAM installed (12GB is highly 
recommended). 

‣ A projector capable of showing a signal of at least 1280 x 900 pixels with a rating of at least 
2000 lumens.  A screen of at least 6 feet across should also be available. 

‣ A whiteboard with dry-erase markers in clear view of the students. 
‣ A flip chart with paper and markers should also be available. 
‣ Lighting in the room must be able to be dimmed to improve the readability on-screen. 
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Classroom media and student machines 
Each student enrolled in the class should purchase a copy of An Editor's Guide to Adobe Premiere 
Pro, Second Edition. This book is sold by Peachpit to authorized training centers and campus 
bookstores. For Adobe authorized training centers in the United States, please contact 
cindy.webster@pearson.com. For education customers in the U.S., please contact your local Pearson 
representative (www.pearsonhighered.com/ educator) or call 800-922-0579. For all International 
orders, contact international@pearson.com. 

 
For each course, student machines should be reset to a refreshed state.  This includes reset preferences 
and workspaces, as well as new copies of project files.  System utilities such as Deep Freeze, 
Sandboxie, or Returnil can be used to streamline this process. A backup image of project files and 
software installers should be kept readily available to restore student machines when necessary. 

Students may need their own media hard drive.  Please ensure that the connection and disk speeds are 
appropriate for digital video. Student machines should be reset to a refreshed state at the start of each 
session.  A backup image of project files and software installers should be kept readily available to 
restore student machines when necessary. 

 

Instructional approach 
Your goal as an instructor is to provide a nurturing environment that respects the past experiences of 
the students while ensuring that all students can learn and grow. Students may need positive 
reinforcement and additional examples to better understand and use the application. 

‣ At the start of each module, review the objectives and time suggestions for the module. 
‣ During each module, enhance the course with your relevant, real-world experiences. 
‣ Ask questions during the module to gauge comprehension. 
‣ After each module, use the review questions so students can self-assess their understanding of the 

material. These questions are a useful way to prepare for the Adobe certification exam, but they 
are not questions that appear on an exam. 

‣ Please endeavor to use proper Adobe terminology to describe components of the software.  This 
will better prepare students for certification and enable them to use proper language when 
searching the Web or additional resources. 

‣ Time management is critical so that you can provide balanced coverage of the lessons in the 
Adobe curriculum. The class is structured with recommended timings to assist you in covering all 
content areas. Please do not drop lesson files from the Adobe curriculum. 
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Additional resources 
Additional resources are identified within modules so you can expand the educational offerings to the 
students. Please suggest that your students choose these titles in the Creative Edge library or their 
favorite book retailer: 

‣ Recommended reading list 
• Adobe Premiere Pro CS6: Learn by Video  
• Adobe Premiere Pro CS6 Classroom in a Book 
• Adobe After Effects CS6 Classroom in a Book 
• Adobe Photoshop CS6 Classroom in a Book 
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Day One* 
 

Module 1: The Adobe workflow       30 mins 
• This Module uses Chapter 1 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Meet Adobe Premiere Pro (p. 2) 

• Interface philosophy (p. 2) 
• Interface tour (p. 3) 
• Using workspaces (p. 12) 

 
‣ Arranging frames and panels onscreen (p. 13) 
 
‣ Creative Suite Production Premium (p. 14) 

• Adobe After Effects (p. 14) 
• Adobe Photoshop Extended (p. 15) 
• Adobe Audition (p. 15) 
• Adobe Media Encoder (p. 15) 
• Adobe Encore (p. 15) 
• Adobe Bridge (p. 16) 
• Adobe Prelude (p. 16) 
• Adobe SpeedGrade (p. 16) 

 
‣ Editing workflow (p. 16) 

• Native editing workflow (p. 16) 
• Transcoded workflow (p. 18) 
• Captured workflow (p. 18) 

 
‣ Operating system requirements (64-bit) [Win/Mac] (http://www.adobe.com/go/64bit) 

 

*Note that this Teacherʼs Guide is used for a 2-day training course (level 
250 Adobe certification) but topics can be taught at other institutions using 
additional days of instruction.
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Review Questions 
 
Q:  How are the Program Monitor and Timeline panels related? 
A:  They both show the arrangement of clips in a timeline (in different ways). The playhead will stay 

ganged (dragging in one will move the playhead in both places). 
 
Q:  How do you add a clip from the Media Browser panel to a project? 
A:  Drag the clip from the Media Browser to a bin or the Project panel. 
 
Q:  Name one way to switch workspaces. 
A:  Any of the following methods work: 

• Choose Window > Workspace and then select from the menu.  
• Click the Workspace menu in the upper-right corner of the Application frame.  
• Press Option+Shift+1 (Alt+Shift+1) for the first workspace. You can use numbers for additional 

workspaces (they are numbered in alphanumeric order). 
 
Q:  Which panel allows for a visual list of your recent actions (and the ability to go back)? 
A:  The History panel allows for up to 32 levels of undo in Adobe Premiere Pro.
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Module 2: Configuring your nonlinear editor  30 mins 
• This module uses Chapter 2 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Please note it is not necessary to cover preferences in detail. Rather, revisit and customize 

preferences in context of lessons throughout the course. 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Notable preferences (p. 20) 

• Brightness (p. 20) 
• Play Audio While Scrubbing (p. 21) 
• Audio Output Mapping (p. 21) 
• Media Cache Files (p. 21) 
• Memory Allocation (p. 22) 
• Default Scale to Frame Size (p. 22) 
• Trim (p. 23) 
• Roll/Ripple Trims (p. 23) 
• Player Settings (p. 23) 

 
‣ Keyboard shortcuts (p. 24) 

• The default keyboard shortcuts (p. 24) 
• Recommended remapping for Final Cut Pro 7 editors (p. 25) 
• Recommended remapping for Avid Media Composer editors (p. 26) 
• Backing up and moving shortcuts (p. 27) 

 
‣ Customizing Source/Program buttons (p. 30) 
 
‣ Mercury Playback Engine performance (p. 31) 

•  Real-time workflow (p. 31) 
• Measuring system load (p. 33) 

 
‣ Monitoring and capture solutions (p.34) 

• Input/Output cards (p.34) 
• Mercury transmit (p.34) 
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Review Questions 
Q:  How do you change the shading of the user interface for Adobe Premiere Pro? 
A:  Use the Brightness preference (located in the Appearance category). 
 
Q:  When working with highly compressed formats, such as HDV or MPEG, how does Adobe 

Premiere Pro improve playback? 
A:  Media cache files are created. 
 
Q:  Which four applications are managed jointly by the Memory preferences? 
A:  Adobe Premiere Pro, Adobe After Effects, Adobe Encore, and Adobe Media Encoder. 
 
Q:  How do you resize oversized stills and footage automatically to match your sequence frame size? 
A:  Use the “Default scale to frame size” setting. 
 
Q:  How do you maximize an individual panel? 
A:  Place the mouse pointer over the desired panel, and then press the grave accent (`) key.
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Module 3: Essential editing skills        60 mins 
• This module uses Chapter 6 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• At this time, skip Chapters 3–5 in the book. You want the students to get hands-on and start to 

enjoy editing video.  You’ll loop back to the other material later. 
• Sidebar information in the chapters (orange boxes) can be used as appropriate. 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
 
‣ Using the Source Monitor (p. 106) 

• Loading a clip (p. 106) 
• Loading multiple clips (p. 107) 
• Source and Program Monitor controls (p. 108) 
• Playback resolution (p. 108) 
• Paused resolution (p. 109) 
• Viewing fields (p. 110) 
• Change magnification (p.110) 
• Changing frames in the Program or Source Monitor (p. 111) 

 
‣ Navigating the Timeline (p. 112) 

• Opening a sequence in a Timeline Panel (p. 112) 
• Targeting tracks (p. 112) 
• In and Out points (p. 113) 

 
‣ Using markers (p. 114) 

• Adding markers to Clips (p. 114) 
• Adding markers to Sequences (p. 115) 
• Syncing with markers (p. 117) 
• Interactive markers (optional) 

 
‣ Essential editing commands (p. 121) 

• Overwrite editing (p. 121) 
• Insert editing (p. 122) 
• Three-point editing (p. 123) 
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Review Questions 
Q:  How do you change the display method that the Current Time Display uses? 
A:  Command-click (Ctrl-click) the numbers to switch the unit of measurement. 
 
Q:  How do you reduce the amount of processing power needed to play back a video clip? 
A:  Right-click the image in the Source Monitor or Program Monitor and choose Playback 

Resolution. You can then set the quality to a lower value. 
 
Q:  Which three keys are most useful for controlling playback from the keyboard? 
A:  You can use J-K-L to Play Backward, Pause, and Play Forward (respectively). 
 
Q:  How do you remove an In point using your mouse or trackpad? 
A:  If you Option-click (Alt-click) the In button, you’ll clear the In or Out points. 
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Module 4: Setting up a project        30 mins 
• This module uses Chapter 3 in An Editor’s Guide to Adobe Premiere Pro, Second Edition.  
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Using the new Project Panel (p. 36) 

• Video rendering and playback (p. 36) 
• Video/Audio display format (p. 37) 
• Capture format settings (p. 37) 
• Project files (p. 38) 
• Scratch disks (p. 39) 

 
‣ Creating a sequence (p. 40) 

• Choosing the correct preset (p. 40) 
• Understanding the makeup of sequence presets (p. 42) 
• Creating custom sequence settings (p. 43) 
• Setting sequence start time (p. 49) 
• Creating your project template (p. 49) 

 
‣ Modifying an existing project’s settings (p. 51) 

• General tab (p. 51) 
• Scratch disks (p. 51) 

 
‣ Importing existing projects (p. 52) 

• Importing an EDL (p. 52) (demo only) 
• Importing Final Cut Pro projects (p. 53) (demo only) 
• Importing Avid projects (p. 54) (demo only) 
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Review Questions 
Q:  How do you change the method that Adobe Premiere Pro uses to count frames for video and 

audio? 
A:  The Video/Audio Display Format in the New Project panel lets you choose between Timecode, 

Frames, Feet + Frames 16mm, or Feet + Frames 35mm. 
 
Q:  Which tape devices can Adobe Premiere Pro control natively? 
A:  Those devices with the DV or HDV spec can be used without the need for a third-party capture 

card. 
 
Q:  How do you create a new sequence based on a selected footage item? 
A:  You can right-click any clip and choose New Sequence from Clip, building a sequence that 

matches your footage. 
 
Q:  Which setting determines where media files and captured footage are stored? 
A:  Click the Scratch Disks tab and use the settings in the Project Settings dialog (Project > Project 

Settings). 
 
Q:  Name a way Adobe Premiere Pro can import project information from another project or editing 

system. 
A:  Adobe Premiere Pro can import an EDL (Edit Decision List), a Batch List, a Final Cut Pro XML 

file, and an Avid AAF project.
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Module 5: Organizing media         45 mins 
• This module uses Chapter 5 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Understanding the Project panel (p. 84) 
 
‣ Working with bins (p. 85) 

• Creating bins (p .85) 
• Opening bins (p. 85) 
• Recommended standard bins (p. 86) 

 
‣ Customizing bins and clip views (p. 87) 

• Changing views (p. 87) 
 
‣ Searching for clips (p. 89) 

• Filtering your view (p. 89) 
• Using the Find command (p. 90) 
• Viewing thumbnails (p. 91) 
• Assigning a label color (p. 91) 

 
‣ Using subclips (p. 92) 

• Creating  a subclip (p. 92) 
• When to subclip (p.  93) 
• The logic of subclips (p. 93) 

 
‣  Get organized with metadata (p. 94) 

• Viewing metadata (p. 94) 
• Customizing headings in the metadata display (p. 95) 
• Saving schema (p. 97) 
• Using the Metadata panel (p. 97) 

 
‣ Organizing clips with Speech Analysis (p. 100) 

• Analyzing a clip (p. 100) 
•  Improving accuracy with a transcript (p. 101) 
•  Improving accuracy with a script and Adobe Story (p. 103) 
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Review Questions 
Q:  How do you reduce the number of items shown in the Project panel based on a filter? 
A:  Enter a keyword or text string into the Find box to filter the visible results. 
 
Q:  Which two views do bins support? 
A:  You can use List view to view details about clips or Icon view to view clips with a larger 

thumbnail. 
 
Q:  How do you select multiple items in your Project panel based on their label? 
A:  Choose Edit > Label > Select Label Group to select all of the similar items that are visible in 

the Project panel. 
 
Q:  How do you change the duration of a subclip to extend its In and Out points? 
A:  To modify a subclip, select the subclip and choose Clip > Edit Subclip. If a subclip is on the 

Timeline, you can’t make it shorter than the original subclip. 
 
Q:  What’s the best way to improve the accuracy of the Speech transcription command? 
A:  Using the Reference Script option, you can attach a transcript or script to the analysis. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
LUNCH BREAK 

MORNING REVIEW       15 mins 
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Module 6: Additional editing skills       60 mins 
• This module uses Chapter 7 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Four-point editing (p. 126) 

• Editing ehoices with four-point edits (p. 126) 
• Making a four-point edit (p. 127) 

 
‣ Retiming clips (p. 129) 

• Changing the speed/duration of a clip (p. 129) 
• Changing speed and duration with the Rate Stretch tool (p. 130) 
• Changing speed and duration with Time Remapping (p. 130) 
• Removing the Time Remapping effect (p. 132) 

 
‣ Replacing clips (p. 133) 

• Replacement techniques (p. 133) 
• Making a Replace edit (p. 133) 
• Replacing footage in a project (p. 136) 

 
‣ Time-saving editing techniques (p. 136) 

• Storyboard editing (p. 136) 
• Editing with markers (p. 139) 
• Nested sequences (p. 140) 
• Find gaps in sequences and tracks (p. 142) 
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Review Questions 
Q:  How do you access the Fit Clip dialog? 
A:  When four points are defined (two in the Source Monitor panel and two in the Program Monitor 

or Timeline panel), the dialog will open when you click the Insert or Overwrite (Overlay) button. 
 
Q:  Name the methods available to retime a clip in Adobe Premiere Pro. 
A:  You can use the Speed/Duration command, the Rate Stretch tool, or the Time Remapping 

command. 
 
Q:  How do you replace all uses of a clip in a project at once? 
A:  Select a clip, and then choose Clip > Replace Footage. Navigate to the new clip and click Select. 
 
Q:  How do you apply multiple effects and transformations to a range of clips? 
A:  Select all of the clips in the Timeline and choose Clip > Nest. 
 
Q:  How do you detect gaps in between clips in a sequence? 
A:  Choose Sequence > Go To Gap, and then select Next in Sequence or Previous in Sequence.
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Module 7: Timeline operations        45 mins 
• This module uses Chapter 8 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed below. 
 
‣ Selecting clips (p. 144) 

• Selecting a clip (p. 144) 
• Selecting a range of clips (p. 144) 
• Selecting all the clips on a track (p. 145) 
• Selecting noncontiguous clips (p. 145) 
• Selecting audio or video only (p. 146) 
• Splitting a clip (p. 146) 
• Linking & unlinking clips (p. 147) 

 
‣ Moving clips (p. 148) 

• Dragging clips (p. 148) 
• Rearranging clips in a sequence (p. 149) 
• Using the clipboard (p. 150) 

 
‣ Extracting and deleting segments (p. 152) 

• Lift (p. 152) 
• Extract (p. 153) 
• Delete & Ripple Delete (p. 154) 
• Disabling a clip (p. 156) 

 
‣ Adding transitions (p. 156) 

• Edit points and handles (p. 156) 
• Adding video transitions (p. 158) 
• Applying audio transitions (p. 162) 
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Review Questions 
Q:  Which tool can be used to select all the clips in a track? 
A:  The Track Select tool (A) selects all the clips on a single track that are forward of the click 

point. 
 
Q:  Which tool can be used to split a clip? 
A:  You can use the Razor tool (C) to split a single or linked clip. Wherever you click on the clip will 

be its split point. To split only the audio or video portion of a linked clip, Option-click (Alt-
click) with the Razor tool.  

 
Q:  Which command places a selection on the clipboard and removes it from the Timeline (leaving 

no gap where the selected frames previously were located)? 
A:  Use the Extract command. 
 
Q:  Which command removes a clip from the Timeline and leaves no gap where the selected frames 

previously were located? 
A:  Use the Ripple Delete command. 
 
Q:  How do you search the Effects panel? 
A:  Enter the name or keyword into the search field of the Effects panel to locate an effect by name 

or open a folder of presets.
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Module 8: The power is in the trim       90 mins 
• This lesson uses Chapter 9 in An Editor’s Guide to Adobe Premiere Pro, Second Edition.. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Basic trimming (p. 166) 

• Trim in Source Monitor (p. 166) 
• Basic trim in a sequence (p. 166) 

 
‣ Rippling edits (p.168) 

• Rippling edits with the Selection and Ripple Edit tools (p. 168) 
 
‣ Rolling edits (p. 172) 

• Rolling edits with the Selection tool and Rolling Edit tool (p. 172) 
 
‣ Trimming in the Program Monitor (p. 173) 

• Launching Trim mode (p. 174) 
• Making Ripple trims using the Trim mode (p. 174) 
• Making Rolling trims using the Trim mode (p. 176) 

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                
‣ Making split edits (p. 176) 
 
‣ Slipping edits (p. 178) 

• Slipping an edit in the Source Monitor (p. 178) 
• Slipping on a sequence (p. 179) 

 
‣ Sliding edits (p. 180) 

• Using the Slide tool (p. 180) 
• Sliding with the keyboard (p. 181) 

 
‣ Maintaining (and breaking) sync (p. 182) 

• Linking and unlinking audio and video (p. 182) 
• Moving and slipping clips into sync (p. 182) 
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Review Questions 
Q:  How do you trim a clip within the Source Monitor? 
A:  You can mark new In and Out points in the Source Panel monitor. You can also drag the In and 

Out points to reposition them. 
 
Q:  Which command is used to trim in conjunction with the playhead? 
A:  Choose Sequence > Extend Previous Edit to Playhead (E) or Sequence > Extend Next Edit to 

Playhead (Shift+E). 
 
Q:  Which tool lets you affect both points (Out and In) on either side of an edit? 
A:  Use the Rolling Edit tool. 
 
Q:  Which panel gives you visual controls for most of the trimming commands? 
A:  The Trim Monitor panel is a useful way to adjust clips in a sequence. 
 
Q:  If the audio and video of a clip fall out of sync in a Timeline, which two options can you choose 

to correct it? 
A:  You can right-click on one of the items and choose “Move clips into sync” or “Slip clips into 

sync.” 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Elapsed Time         3.5 hours 
 

End of Day 1 
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Day Two 
Recap Day One           10 mins 
• Answer any questions from the day one lessons. 
• No presentation needed. 
 

Module 9: Audio mixing and repair       60 mins 
• This module uses Chapter 10 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Setting up the interface to work with audio (p. 186) 

• The audio workspace (p. 186) 
• Master track output (p. 187) 
• Monitoring audio levels with the Audio Mixer (p. 188) 

 

‣ Adjusting audio levels on a sequence (p. 189) 
• Showing audio waveforms (p. 189) 
• Adjusting overall clip levels (p. 190) 
• Keyframing clip volume changes (p. 190) 
• Smoothing volume between clip keyframes (p. 191) 
• Track keyframes (p. 192) 

 

‣ Using the Audio Mixer (p. 193) 
• Overview of the Audio Mixer (p. 193) 
• Understanding Automation modes (p. 197) 
• Submixes and bussing (p. 199) 

 

‣ Routing with adaptive tracks (p. 201) 
 

‣ Using audio effects (p. 203) 
• Two ways of adding audio effects (p. 203) 

 

‣ Working with Adobe Audition (p. 204) (optional – demo only) 
• Sending audio from Adobe Premiere Pro to Adobe Audition (p. 205) 
• Noise reduction (p. 206) 
• Amplitude reduction (p. 209) 
• Getting audio back to Adobe Premiere Pro (p. 209) 

 
 
 
 



 

August 8, 2012  22 

Review Questions 
Q:  How do you adjust the output volume for all tracks? 
A:  Adjust the volume for the master track. 
 
Q:  How do you add keyframes to adjust volume? 
A:  Use the Pen tool to add keyframes to the audio track, and then adjust the keyframes up or down 

to change the volume. 
 
Q:  How do you modify the Audio Mixer to make it easier to know how a slider affects tracks? 
A:  At the top of each channel strip is a text box for the name of the track. The name defaults to 

the Audio 1, 2, 3 naming structure. Click in this box to give the track a custom name.  
 
Q:  How do you apply an audio effect to all the clips in a track? 
A:  By using the effect inserts in the Audio Mixer, you can apply audio effects at the track level.  
 
Q:  If you’ve sent an entire sequence to Audition, how do you get the updated Audition sequence back 

to Adobe Premiere Pro?  
A:  Choose Multitrack > Export to Adobe Premiere Pro.
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Module 10: Color correction         60 mins 
• This module uses Chapter 11 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only  the headings listed here. 
 
‣ Using video scopes (p. 212) 

• Accessing scopes and the color correction workspace (p. 212) 
• Scope essentials (p. 213) 
• More about the Reference Monitor (p. 218) 

 
‣ Primary color corrections (p. 218) 

• Exposure problems (p. 219) 
• Adobe Premiere Pro effects to fix exposure (p. 220) 
• Fixing underexposed footage (p. 222) 
• Fixing overexposed footage (p. 223) 
• Fixing color casts (p. 224) 
• Adobe Premiere Pro effects to fix color (p. 225) 
• Fixing (exposure) contrast first (p. 227) 
• Tackling color (p. 227) 

 
‣ Secondary color corrections (time permitting) (p. 229) 

• Adobe Premiere Pro effects for secondary color corrections (p. 229) 
• Using a secondary correction to fix skin tone (p. 230) 

 
‣ Using Adobe SpeedGrade (p. 233) (optional based on time)  

• Importing (p. 233) 
• Using Scene Cut Detection (p. 234) 
• Sending to SpeedGrade (p. 234) 
• Conforming a sequence with an EDL (p. 234) 

 
‣ Using After Effects and Photoshop for correction (demo only) (p. 234) 

• Sending a clip to After Effects (p. 234) 
• Correcting a clip with Photoshop (p. 235) 
• Open a clip with Photoshop Extended and apply an adjustment layer (demo only) 
• Convert clip to a Smart Object before applying filters (demo only) 
• View videos # 52–54 for additional technical details 
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Review Questions 
Q:  How do you enable a scope in the Program Monitor or Source Monitor panel?  
A:  Click the Output button at the bottom right of the Source Monitor. Choose an appropriate scope 

or combination of scopes. 
 
Q:  Which scope measures hue and saturation for a particular clip?  
A:  The Vectorscope is most often used to analyze overall color casts and saturation in a clip. 
 
Q:  Name the process of correcting only part of an image. 
A:  It is called secondary color correction. 
 
Q:  How do you send a clip from an Adobe Premiere Pro Timeline directly to After Effects?  
A:  Select the clip in the Timeline and choose File > Adobe Dynamic Link > Replace with After 

Effects Composition. 
 
Q:  If you want to open a video clip directly in Photoshop, which version do you need? 
A:  Adobe Photoshop Extended can open QuickTime movie files. 
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Module 11: Essential effects         60 mins 
• This module uses Chapter 12 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ The effects workflow (p. 238) 
 
‣ Applying effects in Adobe Premiere Pro (p. 238) 

• Fixed effects (p. 238) 
• The Effects browser (p. 238) 
• Applying effects in Adobe Premiere Pro (p. 240) 
• Using adjustment layers in Adobe Premiere Pro (p. 240) 
• Using effects presets in Adobe Premiere Pro (p. 241) 
• Saving effect presets in Adobe Premiere Pro (p. 242) 
• Removing effects in Adobe Premiere Pro (p. 243) 

 
‣ Applying effects in After Effects (brief overview) (p. 243)  

(demo or hands-on - time permitting) 
• Dynamic Link revisited (p. 244) 
• Browsing After Effects animation presets (p. 245) 
• Applying effects and animation presets in After Effects (p. 246) 
• Saving After Effects presets (p. 247) 
• Removing effects in After Effects (p. 247) 

 
‣ Understanding keyframes (p. 247) 

• Adding keyframes (p. 247) 
• Keyframe interpolation (p. 248) 

 
‣ Selected effects (p 249) 

• Image stabilization & rolling shutter reduction (p. 250) 
• Timecode burn-in (p. 251) 
• Vector keying in Adobe Premiere Pro (p. 253) 
• Camera Lens Blur effect (p. 255) 
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• Enhanced depth of field (with the Roto Brush) (p. 257) 

Review Questions 
Q:  Name the effects that are fixed (attached) to every clip by default.  
A:  Motion, Opacity, Time Remapping, and Volume are pre-applied to every clip.  
 
Q:  How do you visually browse presets from Adobe After Effects?  
A:  In Adobe After Effects, click the submenu in the upper-right corner of the Effects & Presets 

panel, and choose Browse Presets to launch Adobe Bridge. 
 
Q:  Which keyframe interpolation method deals with changes in motion across time?  
A:  The Temporal interpolation method is an effective way to determine the speed at which an 

object moves across a motion path.  
 
Q:  What effect in Adobe After Effects can be used to reduce rolling shutter?  
A:  The new Warp Stabilizer effect in After Effects CS5.5 is most useful.  
 
Q:  Which keying effect is GPU accelerated and can be found in Adobe Premiere Pro?  
A:  You can use the Ultra Key effect. 
 
 

 
 

 

 

 

 

 

 

 

Elapsed Time         3.25 hours 

Lunch 
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Module 12: Creating titles         45 mins 
• This module uses Chapter 13 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.  

 Please teach only the headings listed here. 
 
‣ Video typography essentials (p. 258) 

• Suggest students read on their own after class 
• Benefits of reading include better understanding of best use of tools and options 

 
•    

‣ Using Adobe Premiere Pro’s Titler (p. 267) 
• Creating and editing titles (p. 268) 
• Entering text (p. 269) 
• Formatting text (p. 269) 
• Stylizing a title (p. 270) 
• Creating a template (p. 272) 

 
•    

‣ Advanced titling with Photoshop (demo or hands-on—time permitting) (p. 272) 
• Creating a Photoshop document (p. 272) 
• Photoshop text essentials (p. 273) 
• Layer styles (p. 275) 

 
•    

‣ Animated titles with Adobe After Effects (demo or hands-on—time permitting) (p. 277) 
• Setting text (p. 277) 
• Browsing presets (p. 278) 
• Retiming animations (p. 279) 
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Review Questions 
Q:  Which text property lets you adjust the overall space between all letters in a line of text? 
A:  Use the Tracking property. 
 
Q:  Which type tools create a text box as Paragraph text? This approach lets you define a box that 

controls when text automatically wraps. 
A:  The Area Type and Vertical Area Type tools. 
 
Q:  What is the fastest way to create a new Photoshop file from within Adobe Premiere Pro?  
A:  Choose File > New > Photoshop File. 
 
Q:  Which Adobe application offers text animation presets?  
A:  You can use Adobe After Effects. 
 
Q:  Do you need to render your After Effects projects before importing them into Premiere Pro?  
A:  No, you can place an .aep file directly into an Adobe Premiere Pro Timeline. 
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Module 13: Acquiring and managing media      75 mins 
• This module uses Chapters 4 and 14 in An Editor’s Guide to Adobe Premiere Pro, Second 

Edition. 
• Sidebar information in the chapter (orange boxes) can be used as appropriate. 
• Most of Chapter 14 is not discussed in class, but should be strongly encouraged as take-home 

reading. 
• Please note that certain sections of the book have been dropped to conserve time.   

Please teach only the headings listed here. 
 
‣ Importing files into Adobe Premiere Pro (p. 56) 

• Standard importing (p .56) 
• Using the Media Browser (p. 58) 
• Adobe Prelude (p.61) 
• Adobe Bridge (p.64) 

 

‣ Tape-based workflows (p.6 6) 
• Tape-Based workflows (Appendix C) – optional 

 

‣ Tapeless workflows (p. 67) 
• Mounting the card (p. 68) 
• Creating a clone and a copy (p. 68) 
• Spanned clips (p. 69) 

 

‣ Supported file types (p. 70) 
• Footage files (p. 70) 
• Graphics files (p. 71) 
• Audio files  (p. 73) 

 

‣ Modifying clips (p. 73) 
• Adjusting audio channels (p. 73) 
• Interpreting footage (p. 74) 
•  Modifying timecode (p. 78) 

 

‣ An Introduction to Dynamic Link (p. 79) 
•  Linking to and from Adobe After Effects (p.79) (Covered in Module 11) 
• Linking to and from Adobe Encore (p. 80) 
• Linking to and from Adobe Audition (p. 80) 

•    

 
•    

‣ Practical media management (p. 296) 
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• Removing unused media (p. 296) 
• Using the Project Manager (p. 297) 

Review Questions 
Q:  Which import method should you use when working with spanned clips and tapeless media? 
A:  The Media Browser is the best way to correctly import spanned clips. 
 
Q:  If you’d like to browse and add metadata to QuickTime and image files, which Adobe application 

is useful? 
A:  Adobe Bridge offers another way to organize and annotate files. 
 
Q:  If you want tapeless sources to continue to be available after you unmount a card, which action 

must you perform? 
A:  You must clone or copy the data to your media hard drive. 
 
Q:  You have been given a raw photograph. What must you do before using the file in Adobe 

Premiere Pro? 
A:  Open the raw file with Adobe Photoshop and save it as a Photoshop or TIFF file.  
 
Q:  If a clip has an incorrect frame rate or pixel aspect ratio, how can you change it? 
A:  Choose Clip > Modify > Interpret Footage, and then select the appropriate option in the Modify 

Clip dialog.
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Module 14: Publishing your video       60 mins 
• This module uses Chapter 15 in An Editor’s Guide to Adobe Premiere Pro, Second Edition. 
• Sidebar information in the chapter (yellow boxes) can be used as appropriate 
• Please note that certain sections of the book have been dropped to conserve time.  Please teach 

only the headings listed here. 
• Customize topics to class needs. 
 
‣ Exporting a digital master (p. 302) 

• Matching sequence settings (p. 302) 
• Choosing another codec (p. 303) 

 
‣ Meet Adobe Media Encoder (p. 305) 

• Accessing Adobe Media Encoder from Adobe Premiere Pro (p. 306) 
• Overview of the Export Settings dialog (p. 306) 
•  Additional options (p. 310) 
• Exporting files (p. 311) 

 
‣ Creating Flash content (p. 312) 

• Choosing between FLV and F4V (p. 312) 
• Using FLV and F4V presets (p. 312) 

 
‣ Creating H.264 content for devices and Web delivery (p. 313) 
 
‣ Publishing to DVD and Blu-ray (brief overview as time permits) (p. 315) 

• Using MPEG-2 presets for DVD (p. 315) 
• Choosing between MPEG-2 and H.264 for Blu-ray (p. 316) 
• Using an H.264 preset for Blu-ray (p. 316) 

 
‣ Exporting additional file types (p. 317) 

• Edit Decision List (EDL) (p. 317) 
• Open Media Framework (OMF) (p. 318) 
• Advanced Authoring Format (AAF) (p. 319) 
• Final Cut Pro XML (eXtensible Markup Language) (p. 319) 
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Review Questions 
Q:  Which application can handle the conversion of your video project to multiple delivery formats? 
A:  You can use Adobe Media Encoder. 
 
Q:  How can you add important information to your digital files? 
A:  Adobe has broad support for adding metadata throughout the Creative Suite. 
 
Q:  Which formats should you choose for broad compatibility on the Web? 
A:  You can export both Flash Video and MPEG-4 files from Adobe Media Encoder. If you are 

working on a Windows machine, you can also create Windows Media files. 
 
Q:  Which Adobe application can be used to simulate the playback of video on a mobile phone or 

portable media player? 
A:  Adobe Device Central is a useful way to check the compatibility of your digital files. 
 
Q:  With which two nonlinear editing platforms can Adobe Premiere Pro exchange project data? 
A:  You can export either OMF or AAF files for Avid editing systems and XML for Final Cut Pro.
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Module 15: Close out          15 mins 
‣ How to take an Adobe Certification Exam (www.adobe.com/support/certification/ace.html) 

• ACA Exam 
• ACE Exam 

   
‣ Additional resources  

• Adobe TV  
• Peachpit.com 

 
‣ Recommended reading/viewing 

• Adobe After Effects CS6 Classroom in a Book 
• Adobe Premiere Pro CS6 Classroom in a Book 
• Photoshop for Video (Fourth Edition) 
• Motion Graphics with Adobe Creative Suite 5 Studio Techniques 
• Adobe Premiere Pro CS6: Learn by Video  
• Adobe After Effects CS6: Learn by Video  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

End of Day 2 
 


