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Introduction

Unified Communications and Collaboration is on the so-called “Hot List” in any forum
wherein people are discussing communications and ways to better stay in touch. This
book is aimed at explaining the concepts, ideas, and capabilities behind Presence, which
is likely one of the least understood and most underestimated features in a Unified
Communications solution. It has the power to end phone-tag before the game even
begins. It has the power to ensure that you reach the right resource by the right means
and on the first attempt.

Goals and Methods

The most important and somewhat obvious goal of this book is to explain not only the
concepts behind Presence but also the technologies involved, their interdependencies, and
how to troubleshoot them. It is understood that knowing a concept is not sufficient in
and of itself. There must be comprehension and direction; a primer of sorts. With that 
in mind, some discussion of practical applications of Presence as a technology has also
been addressed herein.

The book has been organized such that you might begin with little or no knowledge of
Presence as a concept. The ideas behind it, installation and deployment of the technolo-
gies, and some possible applications are discussed to show some basic capabilities. It is
largely up to you to decide how to best utilize these technologies within your organiza-
tion; However, we assist in getting things moving in the right direction.

Who Should Read This Book?

This book is not designed to be a general networking topics book, although it can be
used for that purpose. It is meant to be a reference before, during, and after the imple-
mentation of Cisco Unified Presence. It is both a guide and a reference resource. This
book is intended to assist in understanding, installing, deploying, and troubleshooting
numerous aspects of Cisco Unified Presence. In being so, it will be quite specific in those
places where it is most important. With the installation out of the way, much of the level
of specificity herein will disappear. This is due to the authors’ desire to avoid placing
impediments to imagination. Unified Communications and Collaboration solutions are
intended to be customized to fit a particular environment, solve business needs, and
transform the way in which business is done. As you read this book, you can apply the
information to your own environment and shape it into your own solution to meet your
needs and that of your business.

How This Book Is Organized

As mentioned, this book is both a reference and a guide. It walks you through the instal-
lation process and detail interdependencies between various systems within a Cisco
Unified Communications environment. So it might be of most benefit to read the book
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cover-to-cover prior to stepping into an installation effort. You can likely learn things in
the troubleshooting chapter that can save you some pain in the installation phase, for
example. The outline of the book is as follows:

■ Chapter 1, “What Is Unified Communications?”—This chapter provides a high-level
tour of Unified Communications components. The purpose of doing so is to provide
a base upon which a solid understanding of Presence and its uses can be built.

■ Chapter 2, “Cisco Unified Presence Overview”—This chapter provides an introduc-
tion to Presence as a concept before getting deeper into Presence features and
functionality. This provides a better understanding of the concepts discussed in the
remainder of the book surrounding both the Presence Server and Presence clients.

■ Chapter 3, “Installing Cisco Unified Presence Server 7”—This chapters provides a
step-by-step guide to installing Cisco Unified Presence Server 7.x. It also discusses in
detail the interdependencies between the Cisco Unified Presence Server and the
Cisco Unified Communications Manager, as well as the configuration of those
interdependencies.

■ Chapter 4, “Cisco Unified Presence Integration with Cisco Unified
Communications Manager”—This chapter provides a deeper view of the combined
functional capabilities of Cisco Unified Presence and Cisco Unified Communications
Manager. It covers LDAP integration and configuration along with user and phone
feature association.

■ Chapter 5, “Cisco Unified Personal Communicator”—This chapter covers the
installation and configuration of the Cisco Unified Personal Communicator. Aside
from simply installing the client, this chapter discusses the interdependencies
between user, desk phone, and CUPC client as they relate to one another. The
configuration includes not only the Cisco Unified Presence Server dependencies, but
also those within the Cisco Unified Communications Manager.

■ Chapter 6, “Cisco Unified Presence Practical Applications”—This chapter provides
some general use cases for Presence as a feature. It looks into how Presence might be
used by a varied user base with varied needs and provides some high-level case studies
of features that different types of users might utilize.

■ Chapter 7, “Cisco Unified Presence Federation”—This chapter discusses needs and
configuration of both intradomain federation and intradomain federation with Cisco
Unified Presence Server clusters. It also goes into the basics of interdomain
federation with Microsoft OCS.

■ Chapter 8, “Leveraging Cisco Unified Presence in Vertical Markets”—This chapter
provides a use-case overview of how varying types of businesses might utilize the
feature set provided by Cisco Unified Presence. 

■ Chapter 9, “Troubleshooting Cisco Unified Presence”—This chapter covers the trou-
bleshooting aspect of Cisco Unified Presence. This includes troubleshooting the Cisco
Unified Presence Server, Cisco Unified Personal Communicator, and Cisco Unified
Communications Manager and the interdependencies between all these elements.
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Chapter 5

Cisco Unified Personal
Communicator

Cisco Unified Personal Communicator (CUPC) is the client application that integrates
into the Cisco Unified Presence Server (CUPS). This client runs on a Windows or
Macintosh desktop environment and provides for several integrated communications fea-
tures such as desk phone control, Instant Messaging (IM), Presence, softphone, commu-
nication escalation, and so on. This chapter covers the client installation, configuration,
basic and advanced features, and client-side troubleshooting.

Figure 5-1 illustrates the communications in a basic CUP deployment with an IP phone
and CUPC client.

CUPS

IP Phone

Cisco Unified
Communications Manager

CUPC

1A

1B

CTI Interface

SIP Trunk

AXL SOAP

HTTP

CTI
SIP

SIMPLE

SCCP/SIP/TFTP

LDAP

Figure 5-1 Communications of a Basic CUP Deployment
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Note CUPS enables Presence information to be populated by many types of presentities;
however, CUPC is the only software client supported directly by CUPS.

CUPC Configuration

The configuration of a user leveraging CUPC has several basic steps that need to be
completed:

Step 1. Configure user in CUCM.

Step 2. Configure desk phone device in CUCM (optional).

Step 3. Configure the CUPC device in CUCM.

Step 4. Configure CUPS advanced end-user features:

■ Voicemail

■ Conferencing

■ Lightweight Directory Access Protocol (LDAP)

Step 5. Install CUPC software on the client machine.

The following sections describe these configuration steps in greater detail.

Configuring CUPC User in CUCM

It is strongly recommended having LDAP synchronization configured in any CUCM
installation. This brief section covers the steps required to configure a user in CUCM
without LDAP integration. This is because when LDAP synchronization is enabled, the
ability to add/delete users in the CUCM user interface is removed. All users are added or
removed via the LDAP management interface. Figure 5-2 illustrates the concepts for the
following steps:

Step 1. In CUCM Administration, select User Management > End User > Add New.

Step 2. Fill in at least the required user information (User ID and Last Name).

Step 3. Device Associations can be left at the default.

Step 4. If this user will use extension mobility services, configure the required set-
tings. Make sure to select the correct Presence group because this impacts
what Presence visibility this user has.

Step 5. Leave directory number associates at the default setting unless you already
have a desk phone and directory number configured for this user.
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Figure 5-2 CUCM User Page

Step 6. The mobility section enables the user to configure single number reach access
and mobile voice access (directory assistant IVR). Configure this section
according to the end user’s needs.

Step 7. Ensure that the user roles include Standard CTI Enabled and Standard CTI
Allow Control of All Devices, as shown in Figure 5-3.

Step 8. Select the Save button.

Step 9. In CUCM Administration, select System > Licensing > Capabilities
Assignments.

Step 10. Select the users recently added that will have Presence and CUPC capabilities.

Step 11. Click both check boxes to enable CUP and CUPC features for the users.
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Figure 5-3 CUCM User Page Continued

Tip The user might not show up for several minutes on the CUP server. If it is taking too
long, go to Cisco Unified Serviceability > Tools > Control Center-Feature Services, select
the CUP server (publisher if in a cluster), and then start or restart Cisco UP Sync Agent.

When the user has been added to CUCM, it will be synchronized over to the CUP server.
There is no need to add the user separately to the CUP server. LDAP synchronization is
strongly recommended so most of these steps would not be necessary, and the rest can
be done when doing the phone device provisioning in CUCM. For more information on
CUCM synchronization with LDAP, refer to the “LDAP System Configuration” section in
the Cisco Unified Communications Manager Administration Guide at
http://tinyurl.com/yaoy42m. 

http://tinyurl.com/yaoy42m
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Figure 5-4 Adding a Desk Phone in CUCM

Configuring IP Phone in CUCM

A common deployment model is for a single user to have both a desk phone and have
CUPC act as a softphone during communications that take place away from the desk.
CUPC offers a softphone capability that enables it to act as a phone device on a comput-
er without the requirement of a desk phone, making the desk phone an optional device in
a deployment. The use of a desk phone is optional and not required when deploying and
configuring CUPC. This section covers the basic steps necessary in setting up an IP
Phone to be used with CUPC. Figure 5-4 shows the addition of a physical desk phone.

Step 1. In CUCM Administration, select Device > Phone.

Step 2. Click the Add New button.

Step 3. Select the device for the desk phone; then click the Next button. Do not

select Cisco Unified Personal Communicator.

Step 4. Select the protocol for the phone to use.

Step 5. Make sure the Presence Group and SUBSCRIBE Calling Search Space are
defined according to your Presence policy.
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Figure 5-5 Adding a Desk Phone in CUCM Continued

Note Presence authorization works with Presence Groups to allow or block Presence
requests between groups. This enables greater granularity in offering Presence services to
groups or departments.

The SUBSCRIBE calling search space determines how CUCM routes Presence requests
that come from the phone. This setting enables you to apply a calling search space separate
from the call-processing search space for Presence (SUBSCRIBE) requests for the phone.

Step 6. Make sure that Allow Control of Device from CTI is checked. Figure 5-5
illustrates the settings for Steps 5 and 6.

Step 7. Configure all the remaining required settings for the phone and end-user
requirements.

Step 8. Associate the user to the phone, as shown in Figure 5-6.

The phone now registers to CUCM with the proper settings and user association. Adding
the phone allows users to have the option to control their phone through a computer
telephony interface (CTI) with the CUPC client. This allows for the added software
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Figure 5-6 Associating Phones with Users

Configuring a CUPC Device in CUCM

The next step is to set up a CUPC device in CUCM associated to the appropriate user and
potentially connected to a desk phone. The first step in planning for the CUPC device con-
figuration is to understand the naming convention required in CUCM. These requirements
follow:

■ Derives from the username

■ Starts with UPC

■ Contains only uppercase letters or numerals

■ Contains no more than 12 additional characters after UPC

Table 5-1 provides some examples that outline these requirements.

features offered by the CUPC client and still has a desk phone for a more reliable voice
experience. 
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Figure 5-7 Adding a CUPC Endpoint in CUCM Continued

Table 5-1 Username Examples for CUPC in CUCM

CUCM Username Associated Softphone Device Name

mpopovich UPCMPOPOVICH

michael_popovich UPCMICHAELPOPOV

michaelpopovich UPCMICHAELPOPOV

mike.popovich UPCMIKEPOPOVICH

When the naming convention has been decided, the CUPC device can now be added to
CUCM:

Step 1. In CUCM Administration, select Device > Phone.

Step 2. Click the Add New button.

Step 3. Select the Cisco Unified Personal Communicator.

Step 4. The Device Name should be the CUPC name determined earlier, for example,
UPCMPOPOVICH. This is shown in Figure 5-7.
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Step 5. Uncheck the box for Allow Control of Device from CTI.

Step 6. Specify the correct Presence Group and SUBSCRIBE Calling Search Space.

Step 7. Set the Owner User ID field to the appropriate user.

Step 8. Configure the rest of the settings according to system/user policy.

Step 9. Click the Save button.

Step 10. Click the Line[1] > Add a new DN link.

Step 11. Assign the directory number to the line. If a phone device is already config-
ured, use the same DN as the phone. If this is a CUPC-only user, enter a new
DN, as shown in Figure 5-8. 

Figure 5-8 Adding a DN to a CUPC Endpoint

Step 12. Uncheck the box for Allow Control of Device from CTI.

Step 13. Configure the rest of the settings according to system policy.

Step 14. Click Save.
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Figure 5-9 Adding a DN to a CUPC Endpoint Continued

When saved, a new screen comes up that shows what devices are associated to the DN.
This field should at least have the CUCP device associated with it. If it is a shared DN
with a phone device, two devices should be listed: the CUPC and the phone device. This
is shown in Figure 5-9.

Now that the CUPC device is set up in CUCM and the users are configured, the client
can be installed, and there will be Presence, desk phone connectivity (CTI), and soft-
phone functionality. These are the basic services that CUPC has available, and in the next
section, the advanced features of CUPC will be configured. It is recommended to have
these features configured before installing the client. 

Configuring Advanced Features for CUPC

The advanced features available to the CUPC client consist of Unity voicemail,
MeetingPlace conferencing, video, and LDAP integration. The following sections
describe the configuration of these advanced features in greater detail.
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Voicemail Configuration for CUPC

CUPC has the capability to access Unity voicemail directly through the client interface.
This is useful to the end user by providing a visual interface to the Unity voicemail sys-
tem, enabling the user to prioritize voicemails by name, timestamp, duration, and so on
without having to listen to the messages first.

Two primary prerequisites must be completed before integrating CUPS to Unity:

■ Implement a supported version of Unity or Unity Connection, which are the only two
supported messaging platforms for CUPS integration.

■ Complete the integration of CUCM and Unity/Unity Connection, and make sure all
voice ports are working properly.

The sections that follow discuss how to satisfy these prerequisites in more detail.

Cisco Unity Connection

The following steps describe the Cisco Unity Connection (CUC) provisioning steps for
CUPC users. Use Figure 5-10 with the following steps. 

Figure 5-10 Enabling IMAP in Unity Connection



150 Cisco Unified Presence Fundamentals

■ Always: Messages will always be marked secure.

■ Never: Messages will never be marked secure. (Users can still mark
messages as private, and they will be secure.)

■ Ask: Users will be prompted from the Special Delivery Options menu
to select if the message is marked secure or not.

■ Private: Messages are marked secure only when the user makes them a
private message. This is the system default.

Note Secure messaging is optional, and a set of features offered in Unity Connection
enables several security features that provide control for access and distribution to mes-
sages. Several caveats need to be understood before enabling these features. You can find
detailed information on these caveats at http://tinyurl.com/y9uuu2q.

Use Figure 5-11 with the following steps to enable secure messaging: 

Step 1. Enable secure messaging:

a. Select Class of Service using the navigation panel; then click the Class of
Service the CUPC users are a part of.

b. Under the Message Options section of the Class of Service; select the type
of secure messaging next to the Require Secure Messaging option:

Step 1. Configure a class of service in CUC with IMAP enabled:

a. Select Class of Service in the left navigation pane.

b. Select or add the desired class of service in the list.

c. Check the Allow Users to Use Unified Client to Access Voice Mail box.
This allows access to port 7993 and TLS for the CUPC client support.

d For IMAP client support as well, check the Allow Users to Access
VoiceMail Using an IMAP Client box and select the Allow Users to
Access Message Bodies button.

e Click Save.

Step 2. Create a CUC user account and voicemail box for each CUPC user.

Step 3. Make sure the web application password is set for the user.

http://tinyurl.com/y9uuu2q
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Figure 5-11 Enabling Secure Messaging in Unity Connection

Step 2. Configure unidentified caller message security settings, as shown in Figure 
5-12:

a. Select Users in the navigation panel.

b. Select the desired user.

c. Select Edit > Message Settings.

d. Check Mark Secure in the Unidentified Callers Message Security section.
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Figure 5-12 Enabling Secure Messaging in Unity Connection Continued

Cisco Unity

The next steps cover the configuration requirements for Unity as the message platform
for the CUPC user: 

Step 1. Configure the Microsoft Exchange server to use IMAP by enabling the IMAP
Connector. Refer to Chapter 9, “Troubleshooting Cisco Unified Presence,” for
step-by-step guidance.

Step 2. Configure the port and encryption type. Ensure that SSL is the only encryp-
tion type being used and not TCP. This setting is manually done in Exchange
2003 but on Exchange 2007, SSL is the default.

Step 3. Configure the user in Unity.

Step 4. Create the exchange mailbox for the users. This step might not be necessary,
depending on whether the user was added in Unity or AD first. If users were
imported from AD into Unity, the mailbox should already be there as a
result of the import process. For purposes of brevity, it is assumed that this
is the case.
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Figure 5-13 Enabling Secure Messaging in Unity

The following steps are necessary only if secure messaging is implemented with Cisco
Unity:

Step 1. Enable secure messaging through the Cisco Unity System Admin Page, as
shown in Figure 5-13:

a. Select Subscribers > Subscribers > Features.

b. Select the desired option in the Message Security When Sending a
Message list.

c. Select Save.

Step 2. Configure unidentified caller message security settings, as shown in Figure 
5-14.:

a. Select System > Configuration > Message Security Settings.

b. Select an option from the list on how messages should be secured from
unidentified callers.

c. Select Save.
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Figure 5-14 Enabling Secure Messaging in Unity Continued

Configuring Voicemail Servers in CUPS

Voicemail servers are defined in CUPS to allow for required interactions between CUPS
and the specified voicemail server. Voice message web service (VMWS) is the service on a
Cisco Unity or CUC server that enables deleted voicemails to be moved to their correct
location in the mail store and also provides encryption service for secure messaging envi-
ronments. The IP address of the voicemail server and the peer Microsoft Exchange server
(if using Unity) is needed prior to the following steps:

Step 1. Navigate to Application > Cisco Unified Personal Communicator >
Voicemail Server in the CUPS administration page, as shown in Figure 5-15.

Step 2. Click Add New.

Step 3. Select Unity or Unity Connection in the server type menu.

Step 4. Define the voicemail server name.

Step 5. Define the FQDN hostname or IP address.

Step 6. For Cisco Unity Servers, define 443 for Web Service Port. For Cisco Unity
Connection Servers, define 143 for the Port.
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Figure 5-15 Configuring the CUPC Voice Mail Server in CUPS

Step 7. For Cisco Unity Servers, select HTTPS for Web Service Protocol. For Cisco
Unity Connection Servers, select TCP, UDP, TLS, or SSL. The default is UDP.

Step 8. If enabling Secure Messaging (optional), define the Secure Port and Secure
Protocol Type. For Cisco Unity Servers, choose HTTP or HTTPS for Protocol
Type. For Cisco Unity Connection Servers, choose TCP, SSL, or TLS as the
Protocol Type. 

Step 9. Click Save.

Configuring Mailstore Server in CUPS

Defining a mailstore in CUPS is required for the CUPC client to access the voicemail mes-
sages on the voicemail server. Figure 5-16 shows the CUPS Mailstore page. The FQDN
hostname or IP address of the mailstore server is necessary to complete the following
tasks.
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Figure 5-16 Configuring the CUPC Mailstore in CUPS

Step 1. Navigate to Application > Cisco Unified Personal Communicator >
Mailstore in the CUPS administration site.

Step 2. Click Add New.

Step 3. Define the mailstore server name.

Step 4. Define the FQDN hostname or IP address.

Step 5. Define the IMAP port number for CUPC to use in connecting to the mail-
store server.

Unity Connection options follow:

■ TCP: port 143

■ SSL: port 993

■ TLS: port 143 or 7993

Unity with Exchange options are the same as Unity Connection except TLS is
supported only on port 143. 

Step 6. Click Save.
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Configuring Voicemail Profiles in CUPS

The voicemail profile is required in CUPS to enable the CUPC client to access the correct
voicemail resources for the end user. The following steps are necessary to configure the
voicemail profile: 

Step 1. Navigate to Application > Cisco Unified Personal Communicator >
Voicemail Profile in the CUPS administration page, as shown in Figure 5-17.

Step 2. Click Add New.

Step 3. Define the profile name.

Step 4. Select the Voice Message Pilot number for the correct voicemail server of the
CUPC end user.

Note Voicemail and mailstore server failover is not supported in CUPS 7.0(4).

Figure 5-17 Configuring the CUPC Voicemail Profile in CUPS
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When the voicemail profile configuration is complete, CUPC end users are now ready to
log in and access the voicemail services through the desktop client. 

Conferencing Configuration for CUPC

One of the major benefits of using the CUPS and the CUPC client is that application
integrations allow for consolidated user functionality into other applications, such as
video and conferencing. These integrations are at the touch of a button and easy to use
from an end-user perspective. Initiating a conversation through an IM window and then
escalating that conversation to an audio or video call at the touch of a button and then
further enhancing that conversation into a collaboration conference is compelling for end
users and has a dramatic effect on their productivity. This functionality begins to bring
the true value of CUPS and the CUPC client to the user.

CUPC can be configured to support ad-hoc web conference sessions with the following
products:

■ Cisco Unified MeetingPlace

■ Cisco Unified MeetingPlace Express

■ Cisco Unified MeetingPlace VT

■ Cisco Webex Meeting Center

MeetingPlace Express and Meeting Place Express VT

MeetingPlace Express and MeetingPlace Express VT can both provide web and audio
conferencing functionality to CUPC. MeetingPlace Express VT provides video confer-
encing resources to provide the capability for CUPC to escalate a point-to-point video
call to a multipoint video call.

Several things need to be completed before integrating the MeetingPlace Express (VT)
platform into the CUPS solution:

1. Install a release of MeetingPlace Express (VT) supported by the CUPC client. The re-
lease notes for the CUPC client will specify the specific supported software versions.
You can find current CUPC 7.x release notes at http://tinyurl.com/y9dephh.

2. Configure CUCM to integrate with MeetingPlace Express (VT).

3. Determine the number of web, audio, and video ports required for the solution. A
good rule of thumb for the average user population is 1:40 (ports:client) for web and
video and 1:20 for audio.

The next steps cover the necessary configuration to integrate MeetingPlace Express (VT)
with CUPC:

Step 1. Configure the MeetingPlace Express (VT) conferencing capabilities:

http://tinyurl.com/y9dephh
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■ adhocsystemsoftware

■ webconf

■ maxadhoc

■ maxweb

b. Configure MeetingPlace Express (VT) for adhoc conferencing. You can
find detailed documentation for this feature at
http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_
Release_2.x.

c. Configure MeetingPlace Express for the reservationless feature to support
full web meetings initiated by MeetingPlace Express and the web meetings
initiated by CUPC. You can find specific details on configuring user pro-
files, call control, and such on MeetingPlace Express at
http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_
Release_2.x. 

Step 2. Enable Secure Sockets Layer (SSL) encryption. This is optional; however, if it
is not completed, passwords sent between CUPC and MeetingPlace Express
will be sent in clear text, creating a potential security vulnerability.

Step 3. Configure a user profile for each CUPC user that is going to initiate web con-
ferences from the CUPC client.

Note This is not required for all CUPC users and is needed only for the users that will
initiate the web conferences.

Step 4. Ensure that the Presenter add-in is installed on each CUPC user’s computer.
This can be done remotely by downloading the install package from Cisco
Connection Online, or the user can download it by navigating to the
MeetingPlace Express server’s main page using a web browser.

Step 5. Configure the voice network so that inbound calls from the PSTN to the
CUPC user support RFC2388. This allows an inbound call from MeetingPlace
Express to the CUPC user to use the CUPC key pad for DTMF instead of
key press markup language (KPML). This is required only for DTMF support
on inbound calls to CUPC, which supports both KPML and DTMF for out-
bound calls. This will be done on the CUCM configuration page for the SIP
Trunk configured to CUPS (see Figure 5-18).

When these configurations are made, CUPS configuration will take place to define a con-
ferencing server and profile. Those steps come later in this chapter, after the MeetingPlace
and Webex configurations are covered. 

a. Install the following licenses:

http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_Release_2.x
http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_Release_2.x
http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_Release_2.x
http://docwiki.cisco.com/wiki/Cisco_Unified_MeetingPlace_Express,_Release_2.x
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Figure 5-18 Configuring RFC 2388 DTMF Support

Configuring MeetingPlace

The following steps configure MeetingPlace to support the CUPC client:

Step 1. Install the web and audio conferencing user licenses.

Step 2. Enable SSL encryption. This is optional; however, if not completed, passwords
sent between CUPC and MeetingPlace Express will be sent in clear text, cre-
ating a potential security vulnerability.

Step 3. Configure user authentication on the web conference server. The following
methods are supported:

■ MeetingPlace

■ LDAP

■ HTTP Basic

■ LDAP, then MeetingPlace

Step 4. Configure user profiles for each CUPC user on the MeetingPlace server.
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When these configurations are made, CUPS configuration takes place to define a con-
ferencing server and profile. Those steps come later in this chapter, after the Webex con-
figurations are covered.

Configuring WebEx Meeting Center

Integration for CUPC into WebEx Meeting Center is a new integration available with
CUPS version 7.0(3) and CUPC version 7.0(2). The WebEx Meeting Center conferencing
server must be installed prior to configuration. You can find documentation on how to
set up this server on the provisioned WebEx site that is being integrated. Create a user
profile on the WebEx Meeting Center for each CUPC user that needs access to initiate
web conferencing meetings.

The previous three integration options outline the steps required to provision a CUPC
user to have access to the conferencing features that the client provides. This provision-
ing, so far, has only taken place on the conferencing servers. The next section covers the
steps to define these conferencing servers and the conferencing profiles in the CUPS for
the CUPC client to leverage these resources. 

Configuring Conference Servers in CUPS

This section covers the configuration of the conferencing server in CUPS so that the
CUPC client can access the available resources. The configuration steps are done through
the CUPS administration web pages. 

Before beginning the configuration, you must complete the following prerequisite tasks:

■ Get the IP address and the port number of the conferencing server.

■ Integrating to a WebEx Meeting Center solution requires the Site ID and the Partner
ID assigned to your WebEx site. If you do not know these IDs, you can get them
from your WebEx administrator.

The following configuration steps are necessary to complete the integration:

Step 1. Go to Application > Cisco Unified Personal Communicator > 
Conferencing Server in the CUPS administration page, as shown in
Figure 5-19.

Step 2. Click Add New.

Step 3. Define the Name of the conference server.

Step 4. Define an optional description of the conference server.

Step 5. Enter the IP address or a hostname of the conference server. The hostname
needs to be a Full Qualified Domain Name (FQDN) that can be resolved by
the DNS server used by CUPS.

Step 6. Define the port that the conference server is configured for. The options are
for 80 (HTTP) or 443 (HTTPS).
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Figure 5-19 Configuring the CUPC Conferencing Server in CUPS

Step 7. Select the protocol used when CUPS communicates with the conferencing
server. The current supported protocols are HTTP and HTTPS.

Step 8. Select the conferencing server being integrated.

Step 9. If WebEx were selected, enter the Site ID and the Partner ID for the WebEx
site being integrated.

Configuring Conferencing Profiles in CUPS

This section covers the final step for CUPC users accessing conferencing resources on the
network. Prior to this section, the steps covered addressed the conferencing server provi-
sioning of the CUPC user and configuring the conference server in CUPS. There can be
more than one conference server defined in CUPS as required by end-user feature/func-
tionality, migration from one platform to another, increased capacity requirements, and
so on. Conference profiles enable the capability to have different CUPC end users config-
ured for different conferencing server resources. The following steps are needed to con-
figure conferencing profiles and assign CUPC users:
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Step 1. Navigate to Application > Cisco Unified Personal Communicator >
Conferencing Profile in the CUPS administration page, as shown in Figure
5-20.

Step 2. Click Add New.

Step 3. In the name section, define the name of the conferencing profile.

Step 4. Select the Primary Conferencing Server as defined in the system.

Step 5. You can add up to two backup conferencing servers defined in the system.

Step 6. Check the Make This the Default Conferencing Profile for the System box
if this is the default system.

Step 7. Click the Add Users to Profile.

Step 8. Select the users for this voicemail profile.

Step 9. Click Add Selected.

Figure 5-20 Configuring the CUPC Conferencing Profile in CUPS
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Step 10. Click Save.

Note Conferencing server failover is not supported in CUPS 7.0(4).

This section completes the required tasks necessary to configure full conferencing fea-
tures for CUPC users. This feature will allow for ad-hoc web conferencing leveraging
Meeting Express, Meeting Place Express VT, MeetingPlace, and WebEx Meeting Center.
Conferencing can be a conversation escalated to a point-to-point web sharing portal or a
full-service web conference with the ability to invite other users to the conference via a
click to add, e-mail, or IM. 

Configuring Video for CUPC

Video is relatively simple for a CUPC deployment. The main thing to note here is that video
with CUPC is supported only when the client is in softphone mode. To configure video for
CUPC, complete the following tasks:

Step 1. Configure the CUPC client for softphone use if it is not the user’s primary
device.

Step 2. Confirm that video use is enabled for the CUPC device in CUCM. This is
done within the Region settings of CUCM and assigned to the device
through the device pool.

Step 3. Distribute supported video cameras for the CUPC users.

Step 4. If three or more parties are required in a video call, the media resource group
defined for those users must have a conference bridge configured with video
resources available. The supported options are MeetingPlace Express VT,
MeetingPlace with video, and Cisco Unified Videoconferencing solution that
leverages the 3500 series Multipoint Control Units (MCU). 

Note Steps 1 through 3 are the only ones necessary for point-to-point video.

Configure LDAP for CUPC

This section covers LDAP integration for the purposes of user lookup in the CUPC
client. This enables CUPC users to search for and add contacts from a defined LDAP
directory. The section does not cover LDAP directory integration for purposes of user
provisioning and authentication with CUCM. Detailed LDAP integration for those pur-
poses can be found in the “Configuring CUPC Users in CUCM” section of this chapter.
Cisco strongly recommends having CUCM integrated to LDAP for user provisioning and
authentication and configuring CUPC for LDAP integration on CUPS for user lookup
functionality.
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The first thing to understand before configuring LDAP servers in CUPS is the rules for
how contacts are displayed in CUPC. This is important to understand because there will
be attributes that need to be mapped for displaying names, and these rules determine
how names are displayed:

■ If a user edits a contact name retrieved from LDAP in CUPC, display that name. This
is the Nickname attribute in CUPS.

■ If the LDAP user field DisplayName is configured, display that name.

■ If the LDAP user field Nickname is configured, display that name with the last name.

■ If none of the preceding are configured, display the LDAP user field of the
FirstName and LastName. If there is no last name, display only the first name. If
there is no first name, display only the last name.

■ If no LDAP user fields are configured, display the LDAP UserID or the CUPS user ID.

■ If a non-LDAP contact is added, the user can define the Display As name, first name,
and last name.

The first thing you need to do is to configure an LDAP attribute map for the supported
LDAP server and the CUPC client attributes. Several attribute mappings available enable
you to manipulate information between the LDAP server and the CUPC client, but only
one is required at the start to provide the functionality of adding users retrieved in an
LDAP search to the CUPC client contact list. The following are the steps necessary to
accomplish that task:

Step 1. Navigate to Application > Cisco Unified Personal Communicator > Settings
in the CUPS administration page, as shown in Figure 5-21.

Step 2. Select the type of LDAP server you want to configure in the drop-down menu.

Step 3. Define the UserID field under the UPC User Fields to one of the following:

Microsoft Active Directory - sAMAccountName

Sun ONE - uid

Step 4. Click Save.

After you correctly set the attributes, you can configure the LDAP server. The steps nec-
essary to configure an LDAP server in CUPS are as follows:

Step 1. Navigate to Application > Cisco Unified Personal Communicator > LDAP
Server, as shown in Figure 5-22.

Step 2. Click Add New. 

Step 3. Define the name of the LDAP server.

Step 4. Define the FQDN hostname or the IP address.

Step 5. Define the port number used by the LDAP server; 389 is the default.



166 Cisco Unified Presence Fundamentals

Figure 5-21 Configuring the User ID Format in CUPS

Step 6. Select the protocol to use. The default is TCP.

Step 7. Click Save.

Note More than one LDAP server can be defined in the CUPS system for purposes of
failover. If this is done, all the defined LDAP servers must be of the same type.

The final required configuration is the LDAP Profile. The required steps to configure an
LDAP profile in CUPS follows:

Step 1. Navigate to Application > Cisco Unified Personal Communicator > LDAP
Profile in the CUPS administration page, as shown in Figure 5-23.

Step 2. Click Add New.

Step 3. Define the name of the profile.

Step 4. It is optional but recommended to define the Bind Distinguished Name field
using an administrator-level account. Anonymous bind is available if wanted.
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Figure 5-22 Configuring the CUPC LDAP Server in CUPS

The syntax can vary depending on the LDAP server used. Table 5-2 provides a
guide to the syntax for Microsoft Active Directory and Sun ONE. 

Step 5. Define the LDAP bind password.

Step 6. Define the search context to be used for LDAP user searches by the CUPC
client. A single OU search context is supported. For example (Microsoft AD):

CN=users,DC=cisco,DC=com

Step 7. Check to perform a recursive search of the directory.

Step 8. Select the primary LDAP server.

Step 9. Select any backup LDAP servers.

Step 10. Click Add Users to Profile.

Step 11. Select the users for this voicemail profile.

Step 12. Click Add Selected.

Step 13. Click Save.
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Figure 5-23 Configuring the CUPC LDAP Profile in CUPS

Table 5-2 Supported LDAP Directory Types and Naming Syntax

LDAP Server Type Distinguished Name Syntax

Microsoft Active
Directory

CN=Michael Popovich, CN=Users, DC=Contoso, DC=com

Sun ONE cn=Michael Popovich, ou=Operations, o=Example Corp, st=CA,
c=US

Upon completion of these steps, the CUPC users can search for contacts in the client
and leverage the defined LDAP directory. When the search is completed on the client,
the user has the option to IM, place an audio and video call to LDAP-defined contact
numbers, initiate a web conference, and add the LDAP contact to the CUPC contact
list.
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CUPC Troubleshooting

The next few sections cover basic troubleshooting relative to the CUPC client. Some
steps can be done by the end user and takes place on the client machine, and others are
done by a system administrator or more experienced network administrator to narrow
down possible root causes to an issue.

Basic CUPC Troubleshooting

If there is any service issues after a user has logged in, there are two basic things an end
user can do to immediately confirm an issue and give administrators a good idea of what
the problem is and how to resolve it follow:

■ Look at the server health of the CUPC services. This is accomplished by navigating to
Help > Show Server Health in the menu of the CUPC client (see Figure 5-24). There
is an overall health status of all the available CUPC services that can be configured.
Next to each process or service is a status indicator telling the user if the status is
good with a green check or bad with a red octagon with an X in the middle. The end
user can quickly tell an administrator what the initial problem might be. In the figure,
there seems to be a couple of issues that need to be resolved.

■ If the first option is not enough to adequately determine the potential problem, the
end user can generate a more detailed dump of information that can be sent to the ad-
ministrator. This is done by navigating to Help > Create Problem Report in the menu
of the CUPC client, as shown in Figure 5-25. This starts a wizard in which the end
users can quickly fill out the required information describing what they were at-
tempting to do and what they were doing at the time of the problem. The tool then
generates a log report and gathers necessary files that will be compiled into a zip file.
This zip file will automatically be saved on the desktop. That file can be e-mailed to
the administrator or appended to a Cisco TAC case for a more detailed review. One
suggestion would be to enable detailed logging on the client and have the user log off
and log back in to the client.

When the user and administrator have determined a specific problem, more troubleshoot-
ing will most likely be required. The following sections cover some initial troubleshoot-
ing steps for the various CUPC services, such as authentication, voicemail, conferencing,
LDAP, and so on. Many of these topics are covered in more depth in Chapter 9. For more
detailed information on using the diagnostic tools available for CUPC, go to
http://tinyurl.com/ydhhfo9. 

http://tinyurl.com/ydhhfo9
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Figure 5-24 CUPC Show Server Health Tool

CUPS and CUCM Integration Troubleshooting

There could be issues with an end user not being able to log in to CUPC. This can be
because of several issues and the following are some ideas on where to look:

■ Make sure the end user has network connectivity to the voice network. This can be
through the enterprise network or VPN, but connectivity must first be confirmed.
Pinging the IP address of the CUPS server is the easiest way to accomplish this.

■ LDAP integration with CUCM is the Cisco recommended way for deploying CUCM.
CUPS authenticates users through CUCM, and if a user cannot authenticate using
CUPC, verify LDAP is functional between CUCM and your LDAP server. This can
be done by having the user authenticate to the CUCM end-user pages. If that is not
allowed, an administrator can authenticate to CUCM admin pages using an LDAP
account to verify connectivity.
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Figure 5-25 CUPC Create Problem Report Tool

Voicemail Troubleshooting

Most common voicemail issues from the CUPC client stem from a user not being able to
log on, or voicemail messages are not downloading or don’t appear in the recent pane.
Here are some things to look at to address voicemail issues on CUPC:

■ Make sure users enter their credentials correctly in the CUPC client. This is found un-
der File > Preferences > Account. If the user can log in to CUPC but does not see
any voicemail messages, this is most likely not configured correctly. Show Server
Health will also reveal this issue.

■ If this is a new user, it is possible that the user has not synched over to the CUPS cluster.
Usually, the administrator would have verified this already because most deployments
have some manual configuration of the CUPC user for voicemail and conferencing pro-
files. Deployments assign default profiles for all services, and when a user is synched and
automatically assigned to a CUPS node, the user should be functional. If this is the case,
make sure the Sync Agent and Proxy Service is running. If those services are not run-
ning, restart them manually and confirm the user is assigned on the cluster. 
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■ If voicemail messages are not downloading but authentication is working, there are a
few things to consider:

■ Check the server configuration to make sure that IMAP is enabled on the mail-
store and that the voicemail profile is accurate for the CUPC user.

■ (Cisco Unity Connection) If messages are still not being received and the cre-
dentials have been checked, make sure that port 7993 is configured on the serv-
er and that the CUPC client is listening on port 7993. If there are any firewalls
between the client and server, make sure that traffic on port 7993 is allowed to
pass through.

■ Clear the voicemail cache on the end-user machine. This is accomplished by
deleting all the files in the following directories:

For Windows XP: drive:\Documents and Settings\UserID\Local
Settings\Application Data\Cisco\Unified Personal Communicator\VoiceMail

For Windows Vista: drive:\Users\UserID\AppData\Local\Cisco\Unified
Personal Communicator\VoiceMail

For Mac OS: home/Library/Caches/Cisco/UnifiedPersonalCommunicator/
VoiceMail

■ If voicemails do not display in the recent pane of the CUPC client and server health
shows that the server fails due to authentication failure, have the user re-enter their
credentials in the CUPC client. If the client tried to reconnect but can’t, it is most
likely that the voicemail account is either locked or the password has expired. 

Conferencing Troubleshooting

This section covers the basic troubleshooting steps focused on conferencing and covers
MeetingPlace Express and MeetingPlace:

■ If the user complains that the conferencing button is dimmed on the CUPC client,
that is most likely due to the conferencing resources not being configured for the sys-
tem, the conference profile has not been defined for the user, or the Web
Conferencing Server credentials on the CUPC client are incorrect. Check the CUPS
server and make sure that a conferencing server has been configured and that the cor-
rect conference profile has been identified for the CUPC client. When that is con-
firmed, make sure the CUPC user has configured the correct user information in the
Web Conference Server setting of the client.

■ If the user complains that he cannot escalate a call to a web conference when he
clicks Start Web Conference, check the CUCM server and make sure that the direc-
tory lookup dial rules are configured correctly. This issue can occur when the CUPC
client cannot match a calling party number with the correct person from LDAP via
the CUCM server. Details on configuring directory lookup dial rules can be found at
http://tinyurl.com/yd5pyd6.

http://tinyurl.com/yd5pyd6
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Note Advanced troubleshooting information for MeetingPlace express can be found at
http://tinyurl.com/ychwbnw and for MeetingPlace at http://tinyurl.com/ya3s2os. 

LDAP Troubleshooting

The following provide solutions to some common LDAP problems. For instance, if there
are no results when a user does a query in the Search pane, there can be several reasons
for this; here are some things to look at to resolve the issue:

■ If anonymous bind is configured in CUPS for the LDAP server, uncheck that check
box and configure the Bind Distinguished Name information.

■ Check client connectivity to the LDAP server by having the user ping the IP address
of the LDAP server or telnet to the LDAP port on the server. (The default is port 389.)

■ If using bind credentials in the LDAP server configuration on CUPS, double-check
that those credentials are correct.

■ Verify the correct search space is defined in the LDAP server configuration on CUPS.

For more detailed LDAP troubleshooting information, go to http://tinyurl.com/yadqb4v.

Summary

The CUPC client is a feature-rich client that offers a lot of productivity enhancements to
the end user. It is flexible for both the stationary and mobile workspace users with desk-
phone CTI control and softphone. The collaboration features provided by the client cover
Instant Messaging, audio/video calls, web conferencing—all at the click of a button. The
idea of escalating a conversation as needed gives the end user the ability to get more
done in a single interaction than has ever been provided before. The click-to-action func-
tionality of CUPC gives the power of advanced collaboration features to end users with
little to no knowledge of how to initiate them. This is especially evident with video and
web conferencing because these two collaborative mediums have historically had low
adoption rates because of complex scheduling and setup.

http://tinyurl.com/ychwbnw
http://tinyurl.com/ya3s2os
http://tinyurl.com/yadqb4v
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IPT (IP Telephony)

call control, 5

CUCM, 7–8

endpoint network access, 8–9

ISRs, 6, 9–11
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ISRs (Integrated Services Routers), 
6, 9-11

J

Jabber, 180

L

LDAP

authentication, configuring, 112

configuring, 109

for CUPC, 164–165, 
167–168

connectivity, configuring, 113

CUCM/CUPS integration 
requirements

authentication, 108

directory access, 108

provisioning, 107

synchronization, configuring,
110–111

troubleshooting, 173

LDAP profile, CUCM/CUPS
integration, configuring, 128,
130–131

LDAP synchronization, 
troubleshooting, 232–234,
236–237, 239–240

leveraging CUPC with CUPS,
206–207

leveraging CUPS in vertical markets

city and county government, 211

emergency services, 210–211

healthcare, 207

doctor communications, 209

nurse communications, 208

retail, 212–213

licensing CUPS, 69–70

log files, 222–223

M

mailstore servers, configuring in
CUPS, 155–156

MeetingPlace, CUPC support,
configuring, 158–159, 161

messaging for stationary users, 182

Microsoft OCS, federation, 
configuring, 197, 200–202

Mobile Connect, 181

mobile users, 183

mobility, 13, 180–181

MOC Troubleshooter page (CUPS
Diagnostics tab), 221–222

multicluster deployment (CUCM),
33–37

multinode scalability (CUP server), 37

active/standby redundant 
high-availability deployment, 40

balanced nonredundant high-
availability deployment, 
39–40

balanced redundant high-availability
deployment, 38–39

nonhigh-availability deployment, 41

N
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nonhigh-availability deployment 
(CUP server), 41

nurse communications, enhancing
productivity with CUPS, 208
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ISRs, 6, 9–11

signaling, 4–5

phone directories (CUCM), 25

platform scalability (CUP), 30

plug-ins (RTMT), 223

Post-Installation Wizard, 66, 68

preconfiguration checks,
CUCM/CUPS integration, 114–115

preinstallation tasks (CUPS), 44–45

Presence, 14–15, 21, 179, 187

CUCM, 23

phone directories, 25

speed dials, 24

CUP

components, 22

deployment models, 27–30

users, 25

CUP server, Publish Trunk service
parameter, 26

Derived Presence, 187

user scenarios

call center agents, 185–186

executives, 183–184

mobile users, 183

stationary users, 181–183

teleworkers, 184

Presence Engine log files, 223

Presence Gateway, adding, 74–79, 81

Presence server

CTI gateway, configuring, 85, 88

IPPM, configuring, 83–85

proxy domain, configuring, 82–83

Presence service parameter,
CUCM/CUPS integration,
configuring, 122, 124

provisioning (LDAP), as CUCM/CUPS
integration requirement, 107

proxy domain, configuring, 82–83

Proxy Listener, configuring for
CUPC, 135–136

public sector, enhancing productivity
with CUPS

city and county government, 211

emergency services, 210–211

Publish Trunk service parameter
(CUP server), 26

R

redundancy

CUP, 29–30

CUPS, configuring, 93–94

retail, CUPS, leveraging, 212–213

RTMT (Real Time Monitoring Tool),
225–226

plug-ins, 223

S

scalability

CUP, 30

CUP server, multinode scalability,
37–41

secure messaging, CUC, configuring,
150, 152

Service Parameter, configuring for
CUPC, 135–136

show network eth0 command,
195–197

single-cluster deployment (CUCM),
32–33

SIP Proxy log files, 223

SIP trunks, CUCM/CUPS 
integration, configuring, 
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SRST, 11
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messaging, 182

Sync Agent log files, 222

synchronization
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LDAP

configuring, 110–111

troubleshooting, 232–234,
236–237, 239–240

System Status page (CUPS
Diagnostics tab), 216–218

System Troubleshooter (CUPS),
218–220

users, troubleshooting, 229–240

System Troubleshooting, 101,
103–104, 106

T

telephony. See also IPT

call control, 3

history of, 2–3

PBX architecture, 3

signaling, 4–5

teleworkers, as typical Presence 
users, 184

TFTP, failed downloads, 
troubleshooting, 250–251

TFTP server connection, configuring
for CUPC, 134–135

TLS peer subject creation, 191, 193

trace files, 222–223

troubleshooting

conferencing, 172–173

CUCM/CUPS dependencies, 226,
228–229

CUCM/CUPS integration, 170–171

CUCP

failed TFTP downloads, 250–251

voicemail access, 251–252, 257
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user device associations,
244–245

user group membership, 246,
248–249

user names, 241, 243

CUPS/CUCM connectivity, 99, 101

CUPS users, 229–230, 232–234,
236–237, 239–240

LDAP, 173

with System Troubleshooter, 101,
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voicemail, 171–172

troubleshooting tools

MOC Troubleshooter page, 221–222

RTMT, 225–226

System Status page, 216–218

System Troubleshooter page,
218–220

trace files, 222–223

U
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UC applications, Cisco Unified
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UC components

call control, 177

Collaboration, 179–180

UC components 267



mobility, 180–181

Presence, 179

voice messaging, 177–178

Integrated Messaging, 178–179

Unified Messaging, 178

UC solutions

applications

Cisco AXP, 11–12

mobility, 13

voice messaging, 13–14

clients, 16

CIPC, 16–17

Cisco UWL, 18–19

CUCIMOC, 17

CUMC, 17

CUPC, 18

CUVA, 18

user experience, 15–16

unattended Presence server
installation, 94–99

Unified Messaging, 178

user device associations (CUPC),
troubleshooting, 244–245

user group membership (CUPC),
troubleshooting, 246, 248–249

user names (CUPC), troubleshooting,
241, 243

user scenarios

call center agents, 185–186

executives, 183–184

mobile users, 183

stationary users, 181

call control, 181–182

collaboration, 182–183

messaging, 182

teleworkers, 184

users (CUCM), configuring without
LDAP integration, 140, 142

users (CUPS), troubleshooting,
229–240

V

verifying TLS Peer Subject 
creation, 191

video, configuring for CUPC, 164

video conferencing, 180

Visual Voice Mail, 177

voice messaging, 13–14, 177–178

Integrated Messaging, 178–179

Unified Messaging, 178

voicemail

configuring in CUPC, 149–150, 152

Cisco Unity configuration, 
152, 154

CUPS mailstore servers,
155–156

CUPS voicemail profiles,
157–158

CUPS voicemail servers,
154–155

troubleshooting, 171–172, 
251–252, 257

voicemail profiles, configuring in
CUPS, 157–158

W

WebEx Connect, 180

WebEx Meeting Center, CUPC
support, configuring, 161

X

XCP (Jabber eXtensible
Communications 
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