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Introduction

Welcome to
Bento…and Bento 2

The Database for the Rest of Us

Bento is a product from FileMaker, which is owned by Apple.
Designed to bring FileMaker’s database expertise to users of Mac OS
X Leopard and later, it integrates data from iCal, Mail, and Address
Book with databases that you can create from your own data as well
as imported data from other sources.

Bento is lightweight in its structure but heavyweight in its capabili-
ties. Because it builds on so many years’ (actually decades’) worth of
experience with users and their needs both at FileMaker and at Apple,
it is responsive to the frequently expressed needs and frustrations of
people who need more organization than a word processing docu-
ment or spreadsheet can provide but less complexity than a full-
featured multiuser database might provide. Organization is the key
to making information usable. Four items that are organized (ideas,
recipes, addresses, bills, or shoes) can be more useful than a thousand
items that are scattered around helter-skelter with no organization
scheme.

Released in beta in the fall of 2007 and in a final version in early win-
ter 2008, Bento caught on immediately. The response was positive
both in reviews and in user comments. Because the Bento team is so
agile and also because its design is so simple yet sophisticated, it was
possible to produce a second version of the software within a year.
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Introduction

This book shows you how to use Bento—both the first version and Bento 2. There are significant
differences to the user interface between the two versions, but the basic functionality is the same.
Figure IN.1 shows one of the sample Bento libraries in Bento 1.
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Figure IN.1

Bento 1 in action.

In Figure IN.2, you see the same library in Bento 2.

Figure IN.2

The library in Bento 2.



The Database for the Rest of Us

The most significant difference that you can see in comparing the two versions is that the
Source list (at the left in Bento 1) and the Fields list (at the right in Bento 1) now share the same
Libraries & Fields pane at the left in Bento 2. There are many other changes. One of the most impor-
tant is the ability to split the main part of the window into two views, as shown in Figure IN.3. Watch
for the New in This Version icon in the book for more Bento 2 features.

wNeNe
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Figure IN.3

In Bento 2, you can split the window display in two.

There are many more changes in Bento 2. Just a few of the highlights are

■ You can include messages from Apple Mail in your Bento libraries in the same way you can
include iCal and Address Book data.

■ You can enter data directly into the Table view, as shown at the top of Figure IN.3.

■ Bento now supports more import and export formats.

■ You can also save a Bento library as a template.

■ Field types can be changed.

■ Related records have more functionality, including the ability to click to go to a specific related
record and, from that record, to return to the original record (“hot relations”).

■ And many, many more features as you will see in the book.

If you are still using Bento 1, have no fear. Where differences exist in functionality or the interface,
both are described and illustrated.



Introduction

How This Book Is Organized

This book shows you how to use Bento, and it presents a number of projects that you can use (with or
without modification). The projects are designed to illustrate the types of tasks that you can perform
with Bento. You may choose to mix and match features and functionality from various projects to
create your own solutions.

The general structure of the book is as follows:

■ In the first few chapters, you see how to use the built-in Bento libraries.

■ Next, you see how to customize them.

■ Then you see how to import data from another source, such as a spreadsheet.

■ Finally, you see how to create and share libraries for data that you enter from scratch.

Along the way, the chapters explore various combinations of these techniques. Here is a summary of
the chapters in the book:

■ Chapter 1,“Bento: The Database for the Rest of Us,” provides the introductory overview of
Bento. It shows how you can organize your data, and it describes the basic Bento terminology,
which consists of just four words. You see how to use the Bento window in both versions and
how to set preferences.

■ Chapter 2,“Using the Bento Window,” uses the built-in Notes library to show you how to add
and delete records, enter data, and find it (both using a simple and advanced find technique).

■ Chapter 3,“Working with Bento Forms,” uses the built-in Classes library to explore how you can
customize libraries with themes, columns, labels, shading, text size, and text boxes.

■ Chapter 4,“Building a Bento Library from Your Own Data,” provides a quick overview of how to
import data from another source such as a spreadsheet. This topic is explored in more depth in
Chapter 15,“Importing and Exporting Bento Data and Libraries.”

■ Chapter 5,“Working with Phone, URL, IM, and Address Fields and Lists in Contacts,” explores the
built-in Contacts library. You see how to use multiple forms and how to work with lists of phone
numbers, URLs, addresses, emails, and IMs. The integration with Mail is explored both in Bento 1
and Bento 2 (there are some differences), and you see how to add fields to a form.

■ Chapter 6,“Working with Bento Fields and Calculations,” shows how you can use calculation
fields to make your data entry faster and more accurate. The built-in Exercise Log serves as the
example.

■ Chapter 7,“Expanding the Inventory Library with Related Records and Collections,” delves into
the concept of related records. You see how to take the built-in Inventory library and modify it
so that it reflects additions or subtractions to or from inventory in a live, on-hand value.

■ Chapter 8,“Using Built-In Bento Libraries for Address Book,” explores one of the most powerful
parts of Bento: its integration with Address Book in Mac OS X. Bento accesses the Address Book
data, and it is always live in the Bento display as well as in the Address Book display. (You also
see how this ties into MobileMe so that the data in Bento and Address Book is automatically
synchronized with data elsewhere in your computing environment.)
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How This Book Is Organized

■ Chapter 9,“Using Built-In Bento Libraries for iCal Tasks and Events,” continues to look at how
Bento is automatically integrated with your data on Mac OS X. This time, the iCal data is consid-
ered.

■ Chapter 10,“Working with Bento’s Projects Library to Use Related Records from iCal Tasks, iCal
Events, and Address Book,” shows how the built-in Bento Projects library uses the technologies
described in Chapters 7 through 9. Related records from the built-in Mac OS X applications are
associated with specific projects. This allows integration so that, for example, iCal can display
tasks and events over a period of time and across many projects while you can view each proj-
ect separately in Bento. Furthermore, the integration of iCal and Address Book with MobileMe
means that your Bento tasks, events, and contacts are automatically available on all your syn-
chronized devices from Macs to PCs to iPhones. This chapter also shows the new Bento 2 fea-
ture that lets you integrate messages from Mail with your Bento libraries.

■ Chapter 11,“Designing a Projects Library with Related Notes,” shows how you can customize
the built-in Projects library with structured notes. This capability allows you to enter and
browse comment and note data by date or other categories. Notes differ from tasks and events
not only in that they are stored totally in Bento, not in iCal, but also because notes are a record
of what has happened and been discussed in a project—the past, as well as  the future events
and tasks. For many people, this library may be all the project tracking they need.

■ Chapter 12,“Building a Garden/Nature Log,” builds a customized project from scratch. This proj-
ect is good for a kid, class, or family. It integrates observations, measurements, and photos of a
garden or natural world with Bento. It also shows how you can perform complex or tricky cal-
culations with Bento’s summary row and Smart Collections (as in calculating the last frost
date—a date that is characterized by the fact that you do not know the date of the last frost
until all possible subsequent frosts have not happened).

■ Chapter 13,“Organizing a Group Project with Bento,” shows how to use Bento as the core of a
multiuser project. Bento is designed for a single user, but this is a great way for a person
(teacher? project leader? committee chair?) to pull a group project together.

■ Chapter 14,“Creating a Storyboard with Bento,” focuses on organizing a visual project and
shows how you can keep track of all the related storyboard project aspects, such as locations,
costumes, actors, and props. You can also integrate notes and visuals into the storyboard itself.
Storyboard can help you organize everything from a political commercial to a family history.

■ Chapter 15,“Importing and Exporting Bento Data and Libraries,” explores Bento data import
and export. You also see how to use the Bento 2 features that allow you to create and use your
own Bento library templates.

■ Chapter 16,“Managing an Email List from Constant Contact or Vertical Response with Bento,”
takes a common real-word problem and explores how you can use Bento to help you.
Managing an email list is more than just tracking names and addresses. In this chapter you see
the basics of importing and exporting addresses to and from the major bulk-mailing programs.

■ Chapter 17,“Bento Quickies,” provides tips and suggestions for a number of projects. Because
you have already seen how to use Bento, these quickies can point you in interesting directions
in just a paragraph or two.
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Introduction

Special Features

This book includes the following special features:

■ Chapter roadmaps: At the beginning of each chapter is a list of the top-level topics addressed
in that chapter. This list enables you to quickly see the information the chapter contains.

■ Notes: Notes provide additional commentary or explanation that doesn’t fit neatly into the sur-
rounding text. Notes give detailed explanations of how something works, alternative ways of
performing a task, and other tidbits to get you on your way.

■ Tips: This element gives you shortcuts, workarounds, and ways to avoid pitfalls.

■ Cautions: Every once in a while there is something that can have serious repercussions if done
incorrectly (or, rarely, if done at all). Cautions give you a heads-up.

■ New in This Version icon: This icon identifies new features in Bento 2.

■ � Cross-references: Many topics are connected to other topics in various ways. Cross-
references help you link related information together, no matter where that information
appears in the book. When another section is related to one you are reading, a cross-reference
directs you to a specific page in the book on which you can find the related information.

Downloadable Files and Web Support

For updates to the book, see the author’s website, www.northcountryconsulting.com and the book's
website, www.thebentobook.com. There is also a Facebook Page for the book at
www.facebook.com/pages/The-Bento-Book/23722243212.

Downloadable files for this book are available on the Web:

■ www.thebentobook.com.

■ www.informit.com/title/9780789738127

FileMaker is the developer of Bento. There are a number of resources on the FileMaker site:

■ www.filemaker.com/bento gets you to the basic Bento page.

■ There is a discussion forum for Bento at http://forums.filemaker.com/fmbnto/.

wNeNe
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Working with 
Bento Forms

Working with Forms

In Chapter 2,“Using the Bento Window,” you saw how to use the
Fields list (Bento 1) or Libraries & Fields pane (Bento 2) to add fields.
This chapter continues the discussion of fields and forms.

Every Bento library can be shown in a table view. At the top of the
Bento window, you will see that for that library you can select either
the table view or a form view. The table view is identified as “Table”;
you can name the form views—and, yes, there can be more than one
form view for a Bento library, but there can only be one table view.

This chapter begins by exploring the Classes template; its table view is
shown in Figure 3.1. It contains a single record that is part of the tem-
plate.

■ Working with Forms 43

■ Customizing a Form with

Themes 47

■ Customizing a Form’s 

Fields 48
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Figure 3.1

Display the Classes template in table view in Bento 1.

The table view in Bento 2 is much the same as you can see in Figure 3.2. The biggest difference is that
in Bento 1, the table view looks like iTunes, whereas in Bento 2, it looks more like a spreadsheet.

44

Figure 3.2

Display the Classes template in table view in Bento 2.

The differences in functionality were described in Chapter 2. As far as the fields in the library that are
shown in the table view, the difference is that the list is at the lower left in Bento 2 and at the right in
Bento 1. In both cases, you select the fields to be shown in the table view by using the checkbox to
the left of the field name. Because there is only one table view in a library, whether a field is displayed
in that table view is an attribute of the field, and it can be set in the Fields list.



Working with Forms

You can switch from table view to form view by clicking Form at the upper left of the Records area.
The Classes form view is shown in Figure 3.3 as it appears in Bento 1.
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Figure 3.3

You can view the data in form view in Bento 1.

There are more differences between Bento 1 and Bento 2 when it comes to form views. Compare
Figure 3.4, the Bento 2 version of the form, with Figure 3.3, the Bento 1 version.

Figure 3.4

The Classes form view is shown in Bento 2.

First, note that in Bento 1, to the left of each field name is a small icon that indicates if that field can
be dragged into the form. (The field is not already in the form because a field can only appear in a
form once.) That icon appears in Bento 2 to the right of each field name. As you switch from one form
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to another, the icons are updated in both Bento 1 and Bento 2 to reflect whether you can add the
field to the form.

Note that in Bento 2, the Fields list makes a distinction between fields in the current library and those
in related data. You can see this clearly in the Assignments & Projects field, a field that shows related
records from iCal. In Bento 2, it clearly shows up as a related records field, whereas in Bento 1, it and
any other related records fields are displayed alongside the library’s fields.

In form view, you are able to rename a form, create new forms, and delete a form. (Except for the last
one; there must always be at least one form in the library.)

To change a form’s name, double-click its name to open the dialog shown in Figure 3.5. (This is the
name of the form itself; it appears to the right of Table and among any other forms. To change the
name of the library, click its name—Classes in this case.) You can also use Forms > Rename Form.
Here, the form in the template is called Form. For this chapter, you are modifying that form. The safest
way to do that is to rename it “Original Form” and then to duplicate it and work on the duplicate.
Thus, Figure 3.5 shows you the first step in the process.
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Figure 3.5

Rename a form.

The second step is to duplicate the form by choosing Insert > Duplicate Form in Bento 1 or Forms >
Duplicate Form in Bento 2. Bento then duplicates the original form; its default name has “Copy” at the
end. The next step is to rename the duplicate form from “Original Form Copy” to “My Form.” Now you
are ready to go.
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Customizing a Form with Themes

Like Keynote with its styles, Bento lets you apply visual themes to your forms. These coordinated
appearances combine a selection of colors and fonts in various styles. With a form selected, you can
change its theme by choosing Format > Theme. Unlike Keynote, Bento does not allow you to change
the details of the themes. However, because of the large number of provided themes, you are likely to
find themes that you like.

A Bento theme is totally separate from your data. That means you can switch themes at any time
without affecting your data. The various templates use a variety of themes, but you can change them
at will.

If you want to be sophisticated about your Bento themes, you can select several of them to use for
specific purposes, such as displaying confidential data from work, displaying social data, and the like.

Themes are applied to the active form; when you next go to a table view, that theme is applied to the
table. If you then go to a form in the library that uses a different theme, that other theme is applied to
the table view when you navigate from the second form to the table view.

With Bento 2, there are more than two dozen themes available. You can select a theme from Forms >
Choose Theme. The first item in the submenu is Theme Chooser. It lets you select a theme and try it
out. The Bento window behind the Theme Chooser dialog is visible using the new theme.

Some examples of Bento themes are shown in Figure 3.6.

47

Figure 3.6

Bento has a variety of themes.
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Customizing a Form’s Fields

To customize a library’s table view, you use the Fields list (to control which fields are shown) and
directly manipulate the table. You can reorder columns, show or hide the summary row, and change
column width. In Bento 1, you modify a form view by choosing View > Customize Form or by clicking
the customize form button at the upper right of the Records area. In either case, the search field is
replaced by Customize Form with an X to its right. To exit from Customize Form, click that X.

In Bento 2, you can customize a form by clicking on the edge of a field to move or change it.
Figure 3.7 shows how you can access the customization options for a form. If you click in the

field itself, you are able to enter data. Clicking on its border shows handles that you can use to resize
the field, as shown in Figure 3.7. When the handles are visible, you can drag on the field’s border to
move it. If you click in the center of the field, the handles disappear, and you are able to enter data.
This and the other interface elements described in this section replace the Customize Form mode in
Bento 1.

wNeNe
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Figure 3.7

Move and reshape fields in Bento 2.

When you start to customize a form in Bento 1, new tools appear at the bottom of the form view; in
addition, guides appear on the form. Among the customization tools is a Themes tool that lets you
select themes just as you can do by choosing Format > Themes. In Bento 2, a button in the lower-
right corner of the window controls whether the form tools are shown or hidden as does View >
Show Form Tools, as shown in Figure 3.7.

Bento puts the labels in the appropriate location and coordinates their appearance with the appear-
ance of the relevant field using the currently selected theme. When you drag a field from the Fields
list or Libraries & Fields pane into a form that you are editing, an outline of the label and data field
appears as soon as you move your mouse into the Records area, as shown in Figure 3.8.
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Figure 3.8

Bento automatically provides the label and data entry fields.

Some fields require more than one data entry element; if so, they are shown in the outline and are
placed in the form as soon as you release the mouse button. A heavy line shows you where in the
form the new field and label are placed. In Figure 3.8, a URL list is being placed on the form; it is one of
the field types that require several elements for display and entry.

� For more details about these composite data fields, see Chapter 5,“Working with Phone, URL, IM, and Address Fields and Lists in
Contacts,” p. 69.

After a field and its label have been placed on a form, you can change its width or height by selecting
it and dragging the right or bottom border. You can also rearrange fields; just drag them up or down
or from column to column. Everything is taken care of for you by Bento: fields move aside as needed.
And, of course, the tab order remains logical (top to bottom and left to right in column one, and then
on to column two with the same ordering). To rearrange fields after you have already added them, in
Bento 1 you choose View > Customize Form, and in Bento 2, you click the border of a field to begin
editing it.

Bento provides you with several formatting objects that you can add to a form. Figure 3.9 illustrates
three of them.
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Figure 3.9

Use form objects to help format a form.

The line beneath the two images is a horizontal separator. Another object, a spacer, has been added
before the Date Created field. Also, a column separator has been added to the right of the column con-
taining the images. Of these objects, only the horizontal separator is visible when you have finished
editing the form (by clicking in another field or going to another form). Figure 3.10 shows the result.
You can tell that a third column has been added to the form by the position of the horizontal scrollbar
at the bottom of the form. In Figure 3.10, it has been moved so that the third column is visible.

50

Figure 3.10

Only the horizontal rule is directly visible in the finished form.
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The Form tools in Bento 1 and Bento 2 are mostly the same, but there are some differences. Table 3.1
describes each of the tools from left to right and provides keyboard equivalents. In the case of tools
that are different in the two versions, that difference is noted. If no version difference is indicated, the
tool works the same in both Bento 1 and Bento 2.

NOTE
Figures illustrating the use of the various tools are referenced in Table 3.1. Some of them occur
in later chapters.

Table 3.1 Form Tools

Tool Equivalent Purpose Version Differences

Form Double-click form name in Change a form’s name Bento 2

the navigation bar or Forms > (Figure 3.5).

Rename Form.

Field Opens the Create a Field dialog Open the Create a Field Bento 2

dialog (Figure 6.2). In Bento 1, a choice in the 

Objects tool

Text Box Insert > Text Box You can type anything you Bento 2

want in the text box, and In Bento 1, a choice in the 

you can move it around the Objects tool

form just like a field. Unlike 

a field, this is not data from 

your library; it is simply text 

that appears on the form.

Objects Insert > Horizontal Separator A spacer is a blank area that See Field,Text Box, and 

Insert > Column Divider also can be moved around. Columns for Bento 1 

Insert > Spacer You use it to add space differences

between fields.There is also 

a horizontal separator (a line) 

that can be used to separate 

groups of fields.

Related Data Insert > Related Records List Open the Create a Field dialog Bento 1

with Related Records List 

selected for Field Type.

Themes Bento 1: Format > Select a theme. Theme Chooser only available 

Theme as the first choice in Bento 2

Bento 2: Forms > 

Choose Theme

51
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Table 3.1 Form Tools (continued)

Tool Equivalent Purpose Version Differences

Columns Format > Columns Choose 1-5 columns Bento 1

for the form.

Labels Bento 1: Format > Labels Choose Above or Beside for Bento 2: can also choose 

Bento 2: Forms > Labels position of labels on all small, medium, and large size

fields in the form.

Shading Bento 1: Format > Shading Choose None, Light, or Dark 

Bento 2: Forms > Shading for selected field(s).

Text Size Bento 1: Format > Text Size Choose Smallest to Largest 

Bento 2: Forms > Text Size for selected field(s).

Align Edges Bento 2: Forms > Align right edges of selected 
Align Right Edges objects. Other edges remain 

where they were.

TIP
Be wary of going overboard with these design elements. If you find yourself needing to organ-
ize your forms with spacers and separators, maybe you would be better off splitting your form
into two separate forms. As you see in Chapter 7,“Expanding the Inventory Library with
Related Records and Collections,” you can use collections and related records to bring whole
sets of data onto a form in a simple way. Bento works best for most people when you can see
all the data elements in a form without scrolling the window.

The field consists of the label and the data entry section(s); a background may be shaded for the
entire rectangle that contains these elements. In the Format menu or the tools at the bottom of the
Customize Form view, you can choose the degree of shading you want. They can be effective in high-
lighting essential (or nonessential) information as long as you use shading consistently.

You can also change the size of the text in the data fields, although the size of the label text is
changeable only in Bento 2. Finally, you can select two or more fields and align their right edges.
You do this by expanding the narrower fields’ widths so that all are consistent.
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collections
adding records to, 108
creating empty 

collections, 108
creating from selected

records, 109
definition, 18, 107
example, 107
overview, 18-19
Smart Collections, 19-20,

109-111, 173-175

columns, 190

command-separated-values
(CSV) data, importing,
57-62

commands
Bento menu, Preferences, 40
Card menu, Add Field, 116
Edit menu, Delete 

Library, 24
File menu

Address Book and iCal
Setup, 13

Export, 206
Import, 23, 58
New Collection, 108
New Library, 23, 154
New Smart 

Collection, 109
Print, 28

Format menu, Themes, 48
Forms menu

Duplicate Form, 46
Rename Form, 46

Insert menu
Current Date and 

Time, 27
Delete Field, 38
Duplicate Field, 38
Duplicate Form, 180
New Field, 38, 156

Records menu
Advanced Find, 31-33
Delete Selected

Record(s), 33
Duplicate Record, 27
New Record, 27

Edit menu, Spelling, 27
View menu, Customize

Form, 48

communicating with multi-
ple people, 208

complexity, managing with
Bento, 189-191

computers, definition 
for MobileMe 
synchronization, 120
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configuring Bento 
preferences, 40

Constant Contact
downloading bulk email

data to Bento, 222-223
uploading data from Bento,

217-220

contacts (Address Book),
sharing with MobileMe,
148-150

Contacts library
address fields

adding to forms, 72-73
in Bento 1, 69-70
in Bento 2, 70-72
overview, 69

creating, 66-67
lists

adding to forms, 72-73
in Bento 1, 69-70
in Bento 2, 70-72
overview, 69

overview, 65-66
views, 67-69

converting
between events and To Do

items (iCal), 130
field types, 14

counters, automatic, 16, 89

Crops database, 170-171

Crops field (Garden/Nature
log), 170

CSV (command-
separated-values) data,
importing, 57-62

currency fields, 16

Current Date and Time 
command (Insert menu), 27

Customize Form command
(View menu), 48

customizing
fields, 148
forms, 148

fields, 48-50
themes, 47

Projects library, 153

D

data, finding
with Advanced Find, 31-33
with search field, 29-31

data detectors
with iCal, 134-135
updating Address Book

with, 124-125

data entry
addresses

adding to forms, 72-73
in Bento 1, 69-70
in Bento 2, 70-72
overview, 69

automatic counters, 89
calculations

Calculation dialog, 82-83
Calories Burned field, 86
Duration field, 84-85
overview, 82

checkbox values, 88
choice values, 87
currency values, 89
customizing fields, 148
dates

date and time field 
controls, 79-80

Start Date field (Exercise
Log), 79

Stop Date field (Exercise
Log), 77-78

editing fields, 90-92
file list fields, 17, 181-183
form fields. See forms

importing data
into existing libraries,

200-204
overview, 199

legacy data
in Bento 2, 63
cleaning up imported

data, 62-63
CSV (command-

separated-values) 
data, 57-62

data formats, 54-56
overview, 53-54

lists. See lists
media fields, 16
message list fields, 17
numbers, 81-82
ratings, 90
related records list fields

adding data to, 103-105
adding to forms, 100
formatting, 101-102
restrictions on, 105-106
reviewing related

records, 103-104
summarizing, 103

storyboards
Image field, 193
Length field, 193
Notes field, 193
Place field, 193
related record fields,

195-196
Script field, 193
Sequence field, 193
Setting field, 193
Status field, 193
Time field, 193
Title field, 193

text data, 27-28
times, 79-80
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data, exporting
exporting files from

libraries, 205-206
exporting libraries as 

templates, 206

data formats, importing,
54-56

data, importing
in Bento 2, 63
cleaning up imported 

data, 62-63
CSV (command-

separated-values) 
data, 57-62

data formats, 54-56
importing libraries as 

templates, 206
into existing libraries,

200-204
overview, 53-54, 199

data structure (iCal), 132

databases. See personal
databases

date and time field 
controls, 79-80

Date field (Garden/Nature
log), 170

date fields, 16
as-of dates, 168
date and time field 

controls, 79-80
entering current dates, 27
Garden/Nature log, 168
Start Date field (Exercise

Log), 79
Stop Date field (Exercise

Log), 77-78

Delete Field command
(Insert menu), 38

Delete Library command
(Edit menu), 24

Delete Selected Record(s)
command (Records 
menu), 33

deleting
fields in Bento 1, 38
libraries, 24
records, 33

Details layout (Projects 
template), 141

dialogs
Calculation, 82-83
Home, 11
New Library, 23, 67
Preferences, 12
Reset Synchronization Data,

120-121
Theme Chooser, 47

displaying event details, 131

do-not-contact list,
organizing into Bento
Quickie, 229-230

downloadable files, 6

downloading
Bento, 11
bulk email data from Bento

with Constant Contact,
222-223

with Vertical Response,
220-222

Duplicate Field command
(Insert menu), 38

Duplicate Form command
Forms menu, 46
Insert menu, 180

Duplicate Record command
(Records menu), 27

duplicating
fields in Bento 1, 38
forms, 46

duration fields, 16, 84-86

E

ease of use (Bento), 9

Edit menu commands
Delete Library, 24
Spelling, 27

editing
events, 131
fields, 36, 90-92

email lists
bulk email (spam)

CAN-SPAM act, 210-211
downloading bulk email

data to Bento, 220-223
ISP rules, 210
overview, 208-209
sending via vendors,

211-212
uploading bulk email

data from Bento,
213-220

email lists, 207
mail filters, 209-210
Mail records, working with,

146-147

events (iCal)
converting to To Dos, 130
displaying event details, 131
editing, 131
sharing with MobileMe,

148-150
synchronizing, 137

Exercise Log library
automatic counter fields, 89
Calories Rate field, 81-82
checkbox fields, 88
choice fields, 87
currency fields, 89
date and time field controls,

79-80
Duration field, 84-86
overview, 75-77
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rating fields, 90
Start Date field, 79
Stop Date field, 77-78

Export command (File
menu), 206

exporting data
exporting files from

libraries, 205-206
exporting libraries as 

templates, 206

F

Fashion Parade Bento
Quickie, 231

fields
adding to Address Book

library, 116-118
address fields

adding to forms, 72-73
in Bento 1, 69-70
in Bento 2, 70-72
overview, 69

automatic counter fields,
16, 89

calculation fields, 17
Calculation dialog, 82-83
Calories Burned field, 86
Duration field, 84-85
overview, 82

changing type of, 14
checkbox fields, 16, 88
choice fields, 16, 87
creating, 38
currency fields, 16, 89
customizing, 148
date fields, 16

date and time field 
controls, 79-80

Start Date field (Exercise
Log), 79

Stop Date field (Exercise
Log), 77-78

definition, 13
deleting, 38
duplicating, 38
duration fields, 16
editing, 90-92
Exercise Log fields

Calories Rate field, 81-82
date and time field 

controls, 79-80
Start Date, 79
Stop Date, 77-78

file list fields, 17
adding to group 

projects, 181-183
form fields, customizing,

48-50
formatting, 14
Garden/Nature log fields

Activity field, 170
Amount field, 170
Crops field, 170
Date field, 170
date fields, 168
high/low temperature

fields, 168
Highlights of the Day

field, 169
media fields, 169
Notes field, 170

media fields, 16
message list fields, 17
names, 14
Notes field (Project Notes

library), 156
number fields, 16

Calories Rate field, 81-82
creating and formatting,

81-82
rating fields, 16, 90
related records list fields, 17

adding data to, 103
adding to forms, 100
formatting, 101-105

restrictions on, 105-106
reviewing related

records, 103-104
summarizing, 103

removing, 148
renaming, 38, 148
storyboard fields

Image, 193
Length, 193
Notes, 193
Place, 193
related record fields,

195-196
Script, 193
Sequence, 193
Setting, 193
Status, 193
Time, 193
Title, 193

text fields, 16
time fields, 16, 79-80

Fields list (Bento window),
22, 37-38

file list fields, 17
adding to group projects,

181-183

File menu commands
Address Book and iCal

Setup, 13
Export, 206
Import, 23, 58
New Collection, 108
New Library, 23, 154
New Smart Collection, 109
Print, 28

FileMaker, 6-7

files
downloadable files, 6
organizing, 183-184

filters, mail, 209-210
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finding data
with Advanced Find, 31-33
with search field, 29-31

folders, Library/Application
Support/Bento, 13

form view of Classes 
template, 45-46

Format menu commands,
Themes, 48

formatting
automatic counter fields, 89
checkbox fields, 88
choice fields, 87
currency fields, 89
fields, 14
number fields, 81-82
rating fields, 90
related records list fields,

101-102

forms
adding to Address Book

library, 116
address fields, adding, 72-73
creating for group projects,

180-181
dragging related libraries

onto, 98-99
duplicating, 46
fields, customizing, 48-50
horizontal separators, 50
lists, adding, 72-73
overview, 43
renaming, 46
revising, 148
spacers, 50
themes, 47
tools, 51-52

Forms menu commands
Duplicate Form, 46
Rename Form, 46

formulas. See
calculation fields

G

Garden/Nature log
analyzing database, 173-175
creating basic library,

167-170
creating related libraries,

170-172
planning, 165-167
Smart Collections, 173-175

Gift List Bento Quickie, 232

group projects
Many People = Many

Projects structure, 187
One Person = Many Projects

structure, 184-185
One Person = One Project

structure
file list fields, 181-183
file organization,

183-184
form creation, 180-181
overview, 179-180

One Project = Many People
structure, 186

organizing, 178
planning, 177-178

H

hard disk backups, impor-
tance of, 123

Highlights of the Day field
(Garden/Nature log), 169

history of storyboards, 192

Home dialog, 11

horizontal separators, 50

I

iCal, 142-146
Bento iCal libraries, 132-134
Calendar list, 128
calendars, 130
data structure, 132
events

converting to To 
Dos, 130

displaying event 
details, 131

editing, 131
sharing with MobileMe,

148-150
Mail data detectors with,

134-135
managing calendar 

data, 135-137
overview, 127
related record fields,

implementing, 196
Search Results pane,

128-130
synchronizing iCal 

events, 137
To Dos, 128

converting to 
events, 130

displaying event 
details, 131

editing, 131

.ics files, 132

Image field
(storyboards), 193

Import command (File
menu), 23, 58

importing data
importing libraries as 

templates, 206
into existing libraries,

200-204
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legacy data
in Bento 2, 63
cleaning up imported

data, 62-63
CSV (command-

separated-values) 
data, 57-62

data formats, 54-56
overview, 53-54

overview, 199

Ins & Outs library
creating, 96-98
dragging onto Inventory

library form, 99
relating to Inventory 

library, 98-99

Insert menu commands
Current Date and Time, 27
Delete Field, 38
Duplicate Field, 38
Duplicate Form, 180
New Field, 38, 156

Internet Service Providers
(ISPs), bulk email rules, 210

inventory
Inventory library

overview, 93-96
tracking inventory with

relationships, 98-105
Software Inventory Bento

Quickie, 227-228

Inventory library
overview, 93-96
tracking inventory with

relationships, 98
adding data to related

records list field,
103-105

adding related records
list field, 100

dragging related
libraries onto forms,
98-99

formatting related
records list field,
101-102

restrictions on related
records list field,
105-106

reviewing related
records, 103-104

summarizing related
records list field, 103

iPhone, synchronizing
Address Book with, 121-123

ISPs (Internet Service
Providers), bulk email 
rules, 210

iTunes, limitations of, 8

J-K-L

Jokes Bento Quickie, 230

jokes, organizing into Bento
Quickie, 230

layouts, 191

legacy data, importing into
Bento

in Bento 2, 63
cleaning up imported data,

62-63
CSV (command-separated-

values) data, 57-62
data formats, 54-56
overview, 53-54

legislation, CAN-SPAM act,
210-211

Length field 
(storyboards), 193

libraries
Address Book library

adding fields to, 116-118
adding forms to, 116
Bento/Address Book

integration, 115-116
creating, 113
example, 114-115

Contacts library
address fields, 69-73
creating, 66-67
lists, 69-73
overview, 65-66
views, 67-69

creating, 23, 154-155
from Projects template,

140-141
from scratch, 96-98

definition, 18
deleting, 24
email libraries

downloading bulk email
data to Bento, 220-223

uploading bulk email
data from Bento,
213-220

Exercise Log
automatic counter 

fields, 89
Calories Burned field, 86
Calories Rate field, 81-82
checkbox fields, 88
choice fields, 87
currency fields, 89
date and time field 

controls, 79-80
Duration field, 84-85
overview, 75-77
rating fields, 90
Start Date field, 79
Stop Date field, 77-78

exporting as templates, 206
exporting data from,

205-206
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Garden/Nature log libraries
analyzing database,

173-175
basic library, creating,

167-170
related libraries, creating,

170-172
Smart Collections,

173-175
iCal libraries, 132-134
importing as templates, 206
importing data into, 23,

200-204
Ins & Outs

creating, 96-98
dragging onto Inventory

library form, 99
relating to Inventory

library, 98-99
Inventory

overview, 93-96
tracking inventory with

relationships, 98-106
naming, 23
Project Notes library

adding list of related
records to, 157-160

creating new library,
154-155

creating Notes field, 156
overview, 154
relationships, 161-164

Projects library, 139-141
in Bento 1, 151-152
in Bento 2, 152
customizing, 153
overview, 151

storyboard 
libraries, creating

Image field, 193
Length field, 193
Notes field, 193

overview, 192-193
Place field, 193
related record fields,

195-196
Script field, 193
Sequence field, 193
Setting field, 193
Status field, 193
Time field, 193
Title field, 193

Libraries & Fields pane, 39-40

Library/Application
Support/Bento folder, 13

lists
adding to forms, 72-73
in Bento 1, 69-70
in Bento 2, 70-72
Calendar list (iCal), 128
email lists

bulk email (spam),
208-212

downloading bulk email
data to Bento, 220-223

mail filters, 209-210
overview, 207
uploading bulk email

data from Bento,
213-220

Gift List Bento Quickie, 232
overview, 69
To Dos list (iCal), 128

converting to 
events, 130

login options, 10

logs, Garden/Nature
analyzing database, 173-175
creating basic library,

167-170
creating related libraries,

170-172
planning, 165-167
Smart Collections, 173-175

M

Mail data detectors
with iCal, 134-135
updating Address Book

with, 124-125

Mail records, working with,
146-147

mailing lists. See email lists

managing calendar data
(iCal), 135-137

Many People = Many 
Projects structure (group
projects), 187

many-to-many 
relationship, 178

Mati, Jose, 192

media fields, 16, 169

message list fields, 17

MobileMe synchronization,
118-120, 124, 148-150

moving form fields, 48

N

naming
fields, 14
libraries, 23

Nature log. See
Garden/Nature log

navigating Bento window
controlling which sections

are displayed, 22-23
Fields list, 22, 37-38
overview, 21-22
Records area, 22

creating records, 27
deleting records, 33
entering text data, 27-28
finding data, 29, 31-33
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overview, 24-26
printing records, 28-29

Source list, 22, 37

need for Bento, 8

New Collection command
(File menu), 108

New Field command (Insert
menu), 38, 156

New Library command (File
menu), 23, 154

New Library dialog, 23, 67

New Record command
(Records menu), 27

New Smart Collection 
command (File menu), 109

Nexts Bento Quickie,
226-227

Nos Bento Quickie, 229-230

notes, Project Notes library
adding list of related

records to, 157-160
creating new library,

154-155
creating Notes field, 156
overview, 154
relationships, 161-164

Notes fields
Garden/Nature log, 170
Project Notes library, 156
storyboards, 193

number fields, 16, 81-82

O

obtaining Bento, 11

One Person = Many Projects
structure (group projects),
184-185

One Person = One Project
structure (group projects)

file list fields, 181-183
file organization, 183-184
form creating, 180-181
overview, 179-180

One Project = Many 
People structure (group
projects), 186

one-to-many 
relationship, 178

one-to-one relationship,
178, 191

organizing. See also
Bento Quickies

files, 183-184
group projects, 178

Overview form (Projects 
template), 140

P

panes, Libraries & Fields,
39-40

pasting data into table
views, 36-37

PDAs (Personal Digital
Assistants), synchronizing
Address Book with, 123

personal databases
access to, 9-10
capabilities of, 8-9
collections

definition, 18
overview, 18-19
Smart Collections, 19-20

Crops, 170-171
ease of use, 9
fields. See fields
libraries. See libraries
need for, 8
records. See records

Place field (storyboards), 193

planning
Garden/Nature log, 165-167
group projects, 177-178
storyboards, 189-191

preferences, setting, 40

Preferences command (Bento
menu), 40

Preferences dialog, 12

Print command (File 
menu), 28

printing records, 28-29

procedural programming, 9

programming, 9

Project Notes library
adding list of related

records to, 157-160
creating new library,

154-155
creating Notes field, 156
overview, 154
relationships, 161-164

Projects library, 139-141
in Bento 1, 151-152
in Bento 2, 152
customizing, 153
overview, 151

pull technology, 208

push technology, 124, 208

Q

queries (SQL), 190

Quickies
Clippings, 229
Fashion Parade, 231
Gift List, 232
Jokes, 230
Nexts, 226-227
Nos, 229-230
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overview, 225
Recipes, 230-231
Shopping Sources, 231
Software Inventory, 227-228

R

rating fields, 16, 90

Recipes Bento Quickie,
230-231

recipes, organizing into
Bento Quickie, 230-231

record fields (storyboards),
195-196

Record menu commands,
Advanced Find, 31-33

records
adding to collections, 108
adding to Project Notes

library, 157-160
Address Book records,

142-146
collections

adding records to, 108
creating empty 

collections, 108
creating from selected

records, 109
definition of, 107
example, 107
Smart Collections,

109-111
creating, 27
creating collections 

from, 109
definition, 17-18
deleting, 33
entering data into. See

data entry
iCal records, 142-146

Mail records, 146-147
printing, 28-29
related records

Address Book records,
142-146

iCal records, 142-146
Mail records, 146-147
related records list fields,

100-106
related records, reviewing,

103-104
table views

in Bento 1, 33-35
in Bento 2, 35-37
editing fields with

(Bento 2), 36
pasting data into in

(Bento 2), 36-37
sorting (Bento 2), 36

Records area (Bento win-
dow), 22

creating records, 27
deleting records, 33
entering text data, 27-28
finding data

with Advanced Find,
31-33

with search field, 29-31
overview, 24-26
printing records, 28-29

Records menu commands
Delete Selected 

Record(s), 33
Duplicate Record, 27
New Record, 27

related records
adding to Project Notes

library, 157-160
Address Book records,

142-146
iCal records, 142-146
Mail records, 146-147

related records list fields, 17
adding data to, 103-105
adding to forms, 100
formatting, 101-102
restrictions on, 105-106
reviewing related

records, 103-104
summarizing, 103

reviewing, 103-104

related records list fields, 17
adding data to, 103-105
adding to forms, 100
formatting, 101-102
restrictions on, 105-106
reviewing related records,

103-104
summarizing, 103

relational databases, 190

relationships
bidirectional 

relationships, 191
creating

adding data to 
related records list
field, 103-105

adding related records
list field, 100

by dragging related
libraries onto 
forms, 98-99

formatting related
records list field,
101-102

restrictions on 
related records list
field, 105-106

summarizing related
records list field, 103

definition, 190
many-to-many

relationship, 178
one-to-many 

relationship, 178
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one-to-one relationship,
178, 191

in Project Notes library,
161-164

reviewing related records,
103-104

tracking inventory with
adding data to related

records list field,
103-105

adding related records
list field, 100

dragging related
libraries onto
forms, 98-99

formatting related
records list field,
101-102

restrictions on related
records list field,
105-106

reviewing related
records, 103-104

summarizing related
records list field, 103

unidirectional 
relationships, 191

removing. See deleting

Rename Form command
(Forms menu), 46

renaming
fields, 38, 148
forms, 46

Reset Synchronization Data
dialog, 120-121

resizing form fields, 48

reviewing related records,
103-104

revising forms, 148

roles of Bento, 8-9

rows, 190

S

Script field (storyboards),
193

Search Results pane (iCal),
128-130

sending bulk email via 
vendors, 211-212

Sequence field 
(storyboards), 193

setting Bento preferences, 40

Setting field 
(storyboards), 193

sharing
Address Book contacts with

MobileMe, 148-150
iCal events with MobileMe,

148-150

Shopping Sources Bento
Quickie, 231

shopping sources, organizing
into Bento Quickie, 231

single-value fields in 
storyboards, 193-194

Smart Collections, 19-20,
109-111, 173-175

Software Inventory Bento
Quickie, 227-228

sorting table views, 36

Source list (Bento 
window), 22, 37

spacers, 50

spam
CAN-SPAM act, 210-211
downloading bulk email

data to Bento
with Constant Contact,

222-223
with Vertical Response,

220-222

ISP rules, 210
mail filters, 209-210
overview, 208-209
sending via vendors, 211-

212
uploading bulk email data

from Bento, 213-214
with Constant Contact,

217-220
with Vertical Response,

214, 216

spell check, 27

Spelling command (Edit
menu), 27

Spotlight, 183

spreadsheets, importing, 63

SQL, 190

Start Date field (Exercise
Log), 79

Status field 
(storyboards), 193

Stop Date field (Exercise
Log), 77-78

storyboards
history of, 192
planning, 189-191
storyboard 

libraries, creating
Image field, 193
Length field, 193
Notes field, 193
overview, 192-193
Place field, 193
related record fields,

195-196
Script field, 193
Sequence field, 193
Setting field, 193
Status field, 193
Time field, 193
Title field, 193

suitability of Bento for, 192
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summarizing related records
list fields, 103

synchronizing
Address Book, 118

with iPhone, 121-123
with MobileMe
with MobileMe push

technology, 124
with PDAs, 123

definition of, 118
iCal events, 137
MobileMe synchronization,

118-120, 124, 148-150

T

table views
of Classes template, 43-44
editing fields with 

(Bento 2), 36
in Bento 1, 33-35
in Bento 2, 35-36

editing fields with table
views, 36

pasting data into table
views, 36-37

sorting table views, 36
pasting data into 

(Bento 2), 36-37
sorting (Bento 2), 36

tables, 190

temperature fields
(Garden/Nature log), 168

templates
Classes template

form view, 45-46
table view, 43-44

exporting libraries as, 206
importing libraries as, 206

text data, entering into
records, 27-28

text fields, 16

Theme Chooser dialog, 47

themes, adding to forms, 47

Themes command (Format
menu), 48

time fields, 16
date and time field controls,

79-80
entering current time, 27
storyboards, 193

Time Machine, 123

Title field (storyboards), 193

To Dos (iCal), 128
converting to events, 130

tools, Form tools, 51-52

tracking inventory 
with relationships

adding data to related
records list field, 103-105

adding related records list
field, 100

dragging related libraries
onto forms, 98-99

formatting related records
list field, 101-102

restrictions on records list
field, 105-106

reviewing related records,
103-104

summarizing related
records list field, 103

types (fields)
changing, 14
definition, 13

U

unidirectional 
relationships, 191

unsolicited bulk email. See
bulk email

updating Address Book with
data detectors, 124-125

uploading bulk email data
from Bento, 213-214

with Constant Contact,
217-220

with Vertical Response,
214-216

V-W-X-Y-Z

vendors, sending bulk email
with, 211-212

verifying imported data, 62

Vertical Response
downloading bulk email

data to Bento, 220-222
uploading data from Bento,

214-216

View menu commands,
Customize Form, 48

views
form view, 45-46
table views

of Classes template,
43-44

editing fields with
(Bento 2), 36

in Bento 1, 33-35
in Bento 2, 35-37
pasting data into (Bento

2), 36-37
sorting (Bento 2), 36

web sites, 6
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