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Rediscover Charts

Brand new to Office 2007 is the new version of Charts to replace the
old Microsoft Graph Chart and the Microsoft Excel Graph—both of
which were inserted as OLE objects in previous versions of Office.
While you can still insert these OLE objects, you will be hard-pressed
to find an opportunity to do so, given that the renovated charts in
Office 2007 look amazing and function much better.

NOTE
OLE stands for object linking and embedding, a technology
prevalent within Office to run one program inside another
program. Microsoft Graph, the predecessor to Office 2007
Charts, used OLE. So, although graphs were technically part of
PowerPoint, graph editing was actually done inside an
entirely different program with menus and commands that
are completely distinct from PowerPoint’s. Office 2007 Charts
do not use OLE and are just another feature that is seamlessly
part of PowerPoint.

This isn’t a tutorial on how to make pivot tables or economic regres-
sions, or how to balance your company’s finances. Instead, let us walk
you through the new features that the reworked charts have to offer,
and hopefully some of the tips and tricks we show you will enable
you to do your job more efficiently.

■ Inserting Excel Charts into
PowerPoint

■ Getting Inside a Chart

■ Understanding Chart Layouts

■ Understanding Chart Styles

■ Creating and Using Chart
Templates

■ Manipulating Data

■ Dragging the Pie

■ Working with Legacy Graphs
and OLE Objects

■ Converting to Office 2007
Format
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6 | Rediscover Charts

Inserting Excel Charts into PowerPoint
There are a couple of important ways to get a chart into your presentation: You could use
the commands found on the Ribbon to insert a generic chart with some default data, or you

could copy and paste an existing chart from an Excel spreadsheet that contains the data you need.

Because charts are a graphical representation of data, and this data is usually in the form of tables or
grids that you can find in Microsoft Excel, we’re going to walk through copying and pasting charts
from Excel first. Following that, we go into how to create a chart from scratch in PowerPoint.

Copying and Pasting
Charts are primarily a native Excel object. The data represented by the chart is contained within cells
in a spreadsheet, but when you need to create a presentation, the best way to get a chart into
PowerPoint from Excel is to copy and paste it.

Aside from the Copy and Paste buttons in the Clipboard group on the Home tab, you can use short-
cut keys Ctrl+C and Ctrl+V to copy and paste, respectively. The default format in which the chart gets
pasted is the Microsoft Office Graphic Object, which creates a native chart on the PowerPoint slide.

TIP
Charts can be pasted as other types, such as an OLE object or as a picture. Use Paste Special to
see other formats, or use Ctrl+Alt+V as a shortcut.

After your chart is pasted, the Paste Options button appears in the lower right side of the chart (see
Figure 6.1).
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Figure 6.1 

The Paste Options button allows you to specify certain paste options.
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Inserting Excel Charts into PowerPoint

The following options are available after pasting a chart from Excel into PowerPoint:

■ Chart (Linked to Excel Data)—The chart updates when the data is changed in Excel.

■ Excel Chart (Entire Workbook)—The data is copied over to PowerPoint.

■ Paste as Picture—An image of the chart is copied but cannot be changed further.

The following options relate to the presentation’s theme and how the chart looks after it is pasted:

■ Keep Source Formatting

■ Use Destination Theme

By default, Chart (linked to Excel data) and Use Destination Theme are selected. In general, you want
to leave your chart linked to Excel data in case the data in your Excel spreadsheet changes and you
want the chart to update to reflect the changes. If you choose an option other than this, the chart
does not change when the data in the cells change.

CAUTION
Keeping the Excel data inside your chart can have implications if you share the presentation
with others because it can contain formulas or calculations that you might not want everyone
to have access to. If this is a concern, choose the Paste as Picture option instead.

Inserting an Excel Chart from Within PowerPoint
To insert an Excel chart from scratch in PowerPoint, do the following:

1. Select the Insert tab.

2. Select Chart.

3. Choose a Chart Type (see Figure 6.2).

4. Click OK.

Notice that the following happens when you click OK:

1. Excel launches in a new window.

2. Both windows are resized to share the whole screen side by side (see Figure 6.3).

3. Fake sample data is created.
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Figure 6.2 

Insert a Chart from the Ribbon.
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Figure 6.3

PowerPoint and Excel share the screen after inserting a new chart.

09_0789737248_ch06.qxd  11/16/07  1:14 PM  Page 104



Getting Inside a Chart

NOTE
As we explain later in this chapter, if you don’t own Excel, Microsoft Graph appears instead of
Excel.

Getting Inside a Chart
Charts are made up of the typical grids, legends, and other elements you would expect to
find in a chart. The interesting part is how the meat of the chart is actually created: It uses

shapes. This might sound familiar considering that SmartArt is made up of shapes, too.

Formatting
Because the contents of the chart are regular shapes, everything you can do to shapes can be done to
the bars, pie pieces, lines, and any other chart piece you can find. (We discuss formatting shapes in
Chapter 12,“Formatting Shapes, Text, and More.”)

Let’s walk through an example in which we format a series with some cool new effects. Start by
inserting a default chart using the methods discussed in the earlier section.

1. Select a bar, series, or any piece of the chart.

2. Modify your selection using any of the Shape Styles commands from the Format tab to change
the shape by adding effects, fills, and so on. Then click on Format, Format Selection.

3. Select the Fill option on the left of the Format Selection dialog (see Figure 6.4).
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Figure 6.4

Click Format Selection to bring up the Format Chart Area dialog, where you can format portions of the chart.
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4. Click on Gradient Fill and choose some nice colors. At this point, you can also apply a Border
Style, Border Color, Shadow, or 3D Format. Try to avoid too much cluttering here. A simple
shadow goes a long way (see Figure 6.5).
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Figure 6.5

By applying a few fills and styles to pieces of a chart, you can end up with a pretty formatted chart series like this.

5. Repeat with the other series in your chart as needed.

Formatting a Specific Piece of a Chart
From the Current Selection group on the Format tab, you can select various parts of the chart, as well
as use the Format Selection dialog to access additional options specific to each part of the chart (see
Figure 6.6).

Figure 6.6

The Current Selection group and the Format Selection button.
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Understanding Chart Layouts

Here’s how you can discover these options:

1. Select a piece of the chart or use the drop-down list from the Current Selection group.

2. Click on Format Selection.

NOTE
The Format Selection dialog is modeless. This means that you can keep it open, continue work-
ing on your presentation, select a different part of the chart, and notice the dialog change,
depending on what you have selected. This also means that if you click somewhere on your
chart that you did not mean to, you can format it accidentally.

Now you can click around on various pieces of the chart with the Format Selection dialog open, and it
adapts to what you have selected. Notice with an Axis selected, Axis Options is the first tab in the dia-
log from which you can modify the units, scale, tick types, and so on.

With this powerful tool, you can completely customize your chart to your liking. Experiment with the
various menus in the Format Selection dialog to see how you can enhance your charts in ways other
than what we’ve discussed here.

Inserting Objects into a Chart
Similar to the legacy charts feature, the new 2007 charts feature allows the insertion of Shapes,
Pictures, ClipArt, Textboxes, and WordArt—all of which behave exactly as they would outside the
chart.

The great thing about this is that the objects you draw into your chart remain there even if you move,
resize, or modify your chart. You can also drag and drop objects into a chart.

This is especially useful when annotating your chart with arrows and text.

Understanding Chart Layouts
Within each chart type, there are various layouts that determine where pieces of the chart
are located and how they look.

To change the layout of your chart, do the following:

1. Select a chart.

2. Select the Design tab under Chart Tools.

3. Click Chart Layouts to drop down the gallery of available layouts and see a small thumbnail of
how it will look (see Figure 6.7).

4. Click the thumbnail to apply the layout.
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Figure 6.7

Change the layout of your chart type. Note that the number of layouts changes based on the type of chart you have
selected.

Understanding Chart Styles
Forty-eight preset chart styles can be found on the Design tab under Chart Tools. These
styles enable you to modify the colors and borders of the series and backgrounds of the

chart.

Use these as a starting point, and then customize according to how you want your chart to look:

1. Select a chart. Figure 6.8 shows a chart with default styles.
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Figure 6.8

This is the default PowerPoint bar chart with only the data modified.
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Understanding Chart Styles

2. Select the Design Tab from the Chart Tools section.

3. From the Chart Styles group, click the drop-down arrow to open the gallery and see a full list of
preset Styles (see Figure 6.9).

NOTE
Unfortunately, Live Preview does not work for Chart Styles.
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Figure 6.9

The gallery of styles you can apply to a Chart.

4. Select one of the styles.

5. Continue modifying your chart by adding effects to series and changing colors if necessary
(see Figure 6.10).

Figure 6.10

A chart created by using one of the Chart Styles and then modified more to suit our needs.
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Creating and Using Chart Templates
Think of chart templates as saving your chart formatting in case you want to apply it to
another chart.

A chart template is actually a file (.crtx) that is saved onto your hard drive. The format is a package
containing XML that describes the content of the chart.

Creating a Template
To create a chart template, do the following:

1. Create a chart.

2. Format it any way that you want.

3. Select the Design tab under the Chart Tools area of the Ribbon.

4. Select the Save As Template option (see Figure 6.11).
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Figure 6.11

The Save As Template option allows you to save a chart template of your own and use it again later.

5. Choose a name and location to save the .crtx file.

NOTE
The default location where your templates will be saved will look something like this:
C:\Documents and Settings\<User Name>\Application Data\Microsoft\Templates.

Using an Existing Template
After you have templates at your disposal, you can use them in two ways:

■ After you create a chart, you can select a chart template for the type that it should be.

■ With an existing chart, you can change its type to be that of a chart template.

When you first insert a chart from scratch in PowerPoint, the top option on the left pane is Templates
(refer to Figure 6.2). When Templates is selected, the right pane contains all the chart templates
located in the default Chart Template folder (C:\Documents and Settings\<User Name>\Application
Data\Microsoft\Templates). Select one of the templates, and your newly inserted chart is given the
same formatting and design as the template you saved.
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Manipulating Data

Similarly, to change the type of an existing chart to that of one of your chart templates, do the 
following:

1. With the chart selected, click the Design tab under Chart Tools.

2. Select Change Chart Type from the Type group.

3. Select Templates from the left pane.

4. Select a template from the right pane.

The template’s formatting is applied to the selected chart.

Managing Templates
This option is mostly for convenience, used for finding the folder in which templates are stored by
default. It launches the directory containing the chart templates that is found by default at
C:\Documents and Settings\<User Name>\Application Data\Microsoft\Templates. This happens in a
separate Windows Explorer window for convenience.

You can access the Manage Templates feature from the Insert Chart dialog.

Manipulating Data
Charts are dependent on data. If no data exists, a set of default numbers is created in a
table.

If you find yourself with a chart in PowerPoint and you want to modify the data that it is associated
with, you can choose from a couple of methods.

First, you can modify the data by clicking the Select Data button (see Figure 6.12):
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Figure 6.12

Use the Select Data feature to modify the data your Chart contains.

1. Select an existing chart.

2. From the Chart Tools section, select the Design tab.

3. Choose Select Data.

4. Notice now that Excel launches, if it was not already open, and the Select Data Source dialog
opens with the data that your chart was created from selected (see Figure 6.13).
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Figure 6.13

This is functionality that was never even dreamed of with the MS Graph Object that was the default chart type in previ-
ous versions of Office.

5. Modify the selection of cells or manually change the rows/columns using the dialog.

Optionally, you can modify the data directly by choosing the Edit Data option. Select Data allows you
to modify the set of data, but by using Edit Data, you can actually change cells and manipulate the
actual numbers. Because PowerPoint is not a spreadsheet tool, it makes sense that Edit Data launches
Excel—if it is not already open—and resizes both PowerPoint and Excel to appear side by side, allow-
ing you to work in both.

To use Edit Data, do the following:

1. Select an existing chart.

2. From the Chart Tools section, select the Design tab.

3. Choose Edit Data.

4. Notice that Excel launches (if it was not already open) and you’re able to change the data that
your chart uses.

TIP
Refresh Data is located on the same group as Select Data and Edit Data, and it is pretty
straightforward. If you have pasted a chart and selected the Excel Chart (entire workbook)
option with the Paste Options tag as described previously, Refresh Data is disabled because
the chart is no longer linked to data within an Excel spreadsheet.
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Dragging the Pie

Dragging the Pie
Pie charts are a different breed. For instance, the default data provided with a pie chart is
different from other charts. In addition, with pie charts, special rules are applied when

pieces of the pie are dragged around. Instead of allowing you to move your pie all over the place
while you drag, the pieces of the pie guide themselves away from the center of the pie but not any-
where else.

To see this in action, do the following:

1. Insert a pie chart.

2. Click once on a piece of a pie or select all the pieces (using the current selection list).

3. Click and hold to drag the pieces around.

4. Notice here that the pieces move toward and away from the center of the pie but not any-
where else.

TIP
You can also add commentary to your charts using text boxes and shapes.

When you want to emphasize a certain piece of the pie, drag it away from the others, as shown in
Figure 6.14.
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Figure 6.14

A piece of the pie emphasized.
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TIP
Spruce up your charts by removing the plot area. This reduces clutter, and the chart it is still
readable. Simply click on the background and press the Delete button.

Working with Legacy Graphs and OLE Objects
In this section, we travel back in time and explore the way in which we survived before
SmartArt and the new charts came into existence.

We call these other objects legacy because they existed long before PowerPoint 2007. It is entirely
possible that you might not be able to use the new SmartArt diagrams or charts with PowerPoint
2007. For instance, if your company has set a group policy that disables them, you are left with using
only the legacy charts and graphs that exist as OLE objects.

In the following sections, we show you how to make full use of these OLE objects, including how to
replace the ugly chart defaults that are unimpressive compared to the native, PowerPoint 2007,
twenty-first century graphics.

Converting to Office 2007 Format
Let’s take a look at what happens when you insert a legacy chart object and then double-click to acti-
vate it in PowerPoint 2007.

To insert a legacy chart, do the following:

1. Select the Insert tab.

2. Click on Object.

3. Select either Microsoft Graph Chart or Microsoft Office Excel Chart.

4. Now de-select the object you inserted by clicking somewhere else on the slide, and then select
the chart again.

Each time you click on a legacy chart, you are prompted with the question,“Do you want to convert
this chart to the new format?” (Figure 6.15 illustrates this.)
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Figure 6.15

Decide whether you would like to convert your legacy chart OLE object into a native 2007 chart.
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Converting to Office 2007 Format

The decision here depends on whether you want to be able to fully use your chart with all the power
of PowerPoint 2007, which is described in this chapter. The drawback to converting is that users of
previous versions of PowerPoint are no longer be able to edit your chart.

OLE Facts
It’s important to note a couple of random OLE facts here because somewhere down the line, you
might have an OLE object in your presentation (such as a legacy chart) and might notice one or two
quirks when working with them.

WHY CAN’T I UNDO INSIDE MY OLE?

While you’re going along knocking out charts left and right, you might notice that something strange
occurs when you try to undo an operation (Ctrl+Z) while the OLE object is activated. With a chart in
edit mode or with any activated OLE object, if you try to undo many times, it’s ineffective and proba-
bly only undoes the last thing you’ve done.

Although this might be a nuisance to those of us who make more mistakes than a first grader writing
a book report, there is a simple, yet tedious workaround. When you make any set of changes while in
an activated OLE object, double-click elsewhere to deactivate the chart. To you, nothing looks differ-
ent, but internally PowerPoint logs it as an event it knows about. Now when you undo in deactivated
mode, that event is undone as one operation.

To summarize: Enter edit mode, make your change, exit edit mode to let PowerPoint know what hap-
pened, and then you are able to undo in PowerPoint as much as you want.

This oddness exists because, technically, chart editing is happening inside a different program and
not in PowerPoint. So, when you’re making each individual chart edit, PowerPoint has no idea what’s
happening and can’t save these operations for undo. By quickly exiting from editing the chart back to
PowerPoint, PowerPoint gets control back and can save everything that’s happened so far.

CORRUPTION

The format that your files are saved to in PowerPoint 2003 and earlier is binary, meaning that it’s a
bunch of 1s and 0s. This lends itself well to corruption of data because if just one of those 1s or 0s is
flipped, your whole document could be ruined.

By adding an OLE object (such as the entire chart) inside your presentation, PowerPoint is adding a
ton of new data in binary format that’s a prime target for corruption. OLE data is fully editable, but
because of that, it’s complicated. Sometimes PowerPoint screws up, and you can lose your chart
entirely.

For this reason, you will often find that a common paradigm to follow is to first use and edit your
charts and OLE objects as OLE objects. When you’re done editing and have finalized it, copy the chart
and paste it as an image back into the desired spot. To do this, select the chart and copy (choose
Home tab, and on the Clipboard group select Copy, or simply press Ctrl+V). Then, click on the Paste
drop-down, select Paste Special (or press Ctrl+Alt+V), and select one of the picture formats, such as
Picture (PNG).

After you’ve done this, the pasted chart image can’t be edited, but the data there is much simpler and
potentially smaller.
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