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Foreword 

Innovations in technology require great minds. Yet how many of those innovations 
would be lost on those they were created for without the dedication of writers and 

editors who are committed to ensuring their success? At Microsoft we are privileged to 
work every day with brilliant engineers who build amazing products for our customers. 
We are equally privileged to work with teams of creative writers and editors who, as the 
shepherds of language and quality, build the important bridges between the promise 
of technology and the ability to understand its use. 

If you’ve spent any time at all as a writer or editor at Microsoft you’ve most likely had 
the experience of attending a session in one of our usability labs watching customers 
attempting to use early prototypes of a product. It’s often with mixed emotions that 
we watch customers who are unable, or only partially able, to use a new feature simply 
because the words on the user interface aren’t easy to follow or descriptive enough. 
We know the words in these early prototypes were probably created hastily by an 
overworked engineer using nerdy language that was not intended for primetime. We 
experience the frustration of both the engineer and the customer. And we know that, 
through language, we can make the customer experience much better. 

The Microsoft Manual of Style is the reference tool that all teams at Microsoft use 
to help ensure language quality. This guide lays the foundation for the language in our 
products and services, which, at the time of this publication, reach more than 1.7 billion 
people worldwide in more than 100 languages. As the sponsor of this publication I am 
honored to have had the experience of working with Elizabeth Whitmire during the last 
year as she readied this reference for public use. Elizabeth, along with Microsoft Press, 
other members of my team and the talented team of editors who are members of the 
Microsoft Editorial Board, have worked diligently to create this reference. We hope that 
you will find the Microsoft Manual of Style useful, that it will save you a lot of time, and 
that your own endeavors with language quality and editorial excellence are innovative 
and fruitful!

Suzanne Sowinska 
Director of Language Services 
Microsoft Corporation 
2011
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Introduction to the Fourth Edition

At Microsoft, the guiding principles for how we communicate the ideas and concepts 
behind our technologies, software, hardware, and services have remained the same 

over the years: consistency, clarity, and accuracy, and our desire to inspire as well as 
inform. However, change occurs rapidly in the world of technology, and so do the ways 
we talk about technology. Even expert editors need a set of vetted guidelines that keep 
them up to date and protect them from making the same decisions repeatedly or in 
isolation. This edition of the Microsoft Manual of Style is about standardizing, clarifying, 
and simplifying the creation of content by providing the latest usage guidelines that 
apply across the genres of technical communication—1,000 decisions you don’t have to 
make again. 

A style guide is by nature a work in progress. Despite the evolutionary nature of a 
reference project like this, the time is right to make this version of the Microsoft Manual 
of Style available outside Microsoft. This edition includes guidelines for the wired and 
global audience, cloud computing, publication on devices, social media, search engine 
optimization (SEO), and the natural user interface (NUI). It also provides guidance for 
the many ways Microsoft writers and editors communicate about technology today, 
including web content, blogging, video, and more.  

Gesture guidelines for the natural user interface (NUI) introduce what have been 
non-technical words such as flick, pinch, and tap into the realm of technical documen-
tation. Terms from gaming, such as achievement and badge, make their way into the 
general vocabulary of technical communicators who are exploring social and interac-
tive media. Other changes directly reflect shifts in the technology we write about. For 
example, the first version of the manual included abbreviation guidelines for kilobyte 
(abbreviated simply as K) and for megabyte, but not for gigabyte. In the world of cloud 
computing, we now include terabyte (TB), petabyte (PB), and on up to yottabyte (YB), 
or 1024. Other entries reflect the way that rapid technological change has affected our 
everyday language. While the Third edition maintained the hyphen in e-mail and the 
status of Web as a proper noun in Web site, the ubiquity of these terms in our daily lives 
has accelerated the adoption of the more streamlined email and website. And of course 
many new terms and concepts have emerged since 2004, such as app, cloud, and sync, 
and many popular new acronyms too, such as IM, PC, NUI, and SEO.

Although this Fourth edition aims to include as many relevant neologisms as 
possible and to represent the most current thinking of senior editors at Microsoft about 
their usage, a printed manual is, by necessity, a snapshot. As always, style is a matter 
of convention and consensus; the guidance offered here does not describe the only 
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correct way to write. Discerned through research and ongoing conversation within 
our company, these guidelines reflect the current state of our discussions about these 
concepts and terms. 

You may notice that examples are labeled as “Microsoft style” and “Not Microsoft 
style” rather than as “Correct” and “Incorrect.” We don’t presume to say that the 
Microsoft way is the only correct way. It’s simply the guidance that we follow in our 
workplace. In sharing it with others, we hope that the decisions we have made for our 
content professionals will help you in your own efforts to promote consistency, clarity, 
and accuracy.

What’s inside

■■ Microsoft style and voice  This chapter highlights the shift toward a lighter, 
friendlier tone in Microsoft content, with succinct guidelines for writing in the 
Microsoft voice. 

■■ Content for the web  This chapter can help you decide which type of web 
content best suits your intended audience. It offers guidance for the creation of 
effective text, video, and audio for the web and includes information about opti-
mizing your content—including blogs and wikis—for readability, search engines, 
and social media.

■■ Content for a worldwide audience  This chapter reflects the pervasive 
internationalization of information in the software industry. The Microsoft 
Manual of Style now includes substantial information about writing for a global 
audience. “International considerations” sections throughout the manual call 
attention to issues of localization, global English, and machine translation. 

■■ Accessible content  This chapter includes the latest guidance on accessibility 
for content, and how to describe accessibility features in software and hardware 
products and services. “Accessibility considerations” sections throughout the 
manual call attention to these concerns. 

■■ The user interface (UI)  This chapter includes content for the NUI and 
Windows Phone UI, and features illustrations of touch and gesture guidelines. 
To help you write about the user interface in new ways, there are guidelines 
for writing content for multiple platforms and a checklist for creating UI text, 
and more.
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■■ Procedures and technical content  This chapter includes topics on document 
conventions, cloud computing style, and other general technical issues. It also 
includes new guidance about reference documentation and code examples 
for software developers, making the manual a more relevant resource for all 
content that is created for this audience—from websites, to Help, to software 
development kits (SDKs).

■■ Practical issues of style  This chapter provides page layout guidelines and 
guidance for common style problems such as how to format titles and headings, 
lists, and numbers.

■■ Acronyms and abbreviations  This list contains acronyms and abbreviations 
that are commonly used in the software industry and a table of abbreviations of 
measurements.

■■ Grammar, Punctuation, Indexes and keywords  These chapters cover 
grammar and punctuation guidelines relevant to Microsoft style and provide 
resources for indexing content.

■■ Usage Dictionary  This section includes individual guidance for more than 
1,000 technical terms.

How to use this manual

The first part of the manual includes general topics that are organized by subject. 
The alphabetical usage dictionary follows with guidance about usage and spelling of 
general and computer-related terms. Topics provide information ranging from a simple 
note on the correct spelling of a term to a thorough review of what to do, why to do it, 
what to avoid, and what to do instead, with frequent examples.

Italic is used to call attention to words or phrases used as words rather than as a 
functional part of a sentence. For example: It is all right to use sync as an abbreviation for 
the verb synchronize. Examples of usage appear in quotation marks.

The Microsoft Manual of Style does not cover all terms or content issues that 
are specific to various Microsoft products and services. In addition, because legal 
guidelines change quickly and cannot be applied internationally, the Microsoft 
Manual of Style does not include content about legal issues. Information about 
Microsoft trademarking, including the trademark list, guidelines for usage, and 
licensing on a per-language basis can be found at http://www.microsoft.com/about 
/legal/en/us/IntellectualProperty/Default.aspx. 

http://www.microsoft.com/about/legal/en/us/IntellectualProperty/Default.aspx
http://www.microsoft.com/about/legal/en/us/IntellectualProperty/Default.aspx
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Other references

The following reference materials provide guidance for issues that are not included in 
the Microsoft Manual of Style:

American Heritage Dictionary of the English Language, 4th ed. Boston: Houghton Mifflin 
Company, 2000.

Chicago Manual of Style, 16th ed. Chicago: The University of Chicago Press, 2010.

Microsoft International Style Guides (http://www.microsoft.com/Language 
/en-US/StyleGuides.aspx), Microsoft Corp.

Windows User Experience Interaction Guidelines (http://msdn.microsoft.com/en-us 
/library/windows/desktop/aa511258.aspx), Microsoft Corp.

Associated Press Stylebook and Briefing on Media Law, 2010 ed. Associated Press, 2010.

Glenn, Cheryl and Gray, Loretta. Hodges Harbrace Handbook, 16th ed. Heinle Cengage 
Learning, 2007.
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Contact the Microsoft Editorial Board

The Microsoft Editorial Board welcomes your content suggestions and feedback about 
the Microsoft Manual of Style at mmstyle@microsoft.com. We read all feedback, but we 
cannot guarantee a personal response or that all suggestions will be addressed. Your 
contact information will be used solely to respond to any questions you may have and 
will not be retained. It will not be shared with any third party, and it will not be associ-
ated with other information you may have previously shared with Microsoft.

Microsoft respects your privacy. To learn more, please read our privacy statement at 
http://www.microsoftpressstore.com/title/9780735648715.

mailto:mmstyle%40microsoft.com?subject=
http://www.microsoftpressstore.com/title/9780735648715
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Errata & book support

We’ve made every effort to ensure the accuracy of this book and its companion 
content. Any errors that have been reported since this book was published are listed on 
our Microsoft Press site: 

http://www.microsoftpressstore.com/title/ 9780735648715

If you find an error that is not already listed, you can report it to us through the 
same page.

If you need additional support, email Microsoft Press Book Support at  
mspinput@microsoft.com.

Please note that product support for Microsoft software is not offered through the 
addresses above.

We want to hear from you

At Microsoft Press, your satisfaction is our top priority, and your feedback our most 
valuable asset. Please tell us what you think of this book at: 

http://www.microsoft.com/learning/booksurvey

The survey is short, and we read every one of your comments and ideas. Thanks in 
advance for your input!

Stay in touch

Let’s keep the conversation going! We’re on Twitter: http://twitter.com/MicrosoftPress

mspinput@microsoft.com
http://www.microsoft.com/learning/booksurvey
http://www.microsoft.com/learning/booksurvey
http://www.microsoftpressstore.com/title/ 9780735648715
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Content for the web

The web provides us with new ways to think about connecting with users and creating content for 
them. We have greater flexibility in how and what types of information we deliver to users than 

we did when print was the dominant medium.

Content types now include text, images, audio, video, and interactive presentations. Publishing 
feels instantaneous compared to print. And the web has become the foremost—and sometimes 
only—method for communicating with users. As a result, having a web content strategy is critical 
to content teams. The topics in this chapter provide high-level guidance for creating content for 
the web.

Make the right content choices

To make the right content choices, first ask these high-level questions:

■■ Who is the intended audience?

■■ What is the user’s goal? What is the user trying to accomplish?

■■ What is your goal for providing the content?

■■ What type of content will best meet the user’s needs and your objectives?

■■ Will a user access the content from a desktop, phone or other mobile device, a console—or all 
of these?

■■ Will the content be translated or localized? For more information, see Chapter 3, "Content for a 
worldwide audience".

■■ How will the user find the content?

■■ How will success be measured?

■■ What are the budget and schedule constraints?

Your answers to these questions will help narrow your options so that you can focus on the best 
approaches for your user. For example, you might decide that either text or video would be appropri-
ate for your user, but you know that your content will be localized into at least five languages, and 
you have a small initial budget for the project. Creating and localizing high-quality video is expensive, 
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/so you might choose text as the best choice to begin with and then, as you measure the text’s suc-
cess, you might be able to justify the larger investment in localized video.

Use the following table to help choose the type of web content to create:

If your user needs Consider this type of content Examples

To learn about a simple task 
or feature in an application

Procedural text with screen shots
Short screen-capture video, with or 
without audio

Procedure with screen shots: Remove a page break
Screen-capture video with audio: Search or move 
around in a document using the navigation pane

To learn about a complex 
task or a feature in an  
application

Screen-capture video, with or 
without audio
Procedural text with screen shots
Procedural text with embedded 
screen-capture video
End-to-end scenario descriptions 
or conceptual topics
Technical papers

Video with audio: Protecting a Word document 
with AD RMS
Procedure with screen shots: Add or remove text 
effects 
Procedure with screen-capture video: Create a 
theme
End-to-end scenarios: 
DirectAccess Test Lab for Windows Server 2008 R2
Network connection problems in Windows

Ongoing, regular 
communications from you

Blog
Microblog (such as Twitter)
Newsletter

OneNote, The Microsoft Office Blog; http://blogs.
office.com/b/microsoft-onenote/
Virtual PC Guy’s blog
TechNet Flash Newsletter

Ongoing engagement and 
participation with a like-
minded community

Wiki
Forum

TechNet wiki
Exchange Server Forum
Microsoft Answers; http://answers.microsoft.com 
/en-us

To learn something complex 
that takes time and practice

Online training
Technical white papers

Windows Phone 7 Training Course
Windows PowerShell Survival Guide

To learn high-level concepts 
about technology subjects

Concept papers
eBooks

An Enterprise Approach to Gov 2.0. Microsoft 
download center:
http://www.microsoft.com/download/en 
/default.aspx
Cloud Basics: Security in the Cloud. Microsoft 
download center:
http://www.microsoft.com/download/en 
/default.aspx

Detailed information about 
a product or technology on 
an ongoing basis

Podcasts
Technical white papers
Technical blogs

The Crabby Office Lady Podcasts
Microsoft SQL Azure Team Blog:  
http://blogs.msdn.com/b/sqlazure/

To learn tips and tricks eBooks
Microblogs (such as Twitter)

eBook: Windows 7 Tips and Tricks: http://www.
microsoft.com/download/en/default.aspx
Microblog: FedDidUKnow: You can easily turn 
your #Access database #applications into 
#SharePoint 2010 applications.  
http://bit.ly/3UaScH #gov #governance

To understand a complex 
or integrated feature or 
scenario

Interactive posters Windows Server 2008 R2 Hyper-V Component 
Architecture (with Service Pack 1)

http://go.microsoft.com/FWLink/?Linkid=227515
http://go.microsoft.com/FWLink/?Linkid=227516
http://go.microsoft.com/FWLink/?Linkid=227516
http://go.microsoft.com/FWLink/?Linkid=227517
http://go.microsoft.com/FWLink/?Linkid=227517
http://go.microsoft.com/FWLink/?Linkid=227518
http://go.microsoft.com/FWLink/?Linkid=227518
http://go.microsoft.com/FWLink/?Linkid=227519
http://go.microsoft.com/FWLink/?Linkid=227519
http://go.microsoft.com/FWLink/?Linkid=227520
http://go.microsoft.com/FWLink/?Linkid=227521
http://go.microsoft.com/FWLink/?Linkid=227522
http://blogs.msdn.com/b/virtual_pc_guy/
http://go.microsoft.com/FWLink/?Linkid=227524
http://go.microsoft.com/FWLink/?Linkid=227525
http://social.technet.microsoft.com/Forums/en-US/category/exchangeserver
http://answers.microsoft.com/en-us
http://answers.microsoft.com/en-us
http://go.microsoft.com/FWLink/?Linkid=227527
http://go.microsoft.com/FWLink/?Linkid=227528
http://download.microsoft.com/download/3/2/9/329F9AFF-FB06-4D25-812F-7BBA7CB8E3F7/Microsoft_Gov20_Paper.pdf
http://download.microsoft.com/download/3/2/9/329F9AFF-FB06-4D25-812F-7BBA7CB8E3F7/Microsoft_Gov20_Paper.pdf
http://download.microsoft.com/download/3/8/6/386B1BC8-EF25-444A-A0BD-339931F97753/SecurityInTheCloud.pdf
http://download.microsoft.com/download/3/8/6/386B1BC8-EF25-444A-A0BD-339931F97753/SecurityInTheCloud.pdf
http://go.microsoft.com/FWLink/?Linkid=227530
http://blogs.msdn.com/b/sqlazure/
http://download.microsoft.com/download/3/D/8/3D8DCCAC-C5B3-408C-B85C-9538A31CD3D5/Windows7TipsTricks.pdf
http://bit.ly/3UaScH
http://go.microsoft.com/FWLink/?Linkid=227531
http://go.microsoft.com/FWLink/?Linkid=227531
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If your user needs Consider this type of content Examples

To learn complex trouble-
shooting or decision making 
processes

Interactive flowcharts Software Update Deployment Superflow

Text for the web

Users are more likely to scan online text than read it. They decide very quickly if content is relevant 
to them, and searching is their most common behavior. With a glance, users should be able to have 
a rough idea of what your content is about, so this means that every word counts: users scan titles, 
headings, and paragraphs to see if they want to continue reading. You need to adapt your writing 
style to the web to show users that your content is valuable.

Make text scannable
Because users scan web content, if they find something that they like (gleaned from just a few words), 
they’ll continue reading.

Here are some general guidelines.

■■ Headings  Make headings and subheadings short and make every word count by using 
keywords. For details about keywords, see Help customers find your content.

■■ TOCs  For long webpages or large content sets, use Tables of Contents (TOCs) with links to every 
subheading. For long pages, include “back to top” links within your content. In general, it’s 
best to use shorter pages when you can.

■■ Lists  When appropriate, use bulleted lists, which are easy to scan and more likely to be read 
than paragraphs of text.

Microsoft style

Use linked files when these criteria are met: 

■■ You will use the same computer to create and display your presentation. 

■■ Your files are larger than 100 KB. 

■■ You plan to make changes to the source files.

Not Microsoft style

Use a linked file if you are going to use the same computer to display your presentation as the 
one you created it on. If your files are large, making them linked files is better. Also, you can 
change things in the source file later and have the changes show up in both the source and 
destination file.

http://go.microsoft.com/FWLink/?Linkid=227532
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■■ Content chunks  Write your content in short, digestible paragraphs. 

■■ White space  White space can help users scan the page and more easily identify what they 
need. Ensure that you include enough white space between the content “chunks” on your 
page.

■■ Text placement  Content that is on the first screen (“above the fold”) is more likely to be read—
users are unlikely to scroll down to find more information. This means that you need to reduce 
word count (preferred) or increase the total number of pages (by dividing a page into shorter, 
separate topics). Remember that where “the fold” is depends on factors that you might not 
control, such as the device used to view your content and the screen resolution.

Eye chart, heat map, and usability studies have shown that most users look at specific areas 
on a page first, so put your most important information there. Generally, in left-to-right 
languages, the area in the upper-left quadrant of a page is where users look first. For example, 
if the most important text on your page is a button that says “Buy” or “Download,” put 
the button where users look first (not below the fold, on the far right, or near the bottom). 
Ensure that the text on the right side of the main body text can’t easily be mistaken for an 
advertisement.

Organize your text
A clear, well-reasoned approach to content organization can help your users locate the information 
that is important to them. Here are some general guidelines.

■■ Use a hierarchical content structure  Put the most important content first, in the content’s 
title, headings, subheadings, and the first sentence of each paragraph.

■■ Give the conclusion first  This is called “inverted pyramid” style—you write the key points first 
by using keywords, so that users will see them and know whether they want to read on. 

■■ See Also  For more information about keywords, see Search Engine Optimization (SEO) later 
in this chapter.

■■ Use short, focused paragraphs  State your point in the first sentence of each paragraph and 
stick with one idea per each short paragraph.

■■ Use notes and tips  Break these out of the main paragraph, which should focus on your 
key point.

■■ Use plain language  Use simple sentences and short words. Use keywords that users use and 
can relate to. For example, they want to “download,” not to “experience the latest innovations.” 
Also avoid technical terms and jargon that users may not understand and wouldn’t search for. 
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Use links—lots of them
Using links to related information can help keep your content concise and scannable. The goal of a 
link is to help users find the information that they want, so descriptive link titles are critical.

Here are some general guidelines.

■■ Use the title or a description of the destination page as the link text. Don’t use “click here” or 
“more info” or a long URL.

■■ Limit link text to four keywords or fewer, if possible. Short links are easier to scan.

■■ Link to background and related information rather than summarizing.

■■ If you’re creating a large set of content, improve the ease of navigation by including many cross-
references.

■■ For more information about links, see Search Engine Optimization (SEO).

Video content for the web

Done well, video does a better job of showing many users what a product or service is and does and 
how to use it than explanatory text and still images can. For example, a screen-capture video for a 
program shows users exactly what to click and when to click it.

But video may not meet your accessibility goals, may require more bandwidth to view than simple 
text and low resolution pictures, may be expensive to produce and localize, and may not be the best 
medium if you’re trying to teach users a long, complicated process.

Here are some general guidelines:

■■ Video titles should clearly indicate the content of the video.

■■ Keep videos short. Shorter than two minutes is a good target. For a more complex subject that 
requires a longer time to cover, consider creating several short segments or chapters that can 
be combined in a playlist. This gives the customer an opportunity to watch the segments over 
time or select only the ones in which they are most interested.

■■ Make your key points clear and memorable and foreground them the way you would written 
content. (See Organize your text.) Don’t say or show more than the audience can easily take in.

■■ Videos should tell a story with a beginning, middle, and end. Simple narratives are best. A plot 
keeps viewers interested and attentive and wanting to see what happens next. For example, 
a good beginning to a video that teaches a task includes a brief statement of what the viewer 
should expect to learn by watching the video. A good ending leaves viewers wanting to 
try the new task or feature. A video about learning to use the mouse could conclude with, 
“Remember: point and click. That’s all you need to master the mouse. Give it a try.”



24	 Chapter 2  Content for the web

2

■■ Use the same voice that you use in your other content. The tone will likely be less formal and 
more conversational, but that will depend on the message that you’re delivering. 

For more information, see Chapter 1, “Microsoft style and voice”.

■■ The pace of the audio and video should be consistent, as should the ratio of audio to video. 
Don’t read too fast or too slowly. Practice reading at a clear pace and enunciating all the 
words. At first, it might feel odd to speak that way, but it will help viewers who are watching 
your video for the first time (think especially of viewers who have trouble hearing or who are 
non-native English speakers). Rushing through seemingly simple procedures can frustrate 
viewers. So, too, can long, audio-only preambles to any video action. Practice timing the 
actions with your words.

■■ Timing is difficult, but can make a big difference in the quality of the videos. A pause in the 
audio while actions are happening on screen is better than reading ahead of the action. The 
audio doesn’t need to explain every action that appears on screen. For example, let the visual 
images communicate common actions, such as clicking OK.

■■ Avoid references to earlier parts of the video, unless references are essential. Viewers should 
be following along, not trying to remember what they saw or heard before. They can always 
replay the video. If you must refer to earlier parts of the video, do so generally. For example, 
“Earlier, you saw how to add X to Z. Here’s something else you can do with X....”

■■ To improve accessibility, include captions. If possible, break closed captions into one-sentence 
chunks so that they’re easier to read.

■■ Because creating and localizing video can be expensive and time-consuming, try to take an 
“evergreen” approach to the content. If you can, avoid mentioning specific dates and product 
version names or showing images that will quickly date your content.

■■ Consider a branding element to open and close your videos, and a URL where the user can get 
more information at the end. These elements give your video credibility by clearly identifying 
the source of the content.

For more information go to Jakob Neilsen’s Talking-Head Video is Boring Online at  
http://www.useit.com/alertbox/video.html.

Blogs

Blogs are a good way to provide customers with ongoing, regular communications from subject 
matter experts, but only if you can commit resources to keeping the blog updated and fresh. Often, 
bloggers start out with good intentions, but fail to keep up the pace, and their blog languishes. A 
stale blog creates customer dissatisfaction and can impact your credibility. An active, credible blog 

http://www.useit.com/alertbox/video.html
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invites customer comments and community promotion. Blog posts can contain text, photos, videos, 
and screen shots.

Here are some general guidelines:

■■ Blog frequently and on a regular schedule, if possible. Post as frequently as necessary to 
tell your story effectively, but don’t distract your customers with meaningless posts. A good 
rule of thumb is at least one blog post a week—consider a team blog so you can share the 
workload.

■■ Identify subject areas to blog about in advance and develop a schedule. This is especially 
important for a team blog. This will help you establish a blogging routine and provide more 
structure for you and your readers. For example, you might want to introduce a subject in an 
initial post and advance the subject further in subsequent posts. By planning this in advance, 
you can quickly prepare for each post. It also lets you inform your readers in advance that the 
post is one in a series.

■■ Tone should be friendly and informal—be yourself! Apply the same common sense and 
guidelines to blogging that you would to any interaction or communications with customers, 
partners, and the press. That is, always bear in mind that what you write or say reflects you 
and the company. For more information, see Chapter 1, “Microsoft style and voice”.

■■ Respond promptly to customer comments. Comments and your responses can be 
as important as the blog post itself because it fosters an image of transparency and 
responsiveness, it can create meaningful dialog with important customers, and it can drive 
feedback to your product team.

■■ If you plan to archive your blog posts, you might consider adding a disclaimer to old content 
along these lines: “To the best of my [our] knowledge, the information in this blog post 
was accurate at the time of publication, but it might not be accurate now. If you’re reading 
something here that was published a while ago, I [we] recommend that you search the web for 
a more recent source.”

■■ If possible, tag each blog entry with keywords to help your readers find related entries or 
entries on topics of interest to them.

■■ Support your blog by using other social media tools, such as Twitter and Facebook, to raise 
awareness about it. For more information, see Social Media Optimization (SMO), later in this 
chapter.
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Community-provided content

Customers expect to interact with content. People still use the web as a source for receiving 
information, obviously, but it’s now also a place to share their information and expertise and to learn 
from other people like them.

If appropriate, consider offering your customers a way to provide content for your site. There are 
different models for this, from “anybody can contribute” to “we’ve selected a few people to provide 
content.” Anytime you have a community-contribution content model, you must consider how you 
will manage the content for appropriateness, accuracy, and adherence to standards.

Wikis
Wikis are a great example of a community creating content—anyone can view wiki content and, 
generally, anyone can contribute or edit wiki content. In theory, the community of wiki users 
manages the content. In practice, most wikis also have assigned editors, content managers, or 
councils to ensure that the wiki content is appropriate, to encourage use of the wiki, and to arbitrate 
disagreements.

If you have an enthusiastic community, such as a highly engaged technical community with lots 
of expertise to share, consider developing a wiki. And remember, the community doesn’t mean just 
customers outside your organization—it can include internal employees such as customer support 
services developers, testers, marketers, salespeople, or anyone else who has a vested interest in your 
wiki.

Many types of content are appropriate for a wiki, but they depend on your audience. Types of 
content and coverage areas that work well on wikis include the following:

■■ Troubleshooting and workarounds

■■ Tips and tricks

■■ Best practices

■■ Interoperability information

■■ Scenario or solution-based content

■■ Product evaluations

■■ Beta content

■■ White papers

■■ Community or wiki lists

■■ Learning roadmaps
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A wiki might not be the best method for communicating the following:

■■ Information that needs to be localized

■■ Release notes or other information that’s essential to defining how the product works 
(because a wiki can be modified)

Consider using a private wiki that is limited to a designated group of internal or external users for 
content that cannot currently be released.

With wikis, as with all web content, you need to think about the best ways to organize your 
content and make it discoverable. Most wikis don’t have a standard TOC structure. You can, however, 
create your own navigation articles that act as a TOC and provide links to your articles. Consider 
creating multiple TOC articles that are specific to your users. For example, you might want to have 
a TOC article that is oriented toward a specific type of customer, such as a software developer or an 
accountant, and another TOC article that links to topics specific to a solution or scenario and isn’t 
role-specific.

Consider using social media both to promote your wiki content and to encourage community 
contribution to your articles.

For more information, see Social Media Optimization (SMO), and for more information about 
making wiki content discoverable, see Search Engine Optimization (SEO).

There are a number of strategies you can use to encourage contribution. Use “stub topics” that 
are partially filled in to encourage community additions and enhancements. Start with content that 
encourages contribution, such as troubleshooting, or tips and tricks. Be willing to experiment with 
content types (with the understanding and support of your product, legal, and localization teams), 
and be open to changing your approach to wiki content and community contributions based on the 
feedback you receive from the community. For more information, see Getting Over the Barriers to 
Wiki Adoption (Alan Porter, 2010); http://arstechnica.com/business/news/2010/02/getting-over-the-
barriers-to-wiki-adoption.ars.

Evaluate your content

By publishing content on the web, you can get immediate feedback in a variety of ways from your 
customers. Using customer feedback, you can change or update your content to better meet your 
customers’ needs—and you can get this improved content to your customer much more quickly.

Some websites have built-in feedback mechanisms so that customers can rate and comment on 
content. For example, some content includes a feedback survey at the bottom of each page.

If your content has many customers, you might want to use tools to help with data mining and 
analysis of customer feedback.

http://arstechnica.com/business/news/2010/02/getting-over-the-barriers-to-wiki-adoption.ars
http://arstechnica.com/business/news/2010/02/getting-over-the-barriers-to-wiki-adoption.ars
http://arstechnica.com/business/news/2010/02/getting-over-the-barriers-to-wiki-adoption.ars
http://arstechnica.com/business/news/2010/02/getting-over-the-barriers-to-wiki-adoption.ars
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A/B testing
If you can’t support sophisticated customer feedback tools and analysis, you might try the A/B 
content testing method, which is done through controlled online experiments. In A/B testing, 
customers are exposed to (A) control content and (B) treated content. Comparing the two by using 
the metrics that make sense for your site (number of downloads, sales, page views, and so on), you 
can make gradual and systematic improvements to your site.

Task analysis
Task analysis—understanding what your customers need to do and how they’re using your content to 
do it—is another way of evaluating your content. In general, the task analysis process is as follows:

■■ Identify the top tasks that customers need to complete by using your content.

■■ Have participants use your content to do the tasks.

■■ Use metrics to measure their success rates.

Some metrics include the following:

■■ Task completion rate

■■ Disaster rate (percentage of failed attempts)

■■ Time it takes to complete the task

After you have identified areas of weakness in your content based on task analysis, you can make 
changes and remeasure as necessary to achieve an optimal success rate. For more information, see 
Customer Carewords: Top Task Management for Websites, http://www.customercarewords.com/ 
task-performance-indicator.html.

Help users find your content

How can you help ensure that your customers will find your great content? First, it’s critical that 
your content is optimized for search. Because algorithms and keyword usage can change rapidly, 
it’s important to understand the latest research in these areas so that you use the right approach to 
optimize your content for search.

Second, take advantage of the community to promote your content by using Social Media 
Optimization (SMO) and Tags.

http://www.customercarewords.com/task-performance-indicator.html
http://www.customercarewords.com/task-performance-indicator.html
http://www.customercarewords.com/task-performance-indicator.html
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Search Engine Optimization (SEO)
SEO is the work that you do to improve the visibility of a website or a webpage in unpaid, algorithmic 
search engine results. Because most customers click one of the first few search results, it’s important 
to do all that you can to ensure that your content is returned at the top of a search engine result 
page.

The four main areas to focus on for SEO are keywords, links, titles, and descriptions.

Keywords 
Know the words and terms that customers use (not the words and terms that you use) to search for 
your information, and use these words as early and as often as possible in the following places in your 
content:

■■ Titles

■■ Headings and subheadings

■■ Summaries

■■ Overviews

■■ Introductions

■■ Page descriptions

■■ Paragraph text

■■ Link text

■■ Image and table alt text

There are specific tools that you can use to learn what search terms customers use—just search for 
“SEO.”

Note   Video and audio files are non-textual content, so search engines can’t find them on 
their own. Add a text description near the asset, and add an alternative text description, if 
possible.

Links
In addition to including keywords in link text, you should link liberally to other content. If you have 
many incoming and outgoing links that use your keywords, you’ll help improve your position in 
search results. The highest value is given to incoming links that match your keywords and which are 
from pages that also use your keywords.
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Each page on your site should include some type of “share this” feature so that readers can easily 
link to your content from their content. This will take advantage of social media technologies and 
help increase the number of well-formed inbound links to your content. For more information, see 
Social Media Optimization (SMO).

Ensure that your links are not circular (that is, don’t link back to the same content), because search 
engines discount these links (and it can be a lousy experience for your customers).

Fix any broken links that occur in your content—if a search engine can’t search your content 
because of a broken link, your ranking will be lower.

Titles
Titles are used by search engines to determine ranking and are then used as the page’s heading 
(anchor text) in the search engine’s results page. Use the following guidelines for titles:

■■ Use no more than 10 to 12 words, or about 65 characters.

■■ Use the most important keywords early in the title.

■■ Unless brand names must appear first in the title or unless the page is mostly about the brand, 
important keywords should precede brand names.

■■ The title should be specific and include what is unique about the content.

Descriptions 
The page description appears in search results as a short paragraph between the title and the body 
of your content. It’s important that you provide this text because if you don’t, the search engine will 
decide what text to present. Use the following guidelines for descriptions:

■■ Include keywords in the description and put them as close as possible to the beginning of the 
description.

■■ A description should be no more than 160 to 170 characters.

■■ Write from specific to general.

■■ Use active words that clearly state what the page is about and that compel customers to 
access your content (without sounding like a sales pitch).

■■ Descriptions should be grammatically correct complete sentences.

■■ Avoid superfluous words. Don’t begin with stock phrases, such as “This article discusses” or 
“In this technical article, we will ....”

■■ For white papers and other long articles, indicate the length of the document.
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Tags
“Tags” are keywords and terms chosen by the content’s creator or by other users of the item 
(depending on the system) to classify the content. Tags are a kind of metadata that helps customers 
find the content by browsing or searching. Tags are often specific to the systems in which the 
content is published. That is, tags are useful within a specific wiki, but do not necessarily increase 
discoverability from external search engines.

As with keywords, use tags that customers would use, not just the tags that you would use.

Many blogging and wiki systems allow authors to add free-form tags to a post, placing the post 
into categories. For example, a post might display that it has been tagged with “Windows” and 
“operating system.” Each of these tags is usually a link leading to an index page that lists all of the 
posts associated with that tag. The blog or wiki might have a sidebar listing all the tags in use, with 
each tag leading to an index page. In many systems, the font size of the tag title will be bigger or 
smaller, depending on the popularity (measured by customer use) of the tag. This gives customers a 
visual indicator of what content on the blog or wiki is most popular.

Social Media Optimization (SMO)
You can use social media like Twitter, Facebook, forums, newsgroups, and YouTube to promote 
your content and identify content needs. It’s another strategy—complementary to Search Engine 
Optimization (SEO)—for making people aware of your content and increasing the amount of traffic to 
your site.

Social media evolves rapidly, so the approaches that you take to optimize your content today 
might need to be different six months from now. Because of this rapidly changing environment, the 
following information is limited to high-level approaches; there are resources available online for 
detailed information.

There are four main ways to approach SMO:

■■ Understand the social media “community of influencers” that might have developed in your area 
of expertise. Engage with them to promote your content, and use social media tools yourself.

■■ Collaborate with a partner team, such as your organization’s marketing team, to promote 
your content.

■■ Monitor social media sites for common customer problems and use this data to identify gaps 
in your content. For example, in addition to responding to a forum or newsgroup post, you 
might need to add or correct content in your portfolio.

■■ Use social media technologies, such as bookmarking, blogging, RSS feeds, and other sharing 
technologies, to improve SEO by increasing the number of well-formed inbound links to 
your content.

To understand your community of influencers, you can use various listening and monitoring tools, 
known as “listening platforms.” Listening platforms not only monitor and track what is being said 
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about you, they also offer insight to help shape your strategy, giving you knowledge about sentiment, 
influence analysis, community, and engagement.

With social media, as with blogging, you need to have the resources to post and monitor 
frequently (once a week is a reasonable target) and respond to customer feedback promptly  
(a 24-hour to 48-hour response time is a good goal).

International considerations for web content

As with printed content, it’s important to partner early with your localization team to share content 
plans and to understand the implications of your web-content strategy.

Certain types of web content, including video, are expensive to localize and this may affect your 
content choices. For more information about creating content for a global audience, see Chapter 3, 
“Content for a worldwide audience”.

Accessibility considerations for web content

There are certain accessibility standards that you must follow when you create content for the web. As 
you develop your web content strategy, partner early with your accessibility contact to share content 
plans, to understand accessibility implications, and to ensure that you understand the accessibility 
standards that you need to follow. For more information, see Chapter 4, “Accessible content”.

Legal considerations for web content

Any content created for the web—including blogs, wikis, Facebook and Twitter posts, and videos—
must follow your corporate legal guidelines.
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The user interface

In the last decade, the types of electronic devices that a person can interact with have proliferated. 
In addition to computers, many people now have smartphones and game consoles, and they’re 

interacting with them by using their voices, fingers, hands, and even their whole bodies.

The term used for these new types of interfaces is natural user interface (NUI). The natural user 
interface is designed and programmed to enable a user to interact more naturally with a computer 
or program through gestures and speech instead of an input device such as a keyboard, mouse, or 
game controller. For example, a user can give a command or select an option by touching the screen 
with a finger or hand. With a device that has a camera or sensor, a user can perform a gesture with 
an arm, a foot, or even the entire body to interact with a character on the screen. With a device that 
has a microphone, a user can say a command, clap, or whistle to cause a program to react in a logical 
or expected manner. Additional interactions can include holding up something for the program to 
digitize and show on the screen, and then working with that item through an avatar. Programs can 
also read facial features to recognize a user, read lips, and even reply to a user’s voice. Natural user 
interface technology can also enable a program to determine the location of a user and to react to 
that location.

As natural user interfaces develop, writing and editing content for the interface will undoubtedly 
generate the need for a new style and new terminology. This version of the Microsoft Manual of Style 
introduces the first wave of this new style and terminology with the intent to set some groundwork 
for future guidelines.

Windows user interface

The following illustrations show a Windows desktop, the desktop access points, an open window, a 
browser window, and a webpage, with the various elements that appear on them called out.

Elements that appear in more than one illustration are not necessarily called out on each 
illustration. For example, the scroll bar and the Close button appear in all windows, so they are only 
called out in the illustration of an open window.

For the names of dialog box elements, see Dialog boxes. For the names of items on a ribbon, 
menu, or toolbar, see those topics. For more information, also see User interface formatting, and the 
names of individual items.
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Windows desktop

Taskbar

Desktop access points

Start button

Pinned taskbar button

Taskbar Notification area

Show desktop button
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Open window

Address bar

Scroll arrow
Scroll bar

Minimize
button

Maximize
button

Close
button

Search box

Menu bar

Status bar

Browser

Address bar

Webpage Notification bar

Home
button

Favorites
button

Tools
buttonFavorites bar
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Webpage
Search box

Link

Navigation
bar

Banner

Windows Phone user interface

The following illustrations show Windows Phone screens and the various elements that appear on them.

Start screen and Tiles
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For a general audience, use Start, rather than Start screen or Home screen to describe this screen.

For a developer audience, if necessary, you can use Start screen.

Use Tile to refer to objects on Start that the user can move around, such as the Phone Tile and the 
Calendar Tile. Tiles are shortcuts to apps or other content. Always capitalize Tile.

Use Live Tile to refer to a Tile that updates automatically and shows content updates on Start.

In procedures, use the name of the Tile, such as Messaging, to refer to the Tile.

Refer to the arrow in a circle on the Windows Phone user interface generically as the arrow.

Microsoft style for Windows Phone

On Start, tap Messaging

You can pin Tiles to Start.

Other screen elements

Pivot control
Screen title

Application bar

More icon
Icons

In general, use the name of an icon and its image instead of the word icon in procedures.

Refer to the text at the top of a screen as the screen title or application title.

Don’t use the terms Pivot control and Application Bar for a general audience. Both terms can be 
used in documentation for developers.

Microsoft style for Windows Phone

In Maps, tap More , and then tap Show traffic.

Tap the check box next to each email that you want to delete, and then tap Delete.
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The Pivot control provides a quick way to manage views of large sets of data within an application. 
(Developer audience)

The Application Bar is a set of one to four buttons that can be displayed along the bottom of the 
phone’s screen. (Developer audience)

App list

The App list shows apps installed on Windows Phone. When referring to the App list, capitalize App. 
Do not use Application list.

Microsoft style for Windows Phone

On Start, flick left to the App list.

Hub

Don’t refer to a Hub unless absolutely necessary. Instead, in procedures, use the name of the Hub, 
such as “In Marketplace…” or “In Pictures…,” to refer to the front page of a Hub for a user action. If 
you do refer to a Hub, capitalize Hub.
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Microsoft style for Windows Phone

In Pictures, find a picture, and tap to open it.

The Pictures Hub is where you go to see all the pictures on your phone and the latest pictures your 
friends have posted to Windows Live.

Menu

Use menu to refer to a context-specific menu that appears when the user taps the More icon.

Dialog box

Dialog box elements include text boxes, check boxes, and buttons.
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Lock screen

The lock screen appears when the phone is turned on. Refer to the lock screen by name or generically 
as your phone’s screen.

Microsoft style for Windows Phone

To unlock your phone, turn it on, and then flick your finger upward on your phone’s screen until you 
can see the keypad for entering your password.

If you haven’t checked your phone for a while, you can get a lot of information from the lock screen, 
including how many new text messages, missed calls, emails, and voicemails you’ve received.

Keyboard

Refer to keyboard elements as keys. Examples are the Enter key and the Shift key.

Use type to refer to using alphanumeric keys; use tap to refer to functional keys.

Microsoft style for Windows Phone

Tap the message box, and then type your message.

Type your password, and then tap Enter.
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User interface elements

User interface elements enable users to interact with programs, applications, and with pages and 
services on websites. These elements, which include controls and commands, can be presented to the 
user in various graphical forms, such as in ribbons, menus, toolbars, dialog boxes, property sheets, or 
web forms. Or they can be individual elements such as hyperlinks or download buttons on webpages.

User interface terminology
In content for software developers, buttons and other dialog box elements are called controls, 
especially in discussions about creating them. Do not use control in content for a general audience.

Note In some hardware products, buttons, switches, and so on are called controls because 
they give the user control over various actions. For example, users use joystick controls to 
move around the screen in games. This usage is all right as long as the meaning is clear.

User interface syntax
The following terms are most commonly used to describe how users interact with controls and 
commands:

■■ Click: Use for commands, command buttons, option buttons, and options in a list, gallery, or 
palette.

■■ Select and clear: Use for check boxes.

■■ Remove the check mark: Use for checked and unchecked commands.

■■ Type or select: Use to refer to an item (as in a combo box) that the user can either type or 
select in the accompanying text box. You can use enter instead if there is no possibility of 
confusion.

Except for the identifiers box, list, check box, and tab, the generic name of a control (button, option, 
and so on) should not follow the label of a control, especially within procedures.

Use bold formatting for dialog box titles, labels, and options. Do not use bold formatting for the 
title of a webpage. Instead, insert a hyperlink if appropriate or use regular type. For more information, 
see dialog boxes, Document conventions (Chapter 6), Procedures (Chapter 6), User interface formatting, 
Windows user interface.

The following example shows typical procedure wording for dialog box controls and 
webpage controls.
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Microsoft style (for dialog boxes)

To view bookmarks

1.	 On the Tools menu, click Options, and then click the View tab.

2.	 Select the Bookmarks check box.

Microsoft style (for webpages)

To create a free website

1.	 Go to http://officelive.com.

2.	 On the Office Live Small Business sign-up page, click Create a free website. A sign-up page 
appears.

Ribbons, menus, and toolbars

Ribbons, menus, and toolbars are three methods that programs can use to show users what 
commands are available in those programs.

Ribbons
The ribbon is a rectangular area that fits across the top of an application window. It was introduced as 
a component of the Microsoft Office Fluent user interface in Office 2007.

The ribbon is composed of several tabs, each of which represents a subset of program 
functionality. The tabs contain related commands that are organized, grouped, and labeled.

TabQuick Access Toolbar Contextual tab

Dialog Box LauncherScreenTipGalleryGroup

Help

The ribbon has several elements. They are listed and described in the following table, using 
examples from Microsoft Word.

http://officelive.com
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Element Description

Tools Context-sensitive tabs that appear on the ribbon under certain circumstances. For example, if you 
select an image in a document, the Picture Tools tab appears on the ribbon. If you select or are 
working in a table, the Table Tools tab appears on the ribbon. The tools tab disappears when the 
user clicks away from the selected item.

tab A rectangular region on a ribbon that represents a subset of the program’s functionality. In the 
following example, the Home tab is open.

group A rectangular region on a tab that contains a set of related controls and commands. The following 
example shows the Paragraph group on the Home tab.

gallery A rectangular window or menu that presents an array or grid of visual choices to a user. For example, 
when a user clicks an image in a document and then clicks the Picture Tools tab, the Picture Styles 
gallery becomes available.

mini toolbar A set of controls that appears in context when an object is selected. A user can use these controls to 
perform actions upon the object. For example, when a user selects text, the formatting mini toolbar 
automatically appears above the text.

As the mouse pointer moves closer to the mini toolbar, the toolbar becomes more visible. As the 
mouse pointer moves away from it, the toolbar fades away or disappears altogether. 

ScreenTip A ScreenTip is a small window that displays descriptive text when a mouse pointer rests on a 
command or control. A ScreenTip may include a link to a Help topic.

Quick Access 
Toolbar 

A collection of icons, located on a program’s title bar, that provides shortcuts to commonly used 
commands. Users can add icons to this toolbar or remove them.
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Element Description

Dialog Box 
Launcher

A specific icon that is used within a group to launch a related dialog box. It is located in the 
lower-right corner of a group.

Dialog Box Launcher

KeyTips Small keyboard tips that indicate what key to press to access program functionality. The user 
must press the Alt key to see the KeyTips and then press the indicated number or letter to run the 
associated command. In the following example, pressing the number 1 saves a Word document.

Ribbon terminology
In Office 2007, Ribbon is capitalized. In Office 2010, ribbon is lowercase. Use on the ribbon, not in the 
ribbon.

Microsoft style

On the ribbon, click the appropriate tab or group to display the command that you want to add to 
the Quick Access Toolbar.

Not Microsoft style

Some tabs display in the ribbon only when they are relevant to the task at hand, such as when for-
matting a table or an image.

Do not use the possessive form of ribbon.

Microsoft style

One of the benefits of using the ribbon is its clear visual layout.

Not Microsoft style

One of the ribbon’s benefits is its clear visual layout.

Spell out Quick Access Toolbar. Do not abbreviate it to QAT.

Microsoft style

You can add or remove commands from the Quick Access Toolbar.

Not Microsoft style

You can add or remove commands from the Quick Access Toolbar (QAT).
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You can add or remove commands from the QAT.

To refer to tools, use the following format: Under x on the y tab, in the z group, click zz.

Microsoft style

Under Table Tools, on the Layout tab, in the Data group, click Repeat Header Rows.

Not Microsoft style

Click the Layout tab under Table Tools, and then in the Data group, click Repeat Header Rows.

To refer to the Dialog Box Launcher, use the following format: On the x tab, in the y group, click 
the z Dialog Box Launcher.

Microsoft style

On the Home tab, in the Font group, click the Font Dialog Box Launcher.

Not Microsoft style

Click the Home tab, and click the Font Dialog Box Launcher in the Font group.

On the Home tab, in the Font group, click the Font box down-arrow.

When writing procedures that involve the ribbon, use the following format:

■■ On the x tab, in the y group, click z.

■■ On the x tab, in the y group, click z, and then click zz.

Microsoft style

On the Review tab, in the Comments group, click New Comment.

On the Home tab, in the Font group, click the arrow next to the Text Highlight Color icon, and then 
click the color that you want.

Not Microsoft style

Click the Review tab, and then click New Comment in the Comments group.

On the Review tab, under Comments, click New.

Menus
A menu is a group of the main commands of a program arranged by category such as File, Edit, 
Format, View, and Help. Menus are usually displayed on a menu bar typically located near the top of a 
window.

Menus contain commands. Do not refer to a menu command as a choice or an option. Also do not 
refer to a menu command as a menu item, except in content for software developers about the user 
interface.

To describe user interaction with menus and menu commands, use click. Do not use choose, select 
or pick. If you must refer to the user action of opening a menu, use click. To open a submenu, the 
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user points to a command on the main menu, which causes the submenu to open, and then clicks the 
appropriate command.

Microsoft style

On the File menu, click Open.

On the View menu, point to Sort by, and then click Date.

The following illustration shows elements of menus. In most content, you should not have to refer 
to user interface elements by their technical names. The usual practice, here as elsewhere in the user 
interface, is to refer to elements by their labels.

Menu name

Unavailable
commands

Keyboard shortcut

Keyboard shortcuts

Commands

Keyboard shortcuts

Submenu

Checked command

Command separator

Menu terminology
When referring to a specific menu, use lowercase for the word menu, as in “the Edit menu.”

In general, refer to unavailable commands as unavailable, not as dimmed, disabled, or grayed  
unless you are describing their appearance. In that case, use dimmed, but not grayed or disabled. In 
content for a technical audience, it is all right to refer to unavailable commands as disabled.
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Microsoft style

There are several unavailable commands on the Edit menu.

If the Paste command is unavailable, first select the text that you want to paste, and then click Cut or 
Copy.

The Paste command appears dimmed because it is unavailable.

A disabled control is unavailable to the user. (In content for software developers.)

Not Microsoft style

There are several dimmed commands on the Edit menu.

If the Paste command is disabled, first select the text that you want to paste, and then choose Cut or 
Copy.

The Paste command appears grayed because it is unavailable.

In general, mention the name of the menu the first time that you refer to a particular command. 
However, if the location of the command is clear from the immediate context, you do not have to 
mention the menu name. An example is a topic about the Edit menu.

Microsoft style

If the Paste command on the Edit menu is unavailable, first select the text that you want to paste, 
and then click Cut or Copy. You now should be able to click Paste to insert the text in its new 
location.

Kinds of menus
In content for a general audience, do not qualify the term menu with the adjectives cascading, 
drop-down, pull-down, pop-up, shortcut, or submenu unless the way that the menu works needs to be 
emphasized as a feature of the product. Shortcut menu is all right to use, although in most cases, you 
can avoid it. Do not use any of these terms as verbs.

Microsoft style

Click the File menu.

When you click the right mouse button, a shortcut menu appears.

Not Microsoft style

Drop down the File menu.

When you click the right mouse button, a shortcut menu pops up.

In content for software developers about the user interface, you might need to detail specific kinds 
of menus.
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Style of menu names and commands
Always surround menu names with the words the and menu both in text and in procedures.

Microsoft style

On the File menu, click Open.

Not Microsoft style

On File, click Open.

From File, click Open.

In procedures, do not surround command names with the words the and command. In text, you 
can use “the ... command” for clarity.

Microsoft style

On the File menu, click Open.

Not Microsoft style

On the File menu, click the Open command.

Do not use the possessive form of menu and command names.

Microsoft style

The Open command on the File menu opens the file.

Not Microsoft style

The File menu’s Open command opens the file.

Follow the user interface for capitalization and use bold formatting both in text and procedures. 
Do not capitalize the identifier, such as menu or command.

Microsoft style

On the Options menu, click Keep Help on Top.

Not Microsoft style

On the Options menu, click Keep Help On Top.

Toolbars
A toolbar is a grouping of commands optimized for efficient access. Unlike a menu, which contains 
a comprehensive list of commands, a toolbar contains the most frequently used commands. Most 
toolbars are customizable, enabling users to add or remove toolbars, change their size and location, 
and even change their contents. Some toolbars are called bars. An example is the Command bar in 
Internet Explorer. Always follow the user interface.
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Toolbars contain buttons. A toolbar button can have a submenu, which is indicated by an arrow 
next to it. A toolbar button with a submenu is called a menu button if the user can click either the 
button or the arrow to open the submenu, and it is called a split button if clicking the button carries 
out the command, but clicking the arrow opens the submenu. Do not refer to a toolbar button as a 
choice or an option. Also do not refer to a toolbar button as a toolbar item or a toolbar control except 
in content for software developers about the user interface.

To describe user interaction with toolbars and toolbar buttons, use click for toolbar buttons and 
submenu commands, and click, type, or enter for submenu commands that require users to provide 
information. Do not use choose, select, or pick.

Microsoft style

To read mail in Internet Explorer, click Read mail on the Command bar.

On the Command bar, click Tools, and then click Internet options.

The following illustration shows an example of a toolbar. In most content, you should not have to 
refer to user interface elements by their technical names. The usual practice, here as elsewhere in the 
user interface, is to refer to elements by their labels.

Drop-down
list box

Unlabeled
icons

SeparatorUnavailable
icons

Toolbar Terminology
When referring to a specific toolbar, use lowercase for the word toolbar, unless the word Toolbar 
appears in uppercase in the user interface, as is the case with the Quick Access Toolbar in programs 
that use a ribbon, such as Word 2010. Toolbar is one word.

If there is only one toolbar, refer to it as the toolbar. If there are multiple toolbars, refer to them by 
name, followed by the word toolbar.

Refer to the main toolbar that is on by default and contains buttons for basic tasks, such as 
opening and printing a file, as the Standard toolbar, unless it is named in the user interface, as is the 
case with the Quick Access Toolbar.

Refer to named toolbar buttons by their user-interface names. Refer to unnamed toolbar buttons 
by their tooltip labels. Use the exact label text, including its capitalization, but do not include the 
shortcut key, the explanation, or the ellipsis for buttons that have them.

Refer to toolbar menu buttons and split buttons by their labels and the word menu. Use the exact 
label text, including its capitalization.
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Microsoft style

On the Quick Access Toolbar, click New.

On the Quick Access Toolbar, click the arrow next to the Font color menu, and then click the color 
that you want.

On the Command bar, click Feeds.

On the Command bar, click the Print menu, and then click Print Preview.

Not Microsoft style

On the Quick Access Toolbar, click New (Ctrl+N).

On the Quick Access Toolbar, click the arrow next to Font color, and then click the color that you 
want.

On the Command bar, click the No feeds detected on this page button.

On the Command bar, click the Print menu, and then click Print Preview….

In general, refer to unavailable commands and options as unavailable, not as dimmed, disabled, 
or grayed, unless you are describing their appearance. In that case, use dimmed, but not grayed or 
disabled. In content for a technical audience, it is all right to refer to unavailable commands  
as disabled.

Microsoft style

There are several unavailable buttons on the Quick Access Toolbar.

When Word first opens, the Can’t Undo and Can’t Repeat buttons are dimmed because they are not 
available until there is something to undo or repeat.

In Microsoft Visual Basic .NET, the Stop Debugging button is disabled when a program is not in the 
process of being debugged. (In content for software developers.)

Not Microsoft style

There are several dimmed buttons on the Quick Access Toolbar.

When Word first opens, the Can’t Undo and Can’t Repeat buttons are disabled.

In Microsoft Visual Basic .NET, the Stop Debugging button is grayed when a program is not in the 
process of being debugged.

Kinds of toolbars
In content for a general audience, do not qualify the term toolbar menu button or toolbar split button 
with the adjective cascading, drop-down, pull-down, pop-up, or submenu unless the way that the 
menu works needs to be emphasized as a feature of the product. Shortcut menu is all right to use, 
although in most cases, you can avoid it. Do not use any of these terms as verbs.
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Microsoft style

On the Windows Help and Support toolbar, click the Options menu.

On the Options menu, point to Text Size, and then click Largest. 

Not Microsoft style

On the Windows Help and Support toolbar, open the Options pull-down menu.

On the Options menu, point to Text Size, and then click Largest on the submenu.

In content for software developers about the user interface, you might need to detail specific kinds 
of toolbars.

Style of toolbar names and buttons
In general, do not use the words the and button with toolbar buttons.

Microsoft style

To start a new document, click New on the Quick Access Toolbar.

Not Microsoft style

To start a new document, click the New button on the Quick Access Toolbar.

In general, do use the and menu with toolbar menu buttons and split buttons, but do not use the 
word button.

Microsoft style

To change Internet options, click the Tools menu on the Command bar, and then click Internet 
Options.

Not Microsoft style

To change Internet options, click Tools on the Command bar, and then click the Internet Options 
button.

To describe removing a check mark from a menu command, use click to remove the check mark. 
Do not use clear.

Microsoft style

To remove the Desktop toolbar from the taskbar, right-click the taskbar, and then click Desktop to 
remove the check mark.

Not Microsoft style

To remove the Desktop toolbar, right-click the taskbar, and then click Desktop to clear the check 
mark.

Do not use the possessive form of toolbars and toolbar buttons.
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Microsoft style

To read mail, click Read Mail on the Command bar.

Not Microsoft style

You can read mail by clicking the Command bar’s Read Mail button.

Follow the interface for capitalization and use bold formatting for toolbar names and buttons. Do 
not capitalize the identifier, such as toolbar or button.

Microsoft style

In Windows Help and Support, click Help and Support home on the toolbar.

Not Microsoft style

In Windows Help and Support, click the Help And Support Home button on the toolbar.

Webpage controls, dialog boxes, and property sheets

Here are some specifics on webpage controls, dialog boxes, and property sheets.

Webpage controls
Webpages contain such controls as hyperlinks, text boxes, and download buttons. A typical webpage 
with controls looks as follows.



	 Webpage controls, dialog boxes, and property sheets	 71

5

Dialog boxes
Dialog boxes contain such controls as command buttons and list boxes through which users can carry 
out a particular command or task. For example, in the Save As dialog box, the user must indicate 
in which folder and under what name the document should be saved. A typical dialog box looks as 
follows.

Property sheets
A property sheet is a dialog box that displays information about an object (the object’s properties). For 
example, the Internet Properties property sheet shows information about Internet security settings. 
Property sheets contain such controls as check boxes and sliders. A typical property sheet looks as 
follows.
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In general, avoid using dialog box or property sheet as a descriptor. If you cannot avoid a 
descriptor, use dialog box for both property sheets and dialog boxes unless your project style sheet 
provides different guidance. The distinction may be important for a technical audience, but do not 
distinguish in content for a general audience. For more information, also see dialog boxes, Document 
conventions (Chapter 6), User interface text.

Backstage view

Although the term Backstage view does not appear in the user interface, writers use it to refer to the 
page that a user sees upon clicking the File tab of any Microsoft Office 2010 program. The Backstage 
view, which is part of the Microsoft Office Fluent user interface, exposes information and metadata 
about the currently active document, lists recently opened documents and network places, and 
provides a variety of user options, such as opening, saving, printing, and versioning.

Note  The File tab replaces the Microsoft Office Button  and the File menu that 
appeared in earlier versions of Office.

How to refer to Backstage view
Use the following guidelines to refer to Backstage view.

■■ On first mention, precede Backstage + descriptor with Microsoft Office, and use the appropriate 
trademark symbols for printed content. The descriptor that follows Backstage is usually view.

Example: Microsoft® Office Backstage® view

■■ On subsequent mentions, you may omit Microsoft Office but you may not omit the descriptor. 
The only exception to this rule is if space is limited.

■■ Always capitalize Backstage.

■■ Always follow Backstage with a descriptor to explain what it is and what it works with. In most 
cases, the descriptor is the word view. Use Backstage only as an adjective; do not use Backstage 
as a noun, verb, or an adverb.

■■ In printed material, apply the trademark on first mention. Because it is trademarked, Backstage 
is not localized. However, the word view can be localized.

■■ It is acceptable, but not required, to precede Backstage view with the definite article the.

■■ In procedures, treat items in the Backstage view, such as tab names, headings, and button 
labels in accordance with the Microsoft Manual of Style guidelines.

■■ The items on the side of the Backstage view, such as Info, Recent, New, and Print, are 
called tabs.
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Tabs

Heading Tab Button

■■ Do not refer to the Backstage view as “the outspace.”

■■ Do not refer to sections of the Backstage view as slabs, billboards, hero buttons, forms, panes, or 
windows except in content for software developers (if these terms appear in code samples or 
in content that documents these controls).

■■ Do not refer to the Backstage view as new.

■■ Do not apply a version number to the Backstage view.

Microsoft style

The Backstage view is where you manage your documents and related data about them.

Click the File tab. The Microsoft Office Backstage view appears.

After you create your document, go to the Backstage view to print it.

Not Microsoft style

After you create your document, go Backstage to print it.

The Office Backstage lets you inspect your document before you share it with others.

Clicking the File tab opens the Backstage.

The Office 2010 Backstage view lets you open previous versions of the active document.
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Control Panel

With Control Panel, users can configure system-level features and perform related tasks. Examples 
of system-level feature configuration include hardware and software setup and configuration, 
security, system maintenance, and user account management.

The term Control Panel refers to the entire Windows Control Panel feature. Individual control 
panels are referred to as control panel items. A control panel item is considered top-level when it is 
directly accessible from the control panel home page or a category page.

The control panel home page is the main entry point for all control panel items. It lists the items by 
their category, along with the most common tasks. It is displayed when users click Control Panel on 
the Start menu.

A control panel category page lists the items within a single category, along with the most common 
tasks. It is displayed when users click a category name on the home page.

Control Panel contains icons that represent different control panel items. Do not use applets, 
programs, tools, or control panels to refer to either the icons or the items. Use bold formatting for the 
names of the icons and items.

If you must identify Control Panel by a category, use the Control Panel application in content for 
a technical audience, or the Control Panel program in content for a general audience. For a mixed 
audience, use program.

When documenting an alternate path to control panel items, use “To open <name of item>”, and 
use bold formatting for the name of the item.

When referring to Control Panel itself, use regular type except when you are referring to the 
command on the Start menu. In that case, use bold formatting.

In documentation for a technical audience, refer to control panel home page and control panel 
category page, without capitalizing any of the words. A preceding definite article is optional.

When referring to a control panel item’s hub page, use “main <control panel item name> page”.

Do not use the when referring to Control Panel.

Microsoft style

In Control Panel, click Network and Internet, and then click Internet Options.

To open Internet Options, click Start, click Control Panel, and then click Network and Internet.
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Experience Interaction Guidelines on MSDN.

Messages

When explaining a message, include the situation in which the message occurs, the message text, and 
what the user should do to continue. Do not use special formatting (such as monospace or bold) or 
title capitalization to set off messages from surrounding text unless specified in your product style 
guide. Instead, set the text off on a separate line or enclose it in quotation marks, as appropriate.

Programs use four types of messages:

■■ Errors

■■ Warnings

■■ Confirmations

■■ Notifications

Errors
An error message alerts a user about a problem that has already occurred. Error messages can be 
presented by using modal dialog boxes, in-place messages, notifications, or balloons.

http://msdn.microsoft.com/en-us/library/aa511272.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
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When referring to errors, follow these guidelines:

■■ In content for a general audience, refer to errors as messages, not alerts, error messages, 
message boxes, or prompts.

■■ For acceptable uses of alert, see alert.

■■ Error message is all right to use in content for a technical audience to describe messages that 
indicate an error condition. It is also all right if you must follow the user interface.

■■ Refer to errors by their main instruction. Use the exact text, including its capitalization. If the main 
instruction is long or detailed, summarize it.

Microsoft style

If you receive a “There is no CD disc in the drive” message, insert a new CD disc in the drive and try 
again.

If you receive Windows Update error 80072ee7 while checking for updates, you might need to change 
or remove static IP addresses for the Windows Update service.

International considerations
For machine-translated content, do not embed error message text that forms a completed sentence 
inside the sentence that makes a statement about the error message. Instead, structure the sentence 
so that the error message text is set off on a separate line or rewrite the sentence so that the error 
message text becomes a grammatical part of the sentence in which it is embedded.

For example, consider the following sentence:

If you receive a “There is no CD disc” in the drive message, insert a new CD disc in the drive and 
try again.

To make this sentence better for machine translation, restructure this sentence as follows:

If you receive the following message, insert a new CD disc in the drive and try again: 
“There is no CD disc in the drive.”

or

If you receive a message that states that there is no CD in the drive, insert a new CD disc in the 
drive and try again.

Set error messages that are not completed sentences off on a separate line if you can. If you 
cannot, enclose the error-message text in quotation marks to mark the text as one unit.

For example, the following sentence may cause mistranslation:

If you receive Windows Update error 80072ee7 while checking for updates, you might need to 
change or remove static IP addresses for the Windows Update service.
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For better machine translation, restructure this sentence as follows:

If you receive the following Windows Update error while checking for updates, you might need 
to change or remove static IP addresses for the Windows Update service: 80072ee7

or

If you receive “Windows Update error 80072ee7” while checking for updates, you might need to 
change or remove static IP addresses for the Windows Update service.

Warnings
A warning message is a modal dialog box, in-place message, notification, or balloon that alerts the 
user of a condition that might cause a problem in the future.

When referring to warnings, follow these guidelines:

■■ In content for a general audience, refer to warnings as messages, not alerts, warning messages, 
message boxes, or prompts.

■■ Warning message is all right to use in content for a technical audience to describe messages 
that indicate an error condition. It is also all right to use if you must follow the user interface. 
However, do not use warning without the word message.

■■ Refer to the warning message by its main instruction, which may be a question. Use the exact 
text, including its capitalization. If the text is long or detailed, summarize it. 

Microsoft style

If you receive the “This file has been modified outside of the source editor. Do you want to reload it?” 
message, click Yes.

Confirmations
A confirmation is a modal dialog box that asks if the user wants to proceed with an action.
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When referring to confirmations, follow these guidelines:

■■ Refer to confirmations as messages, not alerts, warning messages, message boxes, or prompts.

■■ Refer to the confirmation by its main instruction, which may be a question. Use the exact text, 
including its capitalization. If the text is long or detailed, summarize it. 

Notifications
A notification informs a user of events that are unrelated to the current user activity, by briefly 
displaying a balloon from an icon in the notification area. The notification could result from a user 
action or significant system event, or could offer potentially useful information from Windows or an 
application.

Close button

When referring to notifications, follow these guidelines:

■■ Refer to a notification as a notification, not as a message, a balloon, or an alert.

■■ Refer to a notification by its main instruction. Use the exact text, including its capitalization. If 
the main instruction is long or detailed, summarize it.

■■ Refer to the notification area as the notification area, not the system tray.

Microsoft style

The Offline Files icon in the notification area intermittently displays the “You are working offline. You 
are no longer connected to Server” notification.

For information about how to write messages, see the Messages section of the Windows User 
Experience Interaction Guidelines on MSDN.

Other user interface elements

In most content, especially for a general audience, do not differentiate between drop-down combo 
boxes, list boxes, and text boxes. Refer to such a control by its label, and use a descriptor only if 
necessary for clarity. If you must use a descriptor, use list or box. Do use the term check box, however.

The following table describes the various controls that can appear in dialog boxes and on 
webpages. Unless otherwise noted, avoid using the control name except in a discussion about 

http://msdn.microsoft.com/en-us/library/dd535525.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx


	 Other user interface elements	 79

5

designing a user interface. Use lowercase for the name of the control (“the Spaces check box”). In 
general, use sentence-style capitalization for the specific descriptor.

Control 
name

Definition Usage Example

Check box* Square box that is 
selected or cleared 
to turn on or off an 
option. More than 
one check box can be 
selected.

Select the Spaces 
check box.  
Click to clear the 
Bookmarks check 
box.
Under Show, select 
the Draft font check 
box.
Note    Always include 
check box with the 
label name.

Combo box Text box with a list box 
attached. The list is 
always visible. Because 
users can either type 
or select their choice, 
you can use enter to 
describe the action. 
Follow your project 
style sheet.

In the Font box, type 
or select the font you 
want to use.
or 
In the File Name box, 
enter a file name.

Command 
button

Rectangular button 
that initiates an action. 
A command button 
label ending with 
ellipses indicates that 
another dialog box will 
appear. More informa-
tion is needed before 
the action can be 
completed.

Click Options.

Command  
link

Command links 
enable users to make 
a choice among a set 
of mutually exclusive, 
related choices.
Insert a hyperlink for 
the link text.
If the user must click 
the link, refer to the 
text without using link 
or hyperlink. If the user 
must make a selection, 
refer to the links as 
options.

Click Browse the 
Internet now.
or
Click one of the 
following options:

Drop-down 
arrow

Arrow associated with 
a drop-down combo 
or list box or some 
toolbar buttons, indi-
cating a list the user 
can view by clicking 
the arrow.

Click the Size arrow to 
see more options.
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Control 
name

Definition Usage Example

Drop-down 
combo box

Closed version of 
a combo box with 
an arrow next to it. 
Clicking the arrow 
opens the list.

In the Size box, type 
or select a point size.

Drop-down 
list box

Closed version of a 
list box with an arrow 
next to it. Clicking the 
arrow opens the list.
Depending on the 
type of list, use either 
list or box, whichever is 
clearer.

In the Item list, click 
Desktop.

Group box Frame or box that 
encloses a set of 
related options. In 
some programs, a 
group box can be 
indicated by a single 
line that unifies the 
options below it. 
The group box is a 
visual device only. If 
necessary for clarity, 
you can use either 
under followed by the 
label or in the <name 
of group> area.

Click Small Caps.
or
Under Effects, click 
SmallCaps.
or
In the Effects area, 
click Small Caps.

Label
(do not use 
caption)

Text attached to 
any option, box, 
command, and so on.
Refer to any option, 
box, and so on by its 
label.

In the Font list, click 
Arial.

Links Links enable a user to 
go to another page, 
window, or Help topic; 
display a definition; 
initiate a command, or 
select an option.
Insert a hyperlink 
for the link text, and 
then refer to the text 
without using the 
word link or hyperlink. 

Click Check for 
updates.
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Control 
name

Definition Usage Example

List box Any type of box 
containing a list of 
items the user can 
select. The user cannot 
type a selection in a 
list box.
Depending on the 
type of list, use either 
list or box, whichever is 
clearer.

In the Wallpaper list, 
click the background 
wallpaper of your 
choice.

List view List views enable users 
to view and interact 
with a collection of 
data objects, using 
either single selection 
or multiple selection. 
Refer to a list view as 
a list.

In the Picture library 
list, click Forest 
Flowers.

Option button
 (do not use 
radio but-
ton except 
in developer 
content.)

Round button used to 
select one of a group 
of mutually exclusive 
options.

Click Portrait.

Progress bar Progress bars enable 
users to follow the 
progress of a lengthy 
operation.

While the Memory 
Diagnostics Tool runs, 
you see a progress 
bar that indicates the 
status of the test.

Progressive 
disclosure 
controls

Progressive disclosure 
controls enable users 
to show or hide 
additional informa-
tion including data, 
options, or commands.
Refer to individual 
controls by name. 
You can also use the 
name and a symbol 
in parentheses or an 
image.

To expand or collapse 
the folder, click the 
plus sign (+) or the 
minus sign (-) next to 
the folder name.
or
Click the chevron to 
expand your current 
network profile.
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Control 
name

Definition Usage Example

Slider*
(also called 
trackbar con-
trol in some 
developer 
content)

Indicator on a gauge 
that displays and sets 
a value from a con-
tinuous range, such as 
speed, brightness, or 
volume.

Move the slider to the 
right to increase the 
volume.

Spin box
(do not use 
spinner or 
other labels)

Text box with up and 
down arrows that the 
user clicks to move 
through a set of fixed 
values. The user can 
also type a valid value 
in the box.

In the Date box, type 
or select the part of 
the date that you want 
to change.

Tab*
(also called 
tabbed page 
in technical 
documenta-
tion)

Labeled group of 
options used for 
many similar kinds of 
settings.

On the Tools menu, 
click Options, and 
then click the View 
tab. 
Note   Always include 
tab with the label 
name.

Text box Rectangular box in 
which the user can 
type text. If the box 
already contains text, 
the user can select 
that default text or 
delete it and type new 
text.

In the Size box, select 
10 or type a new font 
size. 
In the Size box, enter 
a font size.
Note   You can use 
enter if there is no 
chance of confusion.

Title
(do not use 
caption)

Title of the dialog 
box. It usually, but not 
always, matches the 
title of the command 
name. Refer to the 
dialog box by its title 
when necessary, espe-
cially if the user needs 
to go to a new tab.

In the Options dialog 
box, click the View 
tab.

Unfold button Command button 
with two “greater 
than” signs (>>) that 
enlarges a second-
ary window to reveal 
more options or 
information.

Click Profiles for more 
information.

* Check box, tab, and slider are the only terms in this table that should typically be used in end-user documentation 
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For the names and functions of some other controls not included in this list, see the Controls 
section of the Windows User Experience Interaction Guidelines on MSDN.

Unnamed buttons
If you refer to an unnamed button that appears in the interface, use the name of the tooltip, and then 
insert a bitmap showing the button, if possible. For more information, see dialog boxes, Document 
conventions (Chapter 6), User interface text.

Microsoft style

Click the Minimize button .

If you need help, click the Microsoft Word Help button .

If you cannot use inline graphics, use the name only.

Microsoft style

Click the Minimize button.

Modes of interaction

This section describes modes of interacting with the user interface.

Gesture
Use gesture to refer to a motion that the user can make to interact with hardware such as a touchpad, 
or a software program such as a game.

An air gesture can be a movement made by any part of a user’s body to give an instruction to the 
program via a sensor or camera, or a pose that the user makes in front of a sensor or camera to which 
an avatar will react.

A contact gesture can be a motion made with a user’s finger or hand directly on a screen or 
surface. If such a gesture is made above the screen or surface, it is an air gesture.

It is all right to use title capitalization for gesture names. Consult your project style sheet for the 
appropriate capitalization for your content. However, do not capitalize a gesture when it is used as a 
verb.

Microsoft style

The Help Me gesture displays the Help screen.

Draw a question mark to get help.

To speed through the intersection, perform the Boost gesture by quickly raising both arms above 
your head.

Now boost through the intersection.

http://msdn.microsoft.com/en-us/library/aa511482.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
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Not Microsoft style

The help me gesture displays the Help screen.

Perform the boost gesture by quickly raising both arms above your head.

Now Boost through the intersection.

For more information about referring to gestures, see the following:

■■ drag

■■ flick

■■ hover over

■■ pan

■■ pinch

■■ pointer

■■ pointing device

■■ scroll

■■ stretch

■■ swipe

■■ tap

■■ turn

■■ vibration

Speech
Users of a natural user interface with speech recognition functionality can interact with a program by 
using voice commands. A voice command is a structured verbal input from the user that a program 
will respond to.

Enclose voice commands in quotation marks. Use punctuation at the end of the command 
or sentence that includes a command, but punctuation preceding or within the command is not 
necessary unless needed to avoid ambiguity. Always capitalize the first word in a voice command.

Microsoft style

To call Sean, say “Call Sean Bentley mobile.”

“Find local pizza.”

“Open Marketplace.”

If you want your cub to roll on the ground, just say “Roll over.”
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Not Microsoft style

To call Sean, say “Call: Sean Bentley, mobile.”

Mouse terminology

This topic includes the following sections:

■■ How to refer to the mouse.

■■ How to refer to mouse pointers.

■■ Which verbs to use to refer to mouse actions.

■■ How to document mouse procedures.

How to refer to the mouse
If you need to refer to more than one mouse, use mouse devices if you can. Otherwise, use mice.

In general, use mouse button to indicate the left mouse button. Use left mouse button only to 
teach beginning skills or in a discussion of more than one mouse button when not referring to the left 
mouse button would create ambiguity.

Use right mouse button, not other terms such as mouse button 2 or secondary mouse button. 
Regardless of accuracy, users understand this term and users who reprogram their buttons make the 
mental shift.

When more than one mouse button is used within a procedure, identify only the least commonly 
used button.

Microsoft style

With the right mouse button, double-click the icon.

Click the Badges tab, and then use the right mouse button to double-click the badge that you want 
to edit.

Use wheel button to refer to the third or middle button on the mouse. Users rotate the wheel itself, 
and they click the wheel button.

How to refer to mouse pointers
Refer to the mouse pointer as the pointer. Use cursor only in content for a technical audience.

For pointers that have activity indicators, use busy pointer for the pointer that consists of only 
an activity indicator and working in background pointer for the combination pointer and activity 
indicator.
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It is best to use a graphic to describe the various ways the mouse pointer can appear on the 
screen. If that is not possible, use descriptive labels for mouse pointers. However, do not use a graphic 
or a descriptive label as a synonym for pointer.

Microsoft style

When the pointer becomes a , drag the pointer to move the split line.

When the pointer becomes a double-headed arrow, drag the pointer to move the split line.

Not Microsoft style

When the pointer becomes a double-headed arrow, drag the double-headed arrow to move the 
split line.

Which verbs to use to refer to mouse actions
In general, use point to, not move the mouse pointer to. Use the latter only in teaching beginning skills.

Microsoft style

Point to the window border.

Use click, not click on.  

Microsoft style

Using the mouse, click the Minimize button.

Click the image to select it.

Use click with a file, command, or option name, as in ”Click OK,” but use in to refer to clicking in a 
general area within a window or dialog box. 

Microsoft style

To see the Control menu, right-click anywhere in the window.

Click in the window to make it active.

Not Microsoft style

To see the Control menu, right-click the window.

Click the Styles box.

Always hyphenate double-click and right-click as verbs.  

Microsoft style

Double-click the Word icon.

Right-click to see the shortcut menu.

Use right-click to mean click with the right mouse button.
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Microsoft style

Right-click the selected text, and then click Copy.

■■ Use press and hold the mouse button only to teach beginning skills.

■■ Use drag, not click and drag. Use press and drag only to teach beginning skills. The drag action 
includes holding down a button while moving the mouse and then releasing the button.

■■ Use drag, not drag-and-drop, for the action of moving a document or folder. It is all right to 
use drag-and-drop as an adjective, as in “moving the folder is a drag-and-drop operation.” It is 
also all right to use drop by itself if drag is not precise enough. For more information, see drag, 
drag-and-drop.

Microsoft style

Drag the folder to the desktop.

Drop your files here.

Use rotate, not roll, to refer to rotating the wheel button.  

Microsoft style

Rotate the wheel button forward to scroll up in the document.

How to document mouse procedures
Be consistent in the way that you list mouse procedures. For example, always list the mouse method 
before listing the keyboard method if you document both.

Do not combine keyboard and mouse actions as if they were keyboard shortcuts.

Microsoft style

Hold down Shift while clicking the right mouse button.

Not Microsoft style

Shift+click the right mouse button.

Key names

In general, spell key names as they appear in the following list, whether the name appears in text or in 
a procedure. Capitalize as indicated.

Note  This list applies to Microsoft and PC-type keyboards unless otherwise noted. 
Differences with the Mac keyboard are noted.
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Microsoft style

Alt

arrow keys (not direction keys, directional keys, or movement keys)

Backspace

Break

Caps Lock

Clear

Command (the Mac keyboard only. Use the bitmap to show this key whenever possible, because the 
key is not named on the keyboard.)

Control (the Mac keyboard only. Does not always map to the Ctrl key on the PC keyboard. Use 
correctly.)

Ctrl

Del (the Mac keyboard only. Use to refer to the forward delete key.)

Delete (Use to refer to the back delete key on the Mac keyboard.)

Down Arrow (Use the definite article the and key with the arrow keys except in key combinations or 
key sequences. Always spell out. Do not use graphical arrows.)

End

Enter (On the Mac, use only when functionality requires it.)

Esc (Always use Esc, not Escape, especially on the Mac.)

F1 - F12

Help (the Mac keyboard only. Always use “the HELP key” to avoid confusion with the Help button.)

Home

Insert

Left Arrow (Use the definite article the and key with the arrow keys except in key combinations or key 
sequences.)

Num Lock

Option (the Mac keyboard only)

Page Down

Page Up

Pause
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Print Screen

Reset

Return (the Mac keyboard only)

Right Arrow (Use the definite article the and key with the arrow keys except in key combinations or 
key sequences.)

Scroll Lock

Select

Shift

Spacebar (Precede with the definite article the except in procedures, key combinations, or key 
sequences.)

Tab (Use the definite article the and key except in key combinations or key sequences.)

Up Arrow (Use the definite article the and key with the arrow keys except in key combinations or key 
sequences.)

Windows logo key

Spell key names that do not appear in this list as they appear on the keyboard. Use title 
capitalization.

When telling a user to press a letter key, capitalize the letter. When telling a user to type a letter 
key, use lowercase for the letter and use bold formatting, unless an uppercase letter is required.

Microsoft style

Press Y.

Type y.

Note  Format punctuation according to intended use. If the user must type the 
punctuation, use bold formatting. If not, use regular type.

On first mention, you can use the definite article the and key with the key name if necessary for 
clarity. For example, use “the F1 key.” On subsequent mention, refer to the key only by its name. 
For example, use “press F1.”

For the arrow keys and the Tab key, list only the key name in key combinations without the definite 
article the and key.

Microsoft style

To move the insertion point, use the Left Arrow key.

To extend the selection, press Shift+Arrow.
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Special character names
Because special character names could be confused with an action (such as +) or be difficult to see, 
always spell out the following special character names: Plus Sign, Minus Sign, Hyphen, Period, and 
Comma.

Microsoft style

Shift+Plus Sign

Press Alt, Hyphen, C

Press Comma

Press Command+Period

Type an em dash

Press the Plus Sign (+)

Not Microsoft style

Shift+ +

Shift+ -

Press +.

It is all right to add the symbol in parentheses after the special character to avoid confusion, as in 
Plus Sign (+). This is probably not necessary for commonly used symbols such as Period (.).

Names of keyboard “quick access” keys
Terms in current or recent use are listed in the following table. See the specific topics for more details.

Keyboard “quick access” keys

Name Alternative name Definition Audience

Accelerator key Now obsolete in all uses. Do not use.

Access key Keyboard shortcut Keyboard sequence 
corresponding to underlined 
letter on a menu name or 
command.

Use with a technical audience 
only. If a term is necessary in 
documentation for a general 
audience, use keyboard shortcut. 

Application key Key that opens a shortcut menu 
containing commands related to a 
selection in a program. Equivalent 
to right-clicking the selection.

All

Back key Key that performs the same action 
as the Back button in a browser.

All

Forward key Key that performs the same 
action as the Forward button in a 
browser.

All
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Name Alternative name Definition Audience

Hot key Key that activates a TSR 
(memory-resident program).

Obsolete. Use keyboard shortcut.

Quick key Do not use.

Shortcut key Keyboard shortcut Key that corresponds to a 
command name on a menu, such 
as Ctrl+Z.

Use with a technical audience 
only. If a term is necessary in 
documentation for a general 
audience, use keyboard shortcut. 

Speed key Do not use.

Start key Key that opens the Windows Start 
menu.

All.

Keyboard shortcuts
In most situations, it should be sufficient to refer to a key combination or key sequence by the keys 
that make it up. To specify a key combination, use the plus sign between the keys to be pressed. To 
specify a key sequence, use commas and spaces to indicate the sequence in which the keys must be 
pressed.

Microsoft style

To undo the last action, press Ctrl+Z.

To open a file, press Alt, F, O.

To show a key combination that includes punctuation that requires use of the Shift key, such as the 
question mark, add Shift to the combination and give the name or symbol of the shifted key. Using 
the name of the unshifted key, such as 4 rather than $, could be confusing to users or even wrong. For 
example, the ? and / characters are not always shifted keys on every keyboard. However, do spell out 
the names of the plus and minus signs, hyphen, period, and comma.

Microsoft style

Ctrl+Shift+?

Ctrl+Shift+*

Ctrl+Shift+Comma

Not Microsoft style

Ctrl+Shift+/

Ctrl+?

Ctrl+Shift+8

Ctrl+*
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If you must use a term to describe a keyboard shortcut, use keyboard shortcut. In content for 
software developers or in content that pertains to customizing the user interface, a more specific 
term such as key combination or key sequence may be needed.

Content for multiple platforms

With the proliferation in new technologies, writers and editors face new challenges in creating 
content that is appropriate for devices as diverse as computers, phones, TVs, and game consoles. 
When you create content that will be published on different devices, you must decide what 
terminology to use and how to write for screens of various sizes.

Before you start writing content or user interface text that will appear on different devices, consult 
with designers, developers, and localizers on your project to establish the guiding principles that will 
be used to govern the design, user flows, and user interface text. Ensure that everyone is working 
from the same frame of reference. Examples of guiding design principles include the following:

■■ There will be virtually no differences among the user interfaces of various devices.

■■ There will be some differences in the user interfaces to ensure that the user isn’t confused 
about where to perform actions.

■■ There will be a number of differences in the user interface to accommodate the various 
devices.

After the design principles have been established, consider the following guidelines when writing 
the content:

■■ Be as specific as possible when referring to the device being used. For example, if you’re 
talking about a phone, and only a phone, use phone. Don’t use device, especially if you are 
writing content for a general audience.

■■ If your content refers to more than one device, such as a phone and a computer, device is most 
likely the appropriate term.

■■ Decide how you will document device-specific user interactions when the user interface or user 
action varies across devices. For example, you might use a table, as in the following example.

To spin 180 degrees 

On this device Do this

Xbox Press Y.

PC Click Spin.

Phone Tap Y.

For more information about documenting alternative procedures, see Chapter 6, “Procedures and 
technical content.”
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User interface text

User interface (UI) text appears on UI surfaces such as dialog boxes, property sheets, buttons, 
and wizards. User interface text is as important to the overall design of a product or service as its 
functionality is. UI text is the most direct means that you have of communicating with your users. 
Therefore, your text must be clear and helpful. And although UI text must be short, it must still follow 
the same voice and tone guidelines as any other content. In addition, if your content will be localized, 
the text must allow for text expansion, which can be as high as 30 percent for some languages. That’s 
the challenge that UI text poses—maintaining clarity and a consistent voice, while working within the 
unique constraints of the user interface.

This topic contains a brief list of guidelines and a checklist to help you develop great UI text. 
For more detailed information about writing UI text, see the extended discussion of UI text on the 
User Interface Text page of the Windows User Experience Interaction Guidelines on MSDN  
(http://msdn.microsoft.com/en-us/library/aa511258.aspx).

If you only do six things 
1.	 Start writing UI text early, because UI text problems often reveal product or service design 

problems.

2.	 Think like a customer and ensure that you understand the entire workflow process:

•	 How do customers get to this surface? 

•	 What is the essential information that they need to accomplish the task on this surface?

•	 Where are they going from here?

3.	 Design your text for scanning. For more information, see the Layout page of the Windows 
User Experience Interaction Guidelines on MSDN.

4.	 Be concise, eliminate redundant text, and don’t over-communicate. Too much text 
discourages reading.

5.	 Provide links to Help content for more detailed information only when necessary. Don’t rely 
on Help to solve a design problem.

6.	 Use a consistent voice and consistent terminology across the product or service. For more 
information, see Chapter 1, “Microsoft style and voice.”

http://msdn.microsoft.com/en-us/library/aa511258.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
http://msdn.microsoft.com/en-us/library/aa511258.aspx
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High-level UI text checklist
■■ Is the text that describes the flow to and from the given UI surface logical? For more 

information, see the Windows User Experience Interaction Guidelines on MSDN.

■■ Is the point of the UI surface clear?

■■ Did you provide enough information for users to make a smart decision? Can they scan the 
text and still be successful?

■■ Did you use plain, straightforward words that your audience will understand?

■■ Did you use terms consistently? Is the voice consistent? For more information, see Chapter 1, 
“Microsoft style and voice.”

■■ Could you use fewer words while still ensuring that the customer will succeed?

■■ Is the UI text easy to localize? Will the text still work with the visual design if the text were to 
be 30 percent longer after translation?

■■ Does the text inspire users’ confidence that they can complete the task at hand?

User interface formatting

Consistent text formatting helps users locate and interpret information easily. Nowhere is this more 
important than in helping users navigate program user interfaces. For user interface elements, follow 
the capitalization and bold formatting guidelines in the following sections. For formatting conven-
tions of elements that are not part of the user interface, see Document conventions (Chapter 6).

Capitalization
Use the following capitalization guidelines for user interface elements:

■■ For menu names, command names, command button names, dialog box titles, and tab names, 
follow the capitalization of the user interface. If the user interface is inconsistent, use title 
capitalization.

■■ For dialog box and page elements, follow the capitalization of the user interface. Current style 
calls for these items to use sentence-style capitalization. If the interface is inconsistent, use 
sentence-style capitalization.

■■ For functional elements that do not have a label in the user interface, such as toolbars (the 
Standard toolbar) and toolbar buttons (the Insert Table button), use title capitalization. 
However, do not capitalize the element type such as toolbar, button, menu, scroll bar, 
and icon.

■■ For labels in the interface that are all lowercase or all uppercase, title capitalization is 
recommended.

http://msdn.microsoft.com/en-us/library/aa511258.aspx
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Always consult your project style sheet for terms that require specific capitalization or for terms 
that are traditionally all uppercase or all lowercase.

Bold formatting
In general, use bold formatting for user interface elements, both in procedures and in other text 
in instructional content. An exception is in content designed to generate interest, such as presales 
materials or overview content on the web, or if following this guidance would make content 
unreadable, it is all right not to use bold formatting for UI elements. When in doubt, consult your 
project style sheet.

Microsoft style

The Word 2010 ribbon has such tabs as the Home tab, the Insert tab, and the Page Layout tab.

On the Home tab, in the Clipboard group, click Copy.

Do not use bold formatting for feature names unless the user must click the feature name.

For more information, see Controls; Document conventions (Chapter 6); Ribbons, menus, and 
toolbars; Procedures (Chapter 6).

Microsoft style

When the Track Changes feature is turned on, you can view all changes that you make in a document.

On the Review tab, in the Tracking group, click Track Changes.

With Remote Desktop Connection, you can connect to your work computer from your home 
computer.

To open Remote Desktop Connection, click Start, point to All Programs, click Accessories, and then 
click Remote Desktop Connection.

Not Microsoft style

When the Track Changes feature is turned on, you can view all of the changes that you make in a 
document.

With Remote Desktop Connection, you can connect to your work computer from your home 
computer.

To open Remote Desktop Connection, click Start, point to All Programs, click Accessories, and 
then click Remote Desktop Connection.

Use the following bold formatting guidelines for user interface elements. For some elements, 
special capitalization guidance is also mentioned.
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Element Convention Example

Butt\on names Bold. On the Standard toolbar, click Toolbox.
On the Debug toolbar, click Immediate.

Commands on menus, 
toolbars, and ribbons

Bold. On the View menu, point to Other 
Windows, and then click Solution Explorer.
On the Outlining toolbar, select the level 
that you want in the Outline Level box.
On the Review tab, in the Comments 
group, click New Comment.

Dialog box options Bold. In the Find and Replace dialog box, type 
the text that you want Word to search for in 
the Find what box.
Click the More button to display more 
options.
If All is not selected in the Search box, click 
the arrow next to the Search box, and then 
click All.
Click the Replace tab, and then type the 
text that you want Word to replace in the 
Replace with box.
Click to select the Match case and Find 
whole words only check boxes. 

Dialog box titles Bold. You can also set a document’s password in 
the Protect Document dialog box.
You can add text entries in the AutoCorrect 
dialog box.

File names 
(system-defined)

Bold in procedures if the user must click 
the file name or type the name as shown. 
Capitalization follows that of the user in-
terface unless the name is all uppercase or 
all lowercase. If the name of the file is all 
uppercase or all lowercase, use title capi-
talization.

Double-click the Scanpst.exe file to open 
the Inbox Repair Tool.
The SignedManagedObject.cer file
The Iexplore.exe file (iexplore in UI)
The Acwzmain.mdb file (ACWZMAIN.mdb 
in UI)

Folder and directory 
names (system-defined)

Bold in procedures if the user must click 
the folder or directory name or type the 
name as shown. Capitalization follows that 
of the user interface unless the name is all 
uppercase or all lowercase. If the name of 
the folder or directory is all uppercase or 
all lowercase, use title capitalization, un-
less the folder or directory name is named 
in part or wholly after an acronym. Then, 
keep the acronym part of the name in up-
percase letters.

Click the Music folder.
The Microsoft shared folder (microsoft 
shared in UI)
The Errorrep folder (ERRORREP in the UI)
The PChealth folder (PCHEALTH in the UI)
The OEM folder

Icon names Usually bold. Treatment may vary, so al-
ways consult your project style sheet.

Drag the file to the Recycle Bin.
In Control Panel, click Add New Hardware.

List names Bold. In the Wallpaper list, click…

Menu names Bold. Debug menu
Favorites menu
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Element Convention Example

Panes, named Usually bold only when clicking a 
command. Treatment may vary, so always 
consult your project style sheet.

If you don’t see the navigation pane on the 
left side of an open window, click Organize, 
point to Layout, and then click Navigation 
pane to display it.
When the Navigation Pane is open, you can 
close it to increase your workspace.

Panes, unnamed or 
generic use

Sentence capitalization. The navigation pane
The annotation pane

Tab names Bold. Click the View tab. 

Toolbar names Usually bold. Treatment may vary, so 
always consult your project style sheet.

On the Data Designer toolbar, click 
Relationship.
On the Text To Speech toolbar, click the 
command that you want to use.

Views, named Bold only when clicking a command. Switch to Design view by right-clicking the 
form, and then clicking Design View.

Views, unnamed Sentence capitalization. In outline view
In chart view

Windows, named Usually bold. Treatment may vary, so 
always consult your project style sheet.

Copy and paste the code from the 
Immediate window into the Code window.
Double-click the table to open the 
Database Properties window.

Windows, unnamed Sentence capitalization. In the document window

Wizard names Bold only if clicked. On the Create tab, in the Forms group, click 
More Forms, and then click Form Wizard.
The Form Wizard can create a variety of 
results depending on the options that you 
select

Wizard page names Bold. On the Identify Fact and Dimension 
Tables page, the fact and dimension tables 
identified by the wizard are displayed.
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