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Features and Conventions
You can save time when you use this book by understanding how the Step by Step series 
shows special instructions, keys to press, buttons to click, and so on.

Convention Meaning

1
2

Numbered steps guide you through hands-on exercises in each topic.

This icon at the beginning of a chapter indicates information about 
the practice files provided on the companion CD for use in the 
chapter.

USE This paragraph preceding a step-by-step exercise indicates the 
practice files that you will use when working through the exercise.

BE SURE TO This paragraph preceding a step-by-step exercise indicates any 
requirements you should attend to before beginning the exercise.

OPEN This paragraph preceding a step-by-step exercise indicates files that 
you should open before beginning the exercise.

CLOSE This paragraph following a step-by-step exercise provides instructions 
for closing open files or programs before moving on to another topic. 

Tip These paragraphs provide helpful hints or shortcuts that make 
working through a task easier.

Important These paragraphs point out information that you need to know to 
complete a procedure.

Troubleshooting These paragraphs explain how to fix common problems that might 
prevent you from continuing through an exercise.

See Also These paragraphs direct you to more information in this book about 
a topic.
In step-by-step exercises, keys you must press appear as they do on 
the keyboard.
A plus sign (+) between two key names means that you must press 
those keys at the same time. For example, “Press ” means that 
you hold down the Alt key while you press the Tab key.
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Convention Meaning
Program elements In steps, program elements such as buttons, commands, and dialog 

boxes are shown in black bold type.
Glossary terms Terms that are explained in the glossary at the end of the book are 

shown in blue italic type.
User input Text that you are supposed to type appears in blue bold type in the 

procedures.
Files, folders, URLs, 
and emphasis

Files, folder paths, URLs, and emphasized words appear in italic type.
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Using the Companion CD
The companion CD included with this book contains practice files you can use as you 
work through the book’s exercises. By using practice files, you won’t waste time creating 
samples and typing spreadsheet data. Instead, you can jump right in and concentrate on 
learning how to use Microsoft Office Excel 2007.

CD Contents
The following table lists the practice files supplied on the companion CD.

Chapter Folder\File
Chapter 1:  
What’s New in Excel 2007

None

Chapter 2:  
Setting Up a Workbook

Creating\Exception Summary.xlsx
Creating\Route Volume.xlsx

Chapter 3: Working with Data 
and Data Tables

Data and Data Tables\2007Q1ShipmentsByCategory.xlsx
Data and Data Tables\Average Deliveries.xlsx
Data and Data Tables\Driver Sort Times.xlsx
Data and Data Tables\Series.xlsx
Data and Data Tables\Service Levels.xlsx

Chapter 4: Performing 
Calculations on Data

Formulas\ConveyerBid.xlsx 
Formulas\ITExpenses.xlsx
Formulas\PackagingCosts.xlsx
Formulas\VehicleMiles.xlsx
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Chapter Folder\File
Chapter 5: Changing 
Document Appearance

Appearance\acbluprt.jpg
Appearance\callcenter.jpg 
Appearance\CallCenter.xlsx
Appearance\Dashboard.xlsx
Appearance\ExecutiveSearch.xlsx
Appearance\HourlyExceptions.xlsx
Appearance\HourlyTracking.xlsx
Appearance\VehicleMileSummary.xlsx

Chapter 6: Focusing on 
Specific Data Using Filters

Focusing\Credit.xlsx
Focusing\ForFollowUp.xlsx
Focusing\PackageExceptions.xlsx

Chapter 7: Reordering and 
Summarizing Data

Sorting\GroupByQuarter.xlsx
Sorting\ShipmentLog.xlsx
Sorting\ShippingSummary.xlsx

Chapter 8: Combining Data 
from Multiple Sources

MultipleFiles\Consolidate.xlsx
MultipleFiles\Daily Call Summary.xlsx
MultipleFiles\February Calls.xlsx
MultipleFiles\Fleeting Operating Costs.xlsx
MultipleFiles\January Calls.xlsx
MultipleFiles\Operating Expense Dashboard.xlsx

Chapter 9: Analyzing 
Alternative Data Sets

Alternatives\2DayScenario.xlsx
Alternatives\Ad Buy.xlsx
Alternatives\Driver Sort Times.xlsx
Alternatives\Multiple Scenarios.xlsx
Alternatives\Target Values.xlsx

Chapter 10: Creating Dynamic 
Lists with PivotTables

PivotTables\Creating.txt
PivotTables\Creating.xlsx
PivotTables\Editing.xlsx
PivotTables\Focusing.xlsx
PivotTables\Formatting.xlsx

Chapter 11: Creating Charts 
and Graphics

Charting\Future Volumes.xlsx
Charting\Org Chart.xlsx
Charting\Revenue Analysis.xlsx
Charting\Volume by Center.xlsx
Charting\Yearly Package Volume.xlsx
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Chapter Folder\File
Chapter 12: Printing Printing\ConsolidatedMessenger.png

Printing\Corporate Revenue.xlsx
Printing\Hourly Pickups.xlsx
Printing\Pickups by Hour.xlsx
Printing\Revenue by Customer.xlsx
Printing\Summary by Customer.xlsx

Chapter 13: Automating 
Repetitive Tasks with Macros

Macros\Performance Dashboard.xlsm
Macros\RunOnOpen.xlsm
Macros\VolumeHighlights.xlsm
Macros\Yearly Sales Summary.xlsx

Chapter 14: Working with 
Other Microsoft Office 
System Programs

Other Programs\2007 Yearly Revenue Summary.pptx
Other Programs\Hyperlink.xlsx
Other Programs\Level Descriptions.xlsx
Other Programs\Revenue Chart.xlsx
Other Programs\Revenue Summary.pptx
Other Programs\RevenueByServiceLevel.xlsx
Other Programs\Summary Presentation.xlsx

Chapter 15: Collaborating 
with Colleagues

Sharing\Cost Projections.xlsx
Sharing\Projection Change Tracking.xlsx
Sharing\Projections for Comment.xlsx
Sharing\Projections Signed.xlsx
Sharing\SecureInfo.xlsx
Sharing\Shipment Summary.xlsx

Minimum System Requirements
To run Excel 2007, your computer needs to meet the following minimum hardware 
requirements:

l	 500 megahertz (MHz) 

l	 256 megabytes (MB) RAM

l	 1.5 gigabytes (GB) available space

l	 CD or DVD drive

l	 1024 × 768 or higher resolution monitor
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Installing the Practice Files
You need to install the practice files in the correct location on your hard disk before you 
can use them in the exercises. Follow the steps below:

	       Important  If for any reason you are unable to install the practice files from the CD, the files 
	         can also be downloaded from the Web at .

	 1.	 Remove the companion CD from the envelope at the back of the book, and insert 
it into the CD drive of your computer. If the AutoPlay window opens, click Run 
startcd.exe.

The Microsoft Software License Terms appear. To use the practice files, you must 
accept the terms of the license agreement.

	 2.	 Click I accept the agreement, and then click Next.
After you accept the license agreement, the CD interface appears.

Important  If the menu screen does not appear, click the Start button and then click 
Computer. Display the Folders list in the Navigation pane, click the icon for your CD 
drive, and then in the right pane, double-click the StartCD executable file.

	 3.	 Click Practice Files. If the File Download and/or Internet Explorer Security dialog 
boxes open, click Yes and/or Run.

	 4.	 On the Welcome page of the InstallShield Wizard, click Next. On the License 
Agreement page, click I accept the terms in the license agreement, and then 
click Next.

	 5.	 If you want to install the practice files to a location other than the default folder 
(Documents\Microsoft Press\Excel2007SBS), click the Browse button, select the 
new drive and path, and then click OK.

Important  If you are using Windows XP or earlier, the default folder will be My 
Documents\Microsoft Press\Excel2007SBS.

	 6.	 On the Custom Setup page, click Next, and then on the Ready to Install the 
Program screen, click Install.

	 7.	 After the practice files have been installed, click Finish.

	 8.	 Close the Step by Step Companion CD window.

	 9.	 Remove the companion CD from the CD drive, and return it to the envelope at the 
back of the book.

http://wwww.microsoftpressstore.com/title/9780735623040
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Using the Practice Files
When you install the practice files from the companion CD that accompanies this book, 
the files are stored on your hard disk in chapter-specific subfolders under Documents\
Microsoft Press\Excel2007SBS. Each exercise is preceded by a paragraph that lists the files 
needed for that exercise and explains any preparations needed before you start working 
through the exercise. Here are examples:

USE   the ForFollowUp workbook. This practice file is located in the Documents\Microsoft 
Press\Excel2007SBS\Focusing folder.

BE SURE TO  start Excel 2007 before beginning this exercise.

OPEN  the ForFollowUp workbook.

You can browse to the practice files in Windows Explorer by following these steps:

	 1.	 On the Windows taskbar, click the Start button, and then click Documents. 

Or 

If you are using Windows XP or earlier, click My Documents instead.

	 2.	 In the Documents or My Documents folder, double-click Microsoft Press, 
double-click Excel2007SBS, and then double-click a specific chapter folder. 

You can browse to the practice files from a dialog box by following these steps:

	 1.	 In the Favorite Links pane in the dialog box, click Documents.

Or 

If you are using Windows XP or earlier, click My Documents on the Places bar 
instead.

	 2.	 In the Documents or My Documents folder, double-click Microsoft Press, 
double-click Excel2007SBS, and then double-click a specific chapter folder.

Tip  You can also view the practice files by selecting Browse on the CD menu.
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Uninstalling the Practice Files
You can free up hard disk space by uninstalling the practice files that were installed 
from the companion CD. The uninstall process also deletes any files that you created in 
the Microsoft Press\Excel2007SBS chapter-specific folders while working through the 
exercises. Follow these steps:

	 1.	 On the Windows taskbar, click the Start button, and then click Control Panel.

	 2.	 In Control Panel, under Programs, click the Uninstall a program task.

Or

In Control Panel, click Add or Remove Programs.

	 3.	 If you are using Windows Vista, in the Programs and Features window, click 
Microsoft Office Excel 2007 Step by Step, and then on the toolbar at the top 
of the window, click the Uninstall button.

Or

In the Add or Remove Programs window, click Microsoft Office Excel 2007 Step 
by Step, and then click Remove.

	 4.	 If a message box asks you to confirm the deletion, click Yes.

See Also  If you need additional help installing or uninstalling the practice files, see “Getting 
Help” later in this book.

Important Microsoft Product Support Services does not provide support for this book or 
its companion CD.
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Getting Help
Every effort has been made to ensure the accuracy of this book and the contents of its 
companion CD. If you do run into problems, please contact the sources listed below for 
assistance.

Errata & Book Support
If you find an error, please report it on our Microsoft Press site:

	 2.	 In the Search box, enter the book’s ISBN or title.

	 3.	 Select your book from the search results.

	 5.	 Click View/Submit Errata.

You’ll find additional information and services for your book on its catalog page. If  
you need additional support, please e-mail Microsoft Press Book Support at 
mspinput@microsoft.com.

If for any reason you are unable to install the practice files from the CD, the files can also 
be downloaded from the Web here: 

 http://www.microsoftpressstore.com/title/9780735623040

Please note that product support for Microsoft software is not offered through the ad-
dresses above.

Getting Help with Excel 2007
If your question is about Microsoft Office Excel 2007, and not about the content  
of this Microsoft Press book, please search the Office 2007 Solution Center or the 
Microsoft Knowledge Base at:

support.microsoft.com

In the United States, Microsoft software product support issues not covered by the 
Microsoft Knowledge Base are addressed by Microsoft Product Support Services. 
Location-specific software support options are available from:

support.microsoft.com/gp/selfoverview/

1. Go to www.microsoftpressstore.com.

4. On your book’s catalog page, find the Errata & Updates tab.

http://www.microsoftpressstore.com/title/9780735623040
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We Want to Hear from You
At Microsoft Press, your satisfaction is our top priority, and your feedback our most 
valuable asset. Please tell us what you think of this book at:

http://www.microsoft.com/learning/booksurvey

The survey is short, and we read every one of your comments and ideas. Thanks in  
advance for your input!

Stay in Touch
Let’s keep the conversation going! We’re on Twitter: http://twitter.com/MicrosoftPress
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The Microsoft Business Certification 
Program

Desktop computing proficiency is becoming increasingly important in today’s business 
world. As a result, when screening, hiring, and training employees, more employers 
are relying on the objectivity and consistency of technology certification to ensure  
the competence of their workforce. As an employee or job seeker, you can use tech-
nology certification to prove that you already have the skills you need to succeed,  
saving current and future employers the trouble and expense of training you.

The Microsoft Business Certification program is designed to assist employees in  
validating their Windows Vista skills and 2007 Microsoft Office program skills. The  
following certification paths are available:

l	 A Microsoft Certified Application Specialist (MCAS) is an individual who has 
demonstrated proficiency in Windows Vista or in a 2007 Office program by  
passing a certification exam in Windows Vista or in one or more of the 2007 
Office programs, including Microsoft Office Word 2007, Microsoft Office Excel 
2007, Microsoft Office PowerPoint 2007, Microsoft Office Outlook 2007, and 
Microsoft Office Access 2007.

l	 A Microsoft Certified Application Professional (MCAP) is an individual who has 
taken his or her knowledge of the 2007 Office system and of Microsoft SharePoint 
Products and Technologies to the next level and has demonstrated by passing 
a certification exam that he or she can use the collaborative power of the Office 
system to accomplish job functions such as Budget Analysis and Forecasting, or 
Content Management and Collaboration.
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Selecting a Certification Path
When selecting a Microsoft Business Certification path that you would like to pursue, 
you should assess the following: 

l•	 The program and program version(s) with which you are familiar

l	 The length of time you have used the program

l	 Whether you have had formal or informal training in the use of that program

Candidates for MCAS-level certification are expected to successfully complete a 
wide range of standard business tasks, such as formatting a document or worksheet. 
Successful candidates generally have six or more months of experience with Windows 
Vista or the specific Office program, including either formal, instructor-led training 
or self study using MCAS-approved books, guides, or interactive computer-based 
materials.

Candidates for MCAP-level certification are expected to successfully complete more 
complex, business-oriented tasks that involve using the advanced functionality of  
the combined 2007 Office suite of products, as well as SharePoint. Successful candi-
dates generally have at least six months and may have several years of experience  
with the programs, including formal, instructor-led training or self study using  
MCAP-approved materials.

Becoming a Microsoft Certified Application 
Specialist—Microsoft 2007 Office System

Every MCAS and MCAP certification exam is developed from a set of exam skill 
standards that are derived from studies of how the 2007 Office programs are used 
in the workplace. Because these skill standards dictate the scope of each exam, they 
provide critical information about how to prepare for certification. 
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To become a Microsoft Certified Application Specialist in one of the 2007 Office programs, 
you must demonstrate the proficiency in these areas: 

Exam Skill sets
77-601: Using Microsoft Office 
Word 2007

Creating and Customizing Documents
Formatting Content
Working with Visual Content
Organizing Content
Reviewing Documents
Sharing and Securing Content

77-602: Using Microsoft Office 
Excel 2007

Creating and Manipulating Data
Formatting Data and Content
Creating and Modifying Formulas
Presenting Data Visually 
Collaborating and Securing Data

77-603: Using Microsoft Office 
PowerPoint 2007

Creating and Manipulating Data
Formatting Data and Content
Creating and Modifying Formulas
Presenting Data Visually 
Collaborating and Securing Data

77-604: Using Microsoft Office 
Outlook 2007

Managing Messaging
Managing Scheduling
Managing Tasks
Managing Contacts and Personal Contact Information
Organizing Information

77-605: Using Microsoft Office 
Access 2007

Structuring a Database
Creating and Formatting Database Elements
Entering and Modifying Data
Creating and Modifying Queries
Presenting and Sharing
Managing and Maintaining Databases
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Taking a Microsoft Business Certification Exam
The MCAS and MCAP certification exams for Windows Vista and the 2007 Office pro-
grams are performance-based and require you to complete business-related tasks using 
interactive simulation (a digital model) of the Windows Vista operating system or one or 
more programs in the Office suite. 

Test Taking Tips
l	 Follow all instructions provided in each question completely and accurately.

l	 Enter requested information as it appears in the instructions, but without duplicating 
the formatting unless you are specifically instructed to do otherwise.

l	 Close all dialog boxes before proceeding to the next exam questions unless you are 
specifically instructed to do otherwise.

l	 Don’t close task panes proceeding to the next exam questions unless you are spe-
cifically instructed to do otherwise.

l	 If you are asked to print a document, spreadsheet, chart, report, or slide, perform 
the task, but be aware that nothing will actually be printed. 

l	 Don’t worry about extra keystrokes or mouse clicks. Your work is scored based on 
its result, not on the method you use to achieve that result, and not on the time 
you take to complete the question. 

l	 If your computer becomes unstable during the exam or if a power outage occurs, 
contact a testing center administrator immediately. The administrator will restart 
the computer and return the exam to the point where the interruption occurred 
with your score intact.
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Certification Benefits
At the conclusion of the exam, you will receive a score report, which you can print with 
the assistance of the testing center administrator. If your score meets or exceeds the 
passing standard (the minimum required score), you will be contacted by e-mail by  
the Microsoft Certification Program team and mailed a printed certificate within approxi-
mately 14 days. The e-mail message you receive will include your Microsoft Certification 
ID and links to online resources, including the Microsoft Certified Professional site. On 
this site, you can order a welcome kit and ID card, view and send your certification tran-
script, build a personalized certification logo, and access other useful and interesting 
resources, including special offers from Microsoft and affiliated companies.

Using the Logo Builder, you can create a personalized certification logo that includes 
the MCAS logo and the specific programs in which you have achieved certification. If 
you achieve MCAS certification in multiple programs, you can include all of them in 
one logo, like this:

You can include your personalized logo on business cards and other personal promo-
tional materials. This logo attests to the fact that you are proficient in the applications 
or cross-application skills necessary to achieve the certification.

For More Information
To learn more about the Microsoft Certified Application Specialist exams, the Microsoft 
Certified Application Professional exams, and related courseware, visit

www.microsoft.com/learning/mcp/msbc
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Quick Reference
	 2	 Setting Up a Workbook

To open a workbook 

	 1.	 Click the Microsoft Office Button, and then click Open.

	 2.	 Navigate to the folder that contains the workbook you want to open.

	 3.	 Click the workbook, and then click Open.

To create a new workbook 

	 1.	 Click the Microsoft Office Button, and then click New.

	 2.	 In the New Workbook window, click Blank Workbook.

	 3.	 Click Create.

To save a workbook 

	 1.	 On the Quick Access Toolbar, click the Save button.

	 2.	 Type a name for the file.

	 3.	 Click Save.

To set file properties 

	 1.	 Click the Microsoft Office Button, point to Prepare, and then click Properties.

	 2.	 In the Document Information Panel, click the type of properties you want to set in 
the Property Views and Options list.

	 3.	 Add information describing your file, and then close the Document Information 
Panel.

To define custom properties 

	 1.	 Click the Microsoft Office Button, point to Prepare, and then click Properties.

	 2.	 In the Property Views and Options list, click Advanced Properties.

	 3.	 In the Properties dialog box, click the Custom tab.

	 4.	 In the Name box, type a property name, select the type of data contained in the 
property, and then type a value for the property.

	 5.	 Click Add, and then click OK.
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To display a worksheet

➜	 Click the sheet tab of the worksheet you want to display.

To create a new worksheet 

	 1.	 Right-click the sheet tab of the worksheet that follows the location where you want 
to insert a worksheet, and then click Insert.

	 2.	 In the Insert dialog box, double-click Worksheet.

To rename a worksheet 

	 1.	 Double-click the sheet tab of the worksheet you want to rename.

	 2.	 Type the new name of the worksheet, and then press .

To copy a worksheet to another workbook

	 1.	 Open the workbook that will receive the new worksheets.

	 2.	 Switch to the workbook that contains the worksheets you want to copy, hold 
down the  key, and click the sheet tabs of the worksheets you want to copy.

	 3.	 Right-click the selection, and then click Move Or Copy.

	 4.	 Select the Create A Copy check box.

	 5.	 In the To Book list, click the workbook to which you want the worksheet(s) 
copied.

	 6.	 Click OK.

To change the order of worksheets in a workbook

➜	 Drag the sheet tab of the worksheet you want to move.

To hide a worksheet

	 1.	 Hold down the  key and click the sheet tabs of the worksheets you want 
to hide.

	 2.	 Right-click any selected worksheet tab, and then click Hide.

To unhide a worksheet 

	 1.	 Right-click any worksheet tab, and then click Unhide.

	 2.	 Click the worksheet you want to unhide, and then click OK.
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To delete a worksheet 

	 1.	 Hold down the  key and click the sheet tabs of the worksheets you want to 
delete.

	 2.	 Right-click the selection, and then click Delete.

To change a row’s height or column’s width 

	 1.	 Select the rows and columns you want to resize.

	 2.	 Drag a row or column border until it is the desired size.

To insert a column or row 

➜	 Right-click the column header to the right of, or the row header below, where you 
want the new column or row to appear, and then click Insert.

To delete columns or rows

	 1.	 Select the rows or columns you want to delete.

	 2.	 Right-click the selection, and then click Delete.

To hide columns or rows

	 1.	 Select the rows or columns you want to hide.

	 2.	 Right-click a row or column header in the selection, and then click Hide.

To unhide columns or rows

	 1.	 Click the row or column header of the row above or the column to the left of the 
rows or columns you want to unhide.

	 2.	 Hold down the  key and click the row or column header of the row or column 
below or to the right of the rows or columns you want to unhide.

	 3.	 Right-click the selection, and then click Unhide.

To insert a cell 

	 1.	 Select the cells in the location where you want to insert new cells.

	 2.	 Display the Home tab.

	 3.	 In the Cells group, in the Insert list, click Insert Cells.

	 4.	 Select the option representing how you want to move the existing cells to make 
room for the inserted cells. Then click OK.
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To delete cells

	 1.	 Select the cells you want to delete.

	 2.	 Display the Home tab.

	 3.	 In the Cells group, in the Delete list, click Delete Cells.

	 4.	 Select the option representing how you want the remaining cells to fill in the 
deleted space.

	 5.	 Click OK.

To move a group of cells to a new location 

	 1.	 Select the cells you want to move.

	 2.	 Point to the outline of the selected cells.

	 3.	 Drag the cells to the desired location.

To zoom in or out on a worksheet 

	 l	 Click the Zoom In control to make your window’s contents 10 percent larger.

	 l	 Click the Zoom Out control to make your window’s contents 10 percent smaller.

	 l	 Drag the Zoom slider control to the left to zoom out, or to the right to zoom in.

To zoom in or out to a specific zoom level 

	 1.	 On the View tab, in the Zoom group, click Zoom.

	 2.	 Select the Custom option.

	 3.	 Type a new zoom level in the Custom field.

	 4.	 Click OK.

To change to another open workbook 

	 1.	 On the View tab, in the Window group, click Switch Windows.

	 2.	 Click the name of the workbook you want to display.

To arrange all open workbooks in the program window 

	 1.	 On the View tab, in the Window group, click Arrange All.

	 2.	 Select the desired arrangement.

	 3.	 Click OK.
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To add a button to the Quick Access Toolbar 

	 1.	 Click the Customize Quick Access Toolbar button, and then click More 
Commands.

	 2.	 In the Choose Commands From list, click the category from which you want to 
choose the command.

	 3.	 Click the command you want to add, and then click the Add button.

	 4.	 After you finish adding commands, click OK.

To move a button on the Quick Access Toolbar 

	 1.	 Click the Customize Quick Access Toolbar button, and then click More 
Commands.

	 2.	 In the active command list, click the command you want to move.

	 3.	 Click the Move Up button or the Move Down button.

To remove a button from the Quick Access Toolbar 

	 1.	 Right-click the button you want to remove.

	 2.	 Click Remove from Quick Access Toolbar.

To hide and display the Ribbon

l	 To hide the Ribbon, double-click the active tab label.

l	 To temporarily redisplay the Ribbon, click the tab label you want. Then click any 
button on the tab, or click away from the tab, to rehide it.

l	 To permanently redisplay the Ribbon, double-click any tab label.

To hide the formula bar

➜	 On the View tab, in the Show/Hide group, clear the Formula Bar check box.

To hide column and row headings

➜	 On the View tab, in the Show/Hide group, clear the Headings check box.



xxx    Quick Reference

	 3	 Working with Data and Data Tables
To enter a data series using AutoFill 

	 1.	 Type the first label or value for your list.

	 2.	 Drag the fill handle to the cell containing the last label or value in the series.

To change how dragging the fill handle extends a series 

	 1.	 Type the first label or value for your list.

	 2.	 Hold down the  key, and drag the fill handle to the cell containing the last label 
or value in the series.

To enter data by using AutoComplete 

	 1.	 Type the beginning of an entry.

	 2.	 Press  to accept the AutoComplete value.

To enter data by picking from a list 

	 1.	 Right-click a cell in a column with existing values, and then click Pick from 
Drop‑down List.

	 2.	 Click the item in the list you want to enter.

To copy and paste cells 

	 1.	 Select the cells you want to copy.

	 2.	 On the Home tab, in the Clipboard group, click Copy.

	 3.	 Click the cells into which you want to paste the values.

	 4.	 On the Home tab, in the Clipboard group, click Paste.

To transpose data when pasting

	 1.	 Copy the cells you want to transpose.

	 2.	 Click the cell in which you want to paste the contents of the top or left copied cell.

	 3.	 In the Paste list, click Transpose.

To copy and paste a row or column 

	 1.	 Select the row or column you want to copy.

	 2.	 On the Home tab, in the Clipboard group, click Copy.

	 3.	 Click the header of the row or column into which you want to paste the values.

	 4.	 On the Home tab, in the Clipboard group, click Paste.
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To find data within a worksheet

	 1.	 On the Home tab, in the Editing group, click Find & Select, and then, in the list, 
click Find.

	 2.	 Type the text you want to find, and then click Find Next.

To replace a value with another value within a worksheet

	 1.	 In the Editing group, click Find & Select, and then, in the list, click Replace.

	 2.	 Type the text you want to replace.

	 3.	 Type the text you want to take the place of the existing text, and then click Find Next.

	 4.	 For each search term located, click Find Next, follow any of these steps, and then 
repeat:

❍	 Click Replace to replace the text.

❍	 Click Find Next to skip this instance of the text and move to the next time it 
occurs.

❍	 Click Replace All to replace every instance of the text.

To edit a cell’s contents by hand 

	 1.	 Click the cell you want to edit.

	 2.	 In the formula bar, select the text you want to edit.

	 3.	 Type the new text, and then press .

To check spelling 

	 1.	 On the Review tab, in the Proofing group, click Spelling. If you are asked whether 
you want to save your work, do so.

	 2.	 Follow any of these steps:

❍	 Click Ignore Once to ignore the current misspelling.

❍	 Click Ignore All to ignore all instances of the misspelled word.

❍	 Click Add to Dictionary to add the current word to the dictionary.

❍	 Click the correct spelling, and then click Change to replace the current 
misspelling with the correct word.

❍	 Click the correct spelling, and then click Change All to replace all instances of 
the current misspelling with the correct word.

❍	 Click Cancel to stop checking spelling.

	 3.	 Click OK to clear the dialog box that appears after the spelling check is complete.
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To look up a word in the Thesaurus 

	 1.	 Select the word you want to look up.

	 2.	 On the Review tab, in the Proofing group, click Thesaurus.

To translate a word to another language 

	 1.	 Select the word you want to look up.

	 2.	 On the Review tab, in the Proofing group, click Translate.

To create a data table 

	 1.	 Type your table headers in a single row.

	 2.	 Type your first data row directly below the header row.

	 3.	 Click any cell in the range from which you want to create a table.

	 4.	 On the Home tab, in the Styles group, click Format as Table.

	 5.	 Click the desired table style.

	 6.	 Verify that Excel identified the data range correctly.

	 7.	 If your table has headers, select the My table has headers check box.

	 8.	 Click OK.

To add rows to a data table 

➜	 Click the cell at the bottom right corner of the data table and press  to create a 
new table row.

➜	 Type data into the cell below the bottom left corner of the data table and press . 
Excel will make the new row part of the data table.

To resize a table 

	 1.	 Click any cell in the table.

	 2.	 Drag the resize handle to expand or contract the table.

To add a Total row to a column 

	 1.	 Click any cell in the table.

	 2.	 On the Design tab, in the Table Style Options group, click Total Row.
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To change the Total row summary function 

	 1.	 Click any cell in the table’s Total row.

	 2.	 Click the down arrow that appears.

	 3.	 Click the desired summary function.

To rename a table 

	 1.	 Click any cell in the table.

	 2.	 On the Design tab, in the Properties group, type a new value in the Table 
Name box.

	 4	 Performing Calculations on Data
To create a named range 

	 1.	 Select the cells you want to name.

	 2.	 On the formula bar, click the Name Box.

	 3.	 Type the name you want for the range.

	 4.	 Press .

To create a named range from a selection 

	 1.	 Select the cells you want to name as a range. Be sure either the first or last cell 
contains the name for the range.

	 2.	 On the Formulas tab, in the Defined Names group, click Create from Selection.

	 3.	 Select the check box that represents the cell that contains the range’s desired 
name.

	 4.	 Click OK.

To display the Name Manager 

➜	 On the Formulas tab, in the Defined Names group, click Name Manager.

To edit a named range 

	 1.	 On the Formulas tab, in the Defined Names group, click Name Manager.

	 2.	 Click the named range you want to edit, and then click the Edit button.

	 3.	 Click the Collapse Dialog button.

	 4.	 Select the cells you want the range to include, and then click Close.
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To delete a named range

➜	 In the Edit Name dialog box, click the range you want to delete, and then click the 
Delete button.

To create a formula 

	 1.	 Click the cell into which you want to enter a formula.

	 2.	 Type =.

	 3.	 Type the expression representing the calculation you want to perform. 

	 4.	 Press .

To create a formula using the Insert Function dialog box 

	 1.	 On the Formulas tab, in the Function Library group, click Insert Function.

	 2.	 Select the function you want to use, and click OK.

	 3.	 Fill in the Function Arguments dialog box, and click OK.

To use a named range in a formula 

	 1.	 Begin typing the formula.

	 2.	 Type the name of the named range as a function’s argument.

To refer to a table column or row in a formula 

	 1.	 Click the cell in which you want to create the formula.

	 2.	 Type =, followed by the function to include in the formula and a left parenthesis; 
for example, =SUM( would be a valid way to start.

	 3.	 Point to the header of the table column you want to use in the formula. When 
the mouse pointer changes to a black, downward-pointing arrow, click the  
column header.

	 4.	 Type a right parenthesis and press .

To create a formula using Formula AutoComplete 

	 1.	 Begin typing the formula.

	 2.	 Click the desired function from the list that appears.

To create a formula that doesn’t change when copied between cells 

	 1.	 Begin typing the formula.

	 2.	 Precede all column and row references with a dollar sign (for example, $C$4).
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To create a formula that does change when copied between cells 

	 1.	 Begin typing the formula.

	 2.	 Type all column and row references without a dollar sign (for example, C4).

To create a conditional formula 

	 1.	 Click the cell in which you want to enter an IF function.

	 2.	 On the Formulas tab, in the Function Library group, click Logical, and then 
click IF.

	 3.	 Type a conditional statement that evaluates to true or false.

	 4.	 Type the text you want to appear if the condition is true.

	 5.	 Type the text you want to appear if the condition is false.

	 6.	 Click OK.

To display cells that provide values for a formula 

	 1.	 Click the cell you want to track.

	 2.	 On the Formulas tab, in the Formula Auditing group, click the Trace Precedents 
button.

To display formulas that use a cell’s contents  

	 1.	 Click the cell you want to track.

	 2.	 On the Formulas tab, in the Formula Auditing group, click the Trace Dependents 
button.

To remove tracer arrows 

	 1.	 Click the cell you want to track.

	 2.	 On the Formulas tab, in the Formula Auditing group, click the Remove Arrows 
button.

To locate errors in a worksheet 

	 1.	 On the Formulas tab, in the Formula Auditing group, click the Error Checking 
button.

	 2.	 Click the Edit in Formula Bar button.

	 3.	 Edit the formula.

	 4.	 Click the Next button to view the next error.
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To step through a formula to locate an error 

	 1.	 Click the cell with the formula you want to evaluate.

	 2.	 On the Formulas tab, in the Formula Auditing group, click Evaluate Formula.

	 3.	 Click Evaluate (one or more times) to move through the formula’s elements.

	 4.	 Click Close.

To watch a value in a cell 

	 1.	 On the Formulas tab, in the Formula Auditing group, click Watch Window.

	 2.	 Click Add Watch.

	 3.	 Select the cells you want to watch.

	 4.	 Click Add.

	 5.	 Click Watch Window.

To delete a watch 

	 1.	 On the Formulas tab, in the Formula Auditing group, click Watch Window.

	 2.	 Click the watch you want to delete.

	 3.	 Click Delete Watch.

	 4.	 Click the Close button.

	 5	 Changing Workbook Appearance
To change a cell’s font, font style, font color, or background color 

	 1.	 Select the cells you want to change.

	 2.	 On the Home tab, use the controls in the Font group to format the cells.

To add a border to a cell 

	 1.	 Select the cells around which you want to draw a border.

	 2.	 On the Home tab, in the Font group, click the Border arrow, and then, in the list, 
click the type of border you want to apply.

To apply a style to a cell 

	 1.	 Select the cells you want to change.

	 2.	 On the Home tab, in the Styles group, click Cell Styles.

	 3.	 Click a style.
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To create a new style 

	 1.	 On the Home tab, in the Styles group, click Cell Styles.

	 2.	 Click New Cell Style.

	 3.	 Type a new style name.

	 4.	 Click Format.

	 5.	 Specify the formatting you want this style to contain.

	 6.	 Click OK twice.

To delete a style 

	 1.	 On the Home tab, in the Styles group, click Cell Styles.

	 2.	 Right-click the style you want to delete.

	 3.	 Click Delete.

To copy a cell’s formatting onto another cell 

	 1.	 Click the cell that contains the format you want to apply to another cell.

	 2.	 On the Home tab, in the Clipboard group, click the Format Painter button.

	 3.	 Select the cells to which you want to apply the formatting.

To apply a workbook theme 

	 1.	 On the Page Layout tab, in the Themes group, click Themes.

	 2.	 Click the theme you want to apply.

To change theme fonts, colors, and graphic effects 

➜	 Using the Controls on the Page Layout tab, in the Themes group, follow one of 
these steps:

❍	 Click the Fonts button and select a new font.

❍	 Click the Colors button and select a new color set.

❍	 Click the Effects button and select a new default effect.

To save a workbook’s format as a new theme 

	 1.	 Format your worksheet using the colors, fonts, and effects you want to include in 
your theme.

	 2.	 On the Page Layout tab, in the Themes group, click Themes.

	 3.	 Click Save Current Theme.
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	 4.	 Type a name for your theme.

	 5.	 Click Save.

To create a new table style 

	 1.	 On the Home tab, in the Styles group, click Format as Table, and then click New 
Table Style.

	 2.	 In the Name field, type a name for the table style.

	 3.	 In the Table Element list, click the element you want to format.

	 4.	 Click Format, and use the controls in the Format dialog box to format the table 
element.

	 5.	 Click OK.

	 6.	 Repeat as desired to format other elements, and then click OK.

To format a cell value as a phone number 

	 1.	 On the Home tab, click the Number dialog box launcher.

	 2.	 Click Special.

	 3.	 Click Phone Number.

	 4.	 Click OK.

To format cell data as a currency value 

➜	 On the Home tab, in the Number group, click the Accounting Number Format 
button.

To select a foreign currency symbol 

➜	 On the Home tab, in the Number group, click the Accounting Number Format 
arrow, and then, in the list, click the currency symbol you want to apply.

To add words to a cell’s value 

	 1.	 On the Home tab, click the Number dialog box launcher.

	 2.	 Click Custom.

	 3.	 Click the format to serve as the base for your custom format.

	 4.	 Type the text to appear in the cell, enclosed in quotes (for example, “cases”).

	 5.	 Click OK.
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To apply a conditional format to a cell 

	 1.	 Select the cells you want to change.

	 2.	 On  the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Click New Rule.

	 4.	 Click Format Only Cells That Contain.

	 5.	 In the Comparison Phrase list, click the comparison phrase you want.

	 6.	 Type the constant values or formulas you want evaluated.

	 7.	 Click Format.

	 8.	 Specify the formatting you want and click OK twice.

To edit a conditional formatting rule 

	 1.	 Select the cells that contain the rule you want to edit.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Click Manage Rules.

	 4.	 Click the rule you want to change.

	 5.	 Click Edit Rule.

	 6.	 Use the controls to make your changes.

	 7.	 Click OK twice to save your changes.

To delete a conditional formatting rule 

	 1.	 Select the cells that contain the rule you want to edit.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Click Manage Rules.

	 4.	 Click the rule you want to delete.

	 5.	 Click Delete Rule.

	 6.	 Click OK.

To display data bars in one or more cells 

	 1.	 Select the cells that contain your data.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Point to Data Bars.

	 4.	 Click the data bar option you want to apply.
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To display a color scale in one or more cells 

	 1.	 Select the cells that contain your data.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Point to Color Scales.

	 4.	 Click the color scale pattern you want to apply.

To display icon sets in one or more cells 

	 1.	 Select the cells that contain your data.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting.

	 3.	 Point to Icon Sets.

	 4.	 Click the icon set you want to apply.

To add a picture to a worksheet 

	 1.	 On the Insert tab, in the Illustrations group, click Picture.

	 2.	 Double-click the picture you want to insert.

To change a picture’s characteristics 

	 1.	 Click the picture.

	 2.	 Use the controls on the Format tab to edit the picture.

	 6	 Focusing on Specific Data by Using Filters
To apply a filter to a worksheet 

	 1.	 Click any cell in the range you want to filter.

	 2.	 On the Data tab, in the Sort & Filter group, click Filter.

	 3.	 Click the filter arrow for the column by which you want to filter your worksheet.

	 4.	 Select the check boxes next to the values by which you want to filter the list.

	 5.	 Click OK.

To clear a filter 

	 1.	 Click any cell in the filtered range.

	 2.	 On the Data tab, in the Sort & Filter group, click Clear.
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To display the top or bottom values in a column 

	 1.	 Click the filter arrow at the top of the column by which you want to filter the list.

	 2.	 Click Number Filters.

	 3.	 Click Top 10.

	 4.	 Select whether to display the top or bottom values.

	 5.	 Select how many values to display.

	 6.	 Select whether the value in the middle box represents the number of items to 
display, or the percentage of items to display.

To create a custom filter 

	 1.	 Click any cell in the list you want to filter.

	 2.	 If necessary, on the Data tab, in the Sort & Filter group, click Filter to display the 
filter arrows.

	 3.	 Click the filter arrow of the column for which you want to create a custom filter.

	 4.	 Point to Text Filters.

	 5.	 Click Custom Filter.

	 6.	 In the Comparison Operator list, click the comparison you want to use.

	 7.	 Type the value by which you want to compare the values in the selected column.

	 8.	 Click OK.

To generate a random value 

➜	 Type the formula =RAND().

To generate a random value between two other values 

➜	 Type the formula =RANDBETWEEN(low, high), replacing low and high with the 
lower and upper bound of values you want to generate.

To summarize data quickly using AutoCalculate 

	 1.	 Select the cells you want to summarize.

	 2.	 View the summary on the status bar, at the bottom right of the Excel program 
window.

To summarize filtered data using a SUBTOTAL formula 

➜	 Type the formula =SUBTOTAL(function, ref), replacing function with the desired 
summary function, and ref with the cell range you want so summarize.
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To find list rows that contain unique values 

	 1.	 Select the cells in which you want to find unique values.

	 2.	 On the Data tab, in the Sort & Filter group, click Advanced.

	 3.	 Select the Unique Records Only check box.

	 4.	 Click OK.

To create a validation rule 

	 1.	 Select the cells you want to validate.

	 2.	 On the Data tab, in the Data Tools group, click the Data Validation, and then, 
in the list, click Data Validation.

	 3.	 In the Allow list, click the type of data you want to allow.

	 4.	 In the Data list, click the condition for which you want to validate.

	 5.	 Type the appropriate values in the boxes.

	 6.	 Click the Input Message tab.

	 7.	 Select the Show input message when cell is selected check box.

	 8.	 Type the message you want to appear when the cell is clicked.

	 9.	 Click the Error Alert tab.

	 10.	 Select the Show error alert after invalid data is entered check box.

	 11.	 In the Style list, click the icon you want to appear next to your message.

	 12.	 Type a title for the error message box.

	 13.	 Type the error message you want.

	 14.	 Click OK.

To identify which cells contain invalid data 

➜	 In the Data Validation list, click Circle Invalid Data.

To turn off data validation in a cell 

➜	 In the Data Validation list, click Clear Invalidation Circles.
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	 7	 Reordering and Summarizing Data
To sort a data list 

	 1.	 Click any cell in the column by which you want to sort your data.

	 2.	 On the Data tab, in the Sort & Filter group, click the Sort Ascending button 
or the Sort Descending button.

To sort a data list by values in multiple columns 

	 1.	 Select a cell in the data list or table you want to sort.

	 2.	 On the Data tab, in the Sort & Filter group, click Sort.

	 3.	 In the Sort By list, click the first column by which you want to sort.

	 4.	 In the Sort On list, click the criteria by which you want to sort.

	 5.	 In the Order list, click A to Z or Z to A to indicate the order into which the 
column’s values should be sorted.

	 6.	 Click Add Level.

	 7.	 If necessary, repeat steps 3–6 to set the columns and order for additional sorting 
rules.

	 8.	 Click OK.

To add a sorting level 

	 1.	 Select a cell in the data list or table you want to sort.

	 2.	 On the Data tab, in the Sort & Filter group, click Sort.

	 3.	 Click Add Level, and define the sort using the tools in the dialog box.

To delete a sorting level 

	 1.	 Select a cell in the sorted data list.

	 2.	 On the Data tab, in the Sort & Filter group, click Sort.

	 3.	 Click the level you want to delete.

	 4.	 Click Delete Level.
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To create a custom list for sorting 

	 1.	 Click the Microsoft Office Button.

	 2.	 Click Excel Options.

	 3.	 Click Popular.

	 4.	 Click Edit Custom Lists.

	 5.	 Click New List.

	 6.	 Type the custom list you want. Separate each entry by pressing .

	 7.	 Click Add.

	 8.	 Click OK twice to close the Custom Lists dialog box and the Excel Options 
dialog box.

To sort worksheet data by a custom list of values 

	 1.	 Click any cell in the list you want to sort.

	 2.	 On the Data tab, in the Sort & Filter group, click Sort.

	 3.	 In the Sort By list, click the column you want to sort by.

	 4.	 In the Sort On list, click the criteria you want to sort by.

	 5.	 In the Order list, click Custom List.

	 6.	 Click a custom list.

	 7.	 Click OK to close the Custom Lists dialog box.

	 8.	 Click OK to sort the data list.

To organize worksheet data into groups 

	 1.	 Click any cell in the range you want to group.

	 2.	 On the Data tab, in the Outline group, click Subtotal.

	 3.	 In the At Each Change In list, click the value on which you want to base the 
subtotals.

	 4.	 In the Use Function list, click the subtotal function you want to use.

	 5.	 Select which columns should have subtotals calculated.

	 6.	 Click OK.
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To show and hide levels of detail in a grouped data list 

➜	 Follow either of these steps:

❍	 Click the Show Detail control on a hidden grouping level to display that 
level’s contents.

❍	 Click the Hide Detail control to hide rows that are currently displayed.

To remove grouping levels from a data list 

	 1.	 Click any cell in the subtotaled range.

	 2.	 On the Data tab, in the Outline group, click Subtotal, and then click Remove All.

To look up data in a data list 

	 1.	 Create a sorted data list or data table that has column headers.

	 2.	 Create a VLOOKUP formula of the form =VLOOKUP(lookup_value, table_array, 
col_index_num, range_lookup). 

	 3.	 Type a value in the cell referred to by the lookup_value argument.

	 8	 Combining Data from Multiple Sources
To create a workbook template 

	 1.	 Click the Microsoft Office Button, and click Save As.

	 2.	 In the Save As Type list, click Excel Template.

	 3.	 Type the name you want for the template.

	 4.	 Click Save.

To create a new workbook that is based on a template 

	 1.	 Click the Microsoft Office Button, and click New.

	 2.	 Click Installed Templates, and double-click the template you want to use to create 
your workbook.

	 3.	 Click the Microsoft Office Button, and click Save As.

	 4.	 Type a name for the file.

	 5.	 In the Save As Type list, click Excel Workbook.

	 6.	 Click Save.
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To create a worksheet template 

	 1.	 Remove all but one worksheet from a workbook, and format the worksheet as you 
want the template to appear.

	 2.	 Click the Microsoft Office Button, and click Save As.

	 3.	 In the Save As Type list, click Excel Template.

	 4.	 Type the name you want for the template.

	 5.	 Click Save.

To add a template-based worksheet to a workbook 

	 1.	 Right-click a sheet tab, and then click Insert.

	 2.	 On the Spreadsheet Solutions tab, click the template you want to use.

	 3.	 Click OK.

To create a link between two cells 

	 1.	 In the cell you want to be target of the link, type =, but do not press .

	 2.	 On the View tab, in the Window group, click Switch Windows, and then click the 
workbook that contains the data for your target cell.

	 3.	 Click the cell that contains the data, and press .

To open multiple workbooks simultaneously 

	 1.	 Open the workbooks you want to open simultaneously.

	 2.	 On the View tab, in the Window group, click Save Workspace.

	 3.	 Type a name for the workspace.

	 4.	 Click Save.

	 9	 Analyzing Alternative Data Sets
Define an alternative data set 

	 1.	 On the Data tab, in the Data Tools group, click What-If Analysis, and then click 
Scenario Manager.

	 2.	 Click Add.

	 3.	 In the Scenario Name field, type a name for the scenario.

	 4.	 At the right edge of the Changing cells field, click the Contract Dialog button.

	 5.	 Select the cells to change, and then click the Expand Dialog button.
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	 6.	 Click OK.

	 7.	 Type new values for the cells, and then click OK.

	 8.	 Click Close.

To change a worksheet’s values using a scenario 

	 1.	 On the Data tab, in the Data Tools group, click What-If Analysis, and then click 
Scenario Manager.

	 2.	 Click the scenario you want to display.

	 3.	 Click Show.

To summarize the values in multiple scenarios 

	 1.	 On the Data tab, in the Data Tools group, click What-If Analysis, and then click 
Scenario Manager.

	 2.	 Click Summary.

	 3.	 Verify that the Scenario summary option is selected and that the correct cells 
appear in the Result cells field.

	 4.	 Click OK.

To determine the required inputs for a formula to generate a specific result 

	 1.	 On the Data tab, in the Data Tools group, click What-If Analysis, and then click 
Goal Seek.

	 2.	 In the Set cell field, type the address of the cell that contains the formula you want 
to generate a target value.

	 3.	 In the To value field, type the target value.

	 4.	 In the By changing cell field, type the cell that contains the value you want to vary.

	 5.	 Click OK.

	 6.	 Click Cancel to close the Goal Seek dialog box without saving your changes.

To analyze data by using Descriptive Statistics 

	 1.	 On the Data tab, in the Analysis group, click Data Analysis.

	 2.	 Click Descriptive Statistics, and then click OK.

	 3.	 Click in the Input Range field, and then select the cells you want to summarize.

	 4.	 Select the Summary Statistics check box.

	 5.	 Click OK.
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	 10	 Creating Dynamic Lists by Using PivotTables
To create a PivotTable from a data list 

	 1.	 Click any cell in the data table.

	 2.	 On the Insert tab, in the Tables group, click PivotTable.

	 3.	 Verify that the proper table name or cell range appears in the Table/Range field 
and that the New Worksheet option is selected.

	 4.	 Click OK.

	 5.	 In the PivotTable Field List task pane, drag the available fields to the desired spots 
in the PivotTable.

To pivot a PivotTable 

➜	 In the PivotTable Field List task pane, drag a field header to a new position.

To filter a PivotTable 

	 1.	 On the PivotTable worksheet, click any cell in the PivotTable.

	 2.	 In the PivotTable Field List task pane’s Choose fields to add to report section, 
click the target field header. Then click the down arrow next to the field header 
and clear the (Select All) check box.

	 3.	 Select the check boxes of the values you do want to show, and then click OK.

To show or hide the PivotTable Field List task pane 

	 1.	 Click any cell in the PivotTable.

	 2.	 On the Options tab, in the Show/Hide group, click the Field List button.

To show or hide levels of detail within a PivotTable 

➜	 In the body of the PivotTable, follow either of these steps:

❍	 Click the Show Detail control to display hidden rows.

❍	 Click the Hide Detail control to hide rows displayed in the PivotTable.

To rename a PivotTable 

	 1.	 On the PivotTable worksheet, click any cell in the PivotTable.

	 2.	 On the Options contextual tab, in the PivotTable group, in the PivotTable Name 
field, type a new name for the PivotTable.
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To control how and where subtotals and grand totals appear in your PivotTable 

	 1.	 On the PivotTable worksheet, click any cell in the PivotTable.

	 2.	 On the Design contextual tab, in the Layout group, click Subtotals, and then click 
the option representing how you want subtotals to appear in your PivotTable. 

	 3.	 On the Design contextual tab, in the Layout group, click Grand Totals, and 
then click the option representing how you want grand totals to appear in your 
PivotTable.

To change the PivotTable summary function 

➜	 Right-click any data cell in the PivotTable, point to Summarize Data By, and then 
click the desired summary function.

To apply a number format to a PivotTable 

	 1.	 On the PivotTable worksheet, right-click any data cell, and then click Number 
Format.

	 2.	 In the Category list, click Number.

	 3.	 Use the controls on the Number tab to create your format.

	 4.	 Click OK.

To apply a conditional format to a PivotTable 

	 1.	 Select the cell ranges you want to format.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting, point to the 
type of conditional format you want to use, and then click the specific format you 
want to apply.

To apply a PivotTable Style to a PivotTable 

	 1.	 Click any cell in the PivotTable.

	 2.	 On the Design tab, in the PivotTable Styles gallery, click the style you want to 
apply to the PivotTable.

To create a new PivotTable style 

	 1.	 Click any cell in the PivotTable.

	 2.	 On the Design contextual tab, in the PivotTable Styles group, click the More but-
ton at the bottom-right corner of the style gallery.

	 3.	 Click New PivotTable Style.
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	 4.	 In the Name field, type a name for the style.

	 5.	 In the Table Element list, click the element you want to change, and then click 
Format.

	 6.	 Use the controls in the Format Cells dialog box to format the element.

	 7.	 If desired, repeat step 6 for other elements.

	 8.	 Click OK twice.

To import data from an external source 

	 1.	 On the Data tab, in the Get External Data group, click From Text.

	 2.	 Navigate to the folder that contains the source file, and double-click the file.

	 3.	 Verify that the Delimited option is selected, and then click Next.

	 4.	 In the Delimiters section, verify that the correct check box is selected, and also verify 
that the data displayed in the Data preview area reflects the structure you expect.

	 5.	 Click Finish.

	 11	 Creating Charts and Graphics
To create a chart 

	 1.	 Click any cell in the data table.

	 2.	 On the Insert tab, in the Charts group, click the desired chart type, and then click 
the desired chart subtype.

To change how Excel plots your data 

	 1.	 On the Design tab, in the Data group, click Select Data.

	 2.	 In the Legend Entries (Series) area, click the data series you want to change.

	 3.	 Click Remove.

	 4.	 In the Horizontal (Categories) Axis Labels area, click Edit.

	 5.	 Select the cells you want to plot on this axis, and then click OK.

To remove a series from an axis 

	 1.	 On the Design tab, in the Data group, click Select Data.

	 2.	 In the Legend Entries (Series) area, click the data series you want to remove from 
the chart.

	 3.	 Click Remove.
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To add a series to an axis 

	 1.	 On the Design tab, in the Data group, click Select Data.

	 2.	 In the Legend Entries (Series) area, click Add.

	 3.	 In the Series name box, type a name for the series.

	 4.	 Click in the Series values box, and select the cells to provide values for the series.

	 5.	 Click OK.

To move a chart to its own worksheet 

	 1.	 Click the chart.

	 2.	 On the Design tab, in the Location group, click Move Chart.

	 3.	 Select the target sheet for the chart, and click OK.

To apply a Chart Style to a chart 

	 1.	 Click the chart.

	 2.	 On the Design tab, in the Chart Styles gallery, click the style you want to apply.

To apply a different layout to a chart 

	 1.	 Click the chart.

	 2.	 On the Design tab, in the Chart Layouts gallery, click the layout you want to apply.

To change the appearance of a chart’s gridlines 

	 1.	 Click the chart.

	 2.	 On the Layout tab, in the Axes group, click Gridlines, and then click the gridline 
settings you want.

To select a chart element for formatting 

	 1.	 Click the chart.

	 2.	 On the Layout tab, in the Current Selection group, click the Chart Elements arrow 
and then, in the list, click the element you want to select.

To select a data point in a series 

	 1.	 Click the chart.

	 2.	 Click any point in the data series.

	 3.	 Click the specific data point you want to select.
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To format a chart element 

	 1.	 Select the chart element you want to format.

	 2.	 On the Layout tab, in the Current Selection group, click Format Selection.

	 3.	 Use the controls in the Format dialog box to format the chart element. 

To save a chart as a chart template 

	 1.	 Click the chart.

	 2.	 On the Design tab, in the Type group, click Save As Template.

	 3.	 Type a name for the template.

	 4.	 Click Save.

To add a trendline to a chart 

	 1.	 Select the chart.

	 2.	 On the Layout contextual tab, in the Analysis group, click Trendline, and then click 
More Trendline Options.

	 3.	 In the Trend/Regression Type area, click Linear.

	 4.	 In the Forecast area, in the Forward field, type the number of periods you want to 
project.

	 5.	 Click Close.

To create a PivotChart 

	 1.	 On the data worksheet, click any cell in the data table.

	 2.	 On the Insert tab, in the Tables group, click the PivotTable arrow and then, in the 
list, click PivotChart.

	 3.	 Verify that the correct data source appears in the Table/Range field and that the 
New Worksheet option is selected.

	 4.	 Click OK.

To change the chart type of a chart or PivotChart 

	 1.	 Click the chart.

	 2.	 On the Design contextual tab, in the Type group, click Change Chart Type.

	 3.	 Click the desired chart type and subtype.

	 4.	 Click OK.
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To create a SmartArt diagram 

	 1.	 On the Insert tab, in the Illustrations group, click SmartArt.

	 2.	 Click the desired graphic type.

	 3.	 Click the desired subtype, and then click OK.

To add text to a diagram shape 

➜	 Click the shape, and type the text.

To add a shape to a diagram 

	 1.	 Click the shape above or to the right of where you want the new shape to 
appears.

	 2.	 On the Design contextual tab, in the Create Graphic group, click the Add Shape 
arrow and then, in the list, click the option representing where you want the 
shape to appear.

To change the format of a diagram shape 

	 1.	 Right-click the shape, and then click Format Shape.

	 2.	 Use the controls in the Format Shape dialog box to change the shape’s 
appearance.

	 12	 Printing
To display a worksheet in Page Layout View 

➜	 On the View tab, in the Workbook Views group, click Page Layout.

To add a header or footer to a worksheet 

	 1.	 On the View tab, in the Workbook Views group, click Page Layout.

	 2.	 Follow either of these steps:

❍	 At the top of the worksheet, click the target header section.

❍	 At the bottom of the worksheet, click the target footer section.

	 3.	 In the active header or footer section, type the text that you want to have appear, 
and press .
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To create an AutoHeader 

	 1.	 On the View tab, in the Workbook Views group, click Page Layout.

	 2.	 At the top of the worksheet, click Click to add header.

	 3.	 Click in the target header section.

	 4.	 On the Design contextual tab, in the Header & Footer Elements group, click the 
auto text you want to add.

To add an image to a header or footer 

	 1.	 On the View tab, in the Workbook Views group, click Page Layout.

	 2.	 Click the desired header or footer section.

	 3.	 On the Design contextual tab, in the Header & Footer Elements group, click 
Picture.

	 4.	 Double-click the picture you want to add to the header or footer.

To format an image in a header or footer 

	 1.	 Click the image in the footer and then, on the Design contextual tab, click 
Format Picture.

	 2.	 Use the controls in the Format Picture dialog box to change the picture’s 
appearance.

	 3.	 Click OK.

To change a worksheet’s margins 

➜	 On the Page Layout tab, in the Page Setup group, click Margins, and then click 
the desired margins, or click Custom Margins to enter the margins manually.

To change a worksheet’s page orientation 

➜	 On the Page Layout tab, in the Page Setup group, click Orientation, and then 
click the desired orientation.

To print a worksheet on a specific number of pages 

	 1.	 On the Page Layout tab, in the Scale to Fit group, click the Width arrow and 
then, in the list, click the desired number of pages.

	 2.	 On the Page Layout tab, in the Scale to Fit group, click the Height arrow and 
then, in the list, click the desired number of pages.
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To preview a worksheet before printing 

➜	 While displaying the worksheet you want to preview, click the Microsoft Office 
Button, point to Print, and then click Print Preview.

To add a page break to a worksheet 

	 1.	 Click the row or header below or to the right of where you want the page break 
to appear.

	 2.	 On the Page Layout tab, in the Page Setup group, click Breaks, and then click 
Insert Page Break.

To remove a page break from a worksheet 

	 1.	 Click the row or header below or to the right of the page break.

	 2.	 On the Page Layout tab, in the Page Setup group, click Breaks, and then click 
Remove Page Break.

To change the order in which worksheets print 

	 1.	 On the Page Layout tab, click the Page Setup dialog box launcher.

	 2.	 If necessary, click the Sheet tab.

	 3.	 In the Page order section, click the desired option.

	 4.	 Click OK.

To print a worksheet 

➜	 Click the Microsoft Office Button, and then click Print.

To print part of a worksheet 

	 1.	 On the Page Layout tab, in the Page Setup group, click Print Titles.

	 2.	 At the right edge of the Columns to repeat at left field, click Collapse Dialog.

	 3.	 Select the column header of the columns you want to repeat.

	 4.	 At the right edge of the Columns to repeat at left field, click the Expand Dialog 
button.

To center material on the printed page 

	 1.	 On the Page Layout tab, click the Page Setup dialog box launcher.

	 2.	 On the Margins page of the dialog box, select the Horizontally and Vertically 
check boxes.

	 3.	 Click OK.
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To print a chart 

	 1.	 Select the chart.

	 2.	 Click the Microsoft Office Button, and then click Print.

	 3.	 Verify that the Selected Chart option is selected, and then click OK (or click 
Cancel if you don’t want to print the chart).

	 13	 Automating Repetitive Tasks by Using Macros
To save a workbook as a macro-enabled workbook 

	 1.	 Click the Microsoft Office Button, and then click Save As.

	 2.	 In the Save as type list, click Excel Macro-Enabled Workbook (*.xlsm).

	 3.	 Click Save.

To enable macros to run in a workbook 

	 1.	 On the Message Bar, click Options.

	 2.	 Click Enable this content.

	 3.	 Click OK.

To view a macro 

	 1.	 On the View tab, in the Macros group, click the Macros arrow and then, 
in the list, click View Macros.

	 2.	 Click the macro you want to view, and then click Edit.

To step through a macro 

	 1.	 In the Macros list, click View Macros.

	 2.	 Click the macro you want to view, and then click Step Into.

	 3.	 Press  to execute the first macro step.

To run a macro 

	 1.	 In the Macros list, click View Macros.

	 2.	 Click the desired macro, and then click Run.
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To record a macro 

	 1.	 In the Macros list, click Record Macro.

	 2.	 In the Record Macro dialog box, delete the existing name from the Macro name 
box, and then type a new name for the macro.

	 3.	 Click OK.

	 4.	 Perform the actions you want to record.

	 5.	 In the Macros list, click Stop Recording.

To edit a macro 

	 1.	 In the Macros list, click View Macros.

	 2.	 Click the macro you want to view, and then click Edit.

	 3.	 Make any desired changes.

	 4.	 Click the Visual Basic Editor Close button.

To run a macro when a Quick Access Toolbar button is clicked 

	 1.	 On the Quick Access Toolbar, click the Customize Quick Access Toolbar button, 
and then click More Commands.

	 2.	 If necessary, in the Choose commands from list, click the desired category.

	 3.	 In the Commands panel, click the desired command.

	 4.	 Click Add.

	 5.	 In the Choose commands from list, click Macros.

	 6.	 In the Commands panel, click the macro you want to run.

	 7.	 Click Add, and then cick OK.

To change the appearance of a Quick Access Toolbar button 

	 1.	 On the Quick Access Toolbar, click the Customize Quick Access Toolbar button, 
and then click More Commands.

	 2.	 In the Customize Quick Access Toolbar command panel, click the command you 
want to change.

	 3.	 Click Modify.

	 4.	 Click the desired button design.

	 5.	 Click OK twice to close the Modify Button dialog box and the Excel Options 
dialog box.
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To run a macro when a shape is clicked 

	 1.	 Right-click the shape, and then click Assign Macro.

	 2.	 Click the macro you want to assign to the shape, and then click OK.

To run a macro when a workbook is opened 

➜	 Name the macro Auto_Open.

	 14	 Working with Other Microsoft Office System Programs
To link to another Microsoft Office system document 

	 1.	 On the Insert tab, in the Text group, click the Insert Object button.

	 2.	 On the Create from File tab of the Object dialog box, click Browse.

	 3.	 Click the file to which you want to link, and then click Insert.

	 4.	 Select the Link to file check box, and then click OK.

To embed another document in a workbook 

	 1.	 On the Insert tab, in the Text group, click Object.

	 2.	 On the Create from File tab of the Object dialog box, click Browse.

	 3.	 Click the file to which you want to link, and then click Insert.

	 4.	 Click OK.

To view a linked or embedded document 

➜	 Double-click the document.

To create a hyperlink 

	 1.	 On the Insert tab, in the Links group, click Hyperlink.

	 2.	 Click the type of hyperlink you want to create.

	 3.	 If necessary, use the controls in the Look in box to locate the file or location to 
which you want to link.

	 4.	 In the file list, click the hyperlink’s target.

	 5.	 In the Text to display box, type the text you want displayed.

	 6.	 Click OK.
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To edit a hyperlink 

	 1.	 Right-click the cell that contains the hyperlink, and then click Edit Hyperlink.

	 2.	 Edit the values in the Hyperlink dialog box.

	 3.	 Click OK.

To delete a hyperlink 

➜	 Right-click the cell that contains the hyperlink, and then click Delete Hyperlink.

To paste a chart into another document 

	 1.	 Right-click the chart, and then click Copy.

	 2.	 Open the destination document.

	 3.	 Right-click the place you want to paste the chart, and then click Paste.

	 4.	 In the Paste Options list, click the desired option.

	 15	 Collaborating with Colleagues
To turn on workbook sharing 

	 1.	 On the Review tab, in the Changes group, click Share Workbook.

	 2.	 Select the Allow changes by more than one use at the same time check box.

	 3.	 Click OK.

To add a comment to a cell 

	 1.	 Click the cell where you want the comment to appear.

	 2.	 On the Review tab, in the Comments group, click New Comment.

	 3.	 Type the comment text, and then click outside the body of the comment.

To edit a comment 

	 1.	 Click the cell that contains the comment.

	 2.	 On the Review tab, in the Comments group, click Edit Comment.

	 3.	 Type the new comment text, and then click outside the body of the comment.

To delete a comment 

	 1.	 Click the cell that contains the comment.

	 2.	 On the Review tab, in the Comments group, click Delete Comment.
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To track changes made to a workbook 

	 1.	 On the Review tab, in the Changes group, click Track Changes, and then in the list 
click Highlight Changes.

	 2.	 Select the Track changes while editing. This also shares your workbook check box.

	 3.	 Click OK.

To accept and reject changes 

	 1.	 In the Track Changes list, click Accept/Reject Changes.

	 2.	 Click OK.

	 3.	 For each change, click Accept to accept the change, or click Reject to reject the 
change. You can also click Accept All or Reject All.

To record workbook changes on a History worksheet 

	 1.	 In the Track Changes list, click Highlight Changes.

	 2.	 Select the List changes on a new sheet check box, and click OK.

To require a password to open a workbook 

	 1.	 Click the Microsoft Office Button, and then click Save As.

	 2.	 Click the Tools button, and then click General Options.

	 3.	 Type a password in the Password to open box.

	 4.	 Type a different password in the Password to modify box.

	 5.	 In the General Options dialog box, click OK.

	 6.	 In the Reenter password to proceed box, type the first password, and then 
click OK.

	 7.	 In the Reenter password to modify box, type the second password, and then 
click OK.

To password protect a worksheet 

	 1.	 On the Review tab, in the Changes group, click Protect Sheet.

	 2.	 In the Password to unprotect sheet box, type a password.

	 3.	 Clear the Select locked cells and Select unlocked cells check boxes, and then 
click OK.

	 4.	 In the Reenter password to proceed box, type the password you entered before, 
and then click OK.
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To password protect a cell range 

	 1.	 On the Review tab, in the Changes group, click Allow Users to Edit Ranges.

	 2.	 In the Allow users to edit ranges dialog box, click New.

	 3.	 In the Title box, type a title for the range.

	 4.	 In the Range password box, type a password, and then click OK.

To sign a workbook using a digital signature 

	 1.	 Click the Microsoft Office Button, click Prepare, and then click Add a Digital 
Signature.

	 2.	 Click OK to clear the dialog box that appears.

	 3.	 In the Purpose for signing this document box, type a reason.

	 4.	 Verify that your certificate appears in the Signing as area of the dialog box, and 
then click Sign.

	 5.	 Click OK.

To publish a workbook to the Web 

	 1.	 Click the Microsoft Office Button, and then click Save As.

	 2.	 In the File name box, type a name for the file.

	 3.	 In the Save as type list, click Web Page.

	 4.	 Click Save.

	 5.	 Click Yes to save the workbook as a Web file.
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	 5	 Changing 
		  Workbook  
		  Appearance

In this chapter, you will learn to:
	 4	 Format cells.
	 4	 Define styles.
	 4	 Apply workbook themes and table styles.
	 4	 Make numbers easier to read.
	 4	 Change the appearance of data based on its value.
	 4	 Add images to worksheets.

Entering data into a workbook efficiently saves you time, but you must also ensure that 
your data is easy to read. Microsoft Office Excel 2007 gives you a wide variety of ways to 
make your data easier to understand; for example, you can change the font, character 
size, or color used to present a cell’s contents. Changing how data appears on a work-
sheet helps set the contents of a cell apart from the contents of surrounding cells. The 
simplest example of that concept is a data label. If a column on your worksheet has a list 
of days, you can set a label (for example, Day) apart easily by presenting it in bold type 
that’s noticeably larger than the type used to present the data to which it refers. To save 
time, you can define a number of custom formats and then apply them quickly to the 
desired cells.

You might also want to specially format a cell’s contents to reflect the value in that cell. 
For instance, Jenny Lysaker, the chief operating officer of Consolidated Messenger, might 
want to create a worksheet that displays the percentage of improperly delivered pack-
ages from each regional distribution center. If that percentage exceeds a threshold, she 
could have Excel 2007 display a red traffic light icon, indicating that the center’s perfor-
mance is out of tolerance and requires attention. 
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In addition to changing how data appears in the cells of your worksheet, you can also 
use headers and footers to add page numbers, current data, or graphics to the top and 
bottom of every printed page.

In this chapter, you’ll learn how to change the appearance of data, apply existing formats 
to data, make numbers easier to read, change data’s appearance based on its value, 
make printouts easier to follow, and position your data on the printed page.

See Also  Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference section at the beginning of this book.

Important  Before you can use the practice files in this chapter, you need to install them 
from the book’s companion CD to their default location. See “Using the Companion CD” at 
the beginning of this book for more information.

Formatting Cells
Excel 2007 spreadsheets can hold and process lots of data, but when you manage nu-
merous spreadsheets it can be hard to remember from a worksheet’s title exactly what 
data is kept in that worksheet. Data labels give you and your colleagues information 
about data in a worksheet, but it’s important to format the labels so that they stand out 
visually. To make your data labels or any other data stand out, you can change the for-
mat of the cells in which the data is stored.



Most of the tools you need to change a cell’s format can be found on the Home tab. You 
can apply the formatting represented on a button by selecting the cells you want to apply 
the style to and then clicking the appropriate button. If you want to set your data labels 
apart by making them appear bold, click the Bold button. If you have already made a cell’s 
contents bold, selecting the cell and clicking the Bold button will remove the formatting.

Tip  Deleting a cell’s contents doesn’t delete the cell’s formatting. To delete a selected cell’s 
formatting, on the Home tab, in the Editing group, click the Clear button, and then click 
Clear Formats.

Buttons in the Home tab’s Font group that give you choices, such as the Font Color control, 
have an arrow at the right edge of the button. Clicking the arrow displays a list of options 
accessible for that control, such as the fonts available on your system or the colors you can 
assign to a cell.

Another way you can make a cell stand apart from its neighbors is to add a border 
around the cell. To place a border around one or more cells, select the cells, and then 
choose the border type you want by selecting the type of border to apply from the 
Border list in the Font group. Excel 2007 does provide more options—to display the full 
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range of border types and styles, in the Border list, click More Borders. The Border tab 
of the Format Cells dialog box contains the full range of tools you can use to define your 
cells’ borders.

Another way you can make a group of cells stand apart from its neighbors is to change 
its shading, or the color that fills the cells. On a worksheet that tracks total package vol-
ume for the past month, Jenny Lysaker could change the fill color of the cells holding her 
data labels to make the labels stand out even more than by changing the formatting of 
the text used to display the labels.

Tip  You can display the most commonly used formatting controls by right-clicking a selected 
range. When you do, a Mini toolbar containing a subset of the Home tab formatting tools  
appears above the shortcut menu.

If you want to change the attributes of every cell in a row or column, you can click the 
header of the row or column you want to format and then select your desired format.

One task you can’t perform using the tools on the Home tab is to change the standard 
font for a workbook, which is used in the Name box and on the formula bar. The stan-
dard font when you install Excel 2007 is Calibri, a simple font that is easy to read on a 
computer screen and on the printed page. If you want to choose another font, click the 
Microsoft Office Button, and then click Excel Options. On the Popular page of the Excel 
Options dialog box, set the values in the Use This Font and Font Size list boxes to pick 
your new display font.



Important  The new standard font doesn’t take effect until you exit Excel 2007 and 
restart the program.

In this exercise, you will emphasize a worksheet’s title by changing the format of cell 
data, adding a border to a cell range, and then changing a cell range’s fill color. After 
those tasks are complete, you will change the default font for the workbook.

USE  the VehicleMileSummary workbook. This practice file is located in the Documents\
Microsoft Press\Excel2007SBS\Appearance folder.

BE SURE TO  start Excel 2007 before beginning this exercise.

OPEN  the VehicleMileSummary workbook.

	 1.	 Click cell D2.

	 2.	 On the Home tab, in the Font group, click the Bold button.

Excel 2007 displays the cell’s contents in bold type.

	 3.	 In the Font group, click the Font Size arrow, and then in the list, click 18.

Excel 2007 increases the size of the text in cell D2.

Bold

Font Size
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	 4.	 Select cells B5 and C4.

	 5.	 On the Home tab, in the Font group, click the Bold button.

Excel 2007 displays the cells’ contents in bold type.

	 6.	 Select the cell ranges B6:B15 and C5:H5.

	 7.	 In the Font group, click the Italic button.

Excel 2007 displays the cells’ contents in italic type.

	 8.	 Select the cell range C6:H15.

	 9.	 In the Font group, click the Border arrow, and then in the list, click Outside 
Borders.

Excel 2007 places a border around the outside edge of the selected cells.

	 10.	 Select the cell range B4:H15.

	 11.	 In the Border list, click Thick Box Border.

Excel 2007 places a thick border around the outside edge of the selected cells.

	 12.	 Select the cell ranges B4:B15 and C4:H5.

	 13.	 In the Font group, click the Fill Color arrow, and then in the Standard Colors 
section of the color palette, click the yellow button.

Italic

Border

Fill Color



Excel 2007 changes the selected cells’ background color to yellow.

	 14.	 Click the Microsoft Office Button, and then click Excel Options.

The Excel Options dialog box opens.

	 15.	 If necessary, click Popular to display the Popular tab.

	 16.	 In the When creating new workbooks section, in the Use this font list, click 
Verdana.

Verdana appears in the Use This Font field.

	 17.	 Click Cancel.

The Excel Options dialog box closes without saving your change.

CLOSE  the VehicleMileSummary workbook.

Microsoft Office 
Button
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Defining Styles
As you work with Excel 2007, you will probably develop preferred formats for data labels, 
titles, and other worksheet elements. Instead of adding the format’s characteristics one 
element at a time to the target cells, you can have Excel 2007 store the format and re-
call it as needed. You can find the predefined formats available to you by displaying the 
Home tab, and then in the Styles group, clicking Cell Styles.

Clicking a style from the Cell Styles gallery applies the style to the selected cells, but 
Excel 2007 goes a step beyond previous versions of the program by displaying a live 
preview of a format when you point to it. If none of the existing styles is what you want, 
you can create your own style by displaying the Cell Styles gallery and, at the bottom  
of the gallery, clicking New Cell Style to display the Style dialog box. In the Style dialog 
box, type the name of your new style in the Style Name field, and then click Format. 
The Format Cells dialog box opens.



After you set the characteristics of your new style, click OK to make your style available 
in the Cell Styles gallery. If you ever want to delete a style, display the Cell Styles gallery, 
right-click the style, and then click Delete.

The Style dialog box is quite versatile, but it’s overkill if all you want to do is apply for-
matting changes you made to a cell to the contents of another cell. To do so, use the 
Format Painter button, found in the Home tab’s Clipboard group. Just click the cell that 
has the format you want to copy, click the Format Painter button, and select the target 
cells to have Excel 2007 apply the copied format to the target range.

In this exercise, you will create a style, apply the new style to a data label, and then use 
the Format Painter to apply the style to the contents of another cell. 

USE  the HourlyExceptions workbook. This practice file is located in the Documents\
Microsoft Press\Excel2007SBS\Appearance folder.

OPEN  the HourlyExceptions workbook.

	 1.	 On the Home tab, in the Styles group, click Cell Styles, and then click New Cell 
Style.
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The Style dialog box opens.

	 2.	 In the Style name field, type Crosstab Column Heading.

	 3.	 Click the Format button.

The Format Cells dialog box opens.

	 4.	 Click the Alignment tab.



	 5.	 In the Horizontal list, click Center.

Center appears in the Horizontal field.

	 6.	 Click the Font tab.

	 7.	 In the Font style list, click Italic.

The text in the Preview pane appears in italicized text.

	 8.	 Click the Number tab.

The Number tab of the Format Cells dialog box is displayed.

	 9.	 In the Category list, click Time.

The available time formats appear.

	 10.	 In the Type pane, click 1:30 PM.

	 11.	 Click OK to accept the default time format.

The Format Cells dialog box closes, and your new style’s definition appears in the 
Style dialog box.

	 12.	 Click OK.

The Style dialog box closes.

	 13.	 Select cells C4:N4.
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	 14.	 On the Home tab, in the Styles group, click Cell Styles.

Your new style appears at the top of the gallery, in the Custom group.

	 15.	 Click the Crosstab Column Heading style.

Excel 2007 applies your new style to the selected cells.

CLOSE  the HourlyExceptions workbook.

Applying Workbook Themes and Table Styles
The 2007 Microsoft Office system includes powerful new design tools that enable  
you to create attractive, professional documents quickly. The Excel 2007 product  
team implemented the new design capabilities by defining workbook themes and 
table styles. A theme is a way to specify the fonts, colors, and graphic effects that 
appear in a workbook. Excel 2007 comes with many themes installed.



To apply an existing workbook theme, display the Page Layout tab. Then, in the Themes 
group, click Themes, and click the theme you want to apply to your workbook. By default, 
Excel 2007 applies the Office theme to your workbooks. 

The theme colors appear in the top segment of the color palette—the standard colors 
and the More Colors link, which displays the Colors dialog box, appear at the bottom of 
the palette. If you format workbook elements using colors from the theme colors portion 
of the color palette, applying a different theme changes that object’s colors.
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You can change a theme’s colors, fonts, and graphic effects by displaying the Page 
Layout tab, and in the Themes group, selecting new values from the Colors, Fonts, and 
Effects lists. To save your changes as a new theme, display the Page Layout tab, and in 
the Themes group, click Themes, and then click Save Current Theme. Use the controls in 
the dialog box that opens to record your theme for later use. Later, when you click the 
Themes button, your custom theme will appear at the top of the gallery.

Tip When you save a theme, you save it as an Office Theme file. You can apply the theme 
to Microsoft Office Word 2007 and Microsoft Office PowerPoint 2007 files as well.

Just as you can define and apply themes to entire workbooks, you can apply and define 
table styles. You select a table’s initial style when you create it; to create a new style, display 
the Home tab, and in the Styles group, click Format As Table. In the Format As Table gallery, 
click New Table Style to display the New Table Quick Style dialog box.

Type a name for the new style, select the first table element you want to format, and  
then click Format to display the Format Cells dialog box. Define the element’s formatting, 
and then click OK. When the New Table Quick Style dialog box reopens, its Preview pane 
displays the overall table style and the Element Formatting section displays the selected 
element’s appearance. Also, in the Table Element list, Excel 2007 displays the element’s 
name in bold to indicate it has been changed. To make the new style the default for new 
tables created in the current workbook, select the Set As Default Table Quick Style For 
This Document check box. When you click OK, Excel 2007 saves the new table style.

See Also  For more information about creating Excel tables, see “Defining a Table” in Chapter 3, 
“Working with Data and Data Tables.”



In this exercise, you will create a new workbook theme, change a workbook’s theme, 
create a new table style, and apply the new style to a table.

USE  the HourlyTracking workbook. This practice file is located in the Documents\
Microsoft Press\Excel2007SBS\Appearance folder.
OPEN  the HourlyTracking workbook.

	 1.	 If necessary, click any cell in the table.

	 2.	 On the Home tab, in the Styles group, click Format as Table, and then click the 
style at the upper-left corner of the Table Styles gallery.

Excel 2007 applies the style to the table.

	 3.	 On the Home tab, in the Styles group, click Format as Table, and then click New 
Table Style.

The New Table Quick Style dialog box opens.

	 4.	 In the Name field, type Exception Default.

	 5.	 In the Table Element list, click Header Row.

	 6.	 Click Format.

The Format Cells dialog box opens.

	 7.	 Click the Fill tab.

The Fill tab appears.
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	 8.	 In the first row of color squares, just below the No Color button, click the third 
square from the left.

The new background color appears in the Sample pane of the dialog box.

	 9.	 Click OK.

The Format Cells dialog box closes. When the New Table Quick Style dialog box 
reopens, the Header Row table element appears in bold, and the Preview pane’s 
header row is shaded.

	 10.	 In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

	 11.	 Click the No Color button, and click the third square from the left again.

The new background color appears in the Sample pane of the dialog box.

	 12.	 Click OK.

The Format Cells dialog box closes. When the New Table Quick Style dialog box   
reopens, the Second Row Stripe table element appears in bold, and every second 
row is shaded in the Preview pane.

	

	 13.	 Click OK.

The New Table Quick Style dialog box closes.

	 14.	 On the Home tab, in the Styles group, click Format as Table. In the gallery that 
appears, in the Custom section, click the new format.

Excel 2007 applies the new format.



	 15.	 On the Page Layout tab, in the Themes group, click the Theme Fonts arrow, and 
then in the list, click Verdana.

Excel 2007 changes the theme’s font to Verdana.

	 16.	 In the Themes group, click the Themes button, and then click Save Current Theme.

The Save Current Theme dialog box opens.

	 17.	 In the File name field, type Verdana Office, and then click Save.

Excel 2007 saves your theme.

	 18.	 In the Themes group, click the Themes button, and then click Origin.

Excel 2007 applies the new theme to your workbook.

CLOSE  the HourlyTracking workbook.

Theme Fonts
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Making Numbers Easier to Read
Changing the format of the cells in your worksheet can make your data much easier to 
read, both by setting data labels apart from the actual data and by adding borders to 
define the boundaries between labels and data even more clearly. Of course, using for-
matting options to change the font and appearance of a cell’s contents doesn’t help with 
idiosyncratic data types such as dates, phone numbers, or currency.

For example, consider U.S. phone numbers. These numbers are 10 digits long and have 
a 3-digit area code, a 3-digit exchange, and a 4-digit line number written in the form 
(###) ###-####. Although it’s certainly possible to type a phone number with the ex-
pected formatting in a cell, it’s much simpler to type a sequence of 10 digits and have 
Excel 2007 change the data’s appearance.

You can tell Excel 2007 to expect a phone number in a cell by opening the Format 
Cells dialog box to the Number tab and displaying the formats available for the 
Special category.

Clicking Phone Number in the Type list tells Excel 2007 to format 10-digit numbers in  
the standard phone number format. As you can see by comparing the contents of the 
active cell and the contents of the formula box in the next graphic, the underlying data 
isn’t changed, just its appearance in the cell.



Troubleshooting  If you type a 9-digit number in a field that expects a phone number, 
you won’t see an error message; instead, you’ll see a 2-digit area code. For example, the 
number 425555012 would be displayed as (42) 555-5012. An 11-digit number would be 
displayed with a 4-digit area code.

Just as you can instruct Excel 2007 to expect a phone number in a cell, you can also 
have it expect a date or a currency amount. You can make those changes from the 
Format Cells dialog box by choosing either the Date category or the Currency category. 
The Date category enables you to pick the format for the date (and determine whether 
the date’s appearance changes due to the Locale setting of the operating system on the 
computer viewing the workbook). In a similar vein, selecting the Currency category dis-
plays controls to set the number of places after the decimal point, the currency symbol 
to use, and the way in which Excel 2007 should display negative numbers.

Tip  The new Excel 2007 user interface enables you to set the most common format 
changes by using the controls in the Home tab’s Number group.

You can also create a custom numeric format to add a word or phrase to a number in a 
cell. For example, you can add the phrase per month to a cell with a formula that calculates 
average monthly sales for a year to ensure that you and your colleagues will recognize the 
figure as a monthly average. To create a custom number format, click the Home tab, and 
then click the Number dialog box launcher to display the Format Cells dialog box. Then, if 
necessary, click the Number tab.

In the Category list, click Custom to display the available custom number formats in the 
Type list. You can then click the base format you want and modify it in the Type box. For 
example, clicking the 0.00 format causes Excel 2007 to format any number in a cell with 
two digits to the right of the decimal point.

Tip  The zeros in the format indicate that the position in the format can accept any number 
as a valid value.
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To customize the format, click in the Type box and add any symbols or text you want to 
the format. For example, typing a dollar ($) sign to the left of the existing format and 
then typing “per month” to the right of the existing format causes the number 1500 to 
be displayed as $1500.00 per month.

Important  You need to enclose any text in quotes so that Excel 2007 recognizes the text 
as a string to be displayed in the cell.

In this exercise, you will assign date, phone number, and currency formats to ranges of 
cells. After assigning the formats, you will test them by entering customer data.

USE  the ExecutiveSearch workbook. This practice file is located in the Documents\
Microsoft Press\Excel2007SBS\Appearance folder.

OPEN  the ExecutiveSearch workbook.

	 1.	 Click cell A3.

	 2.	 On the Home tab, click the Font dialog box launcher.

The Format Cells dialog box opens.

	 3.	 If necessary, click the Number tab.

	 4.	 In the Category list, click Date.

The Type list appears with a list of date formats.

Dialog Box 
Launcher



	 5.	 In the Type list, click 3/14/01.

Important  Be sure to click the format without the asterisk (*) in front of the 
sample date.

	 6.	 Click OK to assign the chosen format to the cell.

	 7.	 Click cell G3.

	 8.	 On the Home tab, click the Font dialog box launcher.

	 9.	 If necessary, click the Number tab in the Format Cells dialog box.

	 10.	 In the Category list, click Special.

The Type list appears with a list of special formats.

	 11.	 In the Type list, click Phone Number, and then click OK.

The contents of the cell change to (425) 555-0102, matching the format you chose 
earlier, and the Format Cells dialog box closes.

	 12.	 Click cell H3.

	 13.	 Click the Font dialog box launcher.

	 14.	 If necessary, click the Number tab in the Format Cells dialog box.

	 15.	 In the Category list, click Custom.

The contents of the Type list are updated to reflect your choice.

	 Making Numbers Easier to Read    105



106    Chapter 5  Changing Workbook Appearance

	 16.	 In the Type list, click the #,##0 item.

#,##0 appears in the Type box.

	 17.	 In the Type box, click to the left of the existing format, and type $. Then click to the 
right of the format, and type “before bonuses”.

	 18.	 Click OK to close the dialog box.

CLOSE  the ExecutiveSearch workbook.

Changing the Appearance of Data Based on 
Its Value

Recording package volumes, vehicle miles, and other business data in a worksheet 
enables you to make important decisions about your operations. And as you saw earlier 
in this chapter, you can change the appearance of data labels and the worksheet itself to 
make interpreting your data easier.

Another way you can make your data easier to interpret is to have Excel 2007 change 
the appearance of your data based on its value. These formats are called conditional 
formats because the data must meet certain conditions to have a format applied to it. 



For instance, if chief operating officer Jenny Lysaker wanted to highlight any Thursdays 
with higher-than-average weekday package volumes, she could define a conditional 
format that tests the value in the cell recording total sales, and that will change the 
format of the cell’s contents when the condition is met.

In previous versions of Excel, you could have a maximum of three conditional formats. 
There’s no such limit in Excel 2007; you may have as many conditional formats as you 
like. The other major limitation of conditional formats in Excel 2003 and earlier versions 
was that Excel stopped evaluating conditional formats as soon as it found one that ap-
plied to a cell. In other words, you couldn’t have multiple conditions be true for the same 
cell! In Excel 2007, you can control whether Excel 2007 stops or continues after it discov-
ers that a specific condition applies to a cell.

To create a conditional format, you select the cells to which you want to apply the 
format, display the Home tab, and then in the Styles group, click Conditional Formatting 
to display a menu of possible conditional formats. Excel 2007 enables you to create all 
the conditional formats available in previous versions of the program and offers many 
more conditional formats than were previously available. Prior to Excel 2007, you could 
create conditional formats to highlight cells that contained values meeting a certain con-
dition. For example, you could highlight all cells that contain a value over 100, contain 
a date before 1/28/2007, or contain an order amount between $100 and $500. In Excel 
2007, you can define conditional formats that change how the program displays data in 
cells that contain values above or below the average values of the related cells, that con-
tain values near the top or bottom of the value range, or that contain values duplicated 
elsewhere in the selected range.

When you select which kind of condition to create, Excel 2007 displays a dialog box that 
contains fields and controls you can use to define your rule. To display all your rules, display 
the Home tab, and then in the Styles group, click Conditional Formatting. From the menu 
that appears, click Manage Rules to display the Conditional Formatting Rules Manager.
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The Conditional Formatting Rules Manager, which is new in Excel 2007, enables you to 
control your conditional formats in the following ways:

	 l	 Create a new rule by clicking the New Rule button.

	 l	 Change a rule by clicking the rule and then clicking the Edit Rule button.

	 l	 Remove a rule by clicking the rule and then clicking the Delete Rule button.

	 l	 Move a rule up or down in the order by clicking the Move Up or Move Down 
button.

	 l	 Control whether Excel 2007 continues evaluating conditional formats after it finds a 
rule to apply by selecting or clearing a rule’s Stop If True check box.

	 l	 Save any new rules and close the Conditional Formatting Rules Manager by 
clicking OK.

	 l	 Save any new rules without closing the Conditional Formatting Rules Manager by 
clicking Apply.

	 l	 Discard any unsaved changes by clicking Cancel.

Tip  Clicking the New Rule button in the Conditional Formatting Rules Manager opens the 
New Formatting Rule dialog box. The commands in the New Formatting Rule dialog box 
duplicate the options displayed when you click the Conditional Formatting button in the 
Styles group on the Home tab.

After you create a rule, you can change the format applied if the rule is true by clicking 
the rule and then clicking the Edit Rule button to display the Edit Formatting Rule dialog 
box. In that dialog box, click the Format button to display the Format Cells dialog box. 
After you define your format, click OK.



Important  Excel 2007 doesn’t check to make sure that your conditions are logically 
consistent, so you need to be sure that you enter your conditions correctly.

Excel 2007 also enables you to create three new types of conditional formats: data bars, 
color scales, and icon sets. Data bars summarize the relative magnitude of values in a cell 
range by extending a band of color across the cell.

Color scales compare the relative magnitude of values in a cell range by applying colors 
from a two-color or three-color set to your cells. The intensity of a cell’s color reflects the 
value’s tendency toward the top or bottom of the values in the range.

Icon sets are collections of three, four, or five images that Excel 2007 displays when 
certain rules are met. 

When you click a color scale or icon set in the Conditional Formatting Rule Manager and 
then click the Edit Rule button, you can control when Excel 2007 applies a color or icon 
to your data.
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Important  Be sure to not include cells that contain summary formulas in your conditionally 
formatted ranges. The values, which could be much higher or lower than your regular cell 
data, could throw off your formatting comparisons.

In this exercise, you will create a series of conditional formats to change the appearance 
of data in worksheet cells displaying the package volume and delivery exception rates of 
a regional distribution center.

USE  the Dashboard workbook. This practice file is located in the Documents\Microsoft 
Press\Excel2007SBS\Appearance folder.

OPEN  the Dashboard workbook.

	 1.	 Select cells C4:C12.

	 2.	 On the Home tab, in the Styles group, click Conditional Formatting. On the 
menu that appears, point to Color Scales, and then in the top row of the palette 
that appears, click the second pattern from the left.

Excel 2007 formats the selected range.



	 3.	 Select cells F4:F12.

	 4.	 On the Home tab, in the Styles group, click Conditional Formatting. From the 
menu that appears, point to Data Bars, and then click the light blue data bar 
format.

Excel 2007 formats the selected range.

	 5.	 Select cells I4:I12.

	 6.	 On the Home tab, in the Styles group, click Conditional Formatting. On the menu 
that appears, point to Icon Sets, and then in the left-hand column of the list of 
formats that appears, click the three traffic lights.

Excel 2007 formats the selected cells.

	 7.	With the range I4:I12 still selected, on the Home tab, in the Styles group, click 
Conditional Formatting, and then click Manage Rules.

The Conditional Formatting Rules Manager opens.

	 8.	 Click the icon set rule, and then click Edit Rule.
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The Edit Formatting Rule dialog box opens.

	 9.	 Select the Reverse Icon Order check box.

Excel 2007 reconfigures the rules so the red light icon is at the top and the green 
light icon is at the bottom.

	 10.	 In the red light icon’s row, in the Type list, click Percent.

	 11.	 In the red light icon’s Value field, type 80.

	 12.	 In the yellow light icon’s row, in the Type list, click Percent.

	 13.	 In the yellow light icon Value field, type 67.

	 14.	 Click OK twice to clear the Edit Formatting Rule dialog box and the Conditional 
Formatting Rules Manager.

Excel 2007 formats the selected cell range.

	 15.	 Click cell C15.

	 16.	 On the Home tab, in the Styles group, click Conditional Formatting. On the menu 
that appears, point to Highlight Cells Rules, and then click Less Than.

The Less Than dialog box opens.

	 17.	 In the left field, type 96%.

	 18.	 In the With list, click Red text.

	 19.	 Click OK.



The Less Than dialog box closes, and Excel 2007 displays the text in cell C15 in red.

CLOSE  the Dashboard workbook.

Adding Images to Worksheets
Establishing a strong corporate identity helps customers remember your organization 
and the products and services you offer. Setting aside the obvious need for sound 
management, two important physical attributes of a strong retail business are a well-
conceived shop space and an eye-catching, easy-to-remember logo. After you or 
your graphic artist has created a logo, you should add the logo to all your documents, 
especially any that might be seen by your customers. Not only does the logo mark 
the documents as coming from your company but it also serves as an advertisement, 
encouraging anyone who sees your worksheets to call or visit your company.

One way to add a picture to a worksheet is to display the Insert tab, and then in the 
Illustrations group, click Picture. Clicking Picture displays the Insert Picture dialog box, 
which enables you to locate the picture you want to add from your hard disk. When you 
insert a picture, the Picture Tools Format contextual tab appears on the Ribbon. You can 
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use the tools on the Format contextual tab to change the picture’s contrast, brightness, 
and so on. The controls in the Picture Styles group enable you to place a border around 
the picture, change the picture’s shape, or change a picture’s effects (such as shadow, 
reflection, or rotation in three dimensions). Other tools, found in the Arrange and Size 
groups, enable you to rotate, reposition, and resize the picture. 

You can also resize a picture by clicking it and then dragging one of the handles that 
appear on the graphic. If you accidentally resize a graphic by dragging a handle, just 
click the Undo button to remove your change. If you want to generate a repeating  
image in the background of a worksheet, forming a tiled pattern behind your work-
sheet’s data, you can display the Page Layout tab, and then in the Page Setup group, 
click Background. In the Sheet Background dialog box, click the image that you want to 
serve as the background pattern for your worksheet, and click OK.

Tip  To remove a background image from a worksheet, display the Page Layout tab, and 
then in the Page Setup group, click Delete Background.

To achieve a watermark-type effect with words displayed behind the worksheet data, 
save the watermark information as an image, and then use the image as the sheet back-
ground; or insert the image in the header or footer, and then resize or scale it to position 
the watermark information where you want it.



In this exercise, you will add an image to an existing worksheet, change the graphic’s 
location on the worksheet, reduce the size of the graphic, change the image’s brightness 
and contrast, rotate and crop the image, delete the image, and then set the image as a 
repeating background for the worksheet.

USE  the CallCenter workbook and the callcenter and acbluprt images. These practice files 
are located in the Documents\Microsoft Press\Excel2007SBS\Appearance folder.

OPEN  the CallCenter workbook.

	 1.	 On the Insert tab, in the Illustrations group, click Picture.

The Insert Picture dialog box opens.

	 2.	 Browse to the Documents\Microsoft Press\Excel2007SBS\Appearance folder, and 
then double-click callcenter.jpg.

The image appears on your worksheet.

	 3.	 Move the image to the upper-left corner of the worksheet, grab the handle at the 
lower-right corner of the image, and drag it up and to the left until it no longer 
obscures the Call Volume label.
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	 4.	 On the Page Layout tab, in the Page Setup group, click Background.

The Sheet Background dialog box opens.

	 5.	 Browse to the Documents\Microsoft Press\Excel2007SBS\Appearance folder, and 
then double-click acbluprt.jpg.

Excel 2007 repeats the image to form a background pattern.

	 6.	 On the Page Layout tab, in the Page Setup group, click Delete Background.

Excel 2007 removes the background image.

CLOSE  the CallCenter workbook. If you are not continuing directly to the next chapter,  
exit Excel.



Key Points
	 l	 If you don’t like the default font in which Excel 2007 displays your data, you can 

change it.

	 l	 You can use cell formatting, including borders, alignment, and fill colors, to 
emphasize certain cells in your worksheets. This emphasis is particularly useful for 
making column and row labels stand out from the data.

	 l	 Excel 2007 comes with a number of existing styles that enable you to change the 
appearance of individual cells. You can also create new styles to make formatting 
your workbooks easier.

	 l	 If you want to apply the formatting from one cell to another cell, use the Format 
Painter to copy the format quickly.

	 l	 There are quite a few built-in document themes and table formats you can 
apply to groups of cells. If you see one you like, use it and save yourself lots of 
formatting time.

	 l	 Conditional formats enable you to set rules so that Excel 2007 changes the appear-
ance of a cell’s contents based on its value.

	 l	 Adding images can make your worksheets more visually appealing and make your 
data easier to understand.
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	10	 Creating Dynamic
		  Lists by Using  
		  PivotTables

In this chapter, you will learn to:
	 4	 Analyze data dynamically by Using PivotTables.
	 4	 Filter, show, and hide PivotTable data.
	 4	 Edit PivotTables.
	 4	 Format PivotTables.
	 4	 Create PivotTables from external data.

When you create Microsoft Office Excel 2007 worksheets, you must consider how  
you want the data to appear when you show it to your colleagues. You can change  
the formatting of your data to emphasize the contents of specific cells, sort and filter 
your worksheets based on the contents of specific columns, or hide rows containing 
data that isn’t relevant to the point you’re trying to make.

One limitation of the standard Excel worksheet is that you can’t change how the data is 
organized on the page. For example, in a worksheet in which each column represents an 
hour in the day, each row represents a day in a month, and the body of the worksheet 
contains the total sales for every hourly period of the month, you can’t easily change 
the worksheet so that it displays only sales on Tuesdays during the afternoon.

An Excel 2007 tool enables you to create worksheets that can be sorted, filtered, and 
rearranged dynamically to emphasize different aspects of your data. That tool is the 
PivotTable.

In this chapter, you’ll learn how to create and edit PivotTables from an existing worksheet 
and how to create a PivotTable with data imported from a text file.

See Also  Do you need only a quick refresher on the topics in this chapter? See the Quick 
Reference section at the beginning of this book.
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Important  Before you can use the practice files in this chapter, you need to install them 
from the book’s companion CD to their default location. See “Using the Companion CD” at 
the beginning of this book for more information.

Analyzing Data Dynamically by Using PivotTables
Excel 2007 worksheets enable you to gather and present important data, but the 
standard worksheet can’t be changed from its original configuration easily. As an 
example, consider the worksheet in the following graphic.

This worksheet records monthly package volumes for each of nine distribution centers in 
the United States. The data in the worksheet is organized so that each row represents a 
distribution center, whereas the columns in the body of the worksheet represent a month 
of the year. When presented in this arrangement, the monthly totals for all centers and 
the yearly total for each distribution center are given equal billing: neither set of totals 
stands out.
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Such a neutral presentation of your data is versatile, but it has limitations. First, although 
you can use sorting and filtering to restrict the rows or columns shown, it’s difficult to 
change the worksheet’s organization. For example, in a standard worksheet you can’t 
reorganize the contents of your worksheet so that the hours are assigned to the rows 
and the distribution centers are assigned to the columns.

The Excel 2007 tool to reorganize and redisplay your data dynamically is the PivotTable. 
You can create a PivotTable, or dynamic worksheet, that enables you to reorganize and 
filter your data on the fly. For instance, you can create a PivotTable with the same layout 
as the worksheet shown previously, which emphasizes totals by month, and then change 
the PivotTable layout to have the rows represent the months of the year and the col-
umns represent a distribution center. The new layout emphasizes the totals by regional 
distribution center, as shown in the following graphic.

To create a PivotTable, you must have your data collected in a list. The new Excel 2007 
data tables mesh perfectly with PivotTable dynamic views; not only do the data tables 
have a well-defined column and row structure but the ability to refer to a data table by 
its name also greatly simplifies PivotTable creation and management.

Analyzing Data Dynamically by Using PivotTables
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The following graphic shows the first few lines of the data table used to create the 
PivotTable just shown.

Notice that each line of the table contains a value representing the Distribution Center, 
Date, Month, Week, Weekday, Day, and Volume for every day of the years 2006 and 
2007. Excel 2007 needs that data when it creates the PivotTable so that it can maintain 
relationships among the data. If you want to filter your PivotTable so that it shows all 
package volumes on Thursdays in January, for example, Excel 2007 must be able to 
identify January 11 as a Thursday.

After you create a data table, you can click any cell in that list, display the Insert  
tab and then, in the Tables group, click PivotTable to display the Create PivotTable 
dialog box.
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In this dialog box, you verify the data source for your PivotTable and whether you want 
to create a PivotTable on a new worksheet. After you click OK, Excel 2007 creates a new 
worksheet and displays the PivotTable Field List task pane.

Tip  You should always place your PivotTable on its own worksheet to avoid unwanted edits 
and reduce the number of cells Excel 2007 must track when you rearrange your data. You 
might not notice a difference with a small data set, but it’s noticeable when your table runs 
more than a few hundred rows.

Analyzing Data Dynamically by Using PivotTables
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To assign a field, or column in a data list, to an area of the PivotTable, drag the field head 
from the Choose Fields To Add To Report area at the top of the PivotTable Field List task 
pane to the Drag Fields Between Areas Below area at the bottom of the task pane. For 
example, if you drag the Volume field header to the Values area, the PivotTable displays 
the total of all entries in the Volume column. 

If the PivotTable Field List task pane isn’t visible, click any cell in the PivotTable to display 
it. If you accidentally click the Close button at the upper-right corner of the PivotTable 
Field List task pane, you can redisplay the task pane by clicking any cell in the PivotTable 
to display the PivotTable Tools contextual tabs. On the Options contextual tab, in the 
Show/Hide group, click Field List.

It’s important to note that the order in which you enter the fields in the Row Labels and 
Column Labels areas affects how Excel 2007 organizes the data in your PivotTable. As an 
example, the following graphic shows a PivotTable that groups the PivotTable rows by 
distribution center and then by month.
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And here is the same PivotTable data, but this time it’s organized by month and then by 
distribution center.

Analyzing Data Dynamically by Using PivotTables
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In the preceding examples, all the field headers are in the Row Labels area. If you drag 
the Center header from the Row Labels area to the Column Labels area, the PivotTable 
reorganizes (pivots) its data to form this configuration.

To pivot a PivotTable, you drag a field header to a new position in the PivotTable Field 
List task pane. As you drag the task pane, Excel 2007 displays a blue line in the interior  
of the target area so you know where the field will appear when you release the left 
mouse button. If your data set is large or if you based your PivotTable on a data col-
lection on another computer, it might take some time for Excel 2007 to reorganize the 
PivotTable after a pivot. You can have Excel 2007 delay redrawing the PivotTable by 
selecting the Defer Layout Update button in the lower-left corner of the PivotTable  
Field List task pane. When you’re ready for Excel 2007 to display the reorganized 
PivotTable, click Update.

If you expect your PivotTable source data to change, such as when you link to an external 
database that records shipments or labor hours, ensure that your PivotTable summarizes 
all the available data. To do that, you can refresh the PivotTable connection to its data 
source. If Excel 2007 detects new data in the source table, it updates the PivotTable con-
tents accordingly. To refresh your PivotTable, click any cell in the PivotTable and then, on 
the Options contextual tab, in the Data group, click Refresh.
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In this exercise, you will create a PivotTable using data from a table, add fields to the 
PivotTable, and then pivot the PivotTable.

USE  the Creating workbook. This practice file is located in the Documents\Microsoft Press\
Excel2007SBS\PivotTables folder.

BE SURE TO  start Excel 2007 before beginning this exercise.

OPEN  the Creating workbook.

	 1.	 Click any cell in the data table.

	 2.	 On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box opens.

	 3.	 Verify that the DailyVolumes table name appears in the Table/Range field and that 
the New Worksheet option is selected.

	 4.	 Click OK.

Excel 2007 creates a PivotTable on a new worksheet.

	 5.	 In the PivotTable Field List task pane, drag the Center field header to the Row 
Labels area.

Excel 2007 adds the Center field values to the PivotTable row area.

Analyzing Data Dynamically by Using PivotTables
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	 6.	 In the PivotTable Field List task pane, drag the Year field header to the Column 
Labels area.

Excel 2007 adds the Year field values to the PivotTable column area.

	 7.	 In the PivotTable Field List task pane, drag the Volume field header to the Values 
area.

Excel 2007 fills in the body of the PivotTable with the Volume field values.

	 8.	 In the PivotTable Field List task pane, in the Column Labels area, drag the Year 
field header to the Row Labels area, and drop it beneath the Center field header.

Excel 2007 changes the PivotTable to reflect the new organization.

CLOSE  the Creating workbook.
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Filtering, Showing, and Hiding PivotTable Data
PivotTables often summarize huge data sets in a relatively small worksheet. The more 
details you can capture and write to a table, the more flexibility you have in analyzing 
the data. As an example, consider all the details captured in the following data table.

Each line of the table contains a value representing the Distribution Center, Date, 
Month, Week, Weekday, Day, and Volume for every day of the year. Each column, in 
turn, contains numerous values: there are nine distribution centers, data from two 
years, twelve months in a year, seven weekdays, and as many as five weeks and 31 
days in a month. Just as you can filter the data that appears in a table, you can filter 
the data displayed in a PivotTable by selecting which values you want the PivotTable 
to include. 

See Also  For more information on filtering an Excel 2007 data table, see “Limiting Data That 
Appears on Your Screen” in Chapter 6, “Focusing on Specific Data by Using Filters.”

To filter a PivotTable based on a field’s contents, click the field’s header in the Choose 
Fields To Add To Report area of the PivotTable Field List task pane to display a menu of 
sorting and filtering options.

Filtering, Showing, and Hiding PivotTable Data
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The PivotTable displays data that’s related to the values with a checked box next to them. 
Clicking the Select All check box clears it, which enables you to select the check boxes 
of the values you want to display. Selecting only the Northwest check box, for example, 
leads to the following PivotTable configuration.
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If you’d rather display as much PivotTable data as possible, you can hide the PivotTable 
Field List task pane and filter the PivotTable by using the filter arrows on the Row Labels 
and Column Labels headers within the body of the PivotTable. Clicking either of those 
headers enables you to select a field by which you want to filter; you can then define 
the filter using the same controls you see when you click a field header in the PivotTable 
Field List task pane.

Excel 2007 indicates that a PivotTable has filters applied by placing a filter indicator next 
to the Column Labels or Row Labels header, as appropriate, and the filtered field name 
in the PivotTable Field List task pane.

So far, all the fields by which we’ve filtered the PivotTable have changed the organization 
of the data in the PivotTable. Adding some fields to a PivotTable, however, might create 
unwanted complexity. For example, you might want to filter a PivotTable by weekday, but 
adding the Weekday field to the body of the PivotTable expands the table unnecessarily.

Instead of adding the Weekday field to the Row Labels or Column Labels area, you can 
drag the field to the Report Filter area near the bottom of the PivotTable Field List task 
pane. Doing so leaves the body of the PivotTable in the same position, but adds a new 
area above the PivotTable in its worksheet.

Filtering, Showing, and Hiding PivotTable Data
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Tip  In Excel 2003 and earlier versions, this area was called the Page Field area.

When you click the filter arrow of a field in the Report Filter area, Excel 2007 displays 
a list of the values in the field. In previous versions of Excel 2007, you could select only 
one Report Filter value by which to filter a PivotTable; in Excel 2007, selecting the Select 
Multiple Items check box enables you to filter by more than one value.

Finally, you can filter values in a PivotTable by hiding and collapsing levels of detail  
within the report. To do that, you click the Hide Detail control (which looks like a box 
with a minus sign in it) or the Show Detail control (which looks like a box with a plus sign 
in it) next to a header. For example, you might have your data divided by year; clicking 
the Show Detail control next to the 2006 year header would display that year’s details. 
Conversely, clicking the 2007 year header Hide Detail control would hide the individual 
months’ values and display only the year’s total.
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In this exercise, you will focus the data displayed in a PivotTable by creating a filter, by 
filtering a PivotTable based on the contents of a field in the Report Filters area, and 
by showing and hiding levels of detail within the body of the PivotTable.

USE  the Focusing workbook. This practice file is located in the Documents\Microsoft Press\
Excel2007SBS\PivotTables folder.

OPEN  the Focusing workbook.

	 1.	 On the PivotTable worksheet, click any cell in the PivotTable.

	 2.	 In the PivotTable Field List task pane’s Choose fields to add to report section, 
click the Center field header, click the Center field filter arrow, and then clear the 
(Select All) check box.

Excel 2007 clears all the check boxes in the filter menu.

	 3.	 Select the Northwest check box, and then click OK.

Excel 2007 filters the PivotTable.

Filtering, Showing, and Hiding PivotTable Data
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	 4.	 On the Quick Access Toolbar, click the Undo button.

Excel 2007 removes the filter.

	 5.	 In the PivotTable Field List task pane, drag the Weekday field header from the 
Choose fields to add to report section to the Report Filter area in the Drag fields 
between areas below section.

	 6.	 In the PivotTable Field List task pane, click the Close button.

The PivotTable Field List task pane closes.

	 7.	 In the body of the worksheet, click the Weekday filter arrow, and then select the 
Select Multiple Items check box.

Excel 2007 adds check boxes beside the items in the Weekday field filter list.

	 8.	 Clear the All check box.

Excel 2007 clears each check box in the list.

Undo

Close
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	 9.	 Select the Tuesday and Thursday check boxes, and then click OK.

Excel 2007 filters the PivotTable, summarizing only those values from Tuesdays and 
Thursdays.

	 10.	 In cell A5, click the Hide Detail button.

Excel 2007 collapses rows that contain data from the year 2006, leaving only the 
subtotal row that summarizes that year’s data.

CLOSE  the Focusing workbook.

Hide Detail

Filtering, Showing, and Hiding PivotTable Data
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Editing PivotTables
After you create a PivotTable, you can rename it, edit it to control how it summarizes 
your data, and use the PivotTable cell data in a formula. As an example, consider the 
following PivotTable.

Excel 2007 displays the PivotTable name on the Options contextual tab, in the PivotTable 
Options group. The name PivotTable5 doesn’t help you or your colleagues understand 
the data the PivotTable contains, particularly if you use the PivotTable data in a formula 
on another worksheet. To give your PivotTable a more descriptive name, click any cell in 
the PivotTable and then, on the Options contextual tab, in the PivotTable Options group, 
type the new name in the PivotTable Name field.

When you create a PivotTable with at least one field in the Row Labels area and one 
field in the Column Labels area of the PivotTable Field List task pane, Excel 2007 adds a 
grand total row and column to summarize your data. You can control how and where 
these summary rows and columns appear by clicking any PivotTable cell and then, in the 
Design contextual tab, in the Layout group, clicking either the Subtotals or Grand Totals 
button and selecting the desired layout.

After you create a PivotTable, Excel 2007 determines the best way to summarize the data 
in the column you assign to the Values area. For numeric data, for example, Excel 2007 
uses the Sum function. If you want to change a PivotTable summary function, right-click 
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any data cell in the PivotTable values area, point to Summarize Data By, and then click 
the desired operation. If you want to use a function other than those listed, click More 
Options to display the Value Field Settings dialog box. On the Summarize By tab of the 
dialog box, you can choose the summary operation you want to use.

You can also change how the PivotTable displays the data in the Values area. On the 
Show Values As tab of the Value Field Settings dialog box, you can select whether to 
display each cell’s percentage contribution to its column’s total, its row’s total, or its 
contribution to the total of all values displayed in the PivotTable.

You can create a link from a cell in another workbook to a cell in your PivotTable. To create 
a link, you click the cell you want to link to your PivotTable, type an equal sign, and then 
click the cell in the PivotTable with the data you want linked. A GETPIVOTDATA formula 
appears in the formula box of the worksheet with the PivotTable. When you press Enter, 
the contents of the PivotTable cell appear in the linked cell.

Editing PivotTables
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In this exercise, you will rename a PivotTable, specify whether subtotal and grand total 
rows will appear, change the PivotTable summary function, display each cell’s contribution 
to its row’s total, and create a link to a PivotTable cell.

USE  the Editing workbook. This practice file is located in the Documents\Microsoft Press\
Excel2007SBS\PivotTables folder.

OPEN  the Editing workbook.

	 1.	 On the PivotTable worksheet, click any cell in the PivotTable.

	 2.	 On the Options contextual tab, in the PivotTable group, in the PivotTable Name 
field, type VolumeSummary.

Excel 2007 renames the PivotTable.

	 3.	 On the Design contextual tab, in the Layout group, click Subtotals, and then click 
Do Not Show Subtotals.

Excel 2007 removes the subtotal rows from the PivotTable.

	 4.	 On the Design contextual tab, in the Layout group, click Grand Totals, and then 
click On for columns only.

Excel 2007 removes the cells that calculate each row’s grand total.
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	 5.	 On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

	 6.	 Right-click any data cell in the PivotTable, point to Summarize Data By, and then 
click Average.

Excel 2007 changes the Value field summary operation.

	 7.	 On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

	 8.	 Right-click any data cell in the PivotTable, and then click Value Field Settings.

The Value Field Settings dialog box opens.

	 9.	 Click the Show values as tab.

The Show Values As tab appears.

	 10.	 In the Show values as list, click % of row.

	 11.	 Click OK.

Excel 2007 changes how it calculates the values in the PivotTable.

Undo

Editing PivotTables
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	 12.	 On the Quick Access Toolbar, click the Undo button.

Excel 2007 reverses the last change.

	 13.	 On the Design tab, in the Layout group, click Subtotals, and then click Show All 
Subtotals at Bottom of Group.

Excel 2007 displays subtotals in the workbook.

	 14.	 Click the Package Summary sheet tab.

The Package Summary worksheet appears.

	 15.	 In cell C4, type =, but do not press .

	 16.	 Click the PivotTable sheet tab.

The PivotTable worksheet appears.

	 17.	 Click cell K32, and then press .

Excel 2007 creates the formula =GETPIVOTDATA(“Volume”,PivotTable!$A$3,”Year”,
2007) in cell C4.
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CLOSE  the Editing workbook.

Formatting PivotTables
PivotTables are the ideal tools for summarizing and examining large data tables, even 
those containing in excess of 10 or even 100,000 rows. Even though PivotTables often 
end up as compact summaries, you should do everything you can to make your data 
more comprehensible. One way to improve your data’s readability is to apply a number 
format to the PivotTable Values field. To apply a number format to a field, right-click any 
cell in the field, and then click Number Format to display the Format Cells dialog box. 
Select or define the format you want to apply, and then click OK to enact the change.

See Also  For more information on selecting and defining cell formats by using the Format 
Cells dialog box, see “Formatting Cells” in Chapter 5, “Changing Workbook Appearance.”

Analysts often use PivotTables to summarize and examine organizational data with an 
eye to making important decisions about the company. For example, chief operating 
officer Jenny Lysaker might examine monthly package volumes handled by Consolidated 
Messenger and notice that there’s a surge in package volume during the winter months 
in the United States.

Formatting PivotTables
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Excel 2007 extends the capabilities of your PivotTables by enabling you to apply a  
conditional format to the PivotTable cells. What’s more, you can select whether to 
apply the conditional format to every cell in the Values area, to every cell at the same 
level as the selected cell (that is, a regular data cell, a subtotal cell, or a grand total 
cell) or to every cell that contains or draws its values from the selected cell’s field  
(such as the Volume field in the previous example).

To apply a conditional format to a PivotTable field, click a cell in the Values area. On the 
Home tab, in the Styles group, click Conditional Formatting, and then create the desired 
conditional format. After you do, Excel 2007 displays a Formatting Options smart tag, 
which offers three options on how to apply the conditional format:

	 l	 Selected cells, which applies the conditional format to the selected cells only

	 l	 All cells showing Sum of field_name values, which applies the conditional format to 
every cell in the data area, regardless of whether the cell is in the data area, a sub-
total row or column, or a grand total row or column

	 l	 All cells showing Sum of field_name values for fields, which applies the conditional 
format to every cell at the same level (for example, data cell, subtotal, or grand to-
tal) as the selected cells

See Also  For more information on creating conditional formats, see “Changing the 
Appearance of Data Based on Its Value” in Chapter 5.
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In Excel 2003 and earlier versions of the program, you were limited to a small number 
of formatting styles, called autoformats, which you could apply to a PivotTable. In Excel 
2007, you can take full advantage of the Microsoft Office system enhanced formatting 
capabilities to apply existing formats to your PivotTables. Just as you can create data table 
formats, you can also create your own PivotTable formats to match your organization’s 
desired color scheme.

To apply a PivotTable style, click any cell in the PivotTable and then, on the Design 
contextual tab, in the PivotTable Styles group, click the gallery item representing the 
style you want to apply. If you want to create your own PivotTable style, click the More 
button in the PivotTable Styles gallery (in the lower-right corner of the gallery), and 
then click New PivotTable Style to display the New PivotTable QuickStyle dialog box.

Type a name for the style in the Name field, click the first table element you want to cus-
tomize, and then click Format. Use the controls in the Format Cells dialog box to change 
the element’s appearance. After you click OK to close the Format Cells dialog box, the 
New PivotTable Quick Style dialog box Preview pane displays the style’s appearance. If 
you want Excel 2007 to use the style by default, select the Set As Default PivotTable Quick 
Style For This Document check box. After you finish creating your formats, click OK to 
close the New PivotTable Quick Style dialog box and save your style.

The Design contextual tab contains many other tools you can use to format your 
PivotTable, but one of the most useful is the Banded Columns check box, which you  
can find in the PivotTable Style Options group. If you select a PivotTable style that offers 
banded rows as an option, selecting the Banded Rows check box turns banding on. If 
you prefer not to have Excel 2007 band the rows in your PivotTable, clearing the check 
box turns banding off.

Formatting PivotTables
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In this exercise, you will apply a number format to a PivotTable values field, apply a 
PivotTable style, create your own PivotTable style, give your PivotTable banded rows, 
and apply a conditional format to a PivotTable.

USE  the Formatting workbook. This practice file is located in the Documents\Microsoft 
Press\Excel2007SBS\PivotTables folder.

OPEN  the Formatting workbook.

	 1.	 On the PivotTable worksheet, right-click any data cell, and then click Number 
Format.

The Format Cells dialog box opens.

	 2.	 In the Category list, click Number.

The Number tab page opens.

	 3.	 In the Decimal places field, type 0.

	 4.	 Select the Use 1000 Separator (,) check box.

	 5.	 Click OK.

Excel 2007 reformats your PivotTable data.
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	 6.	 If necessary, on the Design contextual tab, in the PivotTable Style Options group, 
select the Banded Rows check box.

	 7.	 On the Design contextual tab, in the PivotTable Styles group, click the third style 
from the left (when you point to it, Excel 2007 displays a ScreenTip that reads Pivot 
Style Light 2).

Excel 2007 applies the PivotTable style.

Formatting PivotTables
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	 8.	 In the lower-right corner of the PivotTable Styles gallery, click the More button.

The gallery expands.

	 9.	 Click New PivotTable Style.

The New PivotTable Quick Style dialog box opens.

	 10.	 In the Name field, type Custom Style 1.

	 11.	 In the Table Element list, click Header Row, and then click Format.

The Format Cells dialog box opens.

	 12.	 On the Font tab, in the Color list, click the white square.

	 13.	 On the Border tab, in the Presets area, click Outline.

	 14.	 On the Fill tab, in the Background Color area, click the purple square at the lower-
right corner of the color palette.

	 15.	 Click OK.

The Format Cells dialog box closes, and the style change appears in the Preview 
pane of the New PivotTable Quick Style dialog box.

	 16.	 In the Table Element list, click Second Row Stripe, and then click Format.

The Format Cells dialog box opens.

	 17.	 On the Fill tab, in the middle part of the Background Color section, click the eighth 
square in the second row (it’s a light, dusty purple).

	 18.	 Click OK twice.

The Format Cells dialog box closes, and your format appears in the PivotTable 
Styles gallery.

More
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	 19.	 Click the new style.

Excel 2007 formats your PivotTable using your custom PivotTable style.

	 20.	 On the Design contextual tab, in the PivotTable Style Options group, clear the 
Banded Rows check box.

Excel 2007 removes the banding from your PivotTable.

	 21.	 Select the cell ranges K6:K17 and K20:K31.

Formatting PivotTables
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	 22.	 On the Home tab, in the Styles group, click Conditional Formatting, point to Color 
Scales, and in the top row, click the three-color scale with red at the top.

Excel 2007 applies the conditional format to the selected cells.

CLOSE  the Formatting workbook.

Creating PivotTables from External Data
Although most of the time you will create PivotTables from data stored in Excel 2007 
worksheets, you can also bring data from outside sources into Excel 2007. For example, 
you might need to work with data created in another spreadsheet program with a file 
format that Excel 2007 can’t read directly. Fortunately, you can export the data from the 
original program into a text file, which Excel 2007 then translates into a worksheet.

Spreadsheet programs store data in cells, so the goal of representing spreadsheet data 
in a text file is to indicate where the contents of one cell end and those of the next cell 
begin. The character that marks the end of a cell is a delimiter, in that it marks the end 
(or “limit”) of a cell. The most common cell delimiter is the comma, so the delimited 
sequence 15, 18, 24, 28 represents data in four cells. The problem with using commas 
to delimit financial data is that larger values—such as 52,802—can be written by using 
commas as thousands markers. To avoid confusion when importing a text file, the most 
commonly used delimiter for financial data is the Tab character.

To import data from a text file, on the Data tab, in the Get External Data group, click 
From Text to display the Import Text File dialog box.
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From within the Import Text File dialog box, you browse to the directory that contains the 
text file you want to import. Double-clicking the file launches the Text Import Wizard.

The first page of the Text Import Wizard enables you to indicate whether the data file 
you are importing is Delimited or Fixed Width; Fixed Width means that each cell value 
will fall within a specific position in the file. Clicking Next to accept the default choice, 
Delimited (which Excel 2007 assigns after examining the data source you selected), 
advances you to the next wizard screen.

Creating PivotTables from External Data
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This screen enables you to choose the delimiter for the file (in this case, Excel 2007 
detected tabs in the file and selected the Tab check box for you) and gives you a preview 
of what the text file will look like when imported. Clicking Next advances you to the final 
wizard screen.

This screen enables you to change the data type and formatting of the columns in your 
data list. Because you’ll assign number styles and PivotTable Quick Styles after you cre-
ate the PivotTable, you can click Finish to import the data into your worksheet. After the 
data is in Excel 2007, you can work with it normally.
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In this exercise, you will import a data list into Excel 2007 from a text file and then create 
a PivotTable based on that list.

USE  the Creating text file.

	 1.	 On the Data tab, in the Get External Data group, click From Text.

The Import Text File dialog box opens.

	 2.	 Navigate to the Documents\Microsoft Press\Excel2007SBS\PivotTables folder, and 
then double-click Creating.txt.

The Text Import Wizard starts.

	 3.	 Verify that the Delimited option is selected, and then click Next.

The next Text Import Wizard page appears.

	 4.	 In the Delimiters section, verify that the Tab check box is selected and also verify 
that the data displayed in the Data preview area reflects the structure you expect.

	 5.	 Click Finish.

The Import Data dialog box opens.

	 6.	 Verify that the Existing worksheet option is selected, and then click OK.

Excel 2007 imports the data into your workbook.

	 7.	 On the Insert tab, in the Tables group, click PivotTable.

The Create PivotTable dialog box opens.

	 8.	 Verify that the Select a table or range option is selected, that the range 
Sheet1$A$1:$H$6571 appears in the Table/Range field, and that the New 
Worksheet option is selected.

	 9.	 Click OK.

Excel 2007 creates a new worksheet.

	 10.	 In the PivotTable Field List task pane, drag the Volume field header to the Values 
area.

Creating PivotTables from External Data
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	 11.	 Drag the Weekday field header to the Column Labels area.

	 12.	 Drag the Center field header to the Row Labels data area.

	 13.	 On the Quick Access Toolbar, click the Save button.

The Save As dialog box opens.

	 14.	 Browse to the Documents\Microsoft Press\Excel2007SBS\PivotTables folder.

	 15.	 In the File name field, type Imported Data.

	 16.	 Click OK.

Excel 2007 saves your file.

CLOSE  the Imported Data workbook. If you are not continuing directly to the next chapter, 
exit Excel.

Save
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Key Points
	 l	 A PivotTable is a versatile tool you can use to rearrange your data dynamically, 

enabling you to emphasize different aspects of your data without creating new 
worksheets.

	 l	 PivotTable data must be formatted as a list. Using a data table as the PivotTable 
data source enables you to streamline the creation process by referring to the table 
name instead of being required to select the entire range that contains the data 
you want to summarize.

	 l	 Excel 2007 comes with many attractive styles for PivotTables; you’ll probably find 
one you like.

	 l	 The PivotTable Field List task pane enables you to create your PivotTable by using a 
straightforward, compact tool.

	 l	 Just as you can limit the data shown in a static worksheet, you can use filters to 
limit the data shown in a PivotTable.

	 l	 If you have data in a compatible format, such as a text file, you can import that 
data into Excel 2007 and create a PivotTable from it.

Key Points
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A
absolute references, 68–69
Accept Or Reject Changes dialog box, 336
access controls, 332, 339.  security
accuracy, 237.  validation rules
active cells, 41, 75, 120
Add Scenario dialog box, 179
add-ins, 2, 190, 195, 350
Advanced Filter dialog box, 128
advertising, 113
Allow Users To Edit Ranges dialog box, 340–341
alternative data sets, 178–185
Analysis ToolPak, 195
appearance, workbook.  formatting; layout

about, 84–86
cell formatting, 86–91
of charts, 10, 235, 242–247
color coding, 106–113
corporate images, 113–116
quick reference, xxxvi–xl
readability, 102–106, 221
spacing, 21
styles, 92–96
table styles, 98–101
themes, 96–98

arguments, 65, 152
arrangement, multiple windows, 27
Assign Macro dialog box, 303
assistance with Excel, xvii
attribution of changes, 335
audits, worksheet, 76
Auto Header & Footer, 267
Auto_Open, 306
AutoCalculate, xli, 126
AutoComplete, xxx, xxxiv, 37–38, 66
AutoCorrect Options, 54
AutoFill, xxx, 36–37, 38–39
AutoFilter, 120
autoformats, 223
AutoHeader, lvi
automation, 3.  macros
AutoRepublish, 348
AVERAGE (function), 65, 126, 127

Index

AVERAGEIF/AVERAGEIFS (function), 8, 71–73
averages, 54–55
axis changes, 237
Axis Labels dialog box, 238

B
background color, xxxvi
background images, 114
backups, 182
banding (formatting), 223
blank pages, 283
borders, cell, xxxvi, 87–88
boundaries between sections, 271
Browse dialog box, 313
browsers, 347
business certification program (Microsoft), xix–xxiii
buttons, adding, 28

C
calculations on data

about, 58–60
corrections, 75–82
data group names, 60–63
formulas, 64–70
quick reference, xxxiii–xxxvi
for specific conditions, 71–74

Calibri (font), 88
case matching (in searches), 45
case sensitive sorting, 140
caveats.  quirks
Cell Styles gallery, 92–93
cells

active, 41, 75, 120
appearance of, xxxvi–xxxxi
with comments, lix, 333
copying and pasting, xxx
delimiters, 228
editing, xxxi
formatting, 5–6, 86–91
inserting/deleting, 22
linking, xlvi, 320
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cells (continued)
location changes, 23
locked, 340
precedents, 76
quick reference, xxix–xxx, xl–xlii
ranges, 41, 60–63, 66
security, lxiii
value monitoring, 78

centering print areas, lvii, 282
certificates, digital, 344–345
certification, professional, xxi–xxv
Change Chart Type dialog box, 252
change history, lxii, 329, 336
change tracking, lxii, 335–338
charts

about, 234–236
appearance of, 10, 242–247
creating, 236–241
in Office documents, lx–lxi, 323–325
PivotCharts, 251–256
printing, lviii, 286–287
quick reference, lii–lv
SmartArt diagrams, 256–263
trends in, 248–250

Choose A SmartArt Graphic dialog box, 256–258
coding sample, 293
col_index_num, 152
collaboration

about, 326–328
change tracking, 335–338
comments, managing, 331–334
data list sharing, 328–331
quick reference, lxi–lxiii
security, 339–344
workbook authentication, 344–346
workbooks as Web documents, 346–350

color
about, 5
background, xxxviii
palettes, 97
scales, xlii, 109
themes, xxxix

color coding, 9, 19, 88, 106–113
columns

alignment, 272
copying and pasting, xxxii
headings, repeated, 283
labeling, 29, 120
limitations on, 3
modifying, 19
quick reference, xxix, xxxi
referencing, xxxvi
rows, transposing to, 43
searching by, 45
selecting, 41
sorting, 140

in table manipulations, 54
top/bottom values, xliii
Total, xxxiv–xxxv

commands, organization of, 2
commas (as delimiters), 228
comments, managing, lxi, 331–334
compatibility packs, 4
conditional formats

color coding, 9, 106–107
limitations on, 3, 107
PivotTables, li, 222
quick reference, xli
rules, xli

Conditional Formatting Rules Manager,  
107–108, 109

conditional formulas, xxxvii, 71–74
Confirm Password dialog box, 339, 341
conflicting changes, 329
Consolidate dialog box, 170–171
consolidation, data, 170–173
convenience, 27, 28. See also Quick Access Toolbar
conventions, xi–xii
copying and pasting

Auto Fill Options, 39
charts, 323–324
columns, 41
eliminating, 36
with formatting, xxxix, 93
formulas, 68, 73
options, 42
quick reference, xxxii
sorting levels, 140
within workbooks, 41–43
worksheets, xxviii, 18

corporate identity, 113
corrections, 48–53, 75–82
COUNT (function), 65, 127
COUNTA (function), 127
COUNTIFS (function), 8, 71–73
Create Charts dialog box, 244
Create Digital Certificate dialog box, 344
Create Names From Selection dialog box, 61
Create PivotTable dialog box, 202–203
currency, xl
customization

charts, 242–247
conditional formats, 106–107
data lists, xlvi
enhancements, 4
filters, xliii, 122
headers, 268
macro access, lix, 301, 302, 303
margins, 271
numeric formats, 103–104
PivotTables, 223
program windows, 26–32

centering print areas
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properties, xxvii, 15–16
Quick Access Toolbar, 28–29
sorting, 140, 141
spelling checker, 48–49
user-defined functions, 7
workbooks, 26–32

cutting and pasting
columns, 41–43
eliminating, 33, 36
shapes, 259

cycle diagrams, 257

D
data

about, 34–36
chart options, 252
collections, 3
color coding, 106–113
correcting/expanding, 48–53
destruction potential, 178, 179
entering/revising, 36–41, 54, 119
from external sources, lii
finding and replacing, 44–48
group names, 60–63
moving, 41–44
from multiple Office applications, 312
quick reference, xxxii–xxxv
series, lii–liii
substitutions, 344
summaries, 8
transposition of, xxxii
trends, 248–250

Data Analysis item, 195
data bars, xli, 109
data combining

about, 156–158
consolidation, 170–173
list templates, 158–164
quick reference, xlvii–xlviii
set groupings, 173–175
sources, linking, 164–169

data filters
about, 118–120
creating, 120–125
list manipulation, 125–130
multiple values, 212
of named ranges, 62
PivotCharts, 251–252
PivotTables, l, 209–215, 251–252
quick reference, xlii–xliv
validation rules, 130–135

data lists. See also PivotTables
evolution of, 53
manipulation, 125–130

organization of, 151–155
PivotTables from, l
printing, 279–286
quick reference, xlv–xlvii, xlvi
sharing, 328–331
templates, 158–164

data organization
about, 136–138
levels, 145–150
limitations, 199, 201
lists, 151–155
in PivotTables, 204–206, 211–212
quick reference, xlv–xlvii
sorting, 138–145

data set analysis
about, 176–178
alternative sets, 178–181
descriptive statistics, 194–196
Goal Seek, 185–188
multiple alternatives, 181–185
quick reference, xlviii–xlix
Solver, 189–194

data tables
linking to, 166
managing, 6–7
names of, 54–55
PivotTable interface, 201–202
quick reference, xxxiv
renaming, xxxv
setting up, 53–56
sharing limitations, 328
styles, xl, 98–99

Data Validation dialog box, 131
defaults

change history, 329
change tracking, 335
charts, 324
margins, 271
page printing order, 275
security, 292
sorting, 139, 140
styles, 98, 223
templates, 159
themes, 97
values, 179
workbooks, 14
worksheet names, 18

Delete dialog box, 23
deletion

cell formatting, 87
comments, lxi
formatting rules, xli
links, lxi
named ranges, xxxvi
rows/columns/cells, xxix, xxx, 22
sorting levels, vl

deletion
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deletion (continued)
styles, xxxix
window watches, xxxviii
worksheets, xxix

delimiters, 228, 229, 230
descriptive statistics, xlix, 194–196
design themes. See themes
destinations, hyperlink, 319
Developer tab, 2
diagrams, lv, 257. See also charts
dialog boxes

Assign Macro, 303
Browse, 313
Confirm Password, 339, 341
Create Digital Certificate, 344
Create Names From Selection, 61
Excel Options, 2, 37, 43, 88, 190, 195, 292, 301–302
Go To Special, 333
Goal Seek Status, 186
Macro, 293, 294, 301, 302
Name Manager, 61, 62
New Name, 61, 62
New Range, 341
New Workbook, 159
Object, 312–313, 316
Open, 347
Print, 281, 286
Protect Sheet, 340
Publish As Web Page, 347
Record Macro, 297
Scenario Summary, 182
Security Options, 291
Select Certificate, 345
Set Title, 348
Share Workbook, 328–329
Sign, 344–345
Solver Parameters, 190

dialog boxes, charts
Axis Labels, 238
Change Chart Type, 252
Create Charts, 244
Create PivotTable, 202–203
Move Chart, 239
New PivotTable QuickStyle, 223
New Table Quick Style, 98

dialog boxes, data functions
Advanced Filter, 128
Consolidate, 170–171
Data Validation, 131
Error Checking, 77
Evaluate Formula, 78
Select Data Source, 237, 238
Sort, 139, 140
Sort Options, 140
Subtotal, 145
Top 10 AutoFilter, 122
Value Field Settings, 217

dialog boxes, editing
Accept Or Reject Changes, 336
Allow Users To Edit Ranges, 340, 341
Delete, 23
Edit Name, 62
Find And Replace, 44–45
Highlight Changes, 335
Move Or Copy, 18
Paste Special, 43
Save As, 15, 339, 346
Save Options, 339
Save Workspace, 173
Select Changes To Accept Or Reject, 335

dialog boxes, formatting
Find Format, 45
Format, 243
Format Cells, 92, 98, 102, 103, 221, 223, 340
Format Shape, 260
Page Setup, 267, 271, 273, 275, 279, 281, 282, 283
Style, 92
Templates, 159

dialog boxes, insertion functions
Add Scenario, 179
Choose A SmartArt Graphic, 256–258
Import Text File, 228–229
Insert, 23, 160
Insert Function, 7
Insert Hyperlink, 318–319, 320

dictionary (spelling checker), 48–49
digital certificates, 344–345
digital signatures, lxiii, 328, 344
displays, worksheet, 19
distribution, electronic, 350
#DIV/0!, 76
Document Inspector, 351
dynamic analysis, 200–208, 235, 251–256
dynamic lists. See PivotTables

E
Edit Name dialog box, 62
electronic distribution, 350
elements, chart, 243
e-mail, 320–321, 329
embedding, lx, 286, 316–317
Encarta encyclopedia, 49
entering data, 36–41
Error Checking dialog box, 77
error messages, 132, 152, 166, 252
errors

in data entry, 119
error codes table, 76
finding, xxxvii–xxxviii
identifying, 75–78
printing options, 279

delimiters
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Evaluate Formula dialog box, 78
Excel 2007 changes, lxiv, 1–11, 266–267. See also 

specific features
Excel 2007 workbook template (.xltm), 159. See also 

templates; workbooks; worksheets
Excel 2007 workbook (.xlsx), 5, 158–159, 165, 291. 

See also workbooks; worksheets
Excel 97–2003 (.xlt), 159
Excel binary workbook (.xlsb), 5
Excel macro-enabled template (.xltxm), 5, 291.  

See also templates
Excel macro-enabled workbook (.xlsm), 5, 291.  

See also workbooks; worksheets
Excel Options dialog box, 2, 37, 43, 88, 190, 195, 

292, 301–302
Excel tables. See data tables
Excel template (.xltx), 5, 158–159, 291. See also 

templates
exercises

charts, 239–241, 245–247, 250, 253–256, 260–263
collaboration, 330–331, 333–334, 336–338, 341–

344, 345–346, 348–350
data calculations, 62–63, 69–70, 73–74, 79–82
data combining, 161–164, 166–169, 174–175
data entry/manipulation, 39–41, 43–44, 46–48, 

51–53, 55–56
data filters, 122–125, 128–130, 132–135
data organization, 141–145, 148–150, 154–155
data set analysis, 180–181, 183–185, 187–188, 

191–194, 195–196
macros, 294–297, 298–301, 304–306, 307–309
Office applications, 314–315, 317–318, 321–323, 

324–325
PivotTables, 207–208, 213–215, 218–221, 224–228, 

231–232
printing, 268–270, 277–278, 280–281, 283–286, 

286–287
workbook appearance, 89–91, 93–96, 99–101, 

104–106, 110–113, 115–116
workbook setup, 16–17, 19–21, 23–25, 29–32

expansion, data/worksheets, 48–53
exponential distribution, 248
Extensible Markup Language (XML), 4–5
extrapolation, 235

F
features, xi–xii
fields (in PivotTables), 204
file properties, xxvii, 4, 15–16
fill handles, xxxii, 36–37
Fill with/without formatting, 39
FillSeries, 37, 38, 39
filtering data. See data filters
financial data delimiters, 228
Find And Replace dialog box, 44–45

Find Format dialog box, 45
finding and replacing options, 44–48
fixed width files, 229
flexibility. See PivotTables
Font Color control, 87
fonts

appearance of, xxxviii, xxxix
applying changes, 89
choices, 88

footers, 266–268
Format Cells dialog box, 92, 98, 102, 103, 221,  

223, 340
Format dialog box, 243
Format Painter, 93
Format Shape dialog box, 260
formatting. See also appearance, workbook; 

conditional formats; layout
cells, 86–91
charts, liii, liv, 242–247
in copying/cutting, 42–43
data tables, 54
diagrams, 258, 260
with fill operations, 39
finding, 45
of inserted rows/columns, 22
options, 5
pitfalls, 306
PivotTables, li, 221–228
predefined, 92
tool display, 88

Formatting Options smart tag, 222
Formula Auditing, 77, 78
Formula AutoComplete, xxxvi, 7–8, 66
formula bars, xxxi, 29
formulas

arguments, 8
calculations, 64–74
conditional, xxxvii, 71–74
creating, xxxvi–xxxvii, 7–8
GETPIVOTDATA, 217
hiding, 327
quirks, 110
RAND function, 125
results, changes, 179
searching by, 45
for specific results, xlix
SUBTOTAL (function), 126
updating multiple locations, 27

functions (data calculations), 65

G
galleries, 1
GETPIVOTDATA formula, 217
Go To Special dialog box, 333
Goal Seek, 185–188

Goal Seek
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Goal Seek Status dialog box, 186
graphics

effects, xxxix
in headers and footers, 268
icons, xlii, 109, 122
images, lvi
inserting/modifying, xlii, 113–114
macro custom shapes, 303

gridlines, liii, 243
groupings, data, xlvi–xlvii, 173–175

H
hardware requirements, xv
headers, lv–lvi, 266–268
help with Excel, xix
Hide Detail buttons, 146–147
hiding

detail levels, vlii, 146–147
formula bars, xxxi, 29
headings, xxxi
PivotTable data, vlii, 209–215
Ribbon, xxxi, 29
rows/columns, xxix, 22
totals, 166
worksheets, xxviii

hierarchy diagrams, 257
Highlight Changes dialog box, 335
History worksheet, lxii, 336
HLOOKUP function, 153
Home tab, 2
horizontal axis, 237
horizontal gridlines, 243
horizontal page breaks, 274
.htm (Hypertext Markup Language), 346
.html (Hypertext Markup Language), 346
hyperlinks, lx–lxi, 311, 312–313, 318–323. See also 

linking
Hypertext Markup Language (.htm/.html), 346

I
icons, xlii, 109, 122
IF (function), 71
IFERROR (function), 8, 71, 72
illustrations. See graphics
images, corporate, 113–116
Import Text File dialog box, 228–229
importing data, li–lii
information compartmentalizing, 3
Insert dialog box, 23, 160
Insert Function dialog box, 7
Insert Hyperlink dialog box, 318–319, 320
insertion

of graphics, xlii, 113–114

of links, lx
of page breaks, lvii
of rows/columns/cells, xxix, 19–20

inspection, document, 351
Intelliprint, 283
Internet Explorer, 347
interoperability, 3
intranets, 327, 347
invalid data, finding, 131

K
knowledge base, Microsoft, xix

L
landscape mode, lvi, 272
language translation, xxxiv, 50
layout. See also appearance, workbook; formatting

charts, liii, 242
deferment, 206
worksheets, 271

levels, data organization, xlv, 145–150
limitations

conditional formats, 107
data filters, 126
data organization, 199, 201
Excel 2007, 3
rows, 44
scenarios, 182
summaries, 171

linear distribution, 248
linking

advantages/disadvantages, 315–316
breaks in, 303
cells, xlviii
data sources, 164–169
Excel with Web sites, 311
Office documents, lx–lxi, 312–313, 318–323
PivotCharts, 251
PivotTables, 206, 217
worksheets, 157–158

lists. See data lists
location changes

cells, 23
charts, 239, 243
shapes, 258
worksheets, 19

locked cells, 340
logarithmic distribution, 248
logical consistency, 109
Logo Builder, xxv
logos, 113
lookup_value, 152

Goal Seek Status dialog box
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M
Macro dialog box, 293, 294, 301, 302
macro-enabled template (.xltxm), 5, 291
macro-enabled workbook (.xlsm), 5, 291
macros

about, 288–297
with button access, 301–306
creating/modifying, 297–301
quick reference, lviii–lx
tips, 2
with workbooks, 306–309

magnification levels, 26
mailto hyperlinks, 320, 321
malware, 290, 292, 344
margins, lvi, 271
matches, exact, 45
mathematical computations, 248
mathematical operations, 43
matrix diagrams, 257
MAX (function), 65, 127
maximums, 54–55
Microsoft Business Certification program, xxi–xxv
Microsoft Certified Application Professional 

(MCAP), xxi–xxii
Microsoft Certified Application Specialist (MCAS), 

xxi–xxiii
Microsoft Office Online Web site, 159
Microsoft Press Knowledge Base, xix
Microsoft Press Technical Support, xix
Microsoft Product Support Services, xix
MIN (function), 65, 127
minimums, 54–55
Move Chart dialog box, 239
Move Or Copy dialog box, 18
multiple data sources. See data combining
multiple windows, arranging, 27

N
#N/A error, 152
#NAME?, 76
name attribution, 332
Name Manager, xxxv
Name Manager dialog box, 61, 62
named ranges, xxxv–xxxvi, 8, 60–63, 66, 138
names

data groups, 60–63
link breaking changes, 303

network sharing, 327
New Name dialog box, 61, 62
New PivotTable QuickStyle dialog box, 223
New Range dialog box, 341
New Table Quick Style dialog box, 98
New Workbook dialog box, 159

noncontiguous groupings, 282
NOW() (function), 65
numbers, readability of, 102–106, 221

O
Object dialog box, 312–313, 316
Office 2007 Solution Center, xix
Office documents (other than Excel)

about, 310–312
charts in, 323–325
hyperlinking, 318–323
quick reference, lx–lxi
workbooks in, 315–318
in worksheets, 312–315

Office file formats, 4–5
Office Fluent user interface, 1, 301
off-the-cuff assessments, 194–195
on-the-fly changes, 201, 251
Open dialog box, 347
operations research, 248
optimization, 189–194
orientation, page, lvi
outline, worksheet, 146, 147–148
overwriting files, 14–15

P
Page Break Preview, 10
Page Layout, 10, 97, 98
Page Setup dialog box, 267, 271, 273, 275, 279, 

281, 282, 283
pages

blanks, 283
breaks, lvii, 10, 273–275
orientation, lvi
printing order, 275–277
size of, 272

password protection, lxii–lxiii, 327, 339
Paste Options, 42–43
Paste Special dialog box, 43
Paste Values, 125
pasting

charts, 323–324
columns, 41
into graphics, 259
options, 42
quick reference, xxxii, lxi

PDF (Portable Document Format), 350
phone numbers, xl, 102–103
Pick From Drop-down List, 37–38
pictures. See graphics
pitfalls. See quirks
PivotCharts, liv, 235, 251–256
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PivotTables
about, 198–200
dynamic analysis with, 200–208
editing, 216–221
from external data, 228–232
filtering/showing/hiding, 209–215
formatting, 221–228
quick reference, l–lii
on the Web, 348

PMT() (function), 65
polynomial distribution, 248
Popular Commands, 302
Portable Document Format (PDF), 350
portrait mode, lvi, 272
PowerPoint, 313, 316
precedents, 76
presentation efficiency, 301, 306
previews, lvii, 92, 273
Print dialog box, 281, 286
printing

about, 264–265
charts, 286–287
controlling, 10–11
data lists, 279–286
headers and footers, 266–270
quick reference, lv–lviii
worksheets, 271–278

process diagrams, 257
process planning, 297
PRODUCT (function), 127
product support, xix
program window customization, 26–32
properties, xxvii, 4, 15–16
Protect Sheet dialog box, 340
protection (security), lxii–lxiii, 290–292, 327, 

339–344
Publish As Web Page dialog box, 347
pyramid diagrams, 257

Q
Quick Access Toolbar

additions to, 13
button options, 28–29
macro access from, lix, 289, 301–303
quick reference, xxxi
scenario removal, 179
spelling checker changes, 49

quick reference
appearance, workbook, xxxviii–xlii
calculations on data, xxxv–xxxviii
charts/graphics, lii–lv
collaboration, lxi–lxiii
data combining, xlvii–xlviii
data filters, xlii–xliv

data organization, xlv–xlvii
data set analysis, xlviii–xlix
data/data tables, xxxii–xxxv
macros, lviii–lx
Office documents (other than Excel), lx–lxi
PivotTables, l–lii
printing, lv–lviii
workbooks, setup, xxvii–xxxi

quirks
chart axes, 237
conditional formats, 110
data destruction potential, 178, 179
language translation, 50
link breaking changes, 303
logical consistency, 109

quote marks (around text), 104

R
RAND function, 125
RANDBETWEEN function, 126
random values, xliii, 125–126
range_lookup, 152
ranges

header cells, 128
named, xxxv–xxxvi, 60–63, 66, 138
password protection, lxiii, 340
random values within, 126
in subtotals, 137
user-named, 8

readability, data, 102–106, 221
Record Macro dialog box, 297
#REF! error, 166
references, xxvii–lxiii, 68–69, 166, 173. See also 

hyperlinks; linking
relationship diagrams, 257
relative references, 68–69
reordering, lvii
repetition (column/row headings), 283
repetitive tasks. See macros
research tools, 49
resizing. See sizing
review comments, managing, 331–334
revision, data, 36–41
Ribbon, xxxi, 1, 29
rows

alignment, 272
columns, transposing to, 43
copying and pasting, xxxii
labels, 29, 283
limitations on, 3, 44
modifying, 19
quick reference, xxix, xxxi
referencing, xxxvi
reordering, 138–139
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searching by, 45
selecting, 125
in table manipulations, 54
Total, xxxiv–xxxv

rules
copying, 140
formatting, xli, 107–108, 109
management, 107–108
validation, xliv, 119, 130–135

S
Save As dialog box, 15, 339, 346
Save Options dialog box, 339
Save Workspace dialog box, 173
saving files

chart templates, liv
overwriting files, 14–15
themes, xxix–xl, 98
workbooks, xxvii, lviii

scaling to fit, lvi, 273, 281–282
Scenario Manager, 178–179, 181–182
Scenario Summary dialog box, 182
scenarios, xlviii–xlix
scientific applications, 248
search convenience, 15
security, lxii–lxiii, 290–292, 327, 339–344, 350
Security Options dialog box, 291
Select Certificate dialog box, 345
Select Changes To Accept Or Reject dialog box, 335
Select Data Source dialog box, 237, 238
sensitive information, 340
series

adding, liii, 54
extending, xxxii, 36–37, 39
plotting, lii
removing, lii

set groupings, 173–175
Set Title dialog box, 348
shading (color), 88
shapes

diagrams, 259–260
macros, lx, 303

Share Workbook dialog box, 328–329
Show Detail buttons, 146–147
Sign dialog box, 344–345
signature, digital, lxiii, 328, 344
simultaneous data entry/editing, 37–38, 328
simultaneous file access, xlviii, 173
sizing

charts, 238–239, 243
files, 4, 312, 315–316
images, 313, 316
paper, 272
tables, xxxiv
workbooks, 13

SmartArt diagrams, lv, 256–263
solution optimization, 189–194
Solver, 189–194
Solver Parameters dialog box, 190
Sort dialog box, 139, 140
Sort Options dialog box, 140
sorting (data lists), xlv–xlvi, 138–145
space optimization, windows, 29
spell checking, xxxiii, 48–49
spreadsheets, 161, 228
statistics, xlix, 194–196
STDEV/STDEVP (function), 127
Style dialog box, 92
styles. See also appearance, workbook; formatting; 

layout
cells, xxxviii–xxxix
charts, liii
creating, 92–96
PivotTables, li–lii, 223, 230
tables, xl

substitute data, 344
SUBTOTAL, xliii, 126
Subtotal dialog box, 145
subtotals

calculating, 145–146
cell ranges in, 137
PivotTables, li

SUM (function)
about, 65
filtering limitations, 126
in SUBTOTAL (function), 127
using, 66–67, 68

SUMIFS (function), 8, 71–73
summaries. See also data organization

AutoCalculate, xliii
charts as, 235, 236
of conditional formulas, 71–74
data, 54–55
limitations, 171
of multiple worksheets, 158
PivotTables, li, 206, 216–217, 221
quirks, 110
scenarios, 179, 182
SUBTOTAL, xliii, 126–127

sums, 54–55
switching documents, 27
system requirements, xi–xii

T
Tab character (as delimiter), 228
Table AutoExpansion, 54
table structure references, 8
table_array, 152
tables. See data tables
targets, hyperlink, 319
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task automation. See macros
technical support, xix
technology certification, xxi–xxv
telephone numbers, xl, 102–103
templates

charts, liv, 243
defaults, 159
lists, 158–164
quick reference, xlvii–xlviii
workbooks, 158–159
worksheets, 160

Templates dialog box, 159
test taking tips, xxiv
text

adding to shapes, 258
errors presented as, 77
in quote marks, 104

text (.txt) files, 228–231
Text To Display box, 321
themes

about, xxxix–xl, 5–6
of imported worksheets, 19
style interface with, 242
of workbooks, 96–98

thesaurus use, xxxiv, 49
3-D references, 165, 171, 320
tiled patterns, 114
tips

Analysis ToolPak installation, 195
background images, 114
backups, 182
change tracking, 166
data distribution, 249
diagrams, 258, 260
digital certificates/signatures, 344
e-mail, 321
error checking, 78
fill handles, 37
filters, 121
formatting, 21, 87, 88, 103, 108
formulas, 68
HLOOKUP function, 153
linking, 165, 312, 313
macros/add-ins, 2
multiple scenarios, 182
named ranges, 61
optimization, 189
page breaks, 273
password choices, 339
PivotTable, 203
printing, 279, 281, 282
RAND function, 125
row/column inserts, 23
saving files, 15
SmartArt diagrams, 259
Solver installation/options, 190, 191

sorting levels, 140
summaries, 127
Table AutoExpansion, 54
templates, 159, 244
Text To Display box, 321
themes, 98
trends, 249
Web pages, 346
worksheet copies, 19
zoom levels, 26

Top 10 AutoFilter dialog box, 122
totals

calculating, 145
finding, 126
hiding, 166
PivotTables, li
quick reference, xxxiv–xxxv

tracer arrows, xxxvii, 76–77
translation, language, xxxiv, 50
transposition (columns/rows/data), xxxii, 43
trends/trendlines, liv, 235, 249
troubleshooting. See also quirks

AutoComplete, 37
formulas, 64
language translation, 50
number fields, 103
Paste Options button, 43

Trust Center Settings, 292
trusted sources, 328
.txt (text) files, 228–231

U
undo

changes, 49
resizing, 114
scenarios, 179, 182
Table AutoExpansion, 54

updating, 27, 312, 315–316, 347, 348. See also 
linking

usability, 10
user interface, 1, 2
user-defined functions, 7

V
validation rules, xliv, 119, 130–135
#VALUE!, 76
Value Field Settings dialog box, 217
values. See also linking

conditional formats, 106–113
as decimals, 186
for formulas, xxxvii
monitoring, 78
projections, 248

task automation
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quick reference, xliii
reformatting, xl
replacing, xxxiii
searching by, 45
sorting, xlv–xlvii, xlvi, 140
in specific scenarios, xlix
unique, xliv, 128, 151
watching, xxxviii

VAR/VARP (function), 127
VBA (Visual Basic for Applications), 290, 293, 306
versatility. See PivotTables
versions, save options, 4
vertical axis, 237
vertical gridlines, 243
vertical page breaks, 274
viruses, 290, 292, 344
Visual Basic Editor, 294, 298
Visual Basic for Applications (VBA), 290, 293, 306
VLOOKUP function, 151–153

W
Watch Window, 78–79
watermarks, 114
Web-Excel integration, 311
Websites, lxiii, 318–319, 328
what-if analysis, 178, 186
windows, 27. See also program window 

customization
Windows, searching in, 15
wizards, 229
workbooks. See also appearance, workbook

authenticating, 344–346
data moves within, 41–44
finalizing, 351
on intranets, 347
macros, lviii, lx, 289–290, 306
Office documents in, 315–318
security, lxii–lxiii, 339–344
sharing, lxi, 328–329
templates, xlvii–xlviii, 158–159
as Web documents, 346–350

workbooks, setup
about, 12–14
creating, 14–18
customization, 26–32
modifying, 18–21
quick reference, xxvii–xxxi

worksheets
charts, importing, liii
correcting/expanding, 48–53
embedding in, 286
formatting, 5–6
graphics, xlii
linking/hyperlinking, 157–158, 320
location changes, 19
modifying, 21–26
names of, 18
Office documents in, 312–315
printing, lv–lviii, 271–278, 279–280
quick reference, xxviii–xxxi
removing, 158
security, lxii–lxiii, 339–344
templates, 160

workspace, 157, 173

X
x-axis, 237
.xlsb (Excel binary workbook), 5
.xlsm (Excel macro-enabled workbook), 5, 291
.xlsx (Excel 2007 workbook), 5, 158–159, 165, 291. 

See also workbooks; worksheets
.xlt (Excel 97–2003), 159
.xltm (Excel 2007 workbook template), 159
.xltx (Excel template), 5, 158–159, 291
.xltxm (Excel macro-enabled template), 5, 291
XML (Extensible Markup Language), 4–5
XML Print Specification (XPS), 350

Y
y-axis, 237

Z
zooming in/out, xxx, 26
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