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Introduction xi

Introduction

Welcome to Dreamweaver CC: Visual 
QuickStart Guide! Adobe Dreamweaver 
has long (initially under its previous name, 
Macromedia Dreamweaver) been the 
premier visual tool for website develop-
ers, allowing you to build great-looking 
webpages and smoothly running websites. 
Dreamweaver’s ease-of-use takes much of 
the pain out of creating websites, without 
sacrificing flexibility. It’s possible to use 
Dreamweaver to create terrific websites 
without knowing much about HTML, CSS, 
and JavaScript. 

Dreamweaver is a rich, powerful, and deep 
program, and at first glance, it can be a bit 
intimidating. We’ve written this book as a 
painless introduction to Dreamweaver and 
its features, and with our help, you will use 
Dreamweaver to build an excellent website. 

Using This Book
We’ve organized the different elements of 
building websites with Dreamweaver CC 
into chapters, and within each chapter are 
numbered, step-by-step directions that 
tell you exactly how to accomplish various 
tasks. You don’t have to work through the 
entire book in order, but it is structured so 
the more complex material builds on the 
earlier tasks. 

We start with an overview of Dreamweaver, 
move on to setting up your website and 
creating your first webpage, then discuss 
how to add content, structure, and interac-
tivity to your pages. Finally, we show you 
how to work with HTML code and manage 
your website. 

When we first decided to write this book, 
we wanted to take a fresh look at Dream-
weaver—at how people use it, and how 
people should use it. Throughout the book, 
we’ve tried to show you how to use Dream-
weaver using its most modern features, 
rather than using some of the features that 
are still in the program but that are “old 
school.” Specifically, we’ll show you how 
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to apply styles and lay out your page ele-
ments using Cascading Style Sheets, rather 
than older, obsolete methods. If you don’t 
know what that means, don’t worry; it’s all 
explained in Chapters 7 through 9. 

For keyboard commands, we’ve included 
Mac keyboard shortcuts in parentheses 
immediately after the Windows shortcut, 
like this:

To open the Find & Replace dialog, press 
Ctrl-F (Cmd-F).

While writing this book, we’ve made the 
assumption that you’re familiar with the 
basics of using Windows or OS X. You 
don’t need to be a computer expert by any 
means, but you shouldn’t be stumped by 
concepts like selecting text, using menus, 
clicking and dragging, and using files and 
folders. Naturally, you should be familiar 
with web surfing and how to use a web 
browser to view a website.

Tips

 Throughout the book we’ve included 
many tips that will help you get things done 
faster, better, or both. 

 Be sure to read the figure captions, too; 
sometimes you’ll find extra nuggets of infor-
mation there.

 When we’re showing HTML, CSS, or 
JavaScript code, we’ve used this code font. 
We also use the code font for web addresses.

 You’ll also find sidebars (with yellow 
backgrounds) that delve deeper into subjects. 

Getting the most 
from Dreamweaver
Dreamweaver is a professional-class tool, 
and it provides professional results. Dream-
weaver allows you to build websites visu-
ally, without needing to know the details 
of HTML, CSS, and JavaScript. But to best 
use Dreamweaver, you will still need some 
fundamental knowledge of what these lan-
guages are, and how they work together to 
make up a website. Similarly, you will find it 
helpful to know basic things such as what a 
webpage is and what a web server does.

Where necessary, throughout this book 
we explain what you’ll need to know about 
HTML, CSS, and JavaScript to work with 
Dreamweaver. But there is much more to say 
about these subjects, and there are thou-
sands of books devoted to that job. In fact, 
we wrote one of the most popular books on 
JavaScript. You’ll find information about that 
book, as well as some of our favorite web 
design and development books written by 
other authors, in Appendix A.

A note for our Mac-
using friends
If you’ve flipped through this book already, 
you probably noticed that the vast major-
ity of the screenshots were taken on 
machines running Windows. That doesn’t 
mean that the book (or its authors) doesn’t 
welcome Dreamweaver users on the Mac. 
Far from it; in fact, both of us are primarily 
Mac users, and we are frequent contribu-
tors to Macworld magazine and other Mac-
oriented publications.
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If you have any questions about the book’s 
contents, please first check the FAQ 
(Frequently Asked Questions) page on the 
companion website. It’s clearly marked. 
If you’ve read the FAQ and your question 
isn’t answered there, you can contact us 
via email at dwcc@dreamweaverbook.com.  
We regret that because of the large vol-
ume of email that we get, we cannot, and 
will not, answer email about the book sent 
to our personal email addresses or via 
the contact forms on our personal sites. 
We can promise that messages sent only 
to the dwcc@dreamweaverbook.com email 
address will be read and answered, as time 
allows. Unfortunately, due to the danger 
of computer viruses being spread with 
email attachments, we cannot accept any 
messages with attachments. We also must 
limit ourselves to responding to questions 
about the book; time doesn’t permit us 
to answer general questions about web 
design and development.

Let’s get started
Every journey begins with a first step, and 
if you’ve read this far, your journey with 
Dreamweaver has already begun. Thanks 
for joining us, and let’s get started building 
your great website. 

—Tom Negrino and Dori Smith, July 2013

However, our crack research department 
tells us that most Dreamweaver users 
are running the program on Windows 
machines, so we have included screen-
shots that will reflect the experience of the 
majority of our readers. Happily, Dream-
weaver works almost identically on both 
platforms. In the few cases where there are 
differences, we’ve included separate pro-
cedures for Windows and for Mac users.

There is one other thing that we haven’t 
done in this book that we have done 
in our previous Mac books. We are no 
longer telling Mac users to Control-click 
to bring up a context menu (also known 
as a shortcut or contextual menu). Instead, 
we’ve adopted right-click, because Apple 
ships its multiple-button mouse with all of 
its computers that come with a mouse. If 
you are using a Mac with a trackpad, just 
mentally substitute Control-click wherever 
you see right-click in the book. Better 
yet, we suggest that you get any USB 
or wireless mouse with multiple buttons 
and a scroll wheel. It will really increase 
your productivity.

There’s more online
We’ve prepared a companion website for 
this book, which you’ll find at:

www.dreamweaverbook.com

On this site, you’ll find news about the 
book and links to other online resources 
that will help you use Dreamweaver CC 
more productively. If we discover any 
mistakes in the book that somehow got 
through the editing process, we’ll list the 
updates on the site, too.

http://www.dreamweaverbook.com
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4
Adding Text to 

Your Pages
The main message of most websites is 
conveyed by the site’s text, and a major 
part of your job in working with any site 
will be adding, modifying, and styling that 
text. Dreamweaver gives you the tools you 
need to effectively put text on your pages 
and get your message across.

When you add text, you need to deal 
with two different aspects of the text: its 
structure and its presentation. Structural 
elements are things like paragraphs, head-
ings, lists, and the like; presentation is how 
the text looks, including things like the font, 
font size, text color, and so on. Most sites 
these days separate the structure and the 
presentation. Structure is about organizing 
the content on the page, and presentation 
involves making the content look good.

In this chapter, we’ll concentrate on getting 
text onto your page and applying structure 
using headings and lists. We’ll also cover 
using basic HTML text styles to change 
the look of your text. Dreamweaver CC 
introduces integration with Adobe Edge 
Fonts, making web fonts easy to use, so 
we’ll show you how to add beautiful type 
to your pages.

In This Chapter
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Cutting, Copying, and Pasting Text 86
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Adding Text
Most of the text on a webpage is formatted 
in blocks, which are enclosed by beginning 
and ending HTML tags. For example, the 
HTML for a line of text with paragraph tags 
wrapped around it looks like this:

<p>This text is wrapped in beginning 
and ending paragraph tags.</p>

For a browser to understand that this is 
a paragraph, you (or in this case, Dream-
weaver) have to make it one by adding the 
surrounding <p> tags.

Of course, in Dreamweaver’s Design view 
or Live view, you won’t see the HTML 
tags. All of the text contained between the 
opening <p> tag and the closing </p> tag is 
considered by a web browser to be within 
the same paragraph, no matter how much 
text is between the tags. The <p>…</p> 
combination is an example of a container 
tag. Virtually all of the structural formatting 
that you can apply with Dreamweaver is 
done with container tags.

Selecting Text
Besides selecting text by dragging over it with the mouse cursor, Dreamweaver also gives you 
some text selection shortcuts in Design view:

 . Double-click a word to select it.

 . Move your cursor to the left of a line of text until the cursor changes from an I-beam to an arrow 
pointing at the text. Then click once to highlight a single line, or drag up or down to select 
multiple lines.

 . Triple-click anywhere in a paragraph to select the entire paragraph.

 . For finer control over selecting individual letters, hold down the Shift key and press the left or 
right arrow key to extend the selection one letter at a time.

 . Ctrl-Shift (Cmd-Shift) plus the left or right arrow key extends the selection one word at a time. 
Ctrl (Cmd) plus the left or right arrow key moves the cursor one word to the left or right but 
doesn’t select any text.

 . Press Ctrl-A (Cmd-A) to Select All (the entire contents of the current document).
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When you add text to a page with Dream-
weaver, the program automatically wraps 
the text with paragraph tags when you 
press the Enter (Return) key on your 
keyboard. You can see this if you switch 
to Code view by clicking the Code but-
ton at the top of the Dreamweaver editing 
window A.

Dreamweaver also has special commands 
that help you import entire Microsoft 
Word or Excel documents as webpages. 
(See “Using Paste Special,” later in this 
chapter. Also, refer to Chapter 19, “Working 
with Other Applications.”)

To insert text:
1. In Dreamweaver’s Design view, click in 

the page where you want to add text.

2. Type the text you want.

A Dreamweaver adds paragraph tags around text when you press the Enter (Return) key.
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Cutting, Copying, 
and Pasting Text
Just as with a word processor, you can cut, 
copy, and paste text on a page in Dream-
weaver, which shares the same menu com-
mands with virtually all standard Windows 
and Mac word processors and text editors. 
When pasting text in Design view from one 
part of a Dreamweaver page to another or 
between Dreamweaver pages, text format-
ting is automatically maintained.

Dreamweaver also allows you to paste 
text and maintain some or all of the text’s 
formatting. This is especially useful when 
moving text from applications such as 
Microsoft Word or Excel to a webpage. See 
“Using Paste Special,” later in this chapter.

To cut or copy text:
1. Select the text you want to cut or copy.

2. To cut the text to the clipboard, choose 
Edit > Cut or press Ctrl-X (Cmd-X).

or

To copy the text to the clipboard, 
choose Edit > Copy or press Ctrl-C 
(Cmd-C).

The text is placed on the clipboard.

 When you have text selected, most of the 
time you can right-click to cut or copy the text 
using a context menu. You can also right-click 
to paste text from the context menu. 

To paste plain text:
1. Click to place the insertion point on 

the page where you want the text 
to appear.

2. Choose Edit > Paste, or press Ctrl-V 
(Cmd-V).

 If you copy some HTML source code 
from another program, such as the Source 
view of a web browser, and paste it into a 
Dreamweaver page in Design view, the HTML 
appears on the page with tags and all. That’s 
because although what you’ve pasted in is 
HTML markup, Dreamweaver is trying to be 
smarter than you—it assumes that markup is 
what you want to display. If that’s not what 
you want, but rather you want the result of the 
markup to display in your page, just switch to 
Code view in Dreamweaver before you paste. 
The HTML code will paste into the page, and 
when you switch back to Design view, it will 
display the proper formatting.

 Dreamweaver offers Undo and Redo 
commands in the Edit menu, which can often 
be very useful for fixing mistakes or repeating 
operations. You can also press Ctrl-Z (Cmd-Z) 
for Undo and Ctrl-Y (Cmd-Y) for Redo.
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Dragging and 
Dropping Text
If all you want to do is move some text 
from one place on a page to another, it’s 
often faster to drag and drop the text.

To drag and drop text:
1. Select the text you want to move A.

2. Move the cursor over the selected text.

The cursor changes from an I-beam to 
an arrow.

3. Click and hold your mouse button over 
the selected text, and drag it to its new 
location, releasing the mouse button 
when the cursor is where you want 
the text B.

The text moves to its new home.

 To duplicate the text, hold down the 
Ctrl (Option) key while dragging and dropping. 
A copy of the text appears when you release 
the mouse button.

A Begin dragging and dropping text by 
selecting it.

B When you release the mouse button, the text 
moves to where you dragged it.
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Using Paste Special
Dreamweaver’s Paste Special command in 
the Edit menu gives you a variety of options 
that control the way formatted content is 
pasted into Dreamweaver’s Design view.

You will probably use the Paste Special 
command most often when pasting in text 
from Microsoft Word or Excel to maintain 
the formatting that the text had in those 
programs A. Text pasted in from Excel 
can appear in Dreamweaver as a format-
ted table, which saves you a lot of time 
and effort.

The Paste Special options include:

n	 Text only pastes just the text; paragraph 
marks and all formatting are stripped 
from the text B.

n	 Text with structure pastes the text and 
maintains the structure (notably para-
graphs, tabs, and lists) but eliminates 
other text formatting C.

n	 Text with structure plus basic format-
ting keeps the text and text structure 
and retains bold and italic formatting D.

n	 Text with structure plus full formatting 
preserves the text, structure, and styles 
from the original document E.

A Paste Special will do a great job of maintaining 
the formatting from this Microsoft Word document.

B This is the “Text only” version of the text 
from A, with paragraph marks and formatting 
stripped out.

C With the “Text with structure” option, the text 
and paragraph marks are there, but there’s no 
character formatting.
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To use Paste Special:
1. Select the text you want to cut or copy.

The text will usually be in an application 
other than Dreamweaver.

2. Cut or copy the text.

3. Switch to Dreamweaver, and click to set 
the insertion point where you want the 
text to appear.

4. Choose Edit > Paste Special, or press 
Ctrl-Shift-V (Cmd-Shift-V).

The Paste Special dialog appears F.

5. In the dialog, click the radio button next 
to the paste option you want.

6. Click OK.

The text pastes in according to the 
option you selected.

 If you use the “Text with structure plus 
basic formatting” or “Text with structure plus 
full formatting” choices, you can also paste 
graphics into Dreamweaver along with the 
formatted text.

 You can copy and paste graphics from 
most applications into Dreamweaver, but if 
you want to paste a graphic along with format-
ted text, you must use Paste Special.

 When pasting from Word and main-
taining full styles, Dreamweaver reads the 
Word styles and creates CSS styles with the 
same names and attributes. It places the CSS 
styles in the same document. If you want to 
use these styles elsewhere on your site, you 
should move these internal styles to an exter-
nal style sheet. See “Dragging and Dropping 
Styles” in Chapter 9 to learn how to do that.

D The “Text with structure plus basic formatting” 
option maintains bold and italic formatting.

E The final option, “Text with structure plus full 
formatting,” maintains all the formatting from the 
Word document.

F Choose the option you want from the Paste 
Special dialog.
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Applying Headings
After paragraphs, headings are the most 
important structural element on most web-
pages. Headings point your site’s visitors 
to essential information on the page, and 
they separate sections of the page. Think 
of headings as being similar to headlines in 
a newspaper.

Text you enter into Dreamweaver begins 
with no heading; Dreamweaver refers to 
this text as None in the Property inspec-
tor. As soon as you press Enter (Return), 
Dreamweaver wraps the text in paragraph 
tags, and the text becomes paragraph text.

HTML has six sizes of headings, plus 
paragraph text A. These headings don’t 
have a fixed point size, unlike headings 
in, say, Microsoft Word or Adobe InDe-
sign. Instead, they are sized relative to 
one another and to the size of the para-
graph text, and the size that the user sees 
depends on the settings in the user’s web 
browser. By default, headings are usually 
displayed in boldface.

You can change the look of headings (their 
size, font, color, and so forth) using CSS, 
which we’ll cover in Chapter 7.

 You can have only one size of HTML 
heading in a particular element. You can work 
around this limitation with CSS styles.

 Headings are also important because 
they help search engines find and index con-
tent on your pages. Google in particular uses 
headings in this fashion, so it’s a good idea 
to use headings when they are appropriate to 
your content.

A Examples of the six heading sizes, plus 
paragraph, which is usually used for body text.
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To apply a heading:
1. Click in the line you want to change.

Note that you don’t have to select text; 
a heading is a block style, so it affects 
the entire paragraph the cursor is in.

2. Choose Format > Paragraph Format > 
Heading x, where x is the heading size 
you want B.

or

Press Ctrl-1 for Heading 1, Ctrl-2 for 
Heading 2, and so on. On the Mac, 
press Cmd-1 for Heading 1, Cmd-2 for 
Heading 2, and so on.

or

Choose a heading from the Format 
pop-up menu in the HTML mode of the 
Property inspector C.

or

Choose one of the heading options 
from the Heading pop-up menu in 
the Structure category of the Insert 
panel D.

The text changes to the heading 
you selected.

B Choose the heading size you want from the 
Paragraph Format submenu.

C Another 
way to choose 
the heading 
size is to use 
the Format 
menu in the 
HTML mode of 
the Property 
inspector.

D The 
Structure 
category of the 
Insert panel 
gives you a 
pop-up menu 
with the six 
heading sizes.
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To turn text into paragraph text:
1. Click in the line you want to change.

2. Choose Format > Paragraph Format > 
Paragraph.

or

Choose Paragraph from the Format 
pop-up menu in the HTML mode of the 
Property inspector.

or

Press Ctrl-Shift-P (Cmd-Shift-P).

Dreamweaver changes the text into 
a paragraph.

To remove heading formatting:
1. Click in the line you want to change.

2. Choose Format > Paragraph Format > 
None.

or

Press Ctrl-0 (Cmd-0). (Those are zeros, 
not the letter “O.”)

The Format menu of the Property 
inspector changes to None, indicating 
that the text has no heading or para-
graph style assigned to it.
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Applying Character 
Formats
Character formatting is styling that you 
can apply to words and individual charac-
ters rather than to blocks such as para-
graphs. This formatting includes changing 
the font, font size, and font color.

Beginning several versions ago and 
continuing through the current version of 
Dreamweaver, the program dispensed with 
the old method of applying these sorts 
of character formatting (which was to use 
the HTML <font> tag) in favor of using 
CSS styles. This change happened mostly 
behind the scenes in Code view, so if you 
have been using Dreamweaver for quite 
some time, you may not have even noticed 
the change. Beginning with Dreamweaver 
CS4, the program enforces the use of CSS 
for text styling by requiring you to partici-
pate in defining CSS rules for changing 
fonts, font sizes, and font colors.

The reason for the change to CSS is 
important. Pages styled with CSS are much 
more flexible than pages that use HTML 
<font> tags, and they can be maintained 
more easily. For example, when a site is 
redesigned, every page that uses <font> 
tags must be individually changed to match 
the new design. If you have hundreds or 
thousands of pages in your site, that’s a 
lot of work. Sites that use CSS to style text 
only need to change the style sheet docu-
ment, and the changes automatically ripple 
through the whole site. You’ll learn more 
about using CSS to style text (especially 
for setting font properties) in Chapter 7. 
Some other formatting operations are still 
performed using HTML markup, and those 
are the ones we’ll explore in this chapter.
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Applying HTML 
Text Styles
The most common text formatting is to 
make text bold or italicized, and of course 
Dreamweaver can do that with either 
HTML markup or a CSS rule. But it can also 
apply several other text styles, some of 
which are for specialized uses, as shown 
in A and Table 4.1.

TAbLe 4.1 Text Styles

Style Description

Bold Makes text boldface.

Italic Italicizes text.

Underline Underlines text.

Strikethrough Text is shown with a line through it.

Teletype Reminiscent of an old typewriter. Usually shows text in a monospaced font such as Courier.

Emphasis Italicizes text onscreen. Causes screen readers to stress importance in speech.

Strong Bolds text onscreen. Causes screen readers to add additional importance to speech.

Code Depicts programming code, usually in a monospaced font.

Variable Marks variables in programming code. Usually displayed as italics.

Sample Meant to display sample output from a computer program or script. Usually displayed in a 
monospaced font.

Keyboard Meant to depict text a user would type on the keyboard. Usually displayed in a 
monospaced font.

Citation Used to mark citations and references. Usually displayed as italics.

Definition Used to mark the first, defining usage of a term in a document. Usually displayed as italics 
(Safari on the Mac displays this as regular text).

Deleted Marks deleted text. Shown the same as strikethrough.

Inserted Marks inserted text. Shown the same as underlined.

A Dreamweaver offers a 
number of useful (and not 
so useful) HTML text styles.
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Many of these text styles are meant for 
displaying programming or script code, 
so they won’t be used at all on many 
sites. Others, such as Underline and 
Strikethrough, are deprecated as of the 
HTML 4.01 standard, which means that 
they are obsolete and may not work in 
future browsers. Instead, you should use 
a CSS property. See “CSS Categories” in 
Chapter 7.

To apply an HTML text style:
1. Select the text you want to change.

2. Choose Format > Style, and then 
choose the style you want from 
the submenu.

The text’s appearance changes.

 Actually, by default Dreamweaver does 
not use the traditional <b> and <i> HTML tags 
for bold and italic, respectively. Instead it uses 
<strong> and <em> (for emphasis). The latter 
tags are preferred as part of best practices, 
because they are better handled by the screen 
readers used by visually impaired users. If 
you want to switch Dreamweaver back to 
using <b> and <i>, choose Edit > Preferences 
(Dreamweaver > Preferences) and, in the 
General category of the Preferences dialog, 
deselect “Use <strong> and <em> in place 
of <b> and <i>.”
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Using Preformatted 
Text
Browsers usually ignore invisible formatting 
that doesn’t affect page content, such as 
tabs, extra spaces, extra line feeds, and the 
like. If you need to display text exactly as 
entered, however, you can use the Prefor-
matted paragraph format, which wraps the 
text in the <pre>…</pre> tags and makes 
browsers display all of the text characters.

Originally, preformatted text was meant to 
display tabular data in rows and columns, 
as in the output of a spreadsheet. To make 
the information line up, browsers display 
preformatted text in a monospaced font 
such as Courier A.

To apply preformatting:
1. Select the text you want to change.

2. From the Format pop-up menu of the 
HTML mode of the Property inspector, 
choose Preformatted B.

or

Choose Format > Paragraph Format > 
Preformatted Text.

The text changes appearance.

 If you want to display tabular data, it 
often makes more sense to use a table rather 
than preformatted text. You get much more 
control over the table style and spacing of the 
items in the table, and you can add CSS to 
style the table’s contents if needed. See Chap-
ter 10 for information about using tables.

A Preformatted text lines up neatly, as in 
this table.

B Apply the 
style using 
the Property 
inspector 
by choosing 
Preformatted 
from the 
Format menu.
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Adding Line breaks
Just as in a word processor, you press Enter 
(Return) in Dreamweaver to create a new 
paragraph. This is fine when you want to 
actually create a new paragraph, but not 
so great when you just want to move the 
cursor down a line, as you might want to do 
when entering an address. That’s because 
web browsers (and Dreamweaver) insert a 
blank line above and below a paragraph, so 
if you make each line of the address its own 
paragraph, it looks goofy A.

What you want to do is add a line break, 
which moves the cursor down one line 
without creating a new paragraph. In the 
code, Dreamweaver adds the HTML  
<br /> tag to the end of the line.

To insert a line break:
At the end of the line you want to break, 
press Shift-Enter (Shift-Return).

or

At the end of the line you want to break, 
in the Common category of the Insert 
panel, select Line Break from the Character 
pop-up menu.

The text changes B.

 Line breaks are invisible characters in 
both Dreamweaver and web browsers, but 
you can make them visible in Dreamweaver if 
you want. Choose Edit > Preferences (Dream-
weaver > Preferences), and then click the 
Invisible Elements category. Select the check 
box next to “Line breaks,” and then click OK. 
Dreamweaver then displays line breaks in 
Design view C.

A Paragraphs 
have whitespace 
before and after 
them, which isn’t 
really appropriate 
for things like 
addresses.

B After you replace 
the paragraph tags 
with line breaks, the 
address looks better.

C With the appro-
priate preference 
enabled, you can 
see the invisible line 
break characters.
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Indenting and Aligning 
Text with HTML
You won’t indent or align text in Dream-
weaver as you would with a word proces-
sor. The most common kind of indenting, 
indenting the first line in a paragraph, is 
usually done with a tab in a word pro-
cessor, but tabs have no effect in HTML. 
Instead, you can use the text-indent CSS 
style property. Similarly, there are CSS 
properties for text alignment. See Chap-
ter 7 for more about using CSS.

You can add whitespace to text—and 
simulate a tab—with non-breaking spaces. 
See “Inserting Special Characters,” later in 
this chapter.

When you are indenting paragraphs to set 
them apart from preceding and following 
paragraphs, Dreamweaver uses the HTML 
<blockquote> tag. This indents both the 
left and right margins of the block-quoted 
paragraph. You aren’t limited to para-
graphs; you can block quote any block 
element, such as headings.

Dreamweaver can align text with the left 
margin, right margin, or center of the page. 
You can also justify text, which adds space 
as needed between words so that both the 
left and right margins are aligned.

The method shown here adds alignment 
attributes to the HTML markup. You can 
also use Cascading Style Sheets to align 
text, which is covered in Chapters 7 and 8.

To block quote text:
1. Click in the paragraph or other block 

element you want to indent.

2. Click the Indent button on the HTML 
mode of the Property inspector A.

or

Outdent Indent

A Use the Indent 
button to apply 
a block quote to 
your text.
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Choose Format > Indent, or press 
Ctrl-Alt-] (Cmd-Opt-]).

The text changes B.

 To add more indenting, click the Indent 
button on the Property inspector again. This 
nests the <blockquote> tags.

 The CSS margin property is a much 
more flexible way to indent block elements, 
as described in Chapter 8.

To remove block quoting:
1. Click in the paragraph or other block 

element you no longer want to indent.

2. Click the Outdent button on the 
Property inspector.

or

Choose Format > Outdent, or press 
Ctrl-Alt-[ (Cmd-Opt-[).

The text changes.

To align text:
1. Click inside the paragraph you want 

to align.

2. Choose Format > Align, and then 
choose Left, Center, Right, or Justify 
from the submenu C.

or

Use one of the keyboard shortcuts 
listed in Table 4.2.

 Longtime Dreamweaver users may be 
thrown a bit by the removal of the alignment 
buttons from the HTML mode of the Property 
inspector. Those buttons have been moved to 
the CSS mode of the Property inspector. If you 
use the alignment buttons, Dreamweaver will 
add a style="text-align:" property to the 
HTML element. It will also open and show you 
the new CSS rule in the CSS Designer panel.

B The block quote nicely sets off the sonnet from 
the commentary text.

C Choose a text alignment from the Format menu.

TAbLe 4.2 Alignment Shortcut Keys

Shortcut Key 
(Windows)

Shortcut Key 
(Mac) What It Does

Ctrl-Alt-Shift-L Cmd-Opt-Shift-L Left 
alignment

Ctrl-Alt-Shift-C Cmd-Opt-
Shift-C

Center 
alignment

Ctrl-Alt-Shift-R Cmd-Opt-
Shift-R

Right 
alignment

Ctrl-Alt-Shift-J Cmd-Opt-Shift-J Full 
justification
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Working with Lists
Lists are an easy way to organize content 
on your webpage. Dreamweaver supports 
three types of lists:

n	 Numbered lists or Ordered lists, for lists 
with items that need to be in a particular 
order A. List items are numbered and 
indented from the left margin. If you add 
or remove items from the numbered list, 
it automatically renumbers.

n	 Bulleted lists or Unordered lists, for 
lists of items in no particular order B.

n	 Definition lists, where each item has an 
indented subitem C.

A Numbered lists automatically renumber if you 
insert a new item between two existing items.

B Bulleted lists 
are single-spaced 
and indented.

C Definition lists have the definitions indented under the definition terms. The definition terms don’t have to 
be all uppercase—they just happen to be in this figure.
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To create a list:
1. Type the items for your list into the 

window. After typing each item, press 
Enter (Return).

2. Select the items in the list.

3. Choose Format > List, and then choose 
Unordered List, Ordered List, or Defini-
tion List from the submenu.

or

Click either the Unordered List or 
Ordered List button in the HTML mode 
of the Property inspector.

or

Click one of two buttons in the Struc-
ture category of the Insert panel: ul for 
Unordered List, or ol for Ordered List. 

The text changes to the kind of list 
you chose.

 At the end of your list, you can turn 
off the list function either by pressing Enter 
(Return) twice or by clicking the appropriate 
list button in the Property inspector again.

 There is another button in the Structure 
category of the Insert panel that you can use 
to apply list tags to text. The li button marks 
text as a list item; the text must be within a 
bulleted or numbered list. 

 Though you can still create a definition list 
in Dreamweaver, Dreamweaver CC removed 
the two definition list item tags from the Insert 
panel. You can still add them in Code view. Use 
dt to tag text as a definition term, and dd to 
mark text as a definition description.

 Because the Text category of the Insert 
panel was originally designed to help you work 
in Code view, some of the list buttons will cause 
the Dreamweaver window to change to Split 
view, so you can see the Code and Design 
panes at the same time. If you want to avoid 
code altogether, use the Property inspector or 
the menu bar to format your lists.
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Setting list properties
You can change numbered list and bul-
leted list properties in Dreamweaver. 
Choose between five types of numbering, 
as shown in Table 4.3. For bulleted lists, 
you can choose either a round bullet (the 
default) or a square bullet. There are no 
properties to set for a definition list.

To set list properties:
1. Click in the list you want to change to 

place the insertion point.

2. Choose Format > List > Properties.

The List Properties dialog appears D.

3. Do one or more of the following:

>	 In the List type pop-up menu, select 
Bulleted List, Numbered List, or 
Directory List (“definition list” is called 
“Directory List” in this dialog for 
some reason).

>	 In the Style pop-up menu, select one 
of the Bulleted List or Numbered 
List styles.

>	 Use the Start count text box to set 
the value for the first item in the 
numbered list.

4. Click OK.

 You may notice that there is a fourth 
choice in the List type pop-up menu: Menu 
List. That choice creates an unusual type of list 
that is based on the <menu> tag. That tag was 
deprecated (that is, it was recommended that 
it not be used) when HTML 4.01 was standard-
ized in 1999. We suggest that you avoid the 
use of the Menu List option. It’s one of those 
little things that should have long since been 
removed from Dreamweaver, in our view.

D In the List Properties dialog, you can change 
the way lists are numbered and bulleted.

TAbLe 4.3 Numbered List Style Options

List Name Example

Number 1, 2, 3, 4

Roman Small i, ii, iii, iv

Roman Large I, II, III, IV

Alphabet Small a, b, c, d

Alphabet Large A, B, C, D
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Nesting lists
You can indent lists within lists to create 
nested lists. Because nested lists do not 
have to be of the same type, you can cre-
ate, for example, a numbered list with an 
indented bulleted list, and you can have 
multiple levels of nested lists within one 
overall list E.

E You can nest numbered lists inside bulleted lists.
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To create a nested list:
1. Click the end of a line within an existing 

list to place the insertion point.

2. Press Enter (Return).

Dreamweaver creates another line of 
the list.

3. Press Tab.

Dreamweaver creates a new indented 
sublist of the same type as the parent 
list. For example, if the parent list is a 
numbered list, the new sublist will also 
be a numbered list.

4. (Optional) If you want the sublist to be 
a different type of list than the parent 
list, click the Numbered List or Bulleted 
List button in the HTML mode of the 
Property inspector.

5. Type the list item.

6. Press Enter (Return).

Dreamweaver creates a new 
sublist item.

7. To return to the original list, use the up 
or down arrow keys to move the inser-
tion point into one of the items in the 
original list, or click to place the inser-
tion point where you want it.

 You can also click the Outdent button in 
the HTML mode of the Property inspector to 
merge the sublist back into the main list.

 Use the List Properties dialog to format 
sublists as well as lists.

 If you try to create a sublist within a 
list that is in a table by pressing Tab, Dream-
weaver jumps to the next cell rather than 
indenting and creating a nested list. One work-
around is to create the nested list outside of 
the table, cut it, and then paste it in the table 
cell where you want it to go.
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Inserting Special 
Characters
You can add special characters, such as 
the Euro, copyright, or trademark symbol, 
to your page in Dreamweaver without 
having to remember their bizarre HTML 
equivalents or odd keyboard combina-
tions. In Dreamweaver, relief is just a menu 
choice away.

About Non-breaking Spaces
An oddity about HTML is that it ignores multiple spaces. One of the special characters you can 
insert is the non-breaking space, which is useful for adding multiple consecutive spaces and occa-
sionally for nudging text and even images. Dreamweaver uses the HTML code for a non-breaking 
space (which is &nbsp;) inside paragraph tags so that blank lines appear in web browsers, like so:

<p>&nbsp;</p>

If you want multiple spaces between words, insert two or more non-breaking spaces. The easiest 
way to do this is to press Ctrl-Shift-spacebar (Cmd-Shift-spacebar), but you can also use the Char-
acter pop-up menu in the Common category of the Insert panel or the Insert > Character submenu.

Dreamweaver by default ignores multiple spaces, but you can change this behavior and force the 
program to insert multiple non-breaking spaces in the code. Choose Edit > Preferences (Dream-
weaver > Preferences), choose the General category, and then select the check box next to “Allow 
multiple consecutive spaces.”
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To insert a special character:
1. Click in the page to place the insertion 

point where you want the special char-
acter to appear.

2. In the Common category of the Insert 
panel, choose the character you want 
from the Character pop-up menu A.

or

Choose Insert > Character, and then 
choose the special character you want 
from the submenu.

or

If the character you want doesn’t 
appear in the menu, choose Other 
Characters from the pop-up menu in the 
Insert panel or choose Other from the 
Insert > Character submenu. The Insert 
Other Character dialog appears B.

3. Click the character you want to use, and 
then click OK to close the dialog.

Dreamweaver inserts the special char-
acter on your page.

A Insert unusual 
characters from the 
Character pop-up 
menu in the Common 
category of the 
Insert panel.

B The Insert Other Character dialog provides 
the rest of the special characters Dreamweaver 
can insert.
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Working with 
Font Styles
Font stacks determine which fonts a 
browser displays on your webpage. 
A browser uses the first font in the stack 
that is installed on the user’s system. If 
none of the fonts in the stack are installed, 
the browser displays the text as specified 
by the user’s browser preferences.

In Dreamweaver, all font control is pro-
vided via CSS, and you access it through 
the CSS tab of the Property inspector A. 
There, you’ll find controls for the font fam-
ily, the font style, the font weight, the font 
size, and the font color. These controls 
have changed somewhat in Dreamweaver 
CC. The two main changes are in the font 
family pop-up menu and the addition of 
the font weight pop-up menu. The Font 
pop-up menu now includes an entirely new 
set of font stacks (which previous versions 
of Dreamweaver called font groups) that 
Adobe says is more up to date in includ-
ing standard fonts installed in Windows, 
OS X, and Linux. Font weight is specified 
in a range of 100 through 900 and speci-
fies the heaviness of the font; Adobe has 
created a table of common font names and 
their numeric weight equivalents, which is 
reproduced in Table 4.4.

font-family

font-style

font-weight

font-size

font-size values Color picker for 
font-color

font-color

A You’ll find Dreamweaver's font styling controls 
in the CSS tab of the Property inspector. We've 
labeled this figure with each of the CSS properties 
and their controls.

TAbLe 4.4 Font Names and Numeric  
Equivalents

Font Name Numeric Equivalent

Thin, Hairline 100

Extra Light 200

Light 300

Normal, Book 400

Medium 500

Semibold, Demibold 600

Heavy, Extra Bold 700

Black 900
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To apply font styling:
1. In Design view, select the text to which 

you want to apply the font stack.

2. In the CSS tab of the Property inspector, 
choose the font stack you want from 
the Font pop-up menu B.

The text will change to take on the 
appearance of the first font in the font 
stack that is installed on your system.

3. Make changes as needed to the font 
style, weight, size, and color values. 
Note that the font size unit values pop-
up menu becomes active only if you first 
change the default value for font size.

 Dreamweaver defines font stacks using 
the font-family CSS property and applies 
the font styling using in-line CSS styles, which 
you can later move to an external style sheet. 
You’ll learn more about CSS starting in Chap-
ter 7, and more about moving internal CSS 
styles to external CSS styles in Chapter 9.

Fonts, browsers, and Operating Systems
Not all computers have the same fonts. For example, a common sans serif font on Windows sys-
tems is Arial. A similar sans serif font on Macintosh systems is Helvetica. Many Linux systems have 
Helvetica, but not all.

But don’t assume that you can make generalizations just based on operating system; different 
versions of operating systems can come with different fonts. And on top of that, different browsers 
(even on the same operating system) can ship with different defaults for serif and sans serif fonts. 
All these systems have some default fonts, however.

When choosing font stacks, select fonts that share similar characteristics and try to cover all the 
bases in terms of operating systems. Then, add either the generic serif or sans serif choice at the 
end, just in case none of your preferred choices are available. Why add a font you don’t even have 
to your font stack? One reason is that you expect a lot of your viewers to have a particular font (even 
though you don’t have it). For example, if you are developing pages for a corporate client for use in 
its intranet, your client may ask for a particular font that is installed on all of the company’s machines. 
Or you might have a font stack that includes web fonts, which we discuss in the next task.

B Apply a font stack using the Font pop-up menu.

 It’s often easier to define one or more 
styles once, name them, and then simply apply 
those styles to text. Again, because this uses 
CSS, you’ll learn how to do that in Chapter 7.
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Using Web Fonts
One of the big constrictions on the freedom 
of web designers has always been the 
limited range of fonts they could use on 
pages. Because there are so many brows-
ers running on so many different platforms, 
designers were more or less forced to use 
a very restricted set of fonts (often known 
as web-safe fonts) that were most likely to 
appear on Windows, Mac, Linux, and mobile 
devices. Microsoft’s set of web-safe fonts, 
including Arial, Verdana, Times New Roman, 
and Trebuchet, gained widespread use. 
They’re fine, but they’re boring.

Once again, CSS3 comes to the rescue. 
The @font-family rule allows you to use 
non-web-safe fonts by defining the loca-
tion of a font resource, which can be either 
local to your machine or external. Different 
companies, including Adobe, Google, and 
others, have created online font repositories 
that contain a wide selection of attractive 
fonts that you can use in your webpages. If 
you do a web search for “web fonts,” you’ll 
find a wide selection of fonts, both free and 
available as a subscription service.
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Using Adobe edge web fonts
One of the big new features in Dream-
weaver CC is its integration with Adobe 
Edge Fonts, which is a large library (more 
than 500) of free-to-use web fonts. Adobe 
Edge Fonts is a combination of Adobe’s 
own fonts, drawn from its much larger 
Typekit font service (www.typekit.com), 
and Google Fonts (www.google.com/
fonts). When you use Adobe Edge web 
fonts in your pages, the fonts are delivered 
with the help of JavaScript to the user’s 
browser or to Dreamweaver’s Live view, 
from Adobe’s content delivery network 
(CDN). A CDN keeps copies of content, 
in this case font files, cached in servers 
across the globe. When a user needs a 
font, it gets served from a nearby server, 
speeding up the page load.

Dreamweaver CC uses the new Manage 
Fonts dialog to add fonts from the Adobe 
Edge Fonts collection to the Font menu 
in the CSS tab of the Property inspector. 
You can then apply those fonts to your 
own pages.

To show you how easy it is to use web 
fonts, we’ve created a simple example 
based on Alice’s Adventures in Wonder-
land. It shows part of a famous conversa-
tion between Alice and the White Queen, 
with different fonts used for each charac-
ter’s dialogue A.

A In this example, we styled Alice’s and the White 
Queen’s dialogue differently by using web fonts.

http://www.typekit.com
http://www.google.com/fonts
http://www.google.com/fonts
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To use Adobe edge web fonts:
1. Choose Modify > Manage Fonts.

or

At the bottom of the Font pop-up menu 
in the CSS tab of the Property inspector, 
choose Manage Fonts.

The Manage Fonts dialog appears, set 
to the Adobe Edge Web Fonts tab B.

continues on next page

B You’ll begin adding Adobe Edge web fonts in the Manage Fonts dialog.

Show headline  
or body fonts

Font filter buttons

Show fonts added 
to font list

Search field

Font samples
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2. To add fonts to your font list, scroll 
through the font samples until you find 
fonts that you like, or use the search field 
or the filter buttons to narrow down your 
choices. To choose a font, click it, which 
will cause a check mark to appear in the 
font’s sample. To see just the fonts that 
you’ve chosen, click the “Show fonts 
added to font list” button C.

3. Click Done.

The web fonts are added to the bottom 
of the Font menu D.

4. In Design view, select the text to which 
you want to apply a font.

5. From the Font menu in the CSS tab of 
the Property inspector, choose the web 
font you want. Repeat as necessary for 
any other text on the page, possibly 
with different web fonts.

The text won’t appear to have changed, 
because Dreamweaver uses JavaScript 
to load web fonts.

6. Click the Live View button in the 
Document toolbar to preview in Dream-
weaver how the web fonts will look E.

C Once you've picked the font you want, see 
them all by clicking the “Show fonts added to font 
list” button.

E You can preview how the web fonts will look 
without leaving Dreamweaver by switching to 
Live view.

D After you choose the fonts in the Manage Fonts 
dialog, they are added to the Font pop-up menu in 
the Property inspector.
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Using local web fonts
It’s possible to have web font files that you 
have locally, and that you wish to include 
in the Font menu and then upload to your 
website to be served along with the rest 
of your site. Dreamweaver CC can handle 
web fonts in the EOT, WOFF, TTF, and SVG 
formats. Once again, you’ll use the Manage 
Fonts dialog to make the fonts available for 
use in Dreamweaver.

To use local web fonts:
1. Choose Modify > Manage Fonts.

The Manage Fonts dialog appears, set 
to the Adobe Edge Web Fonts tab B.

2. Click the Local Web Fonts tab.

3. Click the Browse button next to the font 
format that you want to add.

4. In the resulting Open dialog, navigate to 
the location of the font file, select it, and 
click Open.

5. Back in the Manage Fonts dialog, select 
the check box next to “I have properly 
licensed the above font(s) for website 
use,” then click the Add button.

The font appears in the box below F.

6. (Optional) Repeat steps 3–5 to add 
additional fonts.

7. Click Done.

The local web fonts are added to the 
Font pop-up menu in the Property 
inspector. Apply them as you would a 
font stack or an Adobe Edge web font.

F If you have web fonts on your local machine, 
you can make them usable in Dreamweaver with 
the Manage Fonts dialog.
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Specifying custom font stacks 
If you want your own custom font stack, 
you can do that with the Manage Fonts dia-
log. You can choose from fonts you have 
installed on your machine, and also any 
local web fonts you’ve previously installed.

To create a custom font stack:
1. Choose Modify > Manage Fonts.

The Manage Fonts dialog appears, set 
to the Adobe Edge Web Fonts tab B.

2. Click the Custom Font Stacks tab.

The Custom Font Stacks pane 
appears G and displays three catego-
ries of information:

>	 Font list: Displays current font stacks.

>	 Chosen fonts: Displays fonts in the 
chosen stack.

>	 Available fonts: Displays all the 
fonts available on your system. The 
font selected is displayed in the text 
field below.

3. Do any of the following:

>	 To add or remove fonts from a font 
stack, select the font and click the 
arrow buttons between the Chosen 
fonts and Available fonts lists.

>	 To add or remove a font stack, select 
it and click the plus (+) or minus (–) 
button at the top left of the dialog.

>	 To add the name of a font that is not 
installed on your system, type the font 
name in the text field below the Avail-
able fonts list and click the left-facing 
arrow button to add it to the group.

>	 To move a font group up or down in 
the list, select it from the Font list box 
and then click the arrow buttons at 
the top right of the dialog.

4. Click Done to accept your changes.

G Use the Manage Fonts dialog to create, modify, 
or remove font stacks.
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Adding Automatic 
Dates
Dreamweaver can insert the current date 
and time in a variety of formats into your 
webpage. You can choose whether or not 
to add the day of the week.

To insert the current date:
1. Click in your page to place the inser-

tion point where you want the date 
to appear.

2. Choose Insert > Date.

The Insert Date dialog appears A.

3. Do one or more of the following:

>	 If you want the name of the day to 
appear, use the Day format pop-up 
menu to set the appearance of the 
day of the week.

>	 Make a selection from the Date 
format list.

>	 If you want the time to appear, 
choose the 12-hour or 24-hour format 
from the Time format list.

>	 Select “Update automatically on 
save” if you want that to happen. This 
is very useful if you want visitors to 
your site to know when the page was 
last updated.

4. Click OK.

Dreamweaver inserts the date (and 
any additional items you chose) into 
your page.

A Dreamweaver lets you insert dates into your 
pages in a variety of formats.
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Finding and Replacing
Dreamweaver’s Find and Replace feature 
can save you a lot of time, because you 
can automatically find and change text on 
a single page, in pages within a folder, on 
pages you select, or throughout your site. 
You can choose to change text in Design 
view, or you can search and change just 
in Code view.

Imagine that you have a company’s site 
with dozens of pages devoted to sing-
ing the praises of its premier product, the 
amazing WonderWidget. Then one day 
you get a call from your client letting you 
know that because of a trademark dispute, 
the company has to rename the product 
WonderThing. Rather than opening each 
page and making one or more changes on 
each of them, just put Dreamweaver’s Find 
and Replace feature to work, and you’ll be 
done in just a few minutes.

The Find and Replace window
The Find and Replace window, which you 
open by choosing Edit > Find and Replace 
or by pressing Ctrl-F (Cmd-F), will be the 
tool you use for changing text A. Let’s 
look at some of this window’s parts.

A The Find and Replace dialog provides a lot of power for making quick changes 
on a single page or throughout your site.

Find in pop-up menu

Search pop-up menu

Find field

Replace field

Search options

Save Query Load Query
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n	 The Find in pop-up menu allows you 
to tell Dreamweaver the scope of the 
search. You can choose to find text in 
the Current Document (the default); in 
Selected Text; in Open Documents; in 
a Folder you select; in Selected Files in 
Site; or in the Entire Current Local Site.

n	 The Search pop-up menu lets you 
choose what kind of search you want 
to do. You can choose Text; Text 
(Advanced), which gives you additional 
search options; Source Code, which 
allows you to search in the HTML; or 
Specific Tag, which searches the con-
tents of HTML tags that you select. The 
latter two options are covered later in 
this chapter.

n	 The Find field is where you enter the 
text you want to find.

n	 The Replace field is where you enter 
the text you want to use to replace the 
found word.

n	 The Save Query button allows you to 
save searches for later use. This is great 
for instances where you create complex 
queries, so you don’t have to do all the 
work to set up the search again.

n	 The Load Query button allows you to 
retrieve a saved search.

n	 The Search options let you constrain 
your searches. “Match case” returns 
results with the same uppercase and 
lowercase letters as the text you 
entered in the Find field. “Match whole 
word” finds the text only if it matches 
one or more complete words. “Ignore 
whitespace” tells Dreamweaver not 
to pay attention to additional spaces 
and non-breaking spaces. It’s on by 
default, and it’s usually best to leave 
it on. Finally, “Use regular expression” 
(covered later in this chapter) lets you 
use wildcard characters to construct 
extremely complex searches.
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Finding Text with 
a Simple Search
Simple searches in Dreamweaver work 
pretty much the same way that they do in a 
word processor. Just enter the text you want 
to find and the text that you want to replace 
it with, and away you go. Of course, you 
don’t have to replace text; if you want you 
can just use the Find and Replace dialog to 
find text in one or more files.

To find text:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears 
(see A in the previous section).

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, 
choose Text.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. Click the Find Next button.

Dreamweaver finds and highlights the 
found text. If the scope of the search 
included more than one page, Dream-
weaver opens the first file the text was 
found within and highlights the text. If 
the text isn’t found, you’ll get a mes-
sage to that effect at the bottom of the 
Find and Replace dialog.

or

Click the Find All button.

Dreamweaver does the search, closes 
the Find and Replace dialog, and opens 
the Search tab of the Results panel A.

6. If you clicked Find All in step 5, double-
click one of the search results in the 
Results panel to open it and highlight 
the found text.

A The Search tab of the Results panel shows you the filename and 
matched text when you click the Find All button.

Reopen Find and Replace with same search items

Cancel currently running search
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 If you select some text before you bring 
up the Find and Replace dialog, the text auto-
matically appears in the Find field, as long as 
you selected fewer than 255 characters.

 You can do a quick find on the current 
page by selecting some text and then choos-
ing Edit > Find Selection or pressing Shift-F3 
(Cmd-Shift-G). Dreamweaver highlights the 
next occurrence of the text you selected.

 You can click the green triangle button 
in the Results panel to reopen the Find and 
Replace dialog with the same search terms.

 If you have a search that’s running for 
a very long time, you can cancel it by click-
ing the octagonal red Cancel button in the 
Results panel (this button is dimmed in A).

 You can clear the search results in the 
Results panel by right-clicking in the panel and 
choosing Clear Results.

To find the next result:
Choose Edit > Find Next, or press 
F3 (Cmd-G).

Dreamweaver finds and highlights the next 
result of the search without reopening the 
Find and Replace dialog.

To find and replace text:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, 
choose Text.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. In the Replace field, type the replace-
ment word or phrase.

6. Click the Find Next button.

When Dreamweaver finds the text, 
it is highlighted.

continues on next page
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7. Click the Replace button.

Dreamweaver replaces the found text 
with the contents of the Replace field.

or

Click Replace All.

Dreamweaver warns you that you can-
not undo changes made in unopened 
files. Of course, you can undo changes 
in any open documents by choosing 
Edit > Undo. If you still want to make the 
changes, click Yes.

Dreamweaver searches through the 
entire scope of the search, replacing 
all occurrences of the found text. When 
it is done, you’ll see a message telling 
you how many changes it made.

Use a Replace operation to expand 
abbreviations and save time while 
you’re creating pages. For example, 
let’s say that you’re creating a website 
about JavaScript. Rather than typing 
JavaScript again and again while writing 
the site, just type “JS”; then before you 
upload the site, do a Find and Replace, 
changing every occurrence of “JS” to 
“JavaScript.” You can do the same thing 
with company names, people’s names, 
or almost any text that you repeat a lot.

 Dreamweaver does not update the 
Search tab of the Results panel when you 
perform Replace operations.

 If you get a bunch of search results but 
only want to make replacements in some 
of those results, you can do that—and save 
a bunch of time in the process. Rather than 
opening each page separately and apply-
ing the replacement, do it all in one swoop 
by using the Results panel and the Find and 
Replace dialog together. First, click the green 
triangle in the Results panel, which reopens 
the Find and Replace dialog. In the Results 
panel, Ctrl-click (Cmd-click) the results where 
you want to make replacements. Those lines 
will highlight. Then switch back to the Find 
and Replace dialog, and click Replace (not 
Replace All). The files that are modified are 
marked by a green dot next to their names in 
the Results panel.
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Performing Advanced 
Text Searches
An advanced text search allows you to 
do a more precise search by looking for 
text within (or outside of) particular HTML 
tags. You can further fine-tune the search 
by specifying particular attributes of the 
HTML tags.

Perhaps the most common example of why 
you would want to use such a search lies in 
the title of your webpages. Whenever you 
create a new page in Dreamweaver, the 
page automatically gets the title “Untitled 
Document.” If you forget to enter titles, you 
could end up with a bunch of pages on 
your site with the same “Untitled Docu-
ment” name (it’s easy to do; while writing 
this section, I found and fixed a page on my 
personal site that had been titled “Untitled 
Document” for four years!). A basic search 
and replace won’t help, because “Untitled 
Document” is within the <title> tag of the 
pages, and a basic search only searches 
the body of a document. An advanced text 
search, which combines text and HTML 
searches, is the solution.
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To perform an advanced text search:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
Text (Advanced).

The dialog changes and adds the 
option to search tags A.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. Choose either Inside Tag or Not Inside 
Tag from the pop-up menu next to the 
+ and – buttons.

Inside Tag refers to text that is enclosed 
within a container tag, such as <p>…</p>.

6. Choose an HTML tag from the Tag 
pop-up menu.

A The Text (Advanced) option allows you to search for text within HTML tags.

Tag pop-up menu
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7. (Optional) If you want to narrow the 
search further by limiting the search 
to a particular attribute of the tag you 
chose in step 6, click the + button. If you 
do not, skip to step 12.

The attribute line is added to the 
dialog B.

An example of an attribute would be 
the class attribute of the <table> tag.

8. (Optional) From the first pop-up menu in 
the attribute line, choose With Attribute 
or Without Attribute.

9. (Optional) Choose the attribute you 
want from the next pop-up menu.

Dreamweaver only shows the attributes 
for the tag you chose in step 6.

B You can narrow your search further by adding one or more attributes 
to the tag search.

10. (Optional) Set a comparison in the next 
pop-up menu, choosing from = (equal), 
< (less than), > (greater than), or != (not 
equal). These only work if the attribute’s 
value is a numeric amount, such as the 
size attribute of the <input> tag—for 
example, <input size="4">.

11. (Optional) In the next field (which is also 
a pop-up menu), type the value of the 
attribute. This can be a number or text.

or

Choose [any value] from the pop-up 
menu. This is useful when you want 
all tags with a particular attribute, but 
you don’t care what the value of the 
attribute is.

12. If you want to replace the found text, 
type the replacement word or phrase 
in the Replace field.

13. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.
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Finding and Replacing 
in Source Code
Dreamweaver’s ability to find and replace 
within the HTML source code is extremely 
powerful. You can look for text within par-
ticular tags, and you can even look within 
particular tags for specific attributes. You 
can also find text relative to other tags. For 
example, you can change specified text 
within a <table> tag and leave everything 
else alone. If you like, you can even use 
Find and Replace to replace, delete, or 
change tags and attributes.

Searching and replacing inside source 
code is much like regular text searches 
except you’ll be working in Code view. 
When you perform the search, Dream-
weaver automatically changes to Code 
view, so you don’t have to do it manually 
before you start the search.

To find and replace in source code:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
Source Code A.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. In the Replace field, type the replace-
ment word or phrase.

6. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

A Choose Source Code to search the HTML in 
Code view.

 If you choose Current Document from 
the Find in pop-up menu, searches will not 
search related files, such as attached CSS 
or JavaScript files. To include those in your 
search scope, choose Open Documents in the 
Find in pop-up menu.
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Finding and Replacing 
with a Specific Tag
A specific tag search lets you find and 
modify HTML tags. This has many uses; for 
example, you may still need to convert old 
sites that used <font> tags to CSS. You 
can use a specific tag search to strip out 
all those old tags, replacing them with CSS 
classes. Or you can change the now-passé 
<b> and <i> tags to their more modern 
equivalents, <strong> and <em>.

The key to the specific tag search is the 
Action menu, which specifies what replace-
ment action Dreamweaver will carry out on 
the tags found in the search. See Table 4.5 
for a list of the actions available.

TAbLe 4.5 Action Menu Options

Action Description

Replace Tag & Contents Replaces the tag and everything within the tag with the contents of the 
field that appears to the right of the Action pop-up menu when this action is 
selected. This can be either plain text or HTML.

Replace Contents only Replaces the contents of the tag with the contents of the With field.

Remove Tag & Contents Deletes the tag and all of its contents.

Strip Tag Replaces the contents of the tag with the contents of the With field.

Change Tag Substitutes one tag for another.

Set Attribute Changes an existing attribute to a new value, or adds a new attribute.

Remove Attribute Removes an attribute from a tag.

Add Before Start Tag Inserts text or HTML before the specified tag.

Add After Start Tag Inserts text or HTML after the specified tag.

And After End Tag Inserts text or HTML after the closing tag.

Add Before End Tag Inserts text or HTML before the closing tag.
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To find and replace within 
a specific tag:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
Specific Tag.

The Find and Replace dialog changes 
to show the tag functions A.

4. Choose the tag that you want from the 
tag pop-up menu that appears next to 
the Search pop-up menu.

You can either scroll the pop-up menu 
to find a tag, or you can type the first 
letter of the tag in the box. Dream-
weaver automatically scrolls the list. 

A When you are searching within a specific tag, you can add attributes 
for that tag, and you can also specify actions that you want to perform 
on the found tag.

Depending on the tag you choose, 
Dreamweaver will change the available 
actions in the Action pop-up menu, so 
don’t be surprised if the contents of that 
menu look a bit different from those 
listed in Table 4.5.

5. (Optional) If you want to narrow the 
search to a particular attribute of the tag 
that you selected, click the + button and 
then choose values for that attribute, as 
discussed previously in this chapter.

If you want to narrow the search further, 
you can do so by clicking the + button 
and adding attributes.

6. Choose from the Action pop-up menu, 
and depending on the action you 
chose, set any required values.

7. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.
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Using Regular 
expressions for 
Searching
A regular expression is a pattern, writ-
ten using special symbols, that describes 
one or more text strings. You use regular 
expressions to match patterns of text, so 
that Dreamweaver can easily recognize 
and manipulate that text. Like an arith-
metic expression, you create a regular 
expression by using operators—in this 
case, operators that work on text rather 
than numbers.

The operators in a regular expression 
(see Table 4.6, on page 129) are like the 
wildcard symbols that you may have seen 
in find and replace features in other pro-
grams, such as word processors, except 
that regular expressions are much more 
powerful. They can also be complex and 
difficult to learn and understand, so if 
Dreamweaver’s other find and replace 
methods are sufficient for you, you may not 
need to bother with regular expressions.

Learning regular expressions is beyond 
the scope of this book, but we’ll show you 
how to use one in an example. Let’s say 
that you want to find all of the HTML com-
ments throughout your site. You can use 
this simple regular expression (we know 
it looks weird, but don’t lose heart; all will 
be explained):

<!--[\w\W]*?-->

Let’s break down that expression. You read 
a regular expression from left to right. This 
one begins by matching the beginning 
characters of the HTML comment, <!--. 
The square brackets indicate a range of 
characters; for example, [a-z] would match 
any character in the range from a to z. In 
this case, the range includes two regu-
lar expression operators: \w means “any 
single letter, number, or the underscore,” 
and \W means “any character other than 
a letter, number, or underscore.” Taken 
together as a range, [\w\W] means “any 
character.”

The * means “the preceding character 
(in this case, everything found by the 
contents of the square brackets) zero or 
more times,” and the ? means “the pre-
ceding character zero or one time.” Taken 
together, they match a comment of any 
length. The regular expression ends by 
matching the closing characters of an 
HTML comment, -->.



128 Chapter 4

To search with a regular expression:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
any of the options.

In this case, since we’re looking for 
HTML comments, you should choose 
Source Code.

4. Enter the regular expression in the Find 
field A.

5. Select the check box next to “Use regu-
lar expression.”

When you choose “Use regular 
expression,” it disables the “Ignore 
whitespace” search option, because 
they are mutually exclusive.

6. (Optional) Enter text or a regular expres-
sion in the Replace field.

7. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

 There’s a lot to say about regular expres-
sions, certainly enough to fill an entire book or 
12. If you’re interested in learning more, check 
out Mastering Regular Expressions by Jeffrey 
Friedl (O’Reilly Media, 2006). For a lighter 
read, try Teach Yourself Regular Expressions in 
10 Minutes by Ben Forta (Sams, 2004). There 
are also many websites that provide regular 
expression tutorials, which you can find with 
a web search.

A You can add regular expressions to both the 
Find and Replace fields.
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TAbLe 4.6 Regular Expression Special Characters

Character Matches

\ Escape character; allows you to search for text containing one of the below special 
characters by preceding it with the backslash

^ Beginning of text or a line

$ End of text or a line

* The preceding character zero or more times

+ The preceding character one or more times

? The preceding character zero or one time

. Any character except newline

\b Word boundary (such as a space or carriage return)

\B Non-word boundary

\d Any digit 0 through 9 (same as [0-9])

\D Any non-digit character

\f Form feed

\n Line feed

\r Carriage return

\s Any single whitespace character (same as [ \f\n\r\t\v])

\S Any single non-whitespace character

\t Tab

\w Any letter, number, or the underscore (same as [a-zA-Z0-9_])

\W Any character other than a letter, number, or underscore

[abcde] A character set that matches any one of the enclosed characters

[̂ abcde] A complemented or negated character set; one that does not match any of the 
enclosed characters

[a-e] A character set that matches any one in the range of enclosed characters

[\b] The literal backspace character (different from \b)

{n} Exactly n occurrences of the previous character

{n,} At least n occurrences of the previous character

{n,m} Between n and m occurrences of the previous character

() A grouping, which is also stored for later use

x|y Either x or y
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Checking Spelling
No word processor comes without a spell-
ing checker these days, and Dreamweaver 
is no different (even though it’s not a word 
processor). You can check the spelling on 
the currently open page and add words 
to Dreamweaver’s spelling checker in a 
personal dictionary.

To spell-check your page:
1. Choose Commands > Check Spelling, 

or press Shift-F7 (same on Windows 
and Mac).

If Dreamweaver finds a word it believes 
is spelled incorrectly, the Check Spell-
ing dialog opens A. Otherwise, you’ll 
get a dialog that says “Spelling check 
completed.”

2. Click the Add to Personal button if the 
word Dreamweaver found is correct 
and you want to add it to your personal 
dictionary so that Dreamweaver doesn’t 
flag it as an error again.

or

Click Ignore to tell the spelling checker 
to ignore this instance of the word, 
or click Ignore All to ignore the word 
throughout the document.

or

Select a replacement from the Sug-
gestions list, or type the replacement 
in the Change to text box. Then click 
the Change button, or click Change 
All to replace the word throughout 
the document.

3. When the spelling check is finished, 
click Close.

A Click Add to Personal in the Check Spelling 
dialog to add an unknown word to the user’s 
personal Dreamweaver dictionary.
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accessibility
and alternate text for images, 63, 132, 134
and new browser windows, 348
preferences, 63, 134, 295

access keys, 295
Accordion widget, 354–358

adding, 354–356
deleting, 358
editing, 357–358
purpose of, 354
styling, 356

Action menu, 125
active links, 77, 78, 210
Add New Server button, 35
Add Selector button, 190, 196
Administer Password dialog, 478
Administer Website dialog, 478
Adobe

BrowserLab, 70
Business Catalyst, 14, 386, 388
cloud-based services, 23
content delivery network, 110
Contribute, 386, 449, 475–478
Creative Cloud (See Creative Cloud)
Creative Suite, 386
Director, 162
Dreamweaver Exchange, 337, 493–494
Dreamweaver resources, 3
Edge Animate tool, 160–161
Edge Code, 430
Edge Web Fonts, 22, 110–112, 430
Exchange, 451, 493
Extension Manager, 493, 495–496
Fireworks, 139, 147, 461
Flash (See Flash)
font names, 107
InContext Editing, 386
InDesign, 161

Index

Symbols
* (asterisk)

for designating required field, 349
in regular expression, 127

# (pound sign)
in anchor name, 179
in file/folder name, 65, 438
in hex value, 209, 227
in id selector, 196, 197, 200, 202, 203–204
in named div, 191

[ ] (square brackets)
in regular expression, 127
selecting in Coding toolbar, 409

_ (underscore)
in file/folder name, 65, 438
in image map name, 181
in image name, 137, 146
preceding target with, 177
in regular expression, 127, 129
in template region name, 389, 390

<!-- --> (comment), in regular expression, 127, 
comment, applying from Coding toolbar, 410

( ) (parentheses), selecting in Coding toolbar, 409
. (period), before class selector, 196, 197
? (question mark), in regular expression, 127
&nbsp; (non-breaking space), 98, 105, 117, 423
/> (ending tag), with code hints, 423
/* */ comment, applying from Coding toolbar, 410
// comment, applying from Coding toolbar, 410
/ (slash), in filename or URL, 65
{ } (braces), selecting in Coding toolbar, 409
2-column fixed layout, 227–228

A
AAC format, 156
absolute links, 172
absolute positioning, 223, 309
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Adobe (continued )
Media Encoder, 164
Muse, 475
online font repository, 109
Photoshop, 461, 464
Typekit, 22, 110
web hosting service, 14
websites, 480–481, 482

Adobe TV, 482
AdSense (Google), 319
Advanced Settings category, 30, 52
advanced text searches, 121–123
a:hover selector, 202, 210
alignment

cell, 276
with HTML, 98–99
shortcut keys, 99
table, 275

alpha value, 209
alternate text, 63, 132, 133–134
Alt text field, 63
Amazon.com, 27
Amazon S3 storage service, 157
anchors, 178–179
Android smartphones, 74
Animate Deployment Package, 161
animations, 160–163, 183
Apache, 376
Appearance (CSS) category, 75, 76, 213
Appearance (HTML) category, 77, 213
Apple

and H.264 codec, 155
and MPEG-4 format, 155
QuickTime (See QuickTime)

Application bar, 5
Application frame, 6–7
Apply Comment pop-up menu, 410
Arrange Panels command, 15
art gallery sites, 211
Assets panel

accessing library items from, 385, 398
accessing templates from, 385, 388, 392, 393
buttons/controls, 136
inserting images from, 136
location of, 14
opening, 392
updating Smart Objects in, 149

asterisk (*), for designating required field, 349
attributes, 198–201
audio codecs, 155, 156
audio files, 154–159
<audio> tag, 156, 424
authentication, 33
Authorize.net, 287
Auto Complete check box, 293
Autocomplete widget, 354, 358–360
Auto Focus text field, 292
automatic dates, 115
Automatic Sync check box, 24
AVI files, 155, 164

B
Background category, CSS Designer panel, 195
background color, 76, 77, 230, 277
background images, 76, 150–151
BBEdit, 431
behaviors, 333–344

adding, 335–336
changing order of, 337
deleting, 337
editing, 336
list of, 334
for specific purposes

inserting jump menus, 345–347
inserting rollovers, 339–341
opening new browser window, 342–344
validating forms, 348–349

Behaviors panel, 14, 335–337, 341, 348
Bezier curves, 365
BlackBerry smartphones, 74
black triangle, 17
<blockquote> tag, 98, 99
blocks, 84
blogging software, 370–371, 483. See also 

WordPress
blogs, 481
<body> tag

and background images, 150, 151
and HTML5 structural tags, 317, 318
and JavaScript Extractor, 432
and library items, 401
selecting page contents with, 12

bold text, 94
book resources, xiv

CSS Detective Guide, The, 486
Designing with Web Standards, Third Edition, 486
HTML5: Up & Running, 287
JavaScript: Visual QuickStart Guide, 337, 353, 486
Mastering Regular Expressions, 128
Styling Web Pages with CSS: Visual QuickProject 

Guide, 486
Teach Yourself Regular Expressions, 128

Border category, CSS Designer panel, 194
border properties, 208
borders

image, 138
table, 263

boxes
floating, 224
positioning, 223

box model, 222, 251
box properties, 207–208
box-shadow property, 74
braces ({ }), selecting in Coding toolbar, 409
breaks, line, 97, 299, 300
Brightness/Contrast dialog, 141–142
broken links, 454–455
Browse for File button, 60, 61, 170
Browse pop-up menu, 40, 42
BrowserLab (Adobe), 70
Browser Navigation toolbar, 11, 382, 383
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browser window, opening new, 342–344
<br> tag, 97
<b> tag, 95
bulleted lists, 100, 102. See also lists
Business Catalyst (Adobe), 14, 386, 388
Button widget, 354

C
Canonical Decomposition setting, 79
captions, xiv, 262
cascade, 205
Cascading Style Sheets, 187. See also CSS
CDNs, 110, 353
cell padding, 263. See also padding
cells. See also tables

defined, 260
merging/splitting, 270
padding/spacing for, 263
selecting, 265
setting properties for, 276–277
wrapping of text in, 273

cell spacing, 263
certificate authorities, 33
CGI, 289
Change All Properties icon, 207
character formatting, 93
Character pop-up menu, 106
charts, importing Excel, 473–474
cheat sheet, keyboard command, 492
check boxes, 297
Check In/Check Out feature, 437, 442–444, 451
Check Spelling dialog, 130
Choose Root Folder dialog, 29
Chrome (Google)

and code hinting, 424
and CSS-based layouts, 258
and H.264 video, 155
and HTML5 video, 156
previewing pages in, 67
and Theora codec, 156
and WebKit, 10, 74

classes
applying, 198–199
applying multiple, 201
creating, 196, 215
removing, 199, 200
renaming styles for, 238
vs. ids, 197

Class field in Property inspector, 137
Class pop-up menu, 238
Clean Up Word HTML command, 471
Cloak command, 52
cloaking files/folders, 52, 388
“Close Window” script, 344
cloud-based services, 23
CMSs, 369–384

back-end administrative interface for, 378
connecting to, 374–375
discovering related files in, 378–379
Dreamweaver support for, 27, 369, 370
how they work, 370, 378

installing, 370
meaning of acronym, 369
most popular, 369–373
purpose of, 369
recommended websites on, 482–483

Coda 2 (Panic), 377, 430, 431
code

collapsing, 419–421
editing, 407, 412–413, 418
expanding, 421
extracting embedded, 432–433
finding and replacing, 124
formatting, 413
highlighting invalid, 410
hinting, 74, 422–427 (See also code hints)
how this book presents, xiv
indenting, 412
validating, 434–436
viewing

in Code view, 408–411
in Live Code view, 416–417
in Split view, 414–415

Code Coloring preferences, 412
codecs, 155–156
code editors, alternative, 430–431
Code Format option, 413
code hints, 422–427

for CSS, 424
for DOM elements, 426–427
for HTML, 422–423, 424
for jQuery, 425
for PHP, 423

Code inspector, 428–429
Code Inspector panel, 14
Code Navigator, 218, 219–220, 233
code snippets. See snippets
Code view

finding and replacing code in, 124
how pages appear in, 9
opening HTML files in, 411
reasons for using, 407
using Coding toolbar in, 408–411

Coding toolbar, 220, 408–411, 412, 415
collaboration features, 437
Collapse to Icons button, 15
collapsing code, 419–421
color

background, 76, 77, 230
reducing opacity of, 209
values, 227, 230

color property, 209
columns. See also tables

deleting, 274
inserting, 268–269
resizing, 272
selecting, 264–265

commands, keyboard, xiv
Commands menu, 493
comments, code, 127, 410
Common category, Insert panel, 16, 59, 260
community websites, 371, 372, 373
Compact workspace, 16, 19
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companion website, this book’s. 
See dreamweaverbook.com

compound selectors, 202
compression, audio/video, 155–156
computer monitors, layouts for, 22
Conflict Resolution menu, 24
conflicts, style rule, 205
containers, 84, 154–155, 187, 191
container tags, 84
content delivery networks, 110, 353
content management systems, 369. See also CMSs
content vs. presentation, 186–187, 258, 321
context menu, Files panel, 43
context menus, xv, 86
contextual selectors, 202–204
Contribute (Adobe), 386, 449, 475–478
Contribute 3 Essential Training, 485
Control-clicking, xv
Convert Inline CSS dialog, 240–241
Convert Inline CSS to Rule command, 240
Copy command, 45, 86
copying and pasting, 86, 145–147
corporate websites, 372, 373
Create a New CSS File dialog, 243
Creative Cloud (Adobe)

and Business Catalyst, 386
and code editors, 430
and Contribute, 475
and Dreamweaver, 21–22
and Fireworks, 465
and Flash video, 164
membership, 21, 386
settings synchronization, 22, 23, 459

Creative Edge, 485
Creative Suite (Adobe), 386
cropping images, 140
C setting, 79
CSS. See also styles; style sheets

benefits of using, 186, 187
box model, 21, 222, 251
code editor, 430
code hints for, 424
content vs. presentation, 186–187, 258
debugging, 252
enable/disable rules feature, 25
extracting from style sheet, 433
how this book presents, xiv
and HTML tags, 187
Inspect mode, 248–249
layout basics, 222–224
layout blocks, 256
recommended books on, 486
setting appearance properties with, 76
setting heading options with, 79
setting link properties with, 78
setting preferences for, 188
shorthand properties, 188, 227
transitions, 362–368

CSS3 standard, 209
CSS3 support, 22

CSS-based layouts
and CSS inspection, 248
and design-time style sheets, 253
purpose of, 307
redesigning, 258
vs. table-based layouts, 258–259

CSS Designer panel
attaching style sheet in, 244–245
benefits of using, 187
buttons/controls, 189
categories, 192–195
creating style rule for tags in, 190–191
and CSS3 standard, 209
deleting styles in, 239
formatting links in, 210–211
laying out pages in, 228–229
modifying styles in, 216
purpose of, 186
renaming styles in, 238
as replacement for CSS Styles panel, 21, 187, 209
style definitions in, 195
using CSS Enable/Disable in, 252
working in 2-column view in, 206

CSS Detective Guide, The, 486
.css file extension, 205, 243
CSS Inspect mode, 11
CSS Layout Backgrounds option, 251
CSS Layout Outlines option, 251
CSS Properties pane, 206–209
CSS Styles panel, 21, 187, 209
CSS tab, Property inspector, 13, 107, 212
CSS Transitions panel, 14, 363
Custom Filter dialog, 381
custom font stacks, 114
Cut command, 45, 86
cutting and pasting, 86

D
database-backed sites, 27, 32
database programs, 376
Datepicker widget, 354, 360–361
dates, 115
debugging tools, 252
Define Media Query dialog, 321–324
definition lists, 100, 101
Delete command, 45
delimited text files, 281, 284
dependent files, 47
descendant selectors, 202
descriptions, site, 81, 82
Designing with Web Standards, Third Edition, 486
Design Notes, 447–449
design-time style sheets, 253–256
Design view, 9, 55, 67, 85, 86
Design View command, 10
Desktop layout, 331
DesktopServer, 377
Developer Center, Dreamweaver, 71, 481
dimensions, setting page, 315–316
Direction pop-up menu, 50
Director (Adobe), 162
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Disable CSS Property icon, 252
Disable JavaScript command, 384
div elements, 191
div tags vs. structural tags, 317
dock area, 14
dock header bar, 14, 15
DocType pop-up menu, 57
doctypes, 57, 79
Document Options preferences, 7
document relative links, 172, 174
Document toolbar, 8
Document Type Definition, 57, 79
document views, 9–11
document window, 6–7, 12, 19, 307
Dojo, 352
DOM elements, code hints for, 426–427
Down state, 341
dragging and dropping

styles, 246–247
text, 87

Dreamweaver
adding extensions to, 4, 487, 493–496
and alternative code editors, 430
assigning external editors in, 462–464
built-in JavaScript actions, 333–334  

(See also behaviors)
and cloud-based services, 23
and CMSs, 369, 370 (See also CMSs)
collaboration features, 437
customizing, 487–492
Developer Center, 71, 481
document window, 6–7
editing images in, 465
event handlers, 338
Exchange, 337, 493–494
extensions, 27
file/folder terminology, 26–27
file management with, 43
frameworks, 351
getting the most from, xiv
importing Excel data to, 281–283
integration with other programs, 461–478
interface, 2–17
learning to use, xiii–xiv
mailing list, 484
menu bar, 5
modern vs. “old school” features, xiii–xiv
naming conventions, 390
new features in CC, 21–22, 286, 317, 354
online resources, 479–485
platform considerations, xv
purpose of, xiii, 1
setting up workspace in, 18–20
site management tools, 385 (See also website 

management)
synchronizing settings for, 23–24
tutorials, 3, 482
W3C validator, 434–436
and web standards, 22
Welcome screen, 2–4
widgets library, 351

dreamweaverbook.com, xv, 479

Dropbox, 157
Drupal, 27, 369, 373, 423, 483
DTD, 57, 79
Duplicate command, 45
duration setting, transition effect, 365
DV files, 164
.dwt file extension, 388
dynamically related files, 378–380
dynamic media, 131
dynamic pages, 436
dynamic sites, 27

E
e-commerce sites, 27, 211
Edge Animate Composition button, 161
Edge Animate tool (Adobe), 160–161
Edge Code (Adobe), 430
Edge Web Fonts (Adobe), 22, 110–112, 430
editable optional regions, 391
editable regions, 387, 389–391
Edit Browser List command, 69
Edit Guides command, 311
editing

behaviors, 336
browser list, 69
code, 407, 412–413
files/folders, 45
Flash video files, 166
images, 139–142, 147
jump menus, 346
library items, 399–401
plug-in file’s properties, 168
preset window sizes, 316
property values, 216
site definitions, 38
snippets, 406
templates, 394–396

editing programs, 462–469
Edit menu, 45, 86, 88, 441
Editor setup, 4
effects, 352
elastic layout, 226
email, contacting authors via, xv
email form field, 291, 349
email links, 184
emphasis tags, 94, 95. See also <em> tag
<em> tag, 13, 95, 212
Enable Automatic Sync check box, 24
enclosure types, 290
encodings, 75, 79
encoding services, 157
encryption, 32, 33
Enctype option, 290
EOT format, 113
event handlers, 338
Excel (Microsoft), 85, 88, 281–283, 461, 471, 472–474
Exchange (Adobe), 337, 451, 493–494
Expand/Collapse button, 48, 438
Expanded Tables mode, 266–267
Expanded workspace, 19
expanding code, 421
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explicit encryption, 32, 33
exporting

site definitions, 459–460
tables, 284

Export Site dialog, 460
Export Table dialog, 284
Extension Manager (Adobe), 493, 495–496
extensions

Dreamweaver, 4, 27, 487, 493–496
file, 45, 65

external editors, 462–464, 465
external links, 456
external styles, 205
external style sheets

attaching to webpage, 244–245
creating, 241, 242–243

F
fallback files, 158, 159
FAQ, xv
favicons, 152–153
Favorites category, Insert panel, 17
fields. See also forms

adding, 291–293
hidden, 293
labeling, 294–295

fieldsets, 298
figure captions, xiv
file associations, 4
file extensions, 45, 65
file formats

audio/video, 154–159, 164
container, 155
graphics, 135

file management, 43. See also website management
File menu, 66
filenames, 65
files

adding/deleting, 39
annotating, 447–449
browsing, 40
checking in/out, 47, 445–446
cloaking, 52, 388
comparing local/remote, 48
creating, 43–44
finding orphaned, 456
locking/unlocking, 33
moving, 44
naming, 44, 45, 438
organizing, 43
putting/getting, 46–47
working with related, 217–218

Files panel
context menu in, 43, 44
expanding, 48, 439–441
opening pages in, 66
purpose of, 39, 43
putting/getting files with, 47
selecting multiple files in, 441
vs. New Document dialog, 43

file transfer clients, 430
File Transfer Protocol, 33. See also FTP
File Types/Editors preferences, 4, 462–463
File view pop-up menu, 41, 44
Filter Related Files menu, 381
Find All button, 119
Find and Replace dialog, 116–117, 122
Find and Replace feature, 116–129

advanced text searches with, 121–123
buttons/controls, 116–117
purpose of, 116
regular expression searches with, 127–129
simple text searches with, 118–120
source code searches with, 124
tag searches with, 125–126

Find in pop-up menu, 117
Find Next button, 119
Find Selection command, 119
Firefox (Mozilla)

and CSS-based layouts, 258
and favicons, 152
and H.264 codec, 155
and <label> tag, 294
and MPEG-4 format, 155
previewing pages in, 67
and Theora codec, 156

Fireworks (Adobe)
copying and pasting images with, 147
and Creative Cloud, 465
editing images with, 139, 465–469
exporting HTML to Dreamweaver from, 467
future of, 465
integration of Dreamweaver with, 461
opening, 464

Fit All command, 314
Fit Width command, 314
fixed layout, 226, 227
fixed positioning, 223
.fla file extension, 162
Flash (Adobe)

animation, 162–163
and H.264 codec, 155
video, 154–155, 156, 164–166
vs. image maps, 183

Flash Player, 162
flattened images, 147
floating boxes, 224
fluid grid layouts, 22, 325–332
.flv file extension, 154, 156, 164
folders

browsing, 40
cloaking, 52, 388
comparing local/remote, 48
creating, 43–44
moving, 44
naming, 29, 44, 45, 438
planning structure of, 438
putting/getting, 46–47

Follow Links Continuously option, 383
font-face property, 74
font family pop-up menu, 107
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font-family property, 74, 107, 108, 109
@font-family rule, 109
Font menu, 110
font names, 107
Font pop-up menu, 107
fonts, 107–114

adding to font list, 112
applying styles to, 108
how browsers display, 107
for links, 78
online sources of, 109
operating-system considerations, 108
previewing, 112
using web, 22, 109–114
for webpages, 76

font size, 76, 78, 79
font stacks, 107, 108, 114
font styles, 107–108
<font> tag, 93, 212, 222
font weight pop-up menu, 107
footers, 230
Format menu, 91, 92, 99, 253
Format Source Code pop-up menu, 411
formatting

code, 413
links, 210–211
tables, 280
text, 59

Form category, Insert panel, 16, 286
form fields. See fields
forms, 285–306

adding buttons to, 304–306
adding check boxes to, 297
adding fieldsets to, 298
adding pop-up menus to, 301–302
adding radio button groups to, 299–300
adding scrolling lists to, 303
adding text areas to, 296
adding text fields to, 291–293
adding to pages, 288–290
creating with Insert panel, 286–287
designating required fields in, 349
labeling fields in, 294–295
naming, 289
purpose of, 285, 288
red border around, 290
server-side handling of, 287
validating, 348–350

Forms category, Insert panel, 286
form services, online, 287
Formstack, 287
<form> tag, 290
Forta, Ben, 128
forums, 481
frames, 135, 138, 177
framesets, 138
frameworks, 351, 352–353
Freeze JavaScript command, 384
Friedl, Jeffrey, 128
FTP, 32, 33, 34–36, 157
FTPS, 33

G
Get button, 51
GET method, 290
getting files/folders, 46–47
GIF files, 135, 143, 144, 469
Git code repository, 450
Go button, 347
Google

AdSense ads, 319
Checkout, 287
fonts, 109, 110
and headings, 90
and jQuery, 353
web browser (See Chrome)
and WebM standard, 155

Go To URL dialog, 335
government websites, 372
graphic formats, 135
graphics. See also images

adding links to, 180
copying and pasting, 89
overuse of, 131

Gravity Forms, 287
grid layouts, 22
grids, 308–309. See also fluid grid layouts
Grid Settings dialog, 309
group selectors, 202
guides, 310–312

H
H.264 codec, 155
hard returns, 412
hash sign. See pound sign
headers, 230
headings, 90–92

applying, 91
purpose of, 90
removing formatting from, 92

Headings (CSS) category, 79, 214
<head> tag, 75, 81
hex color values, 209, 227, 230
hidden fields, 293
hidden files, 441
Hide Panels command, 15
History panel, 14
host directory, 36
hotspots, 181–183
hover selector, 202, 210
hover style, 232, 233
.htm/.html file extension, 45
HTML. See also HTML5

aligning text with, 98–99
applying page properties with, 77
for bold/italic, 95
character formatting with, 93
cleaning up Word, 470–471
code editor, 430
code hints for, 422–423
copying and pasting, 86
finding and replacing, 124, 125–126
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HTML (continued )
heading sizes, 90
how this book presents, xiv
indenting text with, 98–99
for non-breaking space, 105
tags (See HTML tags)
text styles, 94–95

HTML5
animations, 183
and audio/video formats, 154–159
code hints, 424
doctypes, 57
form elements, 286–287, 291
form validation, 349, 350
structural tags, 317–318
support, 22

HTML5: Up & Running, 287
HTML Reports category, 452
HTML tab, Property inspector, 13, 212
HTML tags. See also specific tags

applying with Property inspector, 212
creating style rules for, 190–191
and CSS, 187
finding and replacing, 125–126
purpose of, 84, 187

http://, 61
hybrid layout, 226
Hyperlink dialog, 171
hyperlinks, 60–61. See also links

I
.ico file extension, 153
icons

displaying function of, 17
shrinking panels to, 15
in website address bar, 152–153

id attribute, 294
applying, 198–199, 200
creating, 178, 196
deleting, 179
importance of, 179
linking to, 179
moving, 200
naming, 196
vs. classes, 197

ID field in Property inspector, 137
IE. See Internet Explorer
iframes, 319–320
image buttons, 305
image editing programs, 139, 447. See also specific 

programs
image folders, 438
image formats, 135, 143
image maps, 138, 181–183
Image Optimization dialog, 143, 147, 474
Image Preview dialog, 147
images, 131–151. See also graphics

adding alternate text to, 63, 132, 133, 134
adding borders to, 138
adding links to, 180

adding to pages, 62–63, 132–134
adjusting brightness/contrast of, 141–142
background, 77, 150–151
copying and pasting, 145–147
creating folders for, 30, 438
cropping, 140
deleting, 134
editing, 139–142, 147, 465–469
inserting from Assets panel, 136
maintaining layers in, 147
naming, 137
optimizing, 143
resampling, 141
resizing, 141
rollover, 339–341
setting properties for, 137–138
sharpening, 142

image states, 341
Image Tag Accessibility Attributes dialog, 63, 134
implicit encryption, 32, 33
importing

site definitions, 459, 460
Word documents/data, 85, 283

Import Site dialog, 460
Import Tabular Data dialog, 282
Include Unicode Signature (BOM) option, 79
InContext Editing (Adobe), 386
Indent Code button, 411, 412
indenting

with Coding toolbar, 412
with HTML, 98–99

InDesign (Adobe), 161
index.html, 54
index page, 26, 31, 54
inherit positioning, 223
inline frames, 319
inline styles, 205, 215, 240–241
Input Tag Accessibility Attributes dialog, 294–295
Insert bar, 17
Insert Date dialog, 115
Insert Other Character dialog, 106
Insert panel

categories, 16–17
creating forms with, 286–287
formatting text with, 59
and HTML markup, 59
Media category, 161
purpose of, 16
Structure category, 318, 325
UI category, 354
vs. Insert bar, 17

Insert Rollover Image dialog, 340, 346
Inspect button, 8, 11
Inspect mode, CSS, 248–249, 380
interactivity, 335, 351, 354, 384
internal styles, 191, 205
Internet Explorer (Microsoft)

and CSS-based layouts, 258
and CSS rendering, 67
and favicons, 153
and H.264 codec, 155
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and HTML5 form elements, 287
and PNG graphics, 135

invisible characters, 97
iOS devices, 159
iPhone screens, 72, 73. See also mobile devices
<i> tag, 95
italicized text, 94

J
Jacobs, Denise R., 486
JavaScript

behaviors, 333–337
code editor, 430
disabling, 384
event handlers, 338
extracting embedded, 432–433
form validation, 289, 350
frameworks, 351, 352
freezing, 384
how this book presents, xiv
and id attribute, 179
libraries, 350
and mobile layouts, 332
recommended book on, 337, 353, 486
and related files, 217

JavaScript Extractor, 432–433
JavaScript library ( jQuery), 22
JavaScript: Visual QuickStart Guide, 337, 353, 486
Joomla, 27, 369, 372, 423, 483
Jordan, Miraz, 483
JotForm, 287
JPEG files, 135, 143, 144, 469
jQuery

code hints for, 425
JavaScript library, 22
opening browser windows with, 344
strengths of, 353
UI category (Insert panel), 17
UI widgets, 17, 22, 354–361

jQuery-based pages, 332
jQuery Mobile

category (Insert panel), 16
JavaScript framework, 332
Swatches panel, 14

Jump Menu dialog, 345
Jump Menu Go dialog, 347
jump menus, 334, 345–347
justifying text, 99

K
keyboard commands, xiv
keyboard shortcuts, xiv, 488–492
Keyboard Shortcuts dialog, 489
keyframes, 160
keywords, 81, 82
KnowIT, 483

L
<label> tag, 294, 295
LAMP, 376–377
layout blocks, 253, 256
Layout category, CSS Designer panel, 192
layouts

CSS-based (See CSS-based layouts)
and CSS box model, 222–224
fluid grid, 22, 325–332
jQuery-based, 332
switching between, 22
using Dreamweaver’s included, 225–226
using tables for, 257, 258–259
workspace, 430

layout tables, 258
layout tools, 307–332

fluid grid layouts, 325–332
grids, 308–309
jQuery, 332
media queries, 321–324
rulers/guides, 310–312
setting page dimensions, 315–316
zooming in on page, 313–314

.lbi file extension, 397

.LCK file extension, 441, 443
Library folder, 397, 402
library items, 397–403

creating, 397
defined, 386
deleting, 398
detaching, 402, 403
editing, 399–401
file extension for, 397
inserting, 398
naming/renaming, 397, 401
and Property inspector, 402–403
re-creating missing/deleted, 403
updating, 400
vs. snippets, 404
vs. templates, 397

line breaks, 97, 299, 300
line numbers, 410, 412
Link field, 60, 61
Link field in Property inspector, 137
Link Relative To, 174–175
links, 169–184

adding to graphics, 180
checking for broken, 454–455
creating, 60–61, 170–171
to email addresses, 184
formatting, 210–211
to id attributes, 179
purpose of, 169
removing, 171
setting color for, 77, 78
to specific places on page, 178–179
targeting, 176–177, 182
types of, 169, 172–173
underlining, 211

Links (CSS) category, 78, 213
<link> tag, 152, 220
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Linux, 108, 376
liquid layout, 226
List Properties dialog, 102, 104
lists, 100–104

creating, 101
nesting, 103–104
scrolling, 301, 303
setting properties for, 102
types of, 100

List Values dialog, 301, 302
Live button, 8
Live Code view, 8, 11, 382, 416–417
Live view

displaying screen sizes in, 72
navigation, 382–383
previewing pages in, 67
purpose of, 10
turning on, 8
using CSS inspection in, 248–249
and WebKit, 74

Live View button, 341
Live View Options menu, 383, 384, 416
Load Query button, 117
Local Info category, 30
local root folder, 26
local site

alternate name for, 26
building pages for, 53
creating, 28–31
displaying contents of, 42
moving items to/from, 46–47
naming, 29
saving pages for, 64–65
switching between remote site and, 41
synchronizing remote site and, 49–51, 396
viewing/changing, 39

local web fonts, 113. See also web fonts
locked regions, 387, 389, 391
Lock Guides command, 312
LoVeHAte mnemonic, 211
L-V-H-A mnemonic, 211
Lynda.com, 485

M
.m4v file extension, 155
Macintosh. See also OS X

and Application frame, 6–7
code editors, 430–431
encodings, 75
expanding Files panel on, 48
font considerations, 108
getting rid of tabs in, 7
keyboard shortcuts, xiv
menu bar on, 5
mouse considerations, xv
previewing pages on, 67, 68
and Submit/Reset buttons, 306
testing server package for, 376

Mac OS Finder, 441
Macromedia, xiii, 350
magnification tools, 313, 314

mailing list, Dreamweaver, 484
Make Template button, 388
MAMP, 376–377
Manage Fonts dialog, 22, 110–114
Manage Sites dialog, 34, 38, 175, 443, 457, 476
Manage Workspaces dialog, 20
Map field, 138
margins, 76, 77, 208
Mastering Regular Expressions, 128
Matroska, 155
Maximize button, 7
Media category, Insert panel, 16
Media Encoder (Adobe), 164
media files, 131, 154–159, 167–168
media queries, 72, 73, 321–324
media query style sheets, 307
menu bar, 5
Menu List option, 102
menus

context, 86
jump, 334, 345–347

<menu> tag, 102
Merge Cells command, 270
<meta> tag, 81, 82
meta tags, 81–82
Method pop-up menu, 290
Microsoft

Excel, 85, 88, 281–283, 461, 471, 472–474
Internet Explorer (See Internet Explorer)
and jQuery, 353
and MPEG-4 format, 155
web-safe fonts, 109
Windows (See Windows systems)
Word (See Word)

.mkv file extension, 155
mobile devices, 16, 72, 74, 159, 321
Mobile layout, 330
Mobile Starters folder, 332
motion paths, 160
mouseovers, 339
Move CSS Rules command, 247
Move Guide dialog, 312
.mov file extension, 155
MP3 format, 156
.mp4 file extension, 155
MP4 format, 156
MPEG-4 format, 155
MPEG format, 164
Multiclass Selection dialog, 201
multimedia content, 154
Muse (Adobe), 475
MySQL, 376, 430

N
named anchors, 179
naming conventions, 390
naming/renaming

buttons, 304
classes, 196
contextual selectors, 203
editable regions, 389, 390
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favicons, 153
files, 44, 45, 438
folders, 29, 44, 45, 438
forms, 289
host directory, 36
ids, 178, 196
images, 137
library items, 397, 401
local site, 29
radio groups, 299
remote server, 35
snippets, 405, 406
styles, 238
webpages, 64–65
workspaces, 20

navigation
creating with Fireworks, 465, 469
laying out, 231–233
Live view, 382–383
modifying, 234–236

navigation bars, 465, 467, 469. See also navigation
nesting

lists, 103–104
tables, 260, 262

Net Applications, 70
netmarketshare.com, 70
New CSS Rule dialog, 187
New Document dialog

changing document defaults in, 57
creating new external style in, 242
creating new page from, 56–57
opening, 3
using included CSS layouts in, 225–226
vs. Files panel, 43
vs. Welcome screen, 56

New Editable Region dialog, 389
new features, 3, 21–22
New File command, 44
New Folder command, 44
New from Template command, 392
New Site command, 28
non-breaking space (&nbsp;), 98, 105, 117, 423
_notes folders, 448
numbered lists, 100, 102. See also lists

O
.oam file extension, 161
Object Tag Accessibility Attributes dialog, 163
.ogg file extension, 155
Ogg standard, 155, 156
.ogv file extension, 155
OK/Submit button, 306
online encoding services, 157
online form services, 287
online magazines, 372, 373
online newspapers, 372
online resources, xv, 479–485
opacity values, 209
Open Browser Window dialog, 343
Open dialog, 66
Opera, 67, 258

operators, 127
Optimize command, 143
optional regions, 391
ordered lists, 100, 101
orientation, screen, 72
orphaned files, 456
OS X. See also Macintosh

expanding Files panel on, 48
Finder, 43
and H.264 codec, 155

Outdent button, 104
Outdent Code button, 411, 412
Over state, 341
OverWhileDown state, 341

P
padding, 191, 208, 236, 263
padlock icon, 442
page dimensions, 315–316
page headers, 230
page properties, 75–80
Page Properties dialog, 75–80

Appearance (CSS) category, 75, 76, 213
Appearance (HTML) category, 77, 213
Headings (CSS) category, 79, 214
Links (CSS) category, 78, 213
names in, 214
Title/Encoding category, 79, 214
Tracing Image options, 80, 214

pages. See webpages
page titles

adding to webpages, 58, 226
changing, 8, 79, 390
importance of, 121
for pages created from templates, 390
purpose of, 58
vs. page names, 64

panel options button, 15
panels, 14–17. See also specific panels

controls for, 14
locating missing, 15
rearranging, 19

Panic Software, 377, 430, 431
paragraph tags, 84, 85, 97, 187
parentheses (( )), selecting in Coding toolbar, 409
password form field, 291
Paste command, 45, 86. See also copying and 

pasting
Paste Special command, 88–89, 283, 470, 471, 472
payment processors, 287
PayPal, 287
period (.), before class selector, 196, 197
Photoshop (Adobe), 139, 144–149, 461, 464
PHP, 54, 370, 376, 423
Pilgrim, Mark, 287
placeholder attribute, 286
placeholders

animation, 163
form field, 286, 292
media file, 164, 167, 168

Place Holder text field, 292
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plug-in media, 167
PNG files, 135, 143, 144, 469
Point to File icon, 60, 170, 180
pop-up menus, 301–302
poster images, 158, 159
POST method, 290
pound sign (#)

in anchor name, 179
in file/folder name, 65, 438
in hex value, 209, 227
in id selector, 196, 197, 200, 202, 203–204
in named div, 191

precedence, style rule, 205
preferences

accessibility, 63, 134, 295
alternate text, 63
bold/italic, 95
browser list, 69
code coloring, 412
code formatting, 413
code hinting, 423, 425
CSS Styles, 188
default document type, 57
document options, 7
field labels, 295
file associations, 4
file saving, 446
file types/editors, 462–463
highlight color, 397
line breaks, 97
links, 173
non-breaking spaces, 105
OK/Submit button, 306
opening files, 411
related files, 218
synchronizing, 23, 24
tabs, 7
Welcome screen, 54
window size, 74, 133, 316

preformatted text, 96
presentation

vs. content, 186–187, 258, 321
vs. structure, 83

presets
window size, 315–316
workspace, 19

<pre> tag, 96
Preview/Debug in Browser button, 68
Preview in Browser submenu, 68, 69
previewing

in browser, 67–70
snippets, 404, 406
using preset screen sizes, 71–74

properties
audio/video, 158–159
border, 208
box, 207–208
cell, 276–277
enabling/disabling, 252
image, 137–138
list, 102

page, 75–80, 77
rule, 220, 252
text field, 292

Property inspector
Accordion controls, 357
adding alternate text with, 63, 134
adjusting Flash video files settings in, 166
adjusting media file settings in, 168
applying CSS styles with, 212
applying HTML tags with, 212
applying multiple classes with, 201
creating classes with, 215
creating inline styles with, 215
creating styles with, 213–214
CSS tab, 13
font styling controls, 107
hiding, 15
HTML tab, 13
image editing tools, 139
purpose of, 13
rearranging, 19
setting audio/video properties with, 158–159
setting image properties with, 137–138
setting text field properties with, 292
setting up forms in, 289–290
styling text with, 212
Validation tab, 434, 435
working on library items with, 402–403

Prototype, 352
PSD files, 144, 147
pseudo-class selectors, 200, 202, 211
<p> tag, 84, 187. See also paragraph tags
Put button, 51
putting files/folders, 46–47

Q
Quicken 2009 for Windows Essential Training, 485
Quick Tag Editor, 418, 428, 430
QuickTime, 155, 164, 167
QuickTime Player, 168

R
radio buttons, 297, 299–300
Radio Group dialog, 299–300
RDS, 32
read-only form fields, 293
Recently Modified dialog, 453
recently opened items, 3
Redo command, 86
regular expressions, 127–129
related files

discovering, 378–379
examples of, 217
filtering, 381
viewing, 218

Related Files toolbar, 11, 217–218, 378, 380, 381, 383
relative positioning, 223
“Relative to” pop-up menu, 174–175
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remote servers. See also remote site
checking in files to, 446
defining, 32–37
naming, 35

remote site
defining, 32–37
displaying contents of, 42
moving items to/from, 46–47
switching between local site and, 41
synchronizing local site and, 49–51, 396
viewing/changing, 39
vs. local site, 27

Remove Template Markup command, 391
Rename command, 45, 238
Rename Style dialog, 238
renaming. See naming/renaming
rendering software, 67, 74
repeating regions, 391
repeating tables, 391
replacing text. See Find and Replace feature
Reports dialog, 453
Repository view, 41
resampling images, 141
Reset button, 304, 305, 306
resizing images, 141
Resolution Management feature, 71, 73
Restore Down button, 7
Results panel, 14
reusable code snippets, 385. See also snippets
reveal strip, 15
Revert command, 451
RGB/RGBA color, 209
right-clicking, xv
RIM BlackBerry smartphones, 74
rollover links, 78, 214, 233
rollovers, 339–341
root folder, 29, 36, 66
rows. See also tables

deleting, 274
inserting, 268, 269
resizing, 272
selecting, 264

rulers, 310, 312
rules. See also style rules

creating from inline style, 240–241
defined, 187
enabling/disabling, 252
moving, 247
viewing properties for, 220

S
Safari (Apple)

and CSS3 code hinting, 424
and CSS-based layouts, 258
and Flash, 183
and H.264 video, 155
and image maps, 183
and Live view, 74
and mobile devices, 73, 183
previewing pages in, 67
and WebKit, 74

Sauce, 70
Save As dialog, 64–65
Save As Template dialog, 388
Save Query button, 117
screen readers, 63, 132
screen sizes

customizing, 74
displaying, 72–73
list of common, 71
previewing using preset, 71–74

<script> tag, 220
Script Warning dialog, 379
scrolling lists, 301, 303
search engines, 81, 82, 90
search feature. See Find and Replace feature
searching

HTML tags, 125–126
with regular expressions, 127–129
source code, 124
text, 118–123

Search pop-up menu, 117, 118
Secure FTP, 32, 33. See also SFTP
Secure Shell protocol, 33
Select File dialog, 171, 174–175
Select form element, 301–303
Select Image Source dialog, 62, 132
Selector Name option, 196
selectors

comma-separated lists of, 202
compound, 202
contextual, 202–204
deleting, 239
descendant, 202
group, 202
types of, 190

Servers category, 34
server-side scripts, 287, 349
Set Text behaviors, 334
settings synchronization, 22, 23–24
SFTP, 32, 33, 34–36
sharpening images, 142
Shockwave animations, 162–163
Shockwave format, 155
shortcut keys, xiv, 45, 99, 488–492
shorthand properties, CSS, 188, 227
Show Grid command, 308
Show Guides command, 310
Show More menu, 380
Show Only Set Properties mode, 206
sidebars, xiv
Silverlight, 164, 167
site definitions, 38, 459–460
site descriptions, 81, 82
site design, 31
site files, 385
site management tools, 26, 385, 437. See also 

website management
Site pane, 28
site reports, 452–453
Site Root button, 66
site root folder, 29, 36, 66, 385
site root relative links, 169, 172, 173, 174
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sites. See websites
site-settings synchronization, 22, 23–24
Site Setup dialog, 476–477

Advanced Settings category, 30, 52
Cloaking category, 52
Local Info category, 30
Local Site Folder field, 29
purpose of, 28, 374
Servers category, 34
Site category, 28
Site Name field, 29

site synchronization feature, 46, 49–51
slash (/), in filenames and URLs, 65
Smart Objects, 144, 148–149
smartphones, 22, 74, 183, 331. See also mobile 

devices
Snap to Grid command, 309
Snap to Guides command, 312
snippets, 404–406

defined, 385
deleting, 406
editing, 406
inserting, 406
inserting recently used, 411
naming, 405, 406
organizing, 406
previewing, 404, 406
saving, 405
updating, 404
vs. library items, 404

Snippets panel, 14, 404–406
Sort Table dialog, 279
source code, 124
Source view, 86
spaces

in button names, 300
in editable region names, 389, 390
in filenames, 65, 137, 146
in id names, 178
non-breaking, 97, 98, 105, 117, 423
in preformatted text, 96
in search queries, 117
in URLs, 65
in window names, 344

spacing, cell, 263
spammers, 184
<span> tag, 191, 200
special characters

in file/folder names, 65, 438
in region names, 390
in regular expressions, 129
in snippet names, 406
in URLs, 65
in webpages, 105–106

spelling checker, 130
Split Cell command, 270
Split Code view, 414
Split Vertically command, 10
Split view, 10, 73, 414–415
Spry, 351, 352

square brackets ([ ])
in regular expression, 127
selecting in Coding toolbar, 409

Src field in Property inspector, 137
SSI files, 217
SSL/TLS, 32, 33
staging servers, 27, 376
Standard toolbar, 12
states, image, 341
static positioning, 223
static sites, 27
Status bar, 12–13
.ste file extension, 459
strikethrough text style, 95
<strong> tag, 95, 212
structural elements, 83, 88, 90
structural tags, 317–318
Structure category, Insert panel, 16, 59, 91, 101, 325
style rules

cascading of, 205
conflicts between, 205
enabling/disabling, 252
moving, 247
for tags, 190–191
viewing properties for, 220

styles. See also CSS; style sheets
applying with Property inspector, 212
creating rules from inline, 240–241
creating with Property inspector, 213–214
deleting, 239
dragging and dropping, 246–247
modifying, 216, 249
moving, 246–247
previewing, 196
renaming, 238
types of, 205
using for layout, 221–236

style sheets. See also CSS
attaching, 244–245
creating external, 242–243
deleting styles from, 239
hiding, 255
media query, 307
using design-time, 253–256

Styling Web Pages with CSS: Visual QuickProject 
Guide, 486

Sublime Text, 431
sublists, 104
Submit button, 304–305, 306
Subversion, 437, 450–451
SVG format, 113
svg property, 74
SVN, 450–451
svn:ignore command, 451
Swap Image Restore behavior, 341
.swf file extension, 155, 156, 162
symbols, 105–106, 127, 191, 381, 423. See also special 

characters
Sync Cloud button, 23
synchronization, settings, 22, 23–24
synchronization feature, 46, 49–51, 396, 459
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Synchronize dialog, 51
Sync Local button, 23
Sync Settings preferences, 24
Sync Status button, 5
syntax coloring, 411, 412
syntax errors, 410
system CGI, 289

T
tab area, 14
tabbed view, 7
Tab Index field, 293, 295
table captions, 262
Table dialog, 260
Table Layout mode, 259
tables, 257–284

adding rows/columns to, 268–269
adding to webpages, 260–262
anatomy of, 263
applying CSS styles to, 280
clearing values for, 273
creating, 260–262
deleting elements in, 274
exporting to delimited files, 284
formatting, 280
as layout device, 257, 258–259
merging cells in, 270
nesting, 260, 262
repeating, 391
resizing, 271–273
selecting elements in, 264–267
setting alignment for, 275
setting cell properties for, 276–277
sorting, 278–279
splitting cells in, 270
vs. preformatted text, 96
ways of using, 257
and web browsers, 273

Tablet layout, 330
tablets, 22
tabs, 7, 15
tabular data, 96, 257, 281–284, 471.  

See also Excel; tables
Tag Editor, 430
tags

creating style rules for, 190–191
and CSS, 187
editing, 418
finding and replacing, 125–126
modifying, 428–429
purpose of, 187
selecting contents of, 12
structural, 317–318

tag searches, 125–126
tag selector, 12
Targeted Rule pop-up menu, 198, 215
Target field, 138
targeting links, 176–177, 182
Target Rule field, 363, 366
Target Rule pop-up menu, 368
Teach Yourself Regular Expressions, 128

Tel (telephone number) form field, 291
templates, 387–396

adding editable regions to, 389–390
building pages based on, 392–393
creating, 387–388
defined, 386
file extension for, 388
modifying, 394–396
purpose of, 387, 394
removing editable regions from, 391
saving documents as, 387
vs. library items, 397

Templates category, Insert panel, 17
Templates folder, 388, 393
terminology, 26–27
testing servers, 27, 41, 374–377
testing webpages, 67–70
text, 83–130

adding, 59, 84–85
aligning, 98–99
applying headings to, 90–92
block quoting, 98–99
cutting/copying, 86
dragging and dropping, 87
duplicating, 87
encoding, 79
finding and replacing, 116–123
formatting, 59
indenting, 98–99
inserting line breaks in, 97
inserting special characters in, 105–106
moving, 87
pasting, 86, 88–89
preformatting, 96
selecting, 84
setting default color for, 76, 77
spell-checking, 130
structure vs. presentation, 83

text areas, 296
Text category

CSS Designer panel, 193
Insert panel, 101

text fields, 291–295
text-indent property, 98
text links, 170–171
text styles, 94–95
Thawte, 33
Theora codec, 156
tiled background images, 151
timeline-based animations, 160
Timing Function pop-up menu, 365, 368
Title/Encoding category, 79, 214
titles

image, 138
page (See page titles)

<title> tag, 121, 390
tool tips, 17
tracing images, 80, 214
trackpads, xv
Transition On pop-up menu, 364
transitions, CSS, 362–368
transparency slider, 80
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triangle, small black, 17
TTF format, 113
tutorials

Dreamweaver, 482
regular expressions, 128

Typekit (Adobe), 22, 110
typography, 22. See also fonts

U
UI category, Insert panel, 354
UI widgets, 353, 354–361, 358
Uncloak command, 52
underline style, 78, 94, 95
underscore (_)

in file/folder name, 65, 438
in image map name, 181
in image name, 137, 146
preceding target with, 177
in regular expression, 127, 129
in template region name, 389, 390

Undo command, 86
Unicode encoding, 75, 79
Unicode Normalization Form, 79
Uniform Resource Locators, 60, 65. See also URLs
unordered lists, 100, 101. See also lists
Update Files dialog, 44, 401
Update Library Items dialog, 400
Update Pages dialog, 395
Up state, 341
Url form field, 291
URLs, xiv, 60, 61, 65
usability, site, 307
user-generated content, 373
user interface widgets. See UI widgets
UTF-8 encoding, 75, 79

V
Validate Form behavior, 348–349
validating

dynamic pages, 436
forms, 348–350
static pages, 434–435

VCS, 437, 450–451
Verisign, 33
Version Control System (VCS), 437, 450–451
video clips, 3
video codecs, 155–156
video-encoding services, 157
video files, 154–159
video formats, 164
video players, 168
<video> tag, 156
video training programs, 485
View menu, 218, 310, 411, 415
View mode buttons, 8
views

refreshing, 42
switching between local/remote, 41

visited links, 77, 78, 210
visual aids, 250–251

visually impaired site visitors, 63, 132.  
See also accessibility

VLC, 168
Vorbis codec, 156
VP8 codec, 156

W
W3C Validator feature, 434–436
web addresses, xiv. See also URLs
WebAssist, 482
web browsers. See also specific browsers

and audio/video formats, 154
and CSS-based layouts, 258
editing list of, 69
and event handlers, 338
and floating boxes, 224
how fonts are displayed by, 107
and HTML5 form elements, 286–287
previewing pages in, 67–70
and tables, 273

web content management systems, 369. See also 
CMSs

WebDAV, 32, 33, 37
web design, 31, 486
web fonts, 22, 109–114
web hosting service, 14
WebKit, 10, 67, 68, 74, 258
web links, 61. See also links
weblog creation software, 370–371, 483.  

See also WordPress
weblogs, 481
.webm file extension, 155
WebM standard, 155, 156
webpages. See also websites

adding animations to, 160–163
adding audio to, 157–159
adding automatic dates to, 115
adding background images to, 150–151
adding favicons to, 152–153
adding forms to, 288–290
adding headings to, 90–92
adding images to, 62–63, 132–134
adding jQuery UI elements to, 354–361
adding links to, 60–61, 170–171
adding special characters to, 105–106
adding tables to, 260–262
adding text to, 59, 83–89
adding titles to, 58, 226
adding video to, 157–159, 164–166
aligning elements on, 308–309
attaching style sheet to, 244–245
creating, 392–393
defining meta tags for, 81–82
defining structure of, 317–318
extracting embedded JavaScript from, 432–433
file extensions for, 45
inserting objects into, 16
laying out, 227–230
naming, 64–65
navigation for (See navigation)
opening, 66
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previewing in browser, 67–70
saving, 64–65
setting dimensions for, 315–316
setting properties for, 75–80
spell-checking, 130
template-based, 392–396
updating, 49
updating links in, 43
validating, 434–436
zooming in on, 313–314

web-safe fonts, 109
web servers

for CMSs, 376–377
ways of connecting to, 32

website management, 437–446
checking for broken links, 454–455
deleting site from Dreamweaver, 457–458
exporting/importing site definitions, 459–460
generating site reports, 452–453
planning for site expansion, 438
setting up Check In/Check Out, 442–444
setting up version control, 450–451
using Design Notes, 447–449

websites. See also webpages
adding interactivity to, 335, 351
checking/fixing broken links in, 454–455
choosing structure/design for, 31, 438
creating, 28–31
database-backed, 27
defining remote server for, 32–37
deleting from Dreamweaver, 457–458
Dreamweaver terminology for, 26–27
key to usability of, 307
local vs. remote, 26–27
naming, 29
navigation for (See navigation)
planning for expansion of, 438
preventing “breaking” of, 386
restricting changes to, 386, 387
static vs. dynamic, 27
styling page content for, 187
switching between, 40
synchronizing local and remote, 49–51, 396
this book’s companion, 479
updating content for, 475

web standards, 22, 155
Welcome screen

buttons/controls, 2–4
creating new page from, 54
Dreamweaver Site link, 28
hiding/showing, 4
opening pages with, 54, 66
turning on/off, 54

whitespace, 97, 98, 117, 128, 129, 263. See also 
spaces

widgets
Accordion, 354–358
Autocomplete, 354, 358–360
Button, 354
Datepicker, 354, 360–361
jQuery UI, 17, 22, 354–361
purpose of, 351

wildcard symbols, 127
windows, opening new browser, 342–344
Windows Explorer, 43, 441
Window Size menu, 71, 72, 73, 74, 315–316
Windows Media, 164, 167
Windows systems

browsers for, 67, 70 (See also specific browsers)
code editors for, 430
Document toolbar on, 8
editor setup, 4
encodings, 75
expanding Files panel on, 48
font considerations, 108
getting rid of tabs in, 7
and H.264 codec, 155
keyboard shortcuts, xiv 
menu bar on, 5
and Submit/Reset buttons, 306
testing server package for, 376

Windows XP, 70
Wise-Women online community, 484
WOFF format, 113
Word (Microsoft)

cleaning up HTML created by, 470–471
getting text from, 461
importing documents from, 85, 470, 471
importing tabular data from, 283, 471
pasting text from, 88–89, 470

WordPress
code hints for, 423
Dreamweaver CC support for, 369
and dynamic sites, 27, 379
online form service, 287
online resources, 483
overview, 370–371
testing servers, 376–377

word wrap, 410, 412
workflow reports, 452
worksheets, importing Excel, 472–473
workspace layouts, 430
workspaces

defined, 18
deleting, 20
preset, 19
purpose of, 19
renaming, 20
saving custom, 20
switching between, 19

Workspace Switcher, 5, 6, 19, 20
Wufoo, 287
wufoo.com, 287
[\w\W], in regular expressions, 127
WYSIWYG mode, 9
WYSIWYG tools, 187, 267, 407, 414, 418

X-Z
XAMPP, 376–377
XML, 217, 352, 447, 459
YUI, 352
Zeldman, Jeffrey, 486
zooming in on a page, 313–314
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