
Temporary spine = .8771”

VISUAL QUICKSTART GUIDE

 Three ways to learn—print, ebook & video!

digital editionIncludes eBook & 
Video access

Dreamweaver 
CS6

T o m  N e g r i n o 

D o r i  S m i t h

•	 Three ways to learn! Now you can curl up with the book, learn on the 
mobile device of your choice, or watch an expert guide you through the 
core features of Dreamweaver CS6. This book includes an eBook version 
and the Dreamweaver Video QuickStart for the same price!

•	 Concise steps and explanations let you get up and running in no time.

•	 Essential reference guide keeps you coming back again and again.

•	 Whether you’re a Dreamweaver newbie or an experienced veteran, this 
book will teach you all you need to know—from the basics of creating and 
publishing Web sites to styling pages with CSS and building sites that use 
popular content management systems—and much more!

•	 Visit the companion Web site at www.dreamweaverbook.com  
to download bonus material, sample files, and updates.

In full color

Learn Dreamweaver— 
the quick and easy way!

V I S U A L  Q U I C K S TA R T  G U I D E VISUAL QUICKSTART GUIDE

	 Peachpit Press
www.peachpit.com

FOR COMPUTERS USING: Adobe Dreamweaver 
CS6 for OS X or Microsoft Windows

CATEGORY: Web Design/Web Development

BOOK Level: Beginning / Intermediate

ISBN-13:
ISBN-10:

978-0-321-82252-9
0-321-82252-8

9 7 8 0 3 2 1 8 2 2 5 2 9

5 3 4 9 9

US $34.99  CAN $36.99  UK £21.99

Author Photo: Morgen Benoit Photography

Tom Negrino and Dori Smith have demystified  
the Web for non-geeks since 1995. Tom, a 
longtime contributor to Macworld magazine,  
has written more than 40 books. Dori was  
a cofounder of the Web Standards Project, 

founded the Wise-Women community, and has programmed 
computers for decades. Together, they’ve written Styling 
Web Pages with CSS: Visual QuickProject Guide and the 
best-selling JavaScript: Visual QuickStart Guide. They live 
with their excellent cat Pixel in California’s wine country. 

D
ream

w
eaver C

S6
V

IS
U

A
L

 Q
U

IC
K

S
TA

R
T

 G
U

ID
E

N
E

G
R

IN
O

SM
ITH



Peachpit Press

V I S U A L  Q U I C K S TA R T  G U I D E

Dreamweaver 
CS6 

Tom Negrino • Dori Smith



Visual QuickStart Guide 
Dreamweaver CS6
Tom Negrino and Dori Smith

Peachpit Press
1249 Eighth Street
Berkeley, CA 94710
510/524-2178
510/524-2221 (fax)

Find us on the Web at www.peachpit.com
To report errors, please send a note to errata@peachpit.com
Peachpit Press is a division of Pearson Education

Copyright © 2012 by Tom Negrino and Dori Smith

Editor: Nancy Peterson
Production Editor: Katerina Malone
Copyeditor: Scout Festa
Compositor: Danielle Foster
Indexer: Emily Glossbrenner
Cover Design: RHDG / Riezebos Holzbaur Design Group, Peachpit Press
Interior Design: Peachpit Press 
Logo Design: MINE™ www.minesf.com

Notice of Rights
All rights reserved. No part of this book may be reproduced or transmitted in any form by any means, 
electronic, mechanical, photocopying, recording, or otherwise, without the prior written permission of the 
publisher. For information on getting permission for reprints and excerpts, contact permissions@peachpit.com.
Photograph of authors courtesy Morgen Benoit Photography (www.photobenoit.com).

Notice of Liability
The information in this book is distributed on an “As Is” basis without warranty. While every precaution has 
been taken in the preparation of the book, neither the authors nor Peachpit Press shall have any liability to any 
person or entity with respect to any loss or damage caused or alleged to be caused directly or indirectly by the 
instructions contained in this book or by the computer software and hardware products described in it.

Trademarks
Visual QuickStart Guide is a registered trademark of Peachpit Press, a division of Pearson Education.
All other trademarks are the property of their respective owners.

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as 
trademarks. Where those designations appear in this book, and Peachpit Press was aware of a trademark 
claim, the designations appear as requested by the owner of the trademark. All other product names and 
services identified throughout this book are used in editorial fashion only and for the benefit of such companies 
with no intention of infringement of the trademark. No such use, or the use of any trade name, is intended to 
convey endorsement or other affiliation with this book.

ISBN 13:	978-0-321-82252-9
ISBN 10:	 0-321-82252-8

9 8 7 6 5 4 3 2 1

Printed and bound in the United States of America

www.peachpit.com
www.minesf.com
www.photobenoit.com


Dedication
To our son, Sean Smith, with love from Mom and Dad



Special Thanks to:
Our patient and cheerful editor, Nancy Peterson, who made this book 
better, and encouraged us when we were weary. Thanks for pushing us 
over the finish line.

Virginia DeBolt, who contributed several chapters to previous editions, 
which we have built upon in this revision. Her work was terrific, and we 
are grateful for her help. 

Katerina Malone, for her excellent production work.

The book’s compositor, Danielle Foster, and to Emily Glossbrenner for 
the index.

Peachpit’s Nancy Ruenzel and Nancy Davis, for their many years of 
friendship and support.

Of course, our gratitude to the members of the Adobe Dreamweaver 
CS6 team for creating a terrific product.

In Tom’s office, the soundtrack for this book included music from my 
Pandora and Rhapsody subscriptions, and lots of embarrassingly 
bouncy pop music that shall go unnamed.



Contents at a Glance  v

Contents at a Glance
	 Introduction  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   xiii

Chapter 1	 Introducing Dreamweaver .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   1

Chapter 2	 Starting Your First Site .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   25

Chapter 3	 Building Your First Page .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  53

Chapter 4	 Adding Text to Your Pages .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                89

Chapter 5	 Including Images and Media .  .  .  .  .  .  .  .  .  .  .  .  .              133

Chapter 6	 Working with Links  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    165

Chapter 7	 Styling Page Content  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 183

Chapter 8	 Using Styles for Layout  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 227

Chapter 9	 Managing Styles .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      243

Chapter 10	 Inserting Tables  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      267

Chapter 11	 Using Forms and Fields  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 295

Chapter 12	 Using Dreamweaver’s Layout Tools  .   .   .   .   .   .   .   .   . 315

Chapter 13	 Using Behaviors and Navigation Objects .  .  .  .  .      339

Chapter 14	 Building Pages with Dynamic Elements .  .  .  .  .  .       361

Chapter 15	 Working with Content Management Systems .  .   377

Chapter 16	 Making Life Easier: Using Templates,  
Libraries, and Snippets  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 391

Chapter 17	 Editing Code .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                        415

Chapter 18	 Managing Your Site .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    451

Appendix A	 Where to Learn More  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 479

Appendix B	 Customizing and Extending Dreamweaver  .   .   .   . 487

	 Index  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 497

	 Bonus chapters .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   B1-1



This page intentionally left blank 



Table of Contents  vii

Table of Contents

	 Introduction .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  xiii

Chapter 1	 Introducing Dreamweaver  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 1

A Quick Tour of Dreamweaver  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 2
Setting Up Your Workspace .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 19
What’s New in Dreamweaver CS6 .   .   .   .   .   .   .   .   .   .   .   .   . 22

Chapter 2	 Starting Your First Site  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   25

Understanding Local and Remote Sites  .  .  .  .  .  .  .  .  .          26
Creating the Local Site .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    28
Defining the Remote Server .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 32
Editing Site Definitions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    38
Working with the Files Panel  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 39
Navigating Disks and Sites  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 40
Switching Between Local View and the  

Remote Server  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                        41
Refreshing Views .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       42
Working with Files and Folders .  .  .  .  .  .  .  .  .  .  .  .  .  .  .               43
Putting and Getting Files .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   46
Expanding the Files Panel .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  48
Synchronizing the Local and Remote Sites  .   .   .   .   .   .   .   . 49
Cloaking Files and Folders  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 52

Chapter 3	 Building Your First Page  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   53

Creating a New Page .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     54
Using Sample Pages .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     58
Titling Your Page  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       60
Adding Text to Your Page .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  61
Creating Links .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                         62
Adding Images .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 64
Naming and Saving Your Page .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 66
Opening a Page .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                        68
Previewing in a Browser .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   69
Preview Using Preset Screen Sizes .  .  .  .  .  .  .  .  .  .  .  .  .             72
Viewing Pages in BrowserLab .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .               76
Setting Page Properties  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   80
Defining Meta Tags .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      87



viii  Table of Contents

Chapter 4	 Adding Text to Your Pages  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   89

Adding Text  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                          90
Cutting, Copying, and Pasting Text .  .  .  .  .  .  .  .  .  .  .  .             92
Dragging and Dropping Text  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 94
Using Paste Special  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 95
Applying Headings .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      97
Applying Character Formats .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .100
Applying HTML Text Styles .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 101
Using Preformatted Text .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   103
Adding Line Breaks .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      104
Indenting and Aligning Text with HTML .   .   .   .   .   .   .   .   .   105
Working with Lists  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   108
Inserting Special Characters  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 113
Adding Automatic Dates .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   115
Finding and Replacing .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    116
Finding Text with a Simple Search .   .   .   .   .   .   .   .   .   .   .   .   . 118
Performing Advanced Text Searches .  .  .  .  .  .  .  .  .  .  .            121
Finding and Replacing in Source Code .  .  .  .  .  .  .  .  .  .           124
Finding and Replacing with a Specific Tag .  .  .  .  .  .  .  .         125
Using Regular Expressions for Searching  .  .  .  .  .  .  .  .         128
Checking Spelling  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   132

Chapter 5	 Including Images and Media  .   .   .   .   .   .   .   .   .   .   .   .   .   . 133

Adding Images .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   134
Inserting Images from the Assets Panel  .  .  .  .  .  .  .  .  .          138
Adding Image Placeholders .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 139
Setting Image Properties  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 141
Editing Images  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   143
Optimizing Images .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   147
Working with Photoshop .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   148
Adding a Background Image  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   154
Adding a Favicon .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       156
Adding Flash and Shockwave .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                158
Adding Flash Video .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     160
Adding QuickTime and Other Media .  .  .  .  .  .  .  .  .  .  .            163

Chapter 6	 Working with Links .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     165

Creating Text Links .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      166
Changing Link Relative To .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  170
Formatting Links  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   172
Targeting Links .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 174



Table of Contents  ix

Adding Named Anchors  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   175
Adding Links to Graphics  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   178
Creating Image Maps .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     179
Adding Email Links  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      181

Chapter 7	 Styling Page Content .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   183

Understanding CSS  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   184
Creating a Style Rule for a Tag  .   .   .   .   .   .   .   .   .   .   .   .   .   .   188
Dreamweaver CSS Categories .   .   .   .   .   .   .   .   .   .   .   .   .   .   190
Creating a Custom Class .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   193
Creating Compound Selectors .   .   .   .   .   .   .   .   .   .   .   .   .   .   195
Working with the CSS Styles Panel .  .  .  .  .  .  .  .  .  .  .  .             198
Adding CSS3 Properties with the CSS Styles Panel .  .  .  .   203
Applying Attributes .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     205
Working with Browser-Specific CSS Properties .  .  .  .  .      210
Creating Styles with the Property Inspector .  .  .  .  .  .  .         211
Modifying a Style .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       215
Working with Related Files .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   216
Working with Font Groups .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  218
Using Web Fonts  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      220
Using the Code Navigator .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 225

Chapter 8	 Using Styles for Layout  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  227

CSS Layout Basics .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  228
Using the Included Layouts  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 231
Laying Out Your Page  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  233
Laying Out Your Navigation .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                237
Modifying Your Navigation  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  239

Chapter 9	 Managing Styles  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   243

Renaming Styles .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  244
Deleting Styles .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  246
Creating Rules from Inline Styles .  .  .  .  .  .  .  .  .  .  .  .  .              247
Creating a New External Style Sheet .  .  .  .  .  .  .  .  .  .  .           249
Moving Internal Styles to External  .   .   .   .   .   .   .   .   .   .   .   .  252
Attaching a Style Sheet  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  254
Using Drag-and-Drop Styles  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  256
Using CSS Inspection  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  258
Using the Visual Aids .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    260
Experimenting with CSS Enable/Disable .  .  .  .  .  .  .  .  .        262
Using Design-Time Style Sheets .   .   .   .   .   .   .   .   .   .   .   .   .  264



x  Table of Contents

Chapter 10	 Inserting Tables .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       267

Moving Away from Tables for Layout .  .  .  .  .  .  .  .  .  .  .           268
Creating a Table .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      270
Selecting Table Elements .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   274
Making Table Selections Easier .  .  .  .  .  .  .  .  .  .  .  .  .  .              276
Adding Rows and Columns .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  278
Merging and Splitting Cells .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  280
Resizing Table Elements .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   281
Deleting Table Elements .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  284
Specifying Table Alignment .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                285
Setting Cell Properties .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   286
Sorting Table Content .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  288
Formatting Tables .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  290
Importing and Exporting Tabular Data .  .  .  .  .  .  .  .  .  .           291

Chapter 11	 Using Forms and Fields .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  295

Adding a Form to a Page .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 297
Adding Text Fields .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  300
Adding a Text Area .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     304
Adding Check Boxes .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    305
Adding a Fieldset .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      306
Adding a Radio Button Group .  .  .  .  .  .  .  .  .  .  .  .  .  .  .               307
Adding a List/Menu .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     309
Adding a Button .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       312

Chapter 12	 Using Dreamweaver’s Layout Tools  .  .  .  .  .  .  .  .  .          315

Using the Grid .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                         316
Using Rulers and Guides .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  318
Zooming In on Your Page .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   321
Setting Page Dimensions .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  323
Using Multiscreen Preview  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  325
Adding Media Queries .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   328
Using Fluid Grid Layouts .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  332

Chapter 13	 Using Behaviors and Navigation Objects .   .   .   .   .   339

Using the Behaviors Panel .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 341
Adding Rollovers  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      345
Opening a New Browser Window .  .  .  .  .  .  .  .  .  .  .  .  .            348
Checking for Plug-ins .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    351
Using Jump Menus .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                     353



Table of Contents  xi

Validating Forms .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  356
Inserting Fireworks Pop-Up Menus .  .  .  .  .  .  .  .  .  .  .  .           359

Chapter 14	 Building Pages with Dynamic Elements .   .   .   .   .   .   . 361

What Are Spry and jQuery?  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                362
Adding Spry Elements  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   364
Using the Adobe Widget Browser  .   .   .   .   .   .   .   .   .   .   .   .  366
Using Widgets .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                       370
Adding CSS3 Transitions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 372

Chapter 15	 Working with Content Management Systems .   .   377

About Content Management Systems .  .  .  .  .  .  .  .  .  .          378
Connecting to Your CMS .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 380
Using Dynamically Related Files .   .   .   .   .   .   .   .   .   .   .   .   .  384
Filtering Related Files  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  387
Using Live View Navigation  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                388
Freezing or Disabling JavaScript  .  .  .  .  .  .  .  .  .  .  .  .  .             390

Chapter 16	 Making Life Easier: Using Templates,  
Libraries, and Snippets  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  391

Creating a Template .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  393
Adding Editable Regions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 395
Removing Editable Regions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                397
Building Pages Based on a Template .  .  .  .  .  .  .  .  .  .  .          398
Modifying a Template  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  400
Creating a Library Item .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   403
Using a Library Item  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  405
Editing a Library Item .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    406
Working on Library Items with the Property  

Inspector  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  409
Using Dreamweaver Snippets .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                411

Chapter 17	 Editing Code .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                         415

Using the Coding Toolbar  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  416
Using Split View .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      424
Using Live Code View .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  426
Using the Quick Tag Editor  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  428
Using the Tag Editor .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  430
Using the Tag Chooser .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    431



xii  Table of Contents

Collapsing Code  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  433
Using Code Hints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                      436
Using the Tag Inspector  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  442
Using the JavaScript Extractor  .   .   .   .   .   .   .   .   .   .   .   .   .   .  444
Using the Code Reference .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                446
Using the W3C Validator .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  448

Chapter 18	 Managing Your Site  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   451

Planning for Site Expansion  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                452
Expanding the Files Panel .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 453
Setting Up Check In and Check Out .   .   .   .   .   .   .   .   .   .   .  456
Checking Files In and Out .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 459
Using Design Notes  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   461
Setting Up Subversion .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   464
Generating Site Reports .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  466
Checking for Broken Links .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 469
Finding External Links and Orphaned Files  .  .  .  .  .  .  .        471
Checking Browser Compatibility  .  .  .  .  .  .  .  .  .  .  .  .  .             472
Deleting Sites .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                         475
Exporting and Importing Site Definitions  .   .   .   .   .   .   .   .   476

Appendix A	 Where to Learn More  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   479

Web Sites .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  480
Other Online Resources .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  484
Other Dreamweaver Books  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                486
Web Design and JavaScript Books .  .  .  .  .  .  .  .  .  .  .  .            486

Appendix B	 Customizing and Extending Dreamweaver  .  .  .  .     487

Customizing Keyboard Shortcuts .  .  .  .  .  .  .  .  .  .  .  .  .             488
Finding and Installing Extensions .  .  .  .  .  .  .  .  .  .  .  .  .             493

	 Index  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   497

Bonus chapters mentioned in this eBook are available
after the index 
Bonus Chapter 1   Adding Frames  .   .   .   .   .   .   .   .   .   .   .   .   B1-1
Bonus Chapter 2  Using Spry Widgets .  .  .  .  .  .  .  .  .  .          B2-1
Bonus Chapter 3  Working with Other Applications  .   .  B3-1 



Introduction  xiii

Introduction

Welcome to Dreamweaver CS6: Visual 
QuickStart Guide! Adobe Dreamweaver 
has long (initially under its previous name, 
Macromedia Dreamweaver) been the 
premier visual tool for Web site developers, 
allowing you to build great-looking Web 
pages and smoothly running Web sites. 
Dreamweaver’s ease-of-use takes much of 
the pain out of creating Web sites, without 
sacrificing flexibility. It’s possible to use 
Dreamweaver to create terrific Web sites 
without knowing much about HTML, CSS, 
and JavaScript. 

Dreamweaver is a rich, powerful, and deep 
program, and at first glance, it can be a bit 
intimidating. We’ve written this book as 
a painless introduction to Dreamweaver 
and its features, and with our help, you will 
use Dreamweaver to build an excellent 
Web site. 

Using this Book
We’ve organized the different elements of 
building Web sites with Dreamweaver CS6 
into chapters, and within each chapter are 
numbered, step-by-step directions that 
tell you exactly how to accomplish various 
tasks. You don’t have to work through the 
entire book in order, but it is structured so 
the more complex material builds on the 
earlier tasks. 

We start with an overview of Dreamweaver, 
move on to setting up your Web site and 
creating your first Web page, then discuss 
how to add content, structure, and interac-
tivity to your pages. Finally, we show you 
how to work with HTML code and manage 
your Web site. 

When we first decided to write this book, 
we wanted to take a fresh look at Dream-
weaver—at how people use it, and how 
people should use it. Throughout the book, 
we’ve tried to show you how to use Dream-
weaver using its most modern features, 
rather than using some of the features that 
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are still in the program but that are “old 
school.” Specifically, we’ll show you how 
to apply styles and lay out your page ele-
ments using Cascading Style Sheets, rather 
than older, obsolete methods. If you don’t 
know what that means, don’t worry; it’s all 
explained in Chapters 7 through 9. 

For keyboard commands, we’ve included 
Mac keyboard shortcuts in parentheses 
immediately after the Windows shortcut, 
like this:

To open the Find & Replace dialog, press 
Ctrl-F (Cmd-F).

While writing this book, we’ve made the 
assumption that you’re familiar with the 
basics of using Windows or OS X. You 
don’t need to be a computer expert by any 
means, but you shouldn’t be stumped by 
concepts like selecting text, using menus, 
clicking and dragging, and using files and 
folders. Naturally, you should be familiar 
with Web surfing and how to use a Web 
browser to view a Web site.

Tips

  Throughout the book we’ve included 
many tips that will help you get things done 
faster, better, or both. 

  Be sure to read the figure captions, too; 
sometimes you’ll find extra nuggets of infor-
mation there.

  When we’re showing HTML, CSS, or 
JavaScript code, we’ve used this code font. 
We also use the code font for Web addresses.

  You’ll also find sidebars (with gray back-
grounds) that delve deeper into subjects. 

Getting the most from Dreamweaver
Dreamweaver is a professional-class tool, 
and it provides professional results. Dream-
weaver allows you to build Web sites visu-
ally, without needing to know the details 
of HTML, CSS, and JavaScript. But to best 
use Dreamweaver, you will still need some 
fundamental knowledge of what these lan-
guages are, and how they work together 
to make up a Web site. Similarly, you will 
find it helpful to know basic things such 
as what a Web page is and what a Web 
server does.

Where necessary, throughout this book 
we explain what you’ll need to know 
about HTML, CSS, and JavaScript to work 
with Dreamweaver. But there is much 
more to say about these subjects, and 
there are thousands of books devoted 
to that job. In fact, we wrote one of the 
most popular books on JavaScript. You’ll 
find information about that book, as well 
as some of our favorite Web design and 
development books written by other 
authors, in Appendix A.

A note for our Mac-using friends
If you’ve flipped through this book already, 
you probably noticed that the vast major-
ity of the screenshots were taken on 
machines running Windows. That doesn’t 
mean that the book (or its authors) doesn’t 
welcome Dreamweaver users on the Mac. 
Far from it; in fact, both of us are primarily 
Mac users, and we are frequent contribu-
tors to Macworld magazine and other Mac-
oriented publications.

However, our crack research department 
tells us that most Dreamweaver users 
are running the program on Windows 
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machines, so we have included screen-
shots that will reflect the experience of the 
majority of our readers. Happily, Dream-
weaver works almost identically on both 
platforms. In the few cases where there are 
differences, we’ve included separate pro-
cedures for Windows and for Mac users.

There is one other thing that we haven’t 
done in this book that we have done in 
our previous Mac books. We are no longer 
telling Mac users to Control-click to bring 
up a context menu (also known as a short-
cut or contextual menu). Instead, we’ve 
adopted right-click, because Apple now 
ships its multiple-button mouse with all of 
its computers that come with a mouse. If 
you are using a Mac with a trackpad, just 
mentally substitute Control-click wherever 
you see right-click in the book. Better 
yet, we suggest that you get any USB 
or wireless mouse with multiple buttons 
and a scroll wheel. It will really increase 
your productivity.

There’s more online
We’ve prepared a companion Web site for 
this book, which you’ll find at:

www.dreamweaverbook.com

On this site, you’ll find news about the 
book and links to other online resources 
that will help you use Dreamweaver CS6 
more productively. If we discover any 
mistakes in the book that somehow got 
through the editing process, we’ll list the 
updates on the site, too.

Because of space limitations in the paper 
edition, we’re taking some sections that 
were in previous editions of the book 
and posting them on the Web site. These 
bonus chapters have been updated for 

Dreamweaver CS6. By moving them to 
the Web, we can also easily keep them 
up to date between paper editions of the 
book. If you bought the paper edition, you 
can download the bonus chapters from 
our site. If you bought the ebook edition, 
there’s no need to download the bonus 
chapters; the ebook edition includes all the 
bonus chapters.

If you have any questions about the book’s 
contents, please first check the FAQ 
(Frequently Asked Questions) page on the 
companion Web site. It’s clearly marked. 
If you’ve read the FAQ and your question 
isn’t answered there, you can contact us 
via email at dwcs6@dreamweaverbook.com.  
We regret that because of the large vol-
ume of email that we get, we cannot, and 
will not, answer email about the book sent 
to our personal email addresses or via the 
contact forms on our personal sites. We 
can promise that messages sent only to 
the dwcs6@dreamweaverbook.com email 
address will be read and answered, as time 
allows. Unfortunately, due to the danger 
of computer viruses being spread with 
email attachments, we cannot accept any 
messages with attachments. We also must 
limit ourselves to responding to questions 
about the book; time doesn’t permit us 
to answer general questions about Web 
design and development.

Let’s get started
Every journey begins with a first step, and 
if you’ve read this far, your journey with 
Dreamweaver has already begun. Thanks 
for joining us, and let’s get started building 
your great Web site. 

—Tom Negrino and Dori Smith, June 2012

www.dreamweaverbook.com
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4
Adding Text to 

Your Pages
The main message of most Web sites is 
conveyed by the site’s text, and a major 
part of your job in working with any site 
will be adding, modifying, and styling that 
text. Dreamweaver gives you the tools you 
need to effectively put text on your pages 
and get your message across.

When you add text, you need to deal 
with two different aspects of the text: its 
structure and its presentation. Structural 
elements are things like paragraphs, head-
ings, lists, and the like; presentation is how 
the text looks, including things like the font, 
font size, text color, and so on. Most sites 
these days separate the structure and the 
presentation. Structure is about organizing 
the content on the page, and presentation 
involves making the content look good.

In this chapter, we’ll concentrate on getting 
text onto your page and applying structure 
using headings and lists. We’ll also cover 
using basic HTML text styles to change the 
look of your text. You’ll learn how to more 
precisely style text and present it using 
Cascading Style Sheets in Chapter 7.

In This Chapter
Adding Text	 90

Cutting, Copying, and Pasting Text	 92

Dragging and Dropping Text	 94

Using Paste Special	 95
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Searching	 128

Checking Spelling	 132
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Adding Text
Most of the text on a Web page is formatted 
in blocks, which are enclosed by beginning 
and ending HTML tags. For example, the 
HTML for a line of text with paragraph tags 
wrapped around it looks like this:

<p>This text is wrapped in beginning 
and ending paragraph tags.</p>

For a browser to understand that this is 
a paragraph, you (or in this case, Dream-
weaver) have to make it one by adding the 
surrounding <p> tags.

Of course, in Dreamweaver’s Design view 
or Live view, you won’t see the HTML 
tags. All of the text contained between the 
opening <p> tag and the closing </p> tag is 
considered by a Web browser to be within 
the same paragraph, no matter how much 
text is between the tags. The <p>…</p> 
combination is an example of a container 
tag. Virtually all of the structural formatting 
that you can apply with Dreamweaver is 
done with container tags.

Selecting Text
Besides selecting text by dragging over it with the mouse cursor, Dreamweaver also gives you 
some text selection shortcuts in Design view:

.. Double-click a word to select it.

.. Move your cursor to the left of a line of text until the cursor changes from an I-beam to an arrow 
pointing at the text. Then click once to highlight a single line, or drag up or down to select 
multiple lines.

.. Triple-click anywhere in a paragraph to select the entire paragraph.

.. For finer control over selecting individual letters, hold down the Shift key and press the left or 
right arrow key to extend the selection one letter at a time.

.. Ctrl-Shift (Cmd-Shift) plus the left or right arrow key extends the selection one word at a time. 
Ctrl (Cmd) plus the left or right arrow key moves the cursor one word to the left or right but 
doesn’t select any text.

.. Press Ctrl-A (Cmd-A) to Select All (the entire contents of the current document).
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When you add text to a page with Dream-
weaver, the program automatically wraps 
the text with paragraph tags when you 
press the Enter (Return) key on your key-
board. You can see this if you switch to 
Code view by clicking the Code button  
at the top of the Dreamweaver editing 
window A.

Dreamweaver also has special commands 
that help you import entire Microsoft 
Word or Excel documents as Web pages. 
(See “Using Paste Special,” later in this 
chapter. Also, refer to the bonus chapter 
“Working with Other Applications” at the 
end of the ebook edition or download it 
from www.dreamweaverbook.com.)

To insert text:
1.	 In Dreamweaver’s Design view, click in 

the page where you want to add text.

2.	 Type the text you want.

A Dreamweaver adds paragraph tags around text when you press the Enter (Return) key.

www.dreamweaverbook.com
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Cutting, Copying, 
and Pasting Text
Just as with a word processor, you can cut, 
copy, and paste text on a page in Dream-
weaver, which shares the same menu com-
mands with virtually all standard Windows 
and Mac word processors and text editors. 
When pasting text in Design view from one 
part of a Dreamweaver page to another or 
between Dreamweaver pages, text format-
ting is automatically maintained.

Dreamweaver also allows you to paste text 
and maintain some or all of the text’s format-
ting. This is especially useful when moving 
text from applications such as Microsoft 
Word or Excel to a Web page. See “Using 
Paste Special,” later in this chapter.

To cut or copy text:
1.	 Select the text you want to cut or copy.

2.	 To cut the text to the clipboard, choose 
Edit > Cut or press Ctrl-X (Cmd-X).

or

To copy the text to the clipboard, 
choose Edit > Copy or press Ctrl-C 
(Cmd-C).

The text is placed on the clipboard.

  When you have text selected, most of the 
time you can right-click to cut or copy the text 
using a context menu. You can also right-click 
to paste text from the context menu. If you 
have a single-button mouse on the Mac, you 
can Ctrl-click to bring up the context menu.
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To paste plain text:
1.	 Click to place the insertion point on 

the page where you want the text 
to appear.

2.	 Choose Edit > Paste, or press Ctrl-V 
(Cmd-V).

  If you copy some HTML source code 
from another program, such as the Source 
view of a Web browser, and paste it into a 
Dreamweaver page in Design view, the HTML 
appears on the page with tags and all. That’s 
because although what you’ve pasted in is 
HTML markup, Dreamweaver is trying to be 
smarter than you—it assumes that markup is 
what you want to display. If that’s not what 
you want, but rather you want the result of the 
markup to display in your page, just switch to 
Code view in Dreamweaver before you paste. 
The HTML code will paste into the page, and 
when you switch back to Design view, it will 
display the proper formatting.

  Dreamweaver offers Undo and Redo 
commands in the Edit menu, which can often 
be very useful for fixing mistakes or repeating 
operations. You can also press Ctrl-Z (Cmd-Z) 
for Undo and Ctrl-Y (Cmd-Y) for Redo.
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Dragging and 
Dropping Text
If all you want to do is move some text 
from one place on a page to another, it’s 
often faster to drag and drop the text.

To drag and drop text:
1.	 Select the text you want to move A.

2.	 Move the cursor over the selected text.

The cursor changes from an I-beam to 
an arrow.

3.	 Click and hold your mouse button over 
the selected text, and drag it to its new 
location, releasing the mouse button 
when the cursor is where you want 
the text B.

The text moves to its new home.

  To duplicate the text, hold down the Ctrl 
(Option) key while dragging and dropping. A 
copy of the text appears when you release the 
mouse button.

A Begin dragging and dropping text by 
selecting it.

B When you release the mouse button, the text 
moves to where you dragged it.
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Using Paste Special
Dreamweaver’s Paste Special command in 
the Edit menu gives you a variety of options 
that control the way formatted content is 
pasted into Dreamweaver’s Design view.

You will probably use the Paste Special 
command most often when pasting in text 
from Microsoft Word or Excel to maintain 
the formatting that the text had in those 
programs A. Text pasted in from Excel 
can appear in Dreamweaver as a format-
ted table, which saves you a lot of time 
and effort.

The Paste Special options include:

n	 Text only pastes just the text; paragraph 
marks and all formatting are stripped 
from the text B.

n	 Text with structure pastes the text and 
maintains the structure (notably para-
graphs, tabs, and lists) but eliminates 
other text formatting C.

continues on next page

A Paste Special will do a great job of maintaining 
the formatting from this Microsoft Word document.

B This is the “Text only” version of the text 
from A, with paragraph marks and formatting 
stripped out.

C With the “Text with structure” option, the text 
and paragraph marks are there, but there’s no 
character formatting.
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n	 Text with structure plus basic format-
ting keeps the text and text structure 
and retains bold and italic formatting D.

n	 Text with structure plus full formatting 
preserves the text, structure, and styles 
from the original document E.

To use Paste Special:
1.	 Select the text you want to cut or copy.

The text will usually be in a different 
application than Dreamweaver.

2.	 Cut or copy the text.

3.	 Switch to Dreamweaver, and click to set 
the insertion point where you want the 
text to appear.

4.	 Choose Edit > Paste Special, or press 
Ctrl-Shift-V (Cmd-Shift-V).

The Paste Special dialog appears F.

5.	 In the dialog, click the radio button next 
to the paste option you want.

6.	 Click OK.

The text pastes in according to the 
option you selected.

  If you use the “Text with structure plus 
basic formatting” or “Text with structure plus 
full formatting” choices, you can also paste 
graphics into Dreamweaver along with the 
formatted text.

  You can copy and paste graphics from 
most applications into Dreamweaver, but if 
you want to paste a graphic along with format-
ted text, you must use Paste Special.

  When pasting from Word and main-
taining full styles, Dreamweaver reads the 
Word styles and creates CSS styles with the 
same names and attributes. It places the CSS 
styles in the same document. If you want to 
use these styles elsewhere on your site, you 
should move these internal styles to an exter-
nal style sheet. See “Moving Internal Styles to 
External” in Chapter 9 to learn how to do that.

D The “Text with structure plus basic formatting” 
option maintains bold and italic formatting.

E The final option, “Text with structure plus full 
formatting,” maintains all the formatting from the 
Word document.

F Choose the option you want from the Paste 
Special dialog.
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Applying Headings
After paragraphs, headings are the most 
important structural element on most Web 
pages. Headings point your site’s visitors 
to essential information on the page, and 
they separate sections of the page. Think 
of headings as being similar to headlines in 
a newspaper.

Text you enter into Dreamweaver begins 
with no heading; Dreamweaver refers to 
this text as None in the Property inspec-
tor. As soon as you press Enter (Return), 
Dreamweaver wraps the text in paragraph 
tags, and the text becomes paragraph text.

HTML has six sizes of headings, plus 
paragraph text A. These headings don’t 
have a fixed point size, unlike headings 
in, say, Microsoft Word or Adobe InDe-
sign. Instead, they are sized relative to 
one another and to the size of the para-
graph text, and the size that the user sees 
depends on the settings in the user’s Web 
browser. By default, headings are usually 
displayed in boldface.

You can change the look of headings (their 
size, font, color, and so forth) using CSS, 
which we’ll cover in Chapter 7.

  You can have only one size of HTML 
heading in a particular element. You can work 
around this limitation with CSS styles.

  Headings are also important because 
they help search engines find and index con-
tent on your pages. Google in particular uses 
headings in this fashion, so it’s a good idea 
to use headings when they are appropriate to 
your content.

A Examples of the six heading sizes, plus 
paragraph, which is usually used for body text.
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To apply a heading:
1.	 Click in the line you want to change.

Note that you don’t have to select text; 
a heading is a block style, so it affects 
the entire paragraph the cursor is in.

2.	 Choose Format > Paragraph Format > 
Heading x, where x is the heading size 
you want B.

or

Press Ctrl-1 for Heading 1, Ctrl-2 for 
Heading 2, and so on. On the Mac, 
press Cmd-1 for Heading 1, Cmd-2 for 
Heading 2, and so on.

or

Choose a heading from the Format 
pop-up menu in the HTML mode of the 
Property inspector C.

or

Click one of the heading buttons in the 
Text category of the Insert panel D.

There are only buttons for Heading 1, 
Heading 2, and Heading 3, which are 
listed as h1, h2, and h3, respectively.

The text changes to the heading 
you selected.

B Choose the heading size you want from the 
Paragraph Format submenu.

C Another 
way to choose 
the heading 
size is to use 
the Format 
menu in the 
HTML mode of 
the Property 
inspector.

D The Text 
category of 
the Insert 
panel gives 
you buttons 
with many 
options, 
including ways 
to apply three 
heading sizes.
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To turn text into paragraph text:
1.	 Click in the line you want to change.

2.	 Choose Format > Paragraph Format > 
Paragraph.

or

Choose Paragraph from the Format 
pop-up menu in the HTML mode of the 
Property inspector.

or

Press Ctrl-Shift-P (Cmd-Shift-P).

Dreamweaver changes the text into 
a paragraph.

To remove heading formatting:
1.	 Click in the line you want to change.

2.	 Choose Format > Paragraph Format > 
None.

or

Press Ctrl-0 (Cmd-0). (Those are zeros, 
not the letter “O.”)

The Format menu of the Property 
inspector changes to None, indicating 
that the text has no heading or para-
graph style assigned to it.
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Applying Character 
Formats
Character formatting is styling that you 
can apply to words and individual charac-
ters rather than to blocks such as para-
graphs. This formatting includes changing 
the font, font size, and font color.

Beginning several versions ago and 
continuing through the current version of 
Dreamweaver, the program dispensed with 
the old method of applying these sorts 
of character formatting (which was to use 
the HTML <font> tag) in favor of using 
CSS styles. This change happened mostly 
behind the scenes in Code view, so if you 
have been using Dreamweaver for quite 
some time, you may not have even noticed 
the change. Beginning with Dreamweaver 
CS4, the program enforces the use of CSS 
for text styling by requiring you to partici-
pate in defining CSS rules for changing 
fonts, font sizes, and font colors.

The reason for the change to CSS is 
important. Pages styled with CSS are much 
more flexible than pages that use HTML 
<font> tags, and they can be maintained 
more easily. For example, when a site is 
redesigned, every page that uses <font> 
tags must be individually changed to match 
the new design. If you have hundreds or 
thousands of pages in your site, that’s a 
lot of work. Sites that use CSS to style text 
only need to change the style sheet docu-
ment, and the changes automatically ripple 
through the whole site. You’ll learn more 
about using CSS to style text (especially 
for setting font properties) in Chapter 7. 
Some other formatting operations are still 
performed using HTML markup, and those 
are the ones we’ll explore in this chapter.
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Applying HTML 
Text Styles
The most common text formatting is to 
make text bold or italicized, and of course 
Dreamweaver can do that with either 
HTML markup or a CSS rule. But it can also 
apply several other text styles, some of 
which are for specialized uses, as shown 
in A and Table 4.1.

A Dreamweaver offers a number of useful (and not so useful) HTML text styles.

Table 4.1  Text Styles

Style Description

Bold Makes text boldface.

Italic Italicizes text.

Underline Underlines text.

Strikethrough Text is shown with a line through it.

Teletype Reminiscent of an old typewriter. Usually shows text in a monospaced font such as Courier.

Emphasis Italicizes text onscreen. Causes screen readers to stress importance in speech.

Strong Bolds text onscreen. Causes screen readers to add additional importance to speech.

Code Depicts programming code, usually in a monospaced font.

Variable Marks variables in programming code. Usually displayed as italics.

Sample Meant to display sample output from a computer program or script. Usually displayed in a 
monospaced font.

Keyboard Meant to depict text a user would type on the keyboard. Usually displayed in a monospaced font.

Citation Used to mark citations and references. Usually displayed as italics.

Definition Used to mark the first, defining usage of a term in a document. Usually displayed as italics 
(Safari on the Mac displays this as regular text).

Deleted Marks deleted text. Shown the same as strikethrough.

Inserted Marks inserted text. Shown the same as underlined.
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Many of these text styles are meant for 
displaying programming or script code, 
so they won’t be used at all on many 
sites. Others, such as Underline and 
Strikethrough, are deprecated as of the 
HTML 4.01 standard, which means that 
they are obsolete and may not work in 
future browsers. Instead, you should use 
a CSS property. See “Dreamweaver CSS 
Categories” in Chapter 7.

To apply an HTML text style:
1.	 Select the text you want to change.

2.	 Choose Format > Style, and then 
choose the style you want from 
the submenu.

The text’s appearance changes.

  Actually, by default Dreamweaver does 
not use the traditional <b> and <i> HTML tags 
for bold and italic, respectively. Instead it uses 
<strong> and <em> (for emphasis). The latter 
tags are preferred as part of best practices, 
because they are better handled by the screen 
readers used by visually impaired users. If 
you want to switch Dreamweaver back to 
using <b> and <i>, choose Edit > Preferences 
(Dreamweaver > Preferences) and, in the 
General category of the Preferences dialog, 
deselect “Use <strong> and <em> in place of 
<b> and <i>.”
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Using Preformatted 
Text
Browsers usually ignore invisible formatting 
that doesn’t affect page content, such as 
tabs, extra spaces, extra line feeds, and the 
like. If you need to display text exactly as 
entered, however, you can use the Prefor-
matted paragraph format, which wraps the 
text in the <pre>…</pre> tags and makes 
browsers display all of the text characters.

Originally, preformatted text was meant to 
display tabular data in rows and columns, 
as in the output of a spreadsheet. To make 
the information line up, browsers display 
preformatted text in a monospaced font 
such as Courier A.

To apply preformatting:
1.	 Select the text you want to change.

2.	 From the Format pop-up menu of the 
HTML mode of the Property inspector, 
choose Preformatted.

or

In the Text category of the Insert panel, 
click the Preformatted Text button B.

or

Choose Format > Paragraph Format > 
Preformatted Text.

The text changes appearance.

  If you want to display tabular data, it 
often makes more sense to use a table rather 
than preformatted text. You get much more 
control over the table style and spacing of the 
items in the table, and you can add CSS to 
style the table’s contents if needed. See Chap-
ter 10 for information about using tables.

A Preformatted text lines up neatly, as in 
this table.

B Apply the 
style with the 
Preformatted 
Text button.
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Adding Line Breaks
Just as in a word processor, you press 
Enter (Return) in Dreamweaver to create a 
new paragraph. This is fine when you want 
to actually create a new paragraph, but 
not so great when you just want to move 
the cursor down a line, as you might want 
to do when entering an address. That’s 
because Web browsers (and Dream-
weaver) insert a blank line above and 
below a paragraph, so if you make each 
line of the address its own paragraph, it 
looks goofy A.

What you want to do is add a line break, 
which moves the cursor down one line 
without creating a new paragraph. In the 
code, Dreamweaver adds the HTML  
<br /> tag to the end of the line.

To insert a line break:
At the end of the line you want to break, 
press Shift-Enter (Shift-Return).

or

At the end of the line you want to break, in 
the Text category of the Insert panel, select 
Line Break from the Special Characters 
pop-up menu.

The text changes B.

  Line breaks are invisible characters in 
both Dreamweaver and Web browsers, but 
you can make them visible in Dreamweaver if 
you want. Choose Edit > Preferences (Dream-
weaver > Preferences), and then click the 
Invisible Elements category. Select the check 
box next to “Line breaks,” and then click OK. 
Dreamweaver then displays line breaks in 
Design view C.

A Paragraphs 
have whitespace 
before and after 
them, which isn’t 
really appropriate 
for things like 
addresses.

B After you replace 
the paragraph tags 
with line breaks, the 
address looks better.

C With the 
appropriate 
preference enabled, 
you can see the 
invisible line break 
characters.
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Indenting and Aligning 
Text with HTML
You won’t indent or align text in Dream-
weaver as you would with a word proces-
sor. The most common kind of indenting, 
indenting the first line in a paragraph, is 
usually done with a tab in a word processor, 
but tabs have no effect in HTML. Instead, 
you can use the text-indent CSS style 
property. Similarly, there are CSS properties 
for text alignment. See Chapter 7 for more 
about using CSS.

You can add whitespace to text—and 
simulate a tab—with non-breaking spaces. 
See “Inserting Special Characters,” later in 
this chapter.

When you are indenting paragraphs to set 
them apart from preceding and following 
paragraphs, Dreamweaver uses the HTML 
<blockquote> tag. This indents both the 
left and right margins of the block-quoted 
paragraph. You aren’t limited to para-
graphs; you can block quote any block 
element, such as headings.

Dreamweaver can align text with the left 
margin, right margin, or center of the page. 
You can also justify text, which adds space 
as needed between words so that both the 
left and right margins are aligned.

The method shown here adds alignment 
attributes to the HTML markup. You can 
also use Cascading Style Sheets to align 
text, which is covered in Chapters 7 and 8.
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To block quote text:
1.	 Click in the paragraph or other block 

element you want to indent.

2.	 Click the Indent button on the HTML 
mode of the Property inspector A.

or

In the Text category of the Insert panel, 
click the Block Quote button.

or

Choose Format > Indent or press 
Ctrl-Alt-] (Cmd-Opt-]).

The text changes B.

  To add more indenting, click the Indent 
button on the Property inspector again. This 
nests the <blockquote> tags.

  The CSS margin property is a much 
more flexible way to indent block elements, 
as described in Chapter 7.

To remove block quoting:
1.	 Click in the paragraph or other block 

element you no longer want to indent.

2.	 Click the Outdent button on the 
Property inspector.

or

Choose Format > Outdent or press 
Ctrl-Alt-[ (Cmd-Opt-[ ).

The text changes.

Outdent Indent

A Use the Indent 
button to apply 
a block quote to 
your text.

B The block quote nicely sets off the sonnet from 
the commentary text.
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To align text:
1.	 Click inside the paragraph you want 

to align.

2.	 Choose Format > Align, and then 
choose Left, Center, Right, or Justify 
from the submenu C.

or

Use one of the keyboard shortcuts 
listed in Table 4.2.

  Longtime Dreamweaver users may be 
thrown a bit by the removal of the alignment 
buttons from the HTML mode of the Property 
inspector. Those buttons have been moved 
to the CSS mode of the Property inspec-
tor, and Dreamweaver will enforce creating 
and naming a new style rule if you use the 
alignment buttons. The program will also 
alert you if you enter a name for the style 
rule that is the same as the HTML alignment 
attributes (left, center, right, or justify). 
Use different names to prevent confusion.

C Choose a text alignment from the Format menu.

Table 4.2  Alignment Shortcut Keys

Shortcut Key 
(Windows)

Shortcut Key 
(Mac) What It Does

Ctrl-Alt-Shift-L Cmd-Opt-Shift-L Left  
alignment

Ctrl-Alt-
Shift-C

Cmd-Opt-Shift-C Center 
alignment

Ctrl-Alt-Shift-R Cmd-Opt-Shift-R Right 
alignment

Ctrl-Alt-Shift-J Cmd-Opt-Shift-J Full 
justification



108  Chapter 4

Working with Lists
Lists are an easy way to organize content 
on your Web page. Dreamweaver supports 
three types of lists:

n	 Numbered lists or Ordered lists, for lists 
with items that need to be in a particular 
order A. List items are numbered and 
indented from the left margin. If you add 
or remove items from the numbered list, 
it automatically renumbers.

n	 Bulleted lists or Unordered lists, for 
lists of items in no particular order B.

n	 Definition lists, where each item has an 
indented subitem C.

A Numbered lists automatically renumber if you 
insert a new item between two existing items.

B Bulleted lists 
are single-spaced 
and indented.

C Definition lists have the definitions indented under the definition terms. The definition terms don’t have to 
be all uppercase—they just happen to be in this figure.
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To create a list:
1.	 Type the items for your list into the 

window. After typing each item, press 
Enter (Return).

2.	 Select the items in the list.

3.	 Choose Format > List, and then choose 
Unordered List, Ordered List, or Defini-
tion List from the submenu.

or

Click either the Unordered List or 
Ordered List button in the HTML mode 
of the Property inspector.

or

Click one of three buttons in the Text 
category of the Insert panel: ul for Unor-
dered List, ol for Ordered List, or dl for 
Definition List.

The text changes to the kind of list 
you chose.

  At the end of your list, you can turn 
off the list function either by pressing Enter 
(Return) twice or by clicking the appropriate 
list button in the Property inspector again.

  There are three other buttons in the Text 
category of the Insert panel that you can use 
to apply list tags to text. The li button marks 
text as a list item; the text must be within a 
bulleted or numbered list. The other two but-
tons are used for definition lists. The dt button 
marks text as a definition term, and the dd but-
ton marks text as a definition description.

  Because the Text category of the Insert 
panel was originally designed to help you work 
in Code view, some of the list buttons will cause 
the Dreamweaver window to change to Split 
view, so you can see the Code and Design 
panes at the same time. If you want to avoid 
code altogether, use the Property inspector or 
the menu bar to format your lists.
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Setting List Properties
You can change numbered list and bul-
leted list properties in Dreamweaver. 
Choose between five types of numbering, 
as shown in Table 4.3. For bulleted lists, 
you can choose either a round bullet (the 
default) or a square bullet. There are no 
properties to set for a definition list.

To set list properties:
1.	 Click in the list you want to change to 

place the insertion point.

2.	 Choose Format > List > Properties.

The List Properties dialog appears D.

3.	 Do one or more of the following:

>	 In the List type pop-up menu, select 
Bulleted List, Numbered List, or 
Directory List (“definition list” is called 
“Directory List” in this dialog for 
some reason).

>	 In the Style pop-up menu, select one 
of the Bulleted List or Numbered 
List styles.

>	 Use the Start count text box to set 
the value for the first item in the 
numbered list.

4.	 Click OK.

  You may notice that there is a fourth 
choice in the List type pop-up menu: Menu 
List. That choice creates an unusual type of list 
that is based on the <menu> tag. That tag was 
deprecated (that is, it was recommended that 
it not be used) when HTML 4.01 was standard-
ized in 1999. We suggest that you avoid the 
use of the Menu List option. It’s one of those 
little things that should have long since been 
removed from Dreamweaver, in our view.

D In the List Properties dialog, you can change 
the way lists are numbered and bulleted.

Table 4.3  Numbered List Style Options

List Name Example

Number 1, 2, 3, 4

Roman Small i, ii, iii, iv

Roman Large I, II, III, IV

Alphabet Small a, b, c, d

Alphabet Large A, B, C, D
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Nesting Lists
You can indent lists within lists to create 
nested lists. Because nested lists do not 
have to be of the same type, you can cre-
ate, for example, a numbered list with an 
indented bulleted list, and you can have 
multiple levels of nested lists within one 
overall list E.

E You can nest numbered lists inside bulleted lists.
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To create a nested list:
1.	 Click the end of a line within an existing 

list to place the insertion point.

2.	 Press Enter (Return).

Dreamweaver creates another line of 
the list.

3.	 Press Tab.

Dreamweaver creates a new indented 
sublist of the same type as the parent 
list. For example, if the parent list is a 
numbered list, the new sublist will also 
be a numbered list.

4.	 (Optional) If you want the sublist to be 
a different type of list than the parent 
list, click the Numbered List or Bulleted 
List button in the HTML mode of the 
Property inspector.

5.	 Type the list item.

6.	 Press Enter (Return).

Dreamweaver creates a new 
sublist item.

7.	 To return to the original list, use the up 
or down arrow keys to move the inser-
tion point into one of the items in the 
original list, or click to place the inser-
tion point where you want it.

  You can also click the Outdent button in 
the HTML mode of the Property inspector to 
merge the sublist back into the main list.

  Use the List Properties dialog to format 
sublists as well as lists.

  If you try to create a sublist within a 
list that is in a table by pressing Tab, Dream-
weaver jumps to the next cell rather than 
indenting and creating a nested list. One work-
around is to create the nested list outside of 
the table, cut it, and then paste it in the table 
cell where you want it to go.
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Inserting Special 
Characters
You can add special characters, such as 
the Euro, copyright, or trademark symbol, 
to your page in Dreamweaver without 
having to remember their bizarre HTML 
equivalents or odd keyboard combina-
tions. In Dreamweaver, relief is just a menu 
choice away.

About Non-Breaking Spaces
An oddity about HTML is that it ignores multiple spaces. One of the special characters you can 
insert is the non-breaking space, which is useful for adding multiple consecutive spaces and occa-
sionally for nudging text and even images. Dreamweaver uses the HTML code for a non-breaking 
space (which is &nbsp;) inside paragraph tags so that blank lines appear in Web browsers, like so:

<p>&nbsp;</p>

If you want multiple spaces between words, insert one or more non-breaking spaces. The easi-
est way to do this is to press Ctrl-Shift-spacebar (Cmd-Shift-spacebar), but you can also use the 
Characters pop-up menu in the Text category of the Insert panel or the Insert > HTML > Special 
Characters submenu.

Dreamweaver by default ignores multiple spaces, but you can change this behavior and force the 
program to insert multiple non-breaking spaces in the code. Choose Edit > Preferences (Dream-
weaver > Preferences), choose the General category, and then select the check box next to “Allow 
multiple consecutive spaces.”
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To insert a special character:
1.	 Click in the page to place the insertion 

point where you want the special char-
acter to appear.

2.	 In the Text category of the Insert panel, 
choose the character you want from the 
Characters pop-up menu A.

or

Choose Insert > HTML > Special Char-
acters, and then choose the special 
character you want from the submenu.

or

If the character you want doesn’t 
appear in the menu, choose Other 
Characters from the pop-up menu in 
the Insert panel or choose Other from 
the Insert > HTML > Special Characters 
submenu. The Insert Other Character 
dialog appears B.

3.	 Click the character you want to use, and 
then click OK to close the dialog.

Dreamweaver inserts the special char-
acter on your page.

A Insert unusual 
characters from the 
Characters pop-up 
menu in the Text 
category of the 
Insert panel.

B The Insert Other Character dialog provides 
the rest of the special characters Dreamweaver 
can insert.
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Adding Automatic 
Dates
Dreamweaver can insert the current date 
and time in a variety of formats into your 
Web page. You can choose whether or not 
to add the day of the week.

To insert the current date:
1.	 Click in your page to place the inser-

tion point where you want the date 
to appear.

2.	 Choose Insert > Date.

The Insert Date dialog appears A.

3.	 Do one or more of the following:

>	 If you want the name of the day to 
appear, use the Day format pop-up 
menu to set the appearance of the 
day of the week.

>	 Make a selection from the Date 
format list.

>	 If you want the time to appear, 
choose the 12-hour or 24-hour format 
from the Time format list.

>	 Select “Update automatically on 
save,” if you want that to happen. This 
is very useful if you want visitors to 
your site to know when the page was 
last updated.

4.	 Click OK.

Dreamweaver inserts the date (and 
any additional items you chose) into 
your page.

A Dreamweaver lets you insert dates into your 
pages in a variety of formats.
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Finding and Replacing
Dreamweaver’s Find and Replace feature 
can save you a lot of time, because you 
can automatically find and change text on 
a single page, in pages within a folder, on 
pages you select, or throughout your site. 
You can choose to change text in Design 
view, or you can search and change just in 
Code view.

Imagine that you have a company’s site 
with dozens of pages devoted to sing-
ing the praises of its premier product, the 
amazing WonderWidget. Then one day 
you get a call from your client letting you 
know that because of a trademark dispute, 
the company has to rename the product 
WonderThing. Rather than opening each 
page and making one or more changes on 
each of them, just put Dreamweaver’s Find 
and Replace feature to work, and you’ll be 
done in just a few minutes.

The Find and Replace window
The Find and Replace window, which you 
open by choosing Edit > Find and Replace 
or by pressing Ctrl-F (Cmd-F), will be the 
tool you use for changing text A. Let’s 
look at some of this window’s parts.

Save Query Load Query

Find in pop-up menu

Search pop-up menu

Find field

Replace field

Search options

A The Find and Replace dialog provides a lot of power for making quick changes 
on a single page or throughout your site.
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n	 The Save Query button allows you to 
save searches for later use. This is great 
for instances where you create complex 
queries, so you don’t have to do all the 
work to set up the search again.

n	 The Load Query button allows you to 
retrieve a saved search.

n	 The Search options let you constrain 
your searches. “Match case” returns 
results with the same uppercase and 
lowercase letters as the text you 
entered in the Find field. “Match whole 
word” finds the text only if it matches 
one or more complete words. “Ignore 
whitespace” tells Dreamweaver not 
to pay attention to additional spaces 
and non-breaking spaces. It’s on by 
default, and it’s usually best to leave 
it on. Finally, “Use regular expression” 
(covered later in this chapter) lets you 
use wildcard characters to construct 
extremely complex searches.

n	 The Find in pop-up menu allows you 
to tell Dreamweaver the scope of the 
search. You can choose to find text in 
the Current Document (the default); 
Selected Text; Open Documents; in a 
Folder you select; in Selected Files in 
Site; or in the Entire Current Local Site.

n	 The Search pop-up menu lets you 
choose what kind of search you want 
to do. You can choose Text; Text 
(Advanced), which gives you additional 
search options; Source Code, which 
allows you to search in the HTML; or 
Specific Tag, which searches the con-
tents of HTML tags that you select. The 
latter two options are covered later in 
this chapter.

n	 The Find field is where you enter the 
text you want to find.

n	 The Replace field is where you enter 
the text you want to use to replace the 
found word.
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Finding Text with 
a Simple Search
Simple searches in Dreamweaver work 
pretty much the same way that they do 
in a word processor. Just enter the text 
you want to find and the text that you 
want to replace it with, and away you 
go. Of course, you don’t have to replace 
text; if you want you can just use the Find 
and Replace dialog to find text in one or 
more files.

To find text:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears 
(see figure A in “The Find and Replace 
window”).

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3.	 From the Search pop-up menu, 
choose Text.

4.	 In the Find field, type the word or 
phrase that you’re looking for.
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5.	 Click the Find Next button.

Dreamweaver finds and highlights the 
found text. If the scope of the search 
included more than one page, Dream-
weaver opens the first file the text was 
found within and highlights the text. If 
the text isn’t found, you’ll get a mes-
sage to that effect at the bottom of the 
Find and Replace dialog.

or

Click the Find All button.

Dreamweaver does the search, closes 
the Find and Replace dialog, and opens 
the Search tab of the Results panel A.

6.	 If you clicked Find All in step 5, double-
click one of the search results in the 
Results panel to open it and highlight 
the found text.

  If you select some text before you bring 
up the Find and Replace dialog, the text auto-
matically appears in the Find field, as long as 
you selected fewer than 255 characters.

  You can do a quick find on the current 
page by selecting some text and then choos-
ing Edit > Find Selection or pressing Shift-F3 
(Cmd-Shift-G). Dreamweaver highlights the 
next occurrence of the text you selected.

Reopen Find and Replace 
with same search items

Cancel currently 
running search

A The Search tab of the Results panel shows you the filename and matched 
text when you click the Find All button.

  You can click the green triangle button 
in the Results panel to reopen the Find and 
Replace dialog with the same search terms.

  If you have a search that’s running for a 
very long time, you can cancel it by clicking the 
octagonal red Cancel button in the Results panel 
(this button is dimmed in figure A).

  You can clear the search results in the 
Results panel by right-clicking in the panel and 
choosing Clear Results.
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To find the next result:
Choose Edit > Find Next, or press 
F3 (Cmd-G).

Dreamweaver finds and highlights the next 
result of the search without reopening the 
Find and Replace dialog.

To find and replace text:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3.	 From the Search pop-up menu, 
choose Text.

4.	 In the Find field, type the word or 
phrase that you’re looking for.

5.	 In the Replace field, type the replace-
ment word or phrase.

6.	 Click the Find Next button.

When Dreamweaver finds the text, it 
is highlighted.

7.	 Click the Replace button.

Dreamweaver replaces the found text 
with the contents of the Replace field.

or

Click Replace All.

Dreamweaver warns you that you can-
not undo changes made in unopened 
files. Of course, you can undo changes 
in any open documents by choosing 
Edit > Undo. If you still want to make the 
changes, click Yes.

Dreamweaver searches through the 
entire scope of the search, replacing 
all occurrences of the found text. When 
it is done, you’ll see a message telling 
you how many changes it made.

  Use a Replace operation to expand 
abbreviations and save time while you’re cre-
ating pages. For example, let’s say that you’re 
creating a Web site about JavaScript. Rather 
than typing JavaScript again and again while 
writing the site, just type “JS”; then before you 
upload the site, do a Find and Replace, chang-
ing every occurrence of “JS” to “JavaScript.” 
You can do the same thing with company 
names, people’s names, or almost any text 
that you repeat a lot.

  Dreamweaver does not update the 
Search tab of the Results panel when you 
perform Replace operations.

  If you get a bunch of search results but 
only want to make replacements in some 
of those results, you can do that—and save 
a bunch of time in the process. Rather than 
opening each page separately and apply-
ing the replacement, do it all in one swoop 
by using the Results panel and the Find and 
Replace dialog together. First, click the green 
triangle in the Results panel, which reopens 
the Find and Replace dialog. In the Results 
panel, Ctrl-click (Cmd-click) the results where 
you want to make replacements. Those lines 
will highlight. Then switch back to the Find 
and Replace dialog, and click Replace (not 
Replace All). The files that are modified are 
marked by a green dot next to their names in 
the Results panel.
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Performing Advanced 
Text Searches
An advanced text search allows you to 
do a more precise search by looking for 
text within (or outside of) particular HTML 
tags. You can further fine-tune the search 
by specifying particular attributes of the 
HTML tags.

Perhaps the most common example of why 
you would want to use such a search lies in 
the title of your Web pages. Whenever you 
create a new page in Dreamweaver, the 
page automatically gets the title “Untitled 
Document.” If you forget to enter titles, you 
could end up with a bunch of pages on 
your site with the same “Untitled Docu-
ment” name (it’s easy to do; while writing 
this section, I found and fixed a page on my 
personal site that had been titled “Untitled 
Document” for four years!). A basic search 
and replace won’t help, because “Untitled 
Document” is within the <title> tag of the 
pages, and a basic search only searches 
the body of a document. An advanced text 
search, which combines text and HTML 
searches, is the solution.

To perform an advanced text search:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

continues on next page
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3.	 From the Search pop-up menu, choose 
Text (Advanced).

The dialog changes and adds the 
option to search tags A.

4.	 In the Find field, type the word or 
phrase that you’re looking for.

5.	 Choose either Inside Tag or Not Inside 
Tag from the pop-up menu next to the 
+ and – buttons.

Inside Tag refers to text that is enclosed 
within a container tag, such as <p>…</p>.

6.	 Choose an HTML tag from the Tag 
pop-up menu.

7.	 (Optional) If you want to narrow the 
search further by limiting the search 
to a particular attribute of the tag you 
chose in step 6, click the + button. If you 
do not, skip to step 12.

The attribute line is added to the 
dialog B.

An example of an attribute would be 
the class attribute of the <table> tag.

Tag pop-up menu

A The Text (Advanced) option allows you to search for text within HTML tags.



Adding Text to Your Pages  123

8.	 (Optional) From the first pop-up menu in 
the attribute line, choose With Attribute 
or Without Attribute.

9.	 (Optional) Choose the attribute you 
want from the next pop-up menu.

Dreamweaver only shows the attributes 
for the tag you chose in step 6.

10.	(Optional) Set a comparison in the next 
pop-up menu, choosing from = (equal), 
< (less than), > (greater than), or != (not 
equal). These only work if the attribute’s 
value is a numeric amount, such as the 
size attribute of the <input> tag—for 
example, <input size="4">.

11.	 (Optional) In the next field (which is also 
a pop-up menu), type the value of the 
attribute. This can be a number or text.

or

Choose [any value] from the pop-up 
menu. This is useful when you want 
all tags with a particular attribute, but 
you don’t care what the value of the 
attribute is.

12.	If you want to replace the found text, 
type the replacement word or phrase in 
the Replace field.

13.	Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

B You can narrow your search further by adding one or more attributes 
to the tag search.

  For more information about the different 
HTML tags and their attributes, choose Win-
dow > Results > Reference, click the Results 
panel, click the Reference tab, and from the 
Book pop-up menu choose O’Reilly HTML 
Reference.
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Finding and Replacing 
in Source Code
Dreamweaver’s ability to find and replace 
within the HTML source code is extremely 
powerful. You can look for text within par-
ticular tags, and you can even look within 
particular tags for specific attributes. You 
can also find text relative to other tags. For 
example, you can change specified text 
within a <table> tag and leave everything 
else alone. If you like, you can even use 
Find and Replace to replace, delete, or 
change tags and attributes.

Searching and replacing inside source 
code is much like regular text searches 
except you’ll be working in Code view. 
When you perform the search, Dream-
weaver automatically changes to Code 
view, so you don’t have to do it manually 
before you start the search.

To find and replace in source code:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3.	 From the Search pop-up menu, choose 
Source Code A.

4.	 In the Find field, type the word or 
phrase that you’re looking for.

5.	 In the Replace field, type the replace-
ment word or phrase.

6.	 Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

A Choose Source Code to search the HTML in 
Code view.

  If you choose Current Document from 
the Find in pop-up menu, searches will not 
search related files, such as attached CSS 
or JavaScript files. To include those in your 
search scope, choose Open Documents in the 
Find in pop-up menu.



Adding Text to Your Pages  125

Finding and Replacing 
with a Specific Tag
A specific tag search lets you find and 
modify HTML tags. This has many uses; for 
example, you may still need to convert old 
sites that used <font> tags to CSS. You 
can use a specific tag search to strip out 
all those old tags, replacing them with CSS 
classes. Or you can change the now-passé 
<b> and <i> tags to their more modern 
equivalents, <strong> and <em>.

The key to the specific tag search is the 
Action menu, which specifies what replace-
ment action Dreamweaver will carry out on 
the tags found in the search. See Table 4.4 
for a list of the actions available.

Table 4.4  Action Menu Options

Action Description

Replace Tag & Contents Replaces the tag and everything within the tag with the contents of the 
field that appears to the right of the Action pop-up menu when this action is 
selected. This can be either plain text or HTML.

Replace Contents Only Replaces the contents of the tag with the contents of the With field.

Remove Tag & Comments Deletes the tag and all of its contents.

Strip Tag Removes the tag, but leaves any content within the tag.

Change Tag Substitutes one tag for another.

Set Attribute Changes an existing attribute to a new value, or adds a new attribute.

Remove Attribute Removes an attribute from a tag.

Add Before Start Tag Inserts text or HTML before the opening tag.

Add After End Tag Inserts text or HTML after the closing tag.

Add After Start Tag Inserts text or HTML after the opening tag.

Add Before End Tag Inserts text or HTML before the closing tag.



126  Chapter 4

To find and replace within 
a specific tag:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3.	 From the Search pop-up menu, choose 
Specific Tag.

The Find and Replace dialog changes 
to show the tag functions A.

4.	 Choose the tag that you want from the 
tag pop-up menu that appears next to 
the Search pop-up menu.

You can either scroll the pop-up menu 
to find a tag, or you can type the first 
letter of the tag in the box. Dream-
weaver automatically scrolls the list. 
Depending on the tag you choose, 
Dreamweaver will change the available 
actions in the Action pop-up menu, so 
don’t be surprised if the contents of that 
menu look a bit different from those 
listed in Table 4.4.

A When you are searching within a specific tag, you can add attributes 
for that tag, and you can also specify actions that you want to perform 
on the found tag.
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5.	 (Optional) If you want to narrow the 
search to a particular attribute of the tag 
that you selected, click the + button and 
then choose values for that attribute, as 
discussed previously in this chapter.

If you want to narrow the search further, 
you can do so by clicking the + button 
and adding attributes.

6.	 Choose from the Action pop-up menu 
and, depending on the action you 
chose, set any required values.

7.	 Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.
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Using Regular 
Expressions for 
Searching
A regular expression is a pattern, writ-
ten using special symbols, that describes 
one or more text strings. You use regular 
expressions to match patterns of text, so 
that Dreamweaver can easily recognize 
and manipulate that text. Like an arith-
metic expression, you create a regular 
expression by using operators—in this 
case, operators that work on text rather 
than numbers.

The operators in a regular expression 
(see Table 4.5 on the next page) are like 
the wildcard symbols that you may have 
seen in find and replace features in other 
programs, such as word processors, 
except that regular expressions are much 
more powerful. They can also be complex 
and difficult to learn and understand, so 
if Dreamweaver’s other find and replace 
methods are sufficient for you, you may not 
need to bother with regular expressions.

Learning regular expressions is beyond 
the scope of this book, but we’ll show you 
how to use one in an example. Let’s say 
that you want to find all of the HTML com-
ments throughout your site. You can use 
this simple regular expression (we know 
it looks weird, but don’t lose heart; all will 
be explained):

<!--[\w\W]*?-->
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Table 4.5  Regular Expression Special Characters

Character Matches

\ Escape character; allows you to search for text containing one of the below special 
characters by preceding it with the backslash

^ Beginning of text or a line

$ End of text or a line

* The preceding character zero or more times

+ The preceding character one or more times

? The preceding character zero or one time

. Any character except newline

\b Word boundary (such as a space or carriage return)

\B Non-word boundary

\d Any digit 0 through 9 (same as [0-9])

\D Any non-digit character

\f Form feed

\n Line feed

\r Carriage return

\s Any single whitespace character (same as [ \f\n\r\t\v])

\S Any single non-whitespace character

\t Tab

\w Any letter, number, or the underscore (same as [a-zA-Z0-9_])

\W Any character other than a letter, number, or underscore

[abcde] A character set that matches any one of the enclosed characters

[̂ abcde] A complemented or negated character set; one that does not match any of the 
enclosed characters

[a-e] A character set that matches any one in the range of enclosed characters

[\b] The literal backspace character (different from \b)

{n} Exactly n occurrences of the previous character

{n,} At least n occurrences of the previous character

{n,m} Between n and m occurrences of the previous character

() A grouping, which is also stored for later use

x|y Either x or y
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Let’s break down that expression. You read 
a regular expression from left to right. This 
one begins by matching the beginning 
characters of the HTML comment, <!--. 
The square brackets indicate a range of 
characters; for example, [a-z] would match 
any character in the range from a to z. In 
this case, the range includes two regular 
expression operators: \w means “any single 
letter, number, or the underscore,” and \W 
means “any character other than a letter, 
number, or underscore.” Taken together as 
a range, [\w\W] means “any character.”

The * means “the preceding character 
(in this case, everything found by the 
contents of the square brackets) zero or 
more times,” and the ? means “the pre-
ceding character zero or one time.” Taken 
together, they match a comment of any 
length. The regular expression ends by 
matching the closing characters of an 
HTML comment, -->.

To search with a regular expression:
1.	 Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2.	 From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.
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3.	 From the Search pop-up menu, choose 
any of the options.

In this case, since we’re looking for 
HTML comments, you should choose 
Source Code.

4.	 Enter the regular expression in the Find 
field A.

5.	 Select the check box next to “Use regu-
lar expression.”

When you choose “Use regular 
expression,” it disables the “Ignore 
whitespace” search option, because 
they are mutually exclusive.

6.	 (Optional) Enter text or a regular expres-
sion in the Replace field.

7.	 Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

  There’s a lot to say about regular expres-
sions, certainly enough to fill an entire book or 
12. If you’re interested in learning more, check 
out Mastering Regular Expressions by Jeffrey 
Friedl (O’Reilly Media, 2006). For a lighter 
read, try Teach Yourself Regular Expressions in 
10 Minutes by Ben Forta (Sams, 2004). There 
are also many Web sites that provide regular 
expression tutorials, which you can find with a 
Google search.

A You can add regular expressions to both the Find and Replace fields.
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Checking Spelling
No word processor comes without a spell-
ing checker these days, and Dreamweaver 
is no different (even though it’s not a word 
processor). You can check the spelling on 
the currently open page and add words 
to Dreamweaver’s spelling checker in a 
personal dictionary.

To spell-check your page:
1.	 Choose Commands > Check Spelling, 

or press Shift-F7 (same on Windows 
and Mac).

If Dreamweaver finds a word it believes 
is spelled incorrectly, the Check Spell-
ing dialog opens A. Otherwise, you’ll 
get a dialog that says “Spelling check 
completed.”

2.	 Click the Add to Personal button if the 
word Dreamweaver found is correct 
and you want to add it to your personal 
dictionary so that Dreamweaver doesn’t 
flag it as an error again.

or

Click Ignore to tell the spelling checker 
to ignore this instance of the word, 
or click Ignore All to ignore the word 
throughout the document.

or

Select a replacement from the Sug-
gestions list, or type the replacement 
in the Change to text box. Then click 
the Change button, or click Change 
All to replace the word throughout 
the document.

3.	 When the spelling check is finished, 
click Close.

A Click Add to Personal in the Check Spelling 
dialog to add an unknown word to the user’s 
personal Dreamweaver dictionary.
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Index

Media Encoder, 160, 162
Photoshop. See Photoshop
Web sites, 480–483
Widget Browser, 366–371

Adobe Dreamweaver CS5 with PHP, 486
Adobe TV, 482
Advanced Settings category, 30, 52, 171, 224, 330
Ajax Essential Training, 485
alignment

cell, 286
with HTML, 105–107
shortcut keys, 107
table, 285

All mode, CSS Styles panel, 198–200
All Rules pane, 255
alternate text, 65, 134, 135, 136
anchors, 175–177
animations, 158–159
Apache, 382
AP elements, 230. See also absolute positioning
App Developer workspace, 20, 421
Appearance (CSS), Page Properties dialog, 80, 

81–82, 212
Appearance (HTML), Page Properties dialog, 

82–83, 212
Application bar, 6
Application frame, 8
ASP, 447
Assets panel

accessing library items from, 404–406, 408, 410
accessing templates from, 394, 398–400
buttons/controls, 138
inserting images from, 138
updating Smart Objects in, 153

Attach External Style Sheet dialog, 255
authentication, 32, 33, 36

B
<b> tag, 102
backgrounds

color, 82, 83, 234–236, 287
CSS rule definitions, 190
images, 82, 154–155

base URLs, 87

Symbols
# (pound sign) using with anchors, 177

using with id selectors, 189, 194, 195–197
() (parentheses), selecting in Coding toolbar, 417
. (period), before class selectors, 194
// comments, applying from Coding toolbar, 

417–418
/* */ comment, applying from Coding toolbar, 

417–418
[] (square brackets) selecting in Coding toolbar, 417
_ (underscore), preceding targets with, 174
{} (braces), selecting in Coding toolbar, 417
<!--  --!> comments, applying from Coding 

toolbar, 417–418
</, ending tags with Code Hints, 437
' comments, applying from Coding toolbar, 

417–418
2-column liquid layout, 233–234
2-up view, 78–79

A
absolute links, 168
absolute positioning, 229, 230, 317
accessibility

and alternate text for images, 65, 134, 135
and new browser windows, 348
preferences, 65, 135, 303
recommended book on, 447

access keys, 303
Action menu, 125
active links, 83, 84, 173
Add Web Font dialog, 224
Adobe

BrowserLab, 15, 71, 76–79, 230
Business Catalyst, 15, 18, 20, 392, 394, 395
Contribute, 392, 395, 457, 463
Creative Cloud, 18, 392
Creative Suite, 392
Dreamweaver. See Dreamweaver
Exchange, 366, 493
Extension Manager, 493, 496
Fireworks, 140, 143, 359–360, 461
InContext Editing, 18, 392
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behaviors, 339–360
adding, 341–342
changing order of, 343
deleting, 343
editing, 342
list of, 340
for specific purposes

checking for plug-ins, 351–352
inserting Fireworks pop-up menus, 359–360
inserting jump menus, 353–355
inserting rollovers, 345–347
opening new browser window, 348–350
validating forms, 356–358

Behaviors panel, 339, 341–343, 347, 357, 365, 
445, 493

Behaviors tab, Tag Inspector panel. See Behaviors 
panel

Bezier curves, 374
Block, CSS rule definitions, 190
<blockquote> tag, 105, 106
blogs, 481
blog software, 378
<body> tag, 13, 154, 155, 189, 192, 194, 195, 234, 

351, 404, 408, 444,
bold text, 101
bonus chapters, xv, 91, 174, 343, 350, 364, 392
book resources

Adobe Dreamweaver CS5 with PHP, 486
CSS Detective Guide, The, 486
Designing with Web Standards, Third Edition, 

486
Dreamweaver CS6 Bible, 486
Dynamic HTML, The Definitive Reference, 447
HTML5 and CSS3 Visual QuickStart Guide, 446
JavaScript: Visual QuickStart Guide, 343, 363, 

447, 486
Mastering Regular Expressions, 131
Styling Web Pages with CSS: Visual 

QuickProject Guide, 447, 486
Teach Yourself Regular Expressions, 131
UsableNet Accessibility Reference, 447

Border, CSS rule definitions, 191
borders

image, 142
table, 273

Box, CSS rule definitions, 191
box model, 228, 261
box-shadow property, 74
breaks

line, 104
page, 192

Brightness/Contrast dialog, 145–146
broken links, 469–470
Browse for File button, 62, 63, 166
Browse pop-up menu, 40, 41, 42
browser compatibility, checking, 472–474
BrowserLab (Adobe), 15, 71, 76–79, 230
Browser Navigation toolbar, 12, 388, 389, 390
browsers. See Web browsers

browser-specific properties, 210
browser window, opening new, 348–350
<br> tag, 104
bulleted lists, 108, 110. See also lists
Business Catalyst (Adobe), 15, 18, 20, 392, 394, 395

C
captions, table, 272
Cascading Style Sheets. See CSS
Castro, Elizabeth, 446
cells. See also tables

defined, 270
merging/splitting, 280
padding/spacing for, 273
selecting, 275
setting properties for, 286–287
wrapping of text in, 283

certificate authorities, 33
CGI, 298, 310
character formatting, 100
Characters pop-up menu, 114
cheat sheet, keyboard command, 492
check boxes, 305
Check Browser Compatibility command, 474
Check In/Check Out feature, 451, 456–460, 465
Check Page pop-up menu, 473–474
Check Plugin behavior, 351–352
Check Spelling dialog, 132
Choose Root Folder dialog, 29
Chrome (Google), 11, 23, 69, 74, 210, 438
classes

applying, 205–206, 209, 214
creating, 193, 213–214
pseudo-classes, 197, 205
removing, 207, 208
renaming styles for, 244–245
vs. id selectors, 194

Classic workspace, 20
Class pop-up menu, 244
Cloak command, 52
cloaking files/folders, 52, 394
CMSs, 377–390

back-end administrative interface for, 384
connecting to, 380–381
discovering related files in, 384–386
Dreamweaver support for, 27, 377, 378
how they work, 378, 384
installing, 378
meaning of acronym, 377
most popular, 377–379
purpose of, 377
recommended Web sites on, 482–483

code, 415–450
collapsing, 433–435
editing, 24, 415, 422–423, 428–430
expanding, 435
extracting embedded, 444–445
finding and replacing, 124–127



Index  499

formatting, 423
highlighting invalid, 418
hinting. See code hints
indenting, 422
reference material, 446–447
snippets. See snippets
validating, 448–450
viewing

in Code view, 416–419
in Live Code view, 426–427
in Split view, 424–425

Code Coloring preferences, 422
Code Format options, 423
code hints, 436–441

for CSS, 74, 438
for DOM elements, 440–441
for HTML, 436–437, 438
for jQuery, 439
for PHP, 437

Code Navigator feature, 217, 225–226, 238, 417
Code Reference tab, 446–447
Coder workspace, 20, 420–421
Coder Plus workspace, 20, 421
Code view

finding and replacing code in, 124–127
how pages appear in, 10, 416
opening HTML files in, 419
reasons for using, 415
using Coding toolbar in, 416–419

Coding toolbar, 226, 416–419, 422, 425
collapsing code, 433–435
color

background, 82, 83, 234–236, 287
hex vs. RGB/RGBA, 203
values, 203, 236

color property values, 203
columns. See also tables

deleting, 284
inserting, 278–279
resizing, 282
selecting, 274–275

Commands menu, 23, 493
Common tab, Insert panel, 17
companion Web site, this book’s, xv, 91, 174, 343, 

364, 392, 479
compound selectors, 195–197
containers, 90, 185, 189
content management systems, 377. See also CMSs
content vs. presentation, 184–185, 268, 328
context menus, xv, 20, 92
contextual selectors, 195, 197
Contribute (Adobe), 392, 395, 457, 463
Contribute 3 Essential Training, 485
Convert Inline CSS dialog, 247–248
Copy command, 45, 92
copying and pasting, 92–93, 149–151
Creative Cloud (Adobe), 18, 392
Creative Edge, 485
Creative Suite (Adobe), 392

cropping images, 144
CSS. See also styles; style sheets

benefits of using, 183, 184
box model, 228, 261
categories, 190–192
code hints for, 74, 438
content vs. presentation, 184–185, 268
creating compound styles in, 195–197
enable/disable rules feature, 262–263
and HTML tags, 185
Inspect mode, 11, 258–259, 386
layout basics, 228–230
layout blocks, 265, 266
recommended books on, 446, 447, 486
Rule Definition dialog. See CSS Rule Definition 

dialog
setting appearance with, 82
setting headings with, 84
setting link appearance with, 83–84
setting preferences for, 186
Styles panel. See CSS Styles panel
transitions, 24, 372–376
and Web fonts, 220–223

CSS3 properties, 203–204
CSS-based layouts

and CSS inspection, 258
and design-time style sheets, 264
purpose of, 315

CSS Detective Guide, The, 486
.css file extension, 202, 251
CSS Layout Backgrounds, 261
CSS Layout Outlines, 261
CSS Rule Definition dialog

categories in, 190–192
creating rules for links in, 173
modifying styles with, 215
purpose of, 184
saving external style sheet in, 251

CSS Styles panel
adding CSS3 properties in, 203–204
attaching style sheet in, 254–255
buttons/controls, 187
creating rule from inline style in, 247–248
deleting styles in, 246
formatting links in, 172–173
laying out pages in, 234–235
modifying styles in, 215
purpose of, 184
renaming styles in, 244
using browser-specific properties in, 210
using CSS Enable/Disable in, 262–263
working in All mode, 198–200
working in Current mode, 200–201

CSS tab, Property inspector, 14, 211
CSS Transitions panel, 372
Current mode, CSS Styles panel, 200–201
Custom Filter dialog, 387
Cut command, 45, 92
cutting and pasting, 92–93
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D
database-backed sites, 27, 32
Data tab, Insert panel, 17
data sets, 362
dates, 115
Default Editor dialog, 5
definition lists, 108–109
delimited text files, 291, 294
dependent files, 47, 333, 459–460
descendant selectors, 195, 197
description, site, 87, 88
Designer Compact workspace, 20
Designer workspace, 20
Designing with Web Standards, Third Edition, 486
Design Notes, 461–463
design-time style sheets, 264–266
Design view, 10, 55, 69, 91, 93
Desktop preset, 330, 331
DesktopServer, 383
Desktop viewport, 327
Developer Center, Dreamweaver, 72, 481
dimensions, setting page, 323–324
Direction pop-up menu, 50
Disable JavaScript command, 390
<div> tag, 189, 197
dock area, 15–16
doctype, 57, 85
document relative links, 168, 170
Document toolbar, 7, 9
Document Type Definition, 57, 85
document views, 10–11
document window, 7–9, 315
Dojo, 362
DOM elements, code hints for, 440–441
Down state, 347
dragging and dropping

styles, 256–257
text, 94

Dreamweaver
adding extensions to, 4, 487, 493–496
built-in JavaScript actions, 339–340
built-in reference books, 446
and CMSs, 377, 378. See also CMSs
collaboration features, 451
CSS categories, 190–192
customizing, 487–492
Developer Center, 72, 481
document window, 7–9
event handlers, 344
Exchange, 4, 343, 480, 493–494
file/folder terminology, 26–27
file management with, 43
frameworks, 361
and HTML5, 204
importing Excel data to, 291–293
interface, 2–18
knowledge required for, xiv
layout tools, 315–338

mailing list, 484
menu bar, 6
naming conventions, 396
new features in CS6, 22–23
online resources, 4, 479–485
platform considerations, xiv–xv
purpose of, xiii
recommended books on, 486
setting up workspace in, 19–21
site management tools, 391. See also Web site 

management
templates, 59
tutorials, 4, 482
Welcome screen, 2–5

dreamweaverbook.com. See companion Web 
site, this book’s

Dreamweaver CS6 Bible, 486
Drupal, 27, 377, 379, 483
DTD, 57, 85
Dual Screen layout, 20
Duplicate command, 45
.dwt file extension, 394
dynamically related files, 384–386
Dynamic HTML, The Definitive Reference, 447
dynamic pages, 449–450
dynamic sites, 27

E
Edit Browser List command, 71
Edit Font List dialog, 218
Edit Guides command, 319
Edit menu, 45, 93, 95, 455
Edit Tag command, 430
editable optional regions, 397
editable regions

adding, 395–396
purpose of, 393
removing, 397
types of, 397

editing
behaviors, 342
browser list, 71
code, 24, 415, 422–423
files/folders, 45
Flash video files, 162
font lists, 218–219
images, 143–146, 151–152
jump menus, 354
library items, 406–408
plug-in file’s properties, 164
preset window sizes, 324
property values, 215
site definitions, 38
snippets, 414
templates, 400–402

Editor setup, 5
effects, 362, 364, 365
<em> tag, 102, 211
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email links, 181
enclosure types, 299
encodings, 80, 81, 85
encryption, 32, 33
Enctype, 299
event handlers, 344
Excel (Microsoft), 91, 95–96, 291–293
Exchange. See Dreamweaver Exchange
Expand/Collapse button, 48, 452
Expanded Tables mode, 276–277
expanding code, 435
explicit encryption, 32, 33
exporting

site definitions, 476–478
tables, 294
widget presets, 371

Export Site dialog, 477
Export Table dialog, 294
Extend Dreamweaver menu, 367
Extension Manager (Adobe), 493, 495–496
extensions

Dreamweaver, 4, 487, 493–496
file, 45, 67

Extensions, CSS rule definitions, 192
external links, 471
external style sheets, 202

attaching to Web page, 254–255
creating, 249–251
moving internal styles to, 252–253

F
FAQ page, this book’s, xv
favicons, 156–157
Favorites tab, Insert panel, 18
fields. See also forms

adding, 300–301
hidden, 301
labeling, 302–303

fieldsets, 306
file extensions, 45, 67
File Field, Forms category, 296
file management, 43. See also Web site 

management
File menu, 68
files

adding/deleting, 39
annotating, 461–463
browsing, 40
checking in/out, 47, 459–460
cloaking, 52, 394
comparing local/remote, 48
creating, 44
finding orphaned, 471
locking/unlocking, 33
moving, 44
naming, 44, 45, 452
organizing, 43

putting/getting, 46–47
working with related, 216–217

Files panel
context menu in, 44
expanding, 48, 453–455
opening pages in, 68
purpose of, 39, 43
putting/getting files with, 47
selecting multiple files in, 455
vs. New Document dialog, 43

File Transfer Protocol, 33. See also FTP
File view pop-up menu, 41, 44
Filter extensions, 192
Filter Related Files menu, 387
Find All button, 119
Find and Replace dialog, 116–117, 122
Find and Replace feature, 116–131

advanced text searches with, 121–123
buttons/controls, 116–117
purpose of, 116
regular expression searches with, 128–131
simple text searches with, 118–120
source code searches with, 124
tag searches with, 125–127

Find in pop-up menu, 117
Find Next button, 119
Find Selection command, 119
Firefox (Mozilla)

and browser-specific CSS properties, 210
and CSS-based layouts, 268
and favicons, 156
and <label> tag, 302
and plug-in detection, 352
previewing pages in, 69

Fireworks (Adobe), 140, 143, 359–360
fixed positioning, 229
.fla file extension, 158
Flash (Adobe)

animation, 158–159
and BrowserLab, 76
video, 160–162
vs. image maps, 180

floating boxes, 230
fluid grid layouts, 22–23, 332–337
Fluid Layout workspace, 20
.flv file extension, 160
folders

browsing, 40
cloaking, 52, 394
comparing local/remote, 48
creating, 44
moving, 44
naming, 29, 44, 45, 452
planning structure of, 452
putting/getting, 46–47

@font-face property, 74, 220, 222
font families, 190
font groups, 218–219



502  Index

fonts
and CSS Type rule definitions, 190
displaying available, 218
for links, 83
sources of, 223
Web browser considerations, 219
for Web pages, 82, 220–224

font size, 82, 83, 84, 190
Font Squirrel, 223
<font> tag, 100, 211
footers, 235
Format menu, 98, 99, 107, 247, 264
formatting

code, 423
links, 172–173
tables, 290
text, 61

form fields. See fields
forms, 295–314

adding buttons to, 312–314
adding check boxes to, 305
adding fieldsets to, 306
adding pop-up menus to, 309–310
adding radio buttons to, 307–308
adding scrolling lists to, 311
adding text areas to, 304
adding text fields to, 300–301
adding to pages, 297–299
designating required fields in, 358
labeling fields in, 302–303
naming, 298
purpose of, 295, 297
red border around, 299
validating, 296, 356–358

Forms tab, Insert panel, 17, 295, 296
form validation widgets, 362, 364
Forta, Ben, 131
forums, 481
frames, 137, 142, 174, 341
framesets, 142, 344
frameworks, 361, 362–363
Freeze JavaScript command, 390
Friedl, Jeffrey, 131
FTP, 32, 33, 34–36
FTPS, 33

G
Get button, 51
GET method, 299
getting files/folders, 46–47
GIF files, 137
Go button, 355
Goodman, Danny, 447
Google

browser. See Chrome
and headings, 97
Web fonts, 220

Go To URL dialog, 341

graphic formats, 137
graphics. See also images

adding links to, 178
copying and pasting, 96
overuse of, 133

grids, 316–317. See also fluid grid layouts
Grid Settings dialog, 317
group selectors, 197
guides, 318, 319–320

H
Hand tool, 13
hard returns, 422
headings, 97–99

applying, 98
purpose of, 97
removing formatting from, 99

Headings (CSS), Page Properties dialog, 84, 212
<head> tag, 80, 87
hex values, 203, 236
hidden fields, 301
hidden files, 455
host directory, 36
hotspots, 179–180
hover style, 173, 213, 238
.htm/.html file extension, 45
HTML

aligning text with, 105–107
applying page properties with, 82–83
for bold/italic, 102
character formatting with, 100
code hints for, 436–437, 438
copying and pasting, 93
finding and replacing, 125–127
heading sizes, 97
indenting text with, 105–107
nesting elements in, 195
for non-breaking space, 113
recommended books on, 446, 447
reference, 123
tags. See HTML tags
text styles, 101–102
validating, 24, 448–450

HTML5, 57, 204, 446
HTML5 and CSS3 Visual QuickStart Guide, 446
HTML Reports category, 466
HTML tab, Property inspector, 14, 211
HTML tags. See also specific tags

applying with Property inspector, 211
creating style rules for, 188–189
and CSS, 185
finding and replacing, 125–127
purpose of, 90, 185
reference document, 123

Hyperlink dialog, 167
hyperlinks, 62–63. See also links
Hyslop, Bruce, 446
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I
.ico file extension, 157
icons, 156–157
id attribute, 141, 194, 205, 208, 302
IE. See Internet Explorer
image buttons, 313
image editing programs, 143. See also specific 

programs
image folders, 452
image formats, 137, 147
image maps, 141, 142, 179–180
Image Optimization dialog, 147, 151
image placeholders, 139–140
Image Preview dialog, 151
images, 133–155. See also graphics

adding alternate text to, 65, 134, 135, 136
adding borders to, 142
adding to pages, 64–65, 134–136
background, 82, 154–155
copying and pasting, 149–151
creating folders for, 30, 452
cropping, 144
deleting, 136
editing, 143–146, 151–152
inserting from Assets panel, 138
naming, 141
optimizing, 147
rollover, 345–347
setting properties for, 141–142
transparent, 203

image states, 347
Image Tag Accessibility Attributes dialog, 65, 135
implicit encryption, 32, 33
@import rule, 221–222
importing

site definitions, 476, 478
widget presets, 371
Word documents/data, 91, 293

Import Site dialog, 478
Import Tabular Data dialog, 292
Include Unicode Signature (BOM), 85
InContext Editing (Adobe), 18, 392
InContext Editing tab, Insert panel, 18, 394
Indent Code button, 422
indenting

with Coding toolbar, 422
with CSS Block rule definitions, 190
with HTML, 105–106

index page, 26, 31, 54
inheritance, 201
inherit positioning, 229
inline style rules, 247–248
inline styles, 202, 213–214, 247–248
Input Tag Accessibility Attributes dialog, 302–303
Insert Date dialog, 115
Insert Div Tag dialog, 197, 250, 251
Insert Fireworks HTML dialog, 359
Insert Jump Menu dialog, 353

Insert menu, 365, 483
Insert Other Character dialog, 114
Insert panel

location of, 7
purpose of, 17
tabs, 17–18, 61
vs. Insert bar, 18

Insert Rollover Image dialog, 346
Inspect mode, CSS, 11, 258–259, 386
interactivity, 341, 361, 390
internal styles, 189, 202, 252–253
Internet Explorer (Microsoft)

and browser-compatibility errors, 474
and browser-specific CSS properties, 210
and CSS-based layouts, 268
and CSS Filter extensions, 192
and CSS rendering, 69, 78
and favicons, 157
and plug-in detection, 351
and PNG graphics, 137

invisible characters, 104
<i> tag, 102
italicized text, 101

J
Jacobs, Denise R., 486
JavaScript

behaviors, 339–343
disabling, 390
event handlers, 344
extracting embedded, 444–445
frameworks, 361, 362, 366
freezing, 390
and mobile layouts, 338
recommended book on, 343, 363, 447, 486
and Spry, 361, 362

JavaScript Essential Training, 485
JavaScript Extractor, 444–445
JavaScript: Visual QuickStart Guide, 343, 363, 

447, 486
Joomla, 27, 377, 379, 483
JPEG files, 137
jQuery

code hints for, 439
strengths of, 363

jQuery-based pages, 58, 338
jQuery Mobile tab, Insert panel, 17
jQuery Mobile JavaScript framework, 338
JSP, 447
jump menus, 296, 340, 353–355
justifying text, 107

K
keyboard shortcuts, xiv, 488–492
keywords, 87, 88
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L
<label> tag, 302, 303
LAMP, 382–383
layout blocks, 265, 266
Layout tab, Insert panel, 17
layouts

for coders, 420–421
CSS-based. See CSS-based layouts
and CSS box model, 228–230
jQuery-based, 58, 338
for mobile devices, 22, 58, 325
starter, 204
using Dreamweaver’s included, 231–232
using tables for, 267, 268–269

layout tables, 268
layout tools, 315–338

fluid grid layouts, 332–337
grids, 316–317
jQuery, 338
media queries, 328–331
multiscreen preview, 325–327
rulers/guides, 318–320
setting page dimensions, 323–324
zooming in on page, 321–322

.lbi file extension, 404

.LCK file extension, 457
Library folder, 404, 409
library items, 403–410

creating, 403–404
defined, 392
deleting, 405
detaching, 409, 410
editing, 406–408
file extension for, 404
inserting, 405
naming/renaming, 404, 408
and Property inspector, 409–410
re-creating missing/deleted, 410
updating, 407
vs. snippets, 411
vs. templates, 403

line breaks, 104
line numbers, 422
link properties, 83
Link Relative To, 170–171
<link> tag, 226
links, 165–181

adding anchors to, 175–177
adding to graphics, 178
checking for broken, 469–470
creating, 62–63, 166–167
to email addresses, 181
formatting, 172–173
purpose of, 165
removing, 167
setting color for, 83
targeting, 174, 180
types of, 165, 168–169

Links (CSS), Page Properties dialog, 83–84, 212
Linux systems, 219, 382
liquid layout, 233–234
List, CSS rule definitions, 191
List Properties dialog, 110, 112
lists, 108–112

creating, 109
nesting, 111–112
scrolling, 309, 311
setting properties for, 110
types of, 108

List Values dialog, 310
Live Code view, 11, 388, 426–427
Live view

displaying screen sizes in, 73
enhancements, 23
navigation, 388–389
previewing pages in, 69
purpose of, 11
using CSS inspection in, 258–259
and WebKit, 11, 74

Live View button, 347
Live View Options menu, 389, 390, 426
Load Query button, 117
Local Info category, 30
local root folder, 26
local site

alternate name for, 26
building pages for, 53
creating, 28–31
displaying contents of, 42
moving items to/from, 46–47
naming, 29
saving pages for, 66–67
switching between remote site and, 41
synchronizing remote site and, 49–51, 402
viewing/changing, 39

locked regions, 393, 397
Lock Guides command, 320
Lowery, Joseph, 486
Lynda.com, 485

M
Macintosh

and Application frame, 8
Dreamweaver menu bar on, 6
encodings, 81
font considerations, 219
getting rid of tabs on, 8–9
keyboard shortcuts, xiv
mouse considerations, xv
previewing pages on, 70
and Submit/Reset buttons, 314
testing server package for, 382
using Dreamweaver on, xiv–xv

magnification tools, 321, 322
mailing list, Dreamweaver, 484
Make Template command, 394
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MAMP, 382–383
Manage Sites dialog, 34, 38, 457, 475
Manage Workspaces dialog, 21
margins, 82, 83, 191
Mastering Regular Expressions, 131
Media Encoder (Adobe), 160, 162
media files, 133, 163–164
Media Queries dialog, 328–331
media query style sheets, 315, 329–331
menu bar, 6
Menu List, 110
menus

context, xv, 20, 92
jump, 296, 340, 353–355
pop-up, 359–360

Merge Cells command, 280
<meta> tag, 87–88
Microsoft

Excel. See Excel
Internet Explorer. See Internet Explorer
Web-safe fonts, 220
Windows. See Windows systems
Word. See Word

Mobile Applications workspace, 20
mobile devices, 22, 73, 220, 325, 328
Mobile layout, 336
Mobile Starters, 58, 338
mouseovers, 345
Move Guide dialog, 320
Move To External Style Sheet dialog, 252
MP3 files, 163
Multiclass Selection dialog, 209
Multiscreen button, 73
Multiscreen Preview feature, 23, 325–327
MySQL, 382

N
Named Anchor dialog, 175
naming conventions, 396
naming/renaming

anchors, 175
buttons, 312
classes, 193
editable regions, 395, 396
favicons, 157
files, 44, 45, 452
folders, 29, 44, 45, 452
forms, 298
host directory, 36
images, 141
library items, 404, 408
local site, 29
radio groups, 307
remote server, 35
snippets, 412, 414
styles, 244–245
Web pages, 66–67
workspaces, 21

navigation
laying out, 237–238
Live view, 388–389
modifying, 239–242

&nbsp; (non-breaking space), 113
nesting

HTML elements, 195
lists, 111–112
tables, 270, 272

Netscape browsers, 352
New CSS Rule dialog

creating classes in, 193, 213–214
creating compound styles in, 195–197
creating inline styles in, 213–214
creating style rule for tags in, 188–189
formatting links in, 172–173

New Document dialog
changing document defaults in, 57
creating new external style in, 249
creating new page from, 3, 56–57
and HTML5, 204
previewing CSS style sheets in, 58
using included CSS layouts in, 231–232
vs. Files panel, 43
vs. Welcome screen, 54

New Editable Region dialog, 395
new features, 4, 22–23
New File command, 44
New Folder command, 44
New from Template command, 398
New Site command, 28
non-breaking spaces, 113
numbered lists, 108, 110. See also lists

O
OK/Submit buttons, 314
Onion Skin view, 76, 78, 79
online magazines, 379
online newspapers, 379
online resources, 479–485
opacity values, 203
Open Browser Window dialog, 349
Open dialog, 68
Opera, 69, 210, 268
operators, 128, 130
Optimize command, 147
optional regions, 397
ordered lists, 108. See also lists
O’Reilly HTML Reference, 123
orphaned files, 471
Outdent Code button, 422
Over state, 347
OverWhileDown state, 347
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P
<p> tag, 90, 185. See also paragraph tags
padding, 191, 238, 242, 273
padlock icon, 456
page breaks, 192
page dimensions, 323–324
page headers, 235
page-layout tools. See layout tools
page properties, 80–86
Page Properties dialog, 80–85

Appearance (CSS), 80, 81–82, 212
Appearance (HTML), 82–83, 212
Headings (CSS), 84, 212
Links (CSS), 83–84, 212
names in, 213
Title/Encoding, 85, 213
Tracing Image, 86, 213

pages. See Web pages
page titles, 9, 60, 66, 85, 121, 396
panels, 15–18
paragraph tags, 90, 91, 104, 185
parent-child relationships, 195
Paste command, 45, 93
Paste Special command, 95–96, 293
Phone preset, 330, 331
Phone viewport, 327
Photoshop (Adobe), 143, 148–153
PHP, 54, 378, 382, 437, 447
placeholders

image, 139–140
media file, 163, 164

plug-in media, 163
plug-ins, checking for, 351–352
PNG files, 137, 147, 148, 150, 360, 461
Point to File icon, 62, 166, 177, 443
pop-up menus, 309–310, 359–360
Positioning, CSS rule definitions, 192
POST method, 299
Powers, David, 486
preferences

accessibility, 65, 135, 303
bold/italic, 102
browser list, 71
code coloring, 422
code formatting, 423
code hinting, 437, 439
CSS styles, 186
default document type, 57
field labels, 303
file saving, 460
highlight color, 404
line breaks, 104
links, 169
non-breaking spaces, 113
OK/Submit buttons, 314
opening files, 419
related files, 217
tabs, 8–9

Welcome screen, 5, 54
window size, 13, 75, 135, 324

preformatted text, 103
presentation

vs. content, 184–185, 268, 328
vs. structure, 89

presets
widget, 371
window size, 323–324

<pre> tag, 103
Preview/Debug in Browser button, 70
Preview in Browser submenu, 70, 71
previewing

in browser, 69–71
snippets, 411, 414
using preset screen sizes, 72–75

properties
adding, 200
disabling, 262–263
displaying, 199
modifying, 200, 204
working with browser-specific, 210
working with CSS3, 203–204

Properties pane, 199–200
Property inspector

adding alternate text with, 136
applying CSS styles with, 211
applying HTML tags with, 211
applying multiple classes with, 209
creating classes with, 213–214
creating inline styles with, 213–214
creating styles with, 211–214
CSS tab, 14
HTML tab, 14
image editing tools, 143
setting image properties with, 141–142
setting text field properties with, 300
styling text with, 211
Validation panel, 448, 449
working on library items with, 409–410

Prototype, 362
PSD files, 148, 151
pseudo-classes, 197, 205
Put button, 51
putting files/folders, 46–47

Q
Quicken 2009 for Windows Essential Training, 485
Quick Tag Editor, 428–429, 442
QuickTime, 160, 163

R
radio buttons, 305, 307–308
Radio Group dialog, 307–308
RDS, 32
RealVideo, 160
Redo command, 93
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Reference tab. See Code Reference tab
regular expressions, 128–131
related files

discovering, 384–386
examples of, 216
filtering, 387
viewing, 217

Related Files toolbar, 12, 216–217, 222, 384, 386
relative positioning, 229
“Relative to” pop-up menu, 170–171
remote servers. See also remote site

checking in files to, 460
defining, 32–37
naming, 35

remote site
defining, 32–37
displaying contents of, 42
moving items to/from, 46–47
switching between local site and, 41
synchronizing local site and, 49–51, 402
viewing/changing, 39
vs. local site, 27

Remove Template Markup command, 397
Rename Class dialog, 244–245
Rename command, 45, 244
Rename Style dialog, 244
rendering software, 69, 74
repeating regions, 397
repeating tables, 397
replacing text. See Find and Replace feature
Reports dialog, 467
Repository view, 41
resampling images, 145
Reset button, 312, 314
resizing images, 145
Resolution Management feature, 72, 74
reusable code snippets, 391. See also snippets
Revert command, 465
RGB/RGBA color, 203
rollover images, 345–347
rollover links, 84, 213, 238
root folder, 29, 36, 68
round-trip editing feature, 359
rows. See also tables

deleting, 284
inserting, 278, 279
resizing, 282
selecting, 274

Rule Definition pop-up menu, 173, 188, 251
rulers, 318, 320
rules

creating from inline style, 247–248
enabling/disabling, 262–263
moving, 252–253, 257
for pseudo-classes, 197
viewing properties for, 226

Rules pane, 247–248

S
Safari (Apple)

and browser-specific CSS properties, 210
and CSS3 code hinting, 438
and CSS-based layouts, 268
and CSS rendering, 78
and Flash, 180
and image maps, 180
and Live view, 11, 23, 74
and mobile devices, 74, 180
previewing pages in, 69
and WebKit, 74

sample pages, 53, 58–59
Save As dialog, 66–67
Save As Template dialog, 394
Save Query button, 117
screen readers, 65, 134
screen sizes

customizing, 75
displaying, 73–74
previewing using preset, 72–75

<script> tag, 226
Script Warning dialog, 385
scrolling lists, 309, 311
search engines, 87, 88, 97
searching

HTML tags, 125–127
with regular expressions, 128–131
source code, 124
text, 118–123

Search pop-up menu, 117, 118
Secure FTP, 32, 33. See also SFTP
Secure Shell protocol, 33
Select (List/Menu) button, 309
Select File dialog, 167, 170–171
Select Image Source dialog, 64, 134
Selector Name, 188, 196
selectors, 188, 195–197
Selector Type, 172–173, 188, 196
Select tool, 13
Servers category, 34
Set Text behaviors, 340
SFTP, 32, 33, 34–36
sharpening images, 146
Shockwave animations, 158
shortcut keys, 107, 488–492
Show Grid command, 316
Show Guides command, 318
Show More menu, 386
Silverlight, 160, 163
site definitions, 38, 476–478
site descriptions, 87, 88
site design, 31
site files, 391
site management tools, 26, 391, 451. See also 

Web site management
Site Map, 455
Site menu, 6



508  Index

Site pane, 28
site reports, 466–468
Site Root button, 68
site root folder, 29, 36, 68, 391
site root relative links, 168, 169, 170
sites. See Web sites
Site Setup dialog

Advanced Settings category, 30, 52, 224
Cloaking category, 52
Local Info category, 30
Local Site Folder field, 29
purpose of, 28, 380
Servers category, 34
Site category, 28
Site Name field, 29
Web Fonts category, 224

Smart Objects, 148, 152–153
smart phones, 22, 74, 180, 325. See also mobile 

devices
Snap to Grid command, 317
Snap to Guides command, 320
snippets, 411–414

defined, 392
deleting, 414
editing, 414
inserting, 414
naming, 412, 414
organizing, 414
previewing, 411, 414
saving, 412–413
updating, 411
vs. library items, 411

Snippets panel, 411–414
Sort Table dialog, 289
source code, 124
Source view, 93
spacer GIFs, 142
spaces, 113
spacing, cell, 273
<span> tag, 189, 208
special characters, 113–114, 129
spelling checker, 132
Split Cell command, 280
Split Code view, 424
Split view, 10–11, 74, 424–425
Spry

commands, 365
components of, 362
data sets, 362
opening browser windows with, 350
purpose of, 361, 362
widgets, 364

Spry tab, Insert panel, 17, 364
Spry Validation, Forms category, 296
SQL, 447
SSL/TLS, 32, 33
staging servers, 27, 382
Standard bar, 12
starter layouts, 204

states, image, 347
static positioning, 229
static sites, 27
Status bar, 13
.ste file extension, 476
strikethrough text style, 102
<strong> tag, 102, 211
structural elements, 89, 95, 97
Style Rendering toolbar, 12, 266
style rules

cascading of, 202
conflicting, 202
displaying all, 198
enabling/disabling, 262–263
moving, 257
for tags, 188–189
troubleshooting, 201
viewing properties for, 226

styles, 243–259. See also CSS; style sheets
applying with Property inspector, 211
creating compound, 195–197
creating rules from inline, 247–248
creating with Property inspector, 211–214
deleting, 246
displaying properties for, 199
dragging and dropping, 256–257
modifying, 215, 259
moving, 252–253, 256–257
previewing in browsers, 201
renaming, 244–245
showing all/selected, 198–201
types of, 202
using for layout, 227–242

style sheets. See also CSS
attaching, 254–255
creating external, 249–251
deleting styles from, 246
hiding, 266
media query, 315, 329–331
setting media type for, 255
using design-time, 264–266

Styling Web Pages with CSS: Visual QuickProject 
Guide, 447, 486

Submit button, 312–313, 314
Subversion, 451, 464–465
SVN, 464–465
Swap Image Restore behavior, 347
.swf file extension, 158
symbols, 113–114
synchronization feature, 46, 49–51, 402
syntax coloring, 422
System CGI, 298

T
Tab Index field, 303
table captions, 272
Table dialog, 270
Table Layout Mode, 269
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tables, 267–294
adding rows/columns to, 278–279
adding to Web pages, 270–272
anatomy of, 273
applying CSS styles to, 290
clearing values for, 283
creating, 270–272
deleting elements in, 284
exporting to delimited files, 294
formatting, 290
as layout device, 267, 268–269
merging cells in, 280
nesting, 270, 272
repeating, 397
resizing, 281–283
selecting elements in, 274–277
setting alignment for, 285
setting cell properties for, 286–287
sorting, 288–289
splitting cells in, 280
vs. preformatted text, 103
ways of using, 267
and Web browsers, 283

Tablet layout, 336
Tablet preset, 330, 331
Tablet viewport, 327
tabs, opening documents in, 8–9
tabular data, 103, 267, 291–294. See also tables
Tag Chooser, 431–432
Tag Editor, 430, 442
Tag inspector, 339, 341, 365, 442–443
tags

creating style rules for, 188–189
and CSS, 185
editing, 428–430
finding and replacing, 125–127
inserting, 431–432
modifying, 442–443
purpose of, 185

tag searches, 125–127
tag selector, 13
Target Browsers dialog, 473
Targeted Rule pop-up menu, 206, 213
targeting links, 174, 180
Target Rule field, 373, 376
Teach Yourself Regular Expressions, 131
templates, 393–402

adding editable regions to, 395–396
building pages based on, 398–399
creating, 393–394
defined, 392
file extension for, 394
finding free/inexpensive, 59
modifying, 400–402
purpose of, 393, 400
removing editable regions from, 397
saving documents as, 393
vs. library items, 403

Templates folder, 394, 399

terminology, 26–27
testing servers, 27, 41, 380–383
text, 89–132

adding, 61, 90–91
aligning, 105–107
applying headings to, 97–99
block quoting, 106
choosing fonts for, 219
cutting/copying, 92
dragging and dropping, 94
duplicating, 94
encoding, 85
finding and replacing, 116–123
formatting, 61
indenting, 105–106, 190
inserting line breaks in, 104
inserting special characters in, 113–114
moving, 94
pasting, 93, 95–96
preformatting, 103
selecting, 90
setting default color for, 82, 83
spell-checking, 132
structure vs. presentation, 89

text areas, 304
Text tab, Insert panel, 18
text fields, 300–301
text-indent property, 105
text links, 166–167. See also links
text styles, 101–102
Thawte, 33
Timing Function pop-up menu, 374, 376
Title/Encoding category, 85–86, 213
titles, page, 9, 60, 66, 85, 121, 396
toolbars, 12
tracing images, 86, 213
trackpads, xv
transitions, CSS, 24, 192, 372–376
transparency slider, 86
tutorials, 4, 482
Type, CSS rule definitions, 190
Typekit, 223

U
UI widgets, 362, 364
Uncloak command, 52
underline style, 84, 101, 102
Undo command, 93
Unicode encoding, 80, 85
Unicode Normalization Form, 85
Uniform Resource Locators, 62. See also URLs
unordered lists, 108. See also lists
Update Files dialog, 44, 400
Update Pages dialog, 401
Up state, 347
URLs, 62, 63, 67, 87
usability, site, 315
UsableNet Accessibility Reference, 447
UTF-8 encoding, 80, 85
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V
Validate Form behavior, 356–358
validating

dynamic pages, 449–450
forms, 296, 356–358
static pages, 448–449

VCS. See version control system
Verisign, 33
version control system, 451, 464–465
video formats, 160
video training programs, 485
View menu, 77, 217, 318, 419, 425
view mode buttons, 9
Viewport Sizes window, 327
views

refreshing, 42
switching between local/remote, 41

visited links, 83, 172
visual aids, 176, 260–261
visually impaired site visitors, 65, 134, 142.  

See also accessibility

W
W3C Validator feature, 24, 448–450, 472
WebAssist, 482
Web browsers. See also specific browsers

and AP elements, 230
checking compatibility with, 472–474
and CSS-based layouts, 268
editing list of, 71
and event handlers, 344
and floating boxes, 230
font considerations, 219
and positioning, 230
previewing pages in, 69–71
previewing styles in, 201
and tables, 283

Web content management systems, 377.  
See also CMSs

WebDAV, 32, 33, 36–37
Web design, 31, 486
Web fonts, 220–224
Web Fonts Manager dialog, 224
WebKit, 11, 23, 74, 268
Web links, 63. See also links
weblogs, 481
Web pages. See also Web sites

adding animations to, 158–159
adding automatic dates to, 115
adding background image to, 154–155
adding favicons to, 156–157
adding forms to, 297–299
adding headings to, 97–99
adding images to, 64–65, 134–136
adding links to, 62–63, 166–167
adding special characters to, 113–114
adding tables to, 270–272. See also tables
adding text to, 61, 89–96

adding titles to, 60
adding video to, 160–162
aligning elements on, 316–317
attaching style sheet to, 254–255
choosing fonts for, 218–219
creating, 54–59, 398–399
defining meta tags for, 87–88
extracting embedded JavaScript from, 

444–445
file extensions for, 45
laying out, 233–236. See also layout tools
naming, 66–67
navigation for, 237–242
opening, 68
previewing in browser, 69–71
sample pages for, 58–59
saving, 66–67
setting properties for, 80–86
showing all styles for, 198–200
spell-checking, 132
template-based, 398–402
updating, 49
validating, 448–450
viewing in BrowserLab, 76–79
vs. Web sites, 25
zooming in on, 321–322

Web-safe fonts, 220
Web servers

for CMSs, 382
ways of connecting to, 32

Web site management, 451–478
checking browser compatibility, 472–474
checking for broken links, 469–471
deleting site from Dreamweaver, 475
exporting/importing site definitions, 476–478
generating site reports, 466–468
planning for site expansion, 452
setting up Check In/Check Out, 456–458
setting up version control, 464–465
using Design Notes, 461–463

Web sites. See also Web pages
adding interactivity to, 341, 361
checking/fixing broken links in, 469–471
choosing structure/design for, 31, 452
creating, 28–31
database-backed, 27
defining remote server for, 32–37
deleting from Dreamweaver, 475
Dreamweaver terminology for, 26–27
key to usability of, 315
local vs. remote, 26–27
managing files for. See Web site management
naming, 29
navigation for, 237–242
preventing “breaking” of, 392
prototyping, 59
restricting changes to, 392, 393
static vs. dynamic, 27
styling page content for, 183. See also CSS
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switching between, 40
synchronizing local and remote, 49–51, 402
this book’s companion, xv, 479
vs. Web pages, 25

Web standards, 24
Welcome screen

buttons/controls, 2–5
creating new page from, 54–55
Dreamweaver Site link, 28
opening pages with, 54–55, 68
turning on/off, 5, 54

whitespace, 105
Widget Browser (Adobe), 366–371
widgets, 366–371

customizing/configuring, 366, 369
downloading, 367–369
exporting/importing presets for, 371
inserting, 370–371
previewing, 368
purpose of, 361
Spry, 364
types of, 362

wildcard symbols, 128
Window menu, 15, 16
windows, opening new browser, 348–350
Window Size menu, 72, 73, 74, 75, 323–324
Windows Media, 160, 163
Windows systems

browsers for, 69. See also specific browsers
Document toolbar on, 9
Dreamweaver menu bar on, 6
encodings, 81
font considerations, 219
getting rid of tabs on, 8

keyboard shortcuts, xiv
and Submit/Reset buttons, 314
testing server package for, 382

Wise-Women online community, 484
Word (Microsoft)

importing documents from, 91
importing tabular data from, 293
pasting text from, 95–96

WordPress, 27, 377, 378, 383, 385, 483
Word Wrap, 422
workflow reports, 466
workspaces

defined, 19
deleting, 21
preset, 20
renaming, 21
saving custom, 21
switching between, 20, 420

WYSIWYG tools, 185, 277, 415, 424, 428

X
XAMPP, 382–383
XHTML, 472
XML, 362, 447, 461, 476
XSLT, 447

Y
YUI, 362

Z
Zeldman, Jeffrey, 486
Zoom tool, 13, 321–322
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