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You know what? I can’t stand introductions. Weird coming from an author, right? It’s like some 
committee got together and said that you’ve got to have an introduction in your book. Oh, 
and please make it long. Really long! In fact, make it so long that it will ensure no one reads 
introductions. And the vicious cycle begins. That said, I understand the concept of an introduction. 
It’s for the author to introduce you to the content of the book and give you an idea of how best to 
get the most out of the book you just purchased. I’m going to do that, but I’m going to do it with 
a very short list (I love lists, by the way). Here goes:

1.  If you want to follow along with the images used in the book, then feel free to download 
them at www.kelbytraining.com/books/layerscs5. You’ll notice that most are watermarked, 
especially the photos don’t belong to me. I’ve used two great online resources for stock photos, 
Fotolia and iStockphoto, because I wanted to include a variety of projects and I don’t happen 
to photograph all of those type of subjects. For example, in Chapter 1, I think the basketball 
sports poster is a great way to use layers, but I don’t shoot basketball, so I used stock photos. 
And you can guarantee that I didn’t use photos of anyone I know for the retouching chapter, 
so I’ve used stock photos for many of those tutorials, as well.

2.  I’ve included four online videos to go along with the book: one on layer basics, one on selection 
basics, one on brush basics, and a tutorial on the making of the cover. We use brushes and 
selections throughout the book, so I wanted to make sure you’re up to speed with the basics 
of what you’ll need.

3.  What’s new in this version of the book? For starters, I’ve added an entire chapter on advanced 
layer techniques, blending, and compositing. Overall though, layers haven’t really changed 
much since I wrote the first version of this book more than three years ago. But Photoshop has 
had two major releases since then, and it was time to bring the book up to date. So, I have 
included all new graphics, examples, and even some new techniques that are more current 
for today’s Photoshop user. That said, if you bought the first version of this book and you’re 
looking for a completely new book, please don’t buy this one (if you’re flipping through it in a 
bookstore. If you’ve already bought it online, most online booksellers allow returns, so return 
it now before you feel the need to write a nasty review on Amazon.com :-).

4.  Feel free to read the book in any order you want. I organized the book into the logical way 
that I teach layers when I teach it to a live class. I started with the easier stuff and moved on to 
the more advanced stuff in later chapters. So jump in wherever you want. Hey, it’s your book. 
You bought it, right? You’re smart enough to realize that if you jumped right to Chapter 6 and 
are lost, that the best thing to do may be to backtrack to Chapter 1. Chapter 10, however, 
assumes you’ve read the rest of the book.

introduction

www.kelbytraining.com/books/layerscs5
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5.  There’s a little bonus at the end of each chapter. As an author, it’s one of the ways that we 
wreak havoc on our editors, and we take a small amount of pleasure in that. After all, you can’t 
just fill the book with tutorials, right? You’ve got to throw some tips in, and throw them in at 
the last minute after all of the chapters are already turned in. My thoughts exactly. So, at the 
end of each chapter, there’s a page of some common “How Do I…” questions. They’re all 
related to things that you read in the chapter. I’ve taken the most common questions and put 
them into one place, so you don’t have to poke around the whole chapter to find them.

That’s it. That’s my introduction. Easy. Simple. Short. Sweet. Getting longer now that I keep adding 
to it at the end. But, still shorter than most. Now, get to it and enjoy the book. —Matt K.
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I’m going to start this chapter intro out with a 

bold statement. In fact, if there’s one chapter 

intro you want to make sure you read, it’s 

this one. Okay, so are you ready for my bold 

statement? Because if you’re not, I’ll wait a 

moment—no, really, it’s okay. Okay, I guess 

I’d better make my bold statement before 

I just flat out annoy you. Here it is: you already 

know what a layer mask is. Yep, as long as 

you read through and understood what we 

did with adjustment layers in Chapter 3, you 

already know all about layer masks. If you 

didn’t read Chapter 3, then I take my bold 

statement back. You have no idea what a 

layer mask is. But you will, if you go back and 

read Chapter 3 and then follow it up with this 

chapter. Why? Because layer masks are one 

of the most important things you can learn 

when it comes to layers. It’s a topic that I’ve 

seen a lot of people try to avoid. But, once 

you figure them out, you’ll wonder how you 

ever got along without them.

Layer MASKS

85

CHAPTER FOUR
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In order to really take advantage 
of layer masks, you need to have 
at least two layers. So go ahead 
and open two images that you’d 
like to combine. You can down-
load the images shown here from 
the website I mentioned in the 
book’s introduction.

STEP 1: OPEN TWO PHOTOS THAT YOU’D LIKE TO COMBINE

 Layer Mask Basics
LAYER MASKS LET YOU NON-DESTRUCTIVELY ERASE AWAY AREAS FROM ONE LAYER TO REVEAL
THE LAYERS BELOW

Let me start out by saying that if you didn’t read the chapter intro on the previous page, then stop right 

now and go read it. I made a very profound statement there and I think it’s important that you read 

it before continuing. If you don’t, then the rest of this chapter just won’t be the same for you. So go read 

it...now. I’ll wait. Okay, you’re back and I bet you feel much better about embarking on your journey to 

learn all about layer masks. Now, in that chapter intro, I said that you already know what a layer mask is. 

You do! That little white thumbnail that kept getting added next to each adjustment layer we added in 

Chapter 3 is a layer mask. The difference between them and what we’re about to do here is that adjust-

ment layers automatically include a layer mask with them. A regular layer doesn’t. But, it takes just one 

click to get the same effect.
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One of the main things to under-
stand about layer masks is that 
they work closely with selections. 
So, in our example, let’s make a 
selection of the boy. Click on the 
top layer, then go to Select>Color 
Range. Set the Fuzziness slider to 
20. Then, move your cursor over 
the orange shirt and click on it with 
the eyedropper. In Color Range, 
Photoshop makes selections based 
on color (I know, duh!). You’ll notice 
it doesn’t select the whole shirt, 
though. Try pressing-and-holding 
the Shift key to go into Add mode 
and Shift-click in a bunch of places 
all over the boy to select all of him. 
Just stay away from clicking on any-
thing blue (the sky, the top of his 
socks). Click OK when you’re done.

STEP 3: MAKE A SELECTION OF THE AREA WE WANT TO KEEP

Press-and-hold the Shift key, 
and use the Move tool (V) to 
drag one photo from its docu-
ment onto the other one (using 
the Shift key keeps the images 
lined up). In this example, I’m 
going to drag the photo of the 
soccer player onto the image of 
the soccer field. Now that photo’s 
document has two layers. Once 
you’ve got the photo moved, you 
can close the original so you’re 
left with only the document with 
two layers.

STEP 2: COMBINE THE IMAGES SO THEY’RE IN THE SAME DOCUMENT
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When you clicked on the Add 
Layer Mask icon, you saw that 
Photoshop added a little white 
thumbnail next to the layer 
thumbnail in your Layers panel. 
This is a layer mask. See how it 
looks just like the one that we
saw in Chapter 3 whenever we 
added an adjustment layer? The 
only real difference here is that 
you’ve got to manually add a 
layer mask to a regular layer. 
When you use adjustment layers, 
Photoshop automatically adds 
the layer mask. But they’re essen-
tially the same exact thing and 
function the same way.

STEP 5: NOTICE HOW A REGULAR LAYER MASK LOOKS JUST LIKE THE ADJUSTMENT LAYER ONE

When you have a selection active, 
adding a layer mask tells Photo-
shop that you want to keep the 
selected area visible and hide 
everything that isn’t selected. 
In our case, the soccer player 
is selected, so he’ll stay visible, 
but the rest of the photo will get 
hidden, right? Try it. Make sure 
the top layer is still active and 
click on the Add Layer Mask icon 
at the bottom of the Layers panel 
(circled here). You’ll see the blue 
sky disappear, but the soccer 
player (which is what we selected 
earlier) is still there.

STEP 4: ADD A LAYER MASK TO HIDE THE BACKGROUND ON THE TOP LAYER

Adjustment layer with mask Regular layer with mask



89L A Y E R  M A S K S C H A P T E R  4

Another way to visualize what a 
layer mask is doing is to imagine 
that the mask is on top of the 
layer you put it on. Even though 
they appear side-by-side in the 
Layers panel, you could put 
the layer mask on top of the 
image thumbnail and it would 
fit perfectly. It would almost look 
like a stencil or an outline that 
you would cut away with scissors. 
The white would be the shape you 
want to keep from the photo, and 
the black would be what you’d cut 
away to reveal whatever was below 
the soccer player.

STEP 7: THEY LOOK LIKE SEPARATE OBJECTS, BUT THEY’RE REALLY ON TOP OF EACH OTHER

It’s all about black and white. That’s 
all layer masks care about. To see 
how things are working here, take 
a look at the layer mask thumbnail. 
Wherever it’s white, we can see 
the soccer player layer (the layer 
that holds the actual layer mask). 
Where you see black on the layer 
mask, you see through the soccer 
player layer to whatever is under-
neath it in the Layers panel (in this 
case, the soccer stadium). That’s 
the single most important thing 
to understand about layer masks: 
black and white. White shows you 
whatever is on the layer that the 
layer mask is on. Black hides that 
layer and shows you whatever is 
below it in the layer stacking order.

STEP 6: WHITE ON THE LAYER MASK SHOWS THE TOP LAYER; BLACK REVEALS WHAT’S UNDERNEATH
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Go to Edit>Undo Fill to undo that 
last step, so the black-and-white 
layer mask is back. If you look 
closely, our selection from Step 
3 wasn’t perfect. A few areas are 
missing, but we’ll take care of that. 
Remember, layer masks just care 
about one thing—black and white. 
It doesn’t matter how black and 
white get there. Earlier, we created 
a selection before adding the 
mask, but you can also use a brush 
to get the ultimate flexibility and 
control. Click on the mask thumb-
nail, get the Brush tool (B), and 
choose a small, soft-edged brush. 
Set your Foreground color to white 
(remember, white keeps whatever 
is on this layer visible) and paint 
over the areas we missed. You’ll 
see them reappear.

STEP 9: USE THE BRUSH TOOL TO FINE TUNE THE LAYER MASK

The biggest advantage of layer 
masks is that nothing is perma-
nent. Even though it looks like 
we’ve deleted the sky around the 
soccer player, it’s still there. Go 
ahead, look at the layer thumbnail 
and you’ll see it looks exactly the 
same. Nothing was deleted—it’s 
just hidden. Layer masks are non-
destructive and always give you 
a way out. Just to demonstrate 
really quickly, click once on the 
layer mask thumbnail (not the layer 
thumbnail) to select it. Then go 
to Edit>Fill. Set the Use pop-up 
menu to White and click OK to fill 
the mask with white again. Things 
are back to normal, as if nothing 
ever happened.

STEP 8: NOTHING IS PERMANENT WITH LAYER MASKS
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You can see I went a little over-
board with the white brush. While 
I did bring back the parts of the 
soccer player that were missing, 
I also brought back parts of the 
sky. No sweat. Remember that 
black-and-white thing? Just switch 
your Foreground color to black, 
then paint on the mask again to 
hide those areas and reveal the 
stadium layer below.

TIP: When using layer masks, get 
used to the X key. Pressing X swaps 
your Foreground and Background 
colors, so you’ve got a quick way 
to switch from black to white or 
vice versa.

STEP 10: YOU CAN PAINT ON THE MASK WITH BLACK, TOO

BEFORE AND AFTER

Before After
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First, go ahead and open two 
photos. They could be of anything, 
but I take any chance I can to show 
off my two sons, Ryan and Justin. 
Select all of one of the photos 
(press Command-A [PC: Ctrl-A]), 
then copy-and-paste it into the 
other one by pressing Command-C 
(PC: Ctrl-C), switching to the other 
photo, and pressing Command-V 
(PC: Ctrl-V), so there are now two 
layers in one document. With the 
top layer active, click on the Add 
Layer Mask icon at the bottom of 
the Layers panel to add a layer 
mask to the top layer.

STEP 1: OPEN TWO PHOTOS TO BLEND TOGETHER

The Only Layer Mask “Gotcha”
THERE’S ONE LITTLE DIFFERENCE YOU NEED TO KNOW ABOUT REGULAR LAYER MASKS BEFORE
MOVING ON

Okay, you got me. I lied earlier. Really, it was just a tiny lie. I said earlier that there was no difference between 

the layer mask that was added automatically with an adjustment layer and the layer mask that you add to 

a regular layer. Well, that’s not totally true. There is a very small difference. When we added the adjustment 

layers, all you had to do was click anywhere on the adjustment layer to edit its layer mask. Well, with a regular 

layer mask, it actually matters where you click on the layer.
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STEP 2: NOTICE THE TWO THUMBNAILS THAT APPEAR IN THE LAYERS PANEL ON THE LAYER WITH A MASK

STEP 3: CLICK ON THE LAYER THUMBNAIL TO SELECT IT

Click once on the actual layer 
thumbnail to select it. And I mean 
click on the thumbnail itself, not 
the highlighted area around it. If 
you look closely, you’ll see a small 
black outline around the corners of 
the thumbnail. That’s Photoshop’s 
way of telling you that the layer 
is selected and ready to edit. If 
you were to get the Brush tool (B) 
and paint with black at this point, 
you’d be painting with black on the 
photo itself and you would see 
black brush strokes everywhere 
you paint.

Take a closer look at the top layer 
(the one with the mask). Notice 
how there are two thumbnails on 
that layer? One is the actual layer 
thumbnail that gives you a little 
preview of what is on that layer. 
The other is the layer mask itself.
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See how it makes a difference 
when it comes to what thumbnail 
you select in the Layers panel? 
That’s why it’s important to know 
that if you want to do something 
to the layer mask, you’ve got to 
actually click on that layer mask 
thumbnail. If you want to do some-
thing to the actual image or what 
you see on that layer, then click 
on the layer thumbnail. So, when 
you work with layer masks, if things 
aren’t showing up like you thought 
they should, take a look over at 
the Layers panel and see which 
thumbnail is selected. Ninety per-
cent of the time, that’s the cause. 
Okay, now we can move on. See? 
I told you it was only a small lie.

This time, click once on the layer 
mask thumbnail to select it. Look 
closely again and you’ll see that 
black outline now appears around 
the corners of the layer mask, not 
the layer thumbnail. Now paint 
with a black brush on the layer 
mask. Wherever you paint with 
black, you’ll start hiding the photo 
on that layer and revealing the layer 
underneath it, as you see here.

STEP 5: IT MAKES A DIFFERENCE WHAT THUMBNAIL YOU SELECT AND PAINT ON

STEP 4: CLICK ONCE ON THE LAYER MASK THUMBNAIL TO SELECT IT

Clicking here 
paints on the layer

Clicking here 
paints on the mask
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Go ahead and open the photos 
you’d like to combine. We’ll 
revisit the soccer player from the 
first tutorial to create an image 
that looks like he’s coming out of 
a ripped page. Just like in that 
tutorial, press-and-hold the Shift 
key, and use the Move tool (V) to 
drag the photo of the boy into 
the ripped image, so now you’ll 
have two layers there.

A Deeper Look Into Layer Masks
LET’S TAKE A DEEPER LOOK INTO LAYER MASKS AND SOME OF THE EXTRA THINGS YOU CAN
DO WITH THEM

We’re going to revisit the soccer player from a previous tutorial and do some other cool stuff with him. Layer 

masks have a lot of tiny features that make them easier to work with. Plus, back in Photoshop CS4, Adobe 

added an entire panel (the Masks panel) to help make working with layer masks easier and more intuitive.

STEP 1: OPEN THE PHOTOS FOR THE MASKING PROJECT. DRAG THE BOY INTO THE RIPPED IMAGE
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Unhide the layer with the soccer 
player on it by clicking where the 
Eye icon used to be, then click on 
the layer to make it active. Click 
on the Add Layer Mask icon at 
the bottom of the Layers panel to 
add a mask to this layer. Since we 
have a selection active, Photoshop 
will hide whatever is not selected. 
Remember, when you have a selec-
tion, adding a layer mask will keep 
the selected area visible and hide 
whatever is not selected.

Click on the Eye icon next to the 
top layer to hide it, and click on the 
ripped image layer. The Quick Selec-
tion tool (W) combined with the new 
Refine Edge feature in Photoshop 
CS5 is one of the most powerful 
selection tools in Photoshop. Since 
it’s a brush, you can just paint on 
the ripped area to select it. Be sure 
to use the Right and Left Bracket 
keys to resize the brush and get any 
areas you may have missed. If you 
select too much, just press-and-hold 
the Option (PC: Alt) key to go into 
Subtract mode and erase away the 
areas you don’t need.

TIP: Don’t forget about the selec-
tion primer tutorial online at www
.kelbytraining.com/books/layerscs5.

STEP 3: ADD A LAYER MASK TO THE LAYER WITH THE BOY ON IT TO HIDE THE REST OF THE PHOTO

STEP 2: USE THE QUICK SELECTION TOOL TO MAKE A SELECTION INSIDE THE RIPPED AREA

www.kelbytraining.com/books/layerscs5
www.kelbytraining.com/books/layerscs5
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We need to add this selection 
to the existing layer mask, so 
the entire soccer player is visible 
through the ripped area. First, 
Shift-click on the layer mask 
thumbnail to unhide it. Then 
go to Edit>Fill. Select White in 
the Use pop-up menu and click 
OK to fill the selection with white. 
You’ve just added the soccer 
player to the layer mask, so now 
the sky and the soccer player are 
visible through the ripped section 
of the background photo. Press 
Command-D (PC: Ctrl-D) to get 
rid of your selection.

At this point, we only have part 
of the soccer player visible in the 
ripped area. We need to get the 
rest of the soccer player showing 
through, too. Let’s make another 
selection with the Quick Selection 
tool. This time, we’ll select the 
soccer player, but only part of that 
layer is visible, right? It’s because 
the rest of it is hidden by the 
mask. Well, Photoshop will let you 
temporarily turn the mask off, so 
you can see everything. Shift-click 
on the layer mask thumbnail, you’ll 
see a big red X appear on it, and 
you’ll be able to see the entire 
layer again. Now, use the Quick 
Selection tool to put a selection 
around the soccer player.

STEP 5: FILL THE SELECTION WITH WHITE

STEP 4: HIDE THE LAYER MASK. USE THE QUICK SELECTION TOOL TO SELECT THE REST OF THE BOY
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Density and Feather are cool, but 
the real power of the Masks panel 
comes when you click the Mask 
Edge button, so go ahead and 
click it. If you look at our selection 
around the soccer player, you’ll 
see it’s not perfect. Without turn-
ing this into a selection book, the 
most powerful feature here is the 
Refine Radius tool (the little brush 
icon on the left side). Click on it 
to turn it on, then brush along 
any edges that seem too harsh 
or poorly selected (like the hair). 
Photoshop does some crazy 
computing, and most of the time 
it comes out looking amazing. 
Brush around any other areas and 
click OK when you’re done. That’s 
it. Photoshop was adjusting the 
mask as you made changes, so it 
should look a lot better now.

Check out the Masks panel. 
It usually appears nested with 
the Adjustments panel, but you 
can go to Window>Masks to 
open it. This panel (added in 
Photoshop CS4) gives you an 
easy way to adjust your masks 
without having to know a lot of 
the secret handshakes that layer 
mask users used to memorize. 
The Density slider is like an Opac-
ity slider for the mask. At 100% 
density, the mask is at full opacity. 
When you drag the Density slider 
below 100% though, you’ll start 
to see whatever the layer mask is 
hiding. You’ll even see the layer 
mask itself turn gray and approach 
white the closer you get to 0%. The 
Feather setting softens (or blurs) the 
edges of the mask (as seen here), 
so they don’t appear too harsh.

STEP 7: USE THE MASKS PANEL TO REFINE THE SELECTION EDGE

STEP 6: CHECK OUT THE MASKS PANEL. IT HELPS YOU CHANGE YOUR LAYER MASKS
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You can probably tell that the 
hexagon texture we just dragged 
in covers the entire photo. We 
could go through the whole 
process of making selections 
and masks again to hide it, but 
instead, we’ll do something that’s 
a lot easier than that. We can 
copy masks from other layers. If 
you simply click-and-drag a mask, 
you can move it from one layer to 
another. But if you press-and-hold 
the Option (PC: Alt) key before you 
click-and-drag the mask, it makes 
a copy of it. Try it. Option-click-
and-drag the mask from the soccer 
player layer to the hexagon layer. 
You’ve just made an exact dupli-
cate of the mask on another layer.

Okay, the soccer player is 
looking good. But, I think 
the orange background is 
a little plain, so let’s bring 
in a texture. Go ahead and 
open the other image for this 
tutorial if you want to follow 
along. It’s a simple layer with 
hexagon shapes on it. Press-
and-hold the Shift key (to keep 
it centered), grab the Move 
tool (V), click on the Hexagon 
layer, and drag it on top of 
our soccer player image. If it 
doesn’t appear directly above 
the soccer player layer in the 
Layers panel, click on the layer 
and drag it to the top of the 
layer stack.

STEP 8: ADD A TEXTURE LAYER TO THE ORANGE BACKGROUND

STEP 9: COPY THE MASK FROM ANOTHER LAYER SO WE CAN REUSE IT
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We’re just about done. I think 
the soccer player looks a little flat, 
though, so let’s add a drop shadow 
under him. First, remember that a 
layer mask is basically a selection. 
Many times they are created from 
a selection to start with, right? 
Well you can load that selection 
and make it visible again. So, let’s 
load the soccer player’s selection 
by first clicking on that layer, then 
Command-clicking (PC: Ctrl-click-
ing) on the layer mask thumbnail.

We have one small problem: the 
mask that was on the soccer player 
was there to show us the soccer 
player through the ripped portion 
of the photo, and to hide every-
thing else. That’s why we now only 
see the hexagon texture over the 
soccer player and not the orange 
background. We want the oppo-
site here. We want the hexagon to 
appear on the orange background. 
No problem. Make sure the layer 
mask thumbnail is selected. Then 
go to the Masks panel and click 
the Invert button. This turns every-
thing that was black to white, and 
whatever was white turns black. It 
essentially reverses the mask and 
gives us just what we want.

STEP 11: ADD A SHADOW BY MAKING A SELECTION FROM A LAYER

STEP 10: USE THE MASKS PANEL TO INVERT THE MASK ON THE TEXTURE LAYER



101L A Y E R  M A S K S C H A P T E R  4

Now, we’ll create a shadow for 
some depth. Click on the Back-
ground layer, then click on the 
Create a New Layer icon at the 
bottom of the Layers panel. Fill 
the selection with black by going 
to Edit>Fill, and selecting Black 
from the Use pop-up menu, then 
clicking OK. Press Command-D 
(PC: Ctrl-D) to Deselect. Now 
let’s blur the selection a little to 
soften the edges. Go to Filter>
Blur>Gaussian Blur and enter 6 
or 7 pixels for the Radius setting. 
Click OK, and you should have a 
nice soft shadow emanating from 
behind the soccer player.

Okay, breathe for a second. There 
are lots of layers and masking 
going on here. Notice that the 
black shadow only appears over 
the orange background. It doesn’t 
show up on the sky at all. Why? 
Think about it for a second. The 
black shadow is on a layer below 
the soccer player, so we’ll only 
see the glow, not the full black 
figure we created. Then, the mask 
on the layer above (the soccer 
player) only lets the sky and soccer 
player show through. So, anything 
we add on a layer below (like a 
shadow) won’t show up on the sky 
(which is a good thing, because we 
don’t want it there). It only shows 
on the ripped background image.

STEP 13: BREATHE FOR A MOMENT AND TAKE A LOOK AT WHAT’S GOING ON

STEP 12: ADD A NEW LAYER. FILL THE SELECTION WITH BLACK. ADD A GAUSSIAN BLUR TO SOFTEN IT
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I finished things up here by adding 
some text. We’ll cover using Type 
layers more in Chapter 5, but I’ve 
also provided an image with the 
layers, in case you want to add 
them, as well.

You may have noticed the shadow 
emanates from behind the soccer 
player like he’s glowing. Since it’s 
a shadow, we only want it to cast 
in one direction (down and to the 
right). So add a layer mask to the 
shadow layer. It’s all white, so noth-
ing happens yet. Select the Brush 
tool (B), set your Foreground color 
to black, and paint away the left 
edges of the shadow. Try reducing 
the shadow layer’s opacity to 
around 60% to soften the shadow 
even more.

STEP 15: ADD ANY TEXT AND FINISHING TOUCHES

STEP 14: ERASE THE AREAS OF THE SHADOW WE DON’T NEED
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Open two photos that you’d 
like to combine in some way. 
In this example, I’d like to 
place the photo of the snowy 
mountains inside the man’s ski 
goggles. There’s a little secret 
to layer masks that makes this 
really simple.

STEP 1: FIND A PHOTO WITH AN AREA IN IT THAT YOU’D LIKE TO REPLACE

using layer masks 
automatically
YOU CAN AUTOMATICALLY CREATE LAYER MASKS BY MAKING A SIMPLE SELECTION

The title to this tutorial definitely doesn’t do it justice, but I couldn’t think of a better name. It’s a 

way to automatically create layer masks simply by copying-and-pasting photos. The amount of 

flexibility you get helps out a lot when combining photos, so make sure you at least flip the page 

to see how cool an effect this is.
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Now, switch over to the photo of 
the man with the ski goggles. We 
need to first make a selection of 
the area we want to replace. Here, 
I used the Quick Selection tool (W) 
to click-and-drag across the lens 
inside the goggles to select it. If 
the selection spills over onto the 
face or the surrounding areas, 
press-and-hold the Option (PC: 
Alt) key and click on those areas to 
subtract them from the selection. 
Press Z to get the Zoom tool if you 
need a larger view.

Note: Don’t forget I created a 
selections video tutorial for you 
over at www.kelbytraining.com/
books/layerscs5. So, if you need 
a selections primer, go watch the 
video first.

STEP 3: MAKE A SELECTION OF THE AREA YOU WANT TO REPLACE

Start off with the photo that you 
want to use as the replacement 
area. In this example, we’re using 
the photo of the mountain. Choose 
Select>All to select everything (or 
press Command-A [PC: Ctrl-A]), 
and then choose Edit>Copy (Com-
mand-C [PC: Ctrl-C]).

STEP 2: SWITCH TO THE PHOTO YOU WANT TO REPLACE IT WITH, SELECT ALL, AND COPY THE PHOTO

www.kelbytraining.com/books/layerscs5
www.kelbytraining.com/books/layerscs5
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Here’s where it gets really cool, 
though: Select the Move tool from 
the Toolbox (or press V). Then click-
and-drag the photo of the mountain 
around. Photoshop lets you move 
the photo to reposition it, but still 
keeps it inside the original selection. 
That’s because the Paste Into com-
mand created that layer mask.

Now click on the Edit menu and 
choose Paste Special>Paste Into 
(remember, we copied the moun-
tain photo in Step 2). You’ve prob-
ably never used this one before, 
but it’s really cool. See, it pastes the 
photo you have copied (in this case, 
the mountain) into the active selec-
tion. It makes sure that the photo 
only appears in the selection by 
creating a layer mask automatically. 
See how the name of this tuto-
rial fits in? You’ve created a layer 
mask automatically just by using 
Edit>Paste Special>Paste Into.

STEP 5: USE THE MOVE TOOL TO REPOSITION THE PHOTO TO BETTER FIT INTO THE GOGGLES

STEP 4: USE PASTE INTO TO PASTE THE MOUNTAIN INTO THE SKI GOGGLES
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Here’s one last finishing touch that 
adds some depth to the flat reflec-
tion: Get the Gradient tool (G), and 
up in the Options Bar, choose the 
default Black, White gradient from 
the Gradient Picker, click the Linear 
Gradient icon, and set the Mode to 
Soft Light. Then, click on the Lock 
Transparent Pixels icon near the 
top left of the Layers panel. Now, 
click-and-drag from the left side of 
the goggles to the far right, so the 
gradient darkens on the left and 
brightens on the right. If you look 
at the layer thumbnail, we did 
indeed add the gradient to the 
entire image, but because of the 
layer mask, you see it only over 
the goggles. I also reduced the 
layer’s opacity to about 90% to 
fade the reflection a bit.

STEP 7: ADD A GRADIENT AND REDUCE THE OPACITY OF THE REFLECTION TO MAKE IT BLEND IN

Even better, you can resize the 
photo without changing anything, 
too. Click the Edit menu and 
choose Free Transform (or press 
Command-T [PC: Ctrl-T]). Press-
and-hold the Shift key and drag 
one of the corner handles in to 
make the photo fit better. Click-
and-drag inside the box to move it. 
Then, from the Edit menu, choose 
Transform>Warp. Choose Inflate 
from the Warp pop-up menu on the 
left of the Options Bar, and bend 
the photo to match the distorted 
(bulged) perspective you’d probably 
see in the reflection of someone’s 
goggles. Press Return (PC: Enter) 
when you’re done to commit the 
transformation.

STEP 6: RESIZE AND WARP THE PHOTO TO MAKE IT APPEAR MORE REALISTIC
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STEP 1: OPEN THE PHOTOS THAT YOU’D LIKE TO BLEND TOGETHER

For starters, open the photos that 
you’d like to blend together.

 Combining Multiple Images
LAYER MASKS LET YOU COMBINE MULTIPLE IMAGES WITHOUT ERASING PARTS OF THE IMAGE

If you think back to Chapter 1, we combined several images together in “Using Multiple Layers” 

by bringing them all into the same document and erasing parts of each layer away. That example 

was great for showing how layers work with each other and how you can see through part of one 

layer to the layer under it. However, when it comes to real life, it’s not that easy. You change your mind, 

the client changes his mind, or something just changes about the project, and you realize that perma-

nently erasing away parts of a layer isn’t a good thing. Mainly because you can’t bring those erased 

pixels back. You’d have to start all over again if you want to change something. Well, now we’re going 

to take a look at doing the same thing with layer masks. In fact, we’re going to use the same example 

to see how it should be done. Trust me, this stuff rocks! Once you see how easy it is, I promise you that 

you’ll never go back to that Eraser tool again.
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This time around we’re going to 
blend the large half-basketball 
into the background but in a much 
easier (and non-destructive) way. 
If you recall, layer masks see only 
in black and white, and they don’t 
care how you actually get black 
and white on them. So, let’s try 
using a gradient to give us a nice, 
smooth blend. Select the Gradient 
tool from the Toolbox (or just press 
G). Then click on the down-facing 
arrow to the right of the gradient 
thumbnail in the Options Bar, and 
choose the third gradient from 
the left in the Gradient Picker. It’s 
the default Black, White gradient. 
Also make sure you click on the 
Linear Gradient (leftmost) icon in 
the Options Bar and turn on the 
Reverse checkbox.

STEP 3: SELECT THE GRADIENT TOOL AND USE THE BLACK, WHITE GRADIENT

Go to File>New to create a new 
document. Enter 5 inches for the 
Width, 7 inches for the Height, 
and 72 ppi for the Resolution, 
and click OK. Now you’ve got a 
blank image. Go to the photo of 
the large half-basketball, choose 
Select>All, then go ahead and 
copy-and-paste it into your blank 
image. Use the Move tool (V) to 
position it toward the bottom. 
You should now have two layers—
the Background layer with the 
basketball layer on top of it.

STEP 2: CREATE A NEW DOCUMENT
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Now let’s bring in the photo 
of the basketball player. Copy-
and-paste it into our main col-
lage document that we’ve been 
working on. Use the Move tool to 
position it in the middle. Now you 
should have three layers in the col-
lage document: Background, the 
large basketball, and the basketball 
player. Go ahead and add a layer 
mask to this layer, as well, just like 
the other one.

STEP 5: BRING ANOTHER PHOTO INTO THE MAIN IMAGE

Now that you’ve got your gradi-
ent selected, let’s use it on a layer 
mask. Select the large basketball 
layer and click on the Add Layer 
Mask icon to add a layer mask to 
it. Then, click near the bottom of 
the ball and drag upward to the 
top of it. When you release your 
mouse button, you’ll have created 
a gradient on the layer mask. More 
than that, though, look at your 
image. The ball now blends nicely 
into the Background layer. If yours 
looks off, it’s probably because of 
the way you dragged your gradi-
ent. Sometimes it takes a few tries, 
so feel free to drag over it again to 
adjust the gradient, as well as the 
overall blend.

STEP 4: ADD A LAYER MASK AND CLICK-AND-DRAG ON IT TO BLEND THE TOP
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Copy-and-paste the last photo 
(the fiery basketball) into the main 
image. Make sure it’s the topmost 
layer in the Layers panel. Use the 
Move tool to position it toward 
the top left of the image, over the 
basketball net. Now, add a layer 
mask to this layer.

STEP 7: BRING THE LAST PHOTO INTO THE MAIN IMAGE

You’ll notice the photo of the 
basketball player totally covers up 
the large basketball below it. Let’s 
use the same Black, White gradi-
ent on the basketball player’s layer 
mask, but turn off the Reverse 
checkbox, and click-and-drag from 
the bottom to the top to fade 
the bottom part of the basketball 
player away, and reveal the large 
basketball below it. Once you do 
this, you’ll be able to see part of 
the white Background layer, so 
click on it, make sure your Fore-
ground color is set to black, and 
press Option-Delete (PC: Alt-Back-
space) to fill it with black.

STEP 6: USE THE GRADIENT TOOL AGAIN TO HIDE PART OF THAT PHOTO



111L A Y E R  M A S K S C H A P T E R  4

STEP 9: PAINT WITH BLACK ON THE LAYER MASK

Now we need to blend the new 
layer into the image. We could 
use the Gradient tool again, but 
that’s no fun. That’s old news, 
right? Instead, let’s try using the 
Brush tool because we can be a 
lot more precise in the areas we 
blend. Remember, we did this 
with our adjustment layer back in 
Chapter 3 when we had to hide 
the background around the mom 
and daughter from the Curves 
adjustment. So select the Brush 
tool (B). Click on the brush thumb-
nail in the Options Bar and set the 
Size to something fairly large, like 
150 pixels. Then set the Hardness 
to 0% so the edges are very soft 
and feathered.

STEP 8: USE THE BRUSH TOOL TO FADE THE PHOTO

Now, click once on the layer mask 
thumbnail to select it. Press D, then 
X to set your Foreground color to 
black. Start painting around the 
basketball to hide its black back-
ground, so it fades nicely into the 
net. As you paint, that area of the 
photo will disappear. Use the Right 
and Left Bracket keys to change 
the size of your brush, if needed.
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STEP 11: ADD THE FINISHING TOUCHES

STEP 10: IF YOU HIDE AN AREA THAT YOU DIDN’T WANT TO, PAINT IT WITH WHITE TO BRING IT BACK

Lastly, I’ve added the same graphic 
and text to finish things off.

Is it pretty much the same final 
image we came away with in 
Chapter 1? Yep. But we accom-
plished the same thing, with just 
about the same amount of work, 
in a non-destructive way. Now we 
can change the image if we ever 
need to. If you had erased those 
areas away, like we did in Chapter 
1, you wouldn’t have the flexibility 
to move and change the layers—
you’d have to start all over again.

Let’s say, for example, you hide 
an area of your photo that you 
didn’t want to. Just switch your 
Foreground color to white (press 
the X key) and paint over it again. 
Wherever you paint with white, 
you’ll start to bring back the origi-
nal photo. This means you can get 
very creative and experiment with 
different degrees of blending your 
photos with each other.
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We’ll kick off our greeting card 
by creating a brand new blank 
document. Click on the File menu 
and choose New (or just press 
Command-N [PC: Ctrl-N]). In the 
New dialog, type the size of the 
final image you want to create. In 
this example, let’s create a docu-
ment that is 8 inches by 10 inches 
at a resolution of 72 ppi. Click OK 
to create the new document.

STEP 1: CREATE A NEW BLANK DOCUMENT

Making One Layer Fit 
Into Another
FORCING THE CONTENTS OF ONE LAYER TO FIT INSIDE THE CONTENTS OF ANOTHER LAYER

There’s another masking feature that comes in really handy. It’s called a clipping mask, and it’s another 

type of mask that we use with layers. Its main purpose is letting you use a shape on one layer to mask 

layers above it. Clipping masks have a ton of good uses, but one great example is creating a greeting card. 

Plus, I’ll show you a very slick little shortcut for aligning multiple layers more precisely.
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Open the photo that you want 
to appear on the card. In this 
example, we’re creating a family 
greeting card, so we’ll use a photo 
of a little girl. Press Command-A 
(PC: Ctrl-A) to select the photo. 
Press Command-C (PC: Ctrl-C), 
then switch documents, and press 
Command-V (PC: Ctrl-V) to copy-
and-paste the photo into the card 
image we just created. Make sure 
it’s on a layer above the rectangle 
layer in the Layers panel.

STEP 3: COPY-AND-PASTE THE PHOTO YOU WANT TO APPEAR ON THE CARD ONTO A NEW LAYER

STEP 2: CREATE A ROUNDED RECTANGLE SELECTION FILLED WITH BLACK ON A NEW LAYER

Select the Rectangular Marquee 
tool (M) and create a rectangle 
in the middle of the canvas. 
Then click the Select menu and 
choose Modify>Smooth. Enter 15 
pixels for the Sample Radius and 
click OK. This creates a rounded 
rectangular selection. Now click 
on the Create a New Layer icon at 
the bottom of the Layers panel to 
create a new blank layer. Press D to 
set your Foreground color to black, 
and press Option-Delete (PC: Alt-
Backspace) to fill the selection 
with black. Press Command-D 
(PC: Ctrl-D) to Deselect.
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Click once on the girl layer to 
select it. Click the Layer menu and 
choose Create Clipping Mask, or 
just press Command-Option-G 
(PC: Ctrl-Alt-G). This forces the 
photo of the girl to only appear 
inside the boundaries of the layer 
below it. Even better, select the 
Move tool (V) and move the photo 
around. You’ll see that you can 
move it around anywhere you want 
and it still only reveals itself inside 
that original rounded rectangle 
shape. In fact, you can resize it, 
as well. Just choose Edit>Free 
Transform, or press Command-T 
(PC: Ctrl-T), and resize or rotate it 
at will. You have total control, and 
you never have to worry about 
the photo extending beyond the 
boundaries of the layer below.

STEP 4: CREATE A CLIPPING MASK TO FORCE THE GIRL TO FIT INSIDE THE ROUNDED RECTANGLE

STEP 5: OKAY, SO WHAT’S REALLY GOING ON HERE?

Pretty cool, right? So, what the 
heck is really going on here? Think 
of it this way: the bottom layer (or 
base layer) of a clipping mask is the 
shape you want to see in the final 
image. In this case, it’s taken the 
form of a rounded rectangle, but 
it doesn’t always have to be that 
way. It could be any shape—circle, 
square, logo, text, etc. That base 
layer tells Photoshop what shape or 
object you want to see in the end. 
Everything else that appears on top 
of that layer is what you’ll actually 
see in the image. It’s “clipped,” 
though, and the shape below is 
what’s clipping it (hence the name 
“clipping mask”).

Base layer with the shape

This is the layer you 
see in the shape
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Go ahead and copy-and-paste 
another photo for this greeting 
card into the image. Move it 
above the new black rounded rect-
angle layer and go to Layer>Create 
Clipping Mask again. Repeat Step 6 
and this step one more time for the 
last photo in the bottom left. You’ll 
see those Smart Guides really help 
when positioning this one.

STEP 7: ADD ANOTHER PHOTO TO THE IMAGE

STEP 6: DUPLICATE THE RECTANGLE AND REPOSITION IT USING SMART GUIDES

Let’s finish this up. Click once on 
the rounded rectangle layer and 
press Command-J (PC: Ctrl-J) to 
duplicate it. Your photo will now 
be clipped to the duplicate, so click 
on the original rounded rectangle 
layer and use the Move tool to 
move it next to the other one. You’ll 
find that moving layers around and 
aligning them with each other can 
be difficult. Smart Guides can help. 
Go to the View menu and choose 
Show>Smart Guides. Then make 
sure you have View>Snap turned 
on. As you drag the new rectangle 
layer around, you’ll see guides pop 
up as you align the top of the layer 
with the top of another layer in the 
Layers panel.
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Add some text and graphics 
and you’re done. In this example, 
I copied-and-pasted a few of 
the scribbles that we saw back 
in the beginning of Chapter 2, 
and changed their blend mode 
to Screen to drop out the black 
background. I added her name 
and the year (in the Cooper Std 
font), as well, to finish things off.

STEP 9: ADD ANY LOGOS, TEXT, OR GRAPHICS TO FINISH OFF THE GREETING CARD

Make one more copy of the black 
rounded rectangle layer. Use the 
Move tool to move it into position 
in the bottom right. Since black 
doesn’t really work for this photo, 
let’s try another color. First, click 
on your Foreground color swatch 
and set the color to R: 211, G: 
138, B: 152. Then grab the Paint 
Bucket tool (it’s nested under the 
Gradient tool in the Toolbox).
As long as the layer you want to 
paint on with the Paint Bucket 
tool is active, all you have to do is 
click on the object you want to fill 
and Photoshop will automatically 
fill it with the Foreground color. 
It won’t fill anything else on the 
layer, though—just the rounded 
rectangle shape.

STEP 8: MAKE ONE MORE COPY OF THE ROUNDED RECTANGLE AND FILL IT WITH ANOTHER COLOR
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Clipping masks can also be used to 
place a photo into any shape you 
can create. And you don’t have to 
have only one shape on a layer. 
Here, I painted with black, using 
some grungy splatter brushes, on 
a blank layer to make my clipping 
mask. Then, I brought in a photo 
of a person’s tattoo and clipped it 
to that mask. Add a layer with the 
company’s logo, and you’ve got a 
cool marketing design that can be 
updated just by placing another 
photo in it.

IDEA 2: CLIPPING MASKS ALSO COME IN HANDY FOR MARKETING DESIGN

IDEA 1: HERE’S ANOTHER USE FOR CLIPPING MASKS: PUTTING A PHOTO INTO TEXT

Another really popular technique 
that clipping masks are used for is 
to make a photo appear inside of 
text. Just create a Type layer (more 
on that in Chapter 5) and move a 
photo onto a layer above it using 
the Move tool. Then click on the 
photo layer and create a clipping 
mask with it. Now you’ll only see 
the photo inside of the shape of 
the text. ©
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Click on the layer to select it, then click on the blend mode pop-up menu in the top left of the 
Layers panel and choose your blend mode.

? CHANGE A LAYER’S BLEND MODE?

How do i…

CHAPTER 4

Shift-click on the layer mask thumbnail in the Layers panel. You’ll see a red X appear over it. It’s still 
there, but the layer mask is disabled. Shift-click again on it to enable it.

To see the contents of a layer mask, or see it in black-and-white mode, Option-click (PC: Alt-click) 
on it. Now you’ll just see the mask onscreen, and you can adjust it (paint on it) there just as you 
normally would. Option-click on it again to get back to the normal view.

To copy a layer mask, press-and-hold the Option (PC: Alt) key and click-and-drag the layer mask to 
another layer. You’ll see a double-arrow cursor indicating that you’re duplicating the mask and not 
just moving it.

To move what is actually on the layer around in your image, but leave the layer mask exactly where 
it is, you need to unlink the two. Click on the little chain-link icon between the layer thumbnail and 
the layer mask thumbnail to unlink them. Click that space again to re-link the two.

To apply a layer mask permanently to a layer, so it actually deletes the masked areas, Right-click on 
the layer mask icon, and then choose Apply Layer Mask from the pop-up menu that appears.

To move a layer mask, just click-and-drag the layer mask to another layer.

Drag the layer mask to the Trash icon at the bottom of the Layers panel.

TURN OFF OR DISABLE A LAYER MASK?

VIEW THE CONTENTS OF A LAYER MASK?

COPY A LAYER MASK TO ANOTHER LAYER?

MOVE THE CONTENTS OF A LAYER WITHOUT MOVING THE LAYER MASK ITSELF?

APPLY A LAYER MASK PERMANENTLY TO A LAYER?

MOVE A LAYER MASK TO ANOTHER LAYER?

DELETE A LAYER MASK?

How do i…
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Index

A
accent lighting, 275
Add Layer Mask icon, 88, 92, 96, 109
Add Layer Style icon, 208
Add to Shape Area icon, 136
adjustment layers, 57–82

basics of, 58–61
Black & White, 70–71, 73
blend modes and, 71, 80–81
boosting color with, 72
brushes for, 66, 67–68
Color Balance, 74
color changes using, 58–61
creating new, 192
Curves, 67–69, 76–78, 150, 151, 273
duplicating, 82
editing, 61
file size and, 81
hiding, 61
Hue/Saturation, 60, 74, 171–172, 190, 192, 280
layer masks and, 64, 68, 82, 92
Levels, 63, 64, 238, 264
multiple photos and, 75–78
painting on, 68
Photo Filter, 73–74, 175, 252, 273
previewing, 65, 82
saving images with, 61
selective changes with, 62–66
Smart Object layers and, 238
thumbnails for, 64, 69
toggling on/off, 65, 82
Vibrance, 72
vintage effect, 74

Adjustments panel, 59
Eye icon, 61, 65, 82
presets, 78
resetting, 82

Adjustments submenu, 58, 59
Adobe Illustrator, 232
Adobe Photoshop. See Photoshop
Adobe Photoshop Lightroom, 287
advanced layer techniques, 249–286

advanced layer blending, 258–262
creating the main cover image, 278–286
lighting and shadow adjustments, 268–277
replacing a person’s background, 250–257
wrapping graphics on uneven surfaces, 263–267

album pages
creating using layers, 15–27
designing with Smart Objects, 234–241

aligning
layers, 20–21, 163–165
text, 129

All Caps option, 127
Application Frame, 8
Auto-Align Layers feature, 163–165

B
background color

filling with, 82
setting to default, 82, 176
swapping with foreground color, 91, 155, 176

Background layer
converting to regular layer, 16, 28, 215
converting to Smart Object, 235
duplicating, 39, 49, 167, 169, 186
filling with white, 210

backgrounds
blurring, 166–167
opacity setting, 18
replacing, 250–257
resources for, 15
spicing up, 255
textured, 15, 18, 99–100

Barker, Corey, 220
before/after previews, 65, 82
Bevel and Emboss layer style, 214, 256
Black, White gradient, 108, 110
Black & White adjustment layer, 70–71
black-and-white images

adjustment layers for creating, 70–71
color tint added to, 71
selectively adding color to, 73

blank layers, 202
blemish removal, 180–182
Blend If sliders, 258–262, 266
Blend Mode pop-up menu, 216
blend modes, 31–54

adjustment layer, 71, 80–81
advanced use of, 258–262
choosing, 54
Color, 45, 216
Color Burn, 43
Color Dodge, 44, 281
contrast-enhancing, 42, 45, 52
dark areas and, 47–48
darkening, 42, 43
Difference, 164
Eraser tool used with, 48
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faded areas and, 49–50
frame images and, 50–51
Hue, 46
keyboard shortcuts, 54
layer style, 216, 217
lightening, 42, 44
Luminosity, 46
Multiply, 34–35, 49–51, 54, 81, 217
Normal, 165, 274
Overlay, 38, 51–52, 53, 153, 176
Pass Through, 274
pop-up menu, 42, 54
Screen, 36–37, 48, 54, 275
Soft Light, 38–39, 52, 53, 54
Vivid Light, 45

Blending Options layer style, 259, 266
blending photos. See combining photos
blur effects

depth of field and, 166–167
drop shadows and, 101
skin softening with, 186–187
smoothing details with, 264
soft focus and, 173–175

Brush Picker
Brush tool, 5, 67, 282
Eraser tool, 12

brush sets, 282, 283
Brush tool

adjustment layers and, 67–68
blur effects and, 167
choosing to use, 5
color boost using, 172
dodging and burning with, 154–155
hardness adjustment for, 176
HDR Toning and, 159
layer masks and, 90–91, 102, 111–112
painting with light using, 150–151
portrait retouching with, 187–188, 191, 193
selective sharpening with, 170, 188
shortcut for resizing, 96, 111, 155
soft focus effect and, 175
video tutorial on, 67, 282

burning and dodging, 152–155, 277
burnt/carved-in-wood effect, 223

C
Calligraphic Brushes, 284
Camera Raw

adjusting RAW photos in, 242, 244
Smart Object layers and, 233, 243, 244

carved-in-wood effect, 223

chain-link icon, 119
Character panel, 127, 143, 240
Classic Tint layer style, 218–219
clicking-and-dragging

layer masks, 119
layer styles, 225, 238
logos from images, 14
photos into documents, 10, 18, 87, 95
See also copying-and-pasting

Clip to Layer icon, 252
clipping masks, 113–118

creating, 115, 116
ideas for using, 118
Type layer and, 118

clone overlay feature, 196
Clone Stamp tool, 194–197, 201, 268
Color Balance adjustment layer, 74
Color blend mode, 45, 216
Color Burn blend mode, 43
Color Dodge blend mode, 44, 281
Color Efex Pro filters, 276
Color Overlay layer style, 216, 219
Color Picker, 24, 123, 125
Color Range dialog, 87, 141
color-coded layers, 22
color-related blend modes, 42, 45
colors

boosting specific, 72, 171–172
changing with adjustment layers, 58–61
colorcast adjustments, 76
filling with, 25, 45, 82
selectively adding, 73
Shape layer, 135
text, 125

combining photos
blending multiple images by, 12–13, 107–112
layer masks used for, 87–91, 95–102
replacing skies by, 146–148, 160–162

concert-like spotlight, 274–275
Content-Aware option, 162, 198–201, 268
contrast-enhancing blend modes, 38, 42, 45, 52
cooling filter, 74
copying-and-pasting

combining exposures by, 147
keyboard shortcuts for, 9
logos from images, 14
photos into documents, 9, 41, 114
selections from images, 19
See also clicking-and-dragging

copyright symbol, 213
cover image design, 278–286
Create a New Layer icon, 6
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Create New Adjustment Layer icon, 192
Crop tool, 165
Cross, Dave, 287
Curves adjustment layer, 67–69, 76–78

applying presets for, 78
lighting adjustments using, 253, 273
painting with light and, 150, 151
saving presets for, 77

Custom Shape tool, 140, 213

D
dark photos, 47–48
darkening blend modes, 42, 43
deleting

layer masks, 119
layer styles, 210, 225
layers, 26
See also removing

Density slider, 98, 148, 175
depth-of-field adjustments, 166–167
Desaturate command, 264
Deselect command, 23, 45
deviantART website, 282, 283, 285
Difference blend mode, 164
digital photos. See photos
disabling layer masks, 119
Displace filter, 266
distraction removal, 194–197, 268
DJ Rob Analyze, 269–277
documents

copying photos into, 9, 41
creating new, 9, 41

dodging and burning, 152–155, 277
double-processing technique, 242–246
drawing shapes, 134
Drop Shadow layer style, 209, 210
drop shadows

adding as layer style, 209
erasing areas of, 102, 211
layer masks and, 100–102

D-Town TV videocast, 287
duplicating

adjustment layers, 82
Background layer, 39, 49, 167, 169, 186
layer masks, 99, 119
layer styles, 225, 238
layers, 23, 28, 79, 176
selections, 43, 48
Smart Object layers, 235, 243
strokes, 23
Type layers, 130, 143

E
edge-darkening effect, 217
edgy effect, 254–255, 276
editing

adjustment layers, 61
layer styles, 219
Smart Object layers, 241, 244
text, 125

enhancing photos, 145–176
auto-aligning layers, 163–165
blend modes for, 47–53
boosting specific colors, 171–172
combining multiple exposures, 146–148
depth-of-field adjustments, 166–167
dodging and burning, 152–155
group photos, 163–165
painting with light, 149–151
pseudo-HDR effect, 156–159
replacing a sky, 160–162
selective sharpening, 168–170
soft focus effect, 173–175

Eraser tool
blend modes and, 48, 52
blending images with, 12–13
choosing to use, 6
drop shadows and, 102, 211
examples of using, 6, 7
setting options in, 12

Eye icon
Adjustments panel, 61, 65, 82
Layers panel, 11, 17, 210

eye whitening, 189, 190–191

F
Facebook page, 288
faded photos, 49–50
Feather setting, 98
file size

adjustment layers and, 81
duplicate layers and, 79

Fill Opacity setting, 214, 257
filling

layer masks, 82, 90
layers, 45, 153
selections, 25, 82, 97, 101, 148

filters
automatically reapplying, 176
Clouds, 281
Displace, 266
Gaussian Blur, 101, 167, 174, 239, 264
High Pass, 39, 254, 276
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Photo, 73–74, 175
Smart, 229, 239, 247
Surface Blur, 186
Unsharp Mask, 169
Warming, 175

flattening layers, 27, 42, 185, 202, 253
folders, grouping layers into, 24, 28
Font Family pop-up menu, 126, 143
fonts

preview size setting, 143
setting options for, 123, 124
sizing/resizing, 143
visually selecting, 126, 143
See also text; Type layers

foreground color
Color Picker setting, 24
filling with, 25, 82
setting to default, 82, 176
swapping with background color, 91, 155, 176
text created using, 123

Foreground color swatch, 123, 125
Foreground to Background gradient, 138
Fotolia.com website, viii, 15, 250, 268
frame images, 50–51
Free Transform command, 41

layer masks and, 106, 115
shadow placement and, 271
Shape layers and, 135, 137, 142
sky replacements and, 162
Smart Object layers and, 236

Fuzziness slider, 87
fx icon, 208, 211, 238

G
Gaussian Blur filter, 101, 167, 174, 239, 264
glitter and sparkles effect, 285–286
glowing light streaks effect, 220–221, 284–285
Gradient Editor, 131, 274
Gradient Picker, 17, 33, 52, 106, 108
Gradient tool, 17, 33, 52, 106, 108, 130, 138
gradients

applying to images, 33, 52
layer masks and, 108–109, 110
Shape layers and, 138
texture layers and, 17–18
Type layers and, 130–131

Graphic Authority website, 15
graphics

logo, 13–14
scribble, 37
symbol, 256–257

vector, 232
wrapping, 263–267

group photos, 163–165
grouping layers, 24, 28, 137, 272, 274
grungy effect, 156–159

H
hair highlights, 283
HDR Toning adjustment, 156, 157–159
Healing Brush tool, 181–183, 255
hiding

adjustment layers, 61
layer masks, 97
layer styles, 210, 225
layers in the Layers panel, 11, 17
text highlight, 143

High Pass filter, 39, 254, 276
highlights

adding to hair, 283
edgy look to accentuate, 254

Hollywood, Calvin, 274
Hue blend mode, 46
Hue/Saturation adjustment layer, 60, 74, 171–172, 

190, 192, 280
Hue/Saturation shortcut keys, 202

I
Illustrator program, 232
Image Size dialog, 142
images

downloading for tutorials, viii
See also graphics; photos

information resources, 287–289
Inner Glow layer style, 217, 220, 256, 284
Inner Shadow layer style, 257
Input Levels slider, 63, 64
Invert button, 100, 150, 159, 280
Invert command, 150, 170, 191
iStockphoto.com website, viii, 15

J
justifying text, 129

K
Kelby, Scott, 287
Kelbytraining.com website, 289
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keyboard shortcuts
for blend modes, 54
for brush hardness setting, 176
for brush resizing, 96, 111, 155
for copying and pasting, 9
for creating layers, 17, 176
for duplicating Background layer, 39, 49, 167, 

169, 186
for font size settings, 143
for hiding/showing Layers panel, 5
for Hue/Saturation options, 202
for inverting images, 150, 170, 191
for merging layers, 42
for opacity settings, 54
for Overlay blend mode, 176
for reapplying filters, 176
for restacking layers, 28
for Screen blend mode, 48
for Subtract mode, 96

Kowkabany, David, 250

L
Lasso tool, 48
layer masks, 85–119

adding to layers, 88, 92, 96, 109
adjustment layers and, 64, 68, 82, 92
automatically creating, 103–106
basics of using, 86–91
black and white in, 89, 90, 91
blurred layers and, 167, 187
boosting colors using, 172
Brush tool and, 90–91, 102, 111–112
combining images using, 87–91, 95–102, 

107–112, 146–148
copying, 99, 119
deleting, 119
Density slider, 98, 148, 175
disabling/enabling, 119
duplicating, 99, 119
Feather setting, 98
filling, 82, 90
gradients and, 108–109, 110
hiding, 97
inverting, 100, 150, 159, 170, 280
light streak effect and, 285
Masks panel, 98, 148, 162, 175
moving between layers, 119
painting on, 68, 90–91, 94, 111–112
permanently applying, 119
selections and, 87
shadows and, 100–102

sharpened layers and, 170
Smart Object layers and, 245
soft focus effect and, 175
textures and, 99–100
thumbnails for, 64, 65, 68, 88, 89, 93–94
unlinking from layers, 119
viewing contents of, 119
X key shortcut, 91

Layer Style dialog, 54, 208, 214, 216, 225
layer styles, 205–225

adding to layers, 225
applying, 219, 225
basics of, 206–212
Bevel and Emboss, 214, 256
blend modes and, 216, 217
burnt/carved-in-wood effect, 223
Classic Tint, 218–219
Color Overlay, 216, 219
deleting, 210, 225
designing with, 206–212
Drop Shadow, 209
duplicating, 225, 238
editing, 219
glowing light streaks effect, 220–221, 284–285
hiding, 210, 225
ideas for using, 220–224
Inner Glow, 217, 220, 256, 284
Inner Shadow, 257
Outer Glow, 220, 284
Pattern Overlay, 221
plastic or watery text effect, 224
pop-up menu of, 208
preset, 218
regular layers from, 211, 225
reusable effects from, 215–219
rock texture effect, 221–222
saving, 217, 225
Smart Object layers and, 237–238, 240
Stroke, 208, 240
symbol images and, 256–257
watermarks and, 213–214

layers
adjustment, 57–82
advanced use of, 249–286
aligning, 20–21, 163–165
auto-aligning, 163–165
basics of, 2–7
blending, 31–54, 258–262
creating new, 6, 17, 28, 176
deleting, 26
duplicating, 23, 28, 79, 176
file size and, 79, 81
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filling, 45, 153
flattening, 27, 42, 185, 202, 253
grouping, 24, 28, 137, 272, 274
hiding, 11, 17
linking, 22
merging, 27, 42, 253
moving, 10, 11
naming/renaming, 22, 28
putting selections on, 207
rearranging, 11
restacking, 28
selecting individual, 7, 28
selecting multiple, 20
Shape, 133–142
Smart Object, 228–247
stroke, 23
thumbnails for, 93, 94
Type, 122–132

Layers panel
adjustment layers in, 60
Eye icon in, 11, 17, 210
hiding layers in, 11
keyboard shortcut for, 5
rearranging layers in, 11
resizing thumbnails in, 16

Leading setting, 240
Levels adjustment layer, 63, 64, 238, 264
lightening blend modes, 42, 44
Lighting brushes, 283
lighting effects

accent lighting, 275
concert-like spotlight, 274–275
glowing light streaks, 220–221, 284–285
lighting angle setting, 225
painting with light, 149–151
randomized lighting, 281

Lightness setting, 190, 192
lightroomkillertips.com website, 287
Linear Gradient, 33, 52, 106, 108, 131
Link Layers icon, 22
linking layers, 22
Lock Transparent Pixels icon, 106, 131
logos

adding to images, 13–14, 117
transparency of, 35

Luminosity blend mode, 46

M
Magic Wand tool, 49, 139
Maldonado, Jessica, 278
Mask Edge button, 98, 162, 251, 269

masks
clipping, 113–118
layer, 85–119

Masks panel, 98, 148, 162, 175
Maximize Compatibility dialog, 247
merging layers, 27, 42, 253
Move tool

aligning layers with, 164
photo positioning with, 10, 11, 18, 20
shape positioning with, 138
text positioning with, 26, 123, 128

moving
layer masks, 119
multiple images, 21, 22
photos into documents, 10, 18
text in layouts, 26

multiple exposures, 146–148
multiple layers

selecting, 20, 28
steps for using, 8–14

Multiply blend mode, 34–35
adjustment layers and, 81
examples of using, 35, 49–51, 279
faded areas and, 49–50
frame images and, 50–51
how it works, 34
keyboard shortcut, 54
layer styles and, 217

N
naming/renaming

custom shapes, 139
layer styles, 217
layers, 22, 28
strokes, 23

National Association of Photoshop Professionals 
(NAPP), 288

New document dialog, 9, 41, 113, 133
New Layer dialog, 153, 215
New Smart Object via Copy option, 243
New Style dialog, 217
Normal blend mode, 165, 274

O
OilPaint filter, 229
online videos. See video tutorials
Opacity setting

blurred layer, 174
dodging/burning, 154–155
drop shadow, 102
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Opacity setting (continued)
Eraser tool, 12
Fill Opacity, 214, 257
foreground color, 25
keyboard shortcut for, 54
layer style, 217
painting with light and, 150, 151
Photo Filter adjustment layer, 252
portrait retouching, 183, 188, 191, 193
Shape layer, 137
texture layer, 18
watermarks, 214

Open Documents as Tabs preference, 8
Open Image/Object button, 233, 243
Outer Glow layer style, 220, 284
Output Levels slider, 238
Overlay blend mode, 38, 51–52, 53

dodging and burning with, 153, 277
semi-black-and-white edgy look and, 71
shortcut key for, 176

P
Paint Bucket tool, 117
painting

on adjustment layers, 68
for dodging/burning, 154–155
on layer masks, 68, 90–91, 94, 111–112
with light, 149–151

Palette Options, 16
Paragraph panel, 129, 143
Pass Through blend mode, 274
Paste Into command, 105, 162
pasting. See copying-and-pasting
paths, turning selections into, 139, 142
Paths panel, 139, 142
Pattern Overlay layer style, 221
Pattern Picker, 221
Photo Filter adjustment layer, 73–74, 175, 252, 273
photos

blending with Eraser tool, 12–13
combining, 86–91, 95–112, 146–148
enhancing, 47–53, 145–176
example of drawing on, 2–3
logos added to, 13–14
opening in Photoshop, 5
repositioning multiple, 21, 22
retouching, 179–202
selecting parts of, 19, 20
Shape layers from, 141–142
sharpening, 39, 168–170
sizing/resizing, 19, 20, 41, 106

strokes added to, 23
watermarking, 213–214

Photoshop
opening photos in, 5
saving PSD files in, 27, 81, 247

Photoshop Lightroom, 287
Photoshop User magazine, 288
Photoshop User TV videocast, 287
Photoshop video/online training, 289
Photoshop World Conference & Expo, 289
plastic text effect, 224
Polygon tool, 138
portrait retouching, 180–193

blemish removal, 180–182
eye whitening, 189, 190–191
skin smoothing, 184–188
teeth whitening, 189, 191–193
wrinkle removal, 180–183

positioning
images, 10, 11
shapes, 138, 140
text, 26, 123, 128

presets
Curves, 77–78
layer style, 218

previewing
adjustment layer effects, 65, 82
clone source area, 196, 197
fonts, 126, 143

Procunier, Nicole, 278
PSD files, 27, 81, 247
pseudo-HDR effect, 156–159

Q
Quick Selection tool, 63, 96, 97, 251

R
Radial Gradient icon, 17, 138
Radius slider, 251
randomized lighting, 281
rasterizing type, 130
RAW photos

adjusting in Camera Raw, 242, 244
Smart Object layers and, 233, 243, 244

rearranging layers, 11
Rectangle tool, 134, 136, 239
Rectangular Marquee tool, 19, 24, 25
Refine Edge feature, 96, 207
Refine Mask dialog, 251
Refine Radius tool, 98, 251, 269, 279
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removing
blemishes, 180–182
distractions, 194–197, 268
lens flare spots, 200
shadows, 200–201, 255
white fringe, 270
wrinkles, 180–183
See also deleting

renaming. See naming/renaming
resizing. See sizing/resizing
resources, 287–289
retouching photos, 179–202

blemish removal, 180–182
Content-Aware option for, 198–201
distraction removal, 194–197
eye whitening, 189, 190–191
lessening the effect of, 202
skin smoothing, 184–188
teeth whitening, 189, 191–193
wrinkle removal, 180–183

reusable photo effects, 215–219
Reverse checkbox, 17, 110
Robinson, Russ, 269
rock texture effect, 221–222
rotating text, 26

S
Sample All Layers option, 199, 202
sampling images, 182, 195–196
Saturation setting, 72, 172, 190, 192, 280
saving

adjustment layers, 61
Curve presets, 77
images as PSD files, 27, 81, 247
layer styles, 217, 225
Smart Object layers, 247

Scale command, 19
Screen blend mode, 36–37

dark areas and, 48
examples of using, 37, 48, 275
how it works, 36
keyboard shortcut, 48, 54

scribble graphics effect, 37
S-curve shape, 76
selecting

multiple layers, 20, 28
parts of images, 19, 20, 63
shapes, 139, 141
text, 143

selections
adjustment layer, 62–66

blurring, 101
copying-and-pasting, 19, 20
duplicating, 43, 48
filling, 25, 82, 97, 101, 148
layer masks and, 87
paths created from, 139, 142
putting on own layer, 207
rectangular, 24
refining edges of, 98
video tutorial on, 63, 96, 104, 147, 251

selective sharpening, 168–170
sepia-tinted look, 71
shadows

adding to photos, 271–272
edgy look to accentuate, 254
layer masks and, 100–102
removing from photos, 200–201, 255
selecting in photos, 141
See also drop shadows

Shape layers, 133–142
adding to, 136, 137
color changes for, 135
creating, 134–135
custom, 139–142
gradients and, 138
grouping, 137
layer masks and, 138
photos as source of, 141–142
positioning, 138, 140
resizing, 142
selecting shapes for, 139, 141
subtracting from, 136
transforming, 135, 137, 142

Shape Name dialog, 139
Shape Picker, 140, 142
Shape tools, 134, 138
sharpening photos

blend mode for, 39
selective sharpening, 168–170

sizing/resizing
brushes, 96, 111, 155
fonts, 143
photos, 19, 20, 41, 106
Shape layers, 142
Smart Object layers, 230, 236
thumbnails in Layers panel, 16
Type layers, 142

skies
adjusting brightness of, 51–52
combining photos with, 146–148, 160–162
removing lens flare spots in, 200
replacing in images, 160–162
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skin retouching
blemish removal, 180–182
skin color adjustment, 252
smoothing skin, 184–188
wrinkle removal, 180–183

Smart Filters, 229, 239, 247
Smart Guides, 116
Smart Object layers, 228–247

adjustment layers and, 238
converting layers into, 235, 247
creating, 228–229
double-processing technique, 242–246
duplicating, 235, 243
editing, 241, 244
layer styles and, 237–238, 240
New Smart Object via Copy option, 243
opening images as, 247
placing images as, 247
RAW photos as, 233, 243, 244
replacing contents of, 231, 241, 247
resizing, 230, 236
saving, 247
Smart Filters and, 229, 239, 247
template design using, 234–241
text added to, 240
vector artwork and, 232

Smart Radius checkbox, 251, 269
Smoke brushes, 282
Smooth command, 114
smoothing

image details, 264
skin, 184–188

soft focus effect, 156, 173–175
Soft Light blend mode, 38–39

examples of using, 39, 52, 53
how it works, 38
keyboard shortcut, 54

spacing text, 127, 240
sparkles and glitter effect, 285–286
Spot Healing Brush tool, 162, 182, 198, 199–201, 

268
spotlight effect, 274–275
stacking/restacking layers, 28
Stamp Visible Layers option, 185
Step Backward command, 158
Stroke dialog, 23
Stroke layer style, 208, 240
strokes

adding, 23, 208
duplicating, 23

styles. See layer styles
Styles panel, 218, 225

Subtract from Shape Area icon, 136
Subtract mode keyboard shortcut, 96
Surface Blur filter, 186
symbol images, 256

T
teeth whitening, 189, 191–193
templates, designing, 234–241
text

adding, 26, 117
aligning, 129
All Caps option, 127
changing color of, 125
creating boxes for, 128–129
editing in Type layer, 125
font settings, 123, 124, 126, 143
hiding highlight around, 143
justifying, 129
plastic or watery, 224
positioning, 26, 123, 128
putting photos inside, 118
rasterizing, 130
rotating, 26
selecting, 143
sizing/resizing, 143
Smart Object layer, 240
spacing adjustments, 127, 240
See also Type layers

text boxes, 128–129
texture map, 264–265
textures

background, 15, 18, 99–100
copying into photos, 53
layer masks and, 99–100
rock-like, 221–222

Threshold Level setting, 141
thumbnails

adjustment layer, 64, 69
layer mask, 64, 65, 68, 88, 89, 93–94
resizing in Layers panel, 16
selecting for layers, 93, 94
Shape layer, 135, 136

tint effect, 71, 215
Tonal Contrast filter, 276
Topaz Adjust plug-in, 254, 276
Tracking setting, 127
transparent paper example, 3–4
Trash icon, 26
tutorials

downloading images for, viii
See also video tutorials



299I n d e x

Twitter info, 288
Type layers, 122–132

adding text on, 124, 128
clipping masks and, 118
color settings, 125
duplicating, 130, 143
editing text on, 125
font settings, 123, 124, 126
gradients added to, 130–131
paragraph options, 129
rasterizing, 130
resizing, 142
text boxes, 128–129
See also text

Type tool, 123, 124, 128, 240

U
underexposed photos, 47–48
Underlying Layer slider, 261–262, 266
Undo command, 158, 182
Undo Fill command, 90
Unsharp Mask filter, 169
Use Global Light checkbox, 225

V
vector artwork, 232
Vibrance adjustment, 72
video tutorials, viii

on brushes, 67, 282
on cover image design, 278, 286
on layer basics, 2
on selections, 63, 96, 104, 147, 251

videocasts, 287
vintage effect, 74
Vivid Light blend mode, 45

W
warming filter, 73, 175
Warp command, 106
watermarks, 213–214
watery text effect, 224
web resources, viii, 287–289
wedding album pages

creating using layers, 15–27
designing with Smart Objects, 234–241

white fringe removal, 270
wrapping graphics, 263–267
wrinkle removal, 180–183
WYSIWYG font preview, 126

X
X key shortcut, 91, 155, 176

Z
Zoom tool, 104, 169, 191, 193
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