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C H A P T E R  F O U R

Collecting Data in Forms

Forms provide a uniquely interactive element in a Web site. Through a 
form you not only convey content, you also collect content. This content 
can range from orders for products, feedback on site content, service 
requests, and subscription list sign-ups to surveys, forum discussions, and 
opinion polls.

Some form content is managed using scripts that run in the visitor’s 
browser. Such scripts are referred to as client-side data handling. A jump 
menu, for example, collects data (the page a visitor to your Web site 
wants to go to, for example) and acts on that input (by opening a new 
Web page). The client-side script does that without sending any data to a 
server. Other forms collect data and send it to a server, where scripts on 
the server manage the data. These are called server-side forms. Most form 
data is managed by server-side scripts. One example of a server-side script 
is a mailing list form. Visitors enter information (at least an email address 
and maybe more) into a form. That data is then stored in a  database on a 
remote server. It can be accessed to send out mailings.

In short, this chapter explains how to design two kinds of forms: 

• Forms that manage data in the browser (client-side)

• Forms that connect to scripts at a server (server-side)

In this chapter, you’ll learn how to connect a form to an existing server 
script (but not how to program the scripts). I’ve also thrown in some tips 
on where you can find already-packaged server scripts to handle things 
like search forms, sign-up mailing lists, and discussion forums.
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Creating Jump Menus
#24

One great example of a client-side form is a jump menu from which a 
visitor selects a page in your Web site from a pop-up menu. A jump menu 
works because script (in this case, JavaScript) acts on a form and effects 
an action (in this case, opening a new Web page) based on data the visitor 
entered into the form (the page the visitor chose from the jump menu). 
Dreamweaver creates jump menu forms and automatically generates the 
required JavaScript.

Jump menus are an efficient and attractive way to allow visitors to nav-
igate your site. You can provide a long list of target links in a jump menu 
without using much valuable space on your Web page.

To create a jump menu, follow these steps:

1. With a page open in the Document window, choose Insert > Form > 
Jump Menu. The Insert Jump Menu dialog opens.

2. Use the Text field to name each menu item—enter text that will appear 
in the jump menu. 

Note 
The text you enter in the Text field defines the name of the menu item. You 
don’t have to enter anything in the Menu Item field; that information is 
automatically generated by what you type in the Text field. 

3. In the “When selected, go to URL” field, either enter a URL for a link or 
use the Browse button to navigate to and select a file on your site.

4. Define additional jump menu options by clicking the plus button in 
the dialog and entering new text and URLs. Repeat to enter as many 
jump menu options as you need. Delete an item from the jump menu 
by selecting it and clicking the minus button.

5. To change the order of an item in the jump menu list, select the item 
and use the Up and Down arrow buttons in the dialog to move the 
selected item up or down in the list.

6. After you define all the links in the jump menu, click OK to generate the 
menu. Test the menu in a browser (you can’t test it in the  Dreamweaver 
Document window because the jump menu works with JavaScript in a 
browser).

Jump Menus Use 

JavaScript to Handle 

Form Input 

When a visitor chooses a 
Web page (or other link, like 
an image file) from the jump 
menu, a script generated 
by Dreamweaver opens the 
selected page in a browser 
window. You don’t need to 
worry about this JavaScript. 
But you can look at it in 
Code view in the Document 
 window if you’re interested 
in seeing what the  
JavaScript looks like (or, if 
you know how to, you can 
edit the generated JavaScript 
in Code view of the Document 
window).
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To edit an existing jump menu, you need to open the behavior that 
Dreamweaver created to control the jump menu. View the Behaviors 
panel (choose Window > Behaviors). Click the jump menu to select it. As 
you do, you will see Jump Menu listed in the second column of the Behav-
iors panel. Double-click it to reopen the Jump Menu dialog and edit the 
jump menu (Figure 24a).

Figure 24a Opening the Jump Menu dialog by double-clicking Jump Menu in the 
Behaviors panel.

The Jump Menu dialog looks just like the Insert Jump Menu dialog, 
and you can add, remove, or move menu items or change menu options 
in this dialog.

Jump Menu Details

In the Insert Jump Menu 
dialog, the “Open URLs in” 
field allows you to define 
a frame in which to open a 
linked page. It applies only 
if you are working in frames. 
The Menu name field is 
automatically filled out by 
Dreamweaver and enables 
Dreamweaver to generate 
JavaScript to manage the 
input. In the Options area 
of the dialog, the “Insert 
go button after menu” 
check box generates a Go 
 button for your jump menu. 
The Go button is not reli-
ably  supported by brows-
ers and should be avoided. 
The “Select first item after 
URL change” check box 
 automatically places the 
first jump menu option as 
the selected choice after 
the jump menu is used to 
 navigate to a page.
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Generating Forms 
#25

Form data is collected using different kinds of form fields. Text is entered 
into text boxes or text areas. Options can be selected from sets of radio 
buttons. Data can be uploaded using file fields. Forms are submitted (or 
cleared) using Submit (or Reset) buttons.

To create a form in an open Web page in Dreamweaver, simply click 
to place the location of the form and choose Insert > Form > Form. The 
form displays as a dashed red box. The Properties inspector displays the 
form name. 

Make sure you have clicked inside the form before you add any form 
fields (Figure 25a).

Figure 25a A form placed on a page in Dreamweaver. 

To activate prompts for accessibility options in forms, choose Edit > 
Preferences (Windows) or Dreamweaver > Preferences (Mac) and select 
the Accessibility category. Select the Form objects check box if it is not 
already selected. With form accessibility options activated, Dreamweaver 
prompts you with the Input Tag Accessibility Attributes dialog when you 
insert a form field into a form. The accessibility options allow visitors to 
fill out the form without using a mouse, or if they are relying on reader 
software, to have an identifying label read to them.

Form Fields Only Work 

in Forms 

It’s important to be  conscious 
of this. Many of my students 
get frustrated trying to figure 
out why their sets of form 
fields aren’t doing anything 
when the problem is that 
those form fields are not 
nested inside a form. A page 
can have more than one 
form. That’s often not a good 
idea from a design standpoint, 
but you can imagine situa-
tions in which you might give 
visitors a choice of different 
forms to fill out.

Accessible Forms

Forms can be a big  challenge 
for visitors with disabilities. 
Form accessibility issues 
include making it easy 
for disabled visitors (who, 
for example, cannot use 
a mouse) to move from 
field to field in a form and 
to easily select form fields. 
Dreamweaver CS5 promotes 
accessibility in many ways, 
including form design. If you 
enable accessibility pref-
erences for form design, 
Dreamweaver prompts you 
to enter accessibility features 
for each form field as you 
place it in the form.
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Inserting Form Fields
#26

Form fields are used within a form to collect data. The main, most widely 
used field types are text boxes, drop-down menus, sets of radio (option) 
buttons, and check boxes. 

Text fields are used to collect all kinds of information in a form. Email 
addresses, phone numbers, purchase prices, zip codes, names, and a wide 
variety of other data can be entered into text fields.

Text fields collect a single line of text. Text areas can collect multiple 
lines of text. Text areas are used to collect comments, descriptions (like 
descriptions of problems for online service forms), guestbook entries, and 
other text that requires more than one line.

To place a text field or a text area in a form, follow these steps:

1. With your cursor inside an existing form, choose Insert > Form > Text 
Field or Insert > Form > Text Area. 

2. After you place the text field, you can define the field attributes in the 
Properties inspector (Figure 26a). In the TextField field, enter a name 
that will help you remember the content of the field. In the Char width 
field, enter the number of characters that will display on a single line 
in a browser as a visitor enters data. 

Figure 26a Defining a one-line text field.

3. In the Max chars field, you can enter the maximum number of charac-
ters that can be entered into the field. 

4. In the Init val field, enter text that will appear in the field in a browser 
before any user interaction. Sometimes (but not always) form design-
ers will include text like “your email goes here” in a field. Visitors then 
replace that content with their own entry. 

5. In the Type options, choose Single line for a text field and Multiline for 
a text area. If you choose Multiline, the Num Lines field appears in the 
Properties inspector. Enter the number of lines that will display in the 

How Many Characters 

Are Too Many for a 

Form Field?

Some thought needs to go 
into how many characters 
you elect to allow in a com-
ment field. My friendly HMO, 
for instance, allows for some-
thing like 25 characters or 
fewer to describe my medical 
condition, providing a nice 
way to raise my frustration 
level when I need to commu-
nicate with the HMO and can’t 
get through by phone! I can 
only hope other constraints 
are set more reasonably. 
There is a point to preventing 
someone from sending you 
his or her upcoming screen-
play in a comment box.

What Are Image Fields?

Image fields are images in 
a form. They are sometimes 
used to create customized 
Submit or Reset buttons, but 
doing that takes scripting 
that is not directly available 
in Dreamweaver.

If you want to place an image 
field, choose Insert > Form > 
Image Field. When you do, 
the Select Image Source dia-
log opens, and you can navi-
gate to and choose an image 
to insert into the form.

(continued on next page)
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form (you cannot define a limit for the number of characters that are 
entered). 

6. Enable the Password option only if you wish to display content entered 
into the field as asterisks.

7. You can use the Class pop-up menu to attach a CSS Class style to the 
field.

Tip
As you define text field or text area attributes in the Properties inspector, 
they display in the Document window. 

You can place any number of check boxes in a form. Check boxes pro-
vide two options for visitors: Checked or Unchecked. You can define a 
default state for a check box as either checked or unchecked.

To place a check box in a form, follow these steps:

1. With your cursor inside an existing form, choose Insert > Form > 
Checkbox. 

2. After you place the check box, if you did not generate a label, you need 
to enter some text in the form (normally to the right of the check box) 
that identifies what is being selected when a visitor selects the check 
box.

3. In the Properties inspector, enter a name for the check box in the 
Checkbox name field. In the Checked value field, enter a value to go 
with the check box name. For example, if the check box asks if a user 
wants to be contacted, the check box name might be “contact” and the 
checked value might be “yes.” 

Using Fieldsets  

for Design

A fieldset is a design tool used 
to draw boxes around sec-
tions of a form. Fieldsets are 
particularly useful if you have 
a long form. Long forms tend 
to be intimidating or confus-
ing, but by breaking groups 
of fields into boxed fieldsets, 
you can make your form 
more inviting and less over-
whelming. You can also use 
fieldsets to emphasize a set of 
fields in a form. For example, 
if there is some information 
that is required or that you 
particularly want to collect, 
you can enclose that group of 
fields in a fieldset.

Placing a Fieldset

To place a fieldset in a form, 
first make sure your cursor 
is inside the form. You don’t 
need to worry, initially, about 
the placement of the form 
fields you want to enclose in 
the fieldset. You can cut and 
paste them into the fieldset 
after you create it. Or you can 
click and drag to select the 
fields you want to include in 
the fieldset and then create 
the fieldset—that way, the 
fields are automatically

(continued on next page)
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4. Select one of the Initial state options to define whether the default 
state of the check box is Checked or Unchecked (Figure 26b). 

Figure 26b Defining a check box.

Radio buttons differ from check boxes in that they are always orga-
nized in groups. You never have a single radio button—if you are asking 
a question for which a user can supply no, one, or several answers, use 
check boxes. The purpose of radio buttons is to compel a user to choose 
one from a group of options.

To create a radio button group, follow these steps:

1. With your cursor inside an existing form, choose Insert > Form > Radio 
Group. The Radio Group dialog appears (Figure 26c).

Figure 26c Defining a group of radio buttons.

enclosed in the fieldset. With 
your cursor inside a form, 
choose Insert > Form > 
Fieldset. The Fieldset dialog 
appears. In the Legend box, 
type a name that will appear 
at the top-left corner of the 
fieldset. This is the label that 
visitors will read when they 
see the form in their browsers.

Attaching Class Styles 

to Text Fields

You can use the Class  pop-up 
menu in the Properties 
inspector to attach a CSS Class 
style to any field. However, 
this is sometimes especially 
handy for text (or text area) 
fields because you can for-
mat the text that a user enters 
into the form. See Chapter 3, 
#18, “Text  Formatting with 
Class Styles,” for a discussion 
on how to create and apply 
 Custom class styles.

Radio Buttons vs. 

Check Boxes

Radio buttons (aka option 
buttons) and check boxes 
represent two different ways 
to allow visitors to make 
selections from a set of 
options in a form. Radio but-
tons force a visitor to choose 

just one from a set of options. 

(continued on next page)

(continued on next page)
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2. In the Name field, enter a name that indicates to you the nature of 
the group of options. For example, if you are inquiring as to a type of 
shipping (Overnight, Two-day, Ground, etc.), you might call your group 
“Shipping_options.” 

3. In the Radio buttons area of the dialog, click the Label column. In the 
first row enter a label that will appear for visitors. Next to that label, 
in the Value column, enter the data that will be sent with the form. 
For example, a label might read “Two-day shipping” to make clear 
to users what they are selecting. But the value sent to your shipping 
department might be “TD-002”—an internal code that tells those in 
the department how to handle and bill shipping.

4. In the second row, enter another label and value. Use the plus button 
to add more rows of labels and values and the minus button to delete 
a selected row. Use the Up and Down arrow buttons to move selected 
rows up or down in the list of radio buttons.

5. In the “Lay out using” area, choose either the Line breaks radio button 
(for separated rows) or the Table radio button (for rows designed in a 
table).

6. After you define the radio button options, click OK in the dialog to 
generate the radio button group. 

After you generate a radio button group, you can edit (or delete) radio 
buttons individually. If you want to add a radio button, you can copy and 
paste an existing one from the group and, in the Properties inspector, 
change the Checked value (but not the Radio Button) content.

Menus and file fields are two different types of fields that can be 
placed in forms. Menus allow visitors to choose from a list of items. File 
fields allow users to upload files when they submit a form. In this how-to, 
you’ll explore both types of fields. (Consider this two how-tos for the price 
of one—I had to sneak them both into the same one to keep the book at 
an even 100 how-tos!) 

Menus (sometimes called pop-up menus) allow visitors to choose one 
option from a pop-up menu. The main difference between menus and list 
menus is that list menus allow users to select more than one choice from 
a list, whereas regular menus restrict users to choosing just one item. List 
menus are usually a confusing way to collect data and are rarely used. 

One frequently encountered 
situation in which radio but-
tons are the best way to 
collect information is when 
you are collecting credit 
card information from a pur-
chaser. In that case, you want 
him or her to select one, and 
just one, type of card from a 
list of cards you accept. 

On the other hand, check 
boxes (aka option boxes) 
allow visitors to choose, or 
not choose, any number of 
options. For instance, you 
might ask those filling out a 
form if they want to be con-
tacted by email, phone, snail 
mail, or text messaging. If you 
want to allow them to choose 
any combination of these 
options (including all or none 
of them), use check boxes.

How Radio Buttons 

Are Generated 

Among the advantages of 
using Dreamweaver’s Label 
dialog is that accessible 
labels are generated along 
with the radio button group 
and individual radio button 
values. There is no need for a 
distinct process of defining 
accessibility options for radio 
button groups if you use 
Dreamweaver’s radio button 
group feature.
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To create a menu, follow these steps:

1. With your cursor inside an existing form, choose Insert > Form > Select 
(List/Menu). You use this menu option to create either a menu or a list 
menu. Later, you will decide whether to make your menu a list menu 
or a regular menu. 

2. To create a list for the menu, click the List Values button in the Proper-
ties inspector. The List Values dialog appears. In the Item Label column, 
enter the text that will display in the menu (for example, Alaska). In 
the Value column, enter the value that will be collected and sent in the 
form (such as AK). Use the plus button to add new items to the list and 
the minus button to delete selected items. After you define the list, 
click OK (Figure 26d). 

Figure 26d Defining list values.

3. After you generate a menu (or list), use the Properties inspector to 
define additional features. If you click the List option button in the 
Type area of the Properties inspector, you can convert the menu into 
a list menu. If you choose the List option, you can click the Allow Mul-
tiple check box in the Options area of the Properties inspector to allow 
users to choose more than one option from the menu. List menus can 
also display more than one option at a time in the drop-down menu. 

4. You can add, delete, or edit actual menu (or list) items by clicking the 
List Values button in the Properties inspector. This will open the List 
Values dialog, where you can edit or change the order of menu (or list) 
options. You can change the initially selected option in the  Properties 

Radio Button  

Group Names

Why don’t you change the 
Radio Button information 
when you edit radio but-
tons? Because the Radio But-
ton value defines the group. 
The values of individual 
radio buttons within a group 
can change, but the group 
name must be the same 
for all buttons in the group. 
You can test your radio but-
ton group in a browser or 
Live view; if you choose 
one option from within the 
group, all other options 
should become deselected. 
If that doesn’t happen, you 
haven’t assigned the exact 
same group name (in the 
Radio Button field in the 
Properties inspector) to each 
radio button.

Because radio buttons are 
organized into groups, they 
are a little more complicated 
to define than other form 
fields. And because Dream-
weaver is the ultimate Web 
design program, it includes 
a dialog (Radio Group) that 
manages the whole process 
of defining a radio button 
group easily.

(continued on next page)
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inspector by clicking an option in the Initially selected area. You can 
assign a CSS style using the Class pop-up menu.

Note
The Properties inspector must be expanded to see the initially selected 
option.

File field forms allow visitors to attach files from their own computers 
to the form and send them along with the form. You can allow visitors 
to attach files to the form submission by inserting a File field in a form. 
Choose Insert > Form > File Field. You can define character width in the 
Properties inspector. A Browse button appears next to the field that the 
user can use to navigate to and select a file to upload. 

For form content to be sent to a server, there must be a Submit button 
in the form. Submit buttons are usually matched with a Reset button. The 
Reset button clears any data entered into the form and allows the user to 
start fresh.

To place a button in a form, choose Insert > Form > Button. Use the 
Properties inspector to define the button as a Submit or Reset button. 
In the Action area, choose the Submit form or Reset form radio button 
(Figure 26e). 

Figure 26e Defining a Submit button.

What’s Wrong with 

List Menus That Allow 

Multiple Options?

Pop-up menus are intuitive. 
Everyone is familiar with 
them, and they are easy to 
use. List menus, on the other 
hand, can be annoying. To 
choose multiple items, you 
must Command-click (Mac) 
or Ctrl-click (Windows). Add 
to this the fact that in a long 
list menu it’s hard to tell 
which options have been 
selected and which ones 
have not. For these reasons, 
list menus are not a good 
way to have visitors choose 
multiple items. Instead, con-
sider check boxes—an intui-
tive, clear way for users to 
choose one or more options 
from a list.

Don’t Limit  

Filename Sizes

Don’t constrain the number 
of characters that visitors can 
use to define an uploaded 
file by entering a value in the 
Max chars field in the Prop-
erties inspector. There is no 
point to setting a limit on the 
number of characters in an 
uploaded file’s name.



83

#26: Inserting Form Fields

You can define custom labels for either the Submit or Reset button 
by entering text in the Value field for either button. Don’t get too fancy; 
visitors are used to seeing buttons that display something like Submit or 
Reset. But if you enter different text in the Value field, that text will display 
in browsers and can be previewed in the Document window.

Using Hidden Fields

Hidden fields send informa-
tion to a server that is not 
entered by the visitor filling 
out the online form. Hidden 
fields can be used to iden-
tify things like the page from 
which a form was sent. Nor-
mally, you won’t be creating 
hidden fields. It’s more likely 
that they will be included in 
the HTML for a form that you 
download, connected to an 
existing server script. If you 
do need to create a hidden 
field in a form, choose  
Insert > Form > Hidden 
Field. The field, of course, 
does not display in the 
form; it appears only as 
an icon in the Document 
window. Enter a name for 
the field in the Hidden-
Field field in the Proper-
ties inspector and enter a 
value in the Value field.

Submit Buttons  

Are Essential!

No other settings are usually 
applied to Submit or Reset 
buttons, but a Submit button 
is essential if the form con-
tent is to be sent to a server.
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Testing Input with 
Validation Scripts 

#27
Spry tools in Dreamweaver CS5 make it easy to define forms with attached 
validation scripts. These scripts test form content before it is submitted to 
make sure certain rules are met; specifically in the case of the new Spry 
form fields, they require that a visitor fill in a form field before submitting 
the form. 

For example, if you want to require that visitors fill in the Email Address 
field in a form before they submit it, you can place a Spry Validation Text 
Field in your form. The four how-tos in this chapter explain how to use 
these Spry validation widgets.

All Spry validation widgets generate JavaScript to allow a form field to 
test input before processing the form. They also generate new CSS files 
that contain the formatting that defines the color, background color, text 
format, and so on for the form field and for form field input. 

To place a Spry Validation Text Field widget in a form, follow these 
steps:

1. Within a form, select Insert > Spry > Spry Validation Text Field. 

2. A text field appears in your form. With the new text field selected, the 
Spry text field options are displayed in the Properties inspector. 

3. In the Spry Text Field box in the Properties inspector, enter a field 
name with no spaces or special characters (use alphanumeric charac-
ters). The field name is used to process data and is not displayed in a 
browser.

4. By default, the Required check box is selected in the Properties inspec-
tor. Leave this check box selected to make the text field a required 
field.

Testing Data  

with Scripts

Many times you will want to 
test content entered into a 
text field before you allow 
a visitor to submit the form. 
For example, you might 
require visitors to enter their 
name before submitting a 
form. In that case, the valida-
tion test would be that a visi-
tor could not leave the Name 
field blank before submitting 
it. The Spry Validation Text 
Field widget can detect a 
blank field and alert the per-
son filling out the form that 
a name is required before 
the form can be submitted. 
Or, you might want to test 
content entered into a text 
field even beyond determin-
ing whether or not the field 
was left blank. If, for example, 
you are collecting a zip code 
from the visitor, you can test 
to see if the data entered into 
the zip code field actually is 
a five- or nine-digit zip code. 
You can use the Spry Valida-
tion Text Field widget to ver-
ify that the data submitted 
in the form field conforms to 
the criteria you define, and 
again, force people to pro-
vide data that at least looks 
like a zip code before the 
form can be submitted.
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5. If you want to test data entered into the text field to meet validation 
criteria (for instance, the data must be in the form of an email address, 
a zip code, a URL, or a phone number), select one of those options 
from the Type pop-up menu in the Properties inspector (Figure 27a).

Figure 27a Choosing Email Address as the validation type. 

6. The Enforce Pattern check box makes it impossible for users to enter 
characters that do not conform to the validation rule. For example, if 
you define validation rules for a U.S. zip code and a user tries to enter 
a letter (like A), that character will not appear in the field. 

7. Use the Hint box in the Properties inspector to provide initial content 
in the text field (for instance, you might use youremail@email.com to 
suggest to users that they need to enter a complete email address). 

8. Choose when to validate the field entry from the set of Validate on 
check boxes. Use Blur to validate when a user clicks outside the text 
field. Select Change to validate as the user changes text inside the 
text field. Choosing Submit validates when the user clicks the Submit 
 button in the form. 

9. The Preview States pop-up menu in the Properties inspector just 
defines what state is displayed in the Document window in Dream-
weaver. The state that displays in a browser depends on whether the 
user conforms to or breaks the validation rules. 

Including Options 

or Rules for Preset 

Validation Types

For example, if you chose to 
test input for zip codes, you 
can test for five-digit  (US-5), 
nine-digit (US-9), British 
(UK), or Canadian (Canada) 
format. The Format pop-up 
menu displays these options. 
Many of the preset valida-
tion types include rules 
defining how many char-
acters will be allowed and/
or maximum and minimum 
values. For example, the 
five-digit zip code validation 
type will only accept five 
numbers.

Creating Your Own 

Validation Rules

You can create your own 
validation rules for text 
boxes by choosing Integer 
(number) from the Type 
pop-up menu in the Prop-
erties inspector, and then 
defining a maximum (Max 
chars) and/or minimum (Min 
chars) number of characters, 
and a maximum (Max value) 
and/or minimum (Min value) 
value for numbers entered 
into the field.
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You can edit Spry validation rules at any time by selecting the turquoise 
Spry Text Field label and changing values in the Properties inspector.

Although validation scripts are most widely used for text boxes, they 
can be defined (in a way similar to the steps I just outlined for text boxes) 
for other form fields as well.

Spry Validation Text 

Field Widgets Don’t 

Verify Actual Data

To be clear: None of the Spry 
Validation Text Field widgets 
actually looks up data and 
verifies that it is accurate. But 
the widgets do verify that at 
least the correct form of data 
has been submitted, elimi-
nating forms that are sent to 
your server that don’t have 
required information fields 
filled in.

Validating Text  

Area Input?

Text area fields are used 
almost exclusively for  
comments—and comments 
in this digital age are one of 
the more available ways that 
customers, clients, students, 
patients, and people in gen-
eral communicate with orga-
nizations and businesses. If 
you place a text area field in 
a form, you might well want 
to use the Spry Validation 
TextArea widget to define 
a few rules for how much 
content can be entered in 
the field. 

Validating Checkbox Input? 

Sometimes a check box provides an option that a user can either choose 
or not choose. Do you want to receive unsolicited email? Do you have a 
discount code? Did you hear about this Web site from a friend? In all these 
cases, a form designer will likely allow the user to select, or not, any or all of 
the check boxes. In other cases, clicking a check box is mandatory to sub-
mit a form. Required check boxes are used to verify that a visitor has read a 
license agreement before downloading software or that a visitor agrees to 
set terms before reading site content. 
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Connecting a Form 
to a Server Script

#28
Form actions define how the data in a form is sent to a database on a 
server. Form actions are defined in the Properties inspector with the 
form—not any specific form field—selected. 

Tip
To select a form, click the dashed red line defining the form border. 
Or, click the <form> tag in the tag selector area on the bottom of the 
 Document window.

The three important fields in the Properties inspector for a form are 
the Action, Method, and Enctype fields. What you enter in these fields is 
determined by how the programmer (who set up the script and database 
to which the form data is being sent) configured the database and scripts 
at the server. Normally, Method is usually set to POST but can sometimes 
be set to GET; this again depends on how data is transferred to the server 
and is defined by how the server is configured. The Action field contains 
the URL of the Web page at the server that has the script that will manage 
the data.

Enctype, short for “encryption type,” is sometimes used to define how 
characters are interpreted and formatted. Your server administrator will 
tell you what, if any, enctype coding is required for forms to be processed 
by your server. 

Because form actions are determined by the settings at your server, 
the information you enter into the Properties inspector is provided by 
your server administrator. In the case of forms designed to match server 
scripts, those forms normally come with Action settings defined.

If you want to collect data in a form and have it sent to an email address, 
you can do this easily without having to work with additional server con-
figuration or scripts. In the Action field, type mailto:<your email address>. 
From the Method pop-up menu, choose POST. In the Enctype field, type 
text/plain (Figure 28a).

Figure 28a Defining an action that will send form content to an email address—in 
this case, mine!

Let me give you a recipe for one of the most widely used server- 
connected forms: a search engine. Follow these steps to place a FreeFind 

Don’t Mess with 

Hidden Fields in 

Imported Forms

If a CGI script provider gives 
you HTML to create a form 
to send data to a server, the 
provider will likely include 
hidden fields. These hidden 
fields define how the data 
is processed at the server. 
It’s best if you don’t edit or 
delete them.

Sending Form Content 

via Email—Pro  

and Con

The easiest way to collect 
form content is to have the 
content sent to an email 
address. This is the model 
used in this technique. The 
advantage is that it requires 
no scripting on your part. 
The downside is that it 
requires the person sub-
mitting the form to have 
an installed email client on 
his or her system. Although 
many users who have Inter-
net access on their system 
have an email client as well, 
people using public comput-
ers at schools or libraries will 
not have access to email cli-
ents. For some applications, 
this is a problem.
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search field on an open Dreamweaver Web page. You can also use them 
as a model for using similar services. 

1. Go to www.freefind.com and enter your email address and your site’s 
URL (at an online server). Click the Instant Signup button. FreeFind 
emails you a password, a login, and a link to the FreeFind control cen-
ter. Follow the link, log in, and then click the link for a free search field 
(or you can choose one of the more elaborate, ad-free pay options).

2. Click the Build Index tab in the FreeFind control center, and then click 
the Index Now link. FreeFind builds a database at the FreeFind server 
of all the words in your Web site. 

3. Click the HTML tab and choose one of the four available types of 
search field forms you can use (the options are Site Search Only, Site 
and Web Search, Web Search Only, or Text Links).

4. Select all the HTML for the search field you selected, and choose Edit > 
Copy from your browser menu.

Online CGI Services

Many online services provide 
you with server-side data-
bases and scripts, and these 
services often host online 
databases and scripts as well 
(or they tell you how to copy 
them to your server). For 
example, there are services 
that allow you to host a mail-
ing list at their server. They 
provide you with HTML that 
you copy into your Web page. 
That HTML contains the cod-
ing for the form, as well as 
a connection to a script at a 
server that manages the data 
put into the form.

Helpful CGI Scripts, 

Forms, and  

Hosting Services

In addition to the FreeFind 
search service, there are a 
few other useful sources for 
scripts and hosting to man-
age form data. These sites 
provide various sets of avail-
able forms and scripts that 
collect Web statistics, collect 
feedback, manage message 
boards, generate survey polls, 
allow guestbook listings,

(continued on next page)

www.freefind.com
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5. Back in Dreamweaver, click in the Document window to set the place 
where the search field will be inserted. Then choose View > Code to 
switch to Code view. Don’t worry about any of the code you see—your 
cursor is in the spot you clicked in Design view. Choose Edit > Paste to 
place the HTML code and switch back to Design view to see the search 
field (Figure 28b). 

Note
The form copied from FreeFind includes hidden fields, which are indicated 
by icons in the form. These fields have information that directs search 
queries to the index FreeFind prepares for your particular site.

Figure 28b Placing a search field from FreeFind. 

Test your search field in a browser. The search field form has fields and 
buttons. You can reformat the fields and buttons using the techniques 
for defining form and form field attributes we’ve covered. In other words, 
you can customize the way this form looks—you just can’t delete any of 
the form fields. Other techniques in this chapter cover how customization 
works, so you can customize forms you get from CGI hosts.

and store and manage email 
lists. You can find online 
database and script ser-
vices by searching for “CGI 
scripts.” CGI stands for Com-

mon Gateway Interface and 
is the protocol (system) that 
is used (with options for 
various programming lan-
guages) to manage form 
input.

Can’t See Your Form in 

Dreamweaver?

Normally, forms display in 
the Document window (in 
Design view) as red lines. 
This border is invisible in a 
browser. Dreamweaver dis-
plays the borders of forms as 
a highly helpful tool so that 
you can make sure all your 
form fields are inside your 
form. If they’re not inside the 
form, they won’t work.

Displaying form outlines is a 
default option that you can 
turn off. If you don’t see the 
dashed red line indicating 
the form, turn on this option 
by choosing View > Visual 
Aids > Invisible Elements. 
With Invisible Elements 
selected in this submenu, 
you’ll be able to see your 
form.
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Numbers

3D perspective angle, 
adjusting in Flash, 227

4-up option, using with 
images, 64

360 grid, using ruler with, 158
960 container style,  

applying, 44
960 Grid System, features  

of, 32, 157

Symbol

* (asterisk), appearance in 
External Files tab, 71

A

absolute link, defining, 16
absolute versus relative  

divs, 52
accessibility settings

activating for forms, 76
choosing for images, 65

actions
adding rotation to, 210
assigning in Catalyst, 

207–210
recording in Photoshop, 145
removing in Catalyst, 209
testing in Catalyst, 209

Adobe Bridge
accessing Fireworks from, 

254–255
managing files in,  

254–255
Adobe BrowserLab, using, 27
Adobe Device Central

accessing in  
Dreamweaver, 29

testing images in, 143–144

Adobe Media Encoder
batch processing video 

conversions, 261
converting to multiple 

formats, 261
modifying appearance  

of interface, 262
turning off autocue, 262
using, 260–262

Adobe Web gallery, creating, 
256–257

anchors, manipulating in 
Illustrator, 170

animations. See also Flash 
animation
previewing in Flash 

Professional, 221
slowing in Flash, 232
stopping from looping in 

Flash, 235
anti-aliasing

preserving in type, 189
previewing, 188–189
type for Web, 188–189

AP (absolute placement) divs
versus div tags, 39
moving, 52
versus relative divs, 52
using, 51–52

Apple QuickTime Player, 
downloading, 118

art brushes, using in  
Illustrator, 175

artboards, setting up for 
Illustrator, 164–166

artwork. See also images; 
photos
animating on banner, 231
converting to button in 

Catalyst, 205
creating for Flash, 220, 224
editing in Flash, 222

exporting to Flash SWFs, 
195–196

importing from  
Illustrator, 224

importing from 
Photoshop, 224

releasing to sequenced 
animation, 197

saving for Flash 
developers, 198

artwork with transparent 
backgrounds, exporting, 
190–191

asterisk (*), appearance in 
External Files tab, 71

audio, previewing with 
HTML5, 121

B

background colors
assigning in  

Dreamweaver, 37
changing for menu  

bars, 100
changing for slideshows, 

245
changing for tabbed 

panels, 102
defining for absolutely 

positioned div, 51
identifying for 

transparency, 191
selecting for three column 

layout, 46
using with links, 61
viewing on pages, 53

background gradients, 
creating in Illustrator, 
179–181

background images, tiling, 
152–154
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backgrounds. See also tiling 
backgrounds; transparent 
backgrounds
assigning to CSS boxes, 53
assigning to pages, 154
formatting for collapsible 

panels, 104
making transparent, 149
pattern ideas, 154
semitransparent, 155–156

banners
animating artwork on, 231
specifying artboard size in 

Flash, 227
Behaviors panel, locating 

behaviors in, 110
Body tag

applying, 56
defining in Dreamweaver, 

34–35
formatting font style, 36
setting page margins, 36

Bridge
accessing Fireworks from, 

254–255
managing files in, 254–255

browser windows
defining OnClick  

trigger, 108
opening, 107–108
pop-up blocking, 108
previewing pages in, 

27–29
testing behavior of, 108
triggering event, 107

BrowserLab, using, using, 27
brushes

calligraphic, 175
drawing with in Illustrator, 

175–176
buttons. See also four-state 

buttons
placing in forms, 82–83

using rounded rectangles 
for, 168

C

Catalyst. See Flash Catalyst
CGI services and scripts, 

availability of, 87–88
check boxes

placing in forms, 78–79
versus radio buttons, 

79–80
validating input, 86

Class styles
attaching to text fields, 79
categories for, 49
creating, 49
defining for fonts, 59
inserting, 50
rounded-corner box, 

132–134
tag independence, 59
using in moderation, 59
using with images, 50

clipboard, copying images 
into, 138

CMS site
connecting Dreamweaver 

to, 68–69
defining remote 

connection to, 68
editing CSS in, 70

CMSs (content management 
systems), 55

code
displaying for forms in 

Catalyst, 216
inspecting in 

Dreamweaver, 25–26
code hints

adding CSS3 attributes 
with, 132–135

availability in Flash, 230

code snippets
adding to stop  

animations, 233
using in Flash, 229–230

Code view, using in 
Dreamweaver, 25–26

coding actions, using  
in Flash, 230

collapsible panels. See Spry 
collapsible panels

color palettes
checking for 

transparencies in, 191
defining in Photoshop, 

147–148
Color Profiles, availability in 

Photoshop, 140
colors. See also text color

applying to CSS boxes, 53
defining for links, 61

columns. See three-column 
layout

compression
choosing export option 

for, 187
choosing to export 

slideshows, 250
defining in Photoshop, 

147–148
Crop command, using with 

images, 141
Crop tool, using in 

Dreamweaver, 24
CSS boxes

applying generated colors 
to, 53

assigning backgrounds 
to, 53

CSS elements
editing, 53
identifying, 53

CSS files
attaching to pages, 38
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creating once, 38
defining, 67
generating, 54
generating in 

Dreamweaver, 34
uploading after  

changing, 71
CSS layout pages

previewing, 54
using, 54

CSS layouts
standards applied  

to, 54
storing styles for, 54

CSS rules
for Firefox, 132
for links, 60–62
for Safari, 132

CSS styles. See also style 
sheets
assigning to HTML5 

elements, 125
associating with HTML 

tags, 63
editing in CMS site, 70
implementing with 

layouts, 54
types of, 34

CSS Styles panel
editing styles in, 38
using to format tabbed 

panels, 102
CSS Visual Aids, using, 130
CSS3 attributes, adding with 

code hints, 132–135
CSS3 code, generating for new 

features, 132
CSS3 styles

applying Web pages, 
134–135

attributes in, 134
curves, adjusting in  

Illustrator, 170

D

data tables. See also tables
choosing for Spry data 

displays, 95
columns and fields in, 92

Design view
testing pages in, 27–29
using in Dreamweaver, 25

Device Central
accessing in  

Dreamweaver, 29
testing images in, 143–144

dithering, defining in 
Photoshop, 147–148

div tag names, using with Spry 
widgets, 98

div tags
versus AP (absolute 

placement) divs, 39
inserting into  

three-column layout, 47
options, 40
Overflow options, 40
reusing styles for, 48
styles, 39

download times,  
displaying, 186

downloading, progressive 
versus interlaced, 146

drawing
with brushes in Illustrator, 

175–176
in Flash CS5, 222–223
with Pen tool in Illustrator, 

169–171
with Perspective Grid, 

182–183
Dreamweaver CS5

960 grid, 32
absolute placement, 51–52
accessibility settings, 20
adding servers, 4

adding spacing around 
images, 23

adjusting line height, 
57–58

Adobe BrowserLab, 27
aligning images, 23
Assets panel, 3
assigning background 

color, 37
attaching CSS files to 

pages, 38
Body tag, 34–35
Brightness and Contrast 

sliders, 24
browsing folders, 3
changing units of 

measurement, 12
choosing DTD (document 

type definition), 12–13
cleaning up HTML from 

Word, 15
Code view, 25
connecting forms to server 

scripts, 87–89
connecting to CMS site, 

68–69
connecting to remote 

server, 8
connecting to remote  

site, 4–7
coordinating sites, 8–9
copying and pasting 

images into, 20–22
creating CSS files once, 38
creating CSS for printable 

pages, 66–67
creating forms, 76
creating style sheets, 

34–38
creating Web pages, 12–14
Crop tool, 24
CSS layout pages, 54
defining Body tag, 34
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defining font size, 57
defining font tag styles, 

56–58
defining image quality, 21
defining local site, 2–3, 11
defining sites, 3
dependent files, 10
deselecting Live Code 

button, 26
Design view, 25
designing three-column 

layout, 43–48
designing with Class styles, 

49–50
developing aesthetic 

theme, 3
Device Central, 29
displaying forms in 

Document window, 89
displaying rulers, 32–33
displaying site content, 3
div overflow options, 40
div tags versus AP  

divs, 39
Document window, 12
downloading files from 

server, 9
editing CSS elements, 53
editing images, 23–24
editing photos in, 24
email links, 17
embedding Flash, 112–113
embedding FLV files, 

114–116
embedding images, 18–24, 

63–65
embedding media with 

HTML5, 120–122
embedding QuickTime 

media, 117–119
embedding SWFs in, 216
embedding Windows 

Media, 118–119
external styles, 35

file management on 
server, 8

file-naming caution, 14
Files panel, 10–11
finding Heading tags, 35
formatting CMS themes, 

70–71
formatting links, 60–62
formatting page  

elements, 36
FTP connections, 68
FTP location for remote 

site, 4
FTP Performance 

Optimization, 5
generating CSS styles, 

34–35
Hand tool, 13
headers and footers, 47
home pages, 14
icons in Files panel, 10
identifying audience, 2
identifying CSS  

elements, 53
Image Description box, 22
Image Preview dialog, 63
Image Preview window, 21
image settings, 21
importing spreadsheets, 

16–17
importing Word 

documents, 16–17
inserting form fields, 77–83
inspecting code, 25–26
installing HTML5 Pack 

extension, 124
layout tools, 32
link targets, 16–17
linking style sheets, 34–38
login name for remote 

site, 4–5
Manage Sites dialog, 4
managing links between 

files, 3

managing sites in Files 
Panel, 8–11

maximizing word 
processors, 15

moving files between 
folders, 10

naming servers, 4
naming sites, 2
navigating documents, 12
New Document dialog 

box, 12
obtaining remote server, 4
online image formats, 

22–23
opening Web pages, 12
organizing files, 3
page filename, 14
page formatting, 35
page title, 14
password for remote site, 5
planning site content, 2
previewing in Live View 

and browsers, 27–29
previewing QuickTime 

movies, 118
print versus Web  

images, 22
Progressive option, 64
Proxy Host settings, 5
redefining zero points, 32
resizing images, 23
root directory for remote 

site, 5
rules for home pages, 11
Save Web Image dialog, 22
saving images to folders, 3
saving Web pages, 12–14
Select Image Source 

dialog, 19
Select tool, 13
selecting HTML pages, 12
server connection  

settings, 7
server parameters, 6–7

Dreamweaver CS5, continued
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setting page margins, 37
settings parameters for 

effects, 109
Sharpen tool, 24
Site Definition dialog, 2
Site folder, 11
site home pages, 14
Site Setup dialog, 4
Split view, 25
Spry tools for validation 

scripts, 84
status bar tools, 13
Switch Now link for views, 

25
synchronization options, 6
synchronizing sites, 9–11
testing data with  

scripts, 84
testing remote  

connection, 6
text and links, 15–17
“This Document Only” 

styles, 35
toggling between views, 25
uploading open Web 

pages, 9
uploading Web sites, 8–9
username for remote 

site, 4
using grids and guides, 

32–33
using ID styles with page 

layouts, 39–42
Web URL field, 5
working with files, 10
XHTML 1.0 Transitional, 13

DTD (document type 
definition), choosing, 12–13

E

effects
applying in Illustrator, 

177–178

applying to objects, 
109–110

defining elements  
for, 109

editing in Illustrator, 177
examples of, 109
grouping in Illustrator, 178
importing into Flash  

CS5, 195
removing in Illustrator, 177
settings parameters, 109

email links, converting text 
to, 17

export settings, choosing, 
186–187

exporting
artwork to Flash SWFs, 

195–196
artwork with transparent 

backgrounds, 190–191
Catalyst projects to  

SWF, 217
FLA files, 220–223
Illustrator files as HTML, 

192–193
slideshows, 246, 249–251
slideshows to QuickTime 

movies, 249–251
external CSS style sheet, 

defining, 34–38
extrusion, using Perspective 

Grid for, 182
Eyedropper tool

accessing, 139
using with transparent 

background color, 191

F

fieldsets, using in forms,  
78–79

file fields, using in forms, 82
file formats, choosing export 

settings for, 186

File Size/Download Time 
display, described, 13

filename sizes, avoiding 
placing limits on, 82

files
saving in Illustrator, 171
slicing for Web, 159

Files panel, displaying in 
Dreamweaver, 10

Fill feature, using in 
Photoshop, 153

fill pattern
defining for  

background, 154
reducing opacity of, 153

Firefox, CSS rule for, 132–133
Fireworks

accessing from Bridge, 
258–259

batch processing images, 
258–259

FXG image format, 259
Incremental Backups 

option, 258
FLA files

creating, 220–223
creating artwork  

for, 220
creating from  

templates, 237
exporting, 220–223
features of, 195
versus FLV and SWF  

files, 113
saving as templates, 236

Flash. See also SWF files
embedding, 112–113
preparing to export to, 195

Flash animation, generating 
layers for, 197–198. See also 
animations

Flash artwork, editing, 222
Flash Builder Standard, 

features of, 253
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Flash Catalyst
adding rotation to  

action, 210
applying filters to button 

states, 206
assigning actions, 207–210
building forms, 216
copying and pasting  

in, 200
creating custom scrollbar, 

214–215
creating four-state 

buttons, 205–206
creating media player, 

211–213
creating Play button, 

211–213
Design-Time Data  

panel, 210
displaying code for  

forms, 216
drawing shapes, 203
drawing tools, 200
duplicating states, 208
editing artwork from 

Illustrator, 200–202
editing artwork from 

Photoshop, 200–202
exporting projects to  

SWF, 217
features of, 199
form field properties, 216
generating forms, 209
image quality versus 

editability, 201
Import dialog, 200
Import to add images 

option, 203
integration of Illustrator 

with, 200
isolating graphic  

elements, 215
limits on video player 

controls, 209

maximum number of 
opened projects, 202

opening artwork from 
Illustrator, 200–202

opening artwork from 
Photoshop, 200–202

removing actions, 209
rotating objects, 204
Select tool, 203
size of imported  

images, 203
sketching prototypes of 

pages, 203
support for effects, 202
testing actions, 209
Transform tool, 204
Video Properties  

panel, 213
wireframing in, 203–204

Flash developers, saving 
artwork for, 198

Flash files. See FLA files
Flash movies

explained, 112
testing, 230, 232
Timeline layers in, 228

Flash objects
entering text in frames 

of, 228
manipulating parameters 

for, 112–113
Flash Player

choosing skin for FLV 
video, 115

choosing version of, 195
choosing versions for 

slideshows, 247–248
saving to version 8, 196

Flash Professional CS5
adjusting 3D perspective 

angle, 227
Advanced Photo Album 

option, 243–246
classic tweens, 231

code “hints,” 230
code snippets, 229–230
coding actions, 230
Convert Anchor Point  

tool, 233
creating animated movie, 

231–233
creating artwork in, 224
creating photo albums, 

240–242
creating projects, 220–221
creating templates, 

236–237
creating timeline,  

227–228
drawing in, 222–223
drawing shapes, 222
editable motion tween 

paths, 233
editing properties for 

strokes, 223
editing properties of  

stage, 220
export options, 221
features of, 219
file type options, 221
Font Embedding  

panel, 230
frames in Timeline  

grid, 228
generating morphing 

shape, 234–235
importing effects into, 195
inserting keyframes in 

animations, 231–232
kerning in, 225
Motion Tween option, 231
moving Timeline layer, 234
placing artwork in  

layers, 234
previewing animations, 221
providing editable  

text, 226
Rectangle tool, 222
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selecting stroke and fill for 
shape, 223

shape tweening, 234–235
slowing animations in, 232
specifying artboard size for 

banner, 227
stopping animations from 

looping, 235
support for effects and 

filters, 224
Templates tab, 221
testing slideshows, 243
Timeline grid and l 

ayers, 228
Timeline snippets, 229
TLF (Text Layout 

Framework), 225–226
Tools panel, 222
typography tools,  

225–226
Flash slideshows.  

See slideshows
Flash SWFs. See SWF files
FLV files

accessibility of, 114
choosing Flash Player skin 

for, 115
converting videos to, 211
creating, 115
detecting video size, 

114–115
embedding, 114–116
embedding from  

YouTube, 114
versus SWF files,  

112–113
FLV videos, previewing, 116
folders, browsing in 

Dreamweaver, 3
font size, defining, 57
font style, defining with Body 

tag, 36
font tags

defining styles for, 56–58

previewing with Apply 
button, 58

fonts. See also text
adding to P (paragraph 

tag) text, 57
avoiding use with links, 

60–61
choosing settings for   

anti-aliasing, 189
defining Class styles for, 59

footers and headers, using, 47
form content, sending via 

email, 87
form fields

character limitations, 77
versus text fields, 77

form input, handling, 74
forms

Action field, 87
activating prompts for 

accessibility  
options, 76

building in Catalyst, 216
check boxes, 78–79
connecting to server 

scripts, 87–89
detecting blank fields  

in, 84
displaying in Document 

window, 89
Enctype field, 87
fields in, 76
fields in Properties 

Inspector, 87
fieldsets, 78–79
file fields, 82
generating in 

Dreamweaver, 76
generating via  

Catalyst, 209
hidden fields, 83
image fields, 77
maintaining hidden fields 

in, 87

menus, 80–82
Method field, 87
placing buttons in, 82
placing Spry Validation 

Text Field widget  
in, 84–86

placing text areas in,  
77–78

placing text fields in, 77–78
pop-up versus list  

menus, 82
radio button groups, 79–80
selecting, 87
Submit button, 82
testing input with 

validation scripts, 84–86
four-state buttons, creating in 

Catalyst, 205–206. See also 
buttons

FTP connections, making in 
Dreamweaver, 68

FXG image format, described, 
258–259

FXP format, explained, 199

G

GIF files
described, 22
using, 147–148, 186

gradient fill, adjusting in 
Illustrator, 181

gradients
adjusting in Illustrator, 179
creating in Illustrator, 

179–181
saving in Illustrator, 181

graphic elements,  
isolating, 215

graphic styles
availability in  

Illustrator, 178
previewing in  

Illustrator, 178
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grids, using in Dreamweaver, 
32–33

Group Selection tool, using in 
Illustrator, 172

guides
creating in Illustrator, 166
using in Dreamweaver, 

32–33

H

h.264 video
converting files to, 

260–262
embedding with HTML5 

elements, 251
Hand tool, using, 13
header style, defining for 

three-column layout, 46
headers and footers, using, 47
Heading tags

assigning to text, 58
finding in Dreamweaver, 35

hidden fields, using in  
forms, 83

home pages
requirement for  

filenames, 14
rules for, 11

hover state
displaying for links, 60
previewing link in, 62

HTML (HyperText Markup 
Language), exporting 
Illustrator files as, 192–193

HTML code, cleaning up, 15
HTML pages, selecting, 12
HTML tags

associating CSS styles 
with, 63

div, 39
HTML text-formatting tags

bullet point lists, 56
Headings 1-6, 56

numbered lists, 56
paragraph tag, 56

HTML Web pages, generating 
for slideshows, 248

HTML5
embedding media with, 

120–122
enabling Media Queries, 

128–131
examining coding in Split 

view, 125
Multiscreen Preview, 126
overview of, 126

HTML5 elements
assigning CSS to, 125
embedding h.264 video 

with, 251
HTML5 layouts

creating pages with, 
125–126

for iPhones, 128
using, 129

HTML5 Pack
installing, 124
Media Queries, 123

HTML5 tags
Aside element, 130
previewing audio and 

video with, 121
hyperlinks. See links

I

ID styles
versus Class div styles, 39
using to create page 

layouts, 39–42
Illustrator CS5

accessing variable width 
paths, 171

adjusting curves, 170
adjusting gradient fill, 181
adjusting gradients, 179
applying effects, 177–178

applying warp effect, 177
assigning colors to 

gradient stops, 180
assigning links in, 194
cleaning up paths, 171
constraining ellipses, 167
constraining lines and 

shapes, 167–168
constraining smooth 

curves, 170
Control panel options, 167
creating background 

gradients, 179–181
creating hybrid  

anchors, 171
creating slices, 192–193
defining links in, 194
Direct Selection tool, 169
displaying and hiding 

panels, 166
displaying bounding boxes 

for objects, 172
displaying rulers, 166
document profiles, 164
documents and  

artboards, 165
drawing lines and shapes, 

167–168
drawing rounded 

rectangles, 168
drawing with brushes, 

175–176
drawing with Pen tool, 

169–171
drawing with Perspective 

Grid, 182–183
editing artwork in Catalyst, 

200–202
generating layers for Flash 

animation, 197–198
gradient angles, 181
gradients and 

transparency, 180
graphic styles, 178
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Grid Color & Opacity 
settings, 182

Group Selection tool, 172
grouping effects, 178
grouping objects, 173
guides and grids, 166
importing artwork for 

Flash, 224
integration with Flash 

Catalyst, 200
manipulating anchors, 

170–171
Mobile and Devices  

profile, 164
optimizing  

rasterization, 188
panels, 165
Perspective Grid, 182–184
pixel preview, 166
polygons and stars, 168
previewing graphic  

styles, 178
Raster Effects  

resolution, 165
Rectangle tool, 183
rescaling objects, 172
resizing with Scale  

dialog, 174
RGB profiles, 164
rotating objects,  

172–174
saving files, 171
saving files in, 171
saving gradients, 181
scaling objects, 172–174
selecting all objects in, 173
sizing objects, 172–174
Slice Options dialog, 194
Spiral tool, 167–168
tiling backgrounds, 179
troubleshooting layers to 

frames, 198
using symbols as art 

brushes, 175

using to create artwork for 
Flash, 220

using type in Perspective 
Grid, 184

Video and Film profile, 164
viewing gradients in 

Swatches panel, 179
Web profile, 164–165
Zoom pop-up, 166

Illustrator files
creating looping 

animations from, 198
exporting as HTML, 

192–193
preparing to export to 

Flash, 195
saving as SWFs, 195

Illustrator templates,  
creating, 171

image fields, using in  
forms, 77

image format, choosing, 147
Image Preview window

opening in  
Dreamweaver, 63

resizing images in, 64
image quality, defining, 21
image size, choosing for  

Web, 138
images. See also artwork; 

photos
4-up option, 64
adding spacing around, 23
aligning in  

Dreamweaver, 23
Alternate text option, 65
applying horizontal 

spacing to, 65
applying style sheets to, 63
applying vertical spacing 

to, 65
assigning links to, 24
batch processing in Bridge, 

258–259

converting to Web-
compatible formats, 63

copying and pasting into 
Dreamweaver, 20–22

copying into clipboard, 138
creating buffer space 

around, 65
cropping in  

Dreamweaver, 24
defining text for, 20
editing in Dreamweaver, 

23–24
embedding in 

Dreamweaver, 18–24, 
63–65

entering descriptions in 
Dreamweaver, 22

“fading in,” 64
grouping in slideshows, 

243
inserting Web-compliant 

formats, 64
opening in Photoshop, 138
preparing for Web, 22, 63
previewing, 64
previewing in 

Dreamweaver, 21
print versus Web, 22
Progressive option, 64
rescaling for Web,  

141–143
resizing for Web,  

141–142
resizing in Dreamweaver, 

23–24
resizing in Image Preview 

window, 64
settings, 21
testing in Adobe Device 

Central, 143–144
using accessibility options 

with, 65
using Class styles  

with, 50
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images with transparent 
backgrounds, saving, 
149–150

Inspect button, using in 
Dreamweaver, 25–26

interlaced downloading, 
applying in Photoshop, 146

iPhone, HTML5 layout for, 
128–131

iPhone-ready h.264 file, 
converting video to, 
260–262

J

JavaScript, using to open 
browser windows,  
107–108

JPEG files
embedding in  

slideshows, 247
lossy format, 148
previewing export options 

for, 139
Quality settings for 

exports, 187
quality settings in 

Photoshop, 140
using, 147

JPEG format
assigning to slices, 160
described, 22, 186
using with photos, 146

jump menus, using 74–75

K

keyframes, inserting in Flash 
animations, 231–232

L

layers
creating in Photoshop, 153

generating for Flash 
animation, 197–198

layout style, creating for three 
columns, 45

line height, adjusting for type, 
57–58

lines
constraining in  

Illustrator, 167
drawing in Illustrator, 

167–168
link states, defining, 60–61
link targets

defined, 194
types of, 16–17

links
assigning in Illustrator, 194
assigning to text in  

Flash, 226
avoiding use of fonts with, 

60–61
colors associated with, 60
defining colors for, 61
defining in Illustrator, 194
defining Target window 

for, 17
displaying hover state, 60
formatting, 60–62
seeing effects of, 62
using Rendering tools 

with, 62
Live view, previewing pages 

in, 27–29
looping animation, creating 

from Illustrator file, 198

M

margins, setting in 
Dreamweaver, 37

media, embedding via HTML5, 
120–122

Media Encoder. See Adobe 
Media Encoder

media player, creating in 
Catalyst, 211–213

Media Queries
displaying without  

HTML5, 131
enabling, 128–131
features of, 123, 128

Menu Bar widget
changing background 

color, 100
changing text color, 100
customizing, 100
default positioning, 100
editing styles associated 

with, 99
generating, 98
horizontal versus  

vertical, 99
styles, 100
Turn Styles Off button, 99

menus. See also Spry menu 
bars
creating lists for, 81
manipulating items in, 81
placing in forms, 80–82

mobile devices
previewing pages in, 29
saving photos for, 138–140

morphing shape, generating 
in Flash, 234–235. See also 
shapes

Motion Tween option, 
choosing in Flash, 231

Movie Settings dialog, Filters 
button in, 250

-moz coding, using with 
Firefox, 132–133

Multiscreen Preview, using, 
127, 131

O

objects, manipulating in 
Illustrator, 172–174
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opacity, reducing for 
background images, 
153–154

P

p (paragraph) tag, defining, 
57–58

page elements, formatting in 
Dreamweaver, 36

page layouts
creating with ID styles, 

39–42
three-column, 43–48
using tables for, 31

page margins, setting in 
Dreamweaver, 37

page-break attribute,  
using, 67

pages. See Web pages
paths

cleaning up in  
Illustrator, 171

variable width in  
Illustrator, 171

pattern brushes, using in 
Illustrator, 176

Pause button, designing in 
Catalyst, 213

Pen tool
adding anchors, 170
defining anchors, 169
deleting anchor  

points, 170
using in Illustrator,  

169–171
Perspective Grid, using, 

182–184
photo albums, creating in 

Flash, 240–242
photos. See also artwork; 

images
converting to sized 

images, 243–246

converting to thumbnails, 
243–246

displaying as slideshows, 
240–242

editing in Dreamweaver, 24
preparing for Web, 22
reducing artifacts in, 139
saving for Web and mobile 

devices, 138–140
Photoshop

applying interlaced 
downloading, 146

applying progressive 
downloading, 146

assigning backgrounds to 
pages, 154

Color Profiles, 140
creating layer for tiling 

background images, 153
creating semitransparent 

backgrounds, 155–156
creating tiling background 

images, 152–154
cropping photos for  

Web, 141
defining color palettes, 

147–148
defining compression, 

147–148
defining dithering, 

147–148
drawing wireframes and 

mockups, 158
editing artwork in Catalyst, 

200–202
Fill feature for tiling 

background images, 
153–154

Image Size dialog, 142
importing artwork for 

Flash, 224
opening image files  

in, 138
preparing thumbnails, 145

quality settings for JPEG 
files, 140

recording actions, 145
reducing opacity of fill 

patterns, 153
Save for Web & Devices 

window, 138–139
saving images 

with transparent 
backgrounds, 149–150

saving photos for mobile 
devices, 138–140

saving photos for Web, 
138–140

scaling for Web and 
devices, 142–144

setting up wireframe 
templates, 157

slicing files for Web, 159
support for image  

files, 138
using for Web photos, 22

Photoshop files
creating from clipboard 

content, 138
saving as Web pages, 

160–161
pixel preview, availability in 

Illustrator, 166
Play button, creating in 

Catalyst, 211–213
PNG files, using 23, 147, 186
polygons, points and sides in 

Illustrator, 168
pop-up versus list menus, 82
pop-ups. See browser 

windows
print formatting, using, 67
printer output, defining style 

sheets for, 66–67
printer styles, previewing for 

CSS, 67
progressive downloading, 

applying in Photoshop, 146



274

I N D E X

Progressive option, using with 
images, 64

Properties Inspector, using to 
define links, 16

Publish settings options, using 
with slideshows, 247–248

Q

QuickTime filters,  
applying, 250

QuickTime media, embedding, 
117–119

QuickTime movies
exporting slideshows to, 

249–251
previewing in 

Dreamweaver, 118

R

radio buttons
versus check boxes, 79–80
generating, 80
group names, 81

rasterization, optimizing in 
Illustrator, 188

Rectangle tool
using in Flash, 222
using in Illustrator, 183

relative link, defining, 16–17
relative versus absolute  

divs, 52
remote connection, defining 

for CMS site, 68
Rendering tools, using with 

links, 62
Reset button, defining custom 

labels for, 83
resizing images for Web, 141
resolution, variations in, 22
rotating objects

in Catalyst, 204
in Illustrator, 172–174

rulers
displaying in 

Dreamweaver, 32–33
displaying in  

Illustrator, 166
using with 360 grid, 158

S

Safari, CSS rule for, 132–133
Save for Web & Devices 

window
applying transparency  

in, 190
checking download  

times, 186
enlarging, 139
features of, 138
Frame Rate setting, 196
interlacing download, 146
Looping setting, 196
progressive download, 146
tools in, 139

saving
FLA files as templates, 236
gradients in Illustrator, 181
images with transparent 

backgrounds, 149–150
Web pages, 12–14
Web-compatible formats, 

186
scaling objects in Illustrator, 

172–174
scripts, using to test  

data, 84
search engine form, placing 

on page, 87–89
Select tool

using, 13
using in Catalyst, 203

server scripts, connecting 
forms to, 87–89

servers, adding for 
Dreamweaver, 4

shape tweening in Flash, 
234–235

shapes. See also morphing 
shape
constraining in  

Illustrator, 167
drawing in Catalyst, 203
drawing in Flash, 222
drawing in Illustrator, 

167–168
Sharpen tool, using in 

Dreamweaver, 24
site content, planning for 

Dreamweaver CS5, 2
Site Definition dialog, opening 

in Dreamweaver, 2
sites

naming in Dreamweaver, 2
uploading to 

Dreamweaver, 8–9
sizing objects in Illustrator, 

172–174
Slice Options dialog, 

accessing, 194
slices

assigning JPEG format  
to, 160

assigning settings  
to, 193

configuring, 193
creating, 192–193
defining link attributes 

for, 194
saving, 160
saving in different  

formats, 193
selecting, 160

slides, adding to  
slideshows, 242

slideshows
adjusting settings, 244
adjusting timing of, 242
changing background 

colors, 245
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displaying photos as, 
240–242

displaying Timeline  
for, 244

editing image titles, 244
embedding JPEG files  

in, 247
exporting, 246, 249–251
generating HTML Web 

pages for, 248
grouping images in, 243
Publish settings  

options, 247
publishing as SWF files, 

247–248
setting timing of, 244
streaming faster, 251
testing, 243

Spiral tool, using in Illustrator, 
167–168

Split view, using in 
Dreamweaver, 25

spreadsheets, importing, 
16–17

Spry Accordion widgets, 
using, 106

Spry collapsible panels, using, 
103–104

Spry data displays, using, 
95–97

Spry Data Set wizard, 
launching, 95

Spry data source tables, using, 
92–94. See also tables

Spry data sources, testing and 
updating, 96–97

Spry menu bars, using, 98–100. 
See also menus

Spry tabbed panels, using, 
101–102

Spry tooltips,  
defining, 105

Spry validation rules,  
editing, 86

Spry Validation Text Field 
widget, using, 84–86. See 
also text fields

Spry widgets, using, 98
status bar tools in 

Dreamweaver, 13
style sheets. See also CSS 

styles
applying changes to all 

pages, 48
applying to images, 63
attaching for three-column 

layout, 43
attaching to pages, 67
creating and linking,  

34–38
defining for printer output, 

66–67
style.css file, expanding styles 

in, 70
styles, editing in CSS Styles 

panel, 38
Submit button, designing for 

forms, 82–83
SWF files. See also Flash

embedding in 
Dreamweaver, 216

exporting artwork to, 
195–196

exporting Catalyst projects 
to, 217

versus FLV files, 112–113
publishing slideshows as, 

247–248
saving Illustrator files  

as, 195
saving to XFL  

format, 220
support for, 216
Web-compatibility, 186

SWF objects, embedding in 
Web pages, 112–113

SWF slideshows. See 
slideshows

symbols, using as art brushes 
in Illustrator, 175

T

tabbed panels. See Spry 
tabbed panels

tables, using for page  
layout, 31. See also data 
tables; Spry data source 
tables

tags
applying, 56
overriding formatting, 56

templates
960-grid, 157
creating FLA files  

from, 237
creating in Flash, 236–237
creating in Illustrator, 171
using with Flash 

Professional, 221
testing Web pages in viewing 

environments, 27–29
text. See also fonts

assigning heading tags 
to, 58

assigning paragraph tags 
to, 58

converting to email  
link, 17

defining for images, 20
text area input, validating, 86
text areas, placing in forms, 

77–78
text boxes, creating validation 

rules for, 85
text color. See also colors

changing for menu  
bar, 100

formatting for tabbed 
panels, 102

text fields. See also Spry 
Validation Text Field widget
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attaching Class styles  
to, 79

versus form fields, 77
placing in forms, 77–78

text tags, defining formatting 
of, 57

three-column layout
changing column  

widths, 47
creating left-column  

style, 47
designing, 43–48
Insert Div Tag dialog, 47

thumbnail action, recording in 
Photoshop, 145

thumbnails
converting photos to, 

243–246
preparing in  

Photoshop, 145
tiling backgrounds, creating, 

152–154, 179. See also 
backgrounds

timeline, creating in Flash, 
227–228

TLF (Text Layout Framework), 
using in Flash, 225–226

tooltips, defining, 105
Transform tool, using in 

Catalyst, 204
transparency

applying, 190
identifying background 

color for, 191
transparency dithering, 150
transparent backgrounds. See 

also backgrounds
saving images with, 

149–150
versus transparency, 190

tweens, classic versus 
generated motion, 231

type
adjusting line height, 

57–58
anti-aliasing for Web, 

188–189
editing in Perspective 

mode, 184
formatting for Web sites, 

56, 58
preserving anti-aliasing 

in, 189
using in Perspective  

Grid, 184
type formatting versus 

typography, 55
type tags, applying, 56
typography versus type 

formatting, 55

U

units of measurement, 
changing, 12

V

validation rules, creating for 
text boxes, 85

validation scripts, using with 
forms, 84–86

vertical scrollbar, creating in 
Catalyst, 214–215

video player controls, using in 
Catalyst, 211–213

<VIDEO> tag, using with 
HTML5, 121

videos
converting to FLV  

format, 211
converting to iPhone-

ready h.264 file, 
260–262

deciding on  
packaging, 111

file formats, 111, 260
previewing with  

HTML5, 121
Visual Aids, using with  

CSS, 130

W

warp effect, applying in 
Illustrator, 177

Web
choosing image sizes  

for, 138
cropping photos for, 141
preparing images for, 22

Web devices, saving photos 
for, 138–140

Web gallery, creating, 256–257
Web pages

assigning backgrounds 
to, 154

assigning titles to, 13–14
attaching CSS files to, 38
bringing text into, 15
choosing from jump 

menus, 74
creating, 12–14
opening, 12
opening in new browser 

windows, 17
presenting optional 

information in, 103–104
previewing, 27–29
previewing in mobile 

devices, 29
saving, 12–14
saving Photoshop files as, 

160–161
saving with filenames, 

13–14
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testing in Design view, 
27–29

testing in viewing 
environments, 27–29

viewing in Multiscreen 
Preview, 127

Web profile, using in 
Illustrator, 165

Web sites
naming in Dreamweaver, 2
uploading to 

Dreamweaver, 8–9
Web-compatible formats, 

saving, 186
-webkit coding, using with 

Firefox, 132–133

Window size display, 
described, 13

Windows Media, embedding, 
118–119

wireframe templates, setting 
up, 157

wireframes, drawing for 
Dreamweaver, 2

wireframing in Catalyst, 
203–204

Word documents, importing, 
16–17

Word HTML, cleaning  
up, 15

word processors,  
maximizing, 15

X

XFL format, saving Flash files 
to, 220

XHTML 1.0 Transitional, use 
of, 13

Y

YouTube, embedding FLV files 
from, 114

Z

zero points, redefining in 
Dreamweaver, 32

zip codes, testing input for, 85
Zoom tool, described, 13



WATCH
READ

CREATE
Meet Creative Edge. 
A new resource of unlimited 

books, videos and tutorials for 

creatives from the world’s 

leading experts.

Creative Edge is your one 

stop for inspiration, answers to 

technical questions and ways to 

stay at the top of your game so 

you can focus on what you do 

best—being creative. 

All for only $24.99 per month 

for access—any day any time 

you need it.

peachpit.com/creativeedge


	Contents
	Chapter Four: Collecting Data in Forms
	#24: Creating Jump Menus
	#25: Generating Forms
	#26: Inserting Form Fields
	#27: Testing Input with Validation Scripts
	#28: Connecting a Form to a Server Script

	Index
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	O
	P
	Q
	R
	S
	T
	U
	V
	W
	X
	Y
	Z


	text: 


