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ADOBE AFTER EFFECTS CS5 CLASSROOM IN A BOOK 1

Adobe® After Effects® CS5 provides a comprehensive set of 2D and 3D tools

for compositing, animation, and effects that motion-graphics professionals, 

visual effects artists, web designers, and film and video professionals need.

After Effects is widely used for digital post-production of film, video, DVD,

and the web. You can composite layers in various ways, apply and combine 

sophisticated visual and audio effects, and animate both objects and effects.

About Classroom in a Book

Adobe After Effects CS5 Classroom in a Book® is part of the official training 

series for Adobe graphics and publishing software, developed with the support 

of Adobe product experts. The lessons are designed to let you learn at your 

own pace. If you’re new to Adobe After Effects, you’ll learn the fundamental 

concepts and features you’ll need to master the program. And if you’ve been 

using Adobe After Effects for a while, you’ll find that Classroom in a Book 

teaches many advanced features, including tips and techniques for using the 

latest version.

Although each lesson provides step-by-step instructions for creating a specific 

project, there’s room for exploration and experimentation. You can follow

the book from start to finish, or do only the lessons that match your interests 

and needs. Each lesson concludes with a review section summarizing what 

you’ve covered.

Prerequisites

Before beginning to use Adobe After Effects CS5 Classroom in a Book, make 

sure that your system is set up correctly and that you’ve installed the required 

software and hardware. You should have a working knowledge of your com-

puter and operating system. You should know how to use the mouse and 

standard menus and commands, and also how to open, save, and close files. If 

you need to review these techniques, see the printed or online documentation 

included with your Microsoft® Windows® or Apple® Mac® OS software.

GETTING STARTED
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Installing After Effects

You must purchase the Adobe After Effects CS5 software separately. For system 

requirements and complete instructions on installing the software, see the Adobe 

After Effects ReadMe.html file on the application DVD. Note that After Effects CS5 

requires a 64-bit operating system. You must also have Apple QuickTime 7.6.2 or 

later installed on your system.

Install After Effects from the Adobe After Effects CS5 application DVD onto 

your hard disk; you cannot run the program from the DVD. Follow the onscreen 

instructions.

Make sure that your serial number is accessible before installing the application; you 

can find the serial number on the registration card or on the back of the DVD case.

Optimizing performance

Creating movies is memory-intensive work for a desktop computer. After Effects CS5 

requires a minimum of 2GB of RAM. The more RAM that is available to After Effects, 

the faster the application will work for you.

OpenGL support

OpenGL is a set of standards for delivering high-performance 2D and 3D graphics 

for a wide variety of applications. Although After Effects can function without it, 

OpenGL accelerates various types of rendering, including rendering to the screen 

for previews. 

To use OpenGL in After Effects, you’ll need an OpenGL card that supports OpenGL 

2.0 and has Shader support and support for NPOT (Non Power of Two) textures. 

When you first start After Effects, it will attempt to determine if your OpenGL card 

meets the requirements, and it will enable or disable OpenGL as appropriate.

To view information about your OpenGL card, as well as enable or disable OpenGL 

in After Effects, choose Edit > Preferences > Previews (Windows) or After Effects >

Preferences > Previews (Mac OS). Select the Enable OpenGL option to enable 

OpenGL; click the OpenGL Info button to learn more about your card.

To learn more about OpenGL support in After Effects, see After Effects Help.

Color management

After Effects CS5 supports color management workflows. We encourage you to take 

advantage of the color management features in After Effects, especially for profes-

sional projects. For an introduction to color management, see the appendix, “Color 

Management in After Effects CS5.” 
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Restoring default preferences

The preferences file controls the way the After Effects user interface appears on 

your screen. The instructions in this book assume that you see the default interface 

when they describe the appearance of tools, options, windows, panels, and so forth. 

Therefore, it’s a good idea to restore the default preferences, especially if you are 

new to After Effects.

Each time you quit After Effects, the panel positions and certain command settings 

are recorded in the preferences file. To restore the original default settings, press 

Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while starting 

After Effects. (After Effects creates a new preferences file if one doesn’t already exist 

the next time you start the program.)

Restoring the default preferences can be especially helpful if someone has already 

customized After Effects on your computer. If your copy of After Effects hasn’t 

been used yet, this file won’t exist, so this procedure is unnecessary.

Important: If you want to save the current settings, you can rename the preferences 

file instead of deleting it. When you are ready to restore those settings, change the 

name back, and make sure that the file is located in the correct preferences folder.

1 Locate the After Effects preferences folder on your computer:

For Windows: .../AppData/Roaming/<username>/Adobe/AfterEffects/10.0.

For Mac OS: .../Users/<user name>/Library/Preferences/Adobe/

After Effects/10.0

2 Rename any preferences file you want to preserve, and then restart After Effects.

Copying the lesson files

The lessons in Adobe After Effects CS5 Classroom in a Book use specific source files, 

such as image files created in Adobe Photoshop® and Adobe Illustrator®, audio files, 

and prepared QuickTime movies. To complete the lessons in this book, you must 

copy these files from the Adobe After Effects CS5 Classroom in a Book DVD (inside 

the back cover of this book) to your hard disk.

1 On your hard disk, create a new folder in a convenient location, and name it

AECS5_CIB, following the standard procedure for your operating system:

Windows: In Explorer, select the folder or drive in which you want to create 

the new folder, and choose File > New > Folder. Then type the new name.

Mac OS: In the Finder, choose File > New Folder. Type the new name, and 

drag the folder to the location you want to use.

Now, you can copy the source files onto your hard disk.
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2 Copy the Lessons folder (which contains folders named Lesson01, Lesson02, 

and so on) from the Adobe After Effects CS5 Classroom in a Book DVD onto 

your hard disk by dragging it to your new AECS5_CIB folder.

When you begin each lesson, you will navigate to the folder with that lesson num-

ber, where you will find all of the assets, sample movies, and other project files you 

need to complete the lesson.

If you have limited storage space on your computer, you can copy each lesson folder 

individually as you need it, and delete it afterward if desired. Some lessons build on 

preceding lessons; in those cases, a starting project file is provided for you for the 

second lesson or project. You do not have to save any finished project if you don’t 

want to, or if you have limited hard disk space.

About copying the sample movies and projects

You will create and render one or more QuickTime movies in some lessons in this 

book. The files in the Sample_Movie folders are examples that you can use to see the 

end results of each lesson and to compare them with your own results. These files 

tend to be large, so you may not want to devote the storage space or time to copying 

all the sample movies before you begin. Instead, find the appropriate Sample_Movie 

folder on the book’s DVD, and copy the file it contains onto your hard disk as you 

begin work on a lesson. (You cannot play movies from the DVD.) After you finish 

viewing the movie, you can delete it from your hard drive.

The files in the End_Project_File folders are samples of the completed project for 

each lesson. Use these files for reference if you want to compare your work in prog-

ress with the project files used to generate the sample movies. These end-project 

files vary in size from relatively small to a couple of megabytes, so you can either 

copy them all now if you have ample storage space, or copy just the end-project file 

for each lesson as needed, and then delete it when you finish that lesson.

How to use these lessons

Each lesson in this book provides step-by-step instructions for creating one or more 

specific elements of a real-world project. Some lessons build on projects created 

in preceding lessons; some stand alone. All of these lessons build on each other in 

terms of concepts and skills, so the best way to learn from this book is to proceed 

through the lessons in sequential order. In this book, some techniques and processes 

are explained and described in detail only the first few times you perform them. 



ADOBE AFTER EFFECTS CS5 CLASSROOM IN A BOOK 5

Many aspects of the After Effects application can be controlled by multiple tech-

niques, such as a menu command, a button, dragging, and a keyboard shortcut. 

Only one or two of the methods are described in any given procedure, so that you 

can learn different ways of working even when the task is one you’ve done before.

The organization of the lessons is also design-oriented rather than feature-oriented. 

That means, for example, that you’ll work with layers and effects on real-world 

design projects over several lessons, rather than in just one lesson.

Additional resources

Adobe After Effects CS5 Classroom in a Book is not meant to replace documentation 

that comes with the program or to be a comprehensive reference for every feature. Only 

the commands and options used in the lessons are explained in this book. For compre-

hensive information about program features and tutorials refer to these resources:

Adobe Community Help: Community Help brings together active Adobe product 

users, Adobe product team members, authors, and experts to give you the most 

useful, relevant, and up-to-date information about Adobe products. Whether 

you’re looking for a code sample or an answer to a problem, have a question about 

the software, or want to share a useful tip or recipe, you’ll benefit from Community 

Help. Search results will show you not only content from Adobe, but also from the 

community.

With Adobe Community Help, you can:

Access up-to-date definitive reference content online and offline.

Find the most relevant content contributed by experts from the Adobe 

community, on and off Adobe.com.

Comment on, rate, and contribute to content in the Adobe community.

Download Help content directly to your desktop for offline use.

Find related content with dynamic search and navigation tools.

To access Community Help: If you have any Adobe CS5 product, then you 

already have the Community Help application. To invoke Help, choose Help > 

After Effects Help. This companion application lets you search and browse Adobe 

and community content, plus you can comment on and rate any article just like you 

would in the browser. However, you can also download Adobe Help and language 

reference content for use offline. You can also subscribe to new content updates 

(which can be automatically downloaded) so that you’ll always have the most up-

to-date content for your Adobe product at all times. You can download the applica-

tion from www.adobe.com/support/chc/index.html.

www.adobe.com/support/chc/index.html
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Adobe content is updated based on community feedback and contributions. You 

can contribute in several ways: Add comments to content or forums, including links 

to web content; publish your own content using Community Publishing; or contrib-

ute Cookbook Recipes. Find out how to contribute: www.adobe.com/community/

publishing/download.html.

See http://community.adobe.com/help/profile/faq.html for answers to frequently 

asked questions about Community Help.

Adobe After Effects Help and Support: www.adobe.com/support/aftereffects is 

where you can find and browse Help and Support content on adobe.com.

Adobe TV: http://tv.adobe.com is an online video resource for expert instruction 

and inspiration about Adobe products, including a How To channel to get you 

started with your product.

Adobe Design Center: www.adobe.com/designcenter offers thoughtful articles 

on design and design issues, a gallery showcasing the work of top-notch designers, 

tutorials, and more.

Adobe Developer Connection: www.adobe.com/devnet is your source for techni-

cal articles, code samples, and how-to videos that cover Adobe developer products 

and technologies.

Resources for educators: www.adobe.com/education includes three free curricula 

that use an integrated approach to teaching Adobe software and can be used to 

prepare for the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Forums: http://forums.adobe.com lets you tap into peer-to-peer discussions, 

questions, and answers on Adobe products.

Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a central 

resource for finding tools, services, extensions, code samples, and more  to  supple-

ment and extend your Adobe products.

Adobe After Effects CS5 product home page: www.adobe.com/products/

aftereffects

Adobe Labs: http://labs.adobe.com gives you access to early builds of cutting-edge 

technology, as well as forums where you can interact with both the Adobe devel-

opment teams building that technology and other like-minded members of the 

community.

www.adobe.com/community/publishing/download.html
www.adobe.com/community/publishing/download.html
http://community.adobe.com/help/profile/faq.html
www.adobe.com/support/aftereffects
http://tv.adobe.com
www.adobe.com/designcenter
www.adobe.com/devnet
www.adobe.com/education
http://forums.adobe.com
www.adobe.com/cfusion/exchange
www.adobe.com/products/aftereffects
www.adobe.com/products/aftereffects
http://labs.adobe.com
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Adobe certification

The Adobe training and certification programs are designed to help Adobe custom-

ers improve and promote their product-proficiency skills. There are four levels of 

certification:

Adobe Certified Associate (ACA)

Adobe Certified Expert (ACE)

Adobe Certified Instructor (ACI)

Adobe Authorized Training Center (AATC)

The Adobe Certified Associate (ACA) credential certifies that individuals have the 

entry-level skills to plan, design, build, and maintain effective communications using 

different forms of digital media.

The Adobe Certified Expert program is a way for expert users to upgrade their 

credentials. You can use Adobe certification as a catalyst for getting a raise, finding 

a job, or promoting your expertise. 

If you are an ACE-level instructor, the Adobe Certified Instructor program 

takes your skills to the next level and gives you access to a wide range of Adobe 

resources.

Adobe Authorized Training Centers offer instructor-led courses and training 

on Adobe products, employing only Adobe Certified Instructors. A directory 

of AATCs is available at http://partners.adobe.com.

For information on the Adobe Certified programs, visit www.adobe.com/support/

certification/main.html.

http://partners.adobe.com
www.adobe.com/support/certification/main.html
www.adobe.com/support/certification/main.html
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Review Questions

1 Review uses Number List

Accelerate your workflow with 

Adobe CS Live

Adobe CS Live is a set of online services that harness the connectivity of the web and integrate with 
Adobe Creative Suite 5 to simplify the creative review process, speed up website compatibility testing, 
deliver important web user intelligence, and more, allowing you to focus on creating your most impactful 
work. CS Live services are complimentary for a limited time* and can be accessed online or from within 
Creative Suite 5 applications.

Adobe BrowserLab is for web designers and developers who need to preview and test their web pages 
on multiple browsers and operating systems. Unlike other browser-compatibility solutions, BrowserLab 

renders screenshots virtually on demand with multiple viewing and diagnostic tools, and can be used with 
Dreamweaver CS5 to preview local content and different states of interactive pages. Being an online ser-
vice, BrowserLab has fast development cycles, with greater flexibility for expanded browser support and 
updated functionality.

Adobe CS Review is for creative professionals who want a new level of efficiency in the creative review 
process. Unlike other services that offer online review of creative content, only CS Review lets you publish 

a review to the web directly from within InDesign, Photoshop, Photoshop Extended, and  Illustrator and view 
reviewer comments back in the originating Creative Suite application.

Acrobat.com is for creative professionals who need to work with a cast of colleagues and clients in order 
to get a creative project from creative brief to final product. Acrobat.com is a set of online services that 

includes web conferencing, online file-sharing and workspaces. Unlike collaborating via email and attend-
ing time-consuming in-person meetings, Acrobat.com brings people to your work instead of sending files to 
people, so you can get the business side of the creative process done faster, together, from any location.

Adobe Story is for creative professionals, producers, and writers working on or with scripts. Story is a 
collaborative script-development tool that turns scripts into metadata that can be used with the Adobe 

CS5 Production Premium tools to streamline workflows and create video assets.

SiteCatalyst NetAverages is for web and mobile professionals who want to optimize their projects for 
wider audiences. NetAverages provides intelligence on how users are accessing the web, which helps 

reduce guesswork early in the creative process. You can access aggregate user data such as browser type, 
operating system, mobile device profile, screen resolution, and more, which can be shown over time. The data is 
derived from visitor activity to participating Omniture SiteCatalyst customer sites. Unlike other web intelligence 
solutions, NetAverages innovatively displays data using Flash, creating an engaging experience that is robust 
yet easy to follow.

You can access CS Live three different ways:

1 Set up access when you register your Creative Suite 5 products, and get complimentary access that includes 
all of the features and workflow benefits of using CS Live with Creative Suite 5.

2 Set up access by signing up online, and get complimentary access to CS Live services for a limited time. 
Note that this option does not give you access to the services from within your products.

3 Desktop product trials include a 30-day trial of CS Live services.

*CS Live services are complimentary for a limited time. See www.adobe.com/go/cslive for details.

www.adobe.com/go/cslive
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4 WORKING WITH SHAPE LAYERS

Lesson overview

In this lesson, you’ll learn how to do the following:

Create custom shapes.

Customize a shape’s fill and stroke.

Use path operations to transform shapes.

Animate shapes.

Repeat shapes. 

Explore design options with the Brainstorm feature.

Add a Cartoon effect to a video layer for a distinctive look.

Use Adobe After Effects in a DVD interface workflow.

This lesson will take approximately an hour to complete. Copy the 

Lesson04 folder into the Lessons folder that you created on your hard 

drive for these projects (or create it now), if you haven’t already done 

so. As you work on this lesson, you’ll preserve the start files. If you need 

to restore the start files, copy them from the Adobe After Effects CS5 

Classroom in a Book DVD.
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Shape layers make it easy to create expressive 
backgrounds and intriguing results. You can animate 
shapes, apply animation presets, and add Repeaters 
to intensify their impact.
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Getting started

Shape layers are created automatically when you draw a shape with any of the 

drawing tools. You can customize and transform an individual shape or its entire 

layer to create interesting results. In this lesson, you will use shape layers to build a 

dynamic background for the introduction of a reality series called DJ Quad Master.

You’ll also use the Cartoon effect to change the overall look of the video. This effect 

performs best with video cards that support OpenGL. You may choose to skip the 

Cartoon effect exercise; if you do, you’ll be able to finish the project, but it won’t 

match the sample movie. 

First, you’ll preview the final movie and set up the project.

1 Make sure the following files are in the AECS5_CIB/Lessons/Lesson04 folder 

on your hard disk, or copy them from the Adobe After Effects CS5 Classroom 

in a Book DVD now:

In the Assets folder: DJ.mov, gc_adobe_dj.mp3

In the Sample_Movie folder: Lesson04.mov

2 Open and play the Lesson04.mov sample movie to see what you will create in 

this lesson. When you are done, quit QuickTime Player. You may delete this 

sample movie from your hard disk if you have limited storage space.

As you start After Effects, restore the default application settings. See “Restoring 

default preferences” on page 3. 

3 Press Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while 

starting After Effects. When asked whether you want to delete your preferences 

file, click OK.

4 Click Close to close the Welcome screen.

After Effects opens to display a blank, untitled project.

5 Choose File > Save As, and then navigate to the AECS5_CIB/Lessons/Lesson04/

Finished_Project folder.

6 Name the project Lesson04_Finished.aep, and then click Save.

Creating the composition

Next, you’ll import the files you need and create the composition.

1 Double-click an empty area of the Project panel to open the Import File 

dialog box.
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2 Navigate to the AECS5_CIB/Lessons/Lesson04/Assets folder on your hard disk, 

Shift-click to select the DJ.mov and gc_adobe_dj.mp3 files, and then click Open.

3 Choose File > New > New Folder 

to create a new folder in the 

Project panel.  

4 Name the folder Assets, press 

Enter or Return to accept the 

name, and then drag the footage 

items you imported into the 

Assets folder. 

5 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new 

composition.

6 In the Composition Settings dialog box, name the composition Shapes 

Background, select the NTSC DV preset, and set the Duration to 10:00. Then 

click OK.

After Effects opens the new composition in the Timeline and Composition panels.

� Tip: To specify 10 
seconds, type 10. in 
the Duration box. The 
period indicates that 
there are no units in 
that position. To specify 
10 minutes, type 10.. in 
the box.
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Adding a shape layer

One advantage of using a shape layer, rather than a solid layer, is that you can use 

the Fill option to create a linear or radial gradient. You’ll use the Rectangle tool to 

create a gradient background for the composition.

About shapes

After Effects includes five shape tools: Rectangle, Rounded Rectangle, Ellipse, 

Polygon, and Star. When you draw a shape directly in the Composition panel, After 

Effects adds a new shape layer to the composition. You can apply stroke and fill set-

tings to a shape, modify its path, and apply animation presets. Shape attributes are all 

represented in the Timeline panel, and you can animate each setting over time.

The same drawing tools can create both shapes and masks. Masks are applied to 

layers to hide or reveal areas of an image, while shapes have their own layers. When 

you select a drawing tool, you can specify whether the tool draws a shape or a mask.

Drawing a shape

You’ll begin by drawing the rectangle that will contain the gradient fill.

1 Select the Rectangle tool ( ).

2 Choose 50% from the Magnification Ratio pop-up menu at the bottom of the 

Composition panel so that you can see the entire composition.

3 Click just outside the upper-left corner of the composition, and drag the tool 

to the area just outside the bottom-right corner, so that a rectangle covers the 

entire composition. 
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The shape appears in the Composition panel, and After Effects adds a shape layer 

named Shape Layer 1 to the Timeline panel.

Applying a gradient fill

You can change the color of a shape by modifying its Fill settings in the Tools panel. 

Clicking the word Fill opens the Fill Options dialog box, where you can select the kind 

of fill, its blending mode, and its opacity. Clicking the Fill Color box opens the Adobe 

Color Picker if the fill is solid, or the Gradient Editor if the fill is a gradient.

1 Click the word Fill to open the Fill Options dialog box.

2 Select the Radial Gradient option ( ), and click OK.

3 Click the Fill Color box (next to the word Fill) to open the Gradient Editor. 

4 Select the white color stop (the left color stop below the gradient ramp), and 

select a light blue color. (We used R=100, G=185, B=240.)

5 Select the black color stop (the right color stop below the gradient ramp), and 

select a dark blue color. (We used R=10, G=25, B=150.)

6 Click OK to apply the new gradient colors.
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Modifying gradient settings

The gradient is a little small, and it falls off quickly. You’ll adjust the settings for the 

shape layer to expand the gradient.

1 In the Timeline panel, expand Shape Layer 1 > Contents > Rectangle 1 > 

Gradient Fill 1.

2 Change the Start Point to 0, 225, and the End Point to 0, 740.

Now the gradient originates at the bottom of the screen and falls off near the top 

and edges of the composition.

3 Hide the Shape Layer 1 properties.

4 Select the layer name (Shape Layer 1), press Enter or Return, and type 

Background. Press Enter or Return to accept the new layer name.

5 Click the Lock column ( ) for the Background layer so that 

you don’t accidentally select it.

Creating custom shapes

Though there are only five shape tools, you can modify the paths you draw to create 

a wide variety of shapes. The Polygon tool, in particular, gives you great flexibility. 

You’ll use it to create rotating sun shapes in the background.

Drawing a polygon

By default, the Polygon tool draws a shape using the settings of the last shape 

drawn with that tool. However, by adjusting the points, position, rotation, outer 

radius, outer roundness, and other values, you can dramatically alter the initial 

shape. You’ll modify a simple polygon to create a much more interesting shape.
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1 Select the Polygon tool ( ), which is hidden behind the Rectangle tool ( ).

2 Drag a polygon shape in the Composition area. 

3 In the Timeline panel, expand Shape Layer 1 > Polystar 1 > Polystar Path 1.

4 Change the Points to 6, the Rotation to 0 degrees, and the Outer Radius to 150.

5 Change the Outer Roundness to -500%.

6 Hide the Polystar Path 1 properties.

7 Click the word Fill in the Tools panel to open the Fill Options dialog box. Select 

the Solid Color icon ( ), and then click OK.

� Tip: While you’re 
dragging the shape, 
you can press the 
spacebar to reposition 
the shape in the 
Composition panel. 

� Tip: You can change 
settings to values below 
0 and above 100% for 
more dramatic results.
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8 Click the Fill Color box, and select a bright yellow. (We used R= 250, G=250, 

B=0.) Click OK.

9 Click the Stroke Color box, and select a bright gray. (We used R=230, G=230, 

B=230.) Click OK.

10  Change the Stroke Width in the Tools panel to 5 pixels to emphasize the stroke.

Twisting a shape

The Twist path operation rotates a path more sharply in the center than at the 

edges. Positive values twist clockwise; negative values twist counterclockwise. You’ll 

use the Twist path operation to give the shape a little more definition. 

1 In the Timeline panel, open the Add pop-up menu next to Contents in the 

Shape Layer 1 layer, and choose Twist.
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2 Expand Twist 1.

3 Change the Angle to 160.

4 Hide the Polystar 1 properties.

5 Choose File > Save to save your work so far.

Repeating a shape

You’ve created the basic shape that you want to use in the background, but you 

need many more copies of it to fill the composition. You could duplicate the shape 

manually, but instead, you’ll use the Repeater path operation to create multiple rows 

of suns.

1 Select Shape Layer 1. You’re selecting the layer because you want to add the 

Repeater to the entire shape group, not just an individual shape.

2 Open the Add pop-up menu, and then choose Repeater. 

3 Expand Repeater 1.

4 Change the number of copies to 5.

The Repeater creates four copies of the shape, overlapping each other. You’ll separate 

them next.

5 Expand Transform: Repeater 1. 

� Note: There are 
multiple Transform 
properties in the 
Timeline panel, 
applying to different 
path operators. Make 
sure you’re selecting the 
appropriate Transform 
property for the object 
or layer you want to 
affect. In this case, you 
want to affect only 
the Repeater.
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6 Change the Position to 345,0. The first value represents the x axis. To move the 

shapes closer together, use a smaller value for the x axis; to move them farther 

apart, use a larger value.

Now the shapes are farther apart. But you can’t see them all at the same time. To 

move all of the shapes, you need to move the entire shape layer.

7 Hide the Transform: Repeater 1 properties.

8 Select Shape Layer 1, and then press P to display the Position property for the 

layer. Change the Position to -50, 65.

The shape layer is now in the upper-left corner of the composition. You’ll scale the 

layer and then add more rows.

9 Select Shape Layer 1, and then press S to display the Scale property for the layer. 

Change the Scale to 50%.

10  Press S to hide the Scale property for the layer.

11  Expand Shape Layer 1 > Contents.

12  Select Shape Layer 1, and then choose Repeater from the Add pop-up menu.

� Note: Because the 
horizontal and vertical 
values are linked, both 
values change when 
you change one.
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13  Expand Repeater 2 > Transform: Repeater 2.

14  Change the Position to 0, 385 so that there is vertical space between the rows.

15  Hide the Repeater 2 properties.

Rotating shapes

The suns should rotate on the background. You’ll animate the Rotation prop-

erty for the original shape, and the changes will automatically apply to the 

duplicated shapes. 

1 In the Timeline panel, expand Shape Layer 1 > Contents > Polystar 1 > 

Transform: Polystar 1.

2 Press the Home key, or drag the current-time indicator to the beginning of 

the timeline.

3 Click the stopwatch ( ) next to the Rotation property to create an initial 

keyframe for the layer.

4 Press the End key, or drag the current-time indicator to the end of the timeline.

5 Change the Rotation to 3x+0 degrees. This setting causes the shape to rotate 

three times in 10 seconds.
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6 Hide the properties for Shape Layer 1.

7 Drag the current-time indicator across the timeline to preview the rotation.

Blending shapes with the background

The rotating suns look good, but they contrast with the background too much. 

You want the character in the main video file to be the focus of attention. You’ll 

change the blending mode and opacity for the shape layer to make the background 

more subtle.

1 Click Toggle Switches/Modes at the bottom of the Timeline panel.

2 Choose Overlay from the Mode pop-up menu for the Shape Layer 1 layer.

3 Select Shape Layer 1, and then press T to display the Opacity property for 

the layer.

4 Change the Opacity to 25%.

5 Press T to hide the Opacity property.

6 Select Shape Layer 1, press Enter or Return, and type Suns for the layer name. 

Press Enter or Return again to accept the new name.

7 Lock the layer to prevent accidental changes to it.

� Note: Instead of 
changing the opacity 
for the entire layer, 
you could change the 
opacity for the original 
shape. The value 
would apply to all the 
duplicates as well.
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Creating stars

The Star tool is similar to the Polygon tool. A polygon is simply a star without an 

Inner Radius or Inner Roundness property; both tools create shapes called poly-

stars. You’ll use the Star tool to draw a star for the background, and then use the 

Pucker & Bloat operation to change the star’s shape. Then you’ll duplicate the star 

and rotate the stars around the layer’s anchor point.

Drawing a star

The Star tool is grouped with the other shape tools. To draw a star, drag the Star 

tool in the Composition panel.

1 Select the Star tool ( ), which is hidden beneath the Polygon tool ( ).

2 Change the fill and stroke settings for the shape before you draw the star:

Click the Fill Color box, and select a medium blue. (We used R=75, G=120, 

B=200.) Then click OK.

Click the word Stroke, and click None ( ) in the Stroke Options dialog box. 

Click OK.

3 Draw a star near the center of the composition. After Effects adds a shape layer 

named Shape Layer 1 to the Timeline panel. 

4 In the Timeline panel, expand Shape Layer 1 >  Polystar 1 > Polystar Path 1.

5 Change the Points to 6 and the Rotation to 150 degrees.

6 Change the Inner Radius to 50 and the Outer Radius to 90. The radius values 

change the shape of the star.

7 Expand the Transform: Polystar 1 properties.

8 Change the Position to -180, -70.

9 Collapse the Polystar 1 properties to hide them.

� Note: If you have 
trouble seeing the 
star in front of the 
background, you can 
temporarily hide the 
Suns and Background 
layers by clicking the 
video switches (eye 
icons) for the layers in 
the Timeline panel. 



110 LESSON 4 Working with Shape Layers

Applying Pucker & Bloat

After Effects includes a powerful path operation called Pucker & Bloat. You can 

pucker a shape by pulling the path’s vertices outward while curving segments 

inward, or bloat a shape by pulling the vertices inward while curving segments 

outward. Negative values pucker a shape; positive values bloat it. You’ll pucker the 

star to give it a distinctive look.

1 Select Shape Layer 1.

2 Choose Pucker & Bloat from the Add pop-up menu. 

3 Expand Pucker & Bloat 1. 

4 Change the Amount to -125 to pucker the star.

This star shape will go well in the background. Now you can duplicate and 

animate it.

Duplicating shapes

You want to have multiple stars in slightly different sizes rotating around the 

screen. You’ll use the Repeater path operation again, but this time you’ll modify the 

Transform properties for the Repeater to get different results. 

1 Select Shape Layer 1, and choose Repeater from the Add pop-up menu.

2 Expand Repeater 1, and change the number of copies to 6.

Now there are six stars on the screen.
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3 Expand Transform: Repeater 1. 

4 Change the Position to 0, 0, and the Rotation to 230 degrees.

Because you applied the rotation to the Repeater, rather than the shape, each star 

rotated around the layer’s anchor point to a different degree. When you change 

the Transform properties for the Repeater, the change is multiplied by the number 

of copies created. For example, if there are 10 copies of a shape and you change 

the Rotation value to 10 degrees, the first shape retains the original value of 0, the 

second shape rotates 10 degrees, the third shape rotates 20 degrees, and so on. The 

same concept applies to each of the Transform properties.

In this project, the anchor point for the layer differs from the position of the 

shapes, so the chain of stars begins to wrap in on itself. 

5 Change the End Opacity to 65%. Each star is more transparent than the one 

before it.

6 Hide the Repeater 1 properties.

7 Select the Shape Layer 1 layer, and choose Repeater from the Add pop-up menu 

again to add another Repeater.

8 Expand Repeater 2 > Transform: Repeater 2.

9 Change the Position to -140, 0 and the Rotation to 40 degrees.

10  Change the Scale to 80%.

Each duplicate star will be smaller than the one before it. Because there are three 

duplicates of the first group of stars, some will be 64% the size of the original.
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11  Change the End Opacity to 0%.

12  Collapse the Repeater 2 properties to hide them.

13 Choose File > Save.

Rotating shapes

You’ve rotated the stars around the anchor point for the layer. Now you want to 

animate each star to rotate around its own axis. To achieve this, you’ll animate the 

Rotation property for the polystar shape itself, not the layer or the Repeater.

1 Expand Polystar 1 > Transform: Polystar 1. 

2 Press the Home key, or drag the current-time indicator to the beginning of the 

timeline.

3 Click the stopwatch icon ( ) for the Rotation property to create an initial 

keyframe.

4 Press the End key, or drag the current-time indicator to the end of the timeline.

5 Change the Rotation to 180 degrees.

6 Manually preview the composition by dragging the current-time indicator along 

the timeline. After you confirm that everything is rotating, collapse the layer.
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7 Rename the Shape Layer 1 layer Stars, and press Enter or Return to accept the 

layer name.

8 Lock the Stars layer.

Incorporating video and audio layers

The background is in place. Now you can add the video of the DJ and the audio 

track that accompanies it.

Adding audio and video files

You imported files at the beginning of the lesson. Now you’ll add them to the com-

position. The DJ.mov clip has no background and was rendered with a premultiplied 

alpha channel, so the underlying layers are visible. You’ll learn about keying footage 

in Lesson 9, “Using the Roto Brush Tool” 

1 Press Home, or drag the current-time indicator to the beginning of the 

composition.

2 Open the Assets folder in the Project panel.

3 Drag the DJ.mov footage item to the Timeline panel, placing it above the 

other layers.

4 Drag the gc_adobe_dj.mp3 item from the Project panel to the Timeline panel, 

placing it beneath the other layers.

5 Lock the audio layer that you just added to the Timeline panel so that you can’t 

accidentally select and move it later. Then choose File > Save.

Trimming the work area

The DJ.mov clip is only 5 seconds long, but the composition is 10 seconds. If you 

rendered this movie now, the DJ would disappear halfway through the movie. To fix 

the problem, you’ll move the work area end point to the 5-second mark. Then only 

the first 5 seconds will render.

� Note: You can place 
an audio layer any-
where in the layer stack, 
but moving it to the 
bottom keeps it out of 
the way while you work.
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1 Move the current-time indicator to the 5-second mark. You can drag the 

current-time indicator in the Timeline panel, or click the Current Time box and 

then type 500.

2 Press N to move the work area end point to the current time.

Applying a Cartoon effect

After Effects includes a Cartoon effect, which makes it easy to create a stylized look 

for your video. Since this intro for the DJ Quad Master reality series is very different 

from other reality series, the Cartoon effect will work perfectly here.

The Cartoon effect performs best on systems with video cards that support 

OpenGL. If you’re not using OpenGL, you can choose to skip this exercise and con-

tinue with “Adding a title bar.” 

1 Select the DJ.mov layer in the Timeline panel.

2 Choose Effect > Stylize > Cartoon.

The Cartoon effect performs three opera-

tions on a layer. First, it smooths the layer, 

removing a great deal of detail. Therefore, 

it works best on video footage rather than a 

graphic layer, such as the background in this 

project. Next, the Cartoon effect emphasizes 

the edges of shapes, based on their bright-

ness values. Finally, it simplifies the color in 

the layer. 

The default settings do a pretty good job, but you’ll fine-tune them in the Effect 

Controls panel. 

3 In the Effect Controls panel, choose Fill from the Render pop-up menu.

� Note: Alternatively, 
if you do not want 
to keep the last 
five seconds of the 
composition, you can 
change the duration 
of the composition to 
5 seconds. To do so, 
choose Composition > 
Composition Settings, 
and then type 5.00 in 
the Duration box.

� Tip: For interesting 
results, try changing the 
Cartoon Render options 
from Fill & Edges to Fill 
(for a color-only effect) 
or Edges (for black-and-
white line art).
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For this project, you’re selecting Fill only temporarily so that you can more easily see 

the results of the Fill settings as you make adjustments.

4 Change the Detail Radius amount to 20 and the Detail Threshold amount to 50.

These settings control how much detail is removed and how it is smoothed. Higher 

values remove more detail.

5 In the Fill area, change the Shading 

Steps value to 10, and make sure 

the Shading Smoothness value 

is 70.

These settings determine how color 

is reduced and how gradients are pre-

served. In this project, changing these 

values reduces the number of colors in 

the DJ’s shirt, creating a simpler design.

6 Choose Edges from the Render pop-up menu so you can focus on the edge 

controls. The layer becomes black and white temporarily.

7 In the Edge area, change the Threshold to 1.25 and the Width to 1.

These settings reduce the number of black lines on the subject.

8 Leave the Softness value at its current setting (60), but lower the Opacity to 60%

to make the lines more subtle.

9 Choose Fill & Edges from the Render pop-up menu to restore the color.

10 Expand Advanced to see the advanced controls, which give you precise control 

over the edges.
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11 Change the Edge Enhancement value to 50 to sharpen the edges of the layer.

12 Change the Edge Black Level to 2 to fill in more areas of the image with solid 

black. This makes the image even more cartoonish.

13 Lock the DJ.mov layer to ensure you don’t accidentally make changes to it as 

you continue the project.

Adding a title bar

You’ve created an exciting background and added the video of the DJ and the audio 

track. The only thing missing is the title to identify the program. You’ll use the 

Rectangle tool and path operations to create a dynamic shape, and then you’ll add 

the text.

Creating a self-animating shape

Wiggle Paths turns a standard rectangle into a series of jagged peaks and valleys. 

You’ll use it to create a shape that looks like a soundwave. Because the operation 

is self-animating, you only need to change a few properties for the entire shape to 

move on its own.

1 Select the Rectangle tool ( ), which is hidden under the Star tool ( ).

2 Click the Fill Color box, and select a light yellow. (We used R=255, G=255, 

B=130.) Click OK.

3 Click the word Stroke. In the Stroke Options dialog box, select Solid Color, and 

click OK.

4 Click the Stroke Color box, and select a light gray. (We used R=200, G=200, 

B=200.) Click OK.
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5 Change the Stroke Width to 10 pixels.

6 Draw a rectangle across the composition—near the bottom and approximately 

50 pixels high.

7 In the Timeline panel, expand Rectangle 1 > Rectangle Path 1. 

8 Unlink the Size values, and then change them to 680, 50.

9 Expand Stroke 1, and then change the Stroke Opacity to 30%.

10  Hide the Rectangle 1 properties.

11  Select Shape Layer 1, and choose Wiggle Paths from the Add pop-up menu.

12  Expand Wiggle Paths 1. Then change the Size to 150 and the Detail to 80.

13  Select Smooth from the Points menu to make the path less jagged.

14  Change Wiggles/Second to 5 to speed up the movement.

15  Move the current-time indicator across the timeline to see the shape move. It’s 

not exactly an audio waveform, but it’s a stylistic version of one.

16  Hide all the properties for the layer. 

17  Rename the layer Lower Third, and then lock the layer.

� Tip: If you need 
to reposition the 
rectangle, use the 
Selection tool to drag 
it into place in the 
Composition panel.
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Adding text

All you need to do now is add the title of the program. You’ll use an animation pre-

set to make the text stand out.

1 Press Home, or move the current-time indicator to the beginning of the 

composition.

2 Select the Horizontal Type tool ( ). In the Character panel, select a sans serif 

font, such as Arial Black, and specify a size of 60 pixels.

3 Click the Fill Color box in the Character panel, and select black (R=0, G=0, B=0).

Then click the Stroke Color box, and select white (R=255, G=255, B=255).

4 Change the Stroke Width to 2 pixels.

5 Click an insertion point in the Composition panel, and type DJ Quad Master.

6 Select the Selection tool ( ), and then reposition the text over the wave-

form shape.

7 Select the text in the Composition panel, and choose Animation > Browse 

Presets. Adobe Bridge opens, displaying the available animation presets.

8 Navigate to the Text/3D Text folder, and then double-click the 3D Rotate In By 

Character thumbnail. After Effects applies the preset to the selected text.
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9  Make a RAM preview to see your movie! Press the spacebar to stop the preview.

Using Brainstorm to experiment

The Brainstorm feature makes it easy to try different settings for effects, and to 

quickly apply the one you like. To use the Brainstorm feature, select the layer or 

properties you want to include, and then click the Brainstorm icon. The Brainstorm 

dialog box displays multiple variations of your image, based on randomized set-

tings. You can save one or more of the variants, apply one to a composition, or redo 

the Brainstorm operation.

The Brainstorm feature works especially well with animation presets. You’ll use it 

to explore possibilities for the Suns layer you created for this project.

1 Save the project, and then choose File > Save As. Name the new copy of the 

project Brainstorm, and save it in the Lesson04/Finished_Project folder.

2 Unlock the Suns layer in the Timeline panel.

3 Click the Solo switches ( ) for the Suns and Background layers, so that you see 

only these two layers in the Composition panel.

You can isolate one or more layers for animating, previewing, or rendering by soloing.

Soloing excludes all other layers of the same type from the Composition panel. 

4 Expand the Suns layer, and then select Contents. 

5 Click the Brainstorm icon ( ) at the top of the Timeline panel to open the 

Brainstorm dialog box.

� Note: With the 
Cartoon effect in place, 
the RAM preview 
may take longer than 
usual to render and 
begin playing.

� Note: Selecting 
Contents selects all the 
properties for the layer, 
so that the Brainstorm 
feature includes them 
all in the operation. 
You can also use the 
Brainstorm feature 
to experiment with 
one or more specific 
properties.
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6 Select the level of randomness Brainstorm should apply to the layer properties. 

The default value is 25%; for drastic changes, try 100%.

7 Click the Brainstorm button. The feature randomizes the properties and 

displays variants. You can click the Brainstorm button multiple times; each 

time, it randomizes the settings by the percentage you’ve selected.

8 When you find a variation you like, move the pointer over the variant, and then 

click the check mark icon to apply it to the composition. 

� Tip: To return to a 
previous variation, click 
the Back button. To see 
all the variants in action, 
click the Play button. 
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Building a DVD menu

You can use After Effects to create buttons for a DVD menu you’re designing 
in Adobe Encore®. When you select a group of layers to create an Encore button, 
After Effects precomposes the layers and names the precomposition according to 
the standards Encore uses for naming buttons. 

After Effects includes template projects with entire DVD menus that you can use 
as the basis of your own menus. To preview them in Adobe Bridge, choose File > 
Browse Template Projects in After Effects. 

To create a button, select the layers you want to include, and choose Layer > 
Adobe Encore > Create Button. Name the button to match its function, such 
as Play Movie or Scene Selection. Then use the menus to assign up to three 
highlight layers and one video thumbnail layer. 

To assign a layer to a subpicture, select the layer, and choose Layer > Adobe 
Encore > Assign To Subpicture.

To export the button, select the composition in the Project panel, and choose 
Composition > Save Frame As > Photoshop Layers.
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Review Questions

1 Review uses Number List

Review questions

1 What is a shape layer, and how do you create one? 

2 How can you quickly create multiple copies of a shape?

3 What is the advantage of using the Brainstorm feature?

4 What does the Pucker & Bloat path operation do?

5 How does the Cartoon effect work?

Review answers

1 A shape layer is simply a layer that contains a vector graphic called a shape. To create 

a shape layer, draw a shape directly in the Composition panel using any of the drawing 

tools or the Pen tool. 

2 To quickly duplicate a shape multiple times, apply a Repeater operation to the shape 

layer. The Repeater path operation creates copies of all paths, strokes, and fills included 

in the layer.

3 The Brainstorm feature creates variants of your composition based on randomized 

settings in the properties you selected. The feature makes it possible to explore 

numerous possibilities quickly and easily, and to save or apply them with a single click.

4 The Pucker & Bloat operation pulls the path’s vertices outward while curving segments 

inward (puckering), or pulls the vertices inward while curving segments outward 

(bloating). Negative values pucker a shape; positive values bloat it.

5 The Cartoon effect stylizes a layer by removing some details and emphasizing others, 

and by simplifying color. You can change settings in the Effect Controls panel to fine-

tune the effect’s behavior.
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base frames

adding with Roto Brush tool  235
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using to remap time  184, 350

Grid effect  272

grid layers for 3D objects  272

grids

displaying  51, 70

hiding  51, 71

snapping to  70

guide layers  274

H

HDR (high dynamic range) 

footage  347

hiding properties  23

Home key  29

Horizontal Type tool  29, 50, 83

I

IEEE 1394  254

importing

Adobe Photoshop files  77

files from Adobe Bridge  47

footage  14, 16, 45, 66

multilayer Photoshop files  14

SWF files  151

text  77–78
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Increase Tracking animation 

preset  83

In point  26, 130
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Interpret Footage dialog box  193

In value for a layer  145

inverting masks  196

iPod, rendering for  374

K

keyframes

about  31

copying from one layer to 

another  142

keyframing motion paths  136

keying  257–258

L

Layer Name  26

layers

3D  270

about  17, 19

adding light layers  304

adjusting timing  304

adjustment layers  266, 302

animating , 161, vi

audio  113

child  76, 77

copying keyframes from  142

deselecting  19

duplicating  20

expanding in the Timeline 

panel  24

fitting to compositions  49

guide layers  274

importing in Photoshop files  161

locking  275

making visible in the Timeline 

panel  33

modifying the In values for  145

naming in Photoshop  162

naming text layers  51

nesting  55

parent  76, 77

precomposing  55, 172, 244

rearranging in the Timeline 

panel  19

renaming  21, 79

scaling  216, 326

shape  96, 100

solid  143, 242, 280

soloing  165

text  68

transforming properties  24

trimming  130, 240

video  113

viewing in three dimensions  273

viewing multiple properties  224

layer styles  163

Layer switches in the Timeline 

panel  26

Lens Flare effect  178, 345

lesson files, copying from DVD  3

lighting, simulating changes in  164

light layers

adding ambient  307

animating  307

creating  304

in 3D compositions  304

point of interest  304

types of  304

locking layers  275

looping audio tracks  153

M

Magnification Ratio pop-up menu

100

mask layers  134

mask modes  196

mask properties, displaying  196

masks

about  192

creating Bezier  197, 199

creating with the Pen tool  195

curved  197

drawing with the Ellipse tool  207

drawing with the Rectangle 

tool  207

editing  196

inverting  196

modes for  196

modifying with the Convert 

Vertex tool  197

replacing content of  200

segments  192

tips for creating  208

using alpha mattes in  134

using vector shapes  132

vertices  192

working with , vii

mask shapes, copying  91

Master Exposure (Exposure effect)  23

Material Options properties  308

Matte Choker effect  258

mattes

about  230

about track mattes  173

about traveling mattes  173

creating a track matte  173

refining  237–238

meshes

adjusting the Triangle value  219

used with Puppet tools  218

Mini-Flowchart  28

mobile devices, preparing 

compositions for  374

mocha for After Effects  336

modes, mask  196

motion

animating  168

stabilizing  325

motion blur

adding  92, 139, 174

adding to 3D objects  312

applying  130

motion paths

about  137

animating nontext layers 

along  90

hiding  33

keyframing  136

viewing in the Composition 

panel  129

Motion Source  331

motion stabilization  320, 323

analyzing and applying  325

Motion Target  331

motion tracking  322

analyzing and applying  332, 336

drift  332

multipoint  333

single-point  328

N

navigating folders in Adobe 

Bridge  45

nesting

3D compositions  289

compositions  18

layers  55

nonsquare pixels  372

null objects

about  282

creating  282

O

opacity

animating  84, 150

modifying  25, 57

OpenGL  2, 35, 365

optimizing performance in After 

Effects  35

Orbit Camera tool  279
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Orient Along Path option  91

Orientation property in a 3D 

layer  294

Out point  26, 130

output module  361

options in the Render Queue 

panel  59

output-module templates

creating  361

saving  363

outputting projects  354

overlap, defining areas of  219

Overlap pins

about  217

customizing  220

overscan, accounting for  33

P

panel groups  13

panel menus  27

panels

docking  13

maximizing  14

rearranging in the application 

window  13

undocking  13

Paragraph panel  51, 69

opening  51

paragraph text  68

parallel corner-pinning  333

parenting  75, 127, 246

parent layers  127

about  76, 77

animating  128

creating  136

particle systems

creating  337, 339

customizing  340

path preset, using to animate text  81

Pen tool  195

performance, optimizing  35

perspective corner-pinning  333

Photo Filter effect  265

Photoshop layers

exporting a composition as  121

using in a DVD menu  121

pick whips, using to duplicate 

animation  166

Pipes animation preset  81

pixel aspect ratio  271

pixel aspect ratio correction  372

point of interest

about  304

setting for a camera layer  292

Point Of Interest property  292

point text  68

polygons, drawing  102

Polygon tool  102

Polystar properties  103, 107

positioning 3D layers  276–278

Position property

displaying in the Timeline 

panel  24

for a 3D layer  201

Pre-compose dialog box  56

precomposing layers  55, 56, 172, 244

preferences, restoring defaults  3, 12

preset paths, customizing  81

presets

browsing in Adobe Bridge  72

finding  22

previewing

audio files in Adobe Bridge  152

compositions  33, 58

images in Adobe Bridge  46

manual  55

RAM  34

spacebar  33

standard  33

using OpenGL  35

Preview panel in Adobe Bridge  46

Project panel  16

projects

After Effects  12

saving  16

properties

changing values for multiple 

layers  25

displaying in the Timeline 

panel  24

PSD files, importing as 3D layers  276

Pucker & Bloat  110

Puppet Overlap tool

about  217

using  219

Puppet Pin tool  217

Puppet Sketch tool

about  225

using  225

Puppet Starch tool

about  217

using  220

Puppet tools  212

about  217

customizing Overlap pins  220

preparing artwork for use 

with  217

Puppet Sketch tool  225

recording animation with  225

settings for Starch pins  220

using the mesh  218

Q

QuickTime  2

R

Radial Blur effect  21

Radial Gradient option  101

Radio Waves effect  145

Ramp effect  288, 344

RAM previews  34, 35

Rectangle tool  100, 207

Reduce Chatter setting  238

reflections, adding to 3D objects  300

remap-time marker in the Source 

Time ruler  183

removing unwanted elements

261–262

renaming layers  21

rendering

compositions  58, 181

for iPod  374

for mobile devices  374

movies  354

templates  357

test movies  366

using compression in  366

using multiple output 

modules  368

using the Render Queue 

panel  367

with OpenGL  365

Render Queue panel  59, 181

adding compositions to  59

opening  59

Render Settings options  59

render-settings template

creating  357, 359

saving  359

Repeaters  105, 110

replacing 3D layers  278

replacing content using a mask  200

resizing layers  216, 326

resources for learning After Effects

5–6

restoring default preferences  12

retiming

compositions  182

playback  347

rotating

3D layers  202

3D objects  294

shapes  107, 112

Rotation property, animating  107

Roto Brush Alpha views  233

Roto Brush effect  238
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Roto Brush span  234–235

Roto Brush tool  228–249

freezing the segmentation 

boundary  237

rotoscoping  230

Rounded Rectangle tool  240

Roving keyframes  225

S

SA Color Finesse 3  264

safe zones  33

saving projects  16

scale keyframes  74

scaling layers  216, 326

scrubbing to select values  22

segmentation boundaries

about  232

creating  232–237

editing  234–235

freezing  236–237

segments in a mask  192

selectors in text animator groups  86

serial number, After Effects  2

shape layers

about  96, 98

adding  100

applying gradient fills to  101

creating  134, 330

using animation presets with  134

shapes

about  100

applying Repeaters to  110

drawing  100, 102

duplicating  110

repeating  105

rotating  107, 112

twisting  104

using as masks  132

shortcuts for Transform 

properties  24

shortening a movie  113

Shutter Angle

about  175

adjusting  175

Shutter Phase  175

skewing text  87

slide shows  147

Snap to Grid command  70

solid layers  242

about  143

adding to a 3D object  280

creating  143

using to create particle 

systems  339

soloing layers  165

Source Name column  19, 26

Source Time ruler in time 

remapping  183

spacebar preview  33

spotlights

creating  304

positioning  305

square pixels  271

stabilizing motion  320

standard preview  33

Starch pins

about  217

adding  220

settings  220

stars

creating  109

modifying settings for  109

Star tool  109

Stroke Color  104

Stroke Options dialog box  109, 241

Stroke Width  104

SWF files

exporting  62, 370

importing  151

supported by Flash Player  61

SWF settings  62

T

templates

output module  361

rendering  357

text

adding  118

animating  77, 66–95, 80, 86,

245–246

animating tracking in  83

animating using a path preset  81

animation presets for  71

converting to editable  79

creating  50

editing  78

entering in the Composition 

panel  68

formatting  118

with the Character 

panel  69

with the Paragraph 

panel  69

imported from Photoshop  77

naming layers  51

point  68

positioning  70

skewing  87

text animator groups  85

text animation presets  29–30

text animator groups  85

text layers  68

time

current-time field  27

current-time indicator  27

measuring  222

specifying in the Duration box  99

timecode  30

Time Controls panel  34

Time graph  26

Timeline panel

about  26, 27

displaying properties in  24

displaying the Opacity property 

in  25

expanding layers in  24

renaming layers in  79

Toggle Switches/Modes 

button  243

TrkMat pop-up menu  243

viewing multiple layer properties 

in  224

Time Remap keyframes  184

Time Remapping  153, 182

Time-Reverse Keyframes 

command  73

time ruler

about  27

in the Timeline panel  27

Time Stretch dialog box  145

Timewarp effect  347

timing, adjusting  304

title-safe zones  33

Toggle Alpha Boundary button  234

Toggle Alpha button  234

Toggle Alpha Overlay button  234

Toggle Switches/Modes button

134, 243

Toggle Transparency Grid button

241

Tools panel

about  20

selecting hidden tools in  20

tracing an object  230–249

Tracker Controls panel  323

tracking, animating  83

tracking motion  322

multipoint  333

single-point  328

tracking presets

customizing  84

using to animate text  83
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tracking using Mocha for After 

Effects  336

Track Matte  242

track mattes

about  173

creating  172, 173

track points

about  322

moving and resizing  324

positioning  322, 330, 335

Track Z Camera tool  279

Transform properties  24

transition effects  309

transparency  57

traveling mattes  173

Triangle value for Puppet tools  219

trimming

layers  130, 240

the work area  113

TrkMat menu  134

TrkMat pop-up menu in the 

Timeline panel  243

twisting shapes  104

Twist path operation  104

U

undocking panels  13

updates for the After Effects CS5 

application  39

User Interface Colors  37

V

vertices

converting  197

in a mask  192

video layers  113

Video Preview  254

video switch  33

in the Timeline panel  57

viewing 3D layers  273

vignette, applying  206

W

walking cycle, animating  221

web, exporting compositions for  60

work area

brackets  27

trimming  113

workflow  12

workspaces

in Adobe Bridge  46

predefined  36

saving custom  37

X

x axis  22

XFL files, exporting  93, 151

Y

y axis  22

Z

z axis  270

Zoom-Bubble effect  30
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