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13  
Going Further

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Start and preview mobile designs in Device Central 

•	 Apply AIR event commands to slices and hotspots

•	 Create an AIR prototype for client review 

•	 Create skins for Flex components 

•	 Export a Fireworks design to Flash Catalyst

•	 Use round-trip editing between Dreamweaver and Fireworks

•	 Create graphics for fixed and fluid web-page containers

•	 Work with native Fireworks PNG files in Flash

This lesson will take about 90 minutes to complete. Copy the Lesson13 
folder into the Lessons folder that you created on your hard drive for 
these projects (or create it now, if you haven’t already done so). As you 
work on this lesson, you won’t always preserve the start files. If you 
need to restore the start files, copy them from the Adobe Fireworks CS5 
Classroom in a Book CD.
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Throughout the book you have learned how 
Fireworks can be an essential part of your design 
workfl ow. Vectors, bitmaps, prototyping, symbols, 
interactivity, animation…the list goes on. In this 
fi nal bonus lesson you will work with a few of the 
more complex capabilities of Fireworks, giving you a 
well-rounded perspective on this unique program.

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



S-40  Lesson 13  Going Further

Starting mobile projects
Mobile application development is a growing industry. As PDAs, netbooks, web 
tablets, and smart phones become increasingly common, it’s only natural that the 
users of these devices want to do more and more with them.

As you’ve seen in Lesson 12, you can begin a mobile project by selecting one of the 
mobile document templates. But you can also base your new mobile project on an 
existing device, or even a custom device, thanks to integration with Device Central.

Device Central integrates parts of the Creative Suite, including Fireworks, to offer 
an easier way to preview and test Flash Lite, bitmap, web, and video content for 
mobile devices. 

In this exercise you will work with both Fireworks and Device Central to take 
advantage of their integration.

Selecting a device profile
Fireworks can access Device Central directly from the File menu.

1	 Choose File > Device Central to open the software.

2	 When Device Central opens, click the Browse button. This action connects you 
with the latest device profiles list from adobe.com. 

3	 In the search field, type nokia and Device Central displays a list of all Nokia 
devices in its database. You can search by a wide variety of parameters; if you 
are more interested in all devices of a specific screen dimension, you can type 
in the dimensions and get a list of all brands and models that match those 
dimensions.

## Note:  Rather 
than adding all the 
device profiles when 
you install Device 
Central, the profiles 
are kept on a server 
hosted by Adobe. This 
ensures that Adobe 
can maintain a current 
list of devices. Device 
Central automatically 
checks for new profiles 
when you select Browse.
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4	 Select the nokia search term and replace it with 240x320.

5	 Scroll the list and select a phone. We chose the Nokia 6600 slide phone. 

6	 Double-click the listing to see a larger screenshot of the phone and more details 
on the device.

7	 Drag the phone photo over to the Test Devices panel. Device Central downloads 
the profile to your computer.
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8	 Click the Back arrow to return to your last search.

9	 Select another phone with the same screen dimensions. We chose the Motorola 
RAZR2 V9M.

10	 Drag the listing over to the Test Device panel.

11	 Select one or both of the phones in the panel and click the Create button.

12	 The New Document window displays, showing the selected phones. In the 
upper-left corner of this window is the Fireworks logo. You can change your 
design software choice by clicking on this logo and picking a different Adobe 
software package. But don’t you dare!

13	 Click the Create button near the bottom-right corner of the window. Fireworks 
appears and generates a new document based on the screen dimensions of your 
selected phone.

Previewing in Device Central
Once you’ve created a mobile application mockup, you can preview it in Device 
Central to see how the graphics look on the device’s screen. You will try this out 
using a document template.

## Note:  You can add 
devices of different 
dimensions to your Test 
Devices panel, but you 
can create only one 
new document layout 
at a time.

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



Adobe f ireworks cs5 Cla ssroom in a B  ook  S-43

1	 Choose File > New from Template.

2	 Open the Mobile folder, choose Navigator.png, and open the file.

3	 When the file is open in Fireworks, choose File > Preview In Device Central.

The current page is displayed in Device Central. The phones that you selected in 
the previous exercise should still be in the Test Devices panel.

4	 Choose Emulate Image.

5	 In the Test Devices panel, double-click on the phone you want to use. The current 
page from the Fireworks document appears on the device screen.

6	 If it isn’t already visible, open the Display panel. You can use the controls in this 
panel to emulate different environmental conditions, such as how the screen 
looks when indoors or outdoors in sunshine. You can also alter the backlighting. 

If you want to see a different page in the mockup, choose File > Return to 
Fireworks, select a new page in the design, and choose File > Preview in Device 
Central again.
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Working with Adobe AIR
AIR (Adobe Integrated Runtime) is a cross-platform runtime environment for 
building rich Internet applications using Adobe Flash, Adobe Flex, HTML, or Ajax. 
Unlike traditional web applications, the AIR application runs on your desktop with-
out a web browser, often as a floating panel. Some examples of AIR applications  
are Adobe’s Kuler desktop (www.adobe.com/products/kuler/) and TweetDeck  
(www.tweetdeck.com/desktop/), for Twitter.

With its combination of HTML and JavaScript support, Fireworks has everything 
you need to create a realistic interactive AIR prototype. The console mockup you 
will soon be working with contains all the necessary elements to give the client the 
appearance of a functional AIR application. The artwork is mostly complete, and 
you will be adding AIR interactivity to the file as well as making some adjustments 
to the imagery. 

AIR functionality in Fireworks
An AIR prototype is akin to an HTML And Images export for a website. You will get 
the look and feel and the interactivity of the application, but there is no live data 
connection to other content—it’s not a fully functional AIR application. Likewise, 
features such as scrolling in a text window are not possible. However, rollovers, 
hyperlinks, and dragging are all possible.

Fireworks gives the client an opportunity to “test-drive” the design and functionality 
of an AIR application before any time is spent on the coding side.

Most of the techniques used in creating an HTML mockup can be applied to creat-
ing an AIR prototype. 

Reviewing interaction
You’ll preview a simulation of a console designed to allow visitors to browse camp-
sites. You’ll test the console’s interactive features as well.

1	 Open the file nature_tours_console.fw.png from the Lesson13 folder. If you are 
prompted about missing fonts, you can simply click Maintain Appearance.

This console allows users to browse various campsites affiliated with the 
fictitious Nature Tours Company, and to check rates and availability of sites. 
Standard web interactivity has been used to create this simulation, even though 
the end result will not be a website.

## Note:  To learn 
more about AIR, visit 
www.adobe.com/
products/air.

## Note:  Fireworks CS5 
exports AIR prototypes 
using the AIR 2.0 spe- 
cification. Before you 
begin this lesson, make 
sure you have AIR 2.0  
installed on your system 
so that you can install 
your prototype when 
it is completed. At the 
time of this writing,  
AIR 2 is in public beta, 
so you may have to  
visit Adobe Labs  
(http://labs.adobe.com/
technologies/air2/) to 
download version 2.
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2	 Expand the Pages panel so you can see the entire list of pages in the document 
(a total of ten). 

## Note:  The decorative 
font used in this design 
is called JI Chaffs. To 
minimize rendering 
issues, this font has 
been converted to 
paths. The only other 
font used in this file is 
Arial and that has been 
left as a true font, rather 
than being converted 
to paths.
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3	 Select the sites page. 

4	 Click Show Slices And Hotspots in the Tools panel.

A little squirrel mascot displays the current location. There are buttons to close 
the application and to return to the main console display.

Note the hotspots over the site names and the slices over the tree icons and the 
console screen.

5	 Switch to the Preview view at the top of the document window. 

6	 Click Hide Slices And Hotspots in the Tools panel.

## Note:  While the 
company may be 
fictitious, the photos 
are the work of the 
completely real Jim 
Babbage, of an equally 
real location called 
Obatanga Provincial 
Park in northern 
Ontario, Canada.
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7	 Roll over the Site B link in the right column. Effects have been added so that the 
screen updates with a different photo when you hover your mouse over the link, 
and the small tree icon also changes in appearance. The hotspots also link to 
other pages in the design.

8	 Select the Site A page in the Pages panel.

Our squirrel acts as a way-finding device, displaying the current location. The 
only rollover effects on this page are for the navigation.

## Note:  In order for 
the interaction to work, 
you must select the 
Pointer tool in the Tools 
panel.
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9	 Switch to the maps page in the Pages panel.

10	 Mouse over the different map links. The appropriate map thumbnail highlights 
in response to your rollover.

11	Select the map_A page from the Pages panel. Only one final site map has been 
completed, but this is enough to show the client how that aspect of the console 
will function.
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Although Fireworks cannot create a user-scrollable area, it can simulate zooming 
in and out of an area.

12	 Click the plus sign (+) on the map zoom bar. A new state appears, with a 
magnified view of the map. 

13	 Click the minus sign (–). A reduced view of the site appears.
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14	 Click the green dot to return to the original map-A page.

15	 Switch back to the Original view in the document window.

Adding Air events
Fireworks supports four AIR mouse events: Close, Drag, Minimize, and Maximize. 
Just like rollovers or links, AIR events must be attached to a web object (a slice or 
a hotspot). If the area being used as an AIR event doesn’t require a rollover, you 
can use a hotspot. If you do need a rollover eff ect (as is the case with our Close 
button), you’ve got to use a slice to enable image swapping. You will add hotspots 
and mouse events to various parts of the console so users can drag the prototype 
around on their desktop. You will also add a mouse event to the Close button. 

You will now add an AIR mouse event to the Close button.

1	 Choose the home page from the Pages panel.

2	 Click Show Slices And Hotspots in the Tools panel if the slices and hotspots are 
not visible.

3	 Select the slice that covers the Close button (the pictogram of the hikers).

4	 Choose Commands > AIR Mouse Events > Close.
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Nothing changes in the slice, but if you look down to the Properties panel, you 
will see that some JavaScript has been added, along with some alt text.

This AIR event has already been added to the other pages, using a shared  
Web layer.

5	 Switch to the sites page, and select the slice over the Close button. The 
Properties panel displays the same JavaScript code and alt text.

6	 Expand the Web layer in the Layers panel.

7	 Expand the common web sublayer. It stores the slices for both the close and 
home slices.

The common sublayer was not shared to the home page because there was no 
need to have a home link on that page.
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8	 Select the main Web layer in the Layers panel again.

9	 Choose New Sub Layer from the Layers panel menu.

10	 Name this new Web layer drag events. Note that even web sublayers are shared 
across states.

11	 Right-click (Windows) or Control-click (Mac) on the squirrel illustration, and 
choose Insert Hotspot.
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12	 Use the Pointer tool to resize the hotspot so it doesn’t overlap the Close button.

13	 Check the Layers panel. The new hotspot might not be nested in the drag 
events sublayer. If the hotspot is not in the sublayer, move it there now by cut-
ting and pasting the hotspot or by dragging the layer to the correct position in 
the Layers panel.

      

14	 Make sure the new hotspot is selected. This will force additional hotspots 
to be created above the current one, but they will still be nested in the drag 
events sublayer.

Inside the drag events layerNot inside the drag events layer
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15	 On the canvas, draw a rectangular hotspot around the Camp Sites sign, without 
overlapping the squirrel.

16	 Draw one more hotspot, covering the entire console from the left corner to just 
before the tree rollover slices.

17	 Select all three hotspots, and then choose Commands > AIR Mouse Events > Drag.

18	 Right-click (or Control-click) on the drag events sublayer, and choose Share 
Layer To All Pages, as we want this shared with every page in our mockup.

19	 Save the file.
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Air mouse events
You can attach specifi c mouse events to hotspots or slices in your AIR mockup. 
Select the web element (slice or hotspot), and then choose Commands > AIR Mouse 
Events. You can choose from four options:

• Close. Closes the application.

• Drag. Applied to a web object, this option lets the user drag the application 
around the desktop. 

• maximize. Maximizes the application.

• minimize. Minimizes the application.

Creating an Air prototype
Yes, you are fi nally at the point where you create the prototype! Much like an 
HTML prototype, this gives you and the client a chance to interact with a simula-
tion of the AIR application before any time is spent coding the real thing.

First you should save this fi le to its own directory. Th is makes the rest of the pro-
cess a little easier.

1	 Choose File > Save As.

2	 Create a new folder inside the Lesson13 folder, and call it 
nature_tours_console.

3	 Open this folder, if necessary, and save the PNG.
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4	 Copy the Lesson13/icons folder to the nature_tours_console folder.

5	 Select the home page in the Pages panel.

6	 Choose Commands > Create AIR File.

Th e Create AIR File dialog box appears, and it’s a big one. In this fi gure, we’ve 
fi lled in the fi elds—refer to this fi gure to complete the Create AIR Package 
dialog box:
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•	 Name. Specify the name that appears on installation screens when users 
install the application. By default, the filename is used, but you can  
change this.

•	 ID (required). Enter a unique ID for your application. Don’t use spaces or 
special characters in the ID. By default, the filename is used.

•	 Version (required). Specify a version number for your application. The 
default value is 1.

•	 Program Menu Folder (affects Windows only). Specify the folder in 
the Windows Start menu where you want the shortcut to the application 
created. 

•	 Description. A description of the application to be displayed when the user 
installs the application. The description we used is Nature Tours presents an 
interactive console where you can view our preferred camp sites, check out 
rates, and even inquire about site availability. 

•	 Copyright (affects Mac only). Include copyright information to be displayed 
in the About information for Adobe AIR applications installed on OS X. 

•	 Window Style. System Chrome surrounds the prototype with the standard 
window control of the operating system. Transparent lets you use your own 
custom chrome instead. Choose Transparent.

•	 Window Size. Specify the dimensions of your application window in pixels 
when it opens. Depending on your page sizes, outer glows, and drop shadows, 
you may need to increase the dimensions slightly to prevent scroll bars from 
appearing. Set the dimensions to 547 and 346, respectively.

Transparent chrome in AIR prototypes
One of the unique characteristics of an AIR application is that it can “float” on your 
desktop. So you could have a custom shape to the application interface—much like 
we have in our nature tours console—and you will see only the application, not the 
background of the original PNG file, surrounding the design. 

To use this look, make sure your canvas color for each page is set to transparent and 
that you use PNG 32 as your Optimization setting. The pages in this file have already 
been set to PNG 32.
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•	 Icon. You can select custom images for the application icons. Select the 
folder for each icon size, and select the image file you want to use. Only PNG 
files are supported for application icon images.

	 Click the button and for each of the four icons, browse to the icon folder you 
copied over to the nature_tours_console folder. Match the 16x16-pixel icon 
with the small.png file, the 32x32-pixel icon with the medium.png file, and 
so on. These icon files must be in the root directory in order to be selected.

•	 Content. Select the Use Current Document option to automatically select 
the folder from which the files are to be included. The resulting list will be 
simpler if your PNG file is in its own folder rather than, for example, your 
desktop or main documents folder. This is why you saved the PNG file to its 
own folder earlier. 

•	 Initial Content. Browse to select the page that appears as the starting 
screen of the prototype. If you selected Current Document, the initial con-
tent is automatically set. 

•	 Included Files. Specify the files or folders to include in your application. 
You can add additional HTML and CSS files, image files, and JavaScript 
library files. Click the plus button (+) to add files, and click Folder to add 

## Note:  Fireworks 
generates all the 
graphics needed for the 
prototype at this stage, 
so it’s not unusual for 
Fireworks to become 
nonresponsive for a 
couple of minutes as 
it runs through all the 
pages in the design.
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folders. To delete a file or folder from your list, select the file or folder, and 
click the minus button (–). The files or folders you include in the Adobe AIR 
package must be in the root content folder. Scroll through this list and locate 
the original PNG file. Select it, and then click the minus button. The PNG 
file is not necessary for the AIR application, and this will reduce the file size 
of the AIR file.

•	 Digital Signature (required). All Adobe AIR applications require a digital 
signature in order to be installed.

	 To add a digital signature, click the Set button next to the Digital Signature 
field, and do one of the following:

	 To sign an application with a digital certificate that you have already 
purchased, click the Browse button, select the certificate, enter the corre-
sponding password, and click OK.

	 To create your own self-signed digital certificate, click the Create button. 
This is the method you will use for this exercise, so click Create.

	 You must fill in every field in order for the Create button to become active. 
You can use the settings in the following figure as a guide.

## Note:  The Key Type 
option refers to the 
level of security of the 
certificate: 1024-RSA 
uses a 1024-bit key (less 
secure) and 2048-RSA 
uses a 2048-bit key 
(more secure).
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	 When you’re finished, click Create. Then enter the corresponding password 
in the Password field of the Digital Signature dialog box, and click OK.

•	 Destination (required). Specify the folder to save the new application 
installer (AIR file). The default location is the initial content folder. Click the 
Browse button to select a different location. 

	 Create a new folder called AIR in the nature_tours_console folder, and select 
this new AIR folder as the location to place the installer package.

The only file required by the user is the AIR installation file. All the neces-
sary files are added to the AIR installer by Fireworks.

7	 Before you click the create button, test the prototype by clicking Preview.

Fireworks builds a temporary version of the prototype and launches it. You can 
test interaction and check for unsightly scroll bars at this time. Click the proto-
type’s Close button (the hiker pictogram) to exit the application.

8	 Click Create AIR file.
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Installing the prototype
You will test the installation of the AIR prototype now. To do this, you may have 
to have administrator rights on your computer, because this is like installing a real 
software application.

1	 Browse to the AIR folder, and double-click on the nature_tours_console.air file 
to launch the installer.

An AIR Application Install window will open.

You may be asked whether you want to install this program, because it is created 
by an unknown publisher. 
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2	 We’ll assume you trust yourself. Click Install.

The window contents will change, displaying the description you wrote earlier. 
You can choose to add a shortcut icon to the desktop, specify whether you want 
to start the application after installation, and indicate where you want to install 
the application. 

3	 Change the installation location to the Lesson13 folder, so it is easy for you to 
find and remove the application afterward.

The application will take a minute or two to install.
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Once installed, the application will start. If you accepted the defaults, you will 
also see a shortcut icon on the desktop. The smallest icon will also display in the 
application bar.

4	 You can experiment with the prototype or just close it by clicking the 
Close button.

Extra Credit
For extra credit, you can make some additional changes to the Fireworks document.

Creative and corrective techniques
You will use a couple of techniques to alter the look of both bitmap images and 
vectors: image correction and stroking text. The majority of the work has been 
completed on this file, but there are still chances for you to practice the techniques.

Applying blending modes for image correction
There are many ways to improve the look of bitmap images. Sometimes, though, as 
here, a quick fix is all you need. 

1	 Switch to the Site C page.

The photo in the console screen lacks color and contrast, due to the sun shining 
on the lens. You will use blending modes and Live Filters to improve the image.
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2	 In the Layers panel, expand the screen layer. You see a masked photo.

3	 Select the photo thumbnail in the screen layer. On the canvas, you will see 
the telltale blue control handle on the image, indicating this photo has been 
masked. The blue outline indicates the true size of the photo.

4	 Choose Modify > Ungroup. 
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This breaks the mask apart into its two original objects.

5	 Hide the rounded rectangle by clicking the Show/Hide icon (   ) in the 
Layers panel.

6	 Drag the photo to the New Bitmap Image button at the bottom of the Layers 
panel, or press Ctrl+Shift+D (Windows) or Command+Shift+D (Mac).
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A duplicate of the photo appears in the screen layer.

7	 Making sure the topmost of these two images is selected, change the blending 
mode from Normal to Soft Burn in the Layers panel.
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The image darkens noticeably, but not so much that a lot of detail is lost. 

Before Soft Burn                                        After Soft Burn

8	 Click the Add Live Filters (+) button in the Filters section of the Properties 
panel, and choose Adjust Color > Hue/Saturation.

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



S-68  Lesson 13  Going Further

9	 Set the Saturation to a value of 30, and click OK.

The new image appears much more lush and green. And because the manipula-
tion was all done using Live Filters and blending modes, the effects are completely 
editable in the future.

Original image                                          �Image with Soft Burn blending mode and  
Hue/Saturation Live Filter applied

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



Adobe f ireworks cs5 Cla ssroom in a B  ook  S-69

In this case, though, you also need to mask the image combination, which 
means you’ve got a decision to make. You can’t apply a single mask to a stack 
of objects in the Layers panel. Grouping the two images together would let you 
mask the group, but would remove the blending mode once the mask is applied. 
If you convert the objects to a symbol, the blending mode is also removed. 
Flattening the two images together (to maintain the appearance of the effects) 
would rasterize them, so they will no longer be editable.

The solution is to create a duplicate set, then hide and lock one set and flatten 
the other for masking. Doing so means you can always go back to the images 
and make changes.

10	 Select both image objects in the Layers panel.

11	 Press Ctrl+Shift+D (Windows) or Command+Shift+D (Mac) to create backup 
copies.

12	 Press Ctrl+G or Command+G to group the duplicates.

13	 In the Layers panel, rename this group to enhanced group.

14	 In the Layers panel, hide and lock the group.

15	 Hold the Ctrl key (Windows) or the Command key (Mac) to select the remain-
ing two images.
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16	 Select Modify > Flatten Selection to merge the two images. The effects are now 
a permanent part of the new image.

17	 Rename the new flattened image enhanced flattened.

18	 Reveal the rounded rectangle path in the Layers panel by clicking the empty 
square to the far left of the object name. This will also select the object.

19	 Choose Edit > Cut.

20	 Choose the enhanced flattened object, and then select Edit > Paste As Mask.
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If you need to edit the effects later, you can unlock and ungroup the duplicate, 
make your changes, and then walk through the same steps to put the new ver-
sion in place.

21	 Save your file.

Stroking rendered text
At the beginning of the lesson, we mentioned that all the decorative text was con-
verted to paths to minimize any rendering issues. But this technique can be used 
on paths or text.

The text in this example is a little rustic, and is in keeping with the color theme of 
the site—but without a stroke, it blends into the background elements too easily. 
While all the other text is fine, the Site C text on the squirrel’s sign has not yet been 
changed. You will do this now.

1	 Use the Pointer tool to select the Site C rendered text.
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2	 In the Properties panel, change the Stroke color to #F3E8C9.

How do you convert text to 
a path, anyway?
Select the text block with the Pointer tool, and then choose Text > Convert To Paths 
from the main menu bar. The text is converted to a grouped set of paths. You can 
select individual letters with the Subselection tool.

3	 Set Stroke Category to Pencil > 1-Pixel Soft.
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You may find that the stroke does not match the other text elements on  
the console. 

This mismatch is due to the default stroke position of Stroke Centered. If this 
has happened to your object, follow these steps to fix it.

4	 Zoom in to 500%.

5	 Select the Subselection tool.

6	 Hold down the Shift key, and click on each letter (remember, the letters are no 
longer a true font but rendered paths).

7	 In the Properties panel, change Stroke Location to Align Stroke To Outside.
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Your Site C text should now match the text on the console.

8	 Save your work.

Stroking real text
The workfl ow for adding strokes to true text is a little diff erent.

1  Select the Text block with the Pointer tool.

2  Choose the Stroke (or Text Outline) color box.

3  Choose Stroke Options.

4  Select the type of stroke you want (in our example, it was 
Pencil > 1-Pixel Soft). You can choose a stroke color at the 
same time by clicking on the color fi ll box in the Stroke 
Options dialog box.

5  Press Enter or Return.
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Adding a Flex skin
Flex is a free, open source framework for building web applications that behave 
consistently across different browsers, desktops, and operating systems using 
Adobe Flash Player or Adobe AIR.

Before you say goodbye to the nature tours console file, you will convert the graphics 
into a form that a Flex application developer can use. Fireworks has a default Flex 
skin from which you can modify either a single component or multiple ones. 

1	 Select the home page of the design.

2	 Choose Commands > Flex Skinning > New Flex Skin.

3	 In the New Flex Skin dialog box, choose Specific Components.

4	 Select Button from the list of components.

## Note:  In a real-
life scenario, we 
recommend you 
talk with your Flex 
developer first, to make 
sure you are both using 
the same style-naming 
conventions.
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5	 For Apply Skin To, choose Instances With Style Name, and type close in the 
input field. (There are other buttons in this prototype, so it’s a good idea to use 
style names so the right skin is applied to the right button.) 

6	 Click OK.

A standard Flex button template opens as a new document within Fireworks.

7	 Switch back to the home page of the console design, and click Hide Slices And 
Hotspots in the Tools panel if the web objects are showing.

8	 Click the Close button (the hiker icon).

9	 Choose Edit > Copy.

## Note:  The Layers 
panel is populated 
with a series of prebuilt 
layers. When skinning 
a Flex component, it is 
important that you do 
not delete or rename 
any of the layers in  
the file.
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10	 Switch back to the skin template, and expand the Button_close_upSkin layer.

11	 Select the group in that layer, and delete it.

12	 Choose Edit > Paste to paste the Up state of the Close button in the layer.

13	 Reposition the button where you see fit.

14	 Return to the console design, and select State 2 from the bottom of the 
Layers panel.
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15	 Select the Over iteration of the Close button, and copy it.

16	 Switch back to the Flex template.

17	 Expand the Button_close_overSkin layer, and delete the group of objects making 
up the existing button.

18	 Paste the copied Over console button.

19	 Reposition as necessary. Don’t worry about lining up the buttons with the labels; 
those labels are simply there to tell you what button is for which state.

Adding additional button states
The current button in Fireworks contains only two states, but you will quickly add 
the two final states to the template.

1	 Expand the Button_close_downSkin layer, and delete the original button’s group.

2	 Paste the Over iteration of the console button.
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3	 In the Property inspector, click the i icon next to the Photoshop Live Effects filter.

4	 Change the direction of the bevel from Down to Up, and click OK.

5	 Delete the button from the Button_close_disabled layer, and paste in the Up 
state of your button again. You can copy the Up state from the Flex skinning 
template you’re working on instead of going back to the console.

6	 Change the Fill color to #71400F.

7	 Reduce the plaster texture to 20%.

8	 Turn off the Photoshop Live Effect by clicking the check mark beside the filter 
name. We have highlighted the three areas to change in the following figure.
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9	 Your new button template should look something like this image. Again, place-
ment of the button states on the canvas doesn’t matter, as long as they’re in the 
correct layers.

Exporting the skin
The last step is to export the button template.

1	 Choose Commands > Flex Skinning > Export Flex Skin.

2	 Browse to the Lesson13 folder, and create a new folder called skins. 
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3	 Open this folder, if necessary, and click the Select “skins” (Windows) or Choose 
(Mac) button.

Fireworks exports out just the four states of the button to this folder.

Flex skinning resources
In-depth discussion about Flex or skinning entire applications is beyond the scope of this book, but we won’t 
leave you hanging! Here are a few resources that you can continue with, if you are interested in learning more 
about Flex skinning.

•	 Adobe Flex Developer Center (www.adobe.com/devnet/flex/)

•	 Adobe Fireworks Developer Center (www.adobe.com/devnet/fireworks/articles/flex_app_design_04.html)

•	 Layers Magazine (www.layersmagazine.com/fireworks-cs4-flex-skinning.html)

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



S-82  Lesson 13  Going Further

Exporting to Flash Catalyst
Adobe® Flash® Catalyst™ is a new professional interaction design tool for rapidly 
creating interactive content without writing code. You can create interactive 
portfolios, product guides, site navigation, interfaces for rich Internet applications 
(RIAs), and more.

You can convert static artwork created in Adobe Fireworks into interactive designs, 
and then publish a finished project as a SWF file ready for distribution.

Flash Catalyst lets you work efficiently with developers who use Adobe Flash 
Builder™ 4 to create RIAs. Designers use Flash Catalyst to create the functional user 
experience and then hand off the project file to developers who use Flash Builder to 
add functionality and integration with servers and services.

Fireworks and Flash Catalyst

Fireworks is optimized to create screen graphics. As such, it’s the ideal application for  
creation of Flash Platform assets. Fireworks CS5 supports the latest FXG format (2.0). 
You can use Fireworks to design assets (individual graphics or multipage design 
mockups) for the Flash platform, export them as FXG, then move them into Flash 
tools like Flash Catalyst, all the while maintaining your design fidelity.

What is FXG? 
FXG 2.0 is an XML-based graphics interchange file format for the Flash platform. FXG 
contains high-level graphical and text primitives that can be used to create, group, 
transform, and visually modify basic vector and bitmap shapes. The FXG render-
ing model follows very closely the Flash Player 10 rendering model and exposes all 
graphics capabilities of the Flash platform, as well as offering expandable support to 
accommodate future capabilities of the Flash Player.  

For more information about FXG, visit http://opensource.adobe.com/wiki/display/
flexsdk/FXG+2.0+Specification.

Exporting pages 
Fireworks pages translate directly to Flash Catalyst pages. As a designer, you  
can build your mockup for a rich media application within Fireworks, and then 
export the file as an FXG document to open in Flash Catalyst or pass it on to  
the developer. 
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You will export a web banner from Fireworks as an FXG document.

1	 Open the fc_banner.fw.png. You might find this file a bit familiar; you helped to 
build the wireframe for this project in Lesson 10.

2	 Open the Pages panel and click on the individual pages. Each one has some dif-
ferent elements while common elements have been added to the master page.

3	 Select the Shop in Meridien page and then open the Layers panel.
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4	 Expand the content layer. Th ere are two sublayers: next feature and teaser.

5	 Choose File > Export.

6	 Name the fi le fc_banner.

7	 Choose the FXG folder in the Lesson13 folder as the location for saving the 
fi le and associated assets.

8	 Make sure that FXG And Images is selected from the Export drop-down list.

9	 Select All Pages from the Pages drop-down list.

10	 Click the Export button.

Th e fi le exports to the chosen folder.

##  Note:  When 
exporting a fi le as FXG 
And Images, you can 
choose to export the 
current selection, the 
current page, or all 
pages in the fi le.
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Viewing files in Flash Catalyst
Next you will check out the fidelity between the Fireworks document and the FXG 
export by opening the exported file in Flash Catalyst.

1	 Launch Flash Catalyst.

2	 When the Flash Catalyst welcome screen appears, choose From FXG File, or 
select File > New Project From Design File.

3	 Browse for the fc_banner.fxg file.

4	 Open the file. The entire design opens, looking identical to the original Fireworks 
document. Each page has been exported as a Flash Catalyst Page/State. 

Editing the FXG file in Flash Catalyst

Next you will make some changes to the file in Flash Catalyst.

1	 Select the page called page_2__Bike_in_Meridien.

2	 Double-click on the paragraph of text below the photo. Flash Catalyst switches 
to text-editing mode so you can make changes, adding or removing the existing 
characters.

## Note:  This exercise 
requires Flash Catalyst. 
If you do not own 
Flash Catalyst, you may 
skip this section, or 
download the 30-day, 
fully functional trial 
version of Flash Catalyst 
from Adobe at www.
adobe.com/downloads.

## Note:  Depending 
on the complexity 
of your design, Flash 
Catalyst may take 
noticeable time to 
analyze the file and 
object structure.
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Fireworks Effects supported  
by FXG 2.0
FXG 2.0 also supports many of Fireworks native effects and filters, retaining their 
editability, including:

•	 Opacity

•	 Solid color fill

•	 Canvas color: Mapped into Flash Catalyst as a Rectangle that has the same color 
and is the size of the project; it is placed on the locked Background layer 

•	 Gradients fills: Linear and Radial

•	 Blending Modes: Normal, Multiply, Screen, Lighten, Darken, Difference, Add, 
Subtract, Invert, Alpha, Erase, Overlay, Hardlight, Color Dodge, Exclusion, Hue, 
Saturation, Color, Luminosity, Color Burn, and Soft Light

•	 Live Filters: Blur, Blur More, Inner Shadow and Drop Shadow

Vector objects, right down to their opacity, are preserved as vectors with  
editable attributes.  

3	 Select the Pointer tool in Flash Catalyst and click once on the gray rectangle 
underneath the text. Note that the rectangle is translucent. 

4	 In the Properties panel, change the opacity from 90 to 60. The selected rectangle 
becomes more transparent.

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



Adobe f ireworks cs5 Cla ssroom in a B  ook  S-87

5	 Select page_2_Shop_in_Meridien and then open the Layers panel.

6	 Expand the content layer. The layer structure from the Fireworks file has been 
maintained, right down to the sublayers.

7	 You can close the file without saving it.

Fireworks and Illustrator
Another advantage of the new FXG export in Fireworks is that Adobe Illustrator  
also supports this format. If you have ever tried saving a Fireworks file as an 
Illustrator file, you’ve no doubt been frustrated with the poor version support for 
this option. Fireworks only saves AI files at the version 8 level. This means that very 
few of Fireworks’ more advanced features are preserved. But now you can export 
your Fireworks design as FXG And Images for further editing in Illustrator.  FXG-
supported vector fill effects are retained as vectors, so your screen-based design 
could easily be converted into a high-resolution CMYK file for printing, or simply 
opened in Illustrator for further editing.
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Fireworks and Dreamweaver
It’s no surprise that products within Adobe Creative Suite are meant to play well 
together—they are a suite, after all. In this section, you’ll learn some techniques for 
making the most of the integration between Fireworks and Dreamweaver.

Copying and pasting to Dreamweaver
You can quickly add objects from a Fireworks design directly into a website layout 
in Dreamweaver. 

1	 Start Dreamweaver.

2	 Open the check_mag_home.html file from the webpage folder of the Lesson13 
folder. This is an HTML prototype page that has been reviewed by the client.  
It has also undergone a lot of layer restructuring for better organization.

## Note:  This exercise 
requires Dreamweaver 
CS5. If you do not own 
Dreamweaver, you may 
skip this section, or 
download the 30-day, 
fully functional trial 
version of Dreamweaver 
from Adobe at www.
adobe.com/downloads.
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Another watch image has been sent as a replacement for the existing watch 
promo image. The client has requested the blue background be removed and 
replaced with a gradient background. 

This work has already been done in the file called watch.fw.png, using a bitmap 
mask and a gradient-filled rectangle. 

The image is currently not the right dimensions for the watch promo section of 
the banner. You will create the correct image size without affecting the original 
file in any way.

3	 In Fireworks, open the watch.fw.png file in the Lesson13 folder.

4	 In the Layers panel, hold down the Shift key and select both the watch and the 
background.
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5	 Choose Edit > Copy.

6	 Switch to Dreamweaver.

7	 Select the original watch image, and delete it.

8	 Choose Edit > Paste.

The Image Preview window opens. This is the same Image Preview window you 
can access from Fireworks, but in this case, it’s initiated by Dreamweaver.

9	 In the Options pane, set the file format to JPEG – Better Quality.

10	 Switch to the File tab, and then set the scaling to 95%.

11	 In the Export Area option, type 237 in the width field and 90 in the height field. 
These are the dimensions of the original watch image.
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12	 Type 0 in the x field and 35 in the y field, and click OK.

The Save Web Image dialog box appears.
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13	 Browse to the images folder within the webpage folder of the Lesson13 folder.

14	 Rename the file to watch_promo2.jpg, and click Save.

The Image Description (Alt Text) dialog box appears. 

15	 Type Win a watch! in the Alt Text field, and click OK. 

The new, cropped image appears on the page, where the old image used to be.

16	 Return to Fireworks; the original PNG file remains unchanged.

17	 Close the watch.fw.png file without saving.

Round-trip editing
Another request has come in—this one for a change to the navigation bar. The  
client would prefer the navigation text to be closer to the right and with more  
spacing between each link. You will make this change using round-trip editing.

1	 Select the navigation bar image within Dreamweaver.
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2	 In the Properties panel, click the Edit icon.

Th e Fireworks prototype opens with two diff erences. Th e watch image slice is now 
a bright green HTML slice because the image was changed within Dreamweaver, 
and the new watch image is not part of the original PNG fi le. To maintain the 
new image, apply an HTML slice rather than the original image slice.

Find Source dialog box
The Find Source dialog box may appear, asking whether you want to edit this indi-
vidual image or locate the Fireworks PNG fi le. If it does, follow these steps:

1  Click the Use A PNG button. 

The Open dialog box appears.

2  Locate and open the check_mag_home.fw.png fi le in the Lesson13 folder.

## Note:  Editing the 
PNG fi le works properly 
only if the page was 
originally exported as 
HTML And Images. If 
the fi le was exported as 
CSS And Images, round-
trip editing will have a 
negative eff ect on the 
HTML page.
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A Done button and the status message, Editing From Dreamweaver, appear near 
the top of the document window.

3	 Click Hide Slices And Hotspots in the Tools panel.

4	 Select the five text links using the Pointer tool.

5	 In the Properties panel, change the X value to 456.

6	 Open the Align panel, and change the Spacing value to 
30. 

7	 Click the Space Evenly Horizontally icon to spread the 
text links apart.
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8	 Click the Done button. 

You are returned to Dreamweaver, and the navigation bar has been updated to 
reflect the changes in the PNG. The PNG file is saved automatically.

Three-slice technique for content containers
A common visual technique for containing web content is to put the content inside 
some sort of container, often called a pod, which can expand vertically or horizon-
tally to contain additional content. The three-slice technique creates a pod that 
expands in one dimension while the other dimension remains fixed.

In this exercise—we’re back in Fireworks now—you will create the slices for verti-
cally flexible pods for the Bare Tree Society website.

1	 Open the bare_tree.fw.png file from the Lesson13 folder.

Conveniently, both pods are the same width, so you need only slice up one pod 
and use the same exported graphics for both pods in the final web design.

To create slices that will export only the pod areas and not the text, you will 
have to hide the text in one pod.

Content Pods
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The content layer holds all the elements for the content area of the design: two 
text blocks and two rounded rectangles.

2	 Select the text in the left pod with the Pointer tool.
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3	 Locate the selected object in the Layers panel, and hide the object by clicking its 
Show/Hide box (   ).

4	 On the canvas, right-click (or Control-click) on the rounded rectangle, and 
choose Insert Rectangular Slice.

This slice will cover the entire rectangle, including the outer glow. When you 
have shapes that use glows or drop shadows, letting Fireworks create the initial 
slice can be more accurate.

5	 In the Properties panel, change the height of the slice to 20 pixels.
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6	 Choose Edit > Clone to create an exact copy of the slice.

7	 Use the Down Arrow key to reposition this new slice below the original slice.

8	 Change the height to 10 pixels in the Properties panel. This will become the 
repeating background image for the pod. Its exact Y position is not too impor-
tant, as long as it doesn’t overlap the other slices.

9	 Select the top slice and clone it 
again.

10	 Use the arrow keys to reposition 
the new slice at the bottom of the 
pod. The Y value for the new slice 
position will be 338.

11	 Select all three slices, and change 
the Slice Export Settings option 
to JPEG – Better Quality from 
within the Properties panel.

12	 Name the slices appropriately in 
the Layers panel: pod_top, pod_
bg, and pod_bottom.

E Tip:  If you hold 
Shift while pressing the 
arrows, your slice will 
move ten pixels at a 
time instead of just  
one pixel.
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Once the graphics have been exported, the design can be assembled in 
Dreamweaver using a combination of HTML and CSS. There are several differ-
ent ways to achieve this result. In this figure, you can see how adding additional 
content to a container within Dreamweaver expands the left container, leaving the 
right container unaffected. 

Fireworks and Flash
Fireworks and Flash work together in several ways. Fireworks PNG files can be 
imported into Flash as movie clips, maintaining the layer structure of the PNG file. 
Fireworks button symbols are imported as fully functional Flash button symbols. 
Flattened bitmaps can be altered using round-trip editing—similar to round-trip 
editing between Dreamweaver and Fireworks.

## Note:  For infor-
mation on different 
methods for creating 
expandable containers 
in a web page, visit 
www.smileycat.com/ 
miaow/archives/ 
000044.php.
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You will use the movie_scene.fw.png file as a backdrop for a Flash interface pro-
moting the Double Identity movie. It consists of a background image, two text 
blocks, and a vector path filled with a gradient.

Preparing files for Flash
Before you jump into this process, it’s best to know what to expect from the process 
of importing and editing between these two programs.

Transformations such as skewing text are not carried over into Flash. Likewise,  
custom letter tracking is ignored by Flash. You can convert the type to paths to 
retain text transformations and tracking, but it will no longer be editable as text 
with Fireworks or Flash. 
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Additionally, certain Live Effects and blending modes are not supported in Flash. 
Table 13.1 and Table 13.2 list the supported features.

Table 13.1  Fireworks effects supported in Flash

F i r e w o r k s  e ff  e c t  n a m e 	 F las   h  f i lt e r  n a m e

Drop shadow	 Drop shadow

Inner shadow	� Drop shadow (with Inner Shadow automatically 
selected)

Blur	 Blur (where blurX = blurY= 1)

Blur more	 Blur (where blurX = blurY= 1)

Gaussian blur	 Blur

Adjust color	 Adjust color brightness

Adjust color	 Adjust color contrast

Table 13.2  Fireworks blending modes supported in Flash

F i r e w o r k s  b l e n d i n g  m o d e  n a m e 	 F las   h  b l e n d i n g  m o d e  n a m e

Normal	 Normal

Darken	 Darken

Multiply	 Multiply

Lighten	 Lighten

Screen	 Screen

Overlay	 Overlay

Hard light	 Hard light

Additive	 Add

Difference	 Difference

Invert	 Invert

Alpha	 Alpha

Erase	 Erase
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Importing Fireworks documents into Flash
It’s important to understand the differences between importing a layered Fireworks 
PNG file and importing a flattened version of a Fireworks PNG file. In this exercise 
you will import a native Fireworks PNG file as well as a standard JPEG file.

What are my import options?

With Fireworks PNG files, you have two main choices.

Fireworks PNG. Import the Fireworks PNG as a multilayered file if you will need 
to animate or add ActionScript to individual objects within the PNG design. 

The document imports into Flash as a PNG (for positioning) and a Fireworks folder 
that holds the bitmap objects and a movie clip containing all the layers (vectors, 
text, bitmaps, and button symbols) from the original Fireworks PNG file. 

There is no dynamic connection between the imported file and the original 
Fireworks PNG file; if elements within the design require additional editing, you 
will have to open the source PNG file within Fireworks, make your changes, save 
the file, and then update the specific object within Flash. The real advantage of this 
method is that you can bring into Flash a fully layered file, so that your various 
bitmaps are available as separate objects and your vector elements are editable 
within the Flash environment. You can also import a specific page from a multipage 
Fireworks document.

Flattened bitmap. Flattening is the process of converting a multilayered image file 
into a single graphic with no individual editable layers or objects. A flattened file is 
imported into the Flash library using the original filename as its label.

With flattened bitmaps, you can make use of round-trip editing by right-clicking 
(or Control-clicking) the desired object in the Library panel or on the stage.

Importing a Fireworks PNG

The text in this design has been skewed to a specific angle and has custom tracking 
applied to different letter pairs in the text block. Flash will discard the tracking and 
skewing on import, so you will convert the text elements to paths to retain its look.

1	 In Fireworks, open movie_scene.fw.png from the Lesson13 folder.

2	 Select both text blocks using the Pointer tool.

## Note:  Standard 
flat files such as JPEG 
files are automatically 
imported as flattened 
bitmaps.

## Note:  This exercise 
requires Flash 
Professional CS5. If you 
do not own Flash, you 
may skip this section, or 
download the 30-day, 
fully functional trial 
version of Flash from 
Adobe at www.adobe.
com/downloads.

Excerpted from Adobe Fireworks CS5 Classroom in a Book. 
Copyright © 2011 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



Adobe f ireworks cs5 Cla ssroom in a B  ook  S-103

3	 Choose Text > Convert To Paths.

4	 In the Layers panel, rename the groups of text to DOUBLE group and 
IDENTITY group.

5	 Save the file as movie_scene_working.fw.png.

6	 Start Flash Professional CS5. 

7	 Choose Flash File (ActionScript 3.0) from the Create New column of the 
Welcome screen. 
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A new document opens.

8	 Choose Modify > Document.

9	 Change the dimensions of the file to 600 pixels wide by 462 pixels high (the 
same dimensions as our Fireworks design). Leave all other settings at their 
defaults and click OK.

10	 Choose File > Import > Import To Library. 

11	 Browse to the Lesson13 folder, and open the movie_scene_working.fw.png file.
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12	 When the Import dialog box appears, use the settings seen in the following 
figure to keep objects as editable as possible, and then click OK.

The PNG file is placed in the Library panel. 

Flash creates a special folder to store the objects from the Fireworks PNG file. 
The alleyway photo is saved as a separate bitmap, and the vector objects are 
grouped within the movie clip. 

13	 Drag the Page 1 movie clip onto the middle of the stage.

The layer structure of the PNG file has also been maintained within the  
movie clip. 
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14	 Double-click on the stage.

15	 Open the Timeline panel (Window > Timeline); you will see all four objects 
in their own layers in the timeline. The object names used in Fireworks are 
retained by Flash.

Each vector object within the timeline is editable within Flash. 

16	 Use the Selection tool (   ) to double-click on the sign background object on 
the stage.

Double-clicking on the object dims everything on the stage but the object you 
just selected. This is called editing in place, as can be seen from the breadcrumb 
trail above the document window.

17	 With the Subselection tool (   ), move your cursor near the border of the 
shape, and click. Vector control handles appear, and, just as in Fireworks, you 
can drag those control points to alter the shape of the path.
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18	 Drag a control point.

19	 Press Ctrl+Z (Windows) or Command+Z (Mac) to undo the edit.

20	 Click the Scene 1 segment of the breadcrumb trail to go back to the main stage.

Importing a flattened bitmap
Standard bitmap objects are easily imported into Flash.

1	 Choose File > Import > Import To Library.

2	 Browse to the Lesson13 folder and select thumb5.jpg.

Because this is a flattened image, no dialog box appears. The image is just 
directly imported into the Library. 
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Bitmap objects cannot be edited within Flash, but this is where Fireworks 
comes in handy. Flattened objects like this image can benefit from the other 
Flash/Fireworks integration feature, round-trip editing.

3	 Right-click (or Control-click) on the image name in the Library panel.

4	 Choose Edit With Fireworks. If it doesn’t say Edit With Fireworks, then choose 
Edit With, navigate to where Fireworks is located, and open it that way. From 
then on, it will say Edit With Fireworks, as expected, here.

The Find Source dialog box may appear and you will be asked if you want to 
edit this image directly or locate a PNG file to make the edits. 

5	 There is no PNG file for this image, so click the Use This File button.
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The image opens in Fireworks, and above the document window you see a Done 
button and the phrase Editing From Flash.

6	 In the Properties panel, click the Add Live Filters button (+) button to add a 
Live Filter. Choose Shadow And Glow > Inner Shadow.

7	 Click the Done button.

Fireworks prompts you to save a PNG version of the image, because you have 
added a Live Filter. As this change will be a permanent one to the JPEG file, it 
would be wise to create a PNG image that can be edited later.

8	 Click Yes, and save the file as thumb5.fw.png in the Lesson13 folder. This way, 
you can always further edit the Live Filter at a later time.
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You are returned to Flash, where the thumb5.jpg image has been updated with 
the inner shadow.

From this point forward, if you need to make further edits to this image, choose 
Use A PNG from the Find Source dialog box. In this manner, you are not con-
stantly editing and resaving a JPEG file, thus reducing its quality each time. 

9	 Close the Flash file without saving it.

Additional considerations 
when importing to Flash
Here are some factors to keep in mind when importing to Flash:

•	 HTML: Pop-up menu code is not supported by Flash. Likewise, interactivity and 
button behaviors are not imported to Flash.

•	 Vectors and text: Flash does not support all the special effects, fills, and strokes 
available in Fireworks. When you import a Fireworks PNG file and choose to keep 
the file as editable as possible, these features may look different. Flash supports 
only solid fills, gradient fills (except the contour gradient), and basic strokes.

•	 Bitmaps: When Fireworks graphics are imported or copied and pasted into 
Flash, some attributes are lost, such as certain Live Filters and textures. 

•	 Graphic symbols with 9-slice scaling are supported in Flash, but 9-slice scaling 
is not maintained for animation symbols.

•	 Drag and drop: You can drag and drop selections from the Fireworks Canvas 
directly on the Flash stage. The import dialog box will appear when you release 
the mouse so that you can control how the objects are imported into Flash.
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Review questions
1	 What is the three-slice technique?

2	 How do you add AIR events?

3	 How do you export Fireworks files for use in Flash Catalyst?

4	 What are the steps to choosing a Flex component for skinning?

5	 How do you import a multilayered Fireworks PNG file into Flash? 

Review answers
1	 The three-slice technique creates graphics for an expandable panel or box on a web 

page. In Fireworks, you draw your container, and then add a slice to the top and the 
bottom, and a third slice to be used as a repeating background image for the main  
content area of the container. You can then assemble the panel within a series of div 
tags within Dreamweaver, or use the Fireworks CSS And Images option to export a 
page containing the flexible container.

2	 To add an AIR event, you draw a slice or hotspot to cover an interactive element in 
the AIR mockup, choose Commands > AIR Mouse Events, and then pick the desired 
event. You can choose from Drag, Close, Minimize, and Maximize.

3	 If you wish to use your Fireworks designs or artwork in Flash Catalyst, choose File > 
Export and then select FXG And Images from the Export list. You can choose to 
export a selected object, selected pages, the current page, or the entire document.

4	 Choose Commands > Flex Skinning > New Flex Skin. Select the Specific Components 
option, and then choose the component you wish to skin from the component list. You 
can also choose whether to apply this skin to all instances of that component, or apply 
it only to skins with a specific class.

5	 To import a multilayered Fireworks PNG into Flash, first you open an existing Flash 
document or create a new one. Choose File > Import > Import To Library. Browse for 
the file. You can then choose whether to import the file as a flattened bitmap or as a 
multilayered, editable file. You gain more flexibility within Flash if you do not flatten 
the file.
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