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12 Improving  
Your Workflow

Lesson overview
Fireworks is full of ways to save you time. From batch processing  
and custom automation of tasks to built-in features and integration 
with Adobe Bridge, there are many ways to speed up your project 
workflow without cutting corners.

In this lesson, you’ll learn how to do the following:

•	 Use document templates

•	 Batch-process tasks

•	 Locate and process files in Adobe Bridge

•	 Add project information to a file 

•	 Add Photoshop Live effects

This lesson will take about 90 minutes to complete. Copy the Lesson12 
folder into the Lessons folder that you created on your hard drive for 
these projects (or create it now, if you haven’t already done so). As 
you work on this lesson, you won’t preserve the start files. If you need 
to restore the start files, copy them from the Adobe Fireworks CS5 
Classroom in a Book CD.	
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Fireworks is all about getting the job done 
professionally, in as little time as possible.
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Using document templates
Many designers love Fireworks because it lets them get in and get out quickly. 
Expediting your workflow is indeed a key goal of Fireworks. 

One feature that may help you in concept and prototyping stages is document  
templates. Fireworks comes with a number of prebuilt templates you can use to  
jump-start a brand-new project. The template options range from common document 
sizes for web and mobile projects, to grid layouts for creating original web-page 
layouts and wireframes, to mobile application and website prototype samples. 
You will use one of these templates to quickly generate a series of web banners to 
promote a website.

Opening a document template
You’ve been asked to create a series of web banners from some supplied artwork. 
This is a great chance to see how document templates can save you time.

1	 Choose File > New From Template or select the From Template option on the 
Welcome screen. The New From Template dialog box opens directly to the main 
Templates folder.

You can choose from one of five default categories.

2	 Open the Document Presets folder and select the Web banners template. 
In Windows, a preview window appears automatically. On the Mac, click the 
Preview button to open the preview window.

3	 Use the playback controls below the preview image to browse through the 
various design options. 
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4	 Choose the 728 x 90 – Leaderboard page and click Open.

The entire document opens, with the 728 x 90 Leaderboard template as the active 
page. Note that all the other banner sizes are still part of the document, including a 
summary page that has all the banners on a single page. This is already saving you 
time because you don’t need to research banner sizes or create the banner files.

Assembling the banners
The main graphics are already created for you as separate files. It’s up to you to  
use them in a variety of ways to create unique banners. We’ll walk you through  
the process for the Leaderboard and skyscraper ads. A final version of the banners 
can be found in the Lesson12 folder. Feel free to refer to this as you work through 
the exercise.

Building the leaderboard banner

Once again, you will be using the Import command to speed up your workflow.

1	 Choose File > Import (Ctrl+R on Windows or Command+R on Mac) and 
browse to the meridian_header.png file. This is a flattened PNG, with no special 
layers or effects.
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2	 Click Import, then Open (Windows) or Open, then Open (Mac) and place your 
import cursor at the top left of the banner rectangle.

3	 Click once to import the image at its original dimensions. On the Mac, you 
may need to click once to set the focus to the Document window first.

4	 Hold down the Ctrl or Command key and press the down arrow key once. 
The image is moved behind the banner rectangle.

5	 Select the Pointer tool and click on the banner rectangle.

6	 Press Ctrl+X or Command+X to cut the rectangle.

7	 Select the image and choose Edit > Paste As Mask. The banner rectangle now 
masks the image at the correct dimensions for the banner.

8	 In the Layers panel, select the image rather than the mask.

9	 On the canvas, locate the blue control handle and reposition the image within 
the mask. Your final X and Y coordinates for the image (not the mask) should 
be X: –206 and Y: 32. Don’t use the Properties panel to do this; use the image 
control handle within the image.

10	 In the Properties panel, reduce the opacity of the image to 50%.

11	Save your file as meridian_banners_working.fw.png.

Adding a logo and a call to action

You’ve got your background image. Now it’s time to add the logo and call to action.

1	 Select File > Import and bring in the local_logo.fw.png file.

2	 Click once on the canvas to import the file at its original size.

This file is made up of several grouped elements: a logo and three text objects.

E Tip:  If you want to 
numerically control the 
position of the masked 
object, rather than drag 
it with the mouse, first 
break the link between 
mask and masked 
object by clicking on 
the chainlink icon 
found between the two 
objects in the layers 
panel. Then select the 
image itself and use the 
Properties panel to alter 
its location.
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3	 Position the group at X: 30 and Y: 75.

4	 Import the join_local.fw.png file at its original size and place it at X: 490 
and Y: 62.

5	 Save your work.

Creating the skyscraper banner

You will now add content to the skyscraper banner on the 160 x 600 Wide 
Skyscraper page.

1	 Select the 160 x 600 Wide Skyscraper page in the Pages panel.

2	 Import the file called meridian_skyline.png at the upper-left corner of the 
skyscraper rectangle.

3	 Hold down the Ctrl or Command key and press the down arrow key once. 

4	 Select and cut the banner rectangle.

5	 Select the image and choose Edit > Paste As Mask. 

6	 In the Layers panel, select the image rather than the mask.

7	 In the Layers panel, break the link between the image and the mask by clicking 
the chain-link icon between the two objects, and then select the image.
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8	 In the Properties panel, set the coordinates for the image to X: –1118 and Y: –79.

9	 Import the local_logo.fw.png file at its original size. 

10	Place it at X: 22 and Y: 70. The text will be located off the canvas.

You need to ungroup the logo so that you can place the text lower in the banner.

11	Select the logo with the Pointer tool and then press Ctrl+Shift+G or 
Command+Shift+G. The objects are ungrouped but remain selected.

12	Click off the canvas to deselect the objects, and then holding the Shift key, click 
on the three text blocks to select them.

13	Use the Pointer tool to drag the text below the logo. The final coordinates 
should be about X: 22 and Y: 203. The text is in the right place, but it’s too small. 
You will adjust this next.

14	With all three blocks still selected, change the text size from 18 pixels to 24 
pixels in the Properties panel. This will force all three blocks to overlap each 
other. Not to worry.

15	Open the Align panel and in the Space field, set a value of 2 and then click on 
the Space Evenly Vertically icon. 

The text is now spaced evenly and no longer overlaps.
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16	Double-click inside the first text block and replace the comma with an 
ampersand.

17	Save the file.

Editing individual objects within a group

You will work with the same call-to-action file as before, but as with the logo, you 
will customize it once it’s been imported. You will use the Subselection tool to edit 
individual objects in the group, without ungrouping them.

1	 Scroll to the bottom of the banner.

2	 Import the join_local.fw.png file near the bottom of the banner.

3	 Select the Subselection tool and click on the gray circle behind the words JOIN 
LOCAL. This circle is a bitmap graphic rather than a vector. You could replace 
it with a vector, but all that’s necessary is a simple color change, so you will just 
edit the bitmap’s live properties.

4	 In the Properties panel, you will see that a Photoshop Live Effect has been 
added to the circle.

5	 Click on the i icon beside the filter name. The Photoshop Live Effects dialog 
box appears.

6	 Select the Color Overlay option by clicking on the name.
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7	 Click the color box in the main window and choose a bright red instead of the 
gray currently in use, and then click OK. The circle is now red.

8	 Hold down the Shift key and click on the JOIN LOCAL text so both the text and 
the circle are selected on the canvas.

9	 In the Properties panel, change the position to X: 24 and Y: 538.

10	With the Subselection tool still selected, double-click on the text block beside 
the circle, and then triple-click the top line of text to select it.

11	Press Delete.

12	Click away from the text; then, making sure the Subselection tool is selected, 
click once on the text block again and reposition it beneath the red line.

13	Shift-click to select the two red lines along with the text and reposition the 
selection to X: 14 and Y: 597.

14	Finally, select just the horizontal red line and change its width to 150 pixels in 
the Properties panel.

15	Save the file.

For extra credit, study the meridian_banners_final.fw.png file and see if you can 
replicate those banners.



Adobe fireworks cs5 Cla ssroom i n a B  ook  S-11

Removing unwanted templates
Chances are you won’t need the All Sizes page in your final file so now you will 
remove it from your new document.

1	 From the Pages panel select the 01 All Sizes page.

2	 Click the trashcan icon to delete the selected page. You are now left with just 
the four banner pages sample.

3	 Save your file and close it.

Working with Adobe Bridge
In this lesson, you’ll develop an art section for an ecotourism company. You will use 
another application to get started this time, however: Adobe Bridge.

Adobe Bridge can save you a lot of time by letting you view, sort, and open images 
you wish to use in Fireworks. You can also add information to certain types of 
images, such as JPEG files or Fireworks PNG files, using the Metadata panel in 
Bridge. If you have purchased a Creative Suite edition, Adobe Bridge installs with 
Fireworks, which is automatically linked to Bridge on installation. You can also use 
Bridge to work with other Adobe applications, such as Photoshop and Illustrator.

1	 In Fireworks, choose File > Browse In Bridge.

2	 When Bridge opens, select Filmstrip from the Workspace Switcher. 

As in other Adobe applications, Bridge has a number of preset workspaces that 
you can use, or you can create custom workspaces to use whatever arrangement 
of panels you find most useful for your own workflow. For the purpose of this 
lesson, the Filmstrip workspace best suits what we’re about to do, because we 
can see thumbnails of the artwork and a large preview of a selected image at the 
same time. 

3	 Click the Folders tab on the left side of the Bridge window.

## Note:  If you 
purchased Fireworks as 
a standalone product, 
Adobe Bridge is not 
included. 
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4	 Navigate to your Lesson12 folder in the Folders panel. 

At the bottom of the Bridge window, in the Content pane, you will see a folder 
called fullsize and several PNG files.

5	 Click once on the nature_tours.png file. An enlarged preview appears above the 
Content panel. 
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Typically, PNG files are associated with Fireworks upon installing Bridge and 
would therefore open automatically, but just to make sure, this time you will 
“manually” open this file in Fireworks. 

6	 Choose File > Open With > Adobe Fireworks CS5. 

Bridge returns you to Fireworks, where the PNG file is ready and waiting.

Batch-processing images
You will be importing thumbnail images to this page—at this point, thumbnails are 
all we need, and all we have space for. A set of guides (green lines) has already been 
put in place to help you align the images as you import them. 

Let’s have a look at the images first. 

## Note:  To resolve 
potential issues with 
missing fonts, we 
converted the text 
in the file to paths. 
This can be a useful 
technique if you have 
used nonstandard fonts 
and need to pass the 
file on to someone else. 
The paths retain the 
shape and attributes of 
the text, but they are no 
longer editable as text. 
As paths, or vectors, 
they can still be scaled 
without losing any 
quality in your work.
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1	 Choose File > Browse In Bridge. If you have not done anything with Bridge since 
the last exercise, Bridge displays the Lesson12 folder. If you have been exploring 
Bridge, use the Folders panel to locate the Lesson12 folder.

2	 In the Content panel, double-click on the fullsize folder. A series of ten images 
loads into the Content panel.

3	 Select any single image, and Bridge displays a large preview as before.

4	 Place your cursor over the thumbnail view of the first image. After a short delay, 
file properties appear. The dimensions of this file are great for making a print, 
but far too large for a web page.

Currently, all the supplied artwork is in high resolution, at much larger dimen-
sions than are needed for thumbnail images. You could use Fireworks to import 
each file, but this is tedious and time-consuming. Besides, you will also need actual  
thumbnail images for the final web-page design, not just for the prototype. 
What you need is a way to resize, optimize, and rename files quickly and easily.

Batch processing can take care of sizing, optimization, and even naming the 
needed files.

5	 Click on the first thumbnail, and then Shift-click the last thumbnail to select all 
ten files.

## Note:  If you don’t 
see the file properties, 
choose Edit > 
Preferences (Windows) 
or Bridge > Preferences 
(Mac), click Thumbnails, 
and then select Show 
Tooltips at the bottom 
of the dialog box.

E Tip:  You can change 
the size of the content 
thumbnails by dragging 
the slider at the bottom 
of the application.
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6	 Choose Tools > Fireworks > Batch Process.

The Batch Process dialog box appears, and all the selected images are displayed 
in the pane at the bottom of the dialog box.

7	 Click Next.

E Tip:  Batch Process 
is a native Fireworks 
command, so you don't 
need Bridge installed 
in order to use it. You 
can access the Batch 
Process Wizard in 
Fireworks by selecting 
File > Batch Process.
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8	 From the left column, select Scale, and then click the Add button to move Scale 
to the right column. Do the same for Rename and Export.

These are the batch-processing commands you will run on the images, in the 
order they appear in the list. Each command in the list has editable properties. 
You will customize them for this project.

9	 Select the Scale command from the right column, and then choose Scale To Fit 
Area from the Scale options list at the bottom of the dialog box.

10	Set the Max Width and Max Height to 125 pixels.

11	Select the Rename command from the right column, and then select the Replace 
option from the list at the bottom of the dialog box.

12	 In the first field (Replace), type DSC. 

13	 In the With field, type wallpaper.
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14	Select the Add Prefix option, and type thmb_ in the text field.

15	Select the Export command from the right column.

16	Choose JPEG – Better Quality from the Settings drop-down list, and then click 
Next.

17	Choose the Custom Location radio button, and browse to the Lesson12 folder.

E Tip:  If this is a series 
of steps you think you 
will repeat again, you 
can save the operations 
as a script by clicking 
the Save Script button. 
You can then access 
this custom command 
any time from the 
Commands menu.
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18	Create a new folder called thumbnails, and open that new folder, if necessary.

19	Click Select Thumbnails (Windows) or Choose (Mac).

20	Click the Batch button.

Fireworks displays a progress box as it processes the images. 
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Once Fireworks is done, it will tell you that the process has been completed, and 
you can click OK to dismiss the progress box.

In a few short steps you have scaled, renamed, and exported ten images all at once. 
The new images are in the thumbnails folder you just created.

Importing and resizing images
Now that you’ve optimized the thumbnail images, you’re ready to import them into 
Fireworks, and, if necessary, easily make them visually consistent. 

Importing the images
The main thing, of course, is to get your newly optimized images into your design 
in Fireworks. 

1	 Make sure the Snap To Guides option is selected by choosing View > Guides > 
Snap To Guides.

2	 Make sure the main sublayer is selected in the Layers panel.

3	 Choose File > Import, and browse to the thumbnail directory.

4	 Select the file thmb_wallpaper_2424.jpg, and click Open.

5	 Click an insertion point where the first two guides (the green lines) intersect.

## Note:  As mentioned 
earlier, we needed only 
thumbnail images for 
this page in the design. 
However, should you 
wish, you could link the 
thumbnails to the full-
sized versions of images 
using Dreamweaver or  
your preferred web-
design software so 
that, when clicked, the 
full-sized images open 
for viewing. 
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6	 Choose File > Import again; you should still be in the thumbnail directory.

7	 Select the file thmb_wallpaper_2581.jpg, and click Open.

These first two images don’t fit the guide dimensions. You will correct that 
problem a bit later in the exercise. 

8	 Place your import cursor where the third vertical guide intersects with the top 
guide so the thumbnails are moving across the document toward the right.

9	 Continue with this process, in numerical order, until all ten images have been 
imported. Each image should snap to the intersection of two guides.

When all the images are imported, the layout should look like the following figure.
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Cropping individual bitmaps in a design
Everything lines up nicely, except those first two images. They were shot with a 
different camera, and their dimensions differ from the other images. You will crop 
these two images right on the canvas.

1	 Zoom in to 150%. 

2	 Pan around the canvas by holding down the spacebar and dragging the mouse 
until you see the first image you imported, at the upper left. Then select this 
image with the Pointer tool.

3	 Choose Edit > Crop Selected Bitmap. A cropping marquee appears around 
the object.

4	 Use the Pointer tool to drag the top crop mark down until the tooltip reads 
w:125, h:83.

5	 Release the mouse. This current crop cuts into the top of the sign. You will 
adjust that now.

6	 Press the Up Arrow key four times to reposition the crop.

7	 Press Enter or Return to commit to the crop.

8	 Drag the image up until it snaps to the top guide.
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9	 Repeat steps 3–5 for the second image. The crop dimensions should again be 
w:125, h:83. 

10	Reposition the crop as you see fit.

11	Press Enter or Return, and use the Pointer tool or the arrow keys to line the 
image up with the top and left guides as necessary.

12	Save the file as nature_tours_working.png.

Cool shortcuts
Improving workflow also means knowing how to speed up your work without  
cutting corners on quality.

Exporting a specific area
The client for Nature Tours is wondering about changing the font for the banner, 
and has asked to have a look at just the website banner. Without changing the  
layout at all, you can export a specific area of the page.

1	 Choose the Export Area tool (hidden beneath the Crop tool) in the Tools panel.

2	 Draw a crop that includes the entire width and height of the banner.

3	 Double-click inside the crop.

The cropped area will appear in the Image Preview dialog box. 
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4	 Set the format to JPEG and the Quality to 70%, if those settings are not already 
present. In the Image Preview dialog box, you can move around your document 
by clicking on the preview and dragging your cursor, allowing you to inspect the 
impact of your formatting choices. 

5	 Click the Export button. The Export dialog box appears. 

6	 Browse to the Lesson12 folder, and change the filename to nature_banner.

7	 In the Type menu (Windows) or Export menu (Mac) near the bottom of the 
dialog box, choose Images Only. 

8	 Make sure Slices is set to None. An alert box may appear telling you that slices 
will be ignored. If it does, click OK to continue. 

At this time, you want to export only the area you cropped. All other settings 
can remain as they are.
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9	 Click Save (Windows) or Export (Mac). Fireworks exports the cropped area as a 
JPEG file. You’ll take a look at it in Bridge.

10	Back in Fireworks, choose File > Browse In Bridge. Locate the Lesson12 folder. 

You’ll see that the area you cropped—the web banner—has been exported as a 
separate JPEG file, which can easily be e-mailed to the client for feedback.

Globally optimize pages
Fireworks remembers the last default export options you selected, and applies 
those settings to new documents as you create them. You can reset the export 
options for all pages very easily in a design: 

•	 Shift-click in the Pages panel to select the pages you wish to change. 

•	 Select a new export option from either the Properties panel or the Optimize 
panel.

•	 All nonsliced areas of each selected page will now export based on the new 
image settings you define.

Changing rectangle corners independently
Way back in Lesson 4, you were introduced to a special vector shape called an Auto 
Shape. You used the Chamfer Auto Shape as a design element in the watch_promo.
png file. There are three rectangular Auto Shapes in the Vector tools section of the 
Tools panel: Bevel, Chamfer, and Rounded Rectangle. Here’s a little secret: all three 
shapes offer the exact same corner options, but which corner is used as the default 
is based on the shape you choose to add. You can also customize the individual 
corners of any of the three shapes.

The client has asked to see a revision to the wallpaper page design. He likes the 
shapes that act as containers for the thumbnails and navigation, and wants to see 
something similar to contain footer information. You will be changing layout ele-
ments this time, so you’ll create a duplicate page first.
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1	 Drag the current page to the Add/Duplicate page icon at the bottom of the 
Pages panel.

2	 Rename the new page footer_concept.

3	 Choose Modify > Canvas > Canvas Size.

4	 Change the height to 968.

5	 Select the top middle anchor in the anchor grid.

6	 Make sure Current Page Only is selected, and click OK.

7	 Select the Rounded Rectangle Auto Shape from the Tools panel.

8	 Starting at X: 20 and Y: 790, draw a rectangle that is 963 pixels wide and 100 
pixels high. The Smart Guides will help you align the new shape at the left and 
right sides, to match the combined width of the two shapes above.

9	 Select the Pointer tool.
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10	Hold down Alt (Windows) or Option (Mac), and click on the top-right yellow 
diamond. Only the right corner changes to a chamfer.

11	Do the same with the top-left yellow diamond.

You want to quickly send off this new page design to the client. 

12	Save the file.

13	Choose File > Send To E-mail > JPEG Compressed. Your e-mail client will open, 
with the image already attached and ready to be sent.

E Tip:  To quickly 
fill a shape with the 
attributes of another 
shape, select the shape 
that has the desired 
attributes and press 
Ctrl+C (Windows) or 
Command+C (Mac), 
and then select the new 
shape and choose Edit 
> Paste Attributes.
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Thinking ahead: 
future-proofi ng your projects
In many situations, your fi les and projects aren’t necessarily going to stay only with 
you, or even within Fireworks. Th ey may take on a further life of their own. You’ll 
want to make sure not only that other people who need to use them can access and 
understand them properly, but also that the fi les will display and behave as predict-
ably as possible when opened within Photoshop. 

metadata
Metadata is additional information about a digital fi le. Th is information can be 
helpful for organizing and locating a project or its assets or just sharing informa-
tion across the design team. 

Th e Adobe XMP (eXtensible Metadata Platform) format lets you add fi le informa-
tion to saved PNG, GIF, JPEG, TIFF, and Photoshop PSD fi les. Data such as author, 
copyright, keywords, contact information, and even job history can be shared and 
updated between Adobe applications.

Adding metadata

You can add metadata using Adobe Bridge, but it is easy enough to do right inside 
Fireworks as well. 

1 Choose File > File Info. Th e XMP data window opens.
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Depending on the fi le you are working with, there may already be metadata 
applied to the image. Th is is most often the case with photographs shot with a 
digital camera. In the case of this fi le, there is no metadata as of yet. But you will 
change that.

2 In the Description tab, add the information you see in this fi gure.

3 Click the IPTC tab to add more specifi c contact information, as seen here.

4 Click OK. 
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Th is data will now travel with the Fireworks PNG fi le. If you export a JPEG, GIF, or 
fl attened PNG fi le, the data is automatically stripped out to reduce the web image 
fi le size (by default, metadata can easily add 10KB to the fi le size, even when there 
is no data added to the individual fi elds).

Creating a metadata template

You can automate this process even further by creating a metadata template. 
A template speeds up the addition of common information to project fi les, such 
as your company’s contact information.

1 Choose File > File Info again.

2 Remove any project-specifi c information from the Description tab, such as 
keywords and description.

3 Click on the Import button at the bottom of the box (to the left of OK and 
Cancel) and choose Export. Th is is a list of options, letting you import, export, 
browse the metadata templates folder, or apply an existing metadata template.

Th e Export metadata dialog box (Windows) or Save dialog box (Mac) will 
appear, pointing to a specifi c folder. All custom templates must be saved in 
this location.
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4	 Name the file fire_designs.xmp. 

5	 Click Save, and then click OK or Cancel to exit the XMP data window.

The next time you start a new design, you can select File Info and use the Import 
option to import your custom metadata template (or any other) into your file. 

Using Fireworks files with Photoshop 
With each product cycle, Fireworks and Photoshop come closer to having a fully 
integrated working relationship. If you need to move your Fireworks designs to 
Photoshop, you’ll get the best results by understanding Photoshop Live Effects,  
best practices for saving your file for Photoshop, and Photoshop export options.

Many elements can be preserved for editing in Photoshop. Text, hierarchical layers, 
layer groups, vector shapes filled with Photoshop Live Effects, solid color, many 
gradients, and masked objects are maintained and supported when you save a file 
in PSD format from within Fireworks. 

Photoshop Live Effects 

You will add a border around the images in the wallpaper page using a Photoshop 
Live Effect.

1	 Switch to the Pointer tool, hold down Shift, and click each of the thumbnails. 
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2	 Click the Add Live Filter (+) button in the Filters section of the Properties panel, 
and choose Photoshop Live Effects. 

3	 Choose the Stroke category. 

4	 Set the size of the stroke to 1, the position to Inside, and leave the opacity at 100. 

Enhanced integration in CS5
Fireworks and Photoshop CS5 have tighter integration in many ways:

Importing from Photoshop to Fireworks

You can force flattening of Photoshop adjustment layers when importing PSDs, which you can enable/disable in 
the Preferences.

Hue, saturation, and color blend modes and the Hue/Saturation filter in Fireworks now use the same algorithms 
as Photoshop to improve color fidelity and appearance

Importing editable gradients from Photoshop now match better:

•	 Linear to Linear (close to perfect match)

•	 Radial to Radial (close to perfect match)

•	 Reflected to Bars (close to perfect match)

•	 Diamond to Rectangular (approximate match)

•	 Angle to Conical (approximate match)

Saving/Exporting Fireworks files as PSD files

Exporting editable gradients from Fireworks to Photoshop are likewise more accurate:

•	 Linear to Linear (close to perfect match)

•	 Radial to Radial (close to perfect match)

•	 Bars to Reflected (close to perfect match)

•	 Rectangular to Diamond (approximate match)

•	 Conical to Angle (approximate match)

•	 Ellipse to Radial (approximate match)

•	 Ripples to Radial (approximate match)

•	 StarBurst to ShapeBurst (loosely matched)

•	 Contour, Satin, Waves to Linear (loosely matched)
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5	 In the Fill area, change the stroke color to Black by clicking the black color swatch. 

6	 Click OK. 

All the thumbnails now have a black border. We’ve hidden the guides and slice 
guides in this figure so you can better see the borders. If you want to hide them 
yourself, choose View > Guides, and then deselect Show Guides. To hide the 
Slice Guides, choose View > Slice Guides. Don’t forget to set them to be shown 
again afterward if you do this. 
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What are Photoshop Live Effects? 
Photoshop Live Effects are editable visual effects you can apply to objects within 
Fireworks. They are supported in Photoshop as layer styles. Fireworks maintains 
layer styles as Photoshop Live Effects when you open a PSD file in Fireworks. 

The Live Effects dialog box in Fireworks is not as robust as its Photoshop counter-
part, but using these Live Effects instead of native Fireworks Live Filters will guaran-
tee Photoshop support of the effect, if you or someone else needs to edit the file in 
Photoshop. 

If Photoshop is not part of your workflow, by all means stick to the Fireworks Live 
Filters or any third-party filters you may have. 

Saving your file for Photoshop 

If your designs and comps must go from Fireworks to Photoshop for further editing, 
and you want to retain as much editability as possible, make sure you save a copy of 
your file in the Photoshop PSD format. 

1	 Choose File > Save As. 

2	 Browse to the Lesson12 folder. 

3	 Choose Photoshop PSD from the Save As Type (or Save As) menu. The menu 
name will change to Save Copy As when Photoshop PSD is chosen. 
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4	 Click the Options button. 

5	 To maintain as much editability as possible, choose Maintain Editability 
Over Appearance. 

6	 Click OK to accept the settings, and then click Save to save the new file. 

If you open the file in Photoshop, you will see that the file is very similar to the 
original Fireworks design, with two exceptions: the brightness of the header and 
the texture in the background are missing. 

Customizing Photoshop Export options 

While maintaining editability makes the file as flexible as possible when opened 
in Photoshop, you may also lose certain effects or features. In the current file, the 
vector shapes used as containers will remain as vectors, and because the fills are 
linear gradients, even those will export properly. Other gradients such as contour, 
satin, or waves will be loosely matched. The header, which uses a Levels Live Filter 
to help with its appearance, will lose the Live Filter, and as a result, the header will 
look different in Photoshop. 

If the appearance is more important than the object’s editability, you can customize 
the Photoshop export options. 

1	 Choose File > Save As. 

2	 Browse to the Lesson12 folder, if necessary. 

3	 Change the name of the file to nature_tours_custom.psd. 

4	 Choose Photoshop PSD, if necessary, from the Save As field. 

5	 Click the Options button. 

6	 Choose Custom from the Settings menu. 
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7	 Change the Vector setting to Maintain Appearance. This will convert vectors to 
bitmaps, but leave any true text as editable text. 

8	 Click OK to accept the custom settings, and then click Save to save the file. 

Common Live Filters 
Some Fireworks Live Filters are supported by Photoshop and behave as standard 
Photoshop layer styles. 

Photoshop Live Filters can be added while in Fireworks, or they can be supported 
(editable) or maintained (only editable in Photoshop) if they are added as a layer 
style in Photoshop. 

The following list of Fireworks Live Filters are supported and maintained between 
Photoshop and Fireworks: 

•	 Drop Shadow, Inner Shadow 

•	 Glow, Inner Glow 

•	 Bevel and Emboss (all) 

## Note:  The only 
way to maintain the 
Levels Live Filter is to 
completely flatten the 
objects in Fireworks. 
If this is an effect you 
desire and still wish for 
editability, let Fireworks 
discard the effect and 
then you can add an 
Adjustment Layer while 
in Photoshop. 
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Common blending modes supported 
by Photoshop and Fireworks 
Blending modes can be applied to objects or layers. When you apply a blending 
mode, the object’s color and opacity are blended with the object beneath it in the 
Layers panel. Fireworks has 46 different blending modes. Photoshop and Fireworks 
share many common blending modes (23 in total). If a blending mode in this list 
is applied to an object or layer, the mode will be supported and remain editable in 
either application.

Normal

Dissolve

Darken

Multiply

Color Burn

Linear Burn

Lighten

Screen

Color Dodge

Linear Dodge 

Overlay

Soft Light

Hard Light

Vivid Light

Linear Light

Pin Light

Hard Mix

Difference

Exclusion

Hue

Saturation

Color

Luminosity
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Review questions
1	 How do you access Bridge from Fireworks?

2	 How do you batch-process files from within Bridge?

3	 How do you crop a bitmap object that is part of a design?

4	 How do you add metadata to a Fireworks PNG file? Why would you do this?

5	 How do you customize the export options for saving a Photoshop file?

6	 How can document templates save you time?

Review answers
1	 To access Bridge from Fireworks, choose File > Browse In Bridge.

2	 To process multiple files within Bridge, select the files in the Content panel, and then 
choose Tools > Fireworks > Batch Process.

3	 Select the object, and then choose Edit > Crop Selected Bitmap. Adjust the cropping 
marquee to suit, and then press Enter or Return to commit to the crop.

4	 To add metadata, choose File > File Info. Select the appropriate tab from the metadata 
panel, for the type of information you want to add, and fill in the areas relevant to the 
project and image. Adding metadata can help organize and locate content by adding 
contact information about the designer or company, and can include basic data about 
the client, such as client name, project goals, and copyright.

5	 You can globally customize the Photoshop Export options by opening the Preferences 
panel, or you can adjust the settings on an image-by-image basis when you choose to 
Save As a Photoshop PSD file.

6	 Document templates can save you time by giving you a head start on the design or 
prototyping stages of a project. The Grid templates give you several variations of 
grid structures to help you lay out your wireframe or even a website prototype. The 
Document Presets folder contains a range of files set at specific dimensions, making it  
easy to start designing a series of web banners at the common banner sizes, for example.


