ADOBE® FLASH®
PROFESSIONAL CS5

CLASSROOM IN A BOOK®
The official training workbook from Adobe Systems

DVD-ROM Included for Windows and Mac OS
WHAT’S ON THE DISC

Here is an overview of the contents of the Classroom in a Book disc

The Adobe Flash Professional CS5 Classroom in a Book disc includes the lesson files that you’ll need to complete the exercises in this book, as well as other content to help you learn more about Adobe Flash Professional CS5 and use it with greater efficiency and ease. The diagram below represents the contents of the disc, which should help you locate the files you need.

Lesson files
Each lesson has its own folder inside the Lessons folder. You will need to copy these lesson folders to your hard drive before you can begin each lesson.

Online resources
Links to Adobe Community Help, product Help and Support pages, Adobe Press, Adobe certification programs, Adobe TV, and other useful online resources can be found inside a handy HTML file. Just open it in your Web browser and click on the links, including a special link to this book’s product page where you can access updates and bonus material.

Learn by Video bonus tutorials
A bonus 2-hour set of Learn Photoshop CS5 by Video tutorials are included on this disc, from video2brain and Adobe Press. Learn by Video is one of the most critically acclaimed training products on Adobe software and is the only Adobe-approved video courseware for the Adobe Certified Associate Level certification.
CONTENTS

GETTING STARTED  1
About Classroom in a Book ........................................... 1
What’s New ................................................................. 1
Prerequisites ............................................................... 2
Installing Flash ............................................................. 2
Copying the Lesson Files ............................................. 3
How to Use the Lessons ............................................... 4
Additional Resources .................................................. 4
Adobe Certification ....................................................... 6

1   GETTING ACQUAINTED  8
Starting Flash and Opening a File ................................. 10
Getting to Know the Workspace .................................... 11
Working with the Library Panel ..................................... 14
Understanding the Timeline .......................................... 16
Organizing Layers in a Timeline .................................... 23
Using the Properties Inspector ..................................... 26
Using the Tools Panel ................................................... 29
Undoing Steps in Flash ................................................ 33
Previewing Your Movie ................................................ 34
Publishing Your Movie ................................................. 35
Saving Your Movie ...................................................... 37
Finding Resources for Using Flash ................................. 39
Checking for Updates .................................................. 40

2   WORKING WITH GRAPHICS  42
Getting Started .......................................................... 44
Understanding Strokes and Fills .................................... 44
Creating Shapes .......................................................... 45
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Making Selections</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td>Editing Shapes</td>
<td>47</td>
</tr>
<tr>
<td></td>
<td>Using Gradient and Bitmap Fills</td>
<td>51</td>
</tr>
<tr>
<td></td>
<td>Making Patterns and Decorations</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td>Creating Curves</td>
<td>63</td>
</tr>
<tr>
<td></td>
<td>Creating Transparencies</td>
<td>66</td>
</tr>
<tr>
<td></td>
<td>Creating and Editing Text</td>
<td>68</td>
</tr>
<tr>
<td></td>
<td>Getting Started</td>
<td>72</td>
</tr>
<tr>
<td>3</td>
<td>CREATING AND EDITING SYMBOLS</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Importing Illustrator Files</td>
<td>73</td>
</tr>
<tr>
<td></td>
<td>About Symbols</td>
<td>74</td>
</tr>
<tr>
<td></td>
<td>Creating Symbols</td>
<td>77</td>
</tr>
<tr>
<td></td>
<td>Importing Photoshop Files</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>Editing and Managing Symbols</td>
<td>80</td>
</tr>
<tr>
<td></td>
<td>Changing the Size and Position of Instances</td>
<td>87</td>
</tr>
<tr>
<td></td>
<td>Changing the Color Effect of Instances</td>
<td>90</td>
</tr>
<tr>
<td></td>
<td>Understanding Blend Effects</td>
<td>93</td>
</tr>
<tr>
<td></td>
<td>Applying Filters for Special Effects</td>
<td>93</td>
</tr>
<tr>
<td></td>
<td>Positioning in 3D Space</td>
<td>95</td>
</tr>
<tr>
<td>4</td>
<td>ADDING ANIMATION</td>
<td>102</td>
</tr>
<tr>
<td></td>
<td>Getting Started</td>
<td>104</td>
</tr>
<tr>
<td></td>
<td>About Animation</td>
<td>105</td>
</tr>
<tr>
<td></td>
<td>Understanding the Project File</td>
<td>106</td>
</tr>
<tr>
<td></td>
<td>Animating Position</td>
<td>106</td>
</tr>
<tr>
<td></td>
<td>Changing the Pacing and Timing</td>
<td>109</td>
</tr>
<tr>
<td></td>
<td>Animating Transparency</td>
<td>112</td>
</tr>
<tr>
<td></td>
<td>Animating Filters</td>
<td>114</td>
</tr>
<tr>
<td></td>
<td>Animating Transformations</td>
<td>119</td>
</tr>
<tr>
<td></td>
<td>Changing the Path of the Motion</td>
<td>122</td>
</tr>
<tr>
<td></td>
<td>Swapping Tween Targets</td>
<td>127</td>
</tr>
<tr>
<td></td>
<td>Creating Nested Animations</td>
<td>129</td>
</tr>
</tbody>
</table>
Using the Motion Editor ........................................ 132
Easing .................................................................. 138
Animating 3D Motion ............................................ 144
Previewing the Animation ..................................... 147

5  ARTICULATED MOTION AND MORPHING  150
Getting Started .................................................. 152
Articulated Motion with Inverse Kinematics .......... 153
Constraining Joints .............................................. 161
Inverse Kinematics with Shapes ......................... 168
Armature Options .............................................. 176
Morphing with Shape Tweens ............................... 180
Using Shape Hints ............................................. 183
Simulating Physics with Inverse Kinematics ........... 185

6  CREATING INTERACTIVE NAVIGATION  194
Getting Started .................................................. 196
About Interactive Movies .................................... 196
Creating Buttons ............................................... 197
Understanding ActionScript 3.0 ......................... 208
Preparing the Timeline ....................................... 212
Adding a Stop Action ......................................... 213
Creating Event Handlers for Buttons ..................... 214
Creating Destination Keyframes ......................... 217
Creating a Home Button ..................................... 222
Playing Animation at the Destination .................... 226
Animated Buttons ............................................. 230

7  USING TEXT .................................................. 234
Getting Started .................................................. 236
Understanding TLF Text ....................................... 237
Adding Simple Text ............................................ 240
Adding Multiple Columns .................................... 246
Wrapping Text ................................................... 250
Hyperlinking Text ............................................. 259
Creating User-input Text ..................................... 261
Loading External Text ........................................ 268
## WORKING WITH SOUND AND VIDEO

Getting Started ............................................................ 280
Understanding the Project File ................................. 281
Using Sounds ............................................................... 282
Understanding Flash Video ........................................ 295
Using Adobe Media Encoder ..................................... 295
Understanding Encoding Options ............................ 299
Playback of External Video ........................................ 305
Working with Video and Transparency ..................... 310
Using Cue Points ......................................................... 314
Embedding Flash Video ................................................. 322

## LOADING AND CONTROLLING FLASH CONTENT

Getting Started ............................................................ 332
Loading External Content .......................................... 334
Removing External Content ...................................... 339
Controlling Movie Clips ............................................. 340
Creating Masks ............................................................ 341

## PUBLISHING FLASH DOCUMENTS

Getting Started ............................................................ 350
Testing a Flash Document .......................................... 350
Understanding the Bandwidth Profiler ....................... 352
Adding Metadata ........................................................... 353
Publishing a Movie for the Web ................................. 356
Alternative Publishing Options ................................. 362

INDEX 369
About the Contributor

Russell Chun is a multimedia developer and consultant specializing in using Adobe Flash Professional to visualize science, data, and stories on the Web. He is on the adjunct faculty of the Columbia University Graduate School of Journalism and the City University of New York Graduate School of Journalism, where he teaches interactive journalism.

Russell has authored the previous edition of this Classroom in a Book and all of the previous editions of *Flash Advanced: Visual QuickPro Guide*. He has also co-authored an interactive e-book on multimedia journalism called *Storytelling with Flash CS3 Professional*, and has written extensively about Flash in magazines such as *SBS Digital Design* and *Macworld*.

Visit the site where Russell shares his Flash-related ideas at www.RussellChun.com.
Adobe Flash Professional CS5 provides a comprehensive authoring environment for creating digital animation and interactive Web sites. Flash is widely used to create engaging applications rich in video, sound, graphics, and animation. You can create content in Flash or import it from other Adobe applications such as Photoshop or Illustrator, quickly design simple animations, and use Adobe ActionScript 3.0 to develop sophisticated interactive projects.

But Adobe Flash Professional is just one product among a suite of Flash CS5 tools. In addition to Flash Professional, Adobe offers Flash Catalyst and Flash Builder. Flash Catalyst is a design tool for rapidly creating expressive interfaces and interactive content without writing code. Flash Builder, formerly known as Flex Builder, is a code-centric environment geared toward developers rather than animators or designers to create interactive content. Although the development platforms are different, all three tools ultimately generate the same end product—Flash content (a SWF file). A Flash SWF file runs in the Flash Player on your browser, in AIR (Adobe Integrated Runtime) on your desktop outside of your browser, or on your mobile phone.

About Classroom in a Book

Adobe Flash Professional CS5 Classroom in a Book is part of the official training series for Adobe graphics and publishing software developed with the support of Adobe product experts. The lessons are designed so you can learn at your own pace. If you’re new to Flash, you’ll learn the fundamental concepts and features you’ll need to use the program. Classroom in a Book also teaches many advanced features, including tips and techniques for using the latest version of this application.

What’s New

The lessons in this book provide opportunities to use some of the new features and improvements in Flash Professional CS5, including:

- The Deco tool, with expanded expressive options to help you create complex patterns and decorations easily and automatically.
• The Text tool, which has been completely overhauled to support more sophisticated layouts such as multiple columns and wrap-around text.

• Spring, a physics simulation option for animating with inverse kinematics.

• Code Snippets, a new panel that provides ready-to-go ActionScript code for your projects and a way to save and share your code with others.

• Live video preview for externally loaded video.

• The new XFL file format, which exposes the Flash file assets and makes it easier for a team of developers to work on a single file.

Prerequisites

Before you begin using Adobe Flash Professional CS5 Classroom in a Book, make sure your system is set up correctly and you’ve installed the required software. You should have a working knowledge of your computer and operating system. You should know how to use the mouse and standard menus and commands, and also how to open, save, and close files. If you need to review these techniques, see the printed or online documentation included with your Microsoft Windows or Apple Mac OS software.

Installing Flash

You must purchase the Adobe Flash Professional CS5 software either as a stand-alone application or as part of the Adobe Creative Suite. The following specifications are the minimum required system configurations.

Windows

• Intel Pentium 4 or AMD Athlon 64 processor

• Microsoft Windows XP with Service Pack 2 (Service Pack 3 recommended); Windows Vista Home Premium, Business, Ultimate, or Enterprise with Service Pack 1; or Windows 7

• 1 GB of RAM

• 3.5 GB of available hard-drive space for installation; additional free space required during installation (cannot install on removable flash-based storage devices)

• 1024 x 768 display (1280 x 800 recommended) with 16-bit video card

• DVD-ROM drive

• QuickTime 7.6.2 software required for multimedia features
Mac OS
- Multicore Intel processor
- Mac OS X v10.5.7 or v10.6
- 1 GB of RAM
- 4 GB of available hard-drive space for installation; additional free space required during installation (cannot install on a volume that uses a case-sensitive file system or on removable flash-based storage devices)
- 1024 x 768 display (1280 x 800 recommended) with 16-bit video card
- DVD-ROM drive
- QuickTime 7.6.2 software required for multimedia features

For updates on system requirements and complete instructions on installing the software, visit www.adobe.com/go/flash_systemreqs.

Install Flash from the Adobe Flash Professional CS5 application DVD onto your hard drive; you cannot run the program from the DVD. Follow the onscreen instructions.

Make sure that your serial number is accessible before installing the application. You can find the serial number on the registration card or on the back of the DVD case.

Copying the Lesson Files

The lessons in Adobe Flash Professional CS5 Classroom in a Book use specific source files, such as image files created in Adobe Illustrator, video files created in Adobe After Effects, audio files, and prepared Flash documents. To complete the lessons in this book, you must copy these files from the Adobe Flash Professional CS5 Classroom in a Book CD (inside the back cover of this book) to your hard drive. Follow these steps to copy the lesson files:

1. On your hard drive, create a new folder in a convenient location and name it FlashProCS5_CIB, following the standard procedure for your operating system:
   - Windows: In Explorer, select the folder or drive in which you want to create the new folder and choose File > New > Folder. Then type the new name.
   - Mac OS: In the Finder, choose File > New Folder. Type the new name and drag the folder to the location you want to use.

   Now, you can copy the source files onto your hard drive.

2. Drag the Lessons folder (which contains folders named Lesson01, Lesson02, and so on) from the Adobe Flash Professional CS5 Classroom in a Book CD onto your hard drive to your new FlashProCS5_CIB folder.
When you begin each lesson, navigate to the folder with that lesson number to access all the assets, sample movies, and other project files you need to complete the lesson.

If you have limited storage space on your computer, you can copy each lesson folder as you need it, and then delete it after you’ve completed the lesson if desired. Some lessons build on preceding lessons: In those cases, a starting project file is provided for you for the second lesson or project. You do not have to save any finished project if you don’t want to or if you have limited hard-drive space.

**Copying the Sample Movies and Projects**

You will create and publish SWF animation files in some lessons in this book. The files in the End folders (01End, 02End, and so on) within the Lesson folders are samples of completed projects for each lesson. Use these files for reference if you want to compare your work in progress with the project files used to generate the sample movies. The end project files vary in size from relatively small to a couple of megabytes, so you can either copy them all now if you have ample storage space or copy just the end project file for each lesson as needed. Then you can delete it when you finish that lesson.

**How to Use the Lessons**

Each lesson in this book provides step-by-step instructions for creating one or more specific elements of a real-world project. Some lessons build on projects created in preceding lessons; most stand alone. All the lessons build on each other in terms of concepts and skills, so the best way to learn from this book is to proceed through the lessons in sequential order. In this book, some techniques and processes are explained and described in detail only the first few times you perform them.

The organization of the lessons is also project oriented rather than feature oriented. That means, for example, that you’ll work with symbols on real-world design projects over several lessons rather than in just one chapter.

**Additional Resources**

*Adobe Flash CS5 Professional Classroom in a Book* is not meant to replace documentation that comes with the program or to be a comprehensive reference for every feature. Only the commands and options used in the lessons are explained in this book. For comprehensive information about program features and tutorials, refer to these resources:

*Adobe Community Help*: Community Help brings together active Adobe product users, Adobe product team members, authors, and experts to give you the most
useful, relevant, and up-to-date information about Adobe products. Whether you’re looking for a code sample or an answer to a problem, have a question about the software, or want to share a useful tip or recipe, you’ll benefit from Community Help. Search results will show you not only content from Adobe, but also from the community.

With Adobe Community Help you can:

• Access up-to-date definitive reference content online and offline
• Find the most relevant content contributed by experts from the Adobe community, on and off Adobe.com
• Comment on, rate, and contribute to content in the Adobe community
• Download Help content directly to your desktop for offline use
• Find related content with dynamic search and navigation tools

To access Community Help: If you have any Adobe CS5 product, then you already have the Community Help application. To invoke Help, choose Help > Flash help. This companion application lets you search and browse Adobe and community content, plus you can comment on and rate any article just like you would in the browser. However, you can also download Adobe Help and language reference content for use offline. You can also subscribe to new content updates (which can be automatically downloaded) so that you’ll always have the most up-to-date content for your Adobe product at all times. You can download the application from www.adobe.com/support/chc/index.html.

Adobe content is updated based on community feedback and contributions. You can contribute in several ways: add comments to content or forums, including links to Web content; publish your own content using Community Publishing; or contribute Cookbook Recipes. Find out how to contribute: www.adobe.com/community/publishing/download.html

See http://community.adobe.com/help/profile/faq.html for answers to frequently asked questions about Community Help.

Adobe Flash CS5 Professional Help and Support: www.adobe.com/support/flash where you can find and browse Help and Support content on adobe.com.

Adobe TV: http://tv.adobe.com is an online video resource for expert instruction and inspiration about Adobe products, including a How To channel to get you started with your product.

Adobe Design Center: www.adobe.com/designcenter offers thoughtful articles on design and design issues, a gallery showcasing the work of top-notch designers, tutorials, and more.

Adobe Developer Connection: www.adobe.com/devnet is your source for technical articles, code samples, and how-to videos that cover Adobe developer products and technologies.
Resources for educators: www.adobe.com/education includes three free curricula that use an integrated approach to teaching Adobe software and can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Forums: http://forums.adobe.com lets you tap into peer-to-peer discussions, questions and answers on Adobe products.

Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a central resource for finding tools, services, extensions, code samples, and more to supplement and extend your Adobe products.

Adobe Flash Professional CS5 product home page: www.adobe.com/products/flash

Adobe Labs: http://labs.adobe.com gives you access to early builds of cutting-edge technology, as well as forums where you can interact with both the Adobe development teams building that technology and other like-minded members of the community.

Adobe Certification

The Adobe training and certification programs are designed to help Adobe customers improve and promote their product-proficiency skills. There are four levels of certification:

- Adobe Certified Associate (ACA)
- Adobe Certified Expert (ACE)
- Adobe Certified Instructor (ACI)
- Adobe Authorized Training Center (AATC)

The Adobe Certified Associate (ACA) credential certifies that individuals have the entry-level skills to plan, design, build, and maintain effective communications using different forms of digital media.

The Adobe Certified Expert program is a way for expert users to upgrade their credentials. You can use Adobe certification as a catalyst for getting a raise, finding a job, or promoting your expertise.

If you are an ACE-level instructor, the Adobe Certified Instructor program takes your skills to the next level and gives you access to a wide range of Adobe resources.


For information on the Adobe Certified programs, visit www.adobe.com/support/certification/main.html.
Accelerate your workflow with Adobe CS Live

Adobe CS Live is a set of online services that harness the connectivity of the web and integrate with Adobe Creative Suite 5 to simplify the creative review process, speed up website compatibility testing, deliver important web user intelligence and more, allowing you to focus on creating your most impactful work. CS Live services are complimentary for a limited time* and can be accessed online or from within Creative Suite 5 applications.

Adobe BrowserLab is for web designers and developers who need to preview and test their web pages on multiple browsers and operating systems. Unlike other browser compatibility solutions, BrowserLab renders screenshots virtually on demand with multiple viewing and diagnostic tools, and can be used with Dreamweaver CS5 to preview local content and different states of interactive pages. Being an online service, BrowserLab has fast development cycles, with greater flexibility for expanded browser support and updated functionality.

Adobe CS Review is for creative professionals who want a new level of efficiency in the creative review process. Unlike other services that offer online review of creative content, only CS Review lets you publish a review to the web directly from within InDesign, Photoshop, Photoshop Extended, and Illustrator and view reviewer comments back in the originating Creative Suite application.

Acrobat.com is for creative professionals who need to work with a cast of colleagues and clients in order to get a creative project from creative brief to final product. Acrobat.com is a set of online services that includes web conferencing, online file sharing and workspaces. Unlike collaborating via email and attending time-consuming in-person meetings, Acrobat.com brings people to your work instead of sending files to people, so you can get the business side of the creative process done faster, together, from any location.

Adobe Story is for creative professionals, producers, and writers working on or with scripts. Story is a collaborative script development tool that turns scripts into metadata that can be used with the Adobe CS5 Production Premium tools to streamline workflows and create video assets.

SiteCatalyst NetAverages is for web and mobile professionals who want to optimize their projects for wider audiences. NetAverages provides intelligence on how users are accessing the web, which helps reduce guesswork early in the creative process. You can access aggregate user data such as browser type, operating system, mobile device profile, screen resolution and more, which can be shown over time. The data is derived from visitor activity to participating Omniture SiteCatalyst customer sites. Unlike other web intelligence solutions, NetAverages innovatively displays data using Flash, creating an engaging experience that is robust yet easy to follow.

You can access CS Live three different ways:

1. Set up access when you register your Creative Suite 5 products and get complimentary access that includes all of the features and workflow benefits of using CS Live with CS5.
2. Set up access by signing up online and get complimentary access to CS Live services for a limited time. Note, this option does not give you access to the services from within your products.
3. Desktop product trials include a 30-day trial of CS Live services.

*CS Live services are complimentary for a limited time. See www.adobe.com/go/cslive for details.
Lesson Overview

In this lesson, you’ll learn how to do the following:

• Animate the position, scale, and rotation of objects
• Adjust the pacing and timing of your animation
• Animate transparency and special effects
• Change the path of the motion
• Create animation inside symbols
• Change the easing of the motion
• Animate in 3D space

This lesson will take approximately two hours to complete. If needed, remove the previous lesson folder from your hard drive and copy the Lesson04 folder onto it.
Use Flash Professional CSS to change almost any aspect of an object—position, color, transparency, size, rotation, and more—over time. Motion tweening is the basic technique of creating animation with symbol instances.
Getting Started

Start by viewing the finished movie file to see the animated title page that you’ll create in this lesson.

1 Double-click the 04End.swf file in the Lesson04/04End folder to play the animation.

The project is an animated splash page for a soon-to-be-released fictional motion picture. In this lesson, you’ll use motion tweens to animate several components on the page: the cityscape, the main actors, several old-fashioned cars, and the main title.

2 Close the 04End.swf file.

3 Double-click the 04Start.fla file in the Lesson04/04Start folder to open the initial project file in Flash. This file is partially completed and already contains many of the graphic elements imported into the Library for you to use.

4 Choose View > Magnification > Fit in Window, or Fit in Window from the view options above the Stage, so that you can see the entire Stage on your computer screen.

5 Choose File > Save As. Name the file 04_workingcopy.fla, and save it in the 04Start folder. Saving a working copy ensures that the original start file will be available if you want to start over.
About Animation

Animation is the movement, or change, of objects through time. Animation can be as simple as moving a box across the Stage from one frame to the next. It can also be much more complex. As you’ll see in this lesson, you can animate many different aspects of a single object. You can change an object’s position on the Stage, change its color or transparency, change its size or its rotation, and even animate the special filters that you saw in the previous lesson. You also have control over an object’s path of motion, and even its easing, which is the way an object accelerates or decelerates.

The basic workflow for animation goes like this: To animate objects in Flash, you select the object on the Stage, right-click/Ctrl-click, and choose Create Motion Tween. Move the red playhead to a different point in time and move the object to a new position. Flash takes care of the rest.

Motion tweens create animation for changes in position on the Stage and for changes in size, color, or other attributes. Motion tweens require you to use a symbol instance. If the object you’ve selected is not a symbol instance, Flash will automatically ask to convert the selection to a symbol. Flash also automatically separates motion tweens on their own layers, which are called Tween layers. There can only be one motion tween per layer without any other element in the layer. Tween layers allow you to change various attributes of your instance at different key points over time. For example, a spaceship could be on the left side of the Stage at the beginning keyframe and at the far-right side of the Stage at an ending keyframe, and the resulting tween would make the spaceship fly across the Stage.

The term “tween” comes from the world of classic animation. Senior animators would be responsible for drawing the beginning and ending poses for their characters. The beginning and ending poses were the keyframes of the animation. Junior animators would then come in and draw the “in-between” frames, or do the “in-betweening.” Hence, “tweening” refers to the smooth transitions between keyframes.
Understanding the Project File

The 04Start.fla file contains a few of the animated elements already or partially completed. Each of the six layers—man, woman, Middle_car, Right_car, footer, and ground—contains an animation. The man and woman layers are in a folder called actors, and the Middle_car and Right_car layers are in a folder called cars.

You’ll be adding more layers to add an animated cityscape, refining the animation of one of the actors, as well as adding a third car and a 3D title. All the necessary graphic elements have been imported into the Library panel. The Stage is set at a generous 1280 pixels by 787 pixels to fill up a high-resolution monitor, and the Stage color is black. You might need to choose a different view option to see the entire Stage. Choose View > Magnification > Fit in Window, or choose Fit in Window from the view options at the top-right corner of the Stage to view the Stage at a magnification percentage that fits your screen.

Animating Position

You’ll start this project by animating the cityscape. It will begin slightly lower than the top edge of the Stage, and then rise slowly until its top is aligned with the top of the Stage.

1 Lock all the existing layers so you don’t accidentally modify them. Create a new layer above the footer layer and rename it city.
2 Drag the bitmap image called cityBG.jpg from the bitmaps folder in the Library panel to the Stage.

3 In the Properties inspector, set the value of X to 0 and the value of Y to 90.
This positions the cityscape image just slightly below the top edge of the Stage.

4 Right-click/Control-click on the cityscape image and choose Create Motion Tween. From the top menu, you can also select Insert > Motion Tween.

5 A dialog box appears warning you that your selected object is not a symbol.
Motion tweens require symbols. Flash asks if you want to convert the selection to a symbol so it can proceed with the motion tween. Click OK.
Flash automatically converts your selection to a symbol, which is stored in your Library panel. Flash also converts the current layer to a Tween layer so you can begin to animate the instance. Tween layers are distinguished by a special icon in front of the layer name, and the frames are tinted blue. Tween layers are reserved for motion tweens, and hence, no drawing is allowed on a Tween layer.

6 Move the red playhead to the end of the tween span at frame 190.

7 Select the instance of the cityscape on the Stage, and while holding down the Shift key, move the instance up the Stage.

Holding down the Shift key constrains the movement to right angles.

8 For more precision, set the value of Y to 0 in the Properties inspector.

A small black triangle appears in frame 190 at the end of the tween span. This indicates a keyframe at the end of the tween. Flash smoothly interpolates the change in position from frame 1 to frame 190 and represents that motion with a motion path. Hide all the other layers to see the results of the motion tween on the cityscape.
Drag the red playhead back and forth at the top of the Timeline to see the smooth motion. You can also choose Control > Play (Enter) to make Flash play the animation.

Animating changes in position is simple, because Flash automatically creates keyframes at the points where you move your instance to new positions. If you want to have an object move to many different points, simply move the red playhead to the desired frame, and then move the object to its new position. Flash takes care of the rest.

### Changing the Pacing and Timing

You can change the duration of the entire tween span or change the timing of the animation by clicking and dragging keyframes on the Timeline.

#### Changing the animation duration

If you want the animation to proceed at a slower pace, taking up a much longer period of time, you need to lengthen the entire tween span between the beginning and end keyframes. If you want to shorten the animation, you need to decrease the tween span. Lengthen or shorten a motion tween by dragging the ends on the Timeline.

1. Move your mouse cursor close to the end of the tween span in the city layer.
   
   Your cursor changes to a double-headed arrow, indicating that you can lengthen or shorten the tween span.

2. Click and drag the end of the tween span back toward frame 60.
   
   Your motion tween shortens to 60 frames, so now the cityscape takes a much shorter time to move.

**Note:** Remove a motion tween by right-clicking/Ctrl-clicking the motion tween on the Timeline or the Stage and choosing Remove Tween.
3 Move your mouse cursor close to the beginning of the tween span (at frame 1).

4 Click and drag the beginning of the frame span forward to frame 10.

Your motion tween begins at an earlier time, so it now only plays from frame 10 to frame 60.

**Adding frames**

You’ll want the last keyframe of your motion tween to hold for the entire duration of the animation, so you’ll need to add frames to make the animation last that long. Add frames by Shift-dragging the end of a tween span.

1 Move your mouse cursor close to the end of the tween span.

2 Hold down the Shift key and click and drag the end of the tween span forward to frame 190.
The last keyframe in the motion tween remains at frame 60, but additional frames are added to frame 190.

Moving keyframes

When you click on a motion tween on the Timeline, the entire span is selected. This allows you to move the entire motion tween forward or backward in time as a single unit. However, if you want to move particular keyframes within a motion tween to change the pacing of the animation, you have to select individual frames. Holding down the Ctrl (Windows)/Command (Mac) key will let you select single frames or a span of frames within a motion tween.

1. Ctrl-click/Command-click on the keyframe at frame 60.
   
   Just the keyframe at frame 60 is selected. A tiny box appears next to your mouse cursor indicating that you can move the keyframe.

2. Click and drag the keyframe to frame 40.

   The last keyframe in the motion tween moves to frame 40, so the motion of the cityscape proceeds quicker.
Animating Transparency

In the previous lesson, you learned how to change the color effect of any symbol instance to change the transparency, tint, or brightness. You can change the color effect of an instance in one keyframe and change the value of the color effect in another keyframe, and Flash will automatically display a smooth change, just as it does with changes in position.

You’ll change the cityscape in the beginning keyframe to be totally transparent but keep the cityscape in the ending keyframe opaque. Flash will create a smooth fade-in effect.

1. Move the red playhead to the first keyframe of the motion tween (frame 10).

2. Select the cityscape instance on the Stage.

3. In the Properties inspector, choose the Alpha option for Color Effect.

4. Set the Alpha value to 0%.
The cityscape instance on the Stage becomes totally transparent.

5 Move the red playhead to the last keyframe of the motion tween (frame 40).

6 Select the cityscape instance on the Stage.

Note: You can also apply a Color Effect through the Motion Editor, as explained later in this lesson. Click the Motion Editor tab next to the Timeline. Click the plus sign next to Color Effect and select Alpha.
7 In the Properties inspector, set the Alpha value to 100%.

The cityscape instance on the Stage becomes totally opaque.

8 Preview the effect by choosing Control > Play (Enter).

Flash interpolates the changes in both position and transparency between the two keyframes.

**Animating Filters**

Filters, which give instances special effects such as blurs and drop shadows, can also be animated. You'll refine the motion tween of the actors next by applying a blur filter to one of them to make it appear as if the camera changes focus. Animating filters is no different than animating changes in position or changes in color effect. You simply set the values for a filter at one keyframe and set different values for the filter at another keyframe, and Flash creates a smooth transition.
1 Make the actors layer folder on the Timeline visible.

2 Lock all the layers on the Timeline except the woman layer.

3 Move the red playhead to the beginning keyframe of the motion tween in the woman layer—at frame 23.

4 Select the instance of the woman on the Stage. You won’t be able to see her because she has an alpha value of 0% (totally transparent), but if you click on the top-right side of the Stage, the transparent instance will be selected.

5 In the Properties inspector, expand the Filters section.

6 Click the Add filter button at the bottom of the Filters section and select Blur.

   The Blur filter is applied to the instance.
7 In the Filters section of the Properties inspector, click the link icon to constrain the blur values to both the x and y directions equally. Set the X and Y Blur values to 20 pixels.

8 Move the red playhead across the entire Timeline to preview the animation.

   The 20-pixel Blur filter is applied to the woman instance throughout the motion tween.

9 Right-click/Ctrl-click on the woman layer at frame 140 and choose Insert Keyframe > Filter.

   A keyframe for filters is established at frame 140.

---

*Note:* You can also apply a Filter through the Motion Editor, as explained later in this lesson. Click the Motion Editor tab next to the Timeline. Click the plus sign next to Filters and select Blur.
10 Move the red playhead to the end of the Timeline at frame 160.

11 Select the instance of the woman on the Stage.

12 In the Properties inspector, change the value of the Blur filter to X=0 and Y=0. The Blur filter changes from the keyframe at frame 140 to the keyframe at 160. Flash creates a smooth transition from a blurry instance to an in-focus instance.
Understanding Property Keyframes

Changes in properties are independent of each other and do not need to be tied to the same keyframes. That is, you can have a keyframe for position, a different keyframe for the color effect, and yet another keyframe for a filter. Managing many different kinds of keyframes can become overwhelming, especially if you want different properties to change at different times during the motion tween. Fortunately, Flash Professional CS5 provides a few helpful tools.

When viewing the tween span, you can choose to view the keyframes of only certain properties. For example, you can choose to view only the position keyframes to see when your object moves. Or, you can choose to view only the filter keyframes to see when there is a filter change. Right-click/Ctrl-click on a motion tween in the Timeline, choose View Keyframes, and then select the desired property among the list. You can also choose All or None to see all the properties or none of the properties.

When inserting a keyframe, you can also insert a keyframe specific to the property you want to change. Right-click/Ctrl-click on a motion tween in the Timeline, choose Insert Keyframes, and then select the desired property.

The Motion Editor is a special panel that displays all the properties of your motion tween visually as lines on a graph. The Motion Editor is helpful when multiple properties are changing at different times. For example, the Motion Editor for the woman is shown here and shows changes in the x-position and Alpha values in the first few frames, and changes in the Blur filter in the last few frames.

You’ll learn more about how to use the Motion Editor later in this lesson.
Animating Transformations

Now you’ll learn how to animate changes in scale or rotation. These kinds of changes are made with the Free Transform tool or with the Transform panel. You’ll add a third car to the project. The car will start small, and then become larger as it moves forward toward the viewer.

1. Lock all the layers on the Timeline.

2. Insert a new layer inside the Cars folder and rename it **Left_car**.

3. Select frame 75 and insert a new keyframe (F6).

4. Drag the movie clip symbol called carLeft from the Library panel to the Stage at frame 75.

5. Select the Free Transform tool.

   The transformation handles appear around the instance on the Stage.
6 While holding down the Shift key, click and drag the corner handle inward to make the car smaller.

7 In the Properties inspector, make sure that the width of the car is about 400 pixels.

8 Alternatively, you can use the Transform panel (Window > Transform) and change the scale of the car to about 29.4%.

9 Move the car to its starting position at about X=710 and Y=488.

10 In the Properties inspector, select Alpha for the Color Effect.

11 Set the value of the Alpha to 0%.

   The car becomes totally transparent.

12 Right-click/Ctrl-click on the car on the Stage and select Create Motion Tween.

   The current layer becomes a Tween layer.
13 Move the red playhead on the Timeline to frame 100.

14 Select the transparent instance of the car, and in the Properties inspector, change the Alpha value to 100%.

A new keyframe is automatically inserted at frame 100 to indicate the change in transparency.

15 Select the Free Transform tool.

16 While holding down the Shift key, click and drag the corner handle outward to make the car larger. For more precision, use the Properties inspector and set the dimensions of the car to width=1379.5 pixels and height=467.8 pixels.

17 Position the car at X=607 and Y=545.
Move the Left_car layer in between the Middle_car and Right_car layers so that the car in the center overlaps the cars on the side.

Flash tweens the change in position and the change in scale from frame 75 to frame 100. Flash also tweens the change in transparency from frame 75 to frame 100.

Changing the Path of the Motion

The motion tween of the left car that you just animated shows a colored line with dots indicating the path of the motion. The path of the motion can be edited easily so that the car travels in a curve, or the path can be moved, scaled, or even rotated just like any other object on the Stage.

To better demonstrate how you can edit the path of the motion, open the sample file 04MotionPath.fla. The file contains a single Tween layer with a rocket ship moving from the top left of the Stage to the bottom right.
**Motion Presets**

If your project involves creating identical motion tweens repeatedly, Flash provides a panel called Motion Presets that can help. The Motion Presets panel (Window > Motion Presets) stores a particular motion tween so you can apply it to different instances on the Stage.

For example, if you want to build a slide show where each image fades out in the same manner, you can save that transition to the Motion Presets panel.

1. Simply select the first motion tween on the Timeline or the instance on the Stage.
2. In the Motion Presets panel, click the Save selection as preset button.
3. Name your motion preset, and it will be saved in the Motion Presets panel.
4. Select a new instance on the Stage and choose the motion preset.
5. Click Apply and your saved motion preset will be applied to the new instance.

Flash provides a number of motion presets that you can use to quickly build sophisticated animations without much effort.

---

**Moving the path of the motion**

You will move the path of the motion so the relative movement of the rocket ship remains the same but its starting and ending positions change.

1. Choose the Selection tool.
2. Click on the path of the motion to select it.

   The path of the motion becomes highlighted when it is selected.
3 Click and drag the motion path to move it to a different place on the Stage. The relative motion and timing of the animation remain the same, but the starting and ending positions are relocated.

![Diagram of motion path being moved](image)

### Changing the scale or rotation of the path
The path of the motion can also be manipulated with the Free Transform tool.

1 Select the path of the motion.
2 Choose the Free Transform tool.

Transformation handles appear around the path of the motion.

![Diagram of transformation handles](image)
3 Scale or rotate the path of the motion as desired. You can make the path smaller or larger, or rotate the path so the rocket ship starts from the bottom left of the Stage and ends at the top right.

![Diagram of rocket ship moving on a curved path.]

**Editing the path of the motion**

Making your objects travel on a curved path is a simple matter. You can either edit the path with Bezier precision using anchor point handles, or you can edit the path in a more intuitive manner with the Selection tool.

1 Choose the Convert Anchor Point tool, which is hidden under the Pen tool.

2 Click on the starting point or the ending point of the motion path on the Stage and drag the control handle out from the anchor point.

![Diagram of rocket ship with anchor point handles.]

The handle on the anchor point controls the curvature of the path.
3 Choose the Subselection tool.

4 Click and drag the handle to edit the curve of the path. Make the rocket ship travel in a wide curve.

**Note:** The path of the motion can also be directly manipulated with the Selection tool. Choose the Selection tool and move it close to the path of the motion. A curved icon appears next to your cursor indicating that you can edit the path. Click and drag the path of the motion to change its curvature.

**Orienting objects to the path**

Sometimes the orientation of the object traveling along the path is important. In the motion picture splash page project, the orientation of the car is constant as it rumbles forward. However, in the rocket ship example, the rocket ship should follow the path with its nose pointed in the direction in which it is heading. The Orient to path option in the Properties inspector gives you this option.
1. Select the motion tween on the Timeline.
2. In the Properties inspector, select the Orient to path option.

Flash inserts keyframes for rotation along the motion tween so that the nose of the rocket ship is oriented to the path of the motion.

**Note:** To direct the nose of the rocket ship, or any other object, along the path of its motion, you must orient its initial position so that it is facing in the direction that you want it to travel. Use the Free Transform tool to rotate its initial position so that it is oriented correctly.

### Swapping Tween Targets

The motion tween model in Flash Professional CS5 is object based. This means that you can easily swap out the target of a motion tween. If, for example, you’d rather see an alien moving around the Stage instead of a rocket ship, you can replace the target of the motion tween with an alien symbol from your Library panel and still preserve the animation.
1 Select the rocket ship on the Stage to select the motion tween.
2 Drag the movie clip symbol of the alien from the Library panel onto the rocket ship.

Flash asks you if you want to replace the existing object with a new object.

3 Click OK.
4 The rocket ship is replaced with the alien.

The motion remains the same, but the target of the motion tween has been swapped.
Note: You can also swap instances in the Properties inspector. Select the object that you want to swap on the Stage. In the Properties inspector, click the Swap button. In the dialog box that appears, choose a new symbol and click OK. Flash will swap the target of the motion tween.

Creating Nested Animations

Often, an object that is animated on the Stage will have its own animation. For example, a butterfly moving across the Stage will have an animation of its wings flapping as it moves. Or the alien that you swapped with the rocket ship could be waving his arms. These kinds of animations are nested animations, because they are contained inside the movie clip symbols. Movie clip symbols have their own Timeline that is independent of the main Timeline.

In this example, you’ll make the alien wave his arms inside the movie clip symbol, so he’ll be waving as he moves across the Stage.

Creating animations inside movie clip symbols

1 In the Library panel, double-click the alien movie clip symbol icon.

You are now in symbol-editing mode for the alien movie clip symbol. The alien is in the middle of the Stage. In the Timeline, the parts of the alien are separated in layers.
2 Choose the Selection tool.

3 Right-click/Ctrl-click on the alien’s right arm and choose Create Motion Tween.

Flash converts the current layer to a Tween layer and inserts one second worth of frames so you can begin to animate the instance.

4 Choose the Free Transform tool.

5 Drag the corner rotation control points to rotate the arm upward to the alien’s shoulder height.

A keyframe is inserted at the end of the motion tween. The right arm rotates smoothly from the resting position to the outstretched position.

6 Move the red playhead back to frame 1.

7 Now create a motion tween for the alien’s other arm. Right-click/Ctrl-click on the left arm and choose Create Motion Tween.

Flash converts the current layer to a Tween layer and inserts one second worth of frames so you can begin to animate the instance.
8 Choose the Free Transform tool.

9 Drag the corner rotation control points to rotate the arm upward to the alien’s shoulder height.

A keyframe is inserted at the end of the motion tween. The left arm rotates smoothly from the resting position to the outstretched position.

10 Select the last frame in all the other layers and insert frames (F5) so that the head, body, and feet all remain on the Stage for the same amount of time as the moving arms.

11 Exit symbol-editing mode by clicking the Scene 1 button at the top-left of the Stage.

Your animation of the alien raising his arms is complete. Wherever you use the movie clip symbol, the alien will continue to play its nested animation.

Note: Animations inside of movie clip symbols won’t play on the main timeline. Choose Control > Test Movie > in Flash Professional to preview nested animations.
Preview the animation by choosing Control > Test Movie > in Flash Professional.

Flash opens a window showing the exported animation. The alien moves along the motion path while the nested animation of his arms moving plays and loops.

**Using the Motion Editor**

The Motion Editor panel provides in-depth information and editing capabilities for all the properties of a motion tween. The Motion Editor is located behind the Timeline and can be accessed by clicking the top tab or by choosing Window > Motion Editor.

On the left side of the Motion Editor, an expandable list of properties is displayed along with their values and easing options. On the right side, a timeline shows various lines and curves representing how those properties change.
Setting the Motion Editor display options

Options for displaying the Motion Editor are listed at the bottom of the panel.

1. Select the alien on the Stage.

2. Open the Motion Editor panel if it is not already visible.

3. Move your cursor over the gray horizontal bar separating the Motion Editor from the Stage.

   Your cursor changes to a double-headed arrow indicating that you can increase or decrease the height of the Motion Editor panel.

4. Click and drag the horizontal bar to increase the height of the Motion Editor panel.

5. Click the triangles to collapse all the properties categories on the left. You can expand or collapse the categories to see only those categories you are interested in.
6 Click and drag on the Viewable Frames icon at the bottom of the Motion Editor to change the number of frames that appear in the timeline. Set the Viewable Frames value to the maximum to see the entire motion tween.

7 Click and drag the Graph Size icon at the bottom of the Motion Editor to change the vertical height of each property that is listed on the left.

8 Click and drag the Expanded Graph Size icon at the bottom of the Motion Editor to change the vertical height of each selected property.

To see how the Expanded Graph Size option affects the display, click the X property under Basic motion. The larger the Expanded Graph Size value, the more of the selected property you can view.
Changing property values

You will change another property of your flapping alien with the Motion Editor and see how easy it is to animate multiple properties independently. For this example, you’ll create a fade-in effect by changing the Alpha property.

1 Next to the Color Effect property, click the Plus icon and choose Alpha.

The Alpha property appears in the Motion Editor under the Color Effect category.

2 Select the Alpha amount.

The Alpha property expands, displaying a black-dotted horizontal line at 100% extending from frame 1 to the end of the timeline. This line represents the opacity of the alien throughout the motion tween.

3 Click on the first keyframe, which is indicated by a black square, and drag it down to 0%. You can also change the Alpha value by clicking and dragging the value next to the Alpha amount.

The alien becomes transparent beginning at frame 1.
Inserting keyframes

Inserting keyframes is easy.

1. Move the red playhead to frame 20.

2. Click the diamond icon to add a keyframe at that point in time for the Alpha property. You can also right-click/Ctrl-click on the graph and choose Insert Keyframe.

A new keyframe for the Alpha property is inserted at frame 20.

3. Click on the second keyframe.

The selected keyframe becomes highlighted.
Drag the second keyframe up to change the Alpha value to 100%.

Flash animates the smooth transition of transparency from frame 1 to frame 20.

**Editing keyframes**

You can easily navigate keyframes and remove them, and you can move keyframes to control the precise timing of each of your transitions.

- Click the left or right arrow beside the diamond-shaped icon to move quickly between keyframes.
- Right-click/Ctrl-click on any keyframe and choose Remove Keyframe to delete a keyframe.
- Select a keyframe and click the yellow diamond to delete the keyframe.
- Shift-click to select multiple contiguous keyframes and move them together.

**Resetting values and deleting properties**

If you’ve made a mistake in setting a property, you can easily reset its value or delete it from the Motion Editor entirely so the property won’t be animated.

1. Click the Reset Values button to reset the property to its default values.
2 Click the Minus button and select Alpha to delete the property from the Motion Editor.

Easing

Easing refers to the way in which a motion tween proceeds. In the most basic sense, it can be thought of as acceleration or deceleration. An object that moves from one side of the Stage to the other side can start off slowly, then build up momentum, and then stop suddenly. Or, the object can start off quickly, and then gradually come to a halt.

Easing is best visualized in the Motion Editor. The graphs that connect one keyframe to another are usually straight lines, which indicate that the change from one value to the next value proceeds linearly. However, if you want a more gradual change from the starting position (known as an ease-in), the line would be curved near the beginning keyframe, indicating a slower start. A gradual slowdown (known as an ease-out) would be represented by a curve near the ending keyframe.

Setting eases of a motion tween

You can create an ease by customizing the curvature of the property graph in the Motion Editor.

1 In the Motion Editor, right-click/Ctrl-click the second keyframe in the Alpha property and choose Smooth point.
Control handles appear from the keyframe, which you can move to change the curvature of the line.

2 Click and drag the control handle to create a smooth curve approaching the 100% Alpha value.

3 Right-click/Ctrl-click the first keyframe in the Alpha property and choose Smooth point.

The transition from 0% to 100% Alpha slows down as it approaches 100% (ease-out).

4 Click and drag the control handle to create a smooth curve as the line begins from 0%.
The transition from 0% to 100% Alpha begins gradually from 0% in addition to slowing down. The total effect of the S-shaped curve is both an ease-in and an ease-out effect.

**Note:** You can also apply ease-in and ease-out effects from the Properties inspector. In the Timeline (not the Motion Editor), select the motion tween. In the Properties inspector, enter a value for the ease between –100 (ease-in) to 100 (ease-out).

**Note:** Eases applied via the Properties inspector will be applied globally to all the properties throughout the entire motion tween. With the Motion Editor, you have precise control over individual properties and eases between keyframes.

### Using preset eases

Easing can be very powerful and can be used to create many specialized motions. For example, a bouncing motion can be created with just two positional keyframes and an ease that moves the object back and forth between the two positions.

For the next example, you’ll return to the motion picture project and add a preset ease to the motion of the car. You’ll make the car shudder up and down to mimic the motion of an idling car. The motion tween will be created inside the movie clip symbol of the car.

1. Continue with your Flash project in progress, 04_workingcopy.fla.
2. In the Library panel, double-click the movie clip symbol called carLeft.

   Flash takes you to symbol-editing mode for the movie clip symbol. Two layers are inside this symbol: the top layer called lights and the bottom layer called smallRumble.

3. Lock the top lights layer.
4 Right-click/Ctrl-click on the car and choose Create Motion Tween.

Flash converts the current layer to a Tween layer so you can begin to animate the instance.

5 Move the red playhead to the end of the Timeline.

6 Choose the Selection tool.

7 Move the car down about 5 pixels.

Flash creates a smooth animation of the car moving down slightly.
Click on the motion tween in the Timeline and open the Motion Editor.

Click the Plus icon on the Eases category and choose Random.

The Random preset ease appears.

Select the Random ease.

The Random ease jumps from one value to the next in random intervals. This is shown graphically as a series of abrupt stair steps.
11 Change the Random value to 15.

The frequency of random jumps increases based on the Random value.

12 Select the Basic motion category.

13 In the Ease pull-down menu next to the Basic motion category, choose Random.

Flash applies the Random ease to the positional changes of the motion tween. Instead of a smooth change in the y-position, Flash makes the car jerk up and down randomly, simulating a rumbling, idling car. Since the animation is nested in a movie clip, choose Control > Test Movie > in Flash Professional to preview the motion.

**Classic Tween Model**

In previous versions of Flash Professional (CS3 and earlier), motion tweens were created by first establishing keyframes in the Timeline, then changing one or more of the properties of the instance, and then applying a motion tween between the two keyframes. If you are more comfortable working with this older way of animating, you can do so by relying on the Classic Tween option. Select the first keyframe containing your instance, and then choose Insert > Classic Tween. Flash applies a classic motion tween to your Timeline. The Motion Editor, however, is not available for classic tweens.
Animating 3D Motion

Finally, you'll add a title and animate it in 3D space. Animating in 3D presents the added complication of a third (z) axis. When you choose the 3D Rotation or 3D Translation tool, you need to be aware of the Global Transform option at the bottom of the Tools panel. The Global Transform option toggles between a global option (button depressed) and a local option (button raised). Moving an object with the global option on makes the transformations relative to the global coordinate system, whereas moving an object with the local option on makes the transformations relative to itself.

1. Click on Scene 1 to return to the main timeline and insert a new layer at the top of the layer stack and rename it title.

<table>
<thead>
<tr>
<th>TIME LINE</th>
<th>MOTION EDITOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td></td>
</tr>
<tr>
<td>cars</td>
<td></td>
</tr>
<tr>
<td>Middle_car</td>
<td></td>
</tr>
<tr>
<td>Left_car</td>
<td></td>
</tr>
<tr>
<td>Right_car</td>
<td></td>
</tr>
<tr>
<td>actors</td>
<td></td>
</tr>
<tr>
<td>man</td>
<td></td>
</tr>
<tr>
<td>woman</td>
<td></td>
</tr>
<tr>
<td>city</td>
<td></td>
</tr>
<tr>
<td>footer</td>
<td></td>
</tr>
<tr>
<td>ground</td>
<td></td>
</tr>
</tbody>
</table>

2. Lock all the other layers.

3. Insert a new keyframe at frame 120.

<table>
<thead>
<tr>
<th>TIME LINE</th>
<th>MOTION EDITOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>title</td>
<td></td>
</tr>
<tr>
<td>cars</td>
<td></td>
</tr>
<tr>
<td>Middle_car</td>
<td></td>
</tr>
<tr>
<td>Left_car</td>
<td></td>
</tr>
<tr>
<td>Right_car</td>
<td></td>
</tr>
<tr>
<td>actors</td>
<td></td>
</tr>
<tr>
<td>man</td>
<td></td>
</tr>
<tr>
<td>woman</td>
<td></td>
</tr>
<tr>
<td>city</td>
<td></td>
</tr>
<tr>
<td>footer</td>
<td></td>
</tr>
<tr>
<td>ground</td>
<td></td>
</tr>
</tbody>
</table>

4. Drag the movie clip symbol called movietitle from the Library panel onto the Stage.

The movie title instance appears in your new layer in the keyframe at frame 120.
5 Position the title at x=180 and y=90.

6 Right-click/​Ctrl-click on the movie title and choose Create Motion Tween. Flash converts the current layer to a Tween layer so you can begin to animate the instance.

7 Move the red playhead to frame 140.

8 Select the 3D Rotation tool.

9 Deselect the Global Transform option at the bottom of the Tools panel.
10 Click and drag the title to rotate it around the $y$-axis (green) so that its angle is at about $-50$ degrees. You can check the rotation values in the Transform panel (Window $>$ Transform).

11 Move the red playhead to the first keyframe at frame 120.

12 Click and drag the title to rotate it around the $y$-axis in the opposite direction so that its angle is at about $25$ degrees and the instance looks like just a sliver.

Flash motion tweens the change in the 3D rotation, so the title appears to swing in three dimensions.
Previewing the Animation

You can quickly preview your animation by “scrubbing” the red playhead back and forth on the Timeline or by choosing Control > Play. You can also choose Window > Toolbars > Controller to display a controller panel with buttons to rewind and play your Timeline.

However, to preview your animation as your audience will see it and to preview any nested animations within movie clip symbols, you should test your movie. Choose Control > Test Movie > in Flash Professional.

Flash exports a SWF file and saves it in the same location as your FLA file. The SWF file is the compressed, final Flash media that you would embed in an HTML page. Flash displays the SWF file in a new window with the exact Stage dimensions and plays your animation.

To exit Test Movie mode, click the Close window button.

*Note:* The exported SWF in Test Movie mode will loop automatically. To prevent the looping in Test Movie mode, choose Control > Loop to deselect the loop option.
Review Questions

1. What are two requirements of a motion tween?
2. What kinds of properties can a motion tween change?
3. What are property keyframes, and why are they important?
4. How can you edit the path of a motion?
5. What are three ways to add easing to a motion tween?

Review Answers

1. A motion tween requires a symbol instance on the Stage and its own layer, which is called a Tween layer. No other tween or drawing object can exist on the Tween layer.

2. A motion tween creates smooth transitions between different keyframes of an object’s location, scale, rotation, transparency, brightness, tint, filter values, or 3D rotation or translation.

3. A keyframe marks a change in one or more of an object’s properties. Keyframes are specific to each property, so that a motion tween can have keyframes for position that are different from keyframes for transparency.

4. To edit the path of a motion, choose the Selection tool and click and drag directly on the path to bend it. You can also choose the Convert Anchor Point tool and Subselection tool to pull out handles at the anchor points. The handles control the curvature of the path.

5. Three ways to add easing to a motion tween include:
   - Select the motion tween on the Timeline and change the Ease value in the Properties inspector.
   - In the Motion Editor, right-click/Ctrl-click on any keyframe to pull out control handles and change the curvature of the graph.
   - Add a preset ease to the Ease category of the Motion Editor and apply it to a property.
This page intentionally left blank
INDEX

NUMBERS
3D motion, animating, 144–146
3D position, changing for objects, 97
3D rotation, changing for objects, 95–96, 98
3D space
  positioning in, 95–100
  x, y, and z axes in, 95
3D Translation tool, using, 98

A
Actions panel
  Actions toolbox, 212
  components of, 211
  Script pane, 211–212
ActionScript 3.0
  Actions panel, 211–212
  arguments, 209
  brackets, 210
  checking syntax, 217
  checking syntax of scripts, 211
  Code Snippets panel, 223–225
  comments (//), 210
  comparing aspects of, 334
  controlling Flash movies with, 361
  curly brackets, 210
  doing multiple replacements in, 228
  dot operator (.), 210
  explained, 10
  Find and Replace command, 228
  formatting code, 217
  functions, 209
  keywords, 209
  methods, 210
  multiline comments (/* */), 210, 225
  navigating Actions panel, 211–212
  objects, 210
  Options button, 211
  overview, 208–209
  parentheses, 210
  properties, 210
  quotation marks, 210, 221
  referencing frame labels in, 221
  Script navigator, 211–212
  scripting syntax, 210–211
  semicolons, 210
  terminology, 209–210
  variables, 209, 267
  writing scripts in Action panel, 211
ActionScript library, merging with SWF file, 238–240
Adobe Application Manager, checking for updates, 40
Adobe certification, levels of, 6
Adobe Community Help, consulting, 5
Adobe Flash. See Flash
Adobe Illustrator. See Illustrator
Adobe Media Encoder, adding video files to, 295–297
Adobe resources, 5–6
After Effects, removing backgrounds in, 313
Align panel, using with objects, 58–59
alpha channels. See transparencies
alpha values, modifying for fills, 66–67
Alt, using with Free Transform tool, 47
Anchor Point tools, using with bones and shapes, 172
anchor points, deleting and adding, 65
animated buttons, using, 230–232. See also buttons
animating
  3D motion, 144–146
  changes in rotation, 119–122
  changes in scale, 119–122
  filters, 114–117
  transformations, 119–122
  transparency, 112–114
animation duration, changing, 109–110
animations
  adding frames to, 110–111
  changing rotation of path, 124–125
  changing scale, 124–125
  of cityscape, 106–109
  creating in movie clip symbols, 231–232
  creating inside movie clips, 129–132
  editing path of motion, 125–126
  motion tweens, 105
  moving keyframes in, 111
  moving path of motion for, 123–124
  nesting, 129–132
orienting objects to path, 126–127
overview, 105
playing at destinations, 226–230
of position, 106–109
previewing, 34–35, 147
stopping, 229–230
swapping tween targets, 127–129
using Motion Presets with, 123
workflow for, 105
armature hierarchy, 157
armatures
adding bones to, 173
authortime and runtime, 176–177
controlling easing for, 177–179
defined, 153
editing, 161, 173
refining spring values for, 190–191
removing bones from, 173
articulated motion, defining bones for, 153–157
audio files
preventing overlapping with video, 312
setting advanced options for, 303–304
authortime armatures, using, 176–177
autoPlay option, changing for video, 309
bones
adding to armatures, 173
armature hierarchy for, 157
defining for articulated motion, 153–157
defining inside shapes, 168–171
defining control points for, 174–175
refining shape behavior for, 174
removing, 161
removing from armatures, 173
cue points. See also synchronized Flash elements, 318–320
described, 301
detecting, 316–319
inserting, 314–316
locating, 299
removing skins for, 321–322
responding to, 316–319
using conditional statements with, 317–318
curves
creating, 63–64
editing, 65
certification, levels of, 6
cityscape, animating, 106–109
codes
applying for gradient transitions, 52
matching for existing objects, 67
colors in Tools panel, options

C
certification, levels of, 6
Character ranges, selecting for external text, 271
characters
changing orientation of, 243
modifying, 244–246
cities, animating, 106–109
Code Snippets panel
using with external content, 337
using with external text, 272–275
using with home button, 223–225
Color Effect, creating via Motion Editor, 113
colors
applying for gradient transitions, 52
cropping video files, 299–301
cue points
adding synchronized Flash elements, 318–320
deleting, 316
described, 301
detecting, 316–319
inserting, 314–316
locating, 299
removing skins for, 321–322
responding to, 316–319
using conditional statements with, 317–318
devices, fonts, using with user-input
downloading performance, testing, 353
drawing modes, 50
drawing tools, availability of, 32
Dreamweaver, inserting Flash movies into, 362
dSL setting, using with download performance, 353
Deco tool
Decorated Brush, 61–62
Flower Brush, 62–63
Symmetry brush, 57–58
decorated brush, using, 61–62
deleting
anchor points, 65
bones, 161
cue points, 316
keyframes in Motion Editor, 137
layers, 19
sound files, 291
destinations. See also keyframes
describing, 301
described, 301
detecting, 316–319
inserting, 314–316
locating, 299
removing skins for, 321–322
responding to, 316–319
using conditional statements with, 317–318
device fonts, using with user-input
downloading performance, testing, 353
drawings
availability of, 32
dreamweaver, inserting Flash movies into, 362
D
damping effects, adding to physics simulation, 191
Deco tool
Decorated Brush, 61–62
Flower Brush, 62–63
Symmetry brush, 57–58
description, 301
detecting, 316–319
inserting, 314–316
locating, 299
removing skins for, 321–322
responding to, 316–319
using conditional statements with, 317–318
descriptions, 318–320
described, 301
detecting, 316–319
inserting, 314–316
locating, 299
removing skins for, 321–322
responding to, 316–319
using conditional statements with, 317–318
device fonts, using with user-input
downloading performance, testing, 353
drawings
availability of, 32
dreamweaver, inserting Flash movies into, 362
DSL setting, using with download performance, 353
B
Bandwidth Profiler
testing download performance, 353
viewing, 352
Bind tool, using to refine shape behavior, 174–175
Bit rate, measurement for sounds, 292
bitmap fill, adding, 54
Bitmap Properties dialog box, displaying, 29
bitmaps
converting to vector graphics, 81
swapping for interactive movies, 202–204
blend effects
overview, 93
using with layers, 78–80
Blur filter
applying, 93–94
applying to instance, 115
buttons
creating for interactive movies, 197–201
using, 76
button instances
naming in interactive movies, 207–208
placing in interactive movies, 205–206
button symbols. See also invisible buttons; symbols
creating for interactive movies, 197–201
Hit keyframe, 201
using, 76
buttons. See also animated buttons
adding sounds to, 293–294
creating event handlers for, 214–217
duplicate for interactive movies, 202
C
certification, levels of, 6
Character ranges, selecting for external text, 271
characters
changing orientation of, 243
modifying, 244–246
cityscape, animating, 106–109
Code Snippets panel
using with external content, 337
using with external text, 272–275
using with home button, 223–225
Color Effect, creating via Motion Editor, 113
colors
applying for gradient transitions, 52
matching for existing objects, 67
Colors area in Tools panel, options in, 32
E

eases
  presets, 140–143
  Random preset, 142
  representing direction of, 178
  setting for motion tweens, 138–140
  using Strength option with, 178
easing, controlling for armatures, 177–179
Edit Envelope dialog box, using with sounds, 287–288
educators, resources for, 5
embedded video, using, 326–328. See also Flash video
encoding options. See video encoding options
Essentials button, location of, 12
event listeners
  adding to movie clips, 336
  creating for buttons, 214–217
  creating for text box, 267
external content
  adding myLoader event listener to, 339
  loading, 334–337
  positioning, 338
  removing, 339
  using Code Snippets panel with, 337
external text. See also text
  embedding fonts, 270–271
  loading and displaying, 272–275
  naming text boxes for, 269–270
  saving content as text-only files, 272
external video, playing back, 305–310. See also video files
Eyedropper tool, using, 67

F
F4V format, encoding video files to, 298
fade-in and fade-out effects, using, 290
files. See also published files
  opening, 10–11
  saving, 11
fills
  changing, 49
  defined, 51
  modifying alpha values of, 66–67
  relationship to shapes, 44
  selecting, 46–47
filters
  animating, 114–117
  applying via Motion Editor, 116
  blur, 93–94
  Clipboard button for, 95
  enabling and disabling for instances, 95
  establishing keyframes for, 116
  options for, 95
  Presets button for, 95
  Quality settings for, 94
Flash
  displaying video in, 295
  finding resources for, 39
  installing on Mac OS, 3
  installing on Windows, 2
  starting, 10–11
  undoing steps in, 33–34
Flash documents, testing, 350–351
Flash Help, using, 39
Flash Lite documents, choosing, 363
Flash movies. See movies for Web
Flash Player, detecting version of, 358
Flash video. See also embedded video; video files
  converting video files to, 297–298
  embedding, 322
  embedding FLV on Timeline, 324–325
  encoding FLV for embedding, 323–324
Flower Brush, using, 62–63
goo and play() command, using, 226, 228–229
Gradient Transform tool, using, 53
gradient transitions, creating, 51–53
graphic symbols, using, 76
graphics, adding for wrapped text, 250–251
green screen, using, 313
guides
  locking, 90
  using with symbol instances, 89–90
gutter, modifying for text, 249

H
Help feature, consulting, 39
hexadecimal numbers, choosing, 45
History panel, undoing steps in, 33–34
Hit keyframe, using with button symbols, 201
home button
  adding button instance, 223
  explained, 222
  using Code Snippets panel for, 223–225
HTML files, creation of, 35–37
hyperlinking text, 259–261

I
Illustrator
  copying and pasting artwork, 75
  FXG file format, 75
  importing layers, 75
  importing symbols, 75
Illustrator files
  editing symbols in, 75
  importing, 73–74
image files
loading dynamically, 336
saving frames as, 362, 364
image formats, availability of, 81
imported images, using, 16
Ink Bottle tool, using, 49
instances. See button instances; symbol instances
interactive movies. See also movies creating button symbols for, 197–201
duplicating buttons for, 202
naming button instances in, 207–208
overview, 196
placing button instances in, 205–206
preparing Timeline for, 212–213
swapping bitmaps for, 202–204
testing button behavior in, 206
interactive navigation
adding stop action, 213
event handlers for buttons, 214–217
inverse kinematics. See also physics simulation
defining bones inside shapes, 168–171
editing bones and armature, 173
editing shapes, 171–172
explained, 153
Spring feature, 185–186
invisible buttons, overview of, 201.
See also button symbols
jagged objects, smoothing, 29
joint speed, changing, 167
joints
changing angle indicators on, 163–164
constraining rotation of, 161–164
constraining translation of, 164–168
JPEG images
importing to Library panel, 15
using, 81
K
keyboard shortcuts
Convert to Symbol command, 77
Copy command, 48
exporting SWF files, 351
frames, 20
Library panel, 14
Paste command, 48
Paste in Place command, 66
previewing movies, 34, 351
Properties inspector, 26
removing frames, 110
Rulers, 89
symbols, 75
keyframes. See also destination keyframes; property keyframes
duplicating containing stop command, 230
editing in Motion Editor, 137
establishing for different shapes, 180–181
establishing for filters, 116
identifying in Timeline, 21
inserting for animations, 118
inserting in layers, 21–22
inserting in Motion Editor, 136–137
moving, 22–23
moving in animations, 111
removing, 23
selecting visual elements on Stage, 231
labels, using on destination keyframes, 220–222
layer folders, creating, 23–24
layers
adding, 17–19
duplicating symbols in, 84
Library
adding folders to, 80, 82
duplicating symbols in, 84
Library panel
accessing, 14
adding items from, 16
features of, 14
importing items to, 15
Line tool
creating dashed lines with, 62
using with patterns and symbols, 56
lines, dashing, 62
linked text boxes
adding content to, 255
creating, 252–254
finding Next link, 259
finding Previous link, 259
Loader object, using with external content, 334–337
Lock Fill option, using with gradient transitions, 52
Lowercase option, using with external text, 271
Mac OS, installing Flash on, 3
main menu button, availability of, 223
mask layers, defining, 341–343
masks
creating, 343–346
defining, 341–343
Media Encoder. See Adobe Media Encoder
Merge drawing mode, described, 50
metadata, adding, 353–356
mobile devices, publishing movies for, 363
Motion Editor
Alpha property, 135
changing property values in, 135
components of, 132
deleting keyframes in, 137
deleting properties in, 137–138
editing keyframes in, 137
features of, 118
Graph Size icons, 134
resetting values in, 137–138
setting display options for, 133–134
using to apply filters, 116
using to create Color Effect, 113
Viewable Frames icon, 134
Motion Presets, using with animations, 123
motion tweens. *See also* path of motion
explained, 105
lengthening and shortening, 109–110
setting easés of, 138–140
movie clip symbols
creating animations in, 231–232
preventing looping in, 132
using, 76, 79
movie clips
adding event listeners to, 336
controlling, 340–341
movies. *See also* interactive movies
copying, 4
previewing, 34–35, 147, 351
publishing, 35–37
publishing for mobile devices, 363
saving, 37–38
movies for Web. *See also* publishing alternatives
changing display settings, 358–361
changing playback settings, 361
controlling with ActionScript, 361
detecting version of Flash Player, 358
Dimensions options for, 358–361
inserting into Dreamweaver, 362
Scale options for, 358–361
specifying Flash file settings, 356–358
myLoader event listener, using, 339

N
Navigation tools, availability of, 32
nodes
defined, 153
isolating rotation of, 159–160
Numerals option, using with external text, 271

O
Object drawing mode, described, 50
objects
in ActionScript 3.0, 210
aligning, 58–59
breaking apart, 60–61
changing 3D position of, 97
changing 3D rotation for, 95–96
converting to shapes, 50
grouping, 54–55, 60–61
matching colors for, 67
smoothing, 29
Option, using with Free Transform tool, 47
Oval tool, creating shapes with, 45–46
Over keyframe option, choosing, 203–204

P
Paint Bucket tool, using, 49
panel group, moving, 28
panels
displaying as icons, 28
docking, 28
expanding, 28
grouping, 28
opening, 28
rearrangement in workspace, 12
unlocking from right side of screen, 28
_parent Target, using with hyperlinked text, 260
Paste command, keyboard shortcut for, 48
Paste in Place command, using, 66
path of motion. *See also* motion tweens
ingedit, 125–126
moving for animations, 123–124
using Free Transform tool with, 124–125
patterns, creating symbols for, 55–56
Pen tool
Anchor Point tools, 172
using to create curves, 63–64
Pencil tool, creating dashed lines with, 62
perspective angle, explained, 98–100
photos, rotating on Stage, 27
Photoshop files
editing after importing, 80
importing, 78–80
physics simulation. *See also* inverse kinematics
adding damping effects, 191
defining bones for armature, 186–187
inserting poses, 189–190
refining armature spring values, 190–191
setting spring strength for bones, 187–188
PNG files, using, 81
poses
clearing, 161
editing on Timeline, 159
inserting, 157–159
inserting for physics simulation, 189–190
moving, 159
removing from layers, 159
preview mode, looping movies in, 35
Primitive drawing mode, described, 50
project file, explained, 106
projectors
creating, 364, 366
and TLF text, 365
projects, copying, 4
Properties inspector
choosing fonts in, 30
choosing text color in, 30–31
easing options in, 177–179
identifying in workspace, 11
opening, 26
positioning objects on Stage, 26–27, 29
property keyframes, overview, 118.
*See also* keyframes
PSD files, using, 81
Publish Settings dialog box, displaying, 354
published files, renaming, 356.
*See also* files publishing alternatives.
*See also* movies for Web
creating projectors, 364, 366
saving frames as images, 362, 364
Punctuation option, using with external text, 271
Rectangle tool, creating shapes with, 45
removeChild() command, using with external content, 339
Retouching tools, availability of, 32
rulers, using with symbol instances, 89–90
runtime armatures, using, 176–177
saving
files, 11
movies, 37–38
workspace, 12
Selection tools
availability of, 32
identifying, 33
using to edit curves, 65
using with armatures, 173
using with path of motion, 126
selections, making, 46–47
_self Target, using with hyperlinked text, 260
shape behavior, refining with Bind tool, 174–175
shape contours, changing, 48–49
shape hints
adding, 183–185
removing, 185
shape tweens, morphing with, 180–182
shapes
changing transparency of, 66–67
converting objects to, 50
creating with Oval tool, 45–46
creating with Rectangle tool, 45
duplicating on Stage, 48
editing, 47–49
editing with bones in, 171–172
fill and stroke of, 44
skins
changing transparency of, 310
removing for cue points, 321–322
using with video files, 307
Smoothing option, using with objects, 29
Snap to Objects option, using with Oval tool, 46
software updates, checking for, 40
sound clips, finding, 284
sound files
deleting, 291
importing, 282–283
sound quality, setting, 291–293
sound settings, overriding, 292
sound sync, options for, 294
SoundMixer.stopAll() command, using, 312
sounds
adding to buttons, 293–294
changing, 291
changing volume of, 289–290
clipping ends of, 286–289
playing on Timeline, 283–285
stopping before starting videos, 312
using Edit Envelope dialog box with, 287–288
Spring feature
effects of, 189
explained, 185–186
spring strength, setting for bones, 187–188
spring values, refining for armatures, 190–191
Stage
adding items to from Library panel, 16
changing properties of, 13–14
duplicating shapes on, 48
features of, 13
identifying in workspace, 11
measuring X and Y values on, 27
positioning objects on, 26–27, 29
repositioning text on, 33
rotating photos on, 27
rotating text on, 33
selecting visual elements on, 231
setting color of, 13–14
setting dimensions of, 13–14
star shape, creating with Deco tool, 57–58
stop action, adding to interactive navigation, 213
stop() command, using with animations, 230
strokes
changing, 49
relationship to shapes, 44
selecting, 46–47
Subselection tools, using to edit curves, 65
Swap Symbol dialog box, displaying, 203
SWF files
changing quality of sounds in, 291–293
creation of, 35–37, 147
exporting, 351
SWZ file
merging ActionScript library with, 238–240
use with TLF Text, 237–238
symbol instances
breaking apart, 86
changing brightness of, 91
changing color effects of, 90–92
changing transparency of, 92
decreasing alpha value of, 90
explained, 74
repositioning, 87–90
resetting rotation and position for, 97
resizing, 87–90
using guides with, 89–90
using rulers with, 89–90
symbols. See also button symbols
button, 76
creating, 77–78
creating for patterns, 55–56
duplicating in Library, 84
editing from Library, 83–84
editing in Illustrator, 75
editing in place, 85–86
graphic, 76
importing from Illustrator, 75
movie clip, 76, 79
overview, 74, 76
swapping for interactive movies, 202–204
types of, 76
using filters with, 93–95
Symmetry brush, using, 57–58
system requirements
for Mac OS, 3
for Windows, 2
Test Movie mode
accessing, 147
preventing looping in, 147
text. See also external text; user-input text
adding multiple columns, 246–249
adding titles, 240–242
Break Apart option, 240
changing dimensions of, 242
changing orientation of, 243
hyperlinking, 259–261
registration of, 242
repositioning on Stage, 33
setting width and height, 242
vertical, 243–244
text boxes
adding content for wrapped text, 255
breaking and relinking, 257–259
changing contents for user-input text, 266–268
defining, 242
deleting from wrapped text, 256–257
inserting in wrapped text, 256–257
linking for wrapped text, 252–254
modifying, 249
naming for external text, 269–270
naming for user-input text, 266
resizing, 249
text color, choosing, 30
Text tool
using, 68
using to add title to animation, 30–31, 33
text wrapping. See wrapping text
Timeline
  adding frames to, 286
  adjusting width of frame cells in, 25
  changing appearance of, 25
  creating more time on, 19–20
  features of, 16–17
  identifying in workspace, 11
  layers in, 16
  location of, 16
  organizing layers in, 23–25
  playing sounds on, 283–285
  preparing for interactive navigation, 212–213
titles
  adding, 240–242
  adding to animation, 30–31, 33
TLF (Text Layout Format) Text
  overview, 237–238
  and projectors, 365
  using, 68
TLF Text library, merging, 238–240
Tools panel
  identifying in workspace, 11
  overview, 32
  selecting tools from, 29–31, 33
Trace Bitmap command, using with caution with, 81
transformations
  animating, 119–122
  global versus local, 98
transition animations, creating, 226–228
transparencies
  animating, 112–114
  creating, 66–67
  importing for video clips, 311
Tween layers, explained, 105
tween span
  lengthening for animations, 109–110
  viewing, 118
tween targets, swapping, 127–129
tweens, Classic option for, 143
Type tools, availability of, 32

U
  Undo command, using, 33–34
  unload() command, using with external content, 339
updates
  checking for, 40
  setting preferences for, 40
  Uppercase option, using with external text, 271
URLRequest object, using with external content, 334–337
user-input text. See also text
  adding display fields, 262–264
  adding static text elements, 261–262
  changing contents of text boxes, 266–268
  device fonts, 264
  embedding fonts, 264–265
  naming text boxes, 266
  testing calculator, 268

W
  Web movies. See movies for Web
  Web sites
    certifications, 6
    Help feature, 39
    program features, 4–6
    resources for educators, 5
    tutorials, 4–6
  Windows, installing Flash on, 2
  workspace
    choosing, 12
    layers in, 11
    Properties Inspector, 11
    saving, 12
    Timeline, 11
    Tools panel, 11
  wrapping text
    adding content to linked text boxes, 255
    adding graphics, 250
    breaking and relinking text boxes, 257–259
    deleting text boxes, 256–257
    inserting text boxes, 256–257
    linking text boxes, 252–254

X
  x axis, using in 3D space, 95, 145
  XFL documents
    modifying, 38
    opening, 38
  XFL format, saving files to, 37–38
  XMP Metadata dialog box, displaying, 355

Y
  y axis, using in 3D space, 95, 145–146

Z
  z axis, using in 3D space, 95, 144–146