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A bonus 2-hour set of Learn Dreamweaver 
CS5 by Video tutorials are included on this 
disc, from video2brain and Adobe Press. 
Learn by Video is one of the most critically 
acclaimed training products on Adobe 
software and is the only Adobe-approved 
video courseware for the Adobe Certifi ed 
Associate Level certifi cation.

Learn by Video 
bonus tutorials

Each lesson has its own 
folder inside the Lessons 
folder. You will need to 
copy these lesson folders to 
your hard drive before you 
can begin each lesson.

Lesson fi les

Th e Adobe Dreamweaver CS5 Classroom in a Book disc includes the lesson fi les that 

you’ll need to complete the exercises in this book, as well as other content to help 

you learn more about Adobe Dreamweaver CS5 and use it with greater effi  ciency 

and ease. Th e diagram below represents the contents of the disc, which should help 

you locate the fi les you need.

WHAT’S ON THE DISC
Here is an overview of the contents of the Classroom in a Book disc

Links to Adobe Community 
Help, product Help and 
Support pages, Adobe 
Press, Adobe certifi cation 
programs, Adobe TV, and 
other useful online resources 
can be found inside a handy 
HTML fi le. Just open it in 
your Web browser and click 
on the links, including a 
special link to this book’s 
product page where you can 
access updates and bonus 
material.
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Adobe® Dreamweaver® CS5 is the industry-leading web authoring program. 

Whether you create websites for a living or plan to create one for your own 

business, Dreamweaver off ers all the tools you need to get professional-

quality results.

About Classroom in a Book

Adobe Dreamweaver CS5 Classroom in a Book® is part of the offi  cial train-

ing series for graphics and publishing software developed with the support of 

Adobe product experts.

Th e lessons are designed so that you can learn at your own pace. If you’re new 

to Dreamweaver, you’ll learn the fundamentals of putting the program to work. 

If you are an experienced user, you’ll fi nd that Classroom in a Book teaches 

many advanced features, including tips and techniques for using the latest 

version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specifi c 

project, you’ll have room for exploration and experimentation. You can follow 

the book from start to fi nish, or complete only those lessons that correspond 

to your interests and needs. Each lesson concludes with a Review section con-

taining questions and answers on the subjects you’ve covered.

Prerequisites

Before using Adobe Dreamweaver CS5 Classroom in a Book, you should have 

a working knowledge of your computer and its operating system. Be sure 

you know how to use the mouse, standard menus, and commands, and also 

how to open, save, and close fi les. If you need to review these techniques, see 

the printed or online documentation that was included with your Microsoft 

Windows or Apple Macintosh operating system.

GETTING STARTED
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Installing the program

Before you perform any exercises in this book, verify that your computer system 

meets the hardware requirements for Dreamweaver CS5, that it’s correctly confi g-

ured, and that all required software is installed.

Adobe Dreamweaver CS5 software is not included on the disc; you must purchase 

it separately as a stand-alone product or as part of one of the Creative Suite editions. 

For complete instructions on installing the software, see the “How to Install” fi le on 

the Adobe Dreamweaver CD.

Copying the Classroom in a Book fi les

Th e Classroom in a Book CD includes folders containing all the fi les necessary for 

the lessons. Each lesson has a folder that contains the fi les and assets needed to 

complete the lesson. You must install these folders on your hard disk to perform 

the exercises in each lesson. It is recommended that you copy all lesson folders to 

your hard drive at once but, to conserve space on your hard disk, you can install 

individual folders for each lesson as you need them. It is vitally important that you 

store all lesson folders within a single folder on your hard drive. If you follow the 

recommended lesson order, this master folder will serve as the local site root folder, 

as described more fully in Lesson 4.

To install the Classroom in a Book fi les:

1 Insert the Adobe Dreamweaver CS5 Classroom in a Book CD into your 

computer’s optical disc drive.

2 Navigate to the CD/DVD drive on your computer. 

3 If you intend to complete all lessons in the book in order, drag the Lessons 

folder to your computer hard drive. Otherwise, skip to step 5.

Th e Lessons folder contains all the individual lesson folders and other assets 

needed for the training.

4 Rename the Lessons folder DW-CIB.

Th is folder will be the local site root folder. 

5 If you desire to perform one or more lessons individually, copy each lesson 

folder to your hard drive as separate folders, as needed. Th en, proceed to the 

“Jumpstart” section for more instructions. 

Th e fi les and folders for each lesson cannot be used interchangeably.
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Recommended lesson order

Th e training herein is designed to take you from A to Z in basic to intermediate 

website design, development, and production. Each new lesson builds on previous 

exercises, using the fi les and assets you create to develop an entire website. It is rec-

ommended that you perform each lesson in sequential order to achieve a successful 

result and the most complete understanding of all aspects of web design. 

Th e ideal training scenario will start in Lesson 1 and proceed through the entire 

book to Lesson 17. Since each lesson builds essential fi les and content for the next, 

once you start this scenario you shouldn’t skip any lessons, or even individual 

exercises. While ideal, this method may not be a practicable scenario for every user. 

So, if desired, individual lessons can be accomplished using the jumpstart method 

described in the next section.

Jumpstart

For users who don’t have the time or inclination to perform each lesson in the book 

in order, or who are having diffi  culty with a particular lesson, a jumpstart method 

is included to facilitate the performance of individual lessons in or out of sequence. 

Once you start using the jumpstart method, you will have to use this method for all 

subsequent lessons. For example, if you want to jumpstart Lesson 6, you will have 

to jumpstart Lesson 7, too. In many instances, essential fi les needed for subsequent 

exercises were built in earlier lessons and exercises and may not be present in a 

jumpstart environment.

Each lesson folder includes all the fi les and assets needed to complete the exercises 

contained within that lesson. Each folder contains fi nished fi les, staged fi les, and 

customized Template and Library fi les. You may think these folders contain seem-

ingly duplicative materials. But these duplicate fi les and assets, in most cases, cannot 

be used interchangeably in other lessons and exercises. Doing so will probably cause 

you to fail to achieve the goal of the exercise. 

Th e jumpstart method for completing individual lessons treats each folder as a 

stand-alone website. To jumpstart a lesson, copy the lesson folder to your hard 

drive and create a new site for that lesson using the Site Setup dialog box. Keep 

your jumpstart sites and assets in their original folders to avoid confl icts. One 

suggestion is to organize the lesson folders, as well as your own site folders, in a 

single webs or sites master folder near the root of your hard drive. But avoid using 

the Dreamweaver application folder or any folders that contain a web server, like 

Apache, ColdFusion, or Internet Information Services (IIS).

Feel free to use the jumpstart method for all lessons if you prefer.
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To set up a jumpstart site, do the following:

1 Choose Site > New Site. 

Th e Site Setup dialog box appears. 

2 In the Site Name fi eld, enter the name of the lesson, such as lesson06.

3 Next to the Local Site Folder fi eld, click the Browse ( ) icon. Navigate to the 

lesson folder you copied from the Adobe Dreamweaver CS5 Classroom in a Book 

CD and click Select/Choose.

4 Click the arrow ( ) next to the Advanced Settings category to reveal the tabs 

listed there. Select the Local Info category.

5 Next to the Default Images Folder fi eld, click the Browse icon. When the dialog 

box opens, navigate to the Images folder contained within the lesson folder and 

click Select/Choose.

6 In the Site Setup dialog box, click Save. 

7 Th e name of the currently active website will appear in the Files panel Show 

pop-up menu. If necessary, press Ctrl-Shift-F/Cmd-Shift-F to display the Files 

panel and select the desired website from the Show menu.

Th ese steps will have to be repeated for each lesson you wish to jumpstart. For a 

more complete description of how to set up a site in Dreamweaver, see Lesson 4, 

“Getting a Quick Start.”

Setting up the workspace

Dreamweaver includes a number of workspaces to accommodate various computer 

confi gurations and individual workfl ows. For this book, the Designer workspace 

is recommended. 

1 In Dreamweaver CS5, locate the Application bar. If necessary, choose Window > 

Application Bar to display it.

2 Th e default workspace is called Designer. If it is not displayed, use the pop-up 

menu in the Application bar to choose it.

Most of the book’s images show the Designer workspace. When you fi nish the lessons 

in this book, experiment using various workspaces to fi nd the one that you prefer.

For a more complete description of the Dreamweaver workspaces, see Lesson 1, 

“Customizing Your Workspace.”
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Windows vs. Macintosh instructions

In most cases, Dreamweaver performs identically in both Windows and Mac OS X. 

Minor diff erences exist between the two versions, mostly due to platform-specifi c 

issues out of the control of the program. Most of these are simply diff erences in 

keyboard shortcuts, how dialog boxes are displayed, and how buttons are named. 

Screen shots alternate between platforms throughout the book. Where specifi c 

commands diff er, they are noted within the text. Windows commands are listed 

fi rst, followed by the Macintosh equivalent, such as Ctrl-C/Cmd-C. Common 

abbreviations are used for all commands whenever possible, as follows:

WINDOWS MACINTOSH

Control = Ctrl Command = Cmd

Alternate = Alt Option = Opt

Finding Dreamweaver information

For complete, up-to-date information about Dreamweaver panels, tools, and other 

application features, visit the Adobe website. Choose Help > Dreamweaver Help. 

Th e Adobe Help application opens and downloads the latest Help fi les from the 

Adobe Community Help website. Th ese fi les are cached locally so you can access 

them even when you are not connected to the Internet. You can also download a 

PDF version of the Dreamweaver Help fi les from the Adobe Help application

For additional information resources, such as tips, techniques, and the latest product 

information, visit www.adobe.com/support/dreamweaver to access the Adobe 

Community Help page.

Checking for updates

Adobe periodically provides software updates. You can obtain these updates using 

Adobe Updater if you have an active Internet connection. 

1 In Dreamweaver, choose Help > Updates. Th e Adobe Updater automatically 

checks for updates for your Adobe software. 

2 In the Adobe Updater dialog box, select the updates you want to install and 

then click Download And Install Updates to install them.

 � Note: 
If Dreamweaver 
detects that you are 
not connected to the 
Internet when you open 
the application, choose 
Help > Dreamweaver 
Help to open the 
Help HTML pages 
that are installed with 
Dreamweaver. For more 
up-to-date information, 
view the online Help 
fi les or download the 
current Dreamweaver 
Help PDF.

 � Note: To choose 
preferences for 
future updates, click 
Preferences. You can 
choose how often 
Adobe Updater should 
check for updates, 
identify applications to 
be updated, and choose 
whether to download 
updates automatically. 
Click OK to accept the 
new settings.

www.adobe.com/support/dreamweaver
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Additional resources

Adobe Dreamweaver CS5 Classroom in a Book is not meant to replace documenta-

tion that comes with the program or to be a comprehensive reference for every 

feature. Only the commands and options used in the lessons are explained in this 

book. For comprehensive information about program features and tutorials, refer 

to these resources:

Adobe Community Help: Community Help brings together active Adobe product 

users, Adobe product team members, authors, and experts to give you the most 

useful, relevant, and up-to-date information about Adobe products. Whether 

you’re looking for a code sample or an answer to a problem, have a question about 

the software, or want to share a useful tip or recipe, you’ll benefi t from Community 

Help. Search results will show you not only content from Adobe, but also from the 

community.

With Adobe Community Help you can:

• Access up-to-date defi nitive reference content online and offl  ine

• Find the most relevant content contributed by experts from the Adobe 

community, on and off  Adobe.com

• Comment on, rate, and contribute to content in the Adobe community

• Download Help content directly to your desktop for offl  ine use

• Find related content with dynamic search and navigation tools

To access Community Help: If you have any Adobe CS5 product, then you 

already have the Community Help application. To invoke Help, choose Help > 

Dreamweaver Help. Th is companion application lets you search and browse Adobe 

and community content, plus you can comment on and rate any article just like 

you would in the browser. However, you can also download Adobe Help and 

language reference content for use offl  ine. You can also subscribe to new content 

updates (which can be automatically downloaded) so that you’ll always have the 

most up-to-date content for your Adobe product at all times. You can download 

the application from www.adobe.com/support/chc/index.html.

Adobe content is updated based on community feedback and contributions. You 

can contribute in several ways: add comments to content or forums, including links 

to web content; publish your own content using Community Publishing; or contrib-

ute Cookbook Recipes. Find out how to contribute: www.adobe.com/community/

publishing/download.html.

See http://community.adobe.com/help/profi le/faq.html for answers to frequently 

asked questions about Community Help.

www.adobe.com/support/chc/index.html
www.adobe.com/community/publishing/download.html
www.adobe.com/community/publishing/download.html
http://community.adobe.com/help/profile/faq.html
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Adobe Dreamweaver Help and Support: www.adobe.com/support/dreamweaver 

is where you can fi nd and browse Help and Support content on adobe.com.

Adobe TV: http://tv.adobe.com is an online video resource for expert instruction 

and inspiration about Adobe products, including a How To channel to get you 

started with your product.

Adobe Design Center: www.adobe.com/designcenter off ers thoughtful articles 

on design and design issues, a gallery showcasing the work of top-notch designers, 

tutorials, and more.

Adobe Developer Connection: www.adobe.com/devnet is your source for techni-

cal articles, code samples, and how-to videos that cover Adobe developer products 

and technologies.

Resources for educators: www.adobe.com/education includes three free curricu-

lums that use an integrated approach to teaching Adobe software and can be used 

to prepare for the Adobe Certifi ed Associate exams.

Also check out these useful links:

Adobe Forums: http://forums.adobe.com lets you tap into peer-to-peer discussions, 

questions, and answers on Adobe products.

Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a central 

resource for fi nding tools, services, extensions, code samples, and more to supple-

ment and extend your Adobe products.

Adobe Dreamweaver CS5 product home page: www.adobe.com/products/

dreamweaver

Adobe Labs: http://labs.adobe.com gives you access to early builds of cutting-edge 

technology, as well as forums where you can interact with both the Adobe devel-

opment teams building that technology and other like-minded members of the 

community.

www.adobe.com/support/dreamweaver
http://tv.adobe.com
www.adobe.com/designcenter
www.adobe.com/devnet
www.adobe.com/education
http://forums.adobe.com
www.adobe.com/cfusion/exchange
http://labs.adobe.com
www.adobe.com/products/dreamweaver
www.adobe.com/products/dreamweaver
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Adobe certifi cation

Th e Adobe training and certifi cation programs are designed to help Adobe 

customers improve and promote their product-profi ciency skills. Th ere are four 

levels of certifi cation:

• Adobe Certifi ed Associate (ACA)

• Adobe Certifi ed Expert (ACE)

• Adobe Certifi ed Instructor (ACI)

• Adobe Authorized Training Center (AATC)

Th e Adobe Certifi ed Associate (ACA) credential certifi es that individuals have the 

entry-level skills to plan, design, build, and maintain eff ective communications 

using diff erent forms of digital media.

Th e Adobe Certifi ed Expert program is a way for expert users to upgrade their 

credentials. You can use Adobe certifi cation as a catalyst for getting a raise, fi nding 

a job, or promoting your expertise. 

If you are an ACE-level instructor, the Adobe Certifi ed Instructor program takes 

your skills to the next level and gives you access to a wide range of Adobe resources.

Adobe Authorized Training Centers off er instructor-led courses and training 

on Adobe products, employing only Adobe Certifi ed Instructors. Check out 

http://partners.adobe.com/public/partnerfi nder/tp/show_fi nd.do for a directory 

of AATCs.

For information on the Adobe Certifi ed programs, visit www.adobe.com/support/

certifi cation/.

http://partners.adobe.com/public/partnerfinder/tp/show_find.do
www.adobe.com/support/certification/
www.adobe.com/support/certification/
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Accelerate your workfl ow with 

Adobe CS Live

Adobe CS Live is a set of online services that harness the connectivity of the web and integrate with 
Adobe Creative Suite 5 to simplify the creative review process, speed up website compatibility testing, 
deliver important web user intelligence, and more, allowing you to focus on creating your most impactful 
work. CS Live services are complimentary for a limited time* and can be accessed online or from within 
Creative Suite 5 applications.

Adobe BrowserLab is for web designers and developers who need to preview and test their web pages 
on multiple browsers and operating systems. Unlike other browser compatibility solutions, BrowserLab 

renders screenshots virtually on demand with multiple viewing and diagnostic tools, and can be used with 
Dreamweaver CS5 to preview local content and diff erent states of interactive pages. Being an online service, 
BrowserLab has fast development cycles, with greater fl exibility for expanded browser support and updated 
functionality.

Adobe CS Review is for creative professionals who want a new level of effi  ciency in the creative review 
process. Unlike other services that off er online review of creative content, only CS Review lets you publish 

a review to the web directly from within InDesign, Photoshop, Photoshop Extended, and Illustrator and view 
reviewer comments back in the originating Creative Suite application.

Acrobat.com is for creative professionals who need to work with a cast of colleagues and clients in order 
to get a creative project from creative brief to fi nal product. Acrobat.com is a set of online services that 

includes web conferencing, online fi le sharing, and workspaces. Unlike collaborating via e-mail and attend-
ing time-consuming in-person meetings, Acrobat.com brings people to your work instead of sending fi les to 
people, so you can get the business side of the creative process done faster, together, from any location.

Adobe Story is for creative professionals, producers, and writers working on or with scripts. Story is a 
collaborative script development tool that turns scripts into metadata that can be used with the Adobe 

CS5 Production Premium tools to streamline workfl ows and create video assets.

SiteCatalyst NetAverages is for web and mobile professionals who want to optimize their projects for 
wider audiences. NetAverages provides intelligence on how users are accessing the web, which helps 

reduce guesswork early in the creative process. You can access aggregate user data such as browser type, 
operating system, mobile device profi le, screen resolution, and more, which can be shown over time. The data is 
derived from visitor activity to participating Omniture SiteCatalyst customer sites. Unlike other web intelligence 
solutions, NetAverages innovatively displays data using Flash, creating an engaging experience that is robust 
yet easy to follow.

You can access CS Live three diff erent ways:

1 Set up access when you register your Creative Suite 5 products and get complimentary access that includes 
all of the features and workfl ow benefi ts of using CS Live with CS5.

2 Sign up online and get complimentary access to CS Live services for a limited time. Note, this option does 
not give you access to the services from within your products.

3 Desktop product trials include a 30-day trial of CS Live services.

*CS Live services are complimentary for a limited time. See www.adobe.com/go/cslive for details.

www.adobe.com/go/cslive
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4 GETTING A QUICK START

Lesson Overview

In this lesson, you’ll be introduced to the Dreamweaver web page 

building features while learning how to work within its workspace. 

You’ll learn how to do the following:

• Set up a site in Dreamweaver

• Create a new page using a CSS layout

• Save a document

• Modify the page title and change text headings

• Insert text from an external document

• Add foreground and background images

• Create, modify, and select CSS styles

• Preview your page in Live view and a browser

Th is lesson will take about 1 hour and 15 minutes to complete. Before 

beginning, make sure you have copied the fi les for Lesson 4 to your hard 

drive as described in the “Getting Started” section at the beginning of 

the book. If you are starting from scratch in this lesson, use the method 

described in the “Jumpstart” section of “Getting Started.”
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Use Dreamweaver’s expertly designed CSS layouts to 
quickly create a standards-based web page, ready for 
your personalized content.
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Defi ning a Dreamweaver site

Th e lessons in this book function within a Dreamweaver site. In Dreamweaver, you 

work with a local site stored in a folder on your hard drive. When you are ready to 

publish your site (see Lesson 17, “Publishing to the Web”), you upload your com-

pleted fi les to a remote site, stored on your web host’s server. Th e folder structures 

and fi les of the local and remote sites are usually mirrors of each other. 

First, set up your local site:

1 Launch Adobe Dreamweaver CS5, if necessary. 

2 Choose Site > New Site, and the Site Setup dialog box appears. 

If you’ve used any previous version of Dreamweaver, you will notice that the Site 

Setup dialog box has been redesigned and simplifi ed. Gone are the Basic and 

Advanced views. Now to create a website in Dreamweaver CS5 you need only to 

name it and select the local site folder:
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3 In the Site Name fi eld, type DW-CIB.

Site names typically relate to a specifi c project or client and will appear in the 

Files panel.

4 Next to the Local Site Folder fi eld, click the folder ( ) icon. When the Choose 

Root Folder dialog box opens, navigate to the DW-CIB folder containing the 

fi les you copied from the Adobe Dreamweaver CS5 Classroom in a Book CD and 

click Select/Choose.

You could click Save at this time and begin working on your new website, but 

we’ll add one more piece of handy information.

5 Click the arrow ( ) next to the Advanced Settings category to reveal the tabs 

listed there. Select the Local Info category.

Although it’s not required, a good policy for site management is to store diff er-

ent fi le types in separate folders. For example, many websites provide individual 

folders for images, PDFs, video, and so on. Dreamweaver assists in this endeavor 

by including an option for a default images folder. Later, as you insert images 

from other places on your computer, Dreamweaver will use this setting to auto-

matically move the images into the site structure.

6 Next to the Default Images Folder fi eld, click the folder ( ) icon. When the 

dialog box opens, navigate to the DW-CIB > images folder containing the fi les 

you copied from the Adobe Dreamweaver CS5 Classroom in a Book CD and 

click Select/Choose.

You’ve entered all the information required to begin your new site. In subse-

quent lessons you’ll add more information to enable you to upload fi les to your 

remote site and to be able to test dynamic web pages.

7 In the Site Setup dialog box, click Save.

Setting up a site is a crucial fi rst step in beginning any project in Dreamweaver. 

Knowing where the site root folder is located determines link pathways and enables 

many site-wide options in Dreamweaver such as Find and Replace.
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Using the Welcome screen

Th e Dreamweaver Welcome screen provides quick access to recent pages, easy 

creation of a range of page types, and a direct connection to several key help topics. 

Th e Welcome screen appears when you fi rst start the program or when no other 

documents are open. Let’s use the Welcome screen to explore ways to create and 

open documents:

1 In the Create New column of the Welcome screen, click HTML to create a new, 

blank HTML page.

2 Choose File > Close.

Th e Welcome screen reappears.

3 In the Open A Recent Item section of the Welcome screen, click the Open button. 

Th is allows you browse for fi les to open in Dreamweaver. Click Cancel.

Th e Welcome screen shows you a list of up to nine of your recently used fi les. 

Recently used fi les are shown in the sample fi gure; however, your installation may 

not display any used fi les at this point. Choosing a fi le from this list is a quick alter-

native to choosing File > Open when you want to edit an existing page you have 

recently opened or created.
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You will use the Welcome screen several times in this book. When you’ve com-

pleted the lessons in this book, you may prefer not to use the Welcome screen. 

If so, you can disable it by selecting the Don’t Show Again option in the lower left 

of the window. You can re-enable the Welcome screen in the General category 

of preferences. 

Selecting a CSS layout

Adobe Dreamweaver CS5 provides 16 diff erent CSS layouts. In this exercise, you’ll 

select and modify one. Th e CSS layouts are carefully built and tested to comply 

with web standards and to work cross-platform in all major browsers with no 

additional changes to the layout. Popular one-, two-, and three-column choices 

are included, specifi ed either in fi xed-width dimensions set in pixels or in relative 

measurements set in percentages:

1 Choose File > New.

2 In the New Document dialog box, from the fi rst column, select Blank Page.

3 In the Page Type column, select HTML. 

Dreamweaver allows you to create a wide range of page types. HTML is the 

page type most commonly used for building basic web pages.

4 In the Layout column, select “1 Column Fixed, Centered, Header And Footer.”

Th e preview for this layout displays a padlock ( ) symbol to indicate that the 

width is fi xed at a set number of pixels. Other layouts display a spring ( ) sym-

bol to indicate that the width will expand or contract with the browser window.

5 Leave all other options at their default settings and click Create. 

Your new page appears in Dreamweaver as a document with fi ller text and default 

coloring. Th is is the document window where you add your own content and 

customize the appearance of the page.
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Saving a page

After you’ve created a page, it’s a good practice to save it immediately:

1 Choose File > Save. Alternatively, you could press Ctrl-S/Cmd-S.

2 When the Save As dialog box appears, navigate to the DW-CIB folder. 

Type greenstart.htm or greenstart.html in the Filename fi eld.

It’s a matter of personal preference whether you use three- or four-letter 

extensions in your fi lenames; either will work fi ne on the web. Just remember 

to be consistent. (Th is book will use .html.)

3 Click Save.

Modifying the page title

As described in Lesson 2, “HTML Basics,” the title of a web page is displayed in 

the browser’s title bar. Page titles are one of the elements used by search engines 

to index and rank websites. It’s important to always change Dreamweaver’s default 

page title of “Untitled Document” to a phrase that describes your specifi c web page:

1 If necessary, choose File > Open Recent > greenstart.html.

2 Click the Design button to view the page in Design view.

3 In the Title fi eld of the document toolbar, select the placeholder text, Untitled 

Document.

4 Type Get a green start with Meridien GreenStart and press Enter/Return.

Changing headings

Dreamweaver’s CSS layouts are populated by sample headings, body text, and 

colors. Placeholder headings and text help you visualize the layout as it will appear 

when your fi nal content is placed on the page. Changing the placeholders is a 

simple process:

1 Double-click the placeholder text, Instructions, to select it. Th en type It’s Easy 

Being Green with GreenStart to replace it.
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Note that the new text remains formatted as an <h1> element.

2 Choose File > Save.

Inserting text

You can change paragraph text as easily as you changed the heading. You can enter 

text manually, but Dreamweaver also allows you to insert text from other sources, 

such as Microsoft Offi  ce:

1 Click the Design button to view the page in Design view. 

2 Choose Window > Files to display the Files panel, if it isn’t visible. 

3 Display the lesson04 folder. Click the triangle ( ) to the left of the folder name 

to reveal its contents. Double-click easygreen.rtf to open it. 

Although Dreamweaver can’t open an RTF fi le, your computer will select a com-

patible application, such as Word, WordPad, TextEdit, or so on, and open the 

RTF fi le.

 � Note: Dreamweaver 
provides a number of 
methods for selecting 
text that operate similar 
to word processing soft-
ware, such as dragging 
the mouse to highlight 
text, double-clicking a 
single word, or triple-
clicking to select an 
entire paragraph.
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4 When the fi le opens, select all the text and press Ctrl-C/Cmd-C to copy the text 

to the clipboard. Do not close the application displaying easygreen.rtf.

Note how the text is formatted in Times New Roman, with indentation, bolding, 

and green highlighting.

5 Switch to Dreamweaver and position the mouse pointer below the header, 

“It’s Easy Being Green with GreenStart.” With the mouse pointer at the beginning 

of the fi rst paragraph element immediately following this heading, click and 

drag to the end of the text in the main content area—so that all the placeholder 

headings and paragraphs are selected—but don’t select the text in the footer.

6 Press Ctrl-V/Cmd-V to paste the text from the clipboard. 

Before proceeding to the next step, it’s important to examine what just hap-

pened. You probably noticed that the pasted text replaced the selection and 

was automatically formatted as a paragraph <p> element. However, although 

the text itself came over successfully, the paragraph indents and font formatting 

didn’t. Besides ignoring the fonts and color, Dreamweaver missed something 

more important: the paragraph breaks.

7 Insert your cursor at the end of the third paragraph “…only a click away.” Click 

the Code view button. Observe the code element that appears at the end of the 

paragraph. 

It turns out that Dreamweaver didn’t completely ignore the paragraph returns, 

but instead of </p> tags it inserted <br /> line break elements. It’s important to 

know that Dreamweaver translates single paragraph returns copied from other 

programs into break codes. Th e trick for producing true HTML <p> elements is 

to insert additional returns between each of the original paragraphs.

8 Switch back to the application displaying easygreen.rtf.

9 Insert the cursor at the end of each paragraph and press Enter/Return to insert 

a second paragraph return.

 � Note: Results may 
diff er when pasting 
text into Dreamweaver, 
depending on the origi-
nating program. Most 
types of font-based 
formatting are ignored, 
but the application of 
bold and italics may be 
honored. For example, 
Word will pass bold 
and italic formatting to 
Dreamweaver; WordPad 
and TextEdit will not.



ADOBE DREAMWEAVER CS5 CLASSROOM IN A BOOK 63

In Word and other programs, you can automate the process of inserting extra 

returns for longer documents by using the Find/Change command to replace 

single paragraph returns with two in a row.

10 Select and copy all the text in easygreen.rtf.

11 Switch to Dreamweaver. Click the Design view button. 

12 Select the improperly formatted text in the main content area. Press Ctrl-V/

Cmd-V to paste from the clipboard.

Th e diff erence between the new and the old text is dramatic. Th e new text 

clearly displays extra space delineating each paragraph.

13 Select any of the newly pasted paragraphs. Click the Code view button. Observe 

the code elements at the beginning and end of each paragraph.

Th e newly pasted text is now properly structured with <p>…</p> tags.

14 Place the cursor in the footer area. Select the placeholder text and type 

Copyright 2010 Meridien GreenStart, All rights reserved to replace it.

Th e placeholder copy is replaced as you type.

15 Press Ctrl-S/Cmd-S to save.

Inserting images

Inserting images and graphics in Dreamweaver is straightforward. Once an image 

has been placed on a page, its image properties, such as alignment, can be adjusted 

using the Property inspector or within the CSS. In this exercise, you will replace the 

image placeholder with a banner graphic and insert an inline image into the 

site content:

1 If necessary, choose File > Open Recent > greenstart.html and click the Design 

button to view the page in Design view. 

2 Select the image placeholder in the header section of the page. Although its 

dimensions are displayed in the placeholder itself, note its width and height 

in the Property inspector. If the Property inspector is not visible, choose 

Window > Properties. 
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Th e placeholder is 180 pixels by 90 pixels in size.

3 Double-click the placeholder.

Th e Select Image Source dialog box appears.

4 Navigate to the DW-CIB > images folder and select banner.jpg. Note the 

dimensions of the image displayed in the dialog box.

Th e banner image is 950 pixels by 200 pixels in size—quite a bit larger than the 

placeholder.

5 Click OK/Choose. 

Th e banner image appears in the layout. 

It is a recommended practice for web designers to enter a brief alternate 

description of images. Th e alternate text, or alt text, is seen when the image is 

not visible. Th e alt text will also appear for users with certain mobile devices, 

screen readers, or other browsing devices that may not see images. You can add 

the alt text using the Property inspector.

6 In the Property inspector Alt fi eld, select the text Add logo here, type 

GreenStart banner in the Alternate Text fi eld. Click OK.

Note the size of the banner in the Property inspector. Although the placeholder 

was only 180 by 90 pixels in size, Dreamweaver ignored these dimensions. Th at’s 

because the size of the placeholder doesn’t determine the size of the inserted 

image; Dreamweaver always honors an image’s actual size.

Note that the banner is not as wide as the predefi ned website structure. You’ll 

adjust this width in an upcoming exercise. Let’s insert an image within the 

page’s main content area.

7 Insert the cursor at the beginning of the paragraph “When people are asked….” 

Choose Insert > Image.
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8 In the Select Image Source dialog box, navigate to the DW-CIB > images folder 

and choose butterfl y.gif. Click OK/Choose. 

9 In the Image Tag Accessibility Attributes dialog box, choose <empty> from the 

Alternate Text menu. 

Web standards recommend that the <empty> attribute should be assigned to 

any graphics used for decorative or spacing purposes, and ones that add no 

specifi c information or semantic meaning to the page content. Assistive readers 

and other devices will ignore images with such a designation.

10 Click OK.

Th e butterfl y appears in the fi rst line of the paragraph and displaces the text in 

an unappealing way. 

You could adjust the image position using the HTML align attribute accessible 

from the Property inspector. But this attribute is deprecated in HTML 4.01 and 

was removed from the HTML 5 specifi cation. Instead, you’ll use a method already 

included with the layout, powered by CSS.

11 With the newly inserted image selected, choose fl trt from the Class pop-up 

menu in the Property inspector.

Th e class fl tlft (abbreviation for fl oat left) aligns the image to the left side of its 

container with text wrapping around it to the right. Th e class fl trt (abbrevia-

tion for fl oat right) aligns the image to the right of its container and forces the 
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text to fl ow around the left side of the image. All 16 CSS sample layouts include 

.fl trt and .fl tlft in their default style sheet.

Float is a CSS relative property that moves an element to the left or right of the 

element containing it. (In this exercise, the container is div.content.) When 

one element fl oats, any subsequent element in the same container will fl ow or 

wrap around it. Th e fl oat attribute essentially overrides, or resets, an element’s 

block attribute (if any), essentially making it perform as an inline element. 

Check out Lesson 3, “CSS Basics,” to learn more about CSS positioning. 

Th e page now contains both text and images. In the next exercise, you will 

improve on the appearance by modifying the CSS styles.

12 Choose File > Save.

Selecting and modifying CSS styles

CSS styles are the current standard for all web styling and layout. In this exer-

cise, you’ll adjust the width of the page, modify the background colors, add a 

background graphic to a page section, and adjust several text attributes. All these 

changes are accomplished using Dreamweaver’s CSS Styles panel.

Changing the page width

You probably noticed that the image inserted in the header section is slightly nar-

rower than the predefi ned page width. Th e width attribute of a web page is typically 

applied either to the <body> element or to a parent <div> element that contains 

the main content. Th e fi rst step to changing the width is to identify the CSS rule 

that is controlling it, which will take some CSS detective work:

1 If necessary, choose File > Open Recent > greenstart.html and click the Design 

button to view the page in Design view. 

2 Insert the cursor anywhere in the page content. Observe the name and order of 

the tag selectors at the bottom of the document window.

Th e tag selector display order directly correlates to the page’s code structure. 

Elements appearing to the left are parents, or containers, of all elements to the 

right. Th e element farthest to the left is the highest in the page structure. As you 



ADOBE DREAMWEAVER CS5 CLASSROOM IN A BOOK 67

can see, the <body> element is highest and <div.container> is second. No 

matter where you click the page, this relationship doesn’t change, so by simple 

deduction you can be certain that one or the other of these two suspects prob-

ably contains the width attribute you’re looking for.

3 Choose Window > CSS Styles, if the panel is not visible and open.

Minimize or close any panels as necessary to give maximum access to the 

CSS Styles panel.

4 In the CSS Styles panel, click the All button to switch from Current view, 

if necessary. 

Th e All view displays the entire style sheet associated with the current page. Th e 

Current view displays only the styles that aff ect a selected element. A document 

must be open to see any styles in the CSS Styles panel.

5 Expand the <style> entry in the CSS Styles panel by clicking the plus symbol

( ) / disclosure triangle ( ). 

6 In the CSS Styles panel, click the body rule. Examine its properties. You may 

have to drag down the bottom border of the CSS Styles panel to see them all.

As displayed, the body rule has attributes for background, color, font, margins, 

and padding, but not for the width. Time to check the other suspect.

7 Click the .container rule. Observe its properties. 

Th is rule features a width attribute of 960 pixels. Since the banner was 950 

pixels in width, it seems clearly to be the culprit we’re looking for. Rules can be 

modifi ed directly in the Properties section of the panel.

 � Note: In this page, 
the style rules are in 
the document head 
section. Dreamweaver 
indicates that styles are 
internal to the docu-
ment with brackets: 
<style>. In later 
lessons you will work 
with styles stored in 
an external style sheet. 
Dreamweaver will list 
these style sheets by 
their fi lenames (for 
example, mystyles.css) 
in the CSS styles panel.
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8 In the Properties section, click the number 960. Type 950 and press Enter/

Return.

Th e web page collapses to the width of the banner graphic.

Changing the page background colors 

As you learned in Lesson 3, a CSS rule can alter the properties and behavior of any 

HTML element, such as <body>. In this exercise you’ll modify the background 

color of the entire page.

1 Click the Design button to view the page in Design view. 

2 In the CSS Styles panel, click the body rule, and then click the Edit Rule ( )

button.

3 When the “CSS Rule Defi nition For body” dialog box appears, select the 

Background category. Click the Background-color color box to display the 

color picker.

4 In the color picker, use the eyedropper to click the white color chip. 

Dreamweaver automatically inserts the hexadecimal value for white, #FFF, in 

the Background-color fi eld. 

 � Note: Hexadecimal 
colors are typically 
written in six characters, 
two characters for 
each color channel: 
red, green, and blue. 
When both characters 
in a pair match, it can 
be abbreviated; for 
example, #003366 can 
be written as #036. 
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5 Click OK to complete the change.

Dreamweaver displays the new color in the Properties section of the CSS Styles 

panel—the body rule background color has now changed from dark gray to 

white. Th e header and footer background colors have not changed. Let’s assign a 

background color to the footer section. 

6 Insert the cursor into the footer section. Observe the tag selectors.

Th e tag <div.footer> appears at the bottom of the document window. 

Although it seemed obvious, don’t assume how an element is styled. Always rely 

on your tag selectors a foolproof way to identify the page structure.

7 In the CSS Styles panel, double-click the .footer rule.

8 Change the Background-color to #060. Click OK.

Th e footer background changes from gray to dark green.

9 Choose File > Save. 

Inserting a graphic background into the footer

Using one solid color over large sections of a page can make for a dull design. But 

intelligent use of gradient images can add a multidimensional fl ourish without unduly 

burdening Internet bandwidth. By combining background colors and background 

images, you can achieve amazing results. While foreground images are inserted 

directly onto the page, background images are placed using CSS. As with many 

other formatting commands, the support of background images using HTML-

based attributes was deprecated in HTML 4.01. In this exercise, you will add a 

background graphic to the footer using CSS to create a three-dimensional eff ect:

1 Click the Design button to view the page in Design view, if necessary. 

2 In the CSS Styles panel, double-click the .footer rule.

3 Select the Background category. Click the Browse button next to the 

Background-image fi eld.

Th e Select Image Source dialog box appears.

4 Navigate to DW-CIB > images and select background.jpg. Observe the image 

dimensions and preview.
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Th e image is 5 pixels by 30 pixels and 2 kilobytes in size. Since the page is 950 

pixels, this graphic could never fi ll the footer unless it was copied and pasted 

hundreds of times. But, such antics are unnecessary with background images; 

they have a special capability called repeat.

5 Click OK/Choose. Click Apply.

Th e background image repeats automatically—both vertically and horizontally

—to fi ll the entire footer. In some cases, a background is not designed to repeat 

in both directions. Th is graphic, for example, was intended to create a rounded 

3D eff ect for the top edge of a <div> element. CSS allows you to control the 

repeat function, such as limiting it to either the vertical or horizontal axis 

among other settings.

6 Choose repeat-x from the Background-repeat fi eld menu. Click Apply.

Th e graphic repeats only horizontally now; it aligns to the top of the <div> 

element by default. But the background color selected earlier doesn’t match the 

graphic; it’s too dark. 

7 Select the Background-color color box to access the Eyedropper tool. Click the 

Eyedropper tool on the lighter of the two shades of green in the footer, which 

enters #090 into the Background-color fi eld. 

8 Click OK.

Th e background color now matches the background image perfectly. Th e result 

is the eff ect of a green container with a 3D rounded top edge. We’ll experiment 

with more dramatic eff ects in later lessons.

9 Choose File > Save. 

Adjusting text fonts, colors, and sizes

CSS gives you tremendous control over page appearance. For example, it’s easy to 

change a page’s overall font formatting and appearance by changing a single rule.

Let’s take a look at the font types:

1 Click the Design button to view the page in Design view, if necessary. 

2 In the CSS Styles panel, double-click the body rule.

3 When the “CSS Rule Defi nition for body“ dialog box opens, observe the entry 

displayed in the Font-family fi eld: Verdana, Arial, Helvetica, sans serif.

Why four typefaces? Can’t Dreamweaver make up its mind?
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Th e answer is a simple, but ingenious, solution to a twofold problem. Not all com-

puters have the same fonts installed, and HTML 4.01 can’t currently embed fonts 

in a web page. Th at means if you chose a single font and it wasn’t installed on the 

visitor’s computer, your carefully designed and formatted web page could immedi-

ately and tragically appear in Courier or some other equally undesirable font. 

Normal browser display

Browser defaulting to 
Courier
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By specifying fonts in groups, the browser is given a second, third, and perhaps 

fourth (or more) choice to default to before it picks for itself (egads!). Some call 

this technique “degrading gracefully.” 

Dreamweaver CS5 off ers more than a dozen predefi ned font groups out of the 

box. If you don’t see a combination you prefer, notice the Edit Font List option 

at the bottom of the Font-Family fi eld menu that allows you to create new 

groups of your own. 

But before you start building your own group, remember this: Your main 

consideration is not to pick your favorite font, but to fi gure out what fonts 

are installed on your visitors’ computers. You may prefer the font Hoefelter 

Allgemeine Bold Condensed, but it’s unlikely that a majority of web users have 

it installed on their computers. By all means select Hoefelter as your fi rst choice, 

just don’t forget to slip in some of the more tried-and-true fonts like Arial, 

Helvetica, Tahoma, Times New Roman, Trebuchet MS, Verdana, and fi nally 

serif and sans serif.

Changing font and color

Using diff erent fonts and colors helps to develop visual interest on a web page. 

You’ll use the CSS Styles panel to change the font type and color:

1 If necessary, choose File > Open Recent > greenstart.html and click the Design 

button to view the page in Design view. 

2 In the CSS Styles panel, double-click the body rule.

3 From the Font-family menu, choose “Trebuchet MS, Arial, Helvetica, sans-serif.” 

Click OK.

You have successfully changed the basic font of the entire web page by editing 

one rule. 

Note that the black footer text is a bit diffi  cult to read against the green back-

ground. You can adjust the footer text color this way, too.

4 In the CSS Styles panel, double-click the .footer rule.

5 In the “CSS Rule Defi nition For .footer” dialog box, select the Type category.

6 Enter #FFF in the Color fi eld. Th e footer text displays in white.

7 Click OK.

Altering text size

In addition to changing the font style and color, as in the previous exercise, you can 

also alter text size with CSS:

1 If necessary, choose File > Open Recent > greenstart.html and click the Design 

button to view the page in Design view. 
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Th e font size is set to 100% for this CSS layout in the body rule. All elements on 

the page will inherit this formatting unless otherwise specifi ed. Let’s change the 

size of the text in the main content area.

2 Insert the cursor in the main content. Observe the tag selectors at the bottom 

of the document window. Identify the <div> element that contains the main 

content itself.

Th e main content is contained in <div.content>.

3 In the CSS Styles panel, double-click the .content rule.

4 In the “CSS Rule Defi nition For .content” dialog box, type 90 in the Font-size 

fi eld, and choose % from the unit of measurement menu. Click OK.

Th e text in <div.content> element now displays at 90 percent of its original size.

5 Choose File > Save.

Using the Property inspector 

Th e Property inspector has traditionally been used to apply quick HTML format-

ting. It now has the ability to create custom CSS formatting, too:

1 Click the Design button to view the page in Design view, if necessary. 

2 If you don’t see the Property inspector docked under the Document window, 

choose Window > Properties.

3 On the left side of the Property inspector, click the HTML button, if necessary, 

to display the HTML formatting commands.

4 Select the name “GreenStart” wherever it appears in the paragraph copy and 

click the B button to apply the <strong> tag.

Th e text “GreenStart” is displayed in bold. Let’s create a custom CSS rule using 

the Property inspector.

5 In the Property inspector, click the CSS button. 

 � Note: If you copied 
and pasted the text 
from Word in the 
exercise earlier in this 
chapter, the text may 
already be formatted 
in bold. Clicking the B 
button in this case will 
toggle the bold format-
ting off . Leave the bold 
formatting in place.
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6 In the main heading, select “Green” in the word “GreenStart”.

7 Type #090 in the Color fi eld and press Enter/Return to change the text’s color 

to match the green color used in the footer.

Th e New CSS Rule dialog box appears. 

8 Choose Class from the Selector Type pop-up menu, if it is not displayed. Type 

green in the Selector Name fi eld. Click OK.

Th e selected text changes color. Note the <span.green> tag selector at the bot-

tom of the document window when you insert the cursor in the formatted text.

9 Click the Code view button and observe the selected code. It should look like this:

<span class="green">Green</span>Start

Dreamweaver created a CSS class and automatically applied it to the selected 

text using the <span> tag. 

10 Click the Design view button. 

11 Locate the word “GreenStart” in the paragraph copy. Select “Green” in the word 

“GreenStart”. In the Property inspector, click the HTML button and choose 

green from the Class menu.
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Th e selected text displays in green. Although the text in the <h1> and <p> 

elements are formatted completely diff erently, the .green class still works as 

desired in both cases.

12 Click the Code view button and observe the selected code. It should look 

like this:

<span class="green"><strong>Green</strong></span><strong>
   Start</strong>

Th is time, not only did Dreamweaver apply the .green class to the word 

“Green”, it also restructured the <strong> tag to comply with standard 

code syntax. 

13 Apply the .green class to the words “Green” or “green” wherever they appear 

on the page.

14 Choose File > Save.

Th ese few examples highlight how useful the Property inspector can be and 

the reason most web designers leave it open at all times while they work.

Previewing a page in Live view

So far you have been working in Dreamweaver using Code and Design view to build 

and format most of the page content. However, Code view ignores the graphical 

display, and Design view doesn’t always display page elements and formatting 

accurately. Th is requires you to switch back and forth from Dreamweaver to the 

browser frequently to preview the code as it will actually appear on the Internet. 

To save time and improve productivity, Dreamweaver has a built-in feature called 

Live view that does a better job generating the page display and virtually eliminates 

the need to switch to the browser. Live view has additional features that will be 

explored in later lessons.

1 If necessary, choose File > Open Recent > greenstart.html and click the Design 

button to view the page in Design view. 

2 In the toolbar, click the Live View button. You may also press Alt-F11/Option-F11 

to enter Live view.

Th e standard Dreamweaver document display is replaced by a live, simulated 

browser display. If the page includes elements such as links, JavaScript, or Flash 

movies, they will be active in Live view. However, you won’t be able to add text 

or images or modify most types of formatting while Live view is active.

3 To resume editing the document, click the Live view button again, or press 

Alt-F11/Option-F11 again.
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Previewing pages in a browser

Although Dreamweaver does an excellent job of rendering web pages in the 

Document window and in Live view, it’s important to always review your pages 

in one or more browsers. Dreamweaver can automatically launch the desired 

browser and load the page, once it has been specifi ed in Dreamweaver’s prefer-

ences. Browsers installed on your computer when Dreamweaver is installed will 

automatically be added to this list. Browsers installed later can be added manually.

1 Choose File > Preview In Browser > Edit Browser List.

Th e Preferences dialog box appears, with the Preview In Browser category 

selected.

2 If your desired browser is not already in the list, click the Add ( ) button to 

add it to the list.

3 In the Add Browser dialog box, leave all fi elds blank and click Browse.

4 When the Select Browser dialog box opens, navigate to the folder containing 

your preferred browser: 

• Windows: All browsers will be installed by default in the Program Files folder.

• Mac: All browsers will be installed by default in the Applications folder.

5 Click Open.

6 In the Add Browser dialog box, in the Name fi eld, type the name you want 

to appear in the browser list, such as Firefox, Internet Explorer, or Safari, if 

necessary.

Can you see the subtle 
variations between 
these views? Remember, 
the only one that 
matters is the browser.

Design view             Live view             Browser display
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7 Select the Primary Browser option to pick the browser that will open when you 

preview a page in your preferred browser. Click OK.

Only one browser can be primary. If another browser was designated primary, 

selecting this option will deselect the previous selection.

8 In the Preferences dialog box, click OK.

9 Select File > Preview in Browser and choose your primary browser to preview 

the current page. 

If you haven’t saved the page, Dreamweaver will remind you to do so.

In the Document window, clicking the Preview/Debug In Browser ( ) button 

allows you to manually select the browser that will preview the open page.

10 After you’ve previewed your new web page, close your browser or simply switch 

back to Dreamweaver.

Congratulations—you’ve created your fi rst full-blown web page in Dreamweaver. 

Using a Dreamweaver CSS layout as a head start, you learned how to modify text, 

change colors, add images, add and modify CSS rules, and quickly produce a 

professional-looking web page. You have previewed the page in Live view and in 

a browser. It’s easy to see how Dreamweaver combines substantial power with 

ease of use.

 � Note: Use the same 
method to add any 
additional browsers 
you may have installed. 
Viewing your pages in 
as many browsers as 
possible is a good test-
ing practice.
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Review questions

1 What’s the advantage in using a CSS layout?

2 How can you use the tag selectors to determine what CSS element to edit?

3 How do you change the background color in a page section?

4 What special capability does a background image have, and how can you use it to 

create special eff ects?

5 How can you create custom CSS formatting using the Property inspector?

Review answers

1 Th e CSS layouts included with Dreamweaver have been carefully built and tested to 

work trouble-free in all major browsers.

2 When you insert the cursor anywhere in the page content, the names and the order 

of the elements in the tag selector display directly correlates to the structure of the 

HTML elements at that position, with the highest parent element farthest to the left.

3 Double-click the CSS rule that formats the element and enter a color into the 

Background-color fi eld of the CSS Rule Defi nition dialog box. Click OK. 

4 Background images can repeat multiple times, both vertically and horizontally. By 

combining them with background color, you can create special eff ects, like 3D.

5 In the Property inspector, click the CSS button. Select text or an object within the web 

page and then choose any of the formatting commands in the inspector. Dreamweaver 

will create a custom CSS rule based on the selection and formatting.
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SYMBOLS
"\r\n," for inserting new paragraphs, 

316–318

. "/ " element, 223, 236

. (period) character

combining text and data variable, 316

declaring CSS class selectors, 51

in rule names, 178

+ (plus) icon

in Bindings panel, 355, 363

in Databases panel, 346

in Server Behaviors panel, 361, 367, 370

# (hash mark)

creating hyperlink placeholder, 117

declaring CSS id selector, 51

enabling links, 222, 260

jumping to top of page, 230

in rule names, 178

$ (dollar sign)

declaring variables in PHP, 316

removing to update HTML data, 334–336

<!--.-->

in creating Library items and, 146

in inserting SSIs, 151

tag functions of, 48

A
<a>

hyperlink anchor, 218

pseudoclass modifi cation of, 116

tag functions of, 48

a:active

hyperlink pseudoclass, 116, 120

predefi ned rule function, 109

AATC (Adobe Authorized Training Center), 

xvi

absolute hyperlinks, 218–219

ACA (Adobe Certifi ed Associate), xvi

Accordion widgets. see Spry Accordion 

widgets

.AccordionPanelTab class

accessing Live Code and, 390

customizing Spry Accordion and, 

272–274

working with related fi les, 392

ACE (Adobe Certifi ed Expert), xvi

ACI (Adobe Certifi ed Instructor), xvi

Acrobat.com, xvii

action attribute, of <form> tag, 292

Action fi eld, 313–314

Active Server Pages language. see ASP 

(Active Server Pages) scripting 

language

Add New Server icon

establishing remote sites and, 399, 403

setting up testing servers and, 341

Add Panel icon, 271

Adobe Authorized Training Center (AATC), 

xvi

Adobe Bridge, 202–203

Adobe BrowserLab, xvii

Adobe Certifi ed Associate (ACA), xvi

Adobe Certifi ed Expert (ACE), xvi

Adobe Certifi ed Instructor (ACI), xvi

Adobe Community Help, xiv

Adobe CS Live, online services, xvii

Adobe CS Review, xvii

Adobe Design Center, xv

Adobe Developer Connection, xv

Adobe Dreamweaver CS3 with ASP, 

ColdFusion, and PHP (Bardzell and 

Flynn), 318, 340

Adobe Dreamweaver CS5 product home 

page, xv

Adobe Dreamweaver Help and Support, xv

Adobe Fireworks

copying/pasting from, 209–211

creating mockups in, 87

Adobe Flash CS5 Video Encoder, 283

Adobe Flash Professional CS5 Classroom in 

a Book, 280

Adobe Forums, xv

Adobe Help application, xiii

Adobe Labs, xv

Adobe Marketplace & Exchange

resource for tools, services, extensions 

and code samples, xv

web design resources, 260–261

Adobe Photoshop (PSD)

cloaked fi les, 405

copying/pasting from, 209–211

creating mockups in, 87

updating images in, 207–208

Adobe Story, xvii

Adobe TV, xv

Adobe Updater, xiii

a:hover

customizing Spry menu bar and, 246–247

hyperlink pseudoclass, 116

modifying hyperlink behavior, 118–120

predefi ned rule function, 109

Ajax (Asynchronous JavaScript and XML)

features of, 233

real time updating of, 328

Spry framework combined with, 326

Align attribute, 65, 199–200

a:link

hyperlink pseudoclass, 116

modifying hyperlink behavior, 118

predefi ned rule function, 109

Allow Multiple option, 311

alpha transparency

in graphic design, 195

in PNG, 196

alphanumeric characters

for number Spry data types, 330

for text fi elds, 296

alternative content, 281–282

Alternative FTP Move Method, 400

anchor code, 230–231

animation. see also graphics

Flash, adding to web pages, 279–283

with GIF, 195

AP div

creating custom ids, 113

inserting <div> components and, 93–94

as unique <div> element, 115

Application bar

location of, 4

setting up workspace and, xii

Th e Art & Science of CSS (Snook), 52

ASP (Active Server Pages) scripting language

adding repeat regions using, 361–362

creating a recordset using, 354–358

creating detail pages using, 374–377

creating dynamic tables using, 362–363

creating master page sets using, 363–365

creating record paging behavior using, 

368–369

displaying data using, 358–360

displaying images dynamically using, 

365–367

displaying multiple items using, 367–368

displaying record counts using, 371

features of, 339

hiding paging controls using, 369–370

inserting go-to-detail-page behavior 

using, 374

staging fi les on testing servers using, 

360–361

styling dynamic data using, 371–374

supporting, 318

Assets panel

inserting images with, 198–199

inserting Spry menus as Library items 

and, 250–254

Library items in, 145

for updating templates, 141

Asynchronous JavaScript and XML. see Ajax 

(Asynchronous JavaScript and XML)

At Home tab, 389, 390

Attach External Style Sheet dialog box

for converting style sheet for print, 

126–127

styling forms and, 319–321

attributes. see also specifi c attributes

hyperlink, 218

Spry, 359

Auto Indent, 383

Automatically Upload Files To Server On 

Save option

for remote FTP site, 401

INDEX



ADOBE DREAMWEAVER CS5 CLASSROOM IN A BOOK 417

for remote site on local/network web 

server, 404

a:visited

hyperlink pseudoclass, 116

modifying hyperlink behavior and, 

118–119

predefi ned rule function, 109

B
background colors

changing with CSS Styles panel, 68–69

for creating faux columns, 121–123

customizing Spry Accordion, 272

of menu items, 99–100

modifying, 96–97

removing for printing, 128–129

styling Spry tables and, 333–334

background, HTML default item, 42, 49

background images

adding to header, 91–92

customizing Spry Accordion, 272

inserting into footer, 69–70

removing for printing, 128–129

banner

adding as background image, 91–92

Flash, adding to web pages, 279–283

modifying page width to match, 96–97

behaviors. see also specifi c behaviors

Dreamweaver. see Dreamweaver 

behaviors

hyperlink, 118–121

Berners-Lee, Tim, 22–23

Bindings panel

creating a recordset and, 355–358

creating detail pages and, 375–377

creating master page sets and, 363–365

bit depth, 194

block elements

defi ned, 26, 31

formatting size of, 48–49

Blockquote button, 240

<blockquote> elements

HTML tag functions, 32

for text indents, 167

Blur option, 299

<body> element

HTML tag functions, 32

in web page structure, 27

writing HTML code and, 23

body rule

changing background colors and, 68–69

changing page width and, 67

defi ning structural elements, 109

body text, HTML default item, 42

books

on CSS formatting, 52

on HTML, 31

border-collapse property, 175

borders

in CSS box model, 41

customizing Spry Accordion, 272–273

deleting Spry menu bar, 244–245

for images formatted with links, 226

object formatting of, 49

removing for printing, 129

styling table cells and, 176–177

styling tables and, 174–175

for text indents, 169–170

box model, CSS, 41

<br />

HTML tag functions, 32

inserting text and, 62

Brightness and Contrast, graphic tool, 214

Browse For File icon

for creating image-based links, 225–226

for creating internal links, 223–224

browser

checking compatibility of, 102

creating external links and, 226–227

graphics resolution for, 193

HTML elements and, 42–43

previewing behaviors in, 261–262

previewing Flash elements in, 278–279

previewing forms in, 290–291

previewing graphics in, 196–197

previewing links in, 219–222

previewing page text in, 160–162

previewing template-based page in, 

134–135

previewing web pages in, 76–77, 88, 106

putting site online and, 412

browser-compatability check, 409

Browser Compatibility report panel, 255

Browser Navigation toolbar, 4

Bulletproof Web Design (Cederholm), 52

button(s)

Data Sources, 365

HTML element, on online forms, 292

radio, 292, 294, 306–307

submit, 311–312

C
<caption> elements

adding/formatting, 182–183

styling Spry tables and, 334

cascade theory, 44–45

cascading style sheets. see CSS (cascading 

style sheets)

case-sensitivity

of FTP user name/password, 399

in Windows/Linux/Unix servers, 341

cell phones, for Internet access/usage, 83–84

cells

adjusting vertical alignment in table, 

181–182

controlling column width in table, 

178–179

styling table, 174–178

cellspacing attribute, 175

certifi cation, Adobe, xvi

Change option, 299

Char Width fi eld, 309

character entities, HTML, 33

Check Spelling dialog box, 184–185

checkboxes

<input> tag and, 294

inserting, 304–305

for online forms, 292

child pages

<caption> elements as, 182

producing, 138–140

class selectors, 51

classes

creating custom, 111–113

creating dynamic tables for, 362–363

Classic workspace, 11–12

Classroom in a Book

introduction to, ix

recommended lesson order, xi

client-based functionality, 228

cloaked folders/fi les

putting site online and, 411–412

setting up remote sites and, 405–406

closing tags, 23, 218

code-hints menu, 386–388

Code Navigator

correcting styling diffi  culties, 112

editing CSS using, 248–249

locating rules with, 392

modifying content/formatting, 98–99

working with, 388–389

Code view

adding/formatting <caption> elements 

in, 182

applying/removing classes in, 112–113

creating lists in, 166–167

creating SSI in, 150–151

editing Library items in, 146

enforcing tabbing order in, 313

features of, 5–6

fi nding/replacing text in, 187–188

location of, 4

modifying formatting in, 98

options, 382–383

code, working with

accessing Live Code, 389–391

accessing Split Code view, 393

adding comments to code, 393–394

adding new code, 386–388

collapsing code, 384–385

expanding code, 385–386

overview, 380–381

review, 395

selecting code elements, 383–384

tools for, 382–383

using Code Navigator, 388–389

using Inspect mode, 391–392

working in related fi les, 392

Coder workspace, 12

Coding toolbar

expanding code and, 396

location of, 4, 13–14

selecting code and, 384–385

ColdFusion scripting language

adding repeat regions using, 361–362

creating a recordset using, 354–358
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creating detail pages using, 374–377

creating dynamic tables using, 362–363

creating master page sets using, 363–365

creating record paging behavior using, 

368–369

displaying data using, 358–360

displaying images dynamically using, 

365–367

displaying multiple items using, 367–368

displaying record counts using, 371

features of, 339

hiding paging controls using, 369–370

inserting go-to-detail-page behavior 

using, 374

staging fi les on testing servers using, 

360–361

styling dynamic data using, 371–374

supporting, 318

Collapse Full Tag icon, 385

color(s)

adjusting text, 70–72

changing background, 68–69

customizing Spry menu bar, 246–247

on menu button borders, 120–121

modifying background, 96–97

in raster graphics, 194–195

styling forms and, 320

columns

controlling width of, 178–179

copying/pasting tables and, 173

creating custom classes for, 180–181

creating faux, 121–123

creating tables and, 171–172

in database design, 343

formatting for, 176–178

in paging behaviors, 368–369

styling for Date and Cost, 333–334

for XML-based Spry tables, 336–338

comma-separated values (CSV) fi le, 180–181

comments

adding to codes, 393–394

function of, 109

compound CSS rule

creating, 320–321

styling dynamic data and, 371–374

compression

graphic quality and, 204–205

with PNG and JPEG, 196

Connects To Remote Host icon, 411

.container rule

changing page width, 67–68

defi ning structural elements, 109

modifying page width/background color, 

96–97

.content .productmaster class, 371–374

.content rule

adding forms to pages and, 294–295

altering text size, 72–73

creating descendant selectors and, 

110–111

defi ning structural elements and, 109

Flash banner animation and, 282–283

modifying page width and, 96–97

for styling tables, 174

.content table rule

styling table cells and, 176

styling tables and, 175

.content td rule

adjusting vertical alignment and, 182

styling table cells and, 176–177

.content th rule

adjusting vertical alignment and, 182

controlling column width and, 178

styling table cells and, 176–177

.content .w100 rule

controlling column width and, 178–179

inserting tables and, 180–181

copy and paste method

for inserting images, 209–211

for moving tables, 173

for transferring code, 188

Copy Dependent Files dialog box, 285

Creative Suite applications

Adobe Bridge and, 202–203

drag and drop capabilities in, 211–212

Crop, graphic tool, 214

CS Live services, xvii

CSS (cascading style sheets) basics

box model, 41

creating class selectors, 51

creating ID selectors, 51

formatting multiple elements, 50

formatting objects, 47–50

formatting text, 44–47

HTML defaults, 42–43

HTML vs. CSS formatting, 39–40

introduction to, 38–39

overview, 36–37

recommended books on, 52

review, 53

CSS class selectors, 51

CSS classes

adding new code and, 387–388

adjusting image positions with, 199–200

creating custom, 111–113

CSS code

CSS Styles panel and, 107

editing using Code Navigator, 248–249

CSS formatting

cascade theory, 44–45

descendant theory, 46

inheritance theory, 45–46

locating/editing with Inspect mode, 

393–394

rule construction, 44

specifi city theory, 47

CSS ID selectors

creating, 51

creating custom, 113–115

in CSS rule construction, 44

as link targets, 232

CSS layout. see also web page layout, 

creating

modifying existing, 88–91

selecting, 59

CSS panel location, 4

CSS Property inspector, 17

CSS rule construction, 44–47

CSS Rule Defi nition for body dialog box, 

68–69

CSS Rule Defi nition for .content .profile 

dialog box, 168–169

CSS rules

creating custom, 268–269

creating new, 110–115

moving to external style sheet, 123–124

working with, 106–109

CSS style sheets

creating custom, 319–321

creating for other media types. see print 

style sheet creation

modifying SpryMenuBarVertical, 

241–247

moving rules to external, 123–124

CSS Styles panel

changing background colors using, 68–69

changing page width using, 66–68

customizing Spry Accordion and, 

272–274

inserting graphic background using, 69–70

moving rules to external style sheet using, 

123–124

styling forms and, 319–321

styling Spry tables and, 333–334

working with, 106–109

CSS: Th e Missing Manual (McFarland), 52

CSS Web Site Design Hands-On Training 

(Meyer), 52

CSS, working with

creating custom classes, 111–113

creating custom ids, 113–115

creating descendant selectors, 110–111

creating faux columns, 121–123

creating interactive menus, 115–118

creating style sheets for print, 124–130

modifying hyperlink behavior, 118–121

moving rules to external style sheet, 

123–124

overview, 104–105

previewing completed page, 106

putting site online and, 411

review, 131

working with CSS Styles panel, 106–109

CSV (comma-separated values) fi le, 180–181

custom classes

creating, 111–113

inserting tables and, 180–181

custom CSS rules, 110–115, 268–269

custom dictionary, 184–185

custom IDs, 113–115

custom keyboard shortcuts, 14–16

custom style sheets, 319–321

custom workspace, 14

customer information, in database design, 

344

customers, website, 82–84
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D
data. see also online data, working with

emailing, 315–318

HTML, 334–336

MS Excel, 180–181

processing, 313–314

styling, 371–374

data placeholder

converting, 360

creating dynamic tables and, 362–363

repeat regions and, 361–362

updating, 335–336

Data Sources button, 365

data tables, Spry

discarding, 358–359

rebuilding, 362–363

styling, 333–334

database applications, building

connecting to, 344–348

design basics, 343–344

displaying data from, 358–360

overview, 343

Databases panel

connecting to MySQL and, 346

creating master page sets and, 363

date Spry data type, 330, 331

declarations, in CSS rule construction, 44

default background, 42, 49

default images folder, 56–57

dependent fi les

for playing Flash components, 285

putting site online and, 410–412

staging on testing servers, 360–361

descendant selectors

creating, 110–111

creating interactive menus and, 115–118

descendant theory, 46

Design view

adding/formatting <caption> elements 

in, 182–183

applying/removing classes in, 112–113

creating lists in, 166

editing Library items in, 146

features of, 5

fi nding/replacing text in, 187

location of, 4

previewing web pages in, 76

Style Rendering toolbar in, 125–126

viewing Code Navigator editing in, 249

viewing CSS rules in, 107

viewing SSIs in, 152

Designer workspace

for Classroom in a Book, xii

features of, 13

detail pages

creating, 374–377

inserting special behavior and, 374

dialog boxes. see also specifi c dialog boxes, 

261

digital cameras, 196

display, of records

hiding paging controls and, 369–370

of record counts, 371

dithering, 194

<div> elements

AP div, 115

collapsing code based on, 385

for columnar designs, 121–123

inserting editable regions in, 137

inserting in web page layout, 93–96

tag selectors for, 384

for text indents, 168

Document title bar, 4

Document toolbar, 4, 13–14

dollar sign ($)

declaring variables in PHP, 316

removing to update HTML data, 334–336

Don’t Show Again option, 59

drag and drop method, 211–212

Dreamweaver behaviors

adding to hyperlinks, 268–269

applying, 265–266

features of, 260–261

previewing, 261–262

removing applied, 267–268

working with, 263–265

Dreamweaver Exchange (online), 260

Dreamweaver Help PDF, xiii

Dreamweaver information, xiii

Dreamweaver local root site

Lessons folder for, x

setting up, 56–57

uploading fi les to remote site. see 

websites, publishing of

Dreamweaver software installation, x

Dreamweaver web page, quick start

adjusting text font/color/size, 70–73

changing headings, 60–61

inserting images, 63–66

inserting text, 61–63

overview, 54–55

previewing page in Live view, 75

previewing pages in browser, 76–77

review, 78

saving page/modifying title, 60

selecting CSS layout, 59

selecting/modifying CSS styles, 66–70

setting up Dreamweaver site, 56–57

using Property inspector, 73–75

using Welcome screen, 58–59

DW-CIB, Lessons folder, x

dynamic content

elements in templates, 136, 144

putting site online and, 412

styling, 371–374

working with, 326

dynamic images, 365–367

dynamic pages, building with data

adding repeat regions, 361–362

creating a recordset, 354–358

creating detail pages, 374–377

creating dynamic tables for classes/

seminars, 362–363

creating master page sets, 363–365

creating record paging behavior, 368–369

displaying data from databases, 358–360

displaying images dynamically, 365–367

displaying multiple items, 367–368

displaying record counts, 371

hiding unneeded paging controls, 

369–370

inserting go-to-detail-page behavior, 374

overview, 352–353

review, 378

staging fi les on testing servers, 360–361

styling dynamic data, 371–374

dynamic placeholders, 374

dynamic tables, 362–363

E
e-mail

hyperlinks, setting up, 227–228

sending form data by, 315–318

Edit, graphic tool, 214

Edit Image Settings, graphic tool, 214

editable regions

function of, 134–135, 136

inserting, 137–138

8-bit palette

with GIF, 195

in graphics color, 194

elements. see also specifi c elements

empty, 32

HTML, 47–50

order of in CSS styling, 90

targeting page, 229–230

working with list/menu, 309–311

<em>

applying inline formatting and, 26

creating password text fi elds and, 302

HTML tag functions, 32

em-width containers, 243

Email Link dialog box, 228

<embed> elements, 282

empty tags, 23

Enable File Check-Out option

for remote FTP site, 401–402

for remote site on local/network web 

server, 404

entities

function of, 25

HTML character, 33

Th e Essential Guide to Dreamweaver CS4 

with CSS. Ajax, and PHP (Powers), 

318

Events table placeholder, 358–360

Extensible Markup Language (XML) data, 

336–338

extensions

for ASP or ColdFusion coding, 314

automatic adding of correct, 347

for creating home pages, 407

for FLV fi les, 283
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for PHP coding, 315

saving pages and, 60

supporting SSI functionality, 151

external CSS style sheet, 123–124

external hyperlinks

creating, 226–227

function of, 218

F
faux columns, 121–123

fi eld(s)

in database design, 343

<form> elements and, 293

including Spry text, 298–300

sets, creating in forms, 300–301

text. see text fi elds

<fieldset> element

adding submit buttons and, 312–313

for creating fi eld sets, 300–301

creating password text fi elds and, 

302–303

inserting checkboxes and, 304–305

fi le formats

proprietary, 22

for raster images, 195–196

for vector graphics, 192

File Transfer Protocol. see FTP (File Transfer 

Protocol)

fi lename

adding . "/ " to, 223

for creating home pages, 407

saving pages and, 60

for style sheets, 67

Files panel

location of, 4

putting site online and, 411–412

setting up jumpstart site and, xii

Filter panel, 202–203

Find And Replace command

Dreamweaver site-wide option, 57

features of, 186–188

updating HTML data using, 334–336

Firefox

hyperlink destination shown in, 220

link destination shown in, 220

popularity statistics of, 43, 83

Fireworks

copying/pasting from, 209–211

creating mockups in, 87

fi xed-width layout

CSS layout and, 59

text refl ows and, 242–243

Flash embedding, 282

Flash Video (FLV) fi les, 283–286

Flash, working with

adding Flash animation, 279–283

adding FLV fi les, 283–286

cloaked fi les, 405

features of, 278

overview, 276–277

previewing Flash elements, 278–279

review, 287

fl at fi le, 344

fl exibility, of Dreamweaver behavior, 261

fl oat attribute, 65–66

fl tlft class, 200, 201, 206, 212

fl trt class, 200, 203, 211, 212

FLV (Flash Video) fi les, 283–286

focused behavior, 273

folders, Classroom in a Book lesson, xi

Font-size fi eld

altering text size and, 73

creating descendant selectors and, 111

creating headings and, 164

customizing Spry Accordion and, 272

formatting <caption> elements and, 183

formatting text and, 44

inserting <div> components and, 95

styling forms and, 320

Font-weight fi eld

formatting <caption> elements and, 183

formatting text and, 44

styling forms and, 320

fonts

adjusting, 70–72

HTML default item, 43

.footer rule

defi ning structural elements, 109

inserting graphic background and, 69–70

for reformatting footer, 101

<form> element

adding forms to pages and, 293–294

features of, 292

function of, 292

HTML tag functions, 32, 292–293

specifying form actions and, 313–314

forms, working with

adding submit buttons, 311–313

adding to web pages, 293–295

creating fi eld sets, 300–301

creating password text fi elds, 301–303

creating radio buttons, 306–307

e-mailing form data, 315–318

enforcing tabbing order in, 313

features of, 292

including Spry Text fi elds, 298–300

incorporating text areas, 307–309

inserting checkboxes, 304–305

overview, 288–289

previewing, 290–291

review, 322

setting preferences, 295

specifying form actions, 313–314

styling, 319–321

using text fi elds, 296–297

working with list/menu elements, 

309–311

Foundation Flex for Developers: Data-Driven 

Applications with PHP, ASP.NET, 

ColdFusion, and LCDS (Jacobs), 318

4-bit color space, in raster graphics, 194

FTP (File Transfer Protocol)

for connecting to remote sites, 398

Passive, 400

setting up remote sites with, 398–402

troubleshooting, 401

FTP Performance Optimization, 400

functionality

of built-in Dreamweaver behavior, 261

collapse, 384–385

creating server-based, 315–318

for sorting tables interactively, 327

of Spry checkboxes, 304

G
generic hyperlinks, 97–100

Get commands

cloaking folders/fi les and, 406

putting site online and, 412

GET method, 314

GIF (graphic interchange format), 195

go-to-detail-page behavior

creating, 375–377

inserting, 374

graphics

adding Flash animation to pages, 279–283

adjusting position with CSS classes, 

199–200

copying/pasting from Fireworks/

Photoshop, 209–211

inserting background into footer, 69–70

inserting by drag and drop, 211–212

inserting dynamic, 365–367

inserting incompatible fi le types, 204–206

inserting into web page, 197–199

inserting, with Dreamweaver, 63–66

optimizing with Property inspector, 

212–214

previewing, 196–197

raster, 192–195

raster image fi le formats, 195–196

tools for, 214

using Adobe Bridge, 202–203

vector, 192

working with Insert panel, 201

working with Photoshop Smart Objects, 

207–208

greendata database folder, 345

H
<h1> elements

creating descendant selectors and, 

110–111

in CSS box model, 41

default margins in, 50

functions of, 25, 32

in HTML code structure, 23

HTML defaults and, 42

selecting code and, 383–384

<h2> elements

creating headings with, 163–165

inserting Spry Accordion widgets and, 

269

<h3> elements

applying behaviors and, 265–266
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applying Swap Image Restore behavior 

and, 267

creating headings and, 163

hash mark (#)

creating hyperlink placeholder, 117

declaring CSS id selector, 51

enabling links, 222, 260

jumping to top of page, 230

in rule names, 178

<head> element

function of, 27

in HTML code structure, 23

inserting JavaScript code in, 267

inserting Spry menus as Library items 

and, 251

Head First HTML with CSS & XHTML 

(Freeman & Freeman), 31

header

adding background image to, 91–92

fi elds, testing table behaviors and, 334

predefi ned rule function, 109

table cell, 177–178

updating templates and, 143

heading(s)

changing, 60–61

creating, 163–165

HTML default item, 42

tags, for text formatting, 25–26

Height fi eld

copying/pasting images and, 210–211

customizing Spry Accordion and, 273

inserting graphics and, 206

modifying in Property inspector, 212–213

hexadecimal colors, 68–69

Hidden Characters, 383

hidden form elements, 292

high color, for smart phones, 195

Highlight Invalid Code, 383

home page

Adobe Dreamweaver CS5 product, xv

creating, 407–408

horizontal menu

creating custom IDs and, 115

for creating internal links, 222–223

updating templates and, 143–144

horizontal rule (empty tag)

in HTML code structure, 23

HTML tag functions, 32

hotspots

defi nition of, 201

Fireworks and, 87

hover eff ect

Ajax scripting and, 327

customizing Spry Accordion and, 273

freezing JavaScript, 390–391

in Spry Accordion, 388–389

styling Spry tables and, 333

working with XML-based Spry table, 

337–338

htdocs folder

PHP/MySQL confi guration and, 346

setting up testing servers and, 341–342

HTML and XHTML Pocket Reference 

(Robbins), 31

HTML-based tables, 328–332

HTML character entities, 33

HTML code

basic structure, 23

frequently used, 31–33

inserting, 25

Live Code and, 389

writing, 23–24

HTML comments, 393–394

HTML-compatible codes, 386–388

HTML data, 334–336

HTML defaults, 42–43

<html> element

adding structure and, 27

HTML tag functions, 32

writing HTML code and, 23

HTML elements

formatting borders of, 49

formatting margins of, 50

formatting padding of, 50

formatting position of, 47–48

formatting size of, 48–49

HTML formatting vs. CSS formatting, 39–40

HTML (HyperText Markup Language) 

basics

adding structure, 27

applying inline formatting, 26

basic code structure, 23

formatting text, 25–26

frequently used codes, 31–33

future of, 34

inserting HTML code, 25

introduction to, 22–23

overview, 20–21

recommended books on, 31

review, 35

understanding HTML syntax, 24

writing HTML code, 23–24

writing in Dreamweaver, 28–31

HTML Property inspector. see Property 

inspector

HTML Spry data type, 330

HTML syntax, 24

HTML tags

frequently used, 32–33

for paragraph structure, 25

for text formatting, 25–26

HTML, XHTML, and CSS: Visual 

QuickStart Guide (Castro), 31

hyperlink behavior

adding visual appeal, 120–121

modifying default, 118–119

modifying existing, 119–120

hyperlink pseudoclasses, 116

hyperlink rules, 130

hyperlink(s)

adding Dreamweaver behavior to, 

268–269

creating external, 226–227

creating image-based, 225–226

creating internal, 222–225

creating named anchors for, 230–231

creating with code hinting, 386–388

customizing appearance of Spry menu 

bar, 241–247

generic, 97–100

hotspots, 201

inserting Spry menu bars and, 234–239

internal and external, 218, 222–225

modifying Spry menus directly, 239–241

names, exact spelling of, 237

relative vs. absolute, 218–219

setting up e-mail, 227–228

targeting page elements, 229–230

targets, using ID attributes as, 232

updating website, 408–409

HyperText Markup Language. see HTML 

(HyperText Markup Language)

Hypertext Preprocessor (PHP) form e-mail 

function, 315–318

I
ID attributes

creating custom, 113–115

in CSS rule construction, 44

as link targets, 232

selectors, creating, 51

Illustrator, 87

image-based links, 225–226

Image Description fi eld, 210

image placeholders

adding Dreamweaver behaviors and, 

263–265

dynamic, 374

inserting, 100–101

Image Preview dialog box

copying/pasting images and, 209–210

inserting incompatible fi le types and, 

204–206

reopening to improve images, 207

Image Property inspector. see also Property 

inspector, 17

Image Tag Accessibility Attributes dialogue 

box

inserting images and, 64–65

inserting images by drag and drop and, 

212

using Adobe Bridge and, 203

working with Insert panel and, 201

images, working with

adjusting positions, 199–200

copying/pasting from Fireworks/

Photoshop, 209–211

graphic tools, 214

inserting by drag and drop, 211–212

inserting dynamic, 365–367

inserting images, 197–199

inserting incompatible fi le types, 204–206

inserting, with Dreamweaver, 63–66

optimizing with Property inspector, 

212–214

overview, 190–191
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previewing graphics, 196–197

raster graphics, 192–195

raster image fi le formats, 195–196

review, 215

using Adobe Bridge, 202–203

vector graphics, 192

working with Insert panel, 201

working with Photoshop Smart Objects, 

207–208

<img> element, 199–200

Import Tabular Data dialog box, 180–181

important page content, 25–26

include command, 151, 153

indents, text, 167–170

information, Dreamweaver application 

features, xiii

inheritance theory, 45–46

inline elements

defi ned, 31

formatting text with, 26

<input> element

HTML form elements and, 294

using text fi elds and, 296–297

Input Tag Accessibility Attributes dialog box

adding submit buttons and, 312–313

creating password text fi elds and, 302–303

incorporating text areas and, 307–309

inserting menu elements and, 309–311

inserting Spry Text Fields and, 298–300

using text fi elds and, 296–297

Insert panel

adding forms to pages and, 293–294

inserting images, 201

inserting placeholder text, 364–365

inserting Spry Accordion widgets, 

269–271

location of, 4

Inspect mode, 391–392

installation, of Classroom in a Book fi les, x

interactive link behavior

adding visual appeal, 120–121

modifying default, 118–119

modifying existing, 119–120

interactive menus, 115–118

interactivity, adding

adding additional panels, 271

adding behavior to hyperlinks, 268–269

applying Dreamweaver behaviors, 

265–266

applying Swap Image Restore behavior, 

266–267

customizing Spry Accordion, 272–274

inserting Spry Accordion widgets, 

269–271

learning Dreamweaver behaviors, 260–261

overview, 258–259

previewing behaviors in completed page, 

261–262

removing applied behaviors, 267–268

review, 275

working with Dreamweaver behaviors, 

263–265

internal hyperlinks

creating, 222–225

function of, 218

Internet access, cell phones for, 83–84

Internet Explorer

Flash Player and, 286

hyperlink destination shown in, 220

link destination shown in, 220

popularity statistics of, 83

intranet, 398

IPV6 Transfer Mode, 400

J
JavaScript

Dreamweaver behaviors and, 260–261

freezing with hover eff ect, 390–391

inserting in <head> section, 267

uploading, 411

working with HTML data and, 332

JPEG (Joint Photographic Experts Group), 

196

jumpstart

method, xi

site, setting up, xii

K
keyboard shortcuts, 14–16

keys, unique, 343

L
<label> element

creating fi eld sets and, 300

creating radio buttons and, 306–307

incorporating text areas and, 308

using text fi elds and, 296

layout. see CSS layout; web page layout, 

creating

Legend fi eld, 300–301

lessons

jumpstart method for, xi–xii

recommended order, xi

Lessons folder, x

<li> elements

building menu buttons using, 120

collapsing code and, 385

collapsing code based on, 385

creating lists and, 166

expanding code and, 385–386

HTML tag functions, 32

modifying existing content and, 98

updating links and, 409

using Inspect mode and, 391

Library items

cloaking of, 405–406

creating, 144–148

inserting Spry menus as, 250–254

overview, 144

updating, 148–149

for updating links, 408–409

Line-height fi eld

in CSS rule construction, 44

formatting <caption> elements and, 183

Line Numbers

Code view and, 106

collapsing code and, 385

function of, 383

Link Checker panel, 255

Link fi eld

for creating internal links, 222–223

inserting Spry menu bars and, 237–239

modifying Spry menus and, 240–241

setting up e-mail links and, 228

link placeholder

adding behavior to hyperlinks and, 

268–269

creating home pages and, 408

link targets, 232

links. see hyperlink(s)

list/menu elements

<input> tag and, 294

for online forms, 292

overview of, 309–311

List Values dialog box, 310–311

lists, working with. see also text, working 

with

creating lists, 165–167

overview, 158–159

previewing page containing, 160–162

review, 189

Live Code

accessing, 389–391

accessing Split Code view and, 393

using Inspect mode and, 391–392

Live view

examining <caption> elements in, 183

Inspect mode and, 391–392

observing updated pages in, 149

previewing dependent fi les in, 360–361

previewing FLV fi les in, 285–286

previewing online data in, 326–327

previewing SSIs in, 152–153

previewing template child page in, 140

previewing web page in, 75, 76

test Spry menu bar in, 247

Local Site Folder fi eld, 57

local site(s)

root folder, 56–57, x

synchronizing remote and, 413–414

local web servers

confi guring, 340

establishing remote site on, 398, 402–404

Loop option, 280

lossy compression, with JPEG, 196

M
Macintosh instructions, vs. Windows 

instructions, xiii

Maintain Synchronization Information 

option

for remote FTP site, 401

for remote site on local/network web 

server, 404

MAMP (Windows/Macintosh Apache 

MySQL PHP) server
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connecting to databases using, 341–342

setting up, 341–342

Manage Sites dialog box

establishing remote site on local/network 

web server and, 402–404

setting up remote FTP site and, 398–402

setting up testing servers and, 340–342

margins

in CSS box model, 41

HTML default item, 43

object formatting of, 50

styling tables and, 174–175

master page sets, 363–365

Max Chars attribute fi eld, 296

menus

adding visual appeal to, 120–121

customizing Spry, 241–247

inserting as Library items, 250–254

inserting Spry, 234–239

interactive, 115–118

Menu bar location, 4

modifying Spry, 239–241

vertical, 144–148, 241–247

vertical navigation, 97–100, 408–409

Microsoft Internet Explorer. see Internet 

Explorer

Microsoft Visual SourceSafe, 398

mockups, in Fireworks/Photoshop, 87

Move To First Page dialog box, 368–369

MS Excel data, 180–181

multicolumn designs, 121–123

multiple items

choosing, 292

displaying, 367–368

MySQL Connection dialog box, 346

MySQL database

connecting to, on PHP server, 345–348

server-based capabilities of, 343

N
named anchors, 230–231

navigation, working with

checking pages, 254–255

creating external links, 226–227

creating image-based links, 225–226

creating internal links, 222–225

creating named anchors, 230–231

customizing appearance of Spry menu 

bar, 241–247

editing CSS using Code Navigator, 

248–249

hyperlink basics, 218–219

inserting Spry menu bars, 234–239

inserting Spry menus as Library items, 

250–254

modifying Spry menus directly, 239–241

overview, 216–217

previewing links, 219–222

review, 256

setting up e-mail links, 227–228

targeting page elements, 229–230

using ID attributes as link targets, 232

network web servers

defi nition of, 398

establishing remote site on, 402–404

New CSS Rule dialog box

creating descendant selectors and, 110

creating headings and, 164–165

creating interactive menus and, 117–118

styling forms and, 319–321

styling Spry tables and, 333–334

normalization, 50

now() function, 357

number Spry data type, 330, 331

O
<object> elements, 282

object formatting, in CSS

borders and shading, 49

margins and padding, 50

positioning, 47–48

size, 48–49

Object Tag Accessibility Attributes dialog 

box, 280

odd/even eff ects

styling Spry tables and, 333

working with XML-based Spry table, 

337–338

<ol> elements

creating lists and, 166

default margins in, 50

default margins with, 50

HTML tag functions, 32

online data, working with

choosing server models, 338–339

confi guring local web servers, 340

database design basics, 343–344

overview, 324–325

previewing online data, 326–327

review, 350

setting up testing servers, 340–342

styling Spry tables, 333–334

updating HTML data, 334–336

working with dynamic content, 326

working with HTML data, 328–332

working with XML data, 336–338

online forms. see forms, working with

online services, Adobe CS Live, xvii

onMouseOut attribute

of Swap Image behavior, 268

of Swap Image Restore behavior, 267

onMouseOver attribute

of Swap Image behavior, 265–266

of Swap Image Restore behavior, 267

opening tags

adjusting image positions and, 200

creating custom classes and, 112

creating Library items and, 146

in HTML code structure, 23

options. see also specifi c options

for FTP server, 400

synchronization, 414

orders table, 344

P
<p> elements

adding new code and, 386–388

creating external links and, 226

creating headings and, 163

creating lists and, 166–167

creating lists with, 166–167

creating named anchors and, 231

default margins in, 50

HTML defaults and, 42

HTML tag functions, 32

HTML vs. CSS formatting and, 39

inserting image placeholders and, 100

inserting text and, 62–63

styling forms and, 320

styling tables with CSS and, 174

targeting page elements and, 229–230

targeting page elements with, 229–230

using Property inspector and, 74

padding

in CSS box model, 41

in Flash banner animation, 282–283

HTML default item, 43

object formatting of, 50

padding fi elds

styling forms and, 320

styling table cells and, 176

page elements

CSS styles and, 106

in Design view, 75

specifi cations of, 97

targeting, 229–230

page layout. see web page layout, creating

page titles, 60

page width, 66–68

paging controls

hiding unneeded, 369–370

inserting, 368–369

palette, in raster graphics, 194

panels

features of, 4–5

fl oating/dragging, 9

grouping/stacking/docking, 10–11

minimizing, 8

standard grouping, 7

paragraph structure, 25

parent element

hiding subitem menus with, 248

updating links and, 409

Passive FTP, 400

password text fi elds, 301–303

pencil sketches

thumbnails, 84–86

wireframes, 86–87

period (.) character

combining text and data variable, 316

declaring CSS class selectors, 51

in rule names, 178

Personal Home Page, 339
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personalized preferences, 14

Photoshop (PSD)

cloaked fi les, 405

copying/pasting from, 209–211

creating mockups in, 87

updating images in, 207–208

PHP form e-mail function, 315–318

PHP (Hypertext Processor)

adding repeat regions using, 361–362

creating a recordset using, 354–358

creating detail pages using, 374–377

creating dynamic tables using, 362–363

creating master page sets using, 363–365

creating record paging behavior using, 

368–369

displaying data using, 358–360

displaying images dynamically using, 

365–367

displaying multiple items using, 367–368

displaying record counts using, 371

features of, 339

hiding paging controls using, 369–370

inserting go-to-detail-page behavior 

using, 374

PHP/MySQL server installation, 345–348

staging fi les on testing servers using, 

360–361

styling dynamic data using, 371–374

picture elements. see pixels

pixels

in raster graphics, 192–193

resolution and, 193

width set in, 243–244

placeholder headings

changing, 60–61

creating lists and, 165

creating text indents and, 167

importing text and, 163

inserting text and, 62

placeholder text

changing, 97–100

creating master page sets and, 364–365

in HTML-based tables, 326–327

inserting, 101

plus (+) icon

in Bindings panel, 355, 363

in Databases panel, 346

in Server Behaviors panel, 361, 367, 370

PNG (Portable Network Graphic), 196

Point To File tool, 223–225

positioning, 47–48

POST method, 314

power position, 86

prebuilt workspace layouts

Classic, 11–12

Coder, 12

Designer, 13

predefi ned options, checkbox, 304

preferences

personalizing, 14

setting for accessible forms, 295

prerequisites, to using Classroom in a 

Book, ix

Preview States menu

creating radio buttons and, 307

inserting Spry Text Fields and, 299–300

print style sheet creation

converting existing style sheet, 126–127

displaying Style Rendering toolbar, 

125–126

hiding unwanted page areas, 127–129

overview, 124–125

removing unneeded styles, 130

product information, in database design, 344

progressive download, of FLV fi les, 283–286

Property inspector

adding/removing panels in, 271

creating custom CSS formatting, 73–75

creating external links with, 226–227

creating image-based links with, 225–226

creating internal links with, 222–225

displaying width/height values, 93

Flash banner animation in, 280–281

HTML/CSS tabs of, 16–17

image properties of, 17

location of, 4

modifying Spry menu bars in, 236–239

optimizing images with, 212–214

refreshing after Code view changes, 30

proximity, in CSS rule construction, 45

Proxy, 400

PSD. see Photoshop (PSD)

pseudoclasses, hyperlink

functions of, 116

modifying hyperlink behavior and, 120

Style Rendering toolbar and, 125–126

public folder name, of FTP server, 399

publishing websites. see websites, 

publishing of

purpose, website, 82

Put command

cloaking folders/fi les and, 406

putting site online and, 410–412

R
radio buttons

creating, 306–307

<input> tag and, 294

for online forms, 292

raster graphics

color in, 194–195

overview, 192–193

raster image fi le formats, 195–196

resolution in, 193

size in, 194

RDS (Remote Development Services), 398

real time updating, 328

recommended lesson order, for Classroom 

in a Book, xi

record paging behavior

creating, 368–369

in Recordset menu, 361

record(s)

in database design, 343

display, 369–371

Recordset dialog box

creating a recordset and, 355–358

creating detail pages and, 375–377

creating dynamic tables and, 362–363

creating master page sets and, 363–365

Recordset Navigation Status dialog box, 371

recordsets, 354–358

regular expressions, 185

Related Files interface, 392

relational databases, 344

relative hyperlinks, 218–219

Remote Development Services (RDS), 398

remote sites

defi nition of, 398

synchronizing local and, 413–414

Render Print Media Type icon

hiding unwanted page areas and, 127–129

removing unneeded styles and, 130

repeat regions

adding, 361–362

displaying multiple items with, 367–368

inserting paging controls, 368–369

Resample, graphic tool, 214

resolution

with JPEG and PNG, 196

in raster graphics, 193

resources, xiv

Resources for educators, xv

rollover eff ect, 261

root directory name, of FTP server, 399

<root> elements

function of, 27

in HTML code structure, 23

rows

adjusting vertical alignment in, 181–182

copying/pasting tables and, 173

creating tables and, 171–172

in database design, 343

in paging behaviors, 368–369

styling Spry tables and, 333–334

for XML-based Spry tables, 336–338

rule construction, CSS, 44–47

rules

moving to external style sheet, 123–124

naming of, 178

order of in CSS styling, 177

removing for printing, 130

S
Save All command

creating custom keyboard shortcuts and, 

15–16

moving rules to external style sheet and, 

124

for updated multiple fi les, 144

updating templates and, 144

Save As Template dialog box, 136

Save Optimized As dialog box, 211

Save Web Image dialog box
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copying/pasting images and, 209

inserting incompatible fi le types and, 206

Scalable Vector Graphics (SVG), 192

screen-media style sheet, 126–127

<script> elements

Flash Player and, 282

HTML tag functions, 33

inserting Spry elements and, 252

inserting Spry menus as Library items 

and, 252

scripting languages. see also specifi c 

scripting languages

displaying data changes, 328

supporting, 318

Secure File Transfer Protocol (SFTP), 398

select eff ects

Ajax scripting and, 327

styling Spry tables and, 333

working with XML-based Spry table, 

337–338

Select External Editor dialog box, 210

Select File dialog box

adding Flash animation and, 280

creating internal links and, 223

inserting go-to-detail-page behavior 

and, 374

Select Image Source dialog box

inserting dynamic images and, 365–367

inserting images and, 197–198

working with Insert panel and, 201

Select Parent Tag icon, 384

Selector Name fi eld, 111

selectors

creating class and id, 51

creating descendant, 110–111

in CSS rule construction, 44

seminars, dynamic tables for, 362–363

server-based databases, vs. stand-alone 

databases, 343

server-based e-mail, 315–318

Server Behaviors panel

adding repeat regions and, 361–362

displaying multiple items and, 367–368

server models, 338–339

server-side functionality, 228

server-side includes (SSIs)

creating, 150–151

implementing menus as, 254

inserting, 151–153

updating, 153–155

uploading, 411

using, 149–150

SFTP (Secure File Transfer Protocol), 398

shading, 49

Sharpen, graphic tool, 214

Show Log option

for updating links, 409

for updating templates, 142

Show Region behaviors, 370

.shtml extension, 151, 153

.sidebar1 rule

for creating faux columns, 122–123

defi ning structural elements, 109

Site Name fi eld, 57

Site Setup dialog box

confi guring testing servers in, 340

creating sites for lessons, xi

setting up Dreamweaver site and, 56–57

setting up jumpstart site, xii

setting up jumpstart site and, xi

setting up remote FTP site and, 398–399

SiteCatalyst NetAverages, xvii

16-bit color space, 195

size

altering text, 72–73

of heading tags, 165

of image, matching container, 94

of image, optimizing with Property 

inspector, 212–213

object formatting of, 48–49

in raster graphics, 194

of Spry menu bar, 242–246

Smart Objects (Photoshop), 207–208

smart phones, 195

software installation, Dreamweaver, x

Source (Bardzell and Flynn), 340

specifi city theory, 47

spell-checking, 184–185, 409

Split Code view, 393

Split view

creating fi eld sets in, 300

creating lists in, 166

editing CSS in, 248

features of, 6–7

HTML vs. CSS formatting and, 39–40

inserting checkboxes in, 305

using Code Navigator in, 388

working with CSS Styles panel in, 109

writing HTML code in, 28

spreadsheets, 343

Spry Accordion widgets

adding additional panels to, 271

Code Navigator and, 388–389

customizing, 272–274

inserting, 269–271

overview, 269

Spry Data, 233

Spry data placeholders, 360

Spry Data Set dialog box

working with HTML data and, 329–331

working with XML data, 336–338

Spry Data Set-Insert Table dialog box, 

331–332

Spry data tables

discarding, 358–359

rebuilding, 362–363

styling, 333–334

Spry data types, 330

Spry Eff ects, 233

Spry Form widgets, 233

Spry framework

creating detail pages using, 374–377

creating master page sets using, 363–365

creating record paging behavior using, 

368–369

displaying images dynamically using, 

365–367

displaying multiple items using, 367–368

displaying record counts using, 371

features/tools of, 233

harnessing Ajax’s power, 326

hiding paging controls using, 369–370

inserting go-to-detail-page behavior 

using, 374

styling dynamic data using, 371–374

working with HTML data, 328–332

Spry Layout widgets, 233

Spry menus

customizing appearance of, 241–247

editing CSS using Code Navigator, 

248–249

inserting, 234–239

inserting as Library items, 250–254

modifying directly, 239–241

Spry Textarea

incorporating text areas and, 307–309

inserting menu elements and, 309–311

Spry Validation Radio Group, 306–307

Spry Validation Text Fields, 298–300

SSIs. see server-side includes (SSIs)

staging server, 398, 402

stand-alone databases, vs. server-based 

databases, 343

standard panel grouping, 7

Standard toolbar, 13–14

statistics, on website access/usage, 83

status bar, 220

streaming, of FLV fi les, 283

string Spry data type, 330

<style> elements

CSS rules contained in, 106–107

in CSS Styles panel, 106–107

HTML tag functions, 33

Style Rendering toolbar

displaying, 125–126

location of, 13–14

style sheets. see CSS style sheets

Stylin’ with CSS: A Designer’s Guide (Wyke-

Smith), 52

submit buttons, 311–313

Submit option, 299

SVG (Scalable Vector Graphics), 192

Swap Image behavior

adding to hyperlinks, 268–269

applying, 265–266

removing, 267–268

Swap Image Restore behavior

applying, 266–267

removing, 267–268

synchronization, of local/remote sites, 

413–414

Syntax Coloring, 383

Syntax Error Alerts In Info Bar, 383
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T
tabindex attribute

commenting codes and, 393

enforcing tabbing order, 313

table cell text, 42

table cells

displaying data and, 360

HTML tag functions, 33

inserting tables and, 182

styling, 176–178

table headers

displaying data and, 359

HTML default item, 43

styling table cells and, 176

Table Property inspector, 17

<table> tag selector

<caption> elements and, 182–183

copying/pasting tables, 173

creating named anchors and, 231

creating tables and, 172

fi nding/replacing text and, 188

inserting tables and, 180–181

styling Spry tables and, 334

styling tables and, 174–175

for targeting page elements, 229–230

using ID attributes as link targets and, 232

tables, working with

adding/formatting <caption> elements, 

182–183

adjusting vertical alignment, 181–182

controlling column width, 178–179

copying/pasting, 173

creating dynamic, 362–363

creating from scratch, 171–172

inserting, from other sources, 180–181

inserting paging controls as, 368–369

overview, 158–159, 170

previewing page containing, 160–162

review, 189

styling table cells, 176–178

styling with CSS, 174–175

tag-based syntax, 339

Tag Inspector panel

accessing Dreamweaver behaviors from, 

260

adding behavior to hyperlinks in, 268–269

applying Swap Image behavior in, 

265–266

applying Swap Image Restore behavior 

in, 267

tag selectors

HTML, 25–26, 32–33

location of, 4

selecting code using, 383–384

targeted links

methods used for, 229–230

using ID attributes as, 232

<td> elements

adjusting vertical alignment and, 182

for formatting columns, 176–177

templates

cloaked folders, 405–406

creating from existing layout, 135–136

creating server-side includes, 150–151

editing horizontal menu in, 222

inserting editable regions, 137–138

inserting server-side includes, 151–153

for inserting Spry menus as Library items, 

251–253

overview, 132–133

previewing completed page, 134–135

producing child pages, 138–140

review, 156

updating, 141–144

updating server-side includes, 153–155

using Library items, 144–149

using server-side includes, 149–150

Test SQL Statement dialog box

creating a recordset and, 356

creating detail pages and, 375–377

creating master page sets and, 364

testing servers

fi nal steps for, 349

setting up, 340–342, 345–348

for SSIs, 153, 155

staging fi les on, 360–361

text

applying classes to, 112–113

color, 70–72

font, 70–72

formatting, 25–26

inserting, with Dreamweaver, 61–63

modifying existing content, 97–100

refl ows, 243

size, altering, 72–73

Text-align fi eld menu

controlling column width and, 179

styling table cells and, 176

text areas

incorporating, 307–309

<input> tag and, 294

for online forms, 292

text-based hyperlinks, 222–225

text editor

opening templates in, 138

writing HTML code and, 23–34

text fi elds

creating fi eld sets, 300–301

creating password, 301–303

<input> tag and, 294

inserting Spry, 298–300

for online forms, 292

using, 296–297

text, working with

adding/formatting <caption> elements, 

182–183

adjusting vertical alignment, 181–182

controlling column width, 178–179

copying/pasting tables, 173

creating headings, 163–165

creating lists, 165–167

creating tables, 170–172

creating text indents, 167–170

fi nding/replacing text, 185–188

importing text, 162–163

inserting tables, 180–181

overview, 158–159

previewing completed page, 160–162

review, 189

spell-checking web pages, 184–185

styling table cells, 176–178

styling tables with CSS, 174–175

text wraps, 243

<th> elements

adjusting vertical alignment and, 182

controlling column width and, 179

for formatting columns, 176–177

32-bit color space

for graphic design, 195

with PNG, 196

three-dimensional eff ect, 120–121

thumbnails, 84–86

<title> elements

adding to web pages, 27

template editable region in, 137

titles, page, 60

toolbar

adjustments, 13–14

features, 4–5

tools, for images, 214

training and certifi cation, Adobe, xvi

transparency

backgrounds and, 49

with GIF, 195

with PNG, 196

Trash Can icon, 122

triggering elements

Blur/Change/Submit options, 299

for Dreamweaver behaviors, 260–261

onMouseOut as, 267

onMouseOver as, 265–266, 267

troubleshooting, 401

true color, 195

Turn Styles On button, 240

24-bit color space, 195

Type-size fi eld, 174

U
<ul> elements

collapsing code based on, 385

creating lists and, 167

expanding code based on, 385–386

inserting Spry Accordion widgets and, 

269–271

ul.MenuBarVertical rule

customizing Spry menu bar and, 242–247

editing CSS and, 248–249

ul.nav li rule

adding vis menus and, 120

formatting menu button and, 120–121

predefi ned rule function, 109

<ul.nav> tag selector

for creating library items, 144–146

for creating SSI, 150–151
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Uniform Resource Locator. see URL 

(Uniform Resource Locator)

unique IDs

for converting radio buttons to 

checkboxes, 306

in database design, 343

for forms/form elements, 293

for Spry data set, 329

for text fi elds, 296

unique keys, 343

unordered lists, 165–167

Update From Original, graphic tool, 214

Update Pages dialog box

creating image-based links and, 225–226

creating internal links and, 224

inserting editable regions and, 138

inserting Spry menus as Library items 

and, 253

updating links and, 409

updates, checking for, xiii

URL (Uniform Resource Locator)

for creating external links, 226

fi eld, inserting folder names into, 366

of FTP server, 399

in HTML code structure, 218

of local web server, 403

for MAMP installation, 345

testing servers in, 342

V
validation

defi nition of, 298

with Spry Text Fields, 298–300

Value column fi eld, 175

values, for radio buttons, 306

variables, in PHP, 316

vector-based animation, 279–283

vertical menu

creating Library items from, 144–148

customizing Spry, 241–247

updating templates and, 144

vertical-nav item

for creating Library items, 144–148

for updating Library items, 148–149

vertical navigation menu

modifying existing content/formatting, 

97–100

updating, 408–409

video formats, 283–286

views

Code. see Code view

Design. see Design view

Live. see Live view

Split. see Split view

visibility, modifying paging link, 369–370

W
W3C

on creating SVG, 192

SQL tutorial off ered by, 354

website access/usage statistics, 83

WAMP/MAMP (Windows/Macintosh 

Apache MySQL PHP) server, 344–348

web-based forms. see forms, working with

web design. see also graphics; images, 

working with

Adobe Marketplace & Exchange 

resources, 260–261

basics of, 82–84

thumbnail, 85–86

Web Distributed Authoring and Versioning 

(WebDav), 398

web page layout, creating

adding background image to header, 

91–92

checking browser compatibility, 102

creating thumbnails, 84–86

creating wireframes, 86–87

inserting image placeholders, 100–101

inserting new <div> components, 93–96

inserting placeholder text/modifying 

footer, 101

inserting Spry Accordion widgets, 

269–271

modifying existing content/formatting, 

97–100

modifying existing CSS layout, 88–91

modifying page width/background color, 

96–97

overview, 80–81

previewing, 88

review, 103

web design basics, 82–84

web pages

adding Flash animation to, 279–283

adding forms to, 293–295

dynamic. see dynamic pages, building 

with data

graphics color for, 194

graphics resolution for, 193

hiding unwanted areas for printing, 

127–129

image size for, 194

modifying width, 96–97

saving/modifying title, 60

spell-checking, 184–185

using JPEG for graphics, 196

writing HTML by hand, 23–27

writing HTML in Dreamweaver, 28–31

web-safe color palette, 194

web servers, local, 340

WebDav (Web Distributed Authoring and 

Versioning), 398

websites, publishing of

cloaking folders and fi les, 405–406

completing sidebar content, 410

creating home pages, 407–408

defi ning remote sites, 398

establishing remote site on local/network 

web server, 402–404

overview, 396–397

prelaunch checklist, 409

putting site online, 410–412

review, 415

setting up remote FTP site, 398–402

synchronizing local/remote sites, 

413–414

updating links, 408–409

weight, in CSS rule construction, 47

Welcome screen, 58–59

What You See Is What You Get 

(WYSIWYG) editor, 3–4

widgets

adding additional panels to, 271

customizing menu bar appearance, 

241–247

customizing Spry Accordion, 272–274

features of, 233

inserting, 234–239

inserting Spry Accordion, 269–271

inserting Spry Text Fields, 298–300

modifying directly, 239–241

Width fi eld

controlling column width and, 178–179

copying/pasting images and, 210–211

inserting graphics and, 206

modifying in Property inspector, 212–213

styling tables and, 174

of text fi elds, 296

width set in ems/pixels, 243

Windows instructions, vs. Macintosh 

instructions, xiii

wireframes, 86–87

Word Wrap, 383

workspace

Coder, 12

creating custom, 14

setting up, xii

workspace, customizing

custom keyboard shortcuts, 14–16

design/code-editing tools, 4–5

overview, 2–3

panels, functions of, 7–11

personalizing preferences, 14

review, 18

switching/splitting views, 5–7

toolbar adjustments, 13–14

using Property inspector, 16–17

workspace layout selection, 11–13

Workspace menu

location of, 4

for prebuilt workspaces, 11

WYSIWYG (What You See Is What You 

Get) editor, 3–4

X
XML (Extensible Markup Language) data, 

336–338
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