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Introduction
Adobe Creative 3D Workflows: A Designer’s Guide to Substance 3D and Creative 
Cloud Integration has a strange origin that actually has little to do with what it has 
become nearly a full year later. 

In early 2023, Adobe released the first beta of its integrated set of generative AI 
technologies, named Firefly. This new artificial intelligence service was exciting, 
as it clearly stood out from existing text-to-image AI services. How so? Adobe 
expressed interest in integrating Firefly into a wide array of existing software 
applications. Moving beyond familiar text-to-image workflows could greatly aug-
ment the design capabilities of creative individuals through the use of AI across a 
variety of media. 

Initially, a few additional integrations and expansions existed in preview—labeled 
as In Exploration—that were unlike anything I’d seen before when exploring gener-
ative AI software. In particular was a Firefly module given the name 3D to Image. 
The idea being that you could arrange a set of 3D models within the software, 
provide a descriptive prompt, and have Firefly generate a visual design based on 
the prompt and strongly influenced by the 3D models assembled across the canvas 
to form the resultant image. 

Although an exciting prospect for sure, that is not exactly what this book is about!

However, my interest in this 3D to Image module has, in a roundabout way, led to 
the book you are now reading. Discussions were begun around whether a book on 
Firefly generative AI—focused upon these 3D-focused aspects—would be a viable 
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work. These discussions evolved into a different but related approach, as Adobe 
was also working steadily on integrating more traditional design software like 
Adobe Photoshop, Adobe Illustrator, and Adobe After Effects with capabilities 
and features derived from various Substance 3D collection applications and file 
formats—a melding of the worlds of 2D and 3D design software.

The result of all these discussions and initiatives is Adobe Creative 3D Workflows. 

Who This Book Is For
The focus of this work is the integration that now exists across these different 
software applications and collections. Adobe Creative Cloud users who want to 
expand their design skills in the area of 3D will find this book useful. In a simi-
lar fashion, Substance 3D users who want an approach to using Creative Cloud 
software can find similar inroads, albeit from the opposite direction. In a general 
way, anyone interested in the intersections of 2D design software and 3D design 
software will benefit from exploring this work. 

Considering the genesis of this work, I have been sure to integrate Firefly gen-
erative AI into the mix, as this service holds great promise in the creative space 
between 2D and 3D design. Adobe is taking wildly variant approaches to genera-
tive AI through its Sensei and Firefly models, and I am very excited to see how 
these explorations will impact 2D and 3D workflows in the coming years. Combine 
that with the expansion of the design techniques covered in this book and we have 
amazing opportunities to expand creativity ahead of us. 

Whether your interest is in expanding traditional 2D-design workflows to include 
3D components or you are coming from a 3D-tooling background to explore how 
these capabilities are being infused into 2D design software, I hope you find this 
book useful in combining these varied application workflows to create some truly 
fantastic results! 

The Design of This Book
This book dives into the capabilities and workflows across the Adobe Creative 
Cloud and Adobe Substance 3D collections of design software. The focus is on the 
intersections between 2D and 3D workflows and how best to approach them when 
designing content with various techniques. This is an increasingly popular focus 
for Adobe and the wider design industry in general, and Adobe in particular has 
been bleeding these technologies together in meaningful and practical ways with 
increasing frequency and capability over the past few years. 
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Prerequisites
Before following the exercises in Adobe Creative 3D Workflows, make sure your sys-
tem is set up correctly and that you’ve installed the required software and hard-
ware. The system requirements for Adobe Creative Cloud and Adobe Substance 3D 
are here:

https://helpx.adobe.com/creative-cloud/system-requirements.html

You should have a working knowledge of your computer and operating system. For 
example, you should know how to use standard menus and commands and also 
how to open, save, and close files. If you need to review these techniques, see the 
documentation included with your macOS or Windows system.

It’s not necessary to have a working knowledge of 3D design software concepts 
and terminology. Much of this will be explained in the first chapter. If you do 
come across a term that you’re not familiar with, consult the glossary at the end of 
the book.

This is not an introductory book, however, and it is assumed you have some 
experience with Creative Cloud or similar software. For a comprehensive intro-
duction to Adobe Creative Cloud design software, you should acquire a copy of 
Adobe Creative Cloud Classroom in a Book from Adobe Press, at peachpit.com/
creativecloudCIB. 

Installing the Software
You must purchase an Adobe Creative Cloud subscription, or obtain a trial version, 
separately from this book. You can find help and resources at the following links 
for the software you will use in this book:

System requirements and complete instructions on installing the software: 
helpx.adobe.com/support. 

Adobe Creative Cloud subscription: (required) This gives you access to 
Adobe’s primary collection of software and includes applications like Photoshop, 
Illustrator, After Effects, and Animate—in addition to many other applications and 
services: www.adobe.com/creativecloud. 

Adobe Substance 3D: (required) Adobe’s collection of 3D-specific software is 
provided as a separate subscription and includes applications like Substance 3D 
Sampler, Substance 3D Stager, and additional applications meant for professional 
3D work:  www.adobe.com/creativecloud/3d-ar.html.

Complimentary Adobe Substance 3D subscription for higher education: 
•	 If you are involved in higher education, you can acquire a complimentary 

subscription to Adobe Substance 3D by visiting https://substance3d.adobe.com/
education/ and verifying your status. 
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•	 If you have a higher education enterprise account for Adobe Creative Cloud, 
the Substance 3D applications are often included with that subscription. 

The first chapter in this book goes into everything you need to know when getting 
started with the software. 

How to Approach the Chapters
The chapters in this book include step-by-step instructions. Some chapters are 
stand-alone, but most of them build on concepts and workflows from previous 
chapters. For this reason, the best way to learn from this book is to sequentially 
proceed through the chapters. 

The chapters generally begin with an overview of a particular piece of design soft-
ware and how to use it in the design of 3D content. They proceed by introducing 
concepts and workflows that are common to the individual workflows and applica-
tions involved until the project is complete. Often, content you design in a chapter 
will be used in a later chapter’s projects to demonstrate the rich workflow you can 
achieve between these applications. 

Many pages contain additional “sidebar” information boxes that explain a par-
ticular technology or offer alternative workflows. It’s not necessary to read these 
additional boxes, or follow the workflows, but you may find them interesting and 
helpful, as they will deepen your understanding and often provide additional con-
text. Tips and notes appear throughout the chapters and contain more situational, 
immediate items for you to apply during the current steps of a project. 

By the end of the book, you’ll have a good understanding of what each Adobe 
Creative Cloud or Substance 3D collection software application does, how to start 
a new project, and how to design useful content with the particular 3D workflows 
being explored. 

Lesson Files
The projects in this book use supplied source files, including images, design assets, 
3D models, materials, project files, and more. To complete the lessons in this book, 
copy all the files to your computer’s storage drive. 

The media files are practice files, provided for your personal, educational use in 
these lessons only. You are not authorized to use these files commercially or to 
publish, share, or distribute them in any form without written permission from 
Adobe Systems, Inc., and the individual copyright holders of the various items. 
Do not share projects created with these lesson files publicly. This includes, but 
is not limited to, distribution via social media or online video services including 
YouTube and Vimeo. A complete copyright statement is on the copyright page at 
the beginning of this book.
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Any original media such as images, 3D models, materials, and so on that are ref-
erenced within or distributed as part of this book are copyright © 2024 by Joseph 
Labrecque. Certain additional design assets referenced are derived from direct use 
of online resources such as Adobe Express or as distributed within the software 
such as the case with Adobe Substance 3D Stager.

How to Access Online Material
You must register your purchase on peachpit.com to access the lesson files: 

1.	 Go to peachpit.com/3dworkflows.

2.	 Sign in or create a new account.

3.	 Click Submit.

4.	 Click the Access Bonus Content link to download the bonus content from the 
Registered Products tab on your Account page.

If you purchased a digital product directly from peachpit.com, your product will 
already be registered.

Additional Resources
Adobe Creative 3D Workflows is not meant to replace documentation that comes 
with the software or to be a comprehensive reference for every feature. Only the 
commands and options used in the exercises are explained in this book. For com-
prehensive information about program features and tutorials, refer to the follow-
ing resources.

Adobe Creative Cloud Learn and Support: https://helpx.adobe.com/creative-cloud 
is where you can find and browse Help and Support content on Adobe.com. On the 
Learn & Support page, click User Guide for documentation on individual features 
or visit https://helpx.adobe.com/creative-cloud/user-guide.html. 

For inspiration, key techniques, cross-application workflows, and updates on new 
features, go to the Creative Cloud tutorials page at helpx.adobe.com/creative-cloud/
tutorials.html. 

Adobe Community: Tap into peer-to-peer discussions, questions, and answers on 
Adobe products at the Adobe Support Community page at community.adobe.com. 

Adobe Creative Cloud Discover: This online resource offers thoughtful articles 
on design and design issues, a gallery showcasing the work of top-notch designers 
and artists, tutorials, and more. Check it out at creativecloud.adobe.com/discover.
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Behance: Adobe’s social network for creatives! Browse the work of others and 
get inspired through the sharing of creative design projects across traditional 2D 
design, 3D asset generation, and much more at behance.net.

Resources for educators: adobe.com/education and edex.adobe.com offer a trea-
sure trove of information for instructors who teach classes on Adobe software. 
Find solutions for education at all levels, including free curricula that use an 
integrated approach to teaching Adobe software and that can be used to prepare 
for the Adobe Certified Professional exams.
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CHAPTER 9

Manipulating 3D Models 
for Motion Graphic Designs

In this chapter, we return to Substance 3D Stager and Adobe After Effects 
for a different approach. We’ll be designing the 3D model of a product in 
Substance 3D Stager with assets created in Adobe Illustrator and Adobe 
Express. We’ll use this 3D model in an After Effects composition alongside 
additional 3D and 2D content using the new Advanced 3D rendering engine. 

We’ll also explore the creation of background elements for the composition through generative AI and 
Adobe Firefly, see how to work with 3D text elements, and use advanced lighting techniques through 
HDRi imagery. A lot of workflows, techniques, and software converge in this chapter! 
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Designing Motion Content with 3D Models
In Chapter 5’s introduction to 3D in After Effects, we looked at two ways of 
working in 3D space. The first was through the manipulation of flat graphics in 
perspective to give the appearance of 3D, and the second was to use actual 3D 
models. After Effects is capable of dealing with both methods within the same 
composition. 

In this figure, you can see that After Effects shows both the 2D object and the 
3D object as 3D layers in a single composition. Their appearance and the related 
controls inform you of their nature. The 2D object, when selected, exhibits a flat 
transformation rectangle around it, whereas the 3D object appears as though 
contained in a three-dimensional transformation cube. This difference is the pro-
jected volume of the object in 3D space.

This chapter focuses on native support for true 3D models and other aspects of the 
Advanced 3D render engine. 

Exploring the Advanced 3D Render Engine
When you create a new composition, After Effects provides three choices of 3D 
rendering engine in the 3D Renderer tab of the Composition Settings dialog box.

1.	 Choose Composition > New Composition from the application menu to 
access this dialog box as part of the composition creation workflow, or choose 
Composition > Composition Settings with an existing composition selected. 

Three tabs are available to you in this dialog box: Basic, Advanced, and 
3D Renderer. 
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2.	 Choose 3D Renderer to select the rendering engine you’d like to use and to see 
the features that are supported by each engine.

Beginning with the release of Adobe After Effects 2024 (version 24.2), the 
following engines are available: 

•	 Classic 3D: The default rendering engine before the Advanced 3D engine 
became available. This renderer enables your 2D layers to be positioned in 
3D space. 

•	 Advanced 3D: This rendering engine, which is the focus of this chap-
ter, is new to After Effects after a long gestation in the public beta. When 
Advanced 3D is selected, you can use true 3D models and materials, 
environmental lighting and shadows, extruded shape and text content, and 
more advanced 3D workflows. 

•	 Cinema 4D: This rendering engine functions alongside the Cinema 4D 
Lite software application, which you can optionally install. This rendering 
engine enables the extrusion of shape and text elements. 

In this chapter, you will use Advanced 3D as the 3D renderer. This is the 
default rendering engine, and it is automatically activated when creating a 3D 
layer or importing a 3D model. 
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3.	 Click the Options button on the 3D Renderer tab of the Composition Settings 
dialog box. The Advanced 3D Render Options dialog box displays. 

From here, you can fine-tune the render performance for your hardware and 
project. The following properties are available:

•	 Render Quality: A lower setting for this property makes editing your com-
position easier, while a higher value represents a greater degree of quality 
as you work. 

You can set it from 1 to 300 with the associated slider control.

•	 Shadows Resolution: The higher the MB value this is set to, the more real-
istic the shadows cast upon your 3D content will appear. 

You can choose values of Half (2 MB), Full (16 MB), or Double (128 MB) from 
the drop-down.

•	 Shadows Smoothness: The Smoothness property works alongside Render 
Quality and indicates how smooth the shadows appear as they are gener-
ated. A high setting can negatively affect performance while you work in 
the composition but will give smoother results. 

Set this from 1 to 32 with the slider. 

•	 Shadows Casting Box Size: The casting box determines the area within 
which shadows are produced in your composition. Keeping this size only as 
large as needed will keep things from being too laggy, as it would be point-
less to cast shadows in areas that are not visible, for example. 

•	 Shadows Casting Box Center: The casting box size is measured from this 
center point. Since you are working in 3D space, you must set the center 
across all three dimensions: X, Y, and Z. 

•	 Fit to Scene: This button will automatically set the Casting Box Size and 
Casting Box Center properties to match your composition content. 

Only content capable of casting shadows is considered. 
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You can alternatively access the Advanced 
3D Render Options dialog box from 
below the composition panel. Click the 
3D Renderer drop-down and choose the 
Renderer Options list item. 

This provides quicker access to make adjust-
ments as you work, since it displays the dialog box immediately. 

Exploring the Major Features of the Advanced 3D Renderer
Now that you are familiar with how to activate the Advanced 3D renderer and 
tweak the options to your liking, let’s look at the major features enabled by this 
rendering engine in After Effects. 

3D Model Support
One of the most important features of the new rendering engine is the ability 
to work with true 3D models in a composition. After Effects supports the GLB 
and GLTF formats for import and use in any composition using the Advanced 3D 
render engine. 

GLB and GLTF are highly popular file formats and include not only the 3D meshes 
that form a model but also any materials and images placed on them. 

HDRi Image-Based Lighting
High dynamic range imaging (HDRi) files are generally shot as equirectangular 
images and include extra information regarding lighting due to how HDR images 
are created. Using HDRi imagery in a composition enables you to use this light-
ing information as the source for environmental lights that have a direct effect on 
3D layers and how they are lit in a scene.1

1. Image sourced from https://hdri-haven.com/hdri/abandoned-cemetary

TIP  You can also switch 
between 3D rendering 
engines from this same 
drop-down, but this is 
a choice that should 
be made early on. 
You usually would not 
switch the 3D renderer 
in the middle of work-
ing on a composition. 
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You can gather HDRi images from several sources, including the Substance 3D 
Assets Collection or Adobe Stock (see Chapter 1). The image file in this figure was 
gathered from HDRI-HAVEN, which is a resource dedicated to making free, high-
quality HDRi images available to 3D artists.

Camera and Light Extraction
Not only can GLB and GLTF files contain 3D models and related materials, but they 
can also hold information regarding cameras and lights. These cameras and lights 
can be extracted from imported 3D files of this kind and used as cameras and 
lights in a composition. 

To extract any lights that are present in a 3D model in your composition, select 
the layer with the 3D model and choose Layer > Light > Create Lights from 3D 
Model from the application menu. 

To extract any cameras that are present in a 3D model in your composition, select 
the layer with the 3D model and choose Layer > Camera > Create Cameras from 
3D Model from the application menu.

If the extracted lights and cameras include animation, keyframes will be placed on 
the timeline. 

2D/3D Effect Workflows
It’s important to remember that you can combine 2D and 3D layers in the same 
composition. The Advanced 3D rendering engine enables effects that reference 
other layers to mingle across 2D and 3D space. This allows effects such as Dis-
placement Map, Vector Blur, or Calculations to use a 3D model layer as a source to 
create highly stylized renders.

We’ll explore much of this new Advanced 3D rendering feature set in the remain-
der of this chapter, but first let’s design a 3D model in Substance 3D Stager for the 
composition.
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Designing a 3D Product for Motion Design
Before you venture back into After Effects to explore the new Advanced 3D render 
engine, you’ll need access to a suitable 3D model to work with. As you saw in 
Chapter 6, you can use Substance 3D Stager to design models and export them 
in many different file formats, some of which can be used in an After Effects 
composition. 

Creating a New Project
Launch Substance 3D Stager and create a new file to design a simple 3D model for 
export. You’ll use starter assets and a few custom decorative elements to form and 
brand the mesh. 

Let’s create a new project to work with. 

1.	 Click Create New on the home screen or choose File > New from the applica-
tion menu. 

This creates a fresh Substance 3D Stager project.

2.	 From the application menu, choose File > Save to display the Save As 
dialog box. 

3.	 Browse to a location on your local file system that you will remember and name 
the file mosquito.ssg. 
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4.	 Click Save to save the project and return to your empty scene in Substance 
3D Stager. 

You now have an empty Substance 3D Stager project ready to work with. This envi-
ronment exists only for your 3D model design and export, so don’t be concerned 
about the environment or camera properties, since you will be exporting the 
model along with any applied design elements and not rendering the content. 

Designing a Branded Product
Now that you have a clean project to work in, you need to identify a 3D model and 
then apply a set of chosen materials to it for greater realism.

1.	 Ensure that the Assets panel is activated and visible along the left side of the 
Substance 3D Stager interface. If it is not, click the Assets button  in the 
lower left of the interface to activate it. 

Next, you will choose a 3D model and select appropriate materials to place on 
the various mesh parts that form the model. 

2.	 In the Starter Assets tab of the Assets panel, 
type tube in the search field at the top to 
display any assets that contain “tube” in their 
name.

If you do not see any models appear, be sure 
none of the filters below the search field are 
active. 
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3.	 Click the Cream tube model from the set of assets that appear.

The tube is added to the very center of your environment and appears as an 
entry in the Scene panel. 

4.	 In the Scene panel, open the cream_tube mesh group to reveal the indi-
vidual mesh parts that compose the model.

One mesh represents the tube body, and the other represents the tube cap. 
Each mesh can have its properties adjusted independently of the other. 

NOTE  Each part of the cream_tube group is brought into the project with a set of sim-
ple default materials applied. The meshes must have these plain materials at this stage 
so that you can visualize the actual model—much like how paths in Illustrator must 
have some sort of appearance properties to visualize them when they’re not selected.

5.	 In the cream_tube group, select the body_mesh object.

The body_mesh object is highlighted in the Scene panel, indicating that 
it is now selected. 

Additionally, the visual model part in the environment exhibits a blue 
outline, and the Properties panel changes to display properties specific 
to the selected object. 

The tube body includes a boring gray default material that you will change 
to something more realistic and interesting. 

6.	 In the Starter Assets tab, search for the term plastic to display several 
materials. 

Many starter assets are meant to exhibit the look of plastic in some way. 
Quite a lot of choices!

7.	 Scroll through the materials and locate the Shinny Plastic material. It 
appears as a reflective, deep orange material with subtle creases. 
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8.	 Click the material preview to apply it to the 
selected body_mesh object.

Notice that since only the body_mesh object was 
selected, the Shinny Plastic material is applied to 
that individual part of the overall model group. 
If the entire group were selected, the cap_mesh 
object would take on this appearance as well. 

9.	 Select the cap_mesh object in the Scene panel.

10.	In the Starter Assets tab, click the Hard Plastic material to apply it to the cap 
of the tube.

Since you did not change or clear out the previous search for “plastic,” you did 
not need to perform a fresh search. 

The Hard Plastic material is applied to the cap_mesh object.

Adjusting Material Properties
You could leave these materials at their default appearance, of course, but the tube 
is a bit too orange for the overall design. To finish working with these materials, 
you will adjust the color of the Shinny Plastic material.

1.	 In the Scene panel, select the body_mesh object again and look at the 
Properties panel.
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2.	 Click the Material tab in the Properties panel and ensure the Shinny 
Plastic material is selected to view the properties that you can adjust. 

Many, many properties can be adjusted, and they differ greatly from 
material to material. 

3.	 Scroll down in the Shinny Plastic section of the Substance properties 
until you locate the Color property, and then click it to display the color 
picker overlay. Adjust the color to more yellow and less orange. 

I am using the value #C5870D, which can be entered into the Hex input box in 
the color picker overlay. 

With individual materials chosen, applied, 
and adjusted, the basic design for the 
cream tube model is complete. 

It already looks very realistic with the 
softer, creased look of the tube body and 
the harder, duller appearance of the plastic 
cap. Applying a set of visually distinctive 
materials to a model in this way is a great 
method of achieving a realistic look for 
your design. 

NOTE  If you do not see 
Hex as your unit type in 
the color picker overlay, 
click the displayed unit 
type to select it from 
the drop-down. Avail-
able types are RGB, 
HSL, HSV, HWB, CMYK, 
and Hex.
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Applying Branding Assets to the Design
To complete the cream tube design, you will include specific branding assets in the 
After Effects composition. These branding assets include a pattern and a label. 

The exercise files for this chapter include a file named pattern.png. You will apply 
this striped pattern, which was designed in Illustrator, across the body of the tube. 
It will give your 3D model more character and help visually align it with other 
products that are part of this campaign. 

The exercise files for this chapter also include a file named label.png. This file is a 
label designed in Adobe Express specifically for the product itself, which is a skin 
cream that wards off bothersome mosquitoes in the warmer months. 

With both branding images in mind (and on-hand), you’ll now apply them to the 
cream tube 3D model. 

Working with the Background Pattern
You will place the background pattern on the tube first and then place the label. Of 
course, you can always adjust the stacking order of these images afterward, but it 
is better to start in the proper placement order.

1.	 Return to the Substance 3D Stager mosquito.ssg 
project and select the body_mesh object in the 
cream_tube group from the Scene panel. 

You will be applying image assets only to this 
mesh. 
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2.	 In the Properties panel, select the Material tab. The Shinny Plastic material 
should be selected, as it is the only material available.

3.	 Click the Place Image On Model button  below the Shinny Plastic material. 

A file browser dialog box appears.

4.	 Select the file pattern.png and click Open.

The image is mapped roughly onto the surface of the tube. 

5.	 In the Properties panel, ensure the Graphic 
material is selected and change the Placement 
setting from Decal to Fill. 

Decal placement treats the image asset like a 
sticker or label, while Fill placement stretches 
the image out across the entire mesh to fill 
every last bit. 

6.	 Ensure you have the Select tool  chosen. A 
transform overlay will appear across the image 
applied to the object. 
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7.	 Adjust the following values of the image until you get an interesting result: 

•	 Position: Drag the image in the transform overlay. 

•	 Rotation: Drag the little circle that protrudes from the overlay. 

•	 Repeat: Drag the four squares around the overlay. 

These properties can also be adjusted through the Offset and Repeat 
properties in the Properties panel when an image is selected in the 
Material tab. 

I used the settings shown in the image for my example. 

Working with the Label
To complete the tube design, you will place the label image on the tube, overlaying 
both the material and the pattern image. 

1.	 Select the Shinny Plastic material in the Material section of the Properties 
panel.

2.	 Click the Place Image On Model button  
beneath the material.

If a graphic is selected instead of the underly-
ing material, the Place Image On Model button 

 will not appear. 

224    ADOBE CREATIVE 3D WORKFLOWS



3.	 In the file browser dialog box that appears, select the image file label.png and 
click Open.

The label image is placed on the tube as a decal, and a transform overlay 
appears around it. 

4.	 Use the transform overlay to adjust the Position, Rotation, and Scale proper-
ties of the label so that it sits squarely on the front surface of the tube. 

NOTE  You might have 
worried that because 
you selected the mate-
rial, which is visually 
placed beneath the 
pattern image in the 
Properties panel, the 
new image would 
appear beneath the 
pattern image. This 
would be the case in 
other software, like 
Adobe Photoshop, but 
in Substance 3D Stager, 
these image layers are 
always added to the 
top of the stack no 
matter what. 

NOTE  You can adjust 
the stacking order of 
images placed on a 
model. To do so, simply 
drag each image to 
a new position in the 
Material tab of the 
Properties panel. You 
cannot move a mate-
rial up and down the 
stack—only images. 
To layer materials, you 
can use other tools, like 
Substance 3D Painter, 
as you did in Chapter 6.
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5.	 Adjust the camera view if necessary to change your view and achieve the ideal 
placement for the label. Chapter 6 covered how this can be done with the Orbit 

, Pan , and Dolly  tools. 

The 3D model design is now complete! 

6.	 Switch the Ray Tracing toggle  to the active position to view the 
cream tube in a more realistic way. 

This renders a more realistic preview of the product, with all materials and 
images applied. 

Notice that the label and pattern images conform to the creases and devia-
tions across the tube because they were placed on the Shinny Plastic material. 
And Ray Tracing renders reflections and shadows in a much more complex and 
realistic manner. 

7.	 Once you are finished admiring your work, switch the Ray Tracing toggle 
 to the inactive position. 

Ray Tracing takes much more computing power to render your content than 
the real-time preview render, so it should be used sparingly. 
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Exporting 3D Models for After Effects
You are nearly finished with Substance 3D Stager and will soon move to After 
Effects to design motion content using your newly designed 3D model. The 
only thing left to do is export the design in a format that is compatible with the 
Advanced 3D render engine. 

1.	 Choose File > Export > Scene from the application menu.

The Export Scene dialog box appears with the default settings. 

After Effects supports only the 3D model formats GLB and GLTF in the 
Advanced 3D render engine. I suggest exporting as GLB, as this produces a 
single file instead of a collection of files (as GLTF would).

2.	 Select GLB from the Format drop-down.

The other settings in the dialog box work fine for our purposes, but if you need 
to, you can change the Save To location to something more accessible to you.

3.	 Click Export to complete the export process. 

The export is saved as a GLB file in the location 
you specified. 

If you ever choose to create a GLTF file, you 
will have a set of files to deal with instead of 
just one. 
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Creating Simple 3D Motion in Substance 3D Stager

Before jumping back into After Effects, note that Substance 3D Stager also features a set of motion design 
tools, however simplistic. 

To access a timeline that appears along the bot-
tom of the interface, click the Timeline button 
in the lower left of the interface. Once animation is 
added to an object in your project, you can control 
the playback through the timeline controls. 

To add animation to an object, access the Properties panel with that object selected and then click the 
Animation tab to reveal the set of animation choices. 

Substance 3D Stager includes two 
animation choices that are activated 
with a toggle switch: Orbit and Spin.

• Orbit: Activates animation that 
enables one object to orbit 
another. This is very useful when 
applied to a camera or a light. You 
must also specify the target object 
it will orbit around. 

• Spin: A bit simpler than Orbit, this 
choice activates animation that 
spins the selected object around. 
This is best to use when you want 
to showcase all sides of an object. 

The animation choices share several 
properties:

• Target Offset: This offsets your 
motion by a distance measured in centimeters along each of the three axes. The default is no offset at 
all, with each being a value of 0 cm. 

• Duration: This determines how long or short your animation is. The default is 3 seconds.

• Rotation: Measured in degrees, this determines how much of a full 360° rotation is achieved across the 
given duration. The default is, of course, the full 360°.

• Reverse: This checkbox reverses the direction of your motion when activated.  

• Easing: This set of common easing algorithms adds a bit of weight and dynamic physicality to the 
motion.

Of course, you want to have full control over any motion given to your 3D model, and that is where After 
Effects steps in. 

228  ADOBE CREATIVE 3D WORKFLOWS



3D Motion Design in After Effects
Now that you have a well-designed 3D model, you can begin creating an After 
Effects composition that uses the Advanced 3D rendering engine. You’ll start 
by creating a new project, importing your GLB file, and animating it across a 3D 
composition. 

Creating a New Composition
Before you can use the 3D model you’ve designed in Substance 3D Stager, you’ll 
need to create a new After Effects composition and save your project. 

1.	 In After Effects, click the New Project button on the Home screen or choose 
New > New Project from the application menu.

The Home screen disappears, and you are prompted to create a new 
composition. 

2.	 Click the large New Composition button in the center of the screen, or choose 
Composition > New Composition from the application menu, to create a new 
composition.

The Composition Settings dialog box appears. 

3.	 In the Composition Settings dialog box, enter Mosquito for the 
Composition Name and choose Social Media Landscape – 1280x720 – 
30 fps from the Preset menu. Set Duration to 0:00:10:00 (10 seconds) and 
choose black (#000000) for the Background Color. 
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4.	 Click OK.

The Composition Settings dialog box closes, and a new composition is 
created according to your choices.

5.	 Save your project by choosing File > Save from the application menu. 

A save dialog box appears.

6.	 Choose a location for the file on your computer and name the file Mosquito.aep. 

7.	 Click Save. 

You now have a new After Effects project file that contains a single empty compo-
sition. You will spend the remainder of this chapter working in the composition 
just created. 

Importing a 3D Model
You spent a lot of time in Substance 3D Stager designing the cream tube model, 
layering it with branding assets, and tweaking everything so it appears just as you 
like. You’ll now import that model into After Effects to use it in your composition.

3D model files are imported into After Affects much like any other asset.

1.	 Ensure your Project panel is open and locate the file mosquito.glb, which you 
exported from Substance 3D Stager. 

The only item in your Project panel is your Mosquito composition. 

TIP  Remember early 
in this chapter when 
we looked at the 3D 
Renderer tab and the 
options in it? You could 
adjust the 3D renderer 
at this point, but you 
don’t need to because 
the act of adding a 3D 
model to a composi-
tion automatically 
triggers the switch to 
Advanced 3D. 
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2. Drag mosquito.glb directly onto the Project panel from your fi le system to add 
it to the panel. It will appear as a folder named Mosquito.

3. Open the Mosquito folder to reveal the mosquito.glb fi le inside it. 

Recall that a GLB fi le contains all meshes, textures, and other assets in a single 
fi le. If you were to import a GLTF fi le, you would see many diff erent types of 
assets in this folder—perhaps even subfolders. 

The Mosquito composition should be open in the timeline below. If it is not, 
double-click it in the Project panel to open it in the timeline.

You will need the composition open to add the 3D model to it. 

4. Add the mosquito.glb fi le to the Mosquito composition by dragging it from the 
Project panel into the timeline. 

Drop the fi le into the left or right area of the timeline; it makes no diff erence. 

The Model Settings dialog box appears, and you can make adjustments to how 
your model appears in the composition. 

NOTE You could also 
choose File > Import > 
File from the applica-
tion menu to locate 
and import your 3D 
model. Either method 
provides the same 
result.
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This dialog box offers choices for how your 3D model will scale in the composi-
tion and how its position is affected when scaling. The Basic tab focuses on 
object scaling, and the Advanced tab allows you to choose the units used to 
measure the scale and which of the three axes determines what is considered 
“up” for this model, determining how the gizmo overlay appears and how each 
axis influences the model.

5.	 Select Do Not Affect Position from the Object Position While Scaling drop-
down if it is not already selected. Leave Object Scale and the other parameters 
at their default values, and click OK. 

Now that the 3D model is available in the composition, you can see it is quite 
small and not ideally positioned to fill the frame. 

6.	 To adjust its appearance, choose the Selection tool  from the tools at the 
top of the interface. Ensure that the mosquito.glb layer is selected, and use the 
gizmo overlay to adjust the scale, rotation, and position of your 3D model to 
view the details of your work so far. 

In the figure, I’ve adjusted my object so that it better fills the frame, and the 
details of the materials, patterned background, and label can be easily viewed 
and appreciated. 

Don’t worry about getting the tube positioned and scaled in any meaningful way 
just yet; you’ll be more precise in the next section, when you begin animating the 
object across time. 

NOTE  Now that a 3D 
model has been added 
to the composition, 
Advanced 3D appears 
as the selected ren-
derer in the lower right 
of the Composition 
panel. 
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Adding Motion to the 3D Model
Now that the 3D model is imported and included in a composition, it’s time to add 
some motion to it! Although this is a new capability of After Effects, the process 
for giving motion to a 3D model is conveniently the same as with just about any 
other asset.

1.	 Open the Transform properties of the mosquito.glb layer and move the play-
head to the 4-second position, 0:00:04:00. 

2.	 Click each Stopwatch toggle  to the left of the Position, Scale, and 
Orientation properties. 

Keyframes are inserted at the 4 second mark along the timeline for the chosen 
transform properties. 

The most direct way to set up your motion design is to start with the end.

3.	 Use the gizmo overlay or adjust the numeric transform properties to place the 
tube product in a prominent position in the composition frame. 
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If you would prefer direct values for these 
properties, set them as follows: 

•	 Position: 190, 465, -55

•	 Scale: 1080%, 1080%, 1080%

•	 Orientation: 0°, 7°, 80°

This results in a tube that fills the screen 
while facing the viewer and being slightly 
tilted to keep the view interesting.

You can always deviate from these choices if desired, of course. Just remember 
that if you do so your results may differ from the figures in this chapter. 

Now, let’s set the second set of keyframes.

4.	 Move your playhead to the 2-second mark along the timeline, 0:00:02:00, and 
click the Insert Keyframe icon  to the left of the property name to dupli-
cate keyframes for the Position, Scale, and Orientation properties. 

This sets these property values to be identical across time between the two 
sets of keyframes you created. 

You should have identical keyframes for Position, Scale, and Orientation 
properties at both 0:00:02:00 and 0:00:04:00 along the timeline. 

The tube of cream should emerge from the bottom of the screen to the previ-
ously set Position, Scale, and Orientation property settings. 

You should be at the first keyframe, at 0:00:02:00, which is your starting point.

Next, you will set the 3D model so that it is much smaller in scale, rotated 
differently from its final value, and positioned out of frame beyond the bottom 
of the composition.

5.	 Using either the gizmo overlay or the 
numeric property values to adjust the fol-
lowing transform properties:

•	 Position: 250, 1200, 1640

•	 Scale: 345%, 345%, 345%

•	 Orientation: 295°, 325°, 30°

Again, you may deviate from these 
values, but the result will differ from what you see here. 
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The tube should be rather small and appear lost in blackness at this point. You 
will, of course, embellish the composition with additional artifacts to keep 
things interesting for the viewer, but the motion of the centerpiece tube asset 
is of primary importance.

TIP  Chapter 5 explained that you can enable Draft 3D mode to view content outside 
the frame in your composition. This is useful when you want an object to emerge from 
outside the frame and into full view.

If you play back the motion you’ve created, it will be very linear and not so 
interesting. You can fix this by applying easing to the keyframes. 

6.	 Using the Selection tool , drag a selection rectangle across all the key-
frames in the timeline.

The selected keyframes are highlighted in blue.

7.	 Choose Animation > Keyframe Assistant > Easy Ease from the application 
menu to create simple easing across the selected keyframes. 
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The selected keyframes change from a diamond shape to an hourglass, indicat-
ing that an ease has been applied. 

This action produces a much more dynamic and physical motion across the 
keyframes’ property transitions. Play back your composition to see how much 
smoother the animation is now. 

The tube emerges from the bottom of the screen, rotates slightly, scales up, and 
settles into position in the center of the frame. The primary motion for this com-
position is now complete. 

Compositing with Additional Elements
At this point in the project, you’ve imported and granted dynamic motion to the 
3D model of the mosquito repellent cream product. Yet, it exists in a black void and 
could be more engaging for the viewer. You will now add some additional design 
elements, including an AI-generated background, some 3D text, and environmen-
tal lighting derived from HDRi panoramic imagery. 
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Generating Background Content with Adobe Firefly
Although you could use stock photography or commission artwork or a photograph 
as a background for your motion design, you have options for creating all sorts of 
assets through generative AI platforms. 

Adobe Firefly is a new set of generative AI tools that you can access via https://
firefly.adobe.com/. It is increasingly being integrated into traditional products like 
Photoshop, Illustrator, and Express. 

Firefly has many advantages over its competitors. It has been ethically trained on 
a dataset of Adobe Stock materials along with openly licensed work and pub-
lic domain content with expired copyright. Other generative AI services have 
been trained on content simply scraped from the open web, which is problematic 
because copyrighted materials are included in such a dataset. When using Firefly, 
this is not a concern.

Additionally, Adobe has declared that content generated through Firefly is com-
mercially viable. You do not have to worry about whether someone is going to 
come after you and declare that you’ve stolen their work. 

Let’s use Firefly to create a suitable background for your motion content.

1.	 In your web browser, visit https://firefly.adobe.com/ and locate one of the Text 
To Image modules that are prominently displayed on the page.

2.	 In the text prompt field, enter soft texture consisting of greens and 
oranges, very dark, painterly strokes, obscured by mist and click the 
Generate button  to have Firefly interpret your text prompt into a 
visual asset.

Being as descriptive as possible with your text prompt is likely to achieve 
results that more closely match what you envision. 
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The results appear, along with several additional options in the right column 
that you can tweak to improve or modify the visuals generated through the 
initial prompt. Since your After Effects composition is framed at a 16:9 
resolution, you should tweak the Aspect Ratio value.

3.	 Select Widescreen (16:9) in the Aspect 
Ratio drop-down. 

I also selected Photo for the Content Type 
and used Firefly Image 2 for the genera-
tive AI model. 

Below these choices are even more ways of 
tweaking the resulting imagery.

4.	 Select the following values to tweak the 
result:

•	 Color and Tone: Warm Tone

•	 Lighting: Dramatic Light

•	 Composition: Wide Angle

These options generate a visual of a hot, 
muggy environment that’s prone to be 
inhabited by many mosquitoes. 

The Prompt area below the images reflects 
the choices made by adding tags along-
side the original text prompt. 

You can remove these tags, if desired, by 
clicking the small x icon to the right of 
each tag.

You can also adjust the initial text prompt from here to further refine the 
results being generated.
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5.	 Click Refresh  to the right of the text prompt to refresh the generated 
visuals based on your refinements.

A new set of four images is generated.

6.	 Click the image that most closely matches your vision to view it in greater 
detail. 

7.	 Select the More Options icon  in the upper right of the image to download 
the image to your computer for use in After Effects and other applications. 
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The image asset downloads to your computer as a high-resolution JPEG. 

The image I produced measures 2688 pixels wide and 1536 pixels high. This is 
much larger than the After Effects composition that it was created for and should 
work well as a background element for the motion design. 

Now that you have a suitable background image—thanks to Firefly—you can 
complete the After Effects composition. 

Adding the Generated Background Image
Now that you have a suitable background asset, it is time to compose it in the 
motion design.

It will not be animated, but subtle panning or scaling might be appropriate, if 
desired. 

1.	 Drag the Firefly-generated JPEG from your system file browser into the Project 
panel, or choose File > Import > File from the application menu, to import it. 

The imported image appears in the Project panel. 

TIP  When using After 
Effects, it is always best 
to keep all your source 
assets in the same 
folder so as not to mis-
takenly delete or lose 
anything that is neces-
sary to the project. 
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2.	 Drag the imported image into the Timeline panel to add it as a layer. Be 
sure to drag it to the lowest point in the layer stack so that it appears behind 
the tube.  

Since the resolution of the image from Firefly is greater than that of your 
composition, you’ll need to make it a 3D-enabled layer and make some other 
adjustments. 

3.	 Click the 3D Layer toggle  to the 
right of the layer name, and set the 
following property values in the 
Properties panel or via the layer 
transform properties group in the 
timeline:

•	 Scale: 85% 

•	 Position: 640, 360, 1335 in. 

This ensures the background image is placed behind the tube in 3D space and 
that it is scaled appropriately. 

The background image generated with Firefly integrates perfectly with the tube 
model from Substance 3D Stager. You really do get the feel of an oppressive, 
humid, mosquito-filled environment with this combination of assets! 

NOTE  You need to 
activate the stopwatch 
only when working 
with a change in prop-
erty values over time 
through keyframes. 
Simply adjusting prop-
erties without the stop-
watch active, as you’ve 
done here, adjusts the 
object’s properties 
across the entire span 
of the timeline without 
motion.
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You aren’t finished with this composition yet, though; you still need to add text 
content and adjust the lighting.

Firefly and 3D Workflows

Although you used Firefly in this project to generate background imagery, there are many more possible 
workflows with generative AI and 3D-capable software applications as part of Adobe Creative Cloud and 
Substance 3D.

A great example of this is material 
generation in Substance 3D Sampler. 
You saw how to generate your own 
materials using this software in 
Chapter 2. Of course, you can also 
generate very realistic materials 
using content generated with Firefly 
and then transformed in Substance 
3D Sampler. 

The prompt used to create these 
textures, for example, was “closeup 
detail of dirt and small pebbles from 
above.” As with all things generative 
AI, the more specific your prompt is, the more likely the resulting image will conform to your request.

Also of note are more direct 3D integrations through Firefly, as showcased through beta experiments such 
as Project Gingerbread, a service that leverages Firefly capabilities to generate visuals through a combina-
tion of 3D primitives and generative text prompts. These elements work together to influence the composi-
tion and structure of the resulting visual that is generated. This is a great example of what to expect from 
generative AI in the months and years ahead. 
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Creating 3D Text
You are approaching the completion of this project. The addition of a suitable 
background image has certainly helped create a fully formed composition in After 
Effects, but there is more to be done. 

You will now add text that implores the viewer to purchase the product 
before summer strikes and the mosquitoes are out in full force. 

1.	 Choose the Text tool  from the tools at the top of the interface, 
and click in the top left of the Composition panel to create a new 
text object. 

2.	 Type Buy Before Summer! for the text content.

3.	 In the Properties panel, set the following values:

•	 Position: 55 for x and 125 for y 

•	 Typeface: Arial Black

•	 Text size: 72px 

•	 Text fill color: #FFE972 (light yellow)

•	 Use the alignment options in the paragraph properties to 
left‑align the text. 

The text appears across the background image. Since similar colors 
are present in the image and the text, some of the text is difficult to read. 

You can remedy this in several ways, but here you will use the Advanced 3D 
renderer to transform your text to native 3D.

NOTE  If you do not 
have Arial Black 
available, substitute a 
typeface that is similar 
in weight and appear-
ance, although you may 
need to adjust other 
properties if you do so. 
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4.	 In the timeline, click the Enable 3D Layer toggle  for the newly created 
text layer.

The text object now includes additional 3D properties, thanks to the Advanced 
3D renderer. 

5.	 To provide a more 3D appearance to the text, open the layer properties and 
then the Geometry Options and Material Options property groups. 

These property groups are available because the text is a 3D layer. Additional 
properties are available in the Transform property group, similar to what you 
saw in Chapter 5. 

6.	 Change Bevel Style to Angular and adjust the Extrusion Depth value to 10.

With these changes made to the text properties, a visible bevel surrounds the 
edges of each character, greatly improving readability. 

With the text element created and transformed to a 3D object, the only thing left 
to do with this object is transition it into view through a small bit of animation. 
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Animating 3D Text
The text message should appear only after the animation of the 3D tube has 
completed. Right now, the text is always present across the entire composition. 
You will now prepare the text for animation and use standard keyframing tech-
niques to perform a small transition. 

1.	 Using the Selection tool , right-click the 
text in the Composition panel, and align the 
anchor point to the visual center of the text by 
choosing Transform > Center Anchor Point 
in Layer Content from the context menu. 

This causes properties such as Scale and 
Rotate to align to the center of the text instead 
of to the left edge, which was the original placement of the anchor point. 

2.	 Move the playhead to the 5-second mark, at 0:00:05:00, and open the 
Transform properties group. 

3.	 Enable the Stopwatch toggle  for the Scale and Opacity properties. 

You will use these properties to design a short fade-in transition where the 
text scales up a small amount. 

4.	 Move the playhead a bit to the right, to 0:00:05:13, and click the Insert 
Keyframe button  to the left of the Scale and Opacity properties. 

This duplicates the previous keyframes for both properties, which ensures 
these properties retain their current values at the end of the transition. 

5.	 Leave the keyframe values at 0:00:05:13 at 100% and click the Go to Previous 
Keyframe button  to the left of either property to return to the keyframes 
at 0:00:05:00. 

6.	 Adjust Scale to 66% and Opacity to 0%.
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These changes make the text initially transparent 
and 66% smaller.

Now let’s finish the motion off with a bit of easing. 

7.	 Select all four keyframes by dragging a selection 
rectangle around them in the timeline.

The keyframes are highlighted with a blue outline.

8.	 Choose Animation > Keyframe Assistant > Easy 
Ease from the application menu. 

The diamond-shaped keyframes transform into small 
hourglass shapes, indicating that an ease has been 
applied. 

9.	 Play back the full composition to view the results of 
your work. 

All the animation is now complete, but there are still a few items left to examine 
before you close out this project. 

Applying an HDRi Image as an Environmental Light
The Advanced 3D rendering engine allows for a new type of lighting, based on 
HDRi photography.

Included in the files for this chapter is an image named rainforest_trail_8k.hdr.

Image sourced from https://hdri-haven.com/hdri/tropical-forest

This is an HDRi file that has been downloaded from HDRI-HAVEN, although 
you can use any HDRi photo that you like, of course. The image file is a high-
resolution, equirectangular 360° photo taken in a rainforest environment. This is 
perfect for your mosquito composition. 
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You will now create a new environment light and use the HDRi image for its 
source. You will first get the HDRi file into the existing composition so that you 
can use it.

1.	 Choose File > Import > File from the application menu and select the .hdr file. 
Alternatively, drag the file into the Project panel from your system file browser. 

2.	 Click Open. 

3.	 Drag the .hdr file from the Project panel to the bottom of the layer stack in the 
timeline. 

Since the image is going to be used as a source for the light you will create, it 
doesn’t need to be visible to the viewer in any way. Placing it at the very bot-
tom of the layer stack completely obscures it from view. 

4.	 Select the top layer in the composition layer stack—this should be the text 
layer—and then choose Layer > New > Light from the application menu.

The Light Settings dialog box appears, allowing you to make choices about 
what sort of light to create and its specific properties. 

5.	 In the Light Settings dialog box, choose Environment from 
the Light Type menu and click OK. 

A new light named Environment Light 1 is created and added as 
a new layer at the top of the layer stack. 

6.	 Open the layer properties and then the Light Options group. 

7.	 Click the Source dropdown and select the HDRi image layer. 

Because After Effects is aware that this layer contains HDRi 
data, it is presented as a source option for use in this light. 
Non‑HDRi images will not appear in this drop-down. 
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The composition takes on a look that is much more overcast—as though 
beneath a vast jungle environment and potentially filled with mosquitoes.

Although the environment light has the intended effect on the look of the 
composition, you can add additional light to bring focus directly onto the 
centerpiece.

8.	 Select the topmost layer in the layer stack and choose Layer > New > Light 
from the application menu.

The Light Settings dialog box appears. 

9.	 In the Light Settings dialog box, 
choose Point for the Light Type and 
enter #F45922 (bright orange) for the 
Color.

10.	Click OK. 

A new point light is added to the 
composition, making the lighting more 
intense across the cream tube. 

248    ADOBE CREATIVE 3D WORKFLOWS



If desired, you can adjust the position of the point light and other properties to 
achieve the exact look you want. 

With the lighting taken care of, your 3D-motion design is complete. 

Rendering the 3D Motion Design
Now that you’ve completed the composition, it’s time to render it for distribution. 
When you created the composition, the duration was set to 10 seconds. Although 
this provides a good amount of wiggle room for designing motion, 10 seconds is 
a bit too lengthy for the final output. That’s okay because After Effects includes 
mechanisms that allow you to render a specific segment of the composition. 

You’ll now set the work area to render and produce a distributable MP4 video file. 
By default, the work area is set to the entire duration of the composition. To set 
it to include a segment of the composition, you’ll adjust the work area start and 
only end markers at the top of the timeline—located above the layers but below the 
time marks.

1.	 Locate the Work Area Start marker, at 0:00:00:00, and drag it to the 01s 
mark. Similarly, locate the Work Area End marker, at 0:00:10:00, and drag it 
to the 08s mark.

TIP  You can also use 
keyboard shortcuts 
to set the marker 
definitions. Move the 
playhead to 01s and 
press B to set the Work 
Area Start marker; then 
move the playhead 
to 08s and press N to 
set the Work Area End 
marker. This is espe-
cially useful if you are 
not sure which markers 
to adjust, since there 
are a few along the 
timeline. 
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This effectively trims the resulting content. When rendering this composition, 
only the work area you’ve defined will be rendered into the final MP4 video. 

2.	 Be sure that the composition is selected in either the Project panel or the 
timeline, and choose Composition > Add to Render Queue from the applica-
tion menu. 

The render queue opens alongside the composition timeline, and a new job 
displays.

3.	 Ensure that Output Module is set to H.264 – Match Render Settings – 15 
Mbps and set the Output To name and location.

4.	 Click the Render button.

The composition work area is rendered as an MP4 video file to the location and 
name you specified. 

5.	 Locate the file on your computer. 

The duration should be 7 seconds, since that is 
how you defined the work area in the composi-
tion timeline. 

That’s it! You’ve completed the project. You’ve 
used many skills and workflows to produce this 3D 
motion design across Adobe Express, Illustrator, 
Substance 3D Stager, Firefly, and After Effects. It 
is truly amazing what can be achieved through the 
combination of 2D and 3D software. 

In the next chapter, we’ll consider several addi-
tional workflows and related techniques. 
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Numbers
360-degree views, 179–181
2D designs

2D objects, 90, 96, 212
2D Photoshop layers, 50, 51
2D/3D effects workflows, 216
3D additions to, vii–viii, 50
3D transformations for, 3, 

77–78
planes in, 74, 75

3D and Materials panel, 72–76
3D assets

file types, 14–15
libraries of, 27
lights, 11
materials/textures, 9–11
mixed reality, 12–14
models, 8–9
Photoshop support for, 51
rendering, 12
resources for acquiring, 

15–20
Stager, 125

3D concepts, xii, 21–22
3D design

2D/3D integration for, 
vii–viii

animating elements of, 
102–112

approaches to, 2–3
artwork imports for, 91–94
Firefly for, vii
layers for, 96–97
unified approach to, 2

3D environments
adding models to, 144–146
external materials for, 

130–133
ground surface design, 

128–130
lighting for, 246–249
properties of, 127
Stager tools, 122–127
texturing in Painter, 

133–144

Index

3D materials/textures
AI-powered, 31–33
Capture for, 26–37
defined, 9–11
Designer for procedural, 

256–257
external, in Stager, 130–133
Firefly and, 242
Illustrator, 70–71, 79–82
imported to Aero, 157–159
Painter texturing, 133–144
Photoshop, 50–68
Sampler for advanced, 37–48
Stager, 125, 220–221

3D models/objects
2D cross-sections to, 77–78
2D objects and, 90
adding additional, 144–146
Aero starter assets, 162–163
animating, 107–111
complex, 77–86
defined, 8–9
ground surface design 

with, 128
Illustrator exports of, 86–88
imported to After Effects, 

230–232
libraries of assets, 252
lighting for, 82–84
materials applied to, 79–82
motion content for, 212–216, 

233–236
painting details on, 138–142
properties for, 75–76
simple, 72–76
Smart Materials for, 137–138
Stager, 125, 217–228
transformed 2D objects vs., 3
Type choices for, 74–75
using true, 112
VR space for, 207–208

3D Types, 74

A
acquiring 3D assets, 15–20
Actions Wizard, 194–196, 201
Adobe

augmented reality 
platforms, 152

new AI tools, vii
resources/community, xi–xii
software installation, ix–x
subscriptions, 2, 3
See also specific Adobe 

application by name
Adobe Animate Classroom in a 

Book, 275
Adobe Creative Cloud Classroom 

in a Book: Design Software 
Foundations with Adobe 
Creative Cloud, 2

Adobe Premiere Pro Classroom in 
a Book, 277

Adobe Stock, 16
Advanced 3D Render engine, 

212–216, 230, 246
advanced materials, 37–48
Aero

3D models for, 128
defined, 6
importing content to, 

157–159
lighting in, 11
Mobile and Desktop, 

152–154
new project creation, 

155–157
Photoshop content in, 

159–162
Stager exports to, 147–149
starter assets, 162–165
supported file formats, 158

Aero Desktop (Beta), 153–154
Aero Mobile, 152–153
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classic tweens, 270, 272
code, VR, 194–197, 201–206
colors

Designer, 256
light color in Illustrator, 83
Stager color picker, 221
Substance 3D materials, 

56, 60
community

3D assets, 19–20, 71
Adobe resources/support, xi
Community Assets library, 

252–255
Community Assets library, 

252–255
compositions

adjusting settings of, 94–95
After Effects exports of, 

113–120
animating 3D, 102–112
importing Illustrator, 93
new After Effects, 229–230
rendering video files from, 

117–120
understanding Illustrator, 

90–91
compression, 117–120
Contrast, 57
Convert to Symbol, 189, 190, 199
Create, 28
Creative Cloud

3D capabilities of, 5–6
3D skills with, viii, 1
desktop application, 6
generative AI in, 242
installing Capture via, 26
knowledge of, ix
Libraries, 27
subscription to, ix
Substance 3D and, 2, 3
support/resources, xi–xii
updates, 6–7
workflows, vii–viii

cross-section paths, 77–78

D
default workspace, 92
defined, 13–14
Depth values, 75
Designer, 256–257
desktop applications

Aero, 153–154
Creative Cloud, 6–7
Modeler, 255
Sampler, 37, 38

mobile, 8, 26–27, 152–153
See also specific Adobe 

application by name
archiving materials, 47–48
aspect ratio, 238
Assets panel, 124–125
augmented reality (AR)

.glb format for, 149
defined, 13
interactive/immersive 

additions, 165–170
“lite” versions of, 173
virtual reality vs., 176
See also Aero

B
background

Firefly for dynamic, 237–242
pattern on objects, 222–224
Photoshop layer, 53–57
Stager environmental, 127
texture wrapping, 184, 187

basic material exports, 35
Behaviors panel, 166–170
Bevel, 76
Bezier curves, 78, 106
Blender, 256, 277
branded products, 218–220, 

222–226
brushes, painting details with, 

138–142

C
cameras

Aero, 164
After Effects, 216
animating 3D, 102–104
concept defined, 21–22
equirectangular images 

via, 180
Orbit tool for moving, 100
Stager controls for, 130, 146

Cap option, 76
Capture

AI-powered materials in, 
31–33

capturing materials, 28–31
defined, 6
installing software, 26–28
material use in, 34–37
mobile-focused, 37

Cinema 4D, 213, 277
classic 3D Illustrator tools, 70
Classic 3D render engine, 213

After Effects
2D objects in 3D space, 90
3D design in, 2, 3, 96–102
Advanced 3D Renderer, 

212–216
animating 3D compositions, 

102–112
cameras in, 22
composition export, 113–120
Draft 3D view, 101
importing models to, 

230–232
motion design in, 212–216, 

229–236
new 3D tools for, 112, 213
project setup, 90–95
saving projects, 95
software needed, 5
source assets, 240
Stager exports to, 146, 227

AI enhancement
lighting, 11
materials/textures, 31–33
Mockup, 262
See also Firefly generative AI

Allegorithmic, 2
anchor points, 77
Android, 153
Animate

3D objects in, 207–208
defined, 3
equirectangular image 

imports, 179–181
new project creation, 

177–179
panoramic VR animations, 

264–275
portals between scenes, 

188–197
project testing, 185–186
scene creation, 181–182
stage in, 266
texture wrapping, 182–185, 

186–187
virtual reality in, 14, 152
web browser testing, 

197–198
workspace configuration, 179

animated GIFs, 113–115
Apple App Clips, 173
applications

Creative Cloud, 5–6
desktop installs/updates, 

6–7
“lite” versions of, 173
menu navigation, 20–21
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K
keyframe timing, 105, 106, 

241, 270

L
labels, 224–226
Layer Styles, 67–68
layers

3D design space, 96–97
Aero imports, 160
Background layer, 53–57
effects layers, 65
parallax movement in, 

98–99
parametric filters on, 260
Photoshop, 52, 225
Sampler, 41–42
stacking order, 91, 225
Stager, 225
Substance 3D Painter, 139

Layers panel, 39
Learn, 28
lesson files, x–xi
libraries, asset, 27, 252–255
lights/lighting

3D motion graphics, 111–112
Aero, 170
After Effects extracts, 216
defined, 11
Designer, 256
drop shadow effect, 62–65
environmental, 246–249
gradient blends, 65–67
HDRi, 215, 246–249
Illustrator, 71, 82–84
Photoshop, 60
ray tracing and, 72
Stager, 125, 127, 146

logo mockups, 261–264
Luminosity, 57

M
macOS, 256
Make it tile filter, 44
masks, 58, 139, 259
materials. See 3D materials/

textures
Materials panel

Illustrator, 71, 82
Photoshop, 52–62

MDL file format, 15, 257
Media Encoder, 113, 116
menu navigation, 20–21

G
generative fill, 265
Ghost layer, 98
GIFs, animated, 113–115
gizmos, 22, 97, 109, 233, 234
GLB format, 149, 157, 215
GLTF file format, 14, 86, 87, 215
Google Instant Apps, 173
gradient blends, 65–67
Graph Editor, 105–107
ground surface design, 128–130

H
H.264 standard codec, 117
HDRi (high dynamic range 

imaging), 215
HTML5 Canvas, 181

I
Illustrator

3D tools, 2, 3, 69, 70–72
After Effects imports from, 

91–94
artwork creation in, 90
complex 3D objects, 77–86
familiarity with, 1
graphics controls, 82
layer organization in, 91
lighting presets, 83
Mockup in, 261–264
rendering objects, 84–86
simple 3D objects, 72–76
software needed, 5

immersive AR, 165–170
imports

3D models to After Effects, 
230–232

Aero, 157–159
Illustrator art to After 

Effects, 91–94
images to Animate, 179–181
photos to Sampler, 40–41

Inflate Both Sides option, 75
Inflate objects, 74, 75
installation, 6–7
intensity, light, 83
interactions

augmented reality, 165–170
virtual reality objects, 

192–206, 264

details, painting, 138–142
Dimension, 82, 127, 152
Discover, 28
displacement, 33, 133
Dolly, 130, 162
Draft 3D view, 101, 235
drop shadow effect, 62–65
Dynamic Link, 113

E
easing, 105, 106, 107, 236, 

272–274
editing

duplicates for, 37
gradients, 67
materials to AI, 32–33

educators, resources for, xii
environments, scenic 3D. See 3D 

environments
equirectangular images, 

179–181, 275
exports

Aero, 172–174
archiving and, 47–48
basic vs. AI-powered, 35
Illustrator, 86–88
Photoshop to Aero, 159–162
Sampler materials, 46–47
Stager to Aero, 147–149
textures to Stager, 142–144

Extrude objects, 74

F
FBX file format, 14
file types

.glb format, 149, 157
3D asset files, 14–15
Aero-supported, 158
materials export files, 35
video files, 117, 275
See also specific file format 

by name
Firefly generative AI

3D workflows and, 242
background graphics via, 

237–249
generative fill, 265
launching of, vii, viii
text-to-image content 

in, 188
FLA files, 181
FPS (frames per second), 114
Free Transform tool, 190, 191, 

200, 271
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motion design for 
distribution, 249–250

natively to video files, 
117–120

NVIDIA Iray, 141
Painter, 141
Stager, 146–147

Repeat Uniform Scaler, 55
Repeat Uniformly, 55
Repeat X/Repeat Y, 55
resolution, 55
Revolve Angle, 75
Revolve objects, 74, 77–78, 79
rotation

3D object property of, 76
immersive AR, 168–169
Revolve object types, 74, 75
Rotation in Illustrator, 76, 79
Substance material, 57, 60

S
Sampler

additional filters, 44–46
cropping/tiling texture, 

41–44
defined, 4
Designer and, 257
exporting materials, 46–47
familiarity with, 35
Firefly and, 242
importing photos, 40–41
material refinement in, 

34–37
menu navigation, 38
new project creation, 37–39

Saturation, 57
saving projects, 95, 136
SBSAR file format, 15, 51, 257
scaling objects, 159
scaling scenes, 182–185
Sculpting, 255–256
seams, 34
shadows

After Effects tools for, 214
drop shadow effect, 62–65
Ray Tracing for, 12, 72, 84

sharing work, 35, 170–174
Smart Filters, 59
Smart Materials, 137–138
Smart Objects, 54, 59
software installation, ix–x
Spin tool, 228
spotlighting, 111–112

Pan tool, 130, 162
panoramic VR animations, 

264–275
parallax movement, 98–99
Parametric Filters, 257–261
parametric models, 125
PBR (physically based 

rendering), 12
peachpit.com, xi
perspective shifts, 3
photographs, 28–29, 40–41
Photoshop

3D tools in, 2, 50–51
discontinued features, 50–51
familiarity with, 1
generative fill, 265
imports to Aero, 159–162
layers, 52, 225
materials in, 52–68, 80
parametric filters, 257–261
software needed, 5
Stager exports to, 146

Physically Sized property, 55
Pixar, 14
Plane type objects, 74, 75
point handles, 78, 106
portals, in VR scenes, 188–197
position, 57, 60
Premiere Pro, 152, 275–277
prerequisites, system, ix
previews, Draft 3D, 101
Procedural Material Creation, 

256–257
Project Gingerbread, 242
Project panel, 38
publication to the web, 173–174, 

208–209

R
Random Seed, 55
raster content, 85, 160
ray tracing, 12, 72, 84, 85, 

133, 226
REAL files, 15, 172–173
Refine view, 29
refinements, 29, 34–37
rendering

Advanced 3D Render engine, 
212–216

animated GIFs, 113, 114
captured materials, 29
defined, 12
Draft 3D view for, 101
Illustrator options, 84–86

mobile work
Aero, 152–153, 170
applications for, 6
installing apps, 8, 26–27

Mockup, 261–264
Modeler, 255–256
models, 8–9
modern 3D Illustrator tools, 

70–71
Moss filter, 45
motion graphics in 3D

3D objects, 107–111, 212–216
After Effects designs, 

229–236
camera animation, 102–104
Firefly for background 

graphics, 237–249
panoramic VR animations, 

264–275
rendering for distribution, 

249–250
Stager, 217–228
timing for dynamic motion, 

104–107, 235–236, 274
MOV files, 117
movie clip symbols, 188–191, 

269
MP4 files, 117, 119, 249

N
names, 33
navigation, 20–21, 28
NVIDIA Iray, 141

O
OBJ file format, 14, 86, 87
Object view, 70–71
Offset, 75
online material, xi
opacity, 109, 139
Orbit tool, 100, 130, 162, 228
overlays, 22, 97

P
Painter

brush details in, 138–142
defined, 4
exports to Stager, 142–144
new project creation, 

134–136
Smart Materials, 137–138
texturing in, 133–144
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Viewport, 39
virtual reality (VR)

.glb format for, 149
3D objects in, 207–208
augmented reality vs., 176
interactive objects, 192–206
Modeler support, 255
panoramic VR animations, 

264–275
portals between scenes, 

188–197
Premiere Pro for, 275–277
publishing projects, 208–209
texture wrapping in, 

182–185, 186–187
web browser testing, 

197–198
See also Animate

Volume, 75
VR 360, 177, 178, 179, 264, 275
VR Panorama, 264–265
VR View, 185–186

W
web browser testing, 274–275
web publications, 173–174
WebGL (Web Graphics Library), 

207, 208
workspace, resetting, 92, 179

X
XR (mixed reality), 12–14

T
Taper, 75
text

animating, 245–246
applying materials to, 60–62
creating 3D, 243–244
layer styles for, 67–68

texture wrapping, 182–185
textures/materials. See 3D 

materials/textures
Tile filter, 44
tiling, 41–44
timelines, 103, 268–269
timing, dynamic motion, 

104–107, 235, 236, 241
titles, 60–62, 67–68
triggers, 166
tweening, 270, 272
Twist option, 75
typefaces, 243

U
USD/USDA/USDZ (Universal 

Scene Description), 14, 86
UV mapping, 10–11

V
vector shapes

applying materials to, 80
converted to 3D object, 79
Mockup for, 261
path design, 73, 77
rendering as, 85

video files
compositions to, 116
equirectangular, 275
natively rendering to, 

117–120

Stager
3D model for motion design, 

217–228
Assets panel, 124–125
cameras in, 22, 146
defined, 4
Dimension vs., 127
exports to After Effects, 227
external materials for, 

130–133
graphics controls, 82
ground surface design, 

128–130
interface for, 122–124
lighting in, 11, 125, 127, 146
motion graphics in, 228
new project creation, 

126–127, 217–218
rendering in, 146–147
texture imports to, 142–144

starter assets
Aero, 162–165
defined, 15–16
Sampler, 39

stock assets, 16
subscriptions, 2, 3
Substance 3D

AI-powered materials in, 
31, 34

assets, 17–20, 252–255 
Creative Cloud and, viii, 2, 

3, 5
exporting/archiving 

materials, 47–48
Firefly and, 242
materials presets, 56
Modeler, 255–256
Photoshop and, 53–68
properties, 55
subscription to, ix–x, 3–4
tutorials, 278
workflows, vii–viii
See also specific application 

by name
Substance 3D Sampler. 

See Sampler
system requirements, ix
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