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86

WORKING WITH CODE

Lesson overview
In this lesson, you’ll learn how to work with code and do the 
following:

• Write code using code hinting and Emmet shorthand.

• Set up a CSS preprocessor and create SCSS styling.

• Use multiple cursors to select and edit code.

• Collapse and expand code entries.

• Use Live Code view to test and troubleshoot dynamic code.

• Use Inspect mode to identify HTML elements and associated 
styling.

• Access and edit attached files using the Related Files interface.

�is lesson will take about 90 minutes to complete. To get the lesson 
files used in this lesson, download them from the webpage for this book 
at adobepress.com/DreamweaverCIB2022. Define a new site for the 
lesson04 folder, as described in the “Getting Started” section at the 
beginning of this book. Name the new site lesson04.

4

http://adobepress.com/DreamweaverCIB2022
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Dreamweaver’s claim to fame is as a visually based 
HTML editor, but its code-editing features don’t take a 
back seat to its graphical interface, and they offer few 
compromises to professional coders and developers.
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Creating HTML code
As one of the leading WYSIWYG HTML editors, Dreamweaver allows users to cre-
ate elaborate webpages and applications without touching or even seeing the code 
that does all the work behind the scenes. But for many designers, working with the 
code is not only a desire but a necessity.

Dreamweaver has always made it as easy to work with a page in Code view as it is 
in Design view or Live view. Dreamweaver can unify your entire web development 
team by providing a single platform that can handle almost any task.

You’ll often find that a specific task is actually easier to accomplish in Code view 
than in Live view or Design view alone. In the following exercises, you’ll learn more 
about how Dreamweaver makes working with the code an effortless and surpris-
ingly enjoyable task.

Writing code manually
As you complete this and the next eight lessons, you will have numerous opportu-
nities to view and edit code by hand. But for anyone jumping directly to this lesson, 
this exercise will provide a quick overview of the topic. One way to experience 
Dreamweaver’s code-writing and editing tools is to create a new file.

1 Define a site based on the lesson04 folder downloaded from your account page, 
as described in the “Getting Started” section at the beginning of the book.

2 Select Developer from the Workspace menu.

All the code-editing tools work identically in either workspace, but the Devel-
oper workspace focuses on the Code view window and provides a better experi-
ence for the following exercises.

� Note: If you have 
not already down-
loaded the project files 
for this lesson to your 
computer from your 
Account page, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.

� Note: Some tools 
and options are avail-
able only when Code 
view is active.
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3 Choose File > New.

�e New Document dialog appears.

4 Choose New Document > HTML > None. 
Click Create.

Dreamweaver creates the basic structure of a webpage automatically. �e cur-
sor will normally appear at the beginning of the code when you are using the 
Developer workspace.

As you can see, Dreamweaver provides color-coded tags and markup to make it 
easier to read, but that’s not all. It also offers code hinting for ten different web 
development languages, including but not limited to HTML, CSS, JavaScript, 
and PHP.

5 Choose File > Save.

6 Name the file myfirstpage.html and save it in the lesson04 folder.

� Note: In all screen 
shots, we use the Classic 
color theme, which can 
be selected in Prefer-
ences. See the “Getting 
Started” section at the 
beginning of the book 
for more details.

http://my$$$�rstpage.html
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7 Insert the cursor after the opening <body> tag.  
Press Enter/Return to create a new line. Type <

A code-hinting window appears, showing you a list of HTML-compatible codes 
you can select from.

8 Type d

�e code-hinting window filters to code elements that start with the letter d. 
You can continue to type the tag name directly or use this list to select the 
desired element. By using the list, you can eliminate simple typing errors.

9 Press the Down Arrow key.

�e dd tag in the code-hinting window is highlighted.

10 Continue pressing the Down Arrow key until the tag div is highlighted.  
Press Enter/Return.

�e tag name div is inserted in the code. �e cursor remains at the end of the 
tag name, waiting for your next input. For example, you could complete the tag 
name or enter various HTML attributes. Let’s add an id attribute to the div 
element.

� Note: Depending on the settings in your program, tags may close automatically, and you 
may have to move the cursor to complete the next step. This behavior can be turned off or 
adjusted in the Code Hints section of Preferences.

11 Press the spacebar to insert a space.

�e hinting menu opens again, displaying a different list; this time the list con-
tains various appropriate HTML attributes.

� Note: Line breaks, 
indenting, and other 
whitespace is not 
required in HTML and 
is used only to make 
the code easier to read 
and edit.
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12 Type id and press Enter/Return.

Dreamweaver creates the id attribute, complete with equals sign and quota-
tion marks. Note that the cursor appears within the quotation marks, ready for 
your entry.

13 Type wrapper and press the Right Arrow key once.

�e cursor moves outside the closing quotation mark.

14 Type >

When you type the >, Dreamweaver closes the div element automatically. As 
you see, the program can provide a lot of help as you write code manually. But it 
can help you write code automatically too.

15 Choose File > Save.

Writing code automatically
Emmet is a web-developer toolkit that was added to Dreamweaver a while ago 
and enables you to supercharge your code-writing tasks. When you enter short-
hand characters and operators, Emmet enables you to create whole blocks of code 
with just a few keystrokes. In the following exercise you will experience the power 
of Emmet.

1 If necessary, open myfirstpage.html.

2 In the Code view window, insert the cursor within the div element and press 
Enter/Return to create a new line.

� Note: In HTML5, 
quotation marks are no 
longer required for tag 
attributes. However, 
older browsers and 
applications may 
not display the code 
properly without them. 
It does no harm to use 
them, so continue to 
add them to your code.

http://my$$$�rstpage.html
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Emmet is enabled by default and works whenever you are typing in Code view. 
In most websites a navigation menu appears at the top of the page. HTML5 uses 
the <nav> element as the foundation of site navigation. You will insert the menu 
and learn how to populate it with menu items.

3 Type nav and press Tab.

Dreamweaver creates the opening and closing tags all at once. �e cursor 
appears inside the nav element, ready for you to add another element, some 
content, or both.

HTML navigation menus are usually based on an unordered list, which consists 
of a <ul> element with one or more child <li> elements. Emmet allows you 
to create multiple elements at the same time, and by using one or more opera-
tors, you can specify whether the subsequent elements follow the first (+) or are 
nested one within the other (>).

4 Type ul>li and press Tab.

A <ul> element containing one list item appears. �e greater-than symbol (>) 
is used to create the parent–child structure you see here. By adding another 
operator, you can create several list items.

5 Choose Edit > Undo.

�e code reverts to the ul>li shorthand. It’s easy to adapt this shorthand 
markup to create a menu with five items.

6 Edit the existing shorthand phrase as highlighted ul>li*5 and press Tab.
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A new unordered list appears, this time with five <li> elements. �e asterisk 
(*) is the mathematical symbol for multiplication, so this latest change says 
“<li> times 5.”

To create a proper menu, you also need to add a hyperlink to each menu item.

7 Press Ctrl+Z/Cmd+Z or choose Edit > Undo.

�e code reverts to the ul>li*5 shorthand.

8 Edit the existing shorthand phrase as highlighted: ul>li*5>a

If you guessed that adding the markup >a would create a hyperlink child ele-
ment for each link item, you are correct. Emmet can also create placeholder 
content. Let’s use it to insert some text in each link item.

9 Edit the shorthand phrase as highlighted: ul>li*5>a{Link}

Adding text within braces passes it to the final structure of the hyperlink, but 
we’re not done yet. You can also increment the items, such as Link 1, Link 2, 
Link 3, and so on, by adding a variable character ($).

10 Edit the shorthand phrase as highlighted ul>li*5>a{Link $} and press Tab.

� Note: The cursor must be outside the brace before you press Tab.

�e new menu appears fully structured, with five link items and hyperlink 
placeholders incremented 1 through 5. �e menu is nearly complete. �e only 
things missing are targets for the href attributes. You could add them now 
using another Emmet phrase, but let’s save that change for the next exercise.

11 Insert the cursor after the closing </nav> tag. 
Press Enter/Return to create a new line.

Let’s see how easy it is to use Emmet to add a header element to your 
new page.

12 Type header and press Tab.

As with the <nav> element you created earlier, the opening and closing header 
tags appear, with the cursor positioned to insert the content. We will model the 
header after one you will use in Lesson 6, “Creating a Page Layout.” You need to 

� Note: Adding the 
new line makes the 
code easier to read and 
edit, but it has no effect 
on how it operates.
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add two text components: an <h2> for the company name and a <p> element 
for the motto. Emmet provides a method for adding not only the tags but also 
the content.

13 Type h2{Favorite City Tour}+p{Travel with a purpose} and 
press Tab.

�e two elements appear complete and contain the company name and motto. 
Note how you added the text to each item using braces. �e plus (+) sign desig-
nates that the <p> element should be added as a peer to the heading.

14 Insert the cursor after the closing </header> tag.

15 Press Enter/Return to insert a new line.

As you can see, Emmet enables you to quickly build complex multifaceted 
 parent–child structures like the navigation menu and the header, but it doesn’t 
stop there. As you string together several elements with placeholder text, you 
can even add id and class attributes. To insert an id, start the name with the 
hash symbol (#); to add a class, start the name with a dot (.). It’s time to push 
your skills to the next level.

16 Type main#content>aside.sidebar1>p(lorem)^article> 
p(lorem100)^aside.sidebar2>p(lorem) and press Tab.

� Note: The entire 
phrase may wrap to 
more than one line in 
Code view, but make 
sure there are no spaces 
or line breaks within the 
markup.
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A <main> element is created with three child elements (aside, article, 
aside), along with id and class attributes. �e caret (^) symbol in the short-
hand is used to ensure that the article and aside.sidebar2 elements are 
created as siblings of aside.sidebar1. Within each child element, you should 
see a paragraph of placeholder text.

Emmet includes a Lorem generator to create blocks of placeholder text auto-
matically. When you add lorem in parentheses after an element name, such as 
p(lorem), Emmet will generate 30 words of placeholder content. To specify 
a larger or smaller amount of text, just add a number at the end, such as 
p(lorem100) for 100 words.

Let’s finish up the page with a footer element containing a copyright 
statement.

17 Insert the cursor after the closing </main> tag. Create a new line. 
Type footer{Copyright 2022 Favorite City Tour. All rights 
reserved.} and press Tab.

18 Save the file.

Using a few shorthand phrases, you have built a complete webpage structure and 
some placeholder content. You can see how Emmet can supercharge your code-
writing tasks. Feel free to use this amazing toolkit at any time to add a single ele-
ment or a complex, multifaceted component. It’s there anytime you need it.

�is exercise has barely scratched the surface of what Emmet can do. It is sim-
ply too powerful to fully describe in just a few pages. But you got a good peek at 
its capabilities.

Check out https://emmet.io to learn more about Emmet. Check out  
https://docs.emmet.io/cheat-sheet/ for a handy Emmet shorthand cheat sheet.

Working with multicursor support
Have you ever wanted to edit more than one line of code at a time? Dreamweaver 
offers multicursor support. �is feature allows you to select and edit multiple lines 
of code at once to speed up a variety of mundane tasks. Let’s take a look at how 
it works.

https://emmet.io
https://docs.emmet.io/cheat-sheet/
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1 If necessary, open myfirstpage.html as it appears at the end of the previous 
exercise.

�e file contains a complete webpage with nav, header, main, and footer 
elements. �e content features classes and several paragraphs of placeholder 
text. �e <nav> element includes five placeholders for a navigation menu, but 
the href attributes are empty. For the menu and links to appear and behave 
properly, you need to add a filename, URL, or placeholder element to each link. 
In HTML, the hash mark (#) is used as placeholder content until the final link 
destinations can be added.

2 Insert the cursor between the quotation marks in the href="" attribute in 
Link 1.

Normally, you would have to add a hash mark (#) to each attribute individually. 
Multicursor support makes this task much easier, but don’t be surprised if it 
takes you a little practice. Note that all the link attributes are aligned vertically 
on consecutive lines.

3 Hold the Alt key (Windows) or Option key (macOS) and drag the mouse down 
through all five links.

Using the Alt/Option key enables you to select code or insert cursors in con-
secutive lines. Be careful to drag down in a straight line. If you slip a little to the 
left or right, you may select some of the surrounding markup. If that happens, 
you can just start over. When you are finished, you should see a cursor flashing 
in the href attribute for each link.

Customizing the Common toolbar
Some of the code-editing exercises in this lesson require tools that may not appear in the interface by default. 
The Common toolbar was previously called the Coding toolbar and appeared only in Code view. The toolbar 
appears in all views, but some tools may be visible only when the cursor is inserted directly in the Code view 
window.

If the exercise calls for a tool that is not visible, even with the cursor in the proper position, you may need to cus-
tomize the toolbar yourself. This can be done by first clicking the Customize Toolbar icon  and then enabling 
the tools within the Customize Toolbar dialog. At the same time, feel free to disable tools you don’t use.
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4 Type #  
�e hash mark (#) appears in all five attributes at the same time.

�e Ctrl/Cmd key enables you to select code or insert cursors in nonconsecu-
tive lines of code.

5 Hold the Ctrl/Cmd key and click to insert the cursor between the p and the > 
bracket in each of the three opening <p> tags in the <main> element.

6 Press the spacebar to insert a space, and type class="first"

�e attribute appears simultaneously in all three <p> tags.

7 Save the file.

Multicursor support can save tons of time in repetitive code-editing tasks.

Commenting your code
Comments allow you to leave notes within the code—invisible in the browser—to 
describe the purpose of certain markup or provide important information to other 
coders. Although you can add comments manually at any time, Dreamweaver has a 
built-in feature that can speed up the process.

1 Open myfirstpage.html using the Developer workspace.

2 Insert the cursor after the opening tag 
<aside class="sidebar1">.

3 Click the Apply Comment icon . 

http://my$$$�rstpage.html
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A pop-up menu appears with several comment options. Dreamweaver supports 
comment markup for various web-compatible languages, including HTML, 
CSS, JavaScript, and PHP.

4 Choose Apply HTML Comment.

An HTML comment block appears, with the text cursor positioned in 
the center.

5 Type Insert customer testimonials into Sidebar 1

�e comment appears in gray between the <!-- and --> markup. �e tool can 
also apply comment markup to existing text.

6 Insert the cursor after the opening tag 
<aside class="sidebar2">.

7 Type Sidebar 2 should be used for content related to the tour 
or product

8 Select the text created in step 7. 
Click the Apply Comment icon .

A pop-up menu opens.

9 Select Apply HTML Comment.

Dreamweaver applies the <!-- and --> markup to the selection. If you need to 
remove existing comment markup from a selection, click the Remove Comment 
icon  in the toolbar.

10 Save all files.
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You’ve created a basic webpage, complete with placeholder text. �e next step is 
to style the page. Dreamweaver supports CSS preprocessors. In the next exercise, 
you’ll learn how to set up and create CSS styling using a preprocessor.

Working with CSS preprocessors
One of the biggest additions to Dreamweaver over the last few years was support 
for industry-standard CSS preprocessors. Known by the acronyms LESS (Leaner 
CSS), Sass (Syntactically Awesome Style Sheets), and SCSS (Sassy CSS), these are 
scripting languages that enable you to extend the capabilities of cascading style 
sheets with a variety of productivity enhancements that can then be compiled in a 
standard CSS file. �ese languages provide a variety of benefits for designers and 
developers who prefer to write their code by hand, including speed, ease of use, 
reusable snippets, variables, logic, calculations, and much more. No other software 
is needed to work in these preprocessors, but Dreamweaver also supports other 
frameworks, such as Compass and Bourbon.

In this exercise, you’ll get a taste of how easy it is use preprocessors with Dream-
weaver as well as what advantages they offer compared to a regular CSS workflow.

Enabling a preprocessor
Support for CSS preprocessors is site-specific and must be enabled for each 
site defined in Dreamweaver, as desired. To enable LESS, Sass, or SCSS, you 
first define a site and then enable the CSS Preprocessors option within the Site 
Definition dialog.

1 Select Site > Manage Sites.

�e Manage Sites dialog appears.

2 Select lesson04 in the Manage Sites window. 
Click the Edit icon  at the bottom of the Manage Sites window.
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�e Site Definition dialog for lesson04 appears.

3 Select the CSS Preprocessors option in the Site Definition dialog.

�e CSS Preprocessors option contains six subcategories, including General, 
Source & Output, and options for various Compass and Bourbon frameworks. 
You can check out the Dreamweaver Help topics for more information on these 
frameworks. For this exercise, you need only the features that are built into the 
program itself.

4 Select the General category.

When selected, this category features the on/off switch for the LESS, Sass, or 
SCSS compiler, as well as various options for how the languages operate. For 
our purposes, the default settings will work fine.

5 Select the Enable Auto Compilation On File Save checkbox to enable the pre-
processor compiler, if necessary.

When this is enabled, Dreamweaver will automatically compile your CSS from 
your LESS, Sass, or SCSS source files whenever they are saved. Some designers 
and developers use the root folder of the site for compilation. In this case, we’ll 
separate the source and output files in distinct folders.

6 Select the Source & Output category.

�is category enables you to designate the source and output folders for your 
CSS preprocessor. �e default option targets the folder where the source file 
is saved.

7 Select the Define Output Folder option.
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When you enable this option, Dreamweaver displays a file path pointing to a 
folder (css). �is folder doesn’t exist yet, but Dreamweaver will create it auto-
matically. If you want to use a different folder, you will have to use the Browse 
For Folder  icon to select or create the folder.

8 Click the Browse For Folder icon beside the Source Folder field.

9 Navigate to the Site Root folder.

10 Select the existing Sass folder, and click Select Folder/Choose.

11 Save the changes and click Done to return to your site.

�e CSS preprocessor is enabled, and the source and output folders are now desig-
nated. Next, you’ll create the CSS source file.

LESS or Sass—the choice is yours
LESS and Sass offer similar features and functions, so which one should you choose? 
That’s hard to say. Some think that LESS is easier to learn but that Sass offers more 
powerful functionality. Both make the chore of writing CSS by hand faster and easier 
and, more importantly, provide significant advantages for maintaining and extend-
ing your CSS over time. There are lots of opinions on which preprocessor is better, 
but you’ll find that it comes down to personal preference.

Before you decide, check out the following links to get some informed perspectives:

• blog.udemy.com/less-vs-sass/

• css-tricks.com/sass-vs-less/

• keycdn.com/blog/sass-vs-less

Dreamweaver provides two syntaxes for Sass. In this lesson, we use SCSS (Sassy CSS), 
which is a form of Sass that is written like and looks more like regular CSS.

Creating the CSS source file
When using a preprocessor workflow, you do not write the CSS code directly. 
Instead, you write rules and other code in a source file that is then compiled to the 
output file. For the following exercise, you’ll create a Sass source file and learn some 
of the functions of that language.

http://blog.udemy.com/less-vs-sass/
http://css-tricks.com/sass-vs-less/
http://keycdn.com/blog/sass-vs-less
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1 Select Standard from the Workspace menu.

2 Choose Window > Files to display the Files panel, if necessary. 
Select lesson04 from the Site List dropdown menu, if necessary.

3 If necessary, open myfirstpage.html and switch to Split view.

�e webpage is unstyled at the moment.

4 Choose File > New.

�e New Document dialog appears. �is dialog allows you to create all types 
of web-compatible documents. In the Document Type section of the dialog, 
you will see the LESS, Sass, and SCSS file types. We’ll use SCSS in the follow-
ing exercises. SCSS is a flavor of Sass that uses a syntax that is similar to regular 
CSS and that many users find easier to learn and work with.

5 Choose New Document > SCSS. 
Click the Create button.

A new blank SCSS document appears in the document window. 

6 Save the file as favorite-styles.scss in the Sass folder you targeted as the Source 
folder in the previous exercise.

http://my$$$�rstpage.html
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You don’t need to create the CSS file; the compiler in Dreamweaver will do 
that for you. You’re all set to start working with Sass. �e first step is to define 
variables. Variables are programmatic constructs that enable you to store CSS 
specifications you want to use multiple times, such as colors in your site theme. 
By using a variable, you have to define it only once. If you need to change it in 
the future, you can edit one entry in the style sheet and all the instances of the 
variable will update automatically.

7 Insert the cursor into line 2 of favorite-styles.scss. 
Type $logoyellow: #ED6; and press Enter/Return.

You’ve created your first variable. �is is the main yellow color of the site theme. 
Let’s create the rest of the variables.

8 Type $darkyellow: #ED0; 
$lightyellow: #FF3; 
$logoblue: #069; 
$darkblue: #089; 
$lightblue: #08A; 
$font-stack: "Trebuchet MS", Verdana, Arial,  
Helvetica, sans-serif;

and press Enter/Return to create a new line.

Entering the variables on separate lines makes them easier to read and edit but 
does not affect how they perform. Just make sure you add a semicolon (;) at the 
end of each variable.

Let’s start the style sheet with the base or default styling of the body element. 
SCSS markup in most cases looks just like regular CSS, except in this case you’ll 
use one of your variables to set the font family.

9 Type body and press the spacebar. 
Type { and press Enter/Return.

� Note: Your color 
coding may appear 
differently than that 
pictured.
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When you typed the opening brace ({), Dreamweaver created the closing brace 
automatically. When you created the new line, the cursor was indented by 
default, and pressing Enter/Return moved the closing brace to the following 
line. You can also use Emmet to enter the settings more quickly.

10 Type ff$font-stack and press Tab.

�e shorthand expands to font-family: $font-stack;.

11 Press Enter/Return to create a new line within the body rule.  
Type c and press Tab.

�e shorthand expands to color: #000;. �e default color is acceptable.

12 Hold the Alt/Cmd key and press the Right Arrow key to move the cursor to the 
end of the current line of code.

13 Press Enter/Return to create a new line. 
Type m0 and press Tab.

�e shorthand expands to margin: 0; completing the basic styling for the body 
element. Before you save the file, this is a good time to see how preprocessors do 
their work.
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Compiling CSS code
You have completed the specifications for the body element. But you have not 
created the styling directly in a CSS file. Your entries were made entirely in the 
SCSS source file. In this exercise, you will see how the compiler that is built into 
Dreamweaver generates the CSS output.

1 Display the Files panel, if necessary, and expand the list of site files.

�e site consists of one HTML file and three folders: Sass, images, and css.

2 Expand the view of the css and Sass folders.

�e Sass folder contains favorite-styles.scss and _base.scss. �e css folder 
contains favorite-styles.css. �is file did not exist when you started the lesson. 
It was generated automatically when you created the SCSS file and saved it into 
the site folder defined as the Source folder. At the moment, the CSS file should 
contain no CSS rules or markup. It’s also not referenced in the sample webpage.

� Note: The favorite-styles.css file should have been created automatically in the previous 
exercise when the SCSS file was saved. If you do not see the .css file, you may need to shut down 
and relaunch Dreamweaver.

� Note: The order of 
the files on your screen 
may appear in a differ-
ent order than pictured.



106 LESSON 4 Working with Code

3 Select the document tab for myfirstpage.html. 
Choose View > Split > Code-Live. 
Choose View > Split > Horizontally, if necessary.

�e document window is split into two windows top to bottom, showing the 
rendered webpage in one and the code in the other. �e page shows only default 
HTML styling at this point.

4 In the Code view window, insert the cursor after the opening <head> tag and 
press Enter/Return to insert a new line.

5 Type link and press Tab.

�e shorthand expands to a <link> reference for a style sheet. It comes in with 
two attributes, rel and href. You’ll use the href attribute to link the webpage 
to the generated CSS file.

6 Insert the cursor between the quotation marks in the href attributes.

7 Type /css/

As you type, Dreamweaver displays a hinting menu for the file structure of the 
site. Once you type the second backslash, you should see the CSS file created 
automatically by the preprocessor.

8 Press the Down Arrow key to highlight the filename favorite-styles.css. 

http://my$$$�rstpage.html
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9 Press Enter/Return.

�e URL to the CSS output file appears in the attribute. �e link to the style 
sheet is now complete.

�e CSS output file is now referenced by the webpage. In the Live view win-
dow, there should be no difference in the styling, but you should now see 
favorite-styles.css displayed in the Related Files interface.

� Note: If you accidentally saved the SCSS file before this step, you may see styling in the 
HTML file and another filename in the Related Files interface.

10 Select favorite-styles.css in the Related Files interface.

Code view displays the contents of favorite-styles.css, which is empty at the 
moment. An asterisk appears next to the filename in the document tab for 
favorite-styles.scss, indicating that the file has been changed but not saved.

11 Choose Window > Arrange > Tile.

�e webpage and the SCSS source file appear side by side in the program 
window.

� Tip: You can also use 
the cursor to select the 
filename directly.
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12 Insert the cursor anywhere in the favorite-styles.scss document window and 
choose File > Save All.

� Note: It must be said that the changes in the SCSS file have not been saved until this point. If 
the program crashes before you save, you will have to start from scratch.

After a moment, the display of myfirstpage.html changes, showing the new font 
and margin settings. �e Code view window also updates to display the new con-
tents of favorite-styles.css. Each time you save the SCSS source file, Dreamweaver 
will update the output file.

Nesting CSS selectors
Targeting CSS styling to one element without accidentally affecting another is a 
constant challenge for web designers everywhere. Descendant selectors are one 
method for ensuring that the styling is applied correctly. But creating and main-
taining the correct descendant structure becomes more difficult as the site and 
style sheets grow in size. All preprocessor languages offer some form of nesting for 
selector names.

In this exercise, you will learn how to nest selectors while styling the navigation 
menu. First, you’ll set the basic styling for the <nav> element itself.

1 In the favorite-styles.scss window, insert the cursor after the closing brace (}) 
on line 13 for the body rule.

2 Create a new line; type nav { and press Enter/Return.

�e nav selector and declaration structure are created and ready for your entry. 
Emmet provides shorthand entries for all CSS properties.

3 Type bg$logoyellow and press Tab. Press Enter/Return.

�e shorthand expands to background: $logoyellow, which is the first vari-
able you created in the SCSS source file. �is will apply the color #ED6 to the 
nav element.

4 Type ta:c and press Tab. Press Enter/Return.

�e shorthand expands to text-align: center.

5 Type ov:a and press Tab. Press Enter/Return.

�e shorthand expands to overflow: auto.

� Note: Make sure 
you are working in the 
SCSS file.

http://my$$$�rstpage.html
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6 Save the source file.

�e <nav> element in myfirstpage.html displays the color #ED6. �e menu 
doesn’t look like much yet, but you’ve only just begun. Next, you’ll format the 
<ul> element. Note that the cursor is still within the declaration structure for 
the nav selector.

7 Type ul { and press Enter/Return.

�e new selector and declaration are created within the nav rule.

8 Type lis:n+m5 and press Tab.

�e shorthand expands to list-style: none and margin: 5px. �ese prop-
erties reset the default styling of the unordered list, removing the bullets and 
indent. Next, you’ll override the styling of the list items.

9 Press Enter/Return and type li {  
Press Enter/Return again.

As before, the new selector and declaration are fully within the ul rule.

10 Create the property d:ib and press Tab.  
Press Enter/Return.

�e property display: inline-block will display all the links in a single row, 
side by side. �e last element to style is the <a> for the link itself.

11 Type a { and press Enter/Return. 
Type m:0+p:10-15+c:$logoblue+td:n+bg:$lightyellow and press Tab.

�e shorthand expands to show the properties margin, padding, color, 
text-decoration, and background styling the rule a entirely within the li 
rule. Each of the rules styling the navigation menu has been nested one inside 
the other in a logical, intuitive manner and will result in an equally logical and 
intuitive CSS output.

http://my$$$�rstpage.html
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12 Save the file.

�e navigation menu in myfirstpage.html is reformatted to display a single line 
of links, side by side. �e CSS output file displays several new CSS rules. �e new 
rules are not nested as in the source file. �ey are separate and distinct. More sur-
prisingly, the selectors have been rewritten to target the descendant structures of 
the menu, such as nav ul li a. As you can see, nesting rules in the SCSS source file 
eliminates the chore of writing complex selectors.

Importing other style sheets
To make CSS styling more manageable, many designers split their style sheets into 
multiple separate files, such as one for navigation components, another for fea-
ture articles, and still another for dynamic elements. Large companies may create 
an overall corporate standard style sheet and then allow various departments or 
subsidiaries to write custom style sheets for their own subdomains, products, and 
purposes. Eventually, all these CSS files need to be brought together and called by 
the webpages on the site, but this can create a big problem.

Every resource linked to a page creates an HTTP request that can bog down the 
loading of your pages and assets. �is is not a big deal for small sites or lightly 
traveled ones. But popular, heavily traveled sites with tons of HTTP requests can 
overload a web server and even cause pages to freeze in a visitor’s browser. Too 
many experiences like this can cause visitors to flee and never return.

Reducing or eliminating superfluous HTTP calls should be the goal of any designer 
or developer, but especially those working on large enterprise or highly popular 
sites. One important technique is to cut down on the number of individual style 
sheets called by each page. If a page needs to link to more than one CSS file, it’s 
usually recommended that you designate one file as the main style sheet and then 
simply import the other files into it, creating one large universal style sheet.

http://my$$$�rstpage.html
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In a normal CSS file, importing multiple style sheets would not produce any 
benefit, because the import command creates the same type of HTTP request that 
you’re trying to avoid in the first place. But since you are using a CSS preprocessor, 
the import command happens before any HTTP request occurs. �e various style 
sheets are imported and combined. Although this makes the resulting style sheet 
larger, this file is downloaded only once by the visitor’s computer and then cached 
for their entire visit, speeding up the process overall.

Let’s see how easy it is to combine multiple style sheets into one file.

1 Open myfirstpage.html and switch to Split view, if necessary. 
Open favorite-styles.scss and choose Window > Arrange > Tile.

�e two files are displayed side by side to make it easier to edit the CSS and see 
the changes as they occur.

2 In myfirstpage.html, click favorite-styles.css in the Related Files interface.

Code view displays the content of favorite-styles.css. It contains the output of 
rules written in the SCSS source file.

3 In favorite-styles.scss, insert the cursor before the body rule (around line 9).  
Type @import "_base.scss"; and press Enter/Return to insert a new line.

�is command imports the contents of the file _base.scss stored in the Sass 
folder. �e file was created ahead of time to style other portions of your page. 
At the moment, nothing has changed, because favorite-styles.scss has not been 
saved yet.

4 Save favorite-styles.scss and observe the changes in myfirstpage.html.

If you correctly followed the instructions on how to create the HTML structure 
earlier in this lesson, the page should be entirely formatted now. When you 
examine favorite-styles.css, you will see that dozens of rules were inserted 
before the body rule. Imported content will be added starting at line 2. �is 
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may be confusing at first since the SCSS file had seven lines of code before the 
body rule. Although the @import command was at line 9 in the SCSS file, the 
variables are not passed to the final CSS directly. �ey are parsed and rendered 
into each of the rules they affect. Once the content has been imported, normal 
CSS precedence and specificity take effect. Just make sure that all rules and file 
references appear after the variables; otherwise, the variables won’t work.

5 Save and close all files.

In this section, you created an SCSS file and learned how to work with a CSS pre-
processor. You experienced various productivity enhancements and advanced func-
tionality and have glimpsed just a bit of the breadth and scope of what is possible.

Learning more about preprocessors
Check out the following books to learn more about CSS preprocessors and super-
charging your CSS workflow:

Beginning CSS Preprocessors: With SASS, Compass.js, and Less.js, by Anirudh 
Prabhu, Apress (2015); ISBN: 978-1484213483

Instant LESS CSS Preprocessor How-to, by Alex Libby, Packt Publishing (2013); 
ISBN: 978-1782163763

Jump Start Sass: Get Up to Speed with Sass in a Weekend, by Hugo Giraudel and 
Miriam Suzanne, SitePoint (2016); ISBN: 978-0994182678

Using linting support
Dreamweaver provides live code error checking. Linting support is enabled by 
default in Preferences, which means the program monitors your code writing and 
flags errors in real time.

1 Open myfirstpage.html and switch to Code view. 
If necessary, select Source Code in the Related Files interface.

2 Insert the cursor after the opening <article> tag and press Enter/Return to 
create a new line.

3 Type <h1>Insert headline here</h1>

� Note: Dreamweaver will create the opening and closing tags at once. If not, skip to step 5. 

4 Delete the closing </h1> tag.

5 Save the file.

You failed to close the <h1> element in step 3. When an error occurs, a red X 
will appear at the bottom of the document window whenever you save the page.

http://my$$$�rstpage.html
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6 Click the X icon .

�e Output panel opens automatically and displays the coding errors. In this 
case, the message says that the tag must be paired and identifies what line it 
thinks the error occurs on. �e message erroneously targets line 27, but this can 
happen because of the nature of HTML tags and structures.

7 Double-click the error message.

Dreamweaver focuses on the article in the Code view window that it identifies 
as containing the error. Since Dreamweaver is looking for the closing tag for 
the <h1> element and flags it. Unfortunately, the error message is not always 
this accurate. Dreamweaver’s linting function will get you close to the error, 
but often you will have to look earlier in the code to track down the actual 
issue yourself.

8 Insert the cursor at the end of the code 
<h1>Insert headline here. Type </h1>

� Note: If your heading closed automatically in step 3, typing </ will probably not close the 
tag. Check your preference settings for code rewriting and adjust them as desired.

Dreamweaver should now be closed. If not, go ahead and  finish it properly.

� Note: You may need 
to click the Refresh 
button to display the 
linting report.
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9 Save the file.

Once the error is corrected, the red X is replaced by a green checkmark.

10 Right-click the Output panel tab and select Close Tab Group from the 
context menu.

It’s important to be alert for this icon as you save your work. No other error mes-
sage will pop up indicating any problems, and you’ll want to catch and correct any 
errors before uploading your pages to the web server.

Selecting code
Dreamweaver provides several methods for interacting with and selecting code in 
Code view.

Using line numbers
You can use your cursor to interact with the code in several ways.

1 Open myfirstpage.html, if necessary, and switch to Code view.

2 Scroll down and locate the <nav> element (around line 11).

3 Drag the cursor across the entire element, including the menu items.

Using the cursor in this way, you can select any portion of the code or its 
entirety. However, using the cursor in this way can be prone to error, causing 
you to miss vital portions of the code. At times, using line numbers to select 
whole lines of code is easier.

4 Click the line number beside the <nav> tag.

�e entire line is selected within the window.
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5 Drag down the line numbers to select the entire <nav> element.

Dreamweaver completely highlights all seven lines. Using line numbers can save 
a lot of time and avoid errors during selection, but it doesn’t take into account the 
actual structure of the code elements, which may begin and end in the middle of a 
line. Tag selectors provide a better way to select logical code structures.

Using tag selectors
One of the easiest and most efficient ways to select code is to use the tag selectors, 
as you will frequently do in upcoming lessons.

1 Scroll down and locate the following code: 
<a href="#">Link 1</a>

2 Insert the cursor anywhere in the text Link 1. 
Examine the tag selectors at the bottom of the document window.

�e tag selectors in Code view display the <a> tag and all its parent elements, 
the same way they do in Live or Design view.
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3 Select the <a> tag selector.

�e entire <a> element, including its content, is highlighted in Code view. It 
can now be copied, cut, moved, or collapsed. �e tag selectors clearly reveal the 
structure of the code, even without referring to the Code view display. �e <a> 
is a child of the <li> element, which is a child of <ul>, which is in turn a child 
of <nav>, which is a child of <div#wrapper>, and so on.

�e tag selectors make it a simple chore to select any part of the code structure.

4 Select the <ul> tag selector.

�e code for the unordered list is entirely selected.
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5 Select the <nav> tag selector.

�e code for the entire menu is selected.

6 Select the <div#wrapper> tag selector.

�e code for the entire page is now selected. Using the tag selectors allows you to 
identify and select the structure of any element on your page, but it requires you 
to identify and select the parent tag yourself. Dreamweaver offers another tool that 
can do it for you automatically.

Using parent tag selectors
Using the parent tag selector in the Code view window makes the job of selecting 
the hierarchical structure of your page even simpler.

1 Choose Window > Toolbars > Common to display the Common toolbar, if 
necessary.

2 Insert the cursor anywhere in the text Link 1.

�e Select Parent Tag option may not be displayed by default in the Common 
toolbar. If you see the tool icon, skip to step 4, otherwise you will need to enable 
this tool before proceeding. 

3 Click the Customize Toolbar icon  and enable the Select Parent Tag tool 
before proceeding to step 4.
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4 In the Common toolbar, click the Select Parent Tag icon .

�e entire <a> element is highlighted.

5 Click the Select Parent Tag icon again or press Ctrl+[/Cmd+[ (left bracket).

�e entire <li> element is selected.

6 Click the Select Parent Tag icon.

�e entire <ul> element is selected.

7 Press Ctrl+[/Cmd+[ until <div#wrapper> is selected.

Each time you click the icon or press the shortcut key, Dreamweaver selects the 
parent element of the current selection. Once you’ve selected it, you may find 
working with long sections of code unwieldy. Code view offers other handy options 
to collapse long sections to make them easier to work with.

Collapsing code
Collapsing code is a productivity practice that makes it simple to copy or move 
large sections of code. Coders and developers also collapse code sections when they 
are looking for a particular element or section of a page and want to temporarily 
hide unneeded sections from view. Code can be collapsed either by selection or by 
logical element.
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1 Select the first three Link items in the <nav> element.

Note the Collapse icon  along the left edge of Code view; it indicates that the 
selection is currently expanded.

2 Click the Collapse icon to collapse the selection.

�e selection collapses, showing only the first <li> element and a snippet of 
text from it.

You can also collapse code based on logical elements, like <ul> or <nav>. 
Notice that each line that contains an opening element tag also displays a Col-
lapse icon.

3 Click the Collapse icon beside the line for the <nav> element.

�e entire <nav> element collapses in the Code window, showing only an 
abbreviated snippet of the entire element. In either instance, the code hasn’t 
been deleted or damaged in any way. It still functions and operates as expected. 
Also, the collapse functionality appears only in Code view in Dreamweaver; on 
the web or in another application, the code will appear normally. To expand the 
code, just reverse the process, as described in the following section.

Expanding code
When the code is collapsed, you can still copy, cut, or move it like you would any 
other selected element. You can then expand elements one at a time or all at once.

1 Click the Expand icon  beside the line for the <nav> element.

�e <nav> element expands, but the three <li> elements collapsed in the 
 previous exercise are still collapsed.

2 Click the Expand icon beside the line for the <li> elements.

All collapsed elements are now expanded. Note that the Expand icon for the 
three <li> elements disappears altogether.
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Accessing Split Code view
Why should coders be denied the ability to work in two windows at the same time? 
Split Code view enables you to work in two different documents or two different 
sections of the same document at once. Take your pick.

1 If necessary, switch to Code view.

2 Choose View > Split > Code-Code.

�e document displays two Code view windows, both focusing on  
myfirstpage.html.

3 Insert the cursor in the top window and scroll down to the <footer> element.

Split Code view enables you to view and edit two different sections of the 
same file.

4 Insert the cursor in the bottom window and scroll to the <header> element.
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You can also view and edit the contents of any related file.

5 In the Related Files interface, select favorite-styles.css.

�e window loads the style sheet into one of the windows. You can work in 
either window and save your changes in real time. Dreamweaver displays an 
asterisk (*) on any filename in the interface that has been changed but not 
saved. If you select File > Save or press Ctrl+S/Cmd+S, Dreamweaver saves the 
changes in the document where your cursor is inserted. Since Dreamweaver can 
make changes to documents even when they are not open, this feature allows 
you to edit and update even the files that are closed but linked to your webpage.

Previewing assets in Code view
Although you may be a diehard coder or developer, there’s no reason you can’t feel 
the love from Dreamweaver’s graphical display too. �e program provides visual 
previews of graphic assets and certain CSS properties in Code view.

1 Open myfirstpage.html. Select Code view.

In Code view, you see only the HTML. �e graphical assets are simply refer-
ences that appear in the CSS file favorite-styles.css.

2 Click favorite-styles.css in the Related Files interface.

�e style sheet appears in the window. Although it’s fully editable, don’t 
waste your time making any changes to it. Since the file is the output of the 
SCSS source file, any changes you make will be overwritten the next time the 
file compiles.

3 Locate the header rule (around line 5).

�e header consists of two text elements and two images. You should be able to 
see the image references in the background property.

4 Position the cursor over the markup url(../images/favcity-logo.jpg) in 
the background property (line 8).

A miniature preview of the company logo appears below the cursor.
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5 Position the cursor over the markup background-color: #ED6; in the 
 background property.

A small color chip appears, displaying the color specified. �e preview func-
tions the same way for all color models. You no longer have to guess what image 
or color you specified before you can see it in Live view or the browser.

In this lesson, you learned a number of techniques to make working with code 
easier and more efficient. You learned how to write code manually using hint-
ing and auto-code completion and how to write code automatically using Emmet 
shorthand. You learned how to check code construction using built-in linting sup-
port. You learned how to select, collapse, and expand code, as well as how to create 
HTML comments and view code in different ways.

Overall, you learned that whether you are a visual designer or a hands-on coder, 
you can rely on Dreamweaver to offer vital features and power that will allow 
you to create and edit HTML and CSS code without compromises. Remember 
these techniques as you work through the book and use any of them whenever 
appropriate.
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Review questions
1 In what ways does Dreamweaver assist you in creating new code?

2 What is Emmet, and what functionality does it provide to users?

3 Does Dreamweaver require you to install any additional software to create a LESS, 
Sass, or SCSS workflow?

4 What feature in Dreamweaver reports code errors when you save a file?

5 True or false? Collapsed code will not appear in Live view or the browser until it 
is expanded.

6 What Dreamweaver feature provides instant access to files linked or referenced within 
the document?

Review answers
1 Dreamweaver provides code hinting and auto-completion for HTML tags, attributes, 

and CSS styling as you type, along with support for JavaScript and PHP, among other 
languages.

2 Emmet is a scripting toolkit that creates HTML code by converting shorthand entries 
into complete elements, placeholders, and even content.

3 No additional software or services are needed to use LESS, Sass, or SCSS. Dream-
weaver supports these CSS preprocessors out of the box. You merely have to enable 
the compiler in the Site Definition dialog.

4 Linting checks the HTML code and structure every time you save a file and then dis-
plays a red X icon at the bottom of the document window when an error is detected.

5 False. Collapsing code has no effect on the display or operation of the code outside 
of Dreamweaver.

6 �e Related Files interface appears at the top of the document window and enables 
users to instantly access and review CSS, JavaScript, and other compatible file types 
linked to the webpage. In some cases, a file displayed in the interface will be stored 
on a remote resource on the internet. While the Related Files interface enables you to 
view the contents of all the files displayed, you will be able to edit only ones that are 
stored on your local hard drive.
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Encryption, 388
Entities, 55
Errors

broken link checks, 383, 402
in CSS syntax, 71
fixing semantic, 206–208
formatting failure from, 474
found via HTML, 52
linting support for, 112–114
from manual link entry, 351
spell checking, 284–285

Expanding code, 119
Experimentation, 46
Explicit encryption, 388
External file use, 34
External hyperlinks, 342, 360–364
Extract panel

gradient backgrounds in, 
169–173

mockup styling via, 143–145
styling elements via, 145–151
for text, 153–156
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Insert menu, 321–322
Insert panel, 322–324
Inspectors, 43–46
Installation, program, 4–5
Internal hyperlinks

on child pages, 357–359
defined, 342
home links, 352–357
relative, 349–352
within a webpage, 371–373

Internet access, 299–300
iOS, 481, 482
IP addresses, 390
ISP (Internet Service 

Provider), 390

J
JPEG (Joint Photographic Experts 

Group), 300
jQuery Mobile, 427
jQuery UI, 427

K
Keyboard shortcuts, 31–33

L
Languages. See HTML; LESS; 

Sass; SCSS 
Layout

creating menu items, 164–165
creating new elements, 

162–163
CSS conflicts, 151–153
deleting menu components, 

156–159
footer, 184–185
gradient backgrounds, 

169–173
header, 179–183
inserting menu items, 159–161
mockup image extraction, 

173–175
mockup text extraction, 

153–156
modifying Bootstrap, 196–201
new Bootstrap structures, 

175–179
online resources, 138
power positions in, 131
review questions, 186

I
Ids

attributes, 43, 370, 374
creating, 81–82, 374
id-based links, 375–376
weight of, 74

Image carousel
adding images to, 331–334
and component visibility, 455
as content model, 191
deleting components in, 247
as editable region, 212
for home page, 400
list-structured, 254
as optional, 216
styling headings and text in, 

331–334
Image Display, 44
Images

adding background, 179–183
adding to carousel, 331–334
Assets panel insertion, 

317–318
onto child pages, 336–338
Design view insertion, 

306–308
extracting mockup assets, 

173–175
formatting, 34
home page, 400
image-based links, 367
Image menu insertion, 

320–322
Image panel insertion, 

322–324
inserting, 303–306
lesson on, 294
list as structure for, 254
for mobile devices, 319–320
from Photoshop, 311–316
placeholder, 212
resizing, 308–311, 316
review questions, 339
screen size and, 448–449
template insertion, 324–328
web image basics, 296–303

img element, 304
Implicit encryption, 388
Importing text, 240–244
Inheritance theory, 72
Inline elements, 52, 69

HTML. See also Code
additions in HTML5, 55–58
as the backbone of the web, 49
comments, 98
composition of, 51–52
creating code, 88–95
creating lists, 248–254
defaults, 64–67
defined, 50
frequently used elements, 

52–55
HTML 4, 58, 65
id attributes in, 82, 370
origins of, 50–51
overview of, 48
review questions, 59
table attributes, 263, 272
textual distinctions for, 2, 3
validating template code, 

210–211
vs. CSS, 62–64

HTML elements
in Design view, 23
DOM Viewer for structure 

of, 42
Live view editing, 23, 43
Property inspector tab for, 33
structural display of, 36

HTML5
defaults, 65–66
id attributes in, 81, 82
new additions in, 55–58
semantic rules, 206
starter layouts in, 141
support, 84
tag attributes, 91

HTTP requests, 110
Hyperlinks

browser display of, 344
checking validity of, 383, 402
destination links, 374–376
email, 346
image-based, 367–370
internal, 349–359
lesson on, 340, 384
pseudo-classes, 354
review questions, 385
syntax for, 375
telephone, 381–382
types of, 342–343

Hypertext, 342
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Microsoft Access, 262
Microsoft Edge, 128
Microsoft Excel, 262, 276
Microsoft Word, 267
Minimizing panels, 25–26
Mobile design

content adaptation for, 
469–477

controlling Bootstrap 
alignment, 460–463

custom media queries, 
443–460

font troubleshooting, 482–484
of images, 319–320
lesson on, 414
media queries, 422–423
media query syntax, 423
media type properties, 422
page component list for, 130
page previews in, 477–482
responsive, 129, 416–421, 427
review questions, 485
template revisions for, 464–468
testing, 463
VMQ interface, 423–427
web frameworks, 427
web-hosted fonts, 428–442
wireframes for, 134

Mobile devices
font issues with, 482
hyperlinks on, 355
image optimization for, 

299, 316
telephone links for, 381
templates for, 20, 198
testing pages on, 479
web access via, 127, 128

Mobile-first design, 134, 416
Mockups

adapting templates to, 143
as basis for page design, 140
extracting image assets, 

173–175
extracting styling from, 165
extracting text from, 153–156
how to make, 132–136

Monochrome, 298
MS DOS, 51
Multicursor support, 95–97
Multiple element placement, 258

Living standard, HTML as, 51, 84
Local site

defining your, 11–14
synchronized with remote, 

408–412
term defined, 388

Locked template areas. See 
Boilerplate (uneditable content)

Logos
in layered header, 179
placement of, 131, 132
on site template, 324
on varying screen sizes, 

448–453
as vector graphics, 296

Lorem generator, 95

M
macOS, 3–4, 51
Maintenance, 387
Manual coding, 88–91
Map links, 346, 361, 362
Marcotte, Ethan, 129
Margins, 81
Mark ups, 51
Marketing research, 127–128
Media features, 423
Media queries

adding rules to, 445–448
for component visibility, 

453–460
custom, 443–460, 473
defined, 422
screen width and, 443
syntax for, 423
text styling with, 448–453
VMQ interface, 42, 423–427

Media types, 421, 422, 423
@Media window

in CSS Designer, 75
custom media queries in, 444
function of, 39
GLOBAL reference, 197, 426

Menu items
copy/paste of, 164–165
inserting new, 159–161

Metadata
adding, 209–210
on child pages, 226–227
editing, 241

small screen revisions, 
464–468

starter layouts, 140–143
styling elements, 145–151
styling predefined, 143–145
tables and page, 262
text styling, 165–168

Learning, continuous, 46
LESS (Leaner CSS), 99, 112
Lessons

accessing files for, 6–7
on coding, 86
on CSS, 60
design of, 1
on Dreamweaver 

templates, 188
on HTML, 48
on images, 294
on mobile design, 414
on navigation, 340
on page layout, 138
for publishing websites, 386
recommended order of, 7–8
on web design, 124
on workspaces, 16

li element, 54, 169
Line number selection, 114–115
Line wraps, 94
Linked styling, 69
Links. See Hyperlinks
Linting support, 112–114
List-based section

as content model, 191
creating new items in, 259–261
deleting components in, 247
as editable region, 212

Lists
content structure via, 254–261
creating, 248–254
lesson on, 236
review questions, 292–293

Live view
as default, 43, 63
defined, 23
external link creation, 360–364
Extract panel styling in, 146
pasting multiple elements 

in, 258
selecting elements in, 460
testing pages in, 477–479
text formatting in, 242
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extracting text from, 153–156
image correction in, 308
image insertion from, 311–316
mockups, 132–136
transfers to Dreamweaver, 139

Pixels
Bootstrap templates and, 198
characteristics of, 296
of desktop browsers, 128
of mobile devices, 134
of predefined layouts, 143
in raster graphics, 296–297
responsive design and, 129
and screen-size 

formatting, 453
Placeholders

adding content, 203–206
in card-based section, 212
defined, 191
home page, 397
replacing graphic, 303, 306, 

311, 325
on third-party web hosts, 405, 

408, 410
PNG (Portable Network 

Graphics), 301
Point to File function, 352, 359
Pop-ups, 21
Position Assist dialog, 43
Power positions, 131
Preprocessors, 99–112
Prerequisites, 2
Presentation and content, 68
Print design, 129
Printers, 297
Productivity tools, 189
Proofs of concept, 132–134
Properties

adding table, 269
background, 169–170, 179
in CSS Designer, 76, 77
dialogs, displays, and 

inspectors, 43–46
manual creation of, 260
of media types, 422
order for layered, 179
uninheritable, 72
window in CSS Designer, 39, 

75, 79

TinyURLs, 1, 414
on web design, 124
for working with code, 86
on workspaces, 16

Opening files, 238
Optimization

color and, 299
for device size, 316
FTP performance, 392
for mobile devices, 416
via web frameworks, 427

Optimize setting, 314
Optional regions

image carousel as, 212, 216
inserting, 219–221
removing, 231–232

Ordered lists, 249–251
Overwrites, file, 405

P
Padding, 81
Palette, 298
Panels, 24–29

closing, 27
floating, 28
grouping, stacking, and 

docking, 28–29
list of available, 25
minimizing, 25–26
reordering, 27
user interface, 18

Paragraphs
content of, 240
list as structure for, 254
returns for, 242, 244

Parent elements
in Bootstrap templates, 196
in DOM panel, 216
inheritance theory and, 72
selecting, 117–118

Password, FTP, 390–391, 392
Paste

of elements in Live view, 258
of new menu items, 164–165
to replace code, 290–291
of tables, 262, 267–268

Personalization, 29–30
Phone links, 381–382
Photoshop

in Creative Cloud, 309
Extract from, 143–145, 145

N
Named anchor, 370, 374
Navbar element, 154
Navigation

as boilerplate, 203
Bootstrap bar, 175
destination links, 374–376
email links, 364–366
external links, 360–364
formatting for screen size, 

455–457
horizontal, 131
HTML, 92
hyperlinks, 342–343
id attributes and, 82
image-based links, 367–370
internal links, 349–359
lesson on, 340, 343, 384
locking elements onscreen, 

376–378
menu in the power 

position, 132
menu styling, 378–381
menu visibility, 371, 376
for mobile devices, 421
review questions, 385
targeting page elements, 

370–373
telephone links, 381–382
text styling, 204
thumbnails for designing, 130

Nesting selectors, 108–110
New Document dialog, 21
New Feature guides, 21
Notepad, 222, 224

O
Online resources

for Adobe Dreamweaver 
Classroom in a Book, 1, 6–7

on coding, 86
on CSS, 60
design of, 1
on Dreamweaver 

templates, 188
on HTML, 48
on images, 294
on mobile design, 414
on navigation, 340
for page layout, 138
for publishing websites, 386
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for media queries, 426–427
overlap in, 74
shorthand for writing, 80–81
syntax for, 71
textual distinctions for, 2, 3

Rules, semantic, 206

S
Safari, 481
Sass (Syntactically Awesome 

Style Sheets)
creating source file for, 

101–104
defined, 99
resources on, 112

Save All command, 231
Saving work, 230, 231, 358, 359
Screen size

Bootstrap defaults for, 198
and element alignment, 

460–463
mobile design and, 

416–417, 425
before mobile devices, 416
revising template for, 464–468
targeting styling to, 443

Scrubber tool, 417–421
SCSS (Sassy CSS)

defined, 99
source files, 101–105
vs. LESS, 99

Search engines
access to uploaded 

material, 396
link-sharing interface, 363
metadata for, 209–210
structure and ranking with, 

81, 278
Security, 388, 481
Selectors

advanced, 476
for component deletion, 

192–194
and declarations, 69
nesting CSS, 108–110
special characters, 73

Selectors window, 39, 40, 75, 445
Semantic text structures, 278–281
Semantic web design, 57

publishing to, 403–408
setup for, 388–394
synchronized with local, 

408–412
term defined, 388–389

Repeating background, 180
Replace function, 285–291
Research, audience, 127, 301
Resizing

elements, 196–201
email to prevent wrapping, 369
fonts, 438–442
images, 308–311, 316
for mobile responsiveness, 

416–421
Resolution, image, 297–298, 416
Responsive web design

defined, 129
how to create, 416–421
starter layouts as, 141
for tables, 471–477
troubleshooting, 469

Review questions
for coding, 123
CSS, 85
HTML, 59
on images, 339
on mobile design, 485
on navigation, 385
for page layout, 186
on publishing to the web, 413
on text, lists, tables, 292–293
on web design, 137
workspace, 47

Robots, 370
Root, 52
Root directory, 391, 395
Rows

added to tables, 265–267
duplicating template, 244–246
row/column screen division, 

175, 196
Rules, CSS

conflict between, 73
conflict with style sheets, 151
for custom media queries, 

445–448
defined, 69
hierarchy of, 74

Property inspector
Document Title field, 209
in Element and Image displays, 

43–44
floating, 177
how to use, 33–34
resizing images via, 308
for table attributes, 265

Pseudo-classes, 354, 379, 473
Publishing to the web

cloaking files/folders, 395–396
FTP troubleshooting, 392
home page creation, 396–402
lesson on, 386
local/remote synchronization, 

408–412
prelaunch checklist, 402
putting your site online, 

403–408
remote site setup, 388–394
review questions, 413
testing server for, 394

Punctuation, missing, 3
Purpose, knowing your, 126

Q
Quick Response (QR) code, 

480, 481
Quick Start, 19–20
Quotation marks, 91

R
Raster graphics, 296–300
RDS (Remote Development 

Services), 389
Read Only files, 148, 166
Readability

code, 90
headers for, 272
lists as aid to, 248
styling and, 477

Real-Time Preview, 477–482
Regular expressions, 285
Related Files interface, 30, 34–35
Relative hyperlinks, 342–343, 

349–352
Remote site

cloaking and, 395
defining your, 11–14
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SVG (Scalable Vector 
Graphic), 296

Switching views, 22–24
Sync Settings, 8
Synchronization, site, 408–412
Syntax, media query, 423

T
Table properties, 34
Tables, 262–283

adding data to, 264
adding rows to, 265–267
borders, 263
caption elements, 282–283
cell size, 274–276
controlling display, 274–276
copying and pasting, 267–268
CSS styling for, 268–270
design conflict checks, 471
header row addition, 272–274
inserted from other sources, 

276–278
lesson on, 236
making responsive, 471–477
review questions, 292–293
from scratch, 262–267
semantic text structures, 

278–281
styling cells, 271–272

Tablets. See Mobile devices
Tag Selector interface, 35, 36–37
Tags, HTML

attributes in HTML5, 91
automatic closing of, 90
list of, 52–54
new in HTML5, 56–57
parent tag selection, 117–118
purpose of, 51
selection, 115–117, 191
weight of, 74

Target menu, 364
Technology

browser support and, 51
constantly evolving, 84
new HTML5, 58
vs. programs, 50

Telephone links, 381–382

creating new Bootstrap, 
175–179

in the DOM panel, 162
DOM Viewer of, 42
duplicating rows in, 244–246
of HTML, 52
HTML as, 49
list-based content, 254–261
revising Bootstrap template, 

464–468
and search engine rank, 81
semantic text structures, 

278–281
structural elements, 52–53
Tag Selector display of, 36
thumbnails for designing, 130

Style Rendering command, 68
Style sheets

body element, 103–104
Bootstrap, 148, 166
combining, 110
importing, 110–112
for mobile devices, 423, 425
placement of new items in, 261
pseudo-classes on, 354
variables, 103

Styling. See also CSS (cascading 
style sheets)

applying CSS, 69–74
Bootstrap style sheet, 148
copy and paste of CSS, 38
custom media queries for, 443
default HTML, 64–67
effect of browsers on, 66–67
extracting text, 165–168
hierarchy of, 74
hyperlinks, 354–355
navigation menu, 378–381
predefined layouts, 143–145
Properties window display 

of, 40
tables, 268–272
targeting, 108
text in a carousel, 334–336
via Extract panel, 145–151

Support
with CSS preprocessors, 

99, 112
font, 437
HTML, 84
linting, 112–114

Servers
establishing remote, 389
home page naming and, 397
HTTP request overwhelm, 110
staging, 388
testing, 394
uploading cloaked files to, 

395–396
Service, 126
SFTP (Secure File Transfer 

Protocol), 388
Shortcuts, 31–33
Shorthand, CSS, 80–81
Show Set, disabling, 76
Site Definition dialog, 174
Site Root button, 142, 223
Size, image, 298, 316, 319
Smartphones. See Mobile devices
Source code, 44–46
Source Code button, 35
Source files, 101–104
Source Sans Pro, 428, 434–435
Sources window, 38, 75
Spacer element, 455–457
Spam, 370
Specificity theory, 73–74
Spell check, 284–285
Split Code view, 119–121
Split view, 24
Splitting views, 22–24
Stacking panels, 28–29
Stacks, font, 430, 436–438
Staging servers, 388
Standard toolbar, 30
Start Screen, 19–21
Starter Templates

Bootstrap. See Bootstrap 
templates

Dreamweaver. See 
Dreamweaver templates

layout via, 128
option defined, 20
on Start Screen, 19

Status bar, 344
Strikethrough formatting, 3
Structure

adding CSS classes to, 328–331
adding elements to, 213–216
automatic creation of, 89
boilerplate elements, 190–191
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Web design
desktop/mobile compromise, 

134–136
with HTML5, 58
for mobile devices, 134
online resources, 124
Photoshop tools for, 134
questions guiding, 126–128
responsive. See Responsive 

web design
review questions, 137
semantic, 57
thumbnails and wireframes, 

128–134
Web Edition, 6
Web frameworks, 427
Web-hosted fonts, 428–442
Web hosts, 390, 391, 405
Web-safe color palette, 299
WebDav (Web Distributed 

Authoring and Versioning), 389
Webpages

adaptability of mobile, 423
browser displays of, 66–67
design conflict checks, 

469–471
design options, 140
designing individual, 130–132
frameworks for mobile, 427
home page, 396–402
hyperlinks within, 370–373
invisible structure of, 52
layout of. See Layout
metadata, 209–210
mockups of, 132
previewing, 238–240, 477–482
spell-checking, 284–285
templates vs., 190
thumbnails for, 130

Websites
development of, 126–128
local and remote site setup, 

11–14
publishing. See Publishing to 

the web
standards for, 65

Weight of rules, 73, 74
What You See Is What You Get 

(WYSIWYG), 18, 22

Troubleshooting
CSS conflicts, 151–153
with custom media 

queries, 443
design conflicts, 469
font issues, 482–484
FTP connection, 392
media queries, 423

True color, 299

U
Uneditable content. See 

Boilerplate 
Unintended inheritance, 73
Unordered lists, 251–254
Unzipping files, 7
Update Pages function, 229
Updates

Bootstrap, 427
checking for, 14–15
CSS3, 82
freezing, 229
how to update, 5–6
learning from the latest, 46
saving template, 230
to starter layouts, 141
to templates, 227–233

Uploading site, 403–408
URLs, 414
Username, FTP, 390–391, 392

V
Validating code, 210–211
Variables, 103
Vector graphics, 296
Vendor prefixes, 83
Version controls, 44–46
Vertical navigation, 131
Views, switching and splitting, 

22–24
Visual previews, 121
VMQ (Visual Media Query) 

interface, 42, 423–427, 443

W
W3C, 66, 84, 316
W3Schools, 127, 296
Web, backbone of, 49

Templates. See also Bootstrap 
templates; Dreamweaver 
templates

adding CSS classes to, 328–331
adding links to, 349, 352, 357
defined, 190
editable regions in, 212
inserting images into, 324–328
matched to mockups, 136

Testing
browser-based, 66–67
importance of, 479, 482
mobile design, 463
webpage previews, 477–482

Testing server, 394
Text

alt text, 305
bold, 272
break points, 449, 451, 462
carousel styling of, 334–336
creating and styling, 240–248
creating lists, 248–254
digital typefaces, 429
extracting from Photoshop, 

153–156
extracting styling of, 165–168
find/replace of, 285–291
home page, 400
importing, 240–244
lesson on, 236
links, 368–369
in list-based section, 212
for mobile display, 134
modifying formatting, 

201–203
review questions, 292–293
structures in tables, 278–281
in table cells, 274

Text Display, 43, 44
TextEdit, 222, 224
th rule, 272
�eme, webpage, 130, 131
�umbnails, 128–132
Time lag, 298
TinyURLs, 1, 414
Titles, 209–210
Toolbars, 30–31
Traffic patterns, 127
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Tag Selector interface, 36–37
toolbars, 30–31
touring the, 18–19
user interface, 18
VMQ interface, 42

Wrapping of content, 
196–201, 369

Write/Read access, 148, 166

Y
Yahoo, 126

Z
ZIP archives, 7

DOM Viewer, 42
experimenting with, 46
group environment, 190, 393, 

396, 408
keyboard shortcuts, 31–33
New Feature guides, 21
panels, 24–29
Property inspector, 33–34
Related Files interface, 34–35
review questions, 47
screen size for, 416–417
setting up, 9–10
Start Screen, 19–21
Switching/splitting views, 

22–24

Whitespace, ignoring, 287
Wildcards, 73
Window menu

list of panels in, 25
opening panels from, 27

Windows computers
Dreamweaver use on, 3–4
percent of users on, 128

Wireframes, 132–134
Workspaces

CSS Designer, 37–42
customizing, 29–30, 62
default images folder, 303
dialogs, displays, and 

inspectors, 43–46
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