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Introduction

About This Book
Written by a Lotus Notes® expert, this book presents easy-to-understand and ready-to-use proce-
dures. It includes answers to dozens of common support problems based on first-hand accounts
from actual IBM® field support representatives. This practical book could be considered a bible,
or survival guide, designed to steer software users and support professionals in all facets of Lotus
Notes support. Outstanding features of the publication include an overview of Lotus Notes
Release 8, unique content for actual field support engineers, and straightforward presentation of
information and experience.

New Features 
This book provides an overview of the Lotus Notes Release 8 client application. Novice users
will learn what features are included in the release while Notes-savvy users can review at a glance
the improvements and enhancements to the product. New users will benefit from learning how to
fix issues and become a power user. Support staff will have access to a wealth of instructions and
a myriad of resolutions to quickly address any problems in a Notes implementation.

Content
This book is set up into three main sections—Client Setup, Technical Support, and Software
Management. With more than 300,000 employees worldwide, IBM has one of the largest imple-
mentations of Lotus Notes in the world. On a daily basis, IBM field support engineers encounter,
manage, and resolve support issues—and store information in a global database.

This book will leverage these proven techniques and solutions as the foundation for its con-
tent. The most frequently occurring issues and solutions will be documented for easy reference.



This will enable small businesses to large corporations optimize support through the experience
and leadership of IBM. Readers will be able to rapidly and concisely respond to issues, and avoid
the pitfalls that stand in the way.

Second, the book includes procedures that you can use to manage a Domino® infrastruc-
ture. Some of the key topics include how to deploy Lotus Notes across an organization, manage
release upgrades, and streamline maintenance for the client. Given the unique nature of the con-
tent, this book will immediately gain support across the Domino technical support community.

Presentation 
This book is presented in a simple, straightforward manner, enabling users and support staff alike
to quickly locate and thumb to the topic of interest without having to read the entire book. You
will find being able to jump to a particular problem resolution or topic as a significant benefit.
This “read-as-you-go” approach enables you to gradually build skills as issues or situations arise.

Experience
As a Lotus Notes support technician, I have supported several Lotus Notes implementations,
including one account with more than 250 users. In this particular case, I managed the entire
spectrum of activities from Domino Server setup, to software installations, to configuration, and
finally steady-state support.

As any technician will tell you, supporting an account of any size will net all sorts of ques-
tions and problems—some as simple as addressing how to use a particular feature, to resolving
actual problems with the application. However, whether it’s fielding a problem with using the
software or managing an actual problem with the software, all the user wants is for the issue to
“go away.” This book is intended to address such a situation by presenting information from an
experienced professional who has fielded such questions. The information is based on first-hand
experiences and includes both instructions and best practices to resolve common support issues.
Its strength comes from a combination of unique elements designed to grab the attention of sup-
port technicians. Such elements include

• Resolutions to common problems

• Streamlined processes for infrastructure support

• Targeted point of view

• Knowledge sharing from experienced experts

• Release of independent information

• Information based on the most current release
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Who Should Read This Book 
Field support representatives will learn how to plan software deployments, manage release
upgrades, address common problems, configure settings based on corporate policies (or direc-
tives), and optimize support. This book is a “must read” for anyone who provides desk-side or
infrastructure support in the Domino arena. The reader should have practical experience working
with computers and a general exposure to the Lotus Notes Client® and Administrator applications.

Although a portion of the book relates to the most current release, there is a continuum of
information that can be used independent of the software release level. No other publication on
the market provides information in this manner or includes resolutions to common Lotus Notes
challenges in the workplace. Readers will have an encyclopedia of information for managing the
Lotus Notes client infrastructure and for supporting their customers—the end users. Being able to
quickly, efficiently, and effectively respond to issues will reduce overhead support costs and
increase customer satisfaction through prompt resolutions.

It’s also important to understand that the images presented in this book are based on the
Standard Lotus Notes client in a Microsoft® Windows® environment. Users running the Basic
version or running on an alternate operating system will observe slight variances in the images
and instructions shown in this book.
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C H A P T E R 1

Lotus Notes

Welcome to IBM Lotus Notes and Domino, leading the way in collaborative software. This chap-
ter is focused specifically on client setup. It provides an introduction to the version 8 client along
with a description of new features and enhancements.

If you are new to the Notes application, this book is a good starting point to learn about the fea-
tures. For readers already experienced with Lotus Notes, this book is a good place to quickly
review changes to the interface.

The remainder of the chapter is dedicated to the setup and management of the Notes client. The
chapter provides detailed instructions for how to configure the client, address common user
activities (such as how to change their password), manage the desktop, and work with user data.
As you read through this chapter, some of the instructions relate specifically to the version 8
client. These sections are denoted with an “(8)” in the section heading.

What’s New with Lotus Notes Version 8?
Lotus Notes version 8 contains a wealth of new features and enhancements, including a com-
pletely redesigned user interface (UI), as shown in Figure 1.1. For users already familiar with the
Lotus Notes product, you will find the new interface to be a significant change and welcomed
improvement.

There are sweeping changes across the board including enhancements to the navigation,
graphics, mail, calendar, and help. While some users will find the new interface and navigational
changes to be a bit overwhelming and unforeseen, most will quickly adapt and feel “at home”
with the technological advancements.

Most users will find the enhanced graphics clean and refreshing. Numerous new features
have been added to messaging—including enhanced calendar management, inbox management,
and the ability to retrieve (or recall) mail messages. Improvements also include the ability for



users to optionally keep deleted or declined calendar entries on the calendar for reference
purposes.
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Figure 1.1 Key navigation elements of the Lotus Notes client.

In addition to the mail and calendar functions, many new and innovative features for information
management have been incorporated into the release. Some of these features include enhanced
search capabilities, activity-centric computing, composite applications, RSS and Atom feeds, fil-
ters, and support for plug-ins, which are designed to help increase personal productivity. 

NOTE

A dedicated Activity server must be set up and implemented in order to utilize the activity-
centric computing feature.



General Enhancements
The following section briefly outlines some of the changes integrated into release 8. For users
already experienced with Lotus Notes, this section is intended to give you a brief overview of the
updates to the tool. At a glance you’ll be able to review the changes, enhancements, and new fea-
tures as you start using release 8. For new and novice users, this section is intended to help you
become acclimated to the application terminology and some of the key features being introduced.

• User interface. Right from the start, you will notice there have been major improve-
ments to the graphics for the Lotus Notes interface. Images have been redesigned and
enhanced to provide a softer look to the user interface. You’ll notice the graphic database
icons in the Lotus Notes workspace have changed slightly to include a shadow and
selector color when the mouse passes over a database icon in the workspace.

• Navigation. There are numerous improvements to the layout of the user interface and
application menu items. First the workspace navigation buttons, also called the “book-
mark bar” in release 7, have been rolled up into an “open” list and displayed at the top of
the UI screen. These buttons were previously displayed as icons along the left side of the
workspace. These items, along with updated graphic icons, are now contained within
the Open button at the top of the screen (see “Open List” further down this bulleted list
for additional information pertaining to this function). 

Next, some of the familiar menu item names have been replaced. For example, File >
Database has been changed to File > Application. So, if you frequently use the Prop-
erties, Access Control…, Copy as Link, or Bookmark functions, you’ll need to look
for these menu options in the Application submenu. 

• Preferences. All user preferences have been consolidated into a single dialog and can be
directly accessed by selecting the File > Preferences menu option. In earlier releases
several separate menu options and preference dialogs are used to set various Lotus
Notes configuration options. The one-click access and consolidated list of preferences is
a terrific improvement and simplification to the user interface. You’ll find new settings
throughout the Preferences dialog. Some of the new preferences include

➤ Activities section. Users can configure an “activities server” and set various display
options. This section is new to release 8.

➤ Contacts section. Users can select a default address format and specify the format
for the contact’s name where the surname is displayed either first or last in sequence.

➤ Log Settings section. Users can enable and disable logging. This section is new to
release 8. This feature is used to log operational messages and errors to a text file for
problem determination. If you find your Notes client is crashing, you might need to
enable logging to capture the various Lotus messages to be reviewed by an adminis-
trator or to be sent to Lotus for review. If the logging is enabled and the Notes client
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crashes, the text file will automatically be sent to the user’s inbox after the application
is restarted. 

While the log file is helpful for capturing messages during a system crash, this file
can also be helpful in the diagnosis of non-crash-related problems. To enable or dis-
able this feature, locate the Log Settings section and toggle the Enable Logging
check box to change the selected value. 

➤ Location section. Location documents can now be managed from within the Prefer-
ences dialog. With prior releases, you had to navigate to the Notes Address Book to
create, manage, or update your location settings. Now you can perform these func-
tions from the Preferences dialog as well as from the pop-up menu located in the
lower-right corner of the Lotus Notes client.

A Locations menu item has also been incorporated into the File menu. With this
menu item, you can Switch to Location or Manage Location. This provides a fast-
path navigation to the location configuration settings that were previously managed
through the address book. You can also manage these settings through the Prefer-
ences dialog, which is discussed later in this section.

➤ Mail section. Several new features have been incorporated into the Mail section,
including enhancements to the Attention Indicators. Users can set Recipient Indica-
tor icon flags to display when you’re the only recipient, one of many recipients, or
simply listed in the Carbon Copy (CC) list. Users can also specify a list of shortcuts
to others’ mail and set preferences for sending and receiving mail messages.

With release 8, mail messages are automatically refreshed in your inbox, thus elimi-
nating the need to click the refresh button or press the F9 key. While this feature is a
welcomed change, you might find it to be a challenge to break the habit of pressing
the F9 key. So, if you’d like to revert back to this way of refreshing, you can disable
the feature in the Receiving section (see Figure 1.2).

➤ Productivity Tools section. This section is new to release 8. Users can configure and
set preferences for a significant number of features and tools, including Accessibility,
Auto Recognizer, Color Scheme, Color, File Supervision, File type association,
Fonts, Help Agent, Language Settings, Macro Security, Memory, Presentation Edi-
tor, Print, Regional Settings, View, Warning Messages, and Word Processing Edits.

Access to the productivity tools can be set to automatically launch when the operat-
ing system loads, when the client starts, or not at all. Changing the preference to
automatically launch in the background will expedite access to these tools and set-
tings. Using productivity tools, such as Lotus Symphony™, you can also create and
edit documents, presentations, or spreadsheets from the Notes interface. The Lotus
Symphony application is available at no charge from the Lotus Web site. 
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Figure 1.2 The automatic refresh option can be set in the Mail, Receiving section of the
Preferences dialog.

➤ Toolbar section. In prior releases you accessed the toolbar settings by selecting a
separate menu item, and configuration settings were displayed in a separate dialog.
These settings have been consolidated and integrated into the general Preferences
dialog (see Figure 1.3).

WARNING

A word of caution: Some users may find toolbar preferences are lost when upgrading from
an older version to release 8. As a result, users may have to reconfigure or recreate the tool-
bar customizations after the installation. If you have any custom buttons or preferences, you
may want to make a list of buttons with the actions, formula language, or LotusScript® code
before installing release 8.

➤ Windows and Themes section. This section, which is new to release 8, allows users
to customize the color scheme for your Lotus Notes client interface.
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Figure 1.3 Toolbar settings are now included in the Preferences settings.

• Open List. The Open List replaces workspace hotlink icons previously displayed on the
left side of the user interface screen. These icons have been rolled up, grouped into a but-
ton called Open, and displayed at the top-left corner of the workspace (see Figure 1.4).
When you click the button, a drop-down list of the hotlinks appears and can be selected. 

By default, the list is collapsed and only expands to display the icons when you click on
the button. Alternatively, if you would prefer to have the list displayed, you can right-
click on the Open button and select the Dock the Open List option. This parks the icons
on the left side of the UI. To switch back to the default, repeat the process and uncheck
the Dock the Open List option.

It’s also important to recognize all references to the Address Book have been replaced
with Contacts, which is the Lotus Notes terminology. To access the Address Book,
select the Open > Contacts menu option (or click on the Contacts hotlink icon).

• Contacts. Multiple contact changes have been incorporated into the Address Book. Sev-
eral new views have been added to the interface, including one to display recent con-
tacts, one to display contacts by company name, and another to display information in
business card format. The contact display format has also been enhanced and now per-
mits pictures to be added to the contact record.



Figure 1.4 The new Open List feature replaces the hotlink navigation icons.

• Enhanced Undo. The Undo function has been greatly improved. When editing a docu-
ment, users can now reverse multiple edits, including changes made to tables—another
long overdue feature, frequently discussed and requested on discussion forums. At the
same time, it’s equally important to mention there are still quirks in the “undo” process
when working with tables. Hopefully Lotus will smooth out the remaining wrinkles
with the version 8.5 upgrade.

• Printing. The print function has been enhanced to support a special type of table called
tabbed tables. A tabbed table allows users to group information together in a series of
tabs (as opposed to the traditional row and column table). Using the new print options
users can print this special type of table “as displayed,” print a single tab, or print all
rows in a table. The new function also prints the labels for tabbed tables.

• Product Help. The help section for the Lotus product suite has been completely
redesigned and enhanced. Users can now choose between Help Contents, which dis-
plays in a separate window and Dynamic Help, which displays in a window pane on the
right-side of the interface screen. The help topics are sorted and displayed in Books with
the continued support to search for any help topic.

• Search. Starting with release 8, a search interface has been permanently incorporated at
the top of the Notes UI. This newly designed search function allows you to initiate a
search from anywhere within the Lotus Notes client. You can also click on the search
parameter icon to refine the search criteria. Here you select to search All mail, calendar
entries, contacts, or expand the search to Yahoo! or Google.
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The Notes client now also tracks and allows you to view recent conducted searches.
While this new search interface has been integrated into the client interface, you can still
access and utilize the previous “advanced” search functionality. To display or hide the
traditional search interface, select View > Search This View to toggle the setting.

• Sidebar. The Sidebar is new to Lotus Notes release 8. Similar to the Bookmark bar (now
called the Open List), the sidebar displays a list of installed Lotus Notes plug-ins for
quick access in a toolbar along the right side of the user interface. You access the sidebar
by dragging open the pane on the right side of the client or, alternatively, by selecting a
display option from the View > Sidebar menu.

Typical plug-ins may include access to Activities, day-at-a-glance, or data feeds.
Depending on the implementation at your company, installation and configuration may
be required to utilize one or more of these features. For additional information on plug-
ins, see the “Sidebar Plug-ins” section later in this chapter for more on Activities, feeds,
day-at-a-glance, My Widgets, Lotus Symphony, and Sametime Contacts.

• Spell checking. Type as you go spell checking has automatically been enabled with the
most current release. The functionality is a nice improvement over the prior implemen-
tation. The checker appears to be much better at identifying misspelled or unknown
words.

Mail Enhancements
While there have been changes to the navigation, many of the features introduced in prior
releases continue to be implemented. Users can continue to utilize the message preview pane and
sort by clicking on the column headers.

Overall, the layout remains very similar to prior releases although the graphics have been
enhanced and new features have been incorporated into the release. With this release, Lotus has
renamed “message threads” to “conversations” and has grouped related messages for quick refer-
ence. Users can simply click on the graphic triangle (also known as a Twistie) to view the trail of
messages. You can then hover the mouse over the message to display the contents for a particular
message.

The most exciting news about the release is the long-awaited ability to recall or retrieve
sent messages. This feature has been available in other products and, as a support person, was a
question frequently asked. In the past you could “catch” a sent e-mail by implementing mail
replication and setting a minimum threshold to transfer outgoing mail to, say, three or four mes-
sages. This would, in most cases, give you the chance to change your mind and delete the outgo-
ing message before replication started. With release 8, you now can actually retrieve the sent
message—with one caveat. The recipient can optionally enable or disable the ability to recall the
message in their local preferences settings.

• Automatic Refresh. With this release, inbound mail messages are automatically dis-
played in the Lotus Notes UI. This eliminates the need to click the refresh button or
F9 key.
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• Collaboration History. The Collaboration history feature, which is new to release 8,
enables users to display a list of recent transactions, such as messages, calendar events,
or instant message chats, for a specific person (see Figure 1.5). This feature can be par-
ticularly handy for locating a previously sent message or when looking for a scheduled
meeting. All transactions are displayed in a scrollable list. Click on a particular item to
display the item, where you can read or perform other normal actions such as reply to
the message.
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Figure 1.5 The new Collaboration History feature displays all recent communications for a
particular person.

• Conversations. Lotus Notes has long included the ability to view a group of related
messages (see Figure 1.6). While this capability continues to be supported in release 8,
the terminology has changed from “message threads” to “conversations” and the func-
tionality has been improved. From the inbox view, you can now use the mouse to hover
over a message to view its content; also, conversations can be expanded or collapsed
from all mail folders and views. You can optionally display the conversation in the top
of a particular message through the use of the Display button (described next) to show
either the entire conversation or the original message when reading a particular
mail item.

• Display button. This feature is new to release 8 and allows you to select certain ele-
ments of the mail message to be displayed or hidden. The button displays at the top of
the mail message and allows you to show the Expiration, Conversation, or Original
Message (see Figure 1.7). This feature works in concert with conversations. Using the
Display feature you can selectively see a conversation trail or simply the original mes-
sage. When selected, the appropriate message or messages appear in a highlighted box
at the top of the message.
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Figure 1.6 Related messages are grouped together in the inbox.

Figure 1.7 The Display menu button allows users to toggle between display settings. 

• Follow-up flag. The follow-up flag is a graphic icon, a green flag, that can be set to dis-
play for any mail message (see Figure 1.8). The intent is to display or highlight a partic-
ular message that needs some sort of action or is an important item you may want to
track. While the follow-up flag has been available in past releases, you may have found
it cumbersome to set the flag through the right-click menu or one of the other navigation
paths. However, with release 8, a follow-up flag button has been added to the top of the
mail interface, which enables quick and easy access to this feature.

Figure 1.8 A new Flag button has been added to the user interface for quick access to actions.

• Message layout. The message layout has been redesigned with new letterhead graphics
and repositioned fields. To manage recipient content, Lotus has included buttons to
Show Details and Hide Details. You can also sort the recipient list to more readily
locate an address.



• Message Recall. This feature is new to Lotus Notes 8. Using this feature, you can
retrieve a sent message even if the recipient has read the mail. However, the recipient
can optionally manage the ability to recall messages through user preferences.

• Out of Office. The underlying architecture for the Out of Office function has been
redesigned. Previously this feature utilized a pop-up window to manage the out of office
configuration settings. With release 8, a dedicated window is utilized, which allows
users to perform other operations while the feature is being configured. Lotus has also
replaced the button names to make the interface more user-friendly and intuitive. Other-
wise, the general settings remain the same as in prior releases. (Technical note: The Out
of Office functions are now managed by a router task on the server for better scalability
and performance. Previously, this function was managed by a mail database agent.)

• Show button. This feature is new to release 8 and allows you to control what’s dis-
played in the mail views. Using this button you can select to view only unread messages,
set the preview pane position, or display messages as conversations. This button is
located in the upper-right corner of the mail user interface screen.

• Suppress Remote Images. This preference option allows you to suppress remote
images from being displayed in messages. This option only applies to Internet messages
that were received external from your mail domain. This can be a handy feature to pre-
vent potentially obscene or offensive images from being displayed in the message.
However, you can optionally display the image as the message is being read.

• Type-ahead addressing. To varying degrees, the Lotus Notes interface has included
smart addressing where the user interface attempts to automatically identify recipient
addresses as you type. This functionality is called type-ahead addressing. In past
releases, the function worked pretty well most of the time, although you often had to
press the comma key (“,”) to trigger the lookup and occasionally there would be a
delayed response or no response whatsoever. However, with release 8, Lotus has finally
gotten it right. The type-ahead feature works flawlessly with incredibly fast response. Its
implementation is identical to the URL type-ahead function in Microsoft Internet
Explorer where a drop-down list of addresses is displayed and refined as you type. Users
can then select from the list, or in many cases, Lotus is smart enough to select the correct
address automatically. The list displays the most recently used addresses at the top of the
type-ahead results list. For those of you frustrated with this feature in prior releases,
you’ll find this to be a slick improvement for this release.

Calendar Enhancements
The following list provides an overview of enhancements, changes, and new features to the Cal-
endar interface. 

• Calendar layout. The graphics and layout for the calendar have been completely
redesigned. The new calendar design includes eye-popping graphics that clearly show
the start and end times for meetings. Overlapping meetings are clearly represented and
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implemented with a new color scheme that makes scanning and identifying calendar
entries easy. Reminders, appointments, meetings, anniversaries, and events each have
unique color schemes and can easily be identified at a glance.

Lotus has also changed the layout for locating free meeting times for attendees. The
Find Available Times function now appears at the bottom of the invitation in a separate
tab. Finally, users can schedule meetings in another time zone. The changes made to the
calendar interface offer greater flexibility in management of scheduled tasks and visibil-
ity to events, such as the Two Day and One Work Week views. Users can customize the
calendar to best match their needs.

• Cleanup. To help manage your mail database size, Lotus has included a new feature that
enables you to manage old, obsolete calendar entries. The slick implementation will
clean up all calendar entries, including recurring events, based on a duration or date. In
prior releases, there was no easy way to remove recurring calendar entries without
adversely impacting future entries. Now you can run Calendar Cleanup to automati-
cally clear old entries.

• Ghost Entries. Starting with release 8, unprocessed invitations can appear on the calen-
dar as a “ghost” or grayed-out. This display option can be set in the Calendar section of
the user preferences.

• Meeting Cancellations. Similar to the calendar’s ability to automatically process meet-
ing invitations, you can now have meeting cancellations automatically processed and
removed from your calendar.

• Retain Deleted Entries. In addition to automatic processing of cancelled meetings you
can optionally select Remove from Calendar (which, as its name implies, removes the
cancelled meeting from your calendar) or Show as Cancellation in Calendar, which
allows you to view in your calendar that a meeting has been automatically cancelled and
keeps you from having to search for a meeting you thought was going to happen but that
you cannot seem to locate.

Sidebar Plug-ins
This newest version of Lotus Notes has been enhanced to include a function called the Sidebar
(see Figure 1.9). The Sidebar is a window pane that can be collapsed or expanded to show various
plug-in features. Each plug-in can subsequently be expanded to show even more information. A
plug-in is a stand-alone feature that contains functions and information designed to facilitate col-
laboration or communicate information.
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Figure 1.9 The new Sidebar feature displays plug-in features and calendar at a glance.

The following are a subset of the functions that may be installed and configured. Implementation
will vary based on your installation or corporate implementation. Several of these can be added to
the client as part of the Lotus Notes release 8 installation procedures. Sidebar functions, when
expanded, are always visible from the client (as opposed to just the mail application).

• Activities. Activities, new to release 8, are groupings of work elements, such as conver-
sation threads, to do’s, files, links, or instant message chat logs. Related elements are
listed or grouped together in the Sidebar based on a specific task or project. Activities
are intended to be a collaborative tool used to communicate, track, and share with peers
or other project team members. To utilize this function a server must be set up and con-
figured to support it; the Activities function is not supported as part of the default client
setup. You will need to work with an administrator to establish a Domino server and to
configure this functionality.

• Feeds. This feature enables you to manage information feeds using the Really Simple
Syndication (RSS) and Atom Publishing Protocol (APP) distribution mechanisms.
Using either communiqué type, you can subscribe to, receive, and manage Web-based
content of interest to you. When this option is enabled, you access the information via
the Feeds section of the Sidebar.
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• Day-at-a-Glance. This feature, new to release 8, enables a quick view of scheduled cal-
endar events to be displayed along the right side of the client window. This feature is
part of the Sidebar feature, which is also new to the release.

• Lotus Symphony. Lotus Symphony is a suite of three application editors—Lotus Sym-
phony Documents, Lotus Symphony Presentations, and Lotus Symphony Spread-
sheets—that enable you to create and edit documents, presentations, and spreadsheets
from within the Lotus Notes client. The application supports the Open Document For-
mat (ODF), which enables you to seamlessly manage documents in either the Microsoft
Office® or Lotus SmartSuite® file formats.

• My Widgets. My Widgets is a new feature that enables you to create custom tools to
perform tasks to manage Notes data. This add-on tool allows you to create custom Lotus
Notes functions that are typically displayed in the right-click pop-up menu. For
example, you could create a function to search Yahoo!. After you create it, you could
highlight a text string and select the function from the right-click menu. The My
Widgets function works in concert with Lotus Live Text. You will need to install and
configure this function because it is not part of the default configuration.

TIP

To learn more about the Live Text and My Widgets features, visit the IBM Lotus Web site on
collaboration and productivity tools. Here you can obtain additional information, view online
demos, and download product information. You can find this information at www.ibm.com/
software/lotus/products/notes/productivitytools.html

• Integrated Sametime®. Sametime, the Lotus implementation of instant messaging, can
be optionally installed as an integrated application within the Notes client. The features
and functionality of Sametime remain unchanged; the application itself is embedded
into Lotus Notes and displayed in the Sidebar.

WARNING

Be careful installing Lotus Notes release 8 with the integrated Sametime option if you
already have Sametime installed on your system. You might encounter quirky behaviors,
including multiple icons displayed in the Windows tray and the inability to launch the appli-
cation by clicking on the tray icon. (See Chapter 2, “User Support and Problem Manage-
ment,” for additional information.)
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Configuring Lotus Notes
The Configuring Lotus Notes section offers common setup and management activities essential
to all Lotus Notes users. This section lists topics in logical order from the perspective of a new
user or installation. As an individual user or support person, you’ll probably want to step through
each of these items as part of the normal setup.

These items are intended to both help set up the environment from a usability perspective
and to implement a fundamental layer of security to protect data stored on the client workstation.
Most of these items are one-time procedures that, once set up, do not need any additional modifi-
cation or tweaking.

Setting Up Mail Replication
What is replication? Replication is the process in which a copy of your mail database is created
on your local workstation. Replication will improve system performance because information is
local and it does not have to travel over the network to be processed. Replication also enables you
to continue working when your mail server is down or when you are working remotely.

Replication works by initially creating a complete copy of the mailbox on your local com-
puter. Once the copy is established, incoming and outgoing messages are transmitted (or repli-
cated) back to the server at a set interval for processing.

Beginning with Lotus Notes 8 there are two ways to create a replica: a new method called
Make Available Offline or the traditional method called New Replica. You can use this latter
method regardless of the Notes client version being used. Users running version 8, however, will
have an alternate method available. The new Make Available Offline option consolidates the
replication setup process. This feature is available by opening the database and selecting the File
> Application > Make Available Offline menu option.

TIP

When working remotely you should switch locations to Island mode. Using Island mode
allows you to queue outgoing messages and to process calendar events already posted to
your inbox. Once you are able to reconnect to the network, simply switch back to the original
location setting, such as Office (Network), to resume normal processing. Otherwise, you
might encounter errors if you work remotely but don’t change the location. To change the
location setting, simply click on the location setting at the bottom right corner of the Lotus
Notes client. 

The following outlines the steps for the traditional method and illustrates to set up replica-
tion for your mail database. As part of the process to create a replica, you will need to compare
the size of your mailbox with the available space on the workstation. Lotus Notes automatically
displays both database size and space available on the destination device. While this process is
geared towards your mail, you can apply this same procedure to most Lotus Notes applications.

Configuring Lotus Notes 19



Step 1. Navigate and open your mail application.

Step 2. Select the File > Replication > New Replica menu option. The Create New
Replica for Application dialog box appears, as shown in Figure 1.10.
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Figure 1.10 The Create New Replica dialog box.

Ensure the Server field is set to Local and optionally set the File path field. Best
practices state that you should create replicated databases within the \Notes\data
folder or directory for the application. (Note: The exact path to this folder will
depend on the value you specified during the application installation procedure.)
This folder is the default setting when creating replicas. By default, it is the
implied top-level folder and is not displayed in the dialog. For example, based on
the information in Figure 1.10, a new replica will be created in the \Notes\data\
mail2\elliott.nsf directory. However, from a configuration and reference perspec-
tive, Notes automatically assumes the file is stored in the \data directory and does
not need to be specified.

Lastly, check the source application size and destination space available to ensure
ample space is available before starting the replication. These values will display
at the bottom of the dialog. In this example, the mail replica will require 191.1MB
of space and there is 51.51GB of space available.

Step 3. Click OK to continue. Lotus Notes opens the replication window and begins
copying the database onto the local workstation. Depending on the size of the
database, this process could be as short as a few minutes or could take an hour or
more to be created. The database has been created once the progress indicator has
completed and a message appears next to the database in the replication work-
space. The message should show the number of documents received and sent.



Step 4. Now that a replica of the database has been created, you need to define replication
preferences such as the frequency in which messages are transferred between the
workstation and the server. Select the File > Preferences menu option and navigate
to the Replication section. You should see a dialog similar to that in Figure 1.11.
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Figure 1.11 Access replication settings via the Preferences dialog.

Step 5. In the Normal-priority replication schedule section, specify the time frame in
which replication should occur. At a minimum, you want this window of time to
match your normal work hours and days. You might want to extend the duration in
case you arrive early or potentially work late. Optionally, you can enable the high-
priority replication settings and whether to replicate at startup and shutdown.

Step 6. Click OK to complete the replication process. A copy of your mail now resides on
your local workstation. Changes will be transmitted and received based on the fre-
quency specified in the preferences (for example, every 5 minutes).

With the replication setup complete, you will want to encrypt the database to prevent unautho-
rized access to the database. You can find more information regarding encryption in the next sec-
tion, “Encrypting Your Mail Database.”



Encrypting Your Mail Database
When implemented, database encryption can prevent unauthorized access to databases stored on
the local workstation. Encryption provides an additional layer of security for local databases or
replica databases. Without encryption, it is possible for a Notes-savvy person to copy and access
data on your workstation.

Encryption works by associating a random public key with a specific user ID and append-
ing the resulting value to the database. Only the user whose ID is encrypted will be able to access
the database. Database encryption has no effect on other replicas of the database. This process is
ideal for computers that are shared with other users or for laptops that are taken out of the office
environment.

Although encryption sounds technically complex, the implementation and subsequent
usage is simple. After the database is encrypted, the decryption occurs seamlessly on the local
workstation. For example, if mail is replicated to a local database, you should encrypt that mail
database to prevent unauthorized users from accessing your mail. After the database is encrypted,
however, you will still be able to open and access mail with no additional steps required.

Three levels of encryption can be implemented: Simple, Medium, and Strong. In most
cases, Simple or Medium encryption is sufficient. It’s important to note that the higher the
encryption level, the longer it will take to open the database.

Starting with Lotus Notes release 8, a new section has been added to the Preferences dialog
and, by default, replicated applications are automatically encrypted—a welcomed enhancement
for all Notes administrators. Follow these steps to check or manage these settings in release 8. If
you’re working with an older release or need to encrypt a database created in a prior release, you
can skip forward to the next set of instructions to learn how to manually encrypt a database.

Step 1. Select the File > Preferences menu option to display the global Lotus Notes pref-
erence settings.

Step 2. Navigate to the Replication section and select the Default preference setting
view (see Figure 1.12).

Step 3. Verify the Encrypt locally using field is enabled. The default should be Medium
Encryption. This will ensure all replications are automatically encrypted as they
are being created. If you want the newly created replication requests to be gener-
ated instantaneously, select the Create immediately (instead of at the next
scheduled replication) option. Alternatively, the replica will be generated at the
next scheduled replication interval as described in the earlier section, “Setting Up
Mail Replication.”

Step 4. Click OK to complete the configuration. 
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Figure 1.12 As a best practice, users should always encrypt local database replicas.

TIP

Until recently, many users had small hard drives and had to constantly monitor files stored
on the workstation. Many of us also had to connect using modems to access the company
network or Internet. For most folks, these issues are no longer of concern because hard
drives now allow for gigabytes of storage and high-speed network connectivity is readily
available. However, if you have a need to reduce the data being replicated to address con-
cerns with storage, network traffic, or both, then you can define what information is repli-
cated to the local database. This feature may also be desired when the documents are very
large in size or possibly contain large attachments. By default, replication is set up to
Receive full documents. To manage the data being sent you could change this setting to
Receive partial documents and a truncated document will be transmitted to the local
replica. To access the complete document, you will need to access the document on the
server instance of the database.

Follow these steps to manually encrypt the mail or other local database replica. You might need to
manually encrypt your mail (and other local databases) if a replica was created using an older
release.

Step 1. Locate and open the database.

Step 2. Select File > Application > Properties to display the database Properties dialog
for the local database.
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Step 3. Click the Encryption Settings button to configure the encryption for the database
(see Figure 1.13).
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Figure 1.13 You can also access encryption settings via the database Properties dialog.

Step 4. To enable encryption, select the option to Locally encrypt this database using
and pick an encryption level: Simple, Medium, or Strong (see Figure 1.14).

Figure 1.14 The three types of encryption are Simple, Medium, or Strong.

Step 5. Click OK to complete the configuration. 

Depending on the size of the database, it will take anywhere from a few seconds to a couple min-
utes to initially encrypt the database. This is a one-time pass. All future encryption will be applied
as documents are created and updated.
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C H A P T E R 2

User Support and
Problem
Management

As with any software package, users are bound to encounter “quirks” when using the application.
In some cases, these quirks will be general usability issues that are not really problems. In other
cases, there might actually be a problem with the workstation or client software. This chapter
focuses on user support issues and common Lotus Notes problems. Some of the topics include

• How to optimize Lotus Notes

• Managing your mail database

• Calendar cleanup

• Troubleshooting issues

The chapter includes a comprehensive list of issues and resolutions that will be beneficial
to field support technicians working to address user issues and software quirks.

Optimizing Lotus Notes
An optimized system will reduce general user frustration and improve overall performance of the
system. This section outlines a few strategies to help users with performance-related issues.
These procedures are simple to run and most complete within a few seconds or minutes. Users
should be encouraged to learn and perform these procedures on a routine basis. Similar to chang-
ing the oil in your car every 3,000 to 5,000 miles, users should get into the habit of routinely
cleaning the application: perhaps once a month or every couple months.

Most of these procedures are specific to the Lotus Notes client, such as compacting the
workspace and emptying the trash folder in your mail client. A couple procedures are operating



system–specific, such as defragmenting the hard drive, which helps the entire workstation run
more efficiently.

In general, the procedures outlined in this section should improve the user’s overall work-
station performance. The results, however, will vary depending on the individual workstation.
First and foremost, it’s important to recognize the minimum hardware requirements for the Lotus
Notes client. The client needs to be installed on hardware that meets the minimum requirements
for the client. If the client is installed on a substandard workstation, a high likelihood exists for
performance-related problems. To use an analogy, it would be hard for a motorcycle to pull a
train. So be sure to match the hardware to the Lotus Notes software requirements.

For example, Lotus recommends Windows XP users have 1GB of memory as the absolute
minimum, 1.5GB of memory for “acceptable” performance, and 2GB or higher for optimum per-
formance. If the workstation does not meet the hardware requirements established for the Notes
client, these steps will have a minimal effect on the overall performance. In other words, perfor-
mance of the Notes client is directly affected by the workstation hardware. If the workstation
does not meet the minimum hardware requirements, then there is a much more important and big-
ger issue that first needs to be addressed.

It’s also important to recognize that other installed applications, spyware, adware, or share-
ware programs can potentially impact or reduce the overall performance of the workstation.
While these programs most likely do not directly affect the Lotus Notes client, they most defi-
nitely can slow down the workstation by consuming both precious memory and workstation CPU
cycles.

Users might want to consider running a workstation tool to check the overall system on a
regular basis. Plenty of tools are available to help remove unused files, clean up the Windows reg-
istry and generally clear the system of “junk.”

TIP

CCleaner is a freeware tool that can check and optimize workstations running Microsoft
Windows. It removes unused files, clears cache files, cleans up the Windows registry, and
much more. The application is small and easy to use. The tool has been reviewed by numer-
ous technical Web sites and magazines such as CNET, Web User Magazine,
Downloads.com, ZDNet, Clarin, and ViePrivee among others. The reviews highly recom-
mend the tool, which is completely free and does not require any type of registration. The
tool is easy to install and contains absolutely no spyware or adware.

For additional information, visit www.ccleaner.com. Be sure to check corporate software
license policies before installing this or any other software product.

Finally, before proceeding, users should be encouraged to create and work from a local
replica of their mail. This one step will improve access and response times while working with
mail memos and calendar events. See the “Setting Up Mail Replication” section in Chapter 1,
“Lotus Notes,” for step-by-step setup instructions.
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Checking Your Database Size and Compacting the Database
Compacting a database helps to recover unused and fragmented storage space. It enables the client
to run more efficiently and reduces the size of the database. Any locally replicated database should
be compacted on a regular basis—whether it’s your mail application or another application.

How do you know when to compact the database? Lotus recommends any database that
drops below the 90% used threshold be compacted. The process is simple: Click one button to
check the percent used and a second button to compact the application (if needed). For many, the
hardest part of the process will be to remember to check the application(s) on a periodic basis.
The compact process typically takes a few seconds or minutes to run and will vary depending on
the usage and size of the database.

What happens during the compact process? The Lotus Notes client makes a temporary
copy of the database on the workstation, compresses the information, and then restores the opti-
mized database back to the user. This happens behind the scenes. It is for this reason that users
cannot use the database while the compact process is running. Throughout the process, informa-
tional messages appear in the message bar for the client.

To compact a database on a server, you need to have sufficient permissions in the Access
Control List (ACL) in order to trigger the compact. Generally speaking, users have this authority
by default for all local replicas.

Finally, the compact process will not affect the documents, memos, calendar entries, or
other information stored in the application. It simply removes the unused space allocated to the
database and compresses the application. The following steps outline the process for checking
and compacting an application. While the instructions specifically reference the mail application,
you can apply them to most any local replica.

Step 1. Open your mail.

Step 2. Select File > Application > Properties. Once selected the Database properties
window will appear and contains multiple property values associated with the
database application (see Figure 2.1).

Step 3. Click on the second tab to display information pertaining to the database.

Step 4. Click the %used button to show the percent of used space. If the value returned is
less than 90%, you should compact the database. To the left of this number is the
total space used.

Step 5. Click the Compact button to compact the database. Lotus displays the status in
the message bar (located at the bottom-left side of the client window). After com-
pacting you should see the %used value increase and the Disk Space used
decrease.

After the compact completes, you should also see a decrease in the overall Disk Space
used. If you click the %used button a second time, this value should increase to show the new
optimized value. Be sure to check all replicated applications on a regular basis to optimize per-
formance and reduce space requirements.
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Figure 2.1 The application properties dialog allows users to view the fragmented storage
space and to compact the database.

Compacting Your Workspace
The process for compacting the workspace is very similar to that used to compact an application.
However, instead of optimizing a particular application, the process compresses the Lotus Notes
desktop environment. This process reduces storage space by removing unreferenced files no
longer being used by the workspace. Lotus recommends the user compact the workspace when
the %used is under 85%. Users should compact the Lotus Notes desktop workspace on a regular
basis. Complete the following steps to check the usage and to compact the workspace.

Step 1. Double-click on any workspace tab to display the Workspace Properties dialog
(see Figure 2.2). You can also access the dialog by right-clicking on the workspace
background and selecting the Workspace Properties option from the pop-up
menu.

Step 2. Switch to the second tab to display the workspace size information.
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Figure 2.2 The workspace properties dialog also allows users to view and compact their Notes
client workspace space allocation.

Step 3. Click on the %used button to display the current workspace usage, shown in Fig-
ure 2.3. If the percent used is lower than 85%, click the Compact button to com-
pact the workspace environment. A progress meter appears as the Lotus Notes



client performs the action. Additional messages appear in the message bar at the
bottom of the client throughout the process. When the process is complete, the
dialog displays the updated information in the second tab.
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Figure 2.3 You can see how much of the workspace has been compacted.

Defragmenting Your Hard Drive (Windows)
Defragmenting your hard drive will improve the overall efficiency of your workstation. What is
defragmenting? It’s a process whereby files are reorganized and stored in continuous blocks of
space on the disk drive. Having the entire file in a single location improves the system perfor-
mance by reducing the work performed by the hard drive. As a result, information is accessed and
displayed with less latency.

How did files get spread across the disk? In short, it just happens as part of the normal read
and write process. Over time, as information is saved, the operating system stores the information
various places. Eventually, information is stored in multiple non-contiguous locations.

Defragmenting is the process where files are arranged and stored in continuous blocks of
space, and only needs to be performed when analysis shows the disk contains a significantly high
number of fragmented files. The Microsoft Windows operating system includes a tool called Disk
Defragmenter that performs both the analysis and the defragmenting.

The following steps outline the process from a Windows XP perspective. It’s important to
note that this process can take anywhere from a few minutes to several hours to run. Users might
want to start this at the end of the day to let the process run overnight.

Step 1. Close all running applications.

Step 2. Select Start > Programs > Accessories > System Tools > Disk Defragmenter
from the Microsoft Windows Start menu. The Disk Defragmenter tool launches
and appears, as shown in Figure 2.4. The tool will include a list of all attached
storage devices.

Step 3. Click on the Analyze button. The tool performs a check of the storage device and
recommends whether or not the device should be defragmented. This might take a
minute to run. No action is needed if you receive the message, “You do not need to
defragment this volume.”

Step 4. Click the Defragment button if the tool recommends it.



Figure 2.4 The Microsoft Windows Disk Defragmenter application.

General Settings That Can Affect Performance
This section contains a general list of settings and recommendations that can affect the perfor-
mance of the Lotus Notes client.

• Best practices suggest users should always create and work from a local replica of the
mail application. Using a local replica offers improved performance as the information
is local to the workstation and is not being transmitted between the client and the server
over network lines. This option also allows the user to work remotely and in the event
the server is not accessible. For additional information see the “Setting up Mail Replica-
tion” section in Chapter 1 for step-by-step instructions.

• As a general rule, users should allow at least 15% free space on the hard drive for gen-
eral Lotus Notes processing, caching, file swapping, mail storage, and other database
application storage. Users should consider running the Microsoft Windows Defrag-
menter, increasing the hard drive capacity or taking other actions as discussed in the
earlier “Defragmenting Your Hard Drive (Windows)” section.

• When creating connection documents to Domino servers, always use the domain name
(as opposed to the decimal IP address). An IP address is a series of four numbers sepa-
rated by periods, such as 9.67.2.100. This number is the unique address that is associ-
ated with the server and is used to communicate with the server. A domain name is an
alias that is also tied to the server, such as Server1.ibm.com. Both values point to the
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same server. However, specifying the domain name in the connection document offers
several advantages. First, the connection document will still work if the IP address for
the server is changed. Second, you can create a generic connection document to cover
all servers within a specific domain. For example, instead of creating a separate connec-
tion document for 100 unique servers in the ibm.com domain, you could create one con-
nection document with the value *.ibm.com in the address field (see Figure 2.5).
Creating a connection document will reduce the time required by the client to locate and
connect to the Domino server.
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Figure 2.5 A sample connection document using a domain name range of *.ibm.com.

• Establish a mail archive to automatically move documents from your mail application to
the archive database. This reduces the size of the mail application. This improves
performance of the Notes client and potentially helps the user meet any mail quotas
established by the company. See the “Enabling Mail Archive” section in Chapter 1 for
additional information and instructions.

Managing Your Mail Database
Managing the size of your mail application can be a challenging and often never-ending task.
Keeping the size at a minimum can help with performance and is often required in order to com-
ply with company storage size quotas. This section offers a variety of options for managing your
mail database including the mail database size and removal of obsolete calendar entries.

Managing Your Mail Database Size
While there’s little you can do to prevent others from sending large documents, you can perform
a number of actions to help reduce the size of your mail application and that of your colleague’s.
This section offers a few suggestions and pointers that can help keep the mail application as small
as reasonably possible.



• Wherever feasible avoid sending attachments in mail memos and calendar invitations.
Instead, consider placing the document in a shared team room and including a document
link in the message. This approach provides a single access point to the document. Con-
sider creating a team room for storage of project-related documents.

• Take careful consideration when sending mail memos as to which messages need to be
saved. You have two options when sending mail: Send and Send and Save. Utilize the
Send button if you do not need to keep a copy of the memo.

• When replying to a memo with an attachment, do not resend the file. Consider using the
Reply with History Only feature.

• Avoid copying and pasting large screenshots or graphics in the body of messages or cal-
endar invitations. Consider placing the document in a shared team room and including
document link in the message.

• Be cautious when creating an embedded signature to use very small images. Remember
the signature is attached to all mail memos. An image in the signature can easily con-
sume a large amount of space in your mail application. If a graphic is included, make
sure it is as small as possible.

• Create a mail archive to move older mail messages to a separate database. It’s important
to note that archived mail is still accessible. Users can still read, reply, or forward mes-
sages that have already been archived. If possible, schedule the archive to move docu-
ments earlier rather than later—say every 30 days as opposed to 6 months. See the
“Enabling Mail Archive” section in Chapter 1 for additional information and instruc-
tions. It’s worth noting that some corporations automatically set up mail archive. Be
sure to check with your mail administrator before establishing a local instance as users
might find it more difficult to find documents spread across multiple archives. Finally,
when creating a local archive, users should always practice good data management tech-
niques and back up the files on a regular basis. This can prevent loss of data in the event
the workstation has hardware failure.

• Detach all attachments before filing the memo in a folder. Saving the attachment to the
local workstation can greatly reduce the size of the mail application. Consider checking
the All Documents view. Click on the Size column to sort by document size. Review the
largest documents to determine whether you can remove any attachments and/or
whether duplicate memos exist.

• Run the calendar cleanup function (in Lotus Notes 8) to clear old meetings from the cal-
endar. Consider adding a monthly reminder to run the calendar cleanup process. The
process for managing old or obsolete calendar entries is described in the next section.

• Instead of saving all mail memos that a user sends, consider changing the user prefer-
ences to Ask Me (see Figure 2.6). This option will ask you “Do you want to save a
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copy?” before sending each mail memo. Consider only saving those memos that are
absolutely necessary. To set this value, select File > Preferences. Navigate to the Mail
section and then select the Sending and Receiving subsection. Locate the Save Copies
of Messages That I Send: field and select the value Ask Me.
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Figure 2.6 Using preferences you can set Notes to prompt you to always or never save
messages.

Managing Old Calendar Entries Using Cleanup in Lotus Notes 8
To manage infrastructure costs, many companies have elected to implement a quota system
where each employee is allotted an amount of storage space. Once a threshold limit has been
reached, a user might start to receive warning messages or even have his or her mailbox “locked”
until the overall storage size has been reduced.

One way to achieve this reduction is through the Calendar Cleanup function. Using Cal-
endar Cleanup, you can remove historical events from your calendar. Frequently people will
attach presentations or other documents to meetings. These files can be large and are often no
longer needed after the meeting is held. This problem can be compounded when a large attach-
ment is embedded in a recurring calendar entry—propagating the problem for each scheduled
event.

In prior releases, cleaning up recurring events without impacting the integrity of future
events was very challenging and cumbersome (and some would say downright impossible). Start-
ing with release 8, Lotus has implemented this slick utility to efficiently and effectively manage
calendar entries. Running this function on a regular basis, perhaps monthly, will help manage and
reduce the size of your mailbox.



The following steps show how to run the Calendar Cleanup routine:

Step 1. Navigate to your personal calendar.

Step 2. To launch the utility, select Actions > More > Calendar Cleanup. You can also
access this utility by selecting More > Calendar Cleanup from the action bar. A
dialog, similar to that in Figure 2.7, appears.
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Figure 2.7 The configuration dialog for the Calendar Cleanup routine.

Step 3. You have two ways to define the events to be cleaned. You can delete entries based
on duration (such as the last 6 months) or based on a specific date (such as
1/1/2008). Select an option in the Which Entries Do You Want to Delete section
and define its corresponding cleanup parameters.

Step 4. Select the type of events to be processed as part of the Calendar Cleanup. The two
options are Calendar Entries and To Do Entries. Selecting the Calendar entries
check box will remove historical meetings, appointments, reminders, events, and
anniversaries. Selecting To Do Entries will remove all personal or group To Do
documents from the calendar. It’s important to note that future meetings, recurring
events, anniversaries, or other scheduled appointments are not impacted by the
routine.

Step 5. Click OK after the cleanup parameters are specified. A confirmation message
appears as shown in Figure 2.8. This is the final opportunity to cancel the routine.



Figure 2.8 A confirmation message is displayed prior to performing the Calendar Cleanup.

Step 6. Click OK to start the cleanup process or click Cancel to abort the process. Once
started, the progress of the cleanup appears in the message bar located at the bot-
tom-left side of the client. You should see messages similar to the following:

Calendar Cleanup:Mark Elliott

Calendar Cleanup:Selecting Documents

Calendar Cleanup:Deleting Documents

Calendar Cleanup:done. 21 documents deleted.

In some cases, these messages might appear in rapid succession. If the messages
are no longer displayed or visible from the client window, simply click on the mes-
sage bar and a history of the most recent messages will be displayed in a small list.

TIP

Consider adding monthly, quarterly, or semi-annual reminders to your calendar to run the
Calendar Cleanup routine. Minimizing the size of the mail will improve performance and
reduce mail server operating costs.

Emptying Your Trash
Emptying the trash folder is a key technique for reducing the overall size of the mail application.
To understand how, let’s start by reviewing the delete process. When a mail memo is deleted, the
document is moved to the Trash folder. This folder is a temporary storage location for docu-
ments. All the documents in the folder have been essentially “earmarked” for deletion.

The document remains in this folder until either the user manually empties or, if config-
ured, the Notes client automatically deletes the document. Until the document is formally deleted
by the user clicking on the Empty Trash button or via the Notes automated process, these docu-
ments consume space in the mail application.

Some might question what the purpose of the folder is. The folder serves as a holding bin
for files that are “about to be deleted.” When a user deletes a file and it is moved to the trash
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folder, this is considered a Soft Delete. This removes the document from the main mail applica-
tion and will be permanently deleted unless the user takes action. At the same time, the soft delete
process enables the user to recover documents that might have inadvertently been deleted or
when the user later decides, “I better keep that document” shortly after pressing the Delete key.

Documents are permanently removed from the application only after the user clicks the
Empty Trash button or if the Notes client is configured to automatically delete the document
based on a set interval. When one of these events occurs the document is permanently deleted
from the mail application and cannot be retrieved. This is called a hard delete. Users should be
encouraged to empty the trash on a regular basis. A simple reminder on the calendar can also help
facilitate users who need additional assistance.

To manually empty documents from the trash folder, navigate to the Trash folder and click
the Empty Trash button. Once the button is clicked, the user will be prompted with a warning
message, “Do you want to permanently remove the document(s) from the application?” This is
the last opportunity to halt the process. Click Yes to permanently delete the documents. Click No
to cancel the process. This option returns you to the trash folder where you can review and/or
restore documents.

In addition to manually emptying documents in the trash folder, users can configure the
Notes client to automatically empty the trash on a set interval in the user preferences. Once the set
interval is reached, the documents will automatically be deleted from the mail application. To
configure the delete interval, select the File > Preferences menu option. Navigate to the Mail
section. Here you will find a field “Delete Documents in My Trash Folder After (     ) Hours.”

Specify a value for this field and click OK to save the values.

WARNING

Users should specify a value between 1 and 5 digits. Users who specify a value greater than
6 digits will most likely encounter an Overflow error message when accessing their mail.
Consider setting this value to a value such as 40 hours. To delete the message every seven
days, set the value to 172. To delete messages every four weeks, set the value to 672.

Switching Back to the Old Desktop
Starting with Lotus Notes release 8, the application user interface was completely redesigned and
now uses a new architecture based on Eclipse. The application includes new graphics, color
schemes, and layout.

However, some users tend to resist change and might prefer to revert to previous layout set-
tings. For those users, Lotus has included an option to toggle between the Notes 7 and Notes 8
desktop layout. Users should be aware, however, that performance might be degraded when
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switching to a an older layout. By default, the new layout appears after upgrading to Notes
release 8. To switch back to the previous workspace layout, complete the following steps:

Step 1. Select the File > Preferences menu option.

Step 2. Navigate to the Basic Notes Client Configuration section.

Step 3. Locate the Additional Options list box near the bottom of the dialog.

Step 4. Select the Textured Workspace option to display the old workspace interface as
displayed in Figure 2.9.
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Figure 2.9 Select Textured Workspace to revert to the previous workspace layout. Users might
see a degradation in performance with this option.

Step 5. Click OK to save the changes.

Troubleshooting
This section outlines just a few error messages, issues, and resolutions that users might experi-
ence while using the Lotus Notes client. This section is not intended to be an exhaustive list of
problems but rather a list of the more common problems that tend to be encountered. It’s also
important to understand many of these items are general usage issues as opposed to actual prob-
lems with the client.



Obviously, corrective actions will vary depending on the application, workstation, and
other corporate-specific customizations to the client or database application. You will notice each
issue includes a description of the symptom, general analysis of the root cause, and resolution.

Additionally, to help with problem determination, some of the issues include a reference to
a specific version of the Lotus Notes client. such as “(Lotus Notes 7).” This is intended to be a
general indication as to the version of Lotus Notes that will most likely encounter the issue.
Where no reference is provided, the issue tends to be release independent.

The majority of the instructions for this section are based on release 8. However, where fea-
sible or appropriate, instructions have been included based on prior release levels. If in the
process of running through the resolution instructions you find the menu options are different,
simply scan through the menu list. In most cases, the menu option is still present, just located
elsewhere within the menu list.

For instance, in release 8 the user preferences are accessed via the File > Preferences menu
option whereas in release 7 it’s accessed via File > Preferences > User Preferences. Ideally the
solutions listed in this section will correct the problem irrespective of the software release being
used.

The section also includes a couple of the more common software code errors. These errors
usually require the application developer to correct a design error or glitch. Even when an appli-
cation has been thoroughly tested, errors are bound to slip through and appear. It’s possible that a
scenario was not considered or was simply not feasible to test. As such, a couple of the common
code error messages have been included along with some general tips for debugging the issue.

If you encounter one of these errors, make note of the steps or actions performed, and relay
the information to an application developer if possible. The resolution section will clearly indi-
cate this is not a problem the average user can resolve and intervention from a Domino developer
will be needed. This will help distinguish between general client issues and programmatic issues.

Lastly, if the problem still exists after trying the suggested resolution, see Chapter 3, “Find-
ing Additional Help,” for more information and assistance with problem determination.

All Messages Are Reset to Unread After Moving to Folder
Symptom: After moving one or more mail messages to a folder, the message changes from read
to unread. Users then have to open the folder and reset the red flag for each document that was
moved into the folder. (Lotus Notes 8)

Analysis: The configuration setting was reset in the process of upgrading from Lotus Notes
release 7 to release 8, or the setting was inadvertently changed.

Resolution: Update the property setting for the database.

Step 1. Open the mail application.

Step 2. Select the File > Application > Properties menu option.
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Step 3. Click on the fourth tab to display the design settings.

Step 4. Enable (or check mark) the option Do Not Mark Modified Documents as
Unread (see Figure 2.10). This will correct the problem. You might need to exit
and reopen the application for the change to be effective.
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Figure 2.10 This option prevents messages from being automatically set to “unread” when
moved to a folder.

Compact Local Database Fails
Symptom: The user receives an error when attempting to compact the database, or the compact
process never completes.

Analysis: Lotus Notes often makes a copy of the database as well as writes data to a cache
file. It’s likely that the file size limit has been reached when attempting to make a copy of the
database and/or the cache file.

Resolution: Clearing the cache files will frequently correct this error. Two files contain
cache information: cache.ndk and log.nsf. Once these files are renamed, Lotus Notes will recre-
ate them as part of the normal startup process.

Step 1. Close the Lotus Notes application.

Step 2. Locate the Cache.ndk and Log.nsf files. These files should be located in the
\Data folder.

Step 3. Rename both files. (Do not delete these files as they are critical to trouble-
shooting.)

Step 4. Restart Lotus Notes.

Step 5. Restart the compact process for the database.



Customized Toolbar Buttons Missing after Software Upgrade
Symptom: Custom toolbar buttons that were created or added in a previous release no longer
appear in the client after upgrading to the most current software release level. (Notes 8)

Analysis: User-created buttons are typically added to the “Universal toolbar.” After the
upgrade to release 8, this toolbar was most likely disabled and is not being displayed in the client.
Enabling the display of this toolbar typically corrects the problem.

Resolution: Check the toolbar display settings and enable the “Universal toolbar.” Select
the View > Toolbar menu option. If the Universal toolbar is not currently enabled, then select
the menu option. You can also navigate to the toolbar settings by right-clicking on the toolbar and
selecting the same options as outlined previously. The toolbar will display and should contain the
missing buttons. However, existing toolbar buttons might shift around the window to accommo-
date the new toolbar. To reorder the buttons, users might drag and drop the toolbars that are dis-
played on the screen.

If after enabling the Universal toolbar one or more buttons still do not display, then the
function might no longer be supported in the current release. For instance, the Close All Open
Windows function is no longer available. This button will not appear in release 8. Perform the fol-
lowing to check whether the desired function is still supported:

Step 1. Select the File > Preferences menu option.

Step 2. Navigate to the Toolbar and Customize section.

Step 3. Locate the button’s icon. If the icon is in the list, but does not appear in the toolbar,
then the function is no longer supported. Consider adding a new button based on
the currently supported functions as an alternative.

User Receives the Clock Synchronization Server Error
Symptom: User receives the clock synchronization error message (“Server Error: Connection
failed because of a problem with clock synchronization and password change intervals. Check
your clock settings, change your password, or consult your system administrator.”) when
attempting to access mail, connect to a Domino server, or after changing operating system time.
(Notes 7)

Analysis: One or more Lotus Notes documents (or files) are potentially corrupt or there is a
save conflict with one of the user’s Location Documents.

Resolution: Resetting the Location Document and/or removing the conflict document usu-
ally corrects the issue.

Step 1. Set the operating system clock to the correct date and time.

Step 2. Close and restart the Lotus Notes client.
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Step 3. Click on the current Location Document (lower-right corner of the client). A
pop-up menu appears with a listing of locations and actions.

Step 4. Select the Edit Current option from the menu.

Step 5. Navigate to the Advanced and Basics tabs.

Step 6. Change the Use Operating Systems Time Zone Settings from Yes to No and
save the document.

Step 7. Edit the Location Document a second time and change the value from No back to
Yes and save the document.

This method should correct the problem. If you continue to encounter the problem, open
the user’s address book and navigate to the Advanced and Locations view. Check for a save con-
flict document and delete it if one exists.

Web Pages Open in Notes Browser after Software Upgrade to
Lotus Notes 8
Symptom: When the user clicks on a link, the Web page opens in the Lotus Notes browser
instead of the default browser. This problem started after the user upgraded to software release 8.
The user did not experience the issue when using a prior version of the Lotus Notes client. Previ-
ously, when the user clicked on an Internet Web link, the page opened in the correct browser. The
value is set correctly in the Location Document. Changing the value of the Location Document
had no effect on the browser display. (Lotus Notes 8)

Analysis: Software is working as designed. Beginning with Lotus Notes release 8, the
browser setting in the Location Document is no longer used. This field has been deprecated, but
remains on the document. Instead, a new function has been added to the user preferences to man-
age the browser display. This value overrides that of the Location Document.

Resolution: To change the default preference, update the default browser setting in the user
preferences.

Step 1. Select the File > Preferences menu option.

Step 2. Navigate to the Web Browser section (see Figure 2.11).

Step 3. Locate the When Clicking on a Hyperlink in the Client field.

Step 4. Select the Use the Browser I Have Set as the Default for This Operating Sys-
tem option.

Step 5. Click OK to save the setting.
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Figure 2.11 Using the Preferences dialog, the user can set where Web pages are opened.

Browser Does Not Launch
Symptom: When the user clicks on a link using Lotus Notes release 7 or earlier, the Web page
opens in the Notes browser. (Lotus Notes 7 or earlier)

Analysis: The Lotus Notes client is working as designed. The Notes browser is the default
setting when the software client is installed. Users can change the default by updating the appro-
priate setting in the user’s Location Document.

Resolution: To change the default preference in the user’s Location Document.

Step 1. Select the File > Mobile > Edit Current Location menu option. (Note: Users can
also click on the current location displayed in the lower-right corner of the client
and select Edit Locations from the popup menu.)

Step 2. Navigate to the Internet Browser tab (see Figure 2.12).

Step 3. Select the default browser.

Step 4. Click OK to complete the update.
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Figure 2.12 By editing the Location Document, users can select the default Web browser to
automatically launch when clicking on a Web link (for release 7 or earlier).

Multiple Sametime Icons Displayed in Windows Tray
Symptom: After installing or upgrading to Lotus Notes release 8, multiple Sametime icons
appear in the Windows system tray. One icon is selectable. When the user clicks on this icon, she
can open the active list of users and perform normal instant message activities. The second icon is
not selectable. This secondary icon cannot be halted and does not launch the Sametime dialog
window when clicked.

Analysis: Two versions of the Sametime client have been installed. One version existed
prior to the installation of Lotus Notes release 8. A second version, called the Integrated Same-
time client, was selected and installed as part of the Notes upgrade. This is the Sametime icon in
the system tray that cannot be managed. The Integrated Sametime Client is incorporated and
managed from the Notes client. To access and manage instant messages, users will have to navi-
gate to the Sidebar in Lotus Notes release 8.

Three options are available to the user: remove the integrated client, remove the stand-
alone client, or take no action. Instructions for removing each client are outlined as follows.

Resolution 1: Uninstall the Integrated Sametime client. This will allow the user to have a
separate client application for each product, similar to the workstation setup prior to the Notes
upgrade.

Step 1. Close the Lotus Notes client.

Step 2. Stop the Sametime client where feasible.

Step 3. Launch the software installation program for Lotus Notes release 8. The Installa-
tion Wizard screen should appear with a general welcome message.

Step 4. Click Next at the Installation Wizard screen. Because the software has already
been installed, the Program Maintenance dialog appears as shown in Figure 2.13.
This window gives you the option to Modify, Repair, or Remove Lotus Notes
from your workstation.
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Figure 2.13 Using the Install Wizard, you can modify the Notes client installation.

Step 5. Select the Modify option and click Next to continue. The Custom Setup dialog
appears as shown in Figure 2.14. This screen allows to you modify which features
are included in the Lotus Notes client. In this particular case, you want to remove
a feature that was previously installed.
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Figure 2.14 Running both integrated and stand-alone Sametime clients can cause usability
issues. Using the Installation Wizard you can remove an integrated client from the Notes client.

Step 6. Click on the drop-down menu next to the Sametime (integrated) option and
select the option This feature will not be available.



Step 7. Click Next to remove the feature and Finish to complete the software modifica-
tion process. Once the process completes, you might need to reboot the worksta-
tion. Otherwise the Lotus Notes and Sametime clients are ready for use.

Resolution 2: Uninstall the stand-alone Sametime client application from the workstation.
This option will require users to utilize the integrated client from the Lotus Notes Sidebar in order
to manage instant messages.

Step 1. Close the Sametime stand-alone application.

Step 2. Select the Start > Settings > Control Panel menu option from the Windows
toolbar.

Step 3. Select the Add or Remove Programs icon.

Step 4. Locate the IBM Lotus Sametime Connect application in the list of currently
installed software programs.

Step 5. Click on the application and select Remove to uninstall the application. Close the
dialog once the removal process completes.

Resolution 3: Take no action. Both applications can be installed concurrently.

Database Is Currently Being Replicated
Symptom: User receives the error message “Database is currently being replicated” when
attempting to replicate an application to their local workstation. However, based on the progress
indicator on the replication page, no replication is currently in progress.

Analysis: The Lotus Notes application incorrectly believes the replication process is
already in progress. This problem might be caused by a corrupt cache file.

Resolution 1: Clear the cache files file for the Lotus Notes client. This is achieved by stop-
ping the client and deleting the related files. When Lotus Notes restarts, it will generate new
cache and log files for the user.

Step 1. Close the Lotus Notes application.

Step 2. Locate the Cache.ndk and Log.nsf files. These files should be located in the
\Data folder.

Step 3. Rename both files. (Do not delete these files as they are critical to trouble-
shooting.)

Step 4. Restart Lotus Notes and retrigger replication for the application.

Resolution 2: Remove both the local and server icons from the workspace and re-add
them. The act of removing and re-adding the database will sometimes clear a varied array of
anomalies associated with a database application. Be sure to note the application name and fold-
ers for both local and server instances of the database application before removing the icon from
the workspace. This information can be found in the database Properties dialog. (Tip: You can
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Smart Upgrade Tracking
Report Database, 223

Soft Delete, 90
source document attachments,

troubleshooting, 136
space quotas, troubleshooting,

133
unable to save draft

memos, 131
spell checker, 12, 54

troubleshooting, 133, 137
startup failure,

troubleshooting, 124-125
Stationery feature, 61-62
supplies, procuring, 195
Support section (IBM

developerWorks Web site),
174-175

Suppress Remote Images, 15
suppressing images from

Internet mail, 56
SURUNAS.EXE, 206
SUSETRUNASWIZARD.EXE,

205
switching back to old

desktops, 90-91

T
tabbed tables, 11, 42

creating, 46-47
table width, 43
tables

animated tables, 43
captions, 43
column widths, 45
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creating, 42-45
basic tables, 46
tabbed tables, 46-47

programmed tables, 43
tabbed tables, 11, 42

teams, establishing, 194
Technote, 174
templates, 154-155
text, troubleshooting, 129
text signatures, 25

creating, 26
time zones, problems when

scheduling meetings, 127
title rows, 73
Toolbar section (Lotus

Notes), 9
tools

NFIXUP.EXE, 185
NSD.EXE, 181

trace, 120
trash, emptying, 89-90
troubleshooting, 91-92

ACTIONSFOLLOWUP,
111

adding entry will 
cause text list to 
exceed 64K, 133

addresses when pasted into
Send To field, 132

attachments cannot be
deleted from declined
calendar invitations, 127

blocked sending rules, 137
browser does not 

launch, 96
calendar delegates can

view mail folders, 144

calendar event overflow
error, 133

calendar events not
showing in “high
importance” inbox
category, 136

cannot respond to
rescheduled calendar
invitations, 126

CHANGEFOLLOW-
UPDATE, 129

compact local database
fails, 93

conflicting information,
140-141

customized toolbar buttons
missing after software
upgrade, 94

database is currently being
replicated, 99-100

default calendar alarm
button set to snooze, 144

deleted documents are
reappearing after
replication, 100-101

duplicate characters
displayed in mail 
folder, 128

“Entry not found in index,”
101-102

error messages,
availability time range is
invalid, 125-126

expired certificates, 
130-131

failure of Lotus Notes to
start, 124-125

field too large (views,
columns, and selection
formulas), 131

“File already exists,” 
102-103

“File not found or File
does not exist,” 104-105

focus shifts in integrated
Sametime sidebar when
launching Lotus
Symphony, 144

folder with custom
expiration date does 
not recognize retention
date, 145

hot keys, 136
icons for mail folders, 127
IFDRAGFROM-

FOLLOWUP, 129
illegal circular use, 111,

118-119
incorrect Lotus Symphony

editor is displayed, 144
“Integrity of a Database

Storage Container Has
Been Lost—Container
Will Be Rebuilt,” 
105-110

invalid RTF data, 132
local time appears invalid

when scheduling
meetings in other time
zones, 127

locating supported
versions of required
Notes or Domino
software, 141
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Lotus Notes directory is
not valid, 113

Lotus Notes hangs or
crashes when using
address assistant 
lookup, 113

mail database is acting
strange or abnormal, 110

margin missing from
Inbox view, 134

message bar displays, 132
message text becomes

corrupt when attempting
to forward memos, 129

messages are reset to
unread after moving to
folder, 92-93

MIME Save Warning, 111
missing source document

attachments, 136
multiple Sametime icons

displayed in Windows
tray, 97-99

not able to see unread flags
when inbox categories
are collapsed, 143

“Notes IPC Async
Message Processor,” 140

object variable not set, 114
Open in Designer 

menu option is not
available, 139

Overflow warning
message, 148

owner values in mail file
preferences, 130

preferences, 134

previous Notes client type
could not be determined,
142-143

private keys, 128
recipient names not

showing in type-ahead
dropdown, 134

remote pathnames, 
115-118

replication and copy status
does not appear, 138

server with this database is
no longer responding,
112

Show button does not
work, 146

spell checker
capitalization, 137
corrects wrong word in

tables, 133
type mismatch on external

name, 111
unable to create partial

replicas, 146
unable to find path to

server, 119-121
unable to install Lotus

Notes 8, 138
unable to invoke programs,

121-122
unable to open database in

new window, 145-146
unable to rename folder or

view, 149-150
unable to save draft memo

when application has
exceeded space quota, 131

“Unable to Send Mail,”
122-123

unable to write to your
mail database, 124

update notice error occurs
when user selects update
calendar, 149

user receives clock
synchronization server
error, 94-95

variant does not contain an
object, 115

View Unread function
hides all read mail, 147

Web links are not clickable
in some messages, 139

Web pages open in Notes
browser after software
upgrade, 95

welcome screen, 115
Windows shutdown hangs

with Notes client
running, 139

workspace didn’t 
upgrade, 135

workstation CPU jumps to
100% when sending
mail, 138

Twistie, 12, 171
type mismatch,

troubleshooting, 111
type-ahead addressing, 15

troubleshooting, 134
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U
“Unable to send mail,”

troubleshooting, 122-123
Undo function, 11
unprocessed invitations,

displaying, 39
update notice error, 149
upgrade activities, managing,

194-197
communication, 196
developing procedures, 195
performing the 

upgrade, 197
pilot tests, 196
process control points, 196
procuring supplies, 195
projects, 195
research, 194
teams, 194

Upgrade by Mail option, 198
upgrade database, creating,

200-202
upgrade kit, obtaining, 204
Upgrade Kit Document, 

215-216
upgrade plans, developing,

190-191
managing upgrade

activities, 194-197
sequence of events, 

191-193

upgrades
automating Notes 

client upgrade process,
198-200

administrator install
package, 205-213

Domino Server
configuration,
213-219

obtaining upgrade 
kit, 204

policy documents, 
219-223

Smart Upgrade
checklist, 223-224

Smart Upgrade
Tracking Report
Database, 223

updating Domino
Directory
Configuration, 202-203

upgrade database,
creating, 200-202

mail folder design, 
153-157

automatic upgrade
process, 157-158

manual upgrade
process, 158

managing resources for,
224-225

performing, 197

user interface (Lotus Notes
version 8), 7

User Security window, 35

V
variants, troubleshooting lack

of objects, 115
View Unread function,

troubleshooting, 147
viewing policy settings, 

260-262

W–Z
Web content feeds

ATOM, 55-56
RSS, 55-56

Web links, troubleshooting,
139

welcome screen,
troubleshooting, 115

windows, User Security, 35
Windows and Themes

section, 9
Windows hard drives,

defragmenting, 83
workspace

compacting, 82-83
troubleshooting

upgrades, 135

Zapnotes, 179-180
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