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Features of Mastering SolidWorks®:  
The Design Approach

Tutorial 4–6: serutaeFetaerC

This tutorial covers the creation of these features: chamfer, fillet, slot, shell, draft, and 
rib. All dimensions are inches. Here are useful observations: 

 1.   Make sure to pay attention to the visual clues shown in the left pane while creating 
.serutaefeseht

 2.   For example, the box symbol under  Chamfer parameters  indicates that you can 
chamfer a face, an edge, or a vertex (corner point). As expected, chamfering a face 
chamfers all its edges. Chamfering a corner chamfers the three edges that meet 
there.  

 3. .ssenkcihtadna)enilesiwpetsroenila,.g.e(hctekseliforpaseriuqerbirA

p 1: Step 5:Shell Block

q p ( g , p )

Step 1: 
  Create  Sketch1
and  Block
feature:  File  > 
New > Part > 
OK > Top 
Plane > 
Extruded 
Boss/Base  on  Features  tab  > Center Rectangle no
Sketch  tab > click origin and sketch and dimension as 
shown > exit sketch > reverse extrusion direction > 
enter 0.5 for thickness  D1  >  >  File > Save As >
tutorial4.6  >  Save.

Step 2:   Chamfer an 
edge of  Block  feature: 
Fillet  dropdown on 
Features  tab >  Chamfer 
>  select  Block  edge 
shown  >  use 0.1 for  D

d 45 d f l

Step 5: llehS Block
feature:  Shell no Fea-
tures bat > pottceles
face of  Block 1.0retne>
for wall thickness  D1 >

.

Step 6: Draft  Block
feature: Delete the 
chamfer, fillet, and shell 
features  > Draft on 
Features tab  > enter 10 
degrees for  Draft Angle >
select top face of  Block as 
Neutral Plane > select  Block four side faces to draft > .

p
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Example 12.1   eerhtgniwollofehtrofsenozecnarelotdnastimilehtetaluclaC
fits: clearance of RC3, transition of LT4, and interference of FN2. 
Use a basic size of 5.0000 in. 

Solution .stluserehtswohs2.21elbaT,spetsruofevobaehtgniwolloF

Fit  dhmin dhmax dsmin dsmax h s A
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)7k/8H(4TL 6100.05200.07100.51000.55200.50000.5 0.0017 

)6s/7H(2NF 6100.05400.55300.56100.50000.5 0.0010  0.0045 

eziScisaBrofstimiL2.21ELBAT d  5.000 in. 

Th li i h i T bl 12 2 i h h S lidW k l h i Fi 12 8

 1. .gnirutcafunamniytilibairavfosecruosehttsiL

 2. ?secnarelotdeenewodyhW

 3. ?lortnocepythcaeseodtahW.secnarelotfosepytowtehttsiL

 4. ecnarelotstinihtiwsitraparehtehwkcehcotdesueraseguagnoitcepsnI
limits. Perform an in-depth research study on inspection gauges including 

.noitcepsnitrapgniruddesuerayehtwohdna,ngisedrieht,sepytrieht

 5. .elpmaxenaeviG?eziscisabadnalanimonaneewtebecnereffidehtsitahW

 6. ebircseD.cirtemmysdna,laretalib,laretalinu:tsixesecnarelotfosepyteerhT
.epythcaerofelpmaxelaciremunaeviG.epythcae
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Preface

The target audience for this book is college students in courses that use 
SolidWorks to learn and master CAD/CAM for design, visualization, 
prototyping, and manufacturing. The book’s primary market is four-year 
colleges and two-year community colleges. Freshman Engineering Design 
courses should find this book useful, refreshing, and interesting. Other 
important markets include high schools, professionals, and training 
courses. We have written the book with the target audience in mind. Page iii 
highlights some of the book’s features.

The book includes relevant math in Chapter 8 (Curves), Chapter 9 
(Surfaces), and Chapter 13 (Analysis Tools). The math is concentrated in 
one or two sections in each of these three chapters. We include the math for 
two reasons. First, it shows students who are curious how CAD/CAM 
systems work “under the hood.” Second, it broadens the book’s appeal to 
many students, professors, and readers. This math may be ignored without 
affecting the continuity of the coverage of the material in any of these three 
chapters.

The philosophy behind the book is original, unique, and effective. We 
cover and present SolidWorks as a design system rather than a software 
program. Thus, instead of focusing on describing SolidWorks menus and 
syntax, we describe design approaches, methodologies, and techniques to 
help CAD designers/engineers and draftspersons achieve engineering tasks 
in the fastest, easiest, and most effective way.

Based on this philosophy, the book focuses on design, modeling, and 
drafting concepts instead of menus and commands. Thus, we present 
command sequences to achieve CAD and modeling tasks. Of course, we 
provide SolidWorks syntax and details, but do so in accordance with the 
proposed philosophy of the book. We start with a CAD task to accomplish 
(what to do) and then go about accomplishing it (showing how to use 
SolidWorks to do it). This philosophy is more motivating to student learning 
than simply going through layers of menus and commands.

The book approach is designed to showcase SolidWorks as a powerful 
modeling and design system instead of only a software program. We include 
challenging modeling and design examples and problems in the book. As 
part of the book’s unique approach, we cover the theoretical concepts 
behind the various functions of SolidWorks. This should provide 
information to curious minds about why things work the way they do, as 
well as explain their limitations and use.

The book provides abundant illustrations, step-by-step instructions, 
and rich and challenging end-of-chapter problems. The book is suitable for 
use at various levels, from freshman to senior to graduate courses. 
Instructors can choose the chapters and topics that suit their teaching 
needs and courses. They can also choose the level of depth. The book 
includes both examples and tutorials. An example covers one concept 
whereas a tutorial is more comprehensive by covering a full design task. 
Most examples and tutorials have a hands-on exercise at the end that 
serves two purposes. First, it ensures that the student has completed the 
example or tutorial, because it builds on it. Second, it both challenges and 
extends the student’s understanding.
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Preface   vii

The book is organized into parts and chapters. Instructors may cover 
the chapters in any order to fit their course and student needs. However, 
we recommend covering Chapters 1 and 2 first to build a sound foundation 
in 3D CAD/CAM modeling concepts. Chapter 1 is designed to provide a 
quick grasp of basic functionalities: create parts, create assemblies, and 
create drawings. These three functionalities correspond to the three modes 
of SolidWorks: part, assembly, and drawing. Therefore, students can start 
designing basic and simple products after using only one chapter of the 
book; they do not have to wait until later chapters to learn how to design 
and document simple parts and assemblies. Later chapters provide further 
details. Thus, Chapter 1 provides breadth and the remainder of the book 
provides depth. Chapter 2 covers essential concepts required for a sound 
understanding of 3D modeling and efficient use of today’s parametric 
features-based solid modeling CAD/CAM systems such as SolidWorks.
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my students, the book reviewers, the Pearson team, the editorial team, and 
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Part II
Basic Part Modeling

The primary goal of this part is to explore and cover the details of 
engineering drawings, assemblies, and rendering. We have covered these 
topics briefly in Part I. Each topic has its own chapter in Part II to under-
stand it in depth. Part II also covers the full set of features that can be used 
in CAD modeling. In Part I, we purposely limited our models to the basic 
features of extrusions and revolves.

Chapter 4, “Features and Macros,” is all about when and how to use 
the full set of features available to design advanced parts with complex 
geometry. Chapter 5, “Drawings,” covers the details of drawings, including 
the creation and control of the title block. Chapter 6, “Assemblies,” covers 
assembly details, including the bottom-up and top-down approaches. 
Chapter 7, “Rendering and Animation,” closes Part II by showing how to 
create realistic renderings of parts and assemblies that show material and 
texture. CAD visualization is important to convey and present designs 
efficiently.
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4 Features and 
Macros

chapterfour

4.1 Introduction
We have been using a limited set of features thus far in the book. We have 
used extrusions and revolves. We have used the SolidWorks features 
Extruded Boss/Base and Revolved Boss/Base and their subtracting 
counterparts, Extruded Cut and Revolved Cut. These four features create 
one class of parts: those with constant cross sections. We use the extruded 
boss or cut to create uniform thickness parts. We use the revolved boss or 
cut to create axisymmetric parts. Amazingly, these four features can create 
80% or more of the mechanical parts you are likely to need.

These four features cannot create some classes of parts: They cannot 
create parts whose cross sections are variable or parts that have nonplanar 
faces or other geometric shapes. The features that allow us to create these 
types of parts are Lofted Boss/Base, Swept Boss/Base, Lofted Cut, 
Swept Cut, Hole Wizard, Rib, Draft, Shell, and Dome, as shown in 
Figure 4.1. We cover all these features in this chapter. You can also access 
more features by clicking this sequence: Insert (menu) > Features.

Figure 4.1
Available  
features

A feature is defined as a solid that, when combined with other features 
(solids), creates parts. A CAD part consists of a set of features created in a 
certain sequence stored in its feature tree. Some features, such as bosses 
and cuts, originate as sketches, while others, such as shells and fillets, 
modify other features. Features are always listed in the feature tree (which 
SolidWorks calls the FeatureManager Design Tree) of the part.
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Today’s modeling is referred to as feature-based modeling, and the 
resulting models are known as feature-based models. The first feature you 
create in a part is known as the base feature. You use the base feature as 
the basis to create other features. A base feature obviously cannot be nega-
tive (i.e., a cut), and SolidWorks does not allow it. When you begin creating 
a feature, Extruded Boss/Base and Revolved Boss/Base are the only 
selectable feature types. You might also expect Swept Boss/Base and 
Lofted Boss/Base to be selectable when you begin creating a feature, but 
they are not. Lofted Boss/Base becomes selectable only after you create a 
sketch (profile), and Swept Boss/Base becomes selectable after you create 
a cross section and a path (sweep direction).

4.2 Features
To master feature-based modeling, you should be able to answer three 
fundamental questions:

1	 What are the available features that a CAD/CAM system offers for 
modeling parts?

2	 What is the input required to create each feature?

3	 Which feature should you use for a given modeling problem?

Section 4.1 and Figure 4.1 provide the answer to the first question. 
Table 4.1 answers the other two questions. It shows a simple basic example 
of each feature. Keep in mind that the third question may have multiple 
answers; one of them is always the best answer. For example, you may use 
a loft or a sweep. However, if a part has a constant cross section along a 
curve, sweep is better to use because it requires fewer steps to create the 
part. If the part has a variable cross section, a loft is better to use. The 
tutorials in this chapter provide some modeling examples.

Table 4.1
Available Features

No. Feature Input (sketch) Resulting Feature When to Use in Modeling?

1 Extrusion Cross section and a thickness •	 Use for parts with constant 
cross section (CS) and 
uniform thickness (UT).

•	 If needed, break part 
into subparts, each with a 
constant CS and UT.

2 Revolve Cross section, an axis of 
revolution, and an angle of 
revolution

•	 Use for parts that are 
axisymmetric.

•	 If needed, break part into 
subparts, each of which is 
axisymmetric.
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No. Feature Input (sketch) Resulting Feature When to Use in Modeling?

3 Sweep Linear sweep: cross section and a 
line as a path

Path

Profile

•	 Use for parts with constant 
cross section (CS) along 
a linear direction (path) 
that may or may not be 
perpendicular to the cross 
section.

•	 If the path is perpendicular 
to the cross section, the 
linear sweep becomes an 
extrusion.

Nonlinear sweep: cross section 
and a curve as a path

Path

Profile

•	 Use for parts with constant 
cross section (CS) along a 
nonlinear direction that may 
or may not be perpendicular 
to the cross section.

4 Loft Linear loft: at least two cross 
sections (profiles)

•	 Use for parts with variable 
cross section along a given 
direction.

•	 The cross sections are 
blended linearly from one 
section to the other.

Nonlinear loft: at least two cross 
sections (profiles), and a curve as 
a guide curve

Guide Curve

•	 Use for parts with variable 
cross section along a given 
direction.

•	 The cross sections are 
blended nonlinearly from 
one section to the other, 
along the guide curve.
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Example 4.1  Create the free-form torus shown in Figure 4.2.

Solution  The torus shown in Figure 4.2 is a variation of the torus 
(donut shape) feature (No. 2) shown in Table 4.1. While that feature of 
Table 4.1 is a revolve, the free-form torus shown in Figure 4.2 can only 
be created as a sweep. The key modeling concept here is to use pierce 
relations to force the torus cross section (small circle) to conform to 
the sweep path (large circle) and the guide curve (closed spline), as 
shown in Figure 4.2. You pierce the small circle to the spline and pierce 
the center of the small circle to the large circle. These two pierce 
conditions force the small circle to become “elastic”; that is, it 
expands and shrinks, as it must always touch the spline and the big 
circle. Pierce condition is only available to pierce a point to a curve. 
You cannot pierce two curves. SolidWorks enables the pierce condition 
in the right context. Figure 4.2

Free-form torus

The other features shown in Figure 4.1 and not covered in Table 4.1 
are covered in the tutorials in this chapter.

No. Feature Input (sketch) Resulting Feature When to Use in Modeling?

5 Rib Rib profile (e.g., line or stepwise 
line)

Profile

•	 Use when a stiffener 
between angled walls 
(faces) of a part is required 
to increase part structural 
strength.

6 Shell Shell face and shell wall thickness

Shell face

•	 Use when you need to 
remove material from an 
existing part.

•	 The material removal 
(shelling) occurs in a 
direction perpendicular to 
the selected shelling face.

•	 While you can achieve the 
same result using an extrude 
cut for simple shells, a shell 
operation is faster to use.

7 Draft Direction of pull, parting lines, 
and a draft angle. The direction 
of pull must be perpendicular to 
the parting lines.

•	 Use when you need to draft 
faces at an angle; usually 
used for injection molding 
to allow pulling the molded 
part from the mold cavity.
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Step 1:	 Create Sketch1-Path (sweep 
path): File > New > Part > OK > Top 
Plane > Sketch tab > Circle on Sketch 
tab > click origin to sketch and dimension as 
shown > exit sketch > File > Save As > 
example4.1 > Save.

Step 3:	 Create 
Sketch3-Profile (sweep 
profile): Front Plane > 
Sketch tab > Circle on 
Sketch tab > sketch a 
circle anywhere > Point 
on Sketch tab > click 
circle anywhere.

Note: Do not dimension the circle as doing so over-constrains it when 
you apply the pierce relation.

Step 2:	 Create Sketch2-Guide (sweep 
guide curve): Top Plane > Sketch tab > 
Spline on Sketch tab > sketch free spline 
as shown > exit sketch.

Note: Sketch1-Path and Sketch2-Guide are 
two separate sketches, and they both use 
Top Plane.

Step 4:	 Create 
pierce relations: 
While Sketch3-
Profile is still 
open from Step 3, 
click small circle 
center + Ctrl + select large circle > Pierce relation > ✓ > select point 
created on circle + Ctrl + spline > Pierce relation > ✓ > exit sketch.

Step 5:	 Create Sweep-Torus feature: Features tab > Swept  
Boss/Base > select Sketch3-Profile as Profile > select Sketch1-Path 
as Path > select Sketch2-Guide as Guide Curve > ✓.

HANDS-ON FOR EXAMPLE 4.1
Re-create the free-form torus by replacing the spline by a circle that is not centric with 
the large circle.

4.3 Spur Gears
Gears are an important and essential mechanical element in mechanical 
design. A wide range of products and applications use gears. There are vari-
ous types of gears: spur, helical, bevel, spiral, worm, planetary, and rack 
and pinion, to name a few. A spur gear is the simplest type of gear and the 
type we cover here. Typical mechanical design courses in colleges cover the 
principles and design of gears. In this section, we cover spur gears from a 
CAD point of view (i.e., how we construct a gear once it is designed). While 
gears are standard elements that can be purchased off the shelf (they can 
also be inserted from the SolidWorks Toolbox into a part or assembly file), it 
is important to learn how to create a gear feature in a CAD/CAM system.

A gear tooth is the intricate part of a gear. Figure 4.3 shows two mesh-
ing gears. Figure 4.4A shows the conjugate line and pressure angle. Figure 
4.4B shows the involute profile. Gearing and gear meshing ensure that two 
disks (the two gears) in contact roll against one another without slipping. 
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Moreover, the gear teeth should not interfere with the uniform rotation that 
one gear would induce in the other—a requirement known as the conjugate 
action. The conjugate action also ensures that the perpendicular line to a 
tooth profile at its point of contact with a tooth from the other gear always 
passes through a fixed point on the centerline connecting the centers of the 
two meshing gears. Figure 4.4A shows the conjugate line. The conjugate 
line is also known as the line of force because the driving force from the 
driving gear (driver) is transmitted in the direction of this line to the other 
gear (driven). The angle between the perpendicular radius to the conjugate 
line and the centerline is always constant for two meshing gears. This angle 
is known as the pressure angle and is shown as the angle Ø in Figure 4.4A.

The key to successful functional gears is the conjugate action. While 
various profiles can produce conjugate action, the involute profile is the 
best because it allows for imperfections in gear manufacturing and yet 
maintains the conjugate action. The imperfection may produce a slightly 
different distance between the two shafts of the gears from the designed 
value. Figure 4.4B shows how the shape of the involute profile is generated. 
An involute is defined as the path of the endpoint of a cord when it is 
pulled straight (held taut) and unwrapped from a circular disk, as shown in 
Figure 4.4B. The involute geometry ensures that a constant rotational 
speed of the driving gear produces a constant rotational speed in the driven 
gear. For spur gears, the teeth are cut perpendicular to the plane of the 
gear, where the involute profile resides.

The creation of a gear CAD model requires two basic concepts: knowl-
edge of the gear geometry and the involute equation. The geometry is shown 
in Figure 4.3. The base circle is the circle where the involute profile begins. 
The pitch circle defines the contact (pitch) point between the two gears (see 
Figure 4.4A). The dedendum circle is usually the same as the base circle, 
as can be concluded from Figure 4.4A (dedendum d = rp − rb). The 
addendum circle is the circle that defines the top of the tooth as shown in 
Figure 4.4C (addendum a = ra − rp, where ra is the addendum circle radius). 
Typically, the addendum and the dedendum are equal. In such case, the 
pitch and base circle sizes determine the values for both. The root circle is 

Base Circle

Root Circle

Pitch Circle

Dedendum Circle

+

+

Pinion

Gear

Involute ProfileTooth

Addendum Circle

Figure 4.3
Meshing gears
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smaller than the base circle to allow cutting the tooth during manufactur-
ing. The tooth profile between the base and root circles is not an involute. It 
could be any geometry, such as line.

The creation of a gear CAD model requires two steps: Calculate the 
tooth angle α and the tooth involute profile. While many books on mechani-
cal engineering design offer extensive in-depth coverage of gear analysis, we 
offer a simplified but accurate version that enables us to create a CAD 
model of the gear. We begin with the definition of circular pitch. As shown 
in Figure 4.4C, the circular pitch, pc, is defined as the distance along the 
pitch circle between corresponding points on adjacent teeth. As shown in 
Figure 4.4C, we use pc as the circular pitch of the gear, rp as the pitch circle 
radius, and α as the tooth angle. Using these variables, we can write:

	
π

=p
dp
Nc 	 (4.1)

where dp = 2rp is the pitch circle diameter and N is the number of gear teeth. 
From the tooth geometry shown in Figure 4.4C, we can write:

	
2

α=p
rc
p 	 (4.2)

Substituting pc from Eq. (4.2) into Eq. (4.1) and reducing gives:

	
N N

180
radius or degreesα π α= = 	 (4.3)

Base Circle

Point of Contact
of Gear Teeth

Line of Force
(conjugate line)

Pressure Angle

Pitch Circle

rb

rp

+

+

(A) Conjugate action

+

rb

rp

Circular Pitch pc

pc
 2

�

2�

Addendum
Circle

Pitch Circle

Base Circle

(C) Tooth angle

Cord

Base Circle

Involute

+

(B) Involute profile

Pb

Y

�

X

rb

a

d

Pa

P (x, y)

(D) Involute coordinate system

Figure 4.4
Details of a gear tooth
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The derivation of the involute equation is more complex and is not cov-
ered here. We align the involute of one tooth with the XY coordinate system 
as shown in Figure 4.4D, where the lowest point Pb on the involute lies on 
the Y axis. This orientation does not represent a limitation but rather sim-
plifies the form of the involute equation, which is therefore given by:

	
x r

y r
b

b

(sin cos )
(cos sin )

maxθ θ θ θ θ θ
θ θ θ

= − − ≤ ≤
= +

	 (4.4)

where rb (the base circle radius) is given by (see Figure 4.4A):

	 r rb p cosφ= 	 (4.5)

and (x, y) are the coordinates of any point P on the involute at an angle θ, 
as shown in Figure 4.4D. The lowest point Pb on the involute corresponds 
to the value of θ = 0 and lies on the base circle. Point Pa lies on the adden-
dum circle and does not necessarily correspond to the value of θ = θ max. We 
can arbitrarily select a large enough value for θ max so that the involute 
crosses the addendum circle and then trim it to that circle. Therefore, we 
create the involute profile by generating points on it using Eq. (4.4) and 
connecting them with a spline curve, or we input Eq. (4.4) into a CAD/CAM 
system.

The root circle is always less than the base circle. For simplicity, we 
have the root circle radius, rr, be 0.98 of the base circle radius. (There are 
other formulas that do not give consistent results.) Thus, we write:

	 r rr b0 98.= 	 (4.6)

The following steps summarize the calculations we need to create a 
gear CAD model:

1	 The input parameters we need are the pitch circle radius rp, the 
pressure angle ∅, and the gear number of teeth N.

2	 Calculate rb using Eq. (4.5).

3	 Calculate rr using Eq. (4.6).

4	 Calculate the gear dedendum d = rp − rb.

5	 Assuming that the addendum and dedendum are equal, calculate the 
addendum circle radius as ra = rp + a = rp + d (see Figures 4.4C and 4.4D).

6	 Use Eq. (4.3) to calculate the tooth angle α.

7	 Enter the involute parametric equation given by Eq. (4.4) into a  
CAD/CAM system to sketch the involute curve as a spline.

8	 Create one gear tooth and use a sketch circular pattern to pattern it to 
create all gear teeth.
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Example 4.2  Create the CAD model of a spur gear with rp = 60 mm, ∅ = 20°, and N = 20.

Solution  Using the above calculation steps, you get rb = 56.382 mm, d = a = 3.618 mm, ra = 63.618 mm, rr = 55.254 mm, and  
α = 9°. There are two methods to create the tooth involute curve. 

In the first method, you use Eq. (4.4) with Δθ = 5°. You generate 11 points on the involute, for θ max = 50°. You generate the points on 
the involute curve. You then use Insert > Curve > Curve Through XYZ Points. A better method is to input Eq. (4.4) into 
SolidWorks and let SolidWorks generate the curve. You need to use radians for the angle θ. You use 1 radian for θ max. This value is 
arbitrary to ensure that the involute curve intersects and crosses the addendum circle to be able to trim it to the intersection point. 
Also, SolidWorks uses the parameter t, requiring us to replace θ with t when you input the equation. Figure 4.5 shows the spur gear. 
You create half a tooth, mirror it to create a full tooth, and use a circular pattern for the full tooth to create all teeth of the gear. Here 
are the detailed steps.

Figure 4.5
Spur gear

Step 1:	 Create Sketch1 circles and axes: File > New > Part > OK > 
Front Plane > Circle on Sketch tab > sketch four circles and 
dimension as shown > Centerline on Sketch tab > sketch vertical 
line > File > Save As > example4.2 > Save.

Note: Set the part units to mm before you start. The vertical centerline 
serves as a validation that the involute bottom endpoint passes through 
it when you create it in Step 2. Also, you will not close the sketch until 
you finish Step 5.

Step 2:	 Create Sketch1 tooth involute: Front Plane > Sketch tab  
> Spline dropdown on Sketch tab > Equation Driven Curve  
> Parametric > enter x and y equations and limits as shown > ✓.
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Step 3:	 Create Sketch1 tooth 
bottom: Line on Sketch tab  
> sketch a line passing through 
bottom end of involute curve 
and crossing the root circle  
> Esc on keyboard > select the 
line + Ctrl on keyboard + 
involute curve > Tangent from 
Add Relations options on left 
pane > ✓ > Point on Sketch 
tab > create a point at 
intersection of involute and pitch circle (turn relations on: View > 
Sketch Relations to see all) > Centerline on Sketch tab > sketch 
a line passing through origin and crossing involute at any point > Esc 
key > select centerline just created + Ctrl + point > Coincident from 
Add Relations options on left pane > ✓ > Trim Entities on Sketch 
tab > Trim to closest > select line below root circle and select root 
circle between two centerlines > ✓ > Fillet on Sketch tab > enter 1 
mm for radius > select line and root circle > Yes to continue > ✓ > 
select base circle > Delete key on keyboard.

Small line
segment

Step 4:	 Create Sketch1 tooth 
other half: Trim Entities on 
Sketch tab > Trim to 
closest > select involute top 
part > Centerline on Sketch 
tab > sketch a line passing 
through origin and to left of 
involute > Smart Dimension 
on Sketch tab > select the 
centerline just created and the 
other centerline to the right of it > enter 4.5 > ✓  
> Mirror Entities on Sketch tab > select involute + Ctrl key + line 
segment connected to involute + fillet created in Step 3 > click Mirror 
about box on left of screen > select the far left centerline > ✓ > Trim 
Entities on Sketch tab > Trim to closest > click addendum circle 
outside tooth > click root circle inside tooth twice to delete its two 
segments inside the tooth > ✓.

Step 5:	 Create Sketch1 
all gear teeth: Linear 
Sketch Pattern 
dropdown on Sketch tab 
> Circular Sketch 
Pattern > click first box 
under Parameters on left 
pane > select origin to 
define axis of pattern > 
click Entities to Pattern 
box > select the tooth 
profile 7 entities  
> enter 20 for the number of instances to create > ✓ > the sketch 
becomes over defined when you pattern the tooth because of the profile 
mirror of first tooth. Click this sequence to resolve it: Over Defined 
(shown red in status bar) > Diagnose > Accept > Trim Entities  
> Trim to closest > trim all excess from root circle (segments inside 
teeth) > ✓ > exit sketch.

Step 6:	 Create Gear feature: Select Sketch1 > Features tab > 
Extruded Boss/Base > Enter 25 for D1  
> reverse extrusion direction > ✓.

Step 8:	 Create Sketch3 and Cut-Extrude2-Chamfer: Repeat Step 7 but 
use the back face of Gear.

Step 7:	 Create Sketch2 and Cut-
Extrude1-Chamfer: Select Gear front 
face > Features tab > Extruded 
Cut > Circle on Sketch tab > click 
origin and draw circle > select root 
circle and sketched circle and add 
Coradial relationship > exit sketch  
> enter 10 for D1 > check Flip side 
cut > click Draft icon > enter 60 for 
Draft Angle > ✓.

9780136887263_print.indb   108 10/03/21   6:43 PM



Ch
ap

te
r 
4

	 Chapter 4  |  Features and Macros� 109

HANDS-ON FOR EXAMPLE 4.2
Add a hole and a keyway to the gear blank. Use a diameter of 50 mm for the hole and 
10 × 10 mm keyway.

4.4 Design Library and Library Features
Design reuse and using off-the-shelf standard components are important 
concepts that speed up design and thus make it less expensive. The field of 
mechanical design has many standard parts that designers use every day 
in their designs (e.g., fasteners [nuts and bolts], gears, bearings). While 
these parts are universally standard, a company may have some parts that 
are unique and reusable only in that company’s designs. SolidWorks pro-
vides the concepts of design library and library features to enable designers 
to reuse off-the-shelf components.

A library feature is a part that you create once and save in a library 
for reuse in the future. This library is known as the design library. You 
may save a library feature with the .sldprt or .sldlfp extension. Most of the 
time library features are inserted into assemblies as components or 
inserted into new empty (blank) parts. Commonly used library features 
include holes and slots. Using several library features to construct a single 
part saves time and also ensures consistency in your CAD models.

Using library features is easy: You drag a library feature from the 
design library and drop it onto the open part or assembly. SolidWorks 
asks you if you want to insert a copy or instance (derived part) of the 
part, as shown in Figure 4.6. If you select Yes, it inserts the copy in 
the open part. If you select No, it opens a blank part and inserts it 
there.

You save library features in a design library, which you can organ-
ize into folders. The path to the SolidWorks design library folder is  

C:\Program Data\SolidWorks\SolidWorks version\design library. (Make 
sure that hidden files are visible in Windows to see the Program Data 
folder.) Click the Design Library tab in the SolidWorks Task Pane (on the 
right of the screen), as shown in Figure 4.7A, to open the design library. 

Figure 4.6
Using a library feature

(A) Open Design Library

Investigate these
icons to learn
more about the
Design Library

Expand this node
to learn more
about the Toolbox

(B) Design Library folders

Figure 4.7
SolidWorks Design Library
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The library is organized into folders, and you can add new custom folders to 
the library. You should save your library features into the SolidWorks 
design library to have them accessible. If you do not, you have to navigate 
to the folder where you saved the features. The most commonly used 
SolidWorks library is Toolbox, shown in Figure 4.7B. Expand the Toolbox 
node and investigate its contents.

4.5 Configurations and Design Tables
A family of parts is a natural outcome from the concept of parametric solid 
modeling. Defining a solid (part) in a sketch by parameters (dimensions are 
values for the parameters) enables us to modify the dimensions and create 
a similar but different-size replica of the part with a click of a button. We 
refer to these replicas as a family of parts. SolidWorks calls them configura-
tions. You can also create configurations of assemblies. The configurations 
are created by changing the dimensions of some key parameters of the part 
or assembly. The configurations have the same topology as the original but 
different geometry. For example, consider a two-feature part: a base block 
and a shaft boss. You configure the part into a square block and a skinny 
long boss or a rectangle block and short fat boss.

You use design tables to help create and control configurations in three 
ways: change sizes, change configurations of components, and/or sup-
press/unsuppress features. SolidWorks uses a Microsoft Excel sheet as 
its design table. You can insert a design table into an open part or 
assembly by clicking this sequence: Insert (menu) > Tables > Design 
Table. This opens the Design Table under the PropertyManager tab on 
the left pane, as shown in Figure 4.8. You can specify one of the three 
sources shown to create the design table. When you click the green 
checkmark to finish, SolidWorks acts accordingly. For example, if you 
select the Auto-create (default) option, SolidWorks displays a list of the 
open part dimensions and asks you to select some to include in the 
design table. The table is created with the current values of the part 
dimensions as the default configuration. The configuration appears as a 
row in the table. You can add other rows with different values for dimen-
sions. Each row is a different configuration. The Design Table is saved 
under the ConfigurationManager tab.

Figure 4.8
Design table

Example 4.3  Create design tables.

Solution  This example builds on Example 2.4. It shows how to create a design table where you change the value of parameter 
(dimension name) D2 to create four configurations of the sketch. The steps are as follows.
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Step 1:	 Open example2.4 part: File > Open > locate and select the 
file > Open.

Step 2:	 Create design table with Default config: Insert > Tables > 
Design Table > ✓ > click D1 (shown here) + Shift key on keyboard + 
D5 (shown here) to select all dimensions > OK.

Step 3:	 Create three other configurations: Step 2 opens the Excel 
sheet shown > copy the Default config row and paste three times > edit 
the name cell and change configuration names as shown > edit the D2 
column and change as shown > click anywhere on screen away from 
Excel sheet to make it disappear > OK to accept the popup window 
indicating that new configurations were created.

Step 4:	 Review the design configurations: Step 3 creates a tree with 
four nodes, as shown, under the ConfigurationManager tab > 
double-click any configuration to display the corresponding sketch > the 
current configuration is displayed in dark black in the tree.

Step 5:	 Investigate effect of design table on sketch parameters: 
Click feature tree > select Sketch1 > observe that dimensions are 
displayed in a pink color and each time you click or move one, you get 
a window (shown to the right) warning you.

HANDS-ON FOR EXAMPLE 4.3
Edit the sketch and change the value of D2 to 6. What happens to the design table? 
Explain the result.

4.6 Macros
Design automation offers two benefits. First, it enhances productivity. 
Second, it helps with repetitive tasks that are mundane. For example, if you 
follow the same design process over and over, automating it would be the 
logical thing to do.

Macros aid in design automation. Macros are also viewed as a way to 
customize your CAD/CAM system. A macro is a short computer program 
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Example 4.4  Develop a macro to create an extrusion.

Solution  This example illustrates the creation and use of macros. It shows how to create a block extrusion and record the steps of 
creating it in a macro.

that is used to repeat commonly performed operations. That computer pro-
gram is generated automatically by a CAD/CAM system in the background 
during use of the system, from the time you turn on the macro until you 
turn it off. You can use the macro after creation over and over, with differ-
ent input values (e.g., new dimensions). After you create a macro, you can 
use it for recording, edit it, run it, pause it, stop it, and assign it to a short-
cut key (hotkey) or to a menu item. When you assign a macro to a shortcut 
key or to a menu item, you can specify which method (function) of the 
macro to run. Click Tools > Macro to access the macro menu. SolidWorks 
saves the macro file in the same part folder and uses .swp as the file exten-
sion, with the default names Macro1.swp, Macro2.swp, and so on, unless 
you change them.

A higher level of automation than using macros is to use Visual Basic 
(VB) or another programming language to perform full automation and have 
better control of the automation. As a matter of fact, VB is the program-
ming engine behind macros. Instead of writing the macro VB code, the 
SolidWorks macro interface enables us to generate the code automatically 
while you perform the design tasks as usual. It is this VB code that you 
save in a file when you save the macro. You can use the VB editor to edit 
and tweak the VB code.

Macro VB code uses the SolidWorks API (application programming 
interface). The code makes calls to API functions. Think of the API as a 
gateway between the application you want to write and SolidWorks code 
that has been already written. In other words, the API provides access to 
the SolidWorks geometric engine.

You can learn VB programming by creating multiple macros, studying 
their generated VB code, and expanding on it. VB is an object-oriented pro-
gramming (OOP) language that requires knowledge and understanding of 
object-oriented design and how objects are defined and implemented.

The programming approach could be useful for creating an entire 
assembly from a few parameters. You can write a program to define some 
variables and store them in a row in a design table. Each row represents a 
new version of the assembly. You delete all rows from the table and keep 
the last row, which is the new assembly.

Step 1:	 Turn on macro and create Sketch1 and Boss-Extrude1 feature: 
File > New > Part > OK > Tools > Macro > Record > Front 
Plane > Extruded Boss/Base on Features tab > Sketch tab > 
Center Rectangle on Sketch tab > sketch a rectangle and 
dimension as shown > exit sketch > enter 2 for D1 > reverse extrusion 
direction > ✓ > File > Save As > example4.4 > Save.

Note: Macro > Record opens the Macro recording window shown. 
Hover over its buttons to read them.
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Step 2:	 Stop and save macro: Tools > Macro > Stop (or click black 
square on Macro window shown in Step 1) > type BlockShaft for macro 
name in the Save As window that opens > Save.

Note: The full macro file name is BlockShaft.swp. The default folder for 
the file is the part file folder from Step 1.

Step 3:	 View the macro VB code: Tools > Macro > Edit > select 
BlockShaft.swp > Open. The editor displays all the lines of code 
associated with the macro. Figure 4.9 shows the first lines of the macro 
VB code. Explore the code and try to understand which sections pertain 
to which steps performed in SolidWorks.

Step 4:	 Run the macro: Open a new part or delete the feature from the current part > Tools > Macro > Run > select BlockShaft.swp >  
Open > enter 8 for rectangle width when dimension box appears > ✓ > enter 6 for rectangle height when dimension box appears > ✓.

HANDS-ON FOR EXAMPLE 4.4
Modify the part as shown to the right and re-create the 
macro. Rerun the macro twice to investigate locating the 
shaft to the left or to the right side from the center. This 
simulates the idea of using a macro to investigate “what 
if” design scenarios such as sizes or feature locations.

Figure 4.9
VB editor window
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4.7 Tutorials

Tutorial 4–1  Create Sweep Features
A sweep feature requires, at minimum, a profile (cross section) to sweep 
and a path (curve) to sweep along. You can use a guide curve to control the 
sweep further. If you do not use a guide curve, the sweep cross section 
stays constant.

Sweep operations may fail for different reasons. Figure 4.10 shows 
three error messages. As a general rule, the sweep path and guide must 
intersect the cross-section plane, and the cross section must not intersect 
itself as it traverses the path and/or the guide curve.

Example 4.5  Create a hotkey for a macro.

Solution  This example assigns the macro from Example 4.4 to the Shift+X hotkey on the keyboard. When the user presses this 
combination on the keyboard, the macro runs.

Step 1:	 Create macro hotkey: File > Open > locate example4.4 > 
Open.

Step 2:	 Locate macro file: Tools > Customize > Keyboard tab > 
scroll to bottom and locate Macros row > click ellipsis button (…) in 
this row to open window shown > click the browse button (…) > locate 
macro file (.swp extension) > Open > OK.Step 3:	 Create hotkey: Click Shortcut(s) column in Macros row as 

shown > Shift+X to add shortcut as shown below > OK.

Step 4:	 Use hotkey to run macro: Press 
Shift+X in an open part.
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(A) Path does not intersect cross-section 
plane

(B) Guide curve does not intersect 
cross-section plane (C) Cross section intersects itself

Figure 4.10
Some possible sweep operation errors

Create the sweep features shown in Figure 4.11. All dimensions are in 
inches.

(A) No guide curve (B) With guide curve

Figure 4.11
Sweep features

No-guide-curve sweep (Figure 4.11A) modeling steps:
Step 1:	 Create Sketch1-Profile: 
File > New > Part > OK > Front 
Plane > Circle on Sketch tab > 
click origin and sketch circle and 
dimension as shown > exit sketch > 
File > Save As > tutorial4.1A > 
Save.

Step 2:	 Create Sketch2-Path: 
Right Plane > Spline on 
Sketch tab > sketch spline as 
shown (press Esc after last point 
is clicked to exit Spline); make 
sure spline snaps to origin > exit 
sketch.

Step 3:	 Create Sweep1 feature: Sweep Boss/Base on Features tab > select circle 
sketch as Profile, as shown to the right > select spline sketch as Path, as shown to the  
right > ✓.
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Step 4:	 Create Sweep feature: Sweep Boss/Base 
on Features tab > select circle sketch as Profile, as 
shown > select Step 2 spline sketch as Path > select 
Step 3 spline sketch as Guide > ✓.

Step 2:	 Create Sketch2-Path: Top Plane > Line on 
Sketch tab > sketch line as shown (to the right) from 
origin > exit sketch.

With-guide-curve sweep (Figure 4.11B) modeling steps:
Step 1:	 Create Sketch1-Profile: 
File > New > Part > OK > Front 
Plane > Circle on Sketch tab > 
click origin and sketch circle as 
shown > exit sketch > File > Save 
As > tutorial4.1B > Save.

Step 3:	 Create Sketch3-Guide: 
Right Plane > Spline on 
Sketch tab > sketch spline as 
shown (press Esc after last point 
is clicked to exit Spline); select 
spline endpoint near circle sketch > Ctrl + select circle sketch > Make 
Pierce > exit sketch.

HANDS-ON FOR TUTORIAL 4–1
Change the cross sections of both sweeps to a 2 × 2-inch square. What happens? Resolve 
the error(s) and explain your solution.

Tutorial 4–2  Create Loft Features
Create the wine glass shown in Figure 4.12. All dimensions are in inches. 
We introduce the concept of Convert Entities on the Sketch tab in this 
tutorial. You copy one circle in one sketch to another sketch. This concept 
enables you to copy entities from one sketch to another. While you could 
easily create a new circle and dimension it, using the Convert Entities 
method is faster (as there is no need to sketch a circle and dimension it). 
SolidWorks creates an On Edge relation between the two circles and shows 
a small green cube on the copied entity to indicate the relation. When you 
click the copied circle while editing the sketch, SolidWorks displays the On 
Edge relation in the relations pane to the left of the screen.

Figure 4.12
Loft feature
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Step 1:	 Create Plane1–Plane3: File > New > Part > OK > 
Reference Geometry on Features tab > Plane > expand feature 
tree and select Top Plane > enter 1.0 for Offset Distance > ✓ > 
repeat for Plane2 and Plane3 but select the previously created plane > 
File > Save As > tutorial4.2 > Save.

Step 2:	 Create Sketch1–
Sketch4: Top Plane > Circle 
on Sketch tab > click origin 
and drag to sketch and 
dimension a 2.0-inch diameter 
circle > exit sketch > select 
Plane1 as sketch plane and 
create a 0.5-inch diameter 
circle > exit sketch > select 
Plane2 as sketch plane > 
Sketch on Sketch tab > 
Convert Entities on 
Sketch tab > click circle on 
Plane1 > ✓ > ✓ > exit sketch 
> select Plane3 as sketch 
plane > Sketch on Sketch tab > Convert Entities on Sketch tab 
> click circle on Top Plane > ✓ > ✓> exit sketch.

Step 3:	 Create Loft-
Base feature: Lofted 
Boss/Base on 
Features tab > select 
Sketch1–Sketch4 > ✓.

Step 4:	 Create Plane4–Plane6: 
Reference Geometry on 
Features tab > Plane > expand 
feature tree and select Plane3 > 
enter 1.0 for distance > ✓ > repeat 
for Plane5 and Plane6 but select the 
previously created plane.

Step 5:	 Create 
Sketch5–Sketch7: Select 
Plane4 as Sketch 
Plane > Circle on 
Sketch tab > click 
origin and drag to 
sketch and dimension a 
3.0-inch diameter circle 
> exit sketch > select 
Plane5 as Sketch 
Plane > Sketch on 
Sketch tab > 
Convert Entities on 
Sketch tab > click 
Sketch5 (just created)  
> ✓ > ✓> exit sketch > 
select Plane6 as sketch 
plane > Sketch on 
Sketch tab > 
Convert Entities on Sketch tab > click circle on Plane3 > ✓ > ✓>  
exit sketch.

Step 6:	 Create 
Loft-Thin1-Top 
feature: Lofted 
Boss/Base on 
Features tab > 
select the circle of 
Sketch4 and then 
select Sketch5–
Sketch7 > check 
Thin Feature box 
> enter 0.1 for 
thickness (T1) > if 
needed, click direction box to toggle direction of thickness to the  
inside > ✓.

Note: Make sure you select the circle and sketches in a way so that the 
interpolation points (green circles shown here) line up; otherwise, you 
twist the loft.

Note: The thickness of the thin feature has a direction: inside or outside 
the profile. Reverse the direction of the double arrows shown to toggle.
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HANDS-ON FOR TUTORIAL 4–2
Create a loft using three squares of different sizes as cross sections separated 
by 1 inch. The square sizes are 2 × 2, 1 × 1, and 2 × 2, respectively. Create the 
loft connecting the three sections such that the loft is twisted as shown.

Step 2:	 Create Sketch2: Top face of Block > Center Rectangle on 
Sketch tab > click origin and sketch a 3.0 × 1.5 rectangle, as shown in 
Figure 4.13 > click For Construction box > exit sketch.

Step 1:	 Create Sketch1 and 
Block feature: File > New > 
Part > OK > Top Plane > 
Extruded Boss/Base on 
Features tab > Center 
Rectangle on Sketch tab > 
click origin and sketch and dimension rectangle as shown > exit sketch 
> enter 1 for D1 > reverse extrusion direction > File > Save As > 
tutorial4.3 > Save.

Step 3:	 Create two 
diagonal countersink 
hole features (CSK… 
node in feature tree): 
Hole Wizard on 
Features tab > 
select Countersink 
under Hole Type 
(hover over types 
until you read it) > 
select #8 for Size under Hole Specifications > Positions tab > 
click top face of Block and then click two corners of construction 
rectangles as shown > ✓.

Tutorial 4–3  Use the Hole Wizard
The hole wizard provides two advantages. First, it helps create standard 
hole sizes and types so that off-the-shelf bolts will fit perfectly in the holes. 
Second, it greatly speeds up the process of creating these holes. This tuto-
rial shows how to create sample holes: counterbore, countersink, and 
tapped holes. Figure 4.13 shows these holes. You create an extrusion and 
add holes to it. You also create Sketch2 on the top face of the Block feature 
with a center rectangle (construction rectangle) that you use to place holes 
at its corners.

Figure 4.13
Wizard holes
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Step 4:	 Create two diagonal counterbore hole features (CBORE… 
node in feature tree): Hole Wizard on Features tab > select 
Counterbore under Hole Type (hover over types until you read it) > 
select #10 for Size under Hole Specifications > Positions tab > 
click top face of Block and then click two other corners of construction 
rectangles as shown > ✓.

Step 5:	 Create Tapped Hole1 feature: Hole Wizard on Features 
tab > select Tapered Tap (hover over types until you read it) > select 
1/4 for Size under Hole Specifications > Positions tab > click top 
face of Block and then click rectangle center as shown > ✓.

Step 1:	 Create Sketch1 and Helix/Spiral1 curve: File > New > Part > OK > Top 
Plane > Circle on Sketch tab > click origin and sketch and dimension circle with  
1.0-inch diameter > exit sketch > Insert (menu) > Curve > Helix/Spiral > select the 
circle just sketched > Height and Revolution from Defined By dropdown shown > 
Constant Pitch > enter 2.0 for Height, 20 for Revolutions, and 90 for Start 
Angle, as shown > ✓ > File > Save As > tutorial4.4 > Save.

HANDS-ON FOR TUTORIAL 4–3
Create a 1/16 tapered pipe tap through all holes, located 0.5 from the top edge and 1.5 
from the left edge of the block.

Tutorial 4–4  Create Compression Spring
Figure 4.14 shows the constant length compression spring you create in 
this tutorial.

Figure 4.14
Compression spring
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HANDS-ON FOR TUTORIAL 4–4
Edit the spring helix to have a variable pitch. Use a pitch of 0.2 at midheight point.

Tutorial 4–5  Create Spiral
Figure 4.15 shows the spiral spring you create in this tutorial.

Step 2:	 Create Sketch2: Front Plane > Circle on Sketch tab > 
sketch and dimension circle as shown (align center with X-axis as 
shown) > exit sketch.

Step 3:	 Create 
Sweep1 feature 
(spring): Swept 
Boss/Base on 
Features tab > 
select Sketch2 as 
Profile > select 
Helix/Spiral1 as 
Path > ✓.

Step 1:	 Create Sketch1 and Helix/Spiral curve: File > New > Part > OK > 
Top Plane > Circle on Sketch tab > click origin and sketch and dimension 
circle with 1.0-inch diameter > exit sketch > Insert (menu) > Curve > Helix/
Spiral > select the circle just created > Spiral from Defined By dropdown 
shown > enter 0.5 for Pitch and 5 for Revolutions, as shown > Start Angle 
of 90 and select Counterclockwise > ✓ > File > Save As > tutorial4.5 > 
Save.

Figure 4.15
Spiral spring
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Step 2:	 Create Sketch2: Front Plane > Center Rectangle on 
Sketch tab > sketch and dimension rectangle as shown (align center 
with X-axis as shown) > exit sketch.

Step 3:	 Create Sweep feature (spiral): Swept Boss/Base on 
Features tab > select Sketch2 as Profile > select Helix/Spiral as Path 
> select Show Preview under Options > ✓.

HANDS-ON FOR TUTORIAL 4–5
Change the spiral cross section to a circle with 2.0-inch diameter. Can you generate the 
spiral? Why or why not? Explain.

Tutorial 4–6  Create Features
This tutorial covers the creation of these features: chamfer, fillet, slot, shell, 
draft, and rib. All dimensions are in inches. Consider these useful 
observations:

1	 Make sure to pay attention to the visual clues shown in the left pane 
while creating these features.

2	 For example, the box symbol under Chamfer parameters indicates 
that you can chamfer a face, an edge, or a vertex (corner point). As you 
would expect, chamfering a face chamfers all its edges. Chamfering a 
corner chamfers the three edges that meet there.

3	 A rib requires a profile sketch (e.g., a line or stepwise line) and a 
thickness.

Step 1:	 Create Sketch1 and 
Block feature: File > New > 
Part > OK > Top Plane > 
Extruded Boss/Base on 
Features tab > Center 
Rectangle on Sketch tab > 
click origin and sketch and dimension as shown > exit sketch > reverse 
extrusion direction > enter 0.5 for D1 > ✓ > File > Save As > 
tutorial4.6 > Save.

Step 2:	 Chamfer an edge of 
Block feature: Fillet dropdown 
on Features tab > Chamfer > 
select Angle Distance chamfer 
> select Block edge shown > use 
0.1 for Distance and 45 degrees 
for Angle > ✓.

Step 4:	 Create a straight slot in 
Block feature: Select Block top 
face as a sketch plane > 
Extruded Cut on Features 
tab > Straight Slot on Sketch 
tab > sketch and dimension slot 
as shown > make origin and slot 
midpoint Coincident > exit 
sketch > Through All > ✓.

Step 3:	 Fillet an edge of Block 
feature: Fillet on Features tab 
> select Constant Size Fillet 
> select Block edge shown > use 
0.1 for Radius > ✓.
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HANDS-ON FOR TUTORIAL 4–6
Create the following features:

•	 Distance-distance chamfer
•	 Vertex chamfer
•	 Variable-size fillet
•	 Face fillet
•	 Full round fillet
•	 3-point arc slot
•	 Three-stepped rib using three-stepped line as the rib profile

Tutorial 4–7  Use the Smart Fasteners Wizard
You use the Smart Fasteners wizard to insert the correct fastener based on 
the hole you select. It is a form of automation using off-the-shelf compo-
nents. SolidWorks has its own standard library of fasteners. You can only 
use the wizard at the assembly level. You need to activate the wizard in 
order for the Smart Fasteners icon on the Assembly tab to work. If you 
click the icon before activation, you get this error: Smart Fasteners 
requires SolidWorks Toolbox, which is not present.

In this tutorial, you create an assembly of a block and plate. You create 
a counterbore hole in the plate and a blind hole in the block, assemble 
them, and fasten them together with a smart fastener. Figure 4.16 shows 
the assembly and its tree. All dimensions are in inches.

Step 5:	 Shell Block feature: 
Shell on Features tab > select 
top face of Block > enter 0.1 for 
D1 > ✓.

Step 6:	 Draft Block feature: 
Suppress the chamfer, fillet, and 
shell features > Draft on 
Features tab > enter 10 degrees 
for Draft Angle > select top 
face of Block as Neutral Plane 
> select Block four side faces to 
draft > ✓.

Step 7:	 Create a rib feature: Suppress the slot and draft features > select front face of Block > Extruded Boss/Base on Features tab > 
Rectangle on Sketch tab > sketch and dimension rectangle as shown below > exit sketch > reverse extrusion direction > enter 3.0 for D1 > ✓  
> Front Plane > Rib on Features tab > Line on Sketch tab > sketch a line using the midpoints of the two edges as shown below > exit sketch 
> enter 0.5 for rib thickness (T1) > select Second Side for Thickness > Parallel to Sketch for Extrusion Direction > ✓.
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HANDS-ON FOR TUTORIAL 4–7
Modify Block and Plate parts to create four corner countersink holes. Re-create the 
assembly and use four smart fasteners.

Tutorial 4–8  Create a Bolt
Bolts, like gears, are important and essential mechanical elements. While 
bolts are standard off-the-shelf components, this tutorial shows how to cre-
ate the CAD model of one due to its learning value. Figure 4.17 shows the 
bolt and its feature tree. All dimensions are in inches.

Step 1:	 Create Plate feature: File > New > Part > OK > Front 
Plane > Extruded Boss/Base on Features tab > Center 
Rectangle on Sketch tab > click origin and sketch and dimension 
rectangle as shown > exit sketch > enter 1 for D1 > reverse  
extrusion direction > ✓ > Hole Wizard on Features tab > select 
Counterbore under Hole Type (hover over each hole type until  
you read the correct type) > ANSI inch for Standard > binding head 
screw for Type > select #5 for Size under Hole Specifications > 
Positions tab > click front face of Plate and then click origin > ✓ > 
File > Save As > Plate > Save.

Note: The diameter of the counterbore hole shown below corresponds 
to #5 size. You need it to create the corresponding hole in the block in 
Step 2.

Step 2:	 Create Block feature: File > New > Part > OK > Front 
Plane > Extruded Boss/Base on Features tab > Center 
Rectangle on Sketch tab > click origin and sketch and dimension 
rectangle as shown > exit sketch > enter 2 for D1 > reverse extrusion 
direction > ✓ > front face of Block > Extruded Cut on Features tab > 
Circle on Sketch tab > click origin and sketch and dimension as shown 
> exit sketch > enter 1 for D1 > ✓ > File > Save As > Block > Save.

Step 3:	 Create assembly: File > New > Assembly > OK > 
Browse > locate Block and Plate parts > select Block + Ctrl + Plate 
> Open > click ✓ to place Block instance in assembly origin > click 
anywhere in graphics pane to place Plate instance > Mate on 
Assembly tab > Coincident > select the corresponding top edges of 
Block and Plate > ✓ > select the corresponding right edges of Block and 
Plate > ✓ > ✓.

Step 4:	 Activate Smart Fasteners wizard: Tools > Add-Ins > 
SolidWorks Toolbox Library > OK. This adds the Toolbox menu 
to the menu bar to the right of the Tools menu. You may deactivate the 
Toolbox by using the same sequence but unchecking the Toolbox 
Browser from the Add-Ins window.

Figure 4.16
Assembly using smart fastener

Step 5:	 Add a 
fastener: Smart 
Fasteners on 
Assembly tab 
> OK (to accept 
that it may take 
extra time) > 
expand feature 
tree > expand 
Plate instance 
tree node > select CBORE for #5 node > Add > ✓ > File > Save As > 
Tutorial4.7 > Save.
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Figure 4.17
A bolt

Step 1:	 Create Sketch1 and Shaft 
feature: File > New > Part > OK > 
Top Plane > Extruded Boss/Base 
on Features tab > Circle on Sketch 
tab > click origin and sketch and 
dimension as shown > exit sketch > 
enter 4 for D1 > reverse extrusion 
direction > ✓ > File > Save As > 
Bolt > Save.

Step 2:	 Create Sketch2 and Head 
feature: Select top face of Shaft feature 
> Extruded Boss/Base on 
Features tab > Polygon (hexagon 
icon) on Sketch tab > click origin and 
sketch and dimension as shown > 
apply vertical relation to one edge > 
exit sketch > enter 0.9 for D1 > ✓.

Step 3:	 Create Sketch3 
and Head-TopTaper 
feature: Select top face 
of Head feature > 
Extruded Cut > 
Circle on Sketch tab > 
click origin and sketch 
(make circle tangent to 
hexagon sides) > exit 
sketch > enter 0.5 for 
D1 > click checkbox as 
shown > enter 60 for draft angle > ✓ > repeat to create Head-
BottomTaper to chamfer the bottom of the head.

Step 4:	 Create 
BottomChamfer 
feature: Fillet 
dropdown on 
Features tab > 
Chamfer > select 
bottom edge of Shaft 
feature > enter 0.1 
for D > enter 45 for 
A > ✓.

Step 5:	 Create 
Plane1: Reference 
Geometry on 
Features tab > 
Plane > expand 
feature tree > select 
Top Plane > enter 
3.9 for D1 > click 
Flip offset 
checkbox > ✓.

Note: You use a distance of 3.9 for Plane1, not 4.0, because the chamfer 
is 0.1 high.
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Step 11:	 Create Cut-Sweep2-EndThread feature: Swept Cut on 
Features tab > select Sketch6 as Profile > select Helix/Spiral2 as 
Path > ✓.

Step 6:	 Create 
Sketch5 and Helix/
Spiral1: Select Plane1 
> select Sketch on 
Sketch tab > 
Convert Entities 
on Sketch tab > 
expand feature tree > 
select Sketch1 > ✓ > 
exit Sketch > select 
Sketch5 > Insert > Curve > Helix/Spiral > select Height and 
Pitch > enter 3.5 for Height, 0.25 for Pitch, and 225 for Start  
angle > ✓.

Note: The helix 3.5 height is arbitrary. That leaves 0.4 (out of 3.9). You 
use 0.25 for the other end thread helix and 0.15 underneath the bottom 
of bolt head as a length with no threads.

Step 7:	 Create 
Plane2: Reference 
Geometry on 
Features tab > 
Plane > expand 
feature tree >  
select Right Plane 
> select Parallel > 
click Second 
Reference box > 
select top endpoint of  
Helix/Spiral1 > ✓.

Step 8:	 Create 
Sketch6 and Cut-
Sweep1-Thread feature: 
Select Plane2 > select 
Sketch Swept Cut 
on Features tab > 
Polygon (hexagon 
icon) on Sketch tab > 
3 for Number of 
Sides > click near end 
of helix and sketch and 
dimension as shown 
with right side vertical 
and Helix/Spiral1 endpoint and right triangle edge midpoint coincident > 
exit sketch > Swept Cut on Features tab > select Sketch6 as Profile 
> select Helix/Spiral1 as Path > ✓.

Step 9:	 Create 
Plane3: Reference 
Geometry on 
Features tab > 
Plane > expand 
feature tree > select 
Top Plane > select 
Parallel > click 
Second Reference 
box > select top endpoint of Helix/Spiral1 > ✓.

Step 10:	 Create 
Sketch7 and Helix/
Spiral2: Select Plane3 
> select Sketch on 
Sketch tab 
Convert Entities 
on Sketch tab > 
expand feature tree > 
select Sketch1 > ✓ > 
exit sketch > select 
Sketch7 > Insert > 
Curve > Helix/Spiral > select Height and Pitch > enter 0.25  
for Height > click Taper Helix checkbox > enter 30 for taper angle 
(A) > click Taper outward checkbox > ✓.
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Problems

1 What is a feature? Give two examples of features.

2 Why can an extruded cut or a revolved cut not be a base feature?

3 What is the required input needed to create a sweep? What is the 
optional input?

4 What is the required input needed to create a loft? What is the optional 
input?

5 Table 4.1 shows a rib feature. Which is the better way to create it: by 
using a rib or by using an extrusion? Explain your answer.

6 Table 4.1 shows a block that is shelled. Which is the better way to  create 
it: by using shelling or by using extrusion cut? Explain your answer.

7 A spur gear has a pitch circle radius of 3 inches, a pressure angle of 
14.5 degrees, and 20 teeth. Calculate all the parameters required to 
create the gear CAD model. Create the CAD model.

8 Same as Problem 7, but for a pitch circle radius of 100 mm, pressure 
angle of 14.5 degrees, and 30 teeth.

9 Create a macro to automate the creation of a donut revolve.

10 Create the brace drill handle shown in Figure 4.18. All dimensions are 
in millimeters.

1 

2 

3 

4 

5 

6 

7 

8 

9 

10 

All vertical dimensions are measured from the 
bottom end of the drill handle. The top curve is a 
spline connecting three points.

Figure 4.18
Brace drill handle

chapterfour4

9780136887263_print.indb   126 10/03/21   6:43 PM



Ch
ap

te
r 
4

Chapter 4 | Features and Macros 127

Drill handle cross section Cross section of middle handle

11 Create the loft feature shown in Figure 4.19. Assume dimensions. 
Hint #1: This loft shows you the local and global influence of the guide 
curve. Hint #2: Use Guide curves influence types under the Guide 
Curves section shown on the left pane of the screen.

11 

Two profiles and guide curve

Local influence of guide curve Global influence of guide curve

Figure 4.19
Influence of guide curve

Figure 4.18
(continued)
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12 Create the CAD model of the helical spring shown in Figure 4.20. All 
dimensions are in centimeters.

Figure 4.20
Helical spring

13 Create the CAD model of the 3D probe shown in Figure 4.21. All 
dimensions are in millimeters.

12 

13 

A-A

The probe uses a 3D
curve to define its
profile. The probe is
hollow. The outer
diameter is 20 mm and
thickness is 2 mm

y z
0 2.4 0

–50 0
–60 150
–65
–65

160
160

x

0
0
15
150

Figure 4.21
3D probe
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Figure 4.21
(continued)

14 Create the CAD model of the football goal post shown in Figure 4.22. 
All dimensions are in inches. Hint: The dimensions of the post are per 
NFL specs: The post is 10 feet (120 in.) high, the crossbar is 18.5 feet 
(222 in.) wide from the inner edges of the uprights, and the uprights 
are 20 feet (240 in.) high. The diameter of the post tubes is arbitrary, 
so use 8 in. here.

14 

Uprights

Crossbar

Post

Post dimensions

Note:
upright diameter = post diameter

Dimensions of crossbar and uprights

Figure 4.22
Football goal post
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15 Create the CAD models shown in Figure 4.23. All dimensions are in 
inches.

15 

16 Create the CAD models shown in Figure 4.24. All dimensions are in 
inches.

16 

(A) Banana (B) Water bottle

Figure 4.23
CAD models

(A) Coffee mug (B) Hand drill

Figure 4.24
CAD models

9780136887263_print.indb   130 10/03/21   6:43 PM



Ch
ap

te
r 
4

Chapter 4 | Features and Macros 131

17 Create the CAD models shown in Figure 4.25. All dimensions are in 
inches.

17 

(A) Goblet (B) Baseball bat

Figure 4.25
CAD models

18 Create the CAD models shown in Figure 4.26.18 

(A) Funnel (dimensions in mm)

(B) Torpedo 
(dimensions in 
inches)

Figure 4.26
CAD models
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19 Create the CAD models shown in Figure 4.27. All dimensions are in 
inches.

19 

20 Create the CAD models shown in Figure 4.28. All dimensions are in 
inches.

20 

(A) Fiber optic wire (B) Desk lamp

Figure 4.27
CAD models

(A) Fruit basket (B) Bowl

Figure 4.28
CAD models
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21 Create the CAD models shown in Figure 4.29.21 

(A) Candle and holder 
(dimensions in inches) (B) Pitcher (dimensions in millimeters)

Figure 4.29
CAD models

22 Create the CAD models shown in Figure 4.30.22 

(A) A flex (B) Steel cone

Figure 4.30
CAD models

9780136887263_print.indb   133 10/03/21   6:43 PM



134 Chapter 4 | Features and Macros

23 Create the CAD models shown in Figure 4.31.23 

(A) Computer mouse (B) Auger drill

Figure 4.31
CAD models
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Index

NUMBERS
2D curves, 222

tutorials
explicit equations, 224
parametric equations, 225
stethoscope model creation, 241–243

3D curves, 223
tutorials

3D points, 227–228
3D sketches, 228–229
composite curves, 229–230
parametric equations, 225–226
projected curves, 232–241
projected sketches on curved faces,  

231–232
stethoscope model creation, 241–243

3D points, 227–228
3D printing, 419. See also rapid 

prototyping (RP)
3D Sketch feature, 303
3D sketches, 228–229
.3dxml file format, 379

A
abbreviation rules (ASME), 137–138
abort symbol, 9
actual size, 340–341
addendum circle (gears), 104
additive manufacturing, 412
additive modeling plan in drain plug 

tutorial, 90
.ai file format, 380
air acidification, 326
aliasing, 195
ambient light, 196
analysis tools. See also tolerance analysis

animation and motion analysis, 385–386
finite element analysis, 389–390
finite element method, 386–389
flow simulation, 386
mass properties calculations, 381–385
purpose of, 377–378
SolidWorks Simulation/SimulationXpress, 

391
tutorials

flow simulation, 406–407
mass properties calculations, 397–398
motion analysis, 398–403
static linear analysis, 403–404
thermal analysis, 405

types of, 377–378
Von Mises stress, 391–396

analytic curves, 217, 218
analytic surfaces, 249
angle dimension tolerances, 346
angle tolerance (STL files), 418
angles of projection, 145–146
angular dimensions, 139
animations

analysis tools for, 385–386
of assembly models, 164–165
tutorials, 210–212
types of, 201–202

annotations, inserting, 153
ANSI (American National Standards 

Institute), 137, 491
ANSI fits, 348–349
ANSI weld symbols, 305–306
anti-aliasing, 195
API (application programming interface), 

112
appearance

of models, 201
tutorials, 205–206

applications of rapid prototyping, 412–413
arithmetic tolerancing, 355
artistic bowl creation tutorial, 265–267
ASME (American Society of Mechanical 

Engineers), 137
abbreviation rules, 137–138
dimensioning rules, 139–144
drafting rules, 138
tolerance rules, 343–346

assemblies. See assembly models
assembly drawings, 164

creating with bill of materials, 154–155
Assembly mode (SolidWorks), 8
assembly models, 157–158

applying colors, 202–203
configurations, 165
creating

bottom-up modeling, 159
example, 20–22
top-down modeling, 159–163
tutorial, 29–31

defined, 157
design tables, 166
exploded views and animations, 164–165
interference and collision detection, 166
mates, 158
motion study, 165–166, 385–386
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parts versus, 157
planning, 157
saving as images, 62
tutorials

ball screw creation, 173–174
cam and follower creation, 167–168
design table creation, 179–180
gear mates, 169–171
interference and collision detection, 178
motion analysis, 398–403
motion study creation, 176–177
part creation in context, 180–182
rack and pinion creation, 171–173
universal joint motion, 174–176
working hinge creation, 168–169

viewing, 62
assembly prototype file creation tutorial, 

422–423
assembly trees, 157, 164
associativity of parts and engineering 

drawings, 151, 155
attachments in design binders, 85
auxiliary views, 146

B
BA (bend allowance), 290–291
background

of models, 201
tutorials, 203–204

ball screw assembly creation tutorial,  
173–174

base circle (gears), 104
base features, 99
base flanges, 292
base plate creation example, 17–18
base support structure for rapid 

prototyping, 416–417
baseball hat creation tutorial, 273–277
baseline dimensions, 139, 354
basic size, 340–341
BD (bend deduction), 291
bend allowance (BA), 290–291
bending sheet metal, 290–291, 298–299, 

310–311
bends, 292, 293
bicycle handlebar model tutorial, 228–229
bilateral tolerances, 342
bill of materials (BOM), 144, 151

assembly drawings with, 154–155
Bill of Rights for the Planet, 322–323
block mold creation tutorial, 473–477
blocks in top-down assembly  

modeling, 160
bolt creation example, 123–125
Boolean operations, 59–61
BootCamp, 6

bosses, 471
bottle prototype, 420–421
bottom-up assembly modeling, 159
boundaries as surfaces, 251, 263–264
bracket creation tutorial, 66–67
broken views, 147
broken-out sections, 147
Brundtland Report, 320
B-splines. See splines
bubbles, 466
build orientation, 415
burn marks, 467
burrs, 436
bushing bearing creation tutorial, 24

C
CAD (computer-aided design) process, 4–5
CAD models. See parts
CAD/CAM systems

analysis tools
animation and motion analysis, 385–386
finite element analysis, 389–390
finite element method, 386–389
flow simulation, 386
mass properties calculations, 381–385
purpose of, 377–378
SolidWorks Simulation/SimulationXpress, 

391
tutorials, 396–407
types of, 377–378
Von Mises stress, 391–396

data exchange, 378–381
SolidWorks supported file formats,  

379–380
standard/de facto file formats, 378
validating file translation, 380–381

CAM (computer-aided manufacturing) 
process, 6. See also manufacturing 
process

CAM add-in software, 449–450
cam and follower assembly creation 

tutorial, 167–168
camera sleds, 201, 202, 210–212
camera-based animation, 202, 210–212
cameras, 201, 206–207
canned cycles, 447
capturing design intent, 82–83
carbon footprint, 321–322, 325
Cartesian dimensions, 139
caster assembly creation tutorial, 70–72
caustic effects, 198
cavity (of molds), 468
center modifiers, 53–54
center planes for features, 38
.cgr file format, 380
chain dimensioning, 354
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Chamfer feature, 304
chamfers, creating, 121–122
changing font size of dimensions, 9
circle parametric equation, 220–221
circular patterns, 54–55
circular pitch, 105
CL (cutter location) data, 447
coil spring creation tutorial, 63–65
collision detection in assembly models, 

166, 178
colors, applying to objects, 202–203
comments, 83–84
communication

guidelines for, 137
abbreviation rules, 137–138
dimensioning rules, 139–144
drafting rules, 138

SolidWorks tools for, 62
components. See parts
composite curves, 229–230
composites

defined, 37
images of, 38
in part creation, 38

compression spring creation example, 
119–120

computer mouse creation tutorial,  
271–273

concurrent engineering, 442
configurations

in assembly models, 165
in design intent, 85
design tables and, 112–114

conical tapers, 347
conics. See analytic curves
conjugate action (gears), 103–104
construction geometry, 48
continuous machining, 437–438
contours (loops), 217
conventional tolerances, 340, 367–368
converting

shelled solids to sheet metal, 298
solids into sheet metal, 297, 309–310
surfaces into solids, 253

cooling time, 468
coordinate systems, 43–44, 437–438
copying

entities, 58, 116–118
features, 58–59

cores (of molds), 468
corners, 292, 294
crop views, 147
cross-section modeling approach,  

12–14
in drain plug tutorial, 90
in slider block tutorial, 87

curve-driven patterns, 54–55

curves
2D curves, 222
3D curves, 223
analytic curves, 217, 218
equations

circle parametric equation, 220–221
line parametric equation, 219–220
parametric versus explicit, 218–219
spline parametric equation, 221–222

in sketches, 217
splitting, 224
surfaces and, 249
synthetic curves, 218
tutorials

2D curve creation with explicit equation, 
224

2D curve creation with parametric 
equation, 225

3D curve creation with 3D points,  
227–228

3D curve creation with 3D sketches,  
228–229

3D curve creation with composite curves, 
229–230

3D curve creation with parametric 
equation, 225–226

3D curve creation with projected curves, 
232–241

3D curve creation with projected sketches 
on curved faces, 231–232

stethoscope model creation, 241–243
customizing SolidWorks, 11–13, 42
cutter location (CL) data, 447
cutting solids with surfaces, 253
cutting tools, 431–433

D
data exchange between CAD/CAM 

systems, 378–381
SolidWorks supported file formats, 379–380
standard/de facto file formats, 378
tutorials

exporting SolidWorks files, 396
importing IGES and STEP files, 396–397

validating file translation, 380–381
datum targets, 343, 359–360, 370–371
datums, 343, 359
de facto file formats, 378
decals, 198–199
Declaration of Interdependence for  

a Sustainable Future, 323
dedendum circle (gears), 104
defects

in injection molding, 466–467
in weldments, 300

degrees of freedom (DOF), 158, 431
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deleting
entities, 9, 349
features, 9

depth of cut, 433–436
derived parts, 109
design, sustainable. See sustainable design
design binders, 84–85
design checkers, 151–152
design for anything (DFX), 442
design for assembly (DFA), 442
design for manufacturing (DFM), 442–445
design intent

capturing, 82–83
defined, 81
documenting, 83

comments, 83–84
design binders, 84–85
design tables and configurations, 85
dimension names, 85
equations, 85
feature names, 85–86
folders in feature tree, 86

geometric modeling versus, 81
manufacturing process and, 441–442
tutorials

design specifications, 91–93
mating conditions, 93–94
three modeling plans, 89–91
two modeling plans, 86–89

design intent systems, 81
design library, 110–112
design specifications in design intent, 

91–93
design tables

in assembly models, 166, 179–180
configurations and, 112–114
in design intent, 85
examples, 110–114

designated points in part creation, 38
detail views, 146–147
deviation tolerance (STL files), 418
DFA (design for assembly), 442
DFM (design for manufacturing), 442–445
DFMXpress, 442–445
DFX (design for anything), 442
diameter/radius display, toggling, 10
dimensioning engineering drawings,  

135–136
dimensioning rules (ASME), 139–144
dimensions. See also tolerances

changing font size, 9
in configurations, 112–114
defined, 40–41
in engineering drawings, examples,  

143–144
limits of, 348–353
naming, 85

radius/diameter display, 10
in SolidWorks, 142–144
types of, 139, 155

DimXpert module, 364–365
direct dimensioning, 354
directional light, 196
disabling snap to endpoint/midpoint,  

9, 54
documenting design intent, 83

comments, 83–84
design binders, 84–85
design tables and configurations, 85
dimension names, 85
equations, 85
feature names, 85–86
folders in feature tree, 86

drafting rules (ASME), 138
drafts, 102, 470

creating, 121–122
drain plug tutorial

additive modeling plan, 90
cross-section modeling approach, 90
subtractive modeling plan, 91

Drawing mode (SolidWorks), 8
drawing templates, 148
drawings. See engineering drawings
drilling, 438–439, 442–443
drilling holes tutorial, 450–452
drills, 431
driving tools in NC machining, 446
dry machining, 430
ductile material, 391–392
.dwg file format, 380
.dxf file format, 380

E
Easter egg mold creation tutorial, 484–486
edge flanges, 293
edges, 40
editing

entities, 58–59
sketch planes, 45–46
templates, 12–13

EDM (electrical discharge machining), 
439–441

EDP (engineering design process),  
4. See also sustainable design

eDrawings, 7, 62
ejection, 468
ejector marks, 467
enabling snap to endpoint/midpoint, 9, 54
enclosure, sheet metal as, 290
End Cap feature, 302–303, 304
end modifiers, 53–54
energy

measuring consumption, 326
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minimizing consumption, 321
renewable versus nonrenewable, 320

engineering design process (EDP), 4. See 
also sustainable design

engineering drawings
assembly drawings, 164
associativity with parts, 151, 155
communication guidelines for, 137

abbreviation rules, 137–138
dimensioning rules, 139–144
drafting rules, 138

content and layout, 144–145
angles of projection, 145–146
bill of materials (BOM), 151
control options in SolidWorks, 150
sheets, 148–149
title blocks, 149
tolerances, 150, 343–346
view types, 146–148

creating, 148
example, 18–20
tutorial, 28–29

design checkers, 151–152
dimensioning, 135–136
examples, dimensions in engineering 

drawings, 143–144
purpose of, 135
saving as images, 62
tutorials

annotation insertion, 153
assembly drawing creation with bill of 

materials, 154–155
model-drawing associativity, 155
mold drawing creation, 487
sheet metal drawing creation, 308–309
title block filling, 153–154
view creation, 152–153
weldment drawing creation, 313–315

viewing, 62
engraving parts tutorial, 231–232
entities

copying, 116–118
deleting, 9, 349
editing, 58–59
enabling/disabling snap to  

endpoint/midpoint, 9
geometric modifiers, 53–54
measuring, 59
offsetting, 58
in part creation, 50
patterns, 54–57
selecting multiple, 9, 58
transforming, 58
trimming, 58
viewing/hiding, 9

environmental sustainability. See 
sustainable design

.eprt file format, 379
equations

for curves
2D curve creation with explicit equation 

tutorial, 224
2D curve creation with parametric 

equation tutorial, 225
3D curve creation with parametric 

equation tutorial, 225–226
circle parametric equation, 220–221
line parametric equation, 219–220
parametric versus explicit, 218–219
spline parametric equation, 221–222

in design intent, 85
in part creation, 38, 51–53
for surfaces

parametric equations, 254–255
plane parametric equation, 255–256
ruled surface parametric equation,  

257–260
event-based motion studies, 385–386
examples

assembly model creation, 20–22
base plate creation, 17–18
Boolean operations, 59–61
circle parametric equation, 221
decal creation, 198–199
design table creation, 110–114
dimensions in engineering drawings,  

143–144
engineering drawings creation, 18–20
equations and link values, 51–53
feature-based pattern creation, 56–57
fit limits and tolerance zone calculations, 

352–353
free-form torus creation, 102–103
Gauss quadrature, 384
line parametric equation, 220
macro creation, 113–115
macro hotkey creation, 114
mass properties calculations, 384–385
material and texture additions, 200
modeling plan approaches, 39–45
parametric modeling, 41–42
part creation, 49–50
pin creation, 16–17
plane parametric equation, 256
plate creation, 15–16
ruled surface parametric equation, 257–258
sketch-based pattern creation, 55–56
SolidWorks DFMXpress, 445
SolidWorks TolAnalyst, 365–367
spline parametric equation, 222
spur gear CAD model creation, 107–109
stress testing, 393–396
surface-to-surface intersection curve 

creation, 258–260
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tolerance analysis, 364
top-down assembly modeling, 161–163

exiting current mode, 9
explicit equations for curves, 218–219, 

224
exploded views of assembly models,  

164–165
exporting SolidWorks files, 396
extension lines, 140
extrusions, 15, 100

creating with macro, 113–115
defined, 37
images of, 38
in part creation, 38
as surfaces, 250, 261–263

F
fabrication with rapid prototyping, 413
faces

milling tutorial, 452–455
part topology, 40

facets (STL files), 418
FDM (fused deposition modeling), 419
FEA (finite element analysis), 389–390

static linear analysis tutorial, 403–404
thermal analysis tutorial, 405

feature tree, 9
assembly trees versus, 164
folders in, 86
in part creation, 14, 47–48
for sheet metal, 296–297
for weldments, 301–302

feature-based pattern creation example, 
56–57

FeatureManager Design Tree. See feature 
tree

features, 15. See also parts; names of 
specific features

base features, 99
Boolean operations, 59–61
center planes, 38
creating, 15, 121–122
defined, 100
deleting, 9
design intent. See design intent
examples

bolt creation, 123–125
feature creation, 121–122
free-form torus creation, 102–103
hole wizard usage, 118–119
loft feature creation, 116–118
Smart Fasteners wizard usage, 122–123
sweep feature creation, 114–116

library features, 110–112
measuring, 59
naming, 85–86

patterns, 54–57
reference geometry, 48–49
sheet metal, 291–296
transforming, 58–59
types of, 99, 100–102
weldments, 301–304

features modeling approach, 12–14
base features, 99
questions in, 100
in slider block tutorial, 88–89

feedrate, 433–436
FEM/FEA (finite element modeling/finite 

element analysis), 386–390, 393–396
file data exchange between CAD/CAM 

systems, 378–381
SolidWorks supported file formats,  

379–380
standard/de facto file formats, 378
tutorials

exporting SolidWorks files, 396
importing IGES and STEP files, 396–397

validating file translation, 380–381
file formats

SolidWorks supported, 379–380
standard/de facto, 378

filled surfaces, 252, 263–264
fillets, creating, 121–122
filling title blocks, 153–154
finite element analysis (FEA), 389–390

static linear analysis tutorial, 403–404
thermal analysis tutorial, 405

finite element method, 386–389,  
393–396

fits, types of, 348–353
flanges, 291–293
flap creation tutorial, 22–23
flashing, 467
flat tapers, 347
flattening sheet metal, 292, 296
flow marks, 467
flow simulation, 386, 406–407
FloXpress, 406–407
flutes, 431
fog light, 196
folders in feature tree, 86
folding sheet metal, 295
font size of dimensions, changing, 9
free forms

defined, 37
images of, 38
in part creation, 38
surfaces as, 249

free-form torus creation example,  
102–103

fully defined sketches, 46
fused deposition modeling (FDM), 419
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G
GaBi, 328
gate and runner system, 469–470
gauges of sheet metal, 290
Gauss quadrature, 382–385
G-code programming, 447–449
GD&T (geometric dimensioning and 

tolerancing). See tolerances
gear teeth, 103
gears

conjugate action, 103–104
examples, 107–109
geometry of, 104–105
modeling, 105–106
spur gears, 103–109
tutorials

gear mates, 169–171
rack and pinion creation, 171–173

types of, 103
genera (genus), 40
geometric arrays. See patterns
geometric dimensioning and tolerancing 

(GD&T). See tolerances
geometric modeling

capturing design intent, 82
curves

2D curves, 222
3D curves, 223
analytic curves, 217, 218
circle parametric equation, 220–221
line parametric equation, 219–220
parametric versus explicit equations,  

218–219
in sketches, 217
spline parametric equation, 221–222
splitting, 224
synthetic curves, 218
tutorials, 224–243

design intent versus, 81
surfaces

curves and, 249
as free forms, 249
manipulation, 260
parametric equations, 254–255
plane parametric equation, 255–256
purpose of, 249–250
ruled surface parametric equation,  

257–260
in solid modeling, 252–253
tutorials, 261–281
types of, 250–252
visualization, 260

geometric modifiers, 53–54
geometric relation symbols, 10
geometric tolerances, 340

assigning and interpreting, 357–359

creation tutorial, 369–370
symbols, 357
true position, 356–357

green design. See sustainable design
grids, 54
Gusset feature, 302–303, 304

H
hair dryer creation tutorial, 277–279
Hannover Principles, 322–323
.hcg file format, 380
healthy buildings, 322
Help menu (SolidWorks), 11–12
hemisphere mold creation tutorial,  

481–484
hems, 292, 294
hiding

sketch relations, 38
sketches, 9
Task Pane (SolidWorks), 9

hinge assembly tutorial, 168–169
hole wizard, 118–119
hole-based systems, 341
holes

drilling tutorial, 450–452
tolerances, 341

home position, 436
hose flow analysis tutorial, 406–407
hotkeys, 43, 114
housing (of molds), 468
.hsf file format, 380

I
IGES files, importing, 396–397
.igs file format, 379
images, saving as, 62
impact metric of sustainable design,  

325–326
importing IGES and STEP files, 396–397
inch tolerances, 345–346
in-context assembly modeling,  

159–163
injection molding

benefits and drawbacks, 464
defects in, 466–467
machines for, 464–465
materials, 464
mold design

overview, 467–470
phases of, 471–472
in SolidWorks, 472–473

part design, 470–471
purpose of, 463–464
steps in, 464, 465–466
tutorials
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block mold creation, 473–477
Easter egg mold creation, 484–486
hemisphere mold creation, 481–484
mold drawing creation, 487
sandbox mold creation, 477–480

inserting annotations, 153
inserts, 470
inspecting

parts, 340
weld joints, 300

instances, 158
interference detection in assembly 

models, 166, 178
interpolations, 447
interpreting tolerances, 360–362
intersection (Boolean operation), 59
intersection modifiers, 53–54
intersections (surfaces) tutorial, 268–269
involute profile, 104
ISO (International Organization for 

Standardization), 137, 327, 491
ISO fits, 348–349
ISO weld symbols, 305

J
job shop production, 428
jogs, 292, 294
.jpg file format, 380

K
K-Factor, 290
knit surfaces, 252, 261–263

L
laminated object manufacturing (LOM), 

419
lathes, 428–430, 438
layering (slicing), 415–416
layout sketches, 159–160
LCA (life cycle assessment), 322, 323–327
leaders, 140
least material condition (LMC), 342–343
library features, 110–112
life cycle assessment (LCA), 322, 323–327
lighting

in rendering, 196–198
tutorials, 204–205
types of, 196

limit dimensions, 341, 343
limits of dimensions, 348–353
line parametric equation, 219–220
linear patterns. See rectangular patterns
link values, 51–53
linking parameters, 51

LMC (least material condition), 342–343
lofted bends, 292, 295
lofts, 101

creating, 116–118
as surfaces, 251, 252, 261–263

LOM (laminated object manufacturing), 
419

loops, 40, 217

M
machine tools, 428–430
machining

cutting tools, 431–433
drilling, 438–439
EDM (electrical discharge machining),  

439–441
home position, 436
machine tools, 428–430
machining parameters, 433–436
machining quality, 436
milling, 439
motion axes, 431
NC machining

G-code and M-code programming,  
447–449

programming concepts, 445–447
process types, 428
rapid positioning, 438
SolidWorks DFMXpress, 442–445
squaring stock, 436
stock, 433
toolpaths, 436–438
turning, 438
tutorials

drilling holes, 450–452
face milling, 452–455
pocket milling, 455–457
slot milling, 457–459

machining parameters, 433–436
machining quality, 436
MacOS, SolidWorks on, 6
macros, 111–114

defined, 111
examples

extrusion creation, 113–115
hotkey creation, 114

manufacturing engineers, 5
manufacturing process, 5

CAM add-in software, 449–450
design and, 441–442
dimensioning for, 136
injection molding

benefits and drawbacks, 464
defects in, 466–467
machines for, 464–465
materials, 464
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mold design overview, 467–470
mold design phases, 471–472
part design, 470–471
purpose of, 463–464
SolidWorks mold design, 472–473
steps in, 464, 465–466
tutorials, 473–487

machining
cutting tools, 431–433
drilling, 438–439
EDM (electrical discharge machining), 

439–441
home position, 436
machine tools, 428–430
machining parameters, 433–436
machining quality, 436
milling, 439
motion axes, 431
process types, 428
rapid positioning, 438
SolidWorks DFMXpress, 442–445
squaring stock, 436
stock, 433
toolpaths, 436–438
turning, 438

NC machining
G-code and M-code programming,  

447–449
programming concepts, 445–447

prototyping
purpose of, 411
visualization with, 412–413

rapid prototyping (RP)
applications, 412–413
benefits of, 411–412
bottle prototype, 420–421
build orientation, 415
layering (slicing), 415–416
steps in, 414, 418–419
STL files, 417–418
support structure, 416–417
techniques, 419
triangulation (tessellation), 414–415
tutorials, 421–424

tolerances
datum targets, 359–360
geometric tolerances, 357–359
interpreting, 360–362
purpose of, 339–340
standardizing, 348–353
statistical tolerancing, 354–355
terminology, 340–343
true position, 356–357
types of, 340

tutorials
drilling holes, 450–452
face milling, 452–455

pocket milling, 455–457
slot milling, 457–459

types of, 427–428
mass customization, 428
mass production, 428
mass properties calculations, 381–385, 

397–398
master parts. See templates
material conditions, 342–343
materials

in injection molding, 464
properties, 392
rendering, 199–200
sheet metal, 289–290
in sustainable design, 325–326
transparency, 205–206
Von Mises stress, 391–396

mates, 20
applying, 158
defined, 157
tutorials

ball screw creation, 173–174
gear mates, 169–171
rack and pinion creation, 171–173

mating conditions in design intent,  
93–94

maximum material condition (MMC),  
342–343

M-code programming, 447–449
MCS (model coordinate system), 43–44, 

437–438
measuring entities/features, 59
meshing gears, 103–104
millimeter tolerances, 344–345
milling, 439, 443

faces, 452–455
pockets, 455–457
slots, 457–459

milling machines, 428–430
mills, 431
mirroring

entities, 58
features, 59

miter flanges, 293
MMC (maximum material condition),  

342–343
model coordinate system (MCS), 43–44, 

437–438
model items (dimensions), 155
modeling plan approaches

design intent tutorials
three modeling plans, 89–91
two modeling plans, 86–89

example, 39–45
explained, 12–14

models. See parts
modes (SolidWorks)
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exiting, 9
list of, 8

mold base, 469
mold design

overview, 467–470
phases of, 471–472
in SolidWorks, 472–473

molds. See injection molding
motion axes, 431
motion study

of assembly models, 165–166, 176–177
tutorials, 207–210, 398–403
types of, 385–386

mount plate creation tutorial, 65–66
mouse button usage, 9
mouse wheel usage, 9
moving

entities, 58
features, 58–59
Task Pane (SolidWorks), 10

multiaxial loading, 393
multiple entities, selecting, 9, 58
multiple open windows, 9
multiple parts, viewing, 10

N
NA (neutral axis), 290
named (orthographic) views, 146
naming

dimensions, 85
features, 85–86

NC (numerical control) machining
G-code and M-code programming, 447–449
programming concepts, 445–447

neutral axis (NA), 290
nominal size, 340–341
nonrenewable energy, 320
normal vectors, 255
numerical control machining. See NC 

(numerical control) machining

O
offsetting

entities, 58
surfaces, 263–264

oil container creation tutorial, 279–281
opening

parts, 8
STL files, 423–424

optimization with rapid prototyping, 413
ordinate dimensions, 139
orthographic (named) views, 146
Our Common Future (Oxford University 

Press), 320
over defined sketches, 46

P
panning parts, 10
parameters, 40–41

in configurations, 112–114
in equations, 51
linking, 51

parametric equations
for circles, 220–221
for curves, 218–219

2D curve creation tutorial, 225
3D curve creation tutorial, 225–226

for lines, 219–220
for planes, 255–256
for ruled surfaces, 257–260
for splines, 221–222
for surfaces, 254–255

parametric modeling, 40–42
part history tree. See feature tree
Part mode (SolidWorks), 8
part prototype file creation tutorial,  

421–422
partial filling (short shot), 466
parting axes, 469
parting lines, 468
parting surfaces, 469
parts. See also features

applying colors, 202–203
assembly models versus, 157
associativity with engineering drawings, 

151, 155
configurations. See configurations
creating, 14–15. See also sketches

in assembly context, 180–182
Boolean operations, 59–61
coordinate systems, 43–44
equations and link values, 51–53
example, 49–50
feature tree, 47–48
grids, 54
modeling plan approaches, 12–14
parametric modeling, 40–42
patterns, 54–57
planning, 38–39
sketch entities, 50
sketch planes, 43–46
templates, 61

curves. See curves
data exchange between CAD/CAM systems, 

378–381
derived parts, 109
design intent. See design intent
designing for injection molding, 470–471
engraving tutorial, 231–232
examples

assembly model creation, 20–22
base plate creation, 17–18
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engineering drawings creation, 18–20
part creation, 49–50
pin creation, 16–17
plate creation, 15–16

inspecting, 340
model communication tools in  

SolidWorks, 62
opening, 8
reusing, 110–112
saving as images, 62
sheet metal. See sheet metal
surfaces. See surfaces
tolerancing, 136, 150. See also tolerances
topology, 40
types of, 37–38
viewing, 10, 61, 62
viewing multiple, 10
visualization. See visualization
welded. See weldments
zooming/panning/rotating, 10

patterns, 38, 54–57
.pdf file format, 379
PDM (product data management), 442
picture frame model tutorial, 229–230
pillow block creation tutorial, 25–27
pin and bushing bearing creation  

tutorial, 24
pin creation example, 16–17
pitch circle (gears), 104
placing toolbars, 10
planar surfaces, 252, 263–264
plane parametric equation, 255–256
planning

assembly models, 157
part creation, 38–39

plate creation example, 15–16
playback animation, 201–202
PLM (product life cycle management), 442
plus and minus tolerancing, 343
pocket milling tutorial, 455–457
point light, 196
point-to-point (PTP) machining, 437–438
pressure angle, 103
process planners, 5
product data management (PDM), 442
product life cycle management (PLM), 442
productivity tools, 43
programmable mice, 43
programming. See NC (numerical control) 

machining
projected curves, 232–241
projected views, 146
projection, angles of, 145–146
prototyping. See also rapid  

prototyping (RP)
purpose of, 411
visualization with, 412–413

.prt file format, 380

.prtdot file format, 379

.psd file format, 379
PTP (point-to-point) machining, 437–438

R
rack and pinion assembly creation 

tutorial, 171–173
radial dimensions, 139
radiate surfaces, 261–263
radius/diameter display, toggling, 10
rapid positioning, 438
rapid prototyping (RP)

applications, 412–413
benefits of, 411–412
bottle prototype, 420–421
build orientation, 415
layering (slicing), 415–416
steps in, 414, 418–419
STL files, 417–418
support structure, 416–417
techniques, 419
triangulation (tessellation), 414–415
tutorials

assembly prototype file creation, 422–423
opening STL files, 423–424
part prototype file creation, 421–422

real-time animation, 201
rectangular patterns, 54–55
recycling, 320, 322
reference dimensions, 155
reference geometry, 48–49
reflection in rendering, 197–198
regardless of feature size material 

condition (RFS), 342–343
relations, 51
relative-to-model views, 148
rendering

appearance and transparency, 201
background, 201
cameras, 201
complexity of, 195–196
decals, 198–199
lighting, 196–198
materials, 199–200
models, 197–198
purpose of, 195
resolution, 195
scenes, 196
textures, 199

renewable energy, 320
resolution

in rendering, 195
of STL files, 417–418

resources for SolidWorks, 11–12
reusing parts, 110–112
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revolves, 15, 100
defined, 37
images of, 38
in part creation, 38
as surfaces, 250, 261–263

RFS (regardless of feature size material 
condition), 342–343

ribs, 102, 471
creating, 121–122

rips, 292, 294
root circle (gears), 104
rotating

entities, 58
features, 58–59
parts, 10

rotation speed, 433–436
ruled surface parametric equation,  

257–260
runners, 469–470

S
sandbox mold creation tutorial, 477–480
.sat file format, 379
save symbol, 9
saving

as images, 62
STL files, 417–418

scaling
entities, 58
features, 59

scenes
accessing library, 201
cameras in, 201, 206–207
in rendering, 196
tutorials

applying, 203–204
lighting, 204–205

screen capture, 9, 62
section views, 146
selecting multiple entities, 9, 58
selective laser sintering (SLS), 419
SGC (solid ground curing), 419
shaft-based systems, 341
shafts, 341
sheet metal

bending, 290–291, 298–299
creating, 297–299
as enclosure, 290
feature tree, 296–297
features, 291–296
gauges, 290
materials, 289–290
purpose of, 289
rules in DFMXpress, 443
tutorials

part creation via bending, 310–311

sheet metal creation, 306–307
sheet metal creation from solid body,  

309–310
sheet metal drawing creation, 308–309

types of, 289
sheets in engineering drawings, 148–149
shelled solids, converting to sheet  

metal, 298
shells, 102, 121–122
short shot (partial filling), 466
shots, 468
shrinkage, 468
shut-off surfaces, 472
simple tensile tests, 392–393
Simulation, 391
SimulationXpress, 391
single limits in tolerances, 346
sink marks, 466
sinker EDM, 439–441
sizes, types of, 340–341
sketch entities. See entities
sketch planes, 15, 43–46
sketch relations, viewing/hiding, 38
sketch symbols, 9
sketch-based pattern creation example, 

55–56
sketches

construction geometry, 48
creating features, 15
curves in, 217
entities, copying, 116–118
parametric modeling, 40–42
relations, 51
status, 46–47
tutorials

3D curve creation with 3D sketches,  
228–229

3D curve creation with projected sketches 
on curved faces, 231–232

viewing/hiding, 9
SLA (stereolithography apparatus), 419
.sldftp file format, 379
.sldlfp file format, 379
.sldprt file format, 379
slicing (layering), 415–416
slider block tutorial

cross-section modeling approach, 87
features modeling approach, 88–89

slots
creating, 121–122
milling, 457–459

SLS (selective laser sintering), 419
Smart Fasteners wizard, 122–123
snap to endpoint/midpoint, enabling/

disabling, 9, 54
society, design and, 321
solid ground curing (SGC), 419
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solid models, 40
converting to sheet metal, 297, 309–310
mass properties calculation tutorial,  

397–398
surfaces in, 252–253

SolidWorks
API (application programming interface), 

112
CAM add-in software, 449–450
certification, 505–516
communication tools, 62
customizing, 11–13, 42
dimensions in, 142–144
drafting control options, 150
exporting files, 396
FEM/FEA modules, 391
FloXpress, 406–407
importing IGES and STEP files, 396–397
machining, 442–445
on MacOS, 6
modes

exiting, 9
list of, 8

mold design, 472–473
operational overview, 8–12
productivity tools, 43
resources, 11–12
starting, 8
STL files, 417–418
sustainable design tools, 328–332
system requirements, 6
tolerance analysis, 364–367, 372–373
viewer version, 62

Sphera, 328
spindle speed, 433–436
spiral spring creation example, 120–121
spline parametric equation, 221–222
splines, 50
splitting curves, 224
spot light, 196
springs

compression spring creation example,  
119–120

spiral spring creation example, 120–121
spur gears, 103–109
squaring stock, 436
standard file formats, 378
standardizing tolerances, 348–353
start parts. See templates
starting SolidWorks, 8
static linear analysis, 389, 403–404
statistical tolerance analysis, 363–364
statistical tolerancing, 354–355
steel washer redesign tutorial, 332–334
.step file format, 379
STEP files, importing, 396–397
stereolithography apparatus (SLA), 419

stethoscope model creation tutorial,  
241–243

.stl file format, 379
STL files

opening, 423–424
saving, 417–418
tutorials

assembly prototype file creation, 422–423
part prototype file creation, 421–422

stock
defined, 433
squaring, 436

stress testing, 391–396
stress-strain curve, 391–392
stretching entities, 58
Structural Member feature, 302, 303
subtraction (Boolean operation), 59
subtractive manufacturing, 412
subtractive modeling plan in drain plug 

tutorial, 91
support structure for rapid prototyping, 

416–417
surface finish, 199
surface intersections tutorial, 268–269
surfaces

curves and, 249
equations

parametric equations, 254–255
plane parametric equation, 255–256
ruled surface parametric equation,  

257–260
as free forms, 249
manipulation, 260
purpose of, 249–250
in solid modeling, 252–253
tutorials

artistic bowl creation, 265–267
baseball hat creation, 273–277
basic surface creation, 261–264
computer mouse creation, 271–273
hair dryer creation, 277–279
oil container creation, 279–281
surface intersections, 268–269
tablespoon creation, 269–271
visualization, 264–265

types of, 250–252
visualization, 260

surface-to-surface intersection curve 
creation example, 258–260

Sustainability, 328–332
SustainabilityXpress, 328
sustainable design

Declaration of Interdependence for a 
Sustainable Future, 323

defined, 320
guidelines for, 321–322
Hannover Principles, 322–323

Z03_Zeid_Index_517-544.indd   529 11/03/21   1:08 pm



530	 Index

impact metric, 325–326
LCA (life cycle assessment), 323–327
manufacturing process and, 441–442
purpose of, 319–320
society and, 321
SolidWorks Sustainability, 328–332
steel washer redesign tutorial, 332–334
steps in, 327–328
tools, 328

sustainable manufacturing, 319–320
sustainable waste, 319–320
sweeps, 101

creating, 114–116
as surfaces, 251, 261–263

symmetric tolerances, 342
symmetry of parts, 38
synthetic curves, 218
synthetic surfaces, 249
system requirements for SolidWorks, 6

T
tablespoon creation tutorial, 269–271
tabs, 292, 293
tangent vectors, 219, 254
tapers, tolerancing, 347–348, 371–372
tapping tools, 431
targets in Boolean subtraction, 59
Task Pane (SolidWorks)

moving, 10
viewing/hiding, 9

templates
creating, 61
drawing templates, 148
editing, 12–13

tessellation (triangulation)
defined, 414–415
STL files, 417–418

testing with rapid prototyping, 413
textures, 199, 200
thermal analysis tutorial, 405
thickening surfaces, 253
thread types, 431
threads, 471
.tif file format, 380
time-based motion studies, 385
tire and pin creation tutorial, 69–70
title blocks

in engineering drawings, 149
filling, 153–154
tolerances in, 343

toggling radius/diameter display, 10
TolAnalyst module, 364–367, 372–373
tolerance accumulation, 353–354
tolerance analysis, 362–367

example, 364
methods of, 362

purpose of, 362
in SolidWorks, 364–367
tutorial, 372–373

tolerance notes, 343
tolerance synthesis, 362
tolerance zone, 341
tolerances. See also dimensions

ASME tolerance rules, 343–346
datum targets, 359–360
geometric tolerances, 357–359
interpreting, 360–362
purpose of, 339–340
standardizing, 348–353
statistical tolerancing, 354–355
of STL files, 418
terminology, 340–343
true position, 356–357
tutorials

conventional tolerance creation, 367–368
datum target definition, 370–371
geometric tolerance creation, 369–370
taper tolerances, 371–372
tolerance analysis, 372–373

types of, 340
tolerancing

parts, 136, 150
tapers, 347–348, 371–372

tool offset, 447
tool splitting, 468
toolbars, placing, 10
tooling, 468
tooling cost, 470
tooling split, 472
toolpaths, 436–438, 449–450
tools

in Boolean subtraction, 59
driving in NC machining, 446
injection molding machines, 464–465
machine tools, 428–430
for sustainable design, 328

top-down assembly modeling, 159–163
topology of parts, 40
torus creation example, 102–103
transforming

entities, 58
features, 58–59

translating
entities, 58
features, 58–59
files, 380–381

transparency
of models, 201
tutorials, 205–206

triangulation (tessellation)
defined, 414–415
STL files, 417–418

Trim/Extend feature, 302–303
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trimming entities, 58
true length dimensions, 139
true position, 356–357
turning, 438, 442
tutorials

for analysis tools
flow simulation, 406–407
mass properties calculations, 397–398
motion analysis, 398–403
static linear analysis, 403–404
thermal analysis, 405

assembly models
ball screw creation, 173–174
cam and follower creation, 167–168
creating, 29–31
design table creation, 179–180
gear mates, 169–171
interference and collision detection, 178
motion study creation, 176–177
part creation in context, 180–182
rack and pinion creation, 171–173
universal joint motion, 174–176
working hinge creation, 168–169

background and scene application,  
203–204

bolt creation, 123–125
bracket creation, 66–67
camera-based animation creation, 210–212
cameras in scenes, 206–207
caster assembly creation, 70–72
coil spring creation, 63–65
compression spring creation, 119–120
for curves

2D curve creation with explicit  
equation, 224

2D curve creation with parametric 
equation, 225

3D curve creation with 3D points,  
227–228

3D curve creation with 3D sketches,  
228–229

3D curve creation with composite curves, 
229–230

3D curve creation with parametric 
equation, 225–226

3D curve creation with projected curves, 
232–241

3D curve creation with projected sketches 
on curved faces, 231–232

stethoscope model creation, 241–243
data exchange

exporting SolidWorks files, 396
importing IGES and STEP files, 396–397

design intent
design specifications, 91–93
mating conditions, 93–94
three modeling plans, 89–91

two modeling plans, 86–89
engineering drawings

annotation insertion, 153
assembly drawing creation with bill of 

materials, 154–155
creating, 28–29
model-drawing associativity, 155
title block filling, 153–154
view creation, 152–153

feature creation, 121–122
flap creation, 22–23
hole wizard usage, 118–119
for injection molding

block mold creation, 473–477
Easter egg mold creation, 484–486
hemisphere mold creation, 481–484
mold drawing creation, 487
sandbox mold creation, 477–480

lighting in scenes, 204–205
loft feature creation, 116–118
for machining

drilling holes, 450–452
face milling, 452–455
pocket milling, 455–457
slot milling, 457–459

materials and transparency, 205–206
motion study creation, 207–210
mount plate creation, 65–66
object color application, 202–203
pillow block creation, 25–27
pin and bushing bearing creation, 24
for rapid prototyping (RP)

assembly prototype file creation, 422–423
opening STL files, 423–424
part prototype file creation, 421–422

for sheet metal
part creation via bending, 310–311
sheet metal creation, 306–307
sheet metal creation from solid body,  

309–310
sheet metal drawing creation, 308–309

Smart Fasteners wizard usage,  
122–123

spiral spring creation, 120–121
steel washer redesign, 332–334
for surfaces

artistic bowl creation, 265–267
baseball hat creation, 273–277
basic surface creation, 261–264
computer mouse creation, 271–273
hair dryer creation, 277–279
oil container creation, 279–281
surface intersections, 268–269
tablespoon creation, 269–271
visualization, 264–265

sweep feature creation, 114–116
tire and pin creation, 69–70
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for tolerances
conventional tolerance creation, 367–368
datum target definition, 370–371
geometric tolerance creation, 369–370
taper tolerances, 371–372
tolerance analysis, 372–373

for weldments
weldment creation, 311–313
weldment drawing creation, 313–315

wheel creation, 67–68
twist vectors, 254

U
under defined sketches, 46
undercuts, 470, 471
undo symbol, 9
unfolding sheet metal, 295
uniaxial stress tests, 392–393
unilateral tolerances, 341–342
union (Boolean operation), 59
universal joint motion assembly tutorial, 

174–176

V
validating file translation, 380–381
VB (Visual Basic), 112
.vda file format, 379
venting, 470
verification with rapid prototyping, 413
vertices (vertex), 40
viewing

multiple parts, 10
parts, 10, 61
sketch relations, 38
sketches, 9
Task Pane (SolidWorks), 9
without SolidWorks software, 62

views
creating, 152–153
exploded, 164–165
types of, 146–148

virtualization software on MacOS, 6
Visual Basic (VB), 112
visualization

animations, types of, 201–202
with prototyping, 412–413
purpose of, 195
rendering

appearance and transparency, 201
background, 201
cameras, 201
complexity of, 195–196
decals, 198–199
lighting, 196–198

materials, 199–200
models, 197–198
purpose of, 195
resolution, 195
scenes, 196
textures, 199

of surfaces, 260, 264–265
voids, 467
Von Mises stress, 391–396

W
warpage, 467
water eutrophication, 326
water footprint, 326
WCS (working coordinate system), 43–44
Weld Bead feature, 302–303, 304
weld joints

inspecting, 300
types of, 301

weld lines, 467
weld symbols, 305–306
welding

equipment, 300
processes, 299–300
purpose of, 299

weldments
creating, 299–301
defects in, 300
feature tree, 301–302
features, 301–304
tutorials

weldment creation, 311–313
weldment drawing creation, 313–315

weld symbols, 305–306
wet machining, 430
wheel creation tutorial, 67–68
wire EDM, 439–441
working coordinate system (WCS), 43–44
working hinge assembly creation tutorial, 

168–169
worst-case tolerance analysis, 362–363
.wrl file format, 379

X
.x_b file format, 379
.x_t file format, 379
.xaml file format, 380

Z
zero-radius programming, 446
zooming parts, 10
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