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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
files you’ll need to complete the exercises in the book.

1	 Go to www.adobepress.com/AfterEffectsCIB2021.

2	 Sign in or create a new account.

3	 Click Submit.

4	 Answer the questions as proof of purchase.

5	 The lesson files can be accessed through the Registered Products tab on your 
Account page.

6	 Click the Access Bonus Content link below the title of your product to proceed to 
the download page. Click the lesson file links to download them to your computer.

� Note:  If you 
encounter problems 
registering your 
product or accessing 
the lesson files or 
web edition, go to 
www.adobepress.com/ 
support for assistance.

� Note:  If you 
purchased a digital 
product directly from 
www.adobepress.com  
or www.peachpit.com,  
your product will 
already be registered. 
However, you still 
need to follow the 
registration steps and 
answer the proof of 
purchase question 
before the Access Bonus 
Content link will appear 
under the product 
on your Registered 
Products tab.
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CREATING A BASIC ANIMATION 
USING EFFECTS AND PRESETS

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Use Adobe Bridge to preview and import footage items.

•	 Work with the layers of an imported Adobe Illustrator file. 

•	 Use guides to position objects.

•	 Apply drop-shadow and emboss effects.

•	 Apply a text animation preset.

•	 Precompose layers.

•	 Apply a dissolve transition effect.

•	 Adjust the transparency of a layer.

•	 Render an animation for broadcast use. 

This lesson will take about an hour to complete. If you haven’t already 
done so, download the project files for this lesson from www.adobepress.
com/AfterEffectsCIB2021, following the instructions in the Getting 
Started section under “Accessing the lesson files and Web Edition.”

2

http://www.adobepress.com/AfterEffectsCIB2021
http://www.adobepress.com/AfterEffectsCIB2021
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Hit the ground running with a variety of effects and 
animation presets in After Effects. You can use them  
to create great-looking animations quickly and easily.

PROJECT:  ANIMATED LOGO
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Getting started
In this lesson, you will become more familiar with the Adobe After Effects project 
workflow. You’ll learn new ways to accomplish basic tasks as you create a simple 
identification graphic for the introduction to a video presentation called “Explore 
Hawaii” for the fictional Blue Crab Charter Services. You will animate the title and 
logo so that they fade to become a watermark in the lower right corner of the screen 
during the presentation. Then you’ll export the introduction for broadcast output. 

First, take a look at the final project files to see what you’ll be doing.

1	 Make sure the following files are in the Lessons/Lesson02 folder  
on your hard disk, or download them from www.adobepress.com now: 

•	 In the Assets folder: BlueCrabLogo.ai, MauiCoast.jpg

•	 In the Sample_Movies folder: Lesson02.avi, Lesson02.mov

2	 Open and play the Lesson02.avi sample movie in Windows Movies & TV  
or the Lesson02.mov sample movie in QuickTime Player to see what you 
will create in this lesson. When you are done, close Windows Movies & TV or 
QuickTime Player. You may delete the sample movies from your hard disk if you 
have limited storage space.

Before you begin the lesson, you’ll restore the default application settings for After 
Effects. See “Restoring default preferences” on page 3 for more information.

3	 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS) to restore default preferences settings. 
When prompted, click OK to delete your preferences.

4	 In the Home window, click New Project.

After Effects opens to display a blank, untitled project.

5	 Choose File > Save As > Save As.

6	 In the Save As dialog box, navigate to the Lessons/Lesson02/  
Finished_Project folder. 

7	 Name the project Lesson02_Finished.aep, and then click Save.

http://www.adobepress.com
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Importing footage using Adobe Bridge
In Lesson 1, you chose File > Import > File to import footage. However, you can  
also use Adobe Bridge—a powerful, flexible tool for organizing, browsing, and 
locating the assets you need to create content for print, web, television, DVD, film, 
and mobile devices. Adobe Bridge keeps native Adobe files (such as PSD and PDF 
files) as well as non-Adobe files available for easy access. You can drag assets into 
your layouts, projects, and compositions as needed; preview your assets; and even 
add metadata (file information) to assets to make files easier to locate. 

Adobe Bridge is not automatically installed with After Effects; you need to install 
it separately from Creative Cloud.  If Bridge is not installed, you’ll be prompted to 
install it when you choose File > Browse In Bridge. 

In this exercise, you will jump to Adobe Bridge to import the still image that will 
serve as the background of your composition.

1	 Choose File > Browse In Bridge. If you receive a message about enabling an exten-
sion to Adobe Bridge, click Yes. You may also be asked to allow Adobe Bridge to 
access various content folders on your computer.

Adobe Bridge opens, displaying a collection of panels, menus, and buttons.

2	 Click the Folders tab in the upper left corner of Adobe Bridge.

3	 In the Folders panel, navigate to the Lessons/Lesson02/Assets folder. Click the 
arrows to open nested folders. You can also double-click folder thumbnail icons 
in the Content panel.

The Content panel updates interactively. For example, when you select the Assets 
folder in the Folders panel, thumbnail previews of the folder’s contents appear in the 
Content panel. Adobe Bridge displays previews of image files such as those in PSD, 
TIFF, and JPEG formats, as well as Illustrator vector files, multipage Adobe PDF 
files, QuickTime movie files, and more.

EE Tip:  You can 
use Adobe Bridge 
separately to manage 
your files. To open 
Adobe Bridge directly, 
choose Adobe Bridge 
from the Start menu 
(Windows) or double-
click the Adobe Bridge 
icon in the Applications/ 
Adobe Bridge folder 
(macOS). 

 Note:  We’re 
using the Essentials 
workspace, which is  
the default workspace 
in Bridge. 
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4	 Drag the thumbnail slider at the bottom of the Adobe Bridge window to enlarge 
the thumbnail previews. 

5	 Select the MauiCoast.jpg file in the Content panel, and notice that it appears in 
the Preview panel as well. Information about the file, including its creation date, 
bit depth, and file size, appears in the Metadata panel.

6	 Double-click the MauiCoast.jpg 
thumbnail in the Content panel to 
place the file in your After Effects 
project. Alternatively, you can drag 
the MauiCoast.jpg thumbnail into 
the Project panel in After Effects.

7	 Return to After Effects, if you’re not 
already there. 

You can close Adobe Bridge if you’d like. You won’t be using it again during this lesson.

EE Tip:  To prioritize 
different information 
in Adobe Bridge, 
change the workspace: 
Choose Window > 
Workspace, and then 
select a workspace. See 
Adobe Bridge Help to 
learn about customizing 
Adobe Bridge.
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Creating a new composition
Following the workflow you learned in Lesson 1, the next step is to create a new 
composition. You’ll create one, and then add your footage items to it.

Creating an empty composition
First, you’ll create the composition itself, without any layers.

1	 Create a new composition by doing one of the following:

•	 Click the Create A New Composition button ( ) at the bottom of the  
Project panel.

•	 Click the New Composition button in the Composition panel.

•	 Choose Composition > New Composition.

•	 Press Ctrl+N (Windows) or Command+N (macOS).

2	 In the Composition Settings dialog box, do the following:

•	 Name the composition Explore Hawaii.

•	 Choose NTSC DV Widescreen from the Preset pop-up menu. NTSC DV 
Widescreen uses the customary settings for television in the United States 
and some other countries. This preset automatically sets the width, height, 
pixel aspect ratio, and frame rate for the composition to NTSC standards.

•	 In the Duration field, type 300 to specify 3 seconds.

•	 Click OK.
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After Effects displays an empty com-
position named Explore Hawaii in the 
Composition panel and in the Timeline 
panel. Now, you’ll add the background.

3	 Drag the MauiCoast.jpg footage 
item from the Project panel to 
the Timeline panel to add it to the 
Explore Hawaii composition.

4	 With the MauiCoast layer selected in the Timeline panel, choose Layer > 
Transform > Fit To Comp to scale the background image to the dimensions  
of the composition.

Importing the foreground element
Your background is now in place. The foreground object you’ll use is a layered  
vector graphic that was created in Illustrator.

1	 Choose File > Import > File. 

2	 In the Import File dialog box, select the BlueCrabLogo.ai file in the Lessons/
Lesson02/Assets folder. (The file appears as BlueCrabLogo if file extensions are 
hidden.)

3	 Choose Composition from the Import As menu. (In macOS, you may need to click 
Options to display the Import As menu.) Then click Import or Open.

EE Tip:  The keyboard 
shortcut for fitting a 
layer to a composition 
is Ctrl+Alt+F (Windows) 
or Command+Option+F 
(macOS).
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The Illustrator file is added to the Project panel as a composition named  
BlueCrabLogo. A folder named BlueCrabLogo Layers also appears. This folder  
contains the three individual layers of the Illustrator file. Click the arrow  
to open the folder and see its contents if you like.

4	 Drag the BlueCrabLogo composition file from the Project panel into the 
Timeline panel above the MauiCoast layer.

You should now see both the background image and the logo in the Composition 
panel and in the Timeline panel.

5	 Choose File > Save to save your work so far.
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Working with imported Illustrator layers
The BlueCrabLogo graphic was created in Illustrator; your job in After Effects  
is to add text and animate it. To work with the layers of the Illustrator file indepen-
dently of the background footage, you’ll open the BlueCrabLogo composition in  
its own Timeline and Composition panels.

1	 Double-click the BlueCrabLogo 
composition in the Project panel. 

The composition opens in its own 
Timeline and Composition panels.

2	 Select the Horizontal Type tool ( ) in the Tools panel, and click in the 
Composition panel.

3	 Type EXPLORE HAWAII, all capital letters, and then select all of the text  
you just entered. Notice that the generic Text 1 layer name in the Timeline panel 
changes to EXPLORE HAWAII, the text you typed. 
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4	 In the Character panel, select a sans serif typeface such as Impact, and change 
the font size to 80 pixels. Click the eyedropper ( ) in the Character panel,  
and click the outer border on the logo to select the yellow color. After Effects 
applies it to the text you typed. Leave all other options in the Character panel at 
their defaults. 

You’ll position the text you just typed using a guide. 

5	 Select the Selection tool ( ) in the Tools panel. 

6	 Choose View > Show Rulers, and then drag a guide from the top ruler into  
the Composition panel.

7	 Right-click or Control-click the guide, click Edit Position, type 120 in the Edit 
Value dialog box, and click OK. The guide moves to the position you specified.

8	 Drag the text so that it is centered over the image, snapping its bottom side to 
the guide.

9	 Drag another guide from the top ruler, right-click or Control-click it, click Edit 
Position, type 150 in the Edit Value dialog box, and click OK.

10	 In the Timeline panel, select the background layer, and then Shift-select the text 
layer to select all three logo layers. Align the top of the logo with the lower guide.

 Note:  If the 
Character panel isn’t 
open, choose Window > 
Character. You may 
need to expand the 
width of the panel to 
see the eyedropper. 

EE Tip:  You can also 
choose View > Show 
Grid to make the 
nonprinting grid visible 
to help you position 
objects. Choose View > 
Show Grid again to hide 
the grid later.
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11	Choose View > Show Rulers, and then choose View > Show Guides, to hide  
the ruler and the guide.

12	Choose File > Save to save your work.

Applying effects to a layer
Now you’ll return to the main composition, Explore Hawaii, and apply an effect  
to the BlueCrabLogo layer. This will apply the effect to all of the layers nested  
in the BlueCrabLogo composition.

1	 Click the Explore Hawaii tab in the Timeline panel, and then select the 
BlueCrabLogo layer. 

The effect you create next will be applied only to the logo elements, not to the back-
ground image.

2	 Choose Effect > Perspective > Drop Shadow. 

A soft-edged shadow appears behind the nested layers of the BlueCrabLogo layer—
the logo graphic and the words Explore Hawaii—in the Composition panel. You can 
customize the effect using the Effect Controls panel, which appears in front of the 
Project panel when you apply an effect.

3	 In the Effect Controls panel, make sure that the drop shadow’s Distance is 5, and 
increase its Softness to 4. You can set each value by clicking the field and typing 
the number or by dragging the blue value.
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Applying and controlling effects
You can apply or remove an effect at any time. Once you’ve applied effects  
to a layer, you can temporarily turn off one or all of the effects in the layer to  
concentrate on another aspect of your composition. Effects that are turned off  
do not appear in the Composition panel, and typically aren’t included when the 
layer is previewed or rendered.

By default, when you apply an effect to a layer, the effect is active for the duration  
of the layer. However, you can make an effect start and stop at specific times, or 
make the effect more or less intense over time. You’ll learn more about creating 
animation using keyframes and expressions in Lesson 5, “Animating a Multimedia 
Presentation,” and Lesson 6, “Animating Layers.”

You can apply and edit effects on adjustment layers just as you do with other layers. 
Note, however, that when you apply an effect to an adjustment layer, the effect is 
applied to all layers below it in the Timeline panel.

Effects can also be saved, browsed, and applied as animation presets.

The drop shadow is nice, but the logo will stand out even more if you apply an emboss 
effect. You can use either the Effect menu or the Effects & Presets panel to locate 
and apply effects.

4	 Click the Effects & Presets tab to open the panel. Then click the arrow next  
to Stylize to expand the category.

5	 With the BlueCrabLogo layer selected in the Timeline panel, drag the  
Color Emboss effect into the Composition panel. 
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The Color Emboss effect sharpens the edges of objects in the layer without sup-
pressing the original colors. The Effect Controls panel displays the Color Emboss 
effect and its settings below the Drop Shadow effect.

6	 Choose File > Save to save your work.

Applying an animation preset
You’ve positioned the type and applied some effects to it. It’s time to add some ani-
mation! You will learn several ways to animate text in Lesson 3; for now, you’ll use 
a simple animation preset that will fade the words Explore Hawaii onto the screen 
next to the logo. You’ll need to work in the BlueCrabLogo composition  
so that you can apply the animation to only the EXPLORE HAWAII text layer.

1	 Click the BlueCrabLogo tab in the Timeline panel, and select the EXPLORE 
HAWAII layer.

2	 Move the current-time indicator to 1:05, which is the point at which you want 
the text to start fading in.

3	 In the Effects & Presets panel, choose Animation Presets > Text > Animate In.

4	 Drag the Fade Up Words animation preset onto the  
EXPLORE HAWAII layer in the Timeline panel or  
over the words Explore Hawaii in the Composition  
panel. Don’t worry about the text disappearing— 
you’re looking at the first frame of the animation,  
before the words have started to appear.
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5	 Click a blank area of the Timeline panel to deselect the EXPLORE HAWAII layer, 
and then drag the current-time indicator to 2:10 to manually preview the text 
animation. The text appears, one word at a time, until the words Explore Hawaii 
are fully onscreen at 2:10.

Precomposing layers for a new animation
The presentation graphic is coming along nicely, and you’re probably eager to 
preview the complete animation. Before you do, however, you’ll add a dissolve to 
all of the logo elements except the words Explore Hawaii. To do this, you need to 
precompose the other three layers of the BlueCrabLogo composition: text, crab, and 
background. 

Precomposing is a way to nest layers within a composition. Precomposing moves the 
layers to a new composition, which takes the place of the selected layers. When you 
want to change the order in which layer components are rendered, precomposing  
is a quick way to create intermediate levels of nesting in an existing hierarchy.

1	 Shift-click to select the text, crab, and background layers in the BlueCrabLogo 
Timeline panel.

2	 Choose Layer > Pre-compose.

3	 In the Pre-compose dialog box, name the new composition Dissolve_logo. Make 
sure the Move All Attributes Into The New Composition option is selected. Then 
click OK.
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The three layers are replaced in the BlueCrabLogo Timeline panel with a single 
layer, Dissolve_logo. This new, precomposed layer contains the three layers that 
you selected in step 1. You can apply the dissolve effect to it without affecting the 
EXPLORE HAWAII text layer and its Fade Up Words animation.

4	 Make sure the Dissolve_logo layer is selected in the Timeline panel, and press  
the Home key or drag the current-time indicator to 0:00.

5	 In the Effects & Presets panel, choose Animation Presets > Transitions – 
Dissolves, and then drag the Dissolve – Vapor animation preset onto the 
Dissolve_logo layer in the Timeline panel or onto the Composition panel.

The Dissolve – Vapor animation preset includes three components—a master  
dissolve, a box blur, and a solid composite, all of which appear in the Effect Controls 
panel. The default settings are fine for this project.

6	 Choose File > Save.

Previewing the effects
It’s time to preview all of the effects together.

1	 Click the Explore Hawaii tab in the Timeline panel to switch to the main 
composition. Press the Home key or drag the current-time indicator to make 
sure you’re at the beginning of the time ruler.

2	 Make sure the Video switch ( ) is selected for both layers in the Explore Hawaii 
Timeline panel.

EE Tip:  To locate the 
Dissolve – Vapor preset 
quickly, type vap in the 
search box in the Effects 
& Presets panel.
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3	 Click the Play button ( ) in the Preview panel, or press the spacebar, to watch  
the preview. Press the spacebar to stop playback at any time.

Adding transparency
The logo should appear semitransparently in the corner of the frame during the 
presentation. You’ll reduce the opacity of the logo, scale it, and shift its position so 
that it can be used this way.

1	 Still in the Explore Hawaii Timeline panel, go to 2:10.

2	 Select the BlueCrabLogo layer, and press T to display its Opacity property.  
By default, the Opacity is 100%—fully opaque. Click the stopwatch icon ( ) 
to set an Opacity keyframe at this point in time.

3	 Press the End key or drag the current-time indicator to go to the end of the time 
ruler (2:29), and change the Opacity to 40%. After Effects adds a keyframe.

The logo appears, the words Explore Hawaii show up, and it all fades to 40% opacity. 
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4	 Go to 2:10, and press P to display the Position property and then Shift+S to 
display the Scale property, too. Click the stopwatch icons ( ) to set initial 
keyframes for both properties.

5	 Go to 2:25, and change the Scale to 25% and the Positon to 620, 410. 

6	 Click the Play button ( ) in the Preview panel, press the spacebar, or press 0 on 
your numeric keypad to preview your composition. 

7	 Press the spacebar to stop playback when you’re done.

8	 Choose File > Save to save your project.

Rendering the composition
You’re ready to prepare your presentation intro for output. When you create out-
put, the layers of a composition and each layer’s masks, effects, and properties are 
rendered frame by frame into one or more output files or, in the case of an image 
sequence, into a series of consecutive files.

Making a movie from your final composition can take a few minutes or many hours, 
depending on the composition’s frame size, quality, complexity, and compression 
method. When you place your composition in the Render Queue, it becomes a render 
item that uses the render settings assigned to it.

 Note:  For more 
about output formats 
and rendering, see 
Lesson 15, “Rendering 
and Outputting.”
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After Effects provides a variety of formats and compression types for rendering 
output; the format you choose depends on the medium from which you’ll play  
your final output or on the requirements of your hardware, such as a video- 
editing system. 

You’ll render and export the composition so that it can be broadcast on television.

1	 Click the Project tab to bring the Project panel forward. If the Project tab is not 
visible, choose Window > Project. 

2	 Do one of the following to add the composition to the Render Queue:

•	 Select the Explore Hawaii composition in the Project panel, and choose 
Composition > Add To Render Queue. The Render Queue panel  
opens automatically.

•	 Choose Window > Render Queue to open the Render Queue panel, and then 
drag the Explore Hawaii composition from the Project panel onto the Render 
Queue panel.

3	 Click the arrow to expand the Render Settings options. By default, After Effects 
renders compositions with Best Quality and Full Resolution. The default 
settings are fine for this project.

4	 Click the arrow to expand the Output Module options. By default, After Effects 
uses lossless compression to encode the rendered composition into a movie file.
If you’re using Windows, skip to step 5. If you’re using macOS, click the arrow 
next to Lossless, and choose QuickTime DV NTSC 48kHz.

5	 Click the blue words next to the Output To menu.

 Note:  For output to 
final-delivery formats, 
you can use Adobe 
Media Encoder. You’ll 
learn about Adobe 
Media Encoder in 
Lesson 15, “Rendering 
and Outputting.”
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6	 In the Output Movie To dialog box, accept the default movie name (Explore 
Hawaii), select the Lessons/Lesson02/Finished_Project folder for the location, 
and then click Save.

7	 Back in the Render Queue panel, click the Render button. 

After Effects displays a progress bar in the Render Queue panel as it encodes the file, 
and issues an audio alert when all items in the Render Queue have been rendered 
and encoded.

8	 If you want to see your final product, double-click the Explore Hawaii.avi or Explore 
Hawaii.mov file in the Lessons/Lesson02/Finished_Project folder to open it in 
Windows Media Player or QuickTime, and then play the file.

9	 Save and close the project file, and then quit After Effects.

Congratulations. You’ve created a presentation intro suitable for broadcast.
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Review questions
1	 How do you use Adobe Bridge to preview and import files? 

2	 What is precomposing? 

3	 How do you customize an effect?

4	 How do you modify the transparency of a layer in a composition?

Review answers
1	 Choose File > Browse In Bridge to jump from After Effects to Adobe Bridge. If Bridge 

isn’t installed, you’ll be prompted to download and install it. In Bridge, you can search 
for and preview image assets. When you locate the asset you want to use in an After 
Effects project, double-click it or drag it to the Project panel. 

2	 Precomposing is a way to nest layers within a composition. Precomposing moves the 
layers to a new composition, which takes the place of the selected layers. When you 
want to change the order in which layer components are rendered, precomposing is  
a quick way to create intermediate levels of nesting in an existing hierarchy.

3	 After you apply an effect to a layer in a composition, you can customize its properties 
in the Effect Controls panel. This panel opens automatically when you apply the effect,  
or you can open it at any time by selecting the layer with the effect and choosing 
Window > Effect Controls. 

4	 To modify the transparency of a layer, reduce its opacity. Select the layer in the Timeline 
panel, press T to reveal its Opacity property, and enter a value lower than 100%.
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Bridge  70
Bad TV 3 - weak  279
browsing in  

Adobe Bridge  41, 69
customizing  70
Explosion 2  278
Fade Out By Character  79
Fade Up Words  25

Fly in with a Twist  205
Increase Tracking  75
Raining Characters In  74
Ripple  70
Slow Fade On  206
text  69
Typewriter  278

animations
about  22
creating with Character 

Animator  218
duplicating using pick 

whips  153
easing  68
linking through 

expressions  156
repeating  132

animator properties in text 
animator groups  81

application window  10

assets, importing  13

audio
adding tracks  143
animating layers  

to match  114
editing files in  

Adobe Audition  144
file formats supported  143

Audio/Video Switches in the 
Timeline panel  27

Audition. See Adobe Audition

Auto Contrast effect  19–20

Auto Levels effect  257

B

background,  
replacing  234, 252–256

background strokes,  
creating with the  
Roto Brush tool  227–228

Bad TV 3 - weak  
animation preset  279

base frames, creating with  
the Roto Brush tool  224–225

Bend pins
about  208
animating  214
placing  210

Bezier curves
in a motion path  130
in masks  184

Bezier masks, creating  187

bicubic scaling  345

bilinear sampling  345

blending modes
about  194
applying  194
for masks  253, 184

blur, adding  266–267  
See also motion blur, adding

Bridge. See Adobe Bridge

brightness, changing in the 
user interface  35

Browse Presets command  69

Bullet Train  
animation preset  50

C

cached frames, using Roto 
Brush tool  229

cameras, adding  
to a 3D scene  310–311

camera tools  309

Casts Shadows property  315

CC Light Sweep effect  21–22

CC Particle Systems II  
effect  360–370

CC Toner  265–266
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Center Anchor Point In New 
Shape Layers  92

Channel Blur effect  28–29

Character Animator  218

Character panel  25, 47, 65, 306

checkboxes, adding to Motion 
Graphics templates  284–286

child layers  111

Cinema 4D Lite  318–319

Cineware effect  318

circles, drawing  196

Clone tool  269–270

codecs  387

color
adjusting color  

balance  247
animating  106
changing for a shape  93
keying  222
mapping  265–266

color correction
about  244
performing  242–271
previewing accurately  246
using Auto-Levels  256
using the Lumetri Color 

effect  250–251

Color Emboss effect  49

color grading  244, 265–266

Color Range effect  262

Composition Navigator bar  23

Composition panel
about  15
splitting into multiple 

views  308
typing in  65

compositions
about  15
adding footage to  16, 44

creating  15, 43, 61, 275
creating from footage  90
defined  12
fitting layers to  44
importing  13
nesting  16
rendering  54
retiming  167–176

Composition Settings  
dialog box  16–17, 43

compression  387

Content-Aware Fill  355–359

Convert To Editable Text 
command  24, 73, 205

Convert Vertex tool  185–186

copying. See duplicating

Corner Pin effect  161–162

Create Nulls From Paths  
panel  111–112

Create Text And Camera 
command  326

Creative Cloud Libraries
about  119
sharing Motion Graphics 

templates in  288–289

current-time indicator  27

curves, in the Lumetri Color 
effect  251

customizing
brightness of  

the user interface  35
workspaces  34

custom shapes,  
drawing  99–101

Custom View 1,  
in 3D views  309

D

default preferences  3, 11

deforming video  
with Puppet tools  215–216

Deform pins. See Puppet tools

Density value for  
Puppet tools  212

dependencies,  
finding missing  14

depth of field,  
adjusting  333–334

Directional Blur effect  136

Dissolve-Ripple effect  339

distortions,  
rolling shutter  324

docking panels  10

downloading lesson files  4

drawing
circles  365
custom shapes  99
ellipses  196
rounded rectangles  101
shapes  91
stars  92
with the Pen tool  107

drift, in motion tracking  354

dropdown menus, creating  281

Drop Shadow effect  48

drop zone  10

duplicating
animations  132
animations  

using pick whips  153
objects in a scene  269–270
shape layers  95
videos  134

duration
about  26
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E

Easy Ease
adding  68
in the Graph Editor  375

editing
masks  183
Premiere Pro clips  

in After Effects  227
segmentation  

boundaries  228–230
text  24, 46–47, 73

Effect Controls panel
about  48
hiding properties in  22

effects
about  18
applying  49, 135
Auto Contrast  19–20
Auto Levels  257
CC Light Sweep  21–22
CC Particle  

Systems II  360–370
Channel Blur  28–29
Color Emboss  49
Color Range  262–263
controlling  49
Corner Pin  161–162
Directional Blur  136
Dissolve-Ripple  339
Dissolve - Vapor 

animation preset  52–53
Drop Shadow  48
Fade Up Words  26
finding  20
Fractal Noise  136
Gaussian Blur  266, 364
Glow  236
Hue/Saturation  235
Lens Flare  368
missing  14
motion blur  85
Ramp  367

Refine Hard Matte  230
Refine Soft Matte  230
Timewarp  371
Wave Warp  140

Effects & Presets panel  19, 20

Ellipse tool
creating  

a vignette with  196
using to  

create a mask  365, 196

encoding presets in  
Adobe Media Encoder  388

Essential Graphics panel
about  274, 280
adding  

checkboxes to  284–286
adding  

properties to  281–286
editing source text in  281
exporting templates  

from  288–289
grouping properties in  283
in Premiere Pro  289
organizing  283
viewing supported 

properties  282

Essential Graphics  
workspace  280

exporting
Motion Graphics 

templates  288–289
movies with Adobe Media 

Encoder  386–392

expressions  156, 270

extruding text  307–317

F

face tracking  239

Fade Out By Character 
animation preset  79

Fade Up Words  
animation preset  26

fills  93

filtering in Adobe Fonts  63

finding missing footage, fonts, 
or effects  14

Fit To Comp command  44

Fit To Comp Width  
command  66

Fly in with a Twist  
animation preset  205

fonts
finding missing  14
installing from  

Adobe Fonts  2, 62–64
selecting  65

footage
about  13
finding missing  14
importing  12, 14, 148
tracking  324
using Adobe Bridge  

to import  41

foreground strokes,  
creating with the  
Roto Brush tool  225–226

Fractal Noise effect  136

freezing Roto Brush tool 
results  233

G

Gaussian Blur effect  266, 364

Glow effect  236

gradient fills  93

Graph Editor
about  170
using to remap  

time  171–175, 375

grids
displaying and hiding  47, 67
snapping to  67
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ground planes, creating  
with 3D Camera Tracker 
effect  325

grouping properties in the 
Essential Graphics panel  283

guides, showing  48

H

HDR (high dynamic range) 
footage  370

hiding properties  22

Home key  25

Home window  11, 36

Horizontal Type tool  24, 46, 75

Hue/Saturation effect  235

I

Illustrator files,  
importing  44–45

images, adding to 3D scenes 
with 3D Camera Tracker  332

importing
files from Adobe Bridge  42
footage  12, 13, 14, 41, 148
layered Illustrator  

files  44–45
layered Photoshop  

files as compositions   
13, 23, 148–150

multiple files  13
Photoshop files  13, 72, 150
text  72–73

Increase Tracking  
animation preset  75

Increment And Save 
command  235–236

Info panel  13

In points, setting  27, 141

installing
After Effects  2
fonts  62–64

interpolation  
between keyframes  28

J

JavaScript in expressions  156

K

keyframes
about  28, 29
adding  127

keying
about  222
with Color Range effect  262
with Keylight 1.2  

effect  254–255

Keylight 1.2 effect  254–255

L

layer features,  
used when snapping  102

layers
about  15, 17
adjustment  140
animating  146–177, 149
animating to match  

audio  114
child 111
converting to 3D  298
copying  127
expanding in the  

Timeline panel  19
fitting to compositions  44
importing in  

Photoshop files  149
locking  204, 295

making visible  
in the Timeline panel  30

naming in Photoshop  150
naming text  46
nesting  51
parenting  123, 110, 111
precomposing   

51, 99, 125, 266
rearranging in the 

Timeline panel  18
renaming  73
scaling  206
setting In points for  141
shape  88–115, 91
shortening  141
snapping  101
solid  136
text  62
Transform  

properties  18–19
trimming  140, 279

layer styles  155

Layer switches in the Timeline 
panel  27

learning resources for  
Adobe After Effects  6

Learn panel  36

Lens Flare effect  368

lesson files, downloading  4

Levels (Individual Controls) 
effect  248

Libraries panel  119

lighting, simulating changes  
in  151–152, 163–167

lights, adding 3D  303

Light Settings dialog box  314

linked assets  14

linking animations through 
expressions  156

locking layers  204, 295

Lumetri Color effect  250–251
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M

Mask Expansion setting  254

Mask Feather tool  193

mask modes  253–254

masks
about  180
Bezier  184, 187
creating  356–357
creating with the  

Pen tool  163–164, 182
curved  184
drawing with  

shape tools  196
editing  183
feathering  193
inverting  183
modes for  184
modifying with the 

Convert Vertex tool  185
properties, displaying  183
replacing content of  187
segments  180
tips for creating  182
tracking  252
vertices  180
working with  178

mask tracker   
252–253, 260–261

master properties  284

Material Options  
properties  315

mattes
about  222
adjusting with the Refine 

Edge tool  231–232
screen  255
track  156–159, 159
traveling  159
viewing against black  228
viewing with  

red overlay  228

Maxon Cinema  
4D Lite  318–319

Media Encoder.  
See Adobe Media Encoder

meshes
adjusting the  

Density value  212
changing the color of  211
used with Puppet tools  208

missing fonts, effects,  
or footage  14

mobile devices, preparing 
compositions for  384

Mocha AE plug-in  358

modes, mask  184

motion blur, adding  85, 160

Motion Graphics templates
about  274
creating  272–291
exporting  288–289
making source text 

editable in  281
opening in After Effects  288
providing image  

options in  284–286
sharing  274
specifying master 

compositions for  280
using in Premiere Pro  289

motion paths, customizing  129

Motion Source  351

Motion Target  351

motion tracking
analyzing and applying  353
managing drift when  354
single-point  350–356
using track points   

258–260, 263–264

N

navigating folders  
in Adobe Bridge  41

nesting compositions  16, 51

New Composition button  275

New Composition from 
Footage button  90

NTSC D1 preset  43

null objects  111–112

O

Offset Paths in shape layers  97

opacity
animating  77
modifying  53

Opacity property, displaying  29

optimizing performance  
in After Effects  3, 32

Out point  27

output modules in the  
Render Queue panel  55

outputting projects  378–393

overlap, defining areas of  212

Overlap pins  208

overscan  24

P

Pan Behind tool  122

panels
docking and arranging  10
maximizing  12
menus  27

panning with touch  
gestures  188

Paragraph panel  66

paragraph text  62
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parenting
about  111
layers  110, 123
layers to  

null objects  111–112

particle systems,  
creating  360–370

path operations
about  103
Pucker & Bloat  103
Wiggle Paths  93

Pen tool  99, 107, 182

performance, optimizing  3, 32

Photoshop.  
See Adobe Photoshop files

pick whip  153

pixel aspect ratio  392

point of interest
for a camera layer  312

point text  65

position,  
animating  83, 105, 108–109

positioning objects using  
ruler guides  47

Position pins
adding  208–210
animating  214

Position property
displaying in the  

Timeline panel  19

Pre-compose  
dialog box  51, 125

precomposed layers, 
animating  138

precomposing layers   
51, 52, 99, 125, 167–168, 266

preferences
Center Anchor Point  

In New Shape Layers  92
location of files  3

restoring defaults  3
restoring defaults  

in Windows  11

Premiere Pro.  
See Adobe Premiere Pro

presets
browsing in  

Adobe Bridge  69
creating for Adobe  

Media Encoder 389–392
finding  20

previewing
compositions  30
images in Adobe Bridge  42
manually  51

Preview panel
in Adobe Bridge  42
in After Effects  30

Project panel
about  14
opening  55

projects
about  12
saving  15

properties
displaying multiple  127
grouping in the Essential 

Graphics panel  283
hiding  22

Pucker & Bloat  103–104

Puppet tools
about  207
distorting objects  

with  200–219
Puppet Advanced Pin  

tool  208, 210–211
Puppet Bend Pin tool   

208, 210
Puppet Overlap Pin  

tool  208, 212
Puppet Position Pin  

tool  208

Puppet Sketch  
tool  216–217

Puppet Starch Pin  
tool  208, 213–217

recording  
animation with  216

using the mesh  208

Q

QuickTime required version  2

R

Raining Characters In 
animation preset  74

Ramp effect  367

Rectangle tool  196

red overlay in matte  
preview  228

Reduce Chatter value  231

Refine Edge tool  231–232

Refine Hard Matte effect  230

Refine Soft Matte effect  230

reflections, adding  190

remap-time marker in  
the Source Time ruler  170

removing objects  
from footage  355–359

Renderer options  
in the Cineware effect  318

rendering
compositions  54
for mobile devices  384
movies  378–393
templates  385
using compression in  387
using the Render Queue 

panel  238, 381–387
with Adobe Media 

Encoder  386–391
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Render Queue
adding compositions to  55

Render Queue  
panel  238, 385–392

Render Settings options  55

render-settings  
templates  385–389

replacing content  
using a mask  187

replacing objects with 
content-aware fill  355–359

resizing layers  206

resources for using  
After Effects  36

Responsive  
Design - Time  287–288

restoring default  
preferences  3, 11

retiming  
compositions  167–176, 371

Ripple animation preset  70

rolling shutter distortions, 
repairing  324

Roto Brush & Refine Edge 
effect  230

Roto Brush tool
creating background 

strokes  227–228
creating foreground 

strokes  225–226
freezing results  232
refining a segmentation 

boundary  228–230
using  220–241

rotoscoping  222

Rounded Rectangle tool  101

rulers, showing  47

S

safe zones  24

sample text, using  
in Adobe Fonts  63

sampling algorithms  345

saving projects  15

scale
animating  67, 105
modifying  206

screen matte  255

segmentation boundary
about  224
creating  224–227
refining  228

segments in a mask  180

selectors in  
text animator groups  81

Select View Layout  
pop-up menu  308

separating background  
from foreground  222–241

Sequence Layers option  247

shadow catcher  338

shadows
adding to a 3D scene  315
creating with the  

3D Camera Tracker 
effect  337

shape layers
about  88, 90
adding  91
applying fills  

and strokes to  93
centering  

anchor points in  92
creating  91
duplicating  95

shapes
custom  99–101
drawing  91, 99
self-animating  93

Shutter Angle  160

Shutter Phase  160

Slow Fade On  
animation preset  206

snapping
about  102
layers  101–105
temporarily enabling  102

Snap to Grid command  67

solid layers
creating  136
using to create particle 

systems  361
using with 3D Camera 

Tracker  332–333

Solo Supported Properties  
in the Essential Graphics 
panel  282

Source Text property  281

Source Time ruler in time 
remapping  170

Specular Intensity  316

Specular Shininess  316

splitting the Composition panel 
into multiple views  308

squares, drawing  196

squash and stretch  
animation  213

stacked panels  10

Starch pins
about  208
adding  213

Star tool  92
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Stock images  
in Libraries panel  119

strokes  93
tapering  108

Subtract mask mode  254

Sync Selected Fonts  64

T

templates for rendering  
385–389

templates,  
Motion Graphics  280

text
adding  62–67, 276
animating  60–87, 72, 74, 

81, 236–238, 276–278
animating tracking in  75
animation presets  

for  25–26, 69
converting  

to editable  23–24, 73
creating  46
editing  24, 47, 73
editing imported  205
entering in the 

Composition panel  65
extruding  307–308
formatting  65, 236, 276
imported from  

Photoshop  72
layers  62
making editable in Motion 

Graphics templates  281
point  65
positioning  66
text animator groups  80

text layers
converting to editable  205
naming  46

time
current-time field  27
current-time indicator  27
duration  26
protecting  

duration  287–288

timecode  26

time graph  27

time-lapse simulation, 
creating  167

Timeline panel
about  27
expanding layers in  19
renaming layers in  73

Time Remap keyframes  171

Time Remapping  169–173

time ruler  27

Timewarp effect  371–376

title-safe zones  24

Toggle Alpha Boundary 
button  228

Toggle Alpha button  228

Toggle Alpha Overlay  
button  228

Toggle Transparency Grid 
button  233

tools
about  25
Clone Stamp  269–270
drawing  91
Ellipse  196
Pan Behind  122
Puppet  207
Rectangle  196

Tools panel  25

touch gestures  188

Track Camera command  325

Tracker panel  253, 258

tracking
animating for text  75
faces  239
masks  260–261, 356–357
motion  263–264
using Mocha AE  358

tracking motion
single-point  350–356
using the 3D Camera 

Tracker  324–325

tracking points for  
3D Camera Tracker  325

tracking presets  76

track mattes  156–159

Track Motion  258

track points  259–260
moving and resizing  352
positioning  351–353

Transform properties  19

transitions  245–268

transparency  53  
See also opacity

traveling mattes  159

trimming
layers  140, 279

type. See text

Typewriter animation  
preset  278

U

U key  74

undocking panels  10

Use Dimensions From  
menu  16

user interface  10

User Interface Colors  35
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V

vertices
converting  185
in a mask  180

Video switch  30, 52

views, 3D  308

vignettes, adding  195, 267

W

Warp Stabilizer VFX  344–349

Wave Warp effect  140

Web Edition  4

white balance, adjusting with 
the Lumetri Color effect  250

Wiggle Paths  94

work area
brackets  27
introduction to  10

workflow  11

workspaces
about  10
customizing  10, 34
Essential Graphics  280
in Adobe Bridge  42
Learn  36
predefined  33

X

x axis in the 3D axis  298

Y

y axis in the 3D axis  298

Z

z axis in the 3D axis  295, 298

zooming with  
touch gestures  188
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Production Notes
Adobe After Effects Classroom in a Book (2021 release) was created electronically using 
Adobe InDesign. Art was produced using Adobe InDesign, Adobe Illustrator, and 
Adobe Photoshop.

References to company names in the lessons are for demonstration purposes only 
and are not intended to refer to any actual organization or person.

Typefaces used

Adobe Myriad Pro and Adobe Warnock Pro as well as other Adobe typefaces are 
used throughout the lessons. 

Team credits

The following individuals contributed to the development of this book:

•	 Writer: Brie Gyncild

•	 Illustrator and Compositor: Lisa Fridsma

•	 Copyeditor and Proofreader: Wendy Katz

•	 Indexer: Brie Gyncild

•	 Keystroker: Megan Ahearn

•	 Interior design: Mimi Heft

•	 Lesson Designers: Lisa Fridsma, Brie Gyncild

•	 Adobe Press Executive Editor: Laura Norman 

•	 Adobe Press Production Editor: Tracey Croom

•	 Adobe After Effects product team liaison: Victoria Nece

Project contributors

The following artists contributed creative assets for lessons in this book:

•	 Bethany Boshela has been a graphic designer for more than 5 years, with a 
passion for motion graphics. Her work includes local stage and social media 
platforms. You can see more of her work at behance.net/bethanyboshela.

•	 Lee Daniels is a freelance animator, illustrator, and motion graphics artist 
working from his home studio in South London. See more of his work at 
leedanielsart.com.

•	 Stephen Schleicher has worked as an editor, graphic designer, videographer, 
director, and producer on a variety of small and large video productions. Stephen 
is a regular contributor to Digital Media Net (www.digitalmedianet.com).
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http://leedanielsart.com
http://www.digitalmedianet.com
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