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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
files you’ll need to complete the exercises in the book.

1	 Go to peachpit.com/register and sign in or create a new account.

2	 On the Register a Product page, enter ISBN 9780135561430 and click Submit.

3	 Answer the proof-of-purchase challenge question by looking in your book  
for the answer.

4	 Navigate to the Registered Products tab on your Account page to access  
the lesson files.

5	 Click the Access Bonus Content link below the title of your product to proceed 
to the download page. Click the lesson file links to download them to your 
computer.

6 	 The Web Edition can be accessed from the Digital Purchases tab on your 
Account page. Click the Launch link to access the product.

• Note:  If you encounter problems registering your product or accessing the lesson files  
or web edition, go to peachpit.com/support for assistance.

• Note:  If you purchased a digital product directly from peachpit.com, your product will  
already be registered. Look for the Access Bonus Content link on the Registered Products  
tab in your account.

https://peachpit.com/register
https://peachpit.com/support
https://peachpit.com
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USING THE ROTO BRUSH TOOL

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Extract a foreground object from the background using the  
Roto Brush tool.

•	 Correct the segmentation boundary across a span of frames.

•	 Touch up a matte with the Refine Edge tool. 

•	 Freeze a matte across a clip.

•	 Replace a background.

•	 Animate properties for creative effects.

•	 Track a face in footage.

This lesson will take about an hour to complete. If you haven’t already 
done so, download the project files for this lesson, following the instruc-
tions in the Getting Started section under “Accessing the lesson files and 
Web Edition.” 

9
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With the Roto Brush tool, you can quickly separate  
a foreground object from a background across many 
frames. You can achieve professional results in a frac-
tion of the time you’d spend performing the same 
task with traditional rotoscoping.

PROJECT:  WEB BANNER 
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About rotoscoping
When you draw or paint on the frames of a movie, you’re rotoscoping. For example, a 
common use of rotoscoping is to trace an object, using the path as a mask to isolate 
it from the background so you can work with it separately. You could draw masks, ani-
mate the mask paths, and then use the masks to define a matte. (A matte is a mask 
used to hide part of an image so that another image can be superimposed.) While 
effective, this is a time-intensive, tedious process, especially if the object moves a 
great deal or the background is complex.

If a background or foreground object is a consistent, distinct color, you could use 
color keying to separate the object from the background. If the subject was shot 
against a green or blue background (green screen or blue screen), keying is usually 
much easier than rotoscoping. However, keying is less efficient when you’re work-
ing with complex backgrounds.

The Roto Brush tool in After Effects, powered by an AI model, is much faster than 
conventional rotoscoping. You use the Roto Brush tool to define the foreground 
and background elements. Then After Effects creates a matte, and tracks the move-
ment of the matte over time. The Roto Brush tool does much of the work for you, 
leaving only a little cleanup work to be done. 

Getting started
In this lesson, you’ll use the Roto Brush tool to isolate a bird and rock pool so you can 
replace the background. To finish up the project, you’ll add an animated title. 

First, you’ll preview the final movie and set up your project.

1	 Make sure the following files are in the Lessons/Lesson09 folder on your hard 
disk, or download them from peachpit.com now:

•	 In the Assets folder: Chickadee.mov, Facetracking.mov, MillPond.mov

•	 In the Sample_Movie folder: Lesson09.mp4

2	 Open and play the Lesson09.mp4 sample movie in Windows Movies & TV  
or QuickTime Player to see what you will create in this lesson. When you are 
done, close Windows Movies & TV or QuickTime Player. You may delete the 
sample movie from your hard disk if you have limited storage space.

When you begin this lesson, restore the default application settings for After Effects. 
See “Restoring default preferences” on page 3.

3	 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (macOS). In the Startup Repair Options dialog box, 
click Reset Preferences. 

https://peachpit.com


ADOBE AFTER EFFECTS CLASSROOM IN A BOOK 2026 RELEASE  227

4	 Click New Project in the Home window.

After Effects opens to display an empty, untitled project.

5	 Choose File > Save As > Save As.

6	 In the Save As dialog box, navigate to the Lessons/Lesson09/ 
Finished_Project folder.

7	 Name the project Lesson09_Finished.aep, and then click Save.

Creating the composition
You’ll import a footage file and create a composition from it.

1	 Click New Composition From Footage in the Composition panel.

2	 Navigate to the Lessons/Lesson09/Assets folder, select the Chickadee.mov file, and 
then click Import or Open.	

After Effects creates a composition 
named Chickadee, based on the settings 
in the Chickadee.mov file. The composi-
tion is almost three seconds long, with a 
frame size of 1920 x 1080. The movie file 
was shot at a rate of 29.97 frames  
per second. 

3	 Choose File > Save to save the project 
so far.

Creating a segmentation boundary
You use the Roto Brush tool to specify which parts of the clip are in the foreground 
and which are in the background. You add strokes to distinguish the two, and then After 
Effects creates a segmentation boundary between the foreground and background.

Creating a base frame
To use the Roto Brush tool to isolate a foreground object, you start by adding strokes 
to a base frame to identify foreground and background areas. You can start on any 
frame in the clip, but in this exercise, you’ll use the first frame as the base frame. 
First, you’ll add the strokes that identify the bird and the rock pool as the fore-
ground objects.

1	 Move the current-time indicator across the time ruler to preview the footage. 

2	 Press the Home key to move the current-time indicator to the beginning  
of the time ruler.
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3	 Select the Roto Brush tool ( ) in the Tools panel.

You use the Roto Brush tool in the Layer panel, which you’ll open now.

4	 Double-click the Chickadee.mov layer in the Timeline panel to open the clip in the  
Layer panel.

The clip opens in the Layer panel, to the right of the Composition panel.

5	 Choose Fit from the Magnification Ratio pop-up menu at the bottom of the Layer 
panel if you don’t see the entire image clearly.

By default, the Roto Brush tool creates green foreground strokes. You’ll start by adding 
strokes to the foreground—the rock pool and the bird. Generally, it’s most efficient 
to start with broad strokes and then use smaller brushes to refine the border.

6	 Choose Window > Brushes to open 
the Brushes panel. Set up a hard round  
100-pixel brush. (You may need to 
resize the Brushes panel to see the 
options.)

• Note:  The Roto 
Brush tool works best 
at full resolution. If 
After Effects prompts 
you, choose View > 
Resolution > Full.
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When you’re drawing strokes to define the foreground object, follow the skeletal 
structure of the subject. Unlike traditional rotoscoping, you don’t need to define a 
precise boundary around the object. Start with broad strokes, and work down to 
small regions as After Effects determines where the boundary is supposed to be.

7	 Draw a green stroke horizontally across the rock pool.

Roto Brush tool properties appear in the Effect Controls panel. In the Layer panel, 
a magenta outline identifies the boundaries After Effects created for the foreground 
object. After Effects recognized only about half of the pool, because you initially 
sampled only a small area of the subject. You’ll help After Effects find the boundary 
by adding some more foreground strokes. First, you’ll make sure you’re using ver-
sion 3 or later of the Roto Brush tool. 

▶▶ Tip:  You can quickly 
zoom in and out of  
the Layer panel using 
the scroll wheel on your 
mouse, if it has one.
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8	 In the Effect Controls panel, make sure 3.0 or later is selected for the Version.

9	 Still using a large brush, continue to draw green strokes along the inside edges of 
the pool. Do not include the branches directly behind the pool and the bird. Keep 
an eye on the Composition panel to see the effects of your strokes.

10	  Use the Hand tool ( ) to pan to the bird. Then zoom to 100% or 200% to see the 
entire bird clearly.

11	Select the Roto Brush tool again. Then select a smaller brush, and draw a green 
stroke across the bird’s body.

It can be tricky to include some areas without accidentally adding background as 
well. It’s okay if you haven’t captured every detail in the foreground. You’ll use 
background strokes to remove any extraneous areas of the matte.

12	Press Alt (Windows) or Option 
(macOS) to switch to the red 
background stroke brush. Add red 
strokes to background areas you 
want to exclude from the matte. 
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13	Switch back and forth between the foreground and background brushes and brush 
sizes to fine-tune the matte. Don’t forget to deselect the branches directly behind 
the bird and the pool. In some cases, one click may be all it takes to exclude an 
object or area from the matte. 

14	When you’re happy with the bird’s matte, zoom back out and fine-tune any 
remaining areas that need to be addressed with the rock pool.

Editing Adobe Premiere Pro 
clips with After Effects
You can work with a clip in both Adobe Premiere Pro and After Effects, moving  
easily between the two applications as you edit your project. 

To edit an Adobe Premiere Pro clip in After Effects, do the following:

1	 Right-click or Control-click the clip in Adobe Premiere Pro, and choose Replace 
With After Effects Composition. 

After Effects starts, and opens the Adobe Premiere Pro clip.

2	 Save the project when you’re prompted by After Effects. Then, work in the 
composition just as you’d work in any other After Effects project. 

3	 When you’re finished, save the project, and return to Adobe Premiere Pro. 

Your changes are automatically reflected in the timeline.
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Don’t worry about being exact about your brush strokes. Just make sure the matte  
is within 1 to 2 pixels of the edge of the foreground object. You’ll have an opportunity 
to refine the matte later. However, After Effects uses the information on the base 
frame to adjust the matte for the rest of the span, so you want the matte to be accurate. 

15	Click the Toggle Alpha button ( ) at the bottom 
of the Layer panel. The selected area is white 
against a black background, so you can see the 
matte clearly.

16	Click the Toggle Alpha Overlay button ( ) at  
the bottom of the Layer panel. The foreground 
area appears in color, and the background has  
a red overlay.

17	Click the Toggle Alpha Boundary button ( ) at 
the bottom of the Layer panel to see the outline 
around the bird and rock pool again.

As you use the Roto Brush tool, the Alpha Boundary is the best way to see how 
accurate your boundary is, because you can see everything in the frame. However, 
the Alpha and Alpha Overlay options let you see your matte without the distraction 
of the background.

Refining the boundary across the span
You used the Roto Brush tool to create a base frame, which includes a segmentation 
boundary that divides the foreground from the background. The Roto Brush span 
appears below the time ruler at the bottom of the Layer panel. When After Effects 
has propagated the current boundary for a frame, the bar beneath that frame on the 
time ruler is green.

As you move forward and backward through the footage, the segmentation bound-
ary moves with the foreground object (in this case, the bird and the rock pool). 
You’ll step through the frames in the span and make adjustments to the segmentation 
boundary as necessary.

Because the rock pool is stationary, its track matte is consistent throughout the 
span. Given that, we’ll focus on the bird, which moves around a lot.
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1	 Zoom in on the bird, and then make sure the Roto Brush tool is selected in the 
Tools panel. Click the Layer panel to make sure it’s the active panel.

2	 Press the 2 key on your main keyboard (not the numeric keypad) to move forward 
one frame.

Working from the base frame, After Effects tracks the edge of the object and attempts  
to follow its movement. Depending on how complex your foreground and back-
ground elements are, the boundary may or may not conform exactly to the area you 
hoped it would. 

3	 Using the Roto Brush tool, paint foreground and background strokes to refine the 
matte for this frame. If the matte is accurate, you don’t need to paint any strokes.

As you progress through this clip, you’ll notice changes to the segmentation bound-
ary with the bird’s beak. Likewise, you may need to refine the segmentation bound-
ary around the feet and legs.

▶▶ Tip:  To move 
forward one frame, 
press the 2 key on your 
keyboard; to move back 
one frame, press the 
1 key.

• Note:  As it propa-
gates the segmentation 
boundary for a frame, 
After Effects caches that 
frame. Cached frames 
have a green bar in the 
time ruler. If you jump 
ahead to a frame  
further along the span, 
After Effects may take 
longer to calculate  
the boundary.
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4	 Press the 2 key again to move forward to the next frame.

5	 Use the Roto Brush tool to add to the foreground or subtract from the back-
ground as necessary to refine the boundary.

If you make a stroke you don’t like, you can always undo the stroke and try again.  
As you move through the span, each change you make affects the frames after it. 
The more you refine your selection, the better the overall results will be. You may 
find it useful to move forward a few frames to see how changes affect the boundary.

When the bird is moving quickly (such as 0:14 –0:19), you’ll notice that the segmen-
tation boundary becomes more vague, but then “catches up” once the bird slows 
down again. When a frame displays rapid movement, focus on removing areas that 
should be excluded (such as the branch behind the bird), rather than adding blurry 
areas of the bird.

6	 Repeat steps 4 and 5 until you reach the end of the layer.

7 	 Once you’re satisfied with the bird, zoom out to fit the entire screen, and scroll 
though the span, making any adjustments as needed.

8	 When you have completed refining the segmentation boundary for the entire 
layer, choose File > Save to save your work so far.
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Fine-tuning the matte
Roto Brush does a pretty good job, but there may be stray bits of background in the 
matte, or foreground areas that weren’t included. You’ll clean those up by refining 
the edge.

Adjusting the Roto Brush & Refine Edge effect
When you use the Roto Brush tool, After Effects applies the Roto Brush & Refine 
Edge effect to the layer. You can modify the effect using settings in the Effect 
Controls panel. You’ll use those settings to further refine the edge of the matte. 

1	 Press the spacebar to preview the clip. Press the spacebar again  
to end the preview when you’ve seen the whole clip. 

As you preview the clip, you may notice that the segmentation boundary jumps 
around a bit. You’ll adjust the Reduce Chatter and Contrast settings to make it 
smoother.

2	 In the Effect Controls panel, decrease the Contrast to 40% and increase Reduce 
Chatter to 20%. 

The Reduce Chatter value determines how much influence the current frame has 
when performing a weighted average across adjacent frames. Contrast affects how 
tight the boundary is. 

3	 Preview the clip again. 
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Refine Soft Matte and  
Refine Hard Matte effects
After Effects includes two related effects for refining mattes: Refine Soft Matte and 
Refine Hard Matte. The Refine Soft Matte effect does the same thing as Refine Edge 
Matte, except it applies the effect to the entire matte at a constant width. If you 
need to capture subtle variations across an entire matte, use this effect.

The Refine Hard Matte effect performs the same edge refinements as the Roto Brush 
when Fine-Tune Roto Brush Matte is turned on in the Roto Brush & Refine Edge 
effect in the Effect Controls panel.

Using the Refine Edge tool
When an object isn’t smooth, the Roto Brush may not pick up the nuanced edge. 
The Refine Edge tool lets you include fine details such as wisps of hair in designated 
areas of the segmentation boundary. 

Though it might be tempting to use the Refine Edge tool immediately after creat-
ing the base frame, it’s best to wait until you’ve refined the segmentation boundary 
across the entire clip. Because of the way After Effects propagates the segmentation 
boundary, using the Refine Edge tool too early results in a matte that is difficult to use.

1	 Go to the base frame, which is the first frame of the clip, and then zoom in so 
that you can see the edges of the bird’s tail clearly. Use the Hand tool if necessary 
to move the layer so you can see the entire bird.

2	 Select the Refine Edge tool ( ), hidden beneath the Roto Brush tool in the  
Tools panel.

The tail is relatively soft, so a small brush size will work well. For a fuzzier object, 
you might have better results with a much larger brush. The brush needs to overlap 
the stray edges that emerge from the object.

3	 Change the brush size to 5 pixels. 

When you use the Refine Edge tool, draw strokes along the edges of the matte.

4	 In the Layer panel, move the Refine Edge tool over the edge of the tail straddling 
the segmentation boundary and including the variations in the feathers. You can 
use multiple strokes if needed.
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When you release the mouse, After Effects switches to the Refine Edge X-ray view 
so that you can see how the Refine Edge tool changes the matte, capturing the detail 
in the edges. 

5	 Move the current-time indicator across the time ruler to view the edge. At 0:15, 
Refine Edge breaks away from the tail as the bird moves away rapidly. 

6	 Change the brush size to 19 pixels.

7	 At 0:15, press Alt (Windows) or Option (macOS) and erase the artifact from the 
Refine Edge tool, as it’s no longer useful going forward.

8	 Continue to move forward and backward through the scene, applying the Refine 
Edge tool wherever the matte’s edge doesn’t capture the fuzziness of the bird’s 
feathers, and removing it wherever it strays from the tail.

9	 Zoom out to see the entire scene, resize the Layer panel if you enlarged it, and then 
choose File > Save to save your work.

• Note:  Use the  
Refine Edge tool only 
after you have cleaned 
up the matte across the 
entire clip.
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Freezing your Roto Brush tool results
You’ve put a fair amount of time and effort into creating the segmentation boundary 
across the entire clip. After Effects has cached the segmentation boundary so it can 
recall it without having to make the calculations again. To keep that data easily 
accessible, you’ll freeze it. This reduces the processing demands on your system  
so you can work faster in After Effects.

Once the segmentation is frozen, you cannot edit it unless you unfreeze it. Refreezing 
the segmentation is time-consuming, so it’s best to refine the segmentation boundary 
as much as possible before freezing.

1	 Click the Freeze button in the lower right area of the Layer panel. You may need 
to widen the panel to see the button.

After Effects displays a progress bar as it freezes the Roto Brush and Refine Edge tool 
data. Freezing may take a few minutes, depending on your system. As After Effects 
freezes the information for each frame, the cache line turns blue. When it has finished 
freezing, a blue warning bar appears above the time ruler in the Layer panel, remind-
ing you that the segmentation is frozen.

DDepending  
on your system, 
this may take  
a while.
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2	 Click the Toggle Alpha Boundary button ( ) in the Layer panel to see the matte. 
Then click the Toggle Transparency Grid button ( ). Move the time marker across 
the time ruler to see the subject without the distractions of the background.

3	 Click the Toggle Alpha Boundary button again to see the boundary.

4	 Choose File > Save. 

After Effects saves the frozen segmentation information with the project.

Changing the background
There are many reasons to isolate a foreground image from a background. You 
may want to replace the background entirely, moving the subject to a different 
setting. Or you could simply want to change the foreground or background 
without modifying the other. In this lesson, you’ll remove the fenced in area of the 
background, and replace it with a different background, which you’ll enhance with 
color correction tools.

1	 Close the Layer panel to return to the Composition panel, and then move  
the current-time indicator to the beginning of the timeline. Choose Fit from  
the Magnification Ratio pop-up menu at the bottom of the Composition panel.

2	 Hide the properties for the Chickadee.mov layer, if they’re visible.

The Composition panel displays the composition, which includes only the 
Chickadee.mov layer, consisting only of the foreground you isolated from the clip. 

3	 Click the Project tab to display the Project panel, and double-click an empty area 
in the Project panel. Navigate to the Lessons/Lesson09/Assets folder, select the 
MillPond.mov file, and click Import or Open. 
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4	 Drag the MillPond.mov clip from the Project panel to the Timeline panel, and 
place it below the original Chickadee.mov layer.

5	 Click the new layer, press Enter or Return, and rename the layer Mill Pond 
Start. Then press Enter or Return again.

6	 Select the Chickadee layer. Then, using the Selection tool ( ), drag the layer to 
the lower half of the Composition panel. Your values should be similar to ours.

7	 Select the Mill Pond Start layer, and choose Effect > Color Correction >  
Hue/Saturation.

You’ll use the Hue/Saturation effect in two different ways, so you’ll create a duplicate 
layer for the second effect.

8	 With the Mill Pond Start layer selected, choose Edit > Duplicate. Rename the 
bottom layer Mill Pond End. Then rename the top layer to remove the number 2 
from the name (so that its name is Mill Pond Start). 
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9	 Select the Mill Pond Start layer, and then, in the Effect Controls panel, do the 
following:

•	 Select Colorize.

•	 Change Colorize Hue to 56 degrees.

•	 Change Colorize Saturation to 19.

•	 Change Colorize Lightness to −25.

10 	In the Properties panel, click the stopwatch icon for the Opacity value to create 
an initial keyframe at 100%.

11	Go to 1:10, and change the Opacity to 0.
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12	Still at 1:10, select the Mill Pond End layer.

13	 In the Effect Controls panel, click the stopwatch icon for the Channel Range 
property to create an initial keyframe.

14	  Go to the end of the footage (2:25), and change the Master Hue to -30.

15 	Press the spacebar to preview the project. Press the spacebar again when you’ve 
finished.

The background transitions from a monochromatic dusk to a full summer day and 
then again to the beginning of fall as the leaves change.

16	Choose File > Increment And Save. 

If you save incrementally, you can return to earlier versions of your project to make 
adjustments later. This can be very useful if you’re experimenting or want to try 
alternative effects. The Increment And Save feature preserves the previously saved 
version of the project and creates a new project with the same name, with an 
increasing number added to the filename. 

Adding animated text
You’re nearly done. All you need to do is to add the animated title between the bird 
and the background. 

1	 Deselect all layers, and then move the current-time indicator to the beginning  
of the time ruler.

2	 Select the Type tool ( ), and then type Reflections in the Composition panel.
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A new text layer named Reflections appears in the Timeline panel at the top  
of the layer stack.

3	 Select the Reflections layer, and then do the following in the Text section  
of the Properties panel:

•	 Choose Courier New Bold for the font and font style.

•	 Type 300 px for the font size.

•	 Choose Optical from the Kerning menu.

•	 Select white for the Fill color.

•	 Deselect the Stroke checkbox.

4	 Click the More button, and then type 140% for the vertical scale.

5	 Use the Selection tool ( ) to reposition the text to rest along the top edge of  
the rock pool, and then move the Reflections layer below the Chickadee layer.

You’ll animate the text so that it appears on the screen in a liquid motion. 
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6	 Make sure you’re at the beginning of the timeline and the Reflections layer is 
selected. In the Effects & Presets panel, type blur in the search box. Under Text, 
double-click the Blur And Fade In preset. 

7	 Deselect all layers in the Timeline panel, and move the current-time indicator  
to the beginning of the time ruler. Press the spacebar to preview the clip. 

8	 Choose File > Save to save your work.
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Outputting your project
You’ll render your movie to complete the project. 

1	 Choose File > Export > Add To Render Queue.

2	 In the Render Queue panel, click the blue words Best Settings.

3	 In the Render Settings dialog box, choose Half from the Resolution menu, and 
make sure Use Comp’s Frame Rate is selected in the Frame Rate area. Then  
click OK.

4	 Click the blue text next to Output Module. Then, at the bottom of the Output 
Module Settings dialog box, choose Audio Output Off, and click OK.

5	 Click the blue text next to Output To. In the Output Movie To dialog box, 
navigate to the Lessons/Lesson09/Finished_Project folder, and click Save.
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6	 Click Render in the top right corner of the Render Queue panel.

7	 When the project has rendered, save and close it. 

Congratulations! You’ve separated a foreground object from the background, 
replaced and modified the background, and animated some text to complete the 
movie. You’re ready to use the Roto Brush tool on your own projects.
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Extra credit

Tracking faces

The face-tracking feature in After Effects makes it easier to track a face or specific facial features, such 
as lips or eyes. Previously, tracking a face required roto brushing or complex keying. 

• Note:  If you open the Lesson09_extra_credit.aep file, you may need to relink the Facetracking.mov asset.

1	 Choose File > New > New Project.

2	 Click the New Composition From Footage button in the Composition panel, and then navigate  
to the Lessons/Lesson09/Assets folder. Select the Facetracking.mov file, and click Import or Open.

3	 Select the Facetracking.mov layer in the Timeline panel. Then, select the Ellipse tool, hidden by the 
Rectangle tool in the Tools panel. 

4	 Drag an elliptical mask roughly covering the face.

5	 Right-click the Mask 1 layer, and choose Track Mask. 

6	 In the Tracker panel, choose Face Tracking (Outline Only) from the Method menu. 

The Face Tracking (Outline Only) option tracks the entire face. The Face Tracking (Detailed Features) 
option tracks the outline plus the lips, eyes, and other distinctive facial features. You can export 
detailed facial data for use in Character Animator, or you can use it in After Effects to apply effects  
or to match it with another layer, such as an eye patch or a hat.

(continued on next page)
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Sidebar head
Sidebar Text

Extra credit (continued)

7	 Click the Track Forward button in the Tracker panel. 

The Tracker tracks the face, changing the mask’s shape and position as the face moves. 

8	 Press the Home key to return to the beginning of the timeline, and then move the current-time 
indicator across the time ruler to see how the mask moves with the face.

9	 In the Effects & Presets panel, search for Bright. Then drag the Brightness & Contrast effect onto 
the Facetracking.mov layer in the Timeline panel.

10	 Expand Effects > Brightness & Contrast > Compositing Options in the Timeline panel. 

11	 Click the + icon next to Compositing Options. Choose Mask 1 from the Mask Reference 1 menu, 
and increase Brightness to 50.

The masked area of the face brightens, but nothing else does. This setting is too bright, and the edge 
of the mask is too abrupt. You’ll make it more subtle. 

12	 Reduce the Brightness to 20. 

13	 Expand the Mask 1 properties. Change the Mask Feather property to 70, 70 pixels. 

14	 Save the project to the Lessons/Lesson09/Finished_Project folder. Then close the file.

You can use the face tracker to blur a face, brighten it, or add any other effect. You can also invert  
the mask to affect everything but the face. 
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Review Questions
1	 Review uses Number List

Review questions
1	 When should you use the Roto Brush tool?

2	 What is the segmentation boundary?

3	 When should you use the Refine Edge tool?

Review answers
1	 Use the Roto Brush tool any time you would have used traditional rotoscoping.  

It’s particularly useful for removing a foreground element from the background.

2	 The segmentation boundary is the boundary between the foreground and background. 
The Roto Brush tool adjusts the segmentation boundary as you progress through the 
frames in the Roto Brush span.

3	 Use the Refine Edge tool when you need to rotoscope objects with fuzzy or wispy edges. 
The Refine Edge tool creates partial transparency for areas of fine detail, such as hair. 
Use the Refine Edge tool only after you’ve adjusted the segmentation boundary across 
the entire clip.
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INDEX

SYMBOLS

3D

adjusting depth of field  341

cameras  319–320, 333–334

camera tools  313

channel effects  325

features  300–327

ground plane  306

importing objects  308

layers  302

lights  315

materials  304–306

meshes  303–307

point of interest  321

Real-time Draft 3D  
preview mode  306

views  312–313

3D Camera Tracker effect  330–348

3D meshes

applying materials to  304–306

creating  303–307

Cube tool  304

3D models, importing  308–309

3D text

creating  310

extruding  311

3D Transform Gizmo  309

.mogrt files  294

A

activating fonts  
in Adobe Fonts  2, 64–66

adjustment layers  51, 144, 287

Adobe After Effects application

installing  2

optimizing performance in  3

workspace  10

Adobe After Effects Classroom  
in a Book 2026 Release

downloading lesson files  4

prerequisites  2

Adobe After Effects Help  38

Adobe Audition  148

Adobe Bridge

about  72

browsing animation presets in  73

importing files with  72

installing  2

Adobe Character Animator  222

Adobe Fonts  2, 64–90

Adobe Illustrator files, importing  46
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Adobe Media Encoder

creating presets  
for  402–405

encoding presets in  400

installing  2

rendering output  
with  398–403

Adobe Photoshop files

importing  14, 154

importing layer styles  
from  159

importing text from  75

layered  153

Adobe Premiere

Motion Graphics 
templates in  297

using with  
After Effects  231

Adobe Stock  123

Advanced pins

about  212

animating  218

placing  214

using to animate  
video  219–220

alpha track mattes.  
See track mattes

ambient lights, adding  347

Analyze Forward button  365

anchor points

adjusting  125

centering in  
shape layers  96

animating

facial expressions  222

fill color  109

layers  150–183

layers to match audio  118

lighting  155–156, 167–171

on a path  132

opacity  26, 80

position  25, 87–89, 107

precomposed layers  143

Puppet tool pins  220

scale  25, 69, 107

text  62–91, 75, 85

video with  
Puppet tools  219–220

animation presets

applying  27–28, 52, 54

Bad TV 3 - weak  288

browsing in  
Adobe Bridge  73

customizing  74

Explosion 2  286

Fade Out By Character  83

Fade Up Words  27

Fly in with a Twist  209

Increase Tracking  79

Raining Characters In  77

Ripple  73

Slow Fade On  210

Smooth Move In  52

text  71

Typewriter  286

animations

about  23

creating with Character 
Animator  222

duplicating using  
pick whips  157

easing  71

linking through 
expressions  160

repeating  137

animator properties in text 
animator groups  85

application window  10

assets, importing  13

audio

adding tracks  147

animating layers  
to match  118

editing files in  
Adobe Audition  148

file formats supported  147

Audio/Video Switches  
in the Timeline panel  24

Audition. See Adobe Audition

Auto Contrast effect   
30–31, 259–260, 266

B

background,  
replacing  239, 262–265

background strokes,  
creating with the Roto 
Brush tool  230–231

Bad TV 3 - weak  
animation preset  288

base frames, creating with the 
Roto Brush tool  227–228

Bend pins

about  212

animating  218

placing  214
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Bezier curves

in a motion path  134

in masks  190

Bezier masks, creating  192

bicubic scaling  353

bilinear sampling  353

Black Clip  266

blending modes

about  200

applying  200

for masks  189, 263

blur, adding.  
See motion blur, adding

Bridge. See Adobe Bridge

Brightness and Contrast  
effect  273–274

brightness, changing  
in the user interface  37

Browse Presets command  73

C

cached frames, using  
Roto Brush tool  233

cameras, adding  
to a 3D scene  319–320

CC Light Sweep effect  31–32

CC Particle Systems II  
effect  371–382

Center Anchor Point  
In New Shape Layers  96

Character Animator  222

Character panel  21, 48, 67

child layers  114

Cinema 4D Lite  326

circles, drawing  201

cloning objects  266–270

codecs  396

collaboration tools  37

color

animating  109

changing for a shape  96

correcting  252–279

correcting using  
Auto Contrast  265

grading  252

keying  226

Color Emboss effect  51

Colorizing an image  260–262

Composition Navigator bar  19

Composition panel

about  15

typing in  67

Composition Profiler  171

compositions

about  15

adding footage to  17, 44

creating  15, 43–44, 63, 283

creating from footage  94

defined  12

duration of  44

fitting layers to  45

importing  13

nesting  17, 19

rendering  56

retiming  172–181

Composition Settings  
dialog box  17–18, 44

compression  396

Content-Aware Fill  367–371

contrast, adjusting  259–260

Convert To Editable Text 
command  19, 76, 209

Convert Vertex tool  191–192

copying. See duplicating

Corner Pin effect  165–166

Create Nulls From Paths  
panel  114–115

Create Text And Camera 
command  334

Creative Cloud Libraries

about  123

sharing Motion Graphics 
templates in  294–295

Cube tool  304

current-time indicator  24

customizing

brightness of the  
user interface  37

workspaces  36

custom shapes,  
drawing  102–104

Custom View 1,  
in 3D views  313
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D

default preferences  3, 11

deforming video with  
Puppet tools  219–220

Deform pins.  
See Puppet tools

Density value for  
Puppet tools  216

dependencies,  
finding missing  14

depth of field,  
adjusting  341–342

Directional Blur effect  141

Dissolve-Ripple effect  347

distortions,  
rolling shutter  332

docking panels  10

Dolly controls  313

downloading lesson files  4

drawing

3D meshes  303–307

circles  377

custom shapes  102

ellipses  201

rounded rectangles  104

shapes  95

stars  96

with the Pen tool  110

drift, in motion tracking  367

Drop Shadow effect  49

drop shadows  32–33

drop zone  10

duotones, creating  260–262

duplicating

animations  137

animations using  
pick whips  157

shape layers  99

videos  139

duration

about  28

setting for composition  44

E

Easy Ease

adding  71

in the Graph Editor  387

editing

imported text  19

masks  189

Premiere Pro clips  
in After Effects  231

segmentation  
boundaries  232–235

text  47–48, 76

Effect Controls panel

about  50

hiding properties in  31

effects

applying  51, 140

Auto Contrast  30–31, 266

Brightness and  
Contrast  273–274

CC Light Sweep  31–32

CC Particle  
Systems II  371–382

Color Emboss  51

controlling  51

Corner Pin  165–166

Directional Blur  141

disabling third-party  406

Dissolve-Ripple  347

Dissolve - Vapor animation 
preset  54–55

Drop Shadow  49

Fade Up Words  28

Fractal Noise  141

Gaussian Blur  376

Hue/Saturation   
240, 257–259, 260–262

Lens Flare  380

missing  14

motion blur  89

Ramp  379

Refine Hard Matte  236

Refine Soft Matte  236

Timewarp  383

Wave Warp  144

Ellipse tool

creating a vignette with  201

using to create  
a mask  201, 377

encoding presets in  
Adobe Media Encoder  400

Essential Graphics panel

about  282, 288

adding properties  
to  289–294

editing source text in  289
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exporting templates  
from  294–295

grouping properties in  291

in Premiere  297

organizing  291

viewing supported 
properties  290

Essential Graphics  
workspace  289

essential properties  296

exporting

Motion Graphics 
templates  294–295

movies with Adobe Media 
Encoder  398–404

expressions  160, 269

extruding text  311

F

face tracking  247

Fade Out By Character 
animation preset  83

Fade Up Words animation 
preset  28

files, importing  11

fills  96

filtering in Adobe Fonts  65

finding missing footage, fonts, 
or effects  14

Fit To Comp command  45

Fit To Comp Width  
command  68

Fly in with a Twist animation 
preset  209

folders, in Project panel  331

fonts

finding missing  14

installing from  
Adobe Fonts  2, 64–66

selecting  67

footage

about  13

finding missing  14, 406

importing  12, 14, 152

tracking  332

foreground strokes,  
creating with the  
Roto Brush tool  228–229

formatting text  67–68

Fractal Noise effect  141

freezing

frames  274, 276–277

Roto Brush tool results  
238

G

Gaussian Blur effect  376

gradient fills  96

Graph Editor

about  176

using to remap  
time  177–181, 387

grids

displaying and hiding  48, 69

snapping to  69

ground plane, viewing in 3D 
projects  306

guides, showing  49

H

HDR (high dynamic range) 
footage  382

hiding properties  31

Home window  11, 38

Horizontal Type tool  20, 47, 78

Hue/Saturation effect   
240, 257–259, 260–262

I

Illustrator files,  
importing  45–46

images

adding to 3D scenes with 
3D Camera Tracker  340

in motion graphics 
templates  292

importing

3D objects  308

footage  12, 13, 14, 152

layered Illustrator  
files  45–46

layered Photoshop files  
as compositions   
13, 18, 152–154

multiple files  13

Photoshop files  13, 75, 154

text  75–76

Increase Tracking animation 
preset  79
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Increment And Save 
command  242

In points, setting  24, 145

installing

After Effects  2

fonts  64–66

J

JavaScript in expressions  160

K

keyframes

adding  131

labels  136

keying  226

L

labeling keyframes  136

layers

about  15, 17

adjustment  144

animating  150–183, 153

animating to  
match audio  118

child  114, 126

copying  130

expanding in the  
Timeline panel  22

fitting to compositions  45

importing in  
Photoshop files  153

isolating  165

locking  208

naming in Photoshop  154

naming text  47

nesting  53

parenting  113, 114, 126

precomposing   
53, 102, 128, 274–275

rearranging in  
the Timeline panel  18

renaming  76

scaling  210

setting In points for  145

shape  92–119, 95

shortening  145

snapping  104

solid  140, 169

soloing  165

splitting with Scene Edit 
Detection  254–255

text  64

Transform  
properties  22–23

trimming  145, 287

layer styles  159

Layer switches in  
the Timeline panel  24

learning resources for  
Adobe After Effects  6

Learn panel  38

length of composition  44

Lens Flare effect  380

lesson files, downloading  4

Libraries panel  123

lighting, simulating changes  
in  155–156, 167–171

lights, adding 3D  315

Light Settings dialog box  316

linked assets  14

linking animations  
through expressions  160

locking layers  208

M

Mask Feather tool  198

masks

about  186

Bezier  190, 192

creating  368–369

creating with the  
Pen tool  167–168, 188

curved  190

drawing with  
shape tools  201

editing  189

feathering  198

inverting  189

modes  169, 189, 263–264

modifying with the 
Convert Vertex tool  191

properties, displaying  189

replacing content of  192

segments  186

tips for creating  188

tracking  262

tracking faces  247

vertices  186

mask tracker  262–264

Material Options  
properties  318
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mattes

about  226

adjusting with the Refine 
Edge tool  236–237

track  160–163, 163

traveling  163

viewing against black  232

viewing with  
red overlay  232

Maxon Cinema 4D  
Lite  326–327

Media Encoder.  
See Adobe Media Encoder

meshes, 3D  303–307

meshes for Puppet tools  212

adjusting the Density  
value  216

changing the color of  215

missing fonts, effects,  
or footage  14, 406

mobile devices, preparing 
compositions for  401

Mocha AE plug-in  371

modes, mask  189

motion blur, adding  89, 164

Motion Graphics templates

about  282

creating  280–299

exporting  294–295

grouping properties in  291

making source text 
editable in  289

opening in After Effects  294

replacing images in  292

sharing  282

specifying master 
compositions for  288

using in Premiere  297

motion paths,  
customizing  132

Motion Source  364

Motion Target  364

motion tracking

analyzing and applying  365

managing drift when  367

single-point  360–366

N

nesting compositions  17, 53

New Composition button  283

New Composition from 
Footage button  94

NTSC D1 preset  44

null objects  114–115

O

Offset Paths in shape layers  101

opacity

animating  26, 80, 195

modifying  55

optimizing performance  
in After Effects  3, 34

Orbit tools  313

Out point  24

output modules in the  
Render Queue panel  57

outputting projects  390–405

overlap, defining areas of  216

Overlap pins  212

P

Pan Behind tool  126

panels

docking and arranging  10

maximizing  12

menus  24

panning with touch  
gestures  193

Pan tools  313

paragraph text  64

Parametric Mesh  
tools  303–307

parenting

about  114

layers  113, 126

layers to null  
objects  114–115

particle systems,  
creating  371–382

Paste Text Formatting Only 
command  87

path operations

about  106

Pucker & Bloat  106

Wiggle Paths  97

Pen tool  102, 110, 188

performance, optimizing  3, 34
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Photoshop.  
See Adobe Photoshop files

pick whip  157

pixel aspect ratio  404

point of interest  321

point text  67

position, animating  25, 87, 107

positioning objects using  
ruler guides  48

Position pins

adding  212–214

animating  218

Position property  22

Pre-compose  
dialog box  53, 129

precomposed layers, 
animating  143

precomposing layers  53, 102, 
128, 173–174, 274–275

preferences

location of files  3

restoring defaults  3, 11, 406

Premiere. See Adobe Premiere

presets

browsing in  
Adobe Bridge  73

creating for Adobe Media 
Encoder  402–405

previewing

compositions  29

manually  53

Preview panel  29

Project panel

about  14

creating folders in  331

opening  57

projects

about  12

saving  15

Properties panel

about  21

essential properties in  296

formatting text in  67

shape settings in  103

Pucker & Bloat  106–107

Puppet tools

about  211

distorting objects  
with  204–223

Puppet Advanced Pin  
tool  212, 214–215

Puppet Bend Pin  
tool  212, 214

Puppet Overlap Pin  
tool  212, 216

Puppet Position Pin  
tool  212

Puppet Sketch  
tool  220–221

Puppet Starch Pin  
tool  212, 217–221

recording animation  
with  220

using the mesh  212

Q

QuickTime  2

R

Raining Characters In 
animation preset  77

Ramp effect  379

recording puppet pin 
animation  220

Rectangle tool  201

red overlay in matte  
preview  232

Reduce Chatter value  235

Refine Edge tool  236–237

Refine Hard Matte effect  236

Refine Soft Matte effect  236

reflections, adding  195

remap-time marker in  
the Source Time ruler  175

removing objects from  
footage  367–371

rendering

compositions  56–58

default settings for  57

for mobile devices  401

movies  390–405

templates  397

using compression in  396

using the Render Queue 
panel  246, 393–399

with Adobe Media 
Encoder  398–403

Render Queue  
panel  245, 397–404

adding compositions to  57
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Render Settings options  57

render-settings  
templates  397–401

render times,  
by layer  171, 406

replacing

backgrounds  262–265

content using a mask  192

content with content-aware 
fill  367–371

resetting preferences  406

resizing layers  210

resources for  
using After Effects  38

Responsive Design -  
Time  293–294

restoring default  
preferences  3, 11

retiming  
compositions  172–181, 383

Ripple animation preset  73

rolling shutter distortions, 
repairing  332

Roto Brush & Refine Edge 
effect  235

Roto Brush tool

creating background 
strokes  230–231

creating foreground 
strokes  228–229

freezing results  238

refining a segmentation 
boundary  232–235

using  224–249

rotoscoping  226

Rounded Rectangle tool  104

rulers, showing  48

S

Safe Mode  406

sampling algorithms  353

saturation, adjusting  257–259

saving projects  15

scale

animating  25, 69, 107

modifying  210

Scene Edit Detection  254–255

segmentation  
boundary  227–230

segments in a mask  186

selectors in text animator 
groups  85

Select View Layout pop-up 
menu  312

separating background from 
foreground  226–249

Sequence Layers  
command  277

shadow catcher  347

shadows

adding to a 3D scene  318

creating with the 3D 
Camera Tracker  
effect  345

simulating  195

shape layers

about  92, 94

applying fills  
and strokes to  96

centering anchor  
points in  96

creating  95

duplicating  99

settings in Properties  
panel  103

shapes

custom  102–104

drawing  95, 102

self-animating  97

shared projects  37

Shutter Angle  164

Shutter Phase  164

Slow Fade On animation 
preset  210

Smooth Move In animation 
preset  52

snapping layers  104–108

Snap to Grid command  69

solid layers

creating  140, 169

using to create particle 
systems  373

using with 3D Camera 
Tracker  340–341

soloing layers  165

Solo Supported Properties  
in the Essential Graphics 
panel  290



416  INDEX

soundtrack, adding  147

Source Text property  289

Source Time ruler in time 
remapping  175

Specular Intensity  318

Specular Shininess  318

split layers by scene  254

squares, drawing  201

squash and stretch  
animation  217

stabilizing video  352–359

stacked panels  10

Starch pins

about  212

adding  217

Star tool  96

Startup Repair Options  
dialog box  406

Stock images in Libraries 
panel  123

strokes  97

tapering  111

Substance Materials  304–306

Sync Selected Fonts  66

T

team projects  37

templates

for rendering  397–401

Motion Graphics  288–289

text

3D  310–311

adding  64–69, 284

animating  62–91, 75,  
85, 242–244, 284–286

animating tracking in  78

animation presets  
for  27–28, 71

converting to  
editable  18–19, 76, 209

copying formatting from 
existing layer  87

creating  47

editing  48, 76

editing imported  209

entering in the 
Composition panel  67

formatting  67–68, 284

imported from  
Photoshop  75

layers  64

making editable in Motion 
Graphics templates  289

naming layers  47

point  67

positioning  68

settings in the Properties 
panel  67, 310

text animator groups  84

time. See also Timewarp effect

current-time indicator  24

duration  28

freezing frames  276–277

protecting  
duration  293–294

remapping  174–178

ruler  24

timecode  28

time graph  24

time-lapse simulation, 
creating  172

Timeline panel

about  24

expanding layers in  22

renaming layers in  76

Time Remap keyframes  177

Timewarp effect  383–388

Toggle Alpha Boundary 
button  232
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Toggle Alpha button  232

Toggle Alpha Overlay  
button  232

Toggle Transparency Grid 
button  239

Tools panel  20

touch gestures  193

Track Camera command  333

Tracker panel  264

tracking in type, animating  78

tracking motion

faces  247

single-point  360–366

using Mocha AE  371

using the 3D Camera 
Tracker  332–333

with masks  368–369

tracking presets  79

track mattes  160–163

track points

for 3D Camera Tracker  333

moving and resizing  363

positioning  362–364

Transform properties  22

transitions between  
scenes  276–277

transparency. See opacity

traveling mattes  163

trimming layers  145, 287

tutorials, accessing  6, 38

type. See text

Typewriter animation  
preset  286

U

U key  77

undocking panels  10

Use Dimensions From  
menu  16

user interface

about  10

customizing brightness  37

V

vertices

converting  191

in a mask  186

Video switch  54

views, 3D  312

vignettes, adding  200, 271

W

Warp Stabilizer VFX  352–359

Wave Warp effect  144

Web Edition  4

White Clip  266

Wiggle Paths  97

work area

brackets  24

introduction to  10

workflow  11

workspaces

about  10

customizing  10, 36

Essential Graphics  289

Learn  38

predefined  35

Z

zooming with touch  
gestures  193
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