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iIntroduction
Microsoft Power BI is a leading business intelligence platform that enables individuals 
and organizations to transform raw data into actionable insights. With Power BI, you 
can connect to a wide variety of data sources, clean and transform the data, model it 
effectively, and create interactive reports and dashboards that communicate insights 
clearly. Power BI also integrates seamlessly with the Microsoft ecosystem, including 
Excel, Teams, PowerPoint, and now Copilot, making it a key tool for modern, data-driven 
decision-making.

This book is part of the Step by Step series, designed to guide you through the funda-
mentals of Power BI with clear explanations and practical, hands-on exercises. Whether 
you are new to data analysis or already familiar with Microsoft tools, this book provides 
the knowledge and skills you need to confidently use Power BI for your own projects.

Who this book is for
Microsoft Power BI Step by Step is written for beginning to intermediate users who want 
to learn how to analyze, visualize, and share data effectively. If you have experience with 
Excel or other Microsoft applications but are new to Power BI, this book will help you get 
started and progress to more advanced scenarios at your own pace.

This book is ideal for

■■ Business analysts and data analysts who need to transform and visualize data

■■ Excel power users who want to expand their skills into modern BI tools

■■ IT professionals and consultants who need to support business users with 
reporting

■■ Students, researchers, and small business owners who want to make data-driven 
decisions

xvii
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At the same time, this book goes beyond the basics. In addition to covering the core 
skills every Power BI user needs, it includes a dedicated chapter on advanced topics 
and best practices, providing guidance on performance tuning, row-level security 
(RLS), and scalable design. In addition, a full chapter on Copilot in Power BI shows how 
AI can accelerate tasks such as preparing data, generating DAX formulas, and creating 
effective visualizations. These advanced sections ensure that you gain not only solid 
foundational skills but also practical knowledge to take your Power BI projects to the 
next level.

How this book is organized
This book is divided into 13 chapters: 

■■ Chapter 1, Introduction to Power BI, provides an overview of the Power BI eco-
system, its main components, and its role in the business intelligence landscape.

■■ Chapter 2, Setting up Power BI, covers the installation and initial configuration 
of Power BI Desktop, including an introduction to the interface and essential 
settings.

■■ Chapter 3, Importing data, explores the Power Query Editor, shows how to  
connect to common data sources, explains storage modes, and describes  
privacy levels.

■■ Chapter 4, Transforming data with Power Query, focuses on cleaning and 
shaping data by defining data types, applying transformations, adjusting table 
structures, and combining queries to prepare reliable datasets for analysis.

■■ Chapter 5, Creating a simple semantic model, explains how to define relation-
ships, manage filters and hierarchies, and customize the semantic model.

■■ Chapter 6, Performing basic calculations with DAX, introduces the DAX 
formula language and shows how to create simple measures and calculated 
columns.

■■ Chapter 7, Building your first report, explains how to create an interactive 
report by adding and customizing visuals, applying slicers and filters, and  
organizing the layout for clarity.
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■■ Chapter 8, Designing advanced visualizations, explores complex visuals such 
as maps, scatter plots, decomposition trees, and small multiples.

■■ Chapter 9, Enhancing reports, covers techniques to improve design and  
interactivity, including themes, bookmarks, tooltips, and mobile layouts.

■■ Chapter 10, Publishing and sharing reports, explains how to publish reports 
to the Power BI Service, configure scheduled refreshes, and collaborate in 
workspaces.

■■ Chapter 11, Creating dashboards, shows how to combine content from mul-
tiple reports into dashboards, add comments, and configure data alerts.

■■ Chapter 12, Applying advanced topics and best practices, discusses row-level 
security (RLS), performance tuning, DAX optimization, and visualization best 
practices.

■■ Chapter 13, Exploring Copilot in Power BI, demonstrates how AI can assist in 
preparing data, generating DAX formulas, and recommending visuals both in 
Power BI Desktop and the Service.

The structure of these chapters allows you to learn the basics step by step if you are 
new to Power BI. If you are already familiar with data analysis, you can focus on the 
chapters that are most relevant to your needs. Each topic is self-contained, so you can 
follow the book from start to finish or jump directly to the skills you want to acquire.

At the end of each chapter, you will also find a series of practice tasks that allow you 
to apply the skills introduced in the chapter.

Download the practice files
Before you can complete the exercises in this book, you need to download the book’s 
practice files to your computer. These practice files can be downloaded from the 
Downloads tab on the following page:

MicrosoftPressStore.com/powerbiSBS/downloads

IMPORTANT  To complete the practice tasks in this book, you need to have Power BI 
Desktop installed on your computer. You can download it free from the Microsoft Store 

or from the official Power BI website.
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The following table lists the practice files for this book.

Chapter File

Chapter 3: Importing data Financial Sample.xlsx

Sales folder with five .CSV files.

Chapter 4: Transforming data with 
Power Query

Applying columnar transformations.xlsx

Changing table structures.xlsx

Combining and appending tables.xlsx

Chapter 5: Creating a simple 
semantic model

customer.csv

date.csv

product.csv

sales.csv

store.csv

Chapter 6: Performing basic 
calculations with DAX

DAX Practice file.pbix

Chapter 7: Building your first report Report practice file.pbix

Chapter 9: Enhancing reports Enhancing reports practice file.pbix

Get support and give feedback
The following sections provide information about getting help with this book and 
contacting us to provide feedback or report errors.

Errata
We’ve made every effort to ensure the accuracy of this book and its companion con-
tent. Any errors that have been reported since this book was published are listed at:

MicrosoftPressStore.com/powerbiSBS/errata

If you discover an error that is not already listed, please submit it to us at the same page.

For additional book support and information, please visit MicrosoftPressStore.com/
Support.

Please note that product support for Microsoft software and hardware is not offered 
through the previous addresses. For help with Microsoft software or hardware, visit 
support.microsoft.com.



Practice files
No practice files are necessary to complete the practice 
tasks in this chapter.

In this chapter, you’ll learn how to get started with Power 
BI Desktop, the main application used for creating reports 
and semantic models in Power BI. Power BI Desktop is a 
free Windows application that provides everything you 
need to design, build, and publish powerful data visualiza-
tions. It’s the starting point for most Power BI projects and 
is used by analysts, developers, and business users alike.

This chapter will walk through the different ways to install 
Power BI Desktop, review the system requirements, and 
explore what happens the first time you launch the app. 
You’ll also become familiar with the user interface and 
learn how to configure a few key settings to optimize 
your experience.

Install and set up Power BI 
Desktop
Before building your first report, you’ll need to install 
Power BI Desktop. In this section, you’ll learn the two 
installation methods, how to verify that your computer 
meets the system requirements, and what to expect the 
first time you launch the application.

2Setting up 
Power BI

In this chapter
■■ Install and set up Power BI 

Desktop

■■ Explore Power BI Desktop 
interface

■■ Configure Power BI Desktop 
settings

13



Install from the Microsoft Store
The most recommended and easiest way to install Power BI Desktop is from Microsoft 
Store. You don’t need administrator permissions, and updates are performed  
automatically, ensuring you always have the latest version.

To install

1.	 Open your browser and go to the Power BI Desktop page in the Microsoft Store.

2.	 Select Install to download and install the app.

Install Power BI Desktop listing from Microsoft Store.

Power BI Desktop installation options
You can install Power BI Desktop in two ways:

1.	 Install from the Microsoft Store.

2.	 Download an executable file (.exe) from the Power BI website.

Both options will give you the latest version, but they work slightly differently and 
offer different advantages.

IMPORTANT  Power BI Desktop is updated every month, incorporating community 
feedback, new features, performance improvements, and visual enhancements.

Chapter 2: Setting up Power BI
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3.	 After it is installed, you can launch Power BI Desktop from the Start menu or 
directly from the Microsoft Store. 

TIP  You can also access the Microsoft Store link from the Power BI service. Just select 
the Download icon in the upper-right corner; then select Power BI Desktop.

Accessing Microsoft Store from Power BI Service.

Installing from the Microsoft Store is the easiest and most convenient option. It  
provides automatic updates, does not require administrator rights, simplifies imple-
mentation across the organization, and reduces the download size by updating only 
the modified components. It also automatically detects your system language and 
applies it to both the interface and the data model.

 

TIP  Installing Power BI Desktop from the Microsoft Store doesn’t copy user settings 
from the .exe version. You might have to reconnect to your recent data sources and 

reenter your credentials.

 

TIP  If you use SAP connectors, you might need to move driver files manually to  
C:\Windows\System32.

Install and set up Power BI Desktop
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Download as an executable file
If you prefer not to use the Microsoft Store, you can download the .exe installer from 
the Power BI Download Center.

To install

1.	 Visit the Power BI Desktop Download Center page.

2.	 Use the dropdown list to choose the language for the installation file and select 
Download.

Download Power BI Desktop from the Microsoft Download Center.

3.	 Select the appropriate version and select Download.

Power BI Desktop download options.

Chapter 2: Setting up Power BI
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IMPORTANT  Microsoft announced the end of support for the 32-bit version of Power 
BI Desktop on July 31, 2025. Only the 64-bit version is now available; it offers better 

performance and is compatible with most modern systems.

4.	 Once the download is complete, double-click the file to run the installer and 
click Next.

Power BI Desktop Setup wizard.

5.	 Windows will ask you to allow the app to make changes to your device. Click 
Yes to continue with the installation.

IMPORTANT  You must have administrator privileges to complete this step.

6.	 You’ll be asked to accept the Microsoft Software License Terms. Review the 
license agreement. To proceed, you must check the box I accept the terms in 
the License Agreement and then select Next.

7.	 Choose the Installation Folder and select Next.

Install and set up Power BI Desktop
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Destination Folder.

8.	 You’ll see a summary screen confirming you’re ready to install Power BI Desk-
top. Here, you can also choose whether to create a desktop shortcut (enabled 
by default). Select Install to begin the process.

Installing Power BI Desktop.

Chapter 2: Setting up Power BI
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IMPORTANT  Do not install both the Microsoft Store version and the executable 
version at the same time. Uninstall one before switching to the other.

Downloading Power BI Desktop as an executable file offers greater flexibility and 
control, allows portable installations, and supports command-line deployment. This 
executable file can be reused on multiple computers. In addition, it can provide access 
to previous versions for compatibility or testing purposes, which is especially useful 
for advanced users or enterprise environments.

System requirements
Before installing, check that your PC meets the minimum requirements.

 
IMPORTANT  Power BI Desktop is no longer supported on Windows 8.1 or earlier.

Requirement Details

Operating system Windows 10, Windows Server 2016 or later

.NET .NET 4.7.2 or later

Memory (RAM) Minimum 2 GB, 4 GB or more recommended

Display resolution At least 1440x900 (16:9); lower resolutions are not supported

CPU 1 GHz or faster, 64-bit processor or better recommended

WebView2 runtime Required. If not installed, download from Microsoft Edge 
Developer page

IMPORTANT  Power BI Desktop is available only for Windows. If you’re using a Mac, 
you can access the Power BI Service through a web browser to view and interact with 

published reports. If you need to create or model data, you can run Power BI Desktop using a 
virtual machine or Windows emulator.

Start Power BI Desktop

 

IMPORTANT  After you launch the installation package, Power BI Desktop installs  
as a standard Windows application that you can launch from the Start menu like any 

other app.

Install and set up Power BI Desktop
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When you open Power BI Desktop for the first time, a welcome screen appears, 
designed to help you quickly begin your work. At the top, under the heading “Select 
a data source or start with a blank report,” you’ll see several common options such as 
starting with a Blank report or connecting to a OneLake catalog, an Excel workbook, a 
SQL Server, or even sample data. If you don’t see the source you need, you can select 
Get data from other sources to access the full list of available connectors.

SEE ALSO  To learn how to connect to and import data from these sources, see  
Chapter 3, “Importing data.”

Below that list, a Recommended section offers helpful resources to get you started, 
like tutorials or Power BI content that links to Microsoft learning material. At the 
bottom of the screen, the Recent and Shared with me tabs help you reopen reports 
you’ve worked on or that others have shared with you.

Start Power BI Desktop.

If this is a fresh install (not an upgrade), you may be asked to

■■ Sign in with a work or school account.

■■ Fill out a short form to proceed without signing in.

After that, you’re ready to build and publish your first report.

Chapter 2: Setting up Power BI

20



2

Sign in to Power BI Desktop
You can use Power BI Desktop without signing in, even if you don’t have a Power BI 
user license. However, the following features require that you sign in with a valid work 
or school account:

■■ Connect to online data sources (e.g., SharePoint Online, Microsoft Dataverse).

■■ Publish reports to the Power BI Service.

■■ Use tenant-specific features like organizational visuals.

■■ Apply sensitivity labels or access other premium capabilities.

 

TIP  If you’re just learning or building reports locally, you can skip the sign-in process. 
But when you’re ready to share, you’ll need to be signed in.

To sign in

1.	 In the top-right corner of Power BI Desktop, select Sign in.

2.	 Enter your work or school email address.

IMPORTANT  Power BI does not support personal email accounts such as @gmail.com,  
@outlook.com, or @yahoo.com for sign-in. You must use a valid work or school account.

3.	 Complete the login process (typically through your organization’s  
Microsoft 365 portal).

4.	 After you’re signed in, you will see your profile picture or initials in the top-right 
corner of the window.

TIP  You can also sign out or switch accounts anytime by selecting your profile icon in 
the same location.

Explore Power BI Desktop interface
Power BI Desktop offers a clean and intuitive interface designed to guide you through 
the process of building reports.

Explore Power BI Desktop interface
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Main elements of the Power BI Desktop interface
Power BI Desktop is organized into distinct interface elements that support the report 
creation process. Each part of the interface serves a specific function, whether for 
designing visuals, modeling data, or navigating your report. The following sections 
describe the key areas of the Power BI Desktop interface.

Canvas
The canvas is the central workspace in Power BI Desktop where you build and design 
your reports. It’s a blank page where you drag fields, insert visuals, and arrange  
content to tell a story with your data. You can create multiple pages within a report, 
each with its own layout and visuals.

Report Canvas.

Ribbon
The ribbon is the toolbar located at the top of Power BI Desktop. Each tab is  
organized by function, making it easy to navigate and find the commands you  
need while building your reports. If you’ve used applications like Microsoft Excel or 
PowerPoint, the Power BI layout will feel familiar.

Chapter 2: Setting up Power BI
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Power BI Desktop ribbon.

Let’s explore each tab on the ribbon and its main features:

■■ Home: This tab is your starting point in Power BI Desktop. It includes the most 
used commands for managing your reports, data, and visuals. From here, you 
can connect to various data sources, refresh and transform data using the 
Power Query Editor, and publish reports to the Power BI Service. The tab also 
includes basic editing actions such as undo, redo, and copy/paste, as well as 
access to tools such as Copilot and the visual gallery.

■■ Insert: This tab allows you to add new elements to your report canvas, such as 
visuals, images, text boxes, and shapes. This tab also enables you to add  
buttons, such as navigation arrows, bookmarks, Q&A triggers, and slicer 
controls to enhance interactivity. Additionally, you can insert new report pages 
to better organize your report.

■■ Modeling: This tab is the place where you define the logic of your data 
model. You can create new tables, columns, and measures using Data Analysis 
Expressions (DAX), define relationships between tables, mark a table as a date 
table, and create parameters. This tab also includes security features, such as 
row-level security (RLS), to manage user-level access.

 

TIP  The Modeling tab becomes essential after your data is loaded and you’re ready to 
structure it for analysis.

Explore Power BI Desktop interface
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■■ View: This tab allows you customize the overall appearance and layout of your 
report. You can apply different themes for color consistency, use the Selection 
and Bookmarks panes to manage visibility and interactivity, and control the 
display of items like gridlines. Additionally, you can open the Performance  
Analyzer to evaluate how efficiently your report loads and runs.

■■ Optimize: This tab focuses on performance tuning and report efficiency. It 
provides tools to pause and refresh visuals, manage query reduction settings, 
apply or clear slicers, and run the Performance Analyzer.

SEE ALSO  For more details on performance tuning, see Chapter 12, “Applying 
advanced topics and best practices.”

■■ External Tools: On this tab, you’ll find tools like DAX Studio or Tabular Editor, 
which offer extended capabilities beyond Power BI Desktop’s native functions. 
Experienced developers use these functions to perform detailed modeling, 
advanced DAX authoring, or version control.

■■ Help: This tab provides easy access to Power BI documentation, tutorials, and 
community support. From here, you can find learning resources, report issues, 
and explore updates or training materials.

Power BI Panels
Power BI Desktop includes several panels that help you manage your data, customize 
visuals, and control what is displayed in your reports. These panels are located on 
the right side of the interface and are essential for building and refining your report 
content.

■■ Data Pane: This pane shows all the data tables and fields you’ve loaded into 
your report. You can expand tables to see individual columns, measures, and 
hierarchies. Just drag and drop any field from here onto the canvas to use it in a 
visual. You can also right-click to rename, hide, or create new fields.

■■ Build Pane: This pane is essential for customizing how your data is displayed. 
Here you can choose the type of chart or visual you want to use, such as bar 
charts, pie charts, maps, cards, or tables. After selecting a visual, use the same 
pane to assign fields to different parts of the chart and format it with colors, 
labels, and more.

Chapter 2: Setting up Power BI
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■■ Filters Pane: This pane enables you to control what data appears in your report. 
You can filter data at the visual, page, or report level. Just drag a field into the 
filter area and choose your filter options. This pane makes it easy to tailor the 
view for different users or use cases without changing the main visuals.

 

TIP  Although you can add slicers to the report for user interaction (we’ll cover this 
topic later in Chapter 7, “Building Your First Report”), the Filters pane allows you to 

apply filters in the background. It’s especially useful for applying filters that you don’t need to 
see or interact with, such as hiding specific categories or limiting the report to a date range.

Power BI panels.

TIP  By default, Power BI Desktop displays the Filters, Build, and Data panes on the 
right side of the screen. Depending on the size of your screen or the selected visual, 

some panes may be collapsed or hidden. Select their icons to show or hide them as needed.

Pages Tab
The Pages tab, located at the bottom of the canvas, allows you to add and manage 
multiple report pages, just like slides in PowerPoint. Each page can show a different 
perspective of your data. You can rename pages, duplicate them, or rearrange their 
order to create a logical flow for your report.

Explore Power BI Desktop interface
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Power BI Desktop Views
Power BI Desktop offers four main views, each designed for a specific part of the 
report creation process. You can switch between them using the icons on the left 
sidebar.

■■ Report View: This is the default view where you design your reports using 
visuals. You’ll use this view most of the time to drag fields, add charts, and  
format your report layout.

■■ Data View: This view shows your data in table form, similar to Excel. It’s 
useful for reviewing imported data, calculating columns, or verifying your 
transformations.

■■ Model View: This view allows you to create and manage relationships between 
tables. It’s essential when you’re working with multiple data sources or building 
a complex data model.

■■ DAX Query View: This advanced view lets you write and run DAX queries 
to explore or troubleshoot your data model. It’s helpful for users with more 
technical needs or deeper analysis.

Power BI views.

Chapter 2: Setting up Power BI

26



2

Configure Power BI Desktop settings
Before you begin working on your first report, it’s a good idea to review a few 
optional settings that can improve your experience with Power BI Desktop. You don’t 
need to make changes right away, but knowing where to find these settings will be 
useful as you advance.

To access the settings, select File > Options and settings > Options.

The Options window organizes settings into two main categories in the left menu:

■■ Global: Applies to all files and Power BI Desktop in general

■■ Current File: Applies only to the report you are currently working on

Power BI configuration.

Configure Power BI Desktop settings
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Recommended setup options
To ensure a smoother and more personalized experience while working in Power BI 
Desktop, let’s explore some recommended setup options that help optimize function-
ality, improve usability, and protect your work.

Enable preview features
Power BI frequently releases experimental features that you can try as they become 
officially available. To enable them, select File > Options and settings > Options > 
Preview features and check any features you’d like to activate.

 

TIP  You must restart Power BI Desktop to apply the changes.

Set regional settings
Under Current File > Regional Settings, you can specify your locale. This setting  
controls how dates, numbers, and currencies are displayed in your reports. Choose 
the region that matches your preferred formatting.

Enable autosave
To avoid losing your work, you can turn on Autosave. To do so, select Current File >  
Save and enable autosave. You can also configure how frequently Power BI saves 
your work automatically.

Check your Power BI Desktop version
To find out which version of Power BI Desktop you are using, select Help > About >  
Version Information. This information is helpful when you’re troubleshooting or 
checking compatibility with certain features.

Chapter 2: Setting up Power BI
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Power BI version.

Knowing your current version is especially useful when

■■ Troubleshooting issues: If you encounter unexpected behavior or errors, 
support resources often need to know your version number to assist you 
accurately.

■■ Matching documentation: Power BI updates monthly, and features may 
appear, change, or be deprecated. Verifying your version helps ensure you’re 
following guidance that aligns with your software.

■■ Collaborating with others: Teams using different versions may notice inconsis-
tencies in features or visual behavior, so aligning versions ensures a smoother 
workflow.

■■ Accessing the latest features: If you’re missing a feature mentioned in this 
book or elsewhere, checking your version is the first step to confirming whether 
an update is needed.

 

TIP  Always use the latest version of Power BI Desktop to benefit from performance 
improvements, new features, and bug fixes. The Microsoft Store version updates 

automatically, but if you installed it via the executable file, you’ll need to check for updates 
manually. 

 

Configure Power BI Desktop settings
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Skills review
In this chapter, you learned how to

■■ Install Power BI Desktop using either the Microsoft Store or the executable 
(.exe) installer from the Power BI website and understand the benefits and  
limitations of each installation method.

■■ Verify your system requirements to ensure your device is compatible with 
Power BI Desktop and supports optimal performance.

■■ Launch Power BI Desktop for the first time and sign in with a valid work or 
school account to access cloud-based features.

■■ Navigate the Power BI Desktop interface, including the report canvas, ribbon, 
views (Report, Data, Model, and DAX Query), and the Filters, Build, and Data 
panes to build, customize, and explore your reports effectively.

■■ Configure Power BI Desktop settings and check your Power BI version.

Chapter 2: Setting up Power BI
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Practice tasks
No practice files are necessary to complete the practice tasks in this 
chapter.

Install and set up Power BI Desktop
Before you can start using Power BI, you’ll need to install the application on your 
computer. Follow these steps to choose the right version and complete the setup 
process:

1.	 Choose and complete an installation method. Visit the Power BI website 
and decide whether to install the Microsoft Store version or download the 
executable file (.exe). Follow the steps outlined in this chapter to complete the 
installation on your device.

2.	 Check your version. After installing Power BI Desktop, select Help > About and 
note the version number currently installed.

Explore Power BI Desktop interface
After Power BI Desktop is installed, it’s helpful to become familiar with its interface. 
The following steps will guide you through the key areas of the workspace so you can 
navigate it with confidence:

1.	 Launch Power BI Desktop. Open the Start menu and then select Power BI 
Desktop. Take a moment to examine the welcome screen and available data 
source options.

2.	 Familiarize yourself with the interface. Open Power BI Desktop and take a few 
minutes to explore the layout. Hover over different areas of the screen and 
identify the main elements of the interface, including the ribbon, the report 
canvas, and the Fields, Visualizations, and Filters panes on the right side.

3.	 On the left sidebar, locate the buttons that switch between Report, Data, 
Model, and DAX Query views.
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Configure Power BI Desktop settings
To get the most out of Power BI Desktop, you may want to adjust certain settings. The 
following steps will help you personalize your experience and enable useful features:

1.	 Access the Options menu. Select File > Options and settings > Options.

2.	 Enable preview features (optional). Under Preview features, turn on any  
feature you’d like to explore. Remember to restart Power BI Desktop to apply 
the changes.

3.	 Review your regional settings. Under Current File > Regional Settings, select 
the appropriate locale for your reports.

4.	 Check autosave options. Under Current File > Save, ensure autosave is enabled 
and adjust the autosave frequency if needed.
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Index
Symbols
@mentions, 223

A
active relationships, 90–91
aggregation functions, DAX, 107–110
aggregations, multi-column, 109–110
AI (artificial intelligence), semantic models, 

272–276
alerts, dashboards, 224–226
All category (Get Data dialog), 36
ALLSELECTED function, 114
animated visuals, 257
anomalies, 167–168
apps, publishing and distributing, 209–211
area charts, Report view, 129
assigning, roles, 238–239
Autosave, 28
Azure category (Get Data dialog), 36

B
basic syntax, DAX, 105–107
BI (business intelligence), 1
bidirectional relationships, 251
bookmarks, reports, 190–192
Build pane (Desktop), 24
business users, Copilot, 268
buttons, reports, 183–185

C
CALCULATE function, 112–117
calculated columns, DAX, 102–103
calculated tables, DAX, 104
canvas

Desktop, 22
Service, 203

capacities, Power BI, 199
cardinality

high, 243–244
relationships, 84

cards, Report view, 133–137
categories, decomposition trees, 160–163
certified visuals, 257
charts

line, 165–168
Report view, 137–145
scatter, patterns, 157–160

collaboration, workspaces, 208–209
Column charts, Report view, 128–129
Column tools, 91–96
columnar transformations, Power Query, 61–62
columns

combining, Power Query, 65–66
pivoting, 73–74
unpivoting, 71–72

comments, dashboards, 221–223
common data sources, connecting, 40
comparisons, displaying multiple, 163–165
conditional calculations, DAX, 110–111
configuration, Desktop, 27–28
contribution charts, Report view, 130
Copilot, 265–266

configuration, 269–272
data queries, 285–287
DAX queries, 280–281
Desktop, 276
narrative visuals, 278–280, 285
pane, 266–268
report creation, 276–278
report pages, creating, 284
reports, summaries, 284–285
roles, 268–269
Service, 282–286

COUNT aggregation function, 108
COUNTROWS aggregation function, 108
CSV files, data extraction, 40–44

D
dashboards, 215

building from reports, 215–216
comments, 221–223
designing, 259–262
permissions, 212
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sharing, 205–212
tiles, 216–219

customizing, 219–221
data alerts, 224–226
insights, 226–228

data alerts, dashboards, 224–226
data analysts, 9
Data category setting (Column tools tab), 91–96
data cleansing, Power Query, 60
data extraction, 36–51
Data groups setting (Column tools tab), 91–96
data model owners, Copilot, 268
Data pane (Desktop), 24
data quality, Power Query, 60
data refreshes, scheduling, 203–205
Data setting (Column tools tab), 91–96
data sources

connecting, 40
relational, data extraction, 46–48

data types, Power Query, 61
Data view (Desktop), 26
data visualizations, 253–254
data volume, reducing, 241–244
Database category (Get Data dialog), 36
DAX

aggregation functions, 107–110
CALCULATE function, 112–117
calculated columns, 102–103
calculated tables, 104
common functions, 105–107
conditional calculations, 110–111
data visualizations, 253–254
execution framework, 102
expressions, 101

writing efficient, 251–262
formulas, descriptions, 282
functions, 252–253
measures, 103
multi-column aggregations, 109–110
queries, Copilot, 280–281
variables, 251–252
visual calculations, 104–105

integration, 117–119
writing basic syntax, 105–107

DAX Query view (Desktop), 26
decomposition trees, 160–163
DENSE function, 118
descriptive names, 248–249

Desktop, 1, 5–6, 13
canvas, 22
configuring, 27–28
Copilot, 276
installation, 14–19
interface, 21–26
Pages tab, 25
panels, 24–25
Performance Analyzer, 257–259
ribbon, 22–24
roles

assigning, 238–239
defining, 234–238
testing, 238

starting, 19–21
system requirements, 19
versions, 28–30
views, 26

developers, 9
dimension tables, 84
dimensional modeling, 83
DirectQuery storage mode, 52–53
DISTINCTCOUNT aggregation function, 108
distribution, apps, 209–211
DIVIDE function, 117
drillthrough pages, reports, 180–182
Dual (Composite) storage mode, 52–53
duplicate values, removing, Power Query, 63–64

E
email accounts, support, 21
end users, 9
Entra B2B (Business-to-Business) accounts, 211
Excel, data extraction, 40–44
executable files, Desktop installation, 16–19
execution framework, DAX, 102
expressions

DAX, 101
writing efficient, 251–262

External Tools tab (Desktop ribbon), 24

F
Fabric, 3
fact tables, 84
field parameters, reports, 186–190
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fields, hiding unnecessary, 249
File category (Get Data dialog), 36
filters, applying, 145–148
Filters pane, 24–25, 126–128
folders, data extraction, 44–46
forecasting, 166–167
Format pane, Report view, 145–148
Format setting (Column tools tab), 91–96
formulas

descriptions, 282
variables, 251–252

functions, costly and complex, 252–253

G
Gartner Quadrant, 4
geographic data, visualizing using maps, 154–157
Get Data feature, 36–51
granularity, reducing, 241–244
grouping data, Power Query, 70–71

H
hierarchical visualization, Report view, 132
high cardinality, 243–244
Home tab (Desktop ribbon), 23
hybrid models, 250

I
images, reports, 183–185
Import storage mode, 52–53
inactive relationships, 90–91
Insert tab (Desktop ribbon), 23
insights

dashboard tiles, 226–228
showing with tooltips and field parameters, 

186–190
installation, Desktop, 14–19
interactions, optimizing, 254–255
interface, Power Query Editor, 35–36
intermediary queries, Power Query, 242

K
KEEPFILTERS function, 116
key indicators, Report view, 131

L
layouts

organizing, 145–148
semantic model, 96–97

Left Navigation pane (Service), 202
licenses, Power BI, 197–199
line charts, 165–168

Report view, 137–142
lines, Report view, 129
layouts, reports, 192–194

M
many-to-many relationships, 250–251
maps, visualizing geographic data, 154–157
matrices, optimization, 256–259
measures

breaking down, 160–163
DAX, 103
zero values, 252

metrics
emphasizing key, 261
Report view, 131

Microsoft Fabric. see Fabric
Microsoft Fabric category (Get Data dialog), 36
Microsoft Store, Desktop installation, 14–15
Mobile, 1, 8–9
Model view (Desktop), 26
Modeling tab (Desktop ribbon), 23
models. see semantic models
multi-column aggregations, DAX, 109–110

N
Name setting (Column tools tab), 91–96
names, descriptive, 248–249
narrative text, 167–168
narrative visuals

Copilot, 285
creating, Copilot, 278–280

O
online services, data extraction, 51
Online Services category (Get Data dialog), 36
Optimize tab (Desktop ribbon), 24
ORDERBY function, 118
Organizational privacy level, 53
Other category (Get Data dialog), 36
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P
Pages tab (Desktop), 25
panels (Desktop), 24–25
patterns, scatter charts, revealing, 157–160
Performance Analyzer, 257–259
permissions, reports, 212
personal email accounts, support, 21
Power BI, 1–3, 198–201. see also Desktop

capacities, 199
complex transformations, 244
Desktop, 1, 5–6, 13

installation, 14–19
licenses, 197–199
Mobile, 1, 8–9
personal email accounts, 21
publishing reports, 201–212
roles, 9–10
Service, 1, 6–8
Service account, configuring, 200–201
star schema, 248
subscriptions, 197–199
workspaces, 199

Power Platform category (Get Data dialog), 36
Power Query, 59–60

changing table structures, 71–78
columnar transformations, 61–62
combining columns, 65–66
complex transformations, 244
data cleansing, 60
data quality, 60
data summary, 249–250
data types, 61, 245
example columns, 69–70
filling missing content, 62–63
grouping data, 70–71
intermediary queries, 242
queries, renaming, 244
query folding, 246–247
removing duplicates, 63–64
replacing values, 67–69
staging, 242
steps

consolidation, 245
renaming, 244

text extraction, 66–67
Power Query Editor, 34
PPU (Premium Per User), Power BI, 198
Premium Per User (PPU), Power BI, 198
Preview features option, 28

PREVIOUS function, 117
privacy levels, 53–54
Private privacy level, 53
proportion charts, Report view, 130
Public privacy level, 53
publishing

apps, 209–211
reports, 201–212

Q
Qlik, 4
queries

Copilot, 285–287
DAX, Copilot, 280–281
renaming, 244

query folding, 48
leveraging, 246–247

R
relational data sources, data extraction, 46–48
relationship charts, Report view, 130
relationships

active, 90–91
bidirectional, 251
cardinality, 84
defining tables, 84–86
differentiating table types, 86–89
inactive, 90–91
many-to-many, 250–251
optimization, 250–251
semantic models, 84–91

REMOVEFILTERS function, 114
renaming queries and steps, 244
report authors, Copilot, 268
report creators, 9
Report view, 26, 123–126

area charts, 129
cards, 133–137
Column charts, 128–129
contribution charts, 130
filters, applying, 145–148
Filters pane, 126–128
hierarchical visualization, 132
key indicators, 131
layouts, organizing, 145–148
line charts, 137–142
lines, 129



testing
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metrics, 131
proportion charts, 130
relationship charts, 130
ribbon charts, 143
slicers, 132–133

applying, 145–148
stacked bar charts, 142–143
stacked column charts, 145
treemaps, 144
trend analysis, 130
tubular visualization, 132
visual objects, 128, 133

reports
applying themes, 176–180
bookmarks, 190–192
building dashboards from, 215–216
creating, Copilot, 276–278
data volume, reducing, 241–244
drillthrough pages, 180–182
field parameters, 186–190
granularity, reducing, 241–244
insights, 186–190
layouts, 192–194
permissions, 212
publishing, 201–212
RLS (row-level security), 233–234
sharing, 205–212
summaries, creating, 284–285
tooltips, 186–190
trigger actions, 183–185

ribbon (Desktop), 22–24
ribbon charts, Report view, 143
RLS (row-level security), 233–234
roles

assigning, 238–239
Copilot, 268–269
Desktop, defining, 234–238
testing

Desktop, 238
Service, 239–241

row-level security (RLS), 233–234

S
scatter charts, revealing patterns, 157–160
scheduling, data refreshes, 203–205
semantic models, 81–82

AI (artificial intelligence), 272–276
customizing, 91–96
dimension tables, 84

fact tables, 84
layouts, 96–97
multiple tables, 83–84
optimization, 247
relationships, 84–91

optimization, 250–251
single table, 82-83

Service, 1, 6–8
account, configuring, 200–201
Copilot, 282–286
navigating, 202–203
roles, testing, 239–241
sharing reports, 205–212

shapes, reports, 183–185
sharing, reports, 205–212
slicers, 189

optimization, 255
Report view, applying, 145–148

slow visuals, troubleshooting, 257–259
small multiples, 163–165
Sort by column setting (Column tools tab), 91–96
stacked bar charts, Report view, 142–143
stacked column charts, Report view, 144
staging, Power Query, 242
star schema, design, 248
steps

consolidation, 245
renaming, 244

storage modes, 51–53
subscriptions, Power BI, 197–199
summaries, reports, creating, 284–285
Summarization setting (Column tools tab), 91–96

T
Tableau, 4
tables

appending, 76–78
changing structures, 71–78
combining, 74–76
dimension, 84
fact, 84
optimization, 256–259
relationships

defining, 84–86
differentiating types, 86–89

testing
roles

Desktop, 238
Service, 239–241
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text extraction, Power Query, 66–67
themes, reports, applying, 176–180
tiles

dashboards, 216–219
customizing, 219–221
data alerts, 224–226
insights, 226–228

tooltips, reports, 186–190
Top Bar, Service, 203
transformations, Power BI, 244
treemaps, Report view, 144
trend analysis, Report view, 130
trend lines, 165–166
trigger actions, reports, 183–185
tubular visualization, Report view, 132

U
unpivoting columns, 71–72
UNRELATIONSHIP function, 116

V
variables

comparing, 157–160
DAX formulas, 251–252

View Native Query, 247
View tab (Desktop ribbon), 24
views, Desktop, 26
visual calculations, DAX, 104–105

integration, 117–119

visual objects, Report view, 133
visualizations

animated, 257
breaking down measures, 160–163
certified, 257
comments, 223
data, 253–254
decomposition trees, 160–163
displaying multiple comparisons, 163–165
geographic data, 154–157
hierarchical, 132
line charts, 165–168
narrative, creating, 278–280
narrative text, 167–168
scatter charts, revealing patterns, 157–160
troubleshooting slow, 257–259
tubular, 132
variable comparisons, 157–160

W
webpages, data extraction, 48–50
workspaces

collaboration, 208–209
Power BI, 199

writing, expressions, 251–262

Z
zero values, measures with no data, 252–253
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