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Adobe After Effects CC provides a comprehensive set of 2D and 3D tools  
for compositing, animation, and effects that motion-graphics professionals, 
visual effects artists, web designers, and film and video professionals need.  
After Effects is widely used for digital post-production of film, video, DVD,  
and the web. You can composite layers in various ways, apply and combine 
sophisticated visual and audio effects, and animate both objects and effects.

About Classroom in a Book
Adobe After Effects CC Classroom in a Book (2014 release) is part of the official 
training series for Adobe graphics and publishing software, developed with the 
support of Adobe product experts. The lessons are designed to let you learn 
at your own pace. If you’re new to Adobe After Effects, you’ll learn the funda-
mental concepts and features you’ll need to master the program. And if you’ve 
been using Adobe After Effects for a while, you’ll find that Classroom in a Book 
teaches many advanced features, including tips and techniques for using the 
latest version.

Although each lesson provides step-by-step instructions for creating a specific 
project, there’s room for exploration and experimentation. You can follow  
the book from start to finish, or do only the lessons that match your interests 
and needs. Each lesson concludes with a review section summarizing what 
you’ve covered.

GETTING STARTED



2  GETTING STARTED

Prerequisites
Before beginning to use Adobe After Effects CC Classroom in a Book (2014 release), 
make sure that your system is set up correctly and that you’ve installed the required 
software and hardware. You should have a working knowledge of your computer and 
operating system. You should know how to use the mouse and standard menus and 
commands, and also how to open, save, and close files. If you need to review these 
techniques, see the printed or online documentation included with your Microsoft® 
Windows® or Apple® Mac® OS software.

To complete the lessons in this book, you’ll need to have both Adobe After Effects 
CC (2014 release) and Adobe Bridge CC installed. The exercises in this book are 
based on After Effects CC (2014.1 release) but can be used with After Effects CC 
(2014 release) as well.

Installing After Effects and Bridge
You must purchase the Adobe After Effects CC software separately. For system 
requirements and complete instructions on installing the software, visit  
http://helpx.adobe.com/support.html. Note that After Effects CC requires a 
64-bit operating system and OpenGL 2.0 support. You must also have Apple 
QuickTime 7.6.6 or later installed on your system.

Many of the lessons in this book use Adobe Bridge. After Effects and Bridge use 
separate installers. You must install these applications from Adobe Creative Cloud 
(creative.adobe.com) onto your hard disk. Follow the onscreen instructions.

Optimizing performance
Creating movies is memory-intensive work for a desktop computer. After Effects CC 
(2014 release) requires a minimum of 4GB of RAM. The more RAM that is available 
to After Effects, the faster the application will work for you. For information about 
optimizing memory, cache, and other settings for After Effects, see “Improve per-
formance” in After Effects Help.

Restoring default preferences
The preferences files control the way the After Effects user interface appears on 
your screen. The instructions in this book assume that you see the default interface 
when they describe the appearance of tools, options, windows, panels, and so forth. 

http://helpx.adobe.com/support.html
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Therefore, it’s a good idea to restore the default preferences, especially if you are 
new to After Effects.

Each time you quit After Effects, the panel positions and certain command settings 
are recorded in the preferences files. To restore the original default settings, press 
Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while starting 
After Effects. (After Effects creates new preferences files if they don’t already exist 
the next time you start the program.)

Restoring the default preferences can be especially helpful if someone has already 
customized After Effects on your computer. If your copy of After Effects hasn’t been 
used yet, these files won’t exist, so this procedure is unnecessary.

Important: If you want to save the current settings, you can rename a preferences 
file instead of deleting it. When you are ready to restore those settings, change the 
name back, and make sure that the file is located in the correct preferences folder.

1	 Locate the After Effects preferences folder on your computer:

•	 For Windows: .../Users/<user name>/AppData/Roaming/Adobe/
AfterEffects/13.1

•	 For Mac OS: .../Users/<user name>/Library/Preferences/Adobe/
After Effects/13.1 

2	 Rename any preferences files you want to preserve, and then restart After Effects.

Accessing the Classroom in a Book files
The lessons in Adobe After Effects CC Classroom in a Book (2014 release) use specific 
source files, such as image files created in Adobe Photoshop® and Adobe Illustrator®, 
audio files, and prepared QuickTime movies. To complete the lessons in this book, 
you need to download the lesson files from peachpit.com. You can download the 
files for individual lessons, or download them all in a single file.

Your Account page is also where you’ll find any updates to the chapters or to the lesson 
files. Look on the Lesson & Update Files tab to access the most current content. 

To access the Classroom in a Book files, do the following:

1	 On a desktop or laptop computer, go to www.peachpit.com/redeem, and enter 
the code found at the back of your book. 

2	 If you do not have a Peachpit.com account, create one when you’re prompted  
to do so.

3	 Click the Lesson & Update Files tab on your Account page. This tab lists 
downloadable files.

4	 Click the lesson file links to download them to your computer, and then  
unzip them. 

 Note:  In Mac OS 
10.7 and later, the user 
library folder is hidden 
by default. To see it, in 
the Finder, choose Go > 
Go To Folder. In the Go 
To Folder dialog box, 
type ~/Library, and 
then click Go.

 Note:  As you 
complete each lesson, 
you will preserve the 
start files. In case you 
overwrite them, you can 
restore the original files 
by downloading the 
corresponding lesson 
files from your Account 
page at peachpit.com.

http://www.peachpit.com/redeem
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The files are compressed into zip archives to speed up download time and to protect 
the contents from damage during transfer. You must uncompress (or “unzip”) the 
files to restore them to their original size and format before you use them with the 
book. On a modern operating system, simply double-click a zip archive to open it.

5	 Create a new folder on your hard disk, and name it Lessons. Then, drag the 
lesson files you downloaded and uncompressed into the Lessons folder on your 
hard disk.

When you begin each lesson, you will navigate to the folder with that lesson 
number, where you will find all of the assets, sample movies, and other project  
files you need to complete the lesson.

If you have limited storage space on your computer, you can download each lesson 
folder individually as you need it, and delete it afterward if desired. You do not have  
to save any finished project if you don’t want to, or if you have limited hard disk space.

About copying the sample movies and projects
You will create and render one or more QuickTime movies in some lessons in this 
book. The files in the Sample_Movie folders are examples that you can use to see the 
end results of each lesson and to compare them with your own results. 

The files in the End_Project_File folders are samples of the completed project for 
each lesson. Use these files for reference if you want to compare your work in prog-
ress with the project files used to generate the sample movies. These end-project 
files vary in size from relatively small to a couple of megabytes, so you can either 
download them all now if you have ample storage space, or download just the end-
project file for each lesson as needed, and then delete it when you finish that lesson.

How to use these lessons
Each lesson in this book provides step-by-step instructions for creating one or more 
specific elements of a real-world project. The lessons build on each other in terms 
of concepts and skills, so the best way to learn from this book is to proceed through 
the lessons in sequential order. In this book, some techniques and processes are 
explained and described in detail only the first few times you perform them. 

Many aspects of the After Effects application can be controlled by multiple tech-
niques, such as a menu command, a button, dragging, and a keyboard shortcut. 
Only one or two of the methods are described in any given procedure, so that you 
can learn different ways of working even when the task is one you’ve done before.

The organization of the lessons is also design-oriented rather than feature-oriented. 
That means, for example, that you’ll work with layers and effects on real-world 
design projects over several lessons, rather than in just one lesson.
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Additional resources
Adobe After Effects CC Classroom in a Book (2014 release) is not meant to replace 
documentation that comes with the program or to be a comprehensive reference 
for every feature. Only the commands and options used in the lessons are explained 
in this book. For comprehensive information about program features and tutorials, 
refer to these resources:

•	 Adobe After Effects Learn and Support: helpx.adobe.com/after-effects.html 
is where you can find hands-on tutorials, Help, answers to common 
questions, troubleshooting information, and more.

•	 Adobe Creative Cloud Learn: helpx.adobe.com/support.html provides 
inspiration, key techniques, cross-product workflows, and updates on  
new features. 

•	 After Effects Forums: forums.adobe.com/community/aftereffects_general_
discussion lets you tap into peer-to-peer discussions, questions, and answers 
about After Effects.

•	 Resources for educators: www.adobe.com/education and edex.adobe.
com offer a treasure trove of information for instructors who teach classes 
on Adobe software. Find solutions for education at all levels, including free 
curricula that use an integrated approach to teaching Adobe software and 
can be used to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

•	 Adobe Add-ons: creative.adobe.com/addons is a central resource for finding 
tools, services, extensions, code samples, and more to supplement and extend 
your Adobe products.

•	 Adobe After Effects CC product home page: www.adobe.com/products/
aftereffects

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training  
on Adobe products. A directory of AATCs is available at partners.adobe.com.

http://www.adobe.com/products/aftereffects
http://www.adobe.com/education
http://www.adobe.com/products/aftereffects
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ANIMATING TEXT

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Create and animate text layers.

•	 Stylize text using the Character and Paragraph panels.

•	 Apply and customize text animation presets.

•	 Preview animation presets in Adobe Bridge.

•	 Install fonts using Adobe Typekit.

•	 Animate text using keyframes.

•	 Animate layers using parenting.

•	 Edit and animate imported Adobe Photoshop text.

•	 Use a text animator group to animate selected characters  
on a layer.

•	 Apply a text animation to a graphic object.

This lesson will take approximately two hours to complete. Download 
the Lesson03 project files from the Lesson & Update Files tab on your 
Account page at www.peachpit.com, if you haven’t already done so.  
As you work on this lesson, you’ll preserve the start files. If you need  
to restore the start files, download them from your Account page. 

3

http://www.peachpit.com
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Your type doesn’t need to sit still while your audience 
is reading it. In this lesson, you’ll learn several ways 
to animate type in After Effects, including timesaving 
methods unique to text layers. 

PROJECT:  MOVIE TITLE SEQUENCE
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Getting started
Adobe After Effects offers many ways to animate text. You can animate text layers 
by manually creating keyframes in the Timeline panel, using animation presets,  
or using expressions. You can even animate individual characters or words in a 
text layer. In this lesson, you’ll employ several different animation techniques, 
including some that are unique to text, while you design the opening title credits 
for an animated documentary called Road Trip. You’ll also take advantage of Adobe 
Typekit to install a font for use in your project.

As in other projects, you’ll begin by previewing the movie you’re creating, and then 
you’ll open After Effects.

1	 Make sure the following files are in the Lessons/Lesson03 folder on your hard 
disk, or download them from your Account page at www.peachpit.com now:

•	 In the Assets folder: background_movie.mov, car.ai, compass.swf, credits.psd

•	 In the Sample_Movie folder: Lesson03.mov

2	 Open and play the Lesson03.mov sample movie to see the title credits you will 
create in this lesson. When you’re done, quit QuickTime Player. You may delete 
this sample movie from your hard disk if you have limited storage space.

As you start the application, restore the default settings for After Effects. See 
“Restoring default preferences” on page 2.

3	 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (Mac OS) to restore default preferences settings. 
When prompted, click OK to delete your preferences.

4	 Click Close to close the Welcome screen.

After Effects opens to display a blank, untitled project.

5	 Choose File > Save As > Save As, and navigate to the Lessons/Lesson03/
Finished_Project folder.

6	 Name the project Lesson03_Finished.aep, and then click Save.

Importing the footage
You need to import two footage items to begin this lesson.

1	 Double-click an empty area of the Project panel to open the Import File dialog box.

2	 Navigate to the Lessons/Lesson03/Assets folder on your hard disk, Ctrl-click 
(Windows) or Command-click (Mac OS) to select both the background_
movie.mov and compass.swf files, and then click Import or Open.

http://www.peachpit.com
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After Effects can import several file formats including Adobe Photoshop and Adobe 
Illustrator files, as well as QuickTime and AVI movies. This makes After Effects an 
incredibly powerful application for compositing and motion graphics work.

Creating the composition
Now, you’ll create the composition.

1	 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.

2	 In the Composition Settings dialog box, name the composition Road_Trip_
Title_Sequence, select NTSC DV from the Preset menu, and set the Duration  
to 10:00, which is the length of the background movie. Then click OK.

3	 Drag the background_movie.mov and compass.swf footage items from the 
Project panel to the Timeline panel. Arrange the layers so that compass.swf  
is above background_movie.mov in the layer stack.

4	 Choose File > Save.

You’re ready to add the title text to the composition. 
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About text layers
In After Effects, you can add text with flexibility and precision. You can create 
and edit text directly on the screen in the Composition panel, and quickly change 
the font, style, size, and color of the text. You can add horizontal or vertical text 
anywhere in a composition. The Tools, Character, and Paragraph panels contain 
a wide range of text controls. You can apply changes to individual characters and 
set formatting options for entire paragraphs, including alignment, justification, 
and word-wrapping. In addition to all of these style features, After Effects provides 
tools for easily animating specific characters and properties, such as text opacity 
and hue.

After Effects uses two types of text: point text and paragraph text. Use point text 
to enter a single word or line of characters; use paragraph text to enter and format 
text as one or more paragraphs.

In many ways, text layers are just like any other layers in After Effects. You can 
apply effects and expressions to text layers, animate them, designate them as 
3D layers, and edit the 3D text while viewing it in multiple views. As with layers 
imported from Illustrator, text layers are continuously rasterized, so when you 
scale the layer or resize the text, it retains crisp, resolution-independent edges. The 
main differences between text layers and other layers are that you cannot open a 
text layer in its own Layer panel, and you can animate the text in a text layer using 
special text animator properties and selectors.

Installing a font using Typekit
Hundreds of fonts are available through Adobe Typekit, which is included with an 
Adobe Creative Cloud membership. You’ll use Typekit to install a font that will work 
well for the title text. When you install a Typekit font on your system, it’s available in 
any application.

1	 Choose File > Add Fonts From Typekit.

After Effects opens the Adobe Typekit page in your default browser.

2	 If prompted to sign in, enter your Adobe ID. If you’re already signed in to Creative 
Cloud, you won’t need to sign in again.

You can browse fonts on the Adobe Typekit website, but because there are so many, 
it’s often more efficient to filter them or to search for a specific font. You’ll filter 
fonts to see those that meet your requirements.

3	 Make sure the Full Library tab is selected so you’ll see all the fonts.
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4	 Choose Sort By Name from the pop-up menu in the upper right corner. Then,  
on the right side of the page, click the Sans Serif button in the Classification area, 
both the Web Use and Desktop Use buttons in the Available For area, and the 
Standard button in the Properties area.

Typekit displays several fonts that meet the requirements you specified. You’ll  
preview the fonts to see which one looks best. 

5	 Type Road Trip in the preview text field, and move the slider to decrease  
the sample text size so you can see the full title.
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Using your own text as the sample text lets you get a feel for how a font will work 
with your text. Calluna Sans will work nicely.

6	 Hover your mouse over Calluna Sans until you see a green overlay. Then click 
+Use Fonts. (If you don’t see Calluna Sans, click +Load More until you do.) 

7	 Click Sync Selected Fonts. If the Creative Cloud application isn’t running on your 
computer, click Launch The Creative Cloud Application to start it.

The selected fonts are automatically added to your system and are then available  
in any application, including After Effects. 

E Tip:  If you click  
the font name without 
clicking +Use Fonts, 
you’ll see sample text 
for all the fonts in 
the selected family, 
as well as additional 
information about  
the font.
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Creating and formatting point text
When you enter point text, each line of text is independent—the length of a line 
increases or decreases as you edit the text, but it doesn’t wrap to the next line. The  
text you enter appears in a new text layer. The small line through the I-beam marks  
the position of the text baseline. 

1	 In the Tools panel, select the Horizontal Type tool ( ).

2	 Click anywhere in the Composition panel, and type Road Trip. Then press 
Enter on the numeric keypad to exit text-editing mode and to select the text 
layer in the Composition panel. Or, you can select the layer name to exit text-
editing mode.

Using the Character panel
The Character panel provides options for formatting characters. If text is high-
lighted, changes you make in the Character panel affect only the highlighted text.  
If no text is highlighted, changes you make in the Character panel affect the selected 
text layers and the text layers’ selected Source Text keyframes, if any exist. If no text  
is highlighted and no text layers are selected, changes you make in the Character panel 
become the new defaults for the next text entry.

1	 Choose Window > Workspace > Text to display only those panels you need 
while working with text.

2	 Select the Road Trip text layer in the Timeline panel.

3	 In the Character panel, choose Calluna Sans from the Font Family menu. 

4	 Choose Bold from the Font Style menu.

5	 Set the Font Size to 90 pixels.

6	 Leave all other options at their default settings. 

 Note:  If you press 
Enter or Return on 
the regular keyboard 
instead of on the 
numeric keypad, you’ll 
begin a new paragraph.

E Tip:  To open the 
panels individually, 
choose Window > 
Character or Window > 
Paragraph. To open  
both panels, select the 
Horizontal Type tool, and 
then click the Toggle 
The Character And 
Paragraph Panels button 
in the Tools panel.

E Tip:  To select a font 
quickly, begin typing its 
name in the Font Family 
box. The Font Family 
menu jumps to the first 
font on your system 
that matches the letters 
you’ve typed. If a type 
layer is selected, the 
text in the Composition 
panel takes on the 
newly selected font. 
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Using the Paragraph panel
Use the Paragraph panel to set options that apply to an entire paragraph, such  
as alignment, indentation, and leading. For point text, each line is a separate 
paragraph. You can use the Paragraph panel to set formatting options for a single 
paragraph, multiple paragraphs, or all paragraphs in a text layer. You just need  
to make one adjustment in the Paragraph panel for this composition’s title text.

1	 In the Paragraph panel, click the Center Text button ( ). This aligns horizontal 
text to the center of the layer, not to the center of the composition.

2	 Leave all other options at their default settings. 

Positioning the type
To precisely position layers, such as the text layer you’re working on now, you can 
display rulers, guides, and grids in the Composition panel. These visual reference 
tools don’t appear in the final rendered movie.

1	 Make sure the Road Trip text layer is selected in the Timeline panel.

2	 Choose Layer > Transform > Fit To Comp Width. This scales the layer to fit  
to the width of the composition. 

Now you can position the text layer using a grid.

3	 Choose View > Show Grid and then View > Snap To Grid.
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4	 Using the Selection tool ( ), drag the text up in the Composition panel until the 
base of the letters sits on the horizontal gridline in the center of the composition. 
Press Shift after you start dragging to constrain the movement and help you 
position the text. 

5	 When the layer is in position, choose View > Show Grid again to hide the grid.

This project isn’t destined for broadcast TV, so it’s okay that the title extends 
beyond the title-safe and action-safe areas of the composition at the beginning  
of the animation.

6	 Choose Standard from the Workspace menu at the top of the application window to  
return to the Standard workspace, and then choose File > Save to save your project.

Using a text animation preset
Now you’re ready to animate the title. The easiest way to do that is to use one of the 
many animation presets that come with After Effects. After applying an animation 
preset, you can customize it and save it to use again in other projects.

1	 Press the Home key or go to 0:00 to make sure the current-time indicator is at the 
beginning of the time ruler. 

After Effects applies animation presets from the current time.

2	 Select the Road Trip text layer.
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Browsing animation presets
You already applied an animation preset using the Effects & Presets panel in Lesson 
2, “Creating a Basic Animation Using Effects and Presets.” But what if you’re not 
sure which animation preset you want to use? To help you choose the right anima-
tion preset for your projects, you can preview them in Adobe Bridge.

1	 Choose Animation > Browse Presets. Adobe Bridge opens, displaying the 
contents of the After Effects Presets folder.

2	 In the Content panel, double-click the Text folder, and then the Blurs folder. 

3	 Click to select the first preset, Blur By Word. Adobe Bridge plays a sample  
of the animation in the Preview panel.

4	 Select a few other presets, and watch them in the Preview panel.

5	 Preview the Evaporate preset, and then double-click its thumbnail preview. 
Alternatively, you can right-click (Windows) or Control-click (Mac OS) the 
thumbnail and choose Place > In After Effects. 

After Effects applies the preset to the selected layer, which is the Road Trip layer, but 
nothing appears to change in the composition. This is because at 0:00, the first frame 
of the animation, the letters haven’t yet evaporated.

Previewing a range of frames
Now, preview the animation. Although the composition is 10 seconds long, you need 
to preview only the first few seconds, since that is where the text animation occurs.

 Note:  If Bridge  
isn’t installed, you’ll 
be prompted to install 
it when you choose 
Browse In Bridge.  
For more information, 
see page 2.

 Note:  Leave Adobe 
Bridge open in the 
background. You’ll use it 
again later in the lesson. 
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1	 In the Timeline panel, move the current-time indicator to 3:00, and press N to set 
the end bracket of the work area.

2	 Press 0 on the numeric keypad, or click the RAM Preview button ( ) in the 
Preview panel, to watch a RAM preview of the animation. 

The letters appear to evaporate into the background. It looks great—but you want the 
letters to fade in and remain onscreen, not disappear. So you will customize the preset 
to suit your needs.

3	 Press the spacebar to stop the preview, and then press the Home key to move 
the current-time indicator back to 0:00.

Customizing an animation preset
After you apply an animation preset to a layer, all of its properties and keyframes 
are listed in the Timeline panel. You’ll use those properties to customize the preset.

1	 Select the Road Trip text layer in the Timeline panel, and press U. 

The U key, sometimes referred to as the Überkey, is a valuable keyboard shortcut 
that reveals all the animated properties of a layer.

2	 Click the Offset property name to select both of its keyframes. 

E Tip:  If you press 
U twice (UU), After 
Effects displays all 
modified properties 
for the layer, instead 
of only the animated 
properties. Press the U 
key again to hide all the 
layer’s properties.
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The Offset property specifies how much to offset the start and end of the selection.

3	 Choose Animation > Keyframe Assistant > Time-Reverse Keyframes. 

The Time-Reverse Keyframes command switches the order of the two Offset key-
frames so that the letters are invisible at the beginning of the composition, and then 
emerge into view.

4	 Drag the current-time indicator from 0:00 to 3:00 to manually preview the 
animation you edited. 

The letters now fade into, rather than disappear from, the composition.

5	 Press U to hide the layer’s properties.

6	 Press the End key to move the current-time indicator to the end of the time 
ruler, and then press N to set the end bracket of the work area. 

7	 Choose File > Save to save your project.

Animating with scale keyframes
The text layer was scaled to nearly 200% when you applied the Fit To Comp com-
mand to it earlier in this lesson. Now, you’ll animate the layer’s scale so that  
the type gradually shrinks down to its original size.

1	 In the Timeline panel, move the current-time indicator to 3:00.

2	 Select the Road Trip text layer, and press the S key to reveal its Scale property.

3	 Click the stopwatch icon ( ) to add a Scale keyframe at the current time (3:00).
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4	 Move the current-time indicator to 5:00. 

5	 Reduce the layer’s Scale values to 100, 100%. After Effects adds a new Scale 
keyframe at the current time.

Previewing the scale animation
Now you’ll preview the change.

1	 Move the current-time indicator to 5:10, and press N to set the end of the work 
area. The scale animation ends shortly before 5:10.

2	 Watch a RAM preview of the animation from 0:00 to 5:10. The movie title fades 
in and then scales to a smaller size.

3	 Press the spacebar to stop playback after you’ve viewed the animation.

Adding Easy Ease
The beginning and end of the scale animation are rather abrupt. In nature, nothing 
comes to an absolute stop. Instead, objects ease into and out of starting and  
stopping points.

1	 Right-click (Windows) or Control-click (Mac OS) the Scale keyframe at 3:00, 
and choose Keyframe Assistant > Easy Ease Out. The keyframe becomes a left-
pointing icon.

E Tip:  You can 
experiment with text 
scale animation presets 
that are included with 
After Effects. They’re 
located in the Presets/
Text/Scale folder in the 
After Effects CC folder 
on your hard drive.
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2	 Right-click (Windows) or Control-click (Mac OS) the Scale keyframe at 5:00, 
and choose Keyframe Assistant > Easy Ease In. The keyframe becomes a right-
pointing icon.

3	 Watch another RAM preview. Press the spacebar to stop it when you’re done.

4	 Choose File > Save.

Animating using parenting
The next task is to make it appear as if the virtual camera is zooming away from the 
composition. The text scale animation you just applied gets you halfway there, but 
you need to animate the scale of the compass as well. You could manually animate 
the compass layer, but it’s easier to take advantage of parenting relationships in 
After Effects.

1	 Press the Home key, or drag the current-time indicator to the beginning of the 
time ruler.

2	 In the Timeline panel, click the Parent pop-up menu for the compass layer, and 
choose 1. Road Trip.

This sets the Road Trip text layer as the parent of the compass layer, which in turn 
becomes the child layer.

As the child layer, the compass layer inherits the Scale keyframes of its parent 
layer (Road Trip). Not only is this a quick way to animate the compass, but it also 
ensures that the compass scales at the same rate and by the same amount as the 
text layer.

3	 In the Timeline panel, move the compass layer above the Road Trip text layer.

 Note:  When you 
move the compass 
layer, its parent 
becomes 2. Road Trip, 
because Road Trip is 
now the second layer. 
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4	 Move the current-time indicator to 9:29, so you can clearly see the compasss  
in the Composition panel.

5	 In the Composition panel, drag the compass so that its anchor point is over  
the dot in the letter i in the word trip. Alternatively, you can select the compass 
layer in the Timeline panel, press P to reveal its Position property, and then  
enter 124, −62.

6	 Move the current-time indicator from 3:00 to 5:00 to manually preview the 
scaling. Both the text and the compass scale down in size, so that it appears  
that the camera is moving away from the scene.

7	 Press the Home key to return to 0:00, and drag the work area end bracket  
to the end of the time ruler.

8	 Select the Road Trip layer in the Timeline panel, and press S to hide its Scale 
property. If you entered Position values for the compass, select the compass 
layer, and press P to hide the Position property, too. Then choose File > Save.

About parent and child layers
Parenting assigns one layer’s transformations to another layer, called a child layer. 
Creating a parenting relationship between layers synchronizes the changes in the 
parent layer with the corresponding transformation values of the child layers, except 
opacity. For example, if a parent layer moves 5 pixels to the right of its starting 
position, then the child layer also moves 5 pixels to the right of its starting position. 
A layer can have only one parent, but a layer can be a parent to any number of 2D 
or 3D layers within the same composition. Parenting layers is useful for creating 
complex animations such as linking the movements of a marionette or depicting 
the orbits of planets in the solar system.

For more on parent and child layers, see After Effects Help.
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Animating imported Photoshop text
If all text animations involved just two short words, such as road trip, life would 
be easy. But in the real world, you may often have to work with longer blocks of 
text, and they can be tedious to enter manually. Fortunately, After Effects lets you 
import text from Photoshop or Illustrator. You can preserve text layers, edit them, 
and animate them in After Effects. 

Importing text
Some of the remaining text for this composition is in a layered Photoshop file, 
which you’ll import now.

1	 Double-click an empty area in the Project panel to open the Import File dialog box.

2	 Select the credits.psd file in the Lessons/Lesson03/Assets folder. Choose 
Composition – Retain Layer Sizes from the Import As menu, and then click 
Import or Open.

3	 In the Credits.psd dialog box, select 
Editable Layer Styles, and click OK.

After Effects can import Photoshop layer 
styles, retaining the appearance of the 
layers you’re importing. The imported 
file is added as a composition to the 
Project panel; its layers are added in a 
separate folder.

4	 Drag the credits composition from the Project panel into the Timeline panel, 
placing it at the top of the layer stack.

Because you imported the credits.psd file as a composition with layers intact, 
you can work on it in its own Timeline panel, editing and animating its layers 
independently.
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Editing imported text
The text you imported isn’t currently editable in After Effects. You’ll change that  
so that you can control the type and apply animations. And if you have a sharp eye, 
you’ve noticed some typos in the imported text. So, first you’ll clean up the type.

1	 Double-click the credits composition in the Project panel to open it in its own 
Timeline panel.

2	 Shift-click to select both layers in the credits Timeline panel, and choose Layer > 
Convert To Editable Text. (Click OK if you see a warning about missing fonts.) 

Now the text layers can be edited, and you can fix the typos.

3	 Deselect both layers, and then double-click layer 2 in the Timeline panel to select 
the text and automatically switch to the Horizontal Type tool ( ).

4	 Type an e between the t and d in the word animated. Then change the k to a c  
in documentary. 

5	 Switch to the Selection tool ( ) to exit text-editing mode. 

6	 Shift-click to select both layers in the Timeline panel. 

7	 If the Character panel isn’t open, choose Window > Character to open it.

 Note:  The layer 
name does not change 
in the Timeline panel 
when you correct the 
spelling in the layer. This 
is because the original 
layer name was created 
in Photoshop. To 
change a layer’s name, 
select it in the Timeline 
panel, press Enter or 
Return, type the new 
name, and press Enter 
or Return again.
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8	 Choose the same typeface you used for the words Road Trip: Calluna Sans. 
Leave all other settings as they are.

9	 Click an empty area of the Timeline panel to deselect both layers. Then select 
layer 2 again.

10	 In the Character panel, click the Fill Color box. Then, in the Text Color dialog 
box, select a shade of green, and click OK. We used R=66, G=82, B=42.

Animating the subtitle
You want the letters of the subtitle—an animated documentary—to fade onscreen 
from left to right under the movie title. The easiest way to do this is to use another 
text animation preset.

1	 Go to 5:00 in the timeline. At that point, the title and the compass have finished 
scaling to their final size.

2	 Select the subtitle layer (layer 2) in the Timeline panel.

3	 Press Ctrl+Alt+Shift+O (Windows) or Command+Option+Shift+O (Mac OS) 
to jump to Adobe Bridge. 

4	 Navigate to the Presets/Text/Animate In folder.

5	 Select the Fade Up Characters animation preset, and watch it in the Preview 
panel. This effect works well to reveal the text gradually.

6	 Double-click the Fade Up Characters preset to apply it to the subtitle layer  
in After Effects.
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7	 With the subtitle layer selected in the Timeline panel, press UU to see the 
properties modified by the animation preset. You should see two keyframes  
for Range Selector 1 Start: one at 5:00, and one at 7:00. 

You still have a lot of animation to do in this composition, so you will speed up the 
effect by 1 second.

8	 Go to 6:00, and then drag the second Range Selector 1 Start keyframe to 6:00.

9	 Drag the current-time indicator across the time ruler between 5:00 and 6:00  
to see the letters fade in.

10		 When you’re done, select the subtitle layer, and press U to hide the modified 
properties. Then choose File > Save to save your work.

Animating text using a path animation preset
You’ve seen how versatile and convenient text animation presets can be. You’ll 
use another type of text animation preset to animate the words directed by along 
a motion path. After Effects includes several animation presets that animate text 
along a prebuilt path. These presets also provide placeholder text when you apply 
them, so in this exercise, you will enter and format your text after you apply the 
animation preset. 

1	 Select the Road_Trip_Title_Sequence tab in the Timeline panel.

2	 Deselect all layers, and then go to 5:00.
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3	 Press Ctrl+Alt+Shift+O (Windows) or Command+Option+Shift+O (Mac OS) 
to jump to Adobe Bridge. 

4	 Navigate to the Presets/Text/Paths folder. 

5	 Double-click the Pipes animation preset. 

Adobe Bridge returns you to After Effects, where the preset automatically creates 
a new layer, pipes, with a predefined path that zigzags across the composition. The 
text on the path is obscured by the movie title. You’ll fix that soon.

Customizing the preset path
First, you need to change the placeholder word pipes to directed by. Then you’ll 
adjust the path itself.

1	 In the Timeline panel, go to 6:05, when the word pipes is visible—and 
horizontal—onscreen.

2	 Double-click the pipes layer in the Timeline panel. 

After Effects switches to the Horizontal Type tool ( ) and selects the word pipes in 
the Composition panel. 

3	 Type directed by to replace the word pipes. Press Enter on the numeric keypad 
or select the layer name when you’re done. After Effects updates the Timeline 
panel with the new layer name.

4	 In the Character panel, do the following:

•	 Set the Font Family to Minion Pro or another serif typeface. 

•	 Set the Font Style to Regular.
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•	 Set the Font Size to 20 pixels.

•	 Leave all other settings at their defaults.

5	 Drag the current-time indicator across the time ruler between 5:00 and 8:00  
to see how the words directed by move onscreen—and then offscreen. 

You’ll fix the text so that it stays onscreen, but now is a good time to adjust the position 
of the path in the composition so that it doesn’t interfere with the movie title.

6	 Using the Selection tool ( ), double-click the yellow motion path in the 
Composition panel.

7	 Drag the path down and slightly to the left, until the words Road Trip are 
centered in the top curve and Your Name Here is within the lower curve.  
You may find it easiest to use the arrow keys.

8	 Press Enter or Return to accept the change.

Later in the lesson, you’ll attach a car graphic to the path so it appears to be pulling 
the text. But first, you’ll finish animating the credits.

9	 Select the directed by layer in the Timeline panel, and hide its properties. Then 
choose File > Save to save your work.
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Animating type tracking
Next, you’ll animate the appearance of the director’s name in the composition using  
a text animation tracking preset. By animating tracking, you can make words seem  
to expand outward as they appear onscreen from a central point. 

Customizing placeholder text
Currently, the director’s name is simply a layer with placeholder text—Your Name 
Here. Before you animate it, change it to your own name. 

1	 Switch to the credits timeline in the Timeline panel, and select the Your Name 
Here layer.

2	 Select the Horizontal Type tool ( ), and then 
replace Your Name Here in the Composition 
panel with your own name. Use a first, 
middle, and last name so that you have a nice 
long string of text to animate. Click the layer 
name when you’re done. 

Applying a tracking preset
Now you will animate the director’s name with a tracking preset so that it starts  
to appear onscreen shortly after the words directed by reach the center of the 
composition.

1	 Go to 7:10.

2	 Select the Your Name Here layer in the Timeline panel.

3	 Jump to Adobe Bridge, and go to the Presets/Text/Tracking folder. Double- 
click the Increase Tracking preset to apply it to the Your Name Here layer  
in After Effects.

4	 Drag the current-time indicator across the time ruler between 7:10 and 9:10  
to manually preview the tracking animation. 

 Note:  It doesn’t 
matter where the 
current-time indicator 
is located when you 
edit the text of this 
layer. Currently, the 
text is onscreen for 
the duration of the 
composition. That 
will change once you 
animate it.

 Note:  Again, the 
layer name doesn’t 
change, because it was 
named in Photoshop.

E Tip:  If you’re tired 
of jumping to Adobe 
Bridge and don’t care 
to preview the preset, 
simply type Increase 
Tracking in the search 
box of the Effects & 
Presets panel. Then 
double-click the effect 
to apply it to the 
selected layer in the 
Timeline panel.
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Customizing the tracking animation preset
The text expands, but you want the letters to be so close initially that they’re on top 
of each other, and then to expand to a reasonable, readable distance apart. The 
animation should also occur faster. You’ll adjust the Tracking Amount to achieve 
both goals.

1	 Select the Your Name Here layer in the Timeline panel, and press UU to reveal 
the properties that were modified.

2	 Go to 7:10.

3	 Under Animator 1, change the Tracking Amount to −5 so that the letters are 
squeezed together. 

4	 Click the Go To Next Keyframe arrow ( ) for the Tracking Amount property, 
and then change the value to 0.

5	 Drag the current-time indicator across the time ruler between 7:10 and 8:10.  
The letters expand as they appear onscreen, and stop animating at the  
last keyframe.
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Animating text opacity
You’ll take the animation of the director’s name a little further by having it fade 
onscreen as the letters expand. To do this, you’ll animate the layer’s Opacity property.

1	 Select the Your Name Here layer in the credits timeline.

2	 Press T to reveal only the layer’s Opacity property.

3	 Go to 7:10, and set the Opacity to 0%. Then click the stopwatch icon ( ) to set 
an Opacity keyframe.

4	 Go to 7:20, and set the Opacity to 100%. After Effects adds a second keyframe.

 Now the letters of the director’s name should fade in as they expand onscreen.

5	 Drag the current-time indicator across the time ruler between 7:10 and 8:10  
to see the letters of the director’s name fade in as they spread out.

6	 Right-click (Windows) or Control-click (Mac OS) the ending Opacity keyframe, 
and choose Keyframe Assistant > Easy Ease In.

7	 Choose File > Save.

Using a text animator group
Text animator groups let you animate individual letters within a block of text  
in a layer. You’ll use a text animator group to animate only the characters in your 
middle name without affecting the tracking and opacity animation of the other 
names in the layer.

1	 In the Timeline panel, go to 8:10.

2	 Hide the Opacity property for the Your Name Here layer. Then expand the layer 
to see its Text property group name.
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3	 Next to the Text property name, click the Animate pop-up menu, and  
choose Skew. 

A property group named Animator 2 appears in the layer’s Text properties.

About text animator groups
A text animator group includes one or more selectors and one or more animator 
properties. A selector is like a mask—it specifies which characters or section of a text 
layer you want an animator property to affect. Using a selector, you can define a 
percentage of the text, specific characters in the text, or a specific range of text. 

Using a combination of animator properties and selectors, you can create complex 
text animations that would otherwise require painstaking keyframing. Most text 
animations require you to animate only the selector values—not the property 
values. Consequently, text animators use a small number of keyframes even for 
complex animations. 

For more about text animator groups, see After Effects Help.

4	 Select Animator 2, press Enter or  
Return, and rename it Skew Animator. 
Then press Enter or Return again to 
accept the new name.

Now you’re ready to define the range of  
letters that you want to skew.

5	 Expand the Skew Animator’s Range Selector 1 properties. 

Each animator group includes a default range selector. Range selectors constrain the 
animation to particular letters in the text layer. You can add additional selectors to  
an animator group, or apply multiple animator properties to the same range selector.
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6	 While watching the Composition panel, drag the Skew Animator’s Range 
Selector 1 Start value up (to the right) until the left selector indicator ( ) is just 
before the first letter of your middle name (the B in Bender, in this example). 

7	 Drag the Skew Animator’s Range Selector 1 End value down (to the left) until  
its indicator ( ) is just after the last letter of your middle name (the r in Bender, 
in this example) in the Composition panel. 

Now, any properties that you animate with the Skew Animator will affect only  
the middle name that you selected.

Skewing the range of text
Now, make that middle name shake and shimmy by setting Skew keyframes. 

1	 Drag the Skew Animator’s Skew value left and right, and notice that only  
the middle name sways. The other names in the line of text remain steady.

2	 Set the Skew Animator’s Skew value to 0.

3	 Go to 8:05, and click the stopwatch icon ( ) for Skew to add a keyframe  
to the property.

4	 Go to 8:08, and set the Skew value to 50. After Effects adds a keyframe.
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5	 Go to 8:15, and change the Skew value to −50. After Effects adds another 
keyframe.

6	 Go to 8:20, and change the Skew value to 0 to set the final keyframe.
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7	 Click the Skew property name to select all of the Skew keyframes. Then  
choose Animation > Keyframe Assistant > Easy Ease to add an Easy Ease  
to all keyframes.

8	 Drag the current-time indicator across the time ruler from 7:10 to 8:20 to see 
how the director’s name fades in and expands onscreen, and the middle name 
rocks side to side while the other names are unaffected. 

9	 Hide the properties for the Your Name Here layer in the Timeline panel.

10	Select the Road_Trip_Title_Sequence tab to open its timeline.

11	Press End, or move the current-time indicator to 9:29. Then press N to set  
the end bracket for the work area at the end of the composition.

12	Press Home, or go to 0:00, and then play a RAM preview of the entire composition.

13	Press the spacebar to stop playback, and then choose File > Save to save  
your work.

Cleaning up the path animation
Currently, the words directed by fade in and out as they wind along the Pipes path 
preset. You’ll modify the text properties so that the words are opaque for the entire 
animation and come to rest just above your name.

1	 With the directed by layer selected in the Timeline panel, press U to display the 
animated properties for the layer.

2	 Click the stopwatch icon ( ) for the Range Selector 1 Offset property to delete 
all of its keyframes.

3	 Depending on where the current-time indicator is located in the time ruler,  
the resulting value for Range Selector 1 Offset may or may not be set to 0%.  
Set it to 0% if it is not. 

Now, directed by will be visible throughout the composition. Next, you’ll modify  
the First Margin property to make the text stop animating above your name.

E Tip:  To quickly 
remove all text 
animators from a text 
layer, select the layer in 
the Timeline panel, and 
choose Animation > 
Remove All Text 
Animators. To remove 
only one animator, 
select its name in the 
Timeline panel, and 
press Delete.
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4	 Select the last keyframe for the First Margin property in the Timeline panel, 
and press the Delete key to delete it. Because the middle keyframe (now the last 
keyframe) is set to Easy Ease, the words directed by come gently to rest above 
your name.

5	 Go to 6:14, and change the First Margin value to 685.

You also need to adjust the path shape so that it starts and ends off the screen.

6	 Using the Selection tool ( ) in the Composition panel, select the control point 
at the top of the S-shaped curve, and then press Shift as you drag it to the right 
and well off the screen so the car won’t be visible.

7	 Click the control point at the end of the S-shaped curve, and Shift-drag the 
control point off the left side of the screen, so that the car won’t be visible.

8	 Preview the animation from about 5:00 to 9:00 to see the corrected path. 

9	 If the text doesn’t stop directly above your name, adjust the First Margin value 
of the final keyframe.

10	Hide the properties for the directed by layer in the Timeline panel, and then 
choose File > Save.

 Note:  Depending  
on how far you move 
the beginning and 
ending control points 
of the path, you may 
need to change the First 
Margin value again to 
reposition the text.
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Animating a nontext layer 
along a motion path
To cap off this project, you’ll use a mask from a text layer to animate a nontext layer. 
Specifically, you’ll use the mask shape for the directed by path to create a motion path 
for a car graphic so that it appears to be pulling the text. First, you’ll import the car 
graphic and add it to your composition.

1	 Double-click an empty area in the Project panel to open the Import File dialog box. 

2	 In the Lessons/Lesson03/Assets folder, select the car.ai file, choose Composition 
– Retain Layer Sizes from the Import As menu, and then click Import or Open.

3	 Drag the car composition from the Project panel to the top of the layer stack  
in the Road_Trip_Title_Sequence Timeline panel.

Copying the mask shape
Now you’re ready to copy the mask shape from the path of the directed by layer  
to the car layer.
d

1	 Go to 5:00.

2	 Select the directed by layer in the Timeline panel, and press M to display  
its Mask Path property.

3	 Click the Mask Path property to select it, and then choose Edit > Copy.

4	 Select the car layer, and then press P to display its Position property.

5	 Click the Position property name to select it, and then choose Edit > Paste. 
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After Effects copies the Position keyframes from the directed by layer to the car layer. 

Orienting the object
Unfortunately, the car is flying backward, but that’s easy to fix. 

1	 With the car layer selected in the Timeline panel, choose Layer > Transform > 
Auto-Orient. 

2	 In the Auto-Orientation dialog box, select Orient Along Path, and then click OK. 

Now the car is facing forward as it flies. 

3	 Select the car layer in the Timeline panel, and press P to hide its Position property.

Coordinating the text and object timing
Next, you need to coordinate the timing of the car’s motion with the words directed 
by so that the words correctly trail behind the car.

1	 Select the directed by layer, and press U to display its Path Options property 
group in the Timeline panel.

2	 Go to 5:18, and change the First Margin value so that the text moves behind the car. 
(We changed the value to 373.) After Effects adds a keyframe.

3	 Go to 5:25, and change the First Margin value so that the car is leading the text. 
We changed the value to 559.

4	 Go to 4:24, and drag the first First Margin keyframe (the left-pointing arrow)  
to that position.

5	 Manually preview the corrected path animation by dragging the current-time 
indicator across the time ruler from about 4:20 to 7:10. 
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The words should follow the car and come to rest above your name, while the car 
continues to fly along the path and off the screen.

6	 Adjust the First Margin value for the first keyframe if necessary to create a 
smoothly flowing animation. You may also need to move the final First Margin 
keyframe to stop the words directed by so they’ll be centered over your name.

7	 Hide the properties for the directed by layer, and then press the Home key  
or move the current-time indicator to the beginning of the time ruler.

Adding motion blur
Motion blur is the blur that occurs as an object moves. You’ll apply motion blur  
to finesse the composition and make the movement look more natural.

1	 In the Timeline panel, click the Motion Blur switch ( ) for each layer except  
the background_movie and credits layers.

Now you’ll apply motion blur to the layers in the credits composition.

2	 Switch to the credits Timeline panel, and enable motion blur for both layers.

3	 Switch back to the Road_Trip_Title_Sequence Timeline panel, and select the 
Motion Blur switch for the credits layer. Then click the Enable Motion Blur  
button ( ) at the top of the Timeline panel so that you can see the motion  
blur in the Composition panel.

4	 View a RAM preview of the entire, completed animation.

5	 Choose File > Save.

Give yourself a pat on the back. You just completed some hard-core text animations. 
If you’d like to export the composition as a movie file, see Lesson 14, “Rendering and 
Outputting,” for instructions. 
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Review questions
1	 What are some similarities and differences between text layers and other types  

of layers in After Effects?

2	 How can you preview a text animation preset?

3	 How can you assign one layer’s transformations to another layer?

4	 What are text animator groups?

Review answers
1	 In many ways, text layers are just like any other layer in After Effects. You can apply 

effects and expressions to text layers, animate them, designate them as 3D layers, and 
edit the 3D text while viewing it in multiple views. However, text layers are like shape 
layers in that you can’t open them in their own Layer panels, and in that they are 
synthetic layers that consist entirely of vector graphics. You can animate the text  
in a text layer using special text animator properties and selectors.

2	 You can preview text animation presets in Adobe Bridge by choosing Animation > 
Browse Presets. Adobe Bridge opens and displays the contents of the After Effects 
Presets folder. Navigate to folders containing categories of text animation presets, such 
as Blurs or Paths, and watch samples in the Preview panel. Then double-click a preset 
to add it to the currently selected layer in the After Effects Timeline panel.

3	 You can use parenting relationships in After Effects to assign one layer’s transforma-
tions to another layer (except opacity transformations). When a layer is made a parent 
to another layer, the other layer is called the child layer. Creating a parenting relationship 
between layers synchronizes the changes in the parent layer with corresponding trans-
formation values of the child layers.

4	 Text animator groups enable you to animate the properties of individual characters  
in a text layer over time. Text animator groups contain one or more selectors, which are 
like masks: They let you specify which characters or section of a text layer you want  
an animator property to affect. Using a selector, you can define a percentage of the 
text, specific characters in the text, or a specific range of text.
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Adobe After Effects Help  36

Adobe Audition, editing audio files in  146

Adobe Bridge

about  41

browsing animation presets in  68

importing files with  41

installing  2, 41

navigating folders in  41

opening  41

previewing audio files in  143

previewing images in  42

preview panel  42

workspaces  42

Adobe Illustrator files, importing  45

Adobe Media Encoder  361–366

creating presets for  364

encoding presets in  362

Adobe Photoshop files

importing  152

importing layer styles from  153

importing text from  74

layered  151

Adobe Premiere Pro, using with  
After Effects  220

Adobe Typekit

installing a font using  62–64

sorting fonts in  63

using sample text in  64

alpha track mattes. See track mattes

adjusting  162

using to constrain layers  126

ambient lights, adding  305

Analyze Forward button  326

anchor points, adjusting  123

animating

along a motion path  88

in time with audio  114

layers  148, 151

lighting  154, 165

motion  158

opacity  82, 278

Puppet tool pins  214

scale  70

shadows  165

slide shows  138

text  310, 60–91, 74, 83

using parenting  72, 119

using the Puppet tools  205

walking cycles  210

animation presets  27–28

applying  50, 80

applying from Adobe Bridge  68

browsing in Adobe Bridge  41, 68

Bullet Train  50

customizing  69

Dissolve - Vapor  52

Evaporate  68

Fade Up Characters  76

Increase Tracking  80

Pipes  78

text  67, 71

using with shape layers  126
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animations

about  24

copying to other elements  312

duplicating using pick whips  156

easing  71, 134

linking through expressions  156

motion paths for  121

Warp Stabilizer VFX  320

animator properties in text animator 
groups  83

application window  8

audio

adding tracks  143

editing files in Adobe Audition  146

file formats supported  142

looping  143

using amplitude to animate layers  114

Audio/Video Switches  
in the Timeline panel  25

Audition. See Adobe Audition

Auto Levels effect  251

Auto-Orient command  89

B

background, replacing  246–251

background strokes, creating with the Roto 
Brush tool  222–223

base frames

adding for the Roto Brush tool  225

creating with the Roto Brush  
tool  220–221

beveling text in Cinema 4D Lite  285

Bezier curves

breaking direction handles for  187

using to create masks  186

Bezier masks, creating  188

bicubic scaling  319

bilinear sampling  319

blending modes

about  195

applying  195

for masks  185, 247

blur, adding  258–259

Brainstorm feature  105

Bridge. See Adobe Bridge

brightness, changing in the user interface  35

broadcast, preparing a movie for  364

Browse Presets command  68

Bullet Train animation preset  50

C

C4D files  281

cached frames  224

cameras, adding to a 3D scene  275–276

Camera Settings  312

Casts Shadows property  274

CC Particle Systems II effect  334

properties  337

CC Toner  257–258

Channel Blur effect  29–30

Character panel  47, 65

checkerboard, generating  109

child layers  72, 73, 119
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Cinema 4D Lite  279–286

adding surface textures to objects in  286

coordinate measurements  279

creating 3D text in  282–284

exporting an After Effects  
composition for  281

positioning objects in  284

updating objects in After Effects  286

workspace  282

Cineware effect  281

Classroom in a Book  1

Clone tool  261

cloning an object  261

codecs  357

Collapse Transformations switch  110

color

adjusting color balance  241

keying  218

mapping  257–258

color correction  236, 251

about  238

previewing accurately  240

Color Emboss effect  49

Color Finesse 3. See SA Color Finesse 3 effect

color grading  238, 257–258

Color Range effect  255

Comp Camera option in the Cineware  
effect  282

Composition Navigator bar  26

Composition panel

about  13

splitting into multiple views  270

typing in  65

compositions

about  13

adding footage items to  15

changing the resolution of  125

creating  13, 43, 61, 139

defined  10

fitting layers to  44

importing  11

nesting  15

rendering  54

retiming  172

swapping into a layer  127

Composition Settings dialog box  43, 61

compression  357

Convert Audio To Keyframes  114

Convert To Editable Text command  26, 75

Convert Vertex tool  186, 187

coordinates

entering for effects  20

measured in After Effects and  
Cinema 4D Lite  279

copying animation to other elements  312

Corner Pin effect  166

Create Text And Camera command  299

creating

compositions  13, 61

shape layers  92, 126, 324

text  46

current-time indicator  25

current time in the Timeline panel  25
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customizing

brightness of the user interface  35

preset paths  78

workspaces  35

custom shapes, drawing  100–101

Custom View 1, in 3D views  270

D

default preferences  2

restoring in Windows  9

Deform pins

about  206

adding  206

customizing  207

dependencies, finding missing  13

depth of field, adjusting  312

deselecting layers  16

direction handles, breaking  187

Dissolve - Vapor animation preset  52

distortions, rolling shutter  296

docking panels  8

drawing

circles  340

custom shapes  100

ellipses  196

rectangles  96

shapes  96

drift, in motion tracking  327

Drop Shadow effect  48

drop zone  8

duplicating

animations using pick whips  156

layers  17

objects in a scene  261

duration  95, 122

about  28

changing  198

E

Easy Ease

about  29

adding  29, 71, 134

adjusting  177

in the Graph Editor  347

editing

masks  184

Premiere Pro clips in After Effects  220

segmentation boundaries  224

text  75

Effect Controls panel  20

about  48

hiding properties in  22

setting properties in  20, 29–30

effects

about  17

applying  48, 135

Auto Levels  251

CC Particle Systems II  334

Channel Blur  29–30

Color Emboss  49

Color Range  255–256

controlling  48

Corner Pin  166

Dissolve - Vapor animation preset  52–53
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Drop Shadow  48

Exposure  21

finding  19

Glow  233

Hue/Saturation  231

Lens Flare  168, 342

missing  13

motion blur  90

Radial Blur  18

Radio Waves  137

Ramp  341

Refine Hard Matte  229

Refine Soft Matte  229

SA Color Finesse 3  243

Stretch And Pitch, in Audition  146

Timewarp  344

Zoom-Bubble  27

Effects & Presets panel  19, 27

Ellipse tool  196, 340

using to create a mask  197

encoding presets in Adobe Media  
Encoder  362

end bracket, setting for the work area  69

Evaporate animation preset  68

Expand Or Collapse The In/Out/Duration/
Stretch Panes button  136

exporting

for Cinema 4D  281

movies with Adobe Media Encoder  361

Exposure effect  21

expressions  114, 262

about  156

adding  144

applying  156

linking animations through  156

working with  144

Extrude in Cinema 4D Lite  284

extruding text

in After Effects  289

in Cinema 4D Lite  284–285

F

Fade Up Characters animation preset  76

fading in images  142

Fast Blur effect  259

feathering masks  193

fills, gradient  97

filtering fonts in Typekit  63

finding missing footage, fonts, or effects  13

First Margin value  89

Fit To Comp command  44

Fit To Comp Width command  66

fonts

finding missing  13

selecting  65

footage

about  10

finding missing  13

importing  10, 13, 60

importing using Adobe Bridge  41

tracking  297

foreground strokes, creating with the Roto 
Brush tool  221–222

freezing Roto Brush tool results  229
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G

Glow effect  233

gradient fills  97

Graph Editor

about  174

in the Timeline panel  25

using to remap time  175, 347

grids

displaying  47, 66

hiding  47, 67

snapping to  66

ground planes, creating with 3D Camera 
Tracker effect  298

H

HDR (high dynamic range) footage  343

hiding properties  22

Home key  27

Horizontal Type tool  27, 46, 80

Hue/Saturation effect  231

I

importing

files from Adobe Bridge  42

footage  10, 13, 41, 60

multiple files  10

Photoshop files  10, 74

text  74–75

Increase Tracking animation preset  80

Increment And Save command  232–233

Info panel  96

In point  25, 122

installing After Effects  2

interpolation between keyframes  29

In value for a layer  136

J

JavaScript in expressions  156

K

keyframes

about  29

adding to current time  211

copying from one layer to another  134

creating from audio amplitude  114

keyframing motion paths  128

keying  218

with Color Range effect  255

with Keylight 1.2 effect  246

Keylight 1.2 effect  248–250

L

layer features, used when snapping  108

Layer Name column  16

layers

about  13, 16

animating  148, 151

animating to match audio  114

child  72, 73

converting to 3D layers  271

copying keyframes from  134

deselecting  16
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duplicating  17

expanding in the Timeline panel  22

fitting to compositions  44

importing in Photoshop files  151

light, 3D  272–274

making visible in the Timeline panel  31

modifying the In values for  136

naming in Photoshop  152

naming text layers  47

nesting  51

null  308

parent  72, 73

precomposing  162, 51

rearranging in the Timeline panel  16

renaming  18, 75

scaling  204

shape  92, 96

snapping  106

solid  107, 135

soloing  155

text  62

transforming properties  22

trimming  122

viewing multiple properties  213

layer styles  153

Layer switches in the Timeline panel  25

learning resources for Adobe After  
Effects CC  5

Lens Flare effect  168, 342

lesson files, downloading  3

Levels (Individual Controls) effect  241

lighting, simulating changes in  154

lightning bolt, drawing  100–101

lights

adding to a 3D scene  271–273

ambient  305

point  304

Light Settings dialog box  272

linking animations through expressions  156

looping audio tracks  143

M

Magnification Ratio pop-up menu  96

Mask Expansion setting  248

Mask Feather tool  193

mask modes  247

Add  248

Subtract  248

masks

about  182

alpha mattes in  126

creating Bezier  186, 188

creating with the Pen tool  183

curved  186

drawing with the Ellipse tool  197

drawing with the Rectangle tool  197

editing  184

feathering  193

inverting  184

layers  126

modes for  185

modifying with the Convert Vertex  
tool  186

properties, displaying  184

replacing content of  189
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masks (continued) 

segments  182

tips for creating  198

tracking  246

vector shapes  124

vertices  182

working with  180

mask shapes, copying  88

mask tracker  246–248, 253–255

Master Exposure (Exposure effect)  22

Material Options properties  269, 274

mattes

about  218

adjusting with the Refine Edge tool  228

screen  250

track  163

traveling  163

viewing against black  223

viewing with red overlay  223

Maxon Cinema 4D Exporter  281

Maxon Cinema 4D Lite  279–286

meshes

adjusting the Triangle value  208

used with Puppet tools  206

missing fonts, effects, or footage  13

mobile devices, preparing compositions  
for  360

mocha for After Effects  333

modes, mask  185

motion

animating  158

stabilization  318

motion blur, adding  90, 122, 131, 164

motion paths

about  129

animating nontext layers along  88

hiding  31

keyframing  128

viewing in the Composition panel  121

Motion Source  326

Motion Target  326

motion tracking  252–253, 256–257

analyzing and applying  326, 332

drift  327

multipoint  329

single-point  322

N

navigating folders in Adobe Bridge  41

nesting

compositions  15

layers  51

NTSC D1 preset  43

null objects  280, 308

O

opacity

animating  82, 142, 278

modifying  24, 53

optimizing performance in After  
Effects  2, 33

Orient Along Path option  89

Out point  25, 122
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output modules in the Render Queue  
panel  55

outputting projects  350

overlap, defining areas of  208

Overlap pins

about  206

customizing  209

overscan, accounting for  31

P

panels

docking and arranging  8

groups  8

maximizing  10

menus  25

Paragraph panel  66

paragraph text  62

parallel corner-pinning  329

parenting  72, 119

object to null layer  309

text in Cinema 4D Lite  284

parent layers  119

about  72, 73

animating  120

creating  128

particle systems

creating  334–335

customizing  336

path preset, using to animate text  77

Pen tool  183

performance, optimizing  2, 33

perspective corner-pinning  329

Photoshop. See Adobe Photoshop files

pick whip  309

using to duplicate animation  156

Pipes animation preset  78

pixel aspect ratio  364

point light, creating  304

point of interest

for a 3D light  272

for a camera layer  276

point text  65

Position property

displaying in the Timeline panel  23

for a 3D layer  190

Pre-compose dialog box  51

precomposing layers  51, 51

preferences

location of files  3

restoring defaults  2

restoring defaults in Windows  9

Premiere Pro. See Adobe Premiere Pro

preset paths, customizing  78

presets

browsing in Adobe Bridge  68

creating for Adobe Media Encoder  364

finding  19

previewing

audio files in Adobe Bridge  143

compositions  31, 53

images in Adobe Bridge  42

limiting to a range of frames  68

manual  50

RAM  32

spacebar  31

standard  31
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Preview panel in Adobe Bridge  42

Project panel  12

projects

about  10

saving  13

properties

changing values for multiple layers  24

displaying in the Timeline panel  23

hiding  22

Puppet Overlap tool

about  206

using  208

Puppet Pin tool  206

Puppet Sketch tool  214

Puppet Starch tool

about  206

using  209

Puppet tools  200

about  206

customizing Overlap pins  209

preparing artwork for use with  205

recording animation with  214

settings for Starch pins  209

using the mesh  206

Q

QuickTime required version  2

R

Radial Blur effect  18

Radio Waves effect  137

Ramp effect  341

RAM previews  33

Ray-Traced 3D Renderer  289

Rectangle tool  96, 197

red overlay in matte preview  223

Reduce Chatter value  228

Refine Edge tool  228–229

Refine Hard Matte effect  229

Refine Soft Matte effect  229

reflections, adding to video  192

remap-time marker in the Source Time  
ruler  173

renaming layers  18

Renderer options in the Cineware effect  281

rendering  313

compositions  54

for mobile devices  360

movies  350

templates  353

test movies  358

using compression in  357

using the Render Queue panel  234, 359

with Adobe Media Encoder  361–366

Render Queue panel  54, 171, 172, 234

adding compositions to  54

opening  54

output modules  55

Render Settings options  55

render-settings templates  353

Repeater path operation  102–105

replacing content using a mask  189

resizing layers  204

resources for using After Effects  36
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restoring default preferences  9, 40, 60

retiming

compositions  172

playback  344

rolling shutter distortions, repairing  296

rotating 3D layers  191

Roto Brush & Refine Edge effect  227

Roto Brush tool  216–235

creating background strokes  
with  222–223

creating foreground strokes  
with  220–221

freezing results  229

refining a segmentation boundary  224

rotoscoping  218

S

SA Color Finesse 3 effect  243–246

safe zones  31

sample text, using in Typekit  64

sampling algorithms  319

saving projects  13

scaling layers  204

screen matte  250

segmentation boundary

about  220

creating  220–223

refining  224

segments in a mask  182

selectors in text animator groups  83

Select View Layout pop-up menu  270

self-animating shapes  101

separating background from  
foreground  218–235

Sequence Layers option  239

shadow catcher  304

shadows

adding to a 3D scene  274

creating with the 3D Camera Tracker  
effect  303

shape layers

about  92, 94

adding  96

applying gradient fills to  97

creating  92–115, 126, 324

using animation presets with  126

shapes

creating a spiral  96–100

custom  100–101

drawing  96, 100

duplicating  102–105

self-animating  101

twisting  97

using as masks  124

shortcuts for Transform properties  23

shortening layers  122, 198

Shutter Angle

about  165

adjusting  165

Shutter Phase  165

skewing text  84

slide shows  138

smoothing animations with Easy Ease  29

snapping

features  108

layers  106–110
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Snapping option

about  108

temporarily enabling  108

Snap to Grid command  66

solid layers

about  135

creating  107, 135

using to create particle systems  335

soloing layers  155

sorting fonts in Typekit  63

Source Name column  16

Source Time ruler in time remapping  173

spacebar preview  31

span, extending for Roto Brush tool  224

Specular Intensity  274

Specular Shininess  274

spiral, creating in After Effects  96–100

splitting the Composition panel into 
multiple views  270

squash and stretch animation  210

stabilizing motion  318

standard preview  31

Starch pins

about  206

adding  209

settings  209

Stretch And Pitch effect, in Audition  146

Subdivision Surface icon in Cinema 4D  
Lite  284

Subtract mask mode  248

surface, adding to objects in Cinema 4D  
Lite  286

synchronizing audio with animation  114

Sync Selected Fonts  64

T

templates for rendering  353

text

adding a bevel in Cinema 4D Lite  285

animating  60–91, 74, 76, 83

animating tracking in  80

animating using a path preset  77

animation presets for  27–28, 67

beveling in Cinema 4D Lite  285

centering  268

converting to editable  75

creating  46

creating 3D  267–269

creating 3D in Cinema 4D Lite  282–284

editing  75

entering in the Composition panel  65

extruding in After Effects  289

extruding in Cinema 4D Lite  284

formatting  65, 233

formatting in Cinema 4D Lite  283

imported from Photoshop  74

layers  62

naming layers  47

point  65

positioning  66

skewing  84

text animator groups  82

Text tool in Cinema 4D Lite  283
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time

current-time field  25

current-time indicator  25

duration  28

measuring  211

specifying in the Duration box  95

timecode  28

time graph  25

time-lapse simulation, creating  172

Timeline panel

about  25

displaying properties in  23, 24

expanding layers in  22

renaming layers in  75

viewing multiple layer properties in  213

Time Remap keyframes  175

Time Remapping  144

Time-Reverse Keyframes command  70

time ruler

about  25

in the Timeline panel  25

Time Stretch dialog box  136

Timewarp effect  344

title-safe zones  31

Toggle Alpha Boundary button  223

Toggle Alpha button  223

Toggle Alpha Overlay button  223

Toggle Switches/Modes button  127

Toggle Transparency Grid button  230

tools

Clone Stamp  261

Mask Feather  193

Puppet  206

Tools panel

about  17

selecting hidden tools in  17

Track Camera command  297

Tracker panel  247, 252

tracking

animating for text  80

masks  253–255

motion  256–257

using Mocha for After Effects  333

tracking motion

multipoint  329

single-point  322

using the 3D Camera Tracker  297

tracking presets

customizing  81

using to animate text  80

track mattes

about  163

creating  162, 163

Track Motion  252

track points  252

3D Camera Tracker  297

moving and resizing  328

positioning  325, 331

Track Selected Masks Backward button  247

Transform properties  22

transitions, adding  239

transparency  53

traveling mattes  163

Triangle value for Puppet  
tools  208
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trimming

layers  122

the work area  198

TrkMat menu  127

twisting shapes  97

Twist path operation  97–100

Typekit. See Adobe Typekit

filtering fonts in  63

U

undocking panels  8

User Interface Colors  35

user interface, introduction to  8

V

vector shapes, masking  
with  124

vertices

converting  186

in a mask  182

Video switch  31, 52

views, 3D  269

vignettes, applying  196, 260

W

walking cycle, animating  210

Warp Stabilizer VFX  318–322

settings  321, 323

Wiggle Paths operation  101

work area

brackets  25, 69

introduction to  8

trimming in the Timeline panel  198

workflow  9

workspaces

customizing  8

in Adobe Bridge  42

predefined  34

saving custom  35

X

x axis  20

in the 3D axis  269

Y

y axis  20

in the 3D axis  269

Z

z axis  267

in the 3D axis  269

Zoom-Bubble effect  27
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