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GETTING STARTED

Adobe® Dreamweaver® CC is the industry-leading web authoring program. Whether 

you create websites for others for a living or plan to create one for your own business, 

Dreamweaver offers all the tools you need to get professional-quality results.

About Classroom in a Book

Adobe Dreamweaver CC Classroom in a Book® (2014 release) is part of the official 

training series for graphics and publishing software developed with the support of 

Adobe product experts.

The lessons are designed so you can learn at your own pace. If you’re new to 

Dreamweaver, you’ll learn the fundamentals of putting the program to work. If you 

are an experienced user, you’ll find that Classroom in a Book teaches many advanced 

features, including tips and techniques for using the latest version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specific 

project, you’ll have room for exploration and experimentation. You can follow the 

book from start to finish, or complete only those lessons that correspond to your 

interests and needs. Each lesson concludes with a review section containing ques-

tions and answers on the subjects you’ve covered.

TinyURLs

At several points in the book, we reference external information available on the 

Internet. The uniform resource locators (URLs) for this information are often long 

and unwieldy, so we have provided custom TinyURLs in many places for your con-

venience. Unfortunately, the TinyURLs sometimes expire over time and no longer 

function. If you find that a TinyURL doesn’t work, look up the actual URL provided 

in the Appendix.
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Prerequisites

Before using Adobe Dreamweaver CC Classroom in a Book (2014 release), you should 

have a working knowledge of your computer and its operating system. Be sure you 

know how to use the mouse, standard menus, and commands, and also how to open, 

save, and close files. If you need to review these techniques, see the printed or online 

documentation included with your Windows or Mac operating system.

Conventions used in this book

Working in Dreamweaver means you’ll be working with code. We have used several 

conventions in the following lessons and exercises to make working with the code 

in this book easier to follow and understand. 

Code font 

In many instructions, you will be required to enter HTML code, CSS rules, and 

properties and other code-based markup. To distinguish the markup from the body 

of the text instructions, the entries will be styled with a code font, like this:

Examine the following code <h1>Heading goes here</h1>

In instances where you must enter the markup yourself, the entry will be formatted 

in color, like this:

Insert the following code <h1>Heading goes here</h1>

Strikethrough

In several exercises, you will be instructed to delete markup that already exists 

within the webpage or style sheet. In those instances, the targeted references will be 

identified with strikethrough formatting, like this:

Delete the following values: 

margin: 10px 20px 10px 20px;
background-image: url(images/fern.png), url(images/stripe.png);

Be careful to delete only the identified markup so that you achieve the 

following result:

margin: 10px 10px;
background-image: url(images/fern.png);
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Missing punctuation

HTML code, CSS markup, and JavaScript often requires the use of various punc-

tuation, like periods (.), commas (,), and semicolons (;) among others, and can be 

damaged by their incorrect usage or placement. Consequently, periods and other 

punctuation expected in a sentence or paragraph may be omitted from an instruc-

tion or hyperlink whenever it may cause confusion or a possible error, like this:

Enter the following code <h1>Heading goes here</h1>

Type the following link: http://adobe.com

Element references

Within the body of descriptions and exercise instructions, elements may be ref-

erenced by name or by class or id attributes. When an element is identified by its 

tag name, it will appear as <h1> or h1. When referenced by its class attribute, the 

name will appear with a leading period (.) in a code-like font, like this .content

or .sidebar1. References to elements by their id attribute will appear with a lead-

ing hash (#) and in a code font, like this #top. This practice matches the way these 

elements appear in Dreamweaver’s tag selector interface. 

Windows vs. OS X instructions

In most cases, Dreamweaver performs identically in both Windows and OS X.

Minor differences exist between the two versions, mostly due to platform-specific 

issues out of the control of the program. Most of these are simply differences in 

keyboard shortcuts, how dialogs are displayed, and how buttons are named. In 

most cases, screen shots were made in the OS X version of Dreamweaver and may 

appear differently from your own screen. 

Where specific commands differ, they are noted within the text. Windows com-

mands are listed first, followed by the OS X equivalent, such as Ctrl+C/Cmd+C. 

Common abbreviations are used for all commands whenever possible, as follows:

W I N D O W S O S  X

Control = Ctrl Command = Cmd

Alternate = Alt Option = Opt

As lessons proceed, instructions may be truncated or shortened to save space, with 

the assumption that you picked up the essential concepts earlier in the lesson. If 

you find you have difficulties in any particular task, review earlier steps or exercises 

in that lesson.

http://adobe.com
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Installing the program

Before you perform any exercises in this book, verify that your computer system 

meets the hardware requirements for Dreamweaver, that it’s correctly configured, 

and that all required software is installed.

Adobe Dreamweaver must be purchased separately; it is not included with the 

lesson files that accompany this book. Go to www.adobe.com/products/dream-

weaver/tech-specs.html to obtain the system requirements. 

Go to https://creative.adobe.com/plans to sign up for Adobe Creative Cloud. 

Dreamweaver may be purchased with the entire Creative Cloud family or as a 

standalone app. Adobe also allows you to try the Creative Cloud and the individual 

applications for 30 days for free. 

Check www.adobe.com/products/dreamweaver.html to learn more about the 

different options for obtaining Dreamweaver.

http://www.adobe.com/products/dreamweaver/tech-specs.html
http://www.adobe.com/products/dreamweaver/tech-specs.html
https://creative.adobe.com/plans
http://www.adobe.com/products/dreamweaver.html
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Updating Dreamweaver to the latest version

Although Dreamweaver is downloaded fully and installed on your computer hard 

drive, periodic updates are provided via the Creative Cloud. Some updates pro-

vide bug fixes and security patches, while others supply amazing new features 

and capabilities. The lessons in this book are based on Dreamweaver CC (2014.1 

release) and may not work properly in any earlier version of the program. To check 

what version is installed on your computer, choose Help > About Dreamweaver in 

Windows or Dreamweaver > About Dreamweaver on the Macintosh. A window 

will display the version number of the application and other pertinent information.

If you do not have Dreamweaver, you will first have to install it from scratch from 

the Creative Cloud or, if you have an earlier version of the program installed, you will 

have to update Dreamweaver to the latest version. You can check the status of your 

installation by opening the Creative Cloud manager and logging in to your account.

Check out https://helpx.adobe.com/creative-cloud/help/download-install-

trials.html to learn how to download and install Creative Cloud to your computer 

or laptop.

https://helpx.adobe.com/creative-cloud/help/download-installtrials.html
https://helpx.adobe.com/creative-cloud/help/download-installtrials.html
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Accessing the Classroom in a Book files
In order to work through the projects in this book, you will first need to download 
the lesson files from peachpit.com. 

To access the Classroom in a Book lesson files:

1	 On a Mac or PC, go to www.peachpit.com/redeem, and enter the code found at 
the beginning of your book.

2	 If you do not have a peachpit.com account, you will be prompted to create one.

3	 The downloadable files will be listed under the Lesson & Update Files tab on 
your Account page. 

4	 Click the lesson file links to download them to your computer. You can download 
the files for individual lessons, or download them all at once in one large file.

The files are compressed into Zip archives to speed up download time and to 
protect the contents from damage during transfer. You must uncompress (or 
“unzip”) the files to restore them to their original size and format before you use 
them with the book. Modern Mac and Windows systems are set up to open Zip 
archives by simply double-clicking.

P	Note:  Do not copy 
one lesson folder into 
any other lesson folder. 
The files and folders for 
each lesson cannot be 
used interchangeably.

9780133924404_Dreamweaver2014CIB_pr1.indb   6 11/24/14   8:19 AM

http://www.peachpit.com/redeem


ADOBE DREAMWEAVER CC CLASSROOM IN A BOOK 2014 RELEASE 7

5 Do one of the following:

• If you downloaded DWCC2014_lesson_files.zip, unzipping the archive will 

produce a folder named DWCC2014_Lesson_Files containing all of the 

lesson files used by the book. 

• If you downloaded the lessons individually, create a new folder and name it 

DWCC2014. Download and unzip the individual lesson files to this folder. 

That way, all the lesson files will be stored in one location.

Recommended lesson order

The training in this book is designed to take you from A to Z in basic to inter-

mediate website design, development, and production. Each new lesson builds 

on previous exercises, using supplied files and assets, to create an entire website. 

We recommend that you download all lesson files at once and then perform each 

lesson in sequential order to achieve a successful result and the most complete 

understanding of all aspects of web design.

The ideal training scenario will start in Lesson 1 and proceed through the entire 

book to Lesson 13. Each lesson builds the skills and understanding necessary to 

complete subsequent tasks. We recommend that you do not skip any lessons, or 

even individual exercises. While ideal, this method may not be a practicable sce-

nario for every user. So, each lesson folder contains all the files needed to complete 

every exercise using partially completed or staged assets, allowing you to complete 

individual lessons out of order, if desired.

However, don’t assume that the staged files and customized templates in each les-

son represent a complete set of assets. You may think these folders contain seem-

ingly duplicative materials. But these duplicate files and assets, in most cases, can-

not be used interchangeably in other lessons and exercises. Doing so will probably 

cause you to fail to achieve the goal of the exercise. 

For that reason, you should treat each folder as a standalone website. Copy the 

lesson folder to your hard drive, and create a new site for that lesson using the Site 

Setup dialog. Do not define sites using subfolders of existing sites. Keep your sites 

and assets in their original folders to avoid conflicts. One suggestion is to organize 

the lesson folders in a single web or sites master folder near the root of your hard 

drive. But avoid using the Dreamweaver application folder or any folders that con-

tain a web server, like Apache, ColdFusion, or Internet Information Services (IIS).
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Defining a Dreamweaver site

In the course of completing the following lessons, you will create webpages from 

scratch and use existing files and resources that are stored on your hard drive. The 

resulting webpages and assets make up what’s called your local site. When you are 

ready to upload your site to the Internet (see Lesson 13, “Publishing to the Web”), 

you publish your completed files to a web host server, which then becomes your 

remote site. The folder structures and files of the local and remote sites are usually 

mirror images of one another. 

The first step is to define your local site:

1 Launch Adobe Dreamweaver CC (2014.1 release) or later.

2 Open the Site menu.

The Site menu provides options for creating and managing standard 

Dreamweaver sites. 

3 Choose New Site.

To create a standard website in Dreamweaver, you need only name it and select 

the local site folder. Site names typically relate to a specific project or client and 

appear in the Files panel. This name is intended for your own purposes, so there 

are no limitations to the name you can create. Use a name that clearly describes 

the purpose of the website. For the purposes of this book, use the name of the 

lesson you intend to complete, such as lesson01, lesson02, lesson03, and so on.

4 Type lesson01 or another name as appropriate, in the Site Name field.

5 Next to the Local Site Folder field, click the Browse for folder icon .

The Choose Root Folder dialog appears. 
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6 Navigate to the appropriate folder containing the lesson files you downloaded 

from Peachpit.com (as described earlier), and click Select/Choose.

You could click Save at this time and begin working on your new website, but 

we’ll add one more piece of handy information.

7 Click the arrow  next to the Advanced Settings category to reveal the 

categories listed there. Select Local Info.

Although it’s not required, a good policy for site management is to store 

different file types in separate folders. For example, many websites provide 

individual folders for images, PDFs, videos, and so on. Dreamweaver assists in 

this endeavor by including an option for a Default Images folder. Later, as you 

insert images from other places on your computer, Dreamweaver will use this 

setting to automatically move the images into the site structure.

8 Next to the Default Images Folder field, click the Browse for folder icon .

When the dialog opens, navigate to the appropriate images folder for that lesson 

or site, and click Select/Choose.

If you have already purchased and set up your website domain, you should enter 

it in this dialog.

9 Enter http://green-start.org for the lessons in this book or your own website 

URL in the Web URL field.

� Note: The main 
folder that contains the 
site will be referred to 
throughout the book as 
the site root folder.

� Note: Resource 
folders for images and 
other assets should 
always be contained 
within the main site 
root folder.

� Note: The folder 
that contains the image 
assets will be referred to 
throughout the book as 
the site default images 
folder or the default 
images folder.

http://green-start.org
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You’ve entered all the information required to begin your new site. In 

subsequent lessons, you’ll add more information to enable you to upload files to 

your remote site and test dynamic web pages. 

10 In the Site Setup dialog, click Save.

The site name now appears in the site list drop-down menu in the Files panel. 

As you add more site definitions, you can switch between the sites by selecting 

the appropriate name from this menu. When a site is selected or modified, 

Dreamweaver will build, or rebuild, a cache that examines every file in the 

folder. The cache identifies relationships between the web pages and the assets 

within sites, and will assist you whenever a file is moved, renamed, or deleted to 

update links or other referenced information.  

Setting up a site is a crucial first step in beginning any project in Dreamweaver. 

Knowing where the site root folder is located helps Dreamweaver determine link 

pathways and enables many site-wide options, such as orphaned-file checking and 

Find and Replace.
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Setting up the workspace

Dreamweaver CC (2014.1 release) includes three main workspaces to accommo-

date various computer configurations and individual workflows. For this book, the 

Design workspace is recommended.

1 If the Design workspace is not displayed by default, you can select it from the 

Workspace drop-down menu on the top-right side of the screen.

2 If the default Design workspace has been modified—where certain toolbars 

and panels are not visible (as they appear in the figures in the book)—you can 

restore the factory setting by choosing Reset ‘Design’ from the Workspace drop-

down menu.

Workspace Layout options can also be accessed from the Window menu.
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Most of the figures in this book show the Design workspace. When you finish the 

lessons in this book, experiment with each workspace to find the one that you pre-

fer, or build your own configuration and save the layout under a custom name.

For a more complete description of the Dreamweaver workspaces, see Lesson 1, 

“Customizing Your Workspace.”

Checking for updates

Adobe periodically provides software updates. To check for updates in the pro-

gram, choose Help > Updates. For book updates and bonus material, visit your 

Account page on Peachpit.com and select the Lesson & Update Files tab.

Additional resources

Adobe Dreamweaver CC Classroom in a Book (2014 release) is not meant to replace 

documentation that comes with the program or to be a comprehensive reference 

for every feature. Only the commands and options used in the lessons are explained 

in this book. For comprehensive information about program features and tutorials, 

refer to these resources:

Adobe Dreamweaver Learn and Support: helpx.adobe.com/dreamweaver.html 

(accessible in Dreamweaver by choosing Help > Help And Support > Dreamweaver 

Support Center) has comprehensive content you can search or browse, provided by 

Adobe. This includes hands-on tutorials, answers to common questions, trouble-

shooting information, and more. 

Dreamweaver Help: helpx.adobe.com/dreamweaver/topics.html is a reference for 

application features, commands, and tools (press F1 or choose Help > Help And 

Support > Dreamweaver Online Help). You can also download Help as a PDF docu-

ment optimized for printing at helpx.adobe.com/pdf/dreamweaver_reference.pdf.

Dreamweaver Forums: forums.adobe.com/community/dreamweaver lets you tap 

into peer-to-peer discussions and questions and answers on Adobe products.

Adobe Creative Cloud Learn & Support: helpx.adobe.com/support.html provides 

inspiration, key techniques, cross-product workflows, and updates on new features. 

Resources for educators: www.adobe.com/education and edex.adobe.com offer a 

treasure trove of information for instructors who teach classes on Adobe software. 

You’ll find solutions for education at all levels, including free curricula that use an 

integrated approach to teaching Adobe software and can be used to prepare for the 

Adobe Certified Associate exams.

http://www.adobe.com/education
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Also check out these useful links:

Adobe Add-ons: creative.adobe.com/addons is a central resource for finding 

tools, services, extensions, code samples, and more to supplement and extend your 

Adobe products.

Adobe Dreamweaver CC product home page: www.adobe.com/products/

dreamweaver has more information about the product.

Adobe Authorized Training Centers: Adobe Authorized Training 

Centers offer instructor-led courses and training on Adobe products. See 

http://training.adobe.com/training/partner-finder.html for a directory of AATC.

http://www.adobe.com/products/dreamweaver
http://www.adobe.com/products/dreamweaver
http://training.adobe.com/training/partner-.nder.html


114

Lesson overview

In this lesson, you’ll learn the following:

• The basics of webpage design

• How to create page thumbnails and wireframes

• How to use Photoshop to generate site image assets automatically

This lesson will take about 45 minutes to complete. If you have not 

already done so, download the project files for this lesson from the 

Lesson & Update Files tab on your Account page at www.peachpit.com, 

store them on your computer in a convenient location, and define a new 

site in Dreamweaver based on this folder, as described in the “Getting 

Started” section of this book. Your Account page is also where you’ll find 

any updates to the chapters or to the lesson files. Look on the Lesson & 

Update Files tab to access the most current content. 

WEB DESIGN BASICS4

http://www.peachpit.com
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Whether you use thumbnails and wireframes, 
Photoshop or just a vivid imagination, Dreamweaver 
can quickly turn your design concepts into complete, 
standards-based CSS layouts.
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Developing a new website

Before you begin any web design project for yourself or for a client, you need to 

answer three important questions:

• What is the purpose of the website?

• Who is the audience?

• How do they get here?

What is the purpose of the website?

Will the website sell or support a product or service? Is your site for entertainment 

or games? Will you provide information or news? Will you need a shopping cart 

or database? Do you need to accept credit card payments or electronic transfers? 

Knowing the purpose of the website tells you what type of content you’ll be devel-

oping and working with and what types of technologies you’ll need to incorporate.

Who is the audience?

Is the audience adults, children, seniors, professionals, hobbyists, men, women, 

everyone? Knowing who your audience will be is vital to the overall design and 

functionality of your site. A site intended for children probably needs more anima-

tion, interactivity, and bright engaging colors. Adults will want serious content and 

in-depth analysis. Seniors may need larger type and other accessibility enhancements.

A good first step is to check out the competition. Is there an existing website 

performing the same service or selling the same product? Are they successful? 

You don’t have to mimic others just because they’re doing the same thing. Look 

at Google and Yahoo—they perform the same basic service, but their site designs 

couldn’t be more different from one another.
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How do they get here?

This sounds like an odd question when speaking of the Internet. But just as with 

a brick-and-mortar business, your online customers can come to you in a variety 

of ways. For example, are they accessing your site on a desktop computer, laptop, 

tablet, or cell phone? Are they using high-speed Internet, wireless, or dial-up ser-

vice? What browser are they most likely to use, and what is the size and resolution 

of the display? These answers will tell you a lot about what kind of experience your 

customers will expect. Dial-up and cell phone users may not want to see a lot of 

graphics or video, whereas users with large flat-panel displays and high-speed con-

nections may demand as much bang and sizzle as you can send at them.

So where do you get this information? Some you’ll have to get through painstaking 

research and demographic analysis. Some you’ll get from educated guesses based 

on your own tastes and understanding of your market. But a lot of it is actually 

available on the Internet itself. W3Schools, for one, keeps track of tons of statistics 

regarding access and usage, all updated regularly:

• w3schools.com/browsers/browsers_stats.asp provides information about 

browser statistics.

• w3schools.com/browsers/browsers_os.asp gives the breakdown on 

operating systems. In 2011, they started to track the usage of mobile devices 

on the Internet.

• w3schools.com/browsers/browsers_display.asp lets you find out the latest 

information on the resolutions, or size, of screens using the Internet.

If you are redesigning an existing site, your web-hosting service itself may provide 

valuable statistics on historical traffic patterns and even the visitors themselves. 

If you host your own site, you can incorporate third-party tools, such as Google 

Analytics and Adobe Omniture, into your code to do the tracking for you for free 

or for a small fee.

As of the fall of 2014, Windows still dominates the Internet (80 to 85 percent), with 

most users favoring Google Chrome (60 percent), followed by Firefox (25 percent), 

with various versions of Internet Explorer (8 percent) a distant third. The vast 

majority of browsers (99 percent) are set to a resolution higher than 1024 pixels by 

768 pixels. If it weren’t for the rapid growth in usage of tablets and smartphones for 

accessing the Internet, these statistics would be great news for most web designers 

and developers. But designing a website that can look good and work effectively for 

both flat-panel displays and cell phones is a tall order.
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Responsive web design

Each day, more people are using cell phones and other mobile devices to access the 
Internet. Some people may use them to access the Internet more frequently than 
they use desktop computers. This presents a few nagging problems to web design-
ers. For one thing, cell phone screens are a fraction of the size of even the smallest 
flat-panel display. How do you cram a two- or three-column page design into a 
meager 200 to 300 pixels? Another problem is that most device manufacturers have 
dropped support for Flash-based content on their mobile devices.

Until recently, web design usually required that you target an optimum size (height 
and width in pixels) for a webpage and then build the entire site on these specifica-
tions. Today, that scenario is becoming a rare occurrence. Now, you are presented 
with the decision to either build a site that can adapt to displays of multiple dif-
ferent dimensions (responsive) or build two or more separate websites to support 
desktop and mobile users at the same time (adaptive).

Your own decision will be based in part on the content you want to provide and on 
the capabilities of the devices accessing your pages. Building an attractive website 
that supports video, audio, and other dynamic content is hard enough without 
throwing in a panoply of different display sizes and device capabilities. The term 
responsive web design was coined by a Boston-based web developer named Ethan 
Marcotte, in a book by the same name (2011), which describes the notion of design-
ing pages that can adapt to multiple screen dimensions automatically. As you work 
through the following lessons, you will learn many techniques for responsive web 
design and implement them in your site and asset design. 

Many of the concepts of print design are not applicable to the web, because you are not 
in control of the user’s experience. A page carefully designed for a typical flat panel is 
basically useless on a cell phone.



ADOBE DREAMWEAVER CC CLASSROOM IN A BOOK 2014 RELEASE 119

Scenario

For the purposes of this book, you’ll be working to develop a website for Meridien 

GreenStart, a fictitious community-based organization dedicated to green invest-

ment and action. This website will offer a variety of products and services and 

require a broad range of webpage types, including dynamic pages using technolo-

gies like jQuery, which is a form of JavaScript.

Your customers come from a wide demographic that includes all ages and educa-

tion levels. They are people who are concerned about environmental conditions 

and who are dedicated to conservation, recycling, and the reuse of natural and 

human resources.

Your marketing research indicates that most of your customers use desktop com-

puters or laptops, connecting via high-speed Internet services. You can expect to 

get 20 to 30 percent of your visitors exclusively via cell phone and other mobile 

devices, and much of the rest will be using mobile from time to time. 

To simplify the process of learning Dreamweaver, we’ll focus on creating a fixed-

width site design first. In Lesson 5, “Designing for Mobile Devices,” you’ll learn how 

to adapt your fixed-width design to work with smartphones and tablets.

Working with thumbnails and wireframes

After you have nailed down the answers to the three questions about your website 

purpose, customer demographic, and access model, the next step is to determine 

how many pages you’ll need, what those pages will do, and finally, what they will 

look like.

Creating thumbnails

Many web designers start by drawing thumbnails with pencil and paper. Think of 

thumbnails as a graphical shopping list of the pages you’ll need to create for the 

website. Thumbnails can also help you work out the basic navigation structure 

for the site. Draw lines between the thumbnails showing how your navigation will 

connect them.
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Most sites are divided into levels. Typically, the first level includes all the pages in 

your main navigation menu—the ones a visitor can reach directly from the home 

page. The second level includes pages you can reach only through specific actions 

or from specific locations, say from a shopping cart or product detail page.

Creating a page design

Once you’ve figured out what your site needs in terms of pages, products, and 

services, you can then turn to what those pages will look like. Make a list of compo-

nents you want or need on each page, such as headers and footers, navigation, and 

areas for the main content and the sidebars (if any). Put aside any items that won’t 

be needed on every page. What other factors do you need to consider? If mobile 

devices are going to be an important consideration of your design identity, which 

of the components will be required or optional for these devices? While many com-

ponents can be simply resized for mobile screens, some will have to be completely 

redesigned or reimagined. 

Thumbnails list the 
pages that need to 
be built and how 
they are connected to 
each other.

Identifying the essential 
components for each 
page helps to create an 
effective page design 
and structure that will 
meet your needs.
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Do you have a company logo, business identity, graphic imagery, or color scheme 

you want to match or complement? Do you have publications, brochures, or cur-

rent advertising campaigns you want to emulate? It helps to gather them all in one 

place so you can see everything all at once on a desk or conference table. If you’re 

lucky, a theme will rise organically from this collection.

Desktop or mobile

Once you’ve created your checklist of the components that you’ll need on each page, 

sketch out several rough layouts that work for these components. Depending on your 

target visitor demographics, you may decide to focus on a design that’s optimized for 

desktop computers or one that works best on tablets and smartphones. 

Most designers settle on one basic page design that is a compromise between 

flexibility and sizzle. Some site designs may naturally lean toward using more than 

one basic layout. But resist the urge to design each page separately. Minimizing the 

number of page designs may sound like a major limitation, but it’s key to producing 

a professional-looking site that’s easy to manage. It’s the reason why some profes-

sionals, like doctors and airline pilots, wear uniforms. Using a consistent page 

design, or template, conveys a sense of professionalism and confidence to your visi-

tor. While you’re figuring out what your pages will look like, you’ll have to address 

the size and placement of the basic components. Where you put a component can 

drastically affect its impact and usefulness. 

In print, designers know that the upper-left corner of a layout is considered one 

of the “power positions,” a place where you want to locate important aspects of 

a design, such as a logo or title. This is because in western culture we read from 

left to right, top to bottom. The second power position is the lower-right corner, 

because this is the last thing your eyes will see when you’re finished reading.

Unfortunately, in web design this theory doesn’t hold up for one simple reason: You 

can never be certain how the user is seeing your design. Are they on a 20-inch flat 

panel or a 2-inch cell phone?

In most instances, the only thing you can be certain of is that the user can see the 

upper-left corner of any page. Do you want to waste this position by slapping the 

company logo here? Or make the site more useful by slipping in a navigation menu? 

This is one of the key predicaments of the web designer. Do you go for design 

sizzle, workable utility, or something in between?
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Creating wireframes

After you pick the winning design, wireframing is a fast way to work out the 

structure of each page in the site. A wireframe is like a thumbnail, but bigger, that 

sketches out each page and fills in more details about the components, such as 

actual link names and main headings. This step helps to catch or anticipate prob-

lems before you smack into them when working in the code.

Wireframes allow you to experiment with page designs quickly and easily without wasting time with code.

The wireframe for the 
final design should 
identify all components 
and include specific 
information about 
content, color, and 
dimensions.
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Once the basic concepts are worked out, many designers take an extra step and 

create a full-size mockup or “proof of concept” using a program like Adobe 

Fireworks, Photoshop, or even Illustrator. It’s a handy thing to do because you’ll 

find that some clients just aren’t comfortable giving an approval based only on 

pencil sketches. The advantage here is that all these programs allow you to export 

the results to full-size images (JPEG, GIF, or PNG) that can be viewed in a browser. 

Such mockups are as good as seeing the real thing, but may take only a fraction of 

the time to produce.

In addition to creating graphical mockups, Photoshop has recently added some new 

tricks geared specifically for web designers, like the new Adobe Generator feature.

Creating web assets using Adobe 
Generator (optional)

Adobe Generator is one of the new web-oriented tools that allow you to export web 

assets from a Photoshop file in a variety of sizes, resolutions, and even file types. 

Best of all, this feature works in real time, exporting image assets from your file 

based on user-specified attributes added to the layer name. In this exercise, you‘ll 

export web image assets from a webpage mockup created in Photoshop. 

In some cases, creating 
a mockup in Adobe 
Photoshop, Adobe 
Fireworks, or Adobe 
Illustrator can save 
hours of tedious coding 
to receive a needed 
approval.
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Working with Adobe Generator

In this exercise, you’ll work with an Adobe Photoshop document to prepare assets 

for your web project.

1 Launch Photoshop CC or higher.

2 Open GreenStart_mockup.psd from the lesson04 folder.

The Photoshop file contains a complete mockup of the GreenStart site design, 

comprised of various vector-based design components as well as image assets 

stored in separate layers. Note the use of colors and gradients in the design. 

3 Choose File > Save As. Name the file 

myGreenStart_mockup.psd.

4 If necessary, choose Window > Layers to 

display the Layers panel. 

Observe the names and contents of the 

layers and layer groups.

The layers and layer groups are named 

for the webpage components.

5 Open the header layer group, and 

observe the contents.

The header group contains two text 

elements and four graphical elements. 

Often, it’s difficult to understand how a 

graphic component is built or for what 

purpose it is intended by looking at the 

layer names alone. 

� Note: This exercise 
requires the installation 
of Photoshop CC or 
higher and the lesson 
files for lesson04.

� Note: The sample 
file used in this exercise 
requires the font Bree 
Serif, which you can 
download and install 
for free from Adobe 
Typekit. To access this 
font, and the entire 
Typekit library, choose 
Type > Add Fonts from 
Typekit in Photoshop 
CC or higher.

� Tip: It’s a good idea 
to save the file under a 
different name so you 
can refer back to the 
original assets should 
you make an error.
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6 In the GreenStart layer, click the eye icon  to toggle the layer visibility off.

The text “greenstart” disappears from the layer.

7 In the fern layer, click the eye icon  to toggle the layer visibility off. 

The image of the fern disappears. Using this method, you can identify each 

element of the header and see what role it plays in the creation of the overall 

design. The number and type of layers and the level of detail used here aren't 

necessary for a mockup that you merely want to use for a client approval. This 

file was set up specifically to create many of the final assets for the page design.

8 Click the eye icon  to toggle the GreenStart and fern layer back on.

Exporting assets from Photoshop

The fern layer will be used to create one component of the header background. 

Photoshop generates a web asset automatically if you add a file extension to the 

layer name.

1 Double-click to edit the name of the 

fern layer to fern.png, and press 

Enter/Return to complete the name.

When activated, Generator works in 

the background exporting assets in 

real time.

2 Choose File > Generate > 

Image Assets.

The next time you look at the Generate menu option, a checkmark will appear 

beside Image Assets, indicating that Generator is active. 

� Tip: To turn off 
Generator, repeat step 2.
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3 Choose File > Open.

Navigate to the lesson04 > resources folder.

A new folder has been created and named myGreenStart_mockup-assets by 

Generator. Whenever you add file extensions to the layer names and enable 

Generator, it creates a folder and fills it with assets automatically, based on the 

layer names and settings.

4 Navigate to the myGreenStart_mockup-assets folder created by Photoshop.

The folder contains a single image: fern.png.

5 Open fern.png.

The file contains the fern with a transparent background. Note how the image 

displays a drop shadow. The shadow is a permanent part of the image, no longer 

created by a Photoshop effect.
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6 Choose Image > Image Size. Note the dimensions and resolution of the image.

The image is 468 pixels by 157 pixels at 72 pixels per inch (ppi).

7 Click OK to close the Image Size dialog. 

Close fern.png.

Creating multiple assets using Generator

Generator can also modify the default export specifications and even create mul-

tiple assets at multiple resolutions.

1 Change the layer name fern.png to 

200% fern.png+fern.jpg, and press 

Enter/Return to complete the name.

2 Choose File > Open.

If necessary, navigate to the 

myGreenStart_mockup-assets folder.

The folder contains two images: fern.png and fern.jpg, both created 

by Generator.

3 Select fern.png, and open the file.

The file contains the fern, but it appears twice as large as the previous image.

4 Open fern.jpg.

The file contains the same fern image, but at the original size. JPEGs do not 

support transparency, so the background is white. There’s no need for the JPEG 

version of the image. Generator can remove assets automatically, too.

� Note: If you do 
not see the images 
created as described, 
check to make sure 
that the command 
File > Generate > 
Image Assets is enabled 
as described in the 
previous exercise.
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5 Change the layer name 200% fern.png+

fern.jpg to 150% fern.png, and press 

Enter/Return to complete the name.

The new specification creates a larger, 

higher-quality image that will display 

well in regular browsers and on the 

new crop of higher resolution devices. 

By your removing “fern.jpg” from the 

layer name, Generator automatically deletes the JPEG version of the file.

6 Choose File > Open. Navigate to the myGreenStart_mockup-assets folder.

The JPEG version of the file is no longer visible in the folder. As you can see, 

Photoshop generates assets based on the name of the layer. You can create an 

entire set of images for your site design from the layers in this file.

7 In the Layers panel, open the header 

layer group.

Change the name of the stripe layer 

group to stripe.png.

8 Open the sidebar2 layer group.

Change the layer shopping to 

shopping.jpg.

Change the layer biking to biking.jpg.

9 Choose File > Open. Navigate to the 

myGreenStart_mockup-assets folder. 

The myGreenStart_mockup-assets folder now contains four image files. These files 

are identical to the ones you will use to build the site template and populate articles 

in upcoming lessons. As you can see, Generator offers some handy tools for turning 

this mockup into real web design assets, but the tricks don’t stop there. Photoshop 

and Dreamweaver have even more collaboration tools to offer, as you will see later. 

Check out http://helpx.adobe.com/photoshop/using/generate-assets-layers.html to 

see a complete explanation of Adobe Generator and how to use it.

http://helpx.adobe.com/photoshop/using/generate-assets-layers.html
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Review questions

1 What three questions should you ask before starting any web design project?

2 What is the purpose of using thumbnails and wireframes?

3 Why is it important to create a design that takes into account smartphones and tablets?

4 Why would you use Adobe Photoshop, Illustrator, or Fireworks to design a website?

5 How does Adobe Generator assist in the creation of a website design?

Review answers

1 What is the purpose of the website? Who is the audience? How did they get here? 

These questions, and their answers, are essential in helping you develop the design, 

content, and strategy of your site.

2 Thumbnails and wireframes are quick techniques for roughing out the design and 

structure of your site without having to waste lots of time coding sample pages.

3 Mobile device users are one of the fastest growing demographics on the web. Many 

visitors will use a mobile device to access your website on a regular basis or exclusively. 

Webpages designed for desktop computers often display poorly on mobile devices, 

making the websites difficult or impossible to use for these mobile visitors.

4 Using Photoshop, Illustrator, or Fireworks, you can produce page designs and 

mockups much faster than when designing in code with Dreamweaver. Designs can 

even be exported as web-compatible graphics that can be viewed in a browser to get 

client approvals.

5 Adobe Generator allows you to export site image assets quickly from Photoshop 

mockups, allowing you to produce multiple sizes and versions of each asset.
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NUMBERS

4-bit color space, 280

8-bit palette, 280

100% font size, using, 145–146

256 colors, 280

256 shades of gray, 280

SYMBOLS

* (asterisk), appearance in document 

tab, 226

<!-- --> comment, 52, 140

< > (opening and closing tags), using in 

HTL, 41

A

<a> tag, described, 52, 167

absolute hyperlinks. See also hyperlinks

creating in Live view, 318–320

explained, 308–309

Adobe Add-ons link, checking, 13

Adobe Authorized Training Centers, 

contacting, 13

Adobe Creative Cloud Learn & Support 

site, 12. See also Creative Cloud

Adobe Dreamweaver CC product home 

page, 13. See also Dreamweaver

Adobe Dreamweaver Learn and Support 

site, 12

Adobe Edge Inspect. See Edge Inspect

Adobe Generator

exporting assets from Photoshop, 

125–126

features of, 123

using, 124–125

using to create assets, 127–128

Adobe Muse program, features of, 41

Adobe website, 204

all media type property, intended 

use, 184

alpha transparency, 281

Alt key. See keyboard shortcuts

Alt text, using, 285

animation

adding to pages, 367–371

defining Publish Settings, 367

overview of, 364

Apache/ColdFusion web server, 387

Apache/PHP web server, 387

<article> tag, described, 56, 58

<aside> tag, described, 56

Asset panel, identifying, 16

assets

creating using Adobe Generator, 

123–128

exporting from Photoshop, 125–126

Assets panel, docking, 232

asterisk (*), appearance in document 

tab, 226

<audio> tag, described, 56

aural media type property, intended 

use, 184

B

background effects, adding, 158–162

background HTML default, 

described, 66

backgrounds, creating using CSS, 

98–101. See also CSS backgrounds

behaviors

adding to hyperlinks, 342–344

availability of, 335

creating page for, 337

explained, 334

INDEX
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behaviors (continued )

features of, 335

flexibility of, 335

functionality, 334–335

making responsive, 344–346

number of, 334

Preload Images option, 340

removing, 341–342

Swap Image, 339

Swap Image Restore, 340–341

triggering element, 334

Behaviors panel

accessing, 334

identifying, 16

Berners-Lee, Tim, 40–41

bit depth, 280

block elements, explained, 45

<blockquote> tag, described, 52

blockquotes, including quotations in, 173

body rule, setting threshold for, 146

body text HTML default, described, 66

<body> element, using, 45–46, 52

bold formatting, producing in HTML, 49

border effects, creating using CSS, 97–98

boxmodel.html file, opening, 68

<br/> tag, described, 52

braille media type property, intended 

use, 184

Brightness and Contrast tool, 

described, 304

browsers, HTML defaults for, 67

bulleted lists, formatting, 242

C

<canvas> tag, described, 56

caption elements

adding, 261–262

formatting, 261–262

cascade theory, overview of, 73–76

cells. See table cells

child pages

adding content to, 221–224

creating, 220–221

updating hyperlinks in, 316–317

Chrome browser, HTML default for, 67

class attributes, using with CSS, 91

Classroom in a Book files, accessing, 6–7

clipboard, using to import text, 233

cloaking folders and files, 389–391

code hinting, using, 49

Code Hinting window, opening, 245

Code Navigator

displaying automatically, 85

introduction of, 87

using, 84–87

Code view

displaying line numbers in, 140

explained, 17

focusing on selected rule, 141

icon, 48

identifying, 16

making changes in, 50

Code workspace, appearance of, 25

Coding toolbar, identifying, 16

color change, accomplishing, 63–64

color spaces, 280

commands, creating with keyboard 

shortcuts, 28

comments, using, 143

Compare option, explained, 398

COMPUTED option, seeing result of, 

88–89

contact_us.html file, opening, 285

copying

images, 295

tables, 252

Creative Cloud. See also Adobe Creative 

Cloud Learn & Support site

downloading, 5

installing, 5

signing up for, 4

Crop tool, described, 304

CSS (cascading style sheets)

backgrounds, 98–101

borders, 97–98

cascade theory, 73–76

class attributes, 91

Code Navigator, 84–87

completing sample page, 109–110

descendant theory, 79–83

formatting elements, 90

formatting objects, 92–97

formatting text, 71
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height, 105

id attributes, 91–92

inheritance theory, 76–79

margins, 106–107

normalization, 108–109

overview of, 62

padding, 107–108

positioning, 102–104

previewing completed file, 69–70

specificity theory, 83–84

CSS backgrounds. See also backgrounds

adding images, 155–157

custom CSS styling, 162–163

CSS box model, 68–69

CSS Designer. See also page layouts

COMPUTED option, 34

identifying, 16

modes, 34

panes in, 33

rules of order, 144

using, 33–34, 87–89, 139–143

CSS markup, containing in comment 

entries, 140

CSS properties

changing, 291

displaying, 155

CSS rules

applying, 71

hierarchy, 83

naming, 237

of order, 144

order and placement of, 73–76

order of, 255

order of hierarchy, 76

ordering, 237

overriding HTML styling, 252–254

syntax, 72

using line breaks with, 74

CSS shorthand, 90–91

CSS styles

creating and editing, 34

creating with Extract, 26

CSS theories

descendant, 79–83

inheritance, 76–79

specificity, 83–84

CSS vs. HTML formatting, 63–64

css_basics_finished.html file, 

opening, 69

CSS3

features and effects, 111–112

support, 112

CSS-based formatting, assessing, 84–87

Ctrl key. See keyboard shortcuts

cutting code, keyboard shortcut for, 211

D

dashes, inserting into headings, 222

Delete synchronization option, 

explained, 398

deprecated, defined, 63

descendant theory

classes and ids, 81–82

impact on CSS formatting, 79–83

selectors, 82–83

Design/Live views, identifying, 16

Design view

creating relative hyperlinks in, 

312–315

explained, 17

icon, 48

Design workspace, displaying, 11, 25

desktop design, 121

destination links

adding to webpages, 330

creating in Element View, 328–329

dithering, 280

<div> tag, described, 52

Document tab, identifying, 16

Document Title field, availability of, 217

Document toolbar, identifying, 16

documents, opening in workspace, 135

Dreamweaver

CC product home page, 13

Help site, 12

installing, 4

interface components, 16

Learn and Support site, 12

obtaining, 4

signing up for Adobe Creative 

Cloud, 4

system requirements, 4

updating, 5
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Dreamweaver Forums, accessing, 12

Dreamweaver site

defining, 8–10

location of, 9

saving name of, 10

setting up, 10

dynamic jQuery styling, editing, 

355–360. See also jQuery Accordion 

widgets

E

Edge Animate

features of, 366

including posters, 371

using, 367–371

Edge Inspect, testing mobile design with, 

203–204

Edge Web Fonts. See also fonts; type

features of, 148

using, 149–151

Edit Image Settings tool, described, 304

Edit tool, described, 304

editable regions

explained, 208

inserting, 215–217

educators, resources for, 12

Element Quick View

features of, 35

using, 175–177, 198–200

element references, explained, 3

Element View

creating image-based links, 322–323

creating text links, 323

features of, 35

elements

replacing, 392

selecting, 249

<em>, using, 45, 52

email links, setting up, 320–322. See also

hyperlinks; spam

embedded CSS, moving to external file, 

210–213. See also templates

events.html file, opening, 328

exporting assets from Photoshop, 

125–126

Extensis WebINK website, 151

external hyperlinks. See also hyperlinks

absolute links in Live view, 318–320

creating, 318–320

explained, 308

Extract panel, accessing layers from, 26

Extract workflow, features of, 26

Extract workspace, appearance of, 25

F

<figcaption> tag, described, 56

<figure> tag, described, 56

files, cloaking, 389–391. See also Related 

File Interface

Files panel, identifying, 16

finding and replacing text, 270–272

Firefox browser, HTML default for, 67

Flash video workflow, using, 375

FLV source file, using with video, 375

folders

cloaking, 389–391

containing image assets, 9

navigating, 137

resources versus root, 9

font services, accessing, 151

font size

determining, 145–146

specifying, 153–154

Font Squirrel website, 151

font stacks, building with web fonts, 

152–153

fonts. See also Edge Web Fonts; type; 

web-hosted fonts

licensing restrictions, 148

specifying in groups, 147

versus typefaces, 146

fonts HTML default, described, 66

<footer> tag, described, 56, 58

<form> tag, described, 52

Format menu, displaying, 236

formatting objects in CSS

fixed and relative, 95–97

fixed widths, 93–94

overview of, 92

relative widths, 94

width, 92–97

formatting text in CSS, 71



ADOBE DREAMWEAVER CC CLASSROOM IN A BOOK 2014 RELEASE 409

FTP (File Transfer Protocol)

explained, 382

setting up remote site, 383–387

FTP connection, troubleshooting, 387

FTP over SSL/TLS, 382

G

Get and Put, accessing, 396

Get synchronization option, 

explained, 398

GIF (graphic interchange format), 281

Google Web Fonts website, 151

graphic tools. See also images

Brightness and Contrast, 304

Crop, 304

Edit, 304

Edit Image Settings, 304

Resample, 304

Sharpen, 304

Update from Original, 304

GreenStart site, displaying in 

browser, 397

H

<h1> to <h6 tags> tag, described, 52

handheld media type property, intended 

use, 184

<head> element, using, 45–46, 52

<header> tag, described, 56, 58

heading tags

formatting, 237

using, 44

headings, creating, 235

headings HTML default, described, 66

height, setting in CSS, 105

<hgroup> tag, described, 56

high color palette, 281

home links, creating, 315–316

home page names, treatment of, 392

<hr /> tag, described, 52

HTML (HyperText Markup Language)

adding structure, 45–46

beginning of, 40–41

character entries, 53

formatting text with, 44

inline formatting, 45

original design of, 57

overview of, 40

writing in Dreamweaver, 47–51

HTML 4 workflow, alternative to, 234

HTML code

balancing, 41

inserting, 43–44

opening and closing tags (< >), 41

structure, 41

using text editors with, 42

validating, 179–180

writing, 42

HTML defaults

background, 66

body text, 66

browsers, 67

Chrome, 67

Firefox, 67

fonts, 66

headings, 66

IE (Internet Explorer), 67

margins, 66

Opera, 67

padding, 66

Safari, 67

table cell text, 66

table header, 66

HTML elements, inspecting, 84–87

HTML entities, inserting, 178–179

HTML properties, changing, 291

HTML structures, adding, 237–239

HTML syntax, explained, 42–43

HTML vs. CSS formatting, 63–64

html_defaults.html file, opening, 63–64

<html> element, using, 45–46, 52

HTML4, adoption of, 53

HTML4 codes, HTML tags, 51–52

HTML4 resources, consulting, 51

HTML5

intention of, 58

overview of, 53–55

resource for, 58

semantic web design, 57–58

tags, 55–56

tags added to, 58

techniques and technology, 58
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HTML5 defaults, lack of, 65

HTML5 video

options, 376–378

resources, 378

HTML5 workflow, building, 234

HUD (heads-up display), Element View 

as, 35

hyperlink pseudo-classes, 167

hyperlinks. See also absolute hyperlinks; 

email links; external hyperlinks; 

internal hyperlinks; navigation; 

relative hyperlinks

adding behaviors to, 342–344

creating ids, 328

editing, 313

external, 318–320

image-based, 322–323

internal, 312–318

overview of, 308

parts of, 308

removing, 313

updating in child pages, 316–317

hyphenation, lack of support in 

HTML, 94

I

id attributes, using with CSS, 91–92

id-based link destinations, targeting, 329

ids, creating, 328

IE (Internet Explorer) browser, HTML 

default for, 67

<iframe> tag, described, 52

Ignore synchronization option, 

explained, 398

IIS/ASP web server, 387

image assets

creating with Extract, 26

including in folders, 9

image positions, adjusting with CSS 

classes, 285–286

image quality, considering, 292

image-based links, creating, 322–323

images. See also graphic tools

adapting to smaller screens, 297–298

adding descriptive metadata for, 285

adding to CSS backgrounds, 155–157

copying, 295

copying and pasting from Photoshop, 

295–298

displaying in Images window, 284

giving unique ids, 339

inserting, 284–285

inserting by drag and drop, 298–301

inserting non-web file types, 289–291

making responsive, 300–301

optimizing with Property inspector, 

302–303

raster graphics, 278–283

selecting, 295

sizing, 292

using Insert menu, 287–289

using Insert panel, 286–287

using Smart Objects, 292–294

vector graphics, 278

Images category icon, clicking, 284

<img> element, using, 52, 285

importing text, 232–234

indented text, creating, 243–247

inheritance theory, impact on CSS 

formatting, 76–79

inline formatting, applying, 45

<input /> tag, described, 52

Insert menu, using with images, 287–289

Insert panel

identifying, 16

using with images, 286–287

Inspect mode, explained, 20

installing Dreamweaver, 5

interactivity. See behaviors

internal hyperlinks

creating, 312–318

explained, 308

home links, 315–316

relative links in Design view, 312–315

internal targeted links, creating, 324–326

italic formatting, producing in HTML, 49
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J

JPEG (Joint Photographic Experts 

Group), 282

jQuery Accordion widgets. See also 

dynamic jQuery styling

creating selectors, 350–351

customizing, 349–355

declaring pseudo-classes, 351

inserting, 347–348

previewing layout, 346

replacing elements, 348

style sheets, 349

K

keyboard shortcuts

copying text, 222

customizing, 28–29

Cut action, 211

Duplicate Set icon, 28

New Document dialog, 220

nonbreaking space, 43

pasting text from clipboard, 241

Quick Tag Editor, 239

refreshing page view, 43

select all, 222, 295

L

layout_finished.html file, opening, 133

layouts, determining basic settings for, 

145–146. See also page layouts; 

predefined layouts; templates

leading, setting for type, 146

lesson order, recommendation for, 16

<li> tag, described, 52

line breaks, using with CSS rules, 74

line height, setting for type, 146

line numbers, displaying in Code view, 

140

<link /> tag, described, 52

link destination, creating using id, 

327–328

linking to pages, 314

links. See hyperlinks

lists

creating, 239–242

reformatting, 242

selecting, 242

Live Code, explained, 20

Live view

absolute hyperlinks, 318–320

explained, 19

selecting elements in, 234

local site, defining, 8–9

local sites, synchronizing with remote 

sites, 397–399

local/network connections, 382

Locked icon, appearance of, 208

M

margins, setting in CSS, 106–107

margins HTML default, described, 66

media queries. See also mobile devices

adding, 263

adding rules to, 201–203

identifying, 190–191

order of CSS rules, 196

resources, 186, 204

in responsive design, 185

syntax, 185–186

targeting, 191–192

targeting selectors, 192–195

troubleshooting styles, 195–198

writing, 264

media type properties

all, 184

aural, 184

braille, 184

handheld, 184

print, 184

projection, 184

screen, 184

tty, 184

tv, 184

menu bar, identifying, 16

Meridien GreenStart scenario, 

described, 119

<meta /> tag, described, 52
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metadata, inserting, 217–219

minimizing, panels, 21–22

mobile design, 121

mobile devices. See also media queries

Element Quick View, 198–200

responsive design, 184–186

testing with Edge Inspect, 203–204

web video, 378

Mobile Size icon, clicking, 188

mobile-ready vs. mobile-optimized, 189

MyFonts.com website, 151

mylayout.html file

opening, 139

saving, 143

N

<nav> tag, described, 56

navigation. See also hyperlinks

adding destination links, 330

checking pages, 329–330

destination link in Element view, 

328–329

id-based link destinations, 329

link destination with id, 327–328

targeting page elements, 327–328

navigation menu

adding items to, 164–166

styling, 167–172

nonbreaking space, creating, 43

normalization, using in CSS, 108–109

O

objects, formatting in CSS, 92–97

Ogg container format, using, 373

<ol> tag, described, 52

Opera browser, HTML default for, 67

OS X vs. Windows instructions, 3

P

<p> tag, described, 52

padding, setting in CSS, 107–108

padding HTML default, described, 66

page design

creating, 120–121

desktop or mobile, 121

experimenting with, 122–123

page elements, targeting, 324–329

page layouts. See also CSS Designer; 

layouts; type

CSS backgrounds, 155–163

defining values, 158

HTML entities, 178–179

modifying content, 163–172

placeholder text, 177–178

positioning elements, 175–177

predefined, 134–139

rules of order, 144

semantic content, 172–175

validating HTML code, 179–180

Welcome Screen, 132–133

page view, refreshing, 43

pages. See webpages

panel groups, closing, 22–23

panels

availability of, 21

closing, 22–23

collapsing to icons, 22

docking, 24

dragging, 23

features of, 21

floating, 23

grouping, 24

minimizing, 21–22

stacking, 24

paragraph structure, displaying in 

browser, 44

personalizing preferences, 27

Photoshop

copying images from, 295–298

exporting assets from, 125–126

pasting images from, 295–298

Photoshop Smart Objects, using with 

images, 292–294

pixels (picture elements), 278–279

placeholder text

changing, 163–164

inserting, 177–178
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PNG (portable network graphics), 

282–283

positioning commands, using in CSS, 

102–104

posters, including with Edge Animate, 

371, 374

predefined layouts, using, 134–139. 

See also layouts

preferences, personalizing, 27

Preload Images option, using with 

behaviors, 340

print media type property, intended 

use, 184

projection media type property, 

intended use, 184

Properties window, modes of, 145

Property inspector

CSS tab, 30

HTML tab, 30

identifying, 16

image properties, 30

refreshing, 50

table properties, 30

publishing to web, connecting to remote 

sites, 382

punctuation, omission of, 3

Put and Get, accessing, 396

Put synchronization option, 

explained, 398

Q

Quick Tag Editor, accessing, 239

R

raster graphics

color, 280–281

overview of, 278–279

resolution, 279

scaling down, 296

size, 280

raster image file formats

GIF (graphic interchange format), 281

JPEG (Joint Photographic Experts 

Group), 282

PNG (portable network graphics), 

282–283

RDS (Remote Development 

Services), 382

refreshing

page view, 43

Property inspector, 50

Related File Interface, using, 31. 

See also files

relative hyperlinks. See also hyperlinks

creating in Design view, 312–315

explained, 308–309

remote FTP site, setting up, 383–387

remote sites

on local/network web server, 388–389

synchronizing with local sites, 

397–399

remote sites, connecting to, 382

Resample tool, described, 304

resizing screen manually, 247

Resolution switchers, identifying, 16

resource folders, use of, 9

resources. See also websites

Adobe, 204

Extensis WebINK, 151

Font Squirrel, 151

Google Web Fonts, 151

HTML5 video, 378

MyFonts.com, 151

Smashing Magazine, 204

W3C Consortium, 204

responsive design. See also websites

applying to behaviors, 344–346

applying to images, 300–301

applying to tables, 262–268

applying to text, 247–248

media queries, 185

media type property, 184–185

overview of, 118

responsive menu, requirements for, 135

rows, adding to tables, 251
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S

Safari browser, HTML default for, 67

Save All command, using, 226

saving, web pages, 290

screen, resizing manually, 247

screen media type property, intended 

use, 184

<script> tag, described, 52

searching and replacing text, 270–272

<section> tag, described, 56, 58

semantic content, building, 172–175

semantic structures, creating, 234–235

semantic web design, overview of, 57–58

SFTP (Secure File Transfer Protocol), 382

Sharpen tool, described, 304

Shift key. See keyboard shortcuts

Show Set option, enabling in Properties 

window, 266

site root folder, explained, 9

sites. See websites

Smart Objects, using with images, 

292–294

Smashing Magazine, 204

Source Code option, choosing, 31

<source> tag, described, 56

spam, limiting, 324. See also email links

<span> tag, described, 52

specifications, creating manually, 246

specificity theory, impact on CSS 

formatting, 83–84

spellchecking webpages, 268–269

Split view

explained, 17–18

icon, 48

using, 48, 63

stories, moving individually, 233

<strong> tag, described, 45, 52

<style> tag, described, 52

styles, identifying with CSS Designer, 33

SVG (scalable vector graphic) format, 278

Swap Image behaviors, applying, 

339–341

Synchronized option, explained, 398

synchronizing websites, 397–399

T

table cell text HTML default, 

described, 66

table cells

navigating, 250

selecting in Live view, 256

styling, 254–256

Table dialog, displaying, 249

table display, controlling, 256–258

table header HTML default, 

described, 66

<table> tag, described, 52

tables

adding rows to, 251

copying and pasting, 252

creating from scratch, 249–251

inserting, 258–260

making responsive, 262–268

navigating, 250

styling with CSS, 252–254

Tablet Size icon, clicking, 187

tag selectors

identifying, 16

using, 32, 249

tags, using for text formatting, 44

Target attribute, accessing in Property 

inspector, 320

<td> tag, described, 52

templates. See also embedded CSS; 

layouts

appearance of Locked icon, 208

creating, 240

creating from existing layouts, 

213–214

editable regions, 208, 215–217

editing, 240

metadata, 217–219

opening in text editors, 219

updating, 224–226

workflow, 215

testing server, installing, 387

text

finding and replacing, 270–272

formatting in CSS, 71

formatting with HTML, 44

importing, 232–234
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indenting, 243–247

making responsive, 247–248

pasting from clipboard, 241

text editor, using with HTML code, 42

text links, creating using Element 

View, 323

<textarea> tag, described, 52

<th> tag, described, 52

thumbnails, creating, 119–120

TinyURLs, explained, 1

tips.html file, saving, 240

<title> element

changing content of, 50

described, 52

displaying contents of, 46

toolbars, adjusting, 27

<tr> tag, described, 52

<track> tag, described, 56

training scenario, starting, 7

travel_finished.html file, opening, 336

tty media type property, intended use, 

184

tv media type property, intended use, 

184

type. See also Edge Web Fonts; fonts; 

page layouts

leading, 146

line height, 146

property font-family, 146

typeface versus font, 146

Typekit service, features of, 148

U

<ul> tag, described, 52

Unordered List icon, clicking, 242

Update from Original tool, 

described, 304

updates, checking for, 12

updating Dreamweaver, 5

V

validating HTML code, 179–180

values, defining, 158

vector graphics, 278

vertical alignment, adjusting, 260–261

<video> tag, described, 56

views

splitting, 17–20

switching, 17–20

W

W3C (World Wide Web Consortium)

explained, 53

resource for, 58

website, 204

Web 2.0, explained, 334

web animation

adding to pages, 367–371

defining Publish Settings, 367

overview of, 364

web assets

creating using Adobe Generator, 

123–128

exporting from Photoshop, 125–126

web fonts, building font stacks with, 

152–153. See also fonts

web servers, resources, 387

web video

adding to pages, 372–374

Flash workflow, 375

HTML5 options, 376–378

for mobile devices, 378

overview of, 364

WebDav (Web Distributed Authoring 

and Versioning), 382

web-hosted fonts, trend of, 151. See also

fonts

webhosting service, using, 396

webpages

<body> element, 45–46

checking, 329–330

<head> element, 45–46

<html> element, 45–46

linking to, 314

saving, 290

spellchecking, 268–269

structure of, 41

websites. See also resources; responsive 

design

determining purpose of, 116

developing, 116–117
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websites (continued )

identifying audience for, 116

page design, 120–121

prelaunch checklist, 394

putting online, 394–397

research and demographic 

analysis, 117

thumbnails, 119–120

web servers, 387

wireframes, 122–123

Welcome Screen, using, 132–133

windows, narrowing, 135

Windows vs. OS X instructions, 3

wireframes, creating for websites, 

122–123

workspace

components in, 16

layout options, 11

opening documents in, 135

setting up, 11–12

workspace layout

code workspace, 25

selecting, 24–25

Workspace menu, identifying, 16

X

XHTML, similarity to HTML, 54
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