
Supporting Non-Standard Development Configurations 
The samples in Data Binding with Windows Forms 2.0 assume you have a 
default instance of SQL Server 2000 or 2005 installed on your machine, and 
that the Northwind database is installed on that default instance. If you have 
that configuration, the downloadable samples on this site should run without 
modification. If you only have SQL Server 2005 Express, you will need to 
perform some extra steps to get SQL Express database instances set up for 
the samples. If you have a non-default instance of SQL Server 2000 or 2005, 
or need to run against a database on a different machine, you will need to 
perform some extra steps as well. 
 
The samples also assume you have a full version of Visual Studio 2005 
installed (Standard, Professional, or Team System versions). If you are 
working with Visual C# Express 2005 or Visual Basic 2005 Express, you will 
need to take additional steps to create SQL Server 2005 Express databases 
for the samples and to connect to those databases. 
 
This document covers how to get things working for those different 
environments and contains the following sections: 

• Working with Connection Strings and Non-Default Instances of SQL 
Server 

• Installing Northwind and Sample Databases on SQL Server 2005 
• Installing Northwind and Sample Databases on SQL Server 2005 

Express 
• Modifying samples to work in Visual C# 2005 Express or Visual Basic 

2005 Express 

Working with Connection Strings and Non-Default Instances of 
SQL Server 
The database connections that are used by the book samples are driven by 
connection strings, as are all data connections in .NET. The samples were 
created on a machine with a default instance of SQL Server with Northwind 
and the sample databases installed on it. As a result, the connection strings 
in the samples will only work without modification if you have a similar 
configuration. 
 
If you need to run the samples using the databases on a different machine, 
or on the same machine but in a named instance of SQL Server, you will 
need to modify the connection strings that are used to establish database 
connections by the samples. All of the samples other than some of those in 
Appendix D use typed data sets for data access. The exceptions in Appendix 
D have connection strings inline in the code that can be edited directly. 
 
When you generate a typed data set in Visual Studio 2005, connection 
strings are placed in several locations within your project.  



An application configuration file (app.config) is added to your project, and a 
<connectionStrings> element is added to that file with the connection 
string in a child <add> element. The connection string is determined by the 
data connection from Server Explorer that you used when creating the data 
set. Using . or localhost as the server name is the most portable solution for 
a development environment with a default instance of SQL Server 2000 or 
2005 when creating data connections in Server Explorer. 
A Settings class is also added under your project Properties node, and a 
connection string property is added to that class to let you access the 
connection string programmatically. For example, if the connection you set 
up was to the Northwind database, a property is added to the Settings class 
named NorthwindConnectionString. The default connection string value is 
also hard coded as an attribute on that property and will be used if the 
configuration file connection string value cannot be found at runtime.  
The table adapters in the typed data set access the connection string by 
using the connection string property added to the Settings class within their 
project. 
 
If you need to change the connection string that is used by the application to 
point to a different database, named instance, or server, the best way to 
correct the connection string is to modify it through the project properties for 
the project that contains the typed data set. 
 
To do so, bring up the project properties pages (Project > Properties from 
the menu) and select the Settings tab. You should see a connection string 
setting there that is being used by the table adapters in the data set. Like in 
the following figure: 
 

 
 
If you click in the Value column, a button will appear on the right edge of 
that cell with ellipses (…) on it. Press that button and you will get the 
following Connection Settings dialog: 
 



 
 
This dialog lets you edit the settings that determine the connection string. 
You can type in the server name that you want, change the log on 
information, or change the database name. For a named instance, you add 
the name after the server name with a backslash in between like the 
following: MyServerName\MyNamedInstanceName. Once you have made any 
desired changes to the connection string setting, press the Save button on 
the toolbar of Visual Studio, or select File > Save Selected Items from the 
menu bar. This will cause the hard coded default attribute in the Settings 
class and the app.config file to both be updated with the new settings. 
 
The configuration file entry looks like the following (assuming a default 
instance installation with Northwind on it): 
 
<connectionStrings> 
    <add 
name="WindowsApplication1.Properties.Settings.NorthwindConnectionString" 
        connectionString="Data Source=localhost;Initial 
Catalog=Northwind;Integrated Security=True" 
        providerName="System.Data.SqlClient" /> 
</connectionStrings> 
 
The Data Source property within the connection string will be set to whatever 
server name you used when you created the Data Connection within Server 
Explorer or through the Add Data Source wizard. If you need to work with a 
different server, such as a named instance of SQL Server 2005, that value 
will need to reflect the correct server name. You can edit it directly in the 



configuration file, but that will leave the hard coded default in the Settings 
class unchanged. Again that default is only used if the entry in the .config file 
cannot be found. 
 
You can consult the MSDN documentation for the SqlConnection class to see 
what all the legal combinations of properties are on a connection string for a 
SQL Server instance, which includes SQL Server 2000, SQL Server 2005, and 
SQL Server 2005 Express.  
 
If your typed data set is located in a class library that the Windows Forms 
application references, then the app.config file was added to the class library 
where the data set was defined. The <connectionStrings> configuration 
setting will have to be placed in the hosting Windows Forms application’s 
config file.  
 
If the Windows Forms project already has its own app.config file, then just 
copy the <connectionStrings> section from the class library into the 
app.config file for the Windows Forms project, under the <configuration> 
root element. Make sure to remove the <connectionStrings /> placeholder 
element if there is one.  
 
If the Windows Forms project does not have a .config file, you will need to 
add one. You can do this by selecting Add New Item… from the Project menu 
and selecting the Application Configuration File template. 
 
If you have no app.config file in your Windows Forms project, then at 
runtime the table adapter in the typed data set in the referenced assembly 
will try to use the hard coded default connection string, which was added as 
an attribute on the Settings class property when the table adapter was 
generated. 
 

Installing Northwind and Sample Databases on SQL Server 2005 
To get the Northwind and MoneyDB sample databases for the book installed 
on SQL Server 2005, you will first need to download the install scripts from 
the book’s Web site at 
http://www.softinsight.com/databindingbook/SQL2005DBScripts.zip.  
 
To run the scripts, open SQL Server Management Studio and connect to the 
SQL Server 2005 instance you want to place the database onto. Open the 
script files by selecting File > Open > File and navigating to the scripts 
wherever you unzipped them to. When you open each file, you will be 
prompted to connect to the database again; make sure you are connecting to 
the SQL Server 2005 instance where you want to install the database.  
Then execute the script using the Execute! button in the toolbar. This will 
create the database with the appropriate schema and populate it with sample 
data. 
 



Installing Northwind and Sample Databases on SQL Server 2005 
Express 
This section assumes that you do not have a full instance of SQL Server 2005 
installed on your machine and therefore do not have access to SQL Server 
Management Studio. If you do and want to run the samples on a SQL 
Express database instead of SQL Server 2005 for some reason, you can use 
the same process described in the preceding section and just connect to your 
SQL Express database instance (named SQLEXPRESS by default) instead of 
connecting to the SQL Server 2005 instance. If you want to run the samples 
on a machine that just has a default SQL Server 2005 Express installation 
(such as the one that gets installed with Visual Studio 2005 by default), then 
follow the procedures in this section. 
 
To get the Northwind and MoneyDB sample databases for the book installed 
into individual SQL Server 2005 Express databases, you will first need to 
create SQL Server 2005 Express database files for the Northwind and 
MoneyDB databases. The easiest way to do this is to download the databases 
from the book’s Web site: 
http://www.softinsight.com/databindingbook/ExpressDatabases.zip.  
 
If you want to create the databases from scratch, you can download the 
scripts at: 
http://www.softinsight.com/databindingbook/SQL2005ExpressDBScripts.zip. 
You will also need to be an administrator on the machine to run the scripts. 
 
If you go with the scripts, you will need to create a SQL Express database file 
for each of those databases. One of the easiest ways to do so is to use Visual 
Studio 2005. Open up a project of any type (such as a Windows Application 
project) and select Add New Item from the Project menu. Select SQL 
Database as the item template type, and give it an appropriate name (i.e. 
Northwind.mdf or MoneyDB.mdf). Press the Add button and the MDF file will 
be added to the project. A Data Source Configuration Wizard window will pop 
up, just press the Cancel button when it does. Repeat this step to create the 
other database file as well.  
 
Once you have created those database files as part of the project, you can 
close Visual Studio. Go and locate the files in the project folder through 
Windows explorer and copy both the MDF and LDF files for Northwind and 
MoneyDB to some folder where you want them to reside for running the 
demos (for example, create a folder C:\Express Databases and copy them 
there). 
 
Now you need to run scripts that will create all the database objects and 
populate them with sample data in those databases. Included in the 
SQL2005ExpressDBScripts.zip file is a utility I wrote for doing just that called 
SQLExpressScripter. This tool lets you run an arbitrary SQL script against a 
SQL Express database that you have as just an MDF file. 



 
To populate the Northwind Express database, run SQLExpressScripter.exe 
and enter the path for the Northwind.mdf file created in the steps above. 
Then enter the path to the instnwnd_no_db_create.sql script path. Then 
press the Execute button and the script will run and populate the database. 
Repeat for the MoneyDB.mdf and MoneyDB_no_db_create.sql files. You will 
now have SQL Express databases that you can use with any of your projects. 
 

Modifying samples to work in Visual C# 2005 Express or Visual 
Basic 2005 Express 
To run the samples from this book on the Express versions of the products, 
you will need to make a few changes to the code and do some extra setup 
steps. 
 
The following steps summarize what needs to be done. 

1. Open the solution and add the express database to the project. 
2. Modify the project settings connection string to point to the express 

database instead of a default SQL Server instance. 
 
The details to accomplish the above are as follows: 

1. Open the solution (.sln) file in Visual Studio. 
2. Right click on the project in Solution Explorer and select Add > 

Existing Item. 
3. Navigate to the location of the Northwind.mdf or MoneyDB.mdf file, 

depending on which database the sample is using and click Open. This 
will add the database to the project as a project file. 

4. Open the Project Properties from the Project > Properties menu. 
5. Select the Settings tab along the left hand side. 
6. Select the Value column for the NorthwindConnectionString or 

MoneyDBConnectionString setting. 
7. Click on the ellipses (...) button to bring up the Connection Properties 

dialog. 
8. Click the Browse button to locate the database file (.mdf file) within 

your project folder. Select it and click the Open button. 
9. Click OK in the Connection properties dialog. 
10.Run the sample. 


