
Timelines let you create animations on a Web page without having to use Flash or write

the Dynamic HTML code yourself. Timelines animate layers and thus appear to animate

any object that’s in a layer on the page. 

Timelines use JavaScript to control layers (see Figures 17.1 through 17.4 on the

next page). A layer can move, resize, appear, or disappear—and these actions are con-

trolled by a sequence of animation frames. 

These frames are similar to the idea of frames in films, cartoons, and flipbooks. And if

you’ve made movies with Flash, Director, or Final Cut Pro—or even if you’ve made an

animated GIF—then you’ve already manipulated frames to create animation. Just like

the frames of footage in a movie, each frame can be slightly different from the last, which

creates the illusion of movement over time on a 2-D surface. In this case, of course, the

2-D surface is a Web page projected on a computer screen rather than a film projected

on a movie screen.

Timelines can look kind of cute, and on the few sites that use them, they provide cool

special effects. But can they actually be useful? Well, because certain properties of a layer

change (such as visibility, position, stacking order, and size), and because these properties

can be triggered by a user event, you could use them to create showy navigation schemes

or, in combination with JavaScript, you could even trigger requests for user registration,

set cookies, or provide bubble captions to go with a photo gallery or catalog that some-

one is browsing. But you could do those things using image rollovers or the Change Property

or Show-Hide Layer behaviors without creating a timeline. 

Because the intrinsic function of timelines is to make these events happen

over time, the main use of timelines is for simple animations—and whether animation is

useful is a question you’ll have to answer for yourself. 
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✔ Tips

� Because timelines rely on layers in order

to work their magic, they can only be

viewed in 4.0 and later browsers.

� A layer, you may recall, is a container for

content that can be positioned anywhere

on a page. Layers can also overlap or

stack on top of one another, a property

called z-index or stacking order. Layers

generally use the <div> tag and their

other properties include size, visibility,

and background color or transparency.

Figure 17.4 One click opens a new little
window with a new timeline.

Figure 17.3 It keeps moving until it’s off the
screen, and then it starts over.

Figure 17.2 It moves!

Figure 17.1 The magic bus at futurefarmers.com
uses a timeline in a JavaScript pop-up window.
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Figure 17.8 The timeline increases the size of
the layer. This layer uses a background
image that is tiled as the layer expands.

Figure 17.7 The
timeline changes
the Z-index of the
layers. In the first
screen, the layers
“person” and
“deadend” are
stacked behind
“map.” In the
second screen,
the map layer has
the lowest z-index
and is thus
stacked behind
the other two.

Figure 17.6 You can
use a timeline to 
show or hide layers. 
In this case, three
layers appear over 
the background
image. You can have
this happen over 
time or you can have 
a user event trigger
the action. The 
layers can appear 
all at once or in
sequence.

Figure 17.5

The timeline moves
the layer from left to
right. You can use
more complex
movements, too.

What Timelines Can Do
Timelines can incorporate three types of

objects: layers, images, and behaviors.

In this chapter, we’re going to rely on a few mod-

ules to try to illustrate motion on the page. The

layers on this page include a bordered one with

an image of a little person in it, and a map.

Layer properties that a timeline can change

include the following:

� Moving a layer by changing its X+Y

coordinates (on the page or within the

parent layer) (Figure 17.5).

� Showing or hiding a layer by changing

its visibility. You can switch between the

three optional states: visible, hidden, or

default (Figure 17.6).

� Changing the stacking order, or Z-index

(Figure 17.7).

� Resizing a layer by adjusting its dimen-

sions (Figure 17.8).
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✔ Tip

� Navigator 4 does not support resizing layers

during a timeline.

The only image property that a timeline can

change directly is the image source. (You

cannot change, say, the image size or border.)

By swapping the source—that is, by making

the image path point to a different image—

you can perform image rollovers during a

timeline without writing additional JavaScript,

or inserting additional behaviors, or asking the

user to do anything at all.

Timelines can also call a behavior from a

particular frame. You can also use a behavior

to start, stop, or skip to a particular frame

within a timeline. (If you’re not familiar with

behaviors, they’re little interactive JavaScript

widgets that you can write using Dream-

weaver’s tools rather than by hand-coding.

These events can be called—that is, triggered—

by a user event or by another script, which is

what the timeline itself is. 
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Figure 17.9 The Timelines panel.

Timeline 

drop-down menu
Rewind

button

Playback

button

Autoplay

checkbox

Back button

Animation channels

Frames

Animation bar

Behaviors channel

Playback head

Keyframes

Frame numbers

Loopback checkbox

Playback rate

(frames per second)

The Timelines Panel
The Timelines panel (Figure 17.9) is the tool

you use to create and modify timelines in

Dreamweaver.

To view the Timelines panel:

� From the menu bar, select Window >

Others > Timelines.

or

Press Alt+F9.

Either way, the Timelines panel will appear

in its own panel group at the bottom of the

Document window. We show it both docked

and undocked in this chapter.
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Dissecting the
Timelines Panel
Each part of the Timelines panel controls a

different aspect of a timeline. Some of these

elements won’t really make much cognitive

sense until you see them in operation, but

you can use this page as a reference for what

things do. Let’s start at the top (Figure 17.10).

If you include more than one timeline on a

page, you can switch between timelines 

by choosing the timeline name from the

Timeline drop-down menu.

You can play timelines in the Document 

window using the Timelines panel’s playback

controls. The Rewind button rewinds the

timeline back to the beginning. The Back

button rewinds one frame at a time; hold it

Figure 17.11 The content area of the Timelines panel.

Behaviors channel

Frame numbers

Playback head

Frames

Keyframe

Animation bar

Animation channels

Keyframe

Figure 17.10 The Toolbar on the Timelines panel.

Frame number text box

Loop checkboxTimeline drop-down menu

Autoplay checkbox

Rewind button Playback button

Back button

Frame number text box Options menu button
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down to play the timeline backwards. The

Playback button advances one frame at a

time; hold it down to play the entire timeline.

The current frame is indicated in the Frame

number text box.

The playback rate is in frames per second

(fps). The default is 15 fps; you can set it

higher or lower depending on your content.

You can easily add behaviors to control how

the animation plays when loaded in the browser.

The Autoplay checkbox adds a behavior that

will make the timeline start as soon as the

page finishes loading. The Loopback check-

box adds a behavior that will make the time-

line play continuously while the page is in the

browser.



Figure 17.12

The options menu
on the Timelines
panel offers quick
access to timeline
commands.

Options menu button
Now we move to the part of the Timelines

panel that controls the content (Figure 17.11).

Use the Behaviors channel to add behav-

iors that will be called from a certain frame

in the timeline.

Each numbered column in the Timelines

panel is a frame. Each frame is numbered.

The playback head (the red bar) shows the

advance of the playback. As the playback head

passes over each frame, the frame number

will appear next to the Playback button.

Each numbered row in the Timelines panel is

an animation channel. Different objects

usually use different animation channels.

When an object is added to a timeline, the

Timelines panel displays an animation bar

in that object’s animation channel. The little

bullets at the beginning and end of the ani-

mation bar are keyframes. You can add other

keyframes in the middle of an animation bar

to add actions to the timeline.

✔ Tips

� A keyframe is a point on a timeline where

something happens. A timeline is com-

prised entirely of “frames”—like the frames

in a movie—and a keyframe, just like in

animation or digital video, is an action

point. When you set two actions in two

keyframes, the animation program—

Dreamweaver in this case—creates a

smooth flow to get from one point to

another. So if in one keyframe King Kong

is on the ground, and in another keyframe

King Kong is on top of the Empire State

Building, in the intervening frames, he’d

be ascending the building.

� In Figure 17.10, at the right side of the

Timelines panel, you can see an Options

menu button. This button pops up a

menu of commands (Figure 17.12) you

can use when editing a timeline. 
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Adding a Layer to a
Timeline
You create a timeline by adding a layer to the

Timelines panel. Once you drag or add the

layer, Dreamweaver creates a timeline for it

and adds the code to the page automatically.

To add a layer to a timeline:

1. Make sure the object you want to ani-

mate is in a layer, and that the layer has

the size and position that you want it to

start with. 

2. Select the layer in the Document window

(Figure 17.13) by selecting its handle 

or tag.

3. From the menu bar, select Modify >

Timeline > Add Object to Timeline.

or

Right-click (Ctrl+click) on an animation

bar in the Timelines panel, and select

Add Object from the context menu.

A new, named animation bar will appear in

the Timelines panel (Figure 17.14).

Figure 17.14 When you add the layer to the timeline,
an animation bar appears in the first available
animation channel.

Figure 17.13 Select the layer in the Document window.
Notice that the Timelines panel doesn’t have any
objects in it yet.

Layer named in Property inspector

<div> tag selected in Tag selector

Layer markerLayer selected, not image
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Figure 17.15 Dragging and dropping a layer into the
Timelines panel—it lands in the channel and starts at
the frame where you drop it.

✔ Tips

� Before you add a layer to a timeline, be

sure that you name it in the Property

inspector. Named layers are easier to

manage than numbered ones.

� You can also have a timeline call image

rollovers or another JavaScript behavior.

See the sections Adding an Image Rollover

to a Timeline and Adding a Behavior to a

Timeline later in this chapter.

� You can also drag a layer onto the

Timelines panel to add it to the timeline.

Click on the layer and drag it to the

location (channel and frame) where you

want it to appear (Figure 17.15).
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Timeline Actions
Timeline actions were briefly described in

What Timelines Can Do earlier in this chapter.

In the next few sections, we’re going to go

over each action, step by step, starting with

moving a layer. As we go through each action

a layer can perform, we’ll describe the various

modifications you can make to a timeline.

Moving a layer

The easiest way to start learning about time-

lines is to move a layer on the page.

To move a layer using a timeline:

1. Add the layer to the timeline.

2. In the Timelines panel, click on the key-

frame bullet at the end of the layer’s anima-

tion bar (Figure 17.16). The playback

head (the red bar) will move to that frame.

The layer will automatically be selected in

the Document window.

3. Click on the layer’s selection handle and

drag it to the position on the page where

you want it to end up (Figure 17.17).

Figure 17.17 With the end keyframe selected, drag the
layer to a new location and let go.

Figure 17.16 Click on the last keyframe bullet in the
layer’s animation bar to select that frame as well as
the layer.
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Figure 17.18 The Timelines panel will record the new
position and draw a line from position 1 (where the
layer used to be) to position 2 (where you dropped
the layer).

You’ll see a line drawn from the layer’s old

position to its new position (Figure 17.18).

The line connects the top-left corners of

the layer in each position. This is the path

the layer will follow.

✔ Tips

� Notice in Figure 17.17 that we’ve stacked

the Layers panel with the Timelines panel.

We can flip back and forth between them

easily and save desktop space, and we don’t

have to keep the side stack of panels open.

(By default the Layers panel appears 

initially on the Advanced Layout panel

group.) To move a panel onto or off of

another one, click the panel’s Options

menu button and select Group [Panel]

With > [Other Panel Group].

� Notice also that in Figure 17.17 the layer

marker is no longer visible. From the

menu bar, we selected View > Visual Aids

and unchecked Invisible Elements.
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Recording movement

If you want your layer to travel in a line that

isn’t straight, you can record its movement. 

To record a layer’s path:

1. Select the layer by its handle and move it

to its starting position.

2. In the Timelines panel, click within the

animation frame where you want move-

ment to begin.

3. From the menu bar, select Modify >

Timeline > Record Path of Layer.

4. Drag the layer’s selection handle along

the path you want to use. Loop-de-loops

are allowed (Figure 17.19). As you drag,

dots will mark the path you’re drawing.

5. When you let go of the mouse button, 

the layer’s path will be translated into 

an animation channel (Figure 17.20),

with keyframes marking specific spots

between which the layer travels along 

its path. 

6. Click and hold the Play button to

watch the layer retrace the path you drew

for it.

✔ Tips

� Recording the path of a layer will add the

layer to the timeline, even if it already

appears there. To rearrange animation

bars, see the next section. 

� Occasionally, you may get an error mes-

sage stating that a layer with the same

name is already in the timeline. Click

within a different frame and draw your

movement again. 

Figure 17.20 After we recorded the path of the layer,
the layer appeared as an object in the Timelines
panel—with more than 100 frames.

Figure 17.19 Using the Record Path of Layer
command, we can drag a layer all over the place and
the timeline will follow. The little dots represent
points that the top-left corner of the layer has graced.
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Setting the Playback Rate

The default playback rate for Dream-

weaver timelines is 15 frames per second.

Macromedia advises not to set this rate

much faster; the 15 fps rate is based on

optimal performance on the average

machine. Setting a faster playback rate

might not actually make the animation 

go faster; although it might do so on your

local machine, all the images and layers

that you’re playing with are stored in your

memory cache. You can, however, set a

lower rate for slower speeds.



Figure 17.24 We drag the sequence to Frame 1 of the
timeline. You can also drag sequences to later in the
timeline or to other animation channels.

Figure 17.23 After deleting the sequence that didn’t
have any actions in it, we select the sequence that
includes the recorded path by clicking on a non-key
(unmarked) frame.

Figure 17.22 In this case, we haven’t added any actions
to the initial animation sequence. We can select it and
delete it. We can also cut, copy, and paste it, as long
as it doesn’t overlap another sequence with the same
object in it.

Figure 17.21 If you’ve already added this layer to the
timeline, Dreamweaver will add a separate animation
sequence (with its own beginning and ending
keyframes) after the initial sequence.

Deleting and moving animation
sequences

Recording the path of a layer adds that layer

to the timeline. If the layer already appears in

the timeline, Dreamweaver will add the layer

again later in the same animation channel

(Figure 17.21). Animation bars cannot

overlap.

You can delete or move animation bars. For

example, in Figure 17.21, the initial, blank bar

remains. We select the bar (Figure 17.22)

and press Delete to remove it. Then, we select

the bar that includes the recorded path

(Figure 17.23) and drag it to the beginning

of the timeline (Figure 17.24).

13

Drawing Timelines
Tim

elin
e A

ctio
n

s



Playing it back 

You can watch the movements you’ve

recorded by playing back the timeline.

To play back a timeline:

1. In the Timelines panel, click on the Rewind

button to move the playback head

back to the beginning of the timeline.

or

Click on Frame 1 in the Timelines panel

to move it back (Figure 17.25).

2. If the Timelines panel is undocked, move

it out of the way in the Document window.

3. In the Timelines panel, click on and hold

down the Play button .

You’ll see the layer move across the page

(Figure 17.26).

✔ Tips

� You can click within any frame to see

what the page looks like at that point in

the timeline. 

� You can play and rewind little bits of the

timeline with the Rewind, Back, and Play

buttons (Figure 17.27). 

� To fine-tune a point within a timeline, see

About Keyframes, on the next page.

Previewing in a browser and
setting Autoplay

A timeline won’t play when previewed in a

browser unless you instruct it to do so. If you

add the Autoplay behavior, the timeline will

play as soon as the page finishes loading.

Just check the Autoplay checkbox on the

Timelines panel (Figure 17.28), and then

preview the page (Figure 17.29). For more

on controlling timelines, see Making

Timelines Go, later in this chapter. Figure 17.29 Preview your timeline in a 4.0 or
later browser.

Preview button

Figure 17.28 Click on the Autoplay
checkbox to make the timeline
play in the browser window.

Figure 17.27 The Rewind,
Back, and Play buttons.

Figure 17.26 The timeline in mid-play.

Figure 17.25 Click on Frame 1, or click on the Rewind
button to return the timeline to its beginning.
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Figure 17.33

A keyframe bullet
will appear on the
animation bar.

Figure 17.31 Our person goes from Maryland straight
to California. We want her to pay a visit to New York
City first. We play the timeline and stop at a fairly
early point, where we’ll add a keyframe.

Figure 17.30 Click at the point on the animation bar where
you want to add the new keyframe. The playback head
will move, and you’ll see the frame number in its text box.

Current frame numberPlayback head About Keyframes
The Timelines panel tracks the movement

of a layer from one point to another, frame by

frame, and it paces the movement of an object

so that the frame-to-frame transitions are

smooth.

If there are only two points in a timeline,

the line in which the layer moves must be a

straight one. You can add a third point to a

timeline to make a layer move in an arc, or

you can add points for multiple positions 

or actions.

You do this by adding keyframes. A keyframe,

as mentioned earlier in the chapter, is a point

on a timeline where something happens. Each

animation bar in a timeline includes at least

two keyframes: the beginning frame and the

end frame.

To add a keyframe:

1. In the Timelines panel, click on the place

on the animation bar where you want the

new action to happen (Figure 17.30), or

press the Play button until you reach it

(Figure 17.31). The playback head will

move to the new frame.

2. From the menu bar, select Modify >

Timeline > Add Keyframe.

or

Right-click (Ctrl+click) on the object’s

animation bar in the Timelines panel, and

select Add Keyframe from the context

menu that appears (Figure 17.32).

or

Press F6.

The Timelines panel will add a keyframe bul-

let to the animation bar (Figure 17.33).

Now you can attach a new position to that

keyframe. 
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To add a new layer position to a

keyframe:

1. In the Timelines panel, click on the new

keyframe. The layer will become selected

automatically (Figure 17.34).

2. Move the layer to the position on the

page where you want it to be when that

keyframe is played (Figure 17.35).

The line drawn between the beginning posi-

tion on the page and the end position on the

page will now arc to fit the third point into

the movement line (Figure 17.36).

Play back the timeline now to see how this

movement looks.

Now you know how to change a layer’s posi-

tion, play back a timeline, and add keyframes

(and therefore, additional actions) to a time-

line. Let’s look at some of the other things

timelines can do.

✔ Tips

� You can add keyframes and then attach

other actions to them, too. We’ll do this

throughout this chapter.

� How do you detach movements from a

layer? What if you make a layer move and

then change your mind? First, click on

the frame in which the layer is where you

want it to be. Then, open the Property

inspector and take note of the L(eft) and

T(op) measurements. In the Timelines

panel, move to the keyframe where the

movement changes. In the Property

inspector, type the numbers you jotted

down in the L and T text boxes. Repeat

for any additional keyframes where the

layer’s position attributes have changed. 

Figure 17.36

We fast-forwarded 
to later in the time-
line so you could 
see the arc drawn 
by Dreamweaver
between the three
keyframes.

Figure 17.35 With the keyframe selected
in the Timelines panel, move the layer to
its new location.

Figure 17.34 Select the keyframe, and the layer will
automatically become selected.
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Figure 17.39 Finally, we added a new keyframe and
set the layer’s visibility to visible on the fifth keyframe.
When the timeline plays, the second layer will appear
on Keyframe 5 after the first layer starts moving.

Visibility set to visible on Keyframe 5

Keyframe 5 is selected for "bubble1" layer

Figure 17.38 Then, we set its initial visibility
to hidden on the first keyframe.

Figure 17.37 First, we add the new layer to the timeline,
and put text in it.

Showing and
Hiding Layers
You can show or hide a layer in a timeline by

changing its visibility to visible, hidden, or

default.

To show or hide a layer:

1. If the layer is not already added to the

timeline, add it.

2. Click on the first keyframe on the layer’s

animation bar (Figure 17.37).

3. Using the Layers panel or the Property

inspector, set the layer’s visibility to the

state you want it to be in when the time-

line begins playing (Figure 17.38).

4. On the layer’s animation bar, add the

keyframe where you want the visibility

change to occur.

5. With the proper keyframe selected, change

the visibility of the layer (Figure 17.39).

6. If you want the layer to change visibility

again at the end of the timeline, click on

the keyframe at the end of the layer’s ani-

mation bar, and change the layer’s visibility.

To change the location of a keyframe:

1. In the Timelines panel, click on the

keyframe you want to move.

2. Hold down the mouse button and drag

the keyframe bullet to a different frame.

3. Let go of the mouse button.

Voilà! The keyframe has moved.

✔ Tip

� Images that are in hidden layers are auto-

matically downloaded with the page. This

is a good way to preload images for swap-

ping image source. Or skip the source

swapping altogether and just show or hide

the layers that the new images are in.
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Changing the Overlaps
As you know, a layer’s Z-index, or stacking

order, is what makes layers so layer-like. You

can change the way layers overlap during a

timeline (Figure 17.40) so that layers appear

stacked in a different order. If you want Pop

on top, you can make him hop.

✔ Tips

� Make sure all the layers have the Z-index

you want them to have at their beginning

keyframe(s) in the timeline (Figure 17.40).

� Z-index numbers affect the overlap of

only those objects that are inside a layer;

you can’t make a layer hide under an

image that isn’t in a layer itself.

To change the Z-index of a layer

during a timeline:

1. In the Timelines panel, add any

keyframes you need to the layer’s anima-

tion bar.

2. Click on the keyframe that marks the

point at which the Z-index will change.

The layer will be selected automatically.

3. Using the Layers panel or the Property

inspector, change the Z-index number of

the layer (Figure 17.41).

4. Play back the timeline to watch the layer

move over or under another layer on the

page (Figure 17.42).

Figure 17.42 Here are three frames from a timeline. 
In Frame 1, only the marble is visible. In Frame 5, the
elephants appear, and the marble is stacked on top of
them. In Frame 8, the elephants’ Z-index changes so
that they’re on top of the marble.

Figure 17.41 At Frame 8,we added a
keyframe and changed the Z-index of
the elephants layer so that it will surface
over the marble.

Figure 17.40. You can change the Z-index
of a layer in the timeline. We set the
Z-index in the first frame so that the
marble overlaps the elephants.
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Figure 17.46 You can also
type a different playback
rate in frames per second
(FPS) in the Fps text box.
Keep in mind that many
computers can’t process
a faster playback rate
than 15 FPS.

Figure 17.45 We moved the animation bar with the
marble in it. It will both start and end later in the
timeline now.

Figure 17.44 We lengthened the animation bar we
selected in Figure 17.43. Notice how the keyframes in
the middle of the animation bar are spaced out over
the new length of the animation bar.

Figure 17.43 Click on the end keyframe and drag it to
a new location.

Changing the Timing
You can change the length and duration of

an animation bar if you want an action to

start sooner or end later within the timeline.

To move the beginning or end of an

animation bar:

1. In the Timelines panel, click on the begin-

ning or ending keyframe on the layer’s

animation bar (Figure 17.43).

2. Drag the keyframe to a new frame num-

ber within the animation channel

(Figure 17.44). You may notice the other

elements in the timeline moving around

as you drag the keyframe.

3. Play the timeline to see how it looks.

4. Repeat Steps 1 and 2 as needed.

Longer timelines allow for more actions and

more gradual movement.

✔ Tips

� If you drag the end keyframe to lengthen

the timeline, any keyframes within the

timeline will be spaced out in proportion

to their original position, to preserve the

gradual arc of the timeline (Figure 17.44).

� You can also move an entire animation

bar to make the action for that layer start

at a different time. Click on the middle of

the bar (not on a keyframe) to select the

whole thing, and drag it to a new location

(Figure 17.45).

� To find out how to move an individual

keyframe, see To change the location of a

keyframe, earlier in the chapter.

� You can also change the frames per second

(fps) of a timeline. Type a number less than

15 in the Fps text box (Figure 17.46).

Remember that most computers can’t

process faster playback speeds.
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Changing Layer
Dimensions
Besides changing the visibility and Z-index

of a layer, you can also use a timeline to change

the dimensions of the layer.

✔ Tips

� Layer size changes work only in Navigator

6 and Internet Explorer 4 and later, and

not in Navigator 4.

� If you want to make a layer shrink in size,

remember to change the layer’s overflow

setting to hidden or scroll in the Property

inspector; otherwise, the shrinking may

not have any effect.

To change the dimensions of a layer

using a timeline:

1. In the Timelines panel, click on the

keyframe where you want the size change

to occur. The layer will become selected

automatically (Figure 17.47).

2. Change the size of the layer by dragging

its handles, or by changing the W(idth)

and H(eight) settings in the Property

inspector (Figure 17.48).

3. Play back the timeline to see how the set-

tings affect the size change.

✔ Tips

� Because the timeline code makes layer

properties change gradually rather than

abruptly, the size change will begin a

few frames before the set keyframe

(Figure 17.49).

� If, instead, you’d like to see an abrupt size

change, put two keyframes in adjacent

frame numbers. In the first keyframe,

we’ll call it Frame 8, set the size at its sta-

tus quo. In Frame 9, then, set the layer’s

size at its new measurements. The layer

will appear to jump into its new size.

Figure 17.49 Three browser windows showing the
progression in size from Frame 1 to Frame 8 to Frame
15. We set two sizes: one in Frame 1, and one in Frame
15. With Dreamweaver timelines, these changes
happen gradually; for an abrupt change, make the
size change happen in two adjacent keyframes.

Figure 17.48 We selected the end keyframe and
changed the size of the layer. If we click on each
individual frame on the animation bar, the Property
inspector will display the layer’s size in each
succeeding frame, leading up to the end frame’s
dimensions.

Figure 17.47 We added the layer to the timeline.
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Figure 17.54 Here we are in the Document window.
We’ve just added the image of the person—this time
independent of any layers—to the timeline.

Figure 17.53 Add the
image to the timeline
by right-clicking
(Ctrl+clicking) on an
empty animation
channel and selecting
Add Object from the
context menu.

Figure 17.52

Name your
image before
you add it to
the timeline.

Figure 17.51 In the example on
the next page, these are the
two images we’ll be using.

Figure 17.50 In our
map timeline, we use
two different map
images: a green one
(the solid map, on
top) and a pink
speckled one. We use
a rollover to make the
images switch at a
certain point in the
timeline.

Adding an Image Rollover
to a Timeline
You can also add an image rollover to a time-

line (Figures 17.50 and 17.51). The only

available action for images that are not in lay-

ers is swap source: That is, you can make an

image roll over, but you can’t make it hide or

disappear unless it’s in a layer. (In that case,

you apply the changes to the layer tag and

not the image.)

To add the image rollover

to a timeline:

1. Place (or select) the initial, pre-roll image

in the Document window.

2. Name the initial image, using the Property

inspector (Figure 17.52).

3. From the Document window menu bar,

select Modify > Timeline > Add Object 

to Timeline.

or

Right-click (Ctrl+click) on an empty ani-

mation bar in the Timelines panel, and

select Add Object from the context menu

that appears (Figure 17.53).

A new animation bar will appear in the

Timelines panel (Figure 17.54).

On the next page, we’ll add the rollover.

✔ Tip

� One way to preload images for source

swapping is to place them in a hidden

layer on the page. Another is to add the

Preload Images behavior to the page. 
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Making the rollover work 

Changing an image source with a Timeline is

similar to using the Swap Image behavior to

create image rollovers, except the rollover

will occur as time elapses rather than when

triggered by a user event.

To change an image source using

a timeline:

1. Add the image to the timeline, as

described on the previous page.

2. Add any keyframes you need to the

image’s animation bar (Figure 17.55).

3. Click on the keyframe in which you want

the image to roll over.

4. In the Property inspector, change the

source of the image to the source of the

new image (Figures 17.56 and 17.57) by

editing the filename in the Src text box,

or by clicking on Browse and select-

ing a new image.

5. To make the image stay in its second

state for the rest of the timeline, select

the end keyframe and set the source to be

that of Image 2.

or

To make the image revert to its original

state, add two keyframes, first the end-stop

for the source for Image 2, and second, the

resetting of the source for Image 1.

Play back the timeline to watch the effect

(Figure 17.58).

✔ Tips

� Sometimes, when you change the source

of the image, Dreamweaver discards

height and width information for both

the original and the preloaded image. If

you want the images to conform to a cer-

tain size, jot down the height and width

before you create the rollover, and go back

and fix them afterward. 

Figure 17.58 When the timeline plays the keyframe,
the source changes to the second image. In this case,
it’s a subtle change of colors from one image to the
next so that the person fades more into the back-
ground. You can use whatever images you like for 
the rollover, as long as they’re the same size.

Figure 17.57 Edit the filename in the Src text box (for
example, type person2.gif instead of person.gif ), or
click on the Browse button to open the Select Image
File dialog box and choose a different image.

Figure 17.56 The two images, side by side for
comparison. With the keyframe selected, change
the source in the Property inspector. The image,
which we selected with the mouse, shows the
rectangular borders of the transparent image.

Figure 17.55 We added a keyframe to the
image’s animation bar; that’s the point at
which the source will change.
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� In previous versions of Dreamweaver, the

image’s animation bar had to be extended

to the end of the timeline to make the

source stay swapped. This has been fixed

as of Dreamweaver 4 and should function

properly in Dreamweaver MX.



Figure 17.60 On the Behaviors panel, click
on the + (plus) button, and choose an
action from the pop-up menu.

Figure 17.59 We double-clicked on the intersection of
the Behaviors channel and Frame 20, and the Behaviors
panel appeared. It’s empty until you add an action.

Frame 20Behaviors channel Adding a Behavior to
a Timeline
All the clever behaviors that come with

Dreamweaver MX can be added to a timeline.

For instance, you can make the timeline exe-

cute an animation and then load a new page;

you can play a sound at a certain frame in a

timeline; or you can use a timeline to start

playing a Shockwave movie at a certain frame.

To add a behavior to a timeline frame:

1. In the Timelines panel, click on the frame

that will launch the behavior to move the

playback head to it.

2. Double-click on the frame number within

the Behaviors channel (Figure 17.59). The

Behaviors panel will appear in the Design

group (and of course it can be undocked).

The browser version (4.0 and later browsers)

will be preset.

3. In the Actions area of the Behaviors panel,

click on the + (plus) button to pop

up the menu of available actions 

(Figure 17.60).

continues on next page
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4. Choose the action you want to add. The

associated dialog box will appear.

5. Fill out the dialog box and click on OK.

The name of the action will appear in the

Actions list box (Figure 17.61). The

event, onFrameNumber, will be added to

the Behaviors panel automatically.

The behavior will be added to the timeline.

You’ll see a little marker at that particular

frame in the Behaviors channel.

✔ Tips

� For a thorough look at behaviors for  

beginners, see Chapter 16 in the 

Dreamweaver MX Visual QuickStart 

Guide.

� You can add a behavior to a frame by

moving the playback head to that frame

and selecting Modify > Timeline > Add

Behavior to Timeline from the menu bar.

Figure 17.61 We added the Open Browser Window
action to Frame 20 of the timeline; when the timeline
is played, the window will launch on Frame 20. The
event will be added automatically after you finish
selecting the action.
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Figure 17.62 When you check the Autoplay checkbox,
a dialog box will appear informing you that it’s going
to add the Autoplay behavior. Once you get the point,
you can make this dialog box go away by checking the
Don’t show me this message again checkbox.

Making Timelines Go
Timelines won’t start playing in a browser

unless another piece of JavaScript tells them

to. There are two ways you can make a time-

line start playing, both of which use JavaScript

behaviors.

One way is to make the timeline play auto-

matically when the page is finished loading.

The other way is to use a behavior, so that a

user event such as a click or a mouseover

triggers the timeline. 

The Autoplay behavior is an onLoad behavior;

once the page loads, the animation will begin.

To make a Timeline play automatically:

� In the Timelines panel, place a check-

mark in the Autoplay checkbox. A dialog

box will appear (Figure 17.62) letting

you know that Dreamweaver will add the

Autoplay code.

Simple, yes?
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Behavior Modification

What sort of behaviors could you add to a timeline? The timeline itself offers actions similar to

Show/Hide Layer and Rollover Image. Here are some ideas to get you started.

� Set Text of Layer, Set Text of Status Bar, Set Text of Text Field, Popup Message: The user

sees a message when a certain frame in the timeline passes.

� Open Browser Window, Popup Message: During or at the end of the timeline, a window or

dialog box opens. 

� Drag Layer: An animation plays in the timeline, and after it’s over, all the layers become

draggable.

� Play Sound: On a certain frame, a sound plays. For example, when the mouse hits the cat in

the head with a hammer, the user hears “Doink!”

� Check Browser: When the page loads (onLoad), the user is sent to a page with a timeline if

the browser is 4.0 or later, and to a page without the timeline if the browser is 3.0 or earlier.

(It would be a nice idea to detect the browser with a timeline frame, but 3.0 browsers may

or may not play the timeline properly. If you want to try this, you should test it in the

browsers you’re targeting.)



Making a Behavior Play
a Timeline
You can also make a behavior play a timeline

when the user clicks on or mouses over a link

or image.

To make a behavior play a timeline:

1. In the Document window, click on the

object you want to use to make the time-

line play (a, img, input for menu or form

button). Make sure you do not have a

behavior selected in the Timelines panel,

or the behavior will be added to the time-

line instead of the link.

2. If a timeline is on your page, the browser

version will be preset to 4.0 and Later

browsers. To check this, click the + (plus)

button , and then select Show Events

For > 4.0 and Later Browsers.

3. In the Actions area of the Behaviors

panel, click on the + (plus) button.

4. From the menu that appears (Figure 17.63),

select Timeline > Play Timeline. The 

Play Timeline dialog box will appear

(Figure 17.64).

5. If there is more than one timeline on your

page, select the timeline you want to use

from the Play Timeline drop-down menu.

6. Click on OK to close the Play Timeline

dialog box.

7. To specify the user event that triggers the

action, click on the arrow button and

choose the event (onClick, onMouseOver)

from the menu (Figure 17.65).

The event will play the timeline when the

page is loaded in a browser.

✔ Tip

� To make a link that can play a timeline

and doesn’t open a page, the content of

the link should be “#”.

Figure 17.65

After you
select the Play
Timeline (or
other) action,
specify the
user event by
choosing it
from the drop-
down list.

Figure 17.64 We chose Timeline > Play Timeline from
the Add Action menu, and now we can select our
timeline in the Play Timeline dialog box.

Figure 17.63 We selected the link called Play It and
added the Play Timeline action.
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Figure 17.67 In the Stop Timeline dialog box, you can
choose to stop all timelines or one selected timeline.

Figure 17.66 Having selected the Stop It link, we
chose Timeline > Stop Timeline from the Add action
menu.

Stopping a timeline

You can also make a behavior stop a timeline.

This is a quite smart thing to do, especially if

you’re using the Loop function (we’ll get to

that in a minute). The browser’s Stop button

will not stop an in-progress timeline.

To make a behavior stop a timeline:

1. In the Document window, click on the

object you want to use to make the time-

line stop (a, img, form button).

2. On the Behaviors panel, click on the + (plus)

button , and from the menu that

appears, select Timeline > Stop Timeline

(Figure 17.66). The Stop Timeline dialog

box will appear (Figure 17.67).

3. If there is more than one timeline on your

page, select the timeline you want to use

from the Stop Timeline drop-down menu.

or

Select ALL TIMELINES from the drop-

down menu.

4. Click on OK to close the Stop Timeline

dialog box.

5. Click on the arrow button and select the

user event from the drop-down menu

(onClick, onMouseOver, and so on).

✔ Tip

� You cannot make the same link (or image)

both play and stop a timeline. An event

that signals both a Play and a Stop event

will only advance the timeline one frame

at a time. (If the order is Stop and then

Play, it won’t stop at all.) We have to admit,

though, that this was a great way to get

screen captures for this chapter.
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Loop and Rewind
Some timelines are so beautiful, you wish

they’d go on forever. (Actually, the first 10

or so timelines you make will automatically

be that beautiful.) You can make a timeline

repeat either indefinitely or a certain number

of times by using the Loop feature.

To add the Loop:

� In the Timelines panel, place a checkmark

in the Loop checkbox. A dialog box will

appear, letting you know that Dream-

weaver will add the Go To Frame behavior

code (Figure 17.68).

The Loop behavior uses the Go to Frame

action. In case of automatic loop, the time-

line reaches the end and returns to frame 1.

To modify the Loop:

1. In the Timelines panel, locate the last

frame in the timeline. You’ll see a marker

in the Behaviors channel in the frame

after that.

2. Double-click on the last Behaviors

marker (Figure 17.69). The Behaviors

panel will appear.

3. Double-click on the action Go To

Timeline Frame listed in the Actions list

box. The Go To Timeline Frame dialog

box will appear (Figure 17.70).

4. To make the loop pick up at a frame other

than Frame 1, type the frame number in

the Go to Frame text box.

5. To make the loop continue for a number

of times less than infinity, type a number

in the Loop text box.

6. Click on OK to close the Go to Timeline

Frame text box.

Preview the timeline in a 4.0 or later browser

to see if it does what you think it will.

Figure 17.70 The Go To Timeline Frame dialog box
controls the Loop behavior.

Figure 17.69 The Behaviors channel in this timeline
has two behavior markers. The one that follows the
last frame is the one to double-click if you want to
edit the Loop behavior.

Loop behavior

Last keyframe

Figure 17.68 Click on the Loop checkbox, and this
friendly dialog box will appear to tell you what’s up
and to which frame number it’s adding the behavior.
To make it go away, click on the Don’t show me this
message again checkbox.
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✔ Tip

� You can move a behavior to a different

frame if you want. Just click on the asso-

ciated keyframe, if any, and move it to a

different frame, and then click on the

behavior (as in Figure 17.69) and move it

to that same frame. 



Figure 17.73 We added the onClick event
and the Go to Timeline Frame action to
the “Play the part with the pie” link.

Figure 17.72 In the Go To Timeline Frame
dialog box, we specified Frame 45.

Figure 17.71 First, select your object. Then,
click on the + (plus) button on the Behaviors
panel, and select Timeline > Go to Timeline
Frame from the menu.

Jumping to or starting with
a specific frame

You can also use the Go to Frame behavior

with an object outside the timeline. For

instance, you can have a “Play Animation”

button, a “Stop Animation” button, and a

“Go Back to the Part with the Pie” button.

You can use a link or button to begin play-

ing the timeline at any frame.

To add a Go to Frame behavior:

1. In the Document window, click on the

object you want to use to make the

Timeline jump to a particular frame (a,

img, form button). 

2. Be sure that you don’t have a behavior

selected in the Timeline panel; click on

any frame without a behavior marked in

the Behaviors channel.

3. On the Behaviors panel, click on the +

(plus) button , and from the menu

that appears, select Timeline > Go to

Timeline Frame (Figure 17.71). The Go

To Timeline Frame dialog box will appear

(Figure 17.72).

4. If there is more than one timeline on your

page, select the timeline you want to use

from the Timeline drop-down menu.

5. Choose the frame to go to (the frame to

rewind or fast forward to), and type its

number in the Go to Frame text box. 

You cannot set a loop from outside the

timeline. 

6. Click on OK to close the dialog box.

7. Click on the arrow button and select the

user event from the drop-down menu

(onClick, onMouseOver, and so on)

(Figure 17.73).

When the user commits the event, the action

will cause the timeline to jump forward or

backward to a particular frame.
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✔ Tip

� You can add a Go to Timeline Frame behavior

within a timeline, too—not just at the end.

Just add the behavior to the Behaviors

channel within your timeline. Imagine this:

On Frame 8, an image appears in a layer. On

Frame 14, the Go to Timeline action makes

the timeline jump back to Frame 7. With the

number of loops set to 3, the timeline would

go back to Frame 7 three times to make the

image pop up three times before the anima-

tion continued to the end.



Adding and
Removing Frames
We’ve already told you how to move the

beginning and end of an animation bar, as

well as the keyframes. You can also add

frames to or remove frames from the middle

of a timeline.

To add frames to a Timeline:

1. In the Timelines panel, click on a frame 

to move the playback head to the place 

in the Timeline where you want to add a

frame (Figure 17.74).

2. From the menu bar, select Modify >

Timeline > Add Frame.

or

Right-click (Ctrl+click) on the object’s

animation bar in the Timelines panel, and

select Add Frame from the context menu

that appears (Figure 17.75).

The frame will be added to the right of the

playback head (Figure 17.76).

You can also remove frames from a timeline

if you want to shorten the duration of the

animation or the space between keyframes.

To remove frames from a Timeline:

1. In the Timelines panel, move the play-

back head to the place in the timeline

from which you want to remove a 

frame.

2. From the menu bar, select Modify >

Timeline > Remove Frame.

or

Right-click (Ctrl+click) on the object’s

animation bar in the Timelines panel, and

select Remove Frame from the context

menu that appears.

The frame that the playback head is resting

on will be removed.

Figure 17.76 We added five new frames
between the playback head and the
behavior. If we want, we can move the
keyframe back five frames by dragging it.

Figure 17.75

Right-click (Ctrl+click) on 
the frame, and select Add 
Frame from the context
menu.

Figure 17.74 We placed the playback
head one frame before a behavior on
our Timeline.
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✔ Tips

� Tinkering with the middle of the timeline

by changing the number of frames is easier

than moving around all the keyframes,

behaviors, and objects.

� Adding and removing frames from the

middle of a timeline will remove any

keyframes or behaviors that reside in

those frames.



Using Multiple Timelines
You may want to use more than one timeline

if you want more than one animation to be

available on the page. You can use the same

objects in different timelines, which could

then be called by behaviors attached to 

different links or buttons.

To add a timeline:

� From the menu bar, select Modify >

Timeline > Add Timeline.

The Timelines panel will reset, hiding the

animation bars for the original timeline;

additionally, all the indicators of the timeline

will disappear from the Document window

(Figures 17.77 and 17.78).

To toggle between timelines:

� In the Timelines panel, select the name

of the timeline you want to work with

from the Timeline drop-down menu

(Figure 17.79).

You can have as many timelines as you want.

✔ Tips

� Each timeline should be fairly simple, or

your page will take several days to load

and will offer more opportunities to crash

browsers around the world.

� You can have both timelines play simul-

taneously, or you can have a behavior 

in a keyframe in the middle or at the end 

of one timeline call another timeline 

and have it start playing. Use the Play

Timeline behavior, and add it to the first

timeline.
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Figure 17.79 Choose which
timeline to work with from
the drop-down menu on the
Timelines panel.

Figure 17.78 The After Picture: We just added Timeline
2. All traces of Timeline 1 are hidden—all the pictures
are placed in their original positions, they’re all
visible, and they’ve got their original overlap settings.

Figure 17.77 The Before Picture: Here’s Timeline 1, in
mid-play.



Renaming and Deleting
Timelines
Tired of flipping between “Timeline 1” and

“Timeline 2”? Rename them.

To rename a Timeline:

1. View the timeline you want to rename.

2. From the menu bar, select Modify >

Timeline > Rename Timeline. The

Rename Timeline dialog box will appear

(Figure 17.80).

3. Type the new name for your timeline in

the Timeline Name text box.

4. Click on OK. The Rename Timeline dialog

box will close.

The new name for your timeline will appear

in the Timeline drop-down menu in the

Timelines panel.

Removing a timeline from a page is easy. Make

sure you select the proper timeline—and if

you want no timelines, delete each one.

To remove a timeline:

1. In the Timelines inspector, select the

name of the timeline you want to remove.

2. Click on the Options menu button on

the side of the Timelines panel, and

select Remove Timeline from the menu

(Figure 17.81).

Poof! It’s gone.

✔ Tips

� If you have a timeline with objects and

behaviors already added to it, it is a good

idea to save a version of the document

(File > Save As) before deleting so that

you don’t lose the entire thing. You might

decide that you want to use a version of

it later on.

Figure 17.81 Select Remove Timeline from the shortcut
menu to remove the timeline code from the page.

Figure 17.80 Type a new name for the timeline in the
Timeline Name text box.
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� If you accidentally remove a Timeline,

remember the magic word: Undo. Select

Edit > Undo from the Document window

menu bar, or press Ctrl+Z (Command+Z).



Figure 17.84 To switch which object 
is animated, select the name of an
object from the Object to Animate
drop-down menu.

Figure 17.83 The Change Object dialog box allows you
to transfer an animation channel from one object to
another.

Figure 17.82 To remove an object, select Modify >
Timeline > Remove Object. The Timelines panel
doesn’t even need to be open for this.

Removing or Changing
Objects
You can remove an object from a timeline if

you no longer want to include it in the ani-

mation, or you might decide that the actions

you’ve set up for a layer are dandy, but that

they’d work better for a different layer. 

To remove an object from a timeline:

1. In the Timelines panel, click on the ani-

mation bar for the object you want to

remove from the timeline.

2. Press Backspace (Delete). The object will

be removed from the timeline, but it will

remain on the page.

✔ Tips

� You can also select the object in the

Document window and then use a menu

command to remove it. From the menu

bar or from a context menu, select

Modify > Timeline > Remove Object

(Figure 17.82).

� To remove a behavior from a Timeline,

select Modify > Timeline > Remove

Behavior from the menu.

To change objects:

1. In the Timelines panel, select the anima-

tion bar for the object you want to switch

with another object.

2. From the menu bar, select Modify > Time-

line > Change Object. The Change Object

dialog box will appear (Figure 17.83).

3. From the Object to Animate drop-down

menu, select an object (Figure 17.84).

4. Click on OK to close the Change Object

dialog box. The animation bar will now

describe the object you selected.
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Bringing It All Together
Timelines are quite versatile, although moving

objects are difficult to illustrate in print. To

wrap up this chapter, we’re going to visually

dissect a quasi-useful timeline we constructed

using almost all timeline capabilities. Follow

the figure captions for Figures 17.85

through 17.93.

One note about Figures 17.90 through 17.92:

The Map layer doesn’t do anything in the

second timeline, but we added it so it would

be visible while working. Dreamweaver dis-

plays the default image rather than the one

that’s been swapped in.

✔ Tip

� To see this timeline in action, pay a visit

to www.tarin.com/newtoys/toys.html.

Figure 17.87 Frame 45 of the Map timeline. A few
frames after the map layer arrives, the image source
changes into a different map (on Frame 45, we changed
the source in the Property inspector). This map has a
larger file size, but the image had been preloaded in 
a layer.

Figure 17.86 Frame 25 of the first timeline, called
Map. We want the window to be blank to start. Then
the first map is brought in from off screen.

Figure 17.85 Here are the raw materials. The page
contains five layers: the map, the person, and three
“bubbles.” The other layers need to be positioned
relative to the map, so they’re all nested within 
the map.
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Figure 17.90 In Frame 1 of the Travel timeline, the
layer “Bubble 1” appears above the person’s head.

Figure 17.89 Frame 82 of the Map timeline. The
person has arrived. A few frames later, in Frame 95, a
behavior will play the second timeline, called Travel.

Figure 17.88 Frame 64 of the Map timeline. The person
layer (“tinyme”) begins to arrive from off screen. Like the
map layer, the person was given negative coordinates (L
–400px,T –300px) at the start of the timeline.

Figure 17.93 The work in action. We created a link to
this timeline in a JavaScript window the same size as
the map images.

Figure 17.92 Frame 73 of the Travel timeline. At the end
of the timeline, the person is all the way across the map.
Bubble 2 is hidden, and Bubble 3 appears. We also
added a Loop behavior inFrame 80; after a pause, the
second timeline will replay.

Figure 17.91 Frame 41 of the Travel timeline. The person
has moved halfway across the country. Bubble 1 is hidden
and Bubble 2 appears. Note that the playback rate is 10
fps rather than 15; this timeline moves more slowly.
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