
Adjusting the Table Size
Besides adding and removing elements from
the table, you can adjust the table’s size and
appearance by increasing or decreasing the
height and width of the entire table, as well
as the size of the columns and rows within it.

You may have set a width for your table when
you created it, but you can easily adjust the
width of the table at any point after that. The
width of your table will be in either pixels or
percent of screen width.

To set the table width:

1. Select the entire table to display the Table
Properties in the Properties inspector
(Figure 10.34). From the drop-down
menu to the right of the W (Width) text
box, choose either Pixels or Percent (%).

2. Type a number in the W (Width) text
box.

3. Click on the Apply button, and the width
of your table will change.

To resize a table: 

1. Select the table. Three handles will
appear in the lower-right corner of the
table (Figure 10.34). 

2. To make the table larger, click on one of
the handles and drag the corner to the
right and/or down.

To make the table smaller, click on one
of the handles and drag the corner to the
left and/or up.

✔ Tip

■ You can use Dreamweaver’s grid for exact
measurements when resizing your table
and its cells. To turn on the grid, select
View > Grid > Show from the Document
window menu bar. For more about the
grid, see Chapter 1.
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Figure 10.34 Type the width of the table in the W
(Width) text box. Or, grab it by the handles and drag it
to resize.

Figure 10.35 A single
cell was added to this
table. Note the blank
space in the rest of the
row.

Adding a Single Cell to a Table

While Dreamweaver doesn’t directly sup-
port the addition of a single cell to a table,
you can do it by add i ng a si ngle line of code .

1. From the Document window menu
bar, select Window > HTML. The
HTML inspector will appear.

2. To add a cell at the end of a table,
locate the closing table tag, </TABLE>,
and type the following line of code just
before it: <tr><td>&nbsp;</td></tr>

Th is adds a new row <tr>with on ly one
cell in it <td>. The &nbsp; gives the cell
some content so it will show up.

3. Press Ctrl+S (Command+S) to save the
changes to the HTML and the new cell
will appear in the table (Figu re 10.35).

You can experiment with placing this
code at other places in the table.



Dragging columns and rows

You can adjust column width or row height
by simply clicking and dragging.

To drag columns and rows:

1. When you move the mouse over a border
between cells, the pointer will turn into a
double-headed arrow (Figure 10.36).

2. Click on the border and drag it to a new
location (Figure 10.37). This will set the
specifications for the dimensions of the
table elements involved.

✔ Tips

■ While you can set row height, a row’s
height will expand to fit the content. 

■ You can also set the height and width for
an individual cell by selecting that cell.
As with column and row dimensions,
this is not as much an exact science as it
purports to be; the size of the content
and the quirks of the browser will vary
your mileage.

Clearing row heights

If you have previously inserted some tall
content, and the table’s row heights have not
contracted to fit the current content, you
can clear row heights to shrink the table.

To clear row heights:

1. Select the entire table and the Properties
inspector will display Table Properties
(as shown in Figure 10.34).

2. In the Properties inspector, click on the
Clear Row Heights button: .

or

From the Document window menu bar,
select Mod ify > Table > Clear Row Heights .

Any row heights previously set will be
cleared (Figure 10.39).
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Figure 10.39 After you reset the row heights, the table
will resize itself. We saw this table in Figure 10.38;
notice how the column widths remain the same.

Figure 10.36 Mouse over the table border and the
pointer will turn into a double-headed arrow.

Figure 10.37 Use the double-headed arrow to drag the
border to a new location.

Figure 10.38 I put an image in this table and then cut
it. Now, I’m left with all this space I don’t need!



To set column and row dimensions:

1. Select the column or row whose width or
height you’d like to specify. The Properties
inspector will display properties of the
selected column or row.

2. If the Properties inspector is collapsed,
expand it by clicking on the Expander
arrow in the lower-right corner.

3. Type a number in the W (Width) text
box. To set a percentage rather than a
pixel width, type the % character directly
after the number (no space).

4. Type a number in the H (Height) text
box. To set a percentage rather than a
pixel height, type the % character directly
after the number (no space).

5. If necessary, click the Apply button to
apply the changes to the table. Figure
10.40 shows a column set to occupy 50
percent of the table width.

✔ Tip

■ While most of the images in this chapter
show little bitty tables, they can be trans-
lated easily into fu ll - page layouts by setti ng
the table width to 100 percent.

To clear column widths:

1. Select the entire table and the Properties
inspector will display Table Properties.

2. In the Properties inspector, click on the
Clear Column Widths button: .

or

From the Document window menu bar,
select Modify > Table > Column Widths.

Any column widths set by you (either in the
Properties inspector or by dragging a cell’s
border) or by Dreamweaver when the table
was created will be reset to no value
(Figure 10.41).
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Figure 10.40 This column was set to occupy half the
table width.

Figure 10.41 After column widths are
cleared, the table will resize itself.

You Ought to Be in Pixels

If you set a column’s width in pixels, the
text you type or paste into the cells in that
column will wrap to fit in the column.
However, if you place an image wider than
the column in one of those cells, the col-
umn will still expand to fit the image.



Converting Percentages
and Pixels
You can convert any width or height mea-
surements in your table from percentages
to pixels. This is especially useful if you’re
working with tables created in another envi-
ronment.

To convert from 
percentages to pixels:

1. Select the entire table and the Properties
inspector will display Table Properties.

2. In the Properties inspector, click on the
Convert Table Widths to Pixels button:

.

or

From the Document window menu bar,
select Modify > Table > Convert Widths
to Pixels (Figure 10.42).

To convert from 
pixels to percentages:

1. Select the entire table and the Properties
inspector will display table properties.

2. In the Properties inspector, click on the
Convert Table Widths to Percent button:

.

or

From the Document window menu bar,
select Modify > Table > Convert Widths
to Percent.

✔ Tip

■ While the changes won’t be visible in the
Document window, you can look at the
changes in the HTML inspector by select-
i ng Wi ndow > HTML from the Docu ment
window’s menu bar, or by pressing F10.
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Figure 10.42 With the table selected, choose Modify >
Table > Convert Widths to Pixels from the Document
window menu bar.

Name That Table

If you’re planning on working with table
code directly, it may help to know which
table you’re working on, particularly if
you’ve inserted a table within a table. You
can name your table, in which case the
table code will say something like

<table name="main">

To name your table, first select it. Then, in
the Properties inspector, type a name in
the Table Name text box to the right of
the Apply button (Figure 10.43), and
click on the Apply button. The table name
will be inserted into the code.

Figure 10.43 Type a
name for your table in
the Table Name text box.



Creating a Table
within a Table
When you have some complex design ideas
to accomplish, you can insert a table within a
larger (full-page size, for example) table.

To insert a table within a table:

1. Click in the table cell where you’d like to
insert a new table (Figure 10.44).

2. Click on the Table button on the Objects
palette and the Insert Table dialog box
will appear.

3. Type a number of columns and a number
of rows in the appropriate text boxes.

4. Click on OK to close the dialog box.

You’ll see your new table inside the old table
(Figure 10.45).
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Saving Excel Spreadsheets and Word Tables as HTMLTables

Although you can’t paste spreadsheet data into Dreamweaver as you can into Front Page, you
can still convert your Excel spreadsheets into tables. Dreamweaver 3’s new features can also
help. For Word, see Cleaning Up Word HTML in Chapter 3. For Excel, see Inserting Tabular
Data, later in this chapter. For basic advice on converting tables into HTML, read on.

Excel 95, Excel 97, and 98 have utilities to save a spreadsheet as HTML. In Excel 95, choose
Tools > Internet Assistant Wizard from the menu. For Excel 97 and 98, the command is
File > Save as HTML. Both of these programs use Wizards to guide you.

You can al so save Microsoft Word table data as HTML. In Word 95, you select File > Save As
from the menu bar, and choose HTML (*.htm) as the file type. In Word 97 and 98, the com-
mand is File > Save as HTML.

On ce you have one of these Office - created docu ments saved, you can open it in Dreamweaver
and edit the page or cut and paste the table onto an existing page.

Figure 10.44 Select the table cell you
want to hold the new table.

Figure 10.45 Your new table appears
inside the old table.
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Working with Table Bord e r s
By default, when you insert a table with
Dreamweaver, a 1-pixel line, called a border,
will delineate the cells and the edges of the
table, but you can easily change the width of
this border. (See the sections on cell padding
and cell spacing later in this chapter for more
about table spacing.)

To adjust border size:

1. Select the table to display table properties
in the Property inspector.

2. In the Border text box, type a number
and press Enter (Return), or click on the
Apply button.

You’ll see your border adjustments immedi-
ately (Figure 10.46); if you set the border
width to 0, you’ll see a light, dashed line
(Figure 10.47). No worries: it won’t show up
in your browser (Figure 10.48).

✔ Tips

■ You can change the border width to
whatever you want, including 0.

■ Setting the border width to 0 is also
known as turning off table borders. You’ll
want to do this if you’re using tables to
lay out pages rather than display tabular
information.

■ It’s useful to work with borders turned on
(set to at least 1) while you’re designing
pages, so you can see what’s going on.
You can toggle off the dashed lines, too,
for a quick preview. With table borders
set to 0, select View > Table Borders from
the Document window menu bar and
they’ll disappear.

■ To find out about coloring table borders,
skip ahead to Coloring Tables.
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Figure 10.46 I gave my table a border
width of 10. Borders larger than 1
affect only the outside edge of the
table, while border widths of zero
render all borders invisible.

Figure 10.47 A table with a border
width of ze ro is shown in Dre a m we a ve r
with light, dashed lines.

Figure 10.48 This is the same table
we saw in F i g u re 10.47. You can also
see your table without dashed lines
by toggling off the table borders.
From the Document window menu
bar, select View > Table Borders to
uncheck that option. In the browser
window, the borders are invisible.



Adjusting Table Spacing
When you’re using a table as a page layout
tool, it’s important to be able to control the
space between elements in a table. We’ve
already talked about table borders, which in
part control the space between the table and
the rest of the page.

Cell spacing is the amount of space between
cells—sort of like table borders, but between
the cells in a table rather than around the
outside of the table. Cell padding is the
amount of space between the walls of the
cells and the content within them.

To adjust cell spacing:

1. Select the table to display table properties
in the Properties inspector.

2. In the CellSpace text box, type a number
(in pixels) (Figure 10.49).

3. Click on the Apply button.

Your changes will be visible in the width of
the table’s borders (Figure 10.50).

✔ Tip

■ Cell spacing changes may not be imme-
diately visible on pages with table borders
set to 0.

To adjust cell padding:

1. Select the table to display table properties
in the Properties inspector.

2. In the CellPad text box, type a number
(in pixels).

3. Click on the Apply button.

You’ll notice a difference in the spacing
between the content and the borders
(Figure 10.51). If there is no content in your
table at this point, you can see the changes
by clicking within the cells and examining
the distance between the cursor and the
walls of the cell.
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Figure 10.49 Type
values for cell padding
and cell spacing in the
Properties inspector.

Figure 10.50 We made the cell spacing 10
pixels wide. If we make the border width
0, the cell spacing will be invisible.

Figure 10.51 This is the same table shown in Figure
10.50, but we added 10 pixels of cell padding. Notice
the space between the characters and the walls of
the cells.



Adjusting Vspace and Hspace

If you want a certain amount of space
arou nd the edges of your table, you can adjust
the Vspace (vertical spacing) and Hspace
(horizontal spacing). Vspace inserts blank
space above and below your table, and Hspace
inserts space to the left and right of it.

To adjust Vspace and Hspace:

1. Select the entire table so that the
Properties inspector displays table
properties.

2. Expand the inspector to display the lower
half, if necessary.

3. Type a number, in pixels, in the V Space
text box to add space above and below
your table (Figure 10.52).

4. Type a number, in pixels, in the H Space
text box to add space to the left and right
of your table.

5. Click on the Apply button to add the
spacing to your page.

If you drag to select the table and some
surrounding space (Figure 10.53), you can
see the Vspace and Hspace surrounding the
table. Without dragging, you can see the
Vspace in Figure 10.54, indicated by the
size of the cursor (it’s taller than the table).

✔ Tip

■ Using cell padding and cell spacing is
particularly useful if you’re going to use
tables in close proxi mity to other elements
on your page, as shown in Figure 10.55.
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Figure 10.52 Type a
number, in pixels, in the
V Space and H Space
text boxes on the
Properties inspector.

Figure 10.54 With 10 pixels of Vspace applied to this
table, the cursor becomes taller than the table is.

Figure 10.53 If you drag to select the table and some
s u r rounding space, the table becomes re versed out,
and you can see the Vspace and Hspace outlined
around the table. I used 10 pixels of each.

Figure 10.55 These tables have 10 pixels of space on
each side to give them natural, borderless spacing
from the rest of the page.


