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ou have totally re-created the Shelley Biotech homepage graphics with
Flash. Now comes the fun part: animating it!

In this chapter you will learn the basic concepts you need to create ani-
mation in Flash movies. You will gain an understanding of what an ani-
mation is, the difference between the speed and the length of your
animation, and what interface elements the Flash editor contains to help
you create and control your animation.

 

�

 

Timelines and Frames

 

Before we begin animating the page elements, we need to do some
clean-up work, including converting some graphics to symbols and
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reorganizing and creating layers. You can download the current
project from the Chapter 2 section of 

 

http://www.phtr.com/essential/
flash5

 

 or directly from 

 

http://www.phptr.com/essential/flash5/shelley/
shelley1-12.html

 

. 

 

Creating the Link Text Symbol

 

Take a look at the current page, Figure 2–1. The links on the page
will all appear to move together in our animation. To allow us to
do this easily, we can create a single graphic symbol that con-
tains all of them grouped together.

1. We need to select all the text links. Use the Arrow and
hold down the Shift key to select the seven text links:
about us, vendors, investors, products, contact us,
research, and press releases.

2. Choose Modify

 

➔

 

Group.
3. Choose Insert

 

➔

 

Convert to Symbol.
4. Name the new symbol “Link Text” and set its behavior to

Graphic. Click OK.

 

Creating the Logo Layer

 

Flash requires that any symbol to be animated must be in its own
layer. The lines connecting the circles need to be moved to their
own layer, since we will be animating them. To do this:

FIGURE 2–1 Current Shelley page.
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1. Select the top layer in the layer list and click on the Insert
Layer button, shown in Figure 2–2.

2. Name the new layer “Logo.”
3. If you haven’t already done so, move the Link Text layer

over the Circles layer.
4. Click on one of the lines connecting the circles. This will

select all the lines and circles, because we grouped them
earlier.

5. Choose Modify

 

➔

 

Ungroup.
6. Choose Edit

 

➔

 

Deselect All.
7. Use the Arrow and the Shift key to select all of the lines. If

you accidentally select something else, just click on it
again with the Shift key held down to deselect it and leave
everything else selected.

8. Choose Edit

 

➔

 

Cut.
9. Select the Logo layer.

10. Choose Edit

 

➔

 

Paste in Place. You have now moved the
lines to the new layer. They are in front of the circles, but
we’ll be moving them in a moment.

FIGURE 2–2 Flash interface with the Add Layer button.
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11. With the lines still selected, choose Modify

 

➔

 

Group.
12. Finally, make the lines into a symbol by selecting

Insert

 

➔

 

Convert to Symbol. Name this symbol “Lines”
and set its behavior to Graphic. See Figure 2–3.

 

CHECKPOINT

 

This would be a good time to save your work. Choose File

 

➔

 

Save As, 
and save this file in the directory of your choice as 

 

shelley.fla

 

. Down-
load the project at this point from 

 

http://www.phptr.com/essential/flash5 

 

or view it directly at

 

http://www.phptr.com/essential/flash5/shelley/shelley2-1.html.

 

Adding an Additional Background Layer

 

Both the white and the brown curves making up the background
will be animated. We need a separate layer for each.

1. Click on the Background layer. This layer currently con-
tains both of the background curves.

2. Choose Insert Layer from the Layer menu. This will place
a new layer immediately above the Background layer.

3. Rename this “Background 1.”
4. Select the white curve. Choose Edit

 

➔

 

Cut.
5. Select the Background 1 layer and choose Edit

 

➔

 

Paste in
Place.

6. Rename the original Background layer “Background 2.”

FIGURE 2–3 Symbol Properties dialog box.
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Creating Some Layers for the Circles

 

The last organizational change you need to make involves mov-
ing each of the seven circles to separate layers so each can be ani-
mated separately.

1. Select the Background 1 layer and create seven new layers. 
2. Name them as follows: Press Releases, Research, Contact

Us, Investors, Vendors, About Us, and Products. Don’t
worry about the order; we will adjust that in a moment.

3. We need to move each one of our current circles to one of
these new layers. For each of our seven circles, select it,
choose Edit

 

➔

 

Cut, click on the appropriate new layer
(according to the text link overlapping it), and choose
Edit

 

➔

 

Paste in Place.
4. When all the circles have been moved, the Circles layer

will have nothing left in it. Get rid of it by selecting it and
choosing Delete Layer from the Layer menu. 

Select and drag the layers up and down to move them. Put
your layers in the following order, from top to bottom:

1. Header Text. This is the Shelley Biotech banner and asso-
ciated shadow.

2. Link Text.
3. Address Text.
4. Address Sphere. This is the sphere under the Address Text.
5. Office Photo.
6. Link Circle layers. Each of the seven circles should be in a

separate layer.
7. Logo. This consists of the seven lines that connect the link

circles.
8. Background 1. The white curve.
9. Background 2. The brown curve.

 

CHECKPOINT

 

This would be a good time to save your work. Choose File

 

➔

 

Save As, 
and save this file in the directory of your choice as 

 

shelley.fla.

 

 Down-
load the project at this point from 

 

http://www.phptr.com/essential/flash5 

 

or view it directly at

 

http://www.phptr.com/essential/flash5/shelley/shelley2-2.html.
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Frames and Animation

 

One of the most important aspects of a Flash movie is the anima-
tion, which is nothing more than a series of still images, displayed
over time. Each of these still images is called a frame. The speed at
which the frames are displayed is controlled by the fps (frames per
second) setting in Flash. A setting of 12 fps, which is the default
setting, means that 12 frames will be displayed every second.

There are two ways to change the fps value:

1. Double-click the fps box, which is located just below the
timeline. See Figure 2–4.

2. Choose the menu option Modify

 

➔

 

Movie.

Both of these open the Movie Properties dialog box, shown in
Figure 2–5. The first blank on this dialog box contains the frame
rate. A rate between 8 and 15 is recommended. This range allows
relatively speedy processing of the animation while retaining
smoothness of motion. For our animation, make sure the value is
set at 12.

 

Tweening and Keyframes

 

Before the advent of computers, cartoon animators had to draw
each frame of an animation. Although you can do that with
Flash, you are provided with a time-saving method of animation
that requires you to create only the most important frames. Flash
creates the intermediate frames for you. This is called 

 

tweening.

 

 In
using tweening, you create only special frames, called 

 

keyframes,

 

to serve as turning points during an animation, and Flash fills in
the gaps. For example, if you wanted to animate an object mov-

FIGURE 2–4 The frames per second box.
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ing to the right, hitting the edge of the screen, and moving left,
you would only have to create three keyframes, and tell Flash to
do the rest.

 

Adding Keyframes to the Shelley Biotech Page

 

We can now put in place the keyframes we will need for the Shel-
ley page.

1. Open the latest version of the Shelley file. This can be
downloaded from 

 

http://www.phptr.com/essential/flash5/
shelley/shelley2-2.html.

 

2. We now need to select the thirtieth frame of all the layers.
To do this, click and hold on the frame area at the 30
frame mark of the top layer and drag downward until all
the layers are selected, as shown in Figure 2–6. This is a
little tricky.

3. Choose Insert

 

➔

 

Keyframe. Your timeline should now look
like Figure 2–7. 

 

CHECKPOINT

 

This would be a good time to save your work. Choose File

 

➔

 

Save As, 
and save this file in the directory of your choice as 

 

shelley.fla

 

. Down-
load the project at this point from 

 

http://www.phptr.com/essential/flash5 

 

or view it directly at

 

http://www.phptr.com/essential/flash5/shelley/shelley2-3.html.

FIGURE 2–5 The Movie Properties dialog box. The frames 
per second rate can be changed here.
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We still have no animation, even though we have multiple
frames. If you click on the first or last keyframe or any frame in
between, you will notice that nothing changes. Two things still
need to be done: First, you select a keyframe and make some
change to the graphic at that point. Then you must tell Flash
what kind of tweening to use. Flash can tween the movement of
an object as well as its shape and color. 

The next section will show you how to animate the graphics
on this page. One final note: The graphics we created in Chapter
1, “The Basics,” are the final product of the animation. We will be
working backward and modifying the first keyframe, while leav-
ing the last one alone. To get a clearer picture of this, go look at
the finished product at 

 

http://www.phptr.com/essential/flash5/shel-
ley/new/

 

 and notice that the page ends up looking like our current
file, but looks totally different when you first see it.

FIGURE 2–6 Selecting the thirtieth frame of all the layers.
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�

 

Movement Tweening

 

The animation you will perform more than any other will be
movement tweening. This consists of giving an object a starting
and an ending location and letting Flash interpolate the frames
in between. Movement tweening also interpolates on the basis of
object size and rotation.

 

Animating the Tan Background Curve

 

For our first animation trick, we will be making the brown back-
ground curve move. Figure 2–8 shows the path of this object.
Only the outlines of the object are shown. In Flash, this view is
called 

 

onion-skinning.

FIGURE 2–7 Current timeline.
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1. Begin by selecting the Background 2 layer and hiding all
the others, using the Layer menu.

2. Click on the first keyframe. This is the frame located at 1
on the timeline that has a solid black circle in it.

3. You will be moving the curve partly off the movie stage.
To allow you to see it, choose View

 

➔

 

Work Area. You may
also find it useful to use the Zoom drop-down box
(located on the bottom left edge of the current movie) set
to 50% or smaller.

4. Change to the Arrow tool. Select the curve and move it to
the left and down, as shown in Figure 2–9.

5. Add a keyframe at 14 by clicking at the 14 mark on the
Background 2 layer and selecting Insert

 

➔

 

Keyframe.
6. Click on this new keyframe.
7. Move the curve up, as shown in Figure 2–10.
8. Click on a frame anywhere between the first and second

keyframes. Choose Window

 

➔

 

Panels

 

➔

 

Frame to open the
Frame panel. You can also right-click (PC) or Ctrl-click
(Mac) and select Panels

 

➔

 

Frame from the pop-up menu.
9. Select Motion from the Tweening drop-down box on this

panel. Scale should be checked, and Rotate should be set to
Auto. The Easing slider should be set to 0. See Figure 2–11.

FIGURE 2–8 The animated path of the tan 
background object. The darker lines indicate 
the most recent events.
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FIGURE 2–9
Tan curve location 
at first keyframe.

FIGURE 2–10
Tan curve location at

second keyframe.

FIGURE 2–11
Frame panel.
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10. Click on a frame anywhere between the second and third
keyframes, and repeat step 9.

11. To test your animation, press the Enter key, or select
Control

 

➔

 

Play.

 

CHECKPOINT

 

This would be a good time to save your work. Choose File

 

➔

 

Save As, 
and save this file in the directory of your choice as 

 

shelley.fla

 

. Down-
load the project at this point from 

 

http://www.phptr.com/essential/flash5 

 

or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-4.html

A Quick Word about Onion-Skinning

Flash has a very nice feature that allows you to see the stages of
an animated object over time. This is known as an onion-skin view.
It displays the graphic in each frame at the same time, giving you
a picture of the path it is taking. The first frames are fainter than
the later frames.

To use it, select the Onion Skin button, shown selected at the
bottom of Figure 2–12. Notice the handles that appear on the
timeline above all the layers. Change the frame interval by drag-
ging the right handle to frame 30. This image also shows the
Onion Skin markers on the timeline. The color changes over time,
with the faintest images representing the early frames. Turn it off
by clicking on the Onion Skin button again. If you only wish to
see the outlines, click on the Onion Skin Outlines button.

FIGURE 2–12 Onion Skin markers on the timeline.
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Animating the Link Circles

The link circles will start out fairly large and centered on the Prod-
ucts circle. They will shrink and move outward to their appropri-
ate places. They will also initially be transparent and fade in.
Don’t worry, this sounds more complex than it actually is!

1. Begin by selecting the Products layer and hiding all the
others, using the Layers Menu➔ Hide Others option.

2. Click on the red X next to the names of the other six link
circle layers to make them appear. You should now see
seven circles against the tan background, as in Figure 2–13.

3. Hold down the Ctrl key and select the fifteenth frame on
each of these layers and choose Insert➔ Keyframe. See
Figure 2–14.

4. Select the center circle with the Arrow. The Products layer
should now be selected.

5. Drag the Products layer below the other circle layers.
6. Click on the first keyframe of the Products layer, located

at frame 1. The circle in this layer should be selected.
7. Open the Info panel if it is not open, by choosing

Window➔ Panels➔ Info.

FIGURE 2–13 Link circles.
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8. On the Info panel, there is a cluster of nine small boxes.
Click on the box in the center, as shown in Figure 2–15,
and change the Width (w) and Height (h) each to 300.
Press Enter.

9. Make sure the first keyframe is still the current one
selected. Using the Arrow and Shift keys, select all of the
circles.

10. Open the Align panel by choosing Window➔ Panels➔
Align.

FIGURE 2–14 Inserting a keyframe.

FIGURE 2–15
Info panel.
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11. We want all the circles to be 300 pixels by 300 pixels and
in the same location. To do this, click on the two middle
buttons under the Align label. Look at the buttons shown
in Figure 2–16.

12. Now click on the Match Size button on the right. This will
make all the circles 300 pixels by 300 pixels and centered,
so only one will be visible, with the rest stacked under it.

13. We need to set the tweening for the circle layers. For each
of the seven link circle layers, click on a frame anywhere
between the first and second keyframes. Open the Frame
panel.

14. Select the Tweening tab on the Frame panel. Choose
Motion from the drop-down list. Scale should be checked,
and Rotate should be Automatic. The Easing slider should
be 0.

15. Take a look at the animation you just added by pressing
Enter.

We still need to make the circles start transparent and fade in.
We will do this by changing the transparency for the circles at the
first keyframes of each layer. This should be clearer to you in a
moment.

1. Open the Effect panel. You can do this by clicking on the
tab labeled “Effect” on the Frame panel dialog, or from
Window➔ Panels➔ Effect. See Figure 2–17.

2. The Effect for the circles at the first keyframe needs to be
changed. Click on the Products layer and hide the others.

3. Click on the first keyframe in this layer. The large circle
visible on the stage should be selected.

4. Choose Alpha from the drop down box on this panel. Set
the value to 0%. 

FIGURE 2–16
Align panel.
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5. Repeat steps 2 through 4 for each of the other six layers.
Make sure you are making this change on the large circle
located at the first keyframe!

6. Select Show All from the Layer menu.

We are getting closer, but still have a few more animations to
add.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-5.html.

Animating the Address Text

Let’s make the Address Text really large when the animation
begins. It will also change color, but we’ll do that a bit later in the
section on Fading. To preview what the Address Text will be
doing, look at Figure 2–18, which shows the onion-skinned ver-
sion of the animation.

1. Click on the first keyframe of the Address Text layer.
2. Select View➔ Work Area. Use the Zoom Control and

change the zoom to 50% or less.
3. Use the Layer menu to hide all the layers except for the

Address layer. With the Arrow, select the address text.

FIGURE 2–17
Effect panel.
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Click on the red X next to the Background 2 layer to make
it visible also.

4. We need to turn the address text into a symbol so we can
animate it. Make sure you are on the first keyframe and
choose Insert➔ Convert to Symbol. Name it “Address
Text,” change its behavior to Graphic, and click OK.

5. Now we have a small problem. The address text in the first
keyframe is a symbol, but the address text in the last key-
frame is not. We need to replace it with the symbol ver-
sion. It’s easy enough to do. Click on the last keyframe on
the Address Text layer and choose Insert➔ Clear Keyframe.

6. Now put a keyframe back at this location by choosing
Insert➔ Keyframe. The Address Text symbol we just cre-
ated will now be present.

7. Select the first keyframe of the Address Text layer and
make sure the Address Text symbol is selected.

8. Click on the Scale button on the bottom of the toolbar.
Using the handles or Object Inspector, stretch the address
text until it is approximately 1000 pixels wide and 1060
pixels high. You may want to do this with the Info panel
instead of scaling it.

9. Reposition and resize until the word “Shelley” is located on
top of the visible part of the tan curve, as in Figure 2–19.
No other words should overlap the visible part of the tan
curve.

FIGURE 2–18
Onion-skin view of 
address text animation.
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10. Click on a frame between the two keyframes on the
Address Text layer. Open the Frame panel.

11. Select the Tweening tab on this dialog box. Choose
Motion from the drop-down list. Scale should be checked,
and Rotate should be Automatic. The Easing slider should
be set to 0. 

12. To see the results, press Enter.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-6.html.

Animating the Text Links

The text links will be very small and on the right side of the
screen, then grow in size and move left. Figure 2–20 shows the
onion-skinned path of these objects.

FIGURE 2–19 Address text stretched and moved.
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1. Begin by selecting the Link Text layer and hiding all the
others, using the Layers menu.

2. Click on the first keyframe.
3. Open the Info panel and resize the group of links to

approximately 40 pixels × 40 pixels and to move it to an
(X, Y) location of (500, 250).

4. Click on a frame between the two keyframes on this layer.
Open the Frame panel.

5. Select the Tweening tab on this dialog box. Choose
Motion from the drop-down list. Scale should be checked,
and Rotate should be Automatic. The Easing slider should
be set to 0. 

6. To see the results, press Enter.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-7.html.

Animating the Header Text

Figure 2–21 shows the onion-skinned path of this object.

FIGURE 2–20
Onion-skin view of text links 
with page border shown.
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1. Begin by selecting the Header Text layer and hiding all
the others, using the Layers menu.

2. Click on the first keyframe.
3. Open the Info panel. Resize the Header Text to approxi-

mately 130 pixels by 10 pixels and to move it to an (X, Y)
location of (630, 90).

4. Click on a frame between the two keyframes on this layer.
Open the Frame panel.

5. Select the Tweening tab on this dialog box. Choose
Motion from the drop-down list. Scale should be checked,
and Rotate should be Automatic. The Easing slider should
be set to 0. 

6. To see the results, press Enter.

If you haven’t viewed the entire page animation already,
select Show All from the Layers menu. Press Enter. You have now
added all the motion tweening to the page. Now let's do some
Shape tweening.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-8.html.

� Shape Tweening

Shape tweening animation is used when you need to change or
morph one shape into another. The shape and the color shifts

FIGURE 2–21 Onion-skin view of header text with page border shown.

ch02.fm  Page 62  Wednesday, November 15, 2000  8:52 AM



Shape Tweening 63

gradually from the beginning graphic to the final one. As in
motion tweening, Flash will interpolate the intermediate frames
for you. Shape tweening is best used somewhat sparingly, as it
increases the final size of the Flash movie much more than
Motion tweening does.

In the Shelley Biotech page, only one object undergoes shape
tweening. This is the semitransparent egg-shaped sphere under-
neath the address text. We will make it start out as a large S and
morph into the sphere.

Creating the Beginning S Shape

Now, we need to create the starting S shape.

1. Select the Sphere layer and hide the other layers.
2. Click on the first keyframe of the Sphere layer.
3. Change to the Text Tool and open the Character panel.

Set the font to Arial, the size to 72, the color black, and
click on both the Bold and Italic buttons.

4. Click on the scene and type an uppercase S. Change to
the Arrow Tool.

5. Select the oval shape in this keyframe and delete it with
the Delete key.

6. Select the S and open the Info panel.
7. Resize the S to approximately 30 width by 155 height in

pixels.
8. Choose Modify➔ Break Apart. This will allow us to apply

a gradient fill to the S.
9. We should make the S have the same colors as the final

sphere it will become. Change to the Paint Bucket. Click
on the Palette button at the bottom of the Tools menu.
Select the gradient fill from the bottom of the color palette
that was used to fill the link circles. See Figure 2–22.

FIGURE 2–22
Gradient fill.
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10. Click on the S shape with the Paint Bucket somewhere
near the center.

11. Click on the Header Text layer to make it visible. Make
sure the S is lined up with the first letter of the header, as
shown in Figure 2–23, by selecting it, moving it, and
using the Scale option with the Arrow.

Now that we have our starting and ending shapes, we can
perform shape tweening and let Flash fill in the frames between
them.

Applying Shape Tweening to the S

1. Hide the Header Text layer and all other layers except for
the Address Sphere layer.

2. Click on any frame between the starting and ending key-
frames on the Address Sphere layer.

3. Open the Frame panel.
4. Choose Shape Tweening with the Blend of Distributive,

and change the Easing to –100, as in Figure 2–24. Moving
the Easing slider left makes the tweening start slowly and
then speed up near the end.

5. Press Enter to view the shape tweening.

FIGURE 2–23
S shape.

FIGURE 2–24
Tweening tab of Frame 
Properties dialog box.
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CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-9.html.

Adding Shape Hints

Shape hints are markers you place on the beginning and ending
shapes in a shape tweening to tell Flash how to proceed in the
frames between the two keyframes. When you create a shape
hint, Flash puts a small, labeled circle on the image at both the
first and second keyframes. You can use the Arrow to move these
markers. If you place the marker at the top of the image in the
first keyframe, and at the bottom of the image in the second, the
image will appear to turn itself inside out, with the top migrating
toward the bottom during the animation.

1. Select the first keyframe in the Address Sphere layer.
2. Choose Modify➔ Transform➔ Add Shape Hint. A small

red circle with a letter a in it appears. Use the Arrow to
move it away from the S.

3. Add two more shape hints, b and c, and move them so all
three are visible.

4. Move the letters to the locations shown in Figure 2–25.
5. Click on the last keyframe. Matching letters are stacked in

the center of the oval. Move them to the locations shown

FIGURE 2–25
Shape hints correctly 
placed on the S graphic.
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in Figure 2–26. These will turn green when they are in
valid locations. 

6. Press Enter to see the result of the shape hint influence on
the shape tweening.

7. To hide the shape hints from the view, uncheck
View➔ Show Shape Hints.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-10.html.

If you make all the layers visible at this point and animate
them, you’ll notice that the page is rather cluttered. We will fix
that in the next section.

� Fading

Now all that remains to be done is to apply some fading to the
beginning keyframes of some of the images. This will help to

FIGURE 2–26 Shape hints correctly placed on 
the transparent oval.
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clean up much of the clutter you see when you view the entire
animation.

Fading in the White Background

The white background layer is nice for the final frame of the ani-
mation, but is a bit distracting while the animation is taking
place. Let’s make it fade in.

1. We made the white background a symbol in Chapter 1.
This allows us to modify its Instance Properties. Select the
Background 1 layer and hide all the rest.

2. Click on the first keyframe.
3. With the Arrow, select the white curve. Open the Effect

panel.
4. Choose Alpha from the drop-down list and set the value

to 0% by moving the slider down or typing in the text
box. See Figure 2–27. Press Enter.

5. Click on a frame between the two keyframes on the White
Background layer. Open the Frame panel.

6. Choose Motion from the drop-down list. Scale should be
checked, and Rotate should be Automatic. Easing should
be set to 0. Press Enter.

7. To see the results, press Enter.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-11.html.

FIGURE 2–27
Effect panel.
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Fading in the Office Photo

The office photo will also fade in. The procedure is basically the
same as before, except that the fade-in will begin at the fifteenth
frame.

1. Select the Office Photo layer and hide all the rest.
2. Click on the first keyframe.
3. With the Arrow, select the photo.
4. We need to make the photo a symbol so we can modify its

transparency. Choose Insert➔ Convert to Symbol. Name it
“Photo,” set its behavior to Graphic, and click OK.

5. Click on the keyframe at 30 and choose Insert➔ Clear
Keyframe. This will remove the keyframe at 30 that does
not have the Photo symbol in it. The photo in this frame
was not the photo symbol you created in step 4. To create
the fade effect, it must be the same symbol.

6. Now add a keyframe to 30 again by choosing
Insert➔ Keyframe. This time the photo image will be the
Photo symbol you created.

7. Click on the first keyframe again. Select the photo. 
8. Open the Effect panel.
9. Choose Alpha from the drop-down list and set the value

to 0% by moving the slider down or typing in the text
box. See Figure 2–27. Press Enter.

10. Click on the fifteenth frame and choose Insert➔ Keyframe.
11. Click on a frame between the second and third keyframes

on the Office Photo layer. Open the Frame panel.
12. Choose Motion from the drop-down list. Scale should be

checked, and Rotate should be Automatic. Easing should
be set to 0. Press Enter.

13. Press Enter to see the result. The fade-in begins at the fif-
teenth frame and finishes at the thirtieth.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-12.html.
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Fading in the Logo Lines

The lines connecting the link circles should also be faded in.

1. Select the Logo layer and hide all the rest.
2. Click on the first keyframe.
3. With the Arrow, select the lines. Open the Effect panel.
4. Choose Alpha from the drop-down list and set the value

to 0% by moving the slider down or typing in the text
box. See Figure 2–27. Press Enter.

5. Click on a frame between the two keyframes. Open the
Frame panel.

6. Choose Motion from the drop-down list. Scale should be
checked, and Rotate should be Automatic. Easing should
be set to 0. Press Enter.

7. Press Enter to see the result. 

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-13.html.

Changing the Color of the Text Links

Instead of fading in the text links, we will make the color change.
The color will start out the same as the background and then will
change to black. This will make the links stand out a bit more
than if they were faded in.

1. Select the Link Text layer and hide all the rest.
2. Click on the first keyframe.
3. With the Arrow, select the links. Open the Effect panel. 
4. Choose Tint from the drop-down list.
5. Set the Tint Amount percentage to 100.
6. Change the color values on this panel to a red of 204,

green of 204, and blue of 153, as shown in Figure 2–28.
Press Enter.
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7. We don’t need to add motion tweening for this layer since
we did that earlier when we made the Link Text start
small and get larger. To see the results, press Enter.

CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-14.html.

Changing the Color of the Address Text

Right now, the Address Text symbol starts out very large and
dominates the screen. If we change the color of it to the back-
ground of our movie, only the word “Shelley” that is over the
brown background curve will be visible. We can then make its
color change to black as it gets smaller.

1. Select the Address Text layer and hide the others.
2. Click on the first keyframe.
3. The Address Text symbol should now be selected. Open

the Effect panel.
4. Choose Tint from the drop-down list and set the Tint

Amount percentage to 100.
5. Change the color values to a red of 204, green of 204, and

blue of 153, as shown in Figure 2–28. Click OK.
6. Again, we added the Motion tweening earlier, so we do

not need to do that now. To see the results, press Enter.

FIGURE 2–28
The Effect panel with the 
RGB set appropriately.
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CHECKPOINT
This would be a good time to save your work. Choose File➔ Save As, 
and save this file in the directory of your choice as shelley.fla. Down-
load the project at this point from 
http://www.phptr.com/essential/flash5 
or view it directly at
http://www.phptr.com/essential/flash5/shelley/shelley2-15.html.

You have created the graphics for the homepage and ani-
mated them. In the next chapter, “Making the Page Interactive,”
you will add buttons and links to make the page interactive, and
we will examine symbols and buttons in depth.

RECAP

In this chapter you’ve learned how to

• Create symbols and animate them
• Animate the color of symbols
• Animate symbols fading
• Morph shapes

ADVANCED PROJECTS

1. In a new movie, create several layers with a graphic in
each and turn these into symbols.

2. Create a layer with a different graphic at different key-
frames.

3. Use shape tweening to morph one shape into another.
4. Try adding shape hints to control the morphing.
5. Animate them so they appear to collide.
6. Use fading and color effects on them before and after the

collision.
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