
WHAT’S NEW IN

DIRECTOR 8

c h a p t e r  1

Ialways have mixed emotions anytime a company releases a new version of its soft-
ware. On one hand, it involves taking the time to learn the new features and try to

adjust to a new way of working with the program. On the other hand, there are usually
a number of cool features to add into your repertoire. When I opened Director 8 and
installed it on my system, I was excited. At first glance, the interface didn’t look that
much different. Then, the more I looked around, the more I noticed the new features
that will truly make working in Director a breeze. This chapter will highlight many of
the new features added into Director 8. I will go into much greater detail with many of
them by showing how they are used throughout the course of this book. 

PROPERTY INSPECTOR: 
A NEW WINDOW

The first addition to Director 8 that you should notice is a new window that appears on
your screen when you launch Director 8 for the first time. This new (and very useful)
window is called the Property Inspector (Figure 1–1). Without a doubt, this window
will change the way you work. It doesn’t perform any magic tricks and it won’t revo-
lutionize the multimedia industry, but instead, it just makes performing all of your daily
authoring tasks simpler. 
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The Property Inspector window provides an easy-to-use, straightforward tool that
contains all of the most often used features and functions right in one window. Select
one of the tabs to access different attributes of the object you have selected. The
Property Inspector adjusts its available categories depending upon what you have
selected. Notice how the options change if you select a cast member or a sprite
(Figure 1–2).

If you select multiple items, the Property Inspector only displays the
information that is common to all the selected items.

Basically, you will rely on the Property Inspector as command central. This is where
you will control most of the attributes for your sprites and cast members. They are all
neatly bundled into one area so you can quickly and easily access these options and
make changes without having to search all over the place. It gives you one convenient
location to adjust: 
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Figure 1–1 The Property Inspector window.  You can view it in graphic
view (left) or list view (right).
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� Starting frames and ending frames.

� Inks.

� Position.

� Size.

� Rotation and skew.

� Behaviors.

This window will be helpful throughout the course of your programming. Just in
the time spent jumping around from window to window to menu to whatever, you’ll
see how beneficial it is to have all of the most common attribute controls right in one
location.
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Figure 1–2 The Property Inspector offers different attributes depending
upon what has been selected (sprite vs. cast member).
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SEEING IS BELIEVING: 
A ZOOMABLE STAGE

How many times have you caught yourself squinting at the monitor to see if you’ve
placed an object in the right area or have too many windows open at once that you’re con-
stantly opening, closing, and reshuffling around just to see the stage? Well, no more. Now
Director 8 offers a zoomable stage. For you Photoshop users, Macromedia has utilized
the same commands. Hold the Control key (Windows) or the Command key (Macintosh)
and press the plus key (+) to zoom into the stage, magnifying the area you are currently
viewing. Hold the Control key (Windows) or the Command key (Macintosh) and press
the minus key (-) to zoom out (Figure 1–3, also found in the color section).

If you’re not a keyboard person and want to use your mouse to alter the view of
your stage:

1. Select Zoom from the View menu.

2. Select Zoom Stage In or Zoom Stage Out on the popup menu or select from one
of the predefined percentage settings.
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Figure 1–3 Director now allows you to increase or decrease your view of the stage.
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By decreasing the viewable stage size, you can now see and work in the off-stage
canvas area. This helps when trying to adjust the exact placement of sprites that enter
the viewable area from off-screen. Changing your view by zooming in and out does not
change the placement of any sprites you have added to the stage. It simply works as a
magnifying tool, allowing you to look at your stage real close up from a further dis-
tance without altering the true physical stage size of your movie. 

One of the great things about Director is that there are many different ways to accom-
plish the same task. You don’t need to remember them all, just the ones you use most fre-
quently. The bottom left of the Stage window contains a popup box that allows you to
quickly adjust the viewing size of your stage (Figure 1–4, also found in the color section). 

If you can afford it, I highly recommend working with two monitors
on your computer system. It involves having an additional video card
installed into your system and a second monitor. This will eliminate
the majority of hassles in trying to shuffle windows. Keep tools and
palettes on one side and the stage open on the other. 
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Figure 1–4 Use the Zoom Menu pulldown box to select one of the
present viewable stage areas.
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A NEW LOOK 
FOR THE CAST WINDOW

One thing that I find very helpful in any program is the ability to customize what I see
and how I am able to work. Director has added the ability to change the way you view
your cast. Traditionally, Director displayed cast members as a single image frame or
thumbnail view (Figure 1–5). Now you can click the Cast View Style button at the top
left corner of the Cast window. This button acts as a toggle between standard thumb-
nail view and the new list view (Figure 1–6).

There are several added benefits when working in list view. For one thing, you can
see more information about each cast member right away. These rows and columns of
information are referred to as Asset Management fields. The default settings include
useful information such as:

� An icon to identify each type of cast member.

� The name of the cast member.

� The number assigned to that individual cast member.
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Figure 1–5 The cast was traditionally displayed in thumbnail view.
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� An asterisk indicating that the cast member has changed since the last time it
was saved.

� Script information on whether the cast member is (or contains) a script or behavior.

� The type of cast member.

� The latest date and time the cast member was modified.

� A comments field (type in any useful information).

� The file size of the cast member*.

� The creation date of the cast member (when it was initially created or imported
into Director)*.

� Who modified the cast member*.

� The full pathname for linked files*.

The asterisk (*) indicates the four optional informational fields that
you can add to the list view. 
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Figure 1–6 The Cast View Style button allows you to view cast members as a list display.
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The order of the columns that the Asset Management fields are displayed in can be
easily customized to your liking. If comments are the most vital piece of information,
simply click and drag that heading where you would like it to appear. Rearrange the
columns in any order to help speed up and improve your workflow within your next
project. You can even turn any of these column settings on or off when viewing your
cast members in the list display mode. To customize which columns are displayed in
list mode:

1. Select Preferences from the File menu.

2. Select Cast from the popup menu. 

3. Place a check mark before any of the options in the List Column section of the
Cast Window Preferences window (Figure 1–7).

4. Click OK.

Click and drag the edge of any column heading to resize the display
area. Director may automatically truncate the width of the column,
hiding valuable information.

Lists of information become more useful if you can sort them and adjust the order
in which they appear. For instance, you may want to view the cast members in order
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Figure 1–7 The Cast Window Preferences window allows you to customize
the information columns in the cast member list display mode.
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from the ones most recently modified to quickly fix a problem. Whatever the case, you
can sort on each and every column in the cast when in list display mode. Simply click
on a column heading to sort the information by that column. Click on it again to reverse
the order of how the information is displayed.

LINKED SCRIPTS
There may be situations where you feel it is better to edit your Lingo scripts in an appli-
cation outside of Director. Now you can link to external text files. Working with exter-
nally linked text file scripts is very similar to importing linked images and digital video
files. The advantages to using externally linked text scripts include:

� Multiple people can work on one project at the same time (for instance, one works
on the images, while another writes the scripts).

� A library of useful scripts is written once and used in any project.

To link to external script files:

1. Select Import from the File menu.

2. Select Script under the Files of type pull-down menu (Figure 1–8).

3. Click on the text file you want to be linked. Add as many files as desired.

4. Select Link to External File from the Media pull-down menu.

5. Click Import.

Director recognizes .TXT and .LS file extensions. (The .LS file 
extension is Director’s own link script extension.)

Once an external text file has been imported as Linked to External File, you can then
make basic adjustments to the script right inside of Director’s Script window. Once you
save your Director movie, the changes you made are updated into your external text
file. Director will not allow you to make changes to a script if the externally linked file
is locked. You can just as easily create a script inside of Director and then save a copy
of it externally for other uses. To change an internal script into an externally linked file:

1. Select the internal script cast member.

2. Select the Script tab in the Property Inspector (Figure 1–9).

3. Click the Link Script As button.

4. Type in a name and select a destination where you want to save the script file.

5. Click Save.
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If you make changes externally to a linked script, you will need to unload that
member in your Director movie and then reload it with the most recently updated ver-
sion. You will need to update the movie using your Message window (see Chapter 4,
“Lingo Basics: An Introduction,” for more details on the Message window). Use the
following Lingo script to unload then reload a script with updated changes (substitute
“NameOfScript” with the name of your script):

unloadMember member “NameOfScript”

BITMAPPED COMPRESSION
Director now offers you the ability to use JPEG compression on bitmap cast members in
a .DCR file. You can either apply compression to individual bitmaps or all bitmaps con-
tained in your movie. This is a great feature, especially for those of you who distribute
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Figure 1–8 Use the pull-down menu to select Script as the type of
file you want to import.
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your movies over the Internet. Compression allows you to optimize your bitmapped
images to maintain as much of the quality as possible while dramatically reducing the size
of the file. This, in turn, provides shorter download times for your movies.

Applying bitmap compression at the individual cast member level
will take precedence over compression applied at the movie level.

I highly recommend compressing individual cast members even if you are not
publishing your movie for the Web. Any application that you develop will always
run smoother when trying to open and play smaller file sizes. Today, my company
is getting more requests to develop sales and promotional applications on Cyber
Card, a business card-shaped CD-ROM that can hold up to 40MB of information
(Figure 1–10, also found in the color section). These work great for promotional
pieces and presentations. Forty megabytes is not a lot of room to put graphics, ani-
mation, text, audio narration, music, and sound effects, so anything you can do to
reduce file size is helpful. But be careful not to over-compress your images. You
don’t want to jeopardize image quality (Figure 1–11, also found in the color section). 
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Figure 1–9 Use the Property Inspector to reallocate an internal script to an externally linked file.
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To apply JPEG compression to individual cast members:

1. Select the bitmapped image of your cast or sprite in your score.

2. Click on the Bitmap tab in the Property Inspector. 

3. Click on the triangle to display the Compression window (if not already open).

4. Select JPEG from the Compression pull-down menu (Figure 1–12).

5. Adjust the Quality slider as desired. The lower the value you select, the more
compression you are applying. The higher the value, the less compression. A
value of 100 means no compression.

To apply JPEG compression to an entire movie:

1. Select Publish Settings from the File menu. The Publish Settings window will
appear (Figure 1–13).

2. Select the Compression tab on the top of the Publish Settings window.

3. Select JPEG for the Image Compression setting.

4. Adjust the Quality slider as desired. The lower the value you select, the more
compression you are applying. The higher the value, the less compression. A
value of 100 means no compression.

5. Click OK.
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Figure 1–10 Business card-shaped CD-ROM that 
contains up to 40MB per disc.
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Figure 1–11 a & b Notice the difference between quality settings. Images quickly
degrade with the more compression you apply. 

(a)

(b)
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Figure 1–13 The Publish Settings window.

Figure 1–12 Use JPEG compression settings to
optimize the file size of any bitmapped sprite.
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You will not notice the results of your compression adjustments in real time. Therefore,
you must publish your file to see the results. To view your results:

1. Set the compression (and other) settings in the Publish Settings window.

2. Save your movie.

3. Select Publish from the File menu. The Compacting File progress bar will appear
(Figure 1–14). Your movie will automatically open as a Shockwave file in your
default browser (Figure 1–15, also found in the color section).

Keep in mind that you must always save your work before Director
will allow you to publish your movie. Therefore, I recommend saving
a backup copy before applying compression just in case you 
accidentally save your project with images that get ruined by 
applying too much compression. 
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Figure 1–14 The Compacting files progress bar.

Figure 1–15 Publishing your movie defaults to opening in a browser
to display your new Shockwave movie.
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SAVE AS SHOCKWAVE 
HAS A NEW NAME

That’s right. Macromedia has changed the name Save As Shockwave to Publish. This
feature still saves your movies for the Web by converting them into Shockwave
movies, but now it gives you even more control. Saving your movie, or now publish-
ing your movie as a Shockwave movie, still produces a .DCR file (Figure 1–16).
Shockwave movies play back in any Shockwave-enabled Web browser. If you do not
have an updated version of the Shockwave plug-in, you can download it from
www.macromedia.com. 

Saving your movie as a Shockwave file creates a closed version and protects
your movie from being altered, even by people who own Director.

The Publish command’s default settings allow you to quickly and easily create
Shockwave movies ready for distribution over the Internet. To publish your movie as
a Shockwave file:

1. Open the Director movie you want to shock.

2. Select Publish from the File menu.
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Figure 1–16 Director identifies each type of movie and file with unique icons and file extensions.
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Director begins to compact the file. As part of the default settings, Director auto-
matically converts your movie into a Shockwave file (.DCR) without changing the
original Director file (.DIR). You should also notice that an HTML file is created in the
same directory as your Shockwave movie. It has the same filename with the appropri-
ate file extension applied to it. This is the file that holds the “setup” characteristics of
your Shockwave movie. 

For more information on creating movies for distribution on the
Internet, check out Chapter 11, “Shock It for the Web.”

SCALABLE SHOCKWAVE MOVIES
Because more and more people are developing content to be distributed on the Web and
every end-user has a slightly different setup (monitor size, preferred browser, etc.),
Macromedia knew they had to introduce a way to make Shockwave movies look their
best no matter what the circumstances were on the end-user’s side. Director now contains
setting options that will let Shockwave movies stretch to fit in the browser window. You
can even set it to maintain the movie’s original aspect ratio, to keep your movie looking
its best during playback. Chapter 11, “Shock It for the Web,” has a complete description
of how to set your Shockwave movies for optimal playback in a browser.

KEEP SPRITES 
UNDER LOCK AND KEY

This feature is great for everyone—those new to Director and even some of the veter-
ans. Director now offers the ability to lock sprites, preventing unwanted changes or
deletions of sprites during your authoring session. I’ve heard many stories, especially
on larger projects, where someone thought that a certain sprite was for something else,
and you guessed it … it wasn’t. If you catch it in time, you can simply undo your last
step. But what happens if it altered your movie enough that you had to go back and
rebuild half of it?

Locking sprites is especially good when you have multiple programmers working on
a single project. The last thing you need is someone else unintentionally changing what
you worked so hard to build. You can lock as many sprites as you feel necessary. If you
select a group of sprites during an authoring session, some locked and some unlocked,
Director will prompt you that alterations will only be made to the unlocked sprites. 

Locking sprites is not supported during playback.
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Select the sprite or sprites that you want to lock either in the stage or in the score.
Once selected, there are several different ways to lock a sprite or group of sprites:

� Select Lock Sprite from the Modify menu.

� Right mouse click (Windows) or Option-click (Macintosh) on a sprite and select
Lock Sprite from the popup menu (Figure 1–17).

� Click on the padlock icon under the Sprite tab of the Property Inspector. Notice 
how all of the setting controls become grayed out once the sprite is locked 
(Figure 1–18).

In authoring mode, you cannot simply select a sprite on the stage once it has become
locked. This prevents you from accidentally shifting its position or deleting it alto-
gether. To select a locked sprite directly from the stage, you must first hold down the
L key to activate it. Notice the bounding box does not have any corner or side markers
that normally allow you to adjust, resize, or reposition a sprite on the stage. In addition,
Director puts a padlock icon in front of the name of the locked sprite in the score
(Figure 1–19). Locked sprites in the score are also represented with a lighter shading
for easier distinction. 

To unlock a sprite, simply apply one of the reverse techniques used to lock it:

� Select Unlock Sprite from the Modify menu.

� Right mouse click (Windows) or Option-click (Macintosh) on a sprite and select
Unlock Sprite from the popup menu. 
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Figure 1–17 Select Lock Sprite from the Sprite popup menu.

01Chominsky.2  1/17/01  5:31 PM  Page 18



� Click on the padlock icon under the Sprite tab of the Property Inspector. All of the
feature settings should become active again.

CHAPTER 1 • WHAT’S NEW IN DIRECTOR 8 19

Figure 1–18 You cannot alter a sprite once it has been locked. You must
first unlock the sprite to change any settings.

Figure 1–19 A padlock icon appears
on the sprite to indicate that it has
been locked.
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POSITION WITH GUIDES
In addition to the normal grid that you have become accustomed to using for lining up
your sprites on the stage, Director now includes a much better way to work with sprites
when trying to position them in just the right place. Guides allow a much more accu-
rate way of positioning your sprites anywhere on the stage without cluttering up the
entire screen the way the grid does (Figure 1–20, also found in the color section). 

For those of you who have worked in programs such as Photoshop, Illustrator, and
Quark, you know how valuable tool guidelines can be for positioning your images
accurately every time. Add Director to the list because you can now add any number
of horizontal and vertical guidelines as necessary. You even have controls to hide
guides, lock them in position, custom-select their color for easier visibility, and even
snap your sprites to a guideline for exact positioning.

Setting up and using guides is very simple. You need to activate the guides before
you can start adding them to your stage:

1. Open the Property Inspector (if not already open).

2. Click on the stage or score to select it.

3. Select the Guides and Grid tab at the top of the Property Inspector (Figure 1–21).

4. Activate guides by either selecting the Visible checkbox in the Guides portion of
the Property Inspector.

OR

Select Guides and Grid from the View menu. Then select Show Guides from the
popup menu.

OR

Use the keyboard shortcut Control-Shift-Alt-D (Windows) or Command-Shift-
Option-D (Macintosh) to toggle guides off and on.

Once you have turned guides on, you can begin to add them to your stage and cus-
tomize their functionality. To add guides to your stage:

1. Click and hold your mouse on either the New Horizontal Guide box or New
Vertical Guide box in the Property Inspector (Figure 1–22).

2. While continuing to hold the mouse button down, drag your cursor onto the
stage and release wherever you want to add a new guideline.

3. If you need to adjust the position of a guideline, roll your cursor slowly over the
line. Your cursor should change to show two little lines with arrows pointing in
either direction. Now you can click and drag the line to a new position.

4. To remove a single guide, click and drag it off the stage’s viewable area. 
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Figure 1–20 A comparison between working with Guides vs. the Grid.
Notice the clean and accurate results with Guides.
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If your cursor does not change as you roll over the Guides, make
sure that you do not have Lock All Guides marked in the Property
Inspector. This will prevent you from repositioning any of the
guidelines.

Other aspects you might find beneficial when working with guides: 

� Change the color of the guides for easier visibility using the guide’s color swatch
in the Property Inspector. Depending upon the color scheme of your sprites, you
can change the color of the guides at anytime throughout the authoring process.
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Figure 1–21 Use the Guides and Grid section of the
Property Inspector to add and customize guidelines
and grid patterns.

Figure 1–22 Click the New Horizontal Guide or New
Vertical Guide buttons and drag onto the stage to add
new positioning guidelines. 
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� Click the Remove All button to clear all of the guides. Once you remove them,
they are gone forever.

� Click the Visible checkbox to hide and then redisplay guides. This is extremely
helpful if you want to view the stage without the guides, but don’t want to remove
them completely.

� Click the Lock Guides checkbox to hold all guides in their current position. Once
this box is checked, you will not be able to reposition any of the guidelines. You
can also lock the guides by selecting Guides and Grids from the View menu, then
selecting Lock Guides from the popup menu.

� Turn on Snap To Guides. This will force the corner edges of your sprite’s bound-
ing box to “snap” up against the guides for easy and accurate placement of your
sprites. You can turn on Snap To Guides by selecting Guides and Grids from the
View menu, then selecting Snap To Guides from the popup menu, or by using the
keyboard shortcut Shift-Control-G (Windows) or Shift-Command-G (Macintosh)
to toggle this feature on and off.

MULTIPLE CURVE VECTORS
You probably know the benefits of working with vector graphics—reduced file size,
scalability, and custom shapes. Now, Director allows you to control multiple vertices
at the same time. This is helpful because it gives you complete control of customizing
and tweaking shapes and curves any way you want (Figure 1–23). The handles that
appear allow you to manipulate the degree of curvature applied to the image between
two vertices. These curves are known as Bézier curves. You can simply adjust the
curves by grabbing one of the handles and dragging it around until you get the desired
look of the curve. Check out the chapter, “Creating Killer Visual Effects,” to learn more
about working with vector graphics. 

ENHANCED LINGO PERFORMANCE
The power of Director keeps growing with every version Macromedia releases. That’s
also true in Director 8. Lingo, Director’s internal programming language, allows you
to build and control just about anything you can imagine. Programming in Director is
becoming easier than ever. The use of parent scripts utilizes the advantages of object-
oriented programming, allowing you to save time and better understand what is taking
place without skimping on functionality.

Director has improved the relationship between parent scripts and child objects, mak-
ing it easier to organize the basic programming functionality behind your movie. Child
objects are generally used when you need the same type of logic or functionality to
occur several times concurrently, each with slightly different parameters. Director refers
to these individual object instances as “children” since they are all slight variations of
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the same “Parent” script. Check out Chapter 9, “Advancing Techniques with Behaviors
and Lingo,” for more detailed information on enhanced Lingo functionality.

CONTROL BITMAPS WITH LINGO
Lingo also allows you to control bitmapped images. There are two basic ways that
Lingo affects bitmaps inside of Director:

� You can perform simple controls that affect an entire cast (i.e., changing fore-
ground color, background color, or switching cast members around).

� You can perform more complex adjustments and detailed manipulations, allowing
for more flexibility and control of your bitmapped images.

SUMMARY
As you can see, Macromedia has added a number of new features and controls to
really improve the speed at which you work and the quality of your final movie. Take
your time and go through as many of the new features and functions of Director 8
that you can. Whether you are new to Director or have used it for years, I think you
will appreciate how easy it is to get started building interactive applications. 
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Figure 1–23 Apply Bézier curves to multiple vertices at the same time.
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