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LESSON 1

Lesson 1 uses a sample project to provide an overview 
of the typical After Effects workflow, from creating a 
project to importing footage, creating a composition, 
applying effects, and outputting content. Along the 
way, students are introduced to the various elements of 
the After Effects workspace, which they’ll need to un-
derstand as they proceed with the lessons in this book.

About the Adobe workspace
After Effects 7.0 offers a redesigned, unified user 
interface. Adobe video and audio applications provide 
a consistent, customizable workspace.  Although each 
application has its own set of panels (such as Tools, 
Properties, Timeline, and so on), you move and group 
panels on your computer screen in the same way across 
products.

The main window of a program is the application win-
dow. The various panels are organized in this window 
in an arrangement called a workspace. The default 
workspace contains groups of panels as well as panels 
that stand alone.

You customize a workspace by arranging the panels, 
usually by dragging them, in the layout that best suits 
your style of working. You can create and save several 
custom workspaces for different tasks—for example, 
one for editing and one for previewing.

You can drag panels to new locations, move panels into 
or out of a group, place panels alongside each other, 
and undock a panel so that it floats in a new window 
above the application window. As you rearrange panels, 
the other panels resize automatically to fit the window.

You can use floating windows to create a workspace 
more like those in previous versions of Adobe applica-
tions, or to place panels on multiple monitors.

Using a scroll-wheel mouse
If your mouse has a wheel for scrolling, you can zoom 
in the Timeline, Project, Render Queue, Composition, 
Layer, Footage, Flowchart, Effect Controls, and Effects 
& Presets panels, and scroll in the Timeline, Project, 

Render Queue, Flowchart, Effect Controls, and Effects 
& Presets panels.

Do any of the following:

• To zoom into the center of the panel, or into the feature 
region when tracking, roll the mouse wheel forward.

• To zoom out of the center of the panel, or out of the fea-
ture region when tracking, roll the mouse wheel backward.

• To zoom into the area under the pointer, hold down Alt 
(Windows) or Option (Mac OS) as you roll the mouse 
wheel forward.

• To zoom out of the area under the pointer, hold down 
Alt (Windows) or Option (Mac OS) as you roll the mouse 
wheel backward.

• To scroll vertically, roll the mouse wheel forward or back-
ward.

• To scroll horizontally, hold down Shift as you roll the 
mouse wheel backward or forward. When you are in the 
Timeline panel, rolling backward moves you forward in 
time and vice versa.

Note: You can scroll in a panel even if it is not 
currently active as long as you move the pointer 
over it. For instance, you can scroll in the Com-
position panel even if the Effect Controls panel 
is currently active.

Lesson 1: Getting to Know the Workflow
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Lesson 2: Creating a Basic Animation Using 
Effects and Presets

LESSON 2

After Effects 7.0 lets you produce great-looking anima-
tions quickly using hundreds of fully customizable 
animation presets, including presets for animating text, 
effects, transitions, backgrounds, and behaviors. You 
can also use included project templates for DVD mo-
tion menus and motion graphics backgrounds. Lesson 
2 explores how to create a composition using some of 
these new presets. At the end of the lesson, students 
export their animation in Flash format for use on the 
web. These notes provide additional background about 
animation presets and Flash export.

About animation presets
Animation presets let you save and reuse specific 
configurations of properties and animations, includ-
ing keyframes, effects, and expressions. After Effects 
includes hundreds of animation presets that you can 
drop into your projects and then modify to suit your 
needs. 

You can apply an entire animation preset to a layer, 
or you can apply a single effect or property from an 
animation preset. If a property or effect exists in the 
animation preset but not in the target layer, the prop-
erty or effect is added to the target layer.

See Gallery of animation presets for animated illustra-
tions of animation presets included with After Effects.

Many animation presets don’t contain animation; 
rather, they contain combinations of effects, trans-
form properties, and so on. You can save one or more 
properties with all of the desired settings to an anima-
tion preset without including keyframes. A particularly 
convenient category of animation presets is behaviors, 
which you can use to quickly and easily animate with-
out keyframes.

Animation presets can be saved as FFX files and 
transferred from one computer to another. By 
default, animation presets are stored in the Presets 
directory. 

For additional information, go to Adobe Studio on 
the Adobe website.

Saving animation presets
You can save settings of one or more effects as an ani-
mation preset. Saving an effect as an animation preset 
also saves any set keyframes, as well as expressions used 
in the effect. For example, if you created an explo-
sion using several effects with complex parameter and 
animation settings within those effects, you can save 
all those settings as a single animation preset. You can 
then apply that animation preset to any other footage, 
or you can apply any single effect from that animation 
preset to any footage. The 20 most recently saved or 
applied animation presets appear under Recent Anima-
tion Presets in the Animation menu.

Animation presets also appear in the Animation Presets 
menu in Effect Controls and in Effects & Presets. The 
Animation Presets menu in the Effect Controls panel 
lists only those animation presets that contain the cur-
rent effect. For example, if the Mirror effect is selected, 
the menu will show only those presets that include 
the Mirror effect. If the Animation Presets category 
in Effects & Presets does not appear, choose the Show 
Animation Presets option from the Effects & Presets 
panel menu.

Note: When you apply an effect from the Ani-
mation Presets pop-up menu, only the current 
effect from the animation preset is applied.

Exporting Flash animations
Flash (SWF) and Flash Video (FLV) formats offer 
popular standards for producing interactive web con-
tent—and now you can output both formats directly 
from After Effects 7.0.

The following tutorial explores the two formats to help 
students understand which to use for a given circum-
stance. It then details how to export these file types 
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from After Effects. You can use it to enhance the Lesson 
2 Flash animation export exercise.

Note: Though you can generate SWF and FLV 
files from After Effects, incorporating these 
files into web content and adding interactivity 
is typically done through a Flash authoring ap-
plication.

The files used in this tutorial are on Disc 2 of the Total 
Training Video Workshop (included with After Effects). 
Depending on the television standard for your region, 
copy either the NTSC or PAL folder from the After Ef-
fects 7.0 folder to your desktop. Alternatively, you can 
follow along using your own files. You’ll need a file with 
a vector logo (such as an Adobe Illustrator file).

SWF vs. FLV
SWF files deliver vector graphics (especially anima-
tions) and other data types, including video, over the 
Internet. SWF files also allow viewer interaction, such 
as following a web link. To view SWF files, you need 
Adobe Flash Player, a plug-in for your web browser.

FLV files contain only video. They may or may not be 
part of a larger SWF file, and they don’t allow inter-
activity themselves. To view FLV files, you need Flash 
Player 7.0 or later; these files can also be viewed by 
embedding Flash Video Player code directly into a 
web page. Several third-party standalone players for 
FLV files are also available. (At the time of this writing, 
Windows Media Player and QuickTime Player don’t 
support FLV files.)

Create a comp
You’ll start by creating a comp, which you’ll then turn 
into a common example of SWF content: a logo ani-
mation that links to a company’s home page, used as a 
web advertisement.

1. Create a new After Effects project by choosing File > New 
> New Project, and then import MC_logo.ai from the folder 
you copied to your desktop.

2. Choose Composition > New Composition. Name the 
composition Linked_Logo, and from the Preset menu, 
choose Web Banner 468 x 60. Enter a duration of 500 (to 
make the composition 5 seconds), and then click OK.

3. Press the Home key to ensure that the current-time 
indicator is at the start of the composition, and then drag 
MC_logo.ai from the Project panel to the Timeline panel.

4. Because the logo is too large for the banner, you’ll scale it 
to fit. With MC_logo.ai selected in the Timeline panel, press 
S to reveal its Scale property. Enter a scale value of 25%.

5. Now change the color of the logo so you’ll be better able 
to view the alpha channel later on. Choose Effect > Color 
Correction > Change To Color. In the Effect Controls 
panel, click the color swatch for To and then enter values of 
R=239, G=9, B=9 to create a bright red. Click OK, and then 
select Hue, Lightness & Saturation from the Change menu.

6. Select the Linked_Logo comp in the Project panel and 
choose Composition > Background Color. Click the color 
swatch and then enter values of R=0, G=88, B=238 to create 
a bright blue. Click OK twice to apply the new color.

Animate the logo

1. With MC_logo.ai selected in the Timeline panel, choose 
Animation > Browse Presets. After Adobe Bridge opens, 
choose Presets from the navigation menu at the top of the 
window, and then open the Behaviors folder. Select the first 
behavior, Autoscroll - horizontal.ffx. The preview panel dis-
plays a thumbnail of the behavior. Double-click Autoscroll 
- horizontal.ffx to apply it to the layer in After Effects, and 
then close Bridge.

2. Press the spacebar to preview the animation—logos 
marching across the screen. The march is a bit frantic; 
you’ll edit the effect to slow it down. In the Effect Controls 
panel, locate the Autoscroll - horizontal effect, and set 
Speed (pixels/second) to 25.

3. Save the project, naming it Flash_Export.aep.

4. In the Timeline panel, move the current-time indicator to 
4:00 (four seconds). Make sure that MC_logo.ai is selected, 
and then choose Layer > Add Marker. A layer-time marker 
is added at the four-second mark.

5. Double-click the marker to display the Marker dialog 
box. Type Company link in the Comment text box, type 
http://www.adobe.com in the URL text box, and then type 
_blank in the Frame Target to specify a new browser win-
dow. Click OK.

Note: With the marker in place, the link is in-
voked automatically at the four-second mark. 
If you prefer that the user initiate the link, you 
could simply add a link to the SWF file after plac-
ing it on a web page (as opposed to embedding 
the link within the SWF file as you just did.)

LESSON 2
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Export the comp to SWF
Now that the animation is complete, you can export 
the comp to SWF. After Effects creates the SWF file, and 
then places it in an HTML file for convenient viewing.

1. Choose File > Export > Macromedia Flash (SWF). 
Choose a location for the file, name it Logo_Ad.swf, and 
then click Save.

Note: Be sure to include the .swf extension so 
that the HTML file After Effect generates can 
locate the SWF file.

2. In the SWF Settings dialog box, choose Rasterize from 
the Unsupported Features menu, and then select Include 
Layer Marker Web Links.

Note: The SWF format doesn’t support several 
effects; choose to rasterize the unsupported 
features to make sure that all effects are in-
cluded in the SWF file. See After Effects Help for 
more information on SWF settings.

3. Click OK. After Effects exports an HTML file and a SWF 
file.

4. Start your web browser and open the HTML file to view 
the animation. If your browser is set up correctly, when the 
animation reaches the four-second mark, the Adobe home 
page opens in a new browser window.

Export the comp for FLV
FLV output can drastically improve the workflow ef-
ficiency for developing animated Flash content in After 
Effects. You can import FLV files from After Effects di-
rectly into your Flash authoring software without hav-
ing to recompress (encode) the video data. FLV even 
supports alpha channels, helping to combine multiple 
files over a consistent background.

Now you’ll export the comp you just created, includ-
ing an alpha channel, in Flash Video (FLV) format. But 
first, you’ll view the alpha channel.

1. Choose Alpha from the Show Channel menu at the bot-
tom of the Composition panel.

2. When you’re finished viewing the alpha channel, choose 
RGB from the Show Channel menu, and then choose File > 
Export > Flash Video (FLV).

Note: QuickTime 6.5.2 or later is required to 
export FLV files from After Effects.

3. In the Flash Video Encoding Settings dialog box, choose 
Flash 8 - Medium Quality (400 kbps) from the Please Select 
A Flash Video Encoding Profile menu. Then click Show 
Advanced Settings.

4. In the Encode Video section, select Encode Alpha Chan-
nel. Then deselect Encode Audio, since the animation 
doesn’t include any audio. You can leave the other settings 
at their defaults. Click OK.

Note: Two codecs are available for FLV export. 
You must use the On2 VP6 codec to include an 
alpha channel.

5. Specify a location for the FLV file, name it Logo_ad, and 
then click Save. After Effects exports the FLV file.

6. To view the FLV file, do either of the following:

• Add the file to a web page, and then open the web page in a 
browser with Flash Player installed.

• Open the file in a third-party standalone player. A quick 
search on the Internet should locate several standalone 
players available for download.

LESSON 2
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LESSON 3

Lesson 3 explores the many text options and text-
animation features in After Effects 7.0. The following 
material provides additional background on formatting 
and animating text in After Effects.

About text layers
With After Effects, you can add text to layers with 
flexibility and precision. You can create and edit text di-
rectly on-screen in the Composition panel and quickly 
change the font, style, size, and color of the text. You 
can apply changes to individual characters and set for-
matting options for entire paragraphs, including align-
ment, justification, and word wrapping. In addition to 
all of these style features, After Effects provides tools 
for easily animating specific characters and features 
such as text opacity and hue.

About fonts
A font is a complete set of characters—letters, num-
bers, and symbols—that share a common weight, 
width, and style. In addition to the fonts installed on 
your system, After Effects uses font files in this local 
folder:

Windows Program Files\Common Files\Adobe\Fonts

Mac OS X Library/Application Support/Adobe/Fonts 

If you install a Type 1, TrueType, OpenType, or CID 
font into the local Fonts folder, the font appears in 
Adobe applications only.

To use smart quotes
Smart quotes, or printer’s quotation marks, use a 
curved left or right quotation mark instead of straight 
quotation marks. To apply smart quotes, choose Use 
Smart Quotes from the Character panel menu.

To edit text in text layers
You can edit text in text layers at any time. If you set the 
text to follow a path, designate it as a 3D layer, trans-
form it, or animate it, you can still continue to edit it. 

The pointer for a type tool changes as you move it 
around the Composition panel. When it is directly over 
a text layer, it appears as the edit text pointer; click to 
edit the existing text. When the pointer is not directly 
over a text layer, it appears as a new text pointer; click 
to create a new text layer. Shift-click always creates a 
new layer. 

1. Select the Horizontal Type tool  or the Vertical Type tool.

2. In the Timeline panel, double-click the text layer to set 
the type tool to editing mode and select the text.

3. Edit text

To blend overlapping characters in a text 
layer

1. In the Timeline panel, expand the text layer and the More 
Options group.

2. Choose a blending mode from the Inter-Character Blend-
ing menu. 

Note: To blend a text layer with the layers 
beneath it, specify a blending mode from the 
Modes column in the Timeline panel.

To change the direction of text
The Vertical Type and Horizontal Type tools let you en-
ter text that flows horizontally or vertically. Horizontal 
text flows from left to right; multiple lines of horizontal 
text lie from top to bottom. Vertical text flows from top 
to bottom; multiple lines of text lie from right to left. 

When you convert the vertical or horizontal orienta-
tion of a text layer, the results from paragraph text 
(justifiable text that wraps within a bounding box) are 
very different from the results of point text (indepen-
dent lines of text) because paragraph text flows relative 
to its bounding box while point text lies relative to the 
Composition panel. For example, when you convert 
paragraph text from horizontal to vertical or vice versa, 
the text’s bounding box doesn’t change its orientation, 
but the flow of text inside the box does.

Lesson 3: Animating Text
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About text animation presets
You can browse and apply text animation presets as you 
would any other animation presets.

The text animation presets were created in an NTSC 
DV 720 x 480 composition, and each text layer uses 72-
point Myriad Pro. Some preset animations move the 
text on, off, or through the composition. The anima-
tion preset position values may not be appropriate for 
a composition that is much larger or smaller than 720 
x 480; for example, an animation that is supposed to 
start off-screen may start on-screen. You may need to 
adjust the text animator’s position values.

If the text isn’t positioned as expected or the text disap-
pears unexpectedly, adjust the text animator’s position 
values in the Timeline or Composition panel.

The Paths category of text animation presets auto-
matically replaces source text with the preset’s name, 
changes the font color to white, and may change other 
character properties.

The Fill And Stroke category of animation presets con-
tains presets that may change the fill color and stroke 
properties of the preset that you apply. If the anima-
tion preset requires a stroke or fill color, the animation 
works only if you have assigned one to your text.

To animate text with text animator groups
Once you create and format your text layers, use text 
animator groups to quickly and easily create elaborate 
animations. A text animator group includes one or 
more selectors and one or more animator properties. A 
selector is like a mask—it specifies which characters or 
section of a text layer you want an animator property 
to affect. Using a selector, you can define a percentage 
of the text, specific characters in the text, or a specified 
range of text. 

Using a combination of animator properties and 
selectors, you can create complex text animations that 
would otherwise require painstaking keyframing. Most 
text animations require you to animate only the selec-
tor values—not the property values. Consequently, 
text animators use a small number of keyframes even 
for complex animations. For example, to animate the 
opacity gradually from the first character to the last, set 
the Opacity value (in the Animator group) to 0, and 

then set the End (Range Selector property) to 0% at 0 
seconds and 100% at the end of the animation.

Text animator groups animate a character’s position, 
shape, and size-related properties relative to each char-
acter’s own anchor point. The text property Anchor 
Point Grouping lets you reposition each character’s 
anchor point relative to its word, line, or entire text 
block. In addition, you can control the alignment of the 
anchor point relative to the anchor point group and the 
font with the Grouping Alignment property.

About selectors
Each animator group includes a default Range selector. 
You can add additional Range selectors to an animator 
group or add multiple animator properties that use the 
same Range selector. 

In addition to this Range selector, you can add a Wiggly 
selector. Use the Wiggly selector to create selections 
that wiggle—vary within a specified amount—over 
time. You can add one or more Wiggly selectors to an 
animator group, and that animator group can contain 
one or more properties.

When you add multiple selectors to an animator group, 
you can control the way they interact with each other 
by using each selector’s Mode property. You can set 
values for the Start and End properties by changing the 
values in the Timeline panel or by using the selector 
bars in the Composition panel.

About the Expression selector
The Expression selector lets you dynamically specify 
how much you want characters to be affected by an 
animator property through the use of expressions. You 
can add one or more Expression selectors to an anima-
tor group, and that animator group can contain one or 
more properties.

LESSON 3
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LESSON 4

Lesson 4: Animating a Multimedia  
Presentation

Lesson 4 builds a complex animation involving  multi-
ple layers, several types of keyframes, audio, and more. 
It starts from a layered, imported Photoshop file. These 
notes provide additional background and teaching 
material on how After Effects works with Photoshop 
and Illustrator files.

Layered files
You can import Adobe Photoshop, Adobe Illustrator, 
EPS, and many PDF files directly into an After Effects 
project. 

After Effects imports attributes that were applied in 
Photoshop, including position, blending modes, opac-
ity, visibility, transparency (alpha channel), layer masks, 
layer groups (imported as nested compositions), 
adjustment layers, common layer styles (Drop Shadow, 
Inner Shadow, Outer Glow, Inner Glow, Bevel and Em-
boss, and Color Fill), layer clipping paths, vector masks, 
image guides, and clipping groups. 

You can also create a new Photoshop file and add it as 
the top layer in a composition from within After Ef-
fects, or use After Effects to create a new Photoshop file 
without adding it to a specific composition.

When you import an Illustrator file, After Effects makes 
all empty areas transparent by converting them into an 
alpha channel.

After Effects can import Illustrator CMYK files. How-
ever, to maintain accurate color, convert your CMYK 
images to RGB images in Illustrator. 

You can import a multilayered Photoshop or Illustrator 
file in the following ways: 

• As a new composition, with each layer in the Photo-
shop or Illustrator file becoming a separate layer in the 
composition that keeps its original dimensions. This 
option, Composition - Cropped, makes it easier to 
manipulate layers and speeds their rendering time.

• As a new composition, with each layer in the Photo-

shop or Illustrator file becoming a separate layer in the 
composition and changing dimensions to match the 
composition size. This option, Composition, is helpful 
when you need to align layers manually.

• As a single still-footage item imported from any one 
layer in the Photoshop or Illustrator file.

• As a single still-footage item merged as you import 
multiple Photoshop or Illustrator layers.

Preparing layered Photoshop files
Importing layers into After Effects makes it possible to 
prearrange a composition in Photoshop using layers 
and preserve those layers in After Effects so that they 
are ready for animation. Preserving layers is also useful 
if you want to use a single Photoshop file as a source 
for both print and dynamic media.

Before you import a layered Photoshop file, prepare 
it thoroughly to reduce preview and rendering time. 
Avoid problems importing and updating Photoshop 
layers by naming them properly. Before you import 
them into After Effects, do the following:

• Organize and name layers. If you change a layer name 
in a Photoshop file after you have imported it into Af-
ter Effects, After Effects retains the link to the original 
layer. However, if you delete a layer, After Effects is 
unable to find the original layer and lists it as Missing 
in the Project panel.

• Make sure that each layer has a unique name to avoid 
confusion.

• If you want to import a composited version of a lay-
ered Photoshop file along with a layered version, select 
Always Maximize Compatibility For Photoshop (PSD) 
Files in the Photoshop File Handling Preferences dialog 
box.

Preparing Illustrator files
Before you save an Illustrator file for importing into 
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After Effects, consider doing the following:

• To ensure that Illustrator files appear correctly in 
After Effects, select Create PDF Compatible File in the 
Illustrator Options dialog box. 

• To copy paths between Illustrator and After Effects, 
make sure that the AICB and Preserve Paths options 
are selected in the Files & Clipboard section of the 
Illustrator Preferences dialog box. If you don’t select 
AICB in Illustrator, After Effects prompts you when 
you attempt to paste the path.

• To ensure that files rasterize most faithfully in After 
Effects, save your file in AI format instead of Illustrator 
8.x or 9.x EPS format.

Transparency in Photoshop files
Photoshop supports a transparent area and one 
optional layer mask (alpha channel) for each layer in 
a file. You can use these layer masks to specify how dif-
ferent areas within a layer are hidden or revealed. If you 
import one layer, After Effects combines the layer mask 
(if present) with the transparent area and imports the 
layer mask as a straight alpha channel.

If you import a layered Photoshop file as a merged file, 
After Effects merges the transparent areas and layer 
masks of all the layers into one alpha channel that is 
premultiplied with white. 

If the layered Photoshop file contains clipping groups, 
After Effects imports each clipping group as a composi-
tion nested within the main composition. After Effects 
automatically applies its Preserve Underlying Transpar-
ency option to each layer in the clipping-group compo-
sition, maintaining transparency settings. 

When you import a Photoshop file as a composition, 
any vector masks convert to After Effects masks. You 
can then modify and animate these masks within After 
Effects.

After Effects also supports any blending modes applied 
to the file. 

For more details about how After Effects works with 
transparency in Photoshop files, visit the support area 
of the Adobe website.

To use adjustment layers from Photoshop
Adjustment layers in Photoshop change the color 
and tonal qualities of an image without permanently 
modifying the original image. Photoshop adjustment 
layers affect the appearance of all layers below them. 
When you import a Photoshop file containing one or 
more adjustment layers as a composition, After Effects 
directly converts the Photoshop adjustment layers to 
After Effects adjustment layers. 

• To remove the effect and display the layer as a white 
solid, turn off the Adjustment Layer switch in After 
Effects. 

• To remove the effect and the white solid, either delete 
the adjustment layer or turn off the Video switch for 
the layer.

To continuously rasterize an Illustrator file
When you import a vector file, After Effects automati-
cally rasterizes it. However, if you want to scale a vector 
file above 100%, you need to continuously rasterize 
it to maintain image quality. You can continuously 
rasterize an Illustrator file (or any other vector file) at 
any time while designing your project. Continuously 
rasterizing causes After Effects to rasterize the file as 
needed based on the transformation for each frame. A 
continuously rasterized file generally produces higher 
quality results, but it may preview and render slower 
than a rasterized image. 

When you apply an effect to a continuously raster-
ized layer, the results may be different than when you 
apply the effect to a nonrasterized layer. This is because 
the default rendering order for the layer changes. The 
default rendering order for a nonrasterized layer is 
masks, effects, and then geometrics (transformations), 
whereas the default rendering order for a continuously 
rasterized layer is masks, geometrics (transformations), 
and then effects. You can change the default rendering 
order.

For example, if an Illustrator file pictures a dog and 
if you want to animate the scale of the dog and apply 
the Bulge effect to the dog’s nose, turn off continu-
ous rasterization so that the bulge stays on the dog’s 
nose as the picture scales larger and smaller. Make sure 
to check the results of the effect before continuing to 

LESSON 4
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work on your project. 

Whether or not you continuously rasterize, if you view 
and render a composition using Best Quality, After 
Effects anti-aliases (smooths) the art. For general infor-
mation about rasterizing, see Illustrator Help.

Note: You cannot paint interactively on a con-
tinuously rasterized layer. However, you can 
apply a paint effect by copying and pasting or 
using the Favorites menu.

Design an Illustrator CS2 workflow for video 
production
When you import Illustrator CS2 files into video pro-
duction applications, you can save production time by 
setting up Illustrator CS2 files for maximum efficiency:

• Customize the startup file—You can customize the 
default settings for new files by editing the startup file 
that Illustrator CS2 uses for RGB files. In the Plug-ins 
folder within the Adobe Illustrator CS2 applications 
folder, you’ll find two files: Adobe Illustrator CS2 
Startup_CMYK.ai and Adobe Illustrator CS2 Startup_
RGB.ai. These files contain the default settings for new 
Illustrator CS2 CMYK and RGB documents, respec-
tively. For a video production workflow, edit the Adobe 
Illustrator CS2 Startup_RGB.ai file. You can set the de-
fault Artboard Size to match your most frequently used 
After Effects composition size. In addition, you can 
customize the contents of any palette. For example, if 
your shop has a standard set of Illustrator CS2 graphic 
styles or symbols, you can save them into the Adobe 
Illustrator CS2 Startup_RGB.ai file, and they’ll be avail-
able in every Illustrator CS2 document you create. As 
you create documents using the File > New command, 
you can adjust the artboard size, orientation, and docu-
ment color mode in the New Document dialog box.

• Create document templates—A template is a custom-
ized Illustrator CS2 document that creates an untitled 
document when you open it. You can use templates 
to create frequently-used documents that differ from 
your customized startup file. There’s only one differ-
ence between saving a document as a document or as 
a template: To save a document as a template, choose 
Illustrator  CS2 Template from the Format menu in the 
Save As dialog box. Open a template using the same 
methods you use to open a document.

• Draw closed paths for masks—When you draw masks 
in Illustrator CS2 for pasting in After Effects, always 
draw closed paths. You can’t use open Illustrator CS2 
paths as masks.

• Control layer dimensions—If you import an Illus-
trator document into After Effects and the Illustrator 
document dimensions aren’t what you expect, specify 
the layer dimensions in the Illustrator CS2 document. 
By default, an Illustrator CS2 document imports using 
the largest area covered by all objects, not the artboard 
size. To override the default behavior, specify a docu-
ment size by drawing a rectangle in Illustrator CS2, 
and with the rectangle selected, choose Object > Crop 
Area > Make. This command sets the outer bounds of 
the document to the size of the rectangle. Areas outside 
the artboard are still clipped even if you extended the 
rectangle past the artboard.

Edit Illustrator CS2 files from within After Ef-
fects projects
Whenever you have an Illustrator CS2 file in an After 
Effects project, you can open the file in Illustrator CS2 
directly from After Effects. To open an Illustrator CS2 
file, select it in the Project panel and choose Edit > Edit 
Original. When you save the file in Illustrator CS2, the 
file is automatically updated in After Effects.

LESSON 4
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Lesson 5: Animating Layers

LESSON 5

Lesson 5 introduces students to the Layer panel, which 
they use to remap time, and to the Graph Editor, where 
they edit Time Remap keyframes.

About the Graph Editor
To view and manipulate all aspects of effects and ani-
mations, including effect property values, keyframes, 
and interpolation, use the Graph Editor. The Graph 
Editor represents changes in effects and animations as a 
two-dimensional graph, with playback time represent-
ed horizontally (from left to right). In layer bar mode, 
on the other hand, the time graph represents only the 
horizontal time element, without showing a visual 
representation of changing values.

There are two types of graphs available in the Graph 
Editor: value graphs, which show property values; and 
speed graphs, which show rates of change of property 
values.

Working with the Graph Editor
In the Graph Editor, each property is represented by its 
own graph. You can view and work on one property at 
a time, or you can view multiple properties simultane-
ously. When more than one property is visible in the 
Graph Editor, each property’s graph has the same color 
as the property’s value in the layer outline.

To select which properties are shown in the 
Graph Editor
Click the Show Properties button  at the bottom of the 
Graph Editor, and select from the following options:

• Show Selected Properties Displays selected properties 
in the Graph Editor.

• Show Animated Properties Displays animated proper-
ties of selected layers in the Graph Editor.

• Show Graph Editor Set Displays properties that have 
the Graph Editor toggle  selected.

To select Graph Options in the Graph Editor
Click the Graph Options button  at the bottom of the 
Graph Editor, and select from the following options:

• Auto-Select Graph Type Automatically selects the 
appropriate graph type for a property: speed graphs for 
spatial properties (such as position), and value graphs 
for other properties.

• Edit Value Graph Displays the value graph for all 
properties.

• Edit Speed Graph Displays the speed graph for all 
properties.

• Show Reference Graph Displays the unselected graph 
type in the background for viewing only. (The gray 
numbers to the right of the Graph Editor indicate the 
values for the reference graph.)

• Show Audio Waveforms Displays the audio waveform 
for any layer that has at least one property in the Graph 
Editor.

• Show Layer In/Out Points Displays In and Out points 
of all layers that have a property in the Graph Editor.

• Show Layer Markers Displays layer-time markers in 
the Graph Editor, if they exist.

• Show Graph Tool Tips Toggles the graph tool tips on 
and off.

• Show Expression Editor Shows or hides the expres-
sion editor field.

• Allow Keyframes Between Frames Allows placement 
of keyframes between frames for fine-tuning anima-
tion.

Using the Snap button
When you drag a keyframe in the Graph editor with 
the Snap button  toggled, the keyframe snaps to the 
following items:

Keyframes (both vertically and horizontally)

Current-time indicator

In/Out points



1�
Adobe After Effects 7.0 Instructor Notes

Markers

Work area start/end

Composition start/end

When the keyframe snaps to one of these items, an 
orange line appears in the Graph Editor to indicate 
the object you’re snapping to. Ctrl-drag (Windows) or 
Command-drag (Mac OS) to temporarily toggle the 
Snap button.

Note: Shift-dragging the current-time indicator 
also snaps to the items in the list above.

To pan and zoom in the Graph Editor
To pan vertically or horizontally, drag with the Hand 
tool.

To invoke the Hand tool momentarily, press and hold 
the spacebar.

To pan vertically, spin the mouse scroll wheel.

To pan horizontally, press the Shift key as you spin the 
mouse scroll wheel.

To zoom in, click with the Zoom tool.

To zoom out, Alt-click (Windows) or Option-click 
(Mac OS) with the Zoom tool.

To zoom using the mouse scroll wheel, press Alt (Win-
dows) or Option (Mac OS) while scrolling to zoom 
horizontally; press Ctrl (Windows) or Command (Mac 
OS) to zoom vertically.

To zoom horizontally, Alt-drag (Windows) or Option-
drag (Mac OS) with the Zoom or Hand tool to the left 
to zoom out or to the right to zoom in. 

To zoom vertically, Alt-drag (Windows) or Option-
drag (Mac OS) with the Zoom or Hand tool up to 
zoom in or down to zoom out.

Note: You cannot pan or zoom vertically when 
Auto Zoom Height is selected.

Auto Zoom Height and Fit
The Auto Zoom Height, Fit Selection, and Fit All but-
tons help you adjust the Graph Editor’s view to focus 
on relevant portions of your animations.

Auto Zoom Height toggles Auto Zoom Height mode, 
which automatically scales the height of the graph so 
that it fits the height of the Graph Editor. The horizon-
tal zoom must still be adjusted manually.

Fit Selection adjusts the value (vertical) and time (hori-
zontal) scale of the graph to fit the selected keyframes 
in the Graph Editor.

Fit All adjusts the value (vertical) and time (horizontal) 
scale of the graph to fit all of the graphs in the Graph 
Editor.

LESSON 5
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Lesson 6: Working with Masks

LESSON 6

Lesson 6 introduces students to the concept of masks 
and teaches them to create masks in After Effects using 
the Pen tool. Students can also use Illustrator to help 
them create and use masks in After Effects.

Enhance animation
In a video production workflow, Illustrator CS2 has 
much more to offer than a role as a specialized applica-
tion for still graphics. The pen tool and bezier paths 
that are fundamental to drawing in Illustrator CS2 are 
also used in video production applications to control 
motion paths and timelines. You can use Illustrator 
CS2 paths not just as source graphics, but also as mo-
tion paths in After Effects. You can also use the warp-
ing, blending, and layer features in Illustrator CS2 to 
prepare shapes for morphing and tweening.

Create motion paths in Illustrator CS2
The path-drawing features in Illustrator CS2 are well-
suited to any task that involves drawing a path. Motion 
graphics typically depend on motion paths, and you 
can draw motion paths more quickly and precisely in 
Illustrator CS2 than you can in After Effects.

In After Effects, you create a motion path by animating 
the Position property and setting a different position 
for each keyframe. You then refine the path by drag-
ging handles on the path. This method works well for 
freeform paths, but it can be time-consuming to edit 
a motion path into a regular shape such as a perfect 
circle. Instead of building a motion path from two 
original points as in After Effects, you can draw a path 
in Illustrator CS2 using the tool that most efficiently 
creates the shape you want.

For example, let’s look at animating a layer along a per-
fect semicircular arc. In After Effects, you establish the 
layer position at the beginning and ending keyframes, 
and then drag control handles to form the arc; it isn’t 
easy to form a perfect semicircle in this way. And while 
it’s possible to animate along an arc using a mathemati-
cal expression, not every motion graphics designer is a 
mathematician. For a quick alternative, draw the shape 

you want in Illustrator CS2 and copy and paste it into 
After Effects.

To create an arc in Illustrator CS2 and use the arc as a 
motion path in After Effects:

1. In Illustrator CS2, draw the arc you need using the Arc 
tool or by cutting an ellipse with the Scissors or Knife tools.

2. Use the Selection or Direct Selection tool to select the 
remaining part of the arc, and choose Edit > Copy.

3. Switch to After Effects.

4. In the Timeline panel, select the layer you want to ani-
mate.

5. Press P to reveal the Position property, and click the Posi-
tion property name to highlight it.

6. In the Timeline panel, set the current-time indicator to 
the time where you want motion to start.

7. Choose Edit > Paste. The path becomes a motion path, 
and After Effects adds start and end keyframes to the layer 
in the Timeline panel. (If a motion path was already pres-
ent, pasting a path replaces the previous motion path.) To 
change the duration of the animation, drag either key-
frame.

8. Preview and edit the composition as needed.
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Lesson 7: Keying

LESSON 7

Lesson 7 is about keying. A common task in video pro-
duction, keying removes the background of a clip so 
that you can place the subject in another environment. 
Keying allows the weather anchor to appear in front of 
a map, a superhero to fly across the night sky, and more 
prosaically, production artists to prepare video files for 
compositing in other applications.

You create a key by isolating the background pixels; 
After Effects uses the keyed pixels to create an alpha 
channel that defines the transparent background. The 
alpha channel can be included in certain video formats, 
such as Flash Video (FLV), for use in other applica-
tions. After Effects offers a comprehensive set of keying 
controls that lets you create seamless compositions.

In this tutorial, which you can use in class to supple-
ment the keying exercises in Lesson 7, you’ll key live-
motion footage of a DJ shot against a green screen. Not 
only will you remove the green background, you’ll also 
explore ways to finesse the key to minimize spill (or 
halo effects) and clean up the edges of the subject.

The files used in this tutorial are on Disc 2 of the Total 
Training Video Workshop (included with After Effects). 
Depending on the television standard for your region, 
copy either the NTSC or PAL folder from the After Ef-
fects 7.0 folder to your desktop. Alternatively, you can 
follow along using your own files. You’ll need footage 
shot against a green screen.

Prepare the project
First, you’ll need to create a project and import the 
footage. Then you’ll create a composition and prepare 
it for keying. When keying, you’ll find it helpful to 
change the composition’s background color to some-
thing other than black or white. A different color helps 
you to see problems as you create your key. Rather 
than changing the background color, you can click the 
Toggle Transparency Grid button at the bottom of the 
Composition panel to view the key as you create it.

1. Start After Effects and choose File > New > New Project.

2. Choose File > Save As. Navigate to the location where you 

want to save the file, name the project Keying.aep, and then 
click Save.

3. Choose File > Import > File. Select Green_Raul.avi from 
the folder you copied to your desktop, and click Open.

4. Drag Green_Raul.avi onto the Create A New Composi-
tion button at the bottom of the Project panel. After Effects 
creates a new composition based on the settings of the 
footage.

5. Choose Composition > Background Color. Click the 
color swatch and then select a bright orange color. Click 
OK twice.

6. Choose File > Save to save the project.

Create a garbage mask
A garbage mask (or garbage matte) helps to define the 
subject area of the key, masking out the unnecessary 
areas.

1. Press the spacebar to preview Green_Raul.avi. Notice 
that the DJ’s arms move, but otherwise there is very little 
movement in the clip. When you’re done, press the Home 
key twice—the first time stops the playback, and the second 
time returns the current-time indicator to the beginning of 
the composition.

2. Select the Pen tool from the Tools panel.

3. In the Composition panel, use the Pen tool to create a 
path around the DJ and his equipment. Try to create a path 
that encompasses all of the DJ’s movement.

4. After closing the path, scrub through the clip to make 
sure that all of the DJ’s movements are within the path. If 
necessary, use the Pen or Selection tool to adjust the path.

5. Choose File > Save to save the project.

Apply the Color Key effect
Now that you’ve created the garbage mask, you can get 
down to the actual keying. You’ll use the Color Key ef-
fect to remove the green pixels of the background.

1. Press the Home key to return the current-time indicator 
to the beginning of the clip, and then select Green_Raul.avi 
in the Timeline panel.

2. Choose Effect > Keying > Color Key. The Effect Controls 
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LESSON 7

panel appears and displays the properties for the Color Key 
effect.

3. Click the eyedropper to the right of the Key Color prop-
erty, and then move the cursor around the green area in 
the Composition panel. Notice that as you move the cursor, 
the Info panel displays the RGB values for each pixel. Click 
a green pixel to the right of Raul’s head. A sprinkling of 
the green pixels are keyed out and the orange background 
shows through. The number of pixels keyed out depends on 
the color values of the pixel you clicked.

4. In the Effect Controls panel, set Color Tolerance to 16. By 
default, Color Tolerance is set to zero, so the pixels that are 
keyed out are those that exactly match the selected color. 
Increasing the value to 16 causes the majority of the green 
pixels to be keyed out.

5. Set Edge Thin to 3 to smooth the edges and tighten the 
key, and set Edge Feather to 4 to soften the transition.

6. Increase Color Tolerance to 32. Though not necessarily 
a high setting, it’s too high for this footage, making Raul’s 
green headband disappear. Just as in the real world, the 
initial key goes a long way toward the desired results, but 
you almost always need to tweak the composition further. 
Reset Color Tolerance to 16.

Apply a second Color Key effect
Although there are many ways to remove the remaining 
green pixels, for this footage, applying a second in-
stance of the Color Key effect is the quickest. If you use 
the Eyedropper tool to examine the remaining green 
pixels, you’ll see that their green values are close to one 
another (and somewhat darker than the green used in 
the original key.)

1. With Green_Raul.avi selected in the Timeline panel, 
choose Effect > Color Key to apply a second instance of the 
effect. The most recent effect applied appears at the top of 
the Effect menu.

2. In the Effect Controls panel, click the color swatch for 
Color Key 2, enter values of R=62, G=108, B=67, and then 
click OK. Set Color Tolerance to 10, Edge Thin to 2, and 
Edge Feather to 2. These settings remove the majority of the 
green pixels. If you zoom in, however, you’ll notice a slight 
green halo around the DJ. Next you’ll remove that.

Remove light spill
The green halo results from light spill, or the light re-
flected from the background onto the subject. You can 
use the Hue/Saturation effect to correct this problem. 

After Effects 7.0 Professional includes the Spill Sup-
pressor effect, which makes quick work of removing 
spill.

1. Select Green_Raul.avi in the Timeline panel, and then 
choose Effect > Color Correction > Hue/Saturation.

2. In the Effect Controls panel, set Channel Control to 
Greens, since you want to change green pixels. Drag the 
Green Saturation slider to the left, to somewhere around 
-40. This setting desaturates the green and removes the 
halo. (It also dulls the green in the DJ’s headband, a perfect 
example of the compromises often required when keying.)

3. Save the project.

View the alpha channel
Now that you’ve completely removed the background, 
view the resulting alpha channel you created.

1. At the bottom of the Composition panel, click the Show 
Channel button and select Alpha.

Add a new background
You can now either add a new background or render 
the composition in a format that retains the alpha 
channel. Many formats can retain alpha channels, in-
cluding Flash Video, QuickTime, and a host of others. 
See After Effects Help for more information.

1. Choose Layer > New > Solid. Type New Background in 
the Name text box, and click OK.

2. In the Timeline panel, drag New Background below 
Green_Raul.avi.

3. Choose Animation > Browse Presets. Bridge opens and 
displays the available presets. In the Backgrounds folder 
within Bridge, double-click Cosmic Powers.ffx to apply 
it to the solid layer. Close Bridge. At first glance, the new 
cosmic background seems a bit dark—the preset you ap-
plied is essentially a collection of predesigned animations, 
so you need to render the frames before you experience the 
crackling energies.

4. In After Effects, press the spacebar to preview the com-
position. You may notice some of the orange background 
appears around the edges of the composition. The orange 
appears because the edges of the layer warp with the 
animation. Select New Background in the Timeline panel, 
and press the S key to reveal its Scale property. Set Scale to 
125%, and then preview the composition again.
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Lesson 8: Performing Color Correction

LESSON 8

Lesson 8 covers color correction. To ensure that color 
appears on a viewers system as students see it on their 
computers, a complete understanding of color and 
color management is useful.

About color depth
Color depth is the number of bits per channel (bpc) 
used to represent the color of a pixel. Channels contain 
color information: RGB images have channels for red, 
green, and blue. The more bits per channel, the more 
colors can be represented. 

In After Effects, you can work in 8-bpc, 16-bpc or 32-
bpc color mode for each project; 16-bpc and 32-bpc 
color modes are available only in After Effects Profes-
sional. Many effects support 16 and 32 bits per channel 
(see Color depth and effects).

Even if your output is 8-bpc (Millions Of Colors), 
you can obtain better rendering quality by having the 
project (or render) color depth set at 16-bpc or 32-bpc 
because of the added precision achieved by calculating 
color values at higher bit depths.

32-bpc color mode (Pro only) is for working with HDR 
(high dynamic range) images. After Effects assumes 
that all HDR footage represents color linearly—in lin-
ear light. When you import HDR images, After Effects 
converts floating-point 32-bit values from linear light 
to the project’s working color space.  If you haven’t 
chosen a working color space for your project, After 
Effects converts HDR footage from linear light using a 
gamma value of 2.2; this value represents the gamma 
for a typical monitor. Gamma is the exponent used in 
converting RGB levels. When you render to a 32-bpc 
output format, After Effects removes the gamma ap-
plied on import, converting 32-bit values back to linear 
light.

16-bpc color-mode (Pro only) frames require half the 
memory of 32-bpc frames and offer advantages in 
terms of speed and storage. Use 16-bpc mode when 
you work with high-resolution images that contain 
a narrow range of colors, such as when you’re creat-
ing subtle gradients for film effects or HDTV output. 

Transitions between colors are smoother with less 
visible banding, and more detail is preserved than with 
8-bpc color (though less than with 32-bpc color). You 
can import 16-bpc images, including those from Adobe 
Photoshop, and composite and color-correct footage 
in 16-bpc mode. Take advantage of 16-bpc color when 
performing most After Effects tasks, including layer ad-
justment, frame blending, 3D compositing, and Cineon 
file import. The Info panel displays 16-bpc color values 
with exact precision. 

When rendering to output module depths of Trillions 
Of Colors, set the project to 16-bpc color depth to take 
advantage of the output file’s extra color precision.

To choose a project color depth
Do one of the following:

• Choose File > Project Settings, and choose a color 
depth from the Color Depth menu.

• In the Project panel, Alt-click (Windows) or Option-
click (Mac OS) the Project Color Depth button.

To expand the range of luma levels
Some file format modules convert 8-bpc luma from 
certain hardware, such as cameras, to RGB levels within 
the range of 16 to 235. In 8-bpc mode, After Effects 
works with RGB levels from 0 to 255. If blacks or 
whites appear either crushed or faded, there may be a 
luma range mismatch that you can correct by expand-
ing the range of luma levels. You can expand the range 
of the luma levels to 0 to 255 without having to apply a 
Levels effect. Luma expansion also works with 16-bpc 
footage and projects.

1. Select the footage in the Project panel and choose File 
> Interpret Footage > Main, and select Expand ITU-R 601 
Luma Levels.

Note: In 32-bpc projects, After Effects can gener-
ate over-range values that let you work with 
whiter-than-white, or over-bright, values (for 
example, values above 235 in an 8-bpc file).
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Color management
Color images can look different when viewed with 
different display devices and in different contexts. For 
example, an image displayed on a computer monitor 
may look different from the same image displayed on a 
video monitor or projected onto a movie screen. Colors 
shift because different devices use different methods to 
create color and produce different ranges of colors. 

In After Effects, you can compensate for color output 
between different display devices by first calibrating 
and profiling your monitor and then selecting an RGB 
working color space, an intermediate color space used 
to define and edit color, which After Effects uses for all 
pixel color calculations. Each project can have its own 
working color space, which is saved with all other proj-
ect settings in the project (.aep) file. When After Effects 
displays pixels, it converts from the working color space 
(which characterizes the space colors are in) to the 
monitor profile (which defines how the monitor repro-
duces color) to produce predictable, consistent color.

Because After Effects doesn’t honor ICC profiles as-
signed to images such as those from Adobe Photoshop 
and doesn’t assign profiles to files on output, it doesn’t 
provide a complete color management system. Howev-
er, if you calibrate and profile your monitor and set an 
RGB working color space for the project, colors in your 
images will look the same on any calibrated monitor.

To calibrate and profile your monitor
When you calibrate your monitor, you’re adjusting it 
so that it conforms to a known specification. After your 
monitor is calibrated, the profiling utility lets you save 
a color profile. The profile describes the color behavior 
of the monitor—what colors can be reproduced on the 
monitor and how the color values in an image must be 
converted so that colors are displayed accurately.

Before you calibrate and profile your monitor, make 
sure that your work environment provides a consistent 
light level and color temperature. For example, the 
color characteristics of sunlight change throughout the 
day and alter the way colors appear on your screen, so 
keep shades closed or work in a windowless room.

Make sure your monitor has been turned on for at least 
half an hour. This gives it sufficient time to warm up 

and produce more consistent output.

Make sure your monitor is displaying millions of colors 
or 24-bits-per-pixel or higher.

Remove colorful background patterns on your monitor 
desktop and set your desktop to display neutral grays. 
Busy patterns or bright colors surrounding a document 
interfere with accurate color perception.

Do one of the following to calibrate and profile your 
monitor:

In Windows, use the Adobe Gamma utility, located in 
the Control Panel.

Note: Don’t use Adobe Gamma to calibrate an 
LCD (flat panel) monitor—it doesn’t produce 
reliable results. Instead, use a hardware calibra-
tor.

In Mac OS, use the Calibrate utility, located in the Sys-
tem Preferences/Displays/Color tab.

For best results, use third-party software and measur-
ing devices. In general, using a measuring device such 
as a colorimeter along with software can create more 
accurate profiles because an instrument can measure 
the colors displayed on a monitor far more accurately 
than the human eye can.

Note: Monitor performance changes and de-
clines over time; recalibrate and profile your 
monitor every month or so. If you find it diffi-
cult or impossible to calibrate your monitor to a 
standard, it may be too old and faded.

Most profiling software automatically assigns the new 
profile as the default monitor profile. For instructions 
on how to manually assign the monitor profile, refer to 
the Help system for your operating system.

To choose a working color space
If you don’t choose a working color space for a proj-
ect, After Effects uses the color space of the monitor. 
For best results, choose a working color space that 
matches your output color space. For example, choose 
SDTV (Rec 601 NTSC) if you’re preparing footage 
for broadcast video, or choose sRGB IEC61966-2.1 if 
you’re preparing footage for the web. A good match 
between working and output color spaces not only lets 
you take advantage of the After Effects color manage-

LESSON 8
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ment feature but also gives more accurate previews and 
somewhat more accurate results when linear blending 
is used (see To enable linear blending). Setting a work-
ing color space, however, can significantly slow RAM 
previews. 

The color spaces available in After Effects vary based on 
the color profiles installed on your computer.

1. Choose File > Project Settings.

2. Choose a working color space from the Working Space 
menu.

3. Use the Color Profile Converter effect to convert a layer 
from one color space to another. For example, apply the 
Color Profile Converter effect to an adjustment layer at the 
top of a composition to convert output to a different color 
space.

To proof colors
If you’ve chosen a working color space, you can choose 
to proof your colors as they’d appear without the work-
ing color space applied; that is, as raw color values in 
the color space of the monitor.

1. Choose View > Proof Setup > Unmanaged.

2. Choose View > Proof Colors to toggle the proof display 
on and off. When proofing is enabled, a check mark appears 
next to the Proof Colors command.

LESSON 8
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Lesson 9: Building and Animating  
a 3D Object

LESSON 9

Lesson 9 is the first of a two-part project that covers all 
aspect of 3D animation in After Effects. Here is some 
additional useful information about 3D editing in After 
Effects.

Using third-party 3D files
Though After Effects can import some third-party 
files with depth information and interpret the z-axis 
information in those files, it cannot animate individual 
objects within those files. After Effects treats each com-
posited third-party 3D file as a single layer. That layer, 
as a whole, can be given 3D attributes and treated like 
any After Effects 3D layer, but the objects contained 
within that 3D file cannot be manipulated individually. 
To access the 3D depth information in these files, use 
the 3D Channel effects.

About z scale
Usually, scaling a layer’s z axis has no effect on the layer 
because the layer itself has no depth. To add depth, you 
can change the position of the layer’s anchor point or 
establish a parenting relationship with other layers. 
Once you add depth, scaling the layer’s z scale value 
appears to change the layer’s position.

How After Effects works with 3D image files
After Effects can import 3D image files saved in Softi-
mage PIC, RLA, RPF, and Electric Image EI format. 
These 3D image files contain red, green, blue, and 
alpha (RGBA) channels, as well as auxiliary channels 
with optional information, such as z depth, object IDs, 
texture coordinates, and more.

With RLA and RPF files, all of the auxiliary channels 
are included in a single file. Softimage PIC files have 
a corresponding ZPIC file that contains the z-depth 
channel information. Although you can’t import a 
ZPIC file, you can access the additional channel infor-
mation as long as the ZPIC file is stored in the same 

folder as the imported PIC file.

Similarly, Electric Image (EI) files can now have associ-
ated EIZ files with z-depth channel data. Just as with 
ZPIC files, you cannot import EIZ files into After Ef-
fects; instead, you simply store them in the same folder 
as the EI files. For information about creating EIZ files, 
see your Electric Image documentation.

After Effects can also import baked camera data, in-
cluding focal length, film size, and transformation data, 
from Maya project files as a single composition or two 
compositions.

To import RLA or RPF data into a camera layer 
(Pro only)
After Effects imports camera data saved with RLA or 
RPF sequence files. That data is incorporated into a 
camera layer that After Effects creates in the Timeline 
panel. You can access the camera data of an imported 
RLA or RPF sequence and create a camera layer con-
taining that data. 

1. Place the imported sequence in the Timeline panel, and 
then select the sequence.

2. Choose Animation > Keyframe Assistant > RPF Camera 
Import.

Note: To create an RLA or RPF file with the 
camera data in 3D Studio Max, save your render-
ing in RPF format with Coverage, Z Depth, and 
Alpha Channels enabled.
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LESSON 10

Lesson 10: Using 3D Effects

Lesson 10 is the second of a two-part project on using 
3D animation in After Effects. It covers 3D effects and 
using lights and cameras.

Camera settings
You can set up cameras in After Effects to simulate the 
capabilities of real-world cameras. Use camera settings 
to configure the camera view to match the settings you 
use to record video footage or to look at the foot-
age from a new perspective. You can change camera 
settings at any time by selecting the camera layer and 
choosing Layer > Camera Settings.

Name—Specifies the name of the camera. By default, 
After Effects assigns the name Camera 1 to the first 
camera you create in a composition, and all subsequent 
cameras are numbered in ascending order. If you delete 
a camera, and are still using the After Effects default 
naming convention, After Effects names the next cam-
era you create with the lowest available number. You 
should choose distinctive names for multiple cameras 
to make it easier to distinguish them. 

Preset—Specifies the type of camera settings you want 
to use. Cameras come with several presets. The presets 
are named according to focal lengths. Each preset is 
meant to represent the behavior of a 35mm camera 
with a lens of a certain focal length. Therefore, the pre-
set also sets the Angle Of View, Zoom, Focus Distance, 
Focal Length, and Aperture values. The default preset is 
50mm. You can also create a custom camera by specify-
ing new values for any of the settings.

Zoom—Specifies the distance from the position of the 
camera to the image plane.

Angle Of View—Specifies the width of the scene 
captured in the image. The Focal Length, Film Size, 
and Zoom values determine the angle of view. A wider 
angle of view creates the same effect as a wide-angle 
lens.

Enable Depth Of Field—Applies custom variables to 
the Focus Distance, Aperture, F-Stop, and Blur Level 
settings. Using these variables, you can manipulate the 
depth of field to create more realistic camera-focus-

ing effects. (The depth of field is the distance range 
within which the image is in focus. Images outside the 
distance range are blurred.)

Focus Distance—Specifies the distance from the 
camera’s position to the plane that is in perfect focus. 

Lock To Zoom—Makes the Focus Distance value 
match the Zoom value. 

Note: If you change the settings of the Zoom or 
Focus Distance options in the Timeline panel, 
the Focus Distance value becomes unlocked 
from the Zoom value. If you need to change the 
values and want the values to remain locked, 
then use the Camera Settings dialog box in-
stead of the Timeline panel. Alternatively, you 
can add an expression to the Focus Distance 
property in the Timeline panel: Select the Focus 
Distance property, and choose Animation > Add 
Expression; then drag the expression pick whip 
to the Zoom property. 

Aperture—Specifies the size of the lens opening. The 
Aperture setting also affects the depth of field; increas-
ing the aperture increases the depth of field blur. When 
you specify new values for Aperture, the values for 
F-Stop change dynamically to match it.

F-Stop—Represents the ratio of the focal length to ap-
erture. Most cameras specify aperture size using the f-
stop measurement; thus, many photographers prefer to 
set the aperture size in f-stop units. When you specify 
new values for F-stop, the values for Aperture change 
dynamically to match it.

Blur Level—Controls the amount of depth-of-field 
blur in an image. A setting of 100% creates a natural 
blur as dictated by the camera settings. Lower values 
reduce the blur.

Film Size—Specifies the size of the exposed area of 
film, which is directly related to the composition size. 
When you specify new values for Film Size, the Zoom 
value changes to match the perspective of a real cam-
era.

Focal Length—Specifies the distance from the film 
plane to the camera lens. In After Effects, the camera’s 
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position represents the center of the lens. When you 
specify new values for Focal Length, the Zoom value 
changes to match the perspective of a real camera. In 
addition, the Preset, Angle of View, and Aperture values 
change accordingly.

Units—Specifies the units of measurement in which 
the camera setting values are expressed.

Measure Film Size  Specifies the dimensions used to 
depict the film size. About 3D previews

You can speed up preview time for 3D layers by en-
abling Wireframe mode on the Fast Previews menu 
or by using Draft 3D mode. These preview modes 
reduce the amount of data displayed in a 3D layer, so 
the screen redraws faster. You can also use OpenGL for 
faster previews of 3D layers.

About 3D rendering
After Effects provides three 3D rendering plug-ins: 
Advanced 3D, Standard 3D, and OpenGL Hardware. 
These plug-ins compute the motion blur, lighting, 
shadow, and depth-of-field information unique to 
3D. OpenGL also provides rendering support for a 
number of other 2D effects. After Effects can also use 
OpenGL—if the appropriate hardware is available—
during interactions like moving and rotating layers. 
After Effects can use the Advanced 3D rendering plug-
in to create both RAM previews and output files. The 
3D rendering plug-in you specify becomes the default 
for future compositions.

LESSON 10
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Lesson 11: Advanced Editing Techniques

LESSON 11

Lesson 11 looks at some of the advanced editing tech-
niques available in the Professional version of After 
Effects 7.0. However, it only touches on one new and 
important feature: support for HDR color. Here is 
some additional information about HDR, as well as a 
tutorial, to supplement the lesson. 

Working with natural light in HDR
It’s a common yet mistaken assumption that the only 
After Effects Professional users who have any business 
using 32-bit mode are artists working on big-budget 
blockbuster films. The reality is that anyone using the 
Professional edition can benefit from the 32-bit HDR 
pipeline. Not only does 32-bit mode mean more colors 
and more accuracy than the 8-bit or 16-bit modes, 
it also means that the behavior of light and color in 
After Effects is remarkably similar to the behavior in 
the natural world. In this tutorial, you’ll explore how 
32-pbc images preserve the full range of light data, and 
how the same principals apply whether or not you’re 
starting with a 32-bit source.

The files used in this tutorial are on Disc 2 of the Total 
Training Video Workshop (included with After Ef-
fects). Depending on the television standard for your 
region, copy either the NTSC or PAL folder from the 
After Effects 7.0 folder to your desktop. Alternatively, 
you can follow along using your own files. You’ll need 
an After Effects project file and a layered 32 bpc PSD 
file. 

Work with 32-bit input 
The most obvious advantage for 32-bit support is that 
it allows you to work with 32-bit source images. Such 
images can store light values beyond what your moni-
tor displays as full white. These light values are useful 
when you want to manipulate the light, such as bring-
ing the light values of your scene down. In 8-bit and 
16-bit images, really bright white values are clipped to 
the color space’s highest value; bringing these clipped 
colors down turns them gray. However, 32-bit images, 
which retain the original (non-clipped) values, behave 

much more like natural light, even through several 
color corrections.

Adjust the exposure of an HDR image

1. Open the After Effects project HDR_1.aep. Select the PSD 
file. Its thumbnail, labeled Floating Point, appears at the 
top of the Project panel. The bottom of the Project panel 
indicates that the file is in 32 bpc mode.

2. From the Workspace menu, choose Standard to ensure 
that the Info panel is clearly visible. Select Auto Color Dis-
play from the Info panel menu.

3. Move the pointer around the image in the Composition 
panel, noting the R, G, and B values in the Info panel. Most 
of the image’s pixel values are in the normal Decimal range 
of 0.0 to 1.0. (In 8-bit terms, this range is 0 to 255.) Now 
move the pointer over the brightest areas of the image, 
and note that the values are greater than 1.0. These areas 
contain whiter-than-white values.

4. Select the HDR.psd layer in the Timeline panel, and 
choose Effect > Color Correction > Levels. Move the 
pointer over the brightest areas again, and note that the val-
ues are 1.00. In the Effect Controls panel, deselect Clip To 
Output White. Note that the values are again greater than 
1.0. Set Output White to 0.5. The result is similar to stop-
ping down a camera’s lens aperture, reducing the amount 
of light entering the camera.

5. Select Clip To Output White, and notice that the bright 
values turn gray. If the brightest possible white is limited to 
1.0 (with clipping on), setting Output White to 0.5 turns it 
medium gray. But if the brightest possible white is limited 
to 2.0 (with clipping off), setting Output White to 0.5 turns 
it back to full white, or 1.0 (with clipping on). Darker values 
in the visible range also change proportionally.

6. Apply a second Levels effect just as you did in step 3. This 
time, set Output White to 2.0. Look familiar? Essentially, 
you restored the levels to their original values with the sec-
ond occurrence of the effect. Toggle the effects off for this 
layer by clicking the Effect switch in the Timeline panel. 
Note that no loss of image quality occurs, even though you 
made two drastic Levels adjustments. The image quality is 
retained because the HDR pipeline provides space to store 
and retrieve the value changes.
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Take advantage of HDR without 32-bit source
Even if you don’t have HDR source material available, 
the ability to work with values that fall outside the 
range of your monitor can still transform your work.

1. Open the project HDR_2.aep. The Main composition 
consists of three layers: a precomposed Source Text 3D 
layer, a Camera 1 layer, and a Light 1 layer. In the Timeline 
panel, reveal the properties for the Camera 1 layer. Notice 
that Depth Of Field is on, and Focus Distance is at the 
center of the text layer. Reveal the properties for the Light 1 
layer. Notice that at frame 0 Intensity is set to 100%, and at 
the end frame it’s set to 1000%, ten times greater.

2. In the lower right corner of the Composition panel, ad-
just the Exposure control by dragging across the value be-
side it. Dragging to the right increases the exposure; drag-
ging to the left decreases exposure. Increasing the value by 
1.0 is equivalent to increasing exposure by one stop.

3. Alt-click (Windows) or Option-click (Mac OS) the 32 
bpc button at the bottom of the Project panel, toggling the 
mode to 8 bpc. Not only do the lighting effects disappear, 
but so does the Exposure control, which is available only in 
32 bpc mode.

Note: The Exposure control is for previewing 
purposes only. To achieve similar results that 
show up in your final render, increase the Inten-
sity of the light or apply the Exposure effect. 
(Keep reading for more information.)

Go further with HDR
• Several effects have been upgraded to work in 32 bpc, 
and new effects have been added to take advantage of 
HDR. In the Effects & Presets panel, choose Show 32 
bpc Effects Only from the panel menu to see these ef-
fects. Many are ideal for blurs and color correction.

• A separate, somewhat more complicated benefit of 
HDR is the Linear Blending option. To set this option, 
choose File > Project Settings. Linear Blending changes 
the way that After Effects works internally with gamma; 
it combines light levels in a way that’s similar to how 
they’re combined in the real world. However, to use 
this option properly, the source images and the work-
ing space of your project must be converted to support 
an altered gamma. For more information, see After 
Effects Help.

What is happening in 32-bit HDR mode?
As you’ve just seen, 32 bpc can calculate and hold 
values even above the brightest value that your moni-
tor can display. (Monitors display brightness at 1.0 
on a decimal scale, or at 255 in 8 bpc color.) But what 
use are these color values if your monitor can’t display 
them? Because the bright values aren’t clipped, they’re 
more realistic. The real world contains brightness 
values far beyond what your monitor can display. And 
now you can capture a little bit of that reality in After 
Effects.

LESSON 11
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Lesson 12: Rendering and Outputting

LESSON 12

Lesson 12 covers the topics rendering and outputting. 
Here is some addition information about DV and HD 
output.

Getting video out of your computer
Once you have finished assembling and editing clips, 
it’s time to get your final production out of your 
computer and on its way to distribution. These days, 
creative professionals are expected to deliver video that 
can be used in multiple media. Broadcast and film pro-
fessionals alike are now creating web-based work, while 
web designers may need to create animations that are 
output in video formats. DVDs have also become an 
extremely popular way to combine high-quality video 
and audio content with menu-driven interactivity. To 
address this growing need for flexibility, After Effects 
offers a wide range of options that enable you to pro-
duce high-quality deliverables for any medium.

The project you edited in the Timeline does not actu-
ally contain the material from which it was pieced 
together. Rather, it references your source files. Before 
export, make sure that the Timeline is ready to output 
at the quality you require. For example, replace any 
offline files with high-resolution files suitable for final 
export. To get your edited program out of your com-
puter in one piece, you can:

• Record the timeline to physical media including vid-
eotape or motion picture film, assuming that you have 
the proper hardware for video or film transfer, or have 
access to a service provider that offers the appropriate 
equipment and services.

• Export a video file for viewing from a hard disk, 
removable cartridge, CD, DVD, or the web.

• Export portions of your timeline as clips.

• Capture stills or sequences of stills.

Good housekeeping
In professional production environments, after a video 
project has been completed, it is typically cleared 
from the editing system to make room for new work. 

Because the multigigabyte storage media that would be 
needed is costly, and the process of uploading can be 
very time-consuming, projects and source files are not 
usually saved in their entirety. If you do want to save 
your entire project, you can trim unused frames from 
some or all of your source clips and remove unused 
clips in their entirety from Project Bins.

Typically, however, a digital master file is exported and 
archived, the original raw footage is stored on tapes, 
and an Edit Decision List (EDL) is saved. If the project 
needs to be revised later, the master file can often be 
edited. For more extensive repurposing, the EDL can be 
used to recapture the necessary clips from the original 
tapes. Files used to develop titles, graphics, and anima-
tions, as well as portions of the project that have under-
gone extreme manipulation to achieve special effects 
can also be archived.

Today, more and more production professionals are 
exporting Advanced Authoring Format (AAF) files 
rather than EDLs to archive or exchange projects. AAF 
is a widely supported industry standard for high-end 
exchange of data, such as the information necessary to 
transfer a video project from one platform to another. 
An AAF file helps you preserve as much of the project’s 
integrity as possible when you transfer it to another 
system. However, not all elements of a project can be 
successfully transferred using AAF. Also, the applica-
tion you use to open the AAF file may not support all 
features. In general, an AAF file dependably translates 
editing data and commonly used transitions, such as 
cross-dissolves and wipes, but does not support effects 
(filters) or audio fade and pan information, including 
audio transitions.

Exporting to videotape
You can record your edited program onto videotape 
directly from your computer. This process can be as 
simple as playing the Timeline and recording on a 
connected device. When you record standard DV video 
back to standard DV tape, all that is required is an 
IEEE 1394 connection. However, if you plan to record 
DV audio and video to an analog format, such as VHS 
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tape, you’ll need a device that can convert DV to analog 
using the connectors supported by your analog video 
recorder. Most DV cameras and all DV video tape 
recorders are capable of this conversion; some DV cam-
eras require you to record the video to DV tape, then 
copy the DV tape to the analog video recorder.

Exporting to digital files
You can prepare variations of a program or clip for a 
variety of different uses. For example, you can create 
separate versions for DVD distribution and web view-
ing. Adobe Premiere Pro and After Effects both offer 
built-in support for exporting the following digital vid-
eo file formats: Microsoft AVI, Animated GIF, Quick-
Time, MPEG-1 and -2, as well RealMedia and Windows 
Media files for the web. After Effects also exports Adobe 
Flash (SWF) files. Several audio-only formats and a 
variety of still-image and sequence formats are also 
supported by both applications. Additional file formats 
may be available if provided with your video capture 
card or if you add third-party plug-in software.

To start the export process, you enter settings that 
determine the properties of the final file. These settings 
may include the data rate for playback, the color depth, 
the frame size and frame rate, the quality, and what 
type of compression method, or codec, to use. Choos-
ing compression settings is a balancing act that varies 
depending on the type of video material, the target 
delivery format, and the intended audience. Often, you 
discover the optimal compression settings through trial 
and error. Prior to distribution, you should always test 
the files you export on the type of platform or equip-
ment you expect your audience to use.

Web video
The web is rapidly gaining importance as a vehicle for 
distributing video content. From training programs, to 
sharing the experience of personal events such as wed-
dings, to full-length feature films, video delivered via 
the Internet or a corporate intranet is big business.

DVD
Adobe Encore DVD adds creative authoring for profes-
sional DVD production to the Adobe Production Stu-

dio solution set. To learn more about DVD production 
and Adobe Encore DVD, take a look at the Adobe DVD 
Primer on the Adobe website at www.adobe.com/mo-
tion/primers.html.

What is high definition?
After years of anticipation, high definition (HD) video 
production has become widespread. Over-the-air 
HDTV is rapidly building an audience, and high defini-
tion DVD development is proceeding quickly. Even 
people not producing for an HD audience are using 
HD formats during production and post-production. 
For example, the pioneering DVD company Criterion 
uses HD on D5 tape for digital intermediates from 
their telecine captures. Suddenly, companies are finding 
that they have HD content to distribute and are look-
ing for ways to distribute it.

The myth is that HD is very expensive and difficult to 
author. The reality is that HD has become cheaper and 
easier to use than standard definition (SD) was only a 
few years ago. Today, you can build a complete entry-
level HD production system, including storage, soft-
ware, and camera, for under U.S.$10,000. Higher-end 
and uncompressed HD editing systems can be much 
more expensive, but they are also declining in price as 
more options enter the market.

Types of HD
High definition simply means more than standard 
definition (SD). The highest resolution SD format is 
PAL, with 576 lines. Thus, almost any video frame with 
a vertical size greater than 576 lines is considered HD. 
If a final video is destined for playback on a computer 
monitor or a custom device, you can create your own 
frame dimensions. However, most HD video is either 
1920 x 1080 or 1280 x 720, with a 16:9 aspect ratio.

Post-production for HD content
In the Adobe production workflow, post-production is 
the domain of Adobe Premiere Pro for editing, Adobe 
Audition for sound mixing and sweetening, and After 
Effects for compositing and finishing.

Post-production for HD is similar to post-production 
for SD. One difference is that with HD you’re dealing 

LESSON 12
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with significantly more data and consequently increas-
ing the load on the CPU and video card. However, if 
you have worked in Adobe Premiere Pro and After 
Effects for SD, you can use the same tools and enjoy the 
same workflow in HD.

A complete HD post-production suite can include a 
workstation for acquisition and editing, and another 
for scene-by-scene color correction and effects. With 
two workstations, an Editor and Colorist can work on 
different parts of the production at the same time. One 
or more videotape playback decks may be located near 
the editing workstation for acquisition, depending on 
the formats used in production. To ensure that high 
quality is maintained throughout the process, a suite 
should include at least one high-resolution monitor. 
High performance computers and a RAID array are 
used for fast processing, and reliable mass storage.

Choosing an HD monitor
HD video monitors can be quite expensive, especially 
models with an HD-SDI input. However, a true profes-
sional-grade HD video monitor is essential for any 
producer working with HD destined for broadcast.

For some tasks, a computer monitor is a less expensive 
way to view the actual HD output, especially for proj-
ects that use progressive scanning. However, computer 
monitors use a different color temperature from true 
video monitors, so it’s beneficial to use a video moni-
tor to ensure that you see the true representation of the 
video as it will be delivered. A number of vendors offer 
HD-SDI to Digital Video Interface (DVI) converters 
to drive computer monitors. High-quality 1920 x 1200 
LCD monitors are now available for around US$2000, 
so this converter is cost effective. Because computer 
monitors are natively progressive, these converters are 
not a good solution for natively interlaced projects in 
Adobe Premiere Pro. (Conversion isn’t an issue with 
After Effects because the preview is progressive.)

Another advantage of using broadcast monitors is 
calibration. These monitors provide features that easily 
set them to the canonical 709 color space of HD. While 
this setting is possible with a computer monitor as well, 
correctly setting the calibration can be difficult or inac-
curate. Even systems with a colorimeter for automatic 
color configuration don’t always include 709 presets.

HD can be slow!
The additional throughout and processing power 
required for HD production often exceeds the capa-
bilities of even the fastest computers. A computer that 
handles SD video simply cannot be expected to provide 
the same performance with HD, without a little help. 
The good news is that modern tools give you a number 
of techniques to get around these limitations.

Specifying rendering quality and compression
After Effects has several rendering modes. For final 
output, you should always use the highest quality 
mode, especially when your final product is to be com-
pressed. High-quality mode can increase compression 
efficiency, resulting in fewer image artifacts.

Rendering in After Effects
16-bit per channel (bpc) rendering was introduced in 
the After Effects Production Bundle and is now avail-
able in both After Effects Standard and After Effects 
Professional. The 16-bpc rendering process doubles 
the number of bits available for each channel, which 
greatly increases the precision of the video rendering. 
That extra precision is quite useful, especially in reduc-
ing the appearance of banding in an image with subtle 
gradients. This precision has a cost. 16-bpc rendering 
takes twice the time and requires twice as much RAM 
as 8-bpc rendering.

16-bit per channel rendering is adequate for most 
video, and After Effects also features 32-bit rendering 
for high dynamic range (HDR) footage. Floating-
point numeric values allow the same number of bits to 
describe a much wider range of values than fixed-point 
values; 32-bits per channel allow for much greater pre-
cision than do 8- or 16-bits per channel. This flexibility 
enables you to work with images that have a very wide 
range of brightness levels, more like the range of levels 
found in the real world.

Rendering in 16 or 32 bpc isn’t necessary when encod-
ing to an 8-bpc delivery format like Windows Media 
or MPEG-2. It does, however, provide a very welcome 
quality boost when going back out to 10-bpc formats 
like D5.

LESSON 12


