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7Advanced Finder
Techniques

Advanced Finder 
Techniques
In addition to the basic Finder and file man-
agement techniques covered in Chapters 2
through 4, Mac OS X offers more advanced 
techniques you can use to work with files:

◆ Use spring-loaded folders to access 
folders while copying or moving items.

◆ Apply color-coded labels to Finder items.

◆ Use aliases to make frequently used files 
easier to access without moving them.

◆ Quickly reopen recently used items.

◆ Use the new Quick Look feature to view 
the contents of a file or folder without 
opening it.

◆ Use the Info window to learn more about 
an item or set options for it.

◆ Compress files and folders to save space 
on disk or minimize data transfer time.

◆ Undo actions you performed while 
working with the Finder.

✔ Tip
■ If you’re brand new to Mac OS, be sure 

to read the information in Chapters 2
through 4 before working with this chap-
ter. Those chapters contain information 
and instructions about techniques that 
are used throughout this chapter.
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Spring-Loaded Folders
The spring-loaded folders feature lets you 
move or copy items into folders deep within 
the file structure of a disk—without manually 
opening a single folder. Instead, you simply 
drag icons onto folders (Figures 1 and 3) and 
wait as they’re automatically opened (Figures 
2 and 4). When you drop the icon into the 
window you want, all windows except the 
source and destination windows automati-
cally close (Figure 5).

✔ Tips
■ The spring-loaded folders feature is 

sometimes referred to as spring-open
folders.

■ Using the spring-loaded folders feature 
requires a steady hand, good mouse 
skills, and knowledge of the location of 
folders on your disk.

■ To use the spring-loaded folders feature, 
it must be enabled in the Finder prefer-
ences. Although this feature is normally 
turned on by default, if it’s not, you can 
learn how to enable it in Chapter 8.

■ To use the spring-loaded folders feature 
to move or copy more than one item at a 
time, select the items first, and then drag 
any one of them.
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Figure 1 Drag an icon onto a folder and wait…

Figure 2 …until the folder opens.
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To move an item using spring-
loaded folders
1. Drag the item you want to move onto the 

folder to which you want to move it 
(Figure 1), but do not release the mouse 
button. After a moment, the folder blinks 
and opens (Figure 2).

2. Without releasing the mouse button, 
repeat step 1. The destination folder 
becomes selected (Figure 3), then blinks 
and opens (Figure 4). Do this until you 
reach the final destination.

3. Release the mouse button to place the 
item into the destination window. All 
windows other than the source and 
destination windows close; the source 
window remains active (Figure 5).

✔ Tips
■ In steps 1 and 2, to open a folder immedi-

ately, press z while dragging an 
item onto it.

■ To close a folder’s window so you can 
open a different folder in the same win-
dow, drag the item away from the open 
window. The window closes so you can 
drag the item onto a different folder and 
open it.

To copy an item using spring-
loaded folders
Hold down o while following the above 
steps.

✔ Tip
■ If the destination folder is on another 

disk, it is not necessary to hold down 
o to copy items; they’re automati-
cally copied.

Figure 5 When you’re fi nished, only the source 
window (which is active) and destination 
window remain open.

Figure 4 …until that folder opens.

Figure 3 Continue to drag the icon onto a 
folder in that window and wait…
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Labels
Mac OS X’s Labels feature enables you to 
assign color-coded labels to Finder icons. You 
can then sort list view windows by label or 
search for items based on the assigned label. 

With a little imagination, labels can be a 
useful file management tool. For example, 
when I write a book and it goes through the 
editing process, I use labels to indicate each 
chapter’s status. Yellow means it’s a first draft, 
orange means it’s a second draft, and green 
means it’s final. This color-coding makes it 
possible for me to see a project’s status just 
by looking inside a folder containing its files. 
(Imagine how good I feel when all of a book’s 
chapter folders are green!)

✔ Tips
■ You can only sort a window by labels if 

the Label column is displayed in that 
window. I explain how to customize a list 
view window in Chapter 4.

■ You can change the name associated 
with a label or its color. I tell you how in 
Chapter 8.La
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Figure 6 Select the icon you want to apply a label to.

Figure 7 
Choose a label 
color from the 
bottom of the 
File menu.
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To assign a label to an item
1. In a Finder window, select the icon(s) you 

want to apply a label to (Figure 6).

2. From the File menu, choose the color of 
the label you want to apply (Figure 7).

The name of the icon is enclosed in an 
oval in the color you choose (Figure 8).

✔ Tip
■ In list view, an item’s entire line turns the 

color you chose (Figure 9).

■ You can also assign a label to an item in 
the Info window for the item. I tell you 
more about the Info window later in this 
chapter.

To remove a label from an item
1. In a Finder window, select the icon you 

want to remove a label from.

2. From the File menu, choose the x
beneath Label (Figure 10).

The label is removed.
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Figure 10 
Choosing the 
X under Label 
removes the 
label from 
selected 
icons.

Figure 9 In list view, the label color is applied to the 
entire line for the item.

Figure 8 The color you chose is applied to the icon’s 
name. (I know it doesn’t look red here, but it is.)
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Aliases
An alias (Figure 11) is a pointer to an item. 
You can make an alias of an item and place it 
anywhere on your computer. Then, when you 
need to open the item, just open its alias.

✔ Tips
■ It’s important to remember that an alias 

is not a copy of the item—it’s a pointer. If 
you delete the original item, the alias will 
not open (Figure 12).

■ By putting aliases of frequently used 
items together where you can quickly 
access them—such as on your desktop—
you make the items more accessible 
without actually moving them.

■ The sidebar, Dock, and recent items 
features work with aliases. The sidebar 
and Dock are discussed in Chapters 2
and 8; recent items are discussed a little 
later in this chapter.

■ You can name an alias anything you like, 
as long as you follow the file naming 
guidelines discussed in Chapter 3. An 
alias’s name does not need to include the 
word alias.

■ The icon for an alias looks very much like 
the icon for the original item but includes 
a tiny arrow in the bottom-left corner 
(Figure 11).

■ You can move, copy, rename, open, and 
delete an alias just like any other file.
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Figure 11 The icon for an alias 
looks like the original item’s 
icon but includes a tiny arrow.

Figure 12 If the original for an alias cannot be found, a 
dialog like this appears when you attempt to open it.
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To create an alias
1. Select the item you want to make an alias 

for (Figure 13).

2. Choose File > Make Alias (Figure 13), or 
press $%L.

The alias appears right beneath the 
original item (Figure 15).

Or

Hold down $%o and drag the item for 
which you want to make an alias to a new 
location. The alias appears in the destination 
location.

✔ Tip
■ An alias’s name is selected right after it is 

created (Figure 15). If desired, you can 
immediately type a new name to replace 
the default name.

To find an alias’s original file
1. Select the alias’s icon.

2. Choose File > Show Original (Figure 16),
or press $%R.

A window for the folder in which the 
original resides opens with the original 
item selected.
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Figure 13 
Select the item 
you want to make 
an alias for.

Figure 16 
To fi nd an alias’s 
original, choose 
Show Original from 
the File menu.

Figure 14 
Choose Make 
Alias from the 
File menu.

Figure 15 The alias 
appears with the 
original.



Chapter 7

138

To fix a broken alias
1. Select the alias’s icon.

2. Choose File > Show Original (Figure 16),
or press $%R.

or

Open the alias icon.

A dialog like the one in Figure 12 appears 
if the original cannot be found.

3. Click Fix Alias.

4. Use the Select New Original dialog that 
appears (Figure 17) to locate and select 
the item that you want to use as the 
original for the alias.

5. Click Choose. The item you selected is 
assigned to the alias.

✔ Tips
■ The Select New Original dialog is similar 

to a standard Open dialog, which is 
covered in Chapter 10.

■ If you would prefer to delete a broken 
alias instead of fixing it, click Delete Alias 
in the dialog that appears when you try to 
open it (Figure 12).

■ If an alias is not broken but you want to 
reassign it to a new original anyway, you 
can click the Select New Original button 
in its Info window (Figure 18). I tell you 
more about the Info window later in this 
chapter.
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Figure 17 Use this dialog to select a new original item 
for an alias.

Figure 18 The Info window for an alias 
includes a Select New Original button 
to change the original for an alias.
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Recent Items
Mac OS automatically tracks the things you 
open. It creates submenus of the most 
recently opened items in four categories—
applications, documents, servers, and 
folders—making it quick to open them again.

✔ Tip
■ You can specify how many recent items 

Mac OS X tracks in the Recent Items 
submenu (Figure 19) by setting options 
in the Appearance preferences pane. I 
explain how in Chapter 8.

To open recent items
To open a recently used application, docu-
ment, or server, choose its name from the 
Recent Items submenu under the Apple 
menu (Figure 19).

Or

To open a recently used folder, choose its 
name from the Recent Folders submenu 
under the Go menu (Figure 20).

✔ Tips
■ Recent Items works with aliases, which 

are discussed earlier in this chapter.

■ Working with applications and docu-
ments is discussed in Chapter 10;
working with servers is discussed in 
Chapter 20.

To clear the Recent Items or 
Recent Folders submenu
Choose Apple > Recent Items > Clear Menu 
(Figure 19) or choose Go > Recent Folders > 
Clear Menu (Figure 20).

✔ Tip
■ Clearing the Recent Items or Recent Folders 

submenu does not delete any items.
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Figure 19 
Mac OS tracks the 
most recently used 
applications, docu-
ments, servers, …

Figure 20 
…and folders.
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Quick Look
Mac OS X 10.5’s new Quick Look feature 
makes it possible to see what’s in a folder 
or file without actually opening it. Instead, 
Quick Look shows a preview of the item 
within a resizable Quick Look window 
(Figures 22 through 24).

To view a file with Quick Look
1. In a Finder window, select the item you 

want to view with Quick Look.

2. Click the Quick Look icon on the toolbar.

or

Choose File > Quick Look “Item Name”
(Figure 21), or press $%Y.

The Quick Look window appears as a 
charcoal gray, translucent window that 
displays the item’s icon (Figure 22) or 
contents (Figures 23 and 24).

✔ Tips
■ If you use Quick Look to view a multiple-

page document, you can use a scroll bar 
to view any document page.

■ If iPhoto is installed, you can click the 
Add to iPhoto button in the Quick Look 
window for an image file (Figure 23) to 
add the image to your iPhoto library.
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Figure 21 
The Quick 
Look command 
displays a 
selected fi le or 
folder using the 
new Quick Look 
feature.

Figures 22, 23, & 24 The Quick Look window for a folder (top-right), image fi le (bottom-left), and PDF fi le 
(bottom-right).
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To browse the Finder 
with Quick Look
1. Open a Finder window for the folder you 

want to browse.

2. Click the Quick Look icon on the toolbar.

or

Choose File > Quick Look “Item Name”
(Figure 21) or press $%Y.

The Quick Look window appears.

3. Use standard Finder browsing techniques 
to select the items you want to browse. 
Each time a new item is selected, the 
Quick Look window changes to display its 
icon or contents (Figures 22 through 24).

✔ Tip
■ I tell you more about navigating folders 

and selecting icons in Chapters 2 and 3.

To switch to full screen view
Click the Full Screen button at the bottom 
of a Quick Look window. The screen turns 
black and fills with the Quick View window 
(Figure 25).

✔ Tips
■ A button bar appears in full screen 

view (Figure 25) so you have the same 
options you would have in the Quick 
Look window. 

■ If the button bar disappears, move the 
mouse pointer to display it again.

■ To leave full screen view, click the 
Exit Full Screen button (Figure 25)
or press q.
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Figure 25 In full 
screen view, Quick 
Look’s preview fi lls 
your entire screen.

Add to iPhoto
Exit Full Screen

Close
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To close the Quick Look window
Use one of the following techniques:

◆ Click the Quick Look window’s close 
button (Figures 22 through 24).

◆ Choose File > Close Quick Look (Figure 26).

◆ Press $%Y.

◆ In full-screen view, click the close button 
in the Quick Look window’s button bar 
(Figure 25).

Figure 26 When the Quick Look 
window is open, the Close Quick Look 
command appears on the File menu.
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The Info Window
You can learn more about an item by open-
ing its Info window (Figures 18 and 27
through 30). Depending on the type of icon 
(disk, folder, application, document, alias, 
and so on), the General information in the 
Info window will provide some or all of the 
following:

◆ Kind or type of item.

◆ Size of item or contents (folders and files 
only).

◆ Where item is on disk.

◆ Created date and time.

◆ Modified date and time.

◆ Format of item (disks only).

◆ Capacity of item (disks only).

◆ Available space on item (disks only).

◆ Used space on item (disks only).

◆ Version number or copyright date or both 
(applications only).

◆ Original location on disk (aliases only).

◆ Color label assigned to the item.

◆ Stationery Pad check box (documents 
only) to convert the file into a stationery 
format file, which is like a document 
template.

◆ Locked check box to prevent the file from 
being deleted or overwritten (folders and 
files only).
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Continued on next page…

Figures 27, 28, 29, & 30 The Info window for a hard 
disk (top-left), folder (top-right), application (bottom-
left), and document (bottom-right).
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In addition to the General category of infor-
mation, the Info window offers additional 
categories (Figure 31), depending on the type 
of item. You can click the disclosure triangle 
beside a category heading to display or hide 
the details for the category. Some categories 
you might find in an Info window include:

◆ Spotlight Comments enable you to enter 
searchable comments or keywords for an 
item.

◆ More Info provides additional informa-
tion about the file, including when the 
content was created and modified and 
when the item was last opened.

◆ Name & Extension displays an edit box 
you can use to modify the file name and 
its file name extension. A check box 
enables you to hide the extension in 
Finder windows.

◆ Open with enables you to choose the 
application that should open the item—
and change the default application for 
all items of that type. This category is 
available for documents only.

◆ Preview displays a preview for the item 
if one is available. Otherwise, it simply 
displays the item’s icon.

◆ Languages (not shown in Figure 31) is a 
list of the languages built in to the appli-
cation. This category is available for 
applications only.

◆ Sharing & Permissions enables you to set 
file sharing permissions for the item.

✔ Tip
■ I tell you about using labels earlier in this 

chapter, searching for files with Spotlight 
in Chapter 5, and file permissions in 
Chapter 20.

Continued from previous page.
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Figure 31 Here are all the categories 
of information in the Info window 
for a typical document.
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To open the Info window
1. Select the item for which you want to 

open the Info window (Figure 13).

2. Choose File > Get Info (Figure 32), or 
press $%I.

The Info window for that item appears 
(Figure 29).

To enter Spotlight comments in 
the Info window
1. Open the Info window for the item you 

want to enter comments for (Figure 30).

2. If necessary, click the disclosure triangle 
beside Spotlight Comments near the top 
of the window. The window expands to 
show the Spotlight Comments box.

3. Type your comments into the Spotlight 
Comments box (Figure 33). They are 
automatically saved.

✔ Tip
■ As discussed in Chapter 4, you can set a 

window’s list view to display comments 
entered in the Info window.

To lock an application or 
document
1. Open the Info window for the item 

you want to lock (Figures 18 and 27
through 30).

2. Turn on the Locked check box.

✔ Tip
■ Locked items cannot be deleted or over-

written. They can, however, be moved.
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Figure 32 
Choose Get 
Info from the 
File menu.

Figure 33 Enter comments for an item 
in the Spotlight Comments section.
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Compressing Files 
& Folders
Mac OS X’s file compression feature enables 
you to create compressed copies of items 
sometimes called archived files or archives.
Compressed files take up less space on disk 
than regular files. You may find them useful 
for backing up files or for sending files to 
others over a network or via e-mail.

✔ Tips
■ In previous versions of Mac OS X, the 

compression feature was known as the 
archive feature.

■ The compression feature uses ZIP format 
compression, which was originally devel-
oped as a DOS and Windows PC format. 
As a result, document archives created 
with this feature are fully compatible with 
DOS and Windows PCs.
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Figure 34 To compress an item, begin by selecting 
its icon.
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To compress a file or folder
1. Select the item you want to compress 

(Figure 34).

2. Choose File > Compress “Item Name”
(Figure 35).

3. Wait while your computer creates the 
archive. While it works, a Copy status 
dialog appears (Figure 36). When the 
dialog disappears, the archive file appears 
in the same location as the original as a 
.zip file (Figure 37).

✔ Tips
■ In previous versions of Mac OS X, you 

compressed files with the Create Archive 
command on the File menu. This is the 
same command with a different name.

■ You can compress multiple items at once. 
Select the items, then choose File > 
Compress n Items (where n is the num-
ber of selected items). When the archive 
appears, it will be named Archive.zip.

To open a compressed file
Double-click the compressed file. The com-
pressed file’s contents are uncompressed and 
appear in the same window as the com-
pressed file.
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Figure 36 A copy progress dialog like this one appears 
when you compress an item.

Figure 37 
The compressed 
fi le appears with 
the original.

Figure 35 
Choose the 
Compress com-
mand from the 
File menu.
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Undoing Finder Actions
The Mac OS X Finder includes limited sup-
port for the Undo command, which can 
reverse the most recently completed action. 
Say, for example, that you move a file from 
one folder to another folder. If you immedi-
ately change your mind, you can choose 
Edit > Undo Move (Figure 38) to put the file 
back where it was.

✔ Tips
■ Don’t depend on the Undo command. 

Unfortunately, it isn’t available for all 
actions (Figure 39).

■ The exact wording of the Undo command 
varies depending on the action and the 
item it was performed on. In Figure 38,
for example, the command is Undo Move 
of “Letter to John” because the last action 
was to move a document icon named 
Letter to John.

■ The Undo command is also available 
(and generally more reliable) in most Mac 
OS applications. You’ll usually find it at 
the top of the Edit menu.

To undo an action
Immediately after performing an action, 
choose Edit > Undo “action description”
(Figure 38), or press $%Z. The action is 
reversed.

To redo an action
Immediately after undoing an action, choose 
Edit > Redo “action description” (Figure 40).
The action is redone—as if you never used 
the Undo command.

✔ Tip
■ Think of the Redo command as the 

Undo-Undo command since it undoes 
the Undo command.
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Figure 38 The Undo command enables you 
to undo the last action you performed.

Figure 39 
If an action cannot be 
undone, the words 
Can’t Undo will ap-
pear at the top of the 
menu in gray.

Figure 40 The Redo command undoes the 
Undo command.


