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Filters are one of those features that everybody uses on a reg-

ular basis. I know some people whose only use for Photoshop 

is to open an image, apply a filter, and then click Save and 

Print. Filters make life easy. I always encourage people to 

experiment with filters. I tell them to play with the filters.  

I advise them, when faced with a dialog box for a filter, to enter  

a few different values and study the results of each. Enter  

negative values and see what happens. I also tell them to 

press the modifier keys—Option and Command (Alt and Ctrl)—

to see if the effect of the filter is altered. Millions of happy 

accidents are waiting to happen!

Some filters have specific purposes. However, the effect of 

these filters can be applied to many other situations. All the 

filters have specific names. Pay no attention to the name of 

a filter. Understanding what a particular filter can do will open 

up possibilities for other uses beyond what its name implies. 

Sometimes a slight modification or combination of filters will 

provide solutions to problems that have nothing to do with what 

the filters were originally designed for. It is this creative use of 

filters that I discuss in the book. 

In this document I’ll cover a couple of the filters in greater 

detail than what I presented in the body of the book.

Filters

What Filters Are All About

PDF
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Figure 2 The Convert for 
Smart Filters option in the 
Filter menu.

Smart Filters
Using multiple filters to produce effects is 

something I do often. CS3 introduced a 

new feature called Smart Filters that makes 

the use of filters a breeze. It allows you the 

freedom to experiment with multiple filters 

without permanently affecting the image. 

Smart Filters lets you apply as many filters as 

you want. The order in which the filters are 

applied can be changed. The settings can be 

altered. Filters can be deleted. All the filter 

functions can be performed without ever 

altering the image. 

I used to run Actions when I experimented 

with filters. That way I had a record of what 

filters I used and what settings were applied. 

Smart Filters has changed the entire dynamic 

of working with filters. You can change the 

order of filters and even go back and change 

the amount! Let’s study this gem of a feature.

Figure 1 shows an image that was opened 

in Photoshop. Selecting Convert for Smart 

Filters from the Filter menu (Figure 2) con-

verts the image to a layer. This layer has an 

icon attached to it that distinguishes it as a 

Smart Filter layer (Figure 3).

Figure 1 This image will be converted for Smart Filters.

Figure 3 The image became a Smart 
Filter layer.
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In Figure 4 a combination of filters has been 

applied to the image. Note that the list of  

filters is displayed in a similar fashion as are 

layer styles when they are applied to a layer.

In Figure 5 the filters Difference Clouds and 

Find Edges have been turned off. As you can 

see, the image starts to return a recognizable 

state. In Figure 6 the settings for the Crystallize 

filter have been modified.

Figure 4 Multiple filters have been applied to the image.

Figure 5 Two of the filters were turned off.

Figure 6 The Crystallize filter was modified.
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The small white box between the layer and 

the list of filters is, as I am sure you have 

guessed by now, a mask. Figure 7 shows that 

the Difference Clouds filter has been turned 

on again, but black has been added to the 

mask, making the effects of the filters visible 

only through the white of the mask.

In Figure 8 all the filters have been turned 

off, showing the untouched image.

This is a great new feature: I don’t know 

how we did without it for so long.

Figure 7 The mask hides portions of the filter effects.

Figure 8 The filters are turned off, showing the unfiltered image.
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Star Fields, 
Snowflakes,  
and Rain
I drew attention to the speckled effect on the 

headlamp in Chapter 6, “Red Truck.” I men-

tioned the use of this effect for star fields, 

snow, and rain. That effect was created with 

a combination of a few different filters. The 

result of these filters can be applied to many 

situations. I’ll show you the three effects just 

mentioned.

In Figure 9 you see a radial gradient. This 

gradient will serve as the backdrop to see the 

effect of the filters.

A new layer is created and filled with black 

(Figure 10). In this black layer the first filter, 

Add Noise, is applied. A large Amount is 

entered to produce a lot of noise, as shown 

in Figure 11.

Figure 9 This gradient will serve as a backdrop for the 
effects of snow and rain.

Figure 10 A new layer was filled with black.

Figure 11 The Add Noise filter with a high Amount.
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To introduce some gray values to the noise, 

the Blur More filter was applied. 

Now here’s the trick to make the noise 

behave the way you want it to so that you 

can create star fields or snowflakes—Levels. 

With the Levels adjustment (Figure 12) the 

dark value (black) slider is moved almost 

entirely to the right. The highlight slider 

(white) is moved slightly to the left, and the 

mid-tone slider (gray) is balanced between 

the two. This adjustment turns the noise 

into a star field.

Changing the mode of the layer with the 

star field to Screen allows only the values 

lighter than the values underneath to show 

through. This creates the effect of falling 

snow, as shown in Figure 13.

I also mentioned rain at the beginning of 

this filter discussion. To turn your star field/

snowflakes into rain, you need to apply one 

more filter—Motion Blur. Controlling the 

Angle and Distance gives you very realistic 

looking rain, as shown in Figure 14.

Figure 12 The effect of Levels on the noise produces a star field.

Figure 13 Changing the mode for the layer with the noise allows 
the gradient beneath it to show through, creating the look of 
snowflakes.

Figure 14 The effect of the Motion Blur filter on the 
noise creates the look of falling rain.
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Displace
During my years lecturing around the world, 

I have heard many complaints about how 

Photoshop lacks the ability to bend or distort 

images along user-defined curves. Adobe has 

introduced a few features that address those 

requests. Liquify made its debut a few ver-

sions ago. It opened the door for all kinds of 

twists and turns, some of which I discuss in 

the book for making wood. 

CS3 introduced Warp (Edit > Transform > 

Warp). Warp is a wonderful addition to the 

gang of exquisite tools. I also discuss Warp 

a few times in the book. However, it just so 

happens that the ability to bend things in a 

controlled fashion has existed in Photoshop 

for a long time—even before layers! It comes 

in the form of a filter that simply needs to be 

understood—the Displace filter (Figure 15).  

I use this filter many times in the book. 

Here I’ll give you a detailed explanation  

of how it works.

Using the Displace 
Filter
Figure 16 shows the dialog box that pops up 

when you invoke the filter. Looking at it you 

understand why very few people know what 

to do with it. Nothing in it tells you what it 

does. To make matters worse, you decide  

to experiment so you enter a couple of  

values and then click OK to see what hap-

pens; as a result, another dialog box pops 

up (Figure 17)! Now what?

What you’re about to explore will come in 

handy many, many times in the future. You’ll 

to say to yourself, “Why didn’t I know this 

when I had to work on the job for so and so?”

The Displace filter works with two files. 

One is the image you want to distort, and 

the other image is the one used to distort it. 

Figure 15 The Displace filter in the menu.

Figure 16 The Displace filter dialog box.

Figure 17 The second dialog box that opens when you click OK 
in the Displace dialog box is more confusing than the first.
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This second image is called a Displacement 

Map. The filter uses the luminosity values 

(lights and darks) of the Displacement 

Map to distort the image. Where there is 

a 50% gray value or neutral density in the 

Displacement Map there will be no displace-

ment (distortion). Any values lighter than 

50% gray will distort the pixels of an image 

up and to the left. Any values that are darker 

than 50% gray will distort the pixels of an 

image down and to the right. 

Keeping this in mind, you can create very 

elaborate Displacement Maps to distort 

images in every variety imaginable. I resort 

to using the Displace filter many times dur-

ing the creation of my paintings. 

Let’s study this concept a little further. 

Figure 18 shows a series of vertical stripes  

of varying colors. The stripes also have 

numbers inside them. This is the image  

I’ll use to distort using Displace. 

In Figure 19 is a gray field with a set of 

white and black horizontal lines followed by 

two different horizontal gradients composed 

of blacks and whites. This image will be used 

as the Displacement Map. 

Figure 18 This image will help you understand 
the Displace filter’s function.

Figure 19 This image will serve as the 
Displacement Map for the image in Figure 18.
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The filter is selected from the Filter menu 

(Filter > Distort > Displace). The default 

settings of 10 are used for both the Horizontal 

and Vertical Scales. I’ll leave all the settings as 

they are for now. I explain them later.

As discussed earlier, clicking OK brings up 

the Open window where you are asked to 

choose a Displacement Map. The map in 

Figure 19 was chosen.

Clicking Open makes the filter perform 

its function. In Figure 20 you see that the 

stripes have been distorted. In Figure 21 

I’ve placed the Displacement Map over the 

image so that you can study the effect that 

each of the values had over the image. The 

white stripe pushed things up and to the 

left, hiding the number two. The black stripe 

pushed things in the opposite direction, 

forcing the number ten to be hidden.

The curviness of the two lower transitions is 

due to the soft transition of tones. The white 

and black stripes had hard edges, making the 

transition sharp. The gradients on the two 

lower bars caused the distortions to be soft 

based on the value of the grays in between. 

The areas that were 50% gray, such as the 

area over the far-left black, vertical stripe, 

were left untouched.

Figure 21 Superimposing the Displacement Map 
over the image, you can see how the values in 
the map have distorted the image.

Figure 20 The effect of the Displace filter on the image.
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As I mentioned earlier, the default settings 

in the dialog box are set to 10 for both the 

Horizontal and Vertical Scales. Obviously, 

the higher the number, the more exaggerated 

the distortion. You can set the vales indepen-

dently. In Figure 22 I’ve set a high value for 

the Horizontal and set the Vertical to zero. 

You can see the result in Figure 23 where the 

stripes have been pushed to the left and right, 

leaving their vertical position intact. Figure 22 The Displace dialog box where 
only a Horizontal value has been entered.

Figure 23 The effect of the horizontal displacement.
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The opposite occurs when I switch the set-

tings, as shown in Figure 24. This time the 

movement of the stripes is vertical, which is 

visible in the numbers in Figure 25, but the 

actual stripes remain straight up and down.

The two lower portions of the Displace dia-

log box control how the displacement file 

will be used. I have never concerned myself 

with these two settings. They make adjust-

ments to the Displacement Map to control 

how it relates to the image being displaced. 

If the Displacement Map is smaller than the 

image being displaced, you can choose to 

scale it up or tile it. You can also decide what 

you want to do with the undefined areas. 

Every time I’ve used this filter perfect regis-

tration has been crucial. I want total control 

over where something will be distorted. To 

get this control, my Displacement Map is 

always the exact same dimensions and reso-

lution as the image being displaced.

Figure 24 The Displace dialog box where 
only a Vertical value has been entered.

Figure 25 The effect of the vertical displacement.
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Example of a necessary 
displacement
Let’s look at a situation where displacement 

is necessary. Figure 26 shows a saltshaker 

sitting on a white surface. A light source 

behind the shaker causes it to cast the long 

shadow across the front. It looks fine. 

In Figure 27 the same saltshaker sits on a 

sandy surface with ripples in the sand. Now 

it looks wrong! The shadow needs to follow 

the contours of the ripples in the sand. This 

is where the Displace filter comes in. 

To enhance the effect of the filter, I increased 

the contrast for the image that will be used 

as the Displacement Map. Figure 28 shows 

the file sand_dark.psd where the lights and 

darks are more pronounced.

In the file to be distorted (shaker), the filter 

is chosen from the menu (Filter > Distort).

Figure 26 A lonely saltshaker casts a long shadow.

Figure 27 The saltshaker on a surface of rippling sand.

Figure 28 The contrast is increased for the original file for the  
sandy surface.
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The Displacement Map is chosen, and the 

shadow is distorted, as shown in Figure 29.

Knowing how shadows behave, you know 

this shadow has to soften in intensity as it 

travels over the mounds of sand that face 

away from the shaker. In Figure 30 a layer 

mask has been added where black tones have 

been placed to hide those portions of the 

shadow where needed.

Figure 29 The effect of the displacement makes the shadow 
curve over the ripples in the sand.

Figure 30 A layer mask is applied to soften the shadow in the 
areas where it should not appear.
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Examples of Displace 
in my paintings
I mentioned using Displace in the course of 

creating my paintings. Let’s look at a couple 

of subtle yet obvious places where I used this 

filter. Let’s go back in time to a painting I did 

in 1999—“The Rendez-vous” (Figure 31).

Figure 32 shows a zoomed in view of the 

detail of the awning above the door. The 

bottom flap with the word COFFEES on  

it has been rippled by the wrinkles in the 

canvas. In Figure 33 the awning appears 

without the text in it.

Figure 31 The painting “Rendez-vous.”

Figure 32 The awning of the café where the word 
COFFEES has been displaced.

Figure 33 The awning without the words in place.
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Figure 34 shows the word COFFEES as it 

was typed using the Type Tool.

The text was rasterized (Layer > Rasterize > 

Type). Using the various transform tools 

(Edit > Transform), like Scale, Skew, and 

Distort, the individual letters were altered 

to simulate a three-dimensional view 

(Figure 35).

In Figure 36 the Displacement Map was 

used to distort the letters into what you see 

in Figure 37.

Figure 34 The word COFFEES is straight text created with the Text Tool.

Figure 35 The type for the word COFFEES has been rasterized and 
distorted.

Figure 36 The Displacement Map for the word COFFEES.

Figure 37 The word COFFEES displaced.
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Vanishing Point
Vanishing Point was introduced to the CS 

versions of Photoshop and suddenly the third 

dimension came to life! Not that Photoshop 

has become a 3D application. In fact, the 

inclusion of a 3D layer in CS3 does not mean 

you can create 3D objects. It means you can 

import 3D objects from 3D applications and 

move them around in 3D space, but the rest 

of Photoshop is still two dimensional. 

What Vanishing Point does is let you estab-

lish the vanishing point of an image and 

then move objects within that 3D space. It 

does not add sides to an object, but it will 

distort that object to conform to the angles 

of the vanishing lines. Chapter 1, “The 

Workflow,” in the book provides an explana-

tion of the concepts behind 3D space and 

vanishing lines.

Using Vanishing Point 
in “Damen” 
I‘ll expand on what was covered in Chapter 9,  

“Damen,” using the same example. Figure 38  

shows the platform on which the viewer is 

standing in the painting “Damen.” I’ll pick 

up where I left off in the book and cover the 

other parts of the Vanishing Point filter.

In Figure 39 you see the lines that were 

drawn to outline the actual platform area. 

The wooden texture has already been dis-

torted into the platform, as outlined in 

Chapter 9.

Figure 38 The platform on the left of the painting “Damen.”

Figure 39 The guide for the platform with the texture distorted into 
place.
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It would be easy to simply select the area of 

the wood, copy it, reduce the size, and place it 

farther back in space. However, doing it this 

way, the detail of the grain started to blur as it 

got smaller and smaller with each distortion 

and copy. The beauty of Vanishing Point is 

that it gives me the ability to copy the planks 

as far back as I want without losing detail.

Let’s take a look at the Vanishing Point filter  

(Figure 40).

The first tool available, besides the view tools, 

is the Create Plane Tool. With this tool you 

trace the existing perspective plane in your 

image. In the case of my painting I traced the 

black lined guide that denoted the shape of 

the platform. In Figure 41 you see the tool 

being dragged along the right side of the 

guide. It is displayed as a blue line, and the 

cursor becomes a target box. 

Figure 40 The Vanishing Point 
filter in the Filter menu.

Figure 41 The Vanishing Point dialog box with one of the plane sides 
being created.
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Each time you click at a specific point, a new  

line pulls out to follow the next edge, as 

shown in Figure 42. 

When you have completely surrounded a 

shape, a blue grid appears, like the one you 

see in Figure 43. If you get a red outline, 

like the one in Figure 44, you have created 

a shape that defies the laws of perspec-

tive. Remember the lesson in Chapter 1: 

Perspective is part of nature, and you 

shouldn’t fool around with nature.

Figure 43 The Vanishing Point grid that denotes a perspective plane.

Figure 44 If the plane has a red outline, the plane is incorrect.

Figure 42 A second plane side being created.
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To correct a red outline, all you have to do is 

adjust any one of the four corners until you 

get the blue grid.

When the grid is complete you can pull out 

other parts of the room or space. Pressing 

the Command (Ctrl) key, grabbing the 

small, white handles on the side edge of 

the grid, and dragging will produce these 

shapes. These shapes will automatically 

conform to the perspective based on the 

vanishing point you established by the initial 

grid you created. Figure 45 shows the left 

sidewall exposed. Figure 46 shows the far wall.

For the platform, I only needed the ground 

plane. Switching to the Marquee Tool in 

the Vanishing Point filters dialog box, I was 

ready to select the planks to duplicate them 

in 3D space. Note in Figure 47 that since I 

am selecting within a perspective plane the 

marquee is conforming to the shape of  

that plane.

Figure 46 The plane for the far wall at the back of the scene.

Figure 47 The selection marquee conforms to the shape of the 3D plane.

Figure 45 The plane for the wall on the left side of the scene.
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Pressing the Option (Alt) key to make a copy, 

the platform was duplicated and shifted back 

along the expanse of the platform (Figure 48). 

To save time, when I had gotten about half-

way to the rear, I reselected the entire area 

(Figure 49) and duplicated it. When the job 

was complete, I clicked OK. The completed 

platform is shown in Figure 50.

Figure 49 A larger area of the wooden planks was selected within the 
perspective plane.

Figure 50 The completed platform.

Figure 48 The area of the wooden planks was selected within the 
perspective plane.
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