CHAPTER 1

Getting Started

Adobe’s new Creative Suite 2 Premium (Photoshop CS2, Illustrator CS2, InDesign CS2, GoLive CS2, and Acrobat 7.0 Professional) has significantly changed the industry in terms of graphic-design software. Now designers are able to purchase all the software they might need for print, Web, and PDF publishing in one box. Although there are hundreds of thousands of GoLive users around the world, many new users are being introduced to the GoLive for the very first time through the Creative Suite. GoLive is an incredibly powerful and fun Web authoring application. GoLive on its own is pretty impressive, but combining it with the rest of the Creative Suite is truly sweet!

In this second edition of the book, we’ve done our very best to write something that will teach beginners the basics and show seasoned users some special tips. We’ll even wow the most experienced users with power tips that will save them time and enable them to be more creative as they build sites with GoLive.

This first chapter introduces the interface, shows you how to optimize GoLive for optimum performance and productivity, and even teaches the pros a few cool tips. Let’s get started!
CHAPTER ONE

GETTING STARTED

TIP 1 Getting Started with the Welcome Screen

Welcome to GoLive CS2! To kick things off, launch GoLive, and you’ll see the Welcome screen which is similar to the Welcome screens in the other Creative Suite applications. The Welcome screen gives you several easy ways to get started with the software, so let’s start at the top and work our way down (Figure 1).

Figure 1 The Welcome screen opens when you launch GoLive and helps get you started with common tasks.

There are three important options in the top portion of the Welcome screen: What’s New in GoLive, Tutorials, and Cool Extras. Clicking any of these links loads a Web page about that topic in your default Web browser.

Clicking the New Document button invokes the New Document window where you can create individual pages of various file types, begin an entirely new site, base a site on a template, or choose from a list of Favorites. The New Document screen is explained in detail in Tip 14.

If you click the Open button in the Welcome screen you’ll see a standard Open dialog where you can locate any file GoLive can edit and open the file. If you click and hold the Open icon you’ll see a list of the most recently used files in the pull-down menu. This is a really handy shortcut to sites and pages you edit frequently.

Picking Up Where You Left Off

To open all the sites and pages you had open the last time you quit GoLive, press the Shift key and click the Close button in the Welcome screen or choose Last Session from the Open menu in the Welcome Screen. Voila!

Turn It Off!

You’ll probably like the Welcome screen at first, but after a while it might start to annoy you. To turn it off, just uncheck the Show This Dialog at Startup option in the bottom left corner. You can always turn it on again in the General Preferences in the At Launch pull-down or open it from the Help menu.

Getting Started
**TIP 2**

Customizing Keyboard Shortcuts

We strongly believe that software should be flexible and allow the user to customize as much as possible. One practical way that GoLive allows you to make the software adapt to how you work is through customizable keyboard shortcuts. If there’s an obscure menu command you happen to use frequently, there’s no need to send a feature request to Adobe to change it. Open the Keyboard Shortcuts Editor from Edit menu to assign a custom keyboard shortcut (Figure 2).

![Figure 2 The Keyboard Shortcuts Editor lets you add, remove, and reassign custom keyboard shortcuts for the menu commands you use most often.](image)

Notice at the very top of the dialog there is a default set in place called GoLive Factory Defaults. To create your own set, just click the New Set... button, name the set, and click OK.

Now select the command in the menu listing that you want to customize and type the new shortcut in the Press New Shortcut field at the bottom of the dialog. If you assign a menu command a keyboard shortcut that is already assigned to another command, you’ll see a warning at the bottom of the dialog that tells you what the shortcut is currently assigned to. In most cases you’ll want to find a unique shortcut that isn’t already taken, but if you want to make the change anyway, click the Assign button, and the shortcut will be removed from the old command and assigned to the new command.

**Returning to Default Shortcuts**

If a friend or coworker ever needs to use GoLive on your computer, and your custom keyboard shortcuts are confusing them, just temporarily switch back to the GoLive Factory Default set. You can always switch back to your custom set.

**Sharing Shortcuts**

If you create a great set of keyboard shortcuts you’ll want to make them the same on every computer you work on and maybe even share them with coworkers. Copy the shortcuts setting file from User/Library/Preferences/Adobe/GoLive/Settings8/Shortcuts on Mac or Documents and Settings/User/Application Data/Adobe/Adobe GoLive/Settings8/Shortcuts on Windows to the same location on the other machine.
Before you start working in GoLive CS, we recommend you familiarize yourself with the application preferences. You’ll only change a few things now, but when you need to make further adjustments in the future, you’ll know where to look. Open the preferences by selecting Adobe GoLive > Preferences… on the Mac or Edit > Preferences… on Windows (Figure 3).

In the General section are At Launch options. You could have GoLive create a new blank page every time you launch the application, but you’ll probably just want to set it to Do Nothing and open the sites you need to work on. If you turned off the Welcome screen as described in Tip 1, you can turn it back on here.

Another set of preferences to become familiar with is under the Modules heading on the left. You can enable and disable features of GoLive by clicking the On/Off checkbox and restarting the application. Disabling features in the application can speed up launch times and reduce the amount of RAM GoLive requires.

Finally, you’ll need to edit the browser preview options. Select Browsers on the left and click the Find All button to let GoLive scour your drives for any Web browsers it can find; or click the Add button to select a browser manually. The browsers listed are added to the File > Preview In menu. If you enable a checkbox next to a browser name, that browser will be launched when you click the Preview in Browser button. If you check more than one, then clicking the button opens multiple browsers at the same time.
The Objects palette contains both tools and objects that you use when working on a Web page or a Web site. The gray icons at the top of the Objects palette represent tools that help you quickly select and move objects.

Click and hold the color icon below the tools to reveal a list of object categories. Select a category in the list, and all the objects in that category are displayed below. To place an object, drag it from the Objects palette onto a Web page or into a Web site. The default Object categories are seen in Figure 4.

- **Basic**: Basic page elements such as tables, images, and multimedia files (see Chapter 3).
- **Smart**: Advanced page elements such as native Adobe image file formats (see Chapter 7) and JavaScript Actions (see Chapter 9).
- **CSS**: CSS-based page elements such as multi-column boxes (see Chapter 3).
- **Forms**: All the form elements you’ll ever need (see Chapter 9).

(continued on next page)

Figure 4 The Objects palette stores everything you might add to a page or site.

TIP 4: Using the Objects Palette
Configuring for Compliance

If you need to target a specific W3C code specification, such as HTML 3.2, HTML 4 Strict, or XHTML 1.1, use the Configure submenu in the bottom right corner of the Objects palette to limit the available objects and help ensure your source code is compliant.

• **Head**: Web page head items such as keywords and other meta tags (see Tip 39).

• **Frames**: iFrames, frames, and pre-built framesets are stored here (see Chapter 4).

• **Site**: Objects you’d add to the site window such as blank pages, email addresses, and folders (see Chapter 2).

• **Diagram**: Dozens of different objects you might use to create a site map with the Diagram feature (see Chapter 10).

• **QuickTime**: 20 different multimedia formats you can use to create interactive QuickTime movies.

• **SMIL**: Synchronized Multimedia Integration Language. Objects used to create interactive, multimedia presentations.
Introducing the Toolbar

New in this version of GoLive is a small but extremely useful set of tools located in the top portion of the Objects palette. These tools make selecting, moving and drawing objects easier than ever before. Click on a tool to use it, or press its associated keyboard shortcut to activate it. The shortcut is shown in parenthesis at the right of the Tool Tip that appears when you hover your mouse pointer over the tool.

Let’s explore the six new tools as shown in Figure 5. The Standard Selection tool is used for selecting text, while the Layer Selection tool makes grabbing and moving CSS layers a breeze. You can now easily draw layers anywhere on your page using the Layer tool and then pick up and apply colors with the Eyedropper tool. Use the Hand tool to pan around the page and Zoom tool to zoom in on page objects.

Figure 5 The six new tools in GoLive CS are the Standard Selection tool, the Layer Selection tool, the Layer tool, the Eyedropper tool, the Hand tool, and the Zoom tool.

For greater detail on how to use any of these fabulous new tools, have a look in Chapter 3.
The Inspector palette in GoLive is where you edit and customize selected objects (Figure 6). The cool thing about the Inspector palette is that it’s context-sensitive and changes depending on what is selected. For example, if you select an HTML table, you’ll see options for adjusting rows, columns, and borders, but if you select a page in the Site window, you’ll see options for adjusting the filename and page title.

When there are too many options to fit in the Inspector palette, the settings are distributed across multiple tabs in the palette, as seen in Figure 6. If you’re looking for a setting in the Inspector, but can’t find it, make sure to look in the other tabs. If you’re not sure you’re inspecting the right object, just look in the bottom left corner of the palette where it shows the name of the Inspector, such as Image, Text, or Table.
TIP 7: Managing Palettes

GoLive CS2 lets you stash palettes on the left and right edges of your monitor to save precious screen real estate. We really like the Adobe palettes, but let’s face it—you want to look at documents, not a clutter of palettes. To stash a palette, grab its tab and drag it to the left or right edge of the monitor (Figure 7a).

Click the tab of a stashed palette, and it slides into view. Click the tab again, and it slides back to its stashed position. To stash more than one palette together in a group, just drag another palette by its tab into a stashed palette. To adjust the height of a stashed palette, click its bottom edge and slide it up or down (Figure 7b).

(continued on next page)

Stashing and Unstashing All Palettes

No doubt you’ll really like the way GoLive CS2 stashes palettes to maximize your usable screen real estate. But opening and closing lots of palettes can still be tedious. A cool power user trick is to Option/Alt-Click on a stashed palette to open or close all stashed palettes simultaneously.

TIP 7: Managing Palettes
Rearranging Palette Tabs

This might not seem like a big deal, but if you’ve used Adobe applications as long as we have, you’ll appreciate the following attention to detail: GoLive lets you rearrange palettes that are grouped together without having to ungroup them first! That’s correct, you can grab a palette tab and move it to the left or right of any other tab in the group until you have it situated just how you like it.

Note

Mac OS X users should note that it’s not possible to stash palettes on the same monitor edge as the OS X dock.

GoLive CS2 also has docked palettes that match the behavior of other Adobe applications, including Photoshop, Illustrator, and InDesign. To dock a palette, grab its tab and hold it over the bottom edge of another palette until you see a blue line appear and then let go (Figure 7c). Now when you move the top palette, any palettes docked along with it will move, too.

Docking groups of palettes top to bottom is a great way to manage your palettes, and it makes it easy to move them all around at one time. The problem with docking palettes is that if you dock too many tall ones, the lower ones can get lost off the bottom of the screen. To remedy that problem, click the triangle to the left of the palette names to twirl open or close a palette set (Figure 7d).

Getting Started
TIP 8
Finding Palettes

We’ve shown how to take charge of your palettes by stashing, docking, and twirling them, but let’s not forget an even more fundamental function: finding them. Where are the rest of the palettes hiding? They’re in the Window menu, of course! Simply choose Window and then select the name of the palette you want to open from the list (Figure 8).

![Figure 8 There’s a plethora of palettes in the Window menu.](image)

Notice that plenty of palettes have keyboard shortcuts associated with them, so when you become familiar with which palettes are used for which tasks, you’ll be able to invoke your favorite palette by pressing its keyboard shortcut.

Also nested in the Window menu are options for Workspaces (see Tip 9) and for Cascade and Tile. Choose Window > Cascade and Tile > Cascade to place all open Windows in a neat stack; choosing Window > Cascade and Tile > Tile Horizontally (or Vertically) lines all of the open windows up next to one another.

Alphabetical Order

The Window menu in GoLive CS2 is sorted alphabetically like the rest of the Creative Suite applications. The only exceptions are that toolbars are grouped at the top, open windows are listed at the bottom, and palettes for Site, Swatches, and QuickTime are grouped into submenus. This alphabetical listing makes it so much easier to find those missing palettes and seldom-used features.
After you have set up your GoLive palettes exactly as you like, you can save the workspace so that you may revert to it at any time. This is extremely helpful if you find that after a work session you’ve got palettes strewn all over the place. Choose Window > Workspaces > Save Workspace and then give your workspace a name (Figure 9a).

Go ahead and get as messy as you’d like with your palettes. To tidy up the workspace again, simply choose Window > Workspace, select the name of your saved workspace from the list, and then watch as all the palettes jump back into position (Figure 9b).

There’s more to workspaces than simply creating or using one. To go back to the default palette location, choose Window > Workspace > Default Workspace. To remove a workspace, Choose Window > Workspace > Manage Workspaces and then create, delete, or rename a workspace.

TIP 9  Customizing the Workspace

Workspace Shortcuts
In Tip 2 we explained how to create keyboard shortcuts for menu items in GoLive CS2. Did you know that you can create a shortcut for your workspace? Simply create your workspace and then follow the directions in Tip 2 to assign it a keyboard shortcut. From then on, one press on the keyboard will put your workspace back in order. If only housework were so simple.
Every now and again you may be unsure about how to accomplish a specific task in GoLive CS2. Adobe Help Center to the rescue. GoLive CS2, like all the applications in the Adobe Creative Suite 2.0, includes a fully searchable help system that is installed by default and accessible from the Help menu. Choose Help > GoLive Help, and the GoLive help system is launched in the Adobe Help Center (Figure 10).

A common misconception is that you need to be online in order to access the Adobe Help Center. It’s not true. The pages themselves are local HTML files that are rendered in the Help Center window.

The fastest way to find help on a specific topic is to use the Search field in the upper right corner and choose from the search results, which are ranked according to relevance. You can also browse the help files in the Contents tab or alphabetically through the Index tab. Click on any of the search results or help listings in the left pane to load the corresponding information into the right pane. You can also use the navigation links at the bottom to go to the next or previous related topic.

**PDF User Guides**

What if you’d like to print a part or even all of the User Guide? Your best bet would be to print from the included PDF version of the User Guide, which can be found on the installation CDs that came with your purchase of GoLive or the Creative Suite.
The new Adobe Help Center is easy to use and full of helpful resources, and to make it easier to access common pages you can use the bookmark feature to remember information you access frequently. Previous versions of GoLive used a Web browser to display its Help files, but it was difficult to bookmark pages for frequent access. It's now a piece of cake in the Help Center.

Click the Bookmark icon in the Help Center toolbar to bookmark the current page. Unfortunately, you can’t organize bookmarks into folders or groups, so we suggest using a prefix that corresponds to the application help you’re bookmarking. For example, if you bookmark a page for GoLive, the bookmark name should start with GL. For Photoshop you could use PS, and so on (Figure 11).

Also notice at the bottom of the Bookmarks section that you can delete, rename, and even change the order of the bookmarks you create. This makes it easy to organize your bookmarks over time.
Adobe offers free phone support to registered users for all installation, crashing, and bug problems for the life of the current version of GoLive. However, if you have “How To” questions or cross-application workflow issues, you might consider the new Adobe Expert Support programs. You even get toll-free phone numbers, unlimited calls, and extended support hours.

If you use Adobe Expert Support, you can click on Support Plan Details in the left pane, store your account information in the Help Center, and even submit support requests via the Internet. Expert Support plans last one year, and the Help Center will remind you when your plan is about to expire so you don’t miss out on the help you need (Figure 12).

![Adobe® Expert Support](image)

**Figure 12** You can store your Expert Support plan details in the Help Center for easy access from GoLive or any other CS2 application.

Though the Expert Support program is pretty cool, we realize that some of your favorite technical support experts very well may be your coworkers, friends, family members, or even Web sites. If that’s the case, click the More Resources button at the top of the Help Center window and enter your support-related contacts in the Personal Contacts section. Also make sure you check out the Online Resources category, which includes hyperlinks to Support options, Adobe User-to-User Forums, Tips and Tutorials, and various Training options.

**TIP 12: Accessing Expert Support from the Help Center**
Update Manager Preferences

You can set the Adobe Updater to automatically check for updates on a monthly basis or check for updates manually. Just toggle the checkbox in the upper left corner of the Update window according to your preference.

TIP 13 Updating Software Automatically

To ensure you have the most recent version of GoLive, use the Update feature built into the Help menu (Figure 13a).

Figure 13a From the Help menu, choose Updates to check for any new patches or updates.

If you already have the latest version, you’ll see a dialog box stating that there are no updates available. If you do need an update, you’ll get a dialog box showing the name of the update and asking if you’d like to download it. You can then download and install the update (Figure 13b).

Figure 13b Use the Update Manager to download and install new GoLive updates.

If you’re not sure which version of GoLive you’re using, select Help > About GoLive... on Windows or GoLive > About GoLive... on Mac, and the exact version of GoLive will appear in the upper left portion of the About screen.

Getting Started