Adobe® CS4
On Demand
Sampler

Compliments of InformIT

informIT.com
Adobe® CS4
On Demand
Sampler

A collection of excerpts from
titles by Que Publishing
Many of the designations used by manufacturers and sellers to distinguish their products are claimed as trademarks. Where those designations appear in this book, and Que Publishing was aware of a trademark claim, the designations have been printed with initial capital letters or in all capitals.

The authors and publisher have taken care in the preparation of this book, but make no expressed or implied warranty of any kind and assume no responsibility for errors or omissions. No liability is assumed for incidental or consequential damages in connection with or arising out of the use of the information or programs contained herein.

VISIT QUE PUBLISHING ON THE WEB:
www.informit.com/que

Copyright © 2009 by Pearson Education, Inc.

NOT FOR RESALE
# TABLE OF CONTENTS

## CREATING LAYER AND CHANNEL MASKS

**PHOTOSHOP CS4 ON DEMAND**

by Steve Johnson, Perspection, Inc. ................................................................. 1

- Introduction ............................................................................................................. 3
- Understanding the Role of Layer Masks ................................................................. 4
- Creating a Layer Mask ............................................................................................ 5
- Working with the Paint Tools .................................................................................. 6
- Using Selections to Generate Complex Layer Masks ............................................. 7
- Using Layer Masks to Generate Soft Transparency .............................................. 8
- Blending Images with Layer Masks ....................................................................... 9
- Using a Layer Mask to Create a Vignette ............................................................... 10
- Creating Unique Layer Mask Borders .................................................................. 11
- Understanding Channel Masks ............................................................................ 12
- Creating Channel Masks from Scratch ................................................................ 13
- Modifying Channel Mask Options ....................................................................... 14
- Creating Channel Masks from Selections .............................................................. 15
- Making Channel Masks from Native Color Channels .......................................... 16
- Loading Channel Masks ...................................................................................... 18
- Moving Channel Masks Between Documents ...................................................... 20
- Combining Channel Masks ................................................................................. 21
- Using the Quick Mask Mode ................................................................................ 22
- Working with Quick Mask Options ..................................................................... 23
- Modifying Selections with Quick Mask Mode ..................................................... 24

## MANIPULATING ARTWORK WITH EFFECTS

**ILLUSTRATOR CS4 ON DEMAND**

by Steve Johnson, Perspection, Inc. ........................................................................ 25

- Introduction ............................................................................................................. 27
- Applying Illustrator Effects ..................................................................................... 28
- Applying the Convert to Shape Effect ................................................................... 30
- Applying the Scribble Effect .................................................................................. 31
- Applying the Inner or Outer Glow Effect .............................................................. 32
- Applying the Drop Shadow Effect ......................................................................... 33
- Applying 3D Effects ............................................................................................... 34
- Changing Raster Effects Settings .......................................................................... 36
- Working with the Effect Gallery ............................................................................ 38
- Using the Gaussian Blue Effect ............................................................................ 40
- Using the Unsharp Mask Effect ............................................................................ 41
- Applying Multiple Effects ...................................................................................... 42
- Controlling Effects Using Selections ...................................................................... 43
- Viewing Various Effects ....................................................................................... 44

## WORKING WITH VIDEO

**FLASH CS4 PROFESSIONAL**

by Steve Johnson, Perspection, Inc. ....................................................................... 47

- Introduction ............................................................................................................. 49
- Using the Video Import Wizard ............................................................................. 50
- Working with Video on the Timeline ..................................................................... 52
- Using Movie Clips with Video Files ....................................................................... 53
- Using Video with ActionScript ............................................................................ 54
- Controlling Video Through Movie Clips ............................................................... 56
- Working with the Flash Player Component ........................................................ 58
Creating Layer and Channel Masks

FROM

Adobe Photoshop CS4 On Demand

by Steve Johnson, Perspection Inc.

ALSO AVAILABLE
- SONY READER: 978-0-768-68860-3
- ADOBE READER: 978-0-768-68760-6
- SAFARI BOOKS ONLINE: 978-0-768-68791-0

TABLE OF CONTENTS

Chapter 1: Getting Started with Photoshop CS4
Chapter 2: Understanding Navigation and Measurement Systems
Chapter 3: Customizing the Way You Work
Chapter 4: Mastering the Art of Selection
Chapter 5: Working with Layers
Chapter 6: Working with the History Panel
Chapter 7: Working with Adjustment Layers, Filters, and Tools
Chapter 8: Understanding Colors and Channels
Chapter 9: Using the Paint, Shape Drawing, and Eraser Tools
Chapter 10: Creating Layer and Channel Masks
Chapter 11: Using the Paths Panel
Chapter 12: Working with Layer Styles
Chapter 13: Getting Creative with Type
Chapter 14: Manipulating Images with Filters
Chapter 15: Automating Your Work with Actions
Chapter 16: Controlling Image Output
Chapter 17: Working with Automate Commands
Chapter 18: Managing Color from Monitor to Print
Chapter 19: Designing for the Web and Devices
Chapter 20: Extending Photoshop
Chapter 21: Working Together with Adobe Programs
Workshops: Putting It All Together

informIT.com
Creating Layer and Channel Masks

Introduction

When you work on documents in Adobe Photoshop, the application does its best to make the experience as similar to the real world as possible. When you select the Brush tool and drag within the document, you expect to see a swath of color using the preselected size and brush tip. That's what you expect to see when you drag a brush on a canvas, and that's what you see in Photoshop. Creating a realistic experience is what Photoshop is all about. Yet, as realistic as the Photoshop experience is, there are elements of digital design that go way beyond the real world. For example, Photoshop has an undo button; the real world does not. Layer masks, for example, give you the ability to remove elements of a layer without actually erasing the image pixels. Layer masks give you ultimate control over your Photoshop design by deciding what elements of an image are visible, and making changes to the image without destroying any pixels. In addition, layer masks are editable, which means you can change your mind at any time during the creative process.

Imagine creating a complicated selection in Photoshop. Selections are temporary; they last only as long as your document is open. But what if you want to save this selection for use later in the design? What you need is a channel mask. Channel masks hold simple, or complicated selections, and can be saved with the document. Channel masks are created from preexisting selections, or can be created from scratch by painting the mask with black, white, or shades of gray. The process of creating a Channel mask is simple, but the results are powerful.

What You’ll Do

Understand the Role of Layer Masks
Create a Layer Mask
Work with the Paint Tools
Use Selections to Generate Complex Layer Masks
Use Layer Masks to Generate Soft Transparency
Blend Images with Layer Masks
Use a Layer Mask to Create a Vignette
Create Unique Layer Mask Borders
Understand Channel Masks
Create Channel Masks from Scratch or from Selections
Modify Channel Mask Options
Make Channel Masks from Native Color Channels
Move Channel Masks Between Documents
Combine Channel Masks
Use the Quick Mask Mode
Modify Selections Using Quick Mask Mode
Layer masks are not new; however, Photoshop designers find new ways to use them every day. A layer mask is an attachment to a layer that defines the visible elements of the layer. Each layer type in Photoshop, with the exception of the Background, has the ability to hold a layer mask. Imagine a layer mask as a piece of paper on top of the image. Then take a trimming blade and cut holes in the paper. The holes in the paper represent the visible area of the image underneath the mask, while the rest of the paper (layer mask) hides the rest of the image. Each layer in a multi-layered document can have its own mask; the mask only influences the image elements of the layer to which it’s attached. Once a mask is created, it can be modified using any of Photoshop’s painting or drawing tools. Black represents transparent (invisible) elements, and white represents visible elements. Painting with a shade of gray introduces a variable level of transparency. For example, painting with 50% gray makes the image pixels appear 50% transparent.
Creating a Layer Mask

Create a Layer Mask

1. Open a document.
2. Click the **Layers** panel.
3. Click the layer that will contain the mask.
4. Click the **Add Layer Mask** button.
5. Click on the image thumbnail to modify or adjust the image. The active pointer resembles a hand with a pointing finger.
6. Click on the mask thumbnail to modify or paint on the mask.
7. Click the **link** button to separate the mask from the image. Control the opacity (density) of the mask and adjust the edge by using the sliders on the Masks panel (New!). You can also access the Color Range command from this panel, delete/invert the mask or load a mask selection.
8. Click the **link** button again to reestablish the connection between the mask and the image.
9. Shift+click on the mask thumbnail to disable or enable the mask, or click on the Disable/Enable Mask button in the Masks panel (New!).
10. Alt+click (Win) or Option+click (Mac) on the mask thumbnail to view or hide the mask in the document window.

The creation of a layer mask requires two things: an open document and any type of Photoshop layer with the exception of the Background. When you add a layer mask, you will be working with two layer elements—the image and the mask. It’s important to know which element you’re working on or you might wind up painting on the image instead of the mask. When that occurs, it’s good to remember the Undo button. Once the mask is created, you can selectively control, without erasing, the visible portions of the image.
Unless a mask is created using a selection, layer masks begin their lives as completely white. The reason a newly created layer mask does not appear to have any visible effect on the image is that the color white indicates visible areas of the image. It’s only when you begin painting on the mask that the image changes. You create transparency in the image by painting in shades of gray. The deeper the shade of gray, the more transparent the image. Painting the mask with pure black produces 100% image transparency. Any of Photoshop’s drawing or painting tools can be used to create a mask. In fact, you could even use the Custom Shape drawing tools and create a mask in the shape of a rubber duck. The trick is to use the right tools to create the right effect. For example, using a hard-edged brush creates an image with sharp edges and using a soft-edged brush creates an image where the visible edges of the image blend smoothly with transparent elements.

**Work with the Paint Tools**

1. Open a document.
2. Create a layer mask on one of the active image layers.
3. Click the layer mask thumbnail.
4. Select the Brush tool and brush tip.
5. Move into the document window and paint with black to create transparency.
6. Use white to touch up the image.
7. Use shades of gray to create partial transparency.

**See Also**

See “Working with the Brush and Airbrush Tools” on page 214 for more information on using the Brush tool.
Using Selections to Generate Complex Layer Masks

Layer masks are easy to create; you select a layer and then click the Add Layer Mask button. Unfortunately, when you create a mask this way, it’s up to you to define the transparent areas, using drawing or painting tools. There is another way to generate a mask, and that’s by making a selection first. When you click the Add Layer Mask button, Photoshop searches the document for any selected areas. If it doesn’t find any, it creates a blank (all white) mask. However, if you first select an area of the image, Photoshop interprets the selection as the area you want to remain visible.

Did You Know?

You can apply layer styles to a masked image. Create the mask, and then click the Add Layer Style button, located at the bottom of the Layers panel. Then use any of Photoshop’s layer styles, such as Drop Shadow, or Bevel and Emboss. The layer style will only be applied to the visible portion of the image.

See Also

See Chapter 4, “Mastering the Art of Selection,” on page 77 for information on selecting areas of an image using different tools.

Use Selections to Generate Masks

1. Open a document.
2. Select the areas of the image you want to preserve.
3. Click the Add Layer Mask button.

Photoshop generates a layer mask based entirely on your selection.
When you create a layer mask using Photoshop’s selection tools, the edges of the image where transparency occurs appear as if cut out with a knife. This occurs because selection tools create hard-edged selections, and then, when you create the layer mask, the edges appear as ragged as the mask. To soften the edge of the selection boundary, you can use the Feather option in the Refine Edge dialog box, which can also be accessed from the Masks panel by clicking on the Mask Edge button (New!). As you adjust the Feather value, the feather effect appears in the Document window with a preview of the image. When you create the layer mask, the edges appear soft and feathered.

Use Layer Masks for Transparency

1. Open a document.
2. Create a selection around the area you want to preserve.
3. Click the Select menu, and then click Refine Edge.
4. Drag the slider to select a Feather Radius value (1 to 250). The greater the value, the greater the feathering effect.
5. Click OK.
6. Click the Add Layer Mask button.

The layer mask uses the Feather option to soften the visual effect of the mask.

Did You Know?

You can also use Gaussian Blur to create a soft transparency. Another way to create a soft edge is to create a hard-edged mask from a selection, and then visually create a softer mask using a filter named Gaussian Blur.

See Also

See Chapter 14, “Manipulating Images with Filters,” on page 319 for more information on using filters.
Blending Images with Layer Masks

You can use layer masks to make areas of an image appear transparent by painting with black. Then just as quickly, you can make those areas reappear by painting with white. There are obvious applications to the use of layer masks—changing a sky, removing a tree, or even removing a person from the photo. For example, you have a line art image and you want to change it to a normal photograph. To accomplish this, you'll need a copy of the image in a separate layer, a layer mask, and the linear gradient tool.

Blend Images with Layer Masks

1. Open a document.
2. Select the layer you want to use for the effect in the Layers panel. If this is a multi-layered document, this layer should be at the top of the layer stack.
3. Drag the layer over the Create New Layer button to make a copy.
   **TIMESAVER** If making a copy of a layer is a common practice, press Ctrl+J (Win) or ⌘+J (Mac).
4. Click the Add Layer Mask button, and then add a layer mask to the layer copy.
5. Use any of Photoshop's adjustment or filter effects to make changes to the layer copy.
6. Select black and white for the default foreground and background colors.
7. Select the Gradient tool, and then select a linear gradient using the foreground to background gradient option.
8. Click the layer mask thumbnail in the copy layer.
9. Drag the Gradient tool across the document, left to right.

The image slowly becomes transparent from left to right, exposing the original image.

You can use layer masks to make areas of an image appear transparent by painting with black. Then just as quickly, you can make those areas reappear by painting with white. There are obvious applications to the use of layer masks—changing a sky, removing a tree, or even removing a person from the photo. For example, you have a line art image and you want to change it to a normal photograph. To accomplish this, you'll need a copy of the image in a separate layer, a layer mask, and the linear gradient tool.
When you open a document in Photoshop, the image is displayed in a standard bounding-box format—a square or rectangle with 90-degree corners. Bounding boxes serve a purpose, and many times a nice square or rectangle box is exactly what you want. But let’s face it, bounding boxes can be a bit boring, especially when you want to spice up that image with a nice soft vignette. To create a soft vignette, you need four things—an image, a selection, a layer mask, and the Gaussian Blur filter.

Using a Layer Mask to Create a Vignette

Create a Vignette

1. Open a document.
2. Select the Elliptical Marquee tool, and then create an oval selection in the document. The Ellipse should contain the area you want to preserve.
3. Click the Add Layer Mask button in the Layers panel.
4. Click the layer mask thumbnail.
5. Click the Filter menu, point to Blur, and then click Gaussian Blur.
6. Drag the Radius slider right or left to increase or decrease the amount of blur applied to the mask.
7. Select the Preview check box, and then watch the live preview until you are satisfied with the amount of blurring applied to the layer mask.
8. Click OK.

Soft vignette applied to the image
Creating Unique Layer Mask Borders

Create a Layer Mask Border

1. Open a document.
2. Click the layer in the Layers panel to which you want to apply a unique border.
3. Create a rectangular selection around a portion of the image.
4. Click the Add Layer Mask button.
5. Click the layer mask thumbnail.
6. Click the Filter menu, point to Brush Strokes, and then click the Sprayed Strokes filter.
7. Adjust the filter options to change the edge of the layer mask.
8. Click OK.

Did You Know?

You can apply more than one filter to a layer mask border. For example, using the Spatter filter creates a ragged edge to the layer mask. Applying a small amount of Gaussian Blur to the mask softens the effect and creates a more pleasing visual transition between the mask and the background.
The Channels panel serves three purposes—to hold color information, to hold spot color information, and to hold selections (channel masks). Creating channel masks can be as easy as clicking the Create New Channel button and then using any painting or drawing tools to create the mask, or by making a selection and converting the selection into a mask by clicking the Save Selection As Channel button. When you paint the channel mask, the defaults are—black for masked areas, white for selected areas, and shades of gray for percentages of selection.

**Understanding Channel Masks**

**Use Channel Masks**

1. Open an image and create a selection.
2. Select the Channels panel.
3. Click the Create New Channel button.
4. Select the new channel.
5. Select the Brush tool on the toolbox, and then select a brush tip on the Options bar.
6. Paint areas of the mask white to create a selection.
7. Paint areas of the mask black to mask the image.

**Did You Know?**

You can quickly convert a channel mask into a selection. To view a channel mask as a selection, open the Channels panel, and then Ctrl+click (Win) or ⌘+click (Mac) on the channel. Photoshop instantly translates the black, white, and gray areas of the mask into a visible selection in the document window.
Creating Channel Masks from Scratch

Channel masks are easy to create and once created, are just as easy to modify. All you need is an open document, and access to the Channels panel. After selecting a painting or drawing tool, you paint on the mask to define the selection area. The problem is you can’t see the image; you can only see the mask. What you need is the ability to view the mask and the image at the same time, as if you were using tracing paper, and then use the drawing tools to paint (trace) the portions of the image you want to select. The secret to viewing the image as you create the mask is to temporarily enable or show, the composite channel. In fact, the composite channel acts like a toggle switch—when it’s visible, you see the image and the mask (tracing paper); when it’s hidden, you only see the mask.

Create Channel Masks

1. Open an image.
2. Select the Channels panel.
3. Click the Create New Channel button.
4. Click the Show/Hide button on the composite channel. The image is revealed in the document window (the new Alpha channel should still be selected). You will use the image to guide the creation of the mask.
5. Select the Brush tool on the toolbox.
6. Paint areas of the image using white to create a selection (painting with white exposes the original image).
7. Paint areas of the image black to mask the image (painting with black masks the image with the default color of red).
8. Click the Show/Hide button on the composite channel. The image is hidden, revealing just the mask.
9. Repeat steps 6-8 until the mask is complete.
Channel masks have default options that control how the mask looks and functions. Photoshop gives you the ability to change the default options of a channel mask. For example, you could change the default color from red to blue, or you could change the function of the channel mask from Selection to Spot Color. Knowing you can change the mask options gives you more control over the final results.

### Modify Channel Mask Options

1. Open a document.
2. Select the **Channels** panel.
3. Click the **Channels Options** button, and then click **New Channel**.
4. Enter a name for the new channel.
5. Click the option to define the mask color as the Masked Areas, Selected Areas, or Spot Color.
6. Click the **Color** box, and then select a color from the Color Picker.
7. Enter an Opacity percentage value (1% to 100%) for the color.
8. Click **OK**.

### Did You Know?

*You can change the Channel options for a preexisting channel.* Double-click on the channel, and Photoshop will open the Channel options dialog box.

*You can set Channel options for each channel.* Changing the Channel options only impacts that specific channel. Each channel can have its own individual settings.
Creating Channel Masks from Selections

Create Channel Masks from Selections

1. Open a document.
2. Create a selection using any of Photoshop’s traditional selection tools.
3. Select the Channels panel.
4. Click the Save Selection As Channel button.

Photoshop creates a new channel mask based on the selected areas of the document.

Creating channel masks from scratch (using brush and drawing tools) is a useful feature, and gives you the ability to create a mask in any desired size or shape. However, there are times when it would be easier to first define the areas you want to protect, and then create the mask. When you create a channel mask from an existing selection, Photoshop uses the selected areas to create the mask. For example, you have an image of a woman wearing a red dress, and you want to change the color of the dress to green. The first step would be to select the red dress. Rather than create a new mask, and paint out the area representing the dress, it would be easier to first use a tool like the Magic Wand, select the dress, and then convert the selected area (the dress) into a channel mask. Once the mask is created, you could fine-tune the mask using Photoshop’s painting tools, and then change the dress color. Whether you create a mask from scratch or choose to create one through a predefined selection depends on the image and what you’re trying to accomplish.
Creating a channel mask from a native color channel takes a few steps; however, if you’re successful, the effort spent making the selection is well worth it. The trick to creating a mask with a native color channel is to use the shifts of gray in one specific color channel to create the black and white areas characteristic of a typical channel mask. For example, you have an image of a model, and you want to remove the model from the background. Unfortunately, that requires selecting around the model’s hair, a difficult thing to accomplish, even in the best of circumstances. To make the channel mask, open the Channels panel and examine the native color channels, one at a time. You’re looking for a color channel that displays a significant shift of gray (amount of contrast) between the model’s hair and the background. For example, you click on the red channel of an RGB image and the model’s hair appears dark gray, while the background appears light gray. The difference is so pronounced you can actually see individual strands of hair standing out against the background. If you can find such a contrast, you can quickly make a channel mask.

## Make Channel Masks from Native Color Channels

1. Open a document.
2. Click the Channels panel.
3. Click and view the individual native color channels one at a time.
4. Click the channel that best represents a visual difference between what you want to select and what you want to mask.
5. Drag the selected channel over the Create New Channel button. Photoshop makes a copy of the selected native color channel.
6. Click the native color channel copy.
7 Click the **Image** menu, point to **Adjustments**, and then click **Threshold**.

8 Move the **Threshold** slider left or right until you see a sharp black and white image with the black and white representing the selected and masked areas of the image.

9 Click **OK**.

10 Use Photoshop’s painting tools with black and white to touch up the new mask.

**Did You Know?**

*You can use native color channel masks to perform image correction.*

Channel masks created from native color channels can be used for more than creating a mask. For example, you have a photo where the shadow portions of the image are too dark. Correct the problem by creating a channel mask that selects just the darker portions of the image, and then use the mask to control the Levels or Curves adjustments to lighten the overexposed areas of the image.
Once you create a channel mask (and you can have up to 28 separate masks in one document), the next step is to use the masks. To save the channel mask all you have to do is save the document in a format that supports channels, such as Photoshop’s native PSD format, or even the TIFF format. The next time you open the document, your channel masks will be there. Deleting a channel mask is simple; just drag the channel mask over the Delete button located at the bottom of the Channels panel, or select the channel mask you want to delete, and click the Delete button. However, sooner or later, you’re going to want to do more than just save or delete—you’re going to want to use a channel mask. Using a channel mask involves a process of converting the mask back into a selection. It’s an easy step, but necessary to complete the process from mask to selection.

**Load Channel Masks**

1. Open a document that contains a channel mask, or create a new channel mask.
2. Click the Select menu, and then click Load Selection.
3. If more than one document is open, click the Document list arrow, and then select the document you want to use.
4. Click the Channel list arrow, and then click the channel you want to convert into a selection (native color channels do not appear in this list).
5. Select the Invert check box to instruct Photoshop to use the black areas of the mask (instead of the white areas) for the selection.
Chapter 10  Creating Layer and Channel Masks

Select the Operation option you want to perform:

◆ **New Selection.** Creates a new selection.

◆ **Add To Selection.** Adds the channel mask to an existing selection.

◆ **Subtract From Selection.** Uses the channel mask to subtract from an existing selection.

◆ **Intersect With Selection.** Uses the channel mask to intersect with an existing selection.

Click **OK**.

---

**For Your Information**

**Working with Channel Masks**

Channel masks provide control over the selected areas of an image. By default, the white areas of the mask represent the selected areas, and the black areas represent the masked areas. When a mask is applied to an image, the black and white areas of the mask create a very sharp-edged selection. To soften the effect of the mask, click the Filter menu, point to Blur, and then click Gaussian Blur. Apply a small amount of blur (one or two pixels) to the mask. Now, when the mask is applied to the image, the Gaussian blur will soften the effects of the selection and create a visually softer transition.
Moving Channel Masks Between Documents

Move Channel Masks Between Documents

1. Open a document that contains a channel mask.
2. Open a second document (this is the document you will move the mask into).
3. Position the two document windows side by side.
4. Click the document containing the channel mask.
5. Select the **Channels** panel.
6. Drag the channel mask from the Channels panel into the open document window of the second document.

Once you create a channel mask in one document, it is possible to move that channel mask to another document. While most channel masks are so specific to a particular document it wouldn’t be practical to move them—a channel mask defining a selection of a specific tree against a blue sky, for example—many channel masks can be used over and over again. For example, you might have a series of channel masks creating unique selection borders around an image. You spent a lot of time creating the borders, and you would like to apply those same border selections to other images. If that’s the case, then increase your efficiency by saving them as channel masks and moving them between documents. Not only will it save you a lot of time, but using selections more than once can add a sense of cohesiveness to a design.
Combining Channel Masks

Channel masks are simply selections defined by black, white, and shades of gray. Once a channel mask is placed in the Channels panel, you can use Photoshop's vast array of drawing and painting tools or filters. The Gaussian Blur filter can make a great enhancement to a channel mask. It's even possible to combine the selection elements of two or more channels together, and in doing so, create an even more complicated mask.

Combine Channel Masks

1. Open a document that contains two or more channel masks.
2. Click the Channels panel.
3. Press Ctrl+click (Win) or ⌘+click (Mac) on one of the channel masks.
   The white areas of the channel become a selection.
4. Press Shift+Ctrl+click (Win) or Shift+⌘+click (Mac) on the second channel mask.
   The white areas of the second channel mask are added to the previous selection.
5. Click the Save Selection As Channel button.
   Photoshop takes the combined areas of the two channels and creates a new channel mask.

The two channels are combined
Quick Mask mode gives you the ability to create a selection using painting and drawing tools without creating a channel mask. For example, you’re creating a selection using traditional selection tools and there’s a portion of the image you’re having difficulty selecting. Since this is a one-time selection, you don’t want to go to the trouble of creating a channel mask. The solution is to move into the Quick Mask mode. Quick Mask mode toggles between a normal (Standard) selection view and a Quick Mask view. When you enter Quick Mask mode, any preexisting selections are converted into a red mask, and changes to the mask are performed using painting tools. When you return to Standard mode, the masked (painted) areas are converted into a selection. While Quick Masks are created the same way as channel masks, they’re temporary. It’s a quick way to create a one-time selection.

Use the Quick Mask Mode

1. Open a document.
2. Create a selection using any of Photoshop’s selection tools.
3. Click the Edit in Quick Mask Mode button to convert the selection into a red overlay mask (the button toggles to Standard mode).
4. Select the Brush tool.
5. Paint with white to open up more selection areas.
6. Paint with black to mask the image; the mask, by default, is red.
7. Click the Edit in Standard Mode button again to return to a standard selection (the button toggles to Quick Mask mode).
8. Toggle between Quick Mask and Standard modes until you create the perfect selection.

Did You Know?

You can convert a Quick Mask into a permanent Channel mask. Create the Quick Mask, return to Standard Mode, select the Channels panel, and then click the Create Channel From Selection button.
When you work in the Quick Mask mode, the color for the mask is red, the opacity of the mask is 50%, and the red mask represents the masked areas of the document. Photoshop uses these Quick Mask options as the default, but they can be modified. For example, it would be very difficult to view a red mask if you were working on a primarily red image, or you might want to increase or decrease the opacity of the mask. Photoshop lets you do this through Quick Mask options.

1. Click the **Edit in Quick Mask Mode** or **Edit in Standard Mode** button (the button toggles between Quick Mask mode and Standard mode).
2. Click the **Masked Areas** or **Selected Areas** option to instruct Photoshop whether to create a mask or a selection from the color areas of the mask.
3. Click the **Color** box, and then select a color from the Color Picker.
4. Enter an Opacity percentage value (0% to 100%).
5. Click **OK**.

**IMPORTANT** Quick Mask options are program specific, not document specific. The changes made to the Quick Mask options remain set until you change them.

---

**Did You Know?**

*Once you’ve created a Quick Mask selection, you can save it as a permanent Channel mask.* Just return the screen to Standard mode, open the Channels panel, and then click the Save Selection As Channel button.

---

**For Your Information**

**Using Quick Masks**

One of the powerful features of a Quick Mask is that you can use filters directly on the mask. Create a selection in the Quick Mask mode, and then click the Filter menu and choose from Photoshop’s many filters, such as Brush Strokes, Blur, or Distort. When you click OK, the filter is applied directly to the Quick Mask. Then, when you return to Standard mode, the effect of the filter is applied to the selection. Working with filters and Quick Masks gives you the option of creating highly complicated masks without ever using the Channels panel.
Photoshop represents an active selection using an animated, single-pixel wide marquee, sometimes referred to as a "marching ant" marquee. Typically, the enclosed or "marquee" area represents the working area of the document. Unfortunately, when selections become complicated, you could wind up with ants marching all over the screen. While complicated selections are a part of the Photoshop designer’s life, they shouldn’t have to be hard to visualize or modify. Photoshop knows this and created the Quick Mask option. When you’re using Quick Mask, Photoshop displays the selected areas with a user-defined color and opacity. Then, by using your painting tools, you can make quick work of modifying the selection.

Modify Selections with Quick Mask Mode

1. Create a selection using any of Photoshop’s selection tools.
2. Click the Default Colors button to default your foreground and background painting colors to black and white.
3. Click the Edit in Quick Mask button to enter Quick Mask mode.
   By default the selected area remains clear and the unselected area becomes masked with a 50% red.
4. Select the Brush tool on the toolbox.
5. Refine the selection by painting on the Quick Mask with white and/or black. In Quick Mask mode, painting with black masks the image using a 50% opacity red, and painting with white reveals the original image.
6. Click the Edit in Standard Mode button to revert the image back to a normal selection marquee.
7. Continue to toggle back and forth between Edit in Quick Mask and Edit in Standard Mode until you achieve the desired selection.
Manipulating Artwork with Effects

FROM

Adobe Illustrator CS4 On Demand

by Steve Johnson, Perspection Inc.

 ALSO AVAILABLE
• SONY READER: 978-0-768-68861-0
• ADOBE READER: 978-0-768-68767-5
• SAFARI BOOKS ONLINE: 978-0-768-68793-4

TABLE OF CONTENTS

Chapter 1: Getting Started with Illustrator CS4
Chapter 2: Creating and Viewing a Document
Chapter 3: Working with Objects
Chapter 4: Working with Color
Chapter 5: Applying Fills, Strokes, and Gradients

Chapter 6: Working with Points and Paths
Chapter 7: Working with Layers
Chapter 8: Working with Type
Chapter 9: Working with Graphics
Chapter 10: Manipulating Artwork with Effects
Chapter 11: Drawing and Painting
Chapter 12: Using Symbols
Chapter 13: Automating the Way You Work

Chapter 14: Proofing and Printing Documents
Chapter 15: Exporting a Document
Chapter 16: Designing for the Web and Devices
Chapter 17: Customizing the Way You Work
Chapter 18: Working Together with Adobe Programs
Workshops: Putting It All Together

informIT.com
Manipulating Artwork with Effects

Introduction

Adobe Illustrator effects are a designer’s dream come true. With effects you can turn an image into an oil painting or a watercolor; you can even change night into day. Illustrator’s Effect menu includes over 100 highly creative effects from Illustrator and Photoshop, which can be applied once, reapplied, or combined with other filters to create any effect your imagination can dream up.

The potential combination of effects and images literally runs into the millions. This means that effects are truly an undiscovered territory. As a matter of fact, the Photoshop Effect Gallery lets you view the effects of one or more filters on the active document. This level of power gives you unbelievable creative control over your images.

Take a moment to view some of the various effects that Illustrator offers. Because there are over 100 effects available, we can’t show you all of them, but we think you’ll enjoy viewing the selection at the end of the chapter.

What You’ll Do

- Apply Illustrator Effects
- Apply the Convert to Shape Effect
- Apply the Scribble Effect
- Apply the Inner or Outer Glow Effect
- Apply the Drop Shadow Effect
- Apply 3D Effects
- Change Raster Effect Settings
- Work with the Effect Gallery
- Use the Gaussian Blur Effect
- Use the Unsharp Mask Effect
- Apply Multiple Effects
- Control Effects Using Selections
- View Various Effects
Illustrator effects change the appearance of an object, not its underlying path, and are fully editable. The effects can be edited or removed without permanently affecting the object. So, you can experiment with an effect and then undo it if you don’t like it. The Illustrator effects appear at the top of the Effect menu. Most of the Illustrator effects are vector-based for the display and upon output, so they can be modified without affecting the object. However, some of the effects—Drop Shadow, Inner Glow, Outer Glow, and Feather—are rasterized (converted from vector to raster) upon output, which doesn’t allow for non-destructive modification without affecting the object. After you apply an effect, it appears on the Appearance panel, where you can make changes. If you apply an effect to a targeted layer, sublayer, or group, it automatically is applied to all current and future objects on the target. If you use graphic styles, you can also apply effects to them.

**Applying Illustrator Effects**

**Apply an Illustrator Effect**

1. Select the Layers panel, and then select the target circle for a layer, sublayer, group or object.
   - To apply an effect to a part of an object, click the Stroke or Fill on the Appearance panel.
2. Click the Effect menu, point to a submenu under Illustrator Effects (if needed), and then select an effect.
3. To preview an effect in your document, select the Preview check box (if available).
4. Select the options you want for the selected effect; options vary depending on the effect.
5. Click OK.

**Did You Know?**

*You can edit an applied effect.* Select the layer, object or object’s stroke or fill, open the Appearance panel, double-click the effect, make changes, and then click OK.
Apply an Illustrator Effect in Graphic Styles

1. Select a style name or swatch on the Graphic Styles panel or select an object that uses a graphic style. The style name appears in the Appearance panel.

2. Click the Effect menu, point to a submenu under Illustrator Effects (if needed), and then select an effect.

3. To preview an effect in your document, select the Preview check box (if available).

4. Select the options you want for the selected effect; options vary depending on the effect.

   If you enter a value in a box, press Tab to update the preview.

5. Click OK.

6. Click the Options button on the Appearance panel, and then click Redefine Graphic Style to update the style.

Did You Know?

You can remove an effect from a layer, object, or graphic style. Select the layer, object, or graphic style, open the Appearance panel, select the effect name, and then click the Delete Selected Item button. If you're removing an effect from a style, click the Options button on the Appearance panel, and then click Redefine Graphic Style to update the style.
With the Illustrator Convert to Shape effect, you can change an object's outline to a rectangle, rounded rectangle, or ellipse without changing the actual underlying path. In the Shape Options dialog box, you can specify the width and height of the converted shape. The size can be set to an absolute value or a relative one based on the original object.

**Applying the Convert to Shape Effect**

1. Select the Layers panel, and then select the target circle for a layer, sublayer, group or object.
2. Click the Effect menu, point to Convert to Shape, and then click Rectangle, Rounded Rectangle, or Ellipse.
3. To preview an effect in your document, select the Preview check box (if available).
4. Click the Absolute or Relative option, and then enter values for width and height.
   - For the Relative option, if you want the shape to be larger or smaller than the actual path, enter a positive or negative value.
5. For a Rounded Rectangle shape, enter a Corner Radius value.
6. Click OK.

**Did You Know?**

*You can round off sharp corners without converting the shape.* Select the shape, click the Effect menu, point to Stylize, and then click Round Corners.
If you want to make an object’s fill look as though it was drawn with a pen or pencil, the Illustrator Scribble effect is the one for you. In the Scribble Options dialog box, you can use one of the many presets to create the look you want. It makes the job easy. The presets include Childlike, Dense, Loose, Sharp, Sketch, Swash, Tight, and Zig-zag. After you select a preset (even if it’s just the Default), you can adjust individual settings to customize the Scribble effect. As you make changes, you can preview the results in your document.

**Apply the Scribble Effect**

1. Select the Layers panel, and then select the target circle for a layer, sublayer, group or object.
2. Click the Effect menu, point to Stylize, and then click Scribble.
3. To preview an effect in your document, select the Preview check box (if available).
4. Select from the following options:
   - **Settings**. Click the Settings popup to select a preset for the Scribble effect.
   - **Angle**. Enter an Angle value or rotate the dial to change the angle of the sketch lines.
   - **Path Overlap**. Drag the Path Overlap slider toward Outside to have the sketch lines extend beyond the edge of the path, or toward Inside to have the sketch lines stay inside the path along with the degree of random variation.
   - **Line Options**. Change the Stroke Width for the lines, the Curviness for the lines (angle sharply or loosely) along with the degree of random variation, and the Spacing for the lines (tight or loose) along with the degree of random variation.
5. Click OK.
With the Illustrator Inner Glow or Outer Glow effect, you can apply a color special effect to an object. The inner glow effect spreads a color from the edge of an object inward, while the outer glow effect spreads a color from the edge of an object outward. You can also apply both effects to the same object. As you make changes, you can preview the results in your document. It’s important to remember that the Inner Glow and Outer Glow effects are rasterized (converted from vector to raster) upon output.

**Apply the Inner Glow or Outer Glow Effect**

1. Select the **Layers** panel, and then select the target circle for a layer, sublayer, group or object.
2. Click the **Effect** menu, point to **Stylize**, and then click **Inner Glow** or **Outer Glow**.
3. To preview an effect in your document, select the **Preview** check box (if available).
4. Select from the following options:
   - **Color**. Click the **Color** box, and then select a glow color.
   - **Blend Mode**. Click the **Mode** popup, and then select a blending mode for the glow color.
   - **Opacity**. Click the arrow, and then drag the slider to adjust the transparency of the glow.
   - **Blur**. Click the arrow, and then drag the slider to adjust how far the glow extends inward or outward.
   - **Center or Edge**. For the Inner Glow effect, click **Center** to have the glow spread outward from the center of the object, or click **Edge** to have the glow spread inward from the edge of the object toward the center.
5. Click **OK**.
The Illustrator Drop Shadow effect allows you to apply soft, natural shadows to an object. With the Drop Shadow effect, you can specify a color blend, opacity (degree of transparency), offset, blur, and shadow color. As you make changes, you can preview the results in your document. You can apply the Drop Shadow effect to images and editable text. It's important to remember that the Drop Shadow effect is rasterized (converted from vector to raster) upon output.

Applying the Drop Shadow Effect

1. Select the Layers panel, and then select the target circle for a layer, sublayer, group or object.
2. Click the Effect menu, point to Stylize, and then click Drop Shadow.
3. To preview an effect in your document, select the Preview check box (if available).
4. Select from the following options:
   - **Blend Mode.** Click the Mode list arrow, and then select a blending mode for the shadow color.
   - **Opacity.** Click the arrow, and then drag the slider to adjust to see thoroughness of the shadow.
   - **X and Y Offset.** Enter the distance of the shadow.
   - **Blur.** Click the arrow, and then drag the slider to adjust how far the shadow extends inward or outward.
   - **Color.** Click the Color option, and then select a color or click the Darkness option and specify a percentage.
5. Click OK.
With the Illustrator 3D Effects, you can create 3D objects from 2D objects. The 3D Effects include Extrude & Bevel, Revolve, and Rotate. You can specify multiple appearance options including: position, rotation, surface, lighting, shading. Every 3D object is composed of multiple surfaces, such as a front, back, and sides. You can map 2D artwork (as a symbol) from the Symbols panel to each surface on a 3D object to create the look that you want.

**Create a 3D Object**

1. Select the object that you want to change.
2. Click the Effect menu, point to 3D, and then click Extrude & Bevel.
   - Click More Options to display all available options in the dialog box.
3. To preview an effect in your document, select the Preview check box (if available).
4. Select from the following options:
   - **Position.** Specifies object perspective and rotation angle.
   - **Extrude & Bevel.** Specifies the extent of object depth and bevel.
   - **Surface.** Specifies the surface of the 3D object.
   - **Lighting.** Adds one or more light sources, varies the light intensity, changes shading color, and changes the light source direction.
   - **Map Art.** Click to map 2D artwork (as a symbol) onto the surface of a 3D object.
5. Click OK.

3D results
Create a 3D Revolving Object

1. Select the object that you want to change.
2. Click the Effect menu, point to 3D, and then click Revolve.
   - Click More Options to display all available options in the dialog box.
3. To preview an effect in your document, select the Preview check box (if available).
4. Select from the following options:
   - **Position.** Specifies object perspective and rotation angle.
   - **Revolve.** Specifies how to sweep the path around the object to create a 3D object.
   - **Surface.** Specifies the surface of the 3D object.
   - **Lighting.** Adds one or more light sources, varies the light intensity, changes shading color, and changes the light source direction.
   - **Map Art.** Click to map 2D artwork (symbol) onto the surface of a 3D object.
5. Click **OK.**
Some of the Illustrator effects—Drop Shadow, Inner Glow, Outer Glow, and Feather—and all of the Photoshop effects, are rasterized upon output. You can control how a raster effect looks in your document and how it will output from Illustrator by using the Document Raster Effects Settings dialog box. The available options allow you to specify a color model, resolution, background type (white or transparent), as well as apply anti-alias, create a clipping mask, and preserve spot colors. These options are globally applied to all raster effects. The raster settings convert a vector object to a bitmap image. If you want to apply raster settings to an individual object, you can specify many of the same options in the Rasterize dialog box.

**Change Raster Effects Settings**

1. Click the **Effect** menu, and then click **Document Raster Effects Settings**.
2. Select from the following options:
   - **Color Mode**. Select a color mode: CMYK, RGB, Grayscale, or Bitmap.
   - **Resolution**. Select a screen size in points per inch (ppi). Use Screen for web or video output, Medium for desktop printers, or High for commercial printing.
   - **Background**. Use White to make any transparent areas white or Transparent to make the background transparent by creating an alpha channel.
   - **Anti-alias**. Select to apply anti-alias to soften the edges of a rasterized object.
   - **Create Clipping Mask**. Select to create a clipping path around the image and specify a size to extend the effect. If you selected the Transparent option, you don’t need to select this option.
   - **Preserve Spot Colors**. Select to preserve spot colors.
3. Click **OK**.
Convert Vector Objects to Bitmap Images

1. Select the Layers panel, and then select the target circle for a layer, sublayer, group or object.

2. Click the Object menu, and then click Rasterize.

3. Select from the following options:
   - **Color Mode.** Select a color mode: CMYK, RGB, Grayscale, or Bitmap.
   - **Resolution.** Select a screen size in points per inch (ppi). Use Screen for web or video output, Medium for desktop printers, High for commercial printing, or Use Document Raster Effects Resolution to apply the global resolution.
   - **Background.** Use White to make any transparent areas white or Transparent to make the background transparent by creating an alpha channel.
   - **Anti-alias.** Use Art Optimized (Supersampling) to soften shape edges. Use Type Optimized (Hinted) to soften type edges. Use None to keep edges jagged.
   - **Create Clipping Mask.** Select to create a clipping path around the image and specify a size to extend the effect. If you selected the Transparent option, you don’t need to select this option.
   - **Preserve Spot Colors.** Select to preserve spot colors.

4. Click OK.
The Effect Gallery enables you to maintain complete and total control over Photoshop effects. In essence, the Effect Gallery gives you access to all of Photoshop’s effects and lets you apply the effects to any image, while viewing a large preview of the results. The Effect Gallery dialog box is composed of three sections—Image Preview, Effect Selection, and Effect Controls. When you use the Effect Gallery to modify the image, you see exactly how the image will look; there is no guesswork involved. When you apply an effect to an image, you are physically remapping the pixel information within the image. Illustrator provides over 50 Photoshop effects and the combinations of those effects are astronomical. That means there are a lot of different combinations available for you to try…have fun.

---

**Working with the Effect Gallery**

1. Select the **Layers** panel, and then select the layer you want to modify with an effect.
2. Click the **Effect** menu, and then click **Effect Gallery**.
3. Change the image preview by clicking the plus or minus zoom buttons, or by clicking the black triangle and selecting from the preset zoom sizes.
4. If necessary, drag the lower right corner in or out to resize the Effect Gallery dialog box.
5. Click the expand triangle, located to the left of the individual categories, to expand an effect category. Effect categories include:
   - Artistic
   - Blur
   - Brush Strokes
   - Distort
   - Pixelate
   - Sharpen
   - Sketch
◆ Stylize
◆ Texture
◆ Video

6 Click an effect from the expanded list to view its default effects on the image.

7 Modify the results of the effect using the effect controls.

8 To temporarily hide the Effect Selections, click the **Show/Hide Effect Thumbnails** button, located to the left of the OK button.

9 Click **OK**.

**Did You Know?**

*You can reapply a specific effect using a shortcut.* Press Shift+Ctrl+E (Win) or Shift+F (Mac) to reapply the last effect to the image.
Using the Gaussian Blur Effect

You can also apply the Photoshop Gaussian Blur effect that blurs an image or a selection by a controllable amount. The Gaussian Blur effect can be used to add a sense of depth to the image. For example, you could select and blur the background of an image while leaving the foreground in focus. The outcome of the effect is to create a hazy, out-of-focus effect on the image or selection.

Use the Gaussian Blur Effect

1. Select the Layers panel, and then select the layer you want to modify with an effect.
2. Click the Effect menu, point to Blur, and then click Gaussian Blur.
3. Drag the Radius slider or enter a pixel value to increase or decrease the amount of Gaussian blur applied to the image.
4. Click OK.
The Photoshop Unsharp Mask effect creates a visually sharper image by locating pixels that differ in value from surrounding pixels. When the effect is applied to the image, the bordering pixels specified by the threshold option get lighter and the darker pixels get darker. It’s important to understand that the Unsharp Mask does not actually sharpen the image; it only attempts to create the illusion of sharpness. Be careful; an over-application of this effect creates harsh images with ragged edges and shadows. Also, the effects of the Unsharp Mask effect appear more severe when viewed with the low resolution of a computer than when the document is output to a printer.

**Using the Unsharp Mask Effect**

1. Select the Layers panel, and then select the layer you want to modify with an effect.
2. Click the Effect menu, point to Sharpen, and then click Unsharp Mask.
3. Select from the following options:
   - **Amount.** Drag the slider or enter a value to determine how much to increase the contrast of pixels.
   - **Radius.** Drag the slider or enter a value to determine the number of pixels surrounding the edge pixels that affect the sharpening.
   - **Threshold.** Drag the slider or enter a value to determine how different the sharpened pixels must be from the surrounding area before they are considered edge pixels and sharpened by the effect.
4. Click **OK.**

The Unsharp Mask filter applied to the image.
Applying Multiple Effects

Apply Multiple Effects

1. Select the Layers panel, and then select the layer you want to modify with an effect.
2. Click the Effect menu, and then click Effect Gallery.
3. Select the effect you want.
4. Adjust the effect as necessary.
5. Click the New Layer Effect button, located at the bottom of the Effect Adjustments section. You can add as many effects layers as needed.
6. Select and adjust a second effect (repeat steps 3 and 4).
7. Adjust each individual effect by clicking on the effect layer you want to change.
8. To change the effect’s influence on the image, drag an effect layer to another position in the stack.
9. To temporarily show or hide the effect on the image, click the Show/Hide button.
10. To delete a selected effect layer, click the Delete button.
11. Click OK.

IMPORTANT Once you click the OK button, the effects are permanently applied to the active image, unless it’s a Smart Object.
When you apply an effect, Illustrator applies the effect equally to the entire image. Unfortunately, that might not be what you had in mind. For example, you might want to apply the Gaussian Blur effect to a portion of the image. In that case, Illustrator’s selection tools come to the rescue. The primary purpose of making a selection is to define a work area, and when you select an area before applying an effect, the only area impacted by the effect will be the selected area.

**Control Effects Using Selections**

1. Select the **Layers** panel, and then select the layer to which you want to apply an effect.
2. Select the **Direct Selection** tool on the Tools panel, and then make a selection in the document window.
3. Click the **Effect** menu, and then click **Effect Gallery**.
4. Select any Photoshop effects.
5. Adjust the effect options until you see the effect you want.
6. Click **OK**.
   
   The effect is only applied to the selected areas of the image.
Viewing Various Effects

Illustrator and Photoshop provide a bountiful selection of over 100 effects. Take a moment to view some of the various effects you can use. The original image is shown to the right, and we’ve displayed some common effects on the following pages. A good thing to think about when using effects is your original image. Look at the background colors, and see if they will look good with some of the effects. The best thing to do is open an image that has a lot of varied details, and then apply some effects to see what looks good to you.

Various Effects

Cutout

Dry Brush

Fresco

Panel Knife
Chapter 10  Manipulating Artwork with Effects
Working with Video

FROM

Adobe Flash CS4 Professional On Demand

by Steve Johnson, Perspection Inc.

ALSO AVAILABLE
• SONY READER: 978-0-768-68858-0
• ADOBE READER: 978-0-768-68761-3
• SAFARI BOOKS ONLINE: 978-0-768-68792-7

FOR MORE INFORMATION
informit.com/title/9780789738363

TABLE OF CONTENTS

Chapter 1: Getting Started with Flash CS4
Chapter 2: Working Within the Flash Environment
Chapter 3: Creating Graphics
Chapter 4: Working with Groups, Symbols, and Instances
Chapter 5: Working with Text
Chapter 6: Importing Graphics
Chapter 7: Creating Frame-by-Frame Animation
Chapter 8: Animating with Motion Tweening
Chapter 9: Animating with Classic Tweening
Chapter 10: Animating with Shape Tweening
Chapter 11: Creating Masks
Chapter 12: Working with Sounds
Chapter 13: Working with Video
Chapter 14: Using Basic Action-Scripts
Chapter 15: Debugging a Movie
Chapter 16: Adding Display Components
Chapter 17: Adding Advanced Display Components
Chapter 18: Adding and Modifying Data Components
Chapter 19: Automating Your Work
Chapter 20: Publishing a Movie
Chapter 21: Using Advanced Flash Features
Workshops: Putting It All Together
Working with Video

Introduction

The Flash Video Import Wizard lets you import a video clip as a file that is streamed from a Flash server, progressively downloaded from a Web server, embedded (stored in movie) or linked (stored out of movie). It guides you through the steps for the specific deployment method. During the import process, you have the ability to compress the video using user-defined profiles, or preset values, set cue points, and trim excess video. It’s important to understand that although Flash can import a video file, it can’t make the quality of the video any better than the original. If you receive your video from outside sources, there is little you can do; however, if you’re the one shooting the footage, pay close attention to lighting, camera angles, and distractions within the video. The more time and attention you spend taking the video, the better the video will be when imported into Flash. If you do need to tweak a video file, video-editing applications such as Adobe’s Premiere (Mac/Win), and Apple’s Final Cut Pro (Mac) are excellent choice for the budding movie director.

If you have a video-editing application and Flash, you can create a movie against a blue screen and then mask the area out using alpha channel masks. They do this in the movies all the time. The process involves opening the image within a video-editing application, and creating the transparency using a specific color (referred to as blue or green screening), using luminosity levels, or actually creating a mask in an image-editing application such as, Adobe Photoshop, and then importing the mask. When you open the movie in Flash, any other background you place behind the movie will replace the original green screen.
Importing video into Flash is not much more difficult than importing a graphic or audio file. The Video Import Wizard is Flash’s way of helping you through the process of importing video files into Flash. When you import video, the Wizard lets you import a video clip as a file that is streamed from a Flash server, progressively downloaded from a Web server, embedded (stored in movie) or linked (stored out of the movie). It guides you through the steps for the specific deployment method. During the import process for some methods, you have the ability to compress the video using user-defined encoding profiles, set cue points, and trim excess video. You can choose to accept the Wizard’s recommendations or make changes. You can also attach movie playback controls with different looks, known as skins. The Wizard seamlessly uses the Skinning component to attach movie controls.

**Use the Video Import Wizard**

1. Click the File menu, point to Import, and then click Import Video.
   - For the FLV format, use Import To Library since the file is native to Flash and doesn’t need to be encoded.
   
   Flash saves the video in the active document’s Library.

2. Select a video file location option:
   - Click the On Your Computer option, click Browse to manually locate the video file.
   
   Choose a video method from the following options:
   - Load external video with playback component.
   - Embed FLV in SWF and play in timeline.
   - Import as mobile device video bundled in SWF.
   - Click the Already deployed to a web server, Flash Video Steaming Service, or Flash Media Server option, and then enter in the file’s URL.

3. Click Next.
Options vary depending on the deployment method; select the ones you want.

- **Skinning**. Specify the appearance and position of the play controls.
- **Embedding**. Specify a symbol type, and other embedding options.

5. Click **Next**.

6. Click **Finish**.

Flash will automatically create an FLV component, and drop it into the active layer on the Timeline.

7. Click the **Control** menu, and then click **Test Movie** to view the video file as it will appear.

---

**See Also**

See “Working with the Video Encoder” on page 342 for information on Flash video encoding settings.

---

**Supported Video Formats**

<table>
<thead>
<tr>
<th>Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.avi</td>
<td>Audio Video Interleaved</td>
</tr>
<tr>
<td>.dv</td>
<td>Digital video</td>
</tr>
<tr>
<td>.flv</td>
<td>Adobe Flash Video</td>
</tr>
<tr>
<td>.mpg, .mpeg</td>
<td>Moving Picture Experts Group</td>
</tr>
<tr>
<td>.mov</td>
<td>QuickTime (version 7 for Mac and version 6.5 for Win)</td>
</tr>
<tr>
<td>.wmv, .asf</td>
<td>Windows Media file (Win only with DirectX 9 or later)</td>
</tr>
</tbody>
</table>
When you import video into a source document, Flash stores a copy of the video in the active document’s Library. Even if you import the video directly to the Stage, Flash will still place a copy in the Library. It’s always best to import video files first into the Library; that way you have control of the video and how it’s brought onto the Stage. Moving a video file directly to the Stage is the easiest way to incorporate video into a Flash movie. In fact, once the video file has been imported into Flash, it’s a simple drag and drop operation. However, video files should always be held within a separate layer. That gives you control over the display of the video and lets you place other Flash elements in other layers.

**Move a Video File Directly to the Stage**

1. Open a Flash source document (.fla) that contains one or more video files in the Library.

   **IMPORTANT** To work directly with video files on the Timeline, you will have to Import them using the Embed video in SWF and play in Timeline (see Using the Video Import Wizard).

2. Click the Window menu, and then click Library to open the Library panel.

3. Click the Insert Layer button, and then name the new layer video_1.

4. Select the new layer.

5. Drag the video file from the Library onto the Stage.

6. Click Yes, if prompted to a dialog box indicating how many frames the video file will occupy on the Stage.

7. Click the Control menu, and then click Test Movie to view the video file as it will appear.
While placing a video file directly onto the Stage may be an easy way to bring a video file into a Flash movie, the best way to control video is to first place it into a movie clip, and then drag the movie clip onto the Stage. That gives you control of the clip with two Timelines: the Timeline on the Stage, and the Timeline of the movie clip.

Using Movie Clips with Video Files

**Use Movie Clips with Video Files**

1. Click the **Window** menu, and then click **Library** to open the Library panel.
2. Click the **Insert** menu, and then click **New Symbol**.
3. Name the new symbol, and then click the **Movie Clip** option.
4. Click **OK**.
5. Drag a video file from the Library into the movie clip Library.
6. Click **Yes** when Flash instructs you as to how many frames the video file will occupy in the movie clip.
7. Return to the current scene by clicking the **Scene** button, located in the upper-left corner of the Flash window.
8. Click the **Insert Layer** button, and name the new layer video_1.
9. Select the new layer.
10. Drag the movie clip from the Library onto the Stage.
   The movie clip occupies a single frame.
11. Click the **Control** menu, and then click **Test Movie** to view the video file as it will appear.
Using Video with ActionScript

Control Video from the Timeline

1. Create or open a Flash document, create a new layer to hold the video file, and then select the layer.
2. Drag the video file from the Library to the Stage.
3. Create a new layer to hold the navigation buttons, and then select the layer.
4. Drag the Play, Stop, and Rewind buttons into the Navigation layer from the Library, and then place them underneath the video.
5. Click the Window menu, and then click Actions to open the Actions panel.
6. To display scripting language commands for the scripting language you want to use, click the Language button, and then select the language you want.

Did You Know?

You can check the syntax of any script with the click of a button. Click the Check Syntax button, located at the top of the Actions panel, and Flash will check the syntax of the your script.
Do either of the following depending on your ActionScript version:

- **ActionScript 2.0.** Select the Play, Stop, and Rewind buttons individually, and then enter the ActionScript 2.0 script as shown in the illustration.

- **ActionScript 3.0.** Click Frame 1 in a layer, and then enter the ActionScript 3.0 script as shown in the illustration.

**IMPORTANT** ActionScript is a relatively easy language to learn, but it is also a very unforgiving language. For example, the gotoAndStop script must be written exactly as shown, including the capital "A" and "S". While ActionScripting, remember to keep an eye on syntax.

Click the Control menu, and then click Test Movie to test the ActionScript.

**IMPORTANT** Although working with embedded video is a common practice, large video files can cause audio sync problems when the file is published and played. It’s always wise to thoroughly test your published documents.

**Did You Know?**

*Flash contains several sets of pre-designed buttons.* Click the Window menu, point to Common Libraries, and then click Buttons. Flash’s button Library contains folders with dozens of buttons, including arcade buttons and buttons for controlling a Flash movie.

**For Your Information**

**Referencing Movie Clips in the Timeline**

Since movie clips have independent Timelines, referring to them can sometimes be confusing. When you are working on a movie clip in the Timeline for the main Flash document, you refer to it with ActionScript with _root. However, if you are working on a movie clip in another Timeline, you refer to it with _parent._parent always refers to the Timeline that contains the movie clip.
While it's an easy matter to drag a video file onto the Stage and then use start and stop ActionScripts to control the playing of the video, it’s better to create a movie clip, and then load the video file into the clip. It’s a bit more work, but the additional rewards are great. For example, you can instruct a movie clip to stop playing without affecting anything else on the Stage. As a matter of fact, you can have as many movie clips on the Stage as you want, and each one can be controlled individually. It’s exactly that kind of control that leads to awesome Flash movies. To control a video using a movie clip you will need to have a flash document that contains one or more video files, in the Library.

Control Video Through Movie Clips

1. Create or open a Flash document, click the Insert button, and then click New Symbol.
2. Name the symbol, and then click the Movie Clip option.
3. Click OK.
4. Drag a video file from your Library into the movie clip symbol.
5. Click the Scene button to return to the Stage of the active scene.
6. Create a new layer to hold the video, and then select the layer.
7. Drag the movie clip to the Stage, and then select the clip.
8. Enter a unique Instance name in the Property Inspector.

**IMPORTANT** The Instance name you enter will be used in the ActionScript to identify the movie clip to the button object “with (instance name)”.

9. Create a new layer to hold the navigation buttons, and then select the layer.
Drag Play, Stop, and Rewind buttons into the Navigation layer from the library, and then place them underneath the video.

Click the Window menu, and then click Actions.

To display scripting language commands for the scripting language you want to use, click the Language button, and then select the language you want.

Do either of the following depending on your ActionScript version:

- **ActionScript 2.0.** select the Play, Stop, and Rewind buttons individually, and then enter the ActionScript 2.0 script as shown in the illustration.

- **ActionScript 3.0.** Click Frame 1 in a layer, and then enter the ActionScript 3.0 script as shown in the illustration.

**IMPORTANT** ActionScript is a relatively easy language to learn, but it is also a very unforgiving language. For example, the gotoAndStop script must be written exactly as shown, including the capital "A" and "S". While ActionScripting, remember to keep an eye on syntax.

Click the Control menu, and then click Test Movie to test the ActionScript.
Instead of importing video into Flash, you can also use the FLVPlayback components to dynamically play external FLV files in Flash Player. The FLVPlayback component is the display area (made up of a customizable skin with playback controls) in which you view video. Simply export your movie as an FLV file from Flash or a video editing programs using the FLV Export plug-in, and then use the FLVPlayback component in Flash to play it back. If you want to include closed captioning (W3C standard XML format Timed Text), you can use the FLVPlayback Captioning component

---

**Working with the Flash Player Component**

**Work with the FLV Playback Component**

1. Create or open a Flash document.
2. Click the **Window** menu, and then click the **Components** and **Component Inspector** to open the panels.
3. Click the **Video** plus sign (+) to expand the list.
4. Drag the **FLVPlayback** component onto the Stage, and then select the component.
5. In the Component Inspector panel, click the **Parameters** tab.
6. Click the **contentPath** (2.0) or **Source** (3.0) value field, and then click the **Magnifying Glass** icon.
7. Click the **Browse folder** icon, navigate to and select the FLV video file that you want to use, and then click **Open**.
8. Click **OK**.
9. Select from the following FLVPlayback parameters:
   - **align** (3.0). Specify FLV file alignment in the player.
   - **autoPlay**. Specify True or False to automatically play the FLV file.
   - **autoRewind** (2.0). Specify True or False to automatically rewind the FLV file upon completion.
◆ **autoSize (2.0).** Specify True or False to resize the component at runtime.

◆ **bufferTime.** Specify the number of seconds to buffer before beginning playback.

◆ **cuePoints.** Specify a string with the cue points for the video.

◆ **isLive.** Specify True or False whether the FLV is streaming live.

◆ **preview (3.0).** Creates a preview for authoring purposes.

◆ **maintainAspectRatio (2.0) or scaleMode (3.0).** Specify True or False to retain the source video aspect ratio.

◆ **skin.** Select a skin and color for the FLV video player.

◆ **skinAutoHide.** Specify True or False to automatically hide or show the skin.

◆ **skinBackground Alpha (3.0).** Specify a background alpha channel for the skin.

◆ **skinBackgroundColor (3.0).** Specify a background color for the skin.

◆ **volume.** Specify a volume setting for the video.

10 Click the Control menu, and then click Test Movie to test the video in the Flash player.
Working with the Media Player for Streaming Video

Work with the Media Playback Component

1. Create or open a Flash document (ActionScript 2.0).
2. Click the Window menu, and then click the Components and Component Inspector to open the panels.
3. Click the Media plus sign (+) to expand the list.
4. Drag the MediaPlayback component onto the Stage, and then select the component.

Did You Know?

The MediaPlayback component (2.0) is a combination of the MediaDisplay and MediaController components. The combination provides the functionality to stream the video.
In the Component Inspector panel, click the Parameters tab.

Click the FLV option.

Enter the URL of the Flash movie file.

Select the Automatically Play check box to have the video automatically play when loaded.

Select the Use Preferred Media Size check box to display the video using the original file’s width and height.

Select the Respect Aspect Ratio check box to keep the video’s width and height in proportion.

Click the Top, Bottom, Left, or Right option for the placement of the control panel.

Click the Auto, On, or Off option to control when the control panel appears with the video.

Click the plus sign (+) button to add cue points to the video file, using hours, minutes, seconds, and milliseconds.

Click the Control menu, and then click Test Movie to test the video in the Flash player.

For Your Information

Streaming Video

Flash gives you three ways to control streaming video files: the Media Player, Media Controller, and Media Display. Each of these components lets you control video (or audio) as a separate file that is loaded into the Flash movie. Flash media components support files in the FLV (video) or MP3 (audio) formats, and since the components must use Adobe Flash Communications Server technology, the Flash files must be saved in the Flash 7 player or later.
The Flash Media Controller component (ActionScript 2.0) lets you control a streaming media file that has been loaded using a Media Display component. The Media Display component gives you an easy way to create a placeholder for a video file, without any play, pause, or rewind buttons. The Media Controller component provides you with standard controls (play, pause, and rewind) for playback of any video on the screen. The Media Controller component is an excellent choice for controlling video and audio files placed on the screen using the Media Display component. The media components require Flash Player 6 or later and don’t support accessibility.

Did You Know?
You can use the Media components to give you control over precise placement of the controller. Drag the Media Controller on the Stage and place it anywhere you like. The advantage of the Media Controller is that you decide the placement of the controls in relationship to the player. This gives you a distinct design advantage over using the Media Player component.
In the Component Inspector panel, click the **Parameters** tab.

Click the **FLV** option.

Enter the URL of the Flash movie file.

Clear the **Automatically Play** check box to play the video when loaded.

Select the **Use Preferred Media Size** check box to display the video using the original file’s width and height.

Select the **Respect Aspect Ratio** check box to keep the video’s width and height in proportion.

Click the plus sign (+) button to add cue points to the video file, using hours, minutes, seconds, and milliseconds.

Drag the Media Controller component onto the Stage, and select the component.

In the Property Inspector, enter a unique instance name for the Controller component.

Click the **Add Behavior** button (+), in the Behaviors panel, point to **Media**, and then click **Associate Display**.

Select the instance name given to the Media Display component, and then click **OK**.

This associates the controller with the correct video.

Click the **Control** menu, and then click **Test Movie** to test the video in the Flash player.
Exporting as a QuickTime Video

Export Flash as a QuickTime Video

1. Click the File menu, point to Export, and then click Export Movie.
2. Click the Format popup (Mac) or Save As Type list arrow (Win), and then click QuickTime.
3. Type the new file name.
4. Navigate to the drive or folder location where you want to save the document.
5. Click Save.
   The QuickTime Export Settings dialog box opens.
6. If available, specify the width and height in pixels you want for the QuickTime video.
   ◆ To maintain the same ratio of width and height, select the Maintain Aspect Ratio check box.
7. To create an alpha channel using the Stage color, select the Ignore Stage Color (Generate Alpha Channel) check box.
   The alpha channel is encoded as a transparent track, letting you overlay the exported QuickTime movie on top of other content to alter the background color or scene.

Flash makes it easy to export a Flash document to a QuickTime video using the QuickTime Export Settings dialog box. By default, Flash creates a QuickTime video of the complete source document with the same dimensions. However, you can change the export options. In the QuickTime Export Settings dialog box, you can set movie dimensions, ignore stage color, specify when to stop exporting and where to store temporary data, and set advanced QuickTime settings. The advanced QuickTime settings are set for optimal playback. If you have experience using QuickTime, you can set the advanced settings to customize the results you want.
Click the When Last Frame Is Reached or After Time Elapsed option and then specify the time you want in the format (hh:mm:ss.msec), where hh is hours, mm is minutes, ss is seconds, and msec is milliseconds.

Click the In Memory or On Disk option to specify where you want to store temporary data.

Click QuickTime Settings.

Select the Video check box, and then click the buttons where you want to make video option changes.

- **Settings.** Select video compression type, quality, frame rate, and data rate.
- **Filter.** Select a video filter, such as blur, emboss, sharpen, and special effects.
- **Size.** Select a standardized size, such as NTSC, PAL, etc.

Select the Sound check box, and then click the buttons where you want to make audio option changes.

- **Settings.** Select sound compression, sample rate, sample bit size, and usage (mono or stereo).

To optimize for Internet streaming, select the Prepare For Internet Streaming check box, and then select the option you want.

Click OK.

Click Export.

Upon completion, click OK.
Publishing as a QuickTime Video

Publish Flash Documents as a QuickTime Video

1. Click the Edit (Win) or Flash (Mac), click Preferences, click QuickTime, click Advanced Media Types, select the Enable the use of Flash Tracks check box, and then click OK twice.

2. Click the File menu, and then click Publish Settings.

3. Click the Formats tab.

4. Select the QuickTime with Flash Track (.mov) check box.
   - If a warning appears, click OK.
   - Click the Flash tab, click the Version popup, and then select Flash Player 5. However, this may change when a newer version of the QuickTime Player is released.

5. Click the QuickTime tab.

6. Select the Match Movie check box or specify the width and height in pixels you want for the QuickTime video.

7. Click the Alpha popup, and then select from the following options:
   - **Auto.** Creates a transparent Flash track when it’s on top of any other tracks, or an opaque track when it’s at the bottom or the only track.
   - **Alpha-transparent.** Creates a transparent Flash track SWF file and shows any content in tracks behind it.

If you have QuickTime software developed by Apple Computer installed on your computer, you can publish a Flash document to Flash 5 or earlier as a QuickTime video in the same format you have installed. The Flash document plays in the QuickTime video the same as it does in the Flash Player. If the Flash document also contains a QuickTime video, Flash copies it to its own track in the published QuickTime video file. To publish a QuickTime video, you use the QuickTime tab in the Publish Settings dialog box, where you can set the options you want.
◆ **Copy.** Creates an opaque Flash track and masks all content in tracks behind it.

7 Click the **Layer** popup, and then select from the following options:

◆ **Auto.** Puts the Flash track in front of other tracks when Flash objects are in front of video objects, or behind other tracks when Flash objects are not in front.

◆ **Top.** Puts the Flash track on top of all other tracks.

◆ **Bottom.** Puts the Flash track at the bottom behind all other tracks.

8 To stream the video/sound, select the **Streaming sound** check box.

9 If you select Streaming sound, click **Settings**, select sound compression, sample rate, sample bit size, and usage (mono or stereo), and then click **OK**.

10 Click the **Controller** popup menu, and then select the type of QuickTime controller you want to use to play the video: **None**, **Standard**, or **QuickTime VR**.

11 Select the playback options you want:

◆ **Loop.** Select to repeat the video when it reaches the last frame.

◆ **Paused At Start.** Select to pause the video at the start until the user clicks a button.

◆ **Play Every Frame.** Select to play every frame, which maintains time and does not play sound.

12 To combine the Flash content and imported video into a single QuickTime video, select **Flatten (Make Self-Contained)** check box.

13 Click **OK**.
To improve workflow for those of us who love to work with video, Adobe Media Encoder CS4 (New!) includes a stand-alone video encoder that you can install on a computer dedicated to video encoding. The Adobe Media Encoder CS4 lets you batch process video encoding, allowing you to encode several video clips, using different codecs at the same time. The Adobe Media Encoder CS4 also lets you edit video clips, add cue points (to trigger other actions), and crop (change viewable area of video) and trim (edit beginning and end points) the video.

**Working with the Video Encoder**

1. Open the Adobe Media Encoder CS4.
   - Use the Start menu (Win) or Applications folder (Mac).
   - If you’re importing a video, click File, point to Import, click Import Video, and then click Launch Adobe Media Encoder.

2. Click Add to add video files to the batch list.
   - Click the File menu, and then click Add Adobe Premiere Pro Sequence or Add Adobe After Effects Composition to add these file types.

3. Click Duplicate to make a copy of the selected video file, which saves the same video file using different compression settings.

4. Click Remove to remove the selected video file from the batch list.

5. Select the video that you want to change settings.

6. Click the Format menu, and then select a format with which to encode the video or audio clip.
   - The selected format displays a list of available presets designed for the delivery format.

7. Click the Preset menu, and then select an encoding preset for your intended application.
Click the Output filename, specify a location and file name for the encoded file or use the default filename from the source clip.

Click the Edit menu, and then click Export Settings.

The Export Settings dialog box appears, displaying tabs for Source and Output.

Click the Advanced Mode button.

This button toggles between Simple Mode and Advanced Mode.

Click the Source tab.

Select the Export Video check box, click the Video tab, and then specify a frame rate, and other video options.

Select the Export Audio check box, click the Audio tab, and then select a kbps data rate, quality setting, and other options.

Click the Crop button, enter edge values to crop the video, and then drag the in and out point markers below the scrubber bar to set the video trim points.

Click the Output tab to preview the cropped image. Use the Crop Setting popup to select an option.

Use the cursor to move the playback head to the frame location you want to embed, click Add Cue Point, and then specify the type of cue point you want.

Click OK.

Click Start Queue to begin batch processing all the files in the batch list. Click Stop Queue to halt the process.

The status column provides information for each video during the encoding process.
One of the cool features in Flash is its ability to work alpha channel masks. Alpha masks are typically created within video-editing applications, such as Apple’s Final Cut Pro or Adobe’s Premiere. The process involves opening the image within the video-editing application and creating the transparency using a specific color (referred to as blue or green screening), using luminosity levels, or actually creating a mask in an image-editing application such as Adobe Photoshop, and then importing the mask. For example, you could film yourself against a green screen, and then mask those areas out. When you open the movie in Flash, any other background you place behind the movie will replace the original green screen. They do this in the movies all the time.

### Working with Alpha Channel Masks

1. Open your video-editing application, and create a specific alpha channel mask.
   
   The mask represents the areas of the movie for which you want to maintain transparency.

2. Use your video-editing Export command and then select the Flash FLV format.

3. Click **Options** or select options for exporting a Flash FLV file.
   
   - If Options is not available, open the Adobe Media Encoder CS4 (from the desktop), add the FLV file to the queue select a FLV preset format, and then open the Export Settings dialog box. Click the **Edit** menu, and then click **Export Settings**.

   The Export Settings dialog box appears, displaying tabs for Source and Output.

4. Click the **Advanced Mode** button.

   This button toggles between Simple Mode and Advanced Mode.

5. Click the **Source** tab.

6. Select the **Export Video** check box.
Click the **Video** tab.

Click the **On2 VP6** option.

Select the **Encode Alpha Channel** check box.

Click **OK**.

Click **Save** to save the file.

Open Flash Professional.

Click the **File** menu, point to **Import**, and then click **Import Video**.

Use the steps outlined in “Using the Video Import Wizard” on page 324.

Move to the Timeline and create a new layer directly underneath the video layer, and name it backdrop.

Place an image in the backdrop layer.

Click the **Control** menu, and then click **Test Movie** to view the video file as it will appear.

When you view the movie, the areas designated as transparent by the alpha channel mask will display the contents of the backdrop layer, directly through the running video.

---

**See Also**

See “Using the Video Import Wizard” on page 324 for more information on using the Video wizard.

See “Working with the Video Encoder” on page 342 for information on Flash video encoding settings.
The FLV (Flash Video) file format allows you to import or export a static video stream including encoded audio. For example, you could use the FLV format to save video for use with communications applications, such as video conferencing. When an FLV clip is exported with streaming audio, the audio is compressed using the Streaming Audio settings in the Publish Settings dialog box, and the file is compressed. FLV files can be used with Flash’s new media components to create streaming video files directly in a Flash movie. In order to use the FLV format, you must first set up the video files for exporting. Any Flash document that contains video clips will work.

Exporting as a FLV File

Export Video Clips into the FLV File Format

1. Select a video clip in the Library panel.
2. Click the Libraries Options button, and then click Properties.
3. Click Export.
4. Enter a name for the exported file.
5. Select a location where it will be saved.
6. Click Save.
7. Click OK.

Did You Know?

You can use the Property Inspector to modify a Flash FLV video clip. Drag the FLV video file onto the Stage, select the video clip, and then open the Property Inspector. The Property Inspector lets you give the clip an instance name; change the width, height, and registration point of the clip; and even swap a video clip with another video clip.

For Your Information

Progressive Downloads

When FLV video files are played back, they’re handled as a progressive download—Progressive downloads begin playing as soon as a certain percent of the complete file has been transferred. The playback is not as quick as that provided by streaming video, but it’s not as slow as complete file download formats such as the MPEG video.
Working with Flash and Other Multimedia

FROM

Adobe Dreamweaver CS4 On Demand

by Steve Johnson, Perspection Inc.

ALSO AVAILABLE
- SONY READER: 978–0–768–68859–7
- ADOBE READER: 978–0–768–68764–4
- SAFARI BOOKS ONLINE: 978–0–768–68794–1

TABLE OF CONTENTS

Chapter 1: Preparing and Planning a Web Site
Chapter 2: Getting Started with Dreamweaver CS4
Chapter 3: Working Within the Dreamweaver Environment
Chapter 4: Managing Web Site Files
Chapter 5: Working with Web Page Text
Chapter 6: Working with Web Page Images
Chapter 7: Linking Web Pages
Chapter 8: Working with Web Page Tables
Chapter 9: Working with Cascading Style Sheets
Chapter 10: Creating Page Layouts Using CSS–P
Chapter 11: Creating Frames
Chapter 12: Working with Flash and Other Multimedia
Chapter 13: Creating Forms
Chapter 14: Viewing the HTML Behind the Page
Chapter 15: Working with Behaviors
Chapter 16: Using Spry Widgets and Effects
Chapter 17: Using Code Snippets and Libraries
Chapter 18: Creating Templates
Chapter 19: Testing a Web Site
Chapter 20: Managing a Web Site
Chapter 21: Moving Your Site to the Internet
Chapter 22: Automating Dreamweaver

informIT.com
Working with Flash and Other Multimedia

Introduction

It almost seems that every page you visit on the Web uses Flash or other multimedia in some way or another. Whether it's an intro movie, or animated buttons, it's everywhere. However, if you don't have applications such as Flash, does that mean you can't create multimedia? If you have Dreamweaver it's a snap to quickly add Flash and other multimedia to your Web pages.

In addition to Flash elements such as text and buttons, Dreamweaver lets you add user-defined Flash movies, Java Applets (Java programs used on Web pages to operate animation, calculators, and other tasks), and ActiveX Controls (can be used to add specialized functionality, such as animation, pop-up menus, or Web pages). Most multimedia is controlled by specific plug-ins. For example, the Flash plug-in allows you to play flash movies, just as the QuickTime plug-in allows you to play QuickTime movies. Plug-ins are a part of the open application architecture of Web browsers. Without the ability to use plug-ins, the only way you would be able to use some of the current multimedia would be if the players were actually coded into the browsers, which would be unreasonable and not very practical.

This chapter will introduce you to multimedia and how to incorporate it into your Web design. As with anything in design, the important thing is to use multimedia to support your message, not just to fill space.
Introducing Flash File Types

Adobe Flash allows you to create a variety of file types—FLA, SWF, SWT, SWC, and FLV—for different purposes. The Flash file (.fla) is the source file format for the Adobe Flash program. This file format cannot be opened in Dreamweaver; you can only open this file format in Flash. You use the source Flash file (.fla) to create the other Flash file formats.

You can insert the following Flash file formats into a Web page in Dreamweaver:

◆ **Flash SWF (.swf).** This file format creates a compressed movie of the Flash (.fla) file.

◆ **Flash Template (.swt).** This file format creates a SWF file you can customize with your own text or links, such as a Flash button or Flash text.

◆ **Flash element file (.swc).** This file format creates a SWF file you can create Rich Internet applications with customizable parameters.

◆ **Flash Video file (.flv).** This file format creates a video file with audio and video encoding you can play in the Flash Player.

If you have Adobe FlashPaper 2 or later, you can convert printable files into Flash documents or Adobe PDF files, which you can insert into Dreamweaver.

You don’t need to have Adobe Flash installed on your computer to insert these file formats into pages in Dreamweaver. However, when you do have Adobe Flash installed on your computer, you can make changes to the source Flash files (.fla), and then create the file format you want to use in Dreamweaver.

You can use the Media button on the Common tab on the Insert panel, or use the Media submenu on the Insert menu to add different Flash file types into a page in Dreamweaver.
Inserting a Flash or Shockwave Movie

Flash can create all types of multimedia content. From a lead-in page (called a splash screen), to animated banners, to cool-looking, as well as functional menus, Flash is leading the way in Web based multimedia content. Flash utilizes resolution independent vector graphics, streaming audio, and even raster images to create fast-loading Web content. Flash is so popular that according to the World Wide Web Consortium, over 90 percent of people surfing the Web have browsers that can view Flash content. And since version 4, Flash has its own scripting language to help designers take designs into the Stratosphere.

Dreamweaver does not create Flash movies; however, it makes it very easy to add them to your Web pages. Once inserted, the Properties panel will give you access to controls that instruct the browser exactly what to do when the movie loads.

1. Open the Web page you want to insert a movie.
2. Click to place the insertion point where you want the movie.
3. Insert the movie using one of the following options:
   - Click the Common tab on the Insert panel, click the Media arrow button, and then click SWF or Shockwave.
   - Click the Insert menu, point to Media, and then click SWF or Shockwave.
4. Navigate to the location with the Flash file (extension .swf or .swc), and then select it.
5. Click OK.
6. Enter the accessibility attributes (title, access key, and tab index) you want.
7. Click OK.
8. To view the Flash content, click the Flash placeholder icon, and then click the Play button in the Properties panel to begin the preview. Click Stop to end the preview.
Changing Flash or Shockwave Movie Properties

Change Flash Movie Properties

1. Open the Web page with the movie you want to change properties.
2. Select the Flash SWF file or a Shockwave movie.
3. Click the Window menu, and then click Properties to display the Properties panel.
4. Click the expander arrow in the lower-right corner of the Properties panel to view all Flash options.
5. Set any of the following options to control a Flash or Shockwave movie:
   - **Name.** Enter a name to identify the movie for scripting.
   - **W and H.** Enter the width and height of the movie (in pixels).
   - **File.** Enter the path to the Flash or Shockwave file. Or click the folder icon to browse to a file, or type a path.
   - **Src.** Specifies the path to a Flash source document (FLA) (when Dreamweaver and Flash are both installed on your computer).
   - **Edit.** Click to locate and update a FLA file; the option is grayed out if the Flash program is not installed on your computer.
   - **Reset Size.** Click to return the selected movie to its original size.

After you insert a Flash or Shockwave movie into your page in Dreamweaver, you can use the Properties panel to set or change movie properties. You can use the Properties panel to adjust the movie size and scale, set loop and autoplay options, show or hide a border, align the movie on the page, and specify a background color for the movie area. If you have the Flash program installed on your computer, you can even edit the source Flash file (.fla) associated with the SWF file directly from the Properties panel.
◆ **Loop.** Select to make the movie play continuously.

◆ **Autoplay.** Select to automatically play the movie when the page loads.

◆ **V Space and H Space.** Specify the number of pixels of white space above, below, and on both sides of the movie.

◆ **Quality.** Controls anti-aliasing during playback of the movie.

◆ **Scale.** Controls how the movie fits into the dimensions set in the width and height text boxes.

◆ **No Border.** Select to fit the movie into the set dimensions so that no borders show and it maintains the original aspect ratio.

◆ **Exact Fit.** Select to scale the movie to the set dimensions, regardless of the aspect ratio.

◆ **Align.** Controls how the movie is aligned on the page.

◆ **Bg.** Defines a background color for the movie area.

◆ **Parameters.** Opens a dialog box for entering additional parameters to pass to the movie.

---

**Did You Know?**

*You can preview all Flash content in a page.* Press Ctrl+Alt+Shift+P (Win) or Shift+Option+P (Mac) to set all Flash objects and SWF files to play.
When you create a Flash video (.flv) file using Adobe Flash, you insert the Flash video component in Dreamweaver. When you view the page in a browser, the component displays the Flash video and playback controls. You can deliver the Flash video in two delivery formats: Progressive Download Video or Streaming Video. **Progressive Download Video** downloads the FLV file to the visitor’s computer and then plays it. The video starts to play before the download is complete to speed up the process. On the other hand, **streaming video** buffers the video on the Web server with Adobe Flash Media Server, and then plays it.

### Inserting a Flash Video

1. **Open the Web page you want to insert a Flash video.**
2. **Click to place the insertion point where you want the Flash video.**
3. **Insert the Flash video using one of the following options:**
   - Click the **Common** tab on the Insert panel, click the **Media** arrow button, and then click **FLV**.
   - Click the **Insert** menu, point to **Media**, and then click **FLV**.
4. **Click the **Video Type** popup, and then click **Progressive Download Video** or **Streaming Video**.**
5. **Select from the following Flash video options:**
   - **URL (Progressive).** Specifies a relative or absolute path to the FLV file.
   - **Server URI (Streaming).** Specifies the server name, program name, and instance name.
   - **Stream Name (Streaming).** Specifies the name of the FLV file; .flv extension is optional.
   - **Skin.** Click the **Skin** popup, and then select the appearance of the Flask Video component.
◆ **Width and Height.** Specifies the width and height of the FLV video (in pixels).

◆ **Constrain.** Select to maintain the same aspect ratio between the width and height.

◆ **Live Video Feed (Streaming).** Select to play the streaming live video content from the Flash Media Server.

◆ **AutoPlay.** Select to play the video when the page opens.

◆ **Auto Rewind.** Select to return the playback to the beginning.

◆ **Buffer Time (Streaming).** Specifies the time (in seconds) needed to buffer before the video starts to play.

6 Click **OK**.

---

**Did You Know?**

*You can remove the code that detects the Flash Player version.* Click the Commands menu, and then click Remove Flash Video Detection.

*You can delete the Flash Video component.* Select the Flash Video component, and then press Delete.

*You can edit the Flash Video component.* Select the Flash Video component placeholder, open the Properties panel, and then make your changes.
If you have Adobe Fireworks 4 or later installed on your computer, you can create a complete Web photo album in Dreamweaver within minutes. The Web photo album contains thumbnails that when clicked show the larger size of the pictures with navigation to go forward or backward to view the entire album. A Web photo album can be used to showcase products, portfolios, art and photography galleries and more… Dreamweaver thinks of everything.

Creating a Web Photo Album

1. Create a folder for your photo album on your hard drive (in this example, a folder was created named, PhotoAlbum).
2. Open Dreamweaver, and then open a blank page (only used to access the Create Web Photo Album command).
3. Click the Commands menu, and then click Create Web Photo Album.
4. In the Create Web Photo Album dialog box, specify any of the following options:
   - **Photo Album Title.** Enter a title for the photo album (appears in the thumbnail page).
   - **Subheading Info.** Enter subheading info (shows along with the enlarged pictures).
   - **Other Info.** Enter any additional information (shows along with the enlarged pictures).
   - **Source Images Folder.** Click Browse to select the folder containing the original images.

   **NOTE** Keep the file names of your original images to the old 8.3 rule, and avoid special characters.

   - **Destination Folder.** Click Browse to select the folder you created in step 1 (this folder should be located within the working site folder).
◆ **Thumbnail Size.** Click the button to select a specific size for the thumbnails.

◆ **Show Filenames.** Select to display filenames along with the images.

◆ **Columns.** Enter the number of columns to use for displaying the thumbnails.

◆ **Thumbnail Format.** Select a thumbnail file format.

◆ **Photo Format.** Select a photo file format.

◆ **Create Navigation Page For Each Photo.** Select to create a navigation page for each image.

5 Click **OK** to create the album.

Dreamweaver prompts you with a popup box, and a message saying that the photo album has been created and you can view the album.

6 Click **OK**.

Dreamweaver creates three sub-folders inside your original folder, and an index page.

◆ **Thumbnails.** Contains all the thumbnails.

◆ **Images.** Contains all the images.

◆ **Pages.** Contains the larger images and navigation between pictures and go back to home.

◆ **Index.htm.** The page which will have all the thumbnails with links to the larger images.

---

**For Your Information**

**Using CSS Styles with the Index Page**

Once the index page is created you can modify it to fit the style of your site. Open the index page and apply a template to format the page or use CSS Styles to format the text you want to change.
If you want to add some life to a Web page, you can add sound to it. Dreamweaver allows you to add a variety of sounds formats, including WAV, MIDI, MP3 (MPG), AIF, RA (Real Audio), MOV (QuickTime). Some audio formats require visitors to download and install a plug-in to play the sound. Some plug-ins include QuickTime, Windows Media Player or RealPlayer. You can add a sound to a page by linking the audio file to text or an image or by embedding the audio file directly into the page. When you link an audio file, the visitor needs to click the link to play the sound. When you embed an audio file, the sound plays when you load a page with a background sound, or when you trigger an event. When you add sounds to one or more pages, use careful judgement and discernment. The old adage “less is more” seems to be a good rule of thumb. It's always a good practice to provide a way for visitors to turn off the sound.

Linking or Embedding Sound

Did You Know?
You can link to or embed other videos (AVI or MPEG). Instead of using a sound file, you can use the same steps to link to a video file or embed a video file.
Chapter 12 Working with Flash and Other Multimedia

Embed a Sound File

1. Open the Web page you want to embed a sound file.
2. Click to place the insertion point where you want to embed a sound file.
3. Embed a sound file using one of the following options:
   - Click the Common tab on the Insert panel, click the Media arrow button, and then click Plugin.
   - Click the Insert menu, point to Media, and then click Plugin.
4. Open the Properties panel.
5. Click the Browse For File button next to the Link box to select the audio file, or enter the file’s path and name.
6. Enter the width and height for the placeholder, or drag to resize it.
Using Java Applets

You can insert a Java applet into an HTML document using Dreamweaver. Java is a programming language that allows the development of lightweight applications (applets) that can be embedded in web pages. Java applets are executed in a secure area (called a sandbox) by most Web browsers, preventing them from accessing local data. The code of the applet is downloaded from a Web server and the browser embeds the applet into a Web page. In order for an applet to run, it requires the Java plug-in, which isn’t available by default on all browsers. It is considered more difficult to build and design a good user interface with Java than other technologies such as DHTML and Flash. It is, however, still a very popular system for the design of Web navigational systems, games, and audio and text effects.

Insert a Java Applet

1. Open the Web page you want to insert a Java applet.
2. Click in the Document window to place the insertion point.
3. Insert the Java applet using one of the following options:
   - Click the Common tab on the Insert panel, click the Media arrow button, and then click Applet.
   - Click the Insert menu, point to Media, and then click Applet.
4. Navigate to the location with the file containing a Java applet.
5. Select a file containing a Java applet.
6. Click OK.
7. Enter the accessibility attributes (title, access key, and tab index) you want.
8. Click OK.
Modify Java Applet Preferences

1. Open the Web page you want to modify settings for a Java applet.
2. Open the Properties panel, and then click the expander arrow to display all properties.
3. Select the Java applet for which you want to modify settings.
4. Select from the following Java Applet options:
   - **Name.** Enter a name to identify the applet for scripting.
   - **W and H.** Enter the width and height of the applet, in pixels.
   - **Code.** Enter the file containing the applet’s Java code, or click the folder icon to browse to a file.
   - **Base.** Displays the folder containing the selected applet (this text box is filled automatically, when you select an applet).
   - **Align.** Controls the alignment of the applet on the page.
   - **Alt.** Specifies alternative content (usually an image) to be displayed if the user’s browser doesn’t support Java applets or has Java disabled.
   - **V Space and H Space.** Specify the amount of white space in pixels above, below, and on both sides of the applet.
   - **Parameters.** Opens a dialog box for entering additional parameters to pass to the applet.
Using ActiveX Controls

Insert an ActiveX Control

1. Open the Web page you want to insert an ActiveX control.
2. Click to place the insertion point where you want to insert an ActiveX control.
3. Insert the ActiveX control using one of the following options:
   - Click the Common tab on the Insert panel, click the Media arrow button, and then click ActiveX.
   - Click the Insert menu, point to Media, and then click ActiveX.
4. Enter the accessibility attributes (title, access key, and tab index) you want.
5. Click OK.

An icon marks where the ActiveX control appears on the page in Internet Explorer.

You can insert an ActiveX control in your page. ActiveX controls (formerly known as OLE controls) are reusable components, somewhat like miniature applications, that can act like browser plug-ins. They run in Internet Explorer with Windows, but they don’t run on the Macintosh or in Netscape Navigator. The ActiveX object in Dreamweaver lets you supply attributes and parameters for an ActiveX control in your visitor’s browser.
Modify ActiveX Properties

1. Open the Web page you want to modify ActiveX control properties.
2. Select the ActiveX icon in the Document window.
3. Open the Properties panel, and then click the expander arrow to display all properties.
4. Select from the following options:
   - **Name.** Enter a name to identify the ActiveX object for scripting.
   - **W and H.** Enter the width and height of the object (in pixels).
   - **Class ID.** Identifies the ActiveX control to the browser (enter a value or select one).
   - **Embed.** Inserts an embed tag within the object tag for the ActiveX control.
   - **Align.** Aligns the object.
   - **Parameters.** Select to enter additional parameters to pass to the ActiveX object.
   - **Src.** Defines the data file used for a Netscape Navigator plug-in if the Embed option is on.
   - **V Space and H Space.** Enter the amount of white space (in pixels) above, below, and on both sides of the object.
   - **Base.** Displays the URL containing the ActiveX control.
   - **Alt Img.** Enter an image to be displayed if the browser doesn’t support the object tag.
   - **Data.** Enter a data file for the ActiveX control to load.
5. Click the File menu, point to Preview In Browser, and then select a browser to preview the ActiveX control.
Using Plug-ins

Insert Plug-in Content

1. Open the Web page you want to insert a plug-in content.
2. Click to place the insertion point where you want to insert Plug-in content.
3. Insert the Plug-in using one of the following options:
   - Click the Common tab on the Insert panel, click the Media arrow button, and then click Plugin.
   - Click the Insert menu, point to Media, and then click Plugin.
4. Navigate to the location with the Plug-in file, and then select it.
5. Click OK.

An icon marks where the Plug-in control appears on the page in Netscape Navigator.

You can include content on a page that runs in a Netscape Navigator plug-in, such as a QuickTime or RealPlayer movie, in the user’s browser. After you insert content for a Netscape Navigator plug-in, you can use the Properties panel to set options and parameters for the selected element. When you're ready to preview the content, you can play all the plug-in elements at once or play them individually. If you want to play movies in Design view, the proper plug-ins must be installed on your computer.
Play the Plug-in

1. Open the Web page with the plug-in you want to play.

2. Use any of the following options to play a Plug-in:
   - **Selected Elements.** Select the media elements, click the View menu, point to Plugins, and then click Play, or click the Play button in the Properties panel.
   - **All Elements.** Click the View menu, point to Plugins, and then click Play All.

3. Use any of the following options to stop a Plug-in:
   - **Selected Elements.** Click the View menu, point to Plugins, and then click Stop, or click the Stop button in the Properties panel.
   - **All Elements.** Click the View menu, point to Plugins, and then click Stop All.

Troubleshooting Plug-ins

If you have followed the steps to play plug-in content in the Document window, but some of the plug-in content does not play, try the following: (1) Make sure the associated plug-in is installed on your computer, and the content is compatible with the plug-in version; (2) Open the file Configuration/Plug-ins/UnsupportedPlug-ins.txt in a text editor and look to see if the problematic plug-in is listed. This file keeps track of plug-ins that cause problems in Dreamweaver and are therefore unsupported. If you experience problems with a particular plug-in, consider adding it to this file; or (3) Check to see if you have enough memory. Some plug-ins require an additional 2 to 5 MB of memory to run.
Use the Check Plugin action to send visitors to different pages depending on whether they have the specified plug-in installed. For example, you might want visitors to go to one page if they have Shockwave and another page if they do not. The Check Plugins action is an excellent tool for making your visitor’s experience a pleasant one.

Checking for Plug-ins

Use the Check Plug-in Action

1. Open the Web page you want to use.
2. Select an object (for an element) or click the <body> tag in the tag selector (for an entire page).
3. Open the Behaviors panel.
4. Click the Plus (+) button, and then click Check Plugin from the Actions menu.
5. Select a plug-in from the Plugin popup, or type the exact name of the plug-in in the adjacent text box.
6. Configure Check Plug-in using the following options:
   - **If Found, Go To URL.** Enter a URL for visitors who have the plug-in.
     
     **NOTE** To cause visitors with the plug-in stay on the same page, leave this field blank.
   - **Otherwise, Go To URL.** Enter an alternative URL for visitors who don’t have the plug-in.
     
     **NOTE** To cause visitors without the plug-in stay on the same page, leave this field blank.
Always Go To First URL If Detection Is Not Possible. In general, if the plug-in content is integral to your page, select this option; visitors without the plug-in will often be prompted by the browser to download the plug-in. If the plug-in content is not essential to your page, leave this option deselected.

NOTE This option applies only to Internet Explorer; Netscape Navigator can always detect plug-ins.

7 Click OK.
8 Select an event from the popup menu.
9 Click the File menu, point to Preview In Browser, and then select a browser to test the page from the available options.

IMPORTANT Plug-in detection is not possible in Internet Explorer on the Macintosh, and most plug-ins cannot be detected in Internet Explorer on Windows.
The Share My Screen command (New!) on the File menu allows you to connect to Adobe ConnectNow, which is a secure Web site where you can start an online meeting and collaborate on any design project across platforms and programs. You can share and annotate your computer screen or take control of an attendee’s computer. During the meeting, you can communicate by sending chat messages, using live audio, or broadcasting live video. In addition, you can take meeting notes, and share files.

### Sharing My Screen

1. Click the **File** menu, and then click **Share My Screen**.
2. Enter your Adobe ID and password.
   - If you don’t have an Adobe ID and password, click the Create a Free Adobe ID link, and then follow the online instructions.
3. Click **Sign In**.
   - If prompted, sign in to ConnectNow.
4. To share your computer screen, click the **Share My Computer Screen** button.
5. Use the ConnectNow toolbar to do any of the following:
   - **Meeting.** Use to invite participants, share my computer screen, upload a file, share my webcam, set preferences, and end a meeting, and exit Adobe ConnectNow.
   - **PODS.** Use to show and hide pod panels.
   - **Help.** Use to get help, troubleshoot problems, and set account and Flash Player settings.
6. Click the participant buttons at the bottom to specify roles, remove a user, or request control of a user’s computer.
# Working with Text

FROM

Adobe InDesign CS4 On Demand

by Steve Johnson, Perspection Inc.

ALSO AVAILABLE
- ADOBE READER: 978-0-768-68770-5
- SAFARI BOOKS ONLINE: 978-0-768-68771-1

FOR MORE INFORMATION
informit.com/title/9780789738394

<table>
<thead>
<tr>
<th>TABLE OF CONTENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 1: Getting Started with InDesign CS4</td>
</tr>
<tr>
<td>Chapter 2: Creating and Viewing a Document</td>
</tr>
<tr>
<td>Chapter 3: Managing Pages and Books</td>
</tr>
<tr>
<td>Chapter 4: Working with Text</td>
</tr>
<tr>
<td>Chapter 5: Placing and Working with Graphics</td>
</tr>
<tr>
<td>Chapter 6: Working with Objects and Layers</td>
</tr>
<tr>
<td>Chapter 7: Applying and Managing Color</td>
</tr>
<tr>
<td>Chapter 8: Applying Fills, Strokes, and Effects</td>
</tr>
<tr>
<td>Chapter 9: Working with Points and Paths</td>
</tr>
<tr>
<td>Chapter 10: Working with Tables</td>
</tr>
<tr>
<td>Chapter 11: Working with Styles</td>
</tr>
<tr>
<td>Chapter 12: Finalizing a Document</td>
</tr>
<tr>
<td>Chapter 13: Creating an Interactive Document</td>
</tr>
<tr>
<td>Chapter 14: Automating the Way You Work</td>
</tr>
<tr>
<td>Chapter 15: Exporting a Document</td>
</tr>
<tr>
<td>Chapter 16: Printing and Putting a Document</td>
</tr>
<tr>
<td>Chapter 17: Customizing the Way You Work</td>
</tr>
<tr>
<td>Chapter 18: Collaborating with Others</td>
</tr>
<tr>
<td>Chapter 19: Working Together with Adobe Programs</td>
</tr>
<tr>
<td>Workshops: Putting It All Together</td>
</tr>
</tbody>
</table>

informIT.com
Working with Text

Introduction

InDesign comes with two main type tools: Type and Type on a Path. The Type tool allows you to create a rectangle text frame where you can store text in your document, while the Type on a Path tool allows you to add text along the inner or outer edge of a path.

Before you can work with text in InDesign, you need to select it. You can select the entire text frame or the characters in the text frame. You can use the type tools to select only the characters in the text frame, not the text frame itself, or use the Selection and Direct Selection tools to select both characters and the text frame. If you type, paste, or import more text than a text frame can hold, an overflow symbol (a tiny red plus sign in a square) appears on the edge of the text frame. You can reshape the text frame to accommodate the extra text or create a thread (link) to another text frame. You can thread overflow text from one text frame to a new or existing text frame.

InDesign provides two panels to modify characters and paragraphs. With the Character panel, you can change the font family (for example, Arial or Times New Roman) and style (Italic, Bold, or Condensed), as well as change other text attributes, such as size, kerning, scale, tracking, leading, and language. With the Paragraphs panel, you can change text alignment, indenting, and before and after spacing.

When integrating artwork and graphics with your text, you can wrap the text in a text frame around another object, such as a graphic. Another type effect, Create Outlines, allows you to convert characters in a text frame into a separate object with a path.
InDesign comes with two main type tools: Type and Type on a Path. The Type tool allows you to create a rectangle text frame where you can store text in your document, while the Type on a Path tool allows you to add text along the inner or outer edge of a path. In addition to the type tools, you can also use the Frame tools—Rectangle, Ellipse, and Polygon—to add text to your document.

**Using Type Tools**

**Use Type Tools**

1. Click the Type tool slot on the Tools panel.
   - Click the arrow on the right of the Type tools menu to create a detachable panel.
2. Click one of the following Type tools:
   - **Type.** Creates a text frame box.
   - **Type on a Path.** Creates text along the outer edge of an open or closed path.
3. For the Type tool, drag to draw a text box. For the Type on a Path tool, click on a path.
4. Type some text.

Adobe InDesign Type Tool
With the Type tool, you can create a rectangle text box any size that you want. Simply, select the Type tool on the Tools pane, drag to create a text frame and then start typing. When you type text in a text frame, it automatically wraps to the size of the frame. If you type more text than the frame can hold, an overflow symbol (a tiny red plus sign in a square) appears on the edge of the rectangle box. You can reshape the text frame object to display the text or create a thread (link) to another text frame.

Creating Type in a Text Frame

1. Select the **Type** tool on the Tools panel.
2. Drag to create a rectangle text box the size that you want.
   A flashing insertion point appears in the text frame.
3. Type some text. The text automatically wraps to the shape of the text frame. Press Enter (Win) or Return (Mac) if you want to start a new line.
   - If the overflow symbol appears, deselect the text frame, select the **Direct Selection** tool on the Tools panel, and then drag a corner to reshape the text frame.

Adobe InDesign Type Tool
Creating Type Using Frame Tools

Create a Rectangle or Elliptical Frame for Type

1. Select the **Rectangle Frame** or **Ellipse Frame** tool on the Tools panel.
2. Drag to create a rectangle or elliptical frame the size that you want.
   - To create a frame to an exact size, click a blank area, specify the width and height you want, and then click **OK**.
3. Select the **Type** tool on the Tools panel.
4. Click in the frame, and then type some text. The text automatically wraps to the shape of the text frame. Press Enter (Win) or Return (Mac) if you want to start a new line.
   - If the overflow symbol appears, deselect the text frame, select the **Direct Selection** tool on the Tools panel, and then drag a corner to reshape the text frame.

In addition to the Type tool, you can also use the Frame tools—Rectangle, Ellipse, and Polygon—to add text to your document. Instead of a rectangle shape for type, you can create irregular shapes to store text in your document. In addition to creating a polygon shape, you can also use the Polygon Frame tool to create a star shape for type. You can drag to create a frame box to the size that you want. If you need a frame box to be an exact size, you can click a blank area with the Rectangle and Ellipse tools or set width and height settings on the Control panel.
Create a Polygon Frame for Type

1. Double-click the **Polygon Frame** tool on the Tools panel.
2. Enter a **Number of Sides** value for the polygon.
3. Leave the **Star Inset** value at 0% to create a polygon.
4. Click **OK**.
5. Drag to create a polygon frame box the size that you want.
   - As you drag, press the Up or Down arrow keys to increase or decrease the number of sides.
6. Click in the frame with the **Type** tool, and then type some text. The text automatically wraps to the shape of the text frame. Press Enter (Win) or Return (Mac) if you want to start a new line.

Create a Star Frame for Type

1. Double-click the **Polygon Frame** tool on the Tools panel.
2. Enter a **Number of Sides** value for the star.
3. Enter a **Star Inset** value. The higher the amount, the sharper the points.
4. Click **OK**.
5. Drag to create a star frame box the size that you want.
   - As you drag, press the Up or Down arrow keys to increase or decrease the number of sides.
6. Click in the frame with the **Type** tool, and then type some text. The text automatically wraps to the shape of the text frame. Press Enter (Win) or Return (Mac) if you want to start a new line.
With the Type on a Path tools, you can add type along the inner or outer edge of a path. You can place the text on either side of the path, but not on both. If you initially place it on the inner part of the path, you can always move it to the outer part of the path later. When you select text on a path, brackets appear that you can drag to adjust the position and placement of the text.

### Creating Path Type

**Create Type on a Path**

1. Select the **Type on a Path** tool on the Tools panel.
2. Click on the edge of the path (closed or open) to which you want to add type.
   
   A flashing insertion point appears in the text frame. Any fill or stroke on the object is removed.
3. Type some text. The text automatically wraps to the shape of the text frame. Don’t press Enter (Win) or Return (Mac).
   
   The type appears along the edge of the object, conforms to its shape, and removes the fill and stroke.
   
   ◆ If the overflow symbol appears, deselect the text frame, select the **Direct Selection** tool on the Tools panel, and then drag a corner to reshape the text frame.
4. Select a selection tool or select the type tool again.

**Did You Know?**

*You can delete the text on a path.* With a selection tool, select the text path frame, click the Type menu, point to Type On A Path, and then click Delete Type From Path.
Modify Type on a Path

1. Select the Direct Selection tool on the Tools panel.
2. Click on the type.
   Center, left, and right brackets appear around the type.
3. Drag the bracket (not the square) to adjust the position of the type on a path.
   - Swap Sides. Drag the Center bracket to the other side to change the inner/outer position of the type along the path.
   - Left. Drag to position the left side (or starting point) of the type along the path.
   - Center. Drag left or right to position the type along the path.
   - Right. Drag to position the right side (or ending point) of the type along the path.
   If the overflow symbol appears, deselect the text frame, select the Direct Selection tool on the Tools panel, and then drag a corner to reshape the text frame.
4. To change type on path options, click the Type menu, point to Type on a Path, and then click Options.
   - Select the Preview check box to view your changes as you make them.
5. Specify the options (Effect, Flip, Align, To Path, and Spacing) you want, and then click OK.
If you have text from another document that you want to use in your InDesign document, you can use the Place command to import it. You can import text from the following text formats: plain text (TXT), Rich Text Format (RTF), Microsoft Word (DOC or DOCX), or Microsoft Excel (XLS or XLSX). When you import text using the Place command, InDesign allows you to place the text in a new text frame or an existing one.

**Importing Text**

1. Click the **File** menu, and then click **Place**.
2. Click the **Files of Type** (Win) or **Enable** (Mac) list arrow, and then click **Importable Files** or select a text format:
   - **Text Import**. Plain text.
   - **Microsoft Word**. Microsoft Word 2003 (DOC) or earlier.
   - **Microsoft Word 2007**. Microsoft Word 2007 (DOCX) or later.
   - **RTF**. Rich Text Format (RTF).
   - **Microsoft Excel**. Microsoft Excel 2003 (XLS) or earlier.
   - **Microsoft Excel 2007**. Microsoft Excel 2007 (XLSX) or later.
3. Navigate to the drive or folder location with the text file you want to import.
4. Select the text file you want to place.
5. Select the **Replace Selected Item** check box to replace the selected item with the imported text.
6. Click **Open**.
   - The imported text is placed in a loaded text cursor.
7. Click or drag a text frame with the loaded text cursor to place the text where you want it in your document.
Import Text with Options

1. Click the File menu, and then click Place.
2. Click the Files of Type (Win) or Enable (Mac) list arrow, and then click Importable Files.
3. Navigate to the drive or folder location with the text file you want to import.
4. Select the text file you want to place.
5. Select the Show Import Options check box to select import options.
6. Click Open.
7. Select the options you want. Options vary depending on the imported file format.
8. Click OK.
   The imported text is placed in a loaded text cursor.
9. Click or drag a text frame with the loaded text cursor to place the text where you want it in your document.
Flowing Imported Text

Import and Flow Text

1. Click the **File** menu, and then click **Place**.
2. Navigate to and select the text file you want to place, and then click **Open**.

   The imported text is placed in a loaded text cursor.

3. Use any of the following to place the imported text in your document:
   - **New Text Frame.** Drag to create a text frame the size you want.
   - **New Text Frame within Margins.** Click to create a text frame the width of the margins.
   - **Existing Text or Master Text Frame.** With the text or master text frame not selected, click inside the text frame.

Did You Know?

*You can create a master text frame when you create a new document.*

Click the File menu, point to New, click Document, select the Master Text Frame check box, and then click OK.

When you import text into your document, InDesign imports the text into a loaded text cursor with a small text icon and the first part of the text. When the text is loaded, you have several options to place the text into your document. You can create a new text frame or add the text to an existing text frame in a document or master page. When the loaded text cursor displays straight lines, the text will be placed in a new text frame. When the loaded text cursor displays curved lines, the text will be placed in an existing text frame. After you import the text, you can reflow the text manually with the overflow symbol (a tiny red plus sign in a square), or automatically with keyboard options.
Import and Autoflow Text

1. Click the File menu, and then click Place.

2. Navigate to and select the text file you want to place, and then click Open.

   The imported text is placed in a loaded text cursor.

3. Use any of the following to place the imported text in your document:
   - **Semi-Autoflow**. Hold down Alt (Win) or Option (Mac), and then click in an existing frame or drag a new frame. Continue to hold down Alt (Win) or Option (Mac), and then click or drag to create another text frame that is linked to the first.
   - **Autoflow**. Hold down Shift, and then point to an existing frame or master frame (unselected) or click at the top-left corner of the margins, click to flow the text on the page and create as many additional pages as needed.
   - **Autoflow on Fixed Pages**. Hold down Shift+Alt (Win) or Shift+Option (Mac), and then click in the master text frame or the margins of the page to flow text on the number of pages in the document.
If you type, paste, or import more text than a text frame can hold, an overflow symbol (a tiny red plus sign in a square) appears on the edge of the text frame. You can reshape the text frame to display the text or create a thread (link) to another text frame. You can thread overflow text from one text frame to a new or existing text frame. After you create a thread between two or more text frames, you can use the Show Text Threads command on the View menu to display the thread connection. If you no longer want to thread two or more text frames, you can unthread or disconnect them. When you unthread text frames, the text in the text frame remains in the first text frame (it may still overflow). When you disconnect text frames, the text in the text frames remains where it is.

Thread Overflow Text and Show Text Threads

TIMESAVER Double-click an Out Port icon with the Selection tool to create a linked copy of the text frame.

1. Select the Selection tool on the Tools panel.
2. Select the text frame with the overflow text.
3. Click the Out Port icon on the selected object.
4. To create a new text frame for the overflow text, click a blank area or drag to create a text frame.
   To use an existing text frame, click in an existing text frame.
   Overflow text from the first text frame threads to the second text frame.
5. To display a text thread between text frames, select a threaded text frame, click the View menu, and then click Show Text Threads.
Unthread Text Frames

1. Select the Selection tool on the Tools panel.
2. Select a threaded text frame.
3. Double-click the In Port or Out Port icon on the selected object.

Change the Thread Between Frames

1. Select the Selection tool on the Tools panel.
2. Select a threaded text frame.
3. Click the In Port or Out Port icon on the selected object.
4. To create a new text frame for the overflow text, click a blank area or drag to create a text frame.
   To use an existing text frame, click in an existing text frame.
Using Smart Text Reflow

Smart Text Reflow (New!) allows you to automatically add or remove pages when you are typing and editing text. You can use Smart Text Reflow on master text frames (the default) and document text frames. When you want to reflow text in document text frames, the text frame needs to be threaded (linked) to another text frame on a different page. Before you reflow text, you can set Smart Text Reflow options in the Type preferences dialog box.

Set Smart Text Reflow Options

1. Click the Edit (Win) or InDesign (Mac) menu, point to Preferences, and then click Type.
2. Select the Smart Text Reflow check box to enable the feature.
3. Select from the following Smart Text Reflow options:
   - **Add Pages To.** Specify where you want to add overflow pages.
   - **Limit To Master Text Frames.** Select to only reflow text to master text frames. Deselect to reflow text in a threaded text frame from one page to another.
   - **Preserve Facing-Page Spreads.** Select to add two page spreads for text reflow. Deselect to add a single page for text reflow and shuffle pages.
   - **Delete Empty Pages.** Select to delete pages when an empty text frame is the only object on the page.
4. Click OK.
Use Smart Text Reflow

1. In Type preferences, select the **Smart Text Reflow** and **Delete Empty pages** check boxes.

2. Hold down Ctrl+Shift (Win) or ⌘+Shift (Mac), and then click the master text frame to override it.

3. Type text until you fill the text frame to automatically add a page, or delete enough text to automatically delete a page.
Before you can work with text in InDesign, you need to select it. You can select the entire text frame or the characters in the text frame. The selection tools (Selection and Direct Selection) allow you to select both characters and its object. You can use the type tools to select only the characters in the text frame, but not the object. When you add text to a text frame, pressing Enter (Win) or Return (Mac) creates a new paragraph. If you want to force a line break, known as a soft return, instead of a new paragraph, you can press Shift+Enter (Win) or Shift+Return (Mac).

**Select Type and its Object**

1. Select the **Selection** or **Direct Selection** tool on the Tools panel.
2. Use the appropriate selection method:
   - **Type**. Click on the text.
   - **Path Type**. Click on the path or text.

**Type Text**

1. Select the **Type** tool on the Tools panel.

   **TIMESAVER** With a selection tool, double-click text to place the insertion point.

2. Click to place the insertion point where you want to insert text.
3. Type some text. The text automatically wraps to the shape of the text frame.
4. Press Enter (Win) or Return (Mac) to create a new paragraph or press Shift+Enter (Win) or Shift+Return (Mac) to create a new line and not a new paragraph.
Select and Deselect Type Text

1 Select the **Type** tool on the Tools panel.

2 Do any of the following to select:
   - **Text**. Drag the I-beam cursor to select and highlight a word or line of text.
   - **Text Range**. Click to place the insertion point at the beginning of the text range, press Shift, and then click at the end of the text range.
   - **Word**. Double-click a word of text.
   - **Paragraph**. Triple-click a paragraph of text.
   - **All Text**. Click to place the insertion point, click the **Edit** menu, and then click **Select All**.

**TIMESAVER** Click in a text frame, press Ctrl+A (Win) or Ô+A (Mac) to select all the text.

3 To deselect the text, click outside the text frame.
   - You can also click the **Edit** menu, and then click **Deselect All**.

**TIMESAVER** Press Esc to return the text frame from text editing mode.

Did You Know?

You can change what triple-clicking does. Click the Edit (Win) or InDesign (Mac) menu, point to Preferences, click Type, select the Triple Click To Select A Line check box, and then click OK.
InDesign’s Autocorrect feature (New!) automatically corrects common capitalization and spelling errors as you type. Autocorrect comes with hundreds of text and symbol entries you can edit or remove. You can add words and phrases to the Autocorrect dictionary that you tend to misspell, or add often-typed words and save time by just typing their initials. You can use Autocorrect to quickly insert symbols. For example, you can type (c) to insert ©. You can enable Autocorrect and customize settings in the Autocorrect preferences dialog box.

Set Autocorrect Options

1. Click the Edit (Win) or InDesign (Mac) menu, point to Preferences, and then click Autocorrect.
2. Select the Enable Autocorrect check box to enable the feature.
3. Select from the following Autocorrect options:
   - Autocorrect Capitalization Errors. Select to have InDesign automatically correct capitalization errors.
   - Language. Choose the language dictionary you want InDesign to use when checking your text.
4. Do one of the following:
   - Add. Type a misspelled word or an abbreviation to add it the list of words that will be autocorrected.
   - Edit. Select any words you want to change.
   - Remove. Select any words you want to delete.
5. Click OK.
Copying and Moving Text

Copy or Cut and Paste Text

1. Select the Type tool on the Tools panel, and then select the text you want to copy or cut (move).

2. Click the Edit menu, and then click Cut or Copy.

3. Click to place the insertion point where you want to place the text.

4. Click the Edit menu, and then click Paste or Paste Without Formatting.

Drag Text

1. Select the Type tool on the Tools panel, and then select the text you want to move or copy. The cursor changes to an arrow with a T.

2. Use any of the following methods:
   - Move. Drag the selected text to a new text frame location.
   - Copy. Press Alt (Win) or Option (Mac) and drag the selected text to a new text frame location.
   - Inherit Formatting. Press Shift and drag the selected text to a new text frame location. The text inherits the formatting of the of the text destination frame.

Like most programs, you can copy and move text by using the Copy or Cut and Paste commands or drag-and-drop techniques. InDesign is no different. There are a couple of differences. When you paste text, you can paste it without formatting. Another difference is that InDesign allows you to inherit formatting from the destination text when you drag and drop text. You can use the Type preferences dialog box to enable drag and drop editing in Layout view and Story Editor.
A font is a collection of alphanumeric characters that share the same typeface, or design, and have similar characteristics. With the Character panel, you can change the font family (Arial or Times New Roman) and style (Italic, Bold, or Condensed), as well as change other type attributes, such as size, kerning, scale, tracking, leading, and language. You can also change these and other attributes by using the Type menu and Control panel. After you select the text that you want to change, you can change font attributes directly on the Control panel. For example, you can style text using All Caps, Small Caps, Underline, Strikethrough, Subscript and Superscript. As you can see, there are several ways to change font attributes. You can use any one of them.

**Changing Fonts**

**Change Font Family and Style**

1. Select the **Type** tool on the Tools panel, and then select the text that you want to change.
   - You can also select the **Selection** tool, and then click the text frame to change all text in the frame.

2. Select the **Character** panel.
   - Click the **Type** menu, and then click **Character**.

3. Click the **Font Family** list arrow, and then select a font.
   - To see the font family in the style of the font, click the **Type** menu, point to **Font**, and then select a font.

4. Click the **Font Style** list arrow, and then select a font style, such as Italic, Bold, or Bold Italic.

**Did You Know?**

*You can change the text language.*

Select the Character panel, click the Language list arrow, and then select the language that you want to use. You can also select text using any type tool, and then change the text language to something else.
Apply Additional Font Styles

1. Select the **Type** tool on the Tools panel, and then select the text that you want to change.
   - You can also select the **Selection** tool, and then click the text frame to change all text in the frame.

2. Select the **Character** panel.
   - Click the **Type** menu, and then click **Character**.
   - You can quickly access the following styles on the Options menu or the Control panel.

3. Click the **Options** menu, and then select the style you want:
   - **All Caps**. Changes lowercase letters to all capitals.
   - **Small Caps**. Changes lowercase letters to reduced capitals.
   - **Superscript**. Reduces and raises the text above the baseline.
   - **Subscript**. Reduces and lowers the text below the baseline.
   - **Underline**. Underlines the text.
   - **Strikethrough**. Adds a line through the text.
   - **Underline Options**. Opens a dialog box, where you can change underline options.
   - **Strikethrough Options**. Opens a dialog box, where you can change strikethrough options.
After setting the font family and style, the next attribute to set is the font size. The font size can range from 6 points to 72 points and beyond depending on the font. Open or TrueType fonts can be scaled to any size and still look and print well. Bitmap (screen fonts) fonts, on the other hand, cannot be scaled and you need to use the available sizes to print well. However, bitmap fonts are the best choice for commercial print jobs. An “O” appears next to an OpenType font, a “TT” appears next to a TrueType font, and an “a” appears next to a bitmap font on the Font submenu.

### Changing Font Size

#### Change Font Size

1. Select the **Type** tool on the Tools panel, and then select the text that you want to change.
   - You can also select the **Selection** tool, and then click the text frame to change all text in the frame.

2. Select the **Character** panel.
   - Click the **Type** menu, and then click **Character**.

3. Enter a font point size, or click the **Font Size** list arrow, and then select a font size. Press Enter (Win) or Return (Mac) to apply the value.
   - You can also hold down **Ctrl+Shift** (Win) or **Cmd+Shift** (Mac), and then press **>** to increase the point size or press **<** to decrease the point size.

   Use **Ctrl+Alt-Shift** (Win) or **Cmd+Option+Shift** to change the point size 5 sizes at a time.

#### Did You Know?

**What is a point?** The size of each font character is measured in points (a point is approximately 1/72 of an inch). You can use any font that is installed on your computer in a document, but the default is 12-point Times New Roman.
Text Leading

Leading is the distance from the baseline of one line to the baseline of the next line and is measured in points. Each line of text can have a different leading size. You can specify a specific setting or use Auto, which is a percentage of the largest text size on each line. Leading is applied to horizontal text. If you want to change vertical spacing in text, you need to adjust horizontal tracking.

Change Text Leading

1. Select the Type tool on the Tools panel, and then select the text that you want to change.
   - You can also select the Selection tool, and then click the text frame to change all text in the frame.

2. Select the Character panel.
   - Click the Type menu, and then click Character.

3. Enter a leading point size, or click the Leading arrows, and then select a leading size. Press Enter (Win) or Return (Mac) to apply the value.
   - You can also hold down Alt (Win) or Option (Mac), and then press the down arrow to increase the point size or press the up arrow to decrease the point size.

   The text increases or decreases by the Size/Leading value set in the Type preferences.

4. To shift characters up or down from the baseline, enter a baseline value, or click the Baseline Shift arrows, and then select a baseline value. A positive size adds space while a negative number removes space. Press Enter (Win) or Return (Mac) to apply the value.
Text Kerning

Kerning is adding or removing space between pairs of characters in your text. Sometimes the space between two characters is larger than others, which makes the word look uneven. You can use the Character panel to change the kerning setting for selected characters. You can expand or condense character spacing to create a special effect for a title, or realign the position of characters to the bottom edge of the text—this is helpful for positioning copyright or trademark symbols.

Change Text Kerning

1. Select the Type tool on the Tools panel, and then click between the two characters of text you want to change.
2. Select the Character panel.
   - Click the Type menu, and then click Character.
3. Enter a kerning size, or click the Kerning arrows, and then select a kerning size. A positive size adds space while a negative number removes space. Press Enter (Win) or Return (Mac) to apply the value.
   - You can also hold down Alt (Win) or Option (Mac), and then press the right arrow to increase the point size or press the left arrow to decrease the point size.

   The text increases or decreases by the Tracking value set in the Type preferences.
Text Tracking

Tracking is the adjustment of space between three or more characters. Typically, you'll track a line of text or a few words depending on the length and design application. This is useful for creating specialize text for a caption or short heading. To adjust space between two characters, kerning is the best choice. To track characters, you need to select them first and then set the Tracking option in the Character panel.

Change Text Tracking

1. Select the Type tool on the Tools panel, and then select the text that you want to change.
   - You can also select the Selection tool, and then click the text frame to change all text in the frame.
2. Select the Character panel.
   - Click the Type menu, and then click Character.
3. Enter a tracking size, or click the Tracking arrows, and then select a tracking size. A positive size adds space while a negative number removes space. Press Enter (Win) or Return (Mac) to apply the value.
   - You can also hold down Alt (Win) or Option (Mac), and then press the right arrow to increase the point size or press the left arrow to decrease the point size.

The text increases or decreases by the Tracking value set in the Type preferences.
Scaling allows you to make text wider or narrower for horizontal text and taller or shorter for vertical text. You can use the Horizontal Scale and Vertical Scale options in the Character panel to modify text. Skewing allows you to distort the text at an angle to give it perspective. If the scaling or skewing doesn’t look quite right, you can always use the Undo command to reverse the modification.

1. Select the text that you want to change.
   - You can also select the Selection tool, and then click the text frame to change all text in the frame.

2. Select the Character panel.
   - Click the Type menu, and then click Character.

3. To scale text, enter a horizontal or vertical percentage, or click the Vertical Scale or Horizontal Scale arrows. Press Enter (Win) or Return (Mac) to apply the value. Other ways of scaling text include:
   - To scale a text frame, select the object, double-click the Scale tool on the Tools panel, specify a Horizontal and Vertical percentage, and then click OK.
   - To scale a text frame, select the object, select the Free Transform tool on the Tools panel, and then drag a side handle on the bounding box.

4. To skew text, enter a degree value, or click the Skew arrows. Press Enter (Win) or Return (Mac) to apply the value.
Aligning Paragraphs

Align Paragraphs

1. Select the Type tool on the Tools panel, and then click in a paragraph or select multiple paragraphs you want to align.

2. Select the Paragraph panel.
   - Click the Type menu, and then click Paragraph.

3. Use any of the following alignment buttons on the panel:
   - **Align Left, Align Center, or Align Right.** Click these buttons to align paragraph text left, center, or right.
   - **Justify Left, Center, or Right.** Click these buttons to justify the paragraph text with only the last line aligned left, center, or right.
   - **Justify.** Click to justify all lines.
   - **Align Towards Spine.** Click to align the paragraph text towards the spine.
   - **Align Away From Spine.** Click to align the paragraph text away from the spine.
   - **Do Not Align To Baseline Grid.** Click to keep the paragraph text from aligning to the baseline grid.
   - **Align To Baseline Grid.** Click to align the paragraph text to the baseline grid.

When you press the Enter (Win) or Return (Mac) in a text frame, InDesign creates a paragraph. You can use the Paragraph panel to align and indent paragraphs in your document. At the top and bottom of the Paragraph panel is a set of buttons that you can use to align text in one or more paragraphs. The panel includes the typical options to align: left, center, right and justify. However, it also includes options to justify text with only the last line aligned left, center, or right.
Indenting and Spacing Paragraphs

Indent and Space Paragraphs

1. Select the Type tool on the Tools panel, and then click in a paragraph or select multiple paragraphs you want to change.

2. Select the Paragraph panel.
   - Click the Type menu, and then click Paragraph.

3. Enter a Left Indent and/or Right Indent value or use the up and down arrows to specify one. Press Enter (Win) or Return (Mac) to apply the value.

4. To create a first-line or last-line indent, enter a First-Line Indent or Last-Line Indent value or use the up and down arrows to specify one. Press Enter (Win) or Return (Mac) to apply the value.
   - To create a hanging indent, enter a negative value in the First-line Left Indent box.
   - To insert a manual indent, place the insertion point, click the Type menu, point to Insert Special Character, point to Other, and then click Indent to Here.

5. To add spacing between paragraphs, enter a Space Before Paragraph and/or Space After Paragraph value or use the up and down arrows to specify one. Press Enter (Win) or Return (Mac) to apply the value.

Quickly indent lines of text to precise locations from the left or right margin with the horizontal ruler. Indent the first or last line of a paragraph (called a **first-line or last-line indent**) as books do to distinguish paragraphs. Indent the second and subsequent lines of a paragraph from the left margin (called a **hanging indent**) to create a properly formatted bibliography. Indent the entire paragraph any amount from the left and right margins (called **left indents** and **right indents**) to separate quoted passages. In addition to indenting paragraphs, you can also set the spacing you want before or after a paragraph.

To od tat, consenit, cotinisi blaore tem zzzilis autpat. Ut niam, se conulla consequat. Ut inci blaor sit, susto core...
A few simple elements—drop caps, borders, and shading—make your newsletters and brochures look like a professional produced them. A drop cap is the enlarged first letter of a paragraph that provides instant style to a document. You can quickly achieve this effect in the Paragraph panel. You can change the drop cap position, font, and height, and then enter the distance between the drop cap and paragraph.

Creating a Drop Cap

1. Select the Type tool on the Tools panel, and then click in a paragraph or select multiple paragraphs you want to change.
2. Select the Paragraph panel.
   - Click the Type menu, and then click Paragraph.
3. Enter a Drop Cap Number of Lines value or use the up and down arrows to specify one. Press Enter (Win) or Return (Mac) to apply the value.
4. Enter a Drop Cap One or More Characters value or use the up and down arrows to specify one. Press Enter (Win) or Return (Mac) to apply the value.

To od tat, consenit, cortinisi blaore tem zzrilis autpat. Ut niam, se conulla consequat. Ut inci blaor sit, susto core magna faciliscipit adignim nos ad tinibh et la consequi ex elit wisi.
Applying a Paragraph Rule

Apply a Paragraph Rule

1. Select the paragraph to which you want to apply a rule.
2. Select the Paragraph panel.
3. Click the Options menu, and then click Paragraph Rules.
4. Select the Preview check box to see changes as you make them.
5. Select Rule Above or Rule Below from the list arrow, and then select the Rule On check box.
   - To set paragraph rules for both Rule Above and Rule Below, repeat Step 5.
6. Select any of the following appearance options:
   - **Weight.** Specify the thickness of the line rule.
   - **Type.** Specify the style of the line rule.
   - **Color.** Specify the color of the line rule.
   - **Tint.** Specify a tint for the line color.
   - **Gap Color.** If you selected a type with a gap, specify a gap color for the line rule.
   - **Gap Tint.** Specify a tint for the line gap color.
   - **Overprint Gap.** Select to set the gap ink to overprint.

If you want a line above or below a paragraph, you can apply it to a paragraph, so the line stays with the paragraph as you add or delete text. A paragraph rule can also be applied as part of a style sheet. In the Paragraph Rules dialog box, you can set the weight, style type, color, width, and position of the paragraph rule line.
7 Select any of the following appearance options:

- **Width.** Select the rule line length equivalent to the column or the text.
- **Offset.** Specify the position above or below the baseline.
  By default, the paragraph rule is positioned on the baseline of the text.
- **Left and Right Indent.** Specify an indent value from the column or text margin.

8 To keep the rule in the text frame, select the **Keep In Frame** check box.

9 Click **OK**.

---

Dionsendiam nim augiam del ut iustrud digna ad dolor at. Ut velit irit aliquis dolobore exero ero ex elender augait, con henim iliquam nibh et, quat vent ex exerces ea feusman enim vel ut iure tat lore magniam, volore ver irit venit augiat. Sed tin ver iliquametum ipsustic consenibh er autetum quat lute modit dunt pratem veliquamet, quumet, veliquat in ute erat. Tat.
Adding Bullets and Numbering

Add Bullets or Numbering to a Paragraph

1. Select the paragraphs to which you want to add bullets or numbers.
2. Click the Bulleted List or Numbered List button on the Control panel.
   - You can also click the Type menu, point to Bulleted & Numbered Lists, and then click Apply Bullets or Apply Numbers.

The last used settings in the Bullets and Numbering dialog box are applied to the text.

Did You Know?

You can convert bullets or numbers to text. Select the text, click the Type menu, point to Bulleted & Numbered Lists, and then click Convert Bullets To Text or Convert Numbering To Text.

The best way to draw attention to a list is to format the items with bullets or numbers. For different emphasis, change any bullet or number style to one of InDesign’s many predefined formats. For example, switch round bullets to check boxes or Roman numerals to lowercase letters. You can also customize the list style. If you move, insert, or delete items in a numbered list, InDesign sequentially renumbers the list for you.
Format Bullets and Numbers

1. Select the Paragraph panel.
2. Click the Options menu, and then click Bullets and Numbering.
3. Select the Preview check box to see changes as you make them.
4. Click the List Type list arrow, and then select Bullets or Numbers.
5. For Bullets, select from the following options:
   - Bullet Character. Select a bullet character. Add or remove specific characters from the list.
   - Text After. Specify characters to separate the bullet and text.
   - Character Style. Specify a bullet style.
6. For Numbers, select from the following options:
   - Format. Specify a number format style.
   - Number. Specify characters to separate the number and text.
   - Character Style. Specify a number style.
   - Mode. Specify a start number or sequence.
7. Select any of the following Bullet or Number Position options:
   - Alignment. Specify an alignment.
   - Left Indent. Specify an indent value.
   - First Line Indent. Specify a first line indent value.
   - Tab Position. Specify the position of the first character after the bullet or number.
8. Click OK.
In your document, **tabs** determines how text or numerical data is aligned in relation to the document margins. A **tab stop** is a predefined stopping point along the document’s typing line. Default tab stops are set every half-inch, but you can set multiple tabs per paragraph at any location. Choose from four types of text tab stops: left, right, center, and decimal (for numerical data). In the Tabs panel, you can view a ruler with the current tab setting for the selected text and add, move, or delete tab stops. When you press the Tab key with the insertion point active, the text shifts to the next tab stop.

### Setting Tabs

**Set Tabs**

1. Select the **Type** tool on the Tools panel, and then click to place the insertion point in a text frame.
2. Select the **Tabs** panel.
   - Click the **Type** menu, and then click **Tabs**.
   - To use the default tabs, press the tab key to shift the text to the next default tab stop.
3. To move the panel next to the text, click the **Position Panel Above Text Frame** button on the panel.
4. Do any of the following:
   - **Insert.** Click one of the tab stop buttons, and then click in the ruler where you want to place it. You can also enter a number in the X box to insert a tab at an exact position.
   - **Move.** Drag the tab stop left or right or enter an exact position in the X box.
   - **Delete.** Drag a tab stop down off the ruler.
   - **Leader.** Enter a character that repeats in the tabbed space, such as a period.
   - **Align On.** Enter a character that is used with the Decimal tab, such as a decimal point.
A glyph is a style variation—such as ligatures, ordinals, swashes, and fractions—for a given character in an OpenType font. OpenType fonts appear with an “O” next to the font name on the Font submenu. OpenType fonts are designed to work well on both Windows and Macintosh operating systems, which reduces font substitution problems when going back and forth between platforms. However, you can always add more character styles to extend the font format. For example, you can change fractions with numerals and slashes to properly formatted fractions. You can automatically insert alternate glyphs with the OpenType panel or insert them manually with the Glyphs panel to extend the font format.

**Working with Glyphs**

**Did You Know?**

*You can use the OpenType panel to insert glyphs.* Select the OpenType submenu from the Character Options menu, select the text that you want to change or deselect all text for the entire document, and then select the buttons with the options for glyphs that you want to apply, such as ligatures, swashes, titling, ordinals, and fractions.
Inserting Special Text Characters

Insert Special Text Characters

1. Select the **Type** tool on the Tools panel.
2. Click to place the insertion point where you want to place the text.
3. To insert a break, click the **Type** menu, point to **Insert Break Character**, and then select a text break.
   - Includes column, frame, page, paragraph return, and forced line break.
4. To insert special characters, click the **Type** menu, point to **Insert Special Character**, point to any of the following, and then select a special character:
   - **Symbols.** Includes copyright and trademark.
   - **Markers.** Includes page numbers and section markers.
   - **Hyphens and Dashes.** Includes Em and En dashes.
   - **Quotation Marks.** Includes double and single quotation marks.
   - **Other.** Includes tabs and indents.
5. To insert a space, click the **Type** menu, point to **Insert White Space**, and then select a text break.
   - Includes Em and En space, Hair, Thin, Punctuation, and Figure.

In addition to inserting normal alphanumeric text, you can also insert special text characters, such as symbols, markers, hyphens, dashes, white space, and breaks. For example, you can insert text breaks to force a break between lines, or add white space, such as an Em or En space, between characters. If you want to keep two words together on the same line, you can insert a nonbreaking space. You can insert special characters, white space, and break characters by using submenus on the Type menu.
Working with Hidden Text

Show and Hide Text

- **Show Hidden Text.** Click the Type menu, and then click Show Hidden Characters.
- **Hide Hidden Text.** Click the Type menu, and then click Hide Hidden Characters.

When you edit a document, sometimes it’s hard to see the number of spaces between words. To make this job easier, you can show hidden characters, such as the Spacebar, Tab key, and Enter (Win) or Return (Mac) key. If you’re still having trouble viewing the text, you can change the color of the hidden text by changing the color of the layer in the Layers panel. Hidden text is also hidden in Preview or Overprint Preview mode.

Adobe Flash Professional On Demand

*Copyright © 2009 by Perspection, Inc.*

All rights reserved. No part of this book shall be reproduced, stored in a retrieval system, or transmitted by any means, electronic, mechanical, photocopying, recording, or otherwise, without written permission from the publisher. No patent liability is assumed with respect to the use of the information contained herein. Although every precaution has been taken in the preparation of this book, the publisher and author assume no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein.

---

Copyright © 2009 by Perspection, Inc.

All rights reserved. No part of this book shall be reproduced, stored in a retrieval system, or transmitted by any means, electronic, mechanical, photocopying, recording, or otherwise, without written permission from the publisher. No patent liability is assumed with respect to the use of the information contained herein. Although every precaution has been taken in the preparation of this book, the publisher and author assume no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein.
Setting Text Frame Options

Set Text Frame Options

1. Select the text frame you want to change.
2. Click the Object menu, and then click Text Frame Options.
3. Select the Preview check box to see changes as you make them.
4. Click the General tab.
5. Select any of the following Columns options:
   - **Number.** Specify the number of columns you want to create.
   - **Width.** Specify the column width you want to use.
   - **Gutter.** Specify the gutter space between the columns you want to use.
   - **Fixed Column Width.** Select to keep a fixed column width.
6. Specify inset spacing values for Top, Bottom, Left, and Right.
7. Select any of the following Vertical Justification options:
   - **Align.** Specify an alignment option for a rectangle text frame.
   - **Paragraph Spacing Limit.** When you select the Justify alignment option, specify a paragraph spacing limit.

If you need to make adjustments to all the text in a text frame, you can use the Text Frame Options dialog box to make all your changes in one place. You can create columns, adjust inset spacing and vertical justification, specify a first baseline offset, and add a baseline grid for a text frame. Inset spacing is the space between the text and the frame. Vertical justification controls the alignment of text in rectangle text frames from the top to the bottom. When you set vertical justification to Justify, you can set paragraph spacing limits. If you’re working with wrapped text in a text frame, you can set an option to ignore it.
8. To ignore text wrapping for the selected text frame, select the **Ignore Text Wrap** check box.

9. Click the **Baseline Options** tab.

10. Click the **Offset** list arrow, select an option, and then specify a minimum offset space.

11. Select any of the following Baseline Grid options:
   - **Use Custom Baseline Grid.** Select to create a baseline grid for the selected text frame.
   - **Start.** Specify a start location for the baseline grid.
   - **Relative To.** Specify a relative location where you want the baseline grid.
   - **Increment Every.** Specify an interval for the baseline grid.
   - **Color.** Select a color for the baseline grid.

12. Click **OK**.
Wrapping Text Around an Object

Wrap and Unwrap Text Around an Object

1. Arrange the object to be wrapped in front of the text frame. The objects should be overlapping.
2. Select the object to be wrapped.
3. Select the Text Wrap panel.
   - Click the Window menu, and then click Text Wrap.
4. Select one of the following buttons:
   - No Text Wrap. Text flows through the object.
   - Bounding Box. Text wraps around the bounding box.
   - Object Shape. Text wraps around the shape.
   - Jump Object. Text wraps to the space under the object.
   - Jump to Next Column. Text wraps to the next column or text frame.
5. Select the Invert check box to flow the text inside the object.
6. Enter offset values to specify the distance between the text and the object.
   - Click the Make All Settings the Same button (chain icon) to set all the offset values to be the same. Click it again (broken chain icon) if you want to set different values.

When integrating graphics with your text, you can wrap the text around objects to create the results that you want. You can use the Text Wrap panel to quickly select button options to wrap text around an object. Some of the text wrapping options include No Wrap, Bounding Box, Object Shape, Jump Object, and Jump to Next Column. When you select Object Shape, you can select additional options to customize text wrapping around the object.
Set Object Shape Wrap Options

1. Select the object to be wrapped.
2. Select the Text Wrap panel.
3. Click the Object Shape button.
4. Click the Wrap Options list arrow, and then select an option:
   - Right Side. Wraps around the right side.
   - Left Side. Wraps around the left side.
   - Both Right & Left Sides. Wraps to both sides.
   - Side Towards Spine. Wraps to the left or right side towards the spine.
   - Side Away From Spine. Wraps to the left or right side away from the spine.
   - Largest Area. Wraps to the side with the most space.
5. Click the Contour Options list arrow, and then select an option to control the shape of the wrap:
   - Bounding Box. Uses the bounding box rectangle.
   - Detect Edges. Uses the difference between the image pixels and the background.
   - Alpha Channel. Uses an embedded alpha channel.
   - Photoshop Path. Uses an embedded path.
   - Graphic Frame. Uses the frame of the graphic object.
   - Same As Clipping. Uses the clipping path shape for the graphic.
6. Select the Include Inside Edges check box to wrap text inside holes in the graphic, path, or alpha channel.
The Create Outlines command converts characters in a text frame into a separate object with a path. Some characters, such as “A” or “B,” that contain an interior shape (known as a counter) are converted into compound objects. After you create an outline, you can reshape the path, use it as a mask object, fill it with a gradient or a mesh, or use it in a compound object. When you create outlines, the fill and stroke attributes and any appearances of the type are applied to the outlines. Before you use the Create Outlines command, it’s a good idea to make a copy of the text frame or your document as a backup to preserve a copy of the original text frame.

Creating Type Outlines

1. Select the Selection tool on the Tools panel.
2. Select the text frame or select characters.
3. Click the Type menu, and then click Create Outlines.
Adding Page Numbers to Continued Text

Add Page Numbers to Continued Text

1. Select the **Type** tool on the Tools panel.
2. Drag to create a text frame for the page number.
3. Select the **Selection** tool on the Tools panel, and then drag to move the text frame so that it touches or overlaps the frame containing the story you want to continue on another page.
4. Select the **Type** tool on the Tools panel, click in the text frame, and then type text you want to appear next to the page number, such as *Continued on* or *Continued from*.
5. Click the **Type** menu, point to **Insert Special Character**, point to **Marker**, and then click **Next Page Number** or **Previous Page number**.
6. Shift-click to select the text frame and the frame containing the story, click the **Object** menu, and then click **Group** to keep both together.

When you enter or import text for an article or story that you want to continue on another page, you can add a page number in a separate text frame to the bottom of the article or story as a jump line to where it continues. The continuation page number is typically put in a separate text frame, so the reflow of text doesn’t move it. When you change pagination in a document, the continuation page numbers are automatically updated.
Praise For On Demand

Your books are quite unparalleled in their presentation.
– Jabulani Sibanda

I couldn’t be more impressed by how your books are layed out out and presented.
– Richard Christian

The best! This is an outstanding reference that is clear and concise to the point without the jargon.
– Charles Aponte

Perfect for beginners and as a reference for experts. The “On Demand” series has been invaluable for me earning my certifications. They are easy to read, well laid out and beautifully illustrated in color. I highly recommend these books.
– David Pease, reviewed on Amazon.com

I’m a big fan of the Photoshop On Demand books, and the latest version, Photoshop CS3 On Demand is a real gem. Filled with everything you’ll ever need to know to work in Photoshop, the book’s best feature is the way the information is presented.
– Photoshopsupport.com