After you've learned basic layer techniques, you can create more complex effects in your artwork using layer masks, path groups, filters, adjustment layers, and more style layers.
In this lesson, you’ll learn how to do the following:

- Create clipping groups, which let you use an image on one layer as a mask for artwork on other layers.
- Create layer sets to organize and manage layers.
- Add adjustment layers to an image, and use them to apply color and tonal adjustments without permanently changing pixel data.
- Create knockout layers to use one layer selectively to reveal others.
- Import layers from other Photoshop files.
- Work with type layers.
- Duplicate and clip layers.
- Add layer styles to a layer, and apply the effects to multiple layers.
- Rasterize layers.
- Convert clipping paths to masks.
- Liquify a layer, giving it a melted appearance.
- Flatten and save layered files, greatly reducing their file size.

This lesson will take about 45 minutes to complete. The lesson is designed to be done in Adobe Photoshop, but information on using similar functionality in Adobe ImageReady is included where appropriate.

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson11 folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to restore the start files, copy them from the Adobe Photoshop 7.0 Classroom in a Book CD.

**Note:** Windows users need to unlock the lesson files before using them. For more information, see “Copying the Classroom in a Book files” on page 4.
Getting started

Before beginning this lesson, restore the default application settings for Adobe Photoshop. See “Restoring default preferences” on page 5.

You’ll start the lesson by viewing the final lesson file to see what you’ll accomplish.

1  Start Adobe Photoshop.

If a notice appears asking whether you want to customize your color settings, click No.

2  Choose File > Open, and open the file 11End.psd from the Lessons/Lesson11 folder.

3  When you have finished viewing the file, either leave the it open on your desktop for reference, or close it without saving changes.

Now you’ll open the start file, which contains an image that has two layers and a background, and you’ll work with various layering and masking techniques to complete the image.

4  Choose File > Open, and open the 11Start.psd file, located in the Lessons/Lesson11 folder on your hard drive.

5  If the Layers palette is not already showing, choose Window > Layers to display it.
The Layers palette shows that there are three layers in the file: the Metal Grille layer, the Rust layer, and the Background. At this point, you can see only the Metal Grille layer, because the Rust layer and the Background are positioned under the image of the metal grille.

6. Using the eye icons ( ) in the Layers palette, examine the layers one by one, hiding each of the other layers so that you can see exactly what each layer image looks like. Then set eye icons in all the layers so that all are visible, as they were when you opened the file.

To make your work area more efficient, you can close all the palettes except the Layers palette, because this is the only palette you’ll use in this lesson. You can then resize the Layers palette so that you’ll be able to see all the layer work you’ll do in the lesson without having to scroll. Be sure to leave the toolbox open, too.

Creating paths to clip a layer
As you’ve learned in other lessons in this book, you can use a vector path to clip a layer, creating a sharp-edged mask on that layer. In this part of the lesson, you’ll draw a circle and use it to knock out the holes in the metal grille image. This will let you see through the holes to the layers below.

Drawing the vector work path
You’ll begin by drawing the basic path on the Metal Grille layer.

1. Click the Metal Grille layer in the Layers palette to select it.
2 Select the ellipse tool ( ), hidden behind the rectangle tool ( ). Then, on the tool options bar, click the Paths option ( ) (the second of three options on the left side).

![Ellipse Tool](image)

3 Move the pointer to the center of one of the holes in the metal grille and start dragging. Then hold down the Shift+Alt (Windows) or Shift+Option (Mac OS) and continue to drag until the circle is the size of the hole. Carefully release the mouse button first, and then release the keyboard keys.

![Circle Drag](image)

**Note:** If the circle is not exactly centered when you’re done, hold down Ctrl (Windows) or Command (Mac OS) and drag the circle path into position.

Next you’ll make copies for the rest of the metal grille.

4 In the toolbox, select the path selection tool ( ), and click to select the circle you just drew.
5 Hold down Alt (Windows) or Option (Mac OS) so that a small plus sign appears below the pointer icon (➕), and then drag the circle to place a copy of the path over another hole in the metal grille. Repeat this step to place copies over the remaining holes, including the holes that extend outside the edges of the image.

Note: You can adjust the position of a selected circle using the arrow keys on the keyboard. You may also find it helpful to choose View > Snap To > and click any of the commands that are checked on the Snap To submenu to deselect them, so that none of these are active.

Creating a layer mask from the work path

You’re ready to use these circles as a layer vector mask.

1 Shift-click to select all 16 circle paths.

2 In the tool options bar, click the Subtract From Shape Area option (.subtract), or press hyphen (-) to select it with the keyboard shortcut.

The subtraction option sets up Photoshop to use the circle shapes to define where it will remove pixels from the layer, so that those areas of the Metal Grille layer become transparent when you apply the path as a vector mask.
Choose Layer > Add Vector Mask > Current Path.

The Rust layer appears through the holes you cut in the Metal Grille layer. In the Layers palette, a thumbnail of the vector mask appears in the Metal Grille layer.

Click the Dismiss Target Path button (✓) in the options bar to deselect the multicircle path you created.

Choose File > Save to save your work.

Creating layer sets

You have already had some practice with layer sets in earlier lessons in this book. Layer sets help you organize and manage individual layers by grouping them. You can then expand the layer set to view the layers contained in it or collapse the set to simplify your view. You can change the stacking order of layers within a layer set.

Layer sets function like layers, so that you can not only select, duplicate, and move entire sets of layers, but you can also apply attributes and masks to the entire layer set. Any changes you make at the layer-set level apply to all the layers within the layer set.

In this section, you’ll create two layer sets, one for type and another for the metal grille.

In the Layers palette, click the Create a New Set button (☐) twice to create two layer sets.

Double-click the name Set 2 and type Words.

Double-click the name Set 1 and type Images.

Now you’re going to move the Metal Grille and Rust layers into the Images layer set.
4 In the Layers palette, drag the Metal Grille layer onto the folder icon (/button) for the Images layer set, and release the mouse button. The Metal Grille layer now appears indented under the Images layer set.

5 Drag the Rust layer to add it to the Images layer set, too. Notice that the Rust layer is also indented and below the Metal Grille layer in the layer set.

6 Choose File > Save.

**Using adjustment layers (Photoshop)**

An adjustment layer lets you experiment with color or tonal adjustments to an image without permanently modifying the pixels in the image. The color or tonal changes reside within the adjustment layer, which acts as a veil through which the underlying image layers appear.

Keep in mind that an adjustment layer affects all the layers below it. This lets you correct multiple layers by making a single adjustment, rather than making the adjustment to each layer separately.

**Note:** Adjustment layers can be applied and edited only in Photoshop; however, they can be viewed in ImageReady. When you apply an adjustment layer to a layer set, Photoshop adds the new adjustment layer in the layer set above the existing layers.

—From Adobe Photoshop 7.0 online Help
Creating an adjustment layer

Adjustment layers can be added to an image to apply color and tonal adjustments without permanently changing the pixel values in the image. For example, if you add a Color Balance adjustment layer to an image, you can experiment with different colors repeatedly, because the change occurs only on the adjustment layer. If you decide to return to the original pixel values, you can hide or delete the adjustment layer.

Here you’ll add a Curves adjustment layer to create a greater contrast between the grille and the rust layer behind it. You’ll do this by darkening the entire rust image. An adjustment layer affects all layers below it in the image’s stacking order. Because you’ll place the Curves adjustment layer below the Metal Grille layer, the adjustment will affect the Rust layer and the Background but not the metal grille.

1. Select the Rust layer in the Layers palette.
2. Click the Create New Fill Or Adjustment Layer button ( ) at the bottom of the Layers palette and choose Curves from the pop-up menu.
3. Click the middle of the diagonal line in the grid (the color curve) to add a control point on the curve that will adjust the midtones.
4. Drag the control point down and to the right or enter values in the Input and Output text boxes. (We moved the control point so that the value in the Input text box was 150% and the value in the Output text box was 105%.)
5. Click OK to close the dialog box.
An adjustment layer named Curves 1 appears in the Layers palette. The thumbnails for the new layer include one of the Curves 1 graph and one of the layer mask.

6 Choose File > Save.

You can experiment by clicking the eye icons for the Curves 1 and Rust layers off and on, to see the effect of the adjustment layer on the other layers. When you finish, be sure to return all layers to their visible state.

Creating a knockout gradient layer

Knockout layer options specify how one layer reveals other layers. In this section, you’ll create a knockout gradient layer so that the lower third of the image reveals the Background layer.

You’ll begin by creating a new layer in the Images layer set.

1 Select the Images layer set in the Layers palette and click the Create a New Layer button ( ) at the bottom of the palette.

This creates a new layer (Layer 1) in the Images layer set, above the Metal Grille, Curves 1, and Rust layers.

2 Double-click the new Layer 1, and type Knockout Gradient to rename it. Keep the Knockout Gradient layer selected.

Now you’ll create a gradient on this layer.

3 Select the gradient tool ( ).

4 If necessary, click the Default Foreground And Background Colors icon ( ) in the toolbox to set the foreground color to black and the background color to white.

5 If necessary, click the Linear Gradient button ( ) in the options bar to create a linear gradient.

6 Click the arrow ( ) to the right of the gradient display in the options bar to open the gradient picker.
Choose Small List from the gradient picker menu (opened by clicking the round arrow button in the upper right area of the gradient picker). Then choose Foreground to Transparent in the gradient picker, and close the gradient picker by clicking outside it.

Shift-drag from the bottom of the image to slightly above the midpoint to create a gradient that goes from black at the bottom to transparent at the top.

In the Layers palette, click the Layers Style button ( ) at the bottom of the palette and choose Blending Options from the pop-up menu.
10 In the Layer Style dialog box, do the following:
• Under Advanced Blending, drag the Fill Opacity slider or type to enter 0 as the value. (Be careful to adjust the Fill Opacity, not the Opacity option under General Blendings.)
• In the Knockout pop-up menu, select Deep.
• Click OK to close the dialog box.

Now the horizontal stripes of gradient colors on the Background layer start to show through the layers in the Images layer set.

11 Choose File > Save.

Importing a layer from another file
In this part of the lesson, you’ll import an existing layer from another file into your artwork. Although the imported layer contains the word *diesel* and was originally created with the type tool, the text has now been converted to a graphic. You can no longer edit it with the type tool, but the advantage here is that you also don’t have to worry about whether or not your users or other people working on the file have the same font installed on their machines in order to see the image correctly.

1 Select the Words layer set in the Layers palette.

2 Choose File > Open, select Diesel.psd, and click Open.
3 With the Diesel.psd active, drag the Diesel layer from the Layers palette into the 11Start.psd image.

Because the Words layer set was selected in the 11Start.psd image, the Diesel layer is added to that set.

4 Select the move tool (V) and drag the Diesel layer image into position so that it is in the center of the 11Start.psd image and near the bottom.

5 Choose File > Save to save your 11Start.psd file.

6 Choose Window > Documents > Diesel.psd, and then close that file without saving it.
Applying layer styles

Once you have the text arranged on the image, you can add layer styles to enhance the look of the type. Layer styles are automated special effects that you can apply to a layer. For more information on layer styles, see Lesson 5, “Layer Basics.”

Now you’ll add two different layer styles to the Diesel type layer.

1. With the Diesel layer selected in the Layers palette, click the Layer Styles icon ( ) at the bottom of the palette and select Drop Shadow from the pop-up menu.
2. In the Layer Style dialog box, select the Preview check box on the right side of the dialog box so you’ll be able to see the changes as you work.
3. On the left side of the dialog box, click the words Bevel and Emboss so that they are highlighted and a checkmark appears in the Bevel and Emboss check box.
4. In the Structure area on the right side of the dialog box, adjust the sliders for Depth and Size until you achieve a fairly subtle beveled look in the Diesel image. (We used 2% for Depth and 2 for Size, but you may think this is too subtle. Or, you can leave them set at the default values: 100% and 5.)
5. Click OK to close the dialog box.

Duplicating and clipping a layer

In this section, you’ll learn how to copy the Rust layer and then use the compound shape of the Diesel layer to clip away some of the Rust layer.

First, you’ll copy the Rust layer and move it above the Diesel layer.

1 Select the Rust layer in the Layers palette and drag it onto the Create a New Layer button ( ) at the bottom of the palette.

A new layer called “Rust copy” is created directly above the Rust layer in the palette.

2 In the Layers palette, drag Rust copy just above the Diesel layer inside the Words layer set. Because Rust copy is the top layer, the rust image is all you can see.

3 Hold down Alt (Windows) or Option (Mac OS) and move the mouse pointer over the line dividing the Rust copy and Diesel layers in the Layers palette. When the pointer changes to two overlapping circles ( ), click the mouse button.
The Rust copy layer is clipped away so that it appears inside the Diesel shape and you can see the other layers in the other areas of the image.

4 Choose File > Save.

**Liquifying a layer**

The Liquify command lets you add a melted look to the image. In this part of the lesson, you’ll make the metal grille look as if it has melted from one side to the other.

*Note:* The Liquify filter in Photoshop 7.0 includes enhancements over previous versions. If you think you’ll want to experiment with other Liquify effects after you finish the next procedure, save a copy of your 11Start.psd file now (choose File > Save As and give the copy a different name, such as 11Testing.psd), and then close it and reopen your 11Start.psd file to continue working.

**Rasterizing the mask**

Before you can apply the Liquify feature to the metal grille, you must rasterize its vector mask and merge the mask and image to create just one image.

1 In the Layers palette, select the Metal Grille layer.
2 Choose Layer > Rasterize > Vector Mask. This converts the circles path, which is a vector graphic and resolution-independent, into a mask that is a raster image and resolution-dependent.

💡 To view a mask by itself, Alt-click (Windows) or Option-click (Mac OS) the mask thumbnail in the Layers palette. You can then use the painting tools to add to or subtract from the mask. For more information, see Lesson 6, “Masks and Channels.”

3 Choose Layer > Remove Layer Mask > Apply to merge the layer with its mask, creating a single rasterized image on that layer.
Applying the Liquify command

Now you’ll warp the layer with the Liquify command and warp tool.

The Liquify filter works by applying a mesh warping. This distorts the image by dragging handles at the intersection of a hidden grid or mesh. Turning on the mesh visibility can help you understand more clearly how you’re manipulating this grid and the different effects created by the various liquify tools.

1. With the Metal Grille layer selected in the Layers palette, chose Filter > Liquify.
2. In the Liquify dialog box, select the following options:
   - In the upper left corner of the dialog box, make sure that the warp tool is selected.
   - On the upper right side of the dialog box under Tool Options, select a brush size that’s the same size as the holes in the grille (we used 133). Then for Brush Pressure, select a moderate value (we used 20).
   - (Optional) Under View Options on the lower right side of the dialog box, select the Backdrop check box, make sure that All Layers is selected on the Backdrop pop-up menu, and then drag the Opacity slider or type 100%.

---

Using the Liquify command

The Liquify command lets you interactively push, pull, rotate, reflect, pucker, and bloat any area of an image. The distortions you create can be subtle or drastic, which makes the Liquify command a powerful tool for retouching images as well as creating artistic effects.

Note: The Liquify command is available only for 8-bit images in RGB Color, CMYK Color, Lab Color, and Grayscale image modes.

You can use tools or alpha channels to freeze areas of the preview image to protect them from further changes, or thaw the frozen areas.

Certain reconstruction modes change unfrozen areas in relation to the distortions in frozen areas. You can hide or show the mask for frozen areas, change the mask color, and use a Brush Pressure option to create partial freezes and thaws.

—From Adobe Photoshop 7.0 online Help
These view options make the layers under the Metal Grille layer visible. This can be visually confusing until you get used to it, especially because as you work you’ll continue to see both the original metal grille and the liquified metal grille ghosted over it. To return to your original view, just deselect the Backdrop check box.

3 Still in the Liquify dialog box, drag the brush across and down the image once to start applying the Liquify filtering effect.

4 Under View Options in the Liquify dialog box, select the Mesh check box, and deselect the Backdrop check box, if necessary. Notice how the mesh has been distorted by the warp tool.

5 On the left side of the dialog box, select the turbulence tool ( ), and drag the brush across another area of the metal grille image.
Notice the differences between the results created with the warp tool and the results created by the turbulence brush: The warp tool simply pulled the mesh and image in one direction. The turbulence tool creates an additional random distortion.

**Note:** If you make mistakes or don’t like one of the brush strokes you apply, press Ctrl+Z (Windows) or Command+Z (Mac OS) to undo that step. If you want to undo more than one step, click Cancel to close the Liquify dialog box, and then start the process again.

6 Continue to apply different effects to the metal grille. When you are satisfied with the results, click OK to close the Liquify dialog box.

7 Choose File > Save.
Creating a border layer

To give the image a finished look, you'll add a border to it.

1. Click the Create a New Layer button (Ⅰ) in the Layers palette. (It doesn’t matter which layer is currently selected because you’re going to move the new layer a little later.)

2. Double-click the new Layer 1, and type Image Border to rename it.

3. Drag the Image Border layer to the top of the Layers palette stack, until a black line appears immediately above the Words layer set, and then release the mouse button.

The Image Border layer is now the top layer in the image.

4. Choose Select > All to select the entire image.

5. Choose Edit > Stroke. In the Stroke area, enter 5 px for Width and click OK. (Or, for a more dramatic black border, enter a larger number, such as 10 or 15 pixels.)

A 5-pixel-wide black stroke now appears around the entire image.

6. Choose Select > Deselect to deselect the entire image.

7. Choose File > Save.
Flattening a layered image

If you plan to send a file out for proofs, it’s also a good idea to save two versions of the file—one containing all the layers so that you can edit the file if necessary, and one flattened version to send to the print shop. When you flatten a file, all layers are merged into a single background, greatly reducing the size of the file.

1 First, note the values in the lower-left corner of the application window (Windows) or the 11Start.psd image window (Mac OS). If the display does not show the file size (such as "Doc: 909K/6.4M"), click the arrow on the bottom of the window to open a pop-up menu, and choose Document Sizes.

The first number is the printing size of the image, which is about the size that the saved, flattened file would have in Adobe Photoshop format. The number on the right indicates the approximate document size of the file as it is now, including layers and channels.

2 Choose Image > Duplicate, name the duplicate file 11Final.psd, and click OK.

3 On the Layers palette menu, choose Flatten Image. The layers for the 11Final.psd file are combined onto a single background layer.

4 Notice that the file size of the 11Final.psd image is significantly smaller than the 11Start.psd image, because it has been flattened onto the background.

5 Choose File > Save. In the Save As dialog box, click Save to save the file in Photoshop format.

You’ve completed the Advanced Layer Techniques lesson.
Review questions

1 Why would you use layer sets?
2 What are grouped layers? How could you use them in your work?
3 How do adjustment layers work, and what is the benefit of using an adjustment layer?
4 What are layer styles? Why would you use them?

Review answers

1 Layer sets help you organize and manage layers. For example, you can move all the layers in a layer set as a group and apply attributes or a mask to them as a group.
2 A layer group consists of at least two layers, where the artwork on the base layer is used as a mask for artwork on the layer or layers above.
3 Adjustment layers are a special type of Photoshop layer that works specifically with color and tonal adjustments. When you apply an adjustment layer, you can edit an image repeatedly without making a permanent change to the colors or tonal range in the image. You can view adjustment layers in ImageReady, but you can create or edit them only in Photoshop.
4 Layer styles are customizable effects that you can apply to layers. They enable you to apply changes to a layer that you can modify or remove at any time.