Motion Tweening in Flash MX

Similar to shape tweening, motion tweening is a method of animation that takes the position and attributes of an object in a start keyframe, and the position and attributes of an object in an end keyframe, and calculates all the animation that will occur between the two. However, unlike shape tweening, motion tweening requires that you use symbols, groups, and text blocks, rather than shapes, to create animation. In addition to position, motion tweens can animate scale, tint, transparency, rotation, and distortion. Throughout the following exercises, you will learn much more than simple motion tweening, including how to edit multiple frames and how to use Motion Guides.
Shape Tweening Versus Motion Tweening

When you start working in Macromedia Flash MX, you might be confused about which type of tween to choose: motion or shape. You may spend unnecessary time trying to figure out why your animation is not working when the solution turns out to be that you simply selected the wrong type of tween. The basic distinction between the two types of tweening is that with shape tweening, you use shapes to create the tweening effect, whereas with motion tweening, you use groups, text, or symbols to create the effect. Use the following chart as a reference tool when deciding on the type of tween to use.

<table>
<thead>
<tr>
<th>Tween Types Simplified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
</tr>
<tr>
<td>---</td>
</tr>
<tr>
<td>Shape Tween</td>
</tr>
<tr>
<td>Motion Tween</td>
</tr>
</tbody>
</table>
Basic Motion Tweening

This exercise demonstrates how to create a basic motion tween, using a Graphic symbol. I've created the Graphic symbol for you, but please note that you would need to create a Graphic symbol first if you were creating a motion tween from scratch. Motion tweening itself is very simple, especially once you've learned shape tweening. The big difference is not in the technique but in understanding when to use which type of object: shape, group, symbol, text, or broken-apart text. You may find yourself referring back to the “Tween Types Simplified” chart often, since remembering the rules of objects and tweening is harder than the process itself.

1. Copy the chap_07 folder, located on the H•O•T CD-ROM, to your hard drive. You need to have this folder on your hard drive in order to save changes to the files inside it.

2. In your chap_07 folder, open the file motionTween.fla. This file contains one layer with a background image.

3. Click on the Insert Layer button to add a new layer to the Timeline. Double-click on the Layer 2 name and rename this layer motionTween.
4. Open the **Library** for this movie by pressing **F11**. Click the **boarder** symbol to select it. Once it’s selected, you will see a preview of it in the preview portion of the Library window.

**Note:** In Chapter 5, “Shape Tweening,” when you were introduced to shape tweening, you saw that your tween had to be created using a shape. With motion tweening it is the opposite. When working with motion tweening, the graphic that you’re tweening cannot be a shape. Instead, it must be a symbol, a text block, or a grouped object.
5. Click and drag an instance of the **boarder** Graphic symbol from the **Library** out onto the middle of the **Stage**, just above the jump, as in the picture above. This is where the boarder is going to start its animation.

6. Click inside **Frame 20**, and press **F6** to add a keyframe. This will copy the contents of Frame 1 to Frame 20.

7. Click on **Frame 20** of the **background** layer and press **F5** to add a frame on that layer as well. This way, the background image will be visible throughout the motion tween.
8. Making sure that the Playhead is still over Frame 20, drag the boarder to the bottom right corner of the Stage. This will serve as the end point for your animation. Note that Macromedia Flash MX switched you to the motionTween layer when you selected the boarder artwork from the Stage.

*Tip:* If you can’t see the whole background image, choose View > Magnification > Show All to see the whole image.
9. In the Timeline, click anywhere between the two keyframes to select one of the frames between Frame 1 and Frame 20.

10. Make sure the Property Inspector is open; if it is not, choose Window > Properties to open it. From the Tween drop-down menu, choose Motion. This turns on motion tweening for the range of frames between Frame 1 and Frame 20.

11. Preview your first motion tween by pressing Enter/Return on the keyboard. The border will move from the middle of the Stage to the lower right-hand side. All you had to do was set up the beginning and ending points and turn on motion tweening, and Macromedia Flash MX did the rest.

12. In the Timeline, click anywhere between the two keyframes again to select one of the frames between Frame 1 and Frame 20. You will add a little finesse to the motion tween next.
13. In the **Property Inspector**, choose **CW** for the **Rotate** option. This will make the boarder rotate clockwise (CW) one time during the motion tween.

14. Press **Enter/Return** to preview the motion tween animation again. Now that’s a jump!

15. Save this file and leave it open. You will need it for the next exercise.

---

**MOVIE | moTween1.mov**

To see a movie of making this motion tween, play **moTween1.mov**, which is located in the **movies** folder on the **H•O•T CD-ROM**.
2. **Tweening Effects**

Surprisingly, a motion tween isn’t used solely for tweening motion, as its name implies; you can also tween the alpha, tint, brightness, size, position, and skew of a Graphic symbol. The next exercise will show you how. This technique will open the door for you to create a wide range of animated effects—far beyond simply moving an object from one location to another.

1. You should have the file open from the previous exercise. If you closed it, open the `motionTween.fla` file from the `chap_07` folder.

2. Make sure the **Playhead** is over the last frame in the Timeline, **Frame 20**.

3. Select the **boarder** graphic on the **Stage** by clicking on it.

4. In the **Property Inspector** (*Window > Properties*), set the **Color Styles** to **Brightness**. Drag the **Brightness** slider up and down and see what effect it has on the instance of the boarder. See how the boarder gets brighter and darker? Set it at **100%**. This will change the brightness of the symbol instance on Frame 20 to 100 percent, or completely white.

*Tip:* If you already know the percentage you want, you can also simply type it in the window next to the slider rather than using the slider to adjust the brightness of your symbol.
5. Preview the animation by clicking on the **Stage** and then pressing **Enter/Return** on the keyboard. Notice that the boarder animation starts out black and progressively turns to the new color, white.

*You just changed the instance of the boarder on the last keyframe but left the first keyframe of your animation unaltered. Since you had motion tweening turned on for this animation, Macromedia Flash MX automatically redrew all of the frames in between the two keyframes to accommodate the changes you made. This technique will carry through not only to brightness but to all of the effects that I mentioned at the beginning of this exercise, such as alpha and tint.*

6. Move your **Playhead** to **Frame 1**.

7. In the **Toolbox**, select the **Free Transform** tool. Select the **boarder** on the **Stage** by clicking on it. You will see the Free Transform tool’s bounding box around the boarder. Click on one of the corner handles, and drag diagonally inward to decrease the size of the boarder. **Note:** Holding down the Shift key while you drag will maintain the original aspect ratio of the image.

8. In the **Timeline**, click on **Frame 20** in the **motionTween** layer.
9. Using the **Free Transform** tool, this time click on one of the corner handles and drag diagonally outward to increase the size of the boarder. **Note:** Holding down the Shift key while you drag will maintain the original aspect ratio of the image.

10. Press **Enter/Return** on your keyboard again to see the changes you've made. Now your boarder starts off smaller and gets larger as it moves toward the right-hand side of the Stage. At the same time that the size is tweening, the brightness of your boarder is also changing as it moves! You are now tweening the brightness and scale (not to mention the position) in a motion tween.

11. Go ahead and experiment by making more changes using the **Free Transform** tool to either the first or last keyframe of the motion tween, and see how it changes the animation.

12. When you are finished, save and close this file. You will not be needing it anymore.
Suppose you created a motion tween but then decided you would rather have the animation occur across the bottom of the Stage rather than the top. Can you imagine repositioning the items one frame at a time? With the *Edit Multiple Frames* feature, you can bypass that tedious work. The following exercise will show you a method to move the entire animation—including the first and last keyframes—simultaneously.

1. Open the file named `editMultipleFrames.fla` from the `chap_07` folder. This file contains one layer with a background image.

*Tip: If you can’t see the whole background image, choose View > Magnification > Show All to see the whole image.*
2. In the **Timeline**, click on the **Insert Layer** button to add a new layer to the Timeline. Double-click on the **Layer 2** name, and rename this layer **tween**.

3. Open the **Library** for this movie by pressing **F11**. Click on the **boarder** in the Library and drag it to the upper left corner of the sky in the background image on the **Stage**, as shown in the picture above. This is where the boarder is going to start its animation.
4. Select **Frame 15** and press **F6** to add a keyframe. This will copy the contents of Frame 1 to Frame 15.

5. Select **Frame 15** on the **background** layer and press **F5** to add frames to that layer too. This way, the background image will be visible throughout the motion tween.

6. Making sure that the **Playhead** is still over **Frame 15**, drag the **boarder** to the right side of the **Stage** in the sky. This will serve as the end point for your animation.

7. In the **Timeline**, click anywhere between the two keyframes to select one of the frames between **Frame 1** and **Frame 15**.
8. In the Property Inspector, from the Tween drop-down menu, choose Motion. Set the Rotate option to CCW. This will make the boarder rotate counterclockwise (CCW) one time during the motion tween.

9. Press Enter/Return on the keyboard to preview the motion tween. Notice that it looks good, but perhaps the animation should occur in the snow rather than in the sky. You will change this next.
10. Turn on the **Edit Multiple Frames** feature by clicking the **Edit Multiple Frames** button (located in the status bar of the Timeline).

**Note:** When you click the **Edit Multiple Frames** button, you’ll see a dark bar appear at the top of the Timeline that looks identical to the Onion Skinning bar, which you learned about in Chapter 4, “Animation Basics.” Don’t be fooled by the similarities, though. Editing multiple frames is quite different from Onion Skinning. When working with Onion Skinning, the Onion Skinning bar represents the range of frames you are seeing at the same time on your Stage. With **Edit Multiple Frames**, however, the bar represents the range of keyframes you will be editing at the same time.

11. Position the starting point and ending point of the dark bar (representing your **Edit Multiple Frames** range) to span from **Frame 1** to **Frame 15**. If either the starting point or ending point is not over the correct frame, click and drag the bar over the correct frame. By doing this, you are defining which keyframes you are going to edit simultaneously.

In the following steps, you will be moving your entire animation to the bottom part of the Stage, so you want to make sure all of the frames are covered by the **Edit Multiple Frames** bar. Since your animation is composed of two keyframes (Frame 1 and Frame 15), these are the frames that you want the bar to cover.
12. Click to the right of the *tween* layer name (in the place shown circled above) to select the entire layer. The layer will turn black in the Timeline when you do. Notice that you can see the boarder on the first keyframe and the boarder on the last keyframe. Unlike Onion Skinning, however, you won’t see ghosted representations of all of the frames in between the two keyframes. Also notice that both boarders are selected (they have a turquoise border around them), which means that you can move them together at one time.

13. Click on either one of the boarders on the *Stage* and drag downward. Notice that as you drag, both boarders move.
14. Turn off Edit Multiple Frames by clicking the Edit Multiple Frames button again.

It’s very important that you turn off Edit Multiple Frames once you have completed your task. If you leave Edit Multiple Frames turned on and continue to work in your movie, Macromedia Flash MX will become confused as to which frame you’re working in, and your movie will produce unexpected results. If you do make this mistake, remember, by default you have 100 undo’s available to you!

15. Preview the animation by pressing Enter/Return on your keyboard. Now the whole animation has been moved to the bottom of the Stage and the boarder is moving across the snow rather than in the air!

Note: The Edit Multiple Frames feature is a great technique to use when you need to move the contents of many frames all at once. It is also the only way to move an entire animation together at one time.

16. Save this file and close it. You won’t need it again.
Using a Motion Guide

This exercise shows you how to create a motion tween using a Motion Guide. A Motion Guide is a type of layer on which you can draw a path. This type of Guide layer allows the symbol used in the motion tween to follow the path, rather than traveling a straight line between two keyframes. This is the only way in Macromedia Flash MX to make a motion tween follow a curved path, so it is an important technique to understand.

1. Open motionGuideFinal.fla from your chap_07 folder. This file is a finished version of the file you are about to create. Choose Control > Test Movie to view the movie (.swf) file. Notice how the snowflake moves from side to side in a downward direction before reaching the bottom of the screen. Using a Motion Guide, you will create this same effect next.

2. When you are finished, close the preview window and then close the project file.
3. Now open motionGuide.fla from your chap_07 folder. Notice that this file contains one layer with the background image. You’ll be adding the falling snowflake in the following steps.

4. In the Timeline, click the Insert Layer button to add a new layer to the Timeline. Double-click on the Layer 2 name and rename this layer flake.
5. If the **Library** is not open, press **F11** to open it, and drag an instance of the **snowflake** symbol onto the **Stage** in the top left corner. This will be the beginning of the animation. You can then close the Library by pressing **F11**.

6. In the **Timeline**, click on **Frame 40** of the **background** layer and press **F5** to add frames up to Frame 40. This will make sure the background shows throughout your animation, which you will create next.
7. On the flake layer, click on Frame 40 and press F6 to add a new keyframe. Make sure the Playhead is over Frame 40, and then click on the snowflake instance and drag it to the lower right corner of the screen. This will serve as the end point of the animation.

8. On the Timeline, click anywhere between Frame 1 and Frame 40 to select a frame between the two keyframes. In the Property Inspector, select Motion from the Tween drop-down menu. Press Enter/Return to test the motion tween animation.

You just created a simple motion tween like the one you built in Exercise 1 of this chapter. Now you will learn some techniques to enhance a basic motion tween.
9. Select the **flake** layer by clicking to the right of the layer name. Next, click the **Add Motion Guide** button once—it’s at the bottom of the **Timeline**, to the right of the Insert Layer button. This will add a Motion Guide layer to the flake layer. This new layer has automatically been named **Guide: flake**.

Notice the icon in front of the Guide layer. This icon is visual feedback that this layer is now a Guide layer. Something else has happened that you haven’t seen before: The flake layer is indented below the Guide layer. This means that the flake layer is taking instructions from the Guide layer. The flake layer contains your motion tween, and the Guide layer will contain the trail or path that the tween will follow. Before it can follow the path, however, you will have to draw one. That’s coming up soon, so keep following along.

10. Lock the **flake** layer so that you don’t accidentally put anything on it. You can do this by clicking on the small **dot** below the **Lock** icon on the **flake** layer (the dot turns into a lock).

11. Select the **Guide: flake** layer by clicking once to the right of the layer name. The layer should turn black.
12. In the Toolbox, select the Pencil tool and, for the Pencil Mode option, choose Smooth. That way, when you draw the line for the snowflake to follow, Macromedia Flash MX will smooth out any irregularities for you.

13. On the Stage, draw a curved line to serve as the trail that the snowflake will follow (as shown above). It doesn’t matter what color or stroke width you choose. Macromedia Flash MX is concerned only with the path of the line.
14. Unlock the flake layer by clicking on the Lock icon (so you can make changes to it), and lock the Guide: flake layer by clicking on the dot (because you’re done with it and you don’t want to move or edit it accidentally).

15. Move the Playhead so that it is over Frame 1. Using the Arrow tool, click the little plus sign inside the circle in the middle of the snowflake instance—this is the Registration Point, as you learned in Chapter 6, “Symbols and Instances.” Click and drag the snowflake to the top point of the line that you drew in the Guide layer. When you get close to the line, the snowflake will “snap” to it and the Registration Point will turn into a small circle. This is where the snowflake will start following the line.

Note: It is very important that you grab the snowflake symbol instance from the Registration Point in order for the Motion Guide to work properly. You will know if you have done this correctly if the Registration Point turns into a circle, as shown above.
16. Move the Playhead to Frame 40, the last keyframe of the animation. Again, click the Registration Point of the snowflake symbol instance, and drag the snowflake to the bottom point of the line that you drew on the Guide layer. This is where the snowflake will stop following the line. That’s it!

17. Preview your animation by pressing Enter/Return on your keyboard. Notice that the snowflake now follows the line that you drew on the Guide layer! Now choose Control > Test Movie. Notice that now you don’t see the line at all! That is because the contents of your Motion Guide layer will not be visually exported to the final movie (.swf) file, but your snowflake will still continue to follow the path. When you choose Test Movie, Macromedia Flash MX creates the .swf file for you.

Wouldn’t it be nice if the snowflake rotated in the direction of its movement, instead of always facing in the same direction? In other words, if the snowflake is moving down, it should be pointing down, don’t you think? You’re going to do that next.
18. Click on Frame 1 of the flake layer. In the Property Inspector, click on the check box next to Orient to path. This option does what its name implies. When it is selected, Macromedia Flash MX will do its best to orient the snowflake to face in the direction that the path is going.

19. To make the snowflake start off slow and the gradually speed up as it follows the path, move the Ease slider to -50.

TIP | Easing In and Easing Out

The terms easing in and easing out have to do with the speed of animation. If you leave the Ease setting at its default of None, animation in Macromedia Flash MX will occur in a linear motion, meaning that all the frames will move at the same speed. Easing out means that the animation gradually slows to the last keyframe. Easing in means that the animation gradually speeds up to the last keyframe.

20. Preview your animation again by pressing Enter/Return on your keyboard.

Just by selecting one check box, you’ve caused Macromedia Flash MX to point the snowflake symbol instance in the direction that the path is moving, as though the wind was blowing it along. Altering the speed of the snowflake and adjusting the amount of easing have also given a more realistic feel to the snowflake’s movement. This is a great (and easy) way to add the visual effect that your graphic is actually following the path.

21. Save and close this file. You won’t be using it again.
5. **Exploding Text**

In this exercise, you will create the effect of a word exploding on the screen. In the process, you’ll get to practice creating a symbol from text, breaking apart the letters, and distributing them to layers.

1. Open the `explodeFinal.fla` file from the `chap_07` folder.

2. Choose Control > Test Movie to test the animation. The words explode before your eyes! When you are finished previewing, close the file. You will create this animation next.

3. Open the `explode.fla` file from the `chap_07` folder. This starter file was created for you; it has a red background, and the frame rate has been set to 20 frames per second.

4. Select the Text tool from the Toolbox. In the Property Inspector, set the Font to Arial, set the Font Size to 96, and select Bold.
5. Click anywhere on the **Stage** and type the word *xboarding*.

6. With the text, *xboarding*, selected, choose **Modify > Break Apart**. This will break the text box into nine individual text boxes, one box for each letter.
7. With all nine text boxes still selected, choose **Modify > Distribute to Layers**. This will place each letter on a separate layer. This step is important because in order to create the effect of many motion tweens occurring at once, each tween must reside on its own layer. Likewise, each symbol (which you will create next) must reside on a separate layer.

8. Switch to the **Arrow** tool and click anywhere off the Stage to deselect all nine letters. Using the Arrow tool, select the x. Press **F8** to convert the letter x into a symbol. In the **Symbol Properties** dialog box, name the symbol x and set **Behavior** to **Graphic**. Click **OK**.

**NOTE | Motion Tweening Text**

You don’t have to convert a regular text block to a symbol in order to use it as the artwork for a motion tween. However, you are limited in the effects that you can apply to text boxes. With a text block, you can animate the position and scale, rotation, skew, and flip. However, with a Graphic symbol with text inside, you can animate Color Styles such as color, brightness, alpha, and tint. With a symbol, you have more options for creating effects in your motion tween than you have using a regular text block.

9. Using the **Arrow** tool, select the b. Press **F8** to convert the letter b into a symbol. In the **Symbol Properties** dialog box, name the symbol b and set the **Behavior** option to **Graphic**. Click **OK**.

10. Repeat step 9 seven more times to make seven more symbols: o, a, r, d, i, n, and g. You can name the symbols o, a, r, d, i, n, and g, respectively, in the **Symbol Properties** dialog box.
11. On the Timeline click on Frame 20 and drag your cursor down over all nine layers that have a symbol on them. Then press F6 on the keyboard. This technique will add a keyframe to Frame 20 on all nine layers at once! Tip: To view all the layers at the same time, click and drag down on the bottom bar (circled above) of the Timeline.

12. Add a keyframe on Frame 40 of all nine layers in the same way you did in the previous step. This is where the letters are going to finish their animation.

13. Click anywhere off the Stage to deselect all the symbols. Making sure the Playhead is over Frame 40, click and drag the x symbol off the left side of the Stage onto the work area. When the x explodes, it will end up in this position.
14. In the Toolbox, select the Free Transform tool. Use this tool to rotate and scale the x symbol. The degree of the rotation and scale are completely up to you.

15. Make sure the Property Inspector is visible; if it is not, choose Window > Properties. In the Color Styles box, choose Alpha and set the amount to 0%. I recommend keeping the Alpha setting at 0% on the last keyframe. That way, the x will fade out completely as the word “xboarding” explodes into space.
16. Modify the positions of the other Graphic symbols on Frame 40 as you did in the previous step, scaling, rotating, and adding an alpha effect to each one. Feel free to move the symbols and then use the Free Transform tool to scale, rotate, or even flip and skew each letter in any way you want, but I recommend keeping the Alpha setting at 0%. In the screen shot above, I’ve selected all of them so that you can see the variety of positions you can choose.

17. Click anywhere between Frames 20 and 40 on the g layer and drag down to the x layer to select all the layers on that frame. Using the Property Inspector, choose Motion from the Tween drop-down menu. This will add a motion tween to all the layers at once! Nice workflow shortcut, don’t you think?

Next you’ll use easing to make the explosion look more realistic.

18. Click and drag down to select Frame 20 on all nine layers.
19. In the **Property Inspector**, drag the **Ease** slider up until it reads **80 Out**. Adding easing to the motion tween will cause the animation to start off fast and then slow down as it nears the end of the animation.

20. That's it! Choose **Control > Test Movie**, or use the shortcut **Ctrl+Enter** (Windows) or **Cmd+Return** (Mac) to preview the animation.

*You are almost done. Just a little housekeeping left to do ....*

21. In the **Timeline**, double-click to the left of the **Layer 1** name to open the **Layer Properties** dialog box. Name the layer **text** and set the **Type** option to **Folder**. This will turn the layer into a Layer Folder. You learned about Layer Folders in Chapter 5, "Shape Tweening."
22. In the **Timeline**, click to the right of the x layer name, and then Shift+click to the right of the g layer name to select all the layers. Drag the layers on top of the **text** Layer Folder to place the layers inside the folder. **Tip:** If you can’t see all the layers, click and drag down on the bottom of the Timeline to reveal them.

23. Click the arrow to the left of the **Layer Folder** icon to collapse the folder. Much better—everything is neat and put away now!

24. You can save and close this file. You will not need it again.
Motion Tweening Options and Limitations

There are many additional options for creating animation using motion tweens. For your reference, here is a list of the things that motion tweening can and can’t do.

What Motion Tweening Can Do

Symbol Instances

• Tween position
• Tween brightness
• Tween tint
• Tween alpha
• Tween scaling
• Tween rotation
• Tween skew

Grouped Objects

• Tween position
• Tween scaling
• Tween rotation
• Tween skew
• Tween a text block (editable text)

What Motion Tweening Can’t Do

• Tween a shape
• Tween broken-apart text
• Tween multiple items on the same layer

This chapter has taught you how to use symbols to create motion tween animations. You learned that motion tweening can produce many different effects beyond simply moving a symbol from one location to another. The exercises showed you how to use motion tweening to animate scale, rotation, tint, and alpha. You also learned how to create a Motion Guide and make text appear as though it