Special Supplement to the OpenOffice.org Resource Kit

OpenOffice.org 1.1 Changes
Special Supplement to the OpenOffice.org Resource Kit

OpenOffice.org 1.1 Changes

Solveig Haugland
Floyd Jones
Contents

Overview of the New Features in OpenOffice.org 1.1 .......................... 1
  What's in This Document .................................................. 2
  Overview of Selected New Features in OpenOffice.org 1.1 .................... 2
    Some Big Things Everyone Wanted ........................................ 2
    Some Small Stuff That Makes Things Easier .............................. 2

Enhanced File Format Support .................................................. 3
  New Procedures .............................................................. 4
  Exporting to PDF .......................................................... 4
  Emailing Document as a PDF Attachment .................................... 6
  Using XML Import and Export Filters ..................................... 9
    What the Point Is of This Feature ..................................... 9
    General Overview of XML Filters in 1.1 ................................. 9
    Slightly Tricky Thing With Filter Names ............................... 10
  Creating or Modifying an XML Filter .................................... 12
  Using an Existing or New XML or Mobile Device Filter ..................... 14
  Testing an XML Filter .................................................... 14
  Exporting to XHTML (or any other format created through the XML Filters window) 16
  Using Mobile Devices With OpenOffice.org 1.1 .......................... 18
    Installing the Filters for Mobile Devices ............................ 18
    Saving OpenOffice.org Documents in a Format For Your Mobile Device .... 20
    Synchronizing File Types ............................................. 21

Accessibility ................................................................. 23
  New Accessibility Information ............................................ 24

Draw/Impress ................................................................. 25
  New Draw/Impress Procedures .......................................... 26
  Exporting a Presentation to Flash ....................................... 26
  Running a Presentation From the Command Line ........................... 27

Database ................................................................. 29
  New Database Features .................................................. 30
  Using the New MySQL Data Source Type ................................ 30
  Using the Database Report AutoPilot .................................... 31
Creating a Mail Merge From the Current Document or an Existing Data Source . . . .36

Creating a Mail Merge Document the New Way, If You’ve Already

Got a Data Source Set Up .................................................. 37

Creating a Data Source and Mail Merge Document All at Once, the New Way ....... 41

Setting Up a Data Source the Old-Fashioned Way .................................. 45

**Programing and Automation** ............................................ 47

New Programming and Automation Features ....................................... 48

Recording a Macro ................................................................ 48

Using the Error Report Tool ................................................................ 48

Starting the Error Report Tool ...................................................... 49

Completing the Report .................................................................. 49

Sending the Error Report ................................................................ 49

**Full List of Additions In OpenOffice.org 1.1** ............................... 51

List of Additions in Office.org 1.1 .................................................. 52

Enhanced File Format Support .................................................... 52

Accessibility .............................................................................. 52

Internationalization .................................................................. 52

Microsoft Office compatibility enhancements .................................. 53

Writer ...................................................................................... 53

Draw/Impress ........................................................................... 53

Spreadsheet ............................................................................ 53

Database .................................................................................. 53

Writing Aids ............................................................................. 54

Programing and Automation ...................................................... 54

Other Enhancements .................................................................. 54
Overview of the New Features in OpenOffice.org 1.1
What’s in This Document

This document covers the key things that are in 1.1, with a complete list in the back. We’re basically putting in all the new procedures we’d have added if we were reprinting the whole book.

We don’t cover everything in detail since, for instance, we don’t have a lot to say about support for copy/paste of bitmap graphics on UNIX. And likewise in 1.1 if you right click on a hyperlink, the right click menu now includes the item “Open Hyperlink.” We find little to add to that, as well.

The full list of features, large and small, is in List of Additions in Office.org 1.1 on page 52. If you want to read the list online, you can see the complete list at:

http://www.openoffice.org/dev_docs/source/1.1rc/features.html

Regarding the blank pages in this document  This document was set up to print correctly in a right/left setup so that if you print it double-sided, you’ll have a nice big left margin to hole-punch and put in a notebook or use the binding of your choice. We’re not trying to pad the content, honest; we’re just dyed-in-the-wool double-sided layout people. And we kinda wanted it to look like the book.

Overview of Selected New Features in OpenOffice.org 1.1

The essence of the changes in 1.1, in our opinion, is that they put in a few things that everyone wanted, and made a lot of small changes that make a lot of thing easier.

Some Big Things Everyone Wanted

Print to PDF  Just choose File > Export to PDF, and you’ve got an easy way of making a noneditable, readable-by-anyone, version of your OpenOffice.org file. This rocks.

Export to Flash  The Impress viewer from 5.2 is no more but you can export your Impress presentations to Flash now.

Macro recorder  Macro folks, rejoice. The macro recorder, a little wonky but present in 5.2, is back and ready to go in 1.1.

Some Small Stuff That Makes Things Easier

More obvious mail merge printing  When you printed a mail merge document in 1.0x, you had to choose File > Form Letter, not File > Print. Now you choose File > Print, and a message pops up and asks if you want to do it the mail merge way (printing a version for each record in the connected database). That’s a really nice usability change.

Green arrows on every dropdown icon  You also have a lot of dropdown icons in OpenOffice.org, like the object bars across the top where you click and get another bunch of selections for color, table borders, etc. Sometimes there was a green arrow on the icon to indicate a dropdown, sometimes there wasn’t. We had fun, or tried to, teaching these features in training classes. “It’s a challenge!” we’d say. “Guess which icons have extra dropdown features!” Now, all that fun is over because there’s a small green arrow on every icon that drops down.

This is just a short selection. The rest of the document lists the new features in each category, and provides summaries or step-by-step procedures for using them.
Enhanced File Format Support

IN THIS CHAPTER

• New Procedures ................................................................. page 4
• Exporting to PDF ................................................................. page 4
• Emailing Document as a PDF Attachment........................... page 6
• Using XML Import and Export Filters ................................ page 9
• Exporting to XHTML (or any other format created through the XML Filters window) . page 16
• Using Mobile Devices With OpenOffice.org 1.1 ....................... page 18
New Procedures

Here are the procedures we wrote up for the features that require more explanation.

- Exporting to PDF
- Emailing Document as a PDF Attachment
- Using XML Import and Export Filters
- Creating or Modifying an XML Filter
- Using an Existing or New XML or Mobile Device Filter
- Testing an XML Filter
- Exporting to XHTML (or any other format created through the XML Filters window)
- Using Mobile Devices With OpenOffice.org 1.1

Exporting to PDF

Export to PDF means that absolutely anyone can now read your OpenOffice.org documents, without your having to save them in MS Office format or another format. (Well, they need to have the free Adobe PDF reader available from www.adobe.com, but that’s easy to get, and most people have it already.)

1. Open an OpenOffice.org document, such as a Writer document, that you want to print to PDF.
2. Choose File > Export as PDF.
3 A window will appear where you can specify what the PDF file name should be and where you want it to be created.

Select the directory where you want the PDF file to be created.

Type the file name you want. Mark the Automatic File Extension option and you don’t have to type PDF.

4 Click Save.

5 The PDF options window will appear. Leave the All pages option selected or specify a range.

Leave the All option selected, or to print a range, specify the page numbers separated by dashes (for a range) or semicolons (for disconnected pages).

6 Next specify Compression options. If you aren’t concerned about file size, leave the Press Optimized option selected. If it’s more important to make the file small and you’re not concerned about print quality, select Screen Optimized. Print Optimized is halfway between the two.
Here’s how the options shake out in a more detailed way, from the online help.

<table>
<thead>
<tr>
<th></th>
<th>Screen optimized</th>
<th>Print optimized</th>
<th>Press optimized</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resolution</td>
<td>600 dpi</td>
<td>1200 dpi</td>
<td>2400 dpi</td>
</tr>
<tr>
<td>Compress Text and Line Art</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Bitmap Images</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resampling</td>
<td>Average</td>
<td>Bicubic</td>
<td>Bicubic</td>
</tr>
<tr>
<td></td>
<td>Downsampling at</td>
<td>Downsampling at</td>
<td>Downsampling at</td>
</tr>
<tr>
<td></td>
<td>72 dpi</td>
<td>300 dpi</td>
<td>300 dpi</td>
</tr>
<tr>
<td>Compression</td>
<td>Automatic</td>
<td>Automatic</td>
<td>Automatic</td>
</tr>
<tr>
<td>Quality</td>
<td>Medium</td>
<td>High</td>
<td>Maximum</td>
</tr>
<tr>
<td>Monochrome Bitmap Images</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resampling</td>
<td>Average</td>
<td>Bicubic</td>
<td>Bicubic</td>
</tr>
<tr>
<td></td>
<td>Downsampling at</td>
<td>Downsampling at</td>
<td>Downsampling at</td>
</tr>
<tr>
<td></td>
<td>300 dpi</td>
<td>1200 dpi</td>
<td>1200 dpi</td>
</tr>
<tr>
<td>Compression</td>
<td>CCITT Group 4</td>
<td>CCITT Group 4</td>
<td>CCITT Group 4</td>
</tr>
</tbody>
</table>

7  Click Export.

8  Find the PDF file and open it; it will open in Adobe PDF reader.

Emailing Document as a PDF Attachment

If you just want to get a PDF version of your OpenOffice.org document to someone else and you don’t care about having a PDF of it around on your hard disk, use this feature.

First: Email Setup

1  You might want to check, first, what OpenOffice.org thinks your email program is. Choose Tools > Options > OpenOffice.org > External Programs.
2 Select your email program from the dropdown list. If it isn’t there, just leave Default Program.

3 In the Path field, if it’s active, specify the path to the executable file for your mail program.

4 Click OK.

Second: Emailing a PDF of a Document

1 Open any OpenOffice.org document; a spreadsheet is shown here.
2 Choose File > Send > Document as PDF Attachment.

3 The PDF options window will appear. It’s probably best to select Screen Optimized.

4 Click Export.

5 Your email program will start, if it hasn’t started already, and you’ll see a new email document from you, with the document in PDF format attached.
Using XML Import and Export Filters

Note – This feature is, quite frankly, not for Normal People. Or rather, this is not a feature you would use in the course of a normal day of writing reports and sending out helpful reminders to your customers to pay their bills.

What the Point Is of This Feature

XML is kind of like chocolate sauce; it’s useful in just about anything. However, one of the advantages of the new XML filters is that one of the ones you get for free is for going between DocBook and OpenOffice.org. This means you can do a lot of complex, powerful XML creation in DocBook, and then open the documents in OpenOffice.org and have a nice WYSIWYG way to deal with the document.

OpenOffice.org documents are, of course, in a compressed XML format. Unzip any OpenOffice.org document and you’ll get a few .xml files, including content.xml where the content is kept. For more information, see chapter 5 of the “OpenOffice.org Resource Kit.”

You can’t swing a cat these days, of course, without hitting a program, document, or electric toothbrush with XML built right in.

Note – If every once in a while you think people are a little too nuts for XML, you’ll appreciate this. http://www.cafeshops.com/techspeak.6243457

General Overview of XML Filters in 1.1

In 1.1, you can now get hip deep in the XML frenzy with the ability to export and import documents based on your own XSLTs and DTDs. (As well as the ones included in 1.1.)

- XSLTs define how the transformation takes place between one document and another. If you encounter <mybigredheading> in one document, it turns into <fancyheading> in another, for instance.
- DTDs define the rules for the content. Your DTD might say that after every <fancyheading> you must have at least one <fancyparagraph>, for instance.
You get a few XML import and export filters with OpenOffice.org 1.1, and you can create your own, as well.

When you bring in a Microsoft Word 2003 XML document, for instance, that Word filter is used to do the translation. When you export to XHTML by choosing File > Export and selecting XHTML as the file format, well, the XHTML filter is used.

**Slightly Tricky Thing With Filter Names**

You can modify the existing filters as you like, though it’s probably a better idea to create new filters just to keep the basics as an emergency backup. The import filters will then show up in the Open window in the file dropdown list, and the export filters will show up in the Export window in the file type dropdown list when you’re exporting files of the type the filter is set up for.

The only tricky part is that the name you give a filter that shows up in the main window isn’t the name that shows up in the dropdown lists. And the field where you put in the name that shows up in dropdown lists isn’t a required field. So you can do everything right, but if you don’t put in the right name, you won’t see the filter.
Using XML Import and Export Filters

See the following diagram for more info.

The name in the Filter Name field for this Export filter is shown in the XML Filter Settings window. But...

Only the “Name of File Type” field value shows up when you choose File > Export and look for the filter in the dropdown list.

Only “Name of File Type” field value shows up when you choose File > Open and dig through the File Format dropdown list.

Figure 1  How naming works for XML import and export filters
Creating or Modifying an XML Filter

You know best how your XML filter is going to be used, so we won’t hit you over the head with lots of detail here. Check the online help also for some supplementary information. Here’s the basics.


2. The filter settings window will appear. The window below shows sample filters we’ve created; you’ll only see Docbook, Word, and XHTML.

3. To modify a filter, select one and click Edit. To create one, click New.

4. In the General tab of the XML Filter window, specify the appropriate information.

5. Click the Transformation tab.
Fill in the appropriate fields, then click OK.

- **DocType** – Enter the DOCTYPE of the XML file. For example, the DOCTYPE defined for the current DocBook XML filter is:
  ```xml
  <!--OASIS//DTD DocBook XML V4.1.2//EN
  The resulting line in the XML document is:
  ```xml
  <!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">

- **DTD** – If you want, enter the public or system identifier of the DTD (Document Type Definition) that you want to use. If present, both identifiers are written to the DOCTYPE declaration in saved XML files. The public identifier is used to detect the filter when you open a file without specifying a filter.

- **XSLT for export** – If this is an export filter, enter the file name of the XSLT stylesheet that you want to use for exporting.

- **XSLT for import** – If this is an import filter, enter the file name of the XSLT stylesheet that you want to use for importing.

- **Template for import** – Enter the name of the template that you want to use for importing. In the template, styles are defined to display XML tags.

The path to the directory that contains the template must be included in Tools > Options > OpenOffice.org > Paths. When you open an XML file whose filter uses the template, the
template opens first. In the template, you can map OpenOffice.org styles to display XML tags in the XML document.

**Using an Existing or New XML or Mobile Device Filter**

When you want to use an import filter to open a particular file, just choose File > Open as usual. Select the right file type in the type dropdown list, as well as the file you want.

To export a file using a particular filter, just choose File > Export. Again, select the right filter in the type dropdown list, and specify the file name.

**Testing an XML Filter**

As likely as it is that your XML is perfect, it’s kind of nice to validate it ahead of time before you start using it on a grand scale. Here’s how to validate the XSLTs for your filters.

1. Open the document to use to validate the filter.
2. Choose Tools > XML Filter Settings.
3. Select the filter to test.
4 Click Test XSLTs.

5 The Test XML Filter window will appear.

6 Click Current Document.

7 The following window will appear. Click Validate.
With any luck, the window that appears will say No Errors Found.

Exporting to XHTML (or any other format created through the XML Filters window)

You can create an XHTML format version of any OpenOffice.org document with the Export feature. The way the file is exported depends on the settings specified in the XML Filter Settings window (choose File > XML Filter Settings).

1. Open the OpenOffice.org document you want to export.

2. Choose File > Export.
3 In the window that appears, select XHTML from the file dropdown list.

4 In the same window, specify the file name and where the file should be created.

5 Click Save.

6 When you open the document in TextPad or a similar editor, it’ll look something like this.

Using Mobile Devices With OpenOffice.org 1.1

You can use OpenOffice.org 1.1 with mobile devices that handle formats like AportisDoc (Palm), Pocket Word and Pocket Excel.
Installing the Filters for Mobile Devices

1. Close OpenOffice.org and the Quickstarter.

2. If you’ve installed ActiveSync in Windows, disconnect your Pocket PC device from ActiveSync.

3. Start the OpenOffice.org Setup program. If it doesn’t show up when you choose Start > Programs > OpenOffice.org, then find it in the directory where you installed OpenOffice.org 1.1 as shown.

4. The main setup window will appear. Select Modify and click Next.
5  The next window lets you choose components to install. Expand the Optional Components item. If the mobile devices option is already dark blue, your filters are installed. If not, click it and it’ll turn blue. (You might have to click a bit but you’ll get it to turn blue before long.)

6  Click Modify.

7  You’ll be prompted again to specify whether you want OpenOffice.org to be the default application for the displayed file formats. This has nothing to do with the mobile device installation. Most people like to leave all the options unmarked.

8  Click Next.

9  The install will run full screen, fairly quickly.
10 The install will complete and tell you when it’s done. Click Complete.

Saving OpenOffice.org Documents in a Format For Your Mobile Device

You just need to select the right format in File > Save As.

1 Choose File > Save As.

2 In the Save As window, select the format type for your device in the dropdown list.

3 Specify a file name.

4 Click Save.

Synchronizing File Types

To convert Pocket PC formats to and from OpenOffice.org formats, you must first change some options within ActiveSync. To do this, open the ActiveSync window and open its Options dialog. Perform the following steps:

1 Open the ActiveSync window.

2 Open the Options dialog box.

3 Select the Rules tab.

4 Click the Conversion Settings button.

5 Click the Device to Desktop tab.
6 Select Pocket Word Document - Pocket PC and click Edit.

7 In the dropdown list of available conversions, select OpenOffice.org Writer.

8 Click OK.

9 Repeat steps 4 and 5 for Pocket Excel Workbook, and for this type select OpenOffice.org Calc.

After these steps you can copy documents between OpenOffice.org and your Pocket PC, either by the ActiveSync software or by the Windows Explorer. The filters will be applied to the document files automatically.
Accessibility

IN THIS CHAPTER

• New Accessibility Information. .....................................................page 24
New Accessibility Information

Here’s the window (choose Tools > Options) that lets you set up the new accessibility features.

Here’s the window for setting colors for changes, the grid, and much more. We’re pretty excited about being able to set the grid to a nice bright color. Choose Tools > Options to get to this window, as well. This is also where the HTML configuration setup has moved to.
Draw/Impress

IN THIS CHAPTER

• New Draw/Impress Procedures ................................................. page 26
• Exporting a Presentation to Flash.............................................. page 26
• Running a Presentation From the Command Line .................. page 27
New Draw/Impress Procedures

Here are the new procedures.

- Exporting a Presentation to Flash
- Running a Presentation From the Command Line

Exporting a Presentation to Flash

If you want to post a presentation online or just distribute it to non OpenOffice.org users, exporting it to Flash first is a useful option. (You’ve been able to export it to HTML as well, for quite a few versions, but the dynamic stuff like transitions doesn’t survive the export.)

1. Open the presentation you want to export to Flash.
2. Choose File > Export.
3. Enter the file name you want, and select Macromedia Flash as the file type, in the dropdown list.
4. Click Save.
5. OpenOffice.org will process for a while; when it’s done, you’ll see the file in the location where you specified.
Running a Presentation From the Command Line

**Note** – The help contains an excellent reference to all the command line parameters. See the help topic titled Starting the OpenOffice.org Software With Parameters. We particularly get a kick out of “headless mode” (allows you to use the application without user interface).

You can start a presentation from the command line now, with this syntax.

1. Under Windows, select **Run** from the Windows Start menu, or open a Shell under UNIX® based platforms.

2. Under Windows, type the following text in the **Open** text field and click **OK**.

3. Under UNIX based systems, type the following line of text, then press **Return**:

   `{install}\program\soffice.exe -start {filename}

   Replace `{install}` with the path to your installation of the OpenOffice.org software (for example, `C:\Program Files\Office`, or `~/office`).
Database

IN THIS CHAPTER

• New Database Features. .......................................................... page 30
• Using the New MySQL Data Source Type .................................... page 30
• Using the Database Report AutoPilot. ....................................... page 31
• Creating a Mail Merge From the Current Document or an Existing Data Source .... page 36
New Database Features

Here are the procedures we’ve written up.

- Using the New MySQL Data Source Type
- Using the Database Report AutoPilot
- Creating a Mail Merge From the Current Document or an Existing Data Source

Using the New MySQL Data Source Type

Creating a MySQL data source follows the same general procedures as setting up a data source for another database type. You’ll probably want to have some pretty solid MySQL documentation too. However, here’s what the help says about the syntax for the URL to the database.

- For a JDBC connection, enter the host name, the port number, and the database name using the form `<host>:<3306>/<DBNAME>`.
- For an ODBC connection, enter the name of the ODBC data source.

We’ve also found that the setup is surprisingly easy. Just download the latest 4.0.15 release of MySQL and the latest release of MyODBC. Install them just like it says in the documentation. Create your database as usual; the command line tool works fine. Then just use the data source window in OpenOffice.org as instructed above to create a data source to connect to it, and you’ll be rockin’ and rollin’ (and even insertin’ and deletin’).

If you’re hooked in Microsoft Access right now and want to switch, take MySQL out for a spin.
Using the Database Report AutoPilot

The new database report AutoPilot is pretty slick. Instead of rolling your own, you can create a report with an AutoPilot. It’s similar to the AutoPilot for creating a form.


3. Select the data source you want to use from the Data Source dropdown list; select and the table, which is a spreadsheet sheet in this case, in the Tables or Queries list.
4 Use the arrows to move the fields you want in the report into the Fields In Report list.

5 Click Next.

6 The next window shows the default labels for the fields. Change any of the labels you want.

7 Click Next.
8 Grouping might not apply to all reports; grouping is useful for fields where there are multiple
values per record. Each field you insert is a subgroup of the previous; you can insert up to four
fields.

9 Click Next.

10 Choose how you want to sort the report, and for each field to sort in ascending order (A to Z, lowest to highest) or descending.

11 Click Next.
12 The layout window will appear. Select what data layout you want and what formatting you want. The preview of your choices will be displayed in the document in the background.

13 Click Next.

14 In the final window, you choose whether to create a dynamic report (one that will stay linked to the data) or a static report. You can usually just accept the defaults.

15 Click Create. You might be warned that an existing file with the same name exists; overwrite it if appropriate; otherwise specify a different filename.
16 The report will appear. Depending on your data and the formatting, there might not be enough room for the data.

17 The formatting is just done in a table with standard text formatting, so resize the table as appropriate, and change the font or font size to make the data fit better.
Creating a Mail Merge From the Current Document or an Existing Data Source

In OpenOffice.org 1.0x, doing mail merges was, technically, not hard. It just helped to know how ahead of time. There were three basic steps.

1. Create a data source (Tools > Data Sources).
2. Create a mail merge document (File > AutoPilot > Letter or roll your own by dragging fields from View > Data Sources onto a document).
3. Print the mail merge document (File > Form Letter, rather than File > Print).

This works fine and we do it that way. There are two new features/changes in 1.1.

- You can still do mail merge the old way. However now, as an alternative, when you choose Data > Mail Merge, a series of windows guides you through the process.

- You just have to choose File > Print, and a message box prompts you to make the right choice for printing a mail merge document.

We really like the second change; it makes a lot of sense.

The first one is nice if you’ve already got your data source set up, and it’s nice if you want to set up a data source for your email address book on the fly. Otherwise stick with the old way.

For more down and dirty info about data sources in general, see the chapters on creating mail merges, and on creating data sources, in the “OpenOffice.org Resource Kit”. It’s also covered in

Creating a Mail Merge Document the New Way, If You’ve Already Got a Data Source Set Up

This is fairly slick. You used to do this by viewing the data source (View > Data Sources) and dragging the fields onto the document. This doesn’t really offer new capabilities but going at it from the Tools menu lets people find it a lot more easily.

1. Open the document that you want to turn into the mail merge document: your holiday letter to all your friends, or your letter gently asking your customers to pay up. The AutoPilot will take you from beginning to printing without really wanting to pause along the way so get your document totally ready to print, just without the data source fields like name or address.

2. Choose Tools > Mail Merge.

3. A message will appear. Select Current Document and click OK.

Note – If you selected From Template, then you’d go to the template selection window and you’d select your Big Mail Merge Template document. And then...well, if your system works like ours, nothing would happen. You’d have to choose Tools > Mail Merge again, and that time select Current Document. So it’s best to just have your mail merge document open already when you start.
4 The next message will appear. You’ve already got a data source, so select Existing and click OK.

![Data Source Connection dialog box]

Fields are used to personalize form letters. The fields are placeholders for data from a data source, such as a database. The fields in the form letter must be connected to the data source.

5 The Fields window will pop up. Leave the Mail Merge Fields item selected.

![Fields window]

6 On the right side, find your data source you want to use for this mail merge and expand it by clicking the + signs til you see fields, as shown.

![Fields window with expanded data source]
7 Select a field you want in the mail merge and click Insert.

8 You’ll see it show up in the mail merge document. If it didn’t get inserted in the right spot (it was inserted wherever your cursor was), just cut and paste the field to the right spot. Then add a space after that field, or whatever other spacing or punctuation you want, and put your cursor wherever you want the next field inserted.

9 Insert all the other fields you need. Either as you insert the fields or afterwards, insert spaces, punctuation, and anything else you need, in the document.
10 When you’re done inserting fields, click Close.

11 The Mail Merge window will appear, whether you’re ready to print the document or not. This is a preprinting window where you can choose again which data source to use and in that data source, which records to use. For instance, you can print to only customers 1-17.

You can cancel out of here if you want; to get back to it later just choose File > Print and when prompted to print a form letter, click Yes.

The “OpenOffice.org Resource Kit” covers more information about this window, including printing to a file.

Click OK when you’re ready to print.

12 The normal print window appears. Select your printer and how many pages of the mail merge document to print. (That is, if it’s a three page document, do you print all three pages for every record in the database, or do you print only the second and third pages, for every record in the database.) Click OK when you’re ready to print.

If you want to just cancel at this point since you’re not ready to print, then go ahead and do so. Just save the file as you would any other document.
13 If you want to see the values, like Jane Roberts instead of firstname lastname, choose View > Data Sources. Find your data source in the scrolling list on the left, and expand it til you see the table. Select the table, and click on the upper left corner of where the data is shown. Then (this is the last step) click the Data to Fields icon shown.

Creating a Data Source and Mail Merge Document All at Once, the New Way

This starts out suspiciously like the previous procedure, but rapidly gets into a bunch of other windows. It’s the same stuff discussed in the data sources chapter of the “OpenOffice.org Resource Kit;” you just come at it from a different angle.

Note – This feature is for people who just want to set up mail merges out of their email address books. It’s fairly easy to do if that’s your goal; it’s actually more complicated to do mail merges this way if you’re doing any other kind of data source. So we say, go away and set up your data source the normal way if you’re not just trying to get a quick and easy mail merge out of your email address book.

1 Determine where your data is that you’re going to turn into a data source. As mentioned above, this procedure is easiest if you’re just trying to use your email address book.

The data source can also be a plain text file with a tab or other separator between each piece of information; it can be a spreadsheet; it can be a mySQL or Oracle database.

If it’s a database, you’re also going to need to know the syntax for connecting to it. Again,
check out the data sources chapter of the “OpenOffice.org Resource Kit” for more information about this.

2 Open the document that you want to turn into the mail merge document.

3 Choose Tools > Mail Merge.

4 A message will appear. Select Current Document and click OK.

5 The next message will appear. You need to set up a data source, so select Create New Connection and click OK.

6 Here’s where you select where your data is. Select the kind of address book you have. (Or if you really want to use this procedure, select Other External Data Source and we’ll tell you what to do about that too.)

7 Click Next.

8 What windows you see next will depend on your address book. Go through the next few steps and if you get these windows, follow the corresponding instructions.
• You might see this, for instance. Make the correct selection and click Next.

• If you selected a data source besides address book, you’ll most likely see these windows. Click Settings first. Then in the Create Address Data Source window (which of course also lets you create non address data source windows) specify the data source type, such as spreadsheet or even mySQL, and then specify the path to the file or database you’re connecting to.

Click OK when you’re done.
- You might see these windows too. If so, just click Field Assignment in the first window, and you’ll see the next window. Then select the correct field in the dropdown list that corresponds to the piece of text next to it.

9 Finally, you’ll see this window. This part is easy, just enter the name for the data source. Click Create.

10 And this message appears. Just click OK.
And now, finally, you get to the point where you can insert fields into your mail merge document. Skip to step 5 of *Creating a Mail Merge Document the New Way, If You’ve Already Got a Data Source Set Up*, on page 38.

### Setting Up a Data Source the Old-Fashioned Way

This is in the “OpenOffice.org Resource Kit” but we’re throwing it in here just to make this chapter more of a one-stop shopping arrangement. This tells you how to create a data source from a spreadsheet, which is pretty much the easiest thing to do.

1. Determine what spreadsheet you’re going to use.

2. Choose Tools > Data Sources.

3. Click New Data Source.
4 Type a name for the data source. The example shown is potential_authors.

5 In the dropdown list of the window, select Spreadsheet as the type.

6 In the Database URL field, click the browse icon and specify the name of your spreadsheet.

7 Click OK to close the window and save your new data source.

At this point, you could go do Creating a Mail Merge Document the New Way. If You’ve Already Got a Data Source Set Up on page 37, or you could choose File > Mail Merge and create a mail merge doc that way. Or a few other things. See the mail merge chapter of the “OpenOffice.org Resource Kit” for more information.
Programing and Automation

IN THIS CHAPTER

• New Programming and Automation Features ...........................................page 48
• Recording a Macro .............................................................................page 48
• Using the Error Report Tool ...............................................................page 48
New Programming and Automation Features

The new features are:

- Macro recorder
- Crash reporter for collecting crash dump and error information
- Integrated Python-UNO bridge allowing creation of UNO components in Python
- A new java to native UNO bridge with up to 10 times better performance.
- Detection of a misconfigured Java installation.
- OpenOffice.org ActiveX Control (Windows only).
- Additional property pages for OpenOffice.org file types in Windows Explorer.

Here are the two new procedures.

Recording a Macro

This procedure just covers recording a macro, new in 1.1. For information about dealing with macros and writing them, refer to the appendix of the “OpenOffice.org Resource Kit,” the OpenOffice.org 1.1 online help, and http://api.openoffice.org/

1. Be sure OpenOffice.org is running, and the document where you want to perform the actions to be recorded is open.

2. Choose Tools > Macro > Record Macro.

3. A small window will appear, as shown at right.

4. Perform the actions you want the macro to perform. This can be typing, searching and replacing, and other actions. We find that it doesn’t complete things like inserting a date field, though, regardless of whether you use mouse or keyboard navigation.

5. Click Stop Recording.

6. The macro window will appear. Type the name of the macro and click Save. (You can also save it within a particular module.)

7. To see the macro, select it and click Edit.

Using the Error Report Tool

This is more of a tool for Sun and the OpenOffice.org team than for you, but what helps them create better software helps you and helps all of us. We really don’t experience crashes but if you do, go ahead and use it to send Sun the info about what was happening when the program crashed. (We think it’s analogous to that message that you get in Windows XP, “you chose to end a nonresponsive program, do you want to send a message to Microsoft.”)

Sun won’t sell your name to the Telemarketers From Hell association; you can see privacy info at http://www.sun.com/privacy/
Starting the Error Report Tool

With most program crashes the Error Report Tool will start automatically. However, if the program seems to be stuck and the tool does not start automatically, you can start the tool manually: Go to the {installpath}/program folder and start the crashrep.exe file.

Completing the Report

On the main Error Report Tool dialog, you can enter some additional information that may help our developers to localize the error. For example, if the error only appears after a change in your hardware or software environment, or if you clicked on a button, go ahead and include that information.

Sending the Error Report

You can enter more info about the crash if you want, then click Send. You won’t get an answer from Sun; if you want to chat with someone, they suggest going to the Support Forum.

The error report consists of several files:

- The main file contains information about the error type, operating system name and version, memory usage, and the description that you entered. You can click the Show Report button on the main dialog of the Error Report Tool to view what will get sent in the main file.
- In addition, relevant memory contents and stack traces are gathered by some system standard tools (dbhhelp.dll on Windows systems, pstack on UNIX systems).
IN THIS CHAPTER

• Enhanced File Format Support ..................................................page 52
• Accessibility .................................................................page 52
• Internationalization ..........................................................page 52
• Microsoft Office compatibility enhancements ...............................page 53
• Writer .................................................................page 53
• Draw/Impress ...............................................................page 53
• Spreadsheet .................................................................page 53
• Database .................................................................page 53
• Writing Aids .................................................................page 54
• Programing and Automation ......................................................page 54
• Other Enhancements ..........................................................page 54
List of Additions in Office.org 1.1

This list is taken directly from the indicated URL.
2003-07-11
http://www.openoffice.org/dev_docs/source/1.1rc/features.html

Enhanced File Format Support
- PDF (Portable Document Format) export
- Support for mailing a document as PDF
- DocBook/XML import/export
- XHTML export
- Support for exporting as a flat XML file
- Support for Macromedia Flash (SWF) export
- Support for mobile device formats like AportisDoc (Palm), Pocket Word and Pocket Excel
- Example XSLT based filter for Office 2003 XML documents

Accessibility
- Support for full keyboard navigation and control
- Support for tracking system color scheme and theme settings
- Support for accessibility in the help system and documents
- Initial support for Assistive Technologies via Java accessibility APIs

Internationalization

CTL, vertical and bidirectional writing
- Support for vertical writing within text documents, text frames and graphic objects
- Support for vertical writing in spreadsheet cells (the direction is individually selectable)
- Support for input, display and editing of scripts using Complex Text Layout (CTL)
- Support for RTL layout and text in the OpenOffice.org GUI
- Support for BiDi-writing in OpenOffice.org documents
- Support for using either Arabic or Hindi numerals
- The RTL vs. LTR default text direction is automatically selected based on locale

Other Internationalization enhancements
- Support for various 8-bit Arabic and Hebrew text encodings / code pages
- Support for the KOI8_U encoding
- New CTL options tab in language options dialog
- Rescue mode support for BiDi/CTL with X11 fonts
- Sequence Input Checking (SIC) for languages like Thai and Hindi
- Initial glyph fallback support
Microsoft Office compatibility enhancements

All components
- More accurate import and export of graphics objects
- Import and export of CJK and CTL documents
- Enhancements to overall stability and accuracy of conversion

Word
- Forms conversion within Word documents
- Improved import of text document layout

Excel
- Support for Data Validation
- Import/export of graphical details of charts

PowerPoint
- Even better one-to-one layout of text frames
- Improvements to import of WordArt objects

Writer
- Enhanced footnote support
- Improved hyperlink support for TOCs
- Improved keyboard handling in toolboxes
- Plain text files are now imported using a non-proportional font
- Configurable font for HTML and BASIC source code
- Support for drawing objects in headers and footers

Draw/Impress
- Alternative language support for spell check on text drawing object
- New command line option -start to start the presentation automatically after the document is loaded

Spreadsheet
- Import and export of areas in charts in Excel files that are formatted with bitmaps, textures or hatchings
- The sum button inserts a sum function or a subtotal function, depending on context
- Support for Excel 95 (and older) form controls

Database
- Table control via keyboard navigation in table designer
- Added ability to switch off brackets for bibliography fields
- New database type in data source administration dialog – MySQL
- Ability to add labels to field names in the report wizard
- A data source can now use any character set known to OpenOffice.org
Full List of Additions In OpenOffice.org 1.1

- UI support for user installed database drivers
- Database Report Wizard

Writing Aids
- Autodetection of newly installed languages for spellchecker, thesaurus and hyphenator
- Integrated support for spell checking English (US and UK) and Italian
- Integrated support for hyphenation of Danish, English (UK and US), German and Russian
- Initial support for spell checking Hindi
- Spell checking uses n-gram scoring for suggestions

Programming and Automation
- Macro Recorder
- Crash reporter for collecting crash dump and error information
- Integrated Python-UNO bridge allowing creation of UNO components in Python
- A new java to native UNO bridge with up to 10 times better performance
- Detection of a misconfigured Java installation
- OpenOffice.org ActiveX Control (Windows only)
- Additional property pages for OpenOffice.org file types in Windows Explorer

Other Enhancements
- The splash screen now has a progress bar
- Improved online help content
- Improved configurability of dialogs and toolbars
- Improved URL autocompletion in hyperlink dialog
- The context menu now contains Open Hyperlink if opened on a URL
- Locking of user installations against accesses from multiple machines with shared directories
- Command line tools and an API for importing configuration data into the back end
- Document windows are now always created in a cascade to avoid new window completely overlapping the old one
- Support for registering add-ons and accessing add-ons via an auto-generated menu
- New FTP file access component
- The registration dialog will now display instead of address book data source selection on first run
- Support for recovering slightly damaged OpenOffice.org files
- New ppd file for generic postscript printing with type42 font support
- Support for copy/paste of bitmap graphics on UNIX