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5.4.8 Optional Lab: Managing System Files with Built-in Utilities
in Windows 7

Introduction
Print and complete this lab.

In this lab, you will use Windows built-in utilities to gather information about the system and to
troubleshoot system resources. You will also learn how to export and import registry setting.

Recommended Equipment
The following equipment is required for this exercise:
» A computer running Windows 7

Step 1
Log on to the computer as an administrator.

To add Run to the Start menu right-click Start > Properties. Select Start Menu tab then
click Customize....

-
i Taskbar and Start Menu Properties

Taskbar | StartMenu | Toolbars

To customize how links, icons, and menus look and k

behave in the Start menu, dick Customize.

Power button action: [Shut down v]

Privacy
Store and display recently opened programs in the Start menu

Store and display recently opened items in the Start menu and the
taskbar

How do I change the way the Start menu looks?

Ok ] [ Cancel Apply

Scroll down until you see the Run command. Click in the box next to Run command.
Click OK.
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.~ Y
Customize Start Menu lﬁ,'
You can customize how links, icons, and menus look and behave on the
Start menu,
@) Display as a link =

Display as a menu
Don't display this item
Recent Items
@ Recorded TV
Display as a link
@) Display as a menu
Don't display this item
| Fun command
. Search other files and libraries
Don't search
@ Search with public folders
Search without public folders
| Search programs and Control Panel
| Sort All Programs menu by name
48 System administrative tools |
Display an the All Programs menu adl |

m

Start menu size

Number of recent programs to display: 10 (5
MNumber of recent items to display in Jump Lists: 10 (=
|
| Use Default Settings | | oK %J | Cancel |

Click Apply > OK to close the “Taskbar and Start Menu Properties” window.

Open the command prompt by clicking Start > Run > type cmd > click OK.

Microsoft Windows [Uersion 6.1.76081
Copyright (c)> 2809 Microsoft Corporation. All rights reserved.

C:~Users~John>_

What is the drive path shown?

Type help and press Enter.
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-

ASS0C
ATTRIB

EX C\Windows\system32\cmd.exe

Microsoft Windows [Version 6.1.76881
Copyright <c? 208%? Microsoft Corporation. All rights reserved.

C:~Users~John>help
For more information on a specific command,. type HELP command-—name

Dizplays or modifies file extension associations.

Displays or changes file attributes.

Sets or clears extended CTRL+C checking.

Sets properties in boot database to control boot loading.
Displays or modifies access control lists (ACLs)> of files.
Calls one batch program from another.

Displays the name of or changes the current directory.
Diszplays or sets the active code page number.

Diszplays the name of or changes the current directory.
Checks a disk and displays a status report.

Dizplays or modifies the checking of disk at hoot time.
Clears the screen.

Starts a new instance of the Windows command interpreter.
Sets the default console foreground and background colors.
Compares the contents of two files or sets of files.
Displays or alters the compression of files on NIFS partitions.
Converts FAT volumes to NIFS. VYou cannot convert the
current drive.

Copies one or more files to another location.

Displays or sets the date.

Deletes one or more files.

Displays a list of files and subdirectories in a directory.
Compares the contents of two floppy disks.

Copies the contents of one floppy disk to another.
Diszplays or configures Disk Partition properties.

Edits command lines. recalls Windows commands, and
creates macros.

Displays current device driver status and properties.
Displays messages, or turns command echoing on or off.
Ends localization of environment changes in a batch file.
Deletes one or more files.

Quits the CHMD.ERE program (command interpreterd.

Compares two files or sets of files,. and displays the
differences hetween them.

Searches for a text string in a file or files.

Searches for strings in files.

RBuns a specified command for each file in a set of files.
Formats a disk for wuse with Windows.

What is the command to change directory?

What is the command to display the contents in a directory?

Type cd .. and press Enter.

BN C\Windows\system32icmd exe

C:wUzerssJohn>cd ..

C:\lUsers>

iC:“Users>cd John

iC=sUserssJohn>

What is the drive path shown?

Change back to original drive path.
Example: Type cd John and press Enter.

What is the drive path shown?

Type dir /? and press Enter.
If asked, Press any key to continue.
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B C\Windows\system32\cmd

C:sUserssJohn>dir ~7
Displays a list of files and subdirectories in a directory.

DIR [drive:1[pathllfilenamel [AALL:lattributes1] [~B1 [-C]1 [-D]1 [-L1 L[/N]
[-OLL:lsortorder]] [-P1 [-Q1 [-R]1 [/8]1 [/TLL:1timefieldl] L[-W]1 L[-X1 [-4]

[drive: l[pathllfilename]
Specifies drive, directory. andrsor files to list.

A Displays files with specified attributes.
T attributes D Directories R Read-only files
H Hidden files A Files ready for archiving

% System files I Mot content indexed files
L Reparse Points — Prefix meaning not
Uszes bhare format ¢(no heading information or summary).
Display the thousand separator in file sizes. This iz the
default. Use ~—C to disable display of separator.
Same as wide but files are list sorted by column.
Uses lowercase.
Mew long list format where filenames are on the far right.
List by files in sorted order.
M By name {(alphabetic)> % By size (smallest first)
E By extension {(alphabetic> D By datestime (oldest first)
G Group directories first — Prefix to reverse order
Pauses after each screenful of information.
Display the ouwner of the file.
Display alternate data streams of the file.
Displays files in specified directory and all subdirectories.
Controls which time field displayed or used for sorting
timefield ¢ Creation

Last Access
W  Last Written

I Uses wide list format.

Ve This displays the short names generated for non—8dot3 file
hefore the long name. If no short name is present,. blanks are
displayed in its place.

/4 Displays four—digit vears

Bwitches may be preset in the DIRCHMD environment variahle. Override
preset switches by prefixing any switch with — <(hyphen>—for example. ~-U.

C:sUserssJohn>_

names. The format is that of /N with the short name inserted

m

Which switch displays a wide list format?

Type dir and press Enter.

Type dir /w and press Enter.

,

C:sUserssJohn>dir
Uolume in drive C has no lahbel.
Volume Serial Number is 347C-8C%6

Directory of C:xUsersJohn

11862018 H <DIR> -
11862018 H <DIR> -
11./86-20108 = <DIR> Contacts
11./86-2018 H <DIR> Desktop
11862818 : <DIR> Documents
11062818 H <DIR> Downloads
11-86-2818 H <DIR> Favorites
11./86-2018 H <DIR> Links
11862018 = <DIR> Music
110620108 H <DIR> Pictures
11-/86-/2018 H <DIR> Saved Games
11862018 H <DIR> Searches
11862018 :38 AM <DIR> Uideos

[€:3] A hytes
13 Diwded> 59,.830.734.848 hytes free

C:sUserssJohn>dir /u
Uolume in drive C has no lahel.
Volume Serial Number is 347C-8C%6

Directory of GC:ixlUsers>John

L= [z [Contacts] [Desktop]l [Documents ]
[Downloads 1 [Favorites] [Links 1 [Music] [Pictures]
[Saved Games] [Searches] [Videos]1

ile(s> bytes

A by
13 Diwded> 59,.830.734.848 hytes free

C:~Users~John>_

What is the difference between these two commands?
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Step 2

Type VOL.
What is the volume name for drive C?

Close the Command prompt window.

Open System Information by clicking Start > Run > type msinfo32 > click OK.

Click the plus sign next to Hardware Resources, Components, and Software
Environment. Expand the window so you can see all the content.

File Edit View Help

System Summary
- Hardware Resources
- Conflicts/Sharing
DMA
Forced Hardware
170
RQs
- Memory
- Components
Multimedia
CD-ROM
Sound Device
- Display
- Infrared
Input
Modem
Network
Ports
Storage
- Printing
Problem Devices
UsB
= Software Environment
- System Drivers
-~ Environment Variables
- Print Jobs
Network Connections
Running Tasks
Loaded Modules
- Services

- Program Groups
Startup Programs
OLE Registration
‘Windows Error Reporting

Item

0S Name

Version

Other OS Description

05 Manufacturer

System Name

System Manufacturer
System Model

System Type

Processor

BIOS Version/Date
SMEBIOS Version

Windows Directary
System Directory

Boot Device

Locale

Hardware Abstraction Layer
User Name

Time Zone

Installed Physical Memary (RAM)
Total Physical Memory
Available Physical Memory
Total Virtual Memory
Available Virtual Memory
Page File Space

Page File

Value

Microsoft Windows 7 Professional
6.1.7600 Build 7600

Not Available

Microsoft Corporation

VICKI-PC

To Be Filled By Q.EM.

To Be Filled By O.EM.

X86-based PC

Intel(R) Pentium(R) 4 CPU 3.00GHz, 2998 Mhz, 1 Core(s), 2 Logical Processor(s)
American Megatrends Inc. 080009, 9/1/2004
23

C\Windows
Cawindows\system32
\Device\Harddiskvolumel

United States

Version = "6.1.7600.16385"
Vicki-PC\John

Pacific Daylight Time

3.00 GB

3.00 GB

2.04 GB

599 GB

497 GB

3.00 GB

C:\pagefile sys

Find what: |

[T15earch selected category only

[T15earch category names only

Find Close Find

Under the System Summary heading locate and list the following:

Processor
BIOS Version/Date

Total Physical Memory

Under the Hardware Resources heading locate and list the following:

DMA channels and the device using the resources.

I/O address range for these devices.

Printer Port (LPT1)
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Communications Port (COM1)
Communications Port (COM2)

IRQ address for these devices.
System timer

Communications Port (COM1)
Communications Port (COM2)

Under the Components heading and Software heading look around to see what
information is provided in these areas.

Close the System Information window.

Step 3
Open System Configuration by clicking Start > Run > type msconfig > click OK.
Note: It is very important that you do not make any changes in this utility without
instructor permission.

——

-
Ll System Configuratio

General |Boot | Services | startup | Tools |

Startup selection

{7) Diagnostic startup

Load basic devices and services only
() Selective startup
Load system services
Load startup items

Use original boot configuration
|

l ) e [ oo

Click the General tab if it is not already active.
What are the startup options?

Click the Boot tab. This tab is for modifying boot options.

Click the Services tab. This tab lists the computers services and there status.
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| General | Boot | Services | startup | Teols |

Service Manufacturer Status Date Disabled

Application Experience Microsoft Carporation Stopped
Application Layer Gateway Service  Microsoft Corporation Stopped
Application Identity Microsoft Corpaoration Stopped
Application Management Microsoft Carporation Stopped
Windows Audio Endpoint Builder Microsoft Corporation Runining
Windows Audio Microsoft Corporation Running
ActiveX Installer (AxInstsV) Microsoft Corporation Stopped
Bitl ocker Drive Encryption Service  Microsoft Corporation Stopped
Base Filtering Engine Microsoft Carparation Running
Background Inteligent Transfer ... Microsoft Corporation Runining
Computer Browser Microsoft Corpaoration Stopped
[¥] Bluetooth Support Service Microsoft Corporation Stopped

Mote that some secure Microsoft services may not be disabled. Enable al Disable l

[ Hide all Microsoft services

-

o) omm ) [ o ) ()

Can you enable and disable services at this tab?

Click the Startup tab. This tab lists the programs that are automatically loaded every time
you turn on your computer.

Click the Tools tab.

| General | Boot | services | startup | Tools |

Tool Mame Description

About Windows Display Windows version information.

Change UAC Settings Change User Account Control settings.

Action Center Open the Action Center,

Windows Troubleshooting Troubleshoot problems with your computer.

Computer Management View and configure system settings and components.

System Information View advanced information about hardware and software settings.
Event Viewer View monitoring and troubleshooting messages.

Programs Launch, add or remove programs and Windows components.

Swatemn Pronerties Wiew hasic infarmatinon aboot vour comnuter svstem settinns.
4 | i

Selected command:
Ci\Windows\System32resman. exe

) G [ 5 ] (o)

What can you do in this tab?

Click Cancel to close the “System Configuration” window.

Step 4
Open the DirectX Diagnostic Tool by clicking Start > Run > type dxdiag > click OK.
If you are asked to have DirectX check driver signatures click No.
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Note: When the DirectX Diagnostic Tool first opens, it may take a minute to load all
information. Your DirectX Diagnostic Tool may not appear exactly as shown in this lab.

€ DirectX Diagnostic Tool

System | Display 1 | Display 2 | Sound 1 [ Sound 2 | Sound 3 [ Input |

visit each page in sequence.

System Information

Current Date/Time:
Computer Name:
Operating System:
Language:

System Manufacturer:
System Model:
BIOS:

Processor:
Memory:

Page file:

Directx Version:

[] check for WHGL digital signatures

This toal reports detailed information about the Direct¥ components and drivers installed on your system.

If you know what area is causing the problem, dick the appropriate tab above. Otherwise, you can use the Next Page” button below to

Saturday, November 06, 2010, 2:05:37 AM
VICKI-PC

Windows 7 Professional 32-bit (8. 1, Build 7600)
English (Regional Setting: English)

To Be Filled By O.E.M.

To Be Filled By O.E.M.

BIOS Date: 09,/01/04 23:23:09 Ver: 08.00.09
Intel(R) Pentium(R) 4 CPU 3.00GHz (2 CPUS), ~3.0GHz
3072MB RAM

1133MB used, 5005MB available

Directx 11

DxDiag 6.01.7600. 16385 32-bit Unicode Copyright © 1998-2006 Microsoft Corporation. All rights reserved.

Help

L Next Page J [ Save All Information ] [ Exit

Make sure the System tab is active.

What does this tool report?

Click Next Page until you are at the Display tab.

System | Display 1 | Display 2 | Sound 1 | Sound 2 [ Sound 3 [ input |

Device
MName:

Manufacturer:

Chip Type:

DAC Type:

Approx. Total Memory:
Current Display Mode:
Mornitor:

AT Technologies Inc.

nja

Internal DAC(400MHz)

754 MB

1600 % 1200 (32 bit) (50Hz)
Generic PnP Monitor

DirectX Features

DirectDraw Acceleration: Enabled
Direct3D Acceleration: Enabled

AGP Texture Acceleration: Enabled

Notes

ATI Radeon HD 2600 XT AGP (Microsoft

Drivers

Main Driver: atidxx32.dl,atidxx64,atiumdag. di,at
8.56.1.15
7/13/2009 6:14:55PM

nfa

Versian:

Date:

WHOL Logo'd:
DDI Version: 10

Driver Model: WDDM 1.1

Mo problems found.

Help

[_ Mext Page J [ Save All Information... ] [

What information is listed on this page?

Click Next Page until you are at the Sound tab.
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Step 5

System | Display 1 [ Display 2| Sound 1 | Sound 2 | Sound 3 [ input |

Device
Name: Speskers (S8 Audigy)

Manufacturer ID: 1
Product ID: 100
Type: WOM
Default Device: Yes

H Notes

Drivers
Name: P17.5ys

Hardware ID: PCI\VEN_11028DEV_00078SUBSYS_100A11028RE Version: 5.12.0001.2020 Englsh)

Date: 10/16/2009 2:11:56 AM
WHGL Logo'd: nja
Other Fies:
Provider: CREATIVE

+ No problems fourd.

Help

[ MNextPage ][ SaveAlifomation... | |

What information is listed on this page?

Click Next Page until you are on the Input tab.
What information is listed on this page?

Click Exit.

Open the “Choose your desktop background” page in Personalize appearance and
sounds by right-clicking the desktop > Personalize > Desktop Background.

What is the Background picture?

Click the Picture location drop-down button and select Solid Colors. Select a blue
color.
Click Save changes.

K2\ &l @ < Personalization  Desktop Background = |43 l| Search Controt Panel

Choose your desktop background

Click a picture to make it your desktop background, or select more than one picture to create a slide show.

Picture location: [Selid Colors

7] Do

m

W
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The computer screen should now have a blue background. If not ask the instructor for
assistance.

Step 6
Open the Registry Editor by clicking Start > Run > type regedit > click OK.
If the “User Account Control” window appears click Yes.
Note: Do make any changes in the Registry Editor without instructor permission.

File Edit View Favorites Help

4 {8 Computer Name Type Data
- 4 HKEY_CLASSES_ROOT
=+ Ly HKEY_CURRENT_USER
- L HKEY_LOCAL_MACHINE
-+ 4y HKEY_USERS
=+ L HKEY_CURRENT_CONFIG
Computer

Click the HKEY_CURRENT_USER icon. To search for the desktop Background key click
Edit > Find > type Background > click Find Next.

File Edit View Favorites Help

4 M Computer Mame Type Data
- HKEY_CLASSES ROOT 2] (Default) REG ST (value not set)
- |y HKEY_CURRENT_USER
- Jy HKEY_LOCAL MACHINE
.11 HKEY USERS [ ) |
- Ly HKEY_CURRENT_CONFIG
Findwhat:  Background Find Mext k
ok
Keys
[¥] Values
Data
[ Match whole string only

Computer\HKEY_CURRENT_USER

The Background value is located. Leave this window open.

Console * || Name Type Data =
44 Contiol Panc| 28] Defaul) REG_SZ (value not set)
>l Accessibilty | A i cBorder REG_SZ 180 180 180
> -}, Appearance I B B £
e 28] ActiveTitle REG_SZ 153 180 209
T 1 ab| AppWorkspace  REG_SZ 1Minin
s Desktop b (I Baciarounc [RELECEYS 1059118
> {3} Infrared 3b] ButtonAlternate... REG_SZ 000
> 1| Input Method abButtonDkShadow REG_SZ 105105 105
s | International || 2b]ButtonFace REG_SZ 240 240 240
Keyboard at)ButtonHilight ~ REG_SZ 255 255 255
Mouse ab) ButtonLight REG_SZ 227227 227
I+ Personalization SﬂButtonShadow REG_SZ 160 160 160
b)) PowerCfg ab] ButtonText REG_SZ 000
Sound || 0] GradientActiveT... REG_SZ 185209 234 =
4 = rrr. ,i 3 «'i n ] *
Computer\HKEY_CURRENT_USER\Control Panel\Calors
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In which folder is the Background located?

What is the data value of the Background (hint — it has three numbers that correspond to
red, green, and blue)? Answers may vary based on the shade of blue selected in Choose
your desktop background.

Step 7
We will now export the HKEY_CURRENT_USER\Control Panel\Colors folder.
In the left pane, click the Colors folder.

Click File > Export. Save the file to the Desktop with the name BlueBKG.
At the desktop, right-click the BlueBKG.reg icon > Edit.

File Edit Format View Help
windows Registry Editor version 5.00

[HKEY CURRENT_ USER\CGntr01 panel Colors]
"Background”="10 59 118"
"Scrollbar"="200 200 200"
"Act‘iveT‘it1e"="153 180 209"
"Inactiveritle"="191 205 219"
”Menu”=”240 240 240"
"window"="255 255 255"
W1nd0wFrame "100 100 100"
"MenuText''="0 7
"WindowText"="0 0 0"
"TitleText"="0 0 0"
"sctiveBorder"="180 180 180"
Inact1ve50rder“—“244 247 252"
qworkspace 171 171 171
ight"="51 153 255"
”H111ghtText ="255 255 255"
"ButtonFace'="240 240 240"
"Buttonshadow"="160 160 160"
”GrayText”:”lOQ 109 109"
"ButtonText"="0 0 0"
Inact1veT1t1eText“—”67 78 84
"ButtonHilight"="255 255 255"
"ButtonDkshadow"="105 105 105"
"ButtonLight"="227 227 227"
”InfoText =”0 o 0"
"Infowindow"'="255 255 225
ButtonA1ternateFace "0 0
"HotTrackingcolor"="0 102 204
"GradientActiveTitle' = 185 209 234"
"GradientInactiveTitle"="215 228 242"
"MenuHilight"="51 153 255"
"MenuBar="240 240 240"

4

What is the data value of the Background? Answers may vary based on the shade of
blue selected in Display Properties.

Close the BlueBKG.reg — Notepad window.

Step 8
Open the “Choose your desktop background” page in Personalize appearance and
sounds by right-clicking the desktop > Personalize > Desktop Background.
Click the Location drop-down button and select Solid Colors. Select a red color.
Click Save changes.

In a few seconds, the desktop will turn to red.

Click the Registry Editor window so it is activated.

© 2007-2011, Cisco Systems, Inc. All rights reserved. Page 11



IT Essentials: PC Hardware and Software v4.1 Chapter 5 - Lab/Student

On your keyboard press F5 to refresh the Registry Editor window.

% Registry Editor (L= ]|

File Edit View Favorites Help

h Console || Name Type Data =
4-ia Control Panel 3] (Default) REG_SZ (value not set)

bodi Accessibility | ) s i eparder REG_SZ 180 180 180

o ‘zsl‘f:me 8] ActiveTitle REG_SZ 153180 209 3

" Clikon | eﬂAppWork;pace REG_SZ 171171171

o] Desktop 3 fﬂBackgruund REG_SZ 184 40 50

. Infrared ab|ButtonAlternate... REG_SZ 000

o1, Input Method b ButtonDkShadow  REG_SZ 105105105

b | International I ;‘_!']ButtonFa(E REG_SZ 240 240 240

il Keyboard aB] ButtonHilight REG SZ 255 255255

Mouse 2| ButtonLight REG_SZ 237227277

- . Personalization ab| ButtonShadow REG_SZ 160 160 160

5 Ju PowerCfg ab|ButtonText REG_SZ 000

.|, Sound _ || 2% GradientActiveT ... REG_SZ 185 209 234 o

< " : d » f-\\ 1 ] »

Computer\HKEY_CURRENT_USER\Control Panel\Colors

What is the data value of the Background? Answers may vary based on the shade of red

selected in Display Properties.

Step 9
We will now import BlueBKG.reg file.
Click the Registry Editor window so it is activated.

Click File > Import. Locate and click the BlueBKG.reg icon then click Open.
Click OK.

% Registry Editor =

File Edit View Favorites Help

i L) Console * || Name Type Data =
-0 Control Panel a5) (Default) REG_SZ (value not sef)

bodi Accessibility | () p tiveBarder REG_SZ 180 180 180

? ?preara”ce ab] ActiveTitle REG_SZ 153180 209 £

‘ e || Pl Appworkspace  REG_S2Z 171171171

; .|| Desktop = 3_!'] Background REG_SZ 1059118

* 1B Infrared 2B ButtonAlternate... REG_SZ 000

{8 Input Method ab|ButtonDkShadow  REG_SZ 105105105

4. | International | ;‘_!']ButtonFa(E REG_SZ 240 240 240

i} Keyboard ab|ButtonHilight ~ REG_SZ 255 255 255

[} Mouse ab|ButtonLight REG_SZ 227227227

b Personalization 3b|ButtonShadow  REG_SZ 160 160160

b )y PowerCfg 3B ButtonText REG_SZ 000

il Sound _ || 28] GradientActiveT... REG_SZ 185200 234 =

< i - y * f-\\ 1 ] »

Computer\HKEY_CURRENT_USER\Control Panel\Colors

Click the Registry Editor window so it is activated.

What is the data value of the Background? Answers may vary based on the shade of

blue selected in Display Properties.

What is the color of the desktop?

Restart the computer.
What is the color of the desktop?

Reset Display Properties Background to the original settings (hint — see Step 5).
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