Charts and Graphs: Microsoft Excel 2010

Finding Complementary Colors ................................................................. 32
Specifying a Theme’s Colors ................................................................. 33
Specify Theme Fonts ............................................................................ 35
Saving a Custom Theme ..................................................................... 35
Using a Custom Theme on a New Document ...................................... 36
Sharing a Theme with Others ............................................................... 36
Next Steps ......................................................................................... 36

2 Customizing Charts .............................................................................37
Accessing Element Formatting Tools ...................................................... 37
Identifying Chart Elements .................................................................. 38
Chart Labels and Axis .......................................................................... 38
Special Elements in a 3-D Chart ......................................................... 39
Analysis Elements ............................................................................. 40
Formatting Chart Elements .................................................................. 41
Formatting a Chart Title ...................................................................... 41
Formatting an Axis Title ...................................................................... 45
Formatting a Legend ............................................................................ 45
Adding Data Labels to a Chart ............................................................. 48
Adding a Data Table to a Chart ............................................................ 51
Formatting Axes ................................................................................ 52
Formatting the Plot Area ..................................................................... 63
Formatting the Chart Walls and Floor of a 3-D Chart ....................... 67
Controlling 3-D Rotation in a 3-D Chart ........................................... 67
Forecasting with Trendlines ................................................................. 70
Adding Drop Lines to a Line or Area Chart ......................................... 72
Adding Up/Down Bars to a Line Chart ............................................... 73
Showing Acceptable Tolerances by Using Error Bars ...................... 74
Formatting a Series ........................................................................... 75
Formatting a Single Data Point ............................................................ 76
Using the Format Tab ......................................................................... 76
Converting Text to WordArt ................................................................. 77
Using the Shape Styles Gallery ........................................................... 77
Using the Shape Fill and Shape Effects ............................................. 77
Using Preset Shape Effects ................................................................ 78
Replacing Data Markers with Clip Art or Shapes .............................. 80
Using Clip Art as a Data Marker ......................................................... 80
Using a Shape in Place of a Data Marker .......................................... 80

3 Creating Charts That Show Trends ..................................................83
Choosing a Chart Type ....................................................................... 83
Column Charts for Up to 12 Time Periods ........................................ 83
Line Charts for Time Series Beyond 12 Periods ................................. 83
Area Charts to Highlight One Portion of the Line ............................ 85
<table>
<thead>
<tr>
<th>Contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>High-Low-Close Charts for Stock Market Data</td>
<td>85</td>
</tr>
<tr>
<td>Bar Charts for Series with Long Category Labels</td>
<td>85</td>
</tr>
<tr>
<td>Pie Charts Make Horrible Time Comparisons</td>
<td>86</td>
</tr>
<tr>
<td>100 Percent Stacked Bar Chart Instead of Pie Charts</td>
<td>86</td>
</tr>
<tr>
<td>Understanding Date-Based Axis Versus Category-Based Axis in Trend Charts</td>
<td>86</td>
</tr>
<tr>
<td>Converting Text Dates to Dates</td>
<td>89</td>
</tr>
<tr>
<td>Plotting Data by Numeric Year</td>
<td>95</td>
</tr>
<tr>
<td>Using Dates Before 1900</td>
<td>95</td>
</tr>
<tr>
<td>Using a Workaround to Display a Time-Scale Axis</td>
<td>100</td>
</tr>
<tr>
<td>Communicate Effectively with Charts</td>
<td>103</td>
</tr>
<tr>
<td>Using a Long, Meaningful Title to Explain Your Point</td>
<td>104</td>
</tr>
<tr>
<td>Highlighting One Column</td>
<td>107</td>
</tr>
<tr>
<td>Replacing Columns with Arrows</td>
<td>109</td>
</tr>
<tr>
<td>Highlighting a Section of Chart by Adding a Second Series</td>
<td>109</td>
</tr>
<tr>
<td>Changing Line Type Midstream</td>
<td>111</td>
</tr>
<tr>
<td>Adding an Automatic Trendline to a Chart</td>
<td>113</td>
</tr>
<tr>
<td>Showing a Trend of Monthly Sales and Year-to-Date Sales</td>
<td>114</td>
</tr>
<tr>
<td>Understanding the Shortcomings of Stacked Column Charts</td>
<td>116</td>
</tr>
<tr>
<td>Using a Stacked Column Chart to Compare Current Sales to Prior-Year Sales</td>
<td>116</td>
</tr>
<tr>
<td>Shortcomings of Showing Many Trends on a Single Chart</td>
<td>118</td>
</tr>
<tr>
<td>Next Steps</td>
<td>118</td>
</tr>
<tr>
<td>4 Creating Charts That Show Differences</td>
<td>119</td>
</tr>
<tr>
<td>Comparing Entities</td>
<td>119</td>
</tr>
<tr>
<td>Using Bar Charts to Illustrate Item Comparisons</td>
<td>119</td>
</tr>
<tr>
<td>Adding a Second Series to Show a Time Comparison</td>
<td>121</td>
</tr>
<tr>
<td>Subdividing a Bar to Emphasize One Component</td>
<td>122</td>
</tr>
<tr>
<td>Showing Component Comparisons</td>
<td>123</td>
</tr>
<tr>
<td>Using Pie Charts</td>
<td>126</td>
</tr>
<tr>
<td>Switching to a 100 Percent Stacked Column Chart</td>
<td>132</td>
</tr>
<tr>
<td>Using a Doughnut Chart to Compare Two Pies</td>
<td>133</td>
</tr>
<tr>
<td>Dealing with Data Representation Problems in a Pie Chart</td>
<td>135</td>
</tr>
<tr>
<td>Using a Waterfall Chart to Tell the Story of Component Decomposition</td>
<td>142</td>
</tr>
<tr>
<td>Creating a Stacked and Clustered Chart</td>
<td>144</td>
</tr>
<tr>
<td>Next Steps</td>
<td>150</td>
</tr>
<tr>
<td>5 Creating Charts That Show Relationships</td>
<td>151</td>
</tr>
<tr>
<td>Comparing Two Variables on a Chart</td>
<td>151</td>
</tr>
<tr>
<td>Using XY Scatter Charts to Plot Pairs of Data Points</td>
<td>152</td>
</tr>
<tr>
<td>Adding a Trendline to a Scatter Chart</td>
<td>153</td>
</tr>
<tr>
<td>Adding Labels to a Scatter Chart</td>
<td>155</td>
</tr>
<tr>
<td>Joining the Points in a Scatter Chart with Lines</td>
<td>156</td>
</tr>
<tr>
<td>Adding a Second Series to an XY Chart</td>
<td>157</td>
</tr>
<tr>
<td>Drawing with a Scatter Chart</td>
<td>160</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Creating Dynamic Charts</td>
<td>243</td>
</tr>
<tr>
<td>Using the OFFSET Function to Specify a Range</td>
<td>244</td>
</tr>
<tr>
<td>Using VLOOKUP or MATCH to Find a Value in a Table</td>
<td>245</td>
</tr>
<tr>
<td>Combining INDEX and MATCH</td>
<td>247</td>
</tr>
<tr>
<td>Using Validation Drop-Downs to Create a Dynamic Chart</td>
<td>248</td>
</tr>
<tr>
<td>Using Dynamic Ranges in a Chart</td>
<td>251</td>
</tr>
<tr>
<td>Creating a Scrolling Chart</td>
<td>254</td>
</tr>
<tr>
<td>Modifying the Scrollbar Example to Show the Last 12 Months</td>
<td>257</td>
</tr>
<tr>
<td>Creating Advanced Charts</td>
<td>257</td>
</tr>
<tr>
<td>Thermometer Chart</td>
<td>258</td>
</tr>
<tr>
<td>Benchmark Chart</td>
<td>259</td>
</tr>
<tr>
<td>Delta Chart</td>
<td>260</td>
</tr>
<tr>
<td>Amazing Things People Do with Excel Charts</td>
<td>262</td>
</tr>
<tr>
<td>Next Steps</td>
<td>264</td>
</tr>
<tr>
<td>Creating and Using Pivot Charts</td>
<td>265</td>
</tr>
<tr>
<td>Creating Your First Pivot Chart</td>
<td>265</td>
</tr>
<tr>
<td>New in Excel 2010 Pivot Tables</td>
<td>265</td>
</tr>
<tr>
<td>Deciding Which Comes First: The Table or the Chart</td>
<td>266</td>
</tr>
<tr>
<td>Rules for Preparing Underlying Pivot Data</td>
<td>266</td>
</tr>
<tr>
<td>Creating Your First Pivot Chart</td>
<td>267</td>
</tr>
<tr>
<td>Changing the Chart Type and Formatting the Chart</td>
<td>269</td>
</tr>
<tr>
<td>Adding Additional Series to a Pivot Chart</td>
<td>270</td>
</tr>
<tr>
<td>Returning to a Pivot Table for Advanced Operations</td>
<td>271</td>
</tr>
<tr>
<td>Filtering a Pivot Table</td>
<td>273</td>
</tr>
<tr>
<td>Filtering Using Slicers</td>
<td>273</td>
</tr>
<tr>
<td>Using the Excel 2010 Filters for Axis and Legend Fields</td>
<td>274</td>
</tr>
<tr>
<td>Creating a Chart for Every Customer</td>
<td>275</td>
</tr>
<tr>
<td>Next Steps</td>
<td>278</td>
</tr>
<tr>
<td>Using Sparklines, Data Visualizations, and Other Nonchart Methods</td>
<td>279</td>
</tr>
<tr>
<td>Fitting a Chart Into the Size of a Cell with Sparklines</td>
<td>280</td>
</tr>
<tr>
<td>Creating a Group of SparkLines</td>
<td>281</td>
</tr>
<tr>
<td>Built-In Choices for Customizing Sparklines</td>
<td>282</td>
</tr>
<tr>
<td>Controlling Axis Values for Sparklines</td>
<td>283</td>
</tr>
<tr>
<td>Setting Up Win/Loss Sparklines</td>
<td>286</td>
</tr>
<tr>
<td>Showing Detail by Enlarging the Sparkline</td>
<td>286</td>
</tr>
<tr>
<td>Labeling a Sparkline</td>
<td>286</td>
</tr>
<tr>
<td>Using Data Bars to Create In-Cell Bar Charts</td>
<td>288</td>
</tr>
<tr>
<td>Creating Data Bars</td>
<td>290</td>
</tr>
<tr>
<td>Customizing Data Bars</td>
<td>290</td>
</tr>
<tr>
<td>Showing Data Bars for a Subset of Cells</td>
<td>292</td>
</tr>
</tbody>
</table>
12 Exporting Charts for Use Outside of Excel ..................................................... 343
  Presenting Excel Charts in PowerPoint or Word .................................................. 343
  Copying a Document from Excel and Pasting to PowerPoint Sets Up an As-Needed Link.... 345
  Copying and Pasting While Keeping Original Formatting ....................................... 349
  Pasting as Link to Capture Future Excel Formatting Changes ................................. 350
  Copying a Chart as a Live Chart Linked to a Copy of the Original Workbook ............ 351
  Copying a Chart as a Picture ..................................................................................... 352
  Creating a Chart in PowerPoint and Copying Data from Excel ................................. 353
  Presenting Charts on the Web .................................................................................. 355
  Exporting Charts to Graphics .................................................................................. 356
  Using VBA to Export Charts as Images ..................................................................... 356
  Using Snag-It or Office 2010 Screen Clipping to Capture Charts ............................... 356
  Converting to XPS or PDF ....................................................................................... 357
  Next Steps ................................................................................................................. 357

13 Using Excel VBA to Create Charts ............................................................... 359
  Introducing VBA ....................................................................................................... 359
  Enabling VBA in Your Copy of Excel ......................................................................... 360
  Enabling the Developer Tab ...................................................................................... 360
  The Visual Basic Editor ............................................................................................. 361
  Visual Basic Tools ..................................................................................................... 361
  The Macro Recorder .................................................................................................. 362
  Understanding Object-Oriented Code ....................................................................... 362
  Learning Tricks of the VBA Trade ............................................................................. 363
  Writing Code to Handle a Data Range of Any Size ................................................... 363
  Using Super-Variables: Object Variables ................................................................... 364
  Using With and End With When Referring to an Object ............................................ 366
  Continuing a Line ...................................................................................................... 366
  Adding Comments to Code ....................................................................................... 367
  Coding for New Charting Features in Excel 2010 .................................................... 367
  Referencing Charts and Chart Objects in VBA Code ............................................... 367
  Creating a Chart ........................................................................................................ 368
  Specifying the Size and Location of a Chart ............................................................ 368
  Later Referring to a Specific Chart ........................................................................... 370
  Coding Commands from the Design Tab .................................................................. 372
  Specifying a Built-In Chart Type .............................................................................. 372
  Specifying a Template Chart Type ........................................................................... 374
  Changing a Chart’s Layout or Style .......................................................................... 375
  Using SetElement to Emulate Changes on the Layout Tab ........................................ 377
  Changing a Chart Title Using VBA ........................................................................... 382
  Emulating Changes on the Format Tab ...................................................................... 382
  Using the Format Method to Access New Formatting Options ................................. 382
Introduction: Using Excel 2010 to Create Charts

Good charts should both explain and arouse curiosity. A chart can summarize thousands of data points into a single picture. The arrangement of a chart should explain the underlying data but also enable the reader to isolate trouble spots worthy of further analysis.

Excel makes it easy to create charts. Even though the improvements in Excel 2010 enable you to create a chart with only a few mouse clicks, it still takes thought to find the best way to present your data.

Choosing the Right Chart Type

Suppose you are an analyst for a chain of restaurants, and you are studying the lunch-hour sales for a restaurant in a location at a distant mall. Corporations that provide a steady lunchtime clientele during the week surround the mall. The mall does well on weekends during the holiday shopping months but lacks weekend crowds during the rest of the year.

From the data contained in the chart in Figure I.1, you can spot a periodicity in sales throughout the year. An estimated 50 spikes indicate that the periodicity might be based on the day of the week. You can also spot that there is a general improvement in sales at the end of the year, which you attribute to the holiday shopping season. However, there is an anomaly in the pattern during the summer months that needs further study.

After studying the data in Figure I.1, you might decide to plot the sales by weekday to understand the sales better. Figure I.2 shows the same data presented as seven line charts. Each line represents the sales for a particular day of the week. Friday is the dashed line. At the beginning of the year, Friday was
the best sales day for this particular restaurant. For some reason, around week 23, Friday sales plummeted.

The chart in Figure I.2 prompts you to make some calls to see what was happening on Fridays at this location. You might discover that the city was throwing free Friday lunch-time concerts from June through August. The restaurant manager was offered a concession at the concert location but thought it would be too much trouble. Using this pair of charts enabled you to isolate a problem and equipped you to make better decisions in the future.

**Using Excel as Your Charting Canvas**

Excel 2007 offered a complete rewrite of the 15-year-old charting engine from legacy versions of Excel. Excel 2007 introduced plenty of new bugs to the charting engine. Excel 2010 fixes many of those bugs, and brings back features like pattern fills that were missing from Excel 2007. Although the software offers no new charting types, Excel 2010 provides plenty of tools that allow you to make eye-catching charts. In Excel 2010, you can create better versions of the 11 existing chart types.
Creating charts in Excel 2010 basically requires these steps:

1. Set up and select your data in an Excel worksheet.
2. Choose the appropriate chart type from the Insert tab.
3. Change the chart layout or color scheme by using the Design tab.
4. Customize chart elements by using the Layout tab.
5. Micromanage formatting for individual data points by using the Format tab.

Most charts require steps 1 and 2. The remaining steps are optional and are used with decreasing frequency. It should be rare that you will need to venture to step 5. However, you are likely to customize at least a couple items in step 4.

**Topics Covered in This Book**

This book covers the Excel 2010 charting engine and three new types of word-sized charts called *Sparklines*. It also covers the Data Visualization and SmartArt Business diagramming tools that were introduced in Excel 2007.

Besides charts, Excel 2010 offers many other ways to display quantitative data visually. This book explains how to use the new conditional formatting features such as data bars, color scales, and icon sets to add visual elements to regular tables of numbers. In Figure I.3, conditional formatting features make it easy to see that Ontario has the largest population and that Nunavut has the largest land area. You can also add in-cell data bars such as these with a couple of mouse clicks, as described in Chapter 9, “Using Sparklines, Data Visualizations, and Other Nonchart Methods.”

![Figure I.3](image)

**Figure I.3**

In-cell data bars draw the eye to the largest values in each column.

<table>
<thead>
<tr>
<th>Province</th>
<th>Population</th>
<th>Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alberta</td>
<td>2574805</td>
<td>619587</td>
</tr>
<tr>
<td>British Columbia</td>
<td>3507740</td>
<td>925403</td>
</tr>
<tr>
<td>Manitoba</td>
<td>1119580</td>
<td>651938</td>
</tr>
<tr>
<td>New Brunswick</td>
<td>729495</td>
<td>71356</td>
</tr>
<tr>
<td>Newfoundland and Labrador</td>
<td>512930</td>
<td>670502</td>
</tr>
<tr>
<td>Northwest Territories</td>
<td>37360</td>
<td>1414100</td>
</tr>
<tr>
<td>Nova Scotia</td>
<td>908000</td>
<td>52917</td>
</tr>
<tr>
<td>Nunavut</td>
<td>26745</td>
<td>3721600</td>
</tr>
<tr>
<td>Ontario</td>
<td>1164004</td>
<td>987659</td>
</tr>
<tr>
<td>Prince Edward Island</td>
<td>135295</td>
<td>5689</td>
</tr>
<tr>
<td>Quebec</td>
<td>723480</td>
<td>1657743</td>
</tr>
<tr>
<td>Saskatchewan</td>
<td>978930</td>
<td>568561</td>
</tr>
<tr>
<td>Yukon Territory</td>
<td>28670</td>
<td>474707</td>
</tr>
</tbody>
</table>

The three new types of word-sized charts in Excel 2010 called Sparklines enable you to create tiny line charts, tiny column charts, and win/loss charts. As shown in Figure I.4, these tiny charts can show win/loss events that paint a better picture than a simple 7-3 record.
Introduction: Using Excel 2010 to Create Charts

This book also takes a look at tools that you can purchase to add functionality to Excel 2010. Many vendors offer tools to create speedometer charts, supply curves, and specialized stock analysis tools. Perhaps one of the best tools is a Microsoft product called MapPoint. Using MapPoint, you can plot your Excel data in a geographic orientation on a map. See Chapter 10, “Presenting Your Excel Data on a Map Using Microsoft MapPoint,” for more information about the cool tricks available with MapPoint.

This Book’s Objectives

The goal of this book is to make you more efficient and effective in creating visual displays of information using Excel 2010.

In the early chapters of this book, you will learn how to use the new Excel 2010 charting interface. Chapters 3 through 6 walk you through all the built-in chart types and talk about when to use each chart type. Chapter 7 discusses creating unusual charts. Chapter 8 covers pivot charts, and Chapter 9 covers creating visual displays of information right in the worksheet. Chapter 10 covers mapping, and Chapter 11 covers the new SmartArt business graphics and Excel 2010’s shape tools. Chapter 12 covers exporting charts for use outside of Excel. Chapter 13 presents macro tools you can use to automate the production of charts using Excel VBA. In Chapter 14, you will see several techniques that people can use to stretch the truth with charts. Finally, Appendix A provides a list of resources that will give you additional help with creating charts and graphs.

Versions of Excel

Excel charting was largely unchanged for the dozen years leading up to Excel 2003. This book will refer to Excel 2003 and earlier collectively as “legacy” versions of Excel.

Microsoft rewrote the charting engine for Excel 2007. Excel 2010 continues with the addition of Sparklines, improvements to data bars and SmartArt, and general fixes of bugs introduced in Excel 2007. Although this book uses screen shots from Excel 2010, most of the concepts will apply equally well to Excel 2007.

Special Elements in This Book

This book contains the following special elements:
Chapter 1, “Introducing Charts in Excel 2010,” presents the new Excel 2010 interface for creating charts. You will learn how to create your first chart and read about the various elements available in a chart.
Creating Charts That Show Trends

Choosing a Chart Type

You have two excellent choices when creating charts that show the progress of some value over time. Because Western cultures are used to seeing time progress from left to right, you are likely to choose a chart where the axis moves from left to right—whether it is a column chart, line chart, or area chart.

The new Sparklines feature is another way to show trends with tiny charts. See Chapter 9, “Using Sparklines, Data Visualizations, and Other Nonchart Methods.”

Column Charts for Up to 12 Time Periods

If you have only a few data points, you can use a column chart because they work well for 4 quarters or 12 months. Within the column chart category, you can choose between 2-D and 3-D styles. To highlight one component of a sales trend, you can use a stacked column chart.

This book recommends not using pyramid charts or cone charts because they distort your message. For an example, see the “Lying with Shrinking Charts” section in Chapter 14, “Knowing When Someone Is Lying to You With a Chart.”

Line Charts for Time Series Beyond 12 Periods

When you get beyond 12 data points, you should switch to a line chart, which can easily show trends for hundreds of periods. Line charts can be designed to show only the data points as markers or data points can be connected with a straight or smoothed line.
Figure 3.1 shows a chart with only nine data points, which makes a column chart meaningful. Figure 3.2 shows a chart of 100+ data points. With this detail, you should switch to a line chart in order to show the trend.

**Figure 3.1**
With 12 or fewer data points, column charts are viable and informative.

**Figure 3.2**
When you go beyond 12 data points, it is best to switch to a line chart without individual data points. The middle chart in this figure shows the same dataset as a line chart.
Choosing a Chart Type

Area Charts to Highlight One Portion of the Line

An area chart is a line chart where the area under the line is filled with a shading or color. This can be appropriate if you want to highlight a particular portion of the time series. If you have fewer data points, adding drop lines can help the reader determine the actual value for each time period.

High-Low-Close Charts for Stock Market Data

If you are plotting stock market data, use stock charts to show the trend of stock data over time. You can also use high-low-close charts to show the trend of data that might occur in a range such as when you need to track a range of quality rankings for each day.

Bar Charts for Series with Long Category Labels

Even though bar charts can be used to show time trends, they can be confusing because readers expect time to be represented from left to right. In rare cases, you might use a bar chart to show a time trend. For example, if you have 40 or 50 points that have long category labels that you need to print legibly to show detail for each point, then consider using a bar chart. Another example is illustrated in Figure 3.3, which includes sales for 45 daily dates. This bar chart would not work as a PowerPoint slide. However, if it is printed as a full page on letter-size paper, the reader could analyze sales by weekday. In the chart in Figure 3.3, weekend days are plotted in a different color than weekdays to help delineate the weekly periods.

Figure 3.3
Although time series typically should run across the horizontal axis, this chart allows 45 points to be compared easily.
Pie Charts Make Horrible Time Comparisons

A pie chart is ideal for showing how components that add up to 100% are broken out. It is difficult to compare a series of pie charts to detect changes from one pie to the next. As you can see in the charts in Figure 3.4, it is difficult for the reader’s eye to compare the pie wedges from year to year. Did market share increase in 2008? Rather than using a series of pie charts to show changes over time, use a 100 percent stacked column chart instead.

100 Percent Stacked Bar Chart Instead of Pie Charts

In Figure 3.5, the same data from Figure 3.4 is plotted as a 100 percent stacked bar chart. Series lines guide the reader’s eye from the market share from each year to the next year. The stacked bar chart is a much easier chart to read than the series of pie charts.

Understanding Date-Based Axis Versus Category-Based Axis in Trend Charts

Excel offers two types of horizontal axes in a trend chart. Having the proper setting can ensure that your message is accurate.

If the spacing of events along the time axis is uniform, it does not matter whether you choose a date-based axis or a text-based axis because the results will be the same. When this occurs, it is fine to allow Excel to choose the type of axis automatically.
However, if the spacing of events along the time axis is haphazard, you definitely want to make sure that Excel uses a date-based axis.

**Accurately Representing Data Using a Time-Based Axis**

Figure 3.6 shows the spot price for a certain component used in your manufacturing plant. To find this data, you downloaded past purchase orders for that product. Your company doesn’t purchase the component on the same day every month; therefore, you have an incomplete dataset. In the middle of the dataset, a strike closed one of the vendors, spiking the prices from the other vendors. Your purchasing department had stocked up before the strike, which allowed your company to slow its purchasing dramatically during the strike.

**Figure 3.6**
The top chart uses a text-based horizontal axis: Every event is plotted an equal distance from the next event. This leads to the shaded period being underreported.

In the top chart in Figure 3.6, the horizontal axis is set to a text-based axis, and every data point is plotted an equal distance apart. Because your purchasing department made only two purchases during the strike, it appears the time affected by the strike is very narrow. The bottom chart uses a date-based axis. In this axis, you can see that the strike actually lasted for half of 2010.

To learn how to highlight a portion of a chart as shown in Figure 3.6, see “Highlighting a Section of Chart by Adding a Second Series,” later in this chapter.

Usually, if your data contains dates, Excel defaults to a date-based axis. However, you should always check to make sure Excel is using the correct type of axis. A number of
potential problems force Excel to choose a text-based axis instead of a date-based axis. For example, Excel will choose a text-based axis when dates are stored as text in a spreadsheet and when dates are represented by numeric years. The list following Figure 3.7 summarizes other potential problems.

To explicitly choose an axis type, follow these steps:

1. Right-click the horizontal axis and select Format Axis.
2. In the Format Axis dialog box that appears, select the Axis Options category.
3. As appropriate, choose either Text Axis or Date Axis from the Axis Type section (see Figure 3.7).

A number of complications that require special handling can occur with date fields. The following are some of the problems you might encounter:

- **Dates stored as text**—If dates are stored as text dates instead of real dates, a date-based axis will never work. You have to use date functions to convert the text dates to real dates.

- **Dates represented by numeric years**—Trend charts can have category values of 2008, 2009, 2010, and so on. Excel does not naturally recognize these as dates, but you can trick it into doing so. Read “Plotting Data by Numeric Year” near Figure 3.15 in this chapter.

- **Dates before 1900**—If your company is old enough to chart historical trends before January 1, 1900, you will have a problem. In Excel’s world, there are no dates before 1900. For a workaround, read “Using Dates Before 1900” around Figure 3.16.
• **Dates that are really time**—It is not difficult to imagine charts in which the horizontal axis contains periodic times throughout a day. For example, you might use a chart like this to show the number of people entering a bank. For such a chart, you need a time-based axis, but Excel will group all of the times from a single day into a single point. See “Using a Workaround to Display a Time-Scale Axis” near Figure 3.19 for the rather complex steps needed to plot data by periods smaller than a day.

Each of these problem situations is discussed in the following sections.

**Converting Text Dates to Dates**

If your cells contain text that looks like dates, the date-based axis will not work. The data in Figure 3.8 came from a legacy computer system. Each date was imported as text instead of as dates.

![Figure 3.8](image)

> These dates are really text, as indicated by the apostrophe before the date in the formula bar.

This is a frustrating problem because text dates look exactly like real dates. You may not notice that they are text dates until you see that changing the axis to a date-based axis has no effect on the axis spacing.

If you select a cell that looks like a date cell, look in the formula bar to see whether there is an apostrophe before the date. If so, you know you have text dates (refer to Figure 3.8). This is Excel’s arcane code to indicate that a date or number should be stored as text instead of a number.

**Understanding How Excel Stores Dates and Time**

On a Windows PC, Excel stores dates as the number of days since January 1, 1900. For a date such as 2/17/2011, Excel actually stores the value 40,591, but it formats the date to show you a value such as 02/17/2011.

On a Mac running Mac OS, Excel stores the dates as the number of days since January 1, 1904. The original designers of the Mac OS were trying to squeeze the OS into 64K of ROM. Because every byte mattered, it seemed unnecessary to add a couple lines of code to handle the fact that 1900 is not a leap year. Excel for the Mac adopted the 1904 convention. On a Mac, 2/17/2011 is stored as 39,129.
Excel for Windows, which needed to be compatible with Lotus 1-2-3, adopted the 1900 convention. As demonstrated in the next case study, the 1900 convention incorrectly made 1900 a leap year.

**CAUTION**

Selecting a new format from the Format Cells dialog does not fix this problem, but it may prevent you from fixing the problem! If you import data from a .txt file and choose to format that column as text, Excel changes the numeric format for the range to be text. After a range is formatted as text, you can never enter a formula, number, or date in the range. People try to select the range, change the format from text to numeric or date, and hope this will fix the problem—but it doesn’t. After you change the format, you still have to use a method described in the “Converting Text Dates to Real Dates” section, later in this chapter, to convert the text dates to numeric dates.

However, it is still worth changing the format from a text format to General, Date, or anything else. If you do not change the format, and then insert a new column to the right of the bad dates, the new column inherits the text setting from the date column. This causes your new formula (the formula to convert text to dates) to fail. Therefore, even though it doesn’t solve your current problem, you should select the range, click the Dialog Launcher icon in the lower-right corner of the Number group on the Home tab, and change the format from Text to General. Figure 3.9 shows the Dialog Launcher icon.

![Launcher Icon](image.png)

**Figure 3.9**

Many groups on the ribbon have this tiny More icon in the lower-right corner. Clicking this icon leads to the legacy dialog box.

Excel for Windows, which needed to be compatible with Lotus 1-2-3, adopted the 1900 convention. As demonstrated in the next case study, the 1900 convention incorrectly made 1900 a leap year.
Comparing Date Systems

Complete the following case study to see firsthand how important date systems information really is:

1. Enter the number 1 in cell A1.
2. Select cell A1, and then press Ctrl+1 to access the Format Cells dialog.
3. Change the numeric formatting to display the number as a date, using the *Wednesday, March 14, 2001 type. On a PC, you see that the number 1 is January 1, 1900.
4. Type 2 in cell A1. The date changes to January 2, 1900.

Now try this:

1. Select cell B5. Press Ctrl+; to enter today’s date in the cell.
2. Again, select cell B5. Press Ctrl+1 to display the Format Cells dialog.
3. Change the number format from a date to a number. Your date changes to a number in the 40,000 to 42,000 range, assuming you are reading this in the 2010–2013 time period.

This might sound like a hassle, but it is worth it. If you store dates as real dates (that is, numbers formatted to display as a date), Excel can do all kinds of date math. For example, you can figure out how many days exist between a due date and today by subtracting one date from another. You can also use the WORKDAY function to figure out how many workdays have elapsed between a hire date and today.

Excel provides a complete complement of functions to deal with dates including functions that convert data from text to dates and back. Excel stores times as decimal fractions of days. For example, you can enter noon today as =TODAY()+0.5 and 9 a.m. as =TODAY()+0.375. Again, the number format handles converting the decimals to the appropriate display.

Converting Text Dates to Real Dates

The DATEVALUE function converts text that looks like a date into the equivalent serial number. You can then use the Format Cells dialog to display the number as a date.

The text version of a date can take a number of different formats. For example, your international date settings might call for a month/day/year arrangement of the dates. Figure 3.10 shows a number of valid text formats that can be converted with the DATEVALUE function.
Figure 3.11 shows a column of text dates. Follow these steps to convert the text dates to real dates:

1. Insert a blank Column B by selecting cell B1. Select Home, Insert, Insert Sheet Columns. Alternatively, you can use the Excel 2003 shortcut Alt+I+C.

2. In cell B2, enter the formula =DATEVALUE(A2). Excel displays a number in the 40,000 range in cell B2. You are halfway to the result (see Figure 3.11). You still have to format the result as a date.

3. Double-click the fill handle in the lower-right corner of cell B2. Excel copies the formula from cell B2 down to your range of dates.

4. Select Column B2. On the Home tab, select the drop-down at the top of the Number group and choose either Short Date or Long Date. Excel displays the numbers in Column B as a date (see Figure 3.12). Alternatively, you can press Ctrl+1 and select any date format from the Number tab.

5. To convert the live formulas in Column B to be static values, while the range of dates in Column B is selected, press Ctrl+C to copy. Press Ctrl+V to paste. Press Ctrl to open the Paste Options dialog. Press V to paste as values.

6. Delete the original column A.

TIP
If some of the dates appear as #######, you need to make the column wider. To do so, double-click the border between the column B and column C headings.
After converting the text dates to real dates, insert a line chart with markers. Excel automatically formats the chart with a date-based axis. In Figure 3.13, the top chart reflects cells that contain text dates. The bottom chart uses cells in which the text dates have been converted to numeric dates.

To watch a video of converting text dates to dates, search for “MrExcel Charts 3” at YouTube.
Converting Bizarre Text Dates to Real Dates

When you rely on others for source data, you are likely to encounter dates in all sorts of bizarre formats. For example, while gathering data for this book, I found a dataset where each date was listed as a range of dates. Each date was in the format 2/4-6/11. I had to check with the author of the data to find out if they meant February 4th through 6th of 2011 or if they meant February 4th through June 11th. They meant the former.

Used in combination, the functions listed below can be useful when you are converting strange text dates to real dates:

- \( =\text{DATE}(2011,12,31) \) — Returns the serial number for December 31, 2011.
- \( =\text{LEFT}(A1,2) \) — Returns the two leftmost characters from cell A1.
- \( =\text{RIGHT}(A1,2) \) — Returns the two rightmost characters from cell A1.
- \( =\text{MID}(A1,3,2) \) — Returns the third and fourth characters from cell A2. You read the function as “return the middle characters from A1, starting at character position 3, for a length of 2.”
- \( =\text{FIND}("/",A1) \) — Finds the position number of the first slash within A1.

Follow these steps to convert the text date ranges shown in Figure 3.14 to real dates:

Follow these steps to convert the text date ranges shown in Figure 3.14 to real dates:
Understanding Date-Based Axis Versus Category-Based Axis in Trend Charts

1. Because the year is always the two rightmost characters in column A, enter the formula
   =RIGHT(A2,2) in cell B2.

2. Because the month is the leftmost one or two characters in column A, ask Excel
to find the first slash and then return the characters to the left of the slash. Enter
   =FIND("/",A2) to indicate that the slash is in second character position. Use
   =LEFT(A2,FIND("/",A2) to get the proper month number.

3. For the day, either choose to extract the first or last date of the range. To extract the
   first date, ask for the middle characters, starting one position after the slash. The
   logic to figure out whether you need one or two characters is a bit more complicated.
   Find the position of the dash, subtract the position of the slash, and then subtract 1.
   Therefore, use this formula in cell D2:
   =MID(A2,FIND("/",A2)+1,FIND("-",A2)-FIND("/",A2)-1)

4. Use the DATE function as follows in cell E2 to produce an actual date:
   =DATE(B2,C2,D2)

Plotting Data by Numeric Year

If you are plotting data where the only identifier is a numeric year, Excel does not auto-
matically recognize this field as a date field.

For example, in Figure 3.15 data is plotted once a decade for the past 50 years and then
yearly for the past decade. Column A contains four-digit years such as 1960, 1970, and so
on. The default chart shown in the top of the figure does not create a date-based axis. You
know this to be true because the distance from 1960 to 1970 is the same as the distance

Listed here are two solutions to this problem:

- Convert the years in column A to dates by using =DATE(A2,12,31). Format the
  resulting value with a yyyy custom number format. Excel displays 2005 but actually
  stores the serial number for December 31, 2005.

- Convert the horizontal axis to a date-based axis. Excel thinks your chart is plotting
daily dates from May 13, 1905, through July 2, 1905. Because no date format has been
  applied to the cells, they show up as the serial numbers 1955 through 2005. Excel dis-
  plays the chart properly, even though the settings show that the base units are days.

Using Dates Before 1900

In Excel 2010, dates from January 1, 1900 through December 31, 9999 are recognized
as valid dates. However, if your company was founded more than a demisesesquicentennial
before Microsoft was founded, you will potentially have company history going back before
1900.

Figure 3.16 shows a dataset stretching from 1787 through 1959. The accompanying chart
would lead the reader to believe that the number of states in the United States grew
at a constant rate. This inaccurate statement would cause Mr. Kessel, my eighth-grade geography teacher, to give me an F for this book.

As mentioned previously, formatting the chart to have a date-based axis will not work because Excel does not recognize dates before 1900 as valid dates. Possible workarounds are discussed in the next two subsections.

**Using Date-Based Axis with Dates Before 1900 Spanning Less Than 100 Years**

In Figure 3.17, the dates in Column A are text dates from the 1800s. Excel cannot automatically deal with dates from the 1800s, but it can deal with dates from the 1900s.
One solution is to transform the dates to dates in the valid range of dates that Excel can recognize. You can use a date format with two years and a good title on the chart to explain that the dates are from the 1800s. However, keep in mind that this solution fails when you are trying to display more than 100 years of data points.

To create the chart in Figure 3.17, follow these steps:

1. Insert a blank Column B to hold the transformed dates.
2. Enter the formula \(=\text{DATE}(100+\text{RIGHT}(A4,4),\text{LEFT}(A4,2),\text{MID}(A4,4,2))\) in cell B4. This formula converts the 1836 date to a 1936 date.
3. Select cell B4. Press Ctrl+1 to open the Format Cells dialog. Select the date format 3/14/01 from the Date category on the Number tab. This formats the 1936 date as 6/15/36. Later, you will add a title to indicate that the dates in this column are from the 1800s.
4. Double-click the fill handle in cell B4 to copy the formula down to all cells.
5. Select the range B3:C17.
6. From the Insert tab, select Charts, Line, 2-D Line, Line.
7. From the Layout tab, select Legend, No Legend.
8. Right-click the vertical axis along the left side of the chart and select Format Axis from the context menu.
9. In the Format Axis dialog that appears, on the Axis Options page, select the Fixed option button next to Minimum and enter a fixed value of 20.
10. Without closing the Format Axis dialog, click the dates in the horizontal axis in the chart. Excel automatically switches to formatting the horizontal axis, and the settings in the Format Axis dialog redraw to show the settings for the horizontal axis. In the Axis Type section, select Date Axis. Click Close to close the dialog box.
11. From the Layout tab, select Chart Title, Centered Overlay Title.
12. Click the State Count title. Type the new title Westward Expansion\(\text{\textless}\)During 1845-1875 Added 13\(\text{\textless}\)New States to the Union. Click outside the title to exit Text Edit mode.
13. Click the title once. You should have a solid selection rectangle around the title. On the Home tab, click the Decrease Font Size button. Click the Left Align button.

14. Carefully click the border of the title. Drag it so the title appears in the top-left corner of the chart.

15. Select the dates in B4:B17. Press Ctrl+1 to access the Format Cells dialog. On the Number tab, click the Custom category. Type the custom number format ‘yy. This changes the values shown along the horizontal axis from m/d/yy format to show a two-digit year preceded by an apostrophe.

The result is the chart shown in Figure 3.17. The reader may believe that the chart is showing dates in the 1800s, but Excel is actually showing dates in the 1900s.

Using Date-Based Axis with Dates Before 1900 Spanning More Than 100 Years

Microsoft Excel 2010 doesn’t do well with large datasets that span 100+ years. Although I managed to create a date-based axis covering 630 years with 10 data points, a dataset covering 102 years and 40 points cannot display a date-based axis.

However, as Figure 3.18 shows, it is possible to create this chart. To do so, you must transform the date axis into a scale that shows months, hide the axis, and then add your own axis using text boxes. These steps are not for the faint of heart.

First, you need to transform the dates from the 1800s to the 1900s. Next, you will transform the dates spanning 172 years into a range where each month in real time is represented by a single day. This results in a time span of 6 years. You then need to use care to completely hide the labels along the horizontal axis and replace them with text boxes showing the centuries. Lastly, you add a new data series to draw vertical lines at the change of each century.

To create the chart in Figure 3.18, follow these steps:

1. Insert new Columns B and C.

2. In cell B4, enter the formula =DATE(113+RIGHT(A4,4),LEFT(A4,2),MID(A4,4,2)). This transforms the dates from 1787 to a valid Excel date in 1900. Format this cell with a short date format.

3. In cell C4, type the formula = (YEAR(B4) - 1899) * 12 + MONTH(B4) to calculate a number of months. Format this cell as a short date. This formula now reduces 172 years into 172x12 into 2,064 days, where each day represents 1 month of real time.

4. Select cells B4:C4 and double-click the fill handle to copy the formula down to your range of data. The dates in Column B span 1900 to 2072. The dates in Column C span 1900 to 1907. Although the relative position of the data points is correct, you have to hide the axis labels that Excel draws in for the horizontal axis. Therefore, it would be helpful to draw in vertical lines to show where the axis switches from the 1700s to the 1800s. Then draw another line to show where the axis switches from the 1800s to the 1900s.
5. Insert a new Column E to hold the data for the second series. This series contains just two nonzero points: one at 1800 and one at 1900. Enter the heading Divide Line in cell E3.

6. Look through the dates in Column A. Insert a new row before the first date in the 1800s. In this new row, enter 01/01/1800 in Column A. Copy the formulas in Columns B and C. In Column D, copy the point from the row above. In Column E, enter the value 50. This draws a single vertical bar from the horizontal axis up to a height of 50.

7. Repeat step 6 to add a new data point for January 1, 1900, and January 1, 2000.


10. On the Layout tab, select Legend, None.

11. Right-click the numbers along the vertical axis and then select Format Axis. Change the Maximum option button to Fixed and enter the value 50. This changes the vertical axis to show from 0 to 50.

12. On the Layout tab, use the Current Selection drop-down to select Series. Note that there are now only two data points selected in the chart.

13. On the Design tab, select Change Chart Type. Select the first icon in the column section—for a clustered column chart. This draws narrow columns—actually lines—at 1800 and 1900 on the chart. Note that the chart type change affects only the second series because you selected the Divide Line series in step 12.

14. Click the labels along the horizontal axis. These labels show wrong dates such as 1/23/02. On the Home tab, from the Font Color drop-down select a white font. This causes the axis labels to disappear.

15. On the Insert tab, click the Text Box icon. On the chart, draw a text box from the 1800 line to the 1900 line, just below the horizontal axis. The mouse pointer changes into a crosshairs as you draw. Make sure the vertical line in the crosshairs corresponds to the vertical dividing lines. After you create the text box, a flashing cursor appears inside the text box.
16. Type 1800s. Click the edge of the text box to change it from a dashed line to a solid line.

17. While the text box is selected, select Center Align from the Home tab. Select Vertical Center Align. Select Increase Font Size from the Home tab.

18. While the text box is still selected, select Format, Shape Outline, Black on the Layout tab in order to outline the text box.

19. Click the text box and start to drag to the right. After you start to drag, hold down the Shift key to constrain the movement to the right. Hold down the Ctrl key to make an identical copy of the text box. When the left edge of the new text box is aligned with the vertical line at 1900, release the mouse button.

20. Click in the text box and change the text from 1800s to 1900s.

21. On the Layout tab, select Chart Title, Centered Overlay Title. When the title Chart Title appears, it is selected.

22. Click inside the Chart Title text area to enter Text Entry mode. Overwrite the default text in the title by typing Growth of USA, press Enter, type by # of States, press Enter, and type 1787-1999.

23. Click the border of the chart title to exit Text Entry mode.

24. Drag the chart title to a new location in the lower-right corner of the chart.

The result is a chart that appears to show a line chart that spans 217 years. The line is scaled appropriately using a date-based axis.

**Using a Workaround to Display a Time-Scale Axis**

The developers who create Microsoft Excel are careful in the Format Axis dialog box to call the option a date axis. However, the technical writers who write Excel Help refer to a time-scale axis. The developers get a point here for accuracy because Excel absolutely cannot natively handle an axis that is based on time.

A worksheet in the download files is used to analyze queuing times. In Column A, it logs the time that customers entered a busy bank. Times range from when the bank opened at 10 a.m. until the bank closed at 4 p.m.

After you enter planned staffing levels in Column C, the model calculates when the customer will move from the queue to an open teller window and when he or she will leave the window based on an average of three minutes per transaction.
Data in Columns I:M record the number of people in the bank every time someone enters or leaves. This data is definitely not spaced equally. Only a few customers arrive in the 10:00 hour, while many customers enter the bank during the lunch hour.

The top chart in Figure 3.19 plots the number of customers on a text-based axis. Because each customer arrival or departure merits a new point, the one hour from noon until 1 p.m. takes up 41 percent of the horizontal width of the chart. In reality, this 1-hour period merits only 16 percent of the chart. This sounds like a perfect use for a time-series axis, right? Read on for the answer.

The bottom chart is an identical chart where the axis is converted to show the data on a date-based axis. This is a complete disaster. In a date-based axis, all time information is discarded. The entire set of 300 points is plotted in a single vertical line.

The solution to this problem involves converting the hours to a different time scale (similar to the 1800s date example in the preceding section). For example, perhaps each hour could be represented by a single year. Using numbers from a 24-hour clock, the 10:00 hour could be represented by 2010 and the 3:00 hour could be represented by 2015.

In this example, you manipulate the labels along the vertical axis using a clever custom number format. A few new settings on the Format Axis dialog ensure that an axis label appears every hour.
Follow these steps to create a chart that appears to have a time-based axis:

1. In cell L2, enter the following formula to translate the time to a date:
   \[ \text{ROUND(DATE(HOUR(I2)+2000,1,1)+MINUTE(I2)/60*365,0)} \]

   Because each hour will represent a single year, the years argument of the DATE function is \( \text{HOUR(I2)+2000} \). This returns values from 2010 through 2013. The other arguments in the date function are 1 and 1 to return January 1 of the year. Outside the date function, the minute of the time cell is scaled up to show a value from 1 to 365, using \( \text{MINUTE(I2)/60*365} \). The entire formula is rounded to the nearest integer because Excel would normally ignore any time values.

2. Select cell L2. Double-click the fill handle to copy this formula down to all the data points. The result of this formula ranges from January 1, 2010, which represents the customer who walked in at 10 a.m., to 12/25/2015, which represents the customer who walked in at 3:57 p.m.


4. From the Insert tab, select Charts, Line, Line with Markers.

5. On the Layout tab, select Legend, None. (After studying Software Quality Metrics (SQM) data for Excel 2007, surely Microsoft realizes that 500 million people instantly turn off the legend in every chart that has a single data series.)

6. Right-click the labels along the horizontal axis and select Format Axis to display the Format Axis dialog box, where you make the following selections:
   - In the Axis Type section, select Date Axis.
   - For Major Unit, select Fixed, 1 Years.
   - For Minor Unit, select Fixed, 1 Days.
   - For Base Unit, select Fixed, Days.
   - Click Close to close the Format Axis dialog.

7. Return to the transformed dates in Column L. Select L2:L303.

8. Press Ctrl+1 to display the Format Cells dialog. On the Number tab, select the Custom category. A custom number format of \( yy \) would display 10 for 2010 and 15 for 2015. Instead, use a custom number format of \( yy:"00" \). This causes Excel to display 10:00 for 2010 and 15:00 for 2015, which is fairly sneaky, eh?

As you see in Figure 3.20, the chart now allocates one-sixth of the horizontal axis to each hour. This is an improvement in accuracy over either of the charts in Figure 3.19. The additional chart in Figure 3.20 uses a similar methodology to show the wait time for each customer who enters the bank. If my bank offered 12-minute wait times, I would be finding a new bank.
A long time ago, a McKinsey & Company team investigated opportunities for growth at the company where I was employed. I was chosen to be part of the team because I knew how to get the data out of the mainframe.

The consultants at McKinsey & Company knew how to make great charts. Every sheet of grid paper was turned sideways, and a pencil was used to create a landscape chart that was an awesome communication tool. After drawing the charts by hand, they sent off the charts to someone in the home office who generated the charts on a computer. This was a great technique. Long before touching Excel, someone figured out what the message should be.

You should do the same thing today. Even if you have data in Excel, before you start to create a chart, it’s a good idea to analyze the data to see what message you are trying to present.

The McKinsey & Company group used a couple of simple techniques to always get the point across:

- To help the reader interpret a chart, include the message in the title. Instead of using an Excel-generated title such as “Sales,” you can actually use a two- or three-line title such as “Sales have grown every quarter except for Q3, when a strike impacted production.”
If the chart is talking about one particular data point, draw that column in a contrasting color. For example, all the columns might be white, but the Q3 bar could be black. This draws the reader’s eye to the bar that you are trying to emphasize. If you are presenting data on screen, use red for negative periods and blue or green for positive periods.

The following sections present some Excel trickery that allows you to highlight a certain section of a line chart or a portion of a column chart. In these examples, you will spend some time up front in Excel adding formulas to get your data series looking correct before creating the chart.

If you would like a great book about the theory of creating charts that communicate well, check out Gene Zelazny’s *Say It with Charts Complete Toolkit*. Gene is the chart guru at McKinsey & Company who trained the consultants who taught me the simple charting rules. While *Say It with Charts* doesn’t discuss computer techniques for producing charts, it does challenge you to think about the best way to present data with charts and includes numerous examples of excellent charts at work. Visit [www.zelazny.com](http://www.zelazny.com) for more information.

**Using a Long, Meaningful Title to Explain Your Point**

If you are a data analyst, you are probably more adept at making sense of numbers and trends than the readers of your chart. Rather than hoping the reader discovers your message, why not add the message to the title of the chart?

Figure 3.21 shows a default chart in Excel. Both the legend and title use the “Market Share” heading from cell B71. These words certainly do not need to be used twice on the chart.

![Figure 3.21](image-url)
Follow these steps to remove the legend, add data labels, and add a meaningful title:

1. From the Layout tab, select Legend, None, and then select Data Labels, Outside End.
2. Click the title in the chart. Click again to put the title in Edit mode.
3. Backspace to remove the current title. Type *market share has improved*, press Enter, and type *13 points since 2007*.
4. To format text while in Edit mode, you would have to select all the characters with the mouse. Instead, click the dotted border around the title. When the border becomes solid, you can use the formatting icons on the Home tab to format the title. Alternatively, right-click the title box and use the Mini toolbar to format the title.
5. On the Home tab, select the icon for Align Text Left, and then click the Decrease Font Size button until the title looks right.
6. Click the border of the chart title and drag it so the title is in the upper-left corner of the chart.

The result, shown in Figure 3.22, provides a message to assist the reader of the chart.

**Resizing a Chart Title**

The first click on a title selects the title object. A solid bounding box appears around the title. At this point, you can use most of the formatting commands on the Home tab to format the title. Click the Increase/Decrease Font Size buttons to change the font of all of the characters. Excel automatically resizes the bounding box around the title. If you do not explicitly have carriage returns in the title where you want the lines to be broken, you are likely to experience frustration at this point.

![Figure 3.22](image)

*Figure 3.22*  
Use the title to tell the reader the point of the chart.

When you have the solid bounding box around the title, carefully right-click the bounding box and select Edit Text. Alternatively, you can left-click a second time inside the bounding box.
box to also put the title in Text Edit mode. Note that the dashed line in the bounding box indicates the title is in Text Edit mode. Using Text Edit mode, you can select specific characters in the title and then move the mouse pointer up and to the right to access the mini toolbar and the available formatting commands. You can edit specific characters within the title to create a larger title and a smaller subtitle, as shown in Figure 3.23.

You cannot move the title when you are in Text Edit mode. To exit Text Edit mode, right-click the title and select Exit Edit Text or simply left-click the bounding box around the title. When the bounding box is solid, you can click anywhere on the border except the resizing handles and drag to reposition the title.

### Deleting the Title and Using a Text Box

If you are frustrated that the title cannot be resized, you can delete the title and use a text box for the title instead. The title in Figure 3.24 is actually a text box. Note the eight resizing handles on the text box instead of the four resizing handles that appear around a title. Thanks to all these resizing handles, you can actually stretch the bounding box horizontally or vertically.

To create the text box shown in Figure 3.24, follow these steps:

1. From the Layout tab, delete the original title by choosing Chart Title, None. Excel resizes the plot area to fill the space that the title formerly occupied.
2. Select the plot area by clicking some whitespace inside the plot area. Eight resizing handles now surround the plot area. Drag the top resizing handle down to make room for the title.

3. On the Insert tab, click the Text Box icon.

4. Click and drag inside the chart area to create a text box.

5. Click inside the text box and type a title. Press the Enter key to begin a new line. If you do not press the Enter key, Excel word-wraps and begins a new line when text reaches the right end of the text box.

6. Select the characters in the text box that make up the main title and use either the mini toolbar or the tools on the Home tab to make the title 18 point, bold, and Times New Roman.

7. Select the remaining text that makes up the subtitle in the text box and use the tools on the Home tab to make the subtitle be 12 point, italics, Times New Roman.

Microsoft advertises that all text can easily be made into WordArt. However, when you use the WordArt drop-downs in a title, you are not allowed to use the Transform commands found under Text Effects on the Drawing Tools Format tab. When you use the WordArt menus on a text box, however, all the Transform commands are available (see Figure 3.25).

A text box works perfectly because it is resizable and you can use WordArt Transform commands. If you move or resize the chart, the text box moves with the chart and resizes appropriately.

**Highlighting One Column**

If your chart title is calling out information about a specific data point, you can highlight that point to help focus the reader’s attention on it as shown in Figure 3.26. Although the tools on the Design tab do not allow this, you can achieve the effect quickly by using the Format tab.

To create the chart in Figure 3.26, follow these steps:
1. Create a column chart by selecting Column, Clustered Column from the Insert tab.
2. Click any of the columns to select the entire series.
3. On the Format tab, select Shape Fill, White. At this point, the columns are invisible. Invisible bars are great for creating waterfall charts, which is discussed in Chapter 4, “Creating Charts That Show Differences.” However, in this case, you want to outline the bars.
4. From the Format tab, select Shape Outline, Black. Select Shape Outline, Weight, 1 point. All your columns are now white with black outline.
5. Click the Friday column in the chart. The first click on the series selects the whole series. A second click selects just one data point. If all the columns have handles, click Friday again.

If you accidentally click outside the series, you might inadvertently deselect the series. Click back on the series to re-select it.
6. From the Format tab, select Shape Fill, Black.
7. On the Layout tab, turn off the legend and the gridlines.
8. Type a title, as shown in Figure 3.26, pressing Enter after the first line of the title. On the Home tab, change the title font size to 14 point, left aligned.
9. Right-click the numbers along the vertical axis and select Format Axis. Change Major Unit to Fixed, 500.

The result is a chart that calls attention to Friday sales.

### Replacing Columns with Arrows

Columns shaped like arrows can be used to make a special point. For example, if you have good news to report about consistent growth, you might want to replace the columns in the chart with arrow shapes to further indicate the positive growth.

Follow these steps to convert columns to arrows:

1. Create a column chart showing a single series.
2. In an empty section of the worksheet, insert a new block arrow shape. From the Insert tab, select Shapes, Blck Arrows, Up Arrow. Click and drag in the worksheet to draw the arrow.
3. Select the arrow. Press Ctrl+C to copy the arrow to the Clipboard.
4. Select the chart. Click a column to select all the columns in the data series.
5. Press Ctrl+V to paste the arrow. Excel fills the columns with a picture of the block arrow.
6. If desired, select Format Selection from the Format tab. Reduce the gap setting from 150 percent to 75 percent to make the arrows wider.

The new chart is shown in the bottom half of Figure 3.27. After creating the chart, you can delete the arrow created in step 2 by clicking the arrow and pressing the Delete key.

### Highlighting a Section of Chart by Adding a Second Series

The chart in Figure 3.28 shows a sales trend over one year. The business was affected by road construction that diverted traffic flow from the main road in front of the business.

The title calls out the July and August time period, but it would be helpful to actually highlight that section of the chart. Follow these steps to add an area chart series to the chart:

1. Begin a new series in Column C, next to the original data. To highlight July and August, add numbers to Column C for the July and August points, plus the previous point, June. In cell C7, enter the formula of =B7. Copy this formula to July and August.
2. Click on a blank area inside of the chart. A blue bounding box appears around B2:B13 in the worksheet. Drag the lower-right corner of the blue bounding box to the right to
extend the series to include the three values in Column C. Initially, this line shows up as a red line on top of a portion of the existing blue line.

3. On the Layout tab, use the Current Selection drop-down to select Series 2, which is the series you just added.

4. While Series 2 is selected, select Design, Change Chart Type. Select the first area chart thumbnail. Click OK. Excel draws a red area chart beneath the line segment of June through August.

5. On the Format tab, use the Current Selection drop-down to reselect Series 2. Open the Shape Fill drop down. Choose a grey fill color. The 4th row, 1st column offers a tooltip f White, Background 1, Darker 25% and is suitable.
The top chart in Figure 3.29 shows the gray highlight extending from the horizontal axis up to the data line for the two line segments. Alternatively, you can replace the numbers in Column C with 70,000 to draw a gray rectangle behind the months, as shown in the bottom chart in Figure 3.29.

Figure 3.29
A second series with only three points is used to highlight a section of the chart.

Changing Line Type Midstream
Consider the top chart in Figure 3.30. The title indicates that cash balances improved after a new management team arrived. This chart initially seems to indicate an impressive turnaround. However, if you study the chart axis carefully, you see that the final Q3 and Q4 numbers are labeled Q3F and Q4F to indicate that they are forecast numbers.

It is misleading to represent forecast numbers as part of the actual results line. It would be ideal if you change the line type at that point to indicate that the last two data points are forecasts. To do so, follow these steps:

1. Change the heading above Column B from Cash Balances to Actual.
2. Add the new heading Forecast in Column C.
3. Because the last actual data point is for Q2 of 2011, move the numbers for Q3 and Q4 of 2011 from Column B to Column C.
4. To force Excel to connect the actual and the forecast line, copy the last actual data point (the 7 for Q2) over to the Forecast column. This one data point—the connecting point for the two lines—will be in both the Forecast and Actual columns.
5. Change the last two labels in Column A from Q3F to just Q3 and from Q4F to just Q4.

6. Click the existing chart. A bounding box appears around B2:B9. Grab the lower-right blue handle and drag outward to encompass B2:C9. A second series is added to the chart as a red line.

7. On the Layout tab, select Legend, Legend at Right.

8. Click the red line. In the Format tab, you should see that the Current Selection dropdown indicates Series “Forecast.”

9. Select Format, Shape Outline, Dashes and then select the fourth dash option. The red line changes to a dashed line.

10. While the forecast series is selected, select Design, Change Chart Type. Select a chart type that does not have markers.

11. The chart title indicates that a new management team arrived, but it does not indicate when the team arrived. To fix this, change the title to indicate that the team arrived in Q3 of 2010.

12. On the Insert tab, select Shapes, Line. Draw a vertical line between Q2 and Q3 of 2010, holding down the Shift key while drawing to keep the line vertical.

13. While the line is selected, on the Format tab, select Shape Outline, Dashes and then select the fourth dash option to make the vertical line a dashed line. Note that this line is less prominent than the series line because the weight of the line is only 1.25 point.

The final chart is shown at the bottom of Figure 3.30.
Adding an Automatic Trendline to a Chart

In the previous example, an analyst had created a forecast for the next two quarters. However, sometimes you might want to allow Excel to make a prediction based on past results. In these situations, Excel offers a trendline feature in which Excel draws a straight line that fits the existing data points. You can ask Excel to extrapolate the trendline into the future. If your data series contains blank points that represent the future, Excel can automatically add the trendline. I regularly use these charts to track my progress toward a goal or trendline.

The easiest way to add a trendline is to build a data series that includes all the days that the project is scheduled to run. In Figure 3.31, Column A contains the days of the month and Column B contains 125 for each data point. Therefore, Excel draws a straight line across the chart showing the goal at the end of the project. Column C shows the writing progress I should make each day. In this particular month, I am assuming that I will write an equal number of pages six days per week. Column D, which is labeled Actual, is where I record the daily progress toward the goal.

The chart is created as a line chart with the gridlines and legend removed. The trendline is formatted as a lighter gray. The actual line is formatted as a thick line. The top chart in Figure 3.31 shows the chart before the trendline is complete. Notice that the thick line is not quite above the progress line.

Figure 3.31
In the top chart, the actual line is running behind the target line, but it seems close.
To add a trendline, follow these steps:

1. Right-click the series line for the Actual column. Select Add Trendline.
2. The Format Trendline dialog offers to add exponential, linear, logarithmic, polynomial, power, or moving average trendlines. Select a linear trendline.
3. In the Trendline Name section, either leave the name as Linear (Actual) or enter a custom name such as Forecast.
4. When forecasting forward or backward for a certain number of periods, leave both of those settings at 0 because this chart already has data points for the entire month. There are also settings where Excel shows the regression equation on the chart. Add this if you desire.
5. Right-click the trendline to select it. On the Format tab, select Shape Outline, Dashes and then select the fourth dash option. Also, select Shape Outline, Weight, 3/4 point.

The trendline is shown at the bottom of Figure 3.31. In this particular case, the trendline extrapolates that if I continue writing at the normal pace, I will miss the deadline by 15 pages or so.

CAUTION

Excel’s trendline is not an intelligent forecasting system. It merely fits past points to a straight line and extrapolates that data. It works great as a motivational tool. For example, the current example shows that it would take a few days of above-average production before the trendline would project that the goal would be met.

Showing a Trend of Monthly Sales and Year-to-Date Sales

In accounting, sales are generally tracked every month. However, in the big picture you are interested in how 12 months add up to produce annual sales.

The top chart in Figure 3.32 is a poor attempt to show both monthly sales and accumulated year-to-date (YTD) sales. The darker bars are the monthly results, while the lighter bars are the accumulated YTD numbers through the current month. To show the large YTD number for November, the scale of the axis needs to extend to $400,000. However, this makes the individual monthly bars far too small for the reader to be able to discern any differences.

The solution is to plot the YTD numbers against a secondary vertical axis. My preference is that after you change the axis for one series, you should also change the chart type for that series. Follow these steps to create the bottom chart in Figure 3.32:

1. Left-click one of the YTD bars to select the YTD series. Right-click the selected series and select Format Data Series. Excel displays the Format Data Series dialog.
2. In the Format Data Series dialog, select Secondary Axis in the Plot Series On section of the Series Options page. Click Close. Excel creates a confusing chart, where the YTD numbers appear directly on top of the monthly numbers, obscuring any monthly numbers beyond August.

3. Excel deselects the series when you change the chart type. Reselect the YTD series by clicking the YTD line.

4. On the Format dialog, select Shape Outline, Black to change the YTD line to black.

5. From the Layout tab, turn off the gridlines by selecting Gridlines, None.

6. From the Layout tab, select Axes, Primary Vertical Axis, Show Axis in Thousands.

7. From the Layout tab, select Axis Titles, Primary Vertical Axis Title, Rotated Title. Type Monthly Sales and press Enter.

8. From the Layout tab, select Axis Titles, Secondary Vertical Axis Title, Rotated Title. Type YTD and press Enter.

9. Right-click the numbers on the secondary vertical axis. Select Format Axis. In the Scaling section, select 100,000.

10. Click the legend and drag it to appear in the upper-left corner of the plot area.

11. Click the plot area to select it. Drag one of the resizing handles on the right side of the plot area to drag it right to fill the space that used to be occupied by the title.
12. To present your charts in color, change the color of text in the primary vertical axis to match the color of the monthly bars. To change the color, click the numbers to select them. Use the Font Color drop-down on the Home tab to select a color such as blue. This color cue helps the reader realize that the blue left axis corresponds to the blue bars.

The resulting chart is shown at the bottom of Figure 3.32. The chart illustrates both the monthly trend of each month’s sales and the progress toward a final YTD revenue number.

**Understanding the Shortcomings of Stacked Column Charts**

In a stacked column chart, Series 2 is plotted directly on top of Series 1. Series 3 is plotted on top of Series 2, and so on. The problem with this type of chart is that the reader can’t tell whether the total is increasing or decreasing. The reader might not also be able to tell if Series 1 is increasing or decreasing. However, because all the other series have differing start periods, it is nearly impossible to tell whether sales in Series 2, 3, or 4 are increasing or decreasing. For example, in the top chart in Figure 3.33, it is nearly impossible for the reader to tell which regions are responsible for the increase from 2004 to 2009.

Stacked column charts are appropriate when the message of the chart is about the first series. In the lower chart in Figure 3.33, the message is that the acquisition of a new product line saved the company. If this new product line had not grown quickly, the company would have had to rely on aging product lines that were losing money. Because this message is about the sales of the new product line, you can plot this as the first series so the reader of the chart can see the impact from that series.

**Using a Stacked Column Chart to Compare Current Sales to Prior-Year Sales**

The chart in Figure 3.34 uses a combination of a stacked column chart and a line chart. The stacked column chart shows this year’s sales, broken out into same-store sales and new-store sales. In this case, the same-store sales are plotted as the first series in white. The new-store sales are the focus and are plotted in black.

The third series, which is plotted as a dotted line chart, shows the prior-year sales. While the total height of the column is greater than last year’s sales, there is some underlying problem in the old stores. In many cases, the height of the white column does not exceed the height of the dotted line, indicating that sales at same store are down.

The process of creating this combination chart involves a few steps during which the chart looks completely wrong. During those steps, overlook the chart and keep progressing through the steps, as follows:

1. Set up your data with months in Column A, old-store sales for this year in Column B, new-store sales for this year in Column C, and last year’s sales in Column D.
2. Select cells A1:D13 and create a stacked column chart. Initially, Excel stacks prior-year sales on top of the other sales, and you have a chart that is not remotely close to the expected outcome.

3. Click the top bar to select the third series. Select Design, Change Chart Type, Line Chart. An important distinction here is that the first two series are plotted as stacked charts. The third series is plotted as a regular line, not as a stacked line.

4. Use the Format tab to format the third series as a dotted line. Format the colors of the first two series as shown in Figure 3.34.
Shortcomings of Showing Many Trends on a Single Chart

Instead of using a stacked column chart, you might try to show many trendlines on a single line chart, which can be confusing. For example, in the top chart in Figure 3.35, the sales trends of five companies create a very confusing chart.

If the goal is to compare the sales results of your company against those of each major competitor, consider using four individual charts instead, as shown at the bottom of Figure 3.35. In these charts, the reader can easily see that your company is about to overtake the longtime industry leader MegaCo, but that quick growth from NewCo might still cause you to stay in the second position next year.

Next Steps

In Chapter 4, you will learn about charts used to make comparisons, including pie, radar, bar, donut, and waterfall charts.
Symbols

#####, dates displaying as, 92
‘ (apostrophe), comments in VBA, 367
_ (underscore) character, line continuation in VBA, 366
2-D exploded pie charts, 126
2-D pie charts, 126
3-D chart elements, 39-40, 67-68
3-D charts
  icons for, 13
  misleading with, 427-430 rotation, 67-70
3-D exploded pie charts, 126
3-D format settings, formatting in VBA, 393-398
3-D pie charts, 126
3-D rotation in surface charts, 187
3-D rotation settings, formatting in VBA, 388-393
100 percent stacked charts, 132-133
  icons for, 12-13
  as trend charts, 86
100+ year datasets, date-based axis for, 98-100
1900, dates before, 95-100

A

accessing custom themes, 36
AddChart method (VBA), 367, 368
Adjusted Close column in stock charts, accounting for stock splits, 193-195
adjusting. See changing; modifying
Alexander, Mike, 441
aligning icon sets with numbers, 297-298
Alt+F1 shortcut key, creating charts, 17
analysis chart elements, 40-41
annotating charts with shapes, 228-230
apostrophe (‘), comments in VBA, 367
applying
  gradients in VBA, 385-386
  patterns as fills, 385
  SmartArt layouts, 321
ApplyLayout method (VBA), 367, 375
area charts
  drop lines, adding, 72-73
  as trend charts, 85
arrows
  limitations in SmartArt, 329
  replacing columns with, 109-110
  Upward Arrow layout (SmartArt), 331-332

Attilis, Andy, 443
AutoShapes. See shapes
axes, formatting, 52-60. See also horizontal axis; vertical axis
axis scale. See scale of axis
axis titles, formatting, 45. See also horizontal axis title

B

back wall (3-D charts), 40, 67-68
backward compatibility of VBA, 359, 367
Baker, Lisa, 440
Balance layout (SmartArt), 331
bar charts. See also data bars
  column charts versus, 118-120
  as comparison charts, 118-121
  adding second series for time comparison, 121-122
  stacked bar charts, 122-123
  creating with conditional formatting, 299-301
  with REPT function, 301-300
extracting imported data with, 219-221
gap width and series separation settings, 400-402
paired bar charts, 164-172
discount and sales relationship case study, 167-169
multiple variable comparisons case study, 170-172
as trend charts, 85
bar of pie charts, 126, 140-141, 406-411
bars, floating, 231-233
Basic Cycle layout (SmartArt), 332
Beautiful Evidence (Tufte), 279, 286, 423, 440-441
benchmark charts, creating, 259-260
Bernardo, Brett, 262-263
bevel settings, formatting in VBA, 393-398
bins, creating for frequency distribution charts, 177-179
Birthday, Dan, 171
blank cells, filling with zeros, 267
blank top-left cell, 24-25
blogs on charting, 442
bubble charts, 161, 172-176
bubble size settings, 411-412
when to use, 150
BubbleScale property (VBA), 412
Bunzel, Tom, 441
candlestick charts, 191
adding volume to, 211-214
colors in, 210-211
column sequence for, 192-193
creating, 209-210
showing volume and competitor prices case study, 214-217
case studies
 candlestick charts, showing volume and competitor prices, 214-217
color gradients, creating, 65
comparing date systems, 91
converting series to gridlines, 235-239
converting SmartArt to shapes, 341-342
customer mapping, 314
date-based axis for time representations, 57
discount and sales relationship (paired bar charts), 167-169
Gene Zelazny radar chart, 182-185
MAD Magazine (paired matching charts), 172
moving charts to top of datasets, 19-20
multiple variable comparisons (paired bar charts), 170-172
pie of pie charts, creating, 141
printing charts for each customer, 418-419
reversing icon order in icon sets, 298
stratifying invoice amounts, 277
time-based axis, accurate data representation with, 87
waterfall charts, creating, 143
categories
reversing to mislead, 436-437
reversing with series, 20-22 of SmartArt, 317-318
category-based axis, 52, 56-57
choosing, 88
date-based axis versus in trend charts, 86-89
cells
contents, displaying in shapes, 336
top-left cell, leaving blank, 24-25
Cells() method (VBA), 363
changing. See also modifying axis scale, 57-60
chart title in VBA, 382
data sequence, 23-24
default charts, 17
legend arrangements, 47
line types mid-line, 111-112
pivot chart types, 269-270
SmartArt colors, 320-321
SmartArt layouts, 321-322
theme colors, 9
chart area, 38, 66-67
chart elements
formatting, 41-75
3-D chart elements, 67-68
3-D chart rotation, 67-70
axes, 52-60
axis titles, 45
chart templates, creating, 82
chart title, 41-44
data labels, 48-50
data markers, 80-82
data points, 76
data tables, 51-52
drop lines, 72-73
error bars, 74-75
gridlines, 60-61
legends, 45-48
plot area, 63-67
series, 75-76
trendlines, 70-72
up/down bars, 73-74
in VBA, 382
list of, 38-41
chart groups, 221-225, 401
chart layouts, choosing, 26-27
Chart Layouts gallery, 26
chart layouts, choosing, 26-27
in VBA, 375-377
Chart object (VBA), 367-368
Chart Styles gallery
  color schemes, choosing, 27-28
  in VBA, 375-377
chart templates
  creating, 82
  saving, 204
  in VBA, 372-375
chart title, 39
  deleting, 106-107
  formatting, 41-44
  meaningful titles, 104-107
  resizing, 105-106
  in VBA, 382
chart types
  choosing
    with Expand icon, 10
    with Insert tab, 9
    for trend charts, 82-86
    combining in single chart, 221-225
    icons for, 11-13
    for pivot charts, changing, 269-270
    in VBA, 372-373
ChartFormat method (VBA), 367
ChartFormat object (VBA), 382
charting blogs, 442
charting tutorials, 441
charting utilities, 443
ChartObject object (VBA), 367-368
charts
  annotating with shapes, 228-230
  benchmark charts, creating, 259-260
  blank top-left cell, 24-25
  comparison charts. See comparison charts
  creating, 14-17
    with conditional formatting, 299-301
    contiguous data, selecting, 15
    with Insert tab, 16-17
    noncontiguous data, selecting, 15-16
    number of combinations possible, 77
    in PowerPoint with data from Excel, 353-355
    with REPT function, 301-300
    with single keystroke, 17
    in VBA, 368
  data sequence, changing, 23-24
  default charts, changing, 17
  delta charts, creating, 260-261
  dynamic charts. See dynamic charts
  exporting
    as pictures, 356-357, 413-415
    to Web pages, 355-356
    as XPS or PDF, 357
  formatting in VBA, 382
    3-D format settings, 393-398
    3-D rotation settings, 388-393
    fills, 383-386
    Format method, 382
    glow settings, 386-387
    line settings, 386
    reflection settings, 387
    shadow settings, 387
    soft edge settings, 387-388
  innovative examples of, 262
  lying with. See misleading charts
  moving, 17-20
    to new sheet, 25-26
    in VBA, 368-369
    between worksheets, 228
  multiple charts on single chart, 239-243
  organization charts, creating, 326-329
  pasting to PowerPoint/Word 2010
    with embedded workbook, 351-352
    as link, 345-349
    with original formatting, 349-350
    as picture, 352-353
    selecting paste options, 341-345
    with updated formatting, 350-351
  pivot charts. See pivot charts
  referencing in VBA, 367-368, 370-371
  relationship charts.
    See relationship charts
  resizing, 17, 220-221, 368-369
  resources for information, 439-443
  saving as templates, 204
  series and categories, reversing, 20-22
  thermometer charts, creating, 258-259
  trend charts. See trend charts
ChartStyle property (VBA), 376-377
ChartType property (VBA), 372
choosing
  axis type, 88
  chart types
    with Expand icon, 10
    with Insert tab, 9
    for trend charts, 82-86
  color schemes, 27-28
  colors for custom themes, 33-34
  contiguous data, 15
  effects for custom themes, 30-31
  fonts for custom themes, 35
  forecast methods, 72
  noncontiguous data, 15-16
  paste options, 341-345
  SmartArt layouts, 330-331
  themes, 28-29
ClearToMatchStyle method (VBA), 377
clip art as data markers, 80

How can we make this index more useful? Email us at indexes@quepublishing.com
clustered and stacked charts, creating, 144-150
combining stacked and clustered columns, 144-145, 226-228
deleting legend entries, 148
icons for, 11-12
manually adjusting vertical axis scale, 148-150
resizing columns, 147
shifting series with blank series, 145-146

color scales, 278
creating, 293
customizing, 293

color schemes
choosing, 27-28
modifying with themes, 28-29

colors
in candlestick charts, 210-211
complementary colors, finding, 32-33
for custom themes, choosing, 33-34
gradients for plot area, 63-65
highlighting pie slices, 131-132
RGB color codes, 31-32
in SmartArt, changing, 320-321
theme colors, changing, 9

column charts
bar charts versus, 118-120
gap width and series separation settings, 400-402
in line charts showing stock volume, 197-199
as sparkcolumns, 280
as trend charts, 83

column depth (3-D charts), 40

columns. See also data markers
floating, 231-233
highlighting single columns, 107-109
reordering for stock charts, 192-193
replacing with arrows, 109-110
resizing, 92, 147
combining
chart types in single chart, 221-225
stacked and clustered columns, 144-145, 226-228

comments in VBA, 367

communication tips for trend charts, 103-112
changing line types, 111-112
highlighting chart sections, 109-111
highlighting single columns, 107-109
long titles, 104-107
replacing columns with arrows, 109-110

coloring and saving, 339-342

correlation, testing with scatter charts, 161-164
cost of MapPoint, 303
CurrentRegion property (VBA), 363
custom shapes, creating, 338-339
custom themes. See themes, creating
customer mapping case study, 314
customizing. See also formatting
correlation, testing with scatter charts, 161-164
copying sparklines, 288. See also pasting to PowerPoint/Word 2010
cut-and-paste method, moving charts, 19
cycle category (SmartArt), 318
cylinders. See data markers
deleting legend entries, 148
manually adjusting vertical axis scale, 148-150
resizing columns, 147
shifting series with blank series, 145-146

conditional formatting
creating charts with, 299-301
in-cell data bars, 271, 288-292
cone charts, misleading with, 430-431
contiguous data, choosing, 15
contrast, showing with surface charts, 185-187
color scales, 278
creating, 448
combining stacked and clustered columns, 144-145, 226-228
deleting legend entries, 148
icons for, 11-12
manually adjusting vertical axis scale, 148-150
resizing columns, 147
shifting series with blank series, 145-146
color schemes
choosing, 27-28
modifying with themes, 28-29
colors
in candlestick charts, 210-211
complementary colors, finding, 32-33
for custom themes, choosing, 33-34
gradients for plot area, 63-65
highlighting pie slices, 131-132
RGB color codes, 31-32
in SmartArt, changing, 320-321
theme colors, changing, 9
column charts
bar charts versus, 118-120
gap width and series separation settings, 400-402
in line charts showing stock volume, 197-199
as sparkcolumns, 280
as trend charts, 83
column depth (3-D charts), 40
columns. See also data markers
floating, 231-233
highlighting single columns, 107-109
reordering for stock charts, 192-193
replacing with arrows, 109-110
resizing, 92, 147
combining
chart types in single chart, 221-225
stacked and clustered columns, 144-145, 226-228
comments in VBA, 367
communication tips for trend charts, 103-112
changing line types, 111-112
highlighting chart sections, 109-111
highlighting single columns, 107-109
long titles, 104-107
replacing columns with arrows, 109-110
coloring and saving, 339-342
correlation, testing with scatter charts, 161-164
cost of MapPoint, 303
CurrentRegion property (VBA), 363
custom shapes, creating, 338-339
custom themes. See themes, creating
customer mapping case study, 314
customizing. See also formatting
correlation, testing with scatter charts, 161-164
copying sparklines, 288. See also pasting to PowerPoint/Word 2010
cut-and-paste method, moving charts, 19
cycle category (SmartArt), 318
cylinders. See data markers
deleting legend entries, 148
manually adjusting vertical axis scale, 148-150
resizing columns, 147
shifting series with blank series, 145-146
conditional formatting
creating charts with, 299-301
in-cell data bars, 271, 288-292
cone charts, misleading with, 430-431
contiguous data, choosing, 15
contrast, showing with surface charts, 185-187
converting
hexadecimal color codes to RGB color codes, 31-32
series to gridlines, 233-239
SmartArt to shapes, 341-342
text dates to dates, 89-95
text to WordArt, 77
zero to NA, 433-434
copying sparklines, 288. See also pasting to PowerPoint/Word 2010
correlation, testing with scatter charts, 161-164
cost of MapPoint, 303
CurrentRegion property (VBA), 363
custom shapes, creating, 338-339
custom themes. See themes, creating
customer mapping case study, 314
customizing. See also formatting
correlation, testing with scatter charts, 161-164
copying sparklines, 288. See also pasting to PowerPoint/Word 2010
cut-and-paste method, moving charts, 19
cycle category (SmartArt), 318
cylinders. See data markers
Daily Dose of Excel blog, 442
D’Amico, Bob, 172, 443
Dashboard Reporting with Excel, 443
dashboards, resizing charts for, 220-221
data bars, 278, 289
   creating, 289-291, 420-422
   customizing, 290-292
   Excel 2007 options, 289
   in-cell data bars, 271, 288-292
   negative data bars, 290-289
   new features, 289-290
   for subset of cells, 292
data labels, 39
   formatting, 48-50
   for pie charts, 127-128, 129-130
   in scatter charts, 155-156
   in sparklines, 281, 287-288
   for vertical axis, using XY series, 233-239
data markers, formatting, 80-82
data points
   formatting, 76
   in scatter charts, joining with lines, 156-158
   two data points, trendlines from, 435-436
data preparation for pivot tables, 266-267
data representation problems in pie charts, 135-141
   bar of pie charts, 140-141
   pie of pie charts, 136-141
   summary slice, 136
data sequence, changing, 23-24
data series. See series
data tables, 39, 51-52
data visualizations. See color scales; data bars; icon sets
datasets, moving charts to top, 19-20
date filters for pivot tables, 274-275
DATE function, 94
date-based axis, 56-57
   choosing, 88
   dates before 1900, 95-100
   numeric years, plotting data by, 95
   text dates, converting to dates, 89-95
   text-based axis versus in trend charts, 86-89
   as time-scale axis, 100-103
dates
   before 1900, 95-100
   comparing date systems, 91
   converting text dates to, 89-95
   displaying as #######, 92
   storage format for, 90-91
DATEVALUE function, 91
Debartolo, Dick, 124
default charts, changing, 17
deleting
   chart title, 106-107
   legend entries, 148
   legends, 48
delta charts, creating, 260-261
demographic data in MapPoint, 313
depth axis
   built-in choices for, 53
   in surface charts, 187
depth rotation in 3-D charts, 69
Design tab, 8, 26
   Chart Layouts gallery. See Chart Layouts gallery
   Chart Styles gallery. See Chart Styles gallery
   chart types in VBA, 372-373
   custom chart templates in VBA, 372-375
Developer tab, enabling, 360
diagrams. See SmartArt
Dialog Launcher icon, chart types, choosing, 10
difference charts. See comparison charts
discount and sales relationship case study (paired bar charts), 167-169
Diverging Radial layout (SmartArt), 333
dotted-line reporting relationships in organization charts, 328-329
doughnut charts, 133-134, 404-406
DoughnutHoleSize property (VBA), 406
downloading stock chart data, 191-192
drawing with scatter charts, 160-161
drop lines, 40, 72-73
dynamic charts, 243
   creating, 341-342
   with dynamic ranges, 251-254
   scrolling charts, creating, 254-257
   in UserForms, 413-415
   with validation drop-downs, 248-251
dynamic ranges, charts with, 251-254
effects for custom themes, choosing, 30-31
embedded workbook, pasting charts with, 351-352
enabling
   Developer tab, 360
   VBA (Visual Basic for Applications), 360
End With statement (VBA), 366
End+Down arrow, 364
End+Up arrow, 364
enlarging sparklines, 285-286
Envisioning Information (Tufte), 440
equations
in SmartArt, limitations, 330
trendline equations, adding to charts, 71-72
error bars, 41, 74-75
Excel, versions of, 4
Excel 2003, 4
Excel 2007, 4
data bar options, 289
filtering pivot tables, 274-275
pivot tables in, 264-266
Excel 2010, new features, 4-8, 264-266, 289-290
Expand icon, chart types, choosing, 10
exploding pie slices, 129-131, 404-406
Explosion property (VBA), 404-405
exponential trendlines, 72
ExportChart method (VBA), 413
exporting charts
as pictures, 356-357, 413-415
to Web pages, 355-356
as XPS or PDF, 357
extracting imported data with bar charts, 219-221
fills for chart objects in VBA, 383-386
filtering pivot tables, 273-275
creating pivot charts per value, 275-276
with Excel 2007 filters, 274-275
with slicers, 273-274
FIND function, 94
finding complementary colors, 32-33
lookup table values, 245-247
FirstSliceAngle property (VBA), 404
five-icon sets, 295
flexible data ranges in VBA, 363-364
floating
columns or bars, 231-233
legends in plot area, 46-47
floor (3-D charts), 40, 67-68
fonts for custom themes, choosing, 35
forecasting with trendlines, 70-72
Format Data Labels dialog box, 50
Format dialog box, 36-38, 44
Format Gridlines dialog box, 61-62
Format Legend dialog box, 48
Format method (VBA), 382
Format Series dialog box, 400
bar of pie and pie of pie charts, 406-411
bubble size settings, 411-412
gap width and series separation settings, 400-402
radar and surface charts, 412-413
rotating and exploding round charts, 404-406
secondary axis for series, 403-404
Format tab, 8, 36, 76-77
chart title, formatting, 44
preset Shape Effects, 78-79
Shape Effects feature, 77-78
Shape Fill feature, 77-78
Shape Outline feature, 77-78
Shape Styles gallery, 77-78
WordArt, converting text to, 77
formatting. See also customizing
bar of pie charts, 406-411
bubble size settings, 411-412
chart elements, 41-75
3-D chart elements, 67-68
3-D chart rotation, 67-70
axes, 52-60
axis titles, 45
chart templates, creating, 82
chart title, 41-44
data labels, 48-50
data markers, 80-82
data points, 76
data tables, 51-52
drop lines, 72-73
error bars, 74-75
gridlines, 60-61
legends, 45-48
plot area, 63-67
series, 75-76
trendlines, 70-72
up/down bars, 73-74
conditional formatting, creating charts with, 299-301
original formatting, pasting charts with, 349-350
pie of pie charts, 406-411
radar and surface charts, 412-413
shapes, 338
SmartArt elements, 322-324-326
updated formatting, pasting charts with, 350-351
in VBA, 382

F
F11 shortcut key, creating charts, 17
Few, Steven, 442
filling blank cells with zeros, 267
3-D format settings, 393-398
3-D rotation settings, 388-393
fills, 383-386
Format method, 382
glow settings, 386-387
line settings, 386
reflection settings, 387
shadow settings, 387
soft edge settings, 387-388
formulas for extracting imported data, 219-221
four-icon sets, 295
Franklin, Charles, 442
frequency distribution charts, 161, 176-180
FREQUENCY function, 161, 177-179
functions
DATE, 94
DATEVALUE, 91
FIND, 94
FREQUENCY, 161, 177-179
HEX2DEC, 32
INDEX, 247-248
LEFT, 94
MATCH, 245-248
MID, 32, 94
OFFSET, 244-245
REPT, 301-300
RIGHT, 94
SERIES, 235-236
SUMIFS, 15
VLOOKUP, 245-247
funnel charts, limitations, 329

G

gallery controls, 14
gap width in column and bar charts, 400-402
gear charts, limitations, 329
Gemignani, Chris, 442
Gemignani, Zach, 442
geographic maps.
See MapPoint
Glass, Ira, 142
glow settings, formatting in VBA, 386-387

G

generates applying in VBA, 385-386
for plot area, 63-65
graphics. See pictures; shapes; SmartArt; WordArt
gridlines. See also horizontal gridlines; vertical gridlines avoiding with data labels, 49
converting series to, 233-239
formatting, 60-61
groups of sparklines, creating, 281-282. See also chart groups

I

icon sets, 278
aligning with numbers, 297-298
reversing order of icons, 298
setting up, 295-296
types of, 293-295
icons for chart types, 11-13
images. See pictures; shapes; SmartArt; WordArt
imported data, extracting with bar charts, 219-221
in-cell data bars, 3
IncrementRotationHorizontal method (VBA), 393
IncrementRotationVertical method (VBA), 393
IncrementRotationX method (VBA), 389
IncrementRotationY method (VBA), 393
IncrementRotationZ method (VBA), 393
INDEX function, 247-248
Insert Screen Clipping feature (Office 2010), 356-357

Insert tab, 8
chart types, choosing, 9
charts, creating, 16-17

inserting
shapes, 337-338
SmartArt, 319-320

Instant Cognition blog, 442
interactive training resources, 441

interface
gallery controls, 14
icons for chart types, 11-13
tabs in, 8-9

J

joining scatter chart points with lines, 156-158

Juice Analytics blog, 442

K

keyboard shortcuts. See shortcut keys
Kusleika, Dick, 442
Kyd, Charley, 239, 443

L

labeled hierarchy charts, creating, 334-335
labels. See data labels
Layout tab, 8, 36, 377-382

layouts in SmartArt, 316-317. See also chart layouts
applying, 321
Balance layout, 331
Basic Cycle layout, 332
changing, 321-322
creating new, 335-336

Diverging Radial layout, 333
selecting, 330-331
Table List layout, 333
Upward Arrow layout, 331-332

LEFT function, 94

legacy versions of Excel, 4
legends, 39
deleting entries, 148
formatting, 45-48
in pivot charts, 270

Leveraging SmartArt Graphics in the 2007 Microsoft Office System (Ozgur), 336
lighting settings, formatting in VBA, 393-398
line charts
drop lines, adding, 72-73
line types, changing
mid-line, 111-112
as sparklines, 280
as stock charts, 187-190
column sequence for, 192-193
creating, 195-197
volume as column chart in, 197-199
as trend charts, 83-84
up/down bars, adding, 73-74

line continuation in VBA, 366
line settings, formatting in VBA, 386
line types, changing
mid-line, 111-112

LineFormat object (VBA), 386
lines, joining scatter chart points with, 156-158
links, pasting charts as, 345-349
list category (SmartArt), 317
live training, 441
live updates to stock charts, creating, 218-221
logarithm trendlines, 72
logarithmic axis, 54-55
lookup tables, finding values in, 245-247

lying with charts. See misleading charts

M

Mac OS, date/time storage format, 90-91
macro recorder, 362
macros. See VBA (Visual Basic for Applications)
MAD Magazine case study (paired matching charts), 172
major gridlines, spacing, 61

MapPoint, 300-314
cost of, 303
customer mapping case study, 314
map styles in, 313
maps
creating in Excel, 304-308
numeric data on, 308-312
saving files, 305
zip code fields, misidentification, 310-311

maps
creating in Excel, 304-308
customer mapping case study, 314
numeric data on, 308-312
styles in MapPoint, 313
zooming, 307-308

MATCH function, 245-248

material type settings, formatting in VBA, 393-398
matrix category (SmartArt), 318, 329

Mehta, Tushar, 239, 441
Michaelides, David, 442
Microsoft MapPoint 2010. See MapPoint
Hiding true numbers, 437
perspective in, 427-430
with pictographs, 437-438
with reversed categories, 436-437
scale of axis in, 432-433
shrinking in, 430-431
stacked area charts, 434-435
trendlines from two data points, 435-436

mixing. See combining
modifying. See also changing color schemes with themes, 28-29
Venn diagrams, 334
monthly sales, plotting with YTD sales, 114-116
moving chart title, 43
charts, 17, 18-20
to new sheet, 25-26
in VBA, 368-369
between worksheets, 228
data labels to avoid gridlines, 49
series to secondary axis, 403-404
moving average trendlines, 72
multiple charts on single chart, 239-243
multiple trends in single chart, 118
multiple variable comparisons case study (paired bar charts), 170-172

N
navigation in MapPoint maps, 307-308
negative data bars, 290-289
noncontiguous data, choosing, 15-16
numbers, aligning icon sets with, 297-298
numeric data on maps, 308-312
numeric years, plotting data by, 95

O
object references in VBA, 366
object variables in VBA, 364-365
object-oriented code, 362-363
ObjectThemeColor property (VBA), 384
OFFSET function, 244-245
OHLC charts, 190-191. See also high-low-close charts column sequence for, 192-193
creating, 202-204
OneColorGradient method (VBA), 385
open-high-low-close charts. See OHLC charts
organization charts, creating, 326-329
Overlap property (VBA), 402
Ozgur, Suat, 336

P
Page Layout tab, themes, choosing, 28-29
paired bar charts, 164-172
discount and sales relationship case study, 167-169
multiple variable comparisons case study, 170-172
paired matching charts, 161, 172
pasting to PowerPoint/Word 2010 with embedded workbook, 351-352
as link, 345-349
with original formatting, 349-350
as picture, 352-353
selecting paste options, 341-345
with updated formatting, 350-351
patterns, applying as fills, 385
PDF file format, exporting charts as, 357
Peltier, Jon, 239, 441
performance review example (radar charts), 180-182
perspective in misleading charts, 427-430
perspective rotation in 3-D charts, 68-69
picture category (SmartArt), 318
pictures adding to SmartArt, 325-326
as data markers, 80
exporting charts as, 356-357, 413-415
misleading with, 437-438
pasting charts as, 352-353
for plot area, 65
pie charts, 126-132
comparing with doughnut charts, 133-134
data labels for, 127-128, 129-130
data representation problems, 135-141
bar of pie charts, 140-141
pie of pie charts, 136-141
summary slice, 136
highlighting slices with color, 131-132
by exploding, 129-131, 404-406
rotating, 128-129, 404-406
as trend charts, 86
when not to use, 123-125
when to use, 118, 124-125
pie of pie charts, 126, 136-141, 406-411
pivot charts, 264
adding series to, 270-271
adding to pivot tables, 266
advanced operations in pivot table, 271-272
changing chart type, 269-270
creating, 267-269, 415-419
new features, 264-266
stratifying invoice amounts case study, 277
values in Report Filter field, creating charts for, 275-276
pivot tables, 264
adding pivot charts to, 266
advanced operations in, 271-272
data preparation for, 266-267
filtering, 273-275
creating pivot charts per value, 275-276
with Excel 2007 filters, 274-275
with slicers, 273-274
new features, 264-266
plot area, 38
floating legends in, 46-47
formatting, 63-67
PNG file format, exporting charts as, 355-357
points. See data points
Politikal Arithmetik blog, 442
polynomial trendlines, 72
Power Excel Seminar, 335
power trendlines, 72
PowerFrameworks.com, 172, 440
PowerPoint/Word 2010 creating charts with data from Excel, 353-355
pasting to
with embedded workbook, 351-352
as link, 345-349
with original formatting, 349-350
as picture, 352-353
selecting paste options, 341-345
with updated formatting, 350-351
preparing data for pivot tables, 266-267
preset Shape Effects, 78-79
PresetGradient method (VBA), 386
PresetTextured method (VBA), 384
printing charts for each customer case study, 418-419
process category (SmartArt), 318
professional chart designers, 442
pyramid category (SmartArt), 318, 330
pyramid charts, misleading with, 430-431
radar charts, 161
formatting, 412-413
Gene Zelazny chart case study, 182-185
performance review example, 180-182
when to use, 150
ranges
dynamic ranges, charts with, 251-254
flexible data ranges in VBA, 363-364
specifying with OFFSET function, 244-245
referencing charts in VBA, 367-368, 370-371
reflection settings, formatting in VBA, 387
relationship category (SmartArt), 318
relationship charts, 150-152.
See also comparison charts bubble charts, 161, 172-176
frequency distribution charts, 161, 176-180
paired bar charts, 164-172
discount and sales relationship case study, 167-169
multiple variable comparisons case study, 170-172
paired matching charts, 161, 172
radar charts, 161
Gene Zelazny chart case study, 182-185
performance review example, 180-182
scatter charts, 152-161
adding second series to, 157-159
data labels in, 155-156
drawing with, 160-161
joining points with lines, 156-158
testing correlation with, 161-164
trendlines in, 153-154
surface charts, 185-187
3-D rotation in, 187
depth axis in, 187
removing. See deleting
reordering columns for stock charts, 192-193
Report Filter field, values in, creating pivot charts for, 275-276
REPT function, 300
ResetRotation method (VBA), 393
resizing
chart title, 105-106
charts, 17, 220-221, 368-369
columns, 92, 147
legends, 47
resources for information, 439-443
reversing
categories to mislead, 436-437
icon order in icon sets, 298
series and categories, 20-22
RGB color codes, 31-32
RIGHT function, 94
rotation
in 3-D charts, 67-70
3-D rotation settings, formatting in VBA, 388-393
of pie charts, 128-129, 404-406
in surface charts, 187
RotationX property (VBA), 389
RotationY property (VBA), 389
R-squared values, 162-164
saving
charts as templates, 204
MapPoint files, 305
themes, 35-36
Say It with Charts Complete Toolkit (Zelazny), 104, 439
scale of axis
changing, 57-60
in misleading charts, 432-433
for sparklines, setting, 284-286
scaling. See resizing
scatter charts, 152-161
adding second series to, 157-159
data labels in, 155-156
drawing with, 160-161
joining points with lines, 156-158
testing correlation with, 161-164
trendlines in, 153-154
when to use, 150
screen capture tools, 356-357
scrolling charts, creating, 254-257
secondary axis for series, 403-404
SecondPlotSize property (VBA), 410
Select Data icon, changing data sequence, 23-24
selecting. See choosing seminars, 39-42
series. See also Format Series dialog box; XY series
adding for time comparison, 121-122
adding to pivot charts, 270-271
adding to scatter charts, 157-159
in chart groups, 401
combining chart types in single chart, 221-225
converting to gridlines, 233-239
formatting, 75-76
highlighting chart sections with, 109-111
reversing with categories, 20-22
secondary axis for, 403-404
shifting with blank series, 145-146
SERIES function, 235-236
SetElement method (VBA), 367, 377-382
shaded area map style, 313
shadow settings, formatting in VBA, 387
Shape Effects feature, 77-78-79
Shape Fill feature, 77-78
Shape Outline feature, 77-78
Shape Styles gallery, 77-78
shapes, 314, 336-339. See also SmartArt
annotating charts with, 228-230
converting SmartArt to, 341-342
creating custom, 338-339
as data markers, 80-82
formatting, 323-324, 338
inserting, 337-338
limitations in SmartArt, 329-330
sharing themes, 36
sheets, moving charts to, 25-26
shortcut keys, creating charts, 17
shrinking in misleading charts, 430-431
side wall (3-D charts), 40, 67-68
Singh, Mala, 262, 443
slicers, filtering pivot tables with, 273-274
SmartArt, 314
adding pictures to, 325-326
categories of, 317-318
changing colors, 320-321
converting to shapes, 341-342
How can we make this index more useful? Email us at indexes@quepublishing.com
elements in, 316-317, 322-324
inserting, 319-320
labeled hierarchy charts, creating, 334-335
layouts, 316-317
applying, 321
Balance layout, 331
Basic Cycle layout, 332
changing, 321-322
creating new, 335-336
Diverging Radial layout, 333
selecting, 330-331
Table List layout, 333
Upward Arrow layout, 331-332
limitations, 329-330
new features, 316
organization charts, creating, 326-329
text pane, 324-326
Venn diagrams, modifying, 334
Snag-It, 356-357
soft edge settings, formatting in VBA, 387-388
spacing of gridlines, 61
sparkcolumns, 280
sparklines, 3-4, 278
  axis scale, setting, 284-286
copying, 288
creating groups of, 281-282
creating in VBA, 423-427
customizing, 282-283
data labels in, 281, 287-288
enlarging, 285-286
types of, 280
win/loss charts, creating, 285
Speedometer Chart Creator, 68
splitting pie of pie charts, 140. See also stock splits
SplitType property (VBA), 407
SplitValue property (VBA), 407
stacked and clustered charts, creating, 144-150
  combining stacked and clustered columns, 144-145, 226-228
deleting legend entries, 148
  manually adjusting vertical axis scale, 148-150
  resizing columns, 147
  shifting series with blank series, 145-146
stacked area charts as misleading, 434-435
stacked bar charts as comparison charts, 122-123
stacked column charts, 132-133
  icons for, 11-12
  as trend charts, 86, 116-117
stock charts, 85
  candlestick charts, 191
  adding volume to, 211-214
  colors in, 210-211
  creating, 209-210
  showing volume and competitor prices case study, 214-217
downloading data for, 191-192
high-low-close charts
  adding volume to, 204-209
  creating, 199-202
line charts as, 187-190
  creating, 195-197
  volume as column chart in, 197-199
live updates, creating, 218-221
OHLC charts, 190-191, 202-204
reordering columns for, 192-193
stock splits, accounting for, 193-195
text boxes as chart title, 106-107
storage format for dates and times, 90-91
stratifying invoice amounts case study, 277
styles. See also Chart Styles gallery
subset of cells, data bars for, 292
SUMIFS function, 15
summary data, creating, 14
summary pie slices, creating, 136
surface charts, 150, 185-187
  3-D rotation in, 187
  depth axis in, 187
  formatting, 412-413
surface settings, formatting in VBA, 393-398
SWIPE (visual design store), 56-58
swimming. See reversing
swoosh arrows (SmartArt), 331-332
T
Table List layout (SmartArt), 333
tables. See lookup tables; pivot tables
tabs in interface, 8-9
Takasaki, Earl, 262
templates
  creating, 82
  saving, 204
  in VBA, 372-375
testing correlation with scatter charts, 161-164
text. See also WordArt
  converting to WordArt, 77
  formatting in SmartArt elements, 322-323
  in shapes, updating, 336
text boxes as chart title, 106-107
text dates, converting to dates, 89-95

text pane in SmartArt, 324-326

text-based axis, 52, 56-57
  choosing, 88
  date-based axis versus in trend charts, 86-89

textures for plot area, 65

theme colors, changing, 9
themes
  choosing, 28-29
  creating, 29-36
    colors, choosing, 33-34
    complementary colors, finding, 32-33
    converting hexadecimal to RGB color codes, 31-32
    effects, choosing, 30-31
    fonts, choosing, 35
    RGB color codes, 31
    saving, 35-36
    sharing, 36
    using custom, 36

thermometer charts, creating, 258-259

three-icon sets, 295

three-variable relationships with bubble charts, 172-176
time charts. See trend charts
time comparisons in bar charts, 121-122
time-based axis, 52, 56-57.
  See also date-based axis
  accurate data representation with, 87
  date-based axis as, 100-103
times, storage format for, 90-91
time-series charts, creating, 309-312
titles. See chart title
tolerance levels, viewing with error bars, 74-75
top-left cell, leaving blank, 24-25

training opportunities, 39-42

transparency of chart area and plot area, 66-67
trend charts
  chart types, choosing, 82-86
  communication tips, 103-112
  changing line types, 111-112
  highlighting chart sections, 109-111
  highlighting single columns, 107-109
  long titles, 104-107
  replacing columns with arrows, 109-110
date-based axis
  converting text dates to dates, 89-95
  dates before 1900, 95-100
  plotting data by numeric years, 95
  text-based axis versus, 86-89
  as time-scale axis, 100-103
  monthly and YTD sales, plotting together, 114-116
  multiple trends in single chart, 118
  stacked column charts, 116-117
trendlines, adding, 113-114
trendlines, 40
  adding to charts, 113-114
  formatting, 70-72
  R-squared values, 162-164
  in scatter charts, 153-154
  from two data points, 435-436
  types of, 72

Tufte, Edward, 80, 278, 440-441
tutorials, websites for, 25-36
TwoColorGradient method (VBA), 385

U
underscore (_) character, line continuation in VBA, 366
updated formatting, pasting charts with, 350-351
updates, live updates to stock charts, 218-221
updating text in shapes, 336
up/down bars, 41, 73-74
Upward Arrow layout (SmartArt), 331-332
user interface. See interface
UserForms, dynamic charts in, 413-415
UserPicture method (VBA), 385
utilities for charting, 65-73

V
validation drop-downs, dynamic charts with, 248-251
value filters for pivot tables, 275
variables, object variables in VBA, 364-365
VaryByCategories property (VBA), 402
VBA (Visual Basic for Applications), 357
  backward compatibility, 359, 367
  Chart Layouts gallery, 375-377
  Chart Styles gallery, 375-377
  chart titles in, 382
  chart types, 372-373
  comments in, 367
  creating charts, 368
  custom chart templates, 372-375
data bars, creating, 420-422
  enabling, 360

How can we make this index more useful? Email us at indexes@quepublishing.com
With and End With statements, 366
exporting charts as graphics, 413-415
exporting charts as images, 356
flexible data ranges, 363-364
Format Series dialog box
  bar of pie and pie of pie charts, 406-411
  bubble size settings, 411-412
  gap width and series separation settings, 400-402
  radial and surface charts, 412-413
  rotating and exploding round charts, 404-406
  secondary axis for series, 403-404
formatting charts, 382
  3-D format settings, 393-398
  3-D rotation settings, 388-393
  fills, 383-386
Format method, 382
glow settings, 386-387
line settings, 386
reflection settings, 387
shadow settings, 387
soft edge settings, 387-388
line continuation, 366
macro recorder, 362
object variables, 364-365
object-oriented code, 362-363
pivot charts, creating, 415-419
referencing charts, 367-368, 370-371
resizing and moving charts, 368-369
SetElement method, 377-382
sparklines, creating, 423-427
tools for, 361-362
Visual Basic Editor, 361
VBA and Macros for Microsoft Excel (Jelen), 359
Venn diagrams, modifying, 334
versions of Excel, 4
vertical axis, 39
  built-in choices for, 54
  formatting, 52-60
  labeling with XY series, 233-239
  manually adjusting scale of, 148-150
vertical axis title, 39, 45
vertical gridlines, 39, 60-61
viewing tolerance levels with error bars, 74-75
Villella, Kathy, 170-172, 440
Visual Basic Editor, 361
Visual Basic for Applications. See VBA (Visual Basic for Applications)
Visual Business Intelligence blog, 50
visual design stores, 56-58
The Visual Display of Quantitative Information (Tufte), 20
Visual Explanations: Images and Quantities, Evidence and Narrative (Tufte), 22
VLOOKUP function, 245-247
volume-high-low-close charts, creating, 204-206
volume-open-high-low-close charts, creating, 211-212
manually adjusting vertical axis scale, 148-150
resizing columns, 147
shifting series with blank series, 145-146
Web pages, exporting charts to, 355-356
websites
  charting blogs, 442
  charting tutorials, 441
  charting utilities, 443
  professional chart designers, 59-64
Windows, date/time storage format, 90-91
win/loss charts, 280, 285
With statement (VBA), 366
Woodbridge, George, 172
WordArt, 77, 316, 338-340
Word/PowerPoint 2010
  creating charts with data from Excel, 353-355
  pasting to
    with embedded workbook, 351-352
    as link, 345-349
    with original formatting, 349-350
    as picture, 352-353
    selecting paste options, 341-345
    with updated formatting, 350-351
worksheets, moving charts between, 228

X

X rotation in 3-D charts, 67
x-axis. See horizontal axis
Xcelsius, 72
XPS file format, exporting charts as, 357
XY scatter charts. See scatter charts

XY series
  labeling vertical axis with, 233-239
  multiple charts on single chart, 239-243

Y

Y rotation in 3-D charts, 67
y-axis. See vertical axis

years
  dates before 1900, 95-100
  plotting data by, 95

YTD sales, plotting with
  monthly sales, 114-116

Z

Zelazny, Gene, 104, 151, 182-185, 439, 440, 441

zero
  converting to NA, 433-434
  filling blank cells with, 267

zip code fields, misidentification in MapPoint, 310-311
zooming in MapPoint maps, 307-308