UI DESIGN with Adobe Illustrator

Discover the ease and power of using Illustrator to design Web sites and apps

Rick Moore
Design with Adobe Illustrator

Rick Moore
For Shelley, Cali, and Carice; my favorite girls in the whole world.
Acknowledgments

Writing a technical book is crazy hard, and this adventure would not have been possible without the help of so many people. First, thanks to my wife, Shelley, for her encouragement, support, understanding, and love as I undertook this wild endeavor. I could never have done this without you. Thanks to my daughters, Cali and Carice, for being patient while Dad was holed up in his office banging away at a keyboard for six months. Let’s go play now!

Huge thanks go to Denise Jacobs for tons of helpful advice and for putting me in touch with the right people to make this a reality. I never could have gotten it started without your help. Thanks to Victor Gavenda who got the ball rolling. Thanks to my superstar editor, Nancy Peterson, and her team, Stephen Nathans-Kelly and Darren Meiss, for all the time and effort spent bringing my words to life and making me sound like I know what the heck I’m talking about. Thanks to my tech editor, Tom Johnson, for methodically checking and questioning my instructions so that they make sense to you, the reader. Finally, thanks to Mimi Heft, Danielle Foster, and all the other production people working behind the scenes to make this book look great.

Thanks to all of my coworkers, friends, and professionals who provided ideas, feedback, and support before, during, and after the process: Colt Pini, Nic Johnson, Kaleb Tracy, Juna Duncan, Albert Candari, Jared Lewandowski, Ty Hatch, Michelle Barber, Clifton Labrum, David Lindes, Cameron Moll, and Khoi Vinh.

Thanks to my mentors who helped me immensely as I started my journey into the world of user experience: Gilbert Lee, John Dilworth, Rob Thomas, Todd Ericksen, and the entire NorthTemple team. You guys rock. I miss the old days.
Contents

Introduction viii

1 UI Design with Adobe Illustrator: An Overview 1
   It’s All About the Vector .................... 2
   Typography + Color = Power ................ 4
   Typography for UI Design ................... 4
   Powerful Tools for Color .................... 6
   Design for Consistency ...................... 7
   Layouts with Precision ..................... 10
   Conclusion .................................. 11

2 Tools and Panels 13
   Choosing Your Tools ........................ 14
   Selection Tools ............................. 16
   Selection Tool (V) .......................... 16
   Direct Selection Tool (A) ................... 17
   Group Selection Tool ....................... 18
   Magic Wand Tool (Y) ....................... 18
   Lasso Tool (Q) ............................. 19
   Drawing .................................... 20
   Pen Tool (P) ................................ 20
   Lines and Shapes ............................ 23
   Typography ................................. 25
   Type Tool (T) ................................ 25
   Transformation Tools ....................... 26

3 The Illustrator Workspace 43
   Reflect Tool (O) ............................ 26
   Free Transform Tool (E) ..................... 26
   Color ........................................ 27
   Gradient Tool (G) ........................... 27
   Eyedropper Tool (I) ......................... 29
   Fill and Stroke .............................. 29
   Workspace Tools ............................ 30
   Modes ....................................... 31
   Drawing Modes .............................. 31
   Screen Modes ............................... 32
   Panels ...................................... 34
   The Control Panel ........................... 34
   Expanding and Collapsing Panels .......... 35
   Workspaces .................................. 38
   Using a Custom Workspace .................. 38
   Conclusion ................................. 41

Go from Print to Pixels ...................... 44
   Choosing the Right Units ................... 44
   Optimizing the Color Space ................ 44
   Application Frame ........................... 45
   Working with Artboards ..................... 47
   Opening a New Document .................... 49
   Creating Artboards .......................... 51
4 UI Design Building Blocks

Guides Objectified
Creating Guides
Making Guides from Objects
Using Alignment Tools
Smart Guides
Alignment Guides
Anchor/Path Labels
Object Highlighting
Measurement Labels
Transform Tools
Construction Guides
Grids Made Easy
Creating a Grid
Making the Gridlines Fit
Applying the Grid to Multiple Artboards
Achieving Pixel Precision
Pixel Preview Mode
Aligning Objects to the Pixel Grid
Coordinates and Reference Points
Beginning the Layout
Typography for the UI
Looking Good on the Screen
Typesetting Basics

Adding the Final Headline

5 Getting Stylish with Graphics

Adding Style to Appearances
Using the Appearance Panel
Stacking Appearance Attributes
Creating and Editing Graphic Styles
Using Symbols
Creating a Symbol
Working with Symbols
Going Off the Pixel Grid
Creating an Application Logo
Enhancing the Hierarchy
Using Layers for Organization
The Layers Panel
Display Options
Creating Layers
Moving Objects Between Layers
Tightening Up the Layout

6 Finishing Touches

Taking Appearances to the Next Level
Illustrator and Photoshop Effects
Adding Old-School Style to the Page Header
Additive Styles .................................. 158
Additional Type Techniques .............. 162
Getting Text into Illustrator ............... 162
Area Type Options ............................. 164
Simulating Floats .............................. 166
Using Find and Replace ...................... 169
Working with Images .......................... 171
Preparing Images for Import .............. 172
Importing Images ............................. 173
Conclusion .................................... 177

7 Working Smarter 179

UI Design Planning ......................... 180
Creating a Site Map ......................... 181
Creating Wireframes ....................... 187
Communicate Your Design Intentions .... 190

Visualizing Interactions with
Storyboards ................................ 190
Adding Notes ................................ 199
Style Libraries .............................. 206
Create Color Schemes ...................... 207
Portable Colors, Symbols, and Styles ... 211
Templates .................................... 212
Getting Your Work Out of Illustrator ... 217
Presentation Mode ......................... 217
Exporting to Other Formats ............... 220
Saving PDFs ................................ 221
Save for Web ................................ 222
Conclusion .................................. 225

Index 226
Introduction

UI Design with Adobe Illustrator

I realize right off the bat that I am going to date myself here. I began my career as a graphic designer when the web was still in its infancy. I learned paste-up techniques and created marker comps before I ever knew that same stuff could be done faster on a computer. Once I got out of school, it became apparent very quickly that those skills, while useful, were pretty much obsolete. To get with the times, I bought myself the only computer I could afford at the time, a shiny new Wintel PC, added a copy of CorelDraw, and started down the path of digital graphic design. Little did I know that many years later my print skills would rarely be put into use. Right around that same time, I got an Earthlink account and started a web page on Geocities as a playground for learning HTML, which at the time was nothing more than a curiosity.

A Web Start

I bought my first Mac in 1998, then designed and built my first client website that same year (I.A). I used Photoshop to mock up the pages and slice up the graphics for a (gasp) table-based layout. Dreamweaver was utilized to write the markup. I remember the joy I experienced watching that first site come to life, as crude and unrefined as it was compared to what is possible today. In the many years since that first site, I have tried to hone my workflow to be the most efficient it could be, but have always struggled in finding a way that felt as fast as it was creative.

In recent years, my career has shifted into the field of interaction design and user interface design. All the skills I learned as a graphic and web designer were taken to a whole new level while creating UIs for web applications and mobile devices. Like many in my profession, I used Photoshop daily to complete my design tasks. I loved the program for its ability to create pixel-perfect mockups. The thing
I liked least about it was its lack of flexibility in performing said task. I did have another tool in my design quiver that I used often, but mostly as a supplement to Photoshop. That application was Adobe Illustrator, which I loved for its speed and its vector-drawing chops. I tried through several versions to use it for mocking up web pages and application UIs, only to end up getting no further than wireframes and ultimately reverting back to Photoshop to finish the job.

Then something marvelous happened. In early 2010, Adobe released Illustrator CS5 with some pretty spiffy pixel-related features. Despite the problems I’d had previously and after some hesitation in upgrading, I decided to give it a go. And wouldn’t you know it, the stars aligned and I was able to move my workflow to this tool without looking back. With the latest version, CS6, I have been able to become even faster and more efficient without ever hampering my creativity.
Who Needs This Book?

You might be a seasoned veteran and a Photoshop ninja, a budding designer fresh out of school, or someone with a good eye that needs help realizing their artistic vision. Whatever your background, this book aims to show you how to produce high-fidelity mockups in an extremely fast and efficient way. Although it covers some drawing techniques and tips for UI element creation, this is not a book that goes into great depth on how to create illustrative design. It’s more focused on how to fit the pieces of your design together into a cohesive structure in order to craft the experience. Readers of any experience level will be able to find useful information.

NOTE Notes are used throughout the book to alert you to important things to look for as you use an Illustrator tool or feature.

TIP Tips provide you with additional information or techniques.

Today’s websites and applications are so much different than they were when I started in the industry. For the web, HTML5 and CSS3 reduce the need for tons of graphics, and responsive design allows for those sites to adapt to the context of the device being used for browsing. I am firmly in the camp that in order to be a great designer, you need to know how to code what you design. It’s important to understand how to design for the screen—no matter the size—and understanding the code helps you do just that. It’s nothing like designing for the printed page. That being said, I don’t follow the crowd that believes design should happen solely in a browser. For me, it happens more quickly on paper first and then in Illustrator. The techniques I cover in this book have made me faster at trying different ideas for a design before I mark them up or send them to development.

Sidebars

Look in the sidebars to find information that more thoroughly explains a tool or feature, as well as the explanation of more advanced concepts.
An Air of Familiarity

If you have experience with Photoshop or InDesign, many of the concepts in Illustrator will seem very familiar. That’s by design. Most of the apps in the Adobe Creative Suite share user interface conventions so they’ll play well with each other (I.B), which makes the Illustrator learning curve much shorter. If you have never used any Adobe apps, all is not lost. You’ll find the learning curve, while somewhat steep, fun to tackle and relatively easy to master. Like anything else, it’s all about practice and patience. Once you get used to Illustrator, you’ll have a hard time wondering why you never used it for web or app design before.

By the way, I am a keyboard-shortcut junkie. As they say, you learn by repetition, so I will repeat keyboard shortcuts throughout the book so that they will be easy to learn and remember. I really dislike choosing commands from menus. If you get nothing else from this book than a head full of keystrokes, you will have gotten your money’s worth. That being said, I’ll be sure to provide a couple different ways to do something and let you decide which works best for you. (Hopefully it’s the shortcut route. Hint hint.)
Let’s Get Started!

As a designer, I’ve used Illustrator for creating illustrations and designing logos for the majority of my career. Coming from using other applications for web design, though, is where I had to “unlearn” many of the habits I developed during those years. If you have never used Illustrator before, you may have an easier time getting settled in. As you open the program for the first time, you may be a little uneasy. The interface is fairly utilitarian and can be daunting at first. You may be looking at the tools, panels, and a big blank screen thinking, “Where do I even start?”

All of this power helps create a flexible workflow that works for you, rather than forces you to conform to the app. Illustrator is fairly customizable, so you can arrange panels, tools, and menus to suit your style and flow. Because of its object-based nature, it’s easy to change your mind or experiment without fear.

I learn by doing, so this book teaches you how to use the tools in the creation of one screen of a UI mockup. Be sure to save your work as you go through the process. However, if you forget, you can download each stage of the mockup, as well as other helpful examples, by going to www.peachpit.com/UIwithAI. So, sit back, grab something refreshing to sip, and let creativity flow as you discover how to use Illustrator to realize your creative vision.
This page intentionally left blank
Chapter Overview

Up to this point, we've spent some time getting to know Illustrator's user interface. Now it's time to begin putting those tools into action and start creating a UI yourself. This chapter takes a look at the basic features that Illustrator provides for the building blocks of UI design:

- Using guides and alignment tools
- Creating page grids
- Achieving pixel precision
- Beginning a layout
- Setting type

You'll learn these features in the context of creating a screen for a mock web application for die-cast car collectors. The mockup has several elements: a sidebar that contains the app name, a search field, app navigation, and some activity info. It also has a section navigation bar and a main content area. It has some simulated browser chrome to finish it off. I'll show you how to create this over the next few chapters.
Guides Objectified

Every professional design application lets you set guides to help you align objects in your document. Alignment is one of the design principles that make any design just feel right. It brings cohesiveness into the layout. In Illustrator, there are two basic ways to use guides in your documents:

- Create an ad-hoc guide when you need to align several objects to a certain plane.
- Pull several guides out to create a layout grid.

By default, guides are “magnetic.” Dragging an object will cause it to snap to a guide once it gets within a certain pixel distance (4.1). This ensures that your objects will line up exactly as you want them. Alternatively, dragging a guide to a selected object will snap the guide to that object.

Guides will be helpful in the mockup for aligning graphic elements. You’ll explore Illustrator’s guides by first creating a new document for the mockup:

1. Choose File > New. In the dialog box, choose the Web profile.
2. Select 1024 x 768 as the artboard size and click OK to create the document. This size represents the target display resolution you’ll use for this mockup.
Creating Guides

Now that you have a document open, it’s time to create some guides. In order to create guides, you’ll need to make sure your rulers are visible. If they aren’t showing at the top and left side of the document window, choose View > Rulers > Show Rulers (⌘R/Ctrl+R).

1. Click and drag a guide from the ruler onto the artboard.

2. If you didn’t get the guide in just the right spot, undo the guide placement by doing one of the following:
   - Press ⌘Z/Ctrl+Z to undo the guide placement and try again.
   - Move the guide into place by selecting it and dragging until you have it positioned correctly. If you are unable to move the guide, it may be locked. Choose View > Guides > Lock Guides (⌘; [semicolon]/Ctrl+Alt+; [semicolon]) to unlock the guides. Selecting this menu option toggles the lock state on or off.

3. To remove a guide, simply select it and press Delete (make sure the guide is unlocked).

4. If you no longer need any guides in your document, or need to start over, remove them all at once by choosing View > Guides > Clear Guides.

**NOTE**  Guides are always visible by default; you can choose to show or hide guides as well. To do so, choose View > Guides > Hide Guides (⌘;/Ctrl+;) to toggle guide visibility. If your guides are hidden, the menu changes to read Show Guides.
Making Guides from Objects

Another awesome feature is the ability to make any vector object on the artboard into a guide. This is really helpful if you need to align objects at strange angles. This feature has a practical use:

1. Click and drag with the Line tool (\) and draw a line on the artboard.

2. Select the line and choose View > Guides > Make Guides (⌘5/Ctrl+5).
   
   You object is instantly turned into a guide, taking on all current attributes you have set for your guides (such as snapping behavior, visibility, lock state, and color). This is a great way to align objects already on your artboard to an angle without having to measure (4.2).

You can also convert any guide—whether you pulled it from a ruler or created it from an object—into an object:

1. Make sure that guides are unlocked (⌘; [semicolon]/Ctrl+Alt+; [semicolon]). You won’t be able to select them otherwise.

2. Select the guide you want to convert and choose View Guides > Release Guides (⌘5/Ctrl+Alt+5).
   
   The guide is now an object, selected and ready for you to work with.
Using Alignment Tools

Besides allowing you to snap and align objects to guides, Illustrator also provides powerful alignment features accessible via the Align panel (Shift-F7). This panel (4.3) helps to align objects to an axis or position as well as distribute them across a distance. A few of the more commonly used alignment features can also be accessed in the Control panel when you have more than one object selected.

The buttons in the top row of the Align panel align objects by their edges and centers along the horizontal and vertical axes. The buttons provide a graphical representation of how Illustrator will align the selected objects.

The buttons in the bottom row of the panel distribute objects across a distance based on the axis or edge that the user has chosen. This is very different from aligning objects. Instead of lining them up along a single edge or center, Illustrator will equally space the objects from the edge or center you clicked.

You can make a couple of extra options (4.4) visible by choosing Show Options from the Align panel menu. The first of these options, Distribute Spacing, distributes objects across a distance by putting an equal amount of space (which can be user-specified) between them.
The second button houses the Align To options. These options allow you to choose how objects will align in the following ways:

- **To the selection (the default behavior):** The selection in this option represents the area in which all selected objects are contained. For example, if you have four rectangles and you want to align all of their left edges, clicking the align left button would move all but the leftmost rectangle.

- **To the artboard:** This option aligns objects to centers or edges of the artboard itself. This alignment method is best used when you want to center a single object or a selection of objects on the artboard.

- **To a key object:** This option allows you to select an object to which all other objects in the selection will align. This method is best used when the object you want to align to needs to stay in place.

To designate an object in your selection as the key object, perform the following steps:

1. Select all objects (including the one that will be the key object) you want to align either by dragging a selection box around them or by Shift-clicking each object.

2. Set the key object for the selection by clicking it.

   The key object is always indicated by a bold selection outline (4.5).
Illustrator has another type of guide called a Smart Guide. Instead of being just a static object to which you can align something, smart guides are dynamic and provide useful feedback as you draw. There are six different types of Smart Guides you can set up in the Preferences dialog box (4.6). You can enable as many of these guides as you’d like, or disable them altogether. You may find it a little intrusive to have these guides on all the time; you can toggle the guides on or off by choosing View > Smart Guides (⌘U/Ctrl+U).

What follows is a description of how each type of Smart Guide works. Play around with each of the settings to see which ones work best for your workflow.
Alignment Guides

Alignment guides help you to align objects while drawing, moving, or editing. They help you align objects and anchor points to the centers and/or edges of nearby objects (4.7) without having to pull guides from the ruler.

Anchor/Path Labels

Anchor/path labels appear as you hover over an object to let you know whether you have an anchor point, path, center point, or edge of an object under your cursor. This really aids in making selections once you have a more complex design (4.8).

Object Highlighting

With the Object Highlighting Smart Guide enabled, objects are highlighted with a selection outline as you hover over them. Again, this Smart Guide is most useful when you have a lot of objects on the artboard, as it allows you a preview of what object will be selected when you click. It also allows you to see objects that have live effects applied, as seen in 4.9.
Measurement Labels

Measurement labels display the size, distance, and position of objects as you draw, move, or edit them (4.10). It helps you to be really precise with layout and placement in context.

Transform Tools

Transform tools display guides when used with the Rotate, Scale, or Shear tools (4.11). These guides help to constrain these transformations to common angles when drawing, so you don’t have to use the Shift key to do the same thing.

Construction Guides

When drawing with the Pen tool, construction guides help to constrain line segments to specified angles (4.12). You can choose a preset angle group or specify your own custom angles (see 4.6).
Grids Made Easy

Over the last several years much discussion has taken place about using traditional grids in web design. Articles and books by designers like Mark Boulton and Khoi Vinh have helped us learn and understand how to use grids effectively to create beautiful designs for the screen. Constraints in design can be a pain and a blessing at the same time. Creating a grid is an essential task that will enable a foundation on which to build a consistent design scheme.

How do we create grids today? I’m sure designers everywhere use a lot of different methods, including not using a grid at all. Typically, though, we painstakingly create a grid by dragging guides from rulers and trying to place them consistently on the page.

My old process for creating a grid was ridiculous. I used to draw a couple of rectangles, one for the column width and one for the gutter, and then copy and paste them end to end across the page. I’d use those as markers.

Grid Resources

Here are links to two really good resources on designing grids for the web:

- “Simple Steps to Designing Grid Systems” by Mark Boulton: http://d.pr/OkyC
so that I would know where to snap my guides. Every new page I would create would need to use the grid; worse, I would often have multiple files or grid layers on sites that called for the use of more than one grid. If those grids ended up changing, frustration would ensue.

Fuss no more, as Illustrator can help make you more productive by not only letting you create a single grid easily, but also allowing you to maintain multiple grids in a single document.

Creating a Grid

You’ll start the mockup for Wheelr by creating a standard 950 pixel-wide grid with 24 columns and 10-pixel gutters. This grid will sit in the center of the 1024 x 768 document you created earlier, defining the “safe” area in a browser or tablet device. In the past, I would have done all kinds of math (which I’m no good at) to figure out how wide the columns and gutters needed to be so that the measurements were in whole numbers. Thankfully, there is a feature in Illustrator that will do these tricky calculations automatically.

1. Start by choosing View > Guides > Clear Guides to remove all the guides. This will give you a clean slate from which to begin.
2. Draw a 950 (W) x 768 (H) rectangle, give it a color of your choosing, and align it to the center of the artboard (4.13) using the Align to Artboard feature.

3. Choose Object > Path > Split Into Grid. The resulting dialog box allows you to choose settings for this particular grid.

4. Under the Columns section, enter 24 in the Number field and 10 px in the Gutter field (4.14).
5. Select the Preview option to see what’s being created, and select the Add Guides option so you don’t have to add your guides manually afterwards. Click OK. The rectangle you started with is now divided into 24 rectangles (4.15). The grid and the rectangles should all be selected at this point.

6. Press and hold the Shift key and click the guides to deselect them.

7. The extra rectangles are unnecessary at this point, so press Delete to get rid of them.

**NOTE** When creating the grid, make all the settings whole-pixel numbers.

4.15 A standard 24-column grid.
4.16 Select the top anchor points of the grid with the Direct Selection tool.

4.17 Move the anchor points to the edge of the artboard.

**Making the Gridlines Fit**

Now you have a nice 24-column grid. The last thing to do at this point is resize the gridlines so they fit nicely on the artboard. It’s an optional step, but it helps when you have multiple artboards so you don’t have grids overlap other artboards. To make them fit, follow these steps:

1. With the Direct Selection tool (A), drag to select all the anchor points on the top of the grid (4.16).

2. Use the arrow keys to nudge the anchor points until they sit at the top of the artboard (4.17).

3. Repeat for the bottom side so that all the vertical grid lines fit within the bounds of the artboard.

4. With the Direct Selection tool (A), select the two horizontal gridlines by clicking on their respective line segments. Press Delete twice to remove these two horizontal lines, as you do not really need them.

5. Press ⌘S/Ctrl+S to save your work.

**NOTE** When you select a line segment with the Direct Selection tool, the segment is selected, but the anchor points on each end are not. Pressing Delete removes only the segment; pressing Delete again removes the anchor points.
Applying the Grid to Multiple Artboards

You started with one artboard; as you begin to design more of the application, you may need to create multiple artboards in this single document. This 24-column grid is versatile enough to be useful on every page of the app. The question remains: How can you get this grid on every artboard in the document without having to copy and paste to each, or worse, recreate the previous steps on each artboard? The answer is stunningly simple.

1. Click the New Artboard button at the bottom of the Artboard panel three times to add three more artboards to the document.

2. Select the grid with the Selection tool (V).

3. Choose Edit > Cut (Cmd/Ctrl+X) to cut the grid to the clipboard.

4. Choose Edit > Paste on All Artboards (Cmd/Ctrl+Alt+Shift+V) . This brilliant shortcut pastes the grid to every artboard in exactly the same spot as where it was cut.

To add some variety to the layout, create a different grid for the landing page than you would on the rest of the application. All you would need to do is delete a grid from one of the artboards and follow the steps to create a new grid with different properties. When it comes to grids, Illustrator allows precision, speed, and flexibility. By using these tools, you’ll find it easier to create and maintain grids than ever before.
Achieving Pixel Precision

I used to be a diehard Photoshop user. But I became frustrated with how difficult creating and maintaining large projects was with it and wanted a more efficient tool for my web design projects. I had tried several times over the last ten years to use Illustrator for web and UI design, only to be stopped in my tracks by the one thing that killed it—the lack of pixel-precise drawing features. My designs suffered from unwanted anti-aliasing (heretofore referred to as “fuzzy-edge syndrome”) and a general lack of character that Photoshop made easy. Chances are you fit in this same camp; that may be the reason you’re reading this book right now.

I made the switch for good when Adobe rolled out Illustrator CS4 in 2008. It turned out that Illustrator already included a few features for enabling pixel precision, I just didn’t know those features were available or how to use them. Once I got it figured out, it was easy to walk away from Photoshop (for UI design, at least) for good. With CS5 and CS6, Adobe has made creating pixel-precise designs even easier (4.18).

4.18 The left side of the button suffers from fuzzy-edge syndrome. The right side is crisp thanks to the pixel-snapping features in Illustrator CS5 and later.
Pixel Preview Mode

The first feature Illustrator provides for ensuring pixel-precise artwork is Pixel Preview mode (⌘Y/Ctrl+Alt+Y). The default Preview mode in Illustrator allows you to view your artwork as it would print. Objects are smooth and crisp no matter how far you zoom into your design. This mode is perfect for creating illustrations, logos, typography, or other illustrative elements that don’t need to be pixel-precise.

However, when creating UI elements like buttons, widgets, or rules, using Preview mode paints an unrealistic picture of how these objects appear on the web or mobile devices, with the exception of newer ultra-high resolution devices. Using Pixel Preview mode renders your design on the screen at 72 pixels per inch, just like a raster-based application such as Photoshop would. When you zoom in, you can see how your objects and effects look on a bitmap display (4.19). This is referred to as anti-aliasing. The application inserts extra pixels of related colors to simulate a smooth curve.

Pixel Preview mode is great as a diagnostic tool, perfect for visualizing how your artwork will render on the low-resolution displays that are still fairly common today. It’s great for viewing how Photoshop and Illustrator effects (to be discussed in Chapter 6) render on the screen. If you are a Photoshop user, you can also use it as your full-time view mode to provide some comfort and familiarity as you try to switch.
Aligning Objects to the Pixel Grid

In Illustrator’s application preferences (⌘K/ Ctrl+K), you can specify and view a customizable document-wide grid that is akin to graph paper (4.20). This is separate from the guide-based grid you created in the last section. However, in my opinion, this extremely loose yet very restrictive grid structure is really only useful for technical drawings. It’s also inefficient, because it can be visually intrusive and has to be toggled on and off manually.
Since the end product of UI design is viewed on a pixel-based screen, it makes sense that it should be designed to match a pixel-based grid. Illustrator’s answer for that need is the pixel grid. This grid is separate from both the document-wide grid and the guide-based grid. It’s made up of one-pixel increments and allows for extremely precise drawing. In Pixel Preview mode (Cmd+Y/Ctrl+Alt+Y), this grid is viewable when you zoom in to 600% or closer (4.21).

One of the newest features to take advantage of this grid is the ability to seamlessly and automatically align objects to the pixel grid as you draw. It enables you to keep your objects from having fuzzy edges in Pixel Preview mode by snapping the dimensions to whole-pixel values. Fuzzy-edge syndrome occurs when an object is either sized at sub-pixel increments (for example, a width of 400.3456 px) or sits on a sub-pixel X or Y point. Since Illustrator is a vector-based program, you have the ability to size and place artwork anywhere on the screen with up to 3-decimal-point precision, which can be helpful when creating print documents.

Since displays use pixels to render artwork, placing an object off of the pixel grid will cause it to blur; the screen can’t color half of a pixel, so it anti-aliases it in order to keep pixel from looking jagged, which is where the fuzzy edge comes in. Keeping your objects on the pixel grid by having whole numbers in the object dimensions ensures that your artwork will render without fuzzy edges, appearing exactly the way you’d expect it. It’s especially helpful when dealing with strokes.

4.21 The pixel grid (which is filled in to show pixel detail) is displayed when in Pixel Preview mode and zoomed in closer than 600%.
You can enable or disable pixel alignment in a three ways:

- You can set pixel alignment on or off in the advanced section of the New Document dialog box when creating a new document (4.22).

- If you didn’t turn the setting on when you created a new document, you can do so at any time from the Transform panel menu (4.23).

- You can control pixel alignment on an object-specific basis by toggling the option in the Transform panel’s options pane (4.24). You can view these extra options by choosing Show Options from the Transform panel menu.

Since pixel alignment is a fairly new feature, opinions vary on whether you should let Illustrator control pixel-precise placement or whether you should turn the feature off and manage it yourself. I feel that as you begin to design UIs with Illustrator, you’ll find the method that works best for you.
Coordinates and Reference Points

The Transform panel can also be a great tool to aid in achieving pixel-precise artwork. The Transform panel contains four fields: two for positioning elements according to values on the X and Y axis, and two for setting the width and height of an object. It also has the reference point locator, which is used for setting the point on an object that will act as the anchor for transformations (like rotations or scaling). You’ll also find these fields in the Control panel when an object is selected (4.25).

It’s really easy to use coordinates to precisely place your artwork anywhere on the artboard. This is a perfect opportunity to begin working on the Wheelr mockup. The first thing you need to do is add the simulated browser chrome. This has been created as a separate file that can be linked in this document via the Place command:

1. Using the document created earlier in the chapter, select Artboard 1 in the artboard navigator. This will place the artboard in the view and make it active.
2. Download the simulated browser chrome file at: www.peachpit.com/UIwithAI/ch4/browser-chrome.ai. Once you’ve downloaded the file to your computer, choose File > Place.

When you import an element using the Place command, it’s dropped in the center of the current view based on its origin point (4.26). Since the object needs to be at the top of Artboard 1, using the X and Y value inputs in the Control panel will be the most precise way to get the object in place. The reference point locator in the Control panel shows the current origin point to be the center of the object.
3. Select the object and click the top left square on the reference point locator to change the object’s point of origin (4.27).

The X and Y values in the Control panel will change to reflect the new reference point. This doesn’t affect the placement of an object; rather, it shows the location of that particular point.

4. Type 0 into the X and Y input fields in the Control panel.

Because the placed object’s reference point was the top-left corner, using zero for the x and y fields moves that point in the top-left corner of the artboard.

---

**The Mathematician Within**

The X, Y, W, and H input fields in the Transform panel and Control panel are much smarter than they initially appear. First, they will allow you to specify a particular unit of measure without changing the ruler units. For example, if you were working with pixels and wanted to make an object two inches wide, you would perform the following step:

1. Type 2 in the W (width) field and press Enter/Return. Illustrator resizes the object and automatically converts the units to pixels.

Second, you can use the Transform inputs to do math.

2. To make an object 150 percent larger, add *150% or *1.5 after the existing number (4.28) in the field and press Enter/Return. You can add, subtract, and divide using the same method.

If you want to resize an object proportionally, hold down the ⌘/Ctrl key as you press Enter/Return. Illustrator will adjust the width or height in proportion to what you entered.

---

4.27 Change the origin point of an object with the reference point locator.

4.28 You can use the Transform inputs to perform math equations.
Beginning the Layout

Now that you have a grid and the browser chrome in place, you can start putting together the design of the screen. In this chapter, you’ll begin by putting in the main structural divisions for the UI as well as the basic typography.

First, you’ll create the sidebar area. This will hold the logo, main navigation, and social features for the app:

1. Draw a rectangle on the left side of the artboard. If the object has a stroke, remove it and set the fill to #2d2d2d.
2. With the rectangle selected, use the width and height fields in the Control panel to make the rectangle 267 px wide and 674 px tall. Place it at the far left of the artboard and under the browser chrome (4.29).
3. Within the sidebar, draw a 49 px wide by 49 px tall square and give it a black fill and no stroke. This will act as the thumbnail image for a Suggested Friends feature.

4. Draw another rectangle that starts under the chrome and just to the right of the sidebar. It should be 38 pixels tall and the width of the remaining area. Set the fill of this rectangle #000000 (4.30). This will be the section navigation bar.
5. Draw a rectangle that fills the remaining space in the artboard. Give it a color of #e6e6e6 (4.31). This will be the main content area.

6. Press ⌘S/Ctrl+S to save your work.
Lining Up Strokes

Filled objects are easy to line up on the grid, but objects with strokes pose a problem. When using strokes on objects, Illustrator places the stroke across the line segment. This means that a one-pixel stroke will cover half a pixel on each side of the line segment. Using pixel alignment on the object will prevent the stroke from looking fuzzy in Pixel Preview mode, but the fact that the stroke is placed over the line segment isn’t accurate to how the object will render in a browser.

In HTML/CSS, the browser box model renders all borders on the outside of the object. To stay true to this rendering, you’ll want to have your strokes in Illustrator do the same thing so that you have accurate measurements for development. To demonstrate how to do this, you’ll create the picture frame for the car photos in the mockup.

1. Draw a 142 px x 142 px rectangle in the content area of the mockup and give it a white fill and a 4 px black stroke.
   If you zoom in, you’ll notice how the line segment sits smack dab in the middle of the stroke (4.32).

2. Select the rectangle and click the Stroke link in the Control panel (4.33).
3. Click Align Stroke to Outside (4.34).

Now the rectangle looks the way it’s supposed to, with the stroke outside the object (4.35).

Things work a little differently with open objects and rules. Aligning a stroke to the inside or outside is not enabled for these objects. Because you have pixel alignment enabled, the stroke will automatically move to the nearest pixel to keep from getting fuzzy-stroke syndrome:

1. Select the Line Segment tool (\) and draw a 223 pixel-wide horizontal rule in the sidebar. Remove the fill and give it a 1 px stroke, with the color set to #1d1d1d. This stroke will be used as a dividing line between sections in the sidebar.

2. Turn on Pixel Preview mode by selecting View Pixel Preview (⌘Y/Ctrl+Alt+Y).

3. Zoom in to view how the stroke automatically adjusts to stay on the pixel grid (4.36).

4. Press ⌘S/Ctrl+S to save your work.

**NOTE** For more information on the browser box model, go to http://d.pr/wdCS.
Typography for the UI

With the main structure created, it’s time to move on to typography. Good typography in a UI can emphasize and give clarity to app structure and hierarchy. In some applications, it can actually be the interface itself. If you have experience in setting type for print documents, there are some factors you need to consider when you’re setting type for a UI.

Looking Good on the Screen

First, you’ll need to think about font choices. You can use web fonts from sources like FontSquirrel (http://www.fontsquirrel.com) or the standard fonts that come with every Mac or Windows system. For system fonts, there is some parity between the two. Choosing a font that both systems have will ensure a similar experience no matter the platform. Make sure to use the same font in your mockup that you are going to use in the final UI.

The next thing to consider is how your type will render on the screen. One of the big pushes in the UI design world is for a tool that will render type the same way as it does in the browser. While I think that is a great idea, it’s difficult for me to imagine it happening anytime soon, simply because of all the variables that go into displaying type on a screen. You have the browser or app rendering engine, screen resolution, computer platform, and quality of typeface working against this idea. In the meantime, my philosophy is to get as close as I can in Illustrator and let the screen do what the screen will do.
That said, Illustrator recently inherited a feature from Photoshop that makes type rendering even better. You can now set the anti-aliasing method of the typeface you’re using to get better results for type destined for the web or mobile devices. There are subtle differences in the way each method affects your type. 4.37 shows a comparison of the four modes on Helvetica Neue.

You’ll see how it works in the real world by adding a current section headline to the navigation bar in the mockup. To make things easier to see for now, go ahead and hide your guides by choosing View > Guides > Hide Guides (⌘;/Ctrl+;).

1. Select the Type tool (T) and set some point type by clicking once in the navigation bar. Type The Latest as the name of this section. Press Escape to leave type-editing mode.

Illustrator defaults new text to Myriad Pro, which always seems to render well. However, since I don’t have a web font license for Myriad and not everyone using the app will likely have it installed on his or her system, you’ll change it to something else.
2. With the Selection tool (V), click once on the text to select it and then click the Character link in the Control panel. This will reveal the Character panel.

3. Choose Helvetica Neue Bold from the font list. If you don’t have Helvetica, choose Arial Bold instead.

4. Change the size to 18 px and give it a white fill by clicking the white swatch in the Swatches panel.

   These typefaces really highlight the wonky rendering effects of the Sharp anti-aliasing mode (4.38).

   At the bottom right of the Character panel is a drop-down menu of anti-aliasing options (4.39).

5. Choose the Crisp setting from the drop-down menu.

   The Sharp setting is the default, and I have found after a lot of experimentation and comparison that the Crisp setting will give you the best results the majority of the time.
Typesetting Basics

Now that you have type rendering looking good, you’ll get the rest of the type into the mockup. You will use a mixture of point type and area type so you can get the feel for how and when to use each.

Using Point Type

Start by finishing off the section navigation bar:

1. Select the Type tool (T) and click once in the navigation bar you created earlier to set a point type object. Type Your Crew as one of the navigation items.

2. When you’re finished, press Escape. This is the fastest way to exit text-editing mode.

3. Finish off the navigation by typing You and Everybody with point type.

4. Select all three blocks of type and use the Character panel to make them Helvetica Neue Bold (or Arial Bold) at 12 px. Give them a white fill.

5. Move the type into place so that it matches the type in 4.40. You don’t need to be precise at this point since you are still in the rough stage of the layout. Things could change as you move on.

Now complete the text for the sidebar.

TIP Using point type as opposed to area type for horizontal navigation elements gives you much more flexibility in moving, aligning, and spacing the individual blocks of type.
6. For the main app navigation, click once with the Type tool and type Collection, Crew, and Profile. Use a hard return after each word with the Return key so that each word is on its own line (4.41).

7. With the area text still selected, select the Eyedropper tool (I) and click the section headline text, The Latest.

Not only does this trick make styling your text fast and easy, but it also ensures consistency in the UI. Just like you don’t want to use too many different fonts in a document, using too many different sizes and styles can make a layout look cluttered and inconsistent.

TIP For vertical navigation elements, it’s easier to keep all the text in one block as opposed to separate ones. You can use leading and paragraph spacing to manage the distances between elements here in a way that is easy to replicate in HTML.

Using Area Type

For the Activity section of the sidebar, we will stray away from point type and use area type instead. The text in this section may end up being lengthy, so we want the line wraps to happen automatically like in the browser.

1. To set a block of area type, select the Type tool (T), and then click and drag a rectangle in the sidebar (4.42).

2. Type the lines from 4.43 in the text box, using a hard return between each line.
3. Style this text using Helvetica Neue (or Arial) at 12 px. Give it a white fill if it doesn’t already have one. Press Escape to exit text-editing mode.

Using area type allows you to constrain the width of a type container automatically. But how do you resize a container once it’s set? There are two ways to accomplish this:

- To manually adjust the width or height, use the Direct Selection tool (A). This will allow you to select a single segment of the container and then either drag it or use the arrow keys to resize it.

- If you know precisely what size you’d like the container to be, select the text and choose Area Type Options from the Type menu. In the dialog box that appears, you can input exact numbers for height and width.

4. To simulate the link in the activity text, double-click the type container with the Selection tool (V). This is another handy way to edit text without having to click the Type tool first.

5. Click and drag over the first couple of words to select them (4.44).

6. In the Character panel, click the Underline button (4.45).
Adding the Final Headline

You’re almost done with the first iteration. Now you’ll add the final headline for a Suggested Friends feature in the sidebar and a label for the picture frame in the content area (4.46).

1. Click with the Type tool (T) just above the small black square in the sidebar. Type Popular Collectors.

2. Style this text with the Eyedropper tool (I) by clicking the text that reads “The Latest.”

3. Use point type to create a label called Image Title for the picture frame box in the content area.

4. Style this text with Helvetica Neue Bold (or Arial Bold) at 12 px.

5. With the text still selected, choose the Eyedropper tool and click the section navigation rectangle.

You used the Eyedropper tool before to pull the color and type attributes from another text element. You can also color your text by pulling the color from a shape. Again, this helps keep consistency in the interface.

6. Press ⌘S/Ctrl+S to save your work.

**TIP** You can use the Eyedropper tool to pull the color from any object. To pull a color from a portion of a gradient or a placed bitmap image, hold the Shift key while you click the color you want to sample.
Creating Character Styles

You’ll need to take care of one final detail before you move on. Creating character styles now will help out immensely as you add more text to the mockup. Character styles save text-formatting information in a way that it can be applied to other text elements with a click.

To create a character style:

1. Select the text to use as the basis for the style. For this example, choose the section navigation headline, “The Latest.”

2. Open the Character Styles panel either from the panel groups onscreen or by choosing Window > Type > Character Styles.

3. Click the Create New Style button (4.47). The new style appears in the panel list with the name “Character Style 1.” Rename it so it’s easier to figure out later when you need to use it.

4. Double-click the style in the list and rename it H1. Press Enter. That was easy! If you need to edit the formatting options of the style, choose Character Style Options from the panel menu. In the dialog box that appears, you can edit pretty much any formatting attribute you need (4.48).

5. Create character styles for the other text elements as you see fit.
The Character Style Options dialog box

4.48 The Character Style Options dialog box

- Style Name: [Input Field]
- General
  - Style Settings: [Normal Character Style] +
    - Basic Character Formats
      - Font Family: Helvetica Neue
      - Font Style: Bold
      - Size: 16 px
      - Leading: 22 px
      - Kerning: 0 (zero)
    - Advanced Character Formats
      - Character Color
      - OpenType Features

- Preview
- [Reset Panel] [Cancel] [OK]
4.49 The mockup for Wheelr … so far
Conclusion

Go ahead and place the last few elements to match 4.49. It may not look like much right now, but don’t be discouraged. Creating a good user experience happens best in layers. It’s vital to make sure that you have the right content and have thought through the interactions before you start thinking about style. Once you have those things figured out, you can move on to creating and polishing the UI.

You began with a wireframe by creating the basic shapes and setting the type. In the next chapter, you’ll learn how to use graphic styles and symbols to speed up UI element creation. You’ll also learn how to take advantage of layers to organize your artwork.

<table>
<thead>
<tr>
<th>TABLE 4.1 Keyboard Shortcuts in This Chapter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/Hide Rulers</td>
</tr>
<tr>
<td>MacOS: R</td>
</tr>
<tr>
<td>PC: Ctrl+R</td>
</tr>
<tr>
<td>Undo</td>
</tr>
<tr>
<td>MacOS: Z</td>
</tr>
<tr>
<td>PC: Ctrl+Z</td>
</tr>
<tr>
<td>Hide/Show Guides</td>
</tr>
<tr>
<td>MacOS: ;</td>
</tr>
<tr>
<td>PC: Ctrl+;</td>
</tr>
<tr>
<td>Lock/Unlock Guides</td>
</tr>
<tr>
<td>MacOS: ;</td>
</tr>
<tr>
<td>PC: Ctrl+Alt+;</td>
</tr>
<tr>
<td>Make Guides</td>
</tr>
<tr>
<td>MacOS: 5</td>
</tr>
<tr>
<td>PC: Ctrl+5</td>
</tr>
<tr>
<td>Release Guides</td>
</tr>
<tr>
<td>MacOS: 5</td>
</tr>
<tr>
<td>PC: Ctrl+Alt+5</td>
</tr>
<tr>
<td>Copy</td>
</tr>
<tr>
<td>MacOS: C</td>
</tr>
<tr>
<td>PC: Ctrl+C</td>
</tr>
<tr>
<td>Align Panel</td>
</tr>
<tr>
<td>MacOS: F7</td>
</tr>
<tr>
<td>PC: Shift+F7</td>
</tr>
<tr>
<td>Show/Hide Smart Guides</td>
</tr>
<tr>
<td>MacOS: U</td>
</tr>
<tr>
<td>PC: Ctrl+U</td>
</tr>
<tr>
<td>Save</td>
</tr>
<tr>
<td>MacOS: S</td>
</tr>
<tr>
<td>PC: Ctrl+S</td>
</tr>
<tr>
<td>Cut</td>
</tr>
<tr>
<td>MacOS: X</td>
</tr>
<tr>
<td>PC: Ctrl+X</td>
</tr>
<tr>
<td>Paste in Place</td>
</tr>
<tr>
<td>MacOS: V</td>
</tr>
<tr>
<td>PC: Ctrl+Shift+V</td>
</tr>
<tr>
<td>Paste on All Artboards</td>
</tr>
<tr>
<td>MacOS: V</td>
</tr>
<tr>
<td>PC: Ctrl+Shift+Alt+V</td>
</tr>
<tr>
<td>Pixel Preview Mode</td>
</tr>
<tr>
<td>MacOS: Y</td>
</tr>
<tr>
<td>PC: Ctrl+Alt+Y</td>
</tr>
<tr>
<td>Preferences</td>
</tr>
<tr>
<td>MacOS: K</td>
</tr>
<tr>
<td>PC: Ctrl+K</td>
</tr>
</tbody>
</table>
Index

A
Actual Size keyboard shortcut 63
Add Anchor Point tool 21–22
Adobe Flash, exporting artwork to 220
Adobe Illustrator
  versus Photoshop
    canvases versus artboards 51
    color settings 45
    effects 142–144
    pixel preview 49
  vector- versus raster-based graphics 2–3
Adobe InDesign, Adobe Swatch Exchange
  format 211
Adobe Photoshop
  Adobe Swatch Exchange format 211
Effect menu
  Document Raster Effects Settings (DRES) 144, 154–157
  list of effects 143
  using 150–153
exporting artwork to 220
  versus Illustrator
    canvases versus artboards 51
    color settings 45
    effects 142–144
    pixel preview 49
  images, editing before placing in
    Illustrator 172
  raster-based applications 2
Adobe Swatch Exchange format 211
alignment
  Align panel
    keyboard shortcut 103
    options 69–70
to artboard 70, 76
  Distribute Spacing option 69
  with guides 66
  to key objects 70
  to objects 72
  to pixel grids 50, 82–84
  point type 96
  to selections 70
  Smart Guides
    anchor/path labels 72
    basics 71
    keyboard shortcut 71, 225
    strokes
      within objects 91–92
      to outside 92
tools 69
anchor/path labels, Smart Guides 72
anti-aliasing 4–5
  Character panel 94–95
  pixel-precise drawing 80
type 94
typography advancement 4–5
Appearance panel/attributes 114.
  See also color/color tools; Effect menu
    (Illustrator)
basics 106
Clear Appearance 158
definition 8
fills/strokes 91–92, 107–108, 115
keyboard shortcut 106
Mixed Objects 147
Opacity settings 110–111, 116, 118
Path layer 109
Swatches panel 108
Application frame 45–46
Arch Warp effect (Illustrator) 115–116
area type 97–98
Area Type options 98
versus point type 96
using 97–98
wrapping text 164–167
Area Type tool 25
artboards 47–48
aligning to 70, 76
applying grids to multiple 79
Artboard tool
basics 52
keyboard shortcut 30, 63
Artboards panel 54
Control panel 53
creating 51–52
from Control panel 53
from existing objects 56
from New Artboard button 79
duplicating 55, 123
exporting to
Flash 220
JPEGs 220
Photoshop 220
PNGs 220
Presentation mode 217–219
moving 58–59
with artwork 55, 60
naming 57
navigating multiple 61–62
rearranging 60
saving
as PDFs 221–222
for web 222–224
Artistic effects (Photoshop), Film Grain 143, 150–151

B
Blur effects (Photoshop) 143
Gaussian Blur 154, 157
Boulton, Mark 74
bounding boxes keyboard shortcut 16
Bring to Front keyboard shortcut 167, 177
Brush Strokes effect (Photoshop) 143

C
Change Screen Mode tool 32
Character panel/styles
anti-aliasing modes 94–95
style guides
creating templates from 216
using in other documents 211
styles, creating 100–101
tools 6–7
Tracking field 128
underlining 98
CMYK color mode 49
Colborne, Giles 180
Color Guide panel 6
Color Settings
basics 44–45
keyboard shortcut 63
color/color tools
Appearance panel
Color panel 108, 114
Color Picker/color options 107–108, 110
CMYK 49
color groups
saving in style guides 211
templates from 215
color schemes 7
Color Settings
basics 44–45
keyboard shortcut 63
color/color tools (continued)
  Edit Colors menu  176
  Eyedropper tool  29
    keyboard shortcut  41
    sampling color  99
  Fill and Stroke tools  29, 41
  Gradient tool  27–28, 41
  RGB color mode  49
    Web Safe RGB  111
  sampling  29, 41, 99
  swatches  7
    templates from color swatches and groups  215
  typography  4, 6
    workspace organization  46–47
  construction guides  73
  Control panel basics  34–35
  Convert Anchor Point tool  21–22
  Convert to Shape effect (Illustrator)  143
  coordinates  85–87
  Copy keyboard shortcut  103
  Crisp setting, anti-aliasing options  95
  Crop Marks effect (Illustrator)  143
  CSS (cascading style sheets) and Illustrator effects  107–108, 113
  Cut command
    basics  79
    keyboard shortcut  103

D

  Delete Anchor Point tool  21–22
  Deselect keyboard shortcut  19, 158

The Design of Everyday Things  180
Designing for Interaction: Creating Smart Applications and Clever Devices  180
Designing Interfaces: Patterns for Effective Interaction Design  180
Designing the Moment: Web Interface Design Concepts in Action  180
Designing the Obvious: A Common Sense Approach to Web & Mobile Application Design  180
  developers and communication, with storyboards  190–198
  adding color and style  202–205
  inserting notes  199–201
Direct Selection tool
  basics  17
  gridlines  78
  keyboard shortcut  41
  Distort & Transform effects (Illustrator)  143
    Transform  115–116, 159–161
  Distort effect (Photoshop)  143
  Distribute Spacing alignment option  69
  Document Raster Effects Settings (DRES)  144, 154–157
documents
  new
    basics  49
    keyboard shortcut  63
    profiles
      saving new  50
      Web and Print  49
Don’t Make Me Think: A Common Sense Approach to Web Usability  180
  Draw Behind mode  31
  Draw Inside mode  31
  Draw Normal mode  31
  Drawing modes
    basics  31
    keyboard shortcut  41
drawing tools
  Add Anchor Point  21–22
  Convert Anchor Point  21–22
  Delete Anchor Point  21–22
Ellipse basics 23 keyboard shortcut 41
Line Segment basics 23 keyboard shortcut 41
Smart Guides 185–186
Pen basics 20–22 construction guides 73 keyboard shortcut 41
Polygon 23–24
Rectangle basics 23–24 keyboard shortcut 41 rounded corners 109
Star 23–24
DRES (Document Raster Effects Settings) 144, 154–157
Drop Shadow Stylize effect (Illustrator) 112–113, 144, 146–147
dummy text 164

E

Effect Gallery (Photoshop) 143, 152
Effect menu (Illustrator). See also Effect menu (Photoshop)
3D 143
Convert to Shape 143
Crop Marks 143
CSS (cascading style sheets) 107–108, 113
Distort & Transform 143 Transform 115–116, 159–161
Illustrator versus Photoshop 142–144
Path 143
Pathfinder 143
Rasterize 143, 155–157

Stylize 143
Drop Shadow 112–113, 144, 146–147
Feather 144
Inner Glow 110–111, 113, 144, 149–150
Outer Glow 144
Round Corners 109–110, 146
SVG Filters 143
viewing effects in Outline mode 112
Warp 143
Arch 115–116

Effect menu (Photoshop). See also Effect menu (Illustrator)
Artistic, Film Grain 143, 150–151
Blur 143
Gaussian Blur 154, 157
Brush Strokes 143
Distort 143
DRES (Document Raster Effects Settings) 144, 154–157
Effect Gallery 143, 152
Illustrator versus Photoshop 142–144
Pixelate 143
Sketch 143
Stylize 143
Texture
Grain 143
Texturizer 143
Video 143

The Elements of User Experience: User-Centered Design for the Web 180

Ellipse tool basics 23 keyboard shortcut 41
ellipses and Pen tool 21–22
Eyedropper tool basics 29 keyboard shortcut 41 sampling color 99 styling text 99
Feather Stylize effect (Illustrator) 144
Fill and Stroke tools 29
basics 29
keyboard shortcuts 41
Film Grain Artistic effect (Photoshop) 143, 150–151
Find and Replace 169–170
Flash. See Adobe Flash
fonts
  FontSquirrel web site 93, 127
  free web fonts 129
  installing 127
  minimal sizes and styles 97
  using 94–95
Free Transform tool 165
basics 26
keyboard shortcut 41
9-Slice scaling 120, 124–126
Full Screen mode 32–33, 41
Full Screen with Menu Bar mode 32–33
Garrett, Jesse James 180
Gaussian Blur effect (Photoshop) 154, 157
Glitschka, Von 20
Glyphs panel 6
Gradient panel 111
Gradient tool
  basics 27–28
  keyboard shortcut 41
Grain Texture effect (Photoshop) 143
Graphic Styles panel/styles
  additive styles 148, 158–161
  creating new 117, 147, 159
  editing 118
  keyboard shortcut 117
  repeating 160–161
  style guides
    creating templates from 216
    using in other documents 211
  versus symbols 119
grids
  applying to multiple artboards 79
  basics 74–75
  creating 75–77
  document-wide 82
  fitting 78
  resources 74
  selecting/deselecting 77
  splitting paths into grids 76
Group Selection tool 18
  guides 66
    adding 77
    clearing 75
    converting to objects 68
    creating 67
      from objects 68
    showing/hiding, keyboard shortcut 64, 103
    using 94, 107, 138
Hand tool
  basics 30, 61–62
  keyboard shortcut 63
Hide/Show Guides
  basics 67, 94
  keyboard shortcut 103
Hide/Show Rulers, keyboard shortcut 67, 103
Hide/Show Smart Guides
  basics 71
  keyboard shortcut 103
Hoekman, Robert 180
Illustrator. See Adobe Illustrator
images in layout example
embedding
  image processing 176
  versus linking 171
  Place command 173–174
image processing 176
importing
  preparations 172
  process 173–175
linking
  automatically 173
  versus embedding 171
  Place command 174
  preventing double compression 172
inches, measurement units
  keyboard shortcut 225
  preferences 44
InDesign. See Adobe InDesign
Inner Glow Stylize effect (Illustrator) 110–111, 113, 144, 149–150
iPad and iPhone, profiles in Illustrator 50
isolation mode 122
  Isolate Selected Clipping Mask 149
J
JPEG file format, exporting artwork to 220
K
keyboard shortcuts
  actual size 63
  Align panel 69, 103
  Appearance panel 106
  Artboard tool 30, 52, 63
  bounding boxes, showing/hiding 16
  Bring to Front 167, 177
  Color Settings 45, 63
  Copy 103
  Cut 79, 103
  Deselect 19, 158
  Direct Selection tool 17, 41
  Drawing mode 31, 41
  Ellipse tool 23–24, 41
  Eyedropper tool 29, 41
  Fill and Stroke tools 29, 41
  Free Transform tool 26, 41
  Gradient tool 27, 41
  Graphic Styles panel 117
  Hand tool 30, 62–63
  Hide/Show Guides 67, 94, 103
  Hide/Show Rulers 67, 103
  Hide/Show Smart Guides 103
  Lasso tool 19, 41
  Line Segment tool 23, 41
  Lock/Unlock Guides 67–68, 103
  Magic Wand tool 18, 41
  Make Guides 68, 103
  New Document 49, 63
  Outline mode 112
  Paste 177
  Paste in Place 103
  Paste on All Artboards 79, 103
  Pen tool 20, 41
  Pixel Preview mode 81, 83
  Preferences 82, 103
  Rectangle tool 23–24, 41
  Reflect tool 26, 41
  Release Guides 68, 103
  Save 90, 103
  Save As 225
  Save for Web 225
  Screen modes 31, 41
  Select All 19
  Select All on Active Artboard 19
keyboard shortcuts (continued)
Select menu options 19
Selection tool 16, 41
Send to Back 177
Show Hide Smart Guides 71, 103
Show/Hide Guides 67, 103
Show/Hide Rulers 67, 103
Slice tool 30
Smart Guides 71, 103
Type tool 25, 41
Undo tool 67, 103
units of measurement preferences 225
Zoom tool 30, 61

Krug, Steve 180
Kuler tool 6

Lasso tool
basics 19
keyboard shortcut 41
Layers panel/layers
basics 130–132
creating 134
information display options 133
objects
moving between 135–137
showing selected 132
layout example
application logo 127–128
content area, grain textures 153
headings 99–100
flame 149–152
images
embedding 171–176
image processing 176
importing 172–175
linking 171–174
preparing for import 172
landing pages 144–145
lining up elements 138
main content area 90
navigation bars 89
grain textures 153
navigation hierarchy with different typefaces 129
photo/picture frames
additive styles 160–161
creating 91–92, 114–116
softening shadows 154
search boxes 107–108
color options 107–108, 110
drop shadows 112–113
fills/strokes 107–108, 115
flexibility of options 113
inner glow shadows 110–111, 113
rounded corners 109–110
sidebars 88–89
grain textures 153
resolution of effects 155–157
sign-up buttons
drop shadows 146–148
rounded corners 146
symbols
basics 119
creating 119–121
duplicating 122
editing 122–123
versus graphic styles 119
instances 121
renaming 122
resizing 124–126
swapping 123–124
text
  drop caps 168
  editing 164–167
  finding/replacing 169–170
  importing 162–164
  resizing 165–167
  simulating floats 166–167
  typing 162
  wrapping 165–168

type
  anti-aliasing 94–95
  area type 96–98
  attributes, duplicating with Eyedropper tool 99
  character styles 100–101
  fonts 93–95, 97
  point type 96–97, 99
  tracking 128
  underlining 98
  viewing 138

Line Segment tool
  basics 23
  keyboard shortcut 41
  Smart Guides 185–186

Line tool 92
Lipservice dummy text tool 164
Lipsum dummy text tool 164
Lock icon 132
Lock/Unlock Guides
  basics 67–68
  keyboard shortcuts 103

M
Magic Wand tool
  basics 18
  keyboard shortcut 41

Make Guides
  basics 68
  keyboard shortcut 103
  measurement labels, Smart Guides 73
  measurement units
    keyboard shortcut 225
  preferences 44
Microsoft Word (Windows and Mac) 162

N
navigation bars 89, 153
navigation hierarchy with different typefaces 129
New Document
  basics 49
  keyboard shortcut 63
Next Object Above/Below keyboard shortcuts 19
9-Slice scaling 120, 124–126
Normal Screen mode 32
Norman, Donald A. 180

O
Object Highlighting Smart Guide 72
objects
  alignment
    to artboard 70, 76
    with guides 66
    to key objects 70
    to pixel grids 50, 82–84
    to selections 70
    strokes to outside 92
    strokes within objects 91–92
  arranging, Bring to Front 167, 177
  artboards, creating from objects 56
  attributes 8
objects (continued)
  color or gradients 27–29
  converting guides to 68
  coordinates and reference points, Scale tool 73
  coordinates for pixel-precision drawing 85–87
drawing
  ellipses 21
  rectangles 21
  editing 122
  grouping 18
  highlighting with Smart Guides 72
  isolation mode 122, 149
  layers
    adding objects to 131
    moving objects between 135–137
    showing objects selected 132
  mirroring 26
  Object Highlighting Smart Guide 72
  object-based drawing model 10
  reference points 85–87
  resizing 16, 26
    proportionally 87
  rotating 16, 26, 85
  scaling, coordinates and reference points 85
  selecting
    all instances of symbols 19
    by attributes 18–19
    behind other objects 17
    with freeform marquee 19
    individual points or line segments 17
    multiple objects 17
    with same graphic style 19
  showing/hiding bounding boxes 16
  splitting paths into grids 76
  stretching 26
  wrapping text 167–168

Ordering Disorder: Grid Principles for Web, Design 74
Outer Glow Stylize effect (Illustrator) 144
Outline mode keyboard shortcut 112

P
  panels
    expanding/collapsing 35–36
    grouping/ungrouping 35–36
    moving 36–37
    tabs
      changing order 37
      switching between 35
  Paragraph styles 6, 7
    saving in style guides 211
  Paste in Place keyboard shortcut 103
  Paste keyboard shortcut 177
  Paste on All Artboards
    basics 79
    keyboard shortcut 103
  Path effect (Illustrator) 143
  Pathfinder effect (Illustrator) 143
  PDF file format, saving artwork 221–222
  Pen tool
    basics 20–22
    construction guides 73
    keyboard shortcut 41
  photo/picture frames in layout example
    additive styles 160–161
    creating 91–92, 114–116
    softening shadows 154
  Photoshop. See Adobe Photoshop
  picas, measurement units
    keyboard shortcut 225
    preferences 44
  Pixelate effect (Photoshop) 143
pixel-precision drawing 80
aligning objects to pixel grid 50, 82–84
coordinates 85–87
Pixel Preview mode
basics 49, 81
keyboard shortcut 103
reference points 85–87
Transform panel 85, 87
Place command
images 173–174
text files 163
Plain text 163
planning UI design
basics 180
resources 180
site maps
basics 181–182
dynamic page symbols 182–184
organizing pages 185–187
wireframes 187–189
PNG file format, exporting artwork to 220
point type
versus area type 96
using 96–97, 99
wrapping text 165
points, measurement units
keyboard shortcut 225
preferences 44
Polygon tool 23–24
preferences
Control panel 34
document-wide grids 82
Eyedropper tool 29
keyboard shortcut 82, 103
Smart Guides 71
units of measurement 44
Presentation mode 217–219
preview mode, documents 49–50
Print profile 49
profiles, documents
saving new 50
Web and Print 49
R
raster-based applications, versus vector-based applications 2
effects, Photoshop versus Illustrator 142–144
Rasterize effect (Illustrator) 143, 155–157
DRES (Document Raster Effects Settings) 144, 154–157
Rectangle tool
basics 23–24
keyboard shortcut 41
rounded corners 109
reference points 85–87
Reflect tool
basics 26
keyboard shortcut 41
Release Guides
basics 68
keyboard shortcut 103
replacing text. See Find and Replace
resolution in effects, Photoshop
Document Raster Effects Settings (DRES) 154–157
versus Illustrator 144
RGB color mode 49
Web Safe RGB 111
Rotate tool 26, 73
Round Corners Stylize effect (Illustrator) 109–110, 146
RTF (Rich Text Format) 163
Saffer, Dan 180
Save As keyboard shortcut 225
Save for Web
basics 222–224
keyboard shortcut 225
Save keyboard shortcut 103
Save Swatch Library as AI 211
Save Swatch Library as ASE 211
Scale tool 73, 128, 192, 204
screen modes
basics 32–33
keyboard shortcut 41
search boxes 107–108
color options 107–108, 110
drop shadows 112–113
fills/strokes 107–108, 115
flexibility of options 113
inner glow shadows 110–111, 113
rounded corners 109–110
selection tools
Direct Selection
basics 17
gridlines 78
keyboard shortcut 41
Group Selection 18
Lasso
basics 19
keyboard shortcut 41
Magic Wand
basics 18
keyboard shortcut 41
Select All keyboard shortcut 19
Select All on Active Artboard keyboard shortcut 19
Select menu options 19
Select Same option 19
Selection
basics 16–17
keyboard shortcut 41
Send to Back keyboard shortcut 177
shapes
adding/removing points from stars or polygon sides 23–24
changing star inner radius 23–24
constraining to squares or circles 23
drawing from center 23–24
locking rotation angle to 0 23
repositioning on artboard 23
Sharp setting, anti-aliasing options 95
Shear tool 73, 128
shortcut keys. See keyboard shortcuts
Show/Hide Guides
basics 67, 94
keyboard shortcut 103
Show/Hide Rulers, keyboard shortcut 67, 103
Show/Hide Smart Guides
basics 71
keyboard shortcut 103
sidebars in layout example 88–89
grain textures 153
resolution of effects 155–157
Simple and Usable Web, Mobile, and Interaction Design 180
“Simple Steps to Designing Grid Systems” 74
site maps 181–182
organizing pages 185–186
symbols 182–184
Sketch effect (Photoshop) 143
Slice tool
keyboard shortcut 30
using 204, 222
Smart Guides 10
alignment 72
anchor/path labels 72
basics 71, 182
construction 73
keyboard shortcut 71, 103
measurement labels 73
object highlighting 72
transform tools 73
Star tool 23–24
storyboards for communication with developers 190–198
adding color and style 202–205
inserting notes 199–201
Stroke panel 91–92
Strong setting, anti-aliasing options 95
Stylize effect (Photoshop) 143
Stylize effects (Illustrator) 143
Drop Shadow 112–113, 144, 146–147
Feather 144
Inner Glow 110–111, 113, 144, 149–150
Outer Glow 144
Round Corners 109–110, 146
SVG Filters effect (Illustrator) 143
Swatches panel 95
Save Swatch Library as AI 211
Save Swatch Library as ASE 211
Symbol panel/symbols 9
basics 119
creating 119–121
duplicating 122
editing 122–123
versus graphic styles 119
instances 121
renaming 122
resizing 124–126
saving symbols in style guides 211
swapping 123–124
Symbol panel/symbols (site map)
creating 182–184
storyboards 193–198
style libraries 206
style libraries, templates from 212–213
in wireframes 189
templates
character styles 216
color swatches and groups 215
graphic styles 214
paragraph styles 216
symbols 212–213
text. See also type; typography
drop caps 168
dummy text tools 164
editing 164–167
finding/replacing 169–170
importing 162–164
file formats 162–163
process 163–164
resizing 165–167
simulating floats 166–167
typing 162
wrapping 165–167, 165–168
with drop caps 168
with simulated floats 166–167
text formatting 6, 7
Texture effects (Photoshop)
Grain 143
Texturizer 143
Texturizer effect (Photoshop) 143
3D effect (Illustrator) 143
Tidwell, Jennifer 180
Tolerance option, Magic Wand tool 18
Tools panel
floating tool panels 15
groups 14
accessing 14–15
point type
  versus area type 96
  using 96–97, 99
  wrapping text 165
styling with Eyedropper tool 99
tracking 128
Type on a Path tool 25
Type tool
  Area Type options 165
  basics 25
  keyboard shortcut 41
Type tool group 25
underlining 98
typography. See also text; typography
anti-aliasing 4–5
color/color tools 4, 6
tools 4–6
Ul design 4–5
design principles 4

U
Ul design
advantages of AI
color and typography 4–6
consistency 7–10
drawing and layout 10
file size 2–3
scalability 3
speed 2
stability 3
artboards, exporting
Flash 220
JPEGs 220
Photoshop 220
PNGs 220
Presentation mode 217–219
artboards, saving
  as PDFs  221–222
  for web  222–224
developers and communication
  with storyboards  190–198
  with storyboards, adding color and
  style  202–205
  with storyboards, inserting notes
  199–201
planning
  basics  180
  resources  180
  site maps  181–186
  wireframes  187–189
site maps  181–186
style libraries/guides
  Adobe Swatch Exchange format  211
  basics  206
  Color Guide panel  207–209
  Kuler plug-in  210
  in other applications  211
templates from style guides
  basics  212
  character styles  216
  color swatches and groups  215
  graphic styles  214
  paragraph styles  216
  saving  216
  symbols  212–213
  wireframes  187–189
Undo tool keyboard shortcut  67, 103
units of measurement
  keyboard shortcut  225
  preferences  44

V
  Vector Basic Training  20
  vector-based applications
    effects, Illustrator versus Photoshop
    142–144
    versus raster-based applications  2
  Vertical Area Type tool  25
  Vertical Type on a Path tool  25
  Vertical Type tool  25
  Video effect (Photoshop)  143
  Vinh, Khoi  74

W
  Warp effects (Illustrator)  143
  Arch  115–116
  Web profile  49
  Web Safe RGB color mode  111
  Wheelr layout example
    application logo  127–128
    content area, grain textures  153
    headings  99–100
    flame  149–152
    images
      embedding  171–176
      image processing  176
      importing  172–175
      linking  171–174
      preparing for import  172
      landing pages  144–145
      lining up elements  138
      main content area  90
      navigation bars  89
      grain textures  153
      navigation hierarchy with different
      typefaces  129
Wheel layout example (continued)

photo/picture frames
- additive styles 160–161
- creating 91–92, 114–116
- softening shadows 154

search boxes 107–108
- color options 107–108, 110
- drop shadows 112–113
- fills/strokes 107–108, 115
- flexibility of options 113
- inner glow shadows 110–111, 113
- rounded corners 109–110

sidebars 88–89
- grain textures 153
- resolution of effects 155–157

sign-up buttons
- drop shadows 146–148
- rounded corners 146

drop caps 168

anti-aliasing 94–95
area type 96–98
attributes, duplicating with Eyedropper tool 99
character styles 100–101
character styles 100–101
fonts 93–95, 97
point type 96–97, 99
tracking 128
underlining 98

viewing 138

workspaces

Application frame 45–46

artboards 47–48
- aligning to 70, 76
- applying grids to multiple 79

Artboard tool 30, 52, 63

Artboards panel 54

Control panel 53

creating 51–52

creating from Control panel 53

creating from existing objects 56

creating from New Artboard button 79
duplicating 55
exporting to other formats 217–220

JPEGs 220

Photoshop 220

PNGs 220

Presentation mode 217–219

moving 58–59

naming 57

navigating multiple 61–62

rearranging 60

savings as PDFs or for web 221–224

color space organization 46–47

custom 38–40

default 38
Hand tool  30, 61–63
measurement units
  keyboard shortcut  225
preferences  44
screen modes
  basics  32–33
  keyboard shortcut  41
workspace switcher  38, 40

Z

Zoom tool
  basics  30
  keyboard shortcut  61
  options  10