Visual QuickStart Guide
InDesign cs6

Peachpit Press
1249 Eighth Street
Berkeley, CA 94710
phone 510 524 2178
fax 510 524 2221

To report errors, please send a note to errata@peachpit.com.

Copyright © 2012 by Sandee Cohen

Peachpit Press is a division of Pearson Education.

Notice of Rights
All rights reserved. No part of this book may be reproduced or transmitted in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, without prior written permission of the publisher. For information on getting permission for reprints and excerpts, contact permissions@peachpit.com.

Some halftone images courtesy of Hemera Photo-Objects 50,000 Volumes I and II
Some halftone images © copyright Photospin.com
Some line art © copyright www.arttoday.com

Notice of Liability
The information in this book is distributed on an “as is” basis, without warranty. Although every precaution has been taken in the preparation of this book, neither the author nor Peachpit Press shall have any liability to any person or entity with respect to any loss or damage caused or alleged to be caused directly or indirectly by the instructions contained in this book or by the computer software and hardware products described herein.

Trademarks
InDesign is a registered trademark of Adobe Systems Incorporated in the United States and/or other countries.

Visual QuickStart Guide is a registered trademark of Peachpit Press, a division of Pearson Education.

All other trademarks are the property of their respective owners.

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as trademarks. Where those designations appear in this book, and Peachpit Press was aware of a trademark claim, the designations appear as requested by the owner of the trademark. All other product names and services identified throughout this book are used in editorial fashion only and for the benefit of such companies. No such use, or the use of any trade name, is intended to convey endorsement or other affiliation with the book.

Editor: Becky Morgan
Production Editor: Becky Winter
Compositor & Interior Design: Sandee Cohen
Cover Design: RHDG/Riezebos Holzbaur, Peachpit Press
Logo Design: MINE (TM) www.minesf.com
Proofreader: Megan Tytler
Indexer: Jack Lewis

ISBN-10: 0321822536

0 9 8 7 6 5 4 3 2 1

Printed and bound in the United States of America
Welcome to the *InDesign CS6 Visual QuickStart Guide*, my ninth version of the book. From its humble start, InDesign is now the primary application for desktop publishing and page layout. I feel very lucky to have been working with and teaching InDesign since its very first beta. In fact, this is the only third-party book that has had editions for all versions of InDesign.

**Using This Book**

If you have used any of the other Visual QuickStart Guides, you will find this book to be similar. Each chapter is divided into different sections that deal with a specific topic — usually a set of tools or similar commands. For instance, the chapter on text has sections on creating text frames, typing text, selecting text, and so on.

Each of the sections contains numbered exercises that show you how to perform a specific technique. As you work through the steps, you gain an understanding of the technique or feature. The illustrations help you judge if you are following the steps correctly.

I've also sprinkled sidebars, printed in colored boxes, throughout the chapters. Some of these sidebars give you a bit of history or background for a specific feature. Other times, I've written out humorous stories about desktop publishing. These sidebars are the same little stories and anecdotes I tell my students in the classes I teach.

Strictly speaking, you don’t have to work through the book in the same order as it is printed. If you want to learn more about imported images, you can skip right over to that chapter.

However, the book is organized in the same order that I run my InDesign beginner classes. We start with the document setup, then move to basic text, color, and so on. It’s just as if you were sitting in one of my classes. The only thing you won’t see is a lunch break.

**Instructions**

You will find it easier to use this book once you understand the terms I am using. This is especially important since some other computer books use terms differently. Therefore, here are the terms I use in the book and explanations of what they mean.

**Click** refers to pressing down and releasing the mouse button on the Macintosh, or the left mouse button on Windows. You must release the mouse button or it is not a click.

**Press** means to hold down the mouse button, or a keyboard key.

**Press and drag** means to hold the mouse button down and then move the mouse. I also use the shorthand term **drag**.
Menu Commands

InDesign has menu commands that you follow to open dialog boxes, change artwork, and initiate certain actions. These menu commands are listed in bold type. The typical direction to choose a menu command might be written as **Object > Arrange > Bring to Front**. This means that you should first choose the Object menu, then choose the Arrange submenu, and then choose the Bring to Front command.

Modifier Keys

Modifier keys are always listed with the Macintosh key first and then the Windows key second. So the instruction “Hold the Cmd/Ctrl key” means hold the Cmd key on the Macintosh platform or the Ctrl key on the Windows platform. When the key is the same on both computers, such as the Shift key, only one key is listed.

Keyboard Shortcuts

You’ll notice that I don’t usually provide the keyboard shortcut for commands. For instance, I’ll list the menu command for File > New, but not the keyboard shortcut Cmd/Ctrl-N.

While keyboard shortcuts help you work faster, you really don’t have to start using them right away. In fact, you will most likely learn more about InDesign by using the menus. As you look for one command, you may see another feature that you would like to explore.

So don’t worry about keyboard shortcuts as you start. Focus on the big picture.

My Thanks to:

**Nancy Ruenzel**, publisher of Peachpit Press.

**Becky Morgan**, my editor at Peachpit Press. Thanks for being so patient with me.

**Becky Winter**, for her eagle production eye and blazingly fast corrections.

The staff of Peachpit Press, all of whom make me proud to be a Peachpit author.

The InDesign team in Seattle, who has made InDesign my favorite program to use and to write about.

And a very special thanks to **David Lerner** of Tekserve, who has helped me keep my computers running in the middle of the book crunch. Tekserve (www.tekserve.com) is the best place to buy, fix, or enhance Macintosh computers.

Colophon

This book was created using InDesign CS5.5 running on a MacBook Pro and a Dell Vostro. Screen shots were taken using Snapz Pro X (Mac) and Snagit (Win). InDesign CS6 beta ran on the Macintosh OS X (Lion) and on Windows 7. Fonts are Myriad Pro from Adobe.

And Don’t Forget…

Whether you’re learning InDesign in a class or on your own, I hope this book helps you master the program.

**Just don’t forget to have fun!**

Sandee Cohen
(Sandee@vectorbabe.com)
June, 2012
# Table of Contents

**Introduction** iii  
**Chapter 1 Getting Started** 1  
Working with Panels 2  
Using Workspaces 4  
Using the Tools Panel 6  
Using the Tool Hints Panel 7  
Using Contextual Menus 8  
**Chapter 2 Document Setup** 9  
The Welcome Screen 10  
Setting Up Documents 11  
Setting the Layout Options 13  
Changing Layout Options 16  
Using the Document Presets 17  
Using Document Rulers 19  
Using the Page Tool 21  
Working with Guides 23  
Using Smart Guides 27  
Viewing Transformation Values 27  
Working with Document Grids 28  
Changing the Magnification 29  
View and Pasteboard Controls 31  
Using the Zoom and Hand Tools 33  
Controlling Windows 35  
Using the Application Bar 36  
File Maintenance 38  
**Chapter 3 Basic Text** 41  
Creating Text Frames 42  
Typing Text 45  
Selecting Text 46  
Moving and Deleting Text 48  
Using the Character Panel 50  
Setting the Typeface and Point Size 51  
Styling Text 52  
Setting Line and Character Spacing 54  
Applying Text Distortions 56  
Setting the Language 57  
Applying Paragraph Formatting 58  
Setting Alignment and Indents 59  
Bullets and Numbering 61  
Setting Paragraph Effects 64  
Working with Hidden Characters 66  
Using the Glyphs Panel 67  
Working with Text Flow 70  
Setting Text Frame General Controls 71  
Spanning and Splitting Columns 75  
Using the Control Panel for Text 76  
Using Special Text Characters 77  
**Chapter 4 Working with Objects** 79  
Types of Frames 80  
Creating Basic Shapes 81  
Selecting Objects 83  
Moving Objects 84  
Replicating Objects 86  
Resizing Objects 88  
Using the Transform Tools 89  
Using the Transform Panel 94  
Using the Transform Commands 98  
Using the Arrange Commands 100  
Aligning Objects 101  
Smart Dimensions; Smart Spacing 104  
Using the Gap Tool 105  
Grouping and Pasting Into Objects 106  
Using the Measure Tool 108  
Using the Info Panel with Objects 110  
Locking Objects 111  
Selecting Frames 112  
**Chapter 5 Working in Color** 113  
The Basics of Color 114  
Using the Color Panel 116  
Defining and Storing Swatches 120  
Using Swatch Libraries 128  
Creating Tints 129
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Fills, Strokes, and Effects</td>
<td>137</td>
</tr>
<tr>
<td></td>
<td>Applying Fills</td>
<td>138</td>
</tr>
<tr>
<td></td>
<td>Applying Stroke Effects</td>
<td>142</td>
</tr>
<tr>
<td></td>
<td>Creating Custom Stroke Styles</td>
<td>149</td>
</tr>
<tr>
<td></td>
<td>Adding Arrows</td>
<td>154</td>
</tr>
<tr>
<td></td>
<td>Corner Options</td>
<td>154</td>
</tr>
<tr>
<td></td>
<td>Opacity and Blend Mode Effects</td>
<td>156</td>
</tr>
<tr>
<td></td>
<td>Working with Effects</td>
<td>158</td>
</tr>
<tr>
<td></td>
<td>Shadow Effects</td>
<td>159</td>
</tr>
<tr>
<td></td>
<td>Glow Effects</td>
<td>160</td>
</tr>
<tr>
<td></td>
<td>Bevel and Emboss Effects</td>
<td>161</td>
</tr>
<tr>
<td></td>
<td>Satin Effect</td>
<td>161</td>
</tr>
<tr>
<td></td>
<td>Feather Effects</td>
<td>162</td>
</tr>
<tr>
<td></td>
<td>Setting the Global Light</td>
<td>163</td>
</tr>
<tr>
<td></td>
<td>Using the Pathfinder Commands</td>
<td>164</td>
</tr>
<tr>
<td></td>
<td>Using the Eyedropper</td>
<td>167</td>
</tr>
<tr>
<td></td>
<td>Setting Object Defaults</td>
<td>169</td>
</tr>
<tr>
<td>7</td>
<td>Points and Paths</td>
<td>171</td>
</tr>
<tr>
<td></td>
<td>Pen Points</td>
<td>172</td>
</tr>
<tr>
<td></td>
<td>Drawing Lines</td>
<td>173</td>
</tr>
<tr>
<td></td>
<td>Drawing Curves</td>
<td>174</td>
</tr>
<tr>
<td></td>
<td>Changing Curves and Corner Points</td>
<td>175</td>
</tr>
<tr>
<td></td>
<td>Modifying Paths</td>
<td>176</td>
</tr>
<tr>
<td></td>
<td>Modifying Points</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Using the Pencil Tool</td>
<td>180</td>
</tr>
<tr>
<td></td>
<td>Using the Smooth Tool</td>
<td>182</td>
</tr>
<tr>
<td></td>
<td>Using the Erase Tool</td>
<td>183</td>
</tr>
<tr>
<td></td>
<td>Adding or Deleting Points on Paths</td>
<td>184</td>
</tr>
<tr>
<td>8</td>
<td>Imported Graphics</td>
<td>185</td>
</tr>
<tr>
<td></td>
<td>Placing Artwork</td>
<td>186</td>
</tr>
<tr>
<td></td>
<td>Using Bridge and Mini Bridge</td>
<td>190</td>
</tr>
<tr>
<td></td>
<td>Specialty Frames</td>
<td>191</td>
</tr>
<tr>
<td></td>
<td>Setting the Image Import Options</td>
<td>194</td>
</tr>
<tr>
<td></td>
<td>Working with Images Inside Frames</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>Fitting Graphics in Frames</td>
<td>201</td>
</tr>
<tr>
<td></td>
<td>Linking Graphics</td>
<td>204</td>
</tr>
<tr>
<td></td>
<td>Setting Layer Visibility</td>
<td>208</td>
</tr>
<tr>
<td></td>
<td>Importing Transparent Images</td>
<td>209</td>
</tr>
<tr>
<td></td>
<td>Viewing Images</td>
<td>210</td>
</tr>
<tr>
<td>9</td>
<td>Text Effects</td>
<td>213</td>
</tr>
<tr>
<td></td>
<td>Wrapping Text</td>
<td>214</td>
</tr>
<tr>
<td></td>
<td>Text on a Path</td>
<td>220</td>
</tr>
<tr>
<td></td>
<td>Working with Paragraph Rules</td>
<td>223</td>
</tr>
<tr>
<td></td>
<td>Inline and Anchored Objects</td>
<td>227</td>
</tr>
<tr>
<td>10</td>
<td>Pages and Books</td>
<td>231</td>
</tr>
<tr>
<td></td>
<td>Changing the Pages Panel</td>
<td>232</td>
</tr>
<tr>
<td></td>
<td>Adding Blank Pages</td>
<td>234</td>
</tr>
<tr>
<td></td>
<td>Navigating and Moving Pages</td>
<td>235</td>
</tr>
<tr>
<td></td>
<td>Modifying Page Sizes</td>
<td>239</td>
</tr>
<tr>
<td></td>
<td>Creating and Separating Spreads</td>
<td>241</td>
</tr>
<tr>
<td></td>
<td>Importing Text</td>
<td>242</td>
</tr>
<tr>
<td></td>
<td>Flowing Text</td>
<td>246</td>
</tr>
<tr>
<td></td>
<td>Creating Text Breaks</td>
<td>248</td>
</tr>
<tr>
<td></td>
<td>Working with Master Pages</td>
<td>249</td>
</tr>
<tr>
<td></td>
<td>Rotating Spreads</td>
<td>255</td>
</tr>
<tr>
<td></td>
<td>Page Numbers and Text Variables</td>
<td>256</td>
</tr>
<tr>
<td></td>
<td>Making Books</td>
<td>260</td>
</tr>
<tr>
<td></td>
<td>Creating a Table of Contents</td>
<td>265</td>
</tr>
<tr>
<td>11</td>
<td>Layers</td>
<td>271</td>
</tr>
<tr>
<td></td>
<td>Creating and Deleting Layers</td>
<td>272</td>
</tr>
<tr>
<td></td>
<td>Setting the Layer Options</td>
<td>274</td>
</tr>
<tr>
<td></td>
<td>Working with Layers</td>
<td>277</td>
</tr>
<tr>
<td></td>
<td>Layer Contents</td>
<td>279</td>
</tr>
<tr>
<td>12</td>
<td>Libraries and Snippets</td>
<td>281</td>
</tr>
<tr>
<td></td>
<td>Storing Items in a Library</td>
<td>282</td>
</tr>
<tr>
<td></td>
<td>Applying Library Items to a Page</td>
<td>284</td>
</tr>
<tr>
<td></td>
<td>Setting the Library Display</td>
<td>285</td>
</tr>
<tr>
<td></td>
<td>Searching and Sorting Libraries</td>
<td>286</td>
</tr>
<tr>
<td></td>
<td>Creating and Using Snippets</td>
<td>287</td>
</tr>
<tr>
<td>13</td>
<td>Tabs and Tables</td>
<td>289</td>
</tr>
<tr>
<td></td>
<td>Inserting Tab Characters</td>
<td>290</td>
</tr>
<tr>
<td></td>
<td>Setting Tab Stops</td>
<td>291</td>
</tr>
<tr>
<td></td>
<td>Creating Tab Leaders</td>
<td>294</td>
</tr>
<tr>
<td></td>
<td>Creating and Using Tables</td>
<td>295</td>
</tr>
<tr>
<td></td>
<td>Navigating Through Tables</td>
<td>300</td>
</tr>
</tbody>
</table>
Selecting Tables . . . . . . . . . . . . . . . . . 301
Working with Rows and Columns . . . . . . . . 303
Adjusting Tables Within a Text Frame . . . . 309
Working with Headers and Footers . . . . . . 310
Adding Images to Tables . . . . . . . . . . . . . 312
Customizing Cells . . . . . . . . . . . . . . . . . . 313
Setting Borders, Strokes, and Fills . . . . . . . 316
Alternating Strokes and Fills . . . . . . . . . . . 319
Adding Diagonal Lines in Cells . . . . . . . . . . 322
Using the Table or Control Panels . . . . . . . 323
Chapter 14 Automating Your Work . . . . . . . 325
Changing Case . . . . . . . . . . . . . . . . . . . . 326
Checking Spelling . . . . . . . . . . . . . . . . . . . 326
Using Find/Change . . . . . . . . . . . . . . . . . 330
Using the Text Find/Change . . . . . . . . . . . 332
Using the GREP Find/Change . . . . . . . . . . 334
Using the Glyph Find/Change . . . . . . . . . . 335
Using the Object Find/Change . . . . . . . . . . 336
Saving Searches . . . . . . . . . . . . . . . . . . . 336
Adding Captions to Images . . . . . . . . . . . 337
Using the Story Editor . . . . . . . . . . . . . . . 340
Tracking Text Changes . . . . . . . . . . . . . . 341
Conditional Text . . . . . . . . . . . . . . . . . . . 343
Conditional Text Sets . . . . . . . . . . . . . . . 346
Footnotes . . . . . . . . . . . . . . . . . . . . . . . 347
Using Find Font . . . . . . . . . . . . . . . . . . . 350
Keeping Lines Together . . . . . . . . . . . . . 351
Using the Eyedropper on Text . . . . . . . . . 352
Using Scripts . . . . . . . . . . . . . . . . . . . . . 354
Chapter 15 Styles . . . . . . . . . . . . . . . . . . 355
Working with Paragraph Styles . . . . . . . . . 356
Working with Character Styles . . . . . . . . . 360
Working with Styles . . . . . . . . . . . . . . . . . 361
Creating Style Groups . . . . . . . . . . . . . . . . 363
Loading and Importing Styles . . . . . . . . . . 364
Importing Text Styles from Word . . . . . . . . 366
Applying Styles and Style Overrides . . . . . . 368
Clearing Style Overrides . . . . . . . . . . . . . . 369
Redefining and Deleting Styles . . . . . . . . . 371
Automatic Drop Cap Styling . . . . . . . . . . . . 373
Using Nested Styles . . . . . . . . . . . . . . . . . 374
Creating Nested Line Styles . . . . . . . . . . . . 377
Creating GREP Styles . . . . . . . . . . . . . . . . 378
Defining Object Styles . . . . . . . . . . . . . . . . 379
Working with Object Styles . . . . . . . . . . . . 381
Defining Table and Cell Styles . . . . . . . . . . 382
Using the Quick Apply Feature . . . . . . . . . . 384
Chapter 16 Typography . . . . . . . . . . . . . . 387
Optical Margin Alignment . . . . . . . . . . . . . 388
Using Adobe Paragraph Composer . . . . . . . 389
Applying Justification Controls . . . . . . . . . . 390
Controlling Hyphenation . . . . . . . . . . . . . . 394
Baseline Grid . . . . . . . . . . . . . . . . . . . . . . 396
Balancing Ragged Lines . . . . . . . . . . . . . . 399
Using OpenType . . . . . . . . . . . . . . . . . . . 399
OpenType Categories . . . . . . . . . . . . . . . . 401
Chapter 17 Interactive and Multimedia . . . . 403
Types of Interactive Elements . . . . . . . . . . . 404
Defining Hyperlinks . . . . . . . . . . . . . . . . . 405
Creating Cross-References . . . . . . . . . . . . . 410
Working with Bookmarks . . . . . . . . . . . . . 413
Adding Sounds . . . . . . . . . . . . . . . . . . . . . 416
Movies and Animations . . . . . . . . . . . . . . 420
Creating Buttons . . . . . . . . . . . . . . . . . . . 423
Sample Buttons . . . . . . . . . . . . . . . . . . . . 427
Creating PDF Forms . . . . . . . . . . . . . . . . . 428
Sample Forms . . . . . . . . . . . . . . . . . . . . . 429
Animating InDesign Objects . . . . . . . . . . . . 430
Timing . . . . . . . . . . . . . . . . . . . . . . . . . . 433
Multi-State Objects . . . . . . . . . . . . . . . . . . 435
Working with the SWF Preview Controls . . . 437
Setting Page Transitions . . . . . . . . . . . . . . 438
Chapter 18 Working with Layouts . . . . . . . . 441
Collecting and Placing Content . . . . . . . . . . 442
Linking Items . . . . . . . . . . . . . . . . . . . . . . 445
Mapping Styles . . . . . . . . . . . . . . . . . . . . 447
Creating Alternate Layouts . . . . . . . . . . . . . 448
Applying Liquid Layout Rules . . . . . . . . . . . 450
Auto-Fit Commands . . . . . . . . . . . . . . . . . 454
At the risk of sounding like an old codger, I can remember when a page-layout program only laid out print files. The idea of creating “push buttons” that sent you flying to other pages—or even other documents—was totally unfathomable. After all, how was someone supposed to press on a weather summary on the front page of a newspaper to jump to the full weather map on the last page?

So it is with some amazement that I write this chapter. Page layout no longer refers to just printed pages. InDesign has a wealth of features that let you create interactive elements for electronic documents.

In This Chapter:
- Types of Interactive Elements 404
- Defining Hyperlinks 405
- Creating Cross-References 410
- Working with Bookmarks 413
- Adding Sounds 416
- Movies and Animations 420
- Creating Buttons 423
- Sample Buttons 427
- Creating PDF Forms 428
- Sample Forms 429
- Animating InDesign Objects 430
- Timing 433
- Multi-State Objects 435
- Working with the SWF Preview Controls 437
- Setting Page Transitions 438
## Types of Interactive Elements

There are five types of interactive elements you can add to InDesign documents: Hyperlinks, Cross-References, Bookmarks, Buttons and Forms. Each has its own particular uses, but some of the features may overlap. Before you start work, decide which type of interactive element is right for you.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
<th>Advantages</th>
<th>Limitations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hyperlink</td>
<td>Adds a hotspot area to text or objects where you can click to move to other parts of the document, other documents, or Web pages.</td>
<td>Can be applied directly to the text inside a story. Hyperlinks can also be automatically applied to the entries in a table of contents or index using those InDesign features.</td>
<td>Provides only very primitive visual indications of the linked area.</td>
</tr>
<tr>
<td>Cross Reference</td>
<td>Adds a hotspot area to text that is linked to other parts of the document.</td>
<td>Also adds dynamic text that indicates the position of the cross-reference.</td>
<td>Provides only primitive visual indications of the linked area.</td>
</tr>
<tr>
<td>Bookmark</td>
<td>Adds a navigational element that is visible in the Bookmarks pane of Adobe Reader or Adobe Acrobat.</td>
<td>The Bookmark pane can be set to be visible at all times in the PDF document. Can be created automatically using the Table of Contents feature.</td>
<td>Requires some education to teach the reader how to use the Bookmarks pane in the Reader. Is not directly on the document page. No special visual indication in the document.</td>
</tr>
<tr>
<td>Button</td>
<td>Adds a hotspot area that can contain text or graphics. This hotspot can be set to invoke a wide variety of behaviors including navigation as well as movie or audio playback.</td>
<td>Offers the most navigational and design choices.</td>
<td>Buttons can’t be created automatically from text or styles. Requires the most work to create.</td>
</tr>
<tr>
<td>Form</td>
<td>Adds an area that can be used in Acrobat to enter information or mark checkboxes or radio buttons.</td>
<td>These forms can be filled out in the PDF and the information then sent back to the creator for tabulation.</td>
<td>Forms can’t be created automatically. Requires the most work to create.</td>
</tr>
</tbody>
</table>
Defining Hyperlinks

A hyperlink is an area of a page that can be clicked to send the reader to a new page, open a new document, move to a Web page, or send an email message. There are two parts to a hyperlink. The source is the object or text that you click to trigger the hyperlink. The destination is the page or Web link you go to.

To create a hyperlink:

1. If the Hyperlinks panel is not visible, choose Window > Interactive > Hyperlinks to open the panel.
2. Select the text or object that you want to make the hyperlink source.
3. Click the Create New Hyperlink icon in the panel or choose New Hyperlink from the panel menu. This opens the New Hyperlink dialog box.
4. Set the options for Link To, Destination, Character Style, and Appearance as described in the following exercises.
There are several types of destinations for hyperlinks. You can, for instance, choose to link to a specific place in the document or you can link to a Web page. The type of link you choose determines the destination options that appear in the New Hyperlink dialog box.

**To choose the type of link:**

Use the Link To menu to choose one of the following types of links:

- **URL** creates a link to a Web page.
- **File** creates a link that opens a file in another application. Note: the file must be accessible to anyone choosing the link.
- **Email** creates a link that opens the default email application. You can also set the email address and subject line.
- **Page** creates a link that opens a new page in the document.
- **Text Anchor** creates a link to a point in the text that was defined as a text anchor.
- **Shared Destination** creates a link to a previously defined hyperlink. This is particularly helpful if you want several different hyperlinks to go to the same destination.

As you define hyperlinks, they appear in the Hyperlinks panel. Different types of hyperlinks display different icons.

**To see the types of hyperlinks in the Hyperlinks panel:**

Click each hyperlink in the Hyperlinks panel. An icon next to the link shows the type of link.

**Tip** A selected hyperlink also displays its URL or other link information in the Hyperlinks panel.
In addition to setting the destinations for hyperlinks, you can also control how the hyperlink appears on the page.

To set a character style to text hyperlinks:
1. Select the text that you want as a hyperlink.
2. In the New Hyperlink dialog box, click the Character Style menu.
3. Choose a predefined character style. Or choose None to apply no style to the selected text. You can also create visual indicators around all hyperlinks. This is controlled using the Appearance settings.

To set the appearance of a hyperlink:
1. Use the Type menu in the Appearance area to choose a setting for the visibility of the rectangle around the hotspot.
2. Use the Highlight menu to choose the appearance of the hotspot area when clicked.
3. Use the Width menu to choose the thickness of the visible rectangle.
4. Use the Style menu to choose a solid or dashed line for the visible rectangle.
5. Use the Color menu to choose a color for the rectangle.

Character Styles for Hyperlinks

The Appearance settings for hyperlinks add rectangles around the hyperlink. But you may want your hyperlink to look more like the links on Web pages: blue text with a blue underline. Once you have created a character style you can easily apply it as part of defining the hyperlink.

Of course all hyperlinks and other interactive elements also display the pointing finger symbol when you move the cursor over the link in the interactive document.

Use the Character Style menu to apply a text style to a hyperlink.

Use the Appearance settings to format the display of hyperlinks.

The easiest way to create a hyperlink destination is to create it as you define the hyperlink. However, it’s also possible to define destinations without defining the hyperlink. This is helpful if you have a lot of destinations that you want to define before you know where you will create the hyperlinks.

**Tip** Destinations don’t appear in the Hyperlinks panel, but are available when you define new hyperlinks.

**To create a page destination:**
1. Choose New Hyperlink Destination in the Hyperlinks panel menu.
2. Choose Page from the Type menu. This sets the Page destination controls A.
3. Use the Page number control to set the page destination.
4. Enter a name for the page destination or
   Click the option for Name with Page Number. This forces the destination name to the name of the page and the zoom setting.
5. Use the Zoom setting menu to set the magnification for the jump to that page.

You can set destinations for a URL. These are the links that are used to open Web pages.

**To create a URL destination:**
1. Choose New Hyperlink Destination in the Hyperlinks panel menu to open the New Hyperlink Destination dialog box.
2. Choose URL from the Type menu B.
3. Enter a name for the destination.
4. Enter the URL information.

---

**Tips for Hyperlinks**

Hyperlinks don’t have to be ordinary text or plain frames. You can use placed images, text inside tables, or even inline graphics as the source objects for hyperlinks.

If you use text as the source object for a hyperlink, you may not want to display the clunky rectangle as the link indicator. Instead, consider using an underline with colored text (applied as a character style) to indicate where the hyperlink is located. This changes the link so it is more similar to links in Web pages.
As you work, you can edit the settings for the hyperlink source.

**To edit hyperlinks:**
1. Double-click the hyperlink entry in the Hyperlinks panel or choose Hyperlink Options in the Hyperlinks panel menu.
2. Make changes in the Hyperlink Options dialog box.

**To delete a hyperlink:**
1. Select the hyperlink you wish to delete.
2. Click the Delete icon in the Hyperlinks panel or choose Delete Hyperlink/Cross-Reference from the Hyperlinks panel menu.

**To move to a hyperlink:**
1. Select the hyperlink in the Hyperlinks panel.
2. Choose Go to Source from the Hyperlinks panel menu or click the Go to Source icon in the Hyperlinks panel.

**To move to a hyperlink destination:**
1. Select the hyperlink in the Hyperlinks panel.
2. Choose Go to Destination from the Hyperlinks panel menu or click the Go to Destination icon in the Hyperlinks panel.

**Tip**
If the destination is a URL, the default Web browser will be launched.

**To fix a missing hyperlink:**
1. Select the hyperlink that displays the missing destination icon.
2. Double-click the hyperlink to open the Edit Hyperlink dialog box.
3. Set the new destination for the hyperlink.
Creating Cross-References

Cross-references are a subset of hyperlinks and are found at the bottom of the Hyperlinks panel. Like hyperlinks, cross-references create an electronic link from one part of a document to a destination in the same or different document. But cross-references go further than hyperlinks in that they also insert a reference to the page number or text. So you can automatically create a cross-reference on one page that says, “for more information see page ###.”

To define a cross-reference:

1. Place your insertion point in the text where you want the cross-reference to appear.
2. Click the Create New Cross-Reference icon in the Hyperlinks panel. This opens the New Cross-Reference dialog box.
3. Choose one of the following from the Link To menu:
   - *Text Anchor* sets the controls to a previously defined text anchor.
   - *Paragraph* sets the controls to text defined with a paragraph style.
4. Set the Text Anchor controls or set the Paragraph controls.
5. Use the Cross-Reference Format menu to control what text is placed inside the cross-reference.
6. Set the Appearance controls for the cross-reference.
To set a text anchor as a cross-reference:
1. With the New Cross-Reference dialog box open, use the Link To menu to choose Text Anchor c.
2. Use the Document menu to choose the current document.
   or
   Choose the Browse command at the bottom of the Document menu to choose a different document.
3. Use the Text Anchor menu to choose a previously defined text anchor.

To set a paragraph style as a cross-reference:
1. With the New Cross-Reference dialog box open, use the Link To menu to choose Paragraph.
2. Use the Document menu to choose the current document.
   or
   Use the Browse command to choose a different document.
3. Click one of the paragraph styles from the paragraph options d.
4. Choose one of the paragraphs shown in the text display.
A cross-reference can be formatted to include the paragraph text, a page number, a file name, and other aspects of the text. You use the Cross-Reference Formats.

**To set the cross-reference text:**
Choose one of the pre-made Cross-Reference Formats from the Format menu A.

**Tip** InDesign ships with these pre-made cross-reference formats already installed. So, for example, the format labeled “Page Number” will insert the cross-reference text “page #” into the text.

Cross-references are a type of hyperlink. So just like you can style hyperlinks, you can also format the appearances of cross-references.

**To set the appearance of a cross-reference:**
1. Use the Type menu in the Appearance area to choose a setting for the visibility of the rectangle around the hotspot B.
2. Use the Highlight menu to choose the appearance of the hotspot area when clicked.
3. Use the Width menu to choose the thickness of the visible rectangle.
4. Use the Style menu to choose a solid or dashed line for the visible rectangle.
5. Use the Color menu to choose a color for the rectangle.
Working with Bookmarks

Bookmarks provide a different way to navigate within a document. Instead of elements on the page, bookmarks are displayed in the Acrobat or Reader Bookmarks pane. The reader clicks each bookmark to move to that position in the document. One of the advantages to using bookmarks is that the Bookmarks pane can be always visible next to the area being read.

To create a bookmark:

1. Choose Window > Interactive > Bookmarks to open the Bookmarks panel.

2. Do one of the following to create the destination for the bookmark:
   - Place the insertion point within the text. This creates a text bookmark.
   - Select the text. This creates a text bookmark named with the selected text.
   - Select a frame or graphic. This creates a page bookmark.
   - Double-click a page in the Pages panel. This creates a page bookmark.

3. Click the New Bookmark icon in the Bookmarks panel.
   or
   Choose New Bookmark from the Bookmarks panel menu. The bookmark is added to the Bookmarks panel.

Tips:

- Icons show the difference between text and page bookmarks, although there are no such differences in Acrobat.

- If you already have bookmarks in the Bookmarks panel, the new bookmark is created directly under whichever bookmark is selected in the panel.
New bookmarks are created with the name *Bookmark 1, Bookmark 2*, and so on. You can rename the bookmark with a more descriptive name to help readers know what is located there.

**To rename a bookmark:**
1. Select the bookmark in the Bookmarks panel.
2. Choose Rename Bookmark from the Bookmarks panel menu. This opens the Rename Bookmark dialog box A.
3. Enter a new name in the field and click OK.

You can also rename a bookmark directly in the list area of the Bookmarks panel.

**To rename a bookmark in the list area:**
1. Click once to select the bookmark in the Bookmarks panel.
2. Click again to open the field that contains the bookmark name B.
3. Type the new name.
4. Press Return/Enter or click a different bookmark to apply the new name.

You can also delete bookmarks you no longer want in the document.

**To delete a bookmark:**
1. Select the bookmark in the Bookmarks panel.
2. Choose Delete Bookmark from the Bookmarks panel menu.
   - or
   - Click the Delete Bookmark icon in the Bookmarks panel.

---

**Loads of Bookmarks?**

What if you want to quickly make lots of bookmarks? Rather than doing it manually, you can cheat by creating a table of contents using InDesign’s Table of Contents command. As you create the TOC, InDesign can automatically create bookmarks for all the elements in the TOC.

While you do need to keep the TOC in the document in order to export the bookmarks into a PDF, the TOC doesn’t have to stay visible. Put the TOC on a non-printing layer to keep the bookmarks in the exported PDF.
Bookmarks don’t have to appear in the order that you create them. You can move important bookmarks up to the top of the list, even if they refer to pages that are at the end of your document.

**To move bookmarks to new positions:**
1. Drag the bookmark up or down the list to the new position.
2. When you see a black line appear, release the mouse button. The bookmark moves to the new position.

**TIP** Use the Sort Bookmarks command in the Bookmarks panel menu to rearrange the bookmarks into the order they occur in the document.

You can also nest, or move bookmarks so they are contained within others. The top bookmark is called the *parent*; the nested bookmark is called the *child*.

**To nest bookmarks:**
1. Drag the bookmark you want to nest onto the name of the parent bookmark.
2. When the name is highlighted, release the mouse button. The child bookmark is indented under the parent. A triangle controller appears that lets you open or close the parent bookmark.

**TIP** When you delete a bookmark, you also delete any bookmarks that are nested within that bookmark.

**TIP** You can continue to nest bookmarks through as many levels as you want.

**To unnest bookmarks:**
1. Drag the child bookmark out from the parent so that the black line is no longer indented below the parent bookmark.
2. Release the mouse button. The child bookmark is no longer nested.
Adding Sounds

Despite the mind-bending concept of adding sound to a page layout, it’s actually very simple to add sounds to an InDesign document. My favorite use for sounds is to add click effects that play when a button is pushed. I also might add short bits of music that play when a document is first opened.

If you know how to place an image into InDesign, you already know how to place a sound in a document.

To add a sound to a document:

1. Choose File > Place, and then choose the sound file you want to import. The cursor changes into the Sound Clip cursor A.

   Tip: You can also click the Place a Video or Audio File button at the bottom of the Media panel to place a sound file.

2. Click or drag the Sound Clip cursor to add the sound clip to the document.

   Tip: The sound clip contains a special icon within its frame that identifies it as a sound item B. This icon and stripes within the frame take their color from the layers panel they are on.
Once you have the sound on the page, you use the Media panel to modify and set the options for how the sound plays.

**To open the Media panel:**
Choose Window > Interactive > Media. The Media panel appears.[C]

![The Media panel controls are unavailable until a media file is selected.](image)

**To set the sound options:**
1. Select Play on Page Load to have the sound automatically play when the page is visible.
2. Select Stop on Page Turn to have the sound automatically stop when the page is no longer visible.
3. Select Loop to have the sound repeat until manually stopped.

![Without this option selected, the sound will continue until it finishes its run time.](image)
The Media panel also lets you play the sound from start to finish or select specific portions of the sound.

**To play a sound using the Media panel:**

1. Select the sound. The media panel shows the controls and poster image for the sound A.
2. Click the Play button to hear the sound. The play head moves along the sound play line to show how far into the sound length the sound has played.
3. As the sound plays, the Play button is replaced by a Stop button. Click the Stop button to stop the playback.

**Tip**
The two time indicators show how far along the playback is and the total length of time that the sound plays.

**Tip**
You can also use the SWF Preview panel to hear sounds.

If a sound file is going to be used in a PDF document, there are some additional controls you can set.

**To set the PDF sound options:**

1. Click the Export Interactive PDF icon on the Media panel or choose PDF Options from the Media panel menu. This opens the PDF Options dialog box B.
2. Enter the text that will be used as a tool tip for the sound clip. This lets sight-impaired users hear a description of what the sound contains so they can choose to activate the sound.

**Tip**
The rest of the options are for video files and are not available for sound clips.
When a sound is included on a page, it acts like a button that can play the sound when clicked. Therefore you might want to include a *poster*, or visual indicator, that lets people know that there is a sound on the page.

**To set the sound poster:**

Use the Poster menu to choose an image that will be used to show where the sound is in the document C:

- **None** leaves the sound clip frame empty D.
- **Standard** uses the standard sound poster image E.
- **From File/Choose Image** lets you import a custom image to use as the sound poster F. Use the Choose button to choose the custom image.

**Tip** The standard sound icon is actually the image `StandardSoundPoster` stored in the Presets > Multimedia folder in the InDesign application folder. You can open this file and make changes to it. This will then become your standard sound file poster.
**Movies and Animations**

One of the more exciting multimedia features is the ability to add movies to your electronic documents.

**To add a video to a document:**

1. Choose File > Place and then choose the movie file you want to import. The cursor changes into the Video Clip cursor A.
2. Click or drag to place the video on the document. This adds a video object to the document. Video objects are identified by the Video Clip icon B.

**Tip** You can also click the Place a Video or Audio File button at the bottom of the Media panel to place a video file.

Once you have the video on the page, you use the Media panel to modify and set the options for how the video plays.

**To open the Media panel:**

Choose Window > Interactive > Media. The Media panel appears C.

**Tip** The Media panel controls are unavailable until a media file is selected.

**To set the video options in the Media panel:**

1. Select Play on Page Load to have the video automatically play when the page is visible.
2. Select Loop (SWF export only) to have the video repeat until manually stopped. This option will not apply if the file is exported as a PDF.

**Tip** If you need a video to loop, but are exporting as a PDF, you can apply a loop setting in the program, such as Adobe Premiere, that creates the video.
Like sound files you can set poster options for movies. However, since they are movies, they have more options than sounds.

**To set the movie poster options:**

1. Use the Poster menu to choose an image that will be used to show where the movie is in the document D:
   - **None** leaves the frame empty.
   - **Standard** uses the standard video file icon.
   - **From Current Frame** uses the frame currently displayed in the Media Panel.
   - **Choose Image** lets you import a custom image to use as the movie poster.

2. Use the Controller menu to apply a controller that can be used to control the playback of the movie as well as play it in full screen and show captions E.
   - The name of each controller explains which features it has. For instance, SkinOverAll contains all the features F. SkinOverPlay contains only the Play button.

3. Select Show Controller on Rollover to have the controller appear and disappear when the mouse moves inside and outside the area of the video.
   - When Show Controller on Rollover is not selected, the controller appears throughout the video playback.
The Media panel also lets you play a movie from start to finish or move to specific portions of the movie.

**To play a movie using the Media panel:**

1. Click the Play button to play the movie within the preview area of the Media panel.
2. As the movie plays, the Play button is replaced by a Pause button. Click the Pause button to stop the playback.
3. Click the Sound button to mute the sound during the playback.

Tip: The two time indicators show how far along the playback is and the total length of time that the movie plays.

If a movie file is going to be used in a PDF document, there are some additional controls you can set.

**To set the options for a video in a PDF document:**

1. Click the Export Interactive PDF icon on the Media panel or choose PDF Options from the Media panel menu. This opens the PDF Options dialog box.
2. In the Description field, enter the text that will be used as a tool tip for the video clip. This lets sight-impaired users hear a description of what the video contains.
3. Click Play Video in Floating Window to have the video display in a separate window above the PDF file.
4. If you have the video play in a floating window, you can set a size for the display. Use the Size list to choose a size for the video.
Creating Buttons

Buttons are more powerful than simple hyperlinks. Buttons contain the code that can send you to destinations, flip pages, open Web pages, play movies, show and hide other buttons, and other tricks.

You use the Buttons and Forms panel to create and apply actions to Buttons.

To view the Buttons and Forms panel:
Choose Window > Interactive > Buttons and Forms to open the Buttons and Forms panel.

To create and name a button:
1. Select an object. Any object, except media files, can be used as a button.
2. Choose Object > Interactive > Convert to Button or click the Convert Object to Button icon in the Buttons and Forms panel. The object displays the button icon.
3. Use the Name field in the Buttons and Forms panel to change the default name to something more descriptive.

Tip I usually name my buttons with their function. So, for example, buttons that move to the previous page and the next page are labeled Previous Page and Next Page.

Tip When a button is selected, the Buttons and Forms panel displays all the interactive options for the button.

If you need to, you can remove the button properties from an object.

To remove the button properties:
1. Select the button object.
2. Choose Object > Interactive > Convert to Object or click the Convert Button to Object icon in the Buttons and Forms panel.

The Buttons and Forms panel for a selected button.

The Convert Object to Button icon at the bottom of the Buttons and Forms panel.

The Button icon appears inside an object that has been converted into a button.

The Convert Button to Object icon at the bottom of the Buttons and Forms panel.
A button without an action is like a light switch that’s not connected to a lamp. You can click the button all you want, but nothing’s going to happen. There are two parts to setting actions. First you choose the type of event that will prompt the action.

**To choose the event for a button action:**

Use the Event menu to choose what type of mouse or keyboard action should prompt the button to perform the action.

- **On Release or Tap** applies an action under two circumstances: when the mouse button is released after a click or when a tablet screen is tapped.
- **On Click** applies an action as the mouse button is pressed down.
- **On Roll Over** applies an action when the mouse cursor is moved over the button’s bounding box.
- **On Roll Off** applies an action when the mouse cursor is moved away from the button’s bounding box.
- **On Focus (PDF)** applies an action when the button is prompted by the Tab key. This event only works for buttons in PDF documents.
- **On Blur (PDF)** applies an action when the Tab key takes the focus off the button. This event only works for buttons in PDF documents.

You can set multiple events for a button. For example, a button can play a sound when the mouse rolls over the button but open a Web page when the same button is clicked.

### A Button Trick

My favorite use for buttons is to use the On Roll Over and On Roll Off events to show and hide other buttons. Usually I set the button to show the image on roll over and then hide it on roll off. Or I show the image on the mouse click and hide it on the mouse release.
Once you have chosen the mouse event, you then choose the action that follows the event.

**To choose the action for a button event:**
1. Click the Add New Action icon from the Actions area of the Buttons and Forms panel. This displays the Actions menu.
2. Choose the action that you want to apply. The action appears in the Actions area of the Buttons and Forms panel.
3. Depending on the action, additional controls may appear in the Buttons and Forms panel. Set those controls as necessary.
4. If desired, you can apply more actions to the button by repeating steps 1–3.

**To delete the action for a button event:**
1. Select the action in the Actions area.
2. Click the Delete Action icon.

**Tip** Instead of deleting an action, you can disable it by clicking its check mark. This keeps the action available, but it does not export with the button.

If you have multiple actions for an event, the actions are applied in the order that they appear in the list. You can change this order of how the actions are applied.

**To change the position of an action:**
Drag the action up or down in the Actions list.

**Tip** The order that the actions appear can be important when playing sounds and movies. For instance, you might want the action for a click sound to play before the action to play a movie.
One of the benefits to working with buttons is the ability to change the appearance so that the button itself responds to the actions of the user. When you create a button, it only has one appearance called the Normal state. You need to create new appearances for the Rollover and Click button states.

To set the appearances of a button:
1. Select the button. Unless you have already modified it, only the [Normal] state is active in the Buttons and Forms panel A.
   
   **Tip:** The [Normal] state displays the appearance of the button when the mouse is not near it.
2. Click the [Rollover] state listing in the Buttons and Forms panel. This activates the state.
   
   **Tip:** The Rollover state displays the appearance of the button when the mouse cursor enters the button area.
3. Click the [Click] state listing in the Buttons and Forms panel. This activates the state.
   
   **Tip:** The [Click] state displays the appearance of the button when the mouse presses down on the button.

To make changes to each appearance state:
1. Select the button you want to modify.
2. In the Buttons and Forms panel, select the state that you want to modify.
3. Use any of InDesign's styling features to add a fill, stroke, or effect to the object. Use the Type tool to insert text as a label. You can also insert different images for each state.

To delete button states:
1. Select the state you want to delete.
2. Click the Delete State icon B.
   
   **Tip:** You cannot delete the [Normal] state.
Instead of deleting states, which tosses out their content, it may be better to change whether or not the state is exported.

**To change the visibility of a state:**
Click the eyeball next to the name of the state. If the eyeball is visible, it means the state is enabled and will export. If the eyeball is not visible, it means the state is disabled and will not export.

### Sample Buttons

In addition to creating your own buttons, Adobe has generously provided a library of pre-made buttons that already have rollover states as well as actions to go to pages and Web addresses.

**Tip** The Sample Buttons And Forms library also contains forms objects which can be used to create interactive PDF forms. (See “Creating PDF Forms” on page 428.)

**To access the Sample Buttons And Forms library:**
Choose Sample Buttons And Forms from the Buttons and Forms panel menu. The library appears.

Once you have the sample buttons visible, you can easily add buttons to a document.

**To place buttons from the Sample Buttons And Forms library:**
Drag the buttons onto your document page. Or, select the buttons in the library and choose Place Item(s) from the panel menu.

**Tip** The sample buttons can be customized with new states, actions, and events like any other button.

---

![A portion of the sample buttons in the Sample Buttons And Forms library.](Image)

---

InDesign CS6 Visual Quickstart Guide  427
Creating PDF Forms

Most likely you’ve gotten a PDF where you click inside the areas of the form and fill it out with the information requested. InDesign lets you add form fields to your documents so you can create these interactive PDF files without having to open Acrobat.

You use the Buttons and Forms panel to create forms.

To view the Buttons and Forms panel:
Choose Window > Interactive > Buttons and Forms to open the Buttons and Forms panel.

To create and name a form:
1. Select an object. Any object, except media files, can be used as a form.
2. Choose Object > Interactive > Convert to [form name] or choose one of the types of forms from the Type menu in the Buttons and Forms panel. The form icon appears in the object.

   Tip: The form icons change depending on the type of form chosen.

3. Use the Name field in the Buttons and Forms panel to change the default name to something more descriptive.
4. Leave the Event menu as On Release or Tap.
5. Use the Action controls to apply actions as described on page 425.
6. If you have chosen a check box or radio button, style the Appearance states as described on page 426.
7. Fill in the PDF options as described in the next exercise.
To set the options for a PDF form:
1. Fill in the Description field with the text that will be used as a tool tip for the form field. This lets sight-impaired users hear a description of what the form field does.
2. Check the options as follows:
   - **Printable** allows the field to be printed.
   - **Required** means the form can not be submitted unless that field is filled.
   - **Password** hides the field’s content as a series of asterisks.
   - **Read Only** prevents the contents of the field from being modified.
   - **Multiline** allows text to wrap to multiple lines.
   - **Scrollable** applies scroll bars if the contents exceed the depth of the field.
   - **Selected by default** applies the selection when the form is first opened.
   - **Sort Items** arranges the list items alphabetically or numerically.

3. If you have chosen List Box or Combo Box, use the List Items controls to select the menu items for the form.
4. If you have chosen List Box or Combo Box, set the Font Size for the menu items.

**Sample Forms**
Like the sample buttons, you can use the Sample Buttons And Forms library to drag out pre-made forms. See page 427 for how to access the library for the sample forms.

**Tip** The sample forms consist primarily of radio buttons and check boxes with one set of combo boxes for the numbers 1–12 and 1–31.
Animating InDesign Objects

Instead of having to go to Flash or some other animation program, I can animate the items on the InDesign page and export the result as a SWF video. This section will show you the controls that let you create this type of animation.

The primary controls for working with animated objects require the use of the Animation panel.

To open the Animation panel:
Choose Window > Interactive > Animation. The Animation panel appears A.

To add animation to an object:
1. With the object selected, choose one of the motion presets from the Preset list B. This applies an animation to the object as indicated by the Animation icon.

   The butterfly image in the Animation panel displays a preview of the action of the animation.

2. If desired, use the Name field to change the generic name of the object into something more descriptive. This is especially helpful if you have many animated objects on the spread.

   The Animation Preset menu contains the preset motions and effects you can apply to objects.
To set the events that prompt the animation:

Use the Event(s) list to choose what mouse or page actions trigger the animation:

- **On Page Load** starts the animation when the page is visible.
- **On Page Click** starts the animation when the mouse clicks anywhere on the page.
- **On Click (Self)** starts the animation when the object is clicked.
- **On Roll Over (Self)** starts the animation when the mouse moves over the area of the object.

**Tip:** If you choose On Roll Over (Self), you can select Reverse on Roll Off to play the animation backwards when the mouse moves away from the object.

**Tip:** The menu item for On Button Event is applied by using the Create Button Trigger icon or by setting a button action in the Buttons panel.

To set the timing and speed settings:

1. Use the Duration field to choose for how long (in seconds) the animation plays.
2. Use the Play field to choose how many times the animation repeats. Select Loop to have the animation repeat endlessly.
3. Use the Speed list to choose how the motion accelerates or decelerates:
   - **None** keeps a constant speed throughout the animation.
   - **Ease In** starts slowly and speeds up.
   - **Ease Out** starts at a constant speed and slows down at the end.
   - **Ease In and Out** starts slowly, remains constant for a while, and then slows down.
The InDesign team figured (rightly) that people would want to quickly make buttons that can play animated objects.

**To create a button to control an animated object:**

1. Select the animated object.
2. Click the Create button trigger icon in the Animation panel A.
3. Click the object that you want to act as a button to play the animation. The object is converted into a button (if necessary) and the controls to play the animation are applied.

   **Tip** You can then make any modifications to the button in the Buttons panel.

If you no longer want an object to be animated, you can convert it back into an ordinary object.

**To remove the animation applied to an object:**

1. Select the animated object.
2. Click the Remove Animation icon in the Animation panel B.

A Use the Create Button Trigger icon to quickly set a button to prompt an animated object.

B Click the Remove animation icon to delete any animations applied to an object.
Timing

Just as in comedy, when working with animation timing is everything. So in addition to the duration controls in the Animation panel, the Timing panel gives you additional control over how an animation plays. There are two main features for what the Timing panel does. The first allows you to set a delay for when animated objects start their animation.

**To set the delay for animated objects:**

1. Open the Timing panel (Window > Interactive > Timing). All the animated objects for that spread are listed in the Timing panel area.

2. In the Timing panel, not on the page itself, click the name of the object you want to control.

3. If you have applied an event to control the animated object, use the Event list to choose the event that triggers the object.

4. Use the Delay field to set the amount (in seconds) that the object’s animation will be delayed.

The Timing panel also lets you control the order that objects are animated.

**To change the order that objects are animated:**

Drag the name of the object up or down in the list in the Timing panel. Objects are played from the top of the list down.
Each object in the Timing panel plays individually. However, you can link objects so they play at the same time.

**To set objects to animate together:**
1. Select the names of the objects in the Timing panel.
2. Click the Play Together icon in the Timing panel. A bracket appears around the selected items indicating they will play together.
3. If you have items linked to play together, you can use the Play field and Loop control to control how many times they play.

Tip: Click the Play Separately icon to release the items from playing together.

---

**Timing Is Everything!**

Even the slightest change in timing can make an enormous difference in the effectiveness of an animation. While I can’t anticipate every timing situation, here are some general rules I try to follow.

**Take a moment.** When items are set to play on the loading of a page, you may want to set a slight delay before they play. This gives your viewers a moment to get accustomed to the setting.

**Keep the pacing up.** Nothing is more boring than elements that move too slowly on the page. This means that the speed of the animation as set in the Animation panel as well as the Timing panel should be short. Your audience can anticipate where an object is moving. So don’t bore them by making them watch it happen.

**Don’t loop unless you mean it.** Setting something to endlessly play on a page is distracting. But that doesn’t mean you can’t loop objects such as wheels on a car that moves across a page. The wheels should loop in that situation.
Multi-State Objects

Instead of cluttering up my bookshelf with hundreds of pictures of my family, friends, and pets, I have an electronic screen that displays all my pictures in a single picture frame. That’s what a multi-state object is like. A regular InDesign frame displays only a single image or text content. But multi-state objects are special frames that can display more than one image or text content. You can then cycle through the multi-state object in a presentation to show many different items.

**TP** Multi-state objects don’t work when exported to PDF documents.

**To create a multi-state object:**

1. Choose Window > Interactive > Object States. This opens the Object States panel A.
2. Select the object that you want to convert into a multi-state object.
3. Click the New State button B. This adds a multi-state name to the object and adds a second state to the object.

**TP** Multi-state objects are identified by the Multi-state Object icon.

**To change the name of the multi-state object:**

1. Double-click the name in the Object Name field.
2. Type a new name.
3. Press Return to apply the new name.

**To add states to a multi-state object:**

1. Click the New State button.
2. Repeat to add as many new states as you want C.
Adding and modifying multi-states one at a time takes too much time. What you want to do is select a whole bunch of objects and convert them into a multi-state object.

**To create a multi-state object from existing frames:**
1. Select all the objects that you want to use in the multi-state object A.
2. Click the New State button in the Object States panel. This converts each object into a new state within a multi-state object.

   **Tip**
   Hold the Opt/Alt key to convert all the objects into a single state of the multi-state object.

   **Tip**
   The objects appear in the multi-states in the same stacking order that they were on the page.

Once you have a multi-state object, you can modify the object as a whole or change the contents of a particular state.

**To modify the content of a state:**
1. Select the multi-state object with the Selection tool.
2. Double-click the name of the state that you want to modify. This selects the state.
3. Switch to the Direct Selection tool. The icon changes to indicate the content of the state has been selected B.
4. Make whatever changes you want to the content of the multi-state.

   **Tip**
   Click with the Direct Selection tool to select the last active state in the object in the content mode.

5. Click the Paste Copied Content icon in the Object States panel C. The pasted content is added to the state.
Working with the SWF Preview Controls

Interactive elements don’t react on the InDesign page. Fortunately, you can preview if your elements are set correctly.

TIP The previews of the interactive documents are for SWF output. If you want to see the PDF attributes, you need to view the PDF in Acrobat.

To use the SWF Preview panel:
1. Choose Window > Interactive > SWF Preview. This opens the SWF Preview panel.
2. Choose one of the preview selection mode buttons:
   - Preview Selection sets the Preview panel to display just the selected object. Use this when you have many interactive elements on a page and need to test just one or two elements.
   - Preview Page sets the Preview panel to display the spread currently selected.
   - Preview Document sets the Preview panel to display the entire document.
3. Click the Play Preview button.
4. If you edit the document, use the Clear Preview button to delete the previous version of the document from the Preview panel.
5. Use the Next Page and Previous Page buttons to move through the document.
6. Move your mouse over the preview area of the Preview panel. Interactive elements react with the mouse cursor as they would in the exported SWF.

TIP Drag the corners or edges of the Preview panel to increase the size of the preview area in the panel. This makes it much easier to control small interactive items.
Setting Page Transitions

Transitions are the effects that are applied when the viewer moves from one page to another when viewing the document in Acrobat or the Flash Player.

To set the transitions using the Page Transitions panel:

1. Select the pages in the Pages panel to which you want to apply a transition.

2. Choose Window > Interactive > Page Transitions. This opens the Page Transitions panel A.

3. Choose one of the transitions from the Transition menu B.

4. If applicable, set the Direction C and Speed D for the transition.

Tip: Click the Apply to All Spreads icon E or choose Apply to All Spreads from the panel menu to apply the transition to all the spreads in the document.

A The Page Transitions panel displays the preview of each page transition.

B Choose a transition from the Transition menu in the Page Transitions panel.

C If needed, use the Direction list to apply the direction to a page transition.
To set the transitions using the Pages panel:

1. Select the pages in the Pages panel to which you want to apply a transition.
2. Choose Page Transitions from the Pages panel menu. The Page Transitions dialog box appears.
3. Select one of the transitions.

Tip: Click Apply to All Spreads to apply the transition to all the spreads in the document.

You may need to clear all the transitions applied to pages.

To clear all the page transitions:

1. Choose Clear All from the Page Transitions panel menu or Page Transitions > Clear All from the Pages panel menu.

Page Turn or Page Curl?

The Page Turn is a page transition that allows any button to trigger the effect of turning a page. The Page Turn also is applied when the arrow keys on the keyboard are invoked to move from page to page.

When you export the document as a SWF, you have the option of adding a Page Curl. The Page Curl is an interactive effect that allows the reader to move the mouse to any corner and pull the page to the next or previous page.
This page intentionally left blank
A

Above Line anchored objects, 228–229
absolute numbering, 257, 518
Accept Change icons, Track Changes, 342
actions
   creating for button events, 425
   PDF forms, 428
Add Anchor Point tool, 178, 184
Add command, Pathfinder, 164
Adjust View Settings menu, 211–212
Adobe
   Bridge. see Bridge
   Flash, 511
   Mini Bridge. see Mini Bridge
   Paragraph Composer, 389
   Photoshop. see Photoshop
   Swatch Exchange (.ase) file, 126–127
   World-Ready Composers, 389
Adobe.com, 37
Advanced options
   exporting documents as SWF files, 510
   exporting EPUB files, 506
   exporting HTML files, 507
   new document set up, 12
   printing, 473
   table of contents, 267–269
Advanced Type preferences, 524
Alert icon, Book panel, 262
alignment
   of above line anchored objects, 229
   with Align panel, 101–103
   of captions, 338
   customizing alignment character, 293
   of drop caps, 65
   fitting graphics in frames, 203
   forcing text into, 396–398
   of objects, 101–103
   optical margin, 388
   of paragraphs, 59
   of strokes, 146
   of tab stops, 291
   of text, 59–60
   of text on a path, 222
   using ruler guides for. see ruler guides
   using Smart Guides for, 26
   using vertical justification of text, 74
All Caps
   as electronic style, 52
   OpenType, 402
Alpha Channel contour, text wraps, 216
alphabetizing, TOC entries, 269
alternate layouts, 233, 448–449
anchor points
   changing curves and corner points, 175
   creating corner curves with, 174
   creating line shapes with, 173
   modifying, 178–179
   as path element, 172
anchored objects, 227–230
animation
   exporting as FLA files, 511
   of InDesign objects, 430–432
   movies and, 420–422
Appearance of Black preferences, 541
Application bar, 13, 30, 36–37
Arrange commands, 100
Arrange Documents menu, 37
arrows, adding to objects, 154
artboard
   different sized pages on, 22
   moving pages on, 240
artwork, imported. see imported graphics
Ascender, aligning text on a path, 222
ASCII (American Standard Code for Information Interchange) text, 242, 245
.ase (Adobe Swatch Exchange) file, 126–127
attributes
   blend mode or opacity, 157
   cell style, 381
   character, 76
   drop cap, 65
   master page, 250
   object style, 380
   paragraph, 58, 76
   redefining style, 371
   sampling with Eyedropper, 167–168
   searching object, 336
   setting eyedropper options for text, 352–353
   table style, 382
audio, adding, 416–419
Auto Leading, 54, 393
Autocorrect preferences, 534
Autocorrection, spell check, 329
auto-fit commands, 200, 203, 454–455
autoflow cursor, 247
automatic drop cap styling, 373
automatic page numbering, 256, 263, 266
automatic table of contents, 269
automatic tiling, 462
automating your work
   adding captions to images, 337–339
   changing text case, 326
   conditional text, 343–345
conditional text sets, 346
footnotes, 347–349
keeping lines together, 351
overview of, 325
saving searches, 336
spell checker, 326–329
tracking text changes, 341–342
using Eyedropper on text, 352–353
using Find Font, 350
using Find/Change, 330–331
using Glyph Find/Change, 335
using GREP Find/Change, 334
using Object Find/Change, 336
using scripts, 354
using Story Editor, 340
using text Find/Change, 332–333
auto-rename, styles, 365

B
balancing
columns, 73
ragged lines, 399
base color, tint swatches, 129–130
base style, 361
baseline
controlling in table cells, 315
shifting text away from, 55
vertically aligning text on a path, 222
baseline grid
preferences, 528
working with, 28, 396–398
basic options, document setup, 11–12
bevel effect, 161
Bevel Join setting, strokes, 145
Bezier curves, mathematics of, 172
black color
appearance preferences, 541
in CMYK vs. RGB, 117
not able to be modified, 123
Black color panel, 116
black eyedropper, 167, 353
black precision eyedropper, 168
blank pages
adding to book, 234
adjusting page numbers by inserting, 263
creating preflight profiles, 487
printing, 460
blank spreads, printing, 481
bleed
advanced document options, 12
creating printer’s spreads, 481
PDF compression options, 499
setting for printing, 464–465
showing area with bleed guides, 23
Bleed view mode, documents, 31
blend modes
applying opacity and, 156–157
flattening transparency, 476
removing effects, 158
setting transparency effects, 212
blur events, buttons, 424
Book panel, 261
bookmarks, 404, 413–415, 496
books. see pages and books
borders
applying to cells, 302
indicating key object, 102
setting table, 316–318
breaks, creating text, 248
Bridge
adding metadata to image in, 337
finding linked file in, 207
libraries in, 283
opening from Application bar, 36
placing artwork from, 190
placing multiple PDF pages from, 198
previewing snippets in, 288
bullets, 61–63, 242
buttons
controlling animation, 432
creating, 423–427
defined, 404
C
Cap settings, strokes, 144–145
capitalized words, hyphenating, 395
captions, image, 337–339
case, changing text, 326
case sensitivity
of Find/Change searches, 330, 332
of PDF passwords, 502
in spell check, 326, 328
of text style names, 364
categories, OpenType, 401–402
cell styles, 382–386
center alignment, 146, 222
Changes Allowed menu, PDFs, 503
chapter numbers, 258, 264
Character icon, 76
Character panel
Glyphs panel vs., 69
language setting, 57
leading and spacing setting, 54–55
styling text, 52–53
working with text, 50
character styles
applying nested styles to, 374–376
applying to drop caps, 65, 373
clearing style overrides, 369–370
creating nested line styles, 377
(no natural text available)
deleting in table cells, 305
layer, 279–280
Content Collector, 442, 447
Content Conveyor, 442–444
content grabber, 199–200
Content Placer, 443, 445
contextual menus, 8, 19–20, 359
continued to/from characters, page numbers, 259
Contour Options, text wraps, 216–217
control handles, 172, 174–176
Control panel, 50–51, 323–324
Controlled by Master rule, 451
Controller menu, movies, 421
copies
controlling number of printed, 459
exporting for InCopy, 504
saving documents as, 39
copying
artwork between frames, 188
content in table cells, 306
moving text by, 48
object while dragging, 85
objects, 86
PDF to clipboard, 544
placing objects into clipboard, 48
with Scale, Rotation, and Shear tools, 90
corner curve point, 174, 179
corner options, 154–155
corner points, 173–175
corners setting, dashed strokes, 148
correction, spell check, 326
creep, creating printer’s spreads, 481
cropping
auto-fit commands, 454–455
Frame Fitting Options, 203
setting for printing, 464
cross-references, 404, 410–412
Ctrl key, 47
cursors
autoflow, 247
interface preferences, 520
link text, 70
loaded image, 186–188
loaded text, 242, 246–247
Padlock, 111
preferences for display, 538
curves, 172–175, 182
customizing
Advanced Type preferences, 524
anchored objects, 230
Appearance of Black preferences, 541
Autocorrect preferences, 534
bullet characters, 62
choosing preference categories, 518
Clipboard Handling preferences, 544
composition preferences, 525–526
dashed strokes, 148
Dictionary preferences, 530–532
Display Performance preferences, 539–540
document ruler unit of measurement, 19
File Handling preferences, 542–543
fill inside individual table cells, 318
frames for artwork, 187
General preference controls, 518–519
Grids preferences, 528
Guides & Pasteboard preferences, 529
Interface preferences, 520–521
keyboard shortcuts, 514–516
Link Info items, 207
menu commands, 517
Notes preferences, 535
overview, 513
Quick Apply, 388
saving custom workspace, 4
size of page, 21
Spelling preferences, 533
Story Editor display preferences, 538
strokes around individual table cells, 317
style import, 367
table cells, 313–315
text wraps, 218
Track Changes preferences, 536–537
trashing preferences, 544
Type Preferences, 522–523
Underline and Strikethrough text, 53
Units and Increments preferences, 526–527
workspace keyboard shortcuts, 5
Cut command, 86
D
dashed strokes, 148–149, 151
decimal places, and Excel cells, 298
default colors, creating, 127
default figures, OpenType, 402
default strokes, Stroke panel, 147
Default View Settings list, images, 210
defaults
resetting document, 15
resetting object, 169
resetting Pencil tool, 181
resetting Smooth tool, 182
resetting text, 50
definition, resolving style conflicts with, 365
deformity, from strokes, 143
delay, animation timing, 433
Delete command, 184
deleting
Anchor Point tool, 178, 184
animations, 432
bookmarks, 414
button events and states, 426
corner events and states, 426
definition, resolving style conflicts with, 365
deformity, from strokes, 143
delay, animation timing, 433
content in table cells, 305
dictionary, 530
document presets, 17
effects, 158
gradient color stop, 133
hyperlinks, 409
keyboard shortcuts, 516
layer items, 280
layers, 273, 278
library items, 283
nested bookmarks, 415
pages, 238
paragraph styles that are in use, 372
parts of paths with Erase tool, 183
path segments, 179
points on paths, 184
preferences, 544
preflight profiles, 488
print presets, 478
ruler guides, 25
stroke styles, 153
styles, 371–372
swatches, 124–125
tab stops, 293
table columns and entire table, 305
text, 48–49
text Find/Change formatting options, 333
transparency flattener presets, 475
words from Autocorrect list, 534
workspaces, 4
Descender, aligning text on a path, 222
Description field, PDF forms, 429
destination, hyperlinks, 405–406, 408
device-independent PostScript files, 483
diagonal lines, 80, 322
dictionary, spell check, 328–329, 397
Dictionary preferences, 530–532
Digital Publishing with Adobe
InDesign CS6 (Cohen and Burns), 505, 510
dimensions, 104, 161
Direct Selection tool
frame containing image modified with, 200
item in group displayed with, 106
multi-state objects modified with, 436
pasted-in content removed with, 107
path segments deleted with, 179
paths modified with, 176–177
placing artwork with, 187–188
scaling objects with, 96
selecting frames with, 112
Selection tool vs., 83
text running on outside of path with, 220
text wrap contour with, 216
transform tools controlled by, 89
direction, page transitions, 438
directional feathers, adding, 162
discretionary hyphens, 395
Display Performance preferences, 539–540
distances, measuring, 108–109
distorting object shape, 92–93
distorting text, 56
distributing objects, 102–103, 307–308
inked objects, interface preferences, 521
docked panels, interface preferences, 521
document page
converting to master page, 251
creating island spread, 241
defined, 234
dragging buttons onto, 427
dragging snippets onto, 288
master page overlay applied to, 238
modifying size of, 239–240
page numbers on, 256
Pages panel display for, 232–233
preflight profiles for, 487
preparing for table of contents, 265
section marker on, 257
shuffling, 238
Story Editor and, 340
working with master pages, 249–254
Document Recovery Data, file preferences, 542–543
document setup
advanced options, 12
Application bar, 36–37
basic options, 11–12
collapsing panel to, 2
grids, 28
guides, 23–25
Hand tool, 34
layout options, 13–16
magnification, 29–30
Page tool, 21–22
presets, 17–18
rulers, 19–20
Smart Guides, 26
Split Window feature, 35
view and pasteboard controls, 31–32
viewing Transformation Values, 26
Welcome Screen, 10
Zoom tool, 33–34
documents
adding library items to, 283
adding to book, 260
changing order in book, 261
default settings on, 169
grid preferences, 528
Info panel display for, 109
interface preferences, 521
linking graphics in, 204–205
master element modifications, 252
opening in book, 261
glyph set characters, 69
glyphs, 409
hyphenation in dictionary, 397
keyboard shortcuts, 514–516
layers of placed file, 208
linked graphics, 206
pasting text, 48
paths with Pencil tool, 180–181
stroke styles, 151
styles through Quick Apply, 385
text quickly, 47
transparency flattener presets, 475
using Story Editor, 340

effects. see also text effects
applying to text on a path, 221
bevel and emboss, 161
feather, 162–163
fills, 138–142
Global Light settings, 163
glow, 160
opacity and blend mode, 156–157
opening Effects dialog box, 158
removing, 158
satin, 161
setting object defaults, 169
setting paragraph, 63
shadows, 159
strokes. see strokes
using Eyedropper for, 167–168
using Pathfinder for, 164–166
working with, 158
elementary book file, creating, 260
electronic styles
applying text distortion, 56
applying to text, 52
language settings, 57
myths and realities of, 57
setting line and character spacing, 54–55
elements
setting to not print, 458
types of interactive, 404
Ellipse Frame tool, 80–81
Ellipse tool, 42–44, 80
Email option, hyperlinks, 406
emboss effect, 161
End Nested Style Here character, 376
endnotes, 349
Entire Pasteboard command, 29
EPS, Image Import Options, 194–195
EPUB files, exporting, 505–506
Erase tool, 183–184
elements
Autocorrect preferences, 534
preflight profiles and, 484, 486–487
Spelling preferences, 533
applying inDesign defaults to, 169
applying to object, 138
customizing in individual table cells, 318
dragging onto objects, 138
resizing graphic to fill frame, 201
sampling with Eyedropper, 167–168
setting for tables, 316–321
swapping strokes and, 142

Find command, 515, 533
Find Font command, 350
Find/Change commands
choosing mode, 330
control buttons, 331
Glyph, 335
GREP, 334
Object, 336
setting search areas, 330
text, 332–333
undo after, 331

first baseline
footnote settings, 349

Fitting commands, 29, 201, 203
fixed-page autoflow cursor, 247
FLA files, exporting, 511
flattening, and printing, 473, 474–477
flipping, 98, 466
flow tables, 309
flow text, 70, 246–248
fly-out panels, opening tools in, 6
focus events, buttons, 424
fonts
Advanced Type preferences, 524
bullet, 61–62
display preferences, 538
drop caps as, 64–65, 373
General preferences, 519
OpenType, 399–402
packaging for printing, 490
printing options, 472
setting typeface and point size, 51
type preferences, 522–523
Type Preferences, 522–523
using Find Font, 350
using Glyphs panel, 67

footers, table
changing number of, 303
converting cells into, 311
creating new table in text frame, 295
working with, 310–311

footnotes
as Find/Change search area, 330
first baseline settings, 349
inserting and formatting, 347–348
placement options, 349
rule settings, 349
spacing options, 348

Eyedropper tool, 135, 167–168, 352–353

F
facing pages, 11, 13–14
Fast, Default View Settings, 210–211
feather effects, 162–163, 212
Fewer Options button, documents, 12
Fidelity settings
Pencil tool, 181
Smooth tool, 182
File Handling preferences, 542–543
File Info, adding metadata to image, 337
File option, hyperlinks, 406
files
exporting. see exporting
maintenance of, 38–40
packaging for printing, 490
replacing/updating in books, 262
Fill icon, 124, 131, 138–142
fills
alternating with strokes for tables, 319–321
applying, 138–141
applying colors to, 119

InDesign CS6 Visual Quickstart Guide 551
formatting  
best Illustrator file, 194  
controlling Word Import options, 242  
Excel cells, 298  
for exporting, 492–493  
eyedropper options for text, 352  
File Handling preferences, 543  
footnotes, 347–348  
importing text files, 242  
nested styles, 374–376  
paragraphs, 58–63  
preserving table cell, 316  
saving files, 38  
setting character style, 360  
supported graphic files, 187  
tab stops, 291–293  
text Find/Change options, 333  
text from Character panel, 50  
TOC entries, 267  
Word tables, 299  

forms  
creating PDF, 428–429  
defined, 404  
Frame Fitting Options, 203, 454  
frame handles, 202  
frames  
fitting graphics, 201–203  
graphic. see graphic frames  
placing artwork, 186–189  
positioning paragraph rule, 224  
selecting, 112  
specialty shaped, 191–193  
text. see text frames  
types of, 80  
unassigned. see unassigned frames  
working with images in, 199–200  

Free Transform tool, 93  
FreeHand, 193  

G  
Gap tool, 105  
gaps  
customizing dashed strokes, 148  
overprint settings, 136  
stroke color settings, 147  
styling paragraph rules, 224  
General preference controls, 518–519  
ghost area, in images, 156  
global defaults, setting, 169  
global light settings, 163  
globally, tracking text changes, 341  
glow effects, 160  
Glyph Find/Change, 330, 335  
glyphs  
customizing bullet characters, 62  
inserting characters with Glyphs panel, 67–69  

OpenType, 400  
scaling, 392  
understanding, 69  
Grabber tool. see Hand tool  
gradient feathers, 163  
gradients fills, 139–140  
Gradient panel, 134, 139  
gradients strokes, 143  
gradients swatches, 132–134  
Gradient tool, 140  
Graphic Frame contour, text wraps, 216  
graphic frames, 80–81, 112  
grahics  
adding to tables, 312  
auto-fit commands, 454  
imported. see imported graphics  
packaging for printing, 490  
positioning guides behind, 23  
printing options, 472  
sampling colors with Eyedropper, 135  
Gravity effect, text on a path, 221  
Gray Out view setting, 211  
grayscale, PDF compression options, 497–498  
greeking, 540  
GREP (Global Regular Expression Parser)  
Find/Change command, 330, 334  
styles, 378  
grids  
baseline, 396–398  
creating while drawing object, 87  
duplicating multiple objects, 87  
exporting PDFs, 496  
placing imported graphics into, 189  
printing, 460  
working with document, 28  
Grids preferences, 528  
Group Selection tool, 89  
grroups  
creating conditional text sets in, 346  
creating object, 106–107  
creating style, 363  
placing images and captions in, 338  

Guide-based rule, 451, 453  
guides  
changing minimum vertical offset with, 32  
controlling visibility on layer, 276  
exporting PDFs, 496  
printing, 460  
working with document, 23–25  
Guides & Pasteboard Preferences, 529  
gutters, 15–16, 24–25  

H  
H&J Violations, 525–526  
Hand tool, 34
headers, table
changing number of, 303
creating new table in text frame, 295
working with, 310–311
hidden characters, 66
hidden commands, restoring, 517
hidden panel display references, 521
hiding. see showing/hiding
highlights
composition preferences, 525–526
menu commands, 517
spelling preferences, 533
splitting columns to create, 75
underlines and strikethroughs for, 53
horizontal distribute icons, Align panel, 102
horizontal layout, Pages panel, 233
horizontal Liquid guides, 453
horizontal scale controls, 56
HTML files, exporting, 506–507
hyperlinks
cross-reference, 410–412
defining, 405–409
exporting PDF, 496
overview, 404
hyphenation
controlling, 394–396
setting exceptions, 490, 531
turning on, 65
icon view
controlling panel, 3
revealing full panel from, 3
IDML files, 504
ignore commands, spell check, 325, 327–328
Illustrator files
best file format from, 194
dragging from, 193
Image Import Options, 194
importing paths as frames in, 193
layer visibility for imported, 208
using transparency, 209
images. see also imported graphics
adding captions to, 337–339
adding to compound shape, 191
adding to tables, 312
auto-fit commands for, 454
creating ghost area in, 156
exporting EPUB files, 505
exporting HTML files, 507
exporting PDFs, 501
linking, 206, 446
preflight profiles, 486
selecting graphic frames containing placed, 112
setting sound poster, 419
wrapping text for hidden layers, 276
imported graphics
fitting in frames, 201–203
linking, 204–207
overview of, 185
placing artwork, 186–189
setting Image Import Options, 194–198
setting layer visibility, 208
specialty frames, 191–193
transparent images, 209
using Bridge and Mini Bridge, 190
viewing images, 210–212
working with images inside frames, 199–200
importing
colors, 471
document presets, 18
entries into spell check dictionary, 329
masters from one document to another, 249
print presets, 479
styles, 364–365
swatches from other documents, 127		
tables from Word or Excel, 297–299
text, 242–245
text styles from Word, 366–367
imposing pages, printer’s spreads, 480–482
InCopy
exporting for, 504
formatting Word imports in, 243
linking text files with, 204
searching locked stories in, 330
tracking text changes in, 341
increments preferences, 526–527
indents
left indent control, 60, 63
margins, 60
right indent control, 60, 63, 290
right indent tab, 290
text, 59–60
TOC entries, 269
InDesign 2.0 Compatibility, Draw menu, 318
InDesign files
adding metadata to image, 337
animation, 430–432
setting Image Import Options, 194–198
setting layer visibility for imported, 208
transferring styles into, 364
indicators, conditional text, 344–345
Info panel
Measure tool, 108
working with, 110
ink, separations preview, 469
Ink Manager, 470–471
inline graphics, 242, 312
inline objects, 227–230
inner glow, 160
inner shadows, 159
In-Rip Separations, output controls, 466
Index

Hand tool, 34
magnification, 30
modifying, 6, 514–516
moving insertion point with, 45
quick guide to, 47
selecting text with, 47
setting style with, 361
setting typeface and point size, 51
setting workspace, 5
using mouse vs., 47
viewing for tools, 7
Zoom tool, 33

Lab color model
basics, 114
creating gradient swatch, 131
defining new color swatch, 122
mixing colors, 118
using Color Picker, 131
language
adding words to spell check, 328
setting Dictionary preferences, 530–532
setting for text, 57
layer comps, Photoshop, 195
layers
applying objects to, 277
applying to captions, 338
creating, 272–273
deleting, 273, 278
hidden, as Find/Change search area, 330
merging, 278
moving objects to different, 277
opening Layers panel, 272
overview of, 271
in placed files with Image Import Options, 194–197
in placed files with Object Layer Options, 208
printing options, 460
reordering, 277
setting options, 274–276
setting preflight options, 489
setting visibility for imported files, 208
working with contents of, 279–280
layouts
advanced, 12
auto-fit commands for, 454–455
basic, 11
changing options, 16
changing pages panel, 233
collecting and placing content for, 442–444
creating alternate, 448–449
of document section, 256
exporting PDFs, 500
footnote spacing options, 348
linking items for, 445–446

Insert command, Pages panel, 234
insertion point
adding images to tables, 312
applying attributes to paragraph, 58
creating table in text frame, 295
creating text frames, 42
inserting characters, 67
inserting columns and rows into tables, 304
inserting footnotes into text, 347
moving, 45
inset spacing, text frames, 73
Intent menu, 11, 13–14
interactive and multimedia
adding sounds, 416–419
animating InDesign objects, 430–432
bookmarks, 413–415
buttons, 423–427
cross-references, 410–412
defining hyperlinks, 405–409
movies and animations, 420–422
multi-state objects, 435–436
overview, 403
page transitions, 438–439
PDF forms, 428–429
SWF Preview controls, 437
timing, 433–434
types of interactive elements, 404
interactive elements
exporting PDFs, 496, 500–501
types of, 404
Interface preferences, 520–521
Intersect command, Pathfinder, 164
Invert command, text wraps, 214
invisible objects, wrapping text around, 218
island spreads, 241
ISO (International Organization for Standardization), PDFs, 494–495

Join command, paths, 177, 184
joins, controlling stroke style, 145
JPEG files
exporting, 508
exporting EPUB files, 506
Image Import Options, 194
PDF compression options, 498
justification controls, 74, 390–394

Keep options, 308, 351
kerning, 54–55
key object, aligning to, 101–102
keyboard shortcuts
dragging text, 49
drawing frames, 44

Liquid Layout Rules, 450–453
mapping styles for, 447
navigating pages using Layout menu, 236
overview, 441
setting, 13–15
using Adobe Paragraph Composer, 389

tab leaders, 294
leading, 54, 393
letter spacing, for justification, 391–392

libraries
adding items to, 282
adding items to page, 284
adding page to, 283
creating, 282
deleting items from, 283
overview of, 281
searching and sorting, 286–287
setting display, 285
strategies for, 283
swatch, 128
using snippets, 287–288

Ligatures, as text style, 52–53
light, setting global, 163
line spacing, text, 54–55
Line Stroke controls, 322
Line tool, 82
linear gradients, 140

lines
adding border to table, 316
balancing ragged, 399
creating above or below paragraphs, 223–226
creating nested styles for, 377
drawing, 173
drawing straight, 82
fitting between margins, 390–393
keeping lines of text together, 351
selecting within paragraph, 46
spacing, 54–55
lining figures, OpenType, 402
link indicators, text flow, 70
Link Info area, Links panel, 207
link text cursor, text flow, 70
Link To menu, 406

links
breaking to styles, 361, 370
collecting and placing content, 442–444
defining hyperlinks, 405–409
exporting PDFs, 496
File Handling preferences, 543
graphics, 204–207
objects, text and images, 206
packaging for printing, 490
preflight profiles, 486
text between frames, 70
working with layout and, 445–446

Links panel, 204–207, 339, 446

Liquid Layout Rules, 21, 449–453
live captions, 338–339
Live Corner Options controls, 155
Load Conveyer, 444
loaded image cursor, 186–188
loaded text cursor, 242, 246–247
loading
styles, 364–365
transparency flattener presets, 475

local formatting, 356, 368–370, 380
local overrides, 234, 254
locked layers, Find/Change search area, 330
locked objects, selecting, 519
locked stories, Find/Change search area, 330
locks
guide, 26
item on layer, 280
layer, 274
object, 111

looping
animations, 434
nested styles, 376
page sound, 417–419
video, 420

M

Macintosh Finder, 207
Macintosh notebooks, 385
magnification
changing document, 29–30
changing from Application bar, 36
changing ruler guide, 26
Zoom tool increasing/decreasing, 33

manual tiling, 463
mapping
colors, 471
one style to another, 367
styles in layouts, 447

margin guides, 23
margins
aligning to, 101
applying justification controls, 390–393
changing layout options, 16
creating printer’s spreads, 481
for facing pages, 13–14
fitting guides to, 25
indent controls, 60
new document options, 11
setting, 14
setting optical margin alignment, 388

markers, section, 257
marks and bleed, 464–465, 499
markup files, for exporting, 504
marquee, dragging, 83, 176
marquee zoom, 33
master page overlay, 21, 239–240
master pages
  adding, 234
  changing Pages panel display for, 232
  as Find/Change search area, 330
  setting section marker on, 257
  setting text wraps on, 219
  working with, 249–254
match criteria, searching library, 286
Measure tool, 108–109
Media panel, 417–422
menus
  displaying panel, 3
  modifying commands, 517
  saving custom workspace, 4
  setting colors of guides, 23
merging
  layers, 278
  swatches, 125–126
  table cells, 313
Messages, Print Booklet dialog box, 482
metacharacters, Find/Change, 333
metadata, adding to image, 337–339
metrics kerning, using, 54
Microsoft Excel, importing from, 244–245, 297–299
Microsoft Word
  importing footnotes from, 349
  importing table from, 297–299
  importing text files from, 242–244
  importing text styles from, 366–367
Mini Bridge, 190, 288
minimizing panels, 2
missing hyperlinks, 409
missing icon, Book panel, 262
missing link, graphics, 204–205
Miter Join setting, strokes, 145
mixed inks, 115
Modified Link, graphics, 204–206
monochrome bitmap resolution, PDFs, 499
mouse
  dragging text, 49
  events, buttons, 424
  interface preferences, 520
  keyboard shortcuts vs., 47
  selecting text, 46
Move command, 85
movies, animations and, 420–422
moving
  artwork between frames, 188
  column guides, 24
  document pages, 238
  hyperlinks, 409
  objects, 84–85
  objects from one layer to another, 277
  objects using Transform panel, 95
pages, 235–238
  swatches to new positions, 126
  text, 48–49
Multiline options, PDFs, 429
multimedia. see interactive and multimedia
multi-state objects, 435–436
N
navigation
  book page, 236–238
  through tables, 300
  working with bookmarks, 404, 413–415
nesting
  bookmarks, 415
  groups of objects, 106–107
  line styles, 377
  panels, 3
  styles, 374–376
nigels, as hyphenation units, 394
nonbreaking spaces, 77
None setting
  applying fill to, 141
  object styles, 379
non-existing items, table of contents for, 266
non-Latin text, preferences, 524
Nonprinting command, 136
non-printing objects, 460, 496
Normal state, 426
Notes preferences, 535
Number of Pages field, documents, 11, 13
number of pages, maximum for InDesign, 237
numbered paragraphs, TOC options for, 266
numbers
  applying to paragraphs, 62
  chapter, 258
  controls for footnotes, 347
  converting to ordinary text, 63
  formatting in paragraphs, 62
  page. see page numbers
  in this book, 63
  Word Import options, 242

O
Object Find/Change, 330, 336
Object Shape text wrap button, 216–218
object styles, 379–381, 384–386
Object Type list, Library Item Information, 285
Object-based rule, 451–452
objects
  adding to master pages, 249
  aligning and centering Smart Guides to, 26
  animating InDesign, 430–432
  applying to layers, 277
  linking, 206
  moving to different layers, 277
multi-state, 435–436
preflight profiles, 486
selecting for text to wrap around, 214
selecting locked, 519
objects, working with
  aligning, 101–103
  creating basic shapes, 81–82
  grouping and pasting into, 106–107
  locking, 111
  moving, 84–85
  overview of, 79
  replicating, 86–87
  resizing, 88
  selecting, 83
  selecting frames, 112
  Smart Dimensions and Smart Spacing, 104
  types of frames, 80
  using Arrange commands, 100
  using Gap tool, 105
  using Info panel, 110
  using Measure tool, 108–109
  using transform commands, 98–99
  using Transform panel, 94–97
  using transform tools, 89–93
offset controls
  applying to captions, 338
  styling paragraph rules, 225
  text wraps, 214
oldstyle figures, OpenType, 402
One-Third Rule, curves, 175
opacity effects, 156–158
Open Path command, 177, 184
Open Prepress Interface (OPI), 473
opening
  Character Styles panel, 360
  files within inDesign, 40
  panels, 2
  recently saved documents, 40
  tools in fly-out panels, 6
OpenType, 399–402
OPI (Open Prepress Interface), 473
optical kerning, 54
optical margin alignment, 388
ordering actions, button events, 425
ordering object animations, 433
orientation
  basic document options, 11
  changing page size, 239
  layout options, 14
  output controls, 466
  printing setup, 461
  text wrap, 217
outer glow, 160
out-of-gamut symbol, RGB and Lab colors, 118
output commands, setting for book, 264
output controls, printing, 466–467
Outside alignment, strokes, 146
overprinting colors
  adding border around table, 316
  overview of, 136
  styling paragraph rules, 224
overrides
  applying style, 368
  clearing in object styles, 380
  clearing style, 369–370
  disallowing on master pages, 253
  removing local, from master pages, 254
overset symbol, text, 45, 340

P

packaging document, for printing, 490
Padlock cursor, for objects, 111
Page, hyperlinks, 406
page breaks, Word Import options, 242
Page Curl, 439
Page Information, printing, 464
Page Load, animation, 431
page numbers
  adjusting in book, 263
  advanced styles for TOC, 268
  automatic, 256
  creating document section, 256
  for each document in book, 263
  inserting continued to/from characters, 259
  preferences, 518
  updating in book, 264
  working with section marker, 257
page ranges, printing options, 459
Page Size list, documents, 11, 14
Page tool, 21–22
Page Turn, 439
PageMaker, 40, 514
pages
  adding all items to library separately on, 283
  adding to library, 283
  aligning and centering Smart Guides to, 26
  aligning to, 101
  applying library items to, 284
  creating alternate layouts, 448–449
  creating bookmarks, 413
  dragging snippets onto, 288
  fitting guides to, 25
  imposing, 480–482
  navigating and moving, 236–238
  printing, 459–460
  setting origin of document ruler to, 20
  setting transitions, 438–439
  Smart Text Reflow, 523
  sound options, 417
  specifying when exporting PDFs, 495
tiling, 462–463
viewing all current, 29

pages and books
adding blank, 234
changing Pages panel, 232–233
creating and separating spreads, 241
creating table of contents, 265–269
creating text breaks, 248
flowing text, 246–248
importing text, 242–245
making books, 260–264
navigating and moving, 235–238
overview of, 231
page numbers and text variables, 256–259
rotating spreads, 255
sizing, 239–240
working with master pages, 249–254

Pages panel
changing display of, 232–233
different sized pages appearing in, 22
selecting pages in, 21
viewing alternate layouts in, 449

panels
arranging into workspaces, 4–5
interface preferences for docked, 521
working with, 2–3

paper size, printing options, 460–461
Paragraph, cross-references, 410–411

paragraph styles
applying, 368
applying to captions, 338
applying to TOC, 265–269
automating drop caps when applying, 373
clearing style overrides, 369–370
creating GREP styles, 378
defining, 357–358
deleting, 372
formatting footnotes with, 348
importing text styles from Word, 366–367
opening Paragraph Styles panel for, 356
overriding, 368
setting for Basic Paragraph, 356
setting Next Style, 358–359
using Quick Apply for, 384–386
viewing in Story Editor, 340

paragraphs
composing with Paragraph Composer, 389
displaying attributes, 76
formatting, 58
formatting alignment, 59
formatting bullets and numbering, 61–63
formatting margin indents, 60
rules for, 223–226
selecting, 46
setting effects, 64–65
setting eyedropper options, 352–353
setting keep options, 351
setting line and character spacing, 54–55
setting spacing limit, 74
setting with Control panel, 76
typography for. see typography parameters, library search, 286
parent, nesting bookmarks, 415
passwords, PDFs, 429, 502
pasteboard
changing Minimum Vertical Offset, 32
controls, 31–32
moving pages in spread, 22
setting preferences, 529
surround document pages, 11
viewing entire area of, 29

pasting
content in table cells, 306
creating new layers while, 273
into objects, 106–107
in place, 86
removing pasted-in content, 107
text into table, 297
text preferences, 544
text without formatting, 48
viewing contents of clipboard, 86

Path Type tool, 220
Pathfinder commands, 164–166

paths. see also points and paths
converting text to, 192
converting vector-drawing paths to frames, 193
modifying in Pathfinder, 166
text on, 220–222

PDF files
creating forms, 404, 428–429
exporting. see exporting PDFs
Image Import Options for, 194, 196
limitations in Bridge, 198
placing multiple pages all at once, 198
setting layer visibility for imported, 208
sound options, 418
video options, 422

pen points, 172

Pen tool
changing curves and corner points, 175
creating frame shapes with, 187
custom text wraps, 218
drawing curves, 174
drawing lines, 173
general rules for, 175
modifying points made with, 178–179
overview of, 172

Pencil tool, 180–181
permissions password, PDFs, 502

Photoshop
adding metadata to image, 337
setting layer visibility for imported, 208
using transparency in, 209
working with layer comps, 195
Photoshop Path contour, text wraps, 216
placeholder text, filling text frames, 248
placement
of artwork, 186–189
content in layouts, 442–444
footnote options, 349
of library items on page, 284
of snippets, 288
of video, 420
plate, 468
PNG files, exporting, 509
point per inch, setting text, 527
point size, setting text, 51
points and paths
adding or deleting points on paths, 184
changing curves and corner points, 175
drawing curves, 174
drawing lines, 173
modifying paths, 176–177
modifying points, 178–179
overview of, 171
pen points, 172
using Erase tool, 183
using Pencil tool, 180–181
using Smooth tool, 182
Polygon Frame tool, 80, 82
Polygon tool, 43–44, 80
Portrait orientation, layout option, 14
positioning
bullets or numbers, 63
captions relative to images, 338
grid, preferences for, 528
inline or anchored objects, 228–229
locking objects, 111
object to be pasted, 107
objects with same spacing, 104
paragraph rule within frame, 224
points of measuring line, 109
text on path, 220
posters
movie options, 421
sound options, 419
PostScript files, 483
Power Point, exporting PNG files, 509
power zoom, 34
precision eyedropper, 168
preferences. see also customizing
baseline grid, 396–398
changing section numbering to absolute numbering, 257
document grids, 28
document ruler, 19
guides, 23
image views, 210–212
Minimum Vertical Offset, 32
Pencil tool, 181
Smooth tool, 182
Story Editor, 340
Transformation Values, 26
preflighting, 484–489
Presentation mode, documents, 31
previews
document, 17–18
flattener, 474–477
print, 478–479
primary text frames
basic document options, 11
creating and flowing text into, 246
flowing text without, 247
Print Booklet, 480–482
Print dialog box, 458
Print PDF files, exporting, 494
print presets, 480
print work
with different-sized pages, 240
graphic formats for, 187
out-of-gamut symbol for, 118
overprinting colors, 135
setting object not to print, 136
using CMYK for, 114, 116–117
using process vs. spot colors, 123
Printable, PDF forms option, 429
printer, choosing, 459
printer’s spreads, 480–482
printing
Advanced options, 473
Appearance of Black preferences, 541
color separations and Ink Manager, 470–471
to disk, 483
document, 458
flattener presets and preview, 474–477
Graphics options, 472
marks and bleed, 464–465
output controls, 466–467
overview, 457
packaging document, 490
permissions, 503
PostScript files, 483
Preflight Options, 489
preflight profiles, 485–488
preflighting documents, 484
preventing layer from, 275
print presets, 478–479
printer’s spreads, 480–482
separations preview, 468–469
setting general print options, 459–460
Setup options, 461
tiling pages, 462–463
process colors
converting to spot colors, 470
defining new color swatch, 122
in gradients, 134
spot colors vs., 123
profiles, preflight, 485–488
prog proofs, 468
Projecting Cap, strokes, 145
properties, button, 423
proportion
fitting graphics in frames, 201
OpenType figures, 402
resizing objects, 95
scaling objects, 96
proxy lines, strokes around table cells, 317
Proxy view setting, 211
PSD files, see Photoshop
punctuation, and optical margin alignment, 388
Q
Q2ID product, 40
quadruple-click, 46
QuarkXPress, 40, 514
Query controls, 336
Quick Apply, 384–386
Quote menus, 530
R
radial gradients, 140
ragged lines, balancing, 399
Rainbow effect, text on a path, 221
raster image processing (RIP), 467
raster images, 211
Read Only, PDF forms, 429
reader’s spreads, 480
Real World Color Management 2nd Edition (Fraser, Murphy, and Bunting), 472
rearranging item on layer, 280
Recent Items area, Welcome Screen, 10
Re-center rule, 450–451
recently saved documents, opening, 40
recovery, automatic file, 40
Rectangle Frame tool, 80–81
Rectangle tool, 44, 80
red dot, inside table cell, 306
Redo command, documents, 39
reference points
controlling transform tools via, 89
formatting for footnotes, 348
setting Transform panel, 94
Registration color, 121
Registration Marks, 464
regular expressions, GREP Find/Change, 330, 334
Reject Change icons, Track Changes, 342
Release Compound Paths command, 141, 191
release events, buttons, 424
relinking dictionary, 530
removing animations, 432
renaming bookmarks, 414
reordering
layers, 277
library entries, 287
repeating
headers and footers, 310
nested line styles, 377
nested styles, 374–376
objects, 87
tab, and tab stop, 292
replicating objects, 86–87
Required, PDF forms, 429
resizing. see sizing
resolution, PDF compression, 497, 499
Reverse Path command, 177
reversed text, 226
Revert command, document files, 39
RIP (raster image processing), 467
rollover events, 424, 431
Rollover state, 426
Rotate command, 91
Rotate tool, 91–92
rotating objects
making copies while, 90
spreads, 255
using Free Transform tool, 93
using Rotate tool/Rotate command, 91–92
using transform commands, 98
using Transform panel, 94, 97
Round Cap setting, strokes, 145
Round Join setting, strokes, 145
row separator, 296
Row Strokes in Front, Draw menu, 318
rows
alternating repeating strokes for, 319
converting into header, 311
creating new table in text frame, 295
creating using guides, 25
jumping to specific, 300
table selection commands, 302
working with, 303–308
ruler guides
changing appearance of, 26
creating, 25
defined, 23
deleting on page, 25
deleting selected, 26
moving existing, 26
repositioning, 26
setting guide-based rule, 453
rulers
adding tab stops to, 291
clearing all tabs off, 293
Units and Increments preferences, 526–527
using document, 19–20
rules
Liquid Layout Rules, 450–453
paragraph, 223–226
setting controls for footnote, 349
S
Sample Buttons and Forms library, 427, 429
sampling
with Eyedropper, 135, 352–353
PDF compression options, 497
satin effect, 161
saving
commands for, 38–40
custom workspaces, 4
File Handling preferences for, 542
files, 38–40
new library, 282
print presets, 478
searches, 336
selected swatches, 126–127
stroke styles, 153
styles for TOC entries, 265
transparency flattener presets, 475
Scale, printing setup, 461
Scale rule, 450–451
Scale X and Y fields, Transform panel, 96
scaling
making copies while, 90
objects numerically, 90
objects using Free Transform tool, 93
objects using Scale tool or Scale command, 90–91
objects using Transform panel, 94, 96
objects visually, 90
preferences for, 519
resizing vs., 88
setting drop cap attributes using, 65
for text distortion, 56
Scissors tool, 177, 184
screens, setting output controls, 467
scripts, running, 354
Scrollable, PDF forms, 429
scrolling, preferences for, 540
searches
within Application bar, 37
Find/Change. see Find/Change commands
within libraries, 286–287
for linked graphic file, 207
saving, 336
within spell check, 326
section numbering, 256–257, 518
security options, exporting PDFs, 502–503
segments
changing shape of, 179
deleting in path, 179
deleting parts of with Erase tool, 183
drawing curves with, 174
as path element, 172
splitting paths into, 177
Selected by default, PDF forms, 429
selecting
all objects on page, 83
frames, 112
groups or objects within groups, 106
objects, 83
tables, 301–302
text, 46–47
text in table cell, 301
Selection tool
controlling effect of transform tools, 89
converting text to frames, 192
displaying grouped items, 106
flowing tables between frames, 309
moving objects with, 84
placing artwork with, 187
scaling objects with Transform panel, 96
selecting frames with, 112
selecting objects, 83
selecting objects within groups, 107
using Live Corner Options controls, 155
working with images inside frames, 199–200
separations
Ink Manager and, 470–471
previewing, 468–469
setting output controls, 466
separator character, TOC, 268
sets, conditional text, 346
Setup, print options, 461
shadow effects, 159
shapes, 81–82
Shared Destination, hyperlinks, 406
shearing objects
  making copies while, 90
  using Free Transform tool, 93
  using Shear tool/Shear command, 92–93
  using Transform panel, 94, 97
Shift key, 47, 83
shortcuts. see keyboard shortcuts
showing
color swatches, 120
controller on rollover for video, 421
panel display options, 2
showing/hiding
  conditional text, 345
  document grids, 28
  guides, 24
  hidden characters, 66
  item on layer, 280
  layers, 275
  Smart Guides, 26, 104
signature size, printer’s spreads, 481
single word justification, 393
single-line composition, 389
sizing. see also magnification
  alternate layouts, 448
  book pages, 239–240
  characters, 524
  document pages, 239–240
  fitting graphics in frames, 201–203
  frame and image by dragging, 200
  frames, 44
  objects proportionally, 95
  objects using bounding box handles, 88
  objects using Gap tool, 105
  objects using Transform panel, 95
  objects using transform tools, 89–92
  pages, 21
  Pages panel, 232
  printing options, 460
  printing setup, 461
  scaling vs., 88
  setting typeface and point, 51
  Units and Increments preferences, 527
skew
text, 56
text on a path, 221
SkinOverAll controller, 421
skip option, spell check, 325
slugs
  advanced document options, 12
  defined, 12, 23
  documents, 31
  setting for printing, 465
Small Caps, text style, 52
Smart Dimensions, Smart Guides, 104
Smart Guides
  defined, 23
  drawing straight lines with, 173
  setting preferences, 529
  showing and hiding, 104
  using for documents, 26
Smart Spacing, Smart Guides, 104
Smart Text Reflow, 523
smooth curves, 174
Smooth tool, 182
Smoothness settings, Pencil tool, 181
Smoothness settings, Smooth tool, 182
snapping
to grid, 28
objects to guides, 23–24
snippets, 287–288, 543
Sort Items, PDF forms, 429
sorting
  libraries, 286–287
  styles, 361
sounds, adding, 416–419
source
  changing linked items, 445–446
  defining hyperlinks, 405
  tips for hyperlinks, 408
spacing
  adding between paragraphs, 64
  creating printer’s spreads with, 481
  distributing objects using, 103
  footnotes, 348
  positioning objects with same, 104
  resizing objects without affecting, 105
  setting around table, 309
  setting line and character, 54–55
  setting paragraph limit for, 74
  setting vertical justification, 315
  with special space characters, 77
  of text frame inset, 73
  with white space characters, 78
  word, 390–391
span columns, 75
special characters
  for automatic page numbering, 256
  Find/Change metacharacters, 333
  inserting continued to/from, 259
  using, 77
specialty frames, 191–193
Speed
  animation settings, 431
  page transition settings, 438
spelling
  checking, 326–329
  customizing preferences, 533
  Track Changes preferences, 537
InDesign CS6 Visual Quickstart Guide 563

applying gradient, 143
applying inDesign defaults to, 169
applying to object, 142
applying to paragraphs, 119
applying to tables, 316–318
applying to text, 143
attributes for, 144–148
customizing individual table cells, 317
customizing styles, 149–153
dragging onto objects, 142
sampling with Eyedropper, 167–168
setting stacking order for table cells, 318
sizing, 527
swapping fill and stroke settings, 142

styles. see also text styles
alternate layouts, 449
applying, 147
applying with Quick Apply, 384–386
automatic drop cap, 373
automatic page numbering, 256
basing, 361
book document, 261
captions, 338
chapter numbers, 258
creating groups, 363
custom, 149–151
deleting, 153, 371–372
defining, 13
deleting, 239
moving pages in, 22
restoring to normal rotation, 255
rotating, 255
setting origin of document ruler to, 20
viewing all current, 29
working on page, 235

spreads:
aligning to, 101
applying flattener preset to, 476
creating and separating, 241
creating printer’s, 480–482
defining, 13
deleting, 239
moving pages in, 22
restoring to normal rotation, 255
rotating, 255
setting origin of document ruler to, 20
viewing all current, 29
working on page, 235

spreadsheets, importing from, 298
stacking order, 100, 253, 318
Stair Step effect, text on a path, 221
Standard menu, exporting PDFs, 494
star frames, 43, 82
state
deleting button, 426
multi-state objects, 435–436
static captions, 338–339
Step command, 87
stops, tab, 291–293
storing items in libraries, 282–283
story, selecting all text within, 46
Story Editor
automating work using, 340
display preferences, 538
displaying Track Changes in, 342
navigating through changes, 342
Notes preferences, 535

straight lines, 173
Strikethrough, as text style, 52–53, 226
stripe icon, 149, 150
Stroke icon, 124, 131
strokes
adding arrows to, 154
alternating with fills for tables, 319–321
applying corner options to objects, 154–155
applying custom styles for, 149–154

spine, setting origin of document ruler to, 20
split columns, 75
splitting
columns, 75
compound shape, 191
table cells, 313
windows, 35
spot colors
basics of, 115
converting to process colors, 470
defining new color swatch, 122
in gradients, 134
mixed inks using, 115
process colors vs., 123

spreads:
aligning to, 101
applying flattener preset to, 476
creating and separating, 241
creating printer’s, 480–482
defining, 13
deleting, 239
moving pages in, 22
restoring to normal rotation, 255
rotating, 255
setting origin of document ruler to, 20
viewing all current, 29
working on page, 235

spreadsw, importing from, 298
stacking order, 100, 253, 318
Stair Step effect, text on a path, 221
Standard menu, exporting PDFs, 494
star frames, 43, 82
state
deleting button, 426
multi-state objects, 435–436
static captions, 338–339
Step command, 87
stops, tab, 291–293
storing items in libraries, 282–283
story, selecting all text within, 46
Story Editor
automating work using, 340
display preferences, 538
displaying Track Changes in, 342
navigating through changes, 342
Notes preferences, 535

straight lines, 173
Strikethrough, as text style, 52–53, 226
stripe icon, 149, 150
Stroke icon, 124, 131
strokes
adding arrows to, 154
alternating with fills for tables, 319–321
applying corner options to objects, 154–155
applying custom styles for, 149–154

applying gradient, 143
applying inDesign defaults to, 169
applying to object, 142
applying to paragraphs, 119
applying to tables, 316–318
applying to text, 143
attributes for, 144–148
customizing individual table cells, 317
customizing styles, 149–153
dragging onto objects, 142
sampling with Eyedropper, 167–168
setting stacking order for table cells, 318
sizing, 527
swapping fill and stroke settings, 142

styles. see also text styles
alternate layouts, 449
applying, 147
applying with Quick Apply, 384–386
automatic drop cap, 373
automatic page numbering, 256
basing, 361
book document, 261
captions, 338
chapter numbers, 258
creating groups, 363
custom, 149–151
deleting, 153, 371–372
defining, 13
deleting, 239
moving pages in, 22
restoring to normal rotation, 255
rotating, 255
setting origin of document ruler to, 20
viewing all current, 29
working on page, 235

spreads:
aligning to, 101
applying flattener preset to, 476
creating and separating, 241
creating printer’s, 480–482
defining, 13
deleting, 239
moving pages in, 22
restoring to normal rotation, 255
rotating, 255
setting origin of document ruler to, 20
viewing all current, 29
working on page, 235

spreadsheets, importing from, 298
stacking order, 100, 253, 318
Stair Step effect, text on a path, 221
Standard menu, exporting PDFs, 494
star frames, 43, 82
state
deleting button, 426
multi-state objects, 435–436
static captions, 338–339
Step command, 87
stops, tab, 291–293
storing items in libraries, 282–283
story, selecting all text within, 46
Story Editor
automating work using, 340
display preferences, 538
displaying Track Changes in, 342
navigating through changes, 342
Notes preferences, 535

straight lines, 173
Strikethrough, as text style, 52–53, 226
stripe icon, 149, 150
Stroke icon, 124, 131
strokes
adding arrows to, 154
alternating with fills for tables, 319–321
applying corner options to objects, 154–155
applying custom styles for, 149–154

applying gradient, 143
applying inDesign defaults to, 169
applying to object, 142
applying to paragraphs, 119
applying to tables, 316–318
applying to text, 143
attributes for, 144–148
customizing individual table cells, 317
customizing styles, 149–153
dragging onto objects, 142
sampling with Eyedropper, 167–168
setting stacking order for table cells, 318
sizing, 527
swapping fill and stroke settings, 142

styles. see also text styles
alternate layouts, 449
applying, 147
applying with Quick Apply, 384–386
automatic drop cap, 373
automatic page numbering, 256
basing, 361
book document, 261
captions, 338
chapter numbers, 258
creating groups, 363
custom, 149–151
deleting, 153, 371–372
editing, 151
footnote, 347–349
formatting Excel cells, 298
GREP, 378
importing text styles from Word, 366–367
loading and importing, 364–365
mapping, 447
nested, 374–376
nested line, 377
new table in text frame, 295
object, 379–381
overrides, 368–370
paragraph rules, 224
redefining, 371–372
saving, transferring, and deleting, 153
style groups, 363
table and cell, 382–383
table of contents, 265–268
transferring, 153
Word Import options, 242

Subscript, applying as text style, 52
Subtract command, Pathfinder, 164
suggested corrections, spell check, 325–326
summary, creating print, 479
Superscript, applying as text style, 52
swatch libraries, 128
swatches
applying, 124
avoiding/naming unnamed colors, 127
creating gradient, 132–134
creating tint, 129–130
defining, 122–123, 131
deleting, 124–125
duplicating, 126
importing from other documents, 127
merging, 125–126
modifying, 123–124
moving to new positions, 126
overview of, 120
saving selected, 126–127
using swatch libraries, 128
working with Swatches panel, 120–121
Swatches panel
creating gradient swatch, 131–133
creating tint swatch, 130
working with, 120–122
SWF files, exporting, 510
SWF Preview controls, 409, 437
synchronizing options, books, 261–262

table of contents (TOC), 265–269, 414
Table panel, 323–324
tables
adjusting within text frame, 309
converting text into, 296
converting to text, 299
creating in text frame, 295
customizing, 313–315
diagonal lines added to, 322
formatting Word import options, 244–245
headers and footers, 310–311
images added to, 312
inserting text into cells, 300
moving from one cell to another, 300
navigating through, 300
pasting text into, 297
placing in table cell, 299
rows and columns, 303–308
selecting, 301–302
setting borders, strokes and fills for, 316–321
styles, 383–386
tabs vs., 294
using Table or Control panels, 323–324
viewing text inside with Story Editor, 340
Word or Excel import options, 297–299
tabs
choosing between tables and, 294
creating tab leaders, 294
inserting character into table, 300
inserting tab characters in text, 290
opening Tabs panel, 291
overview of, 289
setting stops, 291–293
swatches
applying, 124
avoiding/naming unnamed colors, 127
creating gradient, 132–134
creating tint, 129–130
defining, 122–123, 131
deleting, 124–125
duplicating, 126
importing from other documents, 127
merging, 125–126
modifying, 123–124
moving to new positions, 126
overview of, 120
saving selected, 126–127
using swatch libraries, 128
working with Swatches panel, 120–121
Swatches panel
creating gradient swatch, 131–133
creating tint swatch, 130
working with, 120–122
SWF files, exporting, 510
SWF Preview controls, 409, 437
synchronizing options, books, 261–262

table of contents (TOC), 265–269, 414
Table panel, 323–324

tables
adjusting within text frame, 309
converting text into, 296
converting to text, 299
creating in text frame, 295
customizing, 313–315
diagonal lines added to, 322
formatting Word import options, 244–245
headers and footers, 310–311
images added to, 312
inserting text into cells, 300
moving from one cell to another, 300
navigating through, 300
pasting text into, 297
placing in table cell, 299
rows and columns, 303–308
selecting, 301–302
setting borders, strokes and fills for, 316–321
styles, 383–386

tabs
choosing between tables and, 294
creating tab leaders, 294
inserting character into table, 300
inserting tab characters in text, 290
opening Tabs panel, 291
overview of, 289
setting stops, 291–293
tabular figures, OpenType, 402
tagged PDF files, 501
tap events, buttons, 424
targeting pages, 235
templates, 38, 40
testing
flattener options, 476
hyperlinks, 409
Liquid Layout Rules, 453
text. see also tables; tabs
Advanced Type preferences, 524
alignment to baseline grid, 397
alignments and indents, 59–60
auto-fit commands, 454–455
bookmarks for, 413
bullets and numbering of, 61–63
cell options for, 314
changing case of, 326
conditional, 343–345
converting into table, 296
converting table into, 299
converting to unique frame shapes, 192
creating breaks in, 248
creating frames, 42–44
cross-references in, 411–412
display preferences, 538–540
displaying information, 109
distortions, 56
duplicating, 49
exporting, 512
eyedropper options for, 352–353
fill colors applied to, 139
fitting paragraph rule to neighboring, 225
flattening and, 476
flowing, 246–248
footnotes within, 347–349
hidden characters, 66
hyperlinks in, 407
importing, 242–245
inserting tab characters in, 290
language options for, 57
line and character spacing, 54–55
linking, 206, 446
moving and deleting, 48–49
output controls for, 466
overview of, 41
packaging for printing, 490
paragraph effects, 64–65
paragraph formatting, 58
pasting into tables, 297
on a path, 214–215, 220–222
positioning guides behind, 23
preflight profiles, 486–487
text effects
inline and anchored objects, 227–230
overview of, 213
paragraph rules, 223–226
text on a path, 220–222
wrapping text, 214–219
text frames
adjusting tables within, 309
auto-fit command for, 455
automatic wrapping of text within, 45
changing text defaults in, 50
creating, 42–44, 80
creating table in, 295
customizing baseline grid for, 398
fill color applied to, 139
General controls for, 71–74
ghost area created in, 156–157
in icon view, 3
inline/anchored objects and, 227–230
resizing, 202
selecting, 112
selecting all text within, 46
strokes applied to, 143
text flow in, 70, 246–248
text on a path in, 220–222
text styles. see also character styles; paragraph styles
applying, 368
clearing style overrides, 369–370
document, 31–32
electronic styling myths and realities, 57
importing from Word, 366–367
named color swatches in, 120
overview of, 52–53
Quick Apply for, 384–386
transferring into document, 364
working with, 361–362

Text tool, 80
text variables, chapter numbers, 258
3D Ribbon effect, text on a path, 221
thumbnails, 233, 285, 461
TIFF files, Image Import Options, 194
tiling, 37, 462–463
timing, animation, 431
Timing panel, 433–434
tints
adding border around table, 316
basics of, 115
creating, 129–130
setting screen for gap color, 147
styling paragraph rules, 224
title, table of contents, 6
TOC (table of contents), 265–269, 414
Toggle Lock space, layers, 274
Toggle Visibility space, 275
tool tips, 6–7, 520
Tools Hint panel, 7
Tools panel, 6, 521
track changes, 242, 536–537
tracking, 55, 341–342
trackpad preferences, 520
transform commands, 98–99
Transformation Values, 26, 42, 81
transformations
applying to frames with placed images, 200
preview preferences, 520
using transform commands, 98–99
using Transform menu, 85
using Transform panel, 94–97
using Transform tools, 89–93
transitions
exporting PDFs, 500
setting page, 438–439
transparency
feather effect for, 162
flattener presets and preview, 474–477
importing images with, 209
opacity and blend effects for, 156–157
printing options, 473
removing, 158
sampling with Eyedropper, 167–168
setting display for, 212, 233
trappping, 467
trashing preferences, 544
triple-click, 46
troubleshooting
missing hyperlinks, 409
Preflight panel, 484
Type Preferences, 522–523, 524
Type tool, 42, 45, 220
typeface, 51, 57, 65
typographer’s quotes, formatting Excel cells, 298
visibility
button state, 426
changing menu display, 517
controlling guides on layer, 276

W
Warning
customizing preferences, 519
in Print Booklet dialog box, 482
weight, 144, 224, 316
Welcome Screen, 10
white eyedropper, 167, 353
white precision eyedropper, 168
white space characters, 77, 78, 294
Window menu, 2
Word. see Microsoft Word
words
adding to spell check dictionary, 328
selecting single, 46
spacing, 390
text Find/Change controls for, 332
workflow
for captions, 338
creating with InCopy, 504
totally style-driven, 371
tracking text changes, 341
workspace, 4–5, 37
wrapping text, 214–219

X
XPress. see QuarkXPress

Z
zero point, positioning document ruler, 20
ZIP files, PDF compression options, 498
zoom
changing magnification, 29–30
creating page destination, 408
modifying keyboard shortcuts for, 501
setting image handling options, 501
setting view threshold in baseline grid for, 528
using Hand tool for power, 34
using loaded cursor for, 247
using Zoom tool for, 33