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Adobe Fireworks® is a professional imaging application that combines vector 
and bitmap imaging technologies and techniques in a single graphics applica-
tion. This unique approach to imaging is due to the specific focus of Fireworks, 
which is creating and manipulating screen graphics for the Web or for other 
screen-based tools such as mobile applications or Adobe Flash® products. 
Fireworks is a tool that lets you quickly and easily create, edit, or alter graphics 
and designs. And it’s a blast to work with, too!

With the release of Adobe Fireworks CS5, the program has gained even more 
distinction as a unique application for rapid prototyping. The built-in flexibility 
of Fireworks and its “everything is editable all the time” mandate have been 
present since it was created. When you’re creating mockups and prototypes, 
where client or design changes can come fast and furious, this type of flex-
ibility is very important. Features such as multiple pages, Device Central and 
Photoshop integration, and workflows like FXG 2.0 export and AIR prototyp-
ing make Fireworks an essential tool in the design process. 

About Classroom in a Book
Adobe Fireworks CS5 Classroom in a Book is part of the official training series 
for Adobe graphics and publishing software developed by experts in associa-
tion with Adobe Systems. The lessons are designed to let you learn at your own 
pace. If you’re new to Adobe Fireworks, you’ll learn the fundamental concepts 
and features you’ll need in order to begin to master the program. And, if you’ve 
been using Adobe Fireworks for a while, you’ll find that Classroom in a Book 
teaches advanced features, including tips and techniques for using the latest 
version of the application and for creating web and application prototypes. 
Although each lesson provides step-by-step instructions for creating a specific 
project, there’s room for exploration and experimentation. You can follow the 
book from start to finish, or do only the lessons that match your interests and 
needs. Each lesson concludes with a review section summarizing what you’ve 
covered.

Getting Started
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What’s in this book
This edition covers many new features in Adobe Fireworks CS5, such as Adobe 
Device Central integration, the new Compound Shape tool, enhancements to the 
Properties panel, improved text handling, and exporting graphics for use in Flash 
Catalyst. 

An overview of the new Adobe interface is covered in the first lesson, where you 
will learn how to configure the panels and document windows in Fireworks to 
suit your workflow. You will learn how to edit bitmap images and work with vec-
tor paths to create web interfaces. You will learn how to create and edit symbols, 
a powerful feature of Fireworks, and learn how Fireworks integrates with other 
Adobe CS5 applications like Dreamweaver, Photoshop, Bridge, and Flash.

Prerequisites
Before you begin to use Adobe Fireworks CS5 Classroom in a Book, you should have 
a working knowledge of your computer and its operating system. Make sure that 
you know how to use the mouse and standard menus and commands, and also how 
to open, save, and close files. If you need to review these techniques, see the docu-
mentation included with your Microsoft Windows or Macintosh system.

Installing Adobe Fireworks
Before you begin using Adobe Fireworks CS5 Classroom in a Book, make sure 
that your computer is set up correctly and that it meets the necessary system 
requirements for software and hardware. You’ll need a copy of Adobe Fireworks 
CS5, of course, but it’s not included with this book. If you haven’t purchased a  
copy, you can download a 30-day trial version from www.adobe.com/downloads. 
For system requirements and complete instructions on installing the software, see 
the Adobe Fireworks CS5 Read Me file on the application DVD or on the Web at 
www.adobe.com/support.

Make sure that your serial number is accessible before installing the application.

www.adobe.com/downloads
www.adobe.com/support
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Starting Adobe Fireworks
You start Fireworks just as you do most software applications. 

To start Adobe Fireworks in Windows: 

Choose Start > All Programs > Adobe Fireworks CS5.

To start Adobe Fireworks in Mac OS X:

Open the Applications/Adobe Fireworks CS5 folder, and then double-click the 
Adobe Fireworks CS5 application icon.

Copying the Classroom in a Book files
The Adobe Fireworks CS5 Classroom in a Book CD includes folders containing all 
the electronic files for the lessons in the book. Each lesson has its own folder; you 
must copy the folders to your hard disk to complete the lessons. To save room on 
your disk, you can install only the folder necessary for each lesson as you need it, 
and remove it when you’re done. 

To install the lesson files, do the following:

1	 Insert the Adobe Fireworks CS5 Classroom in a Book CD into your 
CD-ROM drive.

2	 Browse the contents and locate the Lessons folder.

3	 Do one of the following:

•	 To copy all the lesson files, drag the Lessons folder from the CD onto 
your hard disk.

•	 To copy only individual lesson files, first create a new folder on your hard 
disk and name it Lessons. Then, open the Lessons folder on the CD and drag 
the lesson folder or folders that you want to copy from the CD into  
the Lessons folder on your hard disk.

##  Note:  The CD 
also contains two 
bonus lessons and 
their accompanying 
lesson files. Chapter 
12 discusses how to 
improve your Fireworks 
workflow and Chapter 
13 discusses some of 
the more complex 
capabilities of Fireworks 
and integration 
between other Creative 
Suite software. PDFs of 
these two chapters are 
located in the Bonus 
Chapters folder on the 
disc, and their lesson 
files are located in the 
Lessons folder.
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Additional resources
Adobe Fireworks CS5 Classroom in a Book is not meant to replace documentation 
that comes with the program or to be a comprehensive reference for every feature. 
Only the commands and options used in the lessons are explained in this book. For 
comprehensive information about program features and tutorials, refer to these 
resources:

Adobe Community Help: Community Help brings together active Adobe product 
users, Adobe product team members, authors, and experts to give you the most 
useful, relevant, and up-to-date information about Adobe products. Whether 
you’re looking for a code sample or an answer to a problem, have a question about 
the software, or want to share a useful tip or recipe, you’ll benefit from Community 
Help. Search results will show you content not only from Adobe but also from the 
community.

With Adobe Community Help you can:

•	 Access up-to-date definitive reference content online and offline

•	 Find the most relevant content contributed by experts from the Adobe 
community, on and off Adobe.com

•	 Comment on, rate, and contribute to content in the Adobe community

•	 Download Help content directly to your desktop for offline use

•	 Find related content with dynamic search and navigation tools

To access Community Help: If you have any Adobe CS5 product, you already have 
the Community Help application. To invoke Help, choose Help > Fireworks Help. 
This companion application lets you search and browse Adobe and community 
content, plus you can comment on and rate any article just like you would in the 
browser. However, you can also download Adobe Help and language reference con-
tent for use offline. You can also subscribe to new content updates (which can be 
automatically downloaded) so that you’ll always have the most up-to-date content 
for your Adobe product at all times. You can download the application from www.
adobe.com/support/chc/index.html.

Adobe content is updated based on community feedback and contributions. You 
can contribute in several ways: add comments to content or forums, including links 
to web content; publish your own content using Community Publishing; or contrib-
ute Cookbook Recipes. Find out how to contribute: www.adobe.com/community/
publishing/download.html.

See http://community.adobe.com/help/profile/faq.html for answers to frequently 
asked questions about Community Help.

Adobe Fireworks Help and Support: See www.adobe.com/support/fireworks to 
find and browse Help and Support content on adobe.com.

www.adobe.com/support/chc/index.html
www.adobe.com/support/chc/index.html
www.adobe.com/community/publishing/download.html
www.adobe.com/community/publishing/download.html
http://community.adobe.com/help/profile/faq.html
www.adobe.com/support/fireworks
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Adobe TV: http://tv.adobe.com is an online video resource for expert instruction 
and inspiration about Adobe products, including a How To channel to get you 
started with your product.

Adobe Design Center: www.adobe.com/designcenter offers thoughtful articles 
on design and design issues, a gallery showcasing the work of top-notch designers, 
tutorials, and more.

Adobe Developer Connection: www.adobe.com/devnet is your source for techni-
cal articles, code samples, and how-to videos that cover Adobe developer products 
and technologies.

Resources for educators: www.adobe.com/education includes three free curricu-
lums that use an integrated approach to teaching Adobe software and can be used 
to prepare for the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Forums: http://forums.adobe.com lets you tap into peer-to-peer discus-
sions, and questions and answers on Adobe products.

Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a central 
resource for finding tools, services, extensions, code samples, and more  to  supple-
ment and extend your Adobe products.

Adobe Fireworks CS5 product home page: www.adobe.com/products/fireworks

Adobe Labs: http://labs.adobe.com gives you access to early builds of cutting-edge 
technology, as well as forums where you can interact with both the Adobe devel-
opment teams building that technology and other like-minded members of the 
community.

Also check out these useful links:

•	 Community MX (www.communitymx.com) for additional free and commercial 
tutorials and samples 

•	 Fireworks Zone—a tutorial, art, and news resource on all things Fireworks 
(www.fireworkszone.com)

•	 Fireworks Guru, the community forum where Fireworks enthusiasts share ideas, 
artwork, and solutions to design challenges (www.fireworksguruforum.com)

•	 Sarthak, the regularly updated Fireworks blog of Sarthak Singhal, a member of 
the Fireworks engineering team (blogs.adobe.com/sarthak)

•	 Adobe Fireworks Team blog, where you can learn the latest news from the 
people directly responsible for bringing you Adobe Fireworks (http://blogs.
adobe.com/fireworks/)

•	 Johndunning.com, a prolific creator of Fireworks extensions, designed to make 
your job even easier (http://johndunning.com/fireworks/)

http://tv.adobe.com
www.adobe.com/designcenter
www.adobe.com/devnet
www.adobe.com/education
http://forums.adobe.com
www.adobe.com/cfusion/exchange
www.adobe.com/products/fireworks
http://labs.adobe.com
www.communitymx.com
www.fireworkszone.com
www.fireworksguruforum.com
http://blogs.adobe.com/fireworks/
http://blogs.adobe.com/fireworks/
http://johndunning.com/fireworks/
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Adobe certification
The Adobe training and certification programs are designed to help Adobe custom-
ers improve and promote their product-proficiency skills. There are four levels of 
certification:

•	 Adobe Certified Associate (ACA)

•	 Adobe Certified Expert (ACE)

•	 Adobe Certified Instructor (ACI)

•	 Adobe Authorized Training Center (AATC)

The Adobe Certified Associate (ACA) credential certifies that individuals have the 
entry-level skills to plan, design, build, and maintain effective communications 
using different forms of digital media.

The Adobe Certified Expert program is a way for expert users to upgrade their 
credentials. You can use Adobe certification as a catalyst for getting a raise, finding 
a job, or promoting your expertise. 

If you are an ACE-level instructor, the Adobe Certified Instructor program 
takes your skills to the next level and gives you access to a wide range of Adobe 
resources.

Adobe Authorized Training Centers offer instructor-led courses and training 
on Adobe products, employing only Adobe Certified Instructors. A directory of 
AATCs is available at http://partners.adobe.com.

For information on the Adobe Certified programs, visit www.adobe.com/support/
certification/main.html.

http://partners.adobe.com
www.adobe.com/support/certification/main.html
www.adobe.com/support/certification/main.html
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4 Working with Selections

Lesson overview
Making selections on a bitmap image is an important component of 
working with bitmaps. Bitmap selections isolate a specific area for 
alteration, protecting all other areas from being affected. For example, 
you might want to brighten a dark part of an image. Without a selec-
tion, this change in pixel brightness would be applied to the entire 
photo. In this lesson, you’ll learn how to do the following:

•	 Make specific areas of an image active using selection tools

•	 Create a selection with the Magic Wand tool

•	 Adjust the edge of a bitmap selection

•	 Apply corrective filters to a selection

•	 Make complex selections using the Lasso and Magic Wand tools

•	 Modify a bitmap selection

•	 Save a bitmap selection for future use

•	 Deselect a selection

•	 Convert a bitmap selection to a path

This lesson takes approximately 60 minutes to complete. Copy the 
Lesson04 folder into the Lessons folder that you created on your hard 
drive for these projects (or create it now, if you haven’t already done 
so). As you work on this lesson, you won’t preserve the start files. If you 
need to restore the start files, copy them from the Adobe Fireworks CS5 
Classroom in a Book CD.
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Making selections on a bitmap image is key 
to working with bitmaps regardless of the 
software application .
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Understanding bitmap selections
Th e bitmap selection tools are helpful if you want to alter or copy a specifi c area of 
an image. Before you begin this lesson, though, you must also be clear on the diff er-
ence between selecting an object and making a bitmap selection.

When you click on an object in the Layers panel, or use the Pointer tool to click 
on an object on the canvas, you are selecting (or activating) the entire object. You 
can then move, copy, edit, or cut that object from the design, without aff ecting 
anything else on the canvas. A bitmap selection diff ers in that you are selecting a 
specifi c part of a bitmap image rather than the entire bitmap object. Once you’ve 
made a selection, you can only copy or edit the area within the selection border.

Bitmap selection tools: a primer
The selection tools in Fireworks include the Marquee and Oval Marquee tools, the 
Lasso and Polygon Lasso tools, and the Magic Wand tool .

Choose the selection tool most suitable for the job . Use the Marquee (  ) or Oval 

Marquee (  ) tool to select regularly shaped areas . Simply click and drag to draw 
out one of these selections after choosing the appropriate tool . Holding Shift con-
strains the rectangular marquee to a square and the oval marquee to a circle .

One of the Lasso tools (the standard Lasso  or the Polygon Lasso  tool) may 
be better suited to select irregular areas when you make a freehand selection . The 
standard Lasso Tool allows you to draw a selection on the canvas using a mouse or 
stylus . You outline the selection by clicking to plot points around the area you want 
selected . You can hold down Shift to constrain Polygon Lasso marquee segments to 
45-degree increments . To close the polygon selection, either click the starting point 
or double-click in the workspace .

If the area is full of similar shades of colors, the Magic Wand tool (  ) may be your 
best choice to quickly create a selection . The Magic Wand tool selects pixels based 
on color . If you have an area of similarly colored pixels in your image (a blue sky, for 
example), the Magic Wand can quickly select that part of your image . You start the 

Magic Wand

Lasso
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Hard Edge Anti-Aliased Edge Feathered Edge

selection by clicking the wand cursor on an area of your image . 
The wand selects contiguous pixels of the same color range, based on the 
Tolerance setting in the Properties panel . You can increase the tool’s sensitivity 
by changing the Tolerance setting to a higher value . 

options

Most of the bitmap selection tools have the option to set the selection edge to Hard, 
Anti-alias, or Feather . A Hard edge gives you a jagged, pixelated selection . Anti-alias 
blends the selection with the area outside the selection . Feather creates a softer, less 
accurate, blended edge selection . Unlike with the other two edge settings, you can 
apply a pixel value to Feather to increase the blend between the inside and outside 
of the selection . 

Additional selection features for the marquee

If you choose the Rectangular or Elliptical Marquee, the Properties panel off ers you 
additional options:

• Normal creates a marquee in which the height and width are independent of 
each other .

• Fixed Ratio constrains the height and width to defi ned ratios . 

• Fixed Size sets the height and width to a defi ned dimension, in pixels .

Using Live Marquee 

The Live Marquee feature is available for the bitmap selection tools listed earlier . 
By default, it is active (selected) in the Properties panel . Live Marquee gives you 
immediate control over the edge of your bitmap selection after it has been drawn . 
You can choose Hard for an aliased, hard-edged selection; Anti-alias for a softer, 
slightly blended selection edge; or Feather for a very soft blend . When you choose 
Feather, you set the amount of feathering you want . This amount will gradually 
blend any eff ect applied to the bitmap selection on both the inner and outer edges 
of the selection .
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Getting started
Various images may require different types of adjustments. In this lesson, you will 
use a variety of selection tools to make local adjustments on three different images. 
You will start with a simple selection exercise using the Magic Wand.

1	 Choose File > Open, and browse to the Lesson04 folder. 

2	 Select Backdrop02.jpg, and then click Open.

Notice how bright the sky is—practically without detail. You will apply a bitmap 
filter to a bitmap selection, which will permanently change the pixels in the image. 
When you are going to apply permanent changes to a bitmap object, it’s a good 
idea to create a duplicate of the image first so that the original is not damaged.

3	 Select the Pointer tool, and click on the image to make it active.

4	 Press Ctrl+Shift+D (Windows) or Command+Shift+D (Mac) to create a clone of 
the image. You now have two bitmap images in the Layers panel.

5	 In the Layers panel, double-click the bottom bitmap image name, and change it 
to Original.

6	 Double-click the top image, and rename it Retouching.

Selecting and modifying with 
the Magic Wand tool
In this section, you are going to use the Magic Wand tool to select a part of the 
scene in order to apply an exposure adjustment. 

Creating the selection
First, create the selection using the Magic Wand tool.

1	 Select the Magic Wand tool (   ) from the Tools panel.
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2	 Move the cursor over the sky portion of the image, and click once. As illustrated 
here, a selection appears.

3	 To see how our alteration blends with the rest of the photo, choose View > Edges 
(or press Ctrl+H on Windows or Option+F9 on Mac). This hides the selection 
from view but still lets you perform actions on it, such as applying filters.

4	 Choose Filters > Adjust Color > Levels.

5	 Set the Shadow (Minimum Intensity) value to 20.

6	 Set the Midtone (Gamma) value to 0.4, and leave the Highlight value at 255. 
You can do this by typing into the input boxes or dragging the middle sliders.

7	 Toggle Preview off and on again repeatedly to see how the cloud definition has 
changed, and then click OK to apply the filter. 

8	 Close the file without saving.

## Note:  When 
applying a filter 
adjustment to a bitmap 
selection, you must use 
the main Filters menu. 
You should also create 
a copy of the image 
before you begin. 

E Tip:  It’s a good idea 
to zoom in on the area 
you are selecting to 
ensure a more accurate 
selection.

Shadow 
Values

Output 
Levels 

(Contrast)

Midtone Values (Gamma)

Highlight 
Values
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Using the Magic Wand tool with keyboard modifiers
Because the Magic Wand tool selects based on contiguous pixel color, areas you 
want included may not always become part of your original selection. You can use 
modifier keys to add to the selection.

In this exercise, you are going to use the Magic Wand tool to select parts of the 
actors’ faces in order to apply an exposure adjustment. You will also modify the 
selection by applying a feathered edge.

1	 Choose File > Open, and browse to the Lesson04 folder. 

2	 Select actors_together.jpg, and then click Open.

Notice the skin tones on the left cheek of the man. They’re almost washed out. 
A similar problem exists with the woman’s face. You will be applying a bitmap 
filter to a bitmap selection, which will permanently change the pixels in the 
image. When you are going to apply permanent changes to a bitmap object, you 
should create a duplicate of the image first so that the original is not damaged.

3	 Select the Pointer tool, and click the image to make it active.

4	 Press Ctrl+Shift+D (Windows) or Command+Shift+D (Mac) to create a clone of 
the image, and rename this duplicate Retouching.

5	 If necessary, select the Magic Wand tool (   ) from the Tools panel.

6	 In the Properties panel, set the Edge to Feather, input a value of 4, set the 
Tolerance to 32, and make sure the Live Marquee option is selected. 

7	 Move the cursor to the bright area of the detective’s cheek, and click once. A 
selection appears.
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Notice that the other bright areas on the woman (her cheek and nose) are not 
part of the selection. This is because these areas are separated by pixels that are 
much darker and of different colors, and not within the Tolerance setting of the 
tool. Increasing the tolerance is not the answer, either, because we would end up 
selecting more areas than we want for this adjustment.

8	 Hold down the Shift key, and click on the bright part of the woman’s cheek, 
between her ear and her eye. 

9	 Hold down the Shift key one more time, and click on the bright side of the 
bridge of her nose. You now have three separate selections.

10	 Choose Filters > Repeat Levels. (This option is available for the last filter 
applied, as long as you have not restarted Fireworks.)

11	 Set the Gamma slider to a value of 0.6.

12	 Click OK to apply the filter. You’ll see that the skin tones of the actors’ faces 
look much more even and are no longer washed out.

If you create a particularly complex selection, such as the one you’ve just  
done, you might want to save your efforts as an alpha channel in order to reuse 
the selection at a later time. See the sidebar “Saving and restoring bitmap 
selections.” (Your file is currently in the perfect position to use these bitmap-
selection functions.)

Finally, it’s time to finish up with this file.

13	 Choose File > Save.

Fireworks recognizes that this altered image has properties that are not sup-
ported in a flat JPEG file, so you will see a dialog box asking you for a decision 
about which type of file you’d like to save. If you want to retain the editability 
of the file, save it as a Fireworks PNG file. If the original image and the bitmap 
selection are not important, you can opt to save the file as a flat JPEG.

## Note:  To subtract 
from a selection, hold 
down the Alt (Windows) 
or Option (Mac) keys. 
These modifiers work 
with the Rubber Stamp, 
Lasso, Marquee, and 
Oval Marquee tools.

E Tip:  Sometimes 
the marquee itself 
can get in your way. 
You can quickly 
show or hide the 
marquee by pressing 
Ctrl+H (Windows) or 
Option+F9 (Mac).
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14	 Click Save Fireworks PNG. This will maintain the selection information and 
both bitmap images. The Save dialog box appears.

15	 Name the file actors_together_retouched.png, save it to the Lesson04 folder, 
and click OK.

## Note:  If you had chosen File > Save As, Fireworks would assume you want to save the file as a 
JPEG. There’s a warning message in the Save As dialog box; pay attention to it! Some people don’t 
notice the warning and later reopen their file only to learn the edits have been flattened, and the 
original unaltered image has been lost. Make sure you click on the Save As Type options and choose 
the format you prefer.

Saving and restoring bitmap selections
Once you’ve created a complex selection, you can save it, giving you the option to 
deselect it, work on other parts of the image, and come back to that selection later. 
These functions are available regardless of the selection tool you’ve used in the first 
place. To save a selection, you first need to have an active bitmap selection.

1	 Choose Select > Save Bitmap Selection.
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Selecting with the lasso tools
Selection tools are also interchangeable; you might start with the Magic Wand tool, 
for example, but then turn to the Lasso tool (   ) to refine a selection.

1	 Choose File > Open, and browse to the Lesson04 folder.

2	 Open the file called Mark_actor07.jpg.

2	 In the Save Selection dialog box, change the name to cheek. 
Leave all other settings as they are.

3	 Click OK. 

	 Once a selection is saved, you can then call it up any time you need it during 
your session. If you save the file as a Fireworks PNG file, the selection remains with 
the file and can be restored even after the file has been closed and reopened.

## Note:  If you have more than one saved selection, you can choose the correct one 
from the Selection menu in the Restore Selection dialog box. In the current exercise,  
the “cheek” selection is the only one in the list.

4	 Press Ctrl+D (Windows) or Command+Shift+A (Mac) to deselect the bitmap 
selections on the canvas (so that you can see how to restore it).

5	 Choose Select > Restore Bitmap Selection.

6	 Click OK. The selection reappears on the canvas.
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3	 Select the Magic Wand tool once again. 

4	 Set Edge to Anti-alias, its value to 0, and Tolerance to 32, and make sure the 
Live Marquee option is selected.

5	 Click on the gray cinderblock wall. 

6	 Hold down the Shift key, and click on other areas of the wall. Avoid clicking the 
shadow of the detective, because this will also select parts of the gun.

7	 Continuing to press the Shift key, click the dark segment to the right of the actor.

8	 Select the Lasso tool.

9	 Holding down the Shift key, draw around a large part of the shadow. Avoid 
lassoing the gun. You do not have to do this in one operation; indeed, it’s a  
good idea to zoom in for the more detailed areas and add to the selection in 
multiple steps.

## Note:  If you don’t 
see the selection 
appear, make sure that 
the marquee is not 
hidden by selecting 
View > Edges.
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As long as you hold down the Shift key, you can add to the existing selection. 
If you select an area by accident, you can switch to the Alt (Windows) or  
Option (Mac) key and draw around the unwanted area.

When you are done, everything except the detective should be selected.

10	 Choose File > Save.

11	 Click Save Fireworks PNG. 

The Save As dialog box appears.

## Note:  Creating this 
selection took some 
time, so it’s wise to save 
the selection as you 
did with the previous 
document (choose 
Select > Save Bitmap 
Selection).
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12	 Name the file Mark_actor07.fw.png. Because you are using a different file type, 
you can still keep the same filename.

13	 Save the file to the Lesson04 folder and click OK.

Converting a selection to a path
In Fireworks, you can easily convert bitmap selections to vector paths. Paths can be 
easier to edit than bitmap selections, in part because you aren’t as likely to delete an 
entire path by accident. If you are adjusting a bitmap selection and forget to use the 
Shift and Alt (Windows) or Option (Mac) modifier keys, you can easily delete the 
entire selection. To edit the shape of a path, you can use the Subselection tool (   ) 
to drag individual control points in the path.

In this exercise, you will continue working with 
the Mark_actor07.fw.png file.

1	 If the selection is not active, choose Select > 
Restore Bitmap Selection.

2	 Choose Select > Convert Marquee To Path. 

The selection is removed, and in its place  
is a new path object, filled with the last  
attributes used for vector objects.

3	 Select the Pointer tool, if it’s not already 
selected. 

4	 Choose Pattern > Wood 3 from the Fill 
Category list in the Properties panel.
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The detective is now up against another type of wall, so to 
speak. In the Layers panel, the newly created vector object  
is called a composite path. 

5	 Double-click the object name in the Layers panel and change 
it to wall.

6	 Rename the bitmap image detective.

7	 Choose File > Save.

You will learn much more about working with paths in Lesson 4.

Other selection options
Select Inverse

Sometimes, selecting the unwanted part of the image is easier. 

The Select Inverse command toggles between the active selection and the unselected area.

Let’s say you have a photo of a city scene with a clear sky in the background. You want to do some levels or  
filter adjustments to the city area. Using the Magic Wand tool to select the evenly colored sky will be easier  
(and faster). Then you can choose Select > Select Inverse to reverse the selected areas, making the city scene  
the active selection.

      

Select Similar

Select Similar adds to the current bitmap selection, based on colors within the active selection. Anywhere the 
colors within the selection appear throughout the image, they will become part of the new selection. You can 
choose Select > Select Similar with any bitmap selection.

Modifying a selection

You can expand, contract, or smooth any active bitmap selection by choosing the desired action from the  
Select menu.
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Review questions
1	 What is the difference between selecting objects and making bitmap selections?

2	 What are the five bitmap selection tools in Fireworks, and what are their functions?

3	 What does the Tolerance setting do when you’re using the Magic Wand tool?

4	 What are the two keyboard modifiers you can use in conjunction with the bitmap 
selection tools?

5	 How do you create a clone of a bitmap image? Why would you do this?

Review answers
1	 When you click on an object in the Layers panel or use the Pointer tool to click an 

object on the canvas, you are selecting (or activating) the entire object, allowing you to 
move, copy, edit, or cut that object from the design, without affecting anything else on 
the canvas. A bitmap selection differs from this in that you are selecting a specific part 
of a bitmap image rather than the entire object. Once you’ve made a selection, you can 
copy or edit only the area within the selection border. The bitmap selection tools cannot 
be used on vector objects.

2	 The Fireworks selection tools are the Marquee and Oval Marquee tools, the Lasso and 
Polygon Lasso tools, and, finally, the Magic Wand tool. 

Typically, you use the Marquee or Oval Marquee tool to select regularly shaped areas, 
and the Lasso or Polygon Lasso tool to select irregular areas. You use the Magic Wand 
tool to select pixels based on color. While drawing the initial selection, the Shift key 
constrains the marquee tools to symmetrical objects (squares and circles) and the 
Polygon Lasso tool segments to 45-degree increments.

After a selection has been created, hold down the Shift Key to add to the selection. 
Pressing Alt (Windows) or Option (Mac) subtracts from a selection. 
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3	 The Magic Wand tool selects contiguous pixels of the same color range based on the 
tolerance setting in the Properties panel. You can increase the tool’s sensitivity by 
changing the Tolerance setting in the Properties panel to a higher value. 

4	 The Shift key is one of the keyboard modifiers you can use with bitmap selection tools, 
and the Alt (Windows) or Option (Mac) key is the other. Both of these modifiers work 
with the Rubber Stamp and freehand Lasso tools, as well as the rectangular and elliptical 
marquees. Holding down the Shift key lets you add to an existing selection. To subtract 
from a selection, hold down Alt (Windows) or Option (Mac). 

5	 To clone a bitmap image (or any other object), press Ctrl+Shift+D (Windows) or 
Command+Shift+D (Mac), or choose Edit > Clone to create a clone of the image. 
Creating a clone of your original image lets you edit and retouch a copy without  
damaging the original.
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Numbers

2-Up view option, 165, 167
4-Up view option, 165, 169
9-slice Scaling tool, 47–48, 87–88

A

active objects, 155
Add States dialog box, 269
adjustment layers, 119, 120, S:31, S:35
Adobe Acrobat Professional, 247, 248
Adobe AIR. See AIR
Adobe Bridge, S:11–S:13
Adobe Dreamweaver. See Dreamweaver 

CS5
Adobe Exchange, 90
Adobe Fireworks. See Fireworks CS5
Adobe Flash. See Flash
Adobe Flash Builder 4, S:82
Adobe Flash Catalyst. See Flash Catalyst
Adobe Flex, S:75, S:81

See also Flex skins
Adobe Illustrator, S:87
Adobe Photoshop. See Photoshop
Adobe Reader, 248
Adobe XMP format, S:27
AIR (Adobe Integrated Runtime), S:44–S:63

adding AIR events, S:50–S:55, S:111
creating AIR prototypes, S:55–S:60
functionality in Fireworks, S:44
installing AIR prototypes, S:61–S:63
transparent chrome option, S:57

Ajax (Asynchronous JavaScript and XML), 
279

Align panel, 49–50, 152, 220, 261
aligning

objects, 49–50
text, 152

alpha transparency, 160, 230

anchor points
adding with Pen tool, 93
basics of using, 92

Animate dialog box, 226–227
Animated GIF format, 230
animation symbols, 225–234

creating, 225–230
exporting, 234
file size reduction, 232
looping settings, 233, 234
onion skinning, 228–230
optimizing, 230–232
overview of, 225
previewing, 232, 233
state delay settings, 232–233

Anti-Aliased selection edge, 65
anti-aliasing

bitmap edges, 65
text, 149–150

Application bar, 5, 14
Application Frame, 6, 17
assets, importing, 114–115
Auto Shapes, 11, 89–90, 93, S:24
Auto Shapes panel, 90, 104
Auto Vector Mask command, 111, 116–117
auto-resizing text blocks, 143

B

Babbage, Jim, S:46
Background Image slices, 199
backgrounds

adding to documents, 112
steps for adjusting, 135–137

banding issues, 231
banner ad project, 111–137

background, 112, 135–137
creating document for, 111–112
gradient settings, 113–114
image positioning, 137
importing assets into, 114–115

Index
Entries for bonus supplemental chapters 12 and 13 are noted with the letter S.
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mask creation/editing, 121–129
Photoshop image import, 118–119
quick fade effect, 116–117
styling text for, 132–135
text added to, 129–132

baseline shift, 148
Batch Process dialog box, S:15
batch-processing images, S:13–S:19
behavior handle, 275
behaviors

adding, 275–276, 287–289
editing, 289–292
explanation of, 275
previewing, 276, 291–292
rollover, 186–187, 275–276
Swap Image, 186

Behaviors panel, 289–291
Bezier control arms, 92
bitmap images, 38–60

aligning, 49–50
batch-processing, S:13–S:19
brightness adjustments, 52–54
correcting, S:63–S:71
cropping, 41–42, S:21–S:22
darkening, 53–54
Flash support for, S:110
flattened, 120, 161, S:102, S:107–S:110
grouping, 51
guides and, 44
hiding objects, 43
importing, 44–45, S:19–S:20
lesson overview, 38
lightening, 53
locking objects, 43
managing on the canvas, 43–44
masks based on, 108
positioning, 43, 49–50
repairing areas in, 56–59
resolution and file size, 40
review questions/answers, 60
scaling, 46–48
selections on, 62–77
sharpening, 54–55
tips for working with, 40
tonal range adjustments, 48–49
vector graphics vs., 86

bitmap masks
changing colors of, 128
converting selections to, 125–126
creating with Brush tool, 108, 109
editing, 126–127

overview of, 108–109
review questions/answers, 138
vector masks vs., 110
See also vector masks

bitmap selections, 62–77
converting to paths, 74–75
explanation of, 64
filter adjustments and, 67
inverse selection option, 75
Lasso tool for, 71–74
lesson overview, 62
Magic Wand tool for, 66–70
masks based on, 108, 125–126
modifying from Select menu, 75
primer on, 64–65
restoring, 71
review questions/answers, 76–77
saving, 70–71
similar selection option, 75
tools for making, 64–65

Bitmap tools, 10
blending modes

applying for image correction, S:63–S:71
Flash support for, S:101
Photoshop support for, S:36

BMP file format, 162
Bridge application, S:11–S:13
brightness adjustments, 52–54
browsers. See Web browsers
Brush tool, 108, 126–127
Burn tool, 52, 53–54
button states, S:78–S:80
button symbols, 217–224

adding multiple, 222–223
creating, 217–219
editing, 220–221
overview of, 217
prototypes using, 259–264
rollover effects, 220–221, 223, 259–264
text for, 220, 222, 223–224

C

canvas
adding guides to, 81
preparing, 7
resizing, 226, 264–265, S:25
trimming, 230

Canvas Size dialog box, 226, S:25
Cascading Style Sheets. See CSS
chainlink icon, S:6
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Chamfer Rectangle tool, 89
checkerboard canvas area, 231
Circle Hotspot tool, 185
clipping groups, 119
Clone Stamp tool, 56
Close event, S:50–S:51, S:55
colors

adjusting, S:67–S:68
bitmap mask, 128
gradient, 12–13, 113
guide, 228
matte, 163, 230
selections based on, 64–65

Colors tools, 10
commands

batch-processing, S:16
custom, 20
See also specific commands

Commands menu, 20
comment feature, 248
Common Library

adding prebuilt symbols from, 216–217
saving symbols to, 210–211

Common Library panel, 199, 212, 216
component symbols, 199, 208
Compound Shape tool, 99–104
compound shapes, 99–104

adding shapes to, 101–104
how they work, 100–101

constraining proportions, 115
content pages, 255–256
control handles

for cropping, 42
for scaling, 46, 47

conversions
pages to PSD file, 28
selection to path, 74–75

Convert Pages to PSD extension, 28
Convert to Symbol dialog box, 209, 228, 260
correcting images, S:63–S:71
Create AIR File dialog box, S:56–S:60
Crisp Anti-Alias setting, 149
Crop tool, 41
cropping

bitmap images, 41–42, S:21–S:22
images in designs, 42

CSS (Cascading Style Sheets), 195–203
CSS and Images export, 201–203
Fireworks functionality and, 195–198
preparing to export, 198–203

cursor display options, 56

curved anchor points, 92, 93
Custom Anti-Alias setting, 149, 150
custom shapes, 94–95
custom styles, 133–134
Custom Symbols folder, 211
custom workspaces

creating, 15–16
deleting, 16

customizing
file names for states, 193
page dimensions, 264–265
Photoshop export options, S:34–S:35
strokes, 97–98

D

darkening images, 53–54
deleting

anchor points, 92
custom workspaces, 16
shapes, 80–81
templates, S:11

Device Central, S:40–S:43
previewing applications in, S:42–S:43
selecting device profiles in, S:40–S:42

digital signature, S:59–S:60
disjointed rollover, 289
distortion-free scaling, 46, 47–48, 87–88
Dither Gradient button, 97
dither settings, 231
DIV tags

creating, 197, 200–201
explained, 196

dock, configuring, 13–15
Document Library panel, 210
document templates, 4, S:4–S:11

opening, S:4–S:5
project assembly using, S:5–S:10
removing unwanted, S:11

documents
creating new, 4, 111–112
graphic symbols added to, 212–213
templates for creating, 4, S:4–S:11
working with multiple, 16–19

Dodge tool, 52, 53
downsampling images, 54
Drag event, S:55
dragging/dropping

from Fireworks to Flash stage, S:110
between floating windows, 18–19
objects into layers, 269, 273
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drawing vector shapes, 7–8, 80
Dreamweaver CS5, S:88–S:99

copying and pasting to, S:88–S:92
creating pods for, S:95–S:99
round-trip editing using, S:92–S:95

duplicating states, 34

E

edge pixels, 55
Edit Gradient pop-up window, 12, 97, 113
Edit in Place mode, 213
editing

bitmap masks, 126–127
button symbols, 220–221
FXG files, S:85–S:87
gradients, 113–114
graphic symbols, 213–215
JavaScript behaviors, 289–292
objects within groups, S:9–S:10
paths, 93
round-trip, S:92–S:95, S:99
text, 145–146, 154
vector masks, 124

Elliptical Marquee tool, 65
e-mail, sending files to, S:26
empty bitmap objects, 58
empty states, 285–286
emulations

pop-up window, 276–279
Spry data table, 279–286

Escape key, 41
Expand/Collapse Layer icon, 32
Export Area tool, S:22
Export As Adobe PDF option, 161
Export dialog box, 201, 246–247, S:23
Export FXG And Images option, 161
exporting

animations, 234
CSS and Images, 195–203
files to Photoshop, S:34–S:35
Flex skins, S:80–S:81
FXG documents, S:82–S:84
HTML and Images, 188–195, 296
optimized files, 170
overlapping slices, 277
pages to files, 28
prototypes, 296–298
resetting options for, S:24
saving vs., 161
specific areas, S:22–S:24
states, 193–194

wireframes, 246–247
extensions, 13
Eyedropper tool, 113

F

face-lift technique, 58–59
Feathered selection edge, 65
file formats

Adobe XMP format, S:27
Fireworks PNG format, 9, 161
Flash FXG format, S:82
Photoshop PSD format, 28, S:33–S:34
for Web graphics, 160–161

file names
customizing for states, 193
specifying for symbols, 211

file size
GIF animations and, 231, 232
resolution and, 40
Web optimization and, 160, 169, 177–179

files
adding metadata to, S:27–S:29
exporting vs. saving, 161
saving in Fireworks, 9

Fill Category Pattern submenu, 100
Fill Color box, 97
fills

gradient, 12–13, 95–97
vector shape, 7–8

Filmstrip workspace, S:11
filters

applying to bitmaps, 67
supported in Flash, S:101
Unsharp Mask filter, 54–55
See also Live Filters

Find Source dialog box, S:93, S:108
Fireworks CS5

AIR functionality in, S:44
blending modes supported in, S:36
CSS and, 195–198
Developer Center, 197, S:81
Dreamweaver and, S:88–S:99
Flash and, S:99–S:110
Flash Catalyst and, S:82
Illustrator and, S:87
interface illustration, 5
native PNG format, 9, 161
Photoshop and, 28, 119–120, S:30–S:36
workflow, S:2–S:37

fixed-width text blocks, 143–144
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Flash, S:99–S:110
complex animations and, 234
considerations for importing to, S:110
Fireworks features supported in, S:101
flattened bitmaps imported into, S:107–S:110
PNG files imported into, S:102–S:107, S:111
preparing files for, S:100–S:101

Flash Builder 4, S:82
Flash Catalyst, S:82–S:87

downloading, S:85
editing FXG files in, S:85–S:87
exporting pages to, S:82–S:84, S:111
Fireworks and, S:82
overview of, S:82
viewing files in, S:85

Flash platform, S:82
Flash Professional CS5, S:102
Flatten Selection command, S:70
Flattened bitmap images

exporting files as, 161
importing into Flash, S:102, S:107–S:110
opening in Fireworks, 120

Flattened PNG format, 9
Flex skins, S:75–S:81

adding button states to, S:78–S:80
choosing components for, S:111
exporting, S:80–S:81
steps for creating, S:75–S:78
Web resources on, S:81

floating document windows
creating, 17–18
dragging/dropping between, 18–19

folders
Custom Symbols, 211
prototype, 298

Font Style menu, 89
fonts

banner ad project, 130
converted to paths, S:45
formatting features, 142
issues with missing, S:13
resizing, 145
Web-safe, 203

footers, 295
Foreground Image slices, 199
Freeform tool, 92
future-proofing projects, S:27–S:36

metadata information and, S:27–S:30
Photoshop integration and, S:30–S:36

FXG files, S:82
editing, S:85–S:87
exporting, S:82–S:84

Fireworks effects and, S:86
viewing, S:85

G

GIF files, 160
animated, 230–232, 234
illustrations optimized as, 176–179
Optimize panel options, 163, 230–232
range of colors in, 231

Gradient Dither icon, 13
Gradient panel, 13
gradients

adding gradient fills, 95–97
editing direction and angle of, 114
setting colors for, 12–13, 113

graphic symbols, 208–217
adding to documents, 212–213
creating, 209–211
editing, 213–215
isolation mode for, 214
overview of, 208
prebuilt, 216–217
saving to Common Library, 210–211

graphics
Web file formats for, 160–161
See also bitmap images; vector graphics

Grayscale Appearance mode, 111, 123
groups

of objects, 51, S:9–S:10
of panels, 13–15
of shapes, 148

guides
9-slice scaling, 47, 87–88
adding to canvas, 81
changing color of, 228
hiding/showing, S:32
measuring distances between, 81–82
placing objects using, 44, 82–83
Snap to Guides option, S:19–S:20
toggling on/off, 81, 89
vector graphics, 81–83
web slice, 173

H

Hard selection edge, 65
Hide Slices and Hotspots icon, 171, 223, 261, 264, 291
hiding

guides, S:32
marquee, 69
objects, 43
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histogram, 48
History panel, 20, 103
horizontal scaling, 148
Hotspot tools, 10, 171, 185
hotspots

creating, 184
Layers panel view of, 174
slice objects and, 184
tools for, 10, 171, 185

HTML
AIR prototypes and, S:44
CSS layouts and, 196, 199
DIV tags in, 196, 197, 200–201
editing rollovers in, 194–195
exporting states with, 193–194
Flash support for, S:110
HTML and Images export, 188–195, 296

HTML Setup dialog box, 297
Hue/Saturation adjustments, S:67–S:68
Hungarter, Doug, 28
hyperlinks

adding to slices, 186–187
creating within slices, 184
prototype navigation, 244–245, 262–264

I

icon images, S:58
illustrations

optimizing, 176–179, 181–182
reducing file size of, 177–179

Illustrator program, S:87
Image Description (Alt Text) dialog box, S:92
Image Preview dialog box, S:22–S:23, S:90
Image Size dialog box, 54–55
images

batch-processing, S:13–S:19
correcting, S:63–S:71
importing, 44–45, S:19–S:20
linking thumbnails to, S:19
positioning, 43, 49–50, 286
resolution vs. quality, 40
rollover, 186–187
See also bitmap images

import cursor, 44
Import dialog box, 26
Import Page window, 26
importing

assets, 114–115
bitmap images, 44–45, S:19–S:20
documents into Flash, S:102–S:110
pages, 26–27

Photoshop images, 118–119
vector objects, 98–99

installing AIR prototypes, S:61–S:63
instances of symbols, 208
instant face-lift technique, 58–59
interactivity

prototype, 262–264
Web page, 186–187
wireframe, 244–245

interface
annotated illustration, 5
common to Adobe programs, 3, 5
custom workspaces, 15–16
default workspaces, 5–6
document window features, 16–19
panel configuration, 13–15
Properties panel, 12–13
review questions/answers, 21
rulers and tooltips, 7
Tools panel, 10–11

isolation mode, 214

J

JavaScript behaviors
adding, 275–276, 287–289
editing, 289–292
rollover effects, 186–187, 275–276
Swap Image behavior, 186

JPEG files, 160
exporting PNG files as, 170
Optimize panel options, 162, 256
saving images as, 70
slices optimized as, 174–175
text quality and, 169

K

kerning, 148
Key Type option, S:59
Kuler panel, S:44

L

Lasso tools
selecting with, 71–74
situations for using, 64

layer styles, 35, S:33, S:35
layers, 24–25, 28–33

adding/naming, 30
detaching shared, 264
Fireworks support for, 18
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moving objects between, 30
multiple objects in, 59
naming objects in, 28–29
Photoshop file, 120
protecting, 32–33
rearranging objects in, 29
retouching on separate, 57–58
review questions/answers, 37
shared, 242, 264, 266–267, 273
stacking order of, 98
sublayers and, 31–32, 267

Layers Magazine, S:81
Layers panel

accessing options in, 33
active objects displayed in, 155
adding/naming layers in, 30
empty bitmap objects in, 58
Flex skin creation and, S:76
locking objects in, 32–33
moving objects between layers in, 30–31
naming objects in, 28–29
rearranging objects in, 29
Share Layer to Pages option, 266, 273
Show/Hide icon in, S:65, S:97
stacking order of layers in, 98
sublayer creation in, 31–32

leaderboard banner, 111, S:5–S:6
leading, 148
Levels dialog box, 36, 48–49
Levels Live Filter, 49, S:35
Library panel, S:105, S:107–S:108
lightening images, 53
linear gradients, 95
links. See hyperlinks
Live Effects. See Photoshop Live Effects
Live Filters, 49

adding to states, 36
contrast adjustments and, 48–49
image correction using, S:67–S:68
masked objects and, 128–129, 155
sharpness adjustments and, 54–55
supported by Photoshop, S:35

Live Marquee feature, 65
locking

layers, 32–33
objects, 33, 43
proportions, 9

logo files, S:6

looping animations, 233, 234
lossy format, 160

M

Mac OS
Fireworks interface, 5–6
importing images on, 99, 115

Magic Wand tool, 66–70
creating selections with, 66–67
keyboard modifiers used with, 68–70
situations for using, 64–65

Main toolbar, 5
Maintain Appearance option, 164
Marquee tool, 64
masks, 106–138

Auto Vector Mask command, 116–117
banner ad project using, 111–137
creating and editing, 121–129
explanation of, 108
image corrections and, S:69–S:70
lesson overview, 106
Live Filters and, 128–129
quick fades with, 116–117
review questions/answers, 138
selections converted to, 125–126
text used as, 153–154
two types of, 108–111
See also bitmap masks; vector masks

master pages, 240–241, 255, 257–258
matte color, 163, 230
Maximize event, S:55
Menu bar, 6
metadata, S:27–S:30

adding to files, S:27–S:29
template creation, S:29–S:30

Minimize event, S:55
mobile projects, S:40–S:43

previewing in Device Central, S:42–S:43
selecting device profiles for, S:40–S:42

mockups. See prototypes; wireframes
mouse

adding AIR events for, S:50–S:55
highlighting objects by moving, 28
testing rollovers using, 223

moving objects between layers, 30
multiple documents, 16–19



Adobe fireworks c s5 Classroom in a B  ook  307

N

naming/renaming
layers, 30
objects, 28–29
slices, 182–183, 274
states, 34, 193
symbols, 211

navigation buttons, 220
nested symbols, 228
New Bitmap Image icon, 52, S:65
New Document dialog box, 4, 111
New Flex Skin dialog box, S:75
New From Template dialog box, S:4
New Style dialog box, 133–134
New Sub Layer button, 31
New/Duplicate Layer button, 30
New/Duplicate page icon, 225
No Anti-Alias setting, 149
Numeric Transform options, 51
N-Up feature, 168

O

object-oriented approach, 59
objects

aligning, 49–50
determining active, 155
editing within groups, S:9–S:10
grouping, 51
hiding, 43
layers and, 59
locking, 33, 43
naming, 28–29
overlapping, 198
placing with guides, 44
positioning, 43, 49–50, 82–83
proportions of, 9
rearranging, 29
selecting, 64

onion skinning, 228–230
Optimize panel, 161–163

choosing settings in, 168–169
view options in, 165, 168
See also Web optimization

Original view option, 165
Oval Marquee tool, 64
overlapping objects, 198
overlapping slices, 277
Oversampling option, 149

P

page weight, 160, 162
pages, 24, 26–28

adding, 242–243, 258–259
content, 255–256
customizing dimensions of, 264–265
exporting, 28, S:82–S:84
importing, 26–27
master, 240–241, 255, 257–258
moving between, 27
reordering, 26, 27
resetting export options for, S:24
review question/answer on, 37
sharing layers to, 266–267
wireframe, 241–245

Pages panel
isolating, 239–240
overview of, 238–240

panels
accessing, 15
arranging, 15
configuring, 13–15
extensions for, 13
See also specific panels

paragraph indent, 148
paragraph spacing, 148
password-protected tasks, 247
Path Outline mode, 110
Path panel, 100
Path Scrubbers, 92
paths

attaching text to, 150–152
drawing with Pen tool, 91
fonts converted to, S:45
methods for editing, 93
selections converted to, 74–75
text converted to, S:73
tools for working with, 92

patterns, applying to vector objects, 100
PDF files, creating interactive, 246–247
Pen tool

adding points with, 93
creating custom shapes with, 94–95
drawing paths with, 91, 151

Pencil bitmap tool, 91
Photoshop

blending modes supported in, S:36
customizing export options for, S:34–S:35
Fireworks integration with, 28, 119–120, S:30–S:36
importing images from, 118–119
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Live Filters supported in, S:35
multipage Fireworks files and, 28
opening files from, 119–120
saving files for, 28, S:33–S:34

Photoshop Export Options dialog box, S:34, S:35
Photoshop File Import Options dialog box, 118
Photoshop Live Effects, 35, S:30

explanation of, S:33
Flex skin button states, S:79
steps for using, S:30–S:32

Photoshop Live Effects dialog box, 35, S:9
pixel dimensions, 7
Pixel Radius property, 55
pixels per inch (ppi), 7
playback controls, 228
PNG files, 9, 160–161

exporting as JPEG files, 170
Fireworks vs. Flattened, 9
illustrations optimized as, 176–179, 181–182
importing into Flash, S:102–S:107
Optimize panel options, 163, 256
round-trip editing of, S:92–S:95
saving documents as, 9

pods, S:95–S:99
Pointer tool, 12
Polygon Hotspot tool, 185
Polygon Lasso tool, 64, 125
Polygon Slice tool, 171, 172
pop-up blockers, 278
pop-up windows

consideration on using, 278
emulating in prototypes, 276–279

positioning
bitmap images, 43, 49–50
vector graphics, 82–83

ppi (pixels per inch), 7
prebuilt symbols, 216–217
Preserving Text Quality option, 169
previews

AIR prototype, S:60
animation symbol, 232, 233
browser-based, 184–185, 202–203, 276
cropped area, S:22–S:23
rollover effect, 276, 291–292
Web optimization, 164–169

primitive shapes, 11
Properties panel, 12–13
proportionate scaling, 9
protecting layers, 32–33
prototypes, 236–299

adding pages to, 258–259
Adobe AIR, S:44, S:55–S:63

advanced or complex, 252–299
behaviors added to, 275–276, 287–289
buttons used in, 259–264
comment feature, 248–249
content pages, 255–256
customizing page dimensions for, 264–265
delivering to clients, 246–249
editing behaviors in, 289–292
exporting, 246–247, 296–298
fleshing out, 257
footers added to, 295
image rollovers in, 265–279
interactivity added to, 244–245, 262–264
lesson overview, 236, 252
locating folder for, 298
master pages, 240–241, 255, 257–258
naming slices in, 274
navigation buttons in, 259–264
Pages panel and, 238–240, 254
populating last pages of, 293–295
pop-up window emulations in, 276–279
review questions/answers, 250, 299
rollover effects in, 259–264, 265–279
Spry data table emulations in, 279–286
steps for completing, 293–298
wireframe page comparison, 241–245
workflow for creating, 238
See also wireframes

PSD files
exporting files as, S:34–S:35
importing, 118–119
saving documents as, 28, S:33–S:34

punching vectors, 102

Q

quality
resolution vs., 40
Web optimization and, 166–169

R

raster graphics. See bitmap images
Rectangle Hotspot tool, 184, 185
Rectangle tool, 7–8
rectangles

changing corners of, S:24–S:26
drawing with Rectangle tool, 7–8

Rectangular Marquee tool, 65
Redraw Path tool, 92
remote rollovers, 289, 291–292
renaming. See naming/renaming
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resampling images, 54
Reshape Area tool, 92
resizing. See sizing/resizing
resolution

file size and, 40
image quality vs., 40
setting in Fireworks, 7

Restore Selection dialog box, 71
retouching images

general steps for, 56–57
instant face-lift technique, 58–59
separate layer used for, 57–58

retouching tools
Dodge and Burn tools, 52–54
Rubber Stamp tool, 56–59

Reverse Gradient button, 13
review questions/answers

on bitmap images, 60
on layers, 37
on masks, 138
on pages, 37
on prototypes, 250, 299
on selections, 76–77
on states, 37
on symbols, 235
on text, 156–157
on user interface, 21
on vector graphics, 105
on Web optimization, 204–205
on workflow, S:37

rich Internet applications (RIAs), S:82
rollover effects

behaviors added to, 186–187, 275–276
button symbol, 220–221, 259–264
creating, 186–187, 217, 220–221, 259–264, 270–271
image, 265–279
navigation, 259–264
previewing, 276, 291–292
remote rollovers, 289, 291–292
slices and, 186–187, 271–273
states added to, 262, 265–273
testing, 223

Rounded Rectangle Auto Shape, S:25
round-trip editing, S:92–S:95, S:99
Rubber Stamp tool, 56–59

instant face-lift technique, 58–59
repairing image areas with, 56–57
retouching on a separate layer with, 57–58

rulers, viewing, 7, 81

S

Save As dialog box, 9, 70, S:33
Save Script button, S:17
Save Web Image dialog box, S:91
saving

bitmap selections, 70–71
exporting vs., 161
files for Photoshop, 28, S:33–S:34
Fireworks PNG files, 9
operations as scripts, S:17
symbols to Common Library, 210

Scale tool, 46, 83, 87
scaling

9-slice guides for, 47, 87–88
bitmap images, 46–48
distortion-free, 46, 47–48, 87–88
proportionate, 9
traditional method of, 46, 87
vector graphics, 83–84, 87–88, 99

scripts, saving operations as, S:17
security certificates, S:59
Select Inverse command, 75
Select menu options, 75
Select Similar command, 75
Select tools, 10
selecting objects, 64
selections, bitmap. See bitmap selections
Selective Quality setting, 169
Send To E-mail option, S:26
Set Nav Bar Image dialog box, 288
shapes

Auto, 11, 89–90, 93, S:24
compound, 99–104
custom, 94–95
deleting, 80–81
downloading, 90
drawing, 7–8, 80, 94–95
flowing text within, 146–148
primitive, 11
ungrouping, 148
See also vector graphics

Share Layer to Pages dialog box, 266–267, 273
shared layers, 242, 264, 266–267, 273
sharpening images, 54–55
Sharpness option, anti-aliasing, 149
Show Slice and Hotspots icon, 171, 261, 264
Show/Hide icon, S:65, S:97
silhouettes, 129
sizing/resizing

canvas, 226, 264–265, S:25
slices, 174
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thumbnails, 33, S:14
vector graphics, 8, 83–84, 99

Skew tool, 152–153
skewing text, 152–153
skyscraper banner, S:7–S:9
Slice tool, 10, 171

choosing style of, 172
creating slices with, 172–173, 283

slices, 171–185
adding, 175–176
button symbol, 219, 220
creating, 172–173
CSS layouts and, 195, 199
explanation of, 171
exporting states and, 193–194
hotspots added to, 184
hyperlinks added to, 186–187
illustration optimization, 176–179, 181–182
JPEG image optimization, 174–175
Layers panel view of, 174
main components of, 173
making multiple, 179–181
naming/renaming, 182–183, 274
overlapping, 277
pods for, S:95–S:99
resizing, 174
rollover, 186–187, 271–273

Smart Guides, 51, S:25
Smooth Anti-Alias setting, 149, 150
Snap to Guides option, S:19–S:20
Soft Burn blending mode, S:66–S:67
Solid Shadow Live Filter, 155
special effects for text, 150–155
Spry data tables, 279–286

adding content to empty states, 285–286
steps for emulating, 279–285

stacking order of layers, 98
state delay settings, 232–233
states, 25, 34–36

adding content to empty, 285–286
changing content on, 34–35
customizing file names for, 193
duplicating and naming, 34
exporting, 193–194
Flex skins and, S:78–S:80
Live Filters added to, 36
review question/answer on, 37
rollover, 262, 265–273

States panel, 229, 268, 269, 280
Stow, Matt, 199
straight anchor points, 92
Strength option, anti-aliasing, 149

strokes
customizing, 97–98
Photoshop Live Effects, S:31–S:32
rendered text, S:71–S:74
true text, S:74

Strong Anti-Alias setting, 149
styling text, 132–135

custom styles for, 133–134
steps in process of, 132–133

sublayers
creating, 31–32
determining objects in, 273
importance/limitations of, 267

Subselection tool, 74, 93, 95, 99, S:9–S:10, S:106
Swap Image behavior, 186, 288–289
Swap Image dialog box, 289
symbols, 206–235

animation, 225–234
button, 217–224
component, 199, 208
explanation of, 208
file names for, 211
graphic, 208–217
instances of, 208
isolation mode for, 214
lesson overview, 206
nested, 228
prebuilt, 216–217
review questions/answers, 235
saving to Common Library, 210–211

T

table-based layouts, 188–189
templates, 4, S:4–S:11

creating metadata, S:29–S:30
opening, S:4–S:5
project assembly using, S:5–S:10
removing unwanted, S:11

Test Devices panel, S:41, S:42
text, 140–157

adding to designs, 88–89, 129–132
anti-aliasing, 149–150
attaching to paths, 150–152
button symbols and, 220, 222, 223–224
converting to paths, S:72
custom styles for, 133–134
editing, 145–146, 154
Fireworks versions and, 148
Flash support for, S:110
flowing within vector shapes, 146–148
formatting features, 142
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improving quality of, 169
lesson overview, 140
Live Filters added to, 155
mask effect using, 153–154
review questions/answers, 156–157
skewing on an angle, 152–153
special effects for, 150–155
stroking, S:71–S:74
styling, 132–135
temporary placement of, 32
text blocks created for, 143–144
tracking adjustments, 89
typography terms for, 148
wireframe, 244

text blocks
auto-resizing, 143
fixed-width, 143–144

text engine, 88
Text Overflow indicator, 148
Text tool, 10

adding text to designs with, 88–89, 129–132
Properties panel options for, 142
text blocks created with, 143–144

three-slice technique, S:95–S:99, S:111
Threshold property, 55
thumbnails

batch-processing, S:13–S:19
linking to full-sized images, S:19
rollover effects for, 265–279
sizing/resizing, 33, S:14

TIFF format, 162
Timeline panel, S:106
tonal range adjustments, 48–49
Tools panel, 10–11
tooltips, 7, 81
tracking, 89, 148
Transform options

Flip Horizontal, 121
Numeric Transform, 51

Transform tools, 80, 84
Trim Canvas command, 230
TweetDeck, S:44
typography terms, 148

See also text

U

Undo command, 19, 57
undoing steps, 19–20

History method of, 20
Undo command for, 19, 57

ungrouping
masked images, S:64–S:65
shapes, 148

Unsharp Mask filter
applying as Live Filter, 54–55
properties controlling, 55

upsampling images, 54
user interface. See interface

V

vector graphics, 78–105
anchor points, 92
Auto Shapes, 89–90
bitmap images vs., 86
compound shapes, 99–104
custom shapes, 94–95
deleting, 80–81
drawing, 7–8, 80, 94–95
editing, 93
explanation of, 80
Flash support for, S:110
flowing text within, 146–148
gradient fills, 95–97
guides for, 81–83
importing, 98–99
lesson overview, 78
modifying appearance of, 84–85
paths and, 91–93
patterns added to, 100
Pen tool and, 91
positioning, 82–83
resizing, 8, 83–84, 99
review questions/answers, 105
scaling, 87–88, 99
stroke styling, 97–98
text and, 88–89, 146–148

vector masks
changing attributes of, 123–124
creating, 121–123
editing, 124
overview of, 110–111
review questions/answers, 138
See also bitmap masks

Vector Path tool, 92
vector primitives, 11
Vector tools, 10
View tools, 10
viewing

guides, 81, 89
rulers, 7, 81
tooltips, 7, 81
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W

web banner project, S:4–S:11
banner assembly, S:5–S:10
document template, S:4–S:5
removing unwanted templates, S:11

Web browsers
animations previewed in, 233
CSS layouts viewed in, 202–203
designs previewed in, 184–185
rollovers previewed in, 276

Web layers, 25
AIR events and shared, S:51
slices and hotspots in, 174

web objects, 174
Web optimization, 158–205

browser preview of, 184–185
choosing settings for, 168–169
CSS-based layouts and, 195–203
exporting optimized files, 170, 188–203
graphics formats and, 160–161
hotspot creation and, 184
HTML and Images export and, 188–195
illustrations and, 176–179, 181–182
interactivity and, 186–187
JPEG images and, 174–175
lesson overview, 158
matte color and, 163
Optimize panel for, 161–163
overview of, 160
preference settings, 164
previews used for, 164–169
quality settings and, 166–169
review questions/answers, 204–205
saving settings for, 182
slices used for, 171–185
tools for, 171

web slices. See slices
Web toolset, 10, 171
Web-safe fonts, 203
Welcome screen, 4
Windows OS, Fireworks interface, 5
wireframes

adding pages to, 242–243
comment feature for, 248
comparing pages in, 241–242
delivering to clients, 246–249
exporting, 246–247
feature layer, 243–244
interactivity added to, 244–245
main image layer, 242, 243
master pages, 240–241

text layer, 244
See also prototypes

workflow, S:2–S:37
adding metadata, S:27–S:29
Adobe Bridge and, S:11–S:13
batch-processing images, S:13–S:19
changing rectangle corners, S:24–S:26
creating metadata templates, S:29–S:30
cropping individual bitmaps, S:21–S:22
customizing Photoshop export options, S:34–S:35
document templates and, S:4–S:11
exporting specific areas, S:22–S:24
Fireworks/Photoshop integration, S:30–S:36
future-proofing projects, S:27–S:36
importing images, S:19–S:20
lesson overview, S:2
Photoshop Live Effects, S:30–S:32, S:33
prototyping process, 238
review questions/answers, S:37
saving files for Photoshop, S:33–S:34
shortcuts for improving, S:22–S:26

Workspace Switcher, 14, 16
workspaces

Adobe Bridge, S:11
custom, 15–16
default, 5–6

X

x and y coordinates, 43
XMP metadata, 161, S:27

Z

Zoom Level menu, 42, 44
Zoom tool, 52, 172, 283


	CONTENTS
	GETTING STARTED
	About Classroom in a Book
	What's in this book
	Prerequisites
	Installing Adobe Fireworks
	Starting Adobe Fireworks
	Copying the Classroom in a Book files
	Additional resources
	Adobe certification

	4 WORKING WITH SELECTIONS
	Lesson overview
	Understanding bitmap selections
	Getting started
	Selecting and modifying with the Magic Wand tool
	Creating the selection
	Using the Magic Wand tool with keyboard modifiers
	Selecting with the lasso tools
	Converting a selection to a path

	INDEX
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	N
	O
	P
	Q
	R
	S
	T
	U
	V
	W
	X
	Z




