13

GOING FURTHER
Lesson overview
Throughout this book, you have learned how Fireworks can be an
essential part of your design workﬂow. Vectors, bitmaps, prototyping,
symbols, interactivity, animation…the list goes on. In this ﬁnal bonus
lesson, you will work with a few of the more complex capabilities of
Fireworks, giving you what we hope is a well-rounded perspective
on this unique program and how easily it interacts with other
Adobe programs.
In this lesson, you’ll learn how to do the following:

• Use blending modes to correct images
• Apply AIR event commands to slices and hotspots
• Create an AIR prototype for client review
• Customize a Flex skin for use in an AIR application
• Use Fireworks and Dreamweaver together
• Create graphics for ﬁxed and ﬂuid web-page containers
• Work with native Fireworks PNG ﬁles in Flash
This lesson will take about 90 minutes to complete. Copy the Lesson13
folder into the Lessons folder that you created on your hard drive for
these projects (or create it now), if you haven’t already done so. As you
work on this lesson, you won’t always preserve the start ﬁles. If you
need to restore the start ﬁles, copy them from the Adobe Fireworks CS4
Classroom in a Book CD.
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Throughout the book you have learned how Fireworks
can be an essential part of your design workflow. Vectors,
bitmaps, prototyping, symbols, interactivity, animation…
the list goes on. In this final bonus lesson you will work
with a few of the more complex capabilities of Fireworks,
giving you what we hope is a well rounded perspective
on this unique program.
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Interaction review
From a prototype perspective, this console mockup contains all the necessary
elements to give the client the appearance of a functional AIR application. The artwork you will be working with is complete, but you will be adding AIR interactivity
to the ﬁle. (See the “What is AIR?” sidebar later in the chapter.)
This console allows
users to browse various
campsites affiliated with
the fictitious Nature
Tours Company, and to
check rates and availability of sites.

Standard web interactivity has been used to create this simulation, even though the
end result will not be a website.

AIR functionality in Fireworks
An AIR prototype is akin to an HTML And Images export for a website. You will get
the look and feel and the interactivity of the application, but there is no live data
connection to other content—it’s not a fully functional AIR application. Likewise,
features such as scrolling in a text window are not possible. However, rollovers,
hyperlinks, and dragging are all possible.
Fireworks gives the client an opportunity to “test-drive” the design and functionality
of an AIR application before any time is spent on the coding side.
Most of the techniques used in creating an HTML mockup can be applied to creating an AIR prototype.
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1 Open the ﬁle nature_tours_console.png from
the Lesson13 folder. If you are prompted about
missing fonts, you can simply click Maintain
Appearance.

 Note: The
decorative font used
in this design is called
JI Chaffs. In order to
minimize rendering
issues, this font has
been converted to
paths. The only other
font used in this file is
Arial and that has been
left as a true font, rather
than being converted
to paths.

2 Expand the Pages panel so you can see the entire
list of pages in the document (a total of ten).
3 Select the sites page.
4 Click Show Slices And Hotspots in the Tools
panel.
Our little squirrel mascot displays the current
location. There are buttons to close the application
and to return to the main console display.

 Note: While the

Note the hotspots over the site names and the
slices over the tree icons and the console screen.

company may be
fictitious, the photos
are the work of the
completely real Jim
Babbage, of an equally
real location called
Obatanga Provincial
Park in northern
Ontario, Canada.

5 Switch to the Preview view at the top of the document window.
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6 Click Hide Slices And Hotspots in the Tools panel.
 Note: In order for
the interaction to work,
you must select the
Pointer tool in the Tools
panel.

7 Roll over the Site B link in the right column. Eﬀects have been added so that
the screen updates with a diﬀerent photo on mouseover, and the small tree icon
also changes in appearance. The hotspots also link to other pages in the design.

8 Select the Site A page in the Pages panel.
Our squirrel acts as a way-ﬁnding device, displaying the current location.
The only rollover eﬀects on this page are for the navigation.
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9 Switch to the maps page in the Pages panel.

10 Mouse over the diﬀerent map links. The appropriate map thumbnail will
highlight in response to your rollover.
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11 Select the map_A page from the Pages panel. Only one ﬁnal site map has been
completed, but this is enough to show the client how that aspect of the console
will function.

While Fireworks cannot create a user-scrollable area, it can simulate zooming in
and out of an area.
12 Click the plus sign (+) on the map zoom bar. A new state appears, with a
magniﬁed view of the map.
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13 Click the minus sign (-). A reduced view of the site appears.

14 Click the green dot to return to the original map-A page.

15 Switch back to the Original view in the document window.
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Creative and corrective techniques
You will use a couple of diﬀerent techniques to alter the look of both bitmap images
and vectors: image correction and stroking text. The majority of the work has been
completed on this ﬁle, but there are still chances for you to practice the techniques.

Blending modes for image correction
There are many ways to improve the look of bitmap images. Sometimes, though,
as here, a quick ﬁx is all you need.
1 Switch to the Site C page.
The photo in the console screen lacks color and contrast, due to the sun shining
on the lens. You will use Blending modes and Live ﬁlters to improve the image.
2 In the Layers panel, expand the screen layer. You see a masked photo.

3 Select the photo thumbnail in the screen layer. On the canvas, you will see
the telltale blue control handle on the image, indicating this photo has been
masked. The blue outline indicates the true size of the photo.
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4 Choose Modify > Ungroup. This breaks the mask apart into its two
original objects.

5 Hide the rounded rectangle by clicking the Show/Hide icon (
Layers panel.

) in the
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6 Drag the photo to the New Bitmap Image button at the bottom of the
Layers panel.

A duplicate of the photo appears in the screen layer.

7 Making sure the topmost of these two images is selected, change the blending
mode from Normal to Soft Burn in the Layers panel.
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The image darkens noticeably, but not so much that a lot of detail is lost.

Before Soft Burn

After Soft Burn

8 Click the Add Live Filters (+) button in the Filters section of the Property
inspector, and choose Adjust Color > Hue/Saturation.

9 Set the Saturation to a value of 30, and click OK.
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The new image appears much more lush and green. And because the manipulation
was all done using Live Filters and Blending modes, the eﬀects are completely
editable in the future.

Original image

Image with Soft Burn blending mode
and Hue/Saturation Live Filter applied

In your case, though, you also need to mask the image combination, which
means you’ve got a decision to make. You can’t apply a single mask to a stack
of objects in the Layers panel. Grouping the two images together would let you
mask the group but removes the blending mode. Flattening the two images
together (to maintain the appearance of the eﬀects) would rasterize them,
turning them into one image, so they will no longer be editable. In order to get
the best of both worlds, the optimal solution is to convert the two images to a
symbol and practice a little layer trickery.
10 Select both image objects in the Layers panel.

11 Choose Modify > Symbol > Convert To Symbol.
12 Rename symbol to Site C photo.
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13 Select Graphic as the symbol type, leave all other options deselected, and
click OK.

The two images are replaced by an instance of the Site C photo symbol. You
may notice though, the blend mode has disappeared. At this time, blend modes
are not supported when they are applied within a symbol. Here’s how you can
work around this.
14 Double-click on the instance on the canvas. You will be taken to Edit in
Place mode.
15 Drag Layer 1 to the New/Duplicate layer icon at the bottom of the Layers panel.
16 Lock and hide the new layer.
17 Select Layer 1 and choose Modify > Flatten Selection. This combines all the
eﬀects into a single ﬂattened image.
18 Click on Site C in the breadcrumb trail to be brought back to the Site C page.
Anytime you wish to edit the blend mode or the Hue/Saturation Live Filter,
just double-click on the symbol, reveal and unlock the preserved layer, make
your edit and then, as before, create a duplicate layer with the new alterations.
Remember to delete the old ﬂattened layer (or just lock and hide it, in case you
want to compare diﬀerent adjustments).
Note: You could do this without converting to a symbol, but having multiple
objects in a symbol also opens up other non-destructive editing features, such
as applying diﬀerent Live Filters to each object and then adjusting the top
object’s opacity to create diﬀerent visual eﬀects.
19 Reveal the rounded rectangle path in the Layers panel by clicking the empty
square to the far left of the object name. This will also select the object.
20 Choose Edit > Cut.
21 Choose the instance of the symbol you named Site C photo, and then choose
Edit > Paste As Mask.
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The rectangle masks the instance and all your (still editable) eﬀects are retained.

You can edit those eﬀects any time by ﬁrst selecting the photo on the canvas
with the Pointer tool, and then choosing Modify > Symbol > Edit In Place.
22 Save your ﬁle.

Stroking rendered text
At the beginning of the chapter, we mentioned that all the decorative text was
converted to paths to minimize any rendering issues. Actually, this technique can
be used on paths or text.
The text in this example is a little rustic, and is in keeping with the color theme of
the site—but without a stroke, it blends into the background elements too easily.
While all the other text is ﬁne, the Site C text on the squirrel’s sign has not yet been
changed. You will do this now.
1 Use the Pointer tool to select the Site C rendered text.
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2 In the Property inspector, change the Stroke color to #F3E8C9.

How do you convert text
to a path, anyway?
Select the text block with the Pointer tool, and then choose Text > Convert To Paths
from the main menu bar. The text will be converted to a group set of paths. You can
select individual letters with the Subselection tool.

3 Set the Stroke Category to Pencil > 1-Pixel Soft.
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You may ﬁnd that the stroke does not match the other text elements on
the console.

This mismatch is due to the default stroke position of Stroke Centered.
If this has happened to your object, here is how to ﬁx it.
4 Zoom in to 500%.
5 Select the Subselection tool.
6 Hold down the Shift key, and click on each letter (remember, the letters are no
long a true font, but rendered paths).

7 Click on the Stroke Category menu, and choose Stroke Options.
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8 Change Stroke location to Stroke Outside.

9 Click away from the Stroke Options panel to close it.
Your Site C text should now match the text on the console.

10 Save your work.
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Stroking real text
The workflow for adding strokes to true text is a little different.

1 Select the Text block.
2 Choose the Stroke (or Text Outline) color box.
3 Choose Stroke Options.

4 Select the type of stroke you want (in our example, it was Pencil >
1-Pixel Soft).

5 Press Enter or Return.
If your stroke color changed during the selection process, just click on the Stroke
color box again, and choose your color (in our example, this value was #F3E8C9).
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Working with Adobe AIR
Fireworks supports four AIR mouse events: Close, Drag, Minimize, and Maximize.
Just like rollovers or hyperlinks, AIR events must be attached to a web object (a
slice or a hotspot). If the area being used as an AIR event doesn’t require a rollover,
you can use a hotspot. If you do need a rollover eﬀect (as is the case with our Close
button), you’ve got to use a slice to enable image swapping. You will add hotspots
and mouse events to various parts of the console so users can drag the prototype
around on their desktop. You will also add a mouse event to the Close button.

What is AIR?
AIR (Adobe Integrated Runtime) is a cross-platform runtime environment for building rich Internet applications using Adobe Flash, Adobe Flex, HTML, or Ajax. Unlike
traditional web applications, the AIR application runs on your desktop without
a web browser, often as a floating panel. Some examples of AIR applications are
Adobe's Kuler panel (www.adobe.com/products/kuler/faq/) and Twhirl (www.twhirl.
org) by Seesmic, for Twitter.
To learn more about AIR, visit the AIR product section (www.adobe.com/products/
air) on Adobe’s website.

Adding AIR events
You will now add an AIR mouse event to the Close button.
1 Choose the home page from the Pages panel.
2 Click Show Slices And Hotspots in the Tools panel if the slices and hotspots are
not visible.
3 Select the slice that covers the Close button (the pictogram of the hikers).

4 Choose Commands > AIR Mouse Events > Close.
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Nothing changes in the slice, but if you look down to the Property inspector,
you will see that some JavaScript has been added, along with some alt text.

This AIR event has already been added to the other pages, using a shared web layer.
5 Switch to the sites page, and select the slice over the Close button. The Property
inspector displays the same JavaScript code and alt text.
6 Expand the Web Layer in the Layers panel.
7 Expand the common web sublayer. It stores the slices for both the close and home
slices.

8 The common sublayer was not shared to the home page because there was no
need to have a home link on that page.

S-50

LESSON 13

Going Further

9 Select the main Web Layer in the Layers panel again.
10 Choose New Sub Layer from the Layers panel menu.

11 Name this new web layer drag events. Note that even web sublayers are shared
across states.
12 Right-click (Windows) or Control-click (Mac) on the squirrel illustration, and
choose Insert Hotspot.
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13 Use the Pointer tool to resize the hotspot, so it doesn’t overlap the Close button.

14 Check the Layers panel. The new hotspot may not be nested in the drag events
sublayer. If it’s not, move it there now by cutting and pasting the hotspot or by
dragging the layer to the correct position in the Layers panel, as shown here.

Not inside the drag layer
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Inside the drag layer

15 Make sure the new hotspot is selected. This will force additional hotspots
to be created above the current one, but they will still be nested in the drag
events sublayer.
16 On the canvas, draw a rectangular hotspot around the Camp Sites sign.

17 Draw one more hotspot, covering the entire console from the left corner to just
before the tree rollover slices.

18 Select all three hotspots, and then choose Commands > AIR Mouse Events > Drag.
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19 Right-click (or Control-click) on the drag events sublayer, and choose Share
Layer To All Pages, as we want this shared with every page in our mockup.
20 Save the ﬁle.

AIR mouse events
You can attach specific mouse events to hotspots or slices in your AIR mockup.
Select the web element (slice or hotspot), and then choose Commands > AIR Mouse
Events. You can choose from four options:

•
•
•
•

Close. Closes the application.
Drag. Applied to a web object, this option lets the user drag the application
around the desktop.
Maximize. Maximizes the application.
Minimize. Minimizes the application.

Creating an AIR prototype
Yes, you are ﬁnally at the point where you create the prototype! Much like an
HTML prototype, this gives you and the client a chance to interact with a simulation of the AIR application before any time is spent coding the real thing.
First you should save this ﬁle to its own directory. This makes the rest of the process a little easier.
1 Choose File > Save As.
2 Create a new folder inside the Lesson13 folder, and call it naturetoursconsole.
3 Open this folder, if necessary, and save the PNG.
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4 Copy the Lesson13/icons folder to the naturetoursconsole folder.
5 Choose Commands > Create AIR Package.

The Create AIR Package dialog box appears, and it’s a big one.
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Complete the Create AIR Package dialog box as follows:

• Application Name. Specify the name that appears on installation screens
when users install the application. By default, the ﬁlename is used, but you
can change this.

• Application ID (required). Enter a unique ID for your application. Don’t use
spaces or special characters in the ID. By default, the ﬁlename is used.

• Version (required). Specify a version number for your application. The default
value is 1.

• Program Menu Folder (Aﬀects Windows only). Specify the folder in the
Windows Start Menu where you want the shortcut to the application created.

• Description. A description of the application to be displayed when the user
installs the application. The description we used is: Nature Tours presents an
interactive console where you can view our preferred campsites, check out
rates, and even inquire about site availability.

Transparent chrome in
AIR prototypes
One of the unique characteristics of an AIR application is that it can “float” on your
desktop. So you could have a custom shape to the application interface—much like
we have in our nature tours console—and you will see only the application, not the
background of the original PNG file, surrounding the design.
To use this look, make sure your canvas color is set to transparent and that you use
PNG 32 as your Optimization setting. This file has already been set to PNG 32.

• Copyright (Aﬀects Mac only). Include copyright information to be displayed
in the About information for Adobe AIR applications installed on OS X.

• Package Content. Select Current Document to automatically select the folder

 Note: Fireworks
generates all the
graphics needed for the
prototype at this stage,
so it’s not unusual for
Fireworks to become
nonresponsive for a
couple of minutes as
it runs through all the
pages in the design.

from which the ﬁles are to be included. The resulting list will be simpler if your
PNG ﬁle is in its own folder rather than, for example, your desktop or main
documents folder. This is why you saved the PNG ﬁle to its own folder earlier.

• Root Content. Browse to select the page that appears as the root content
(starting screen of the prototype). If you selected Current Document, the root
content is automatically set.

• Included Files. Specify the ﬁles or folders to include in your application. You
can add additional HTML and CSS ﬁles, image ﬁles, and JavaScript library ﬁles.
Click the plus button (+) to add ﬁles, and click Folder to add folders. To delete a
ﬁle or folder from your list, select the ﬁle or folder, and click the minus button (-).
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The ﬁles or folders you include in the Adobe AIR package must be in the root
content folder. Scroll through this list and locate the original PNG ﬁle. Select it,
and then click the minus sign (-). The PNG ﬁle is not necessary for the AIR app,
and this will reduce the ﬁle size of the AIR ﬁle.

• System Chrome and Transparent. System Chrome surrounds the prototype
with the standard window control of the operating system. Transparent lets you
use your own custom chrome instead. Choose Transparent.

• Width and Height. Specify the dimensions of your application window in pixels
when it opens. Depending on your page sizes, outer glows, and drop shadows,
you may need to increase the dimensions slightly to prevent scroll bars from
appearing. Set the dimensions to 545 and 345, respectively.

• Select Icon Images. You can select custom images for the application icons.
Select the folder for each icon size, and select the image ﬁle you want to use.
Only PNG ﬁles are supported for application icon images.
Click the button and for each of the four icons, browse to the icon folder you
copied over to the naturetoursconsole folder. Match the 16x16 pixel icon with
the small.png ﬁle, the 32x32 pixel icon with the medium.png ﬁle, and so on.
These icon ﬁles must be in the root directory in order to be selected.
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• Digital Signature (required). All Adobe AIR applications require a digital
signature in order to be installed.
To add a digital signature, click the Set button next to the Digital Signature ﬁeld,
and do one of the following:

• To sign an application with a digital certiﬁcate that you have already
purchased, click the Browse button, select the certiﬁcate, enter the
corresponding password, and click OK.

The Key Type
option refers to
the level of security
of the certificate:
1024-RSA uses a
1024-bit key (less
secure) and 2048RSA uses a 2048-bit
key (more secure).

• To create your own self-signed digital certiﬁcate, click the Create button.
You must ﬁll in every ﬁeld in order for the Create button to become active.
You can use the settings in the ﬁgure below as a guide.
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When you’re ﬁnished, click Create. Then enter the corresponding password in
the Password ﬁeld of the Digital Signature dialog box, and click OK.

• Package File (required). Specify the folder to save the new application installer
(.air ﬁle). The default location is the site root. Click the Browse button to select
a diﬀerent location.
Create a new folder called AIR in the naturetoursconsole folder, and select the
new AIR folder as the location to place the installer package.

The only ﬁle required by the user will be the AIR installation ﬁle. All the
necessary ﬁles are added to the AIR installer by Fireworks.
6 Before you click the create button, test out the prototype by clicking Preview.
Fireworks builds a temporary version of the prototype and launches it. You
can test interaction and check for unsightly scroll bars at this time. Click the
prototype’s Close button (the hiker pictogram) to exit the application.
7 Click Create Package.
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Installing the prototype
You will test the installation of the AIR prototype now. In order to do this, you may
have to have administrator rights on your computer, because this is like installing a
real software application.
1 Browse to the AIR folder, and double-click on the nature_tours_console.air ﬁle
to launch the installer.
An AIR Application Install window will open.

You may be prompted whether or not you wish to install this program, as it is
created by an unknown publisher.

2 We’ll assume you trust yourself. Click Install.
The window contents will change, displaying the description you wrote earlier
and giving you options for adding a shortcut icon to the desktop, whether to
start the application after installation, and where to install the application.
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3 Change the installation location to the Lesson13 folder, so it is easy for you to
ﬁnd and remove the application afterward.

The application will take a
minute or two to install.
Once installed, the application
will start. If you accepted the
defaults, you will also see a
shortcut icon on the desktop.
The smallest icon will also
display in the application bar.

4 You can experiment with the prototype or just close it by clicking the
Close button.
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Flex skinning
Before you say goodbye to the nature tours console ﬁle, you will look at how to convert the graphics into a form that a Flex application developer can use. Fireworks
has a default Flex skin from which you can modify either a single component or
multiple ones.

Creating a Flex skin
In this exercise, you’ll learn to skin a button, using the Close button as an example.
Make sure your nature_tours_console ﬁle has been saved, and keep it open within
Fireworks.
1 Choose Commands > Flex Skinning > New Flex Skin.

2 In the New Flex Skin
dialog box, choose
Speciﬁc Components.
3 Select Button from the
list of components.
4 For Apply Skin To, choose
Instances With Style
Name, and type close
in the input ﬁeld. (There
are other buttons in this
prototype, so it’s a good
idea to use style names
so the right skin is applied
to the right button.)
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 Note: In a reallife scenario, we
recommend you
talk with your Flex
developer first, to make
sure you are both using
the same style-naming
conventions.

5 Click OK.
A standard Flex button template opens within Fireworks.
 Note: The Layers
panel is populated
with a series of prebuilt
layers. When skinning
a Flex component, it
is very important that
you do not delete or
rename any of the
layers in the file.

6 Switch back to the home page of the console design, and click Hide Slices And
Hotspots in the Tools panel if the web objects are showing.
7 Select the Close button.
8 Choose Edit > Copy.
9 Switch back to the skin template, and expand the Button_close_upSkin layer.

10 Select the group in that layer, and delete it.
11 Choose Edit > Paste to paste the Up state of the Close button in the layer.
12 Reposition the button where you see ﬁt.
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13 Return to the console design, and select State 2 from the bottom of the
Layers panel.

14 Select the Over iteration of the Close button, and copy it.
15 Switch back to the Flex template.
16 Expand the Button_close_overSkin layer, and delete the group of objects
making up the existing button.

17 Paste the copied Over console button.
18 Reposition as necessary. Don’t worry about lining up the buttons with the
labels; those labels are simply there to tell you what button is for which state.
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Adding additional button states
Our current button in Fireworks contains only two states, but you will quickly add
the two ﬁnal states to the template.
1 Expand the Button_close_downSkin layer, and delete the original button’s group.
2 Paste in the Over iteration of the console button.

3 In the Property inspector, click the i icon next
to the Photoshop Live Eﬀects ﬁlter.
4 Change the direction of the bevel from Down
to Up, and click OK.

5 Delete the button from the Button_close_disabled layer, and paste in the Up
state of your button again. You can copy the Up state from the Flex skinning
template you’re working on instead of going back to the console.
6 Change the Fill color to #71400F.
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7 Reduce the plaster texture to 20%.
8 Turn oﬀ the Photoshop Live Eﬀect by clicking on the checkmark beside the
ﬁlter name. We have highlighted the three areas to change in the ﬁgure below.

9 Your new button template should look something like this image. Again,
placement of the button states on the canvas doesn’t matter, as long as they’re
in the correct layers.

Exporting the skin
The last step is to export the button template.
1 Choose Commands > Flex Skinning > Export Flex Skin.
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2 Browse to the Lesson13 folder, and create a new folder called skins.
3 Open this folder, if necessary, and click the Select “skins” (Windows) or Choose
(Mac) button.

Fireworks exports out just the four states of the button to this folder.

Flex skinning resources
In-depth discussion about Flex or skinning entire applications is beyond the scope
of this book, but we won’t leave you hanging! Here are a few resources that you can
continue on with, if you are interested in learning more about Flex skinning.

•

Adobe Developer Center (www.adobe.com/devnet/flex/)

•

Layers Magazine (www.layersmagazine.com/fireworks-cs4-flex-skinning.html)

•

ScaleNine (www.scalenine.com/)
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Fireworks and Dreamweaver
It’s no surprise that products within Adobe Creative Suite are meant to play well
together—they are a suite, after all. In this section, you’ll learn some techniques for
making the most of the integration between Fireworks and Dreamweaver.

Copying and pasting to Dreamweaver
When working on a website design in Dreamweaver, you can quickly add objects
from a Fireworks design directly into Dreamweaver.
1 Start Dreamweaver.
2 Open the check_mag_home.html ﬁle from the webpage folder of the Lesson13
folder.
 Note: This exercise
requires the use of
Dreamweaver. If you do
not own Dreamweaver,
feel free to either
skip this section, or
download the 30-day,
fully functional trial
version of Dreamweaver
from Adobe at www.
adobe.com/downloads.
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Another watch image has been sent as a seasonal replacement for the existing
watch promo image. The client has requested the blue background be removed
and replaced with a gradient background.

This work has already been done in the ﬁle called watch.png, using a bitmap
mask and a gradient ﬁlled rectangle.

The image is currently not the right dimensions for the watch promo section of
the banner. You will create the correct image size without aﬀecting the original
ﬁle in any way.
3 In Fireworks, open the watch.png ﬁle in the Lesson13 folder.
4 In the Layers panel, hold down the Shift key and select both the watch and the
background.
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5 Choose Edit > Copy.
6 Switch to Dreamweaver.
7 Select the original watch image, and delete it.
8 Choose Edit > Paste.
The Image Preview window opens. This is the same Image Preview window you
can access from Fireworks, but in this case, it’s initiated by Dreamweaver.
9 In the Options pane, set the ﬁle format to JPEG – Better Quality.

10 Switch to the File tab, and then select the Export Area option.
11 Type 237 in the width ﬁeld and 90 in the height ﬁeld. These are the dimensions
of the original watch image.
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12 Type 4 in the x ﬁeld and 44 in the y ﬁeld, and click OK.

The Save Web Image dialog box appears.
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13 Browse to the images folder within the webpage folder of the Lesson13 folder.
14 Rename the ﬁle to watch_promo2.jpg, and click Save.
The Image Description (Alt Text) dialog box appears.
15 Type Win the Watch! in the Alt Text ﬁeld, and click OK.

The new, cropped image appears on the page, where the old image used to be.
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16 Return to Fireworks; you will see the original PNG ﬁle remains unchanged.
17 Close the watch.png ﬁle without saving.

Roundtrip editing
Another request has come in—this one for a change to the navigation bar. The client would prefer the navigation text to be closer to the right and with more spacing
between each link. You will make this change using roundtrip editing.
1 Select the navigation bar image within Dreamweaver.

2 In the Property inspector, click the Edit icon.

The Find Source dialog box appears, asking whether you want to edit this
individual image or locate the Fireworks PNG ﬁle.

3 Click the Use A PNG button.
 Note: Editing the PNG file works properly only if the page was originally exported as HTML And
Images. If the file was exported as CSS And Images, roundtrip editing will have a negative effect on
the HTML page.
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The Open dialog box appears.

4 Locate and open the check_mag_home.png ﬁle in the Lesson13 folder.
The ﬁle opens with two diﬀerences. The watch image slice is now a bright green
HTML slice. The reason for this is the image was changed within Dreamweaver,
and the new watch image is not part of the original PNG ﬁle. In order to
maintain the new image, an HTML slice is applied rather than the original
image slice.
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You will also see a Done button and the status message, Editing From
Dreamweaver, near the top of the document window.

5 Click Hide Slices And Hotspots in the Tools panel.
6 Select the ﬁve text links using the Pointer tool.

7 In the Property inspector, change the X value to 456.
8 Open the Align panel, and change the Spacing value
to 30.
9 Click the Space Evenly Horizontally icon to spread the
text links apart.
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10 Reveal the hotspots and reposition the navigation hotspots so they cover the
links again.
11 Click the Done button.
You are returned to Dreamweaver, and the navigation bar has been updated to
reﬂect the changes in the PNG. The PNG ﬁle is saved automatically.

Three-slice technique for content containers
A very common visual technique for containing web content is to put the content
inside some sort of container, often called a pod, which can expand vertically or
horizontally to contain additional content. The three-slice technique creates a pod
that expands in one dimension while the other dimension remains ﬁxed.
In this exercise—we’re back in Fireworks now—you will create the slices for vertically ﬂexible pods for the Bare Tree Society website.
1 Open the bare_tree.png ﬁle from the Lesson13 folder.

Content pods

Conveniently, both pods are the same width, so you need only slice up one pod
and use the same exported graphics for both pods in the ﬁnal web design.
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In order to create slices that will export only the pod areas and not the text, you
will have to hide the text in one pod.
The content layer holds all the elements for the content area of the design: two
text blocks and two rounded rectangles.

2 Select the text in the left pod with the Pointer tool.
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3 Locate the selected object in the Layers panel, and hide the object by clicking its
Show/Hide box ( ).

4 On the canvas, right-click (or Control-click) on the rounded rectangle, and
choose Insert Rectangular Slice.
This slice will cover the entire rectangle, including the outer glow. When you
have shapes that use glows or drop shadows, letting Fireworks create the initial
slice can be more accurate.
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5 In the Property inspector, change the height of the slice to 20 pixels.

 Tip: If you hold
Shift while pressing the
arrows, your slice will
move ten pixels at a
time instead of just one
pixel.
6 Choose Edit > Clone to create an exact copy of the slice.
7 Use the Down Arrow key to reposition this new slice below the original slice.

8 Change the height to 10 pixels in the Property inspector. This will become
the repeating background image for the pod. Its exact Y position is not too
important, as long as it doesn’t overlap the other slices.
9 Select the top slice and clone it again.
10 Use the arrow keys to reposition the new slice at the bottom of the pod.
The Y value for the new slice position will be 338.

11 Select all three slices, and change the Slice Export Settings option to JPEG –
Better Quality from within the Property inspector.
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12 Name the slices appropriately in the Layers panel: pod_top, pod_bg, and
pod_bottom.

Once the graphics have been exported, the design can be assembled in
Dreamweaver using a combination of HTML and CSS. There are several diﬀerent
ways to achieve this result. In this ﬁgure, you see how adding additional content
to a container within Dreamweaver expands the left container, leaving the right
container unaﬀected.
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Fireworks and Flash
Fireworks and Flash work together in a couple diﬀerent ways. Fireworks PNG ﬁles
can be imported into Flash as movie clips, maintaining the layer structure of the
PNG ﬁle. Flattened bitmaps can be altered using roundtrip editing—similar to
roundtrip editing between Dreamweaver and Fireworks.
You will use the movie_scene.png ﬁle as a backdrop for a Flash interface promoting
the Double Identity movie. It consists of a background image, two text blocks, and
a vector path ﬁlled with a gradient.

Preparing files for Flash
Before you jump in to this process, it’s best to know what to expect from the process of importing and editing between these two programs.
Transformations such as skewing text are not carried over into Flash. Likewise, custom letter tracking is ignored by Flash. You can convert the type to paths to retain
text transformations and tracking, but it will no longer be editable as text with
Fireworks or Flash.
Additionally, certain Live Eﬀects and blending modes are not supported in Flash.
Table 13.1 and Table 13.2 list the supported features.

ADOBE FIREWORKS CS4 CLASSROOM IN A BOOK

S-81

Table 13.1 Fireworks effects supported in Flash
FIREWORKS EFFECT NAME

F L A S H F I LT E R N A M E

Drop shadow

Drop shadow

Inner shadow

Drop shadow (with Inner Shadow automatically selected)

Blur

Blur (where blurX = blurY= 1)

Blur more

Blur (where blurX = blurY= 1)

Gaussian blur

Blur

Adjust color

Adjust color brightness

Adjust color

Adjust color contrast

Table 13.2 Fireworks blending modes supported in Flash

S-82

LESSON 13

FIREWORKS BLENDING MODE NAME

FLASH BLENDING MODE NAME

Normal

Normal

Darken

Darken

Multiply

Multiply

Lighten

Lighten

Screen

Screen

Overlay

Overlay

Hard light

Hard light

Additive

Add

Difference

Difference

Invert

Invert

Alpha

Alpha

Erase

Erase

Going Further

Importing Fireworks documents into Flash
It’s important to understand the diﬀerences between importing a Fireworks
PNG ﬁle and importing a ﬂattened bitmap. You will test both methods in this
ﬁnal exercise.

What are my import options?
Fireworks PNG. Import the Fireworks PNG as a multilayered ﬁle if you will
need to animate or add ActionScript to individual objects within the PNG design.
There is no automatic connection between the imported ﬁle and the original
Fireworks PNG ﬁle; if elements within the design require additional editing, you
will have to open the source PNG ﬁle within Fireworks, make your changes, save
the ﬁle, and then update the speciﬁc object within Flash. The real advantage of this
method is that you can bring into Flash a fully layered ﬁle, so that your various
bitmaps are available as separate objects and your vector elements are editable
within the Flash environment. You can also import a speciﬁc page from a multipage
Fireworks document.
Flattened bitmap. Flattening is the process of converting multilayered image ﬁle
into a single graphic with no individual editable layers or objects. A ﬂattened ﬁle is
imported into the Flash library using the original ﬁlename as its label.
Flattened bitmaps can make use of roundtrip editing by right-clicking (or Controlclicking) the desired object in the Library panel or on the stage.

Importing a Fireworks PNG
The text in this design has been skewed to a speciﬁc angle and has custom tracking
applied to diﬀerent letter pairs in the text block. Flash will discard the tracking and
skewing on import, so you will convert the text elements to paths to retain its look.
1 In Fireworks, open movie_scene.png from the Lesson13 folder.
2 Select both text blocks using the Pointer tool.
3 Choose Text > Convert To Paths.
 Note: This exercise
requires the use of
Flash. If you do not own
Flash, you can either
skip this section, or
download the 30-day,
fully functional trial
version of Flash from
Adobe at www.adobe.
com/downloads.
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4 Save the ﬁle as movie_scene_working.
5 Start Flash CS4.
6 Choose Flash File (ActionsScript 3.0) from the Create New column of the
Welcome screen.

7 Choose Modify > Document.
8 Change the dimensions of the ﬁle to 600 pixels wide by 462 pixels high (same
dimensions as our Fireworks design). Leave all other settings at their defaults
and click OK.
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9 Choose File > Import > Import To Library.

10 Browse to the Lesson13 folder, and open the movie_scene_working.png ﬁle.

11 When the Import dialog box appears, use the settings seen in the ﬁgure below
to keep objects as editable as possible, and click OK.
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The PNG ﬁle is placed in the Library panel.

Flash has created a special folder to store the objects from the Fireworks PNG
ﬁle. The alleyway photo is saved as a separate bitmap, and the vector objects
are grouped within the movie clip. Flash also generates a graphic symbol
automatically when you import assets directly to the Library.
The layer structure of the PNG ﬁle has also been maintained within the
movie clip.
12 Double-click on the Page 1 movie clip in the Library panel.
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13 Open the Timeline panel (Window > Timeline); you will see all four objects in
their own layers in the timeline.

Each vector object within the timeline is editable within Flash.
14 Use the Selection tool (
the stage.

) to double-click on the red custom vector shape on

Double-clicking on an object on the stage activates Edit In Place, moving you
deeper into the movie clip, as can be seen from the breadcrumb trail above the
document window.

15 With the Subselection tool (
), move your cursor near the border of the
shape, and click. Vector control handles appear, and, just as in Fireworks, you
can drag those control points to alter the shape of the path.
16 Drag a control point.
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17 Press Ctrl+Z (Windows) or Command+Z (Mac) to undo the edit.
18 Click the Scene 1 segment of the breadcrumb trail to go back to the main
movie clip.

Importing a flattened bitmap
Bitmap objects cannot be edited within Flash, but this is where Fireworks comes
in very handy. Standard bitmap objects are easily imported into Flash.
1 Choose File > Import > Import To Library.
2 Browse to the Lesson13 folder and select thumb5.jpg.
Because this is a ﬂattened image, no dialog box appears. The image is just
directly imported into the Library.

Flattened objects like this image can beneﬁt
from the other Flash/Fireworks integration
feature, roundtrip editing.
3 Right-click (or Control-click) on the image
name in the Library panel.
4 Choose Edit With Fireworks. If it doesn’t say
Edit With Fireworks, then choose Edit With,
navigate to where Fireworks is located, and
open it that way. From then on, it will say Edit
With Fireworks, as expected, here.
Much like roundtrip editing with Dreamweaver,
the Find Source dialog box will appear and
you will be asked if you want to edit this image
directly or locate a PNG ﬁle to make the edits.
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5 There is no PNG ﬁle for this image, so click the Use This File button.

The image opens in Fireworks, and above the document window you see a
Done button and the phrase Editing From Flash.

6 In the Property inspector, click the Add Live Filters button (+) button to add a
Live Filter. Choose Shadow And Glow > Inner Shadow.

7 Click the Done button.
Fireworks prompts you to save a PNG version of the image, because you have
added a Live Filter. As this change will be a permanent one to the JPEG ﬁle,
it would be wise to create a PNG image that can be edited later.
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8 Click Yes, and save the thumb5.png ﬁle to the Lesson13 folder. This way, you
can always further edit the Live Filter at a later time.
You are returned to Flash, where the thumb5.jpg image has been updated with
the inner shadow.

From this point forward, if you need to make further edits to this image, choose
Use A PNG from the Find Source dialog box. In this manner, you are not
constantly editing and resaving a JPEG ﬁle, thus reducing its quality each time.
9 Close the Flash ﬁle without saving it.

Additional considerations
when importing to Flash
•

HTML: Pop-up menu code is not supported by Flash. Likewise, interactivity and

•

Vectors and Text: Flash does not support all the special effects, fills, and strokes

button behaviors are not imported to Flash.
available in Fireworks. When you import a Fireworks PNG file and choose to keep
the file as editable as possible, these features may look different. Flash supports
only solid fills, gradient fills (except the contour gradient), and basic strokes.

•

Bitmaps: When Fireworks graphics are imported or copied and pasted into
Flash, some attributes are lost, such as Live Filters and textures.

•

Graphic Symbols with 9-slice scaling are supported in Flash, but 9-slice
scaling is not maintained for animation symbols.
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Review questions
1 What is the three-slice technique?
2 How do you add AIR events?
3 How do you export an AIR prototype?
4 What are the steps to choosing a Flex component for skinning?
5 How do you import a multilayered Fireworks PNG ﬁle into Flash?

Review answers
1 The three-slice technique creates graphics for an expandable panel or box on a web
page. In Fireworks, you draw your container, and then add a slice to the top and the
bottom, and a third slice to be used as a repeating background image for the main
content area of the container. You can then assemble the panel within a series of divs
within Dreamweaver, or use the Fireworks CSS And Images option to export a page
containing the ﬂexible container.
2 To add an AIR event, you draw a slice or hotspot to cover an interactive element in
the AIR mockup, choose Commands > AIR Mouse Events, and then pick the desired
event. You can choose from Drag, Close, Minimize, and Maximize.
3 To create an AIR prototype, once all your interactivity is in place, choose Commands >
Create AIR Package. Fill in all of the required portions of the Create AIR Package dialog
box, browse for or create a digital signature, preview the application, and then choose
Create to have Fireworks build the actual package.
4 Choose Commands > Flex Skinning > New Flex Skin. Select the Speciﬁc Components
option, and then choose the component you wish to skin from the component list. You
can also choose whether to apply this skin to all instances of that component, or apply
it only to skins with a speciﬁc class.
5 To import a multilayered Fireworks PNG into Flash, ﬁrst you open an existing Flash
document or create a new one. Choose File > Import > Import To Library. Browse for
the ﬁle. You can then choose whether to import the ﬁle as a ﬂattened bitmap or as a
multilayered, editable ﬁle. You gain more ﬂexibility within Flash if you do not ﬂatten
the ﬁle.
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