ONLINE ADDENDUM:

iDVD

Part of
iMovie ’09 & iDVD for Mac OS X:
Visual QuickStart Guide

Jeff Carlson
http://jeffcarlson.com/imovievqs/

Peachpit Press
About This Addendum

When Apple released iLife ’09, the company added a lot of new features to iMovie but barely touched iDVD. To keep this book from becoming a 500-page behemoth, I decided to pull the bulk of the iDVD section and offer it as a free download.

If you downloaded this file and do not own the print version of my iMovie ’09 book, I hope this gives you an idea of how easy to read and information-packed the book is. I encourage you to buy a copy at your favorite local bookstore or online. (If you buy it from jeffcarlson.com/imovievqs/, I get a small percentage of the sale.)

About iDVD

The biggest change in iDVD between iLife ’08 and iLife ’09 is that Apple removed the year from the product name—it’s now known just as “iDVD”. If you want to get specific, the version number changed from iDVD 7.0.2 to iDVD 7.0.3. Apple has lost interest in DVDs, and views online delivery—such as via a MobileMe Gallery or the Apple TV—as the way of the future.

That said, iDVD still works just fine, and is a great way to create and customize DVDs that can be played in any DVD player. Not everyone has broadband Internet access that’s fast enough to realistically watch high-resolution movies online, and the medium is still fairly brittle for long movies or DVD projects for most people.

The chapters in this addendum were taken from the last edition of this book, iMovie ’08 & iDVD ’08: Visual QuickStart Guide, and have been updated where necessary.
# Table of Contents

**Chapter 1: iDVD Overview**

- About DVDs ........................................ 4
- Working with iDVD Projects ......................... 5
- Using OneStep DVD ................................ 6
- Using Magic iDVD ................................... 7
- iDVD’s Interface ..................................... 8
- Creating a New Project ............................... 10
- Creating an iDVD Project from Final Cut .......... 11
- Creating a Submenu ................................ 12
- Setting an Autoplay Movie ......................... 15
- Previewing the DVD ................................ 16
- Adding DVD-ROM Data .............................. 17

**Chapter 2: iDVD Themes**

- Applying a Theme .................................. 20
- Using Motion ....................................... 22
- Using Drop Zones .................................. 25
- Editing Text ......................................... 30

**Chapter 3: Customizing iDVD Themes**

- Editing Text Formatting ............................ 34
- Editing Text Alignment and Position .............. 36
- Editing Buttons ..................................... 38
- Changing the Background .......................... 40
- Setting Background Audio ........................... 42
- Looping Movie Playback ............................ 44
- Saving a Favorite Theme ............................ 45
- Deleting a Favorite Theme .......................... 46

**Chapter 4: Slideshows**

- Creating a Slideshow ............................... 48
- Setting Slideshow Options .......................... 50
- Adding Photos ....................................... 53
- Adding Background Audio .......................... 54
## Table of Contents

**Chapter 5: Archiving, Encoding, and Burning**  
- Creating a Project Archive ....................... 56  
- Choosing an Encoding Setting .................... 58  
- Burning the DVD .................................. 60  
- Saving as a Disc Image ............................ 63  
- After the Burn ..................................... 64  

**Index** ........................................... 65
Addendum: iDVD

Chapter 1  iDVD Overview ........................................ 3
Chapter 2  iDVD Themes .......................................... 19
Chapter 3  Customizing iDVD Themes ...................... 33
Chapter 4  Slideshows ............................................. 47
Chapter 5  Archiving, Encoding, and Burning .......... 55
iMovie took a technology dominated by professionals—movie editing—and made it easy for normal people to use. In some ways, though, iDVD is even more impressive.

Quite a lot of highly technical work goes into creating a DVD—in the background. While you’re focused on choosing which photo should appear on the title page of your DVD, iDVD handles the specifics of building the structure necessary for most consumer DVD players to play back your masterpiece. More importantly, it manages the MPEG-2 compression needed to cram multiple gigabytes’ worth of data onto a shiny platter the size and shape of a regular audio CD.

iDVD also does something that no other program can do: It gives you style. Apple has clearly put a lot of thought into the DVD themes that ship with iDVD, making each one something you’d actually want to show off to people. An iDVD project, whether you like it or not, is polished, which goes a long way toward making people think, “Wow, I had no idea he was so talented.”

This chapter offers a look at iDVD’s interface and major functions in order to give you the foundation you’ll need for the next chapters that deal with building projects and customizing them.
About DVDs

The Digital Versatile Disc is quite a wonder: it’s physically small, like a CD, but packs nearly seven times the data into the same space: a CD stores roughly 700 MB, while a DVD holds approximately 4.7 GB. In addition to storing all this data, DVDs can be set up so they automatically play movie files and include a menu system to give you control over how the content plays.

DVD physical formats

Before you rush out and buy a mega-pack of blank DVDs, take a few minutes to acquaint yourself with the different formats that are out there.

- **DVD-R.** DVD-Recordable discs can be burned once, and then played back in nearly any consumer DVD player and DVD-capable computer. When purchasing DVD-R media, be sure to get DVD-R (General); the other type, DVD-R (Authoring), is used in professional DVD writers and is not supported by iDVD. The discs Apple sells are DVD-R format.

- **DVD-RW.** DVD-Rewritable discs can be erased and burned hundreds of times, which make them great for testing purposes (you can burn iterations of your project onto one DVD-RW disc, instead of making lots of DVD-R coasters).

- **DVD+R, DVD+RW.** These two formats use a different method of recording data than DVD-R and DVD-RW. They don’t offer more storage or features, and cost about the same as the -R and -RW discs.

- **DVD-ROM.** DVD-Read-Only-Media discs cannot be burned because their data has already been written to disc. The iLife installation disc is an example of DVD-ROM.

4x DVD Media Alert!

Before you burn any DVD disc, make sure your SuperDrive’s firmware has been updated. All SuperDrives can burn 1x- and 2x-speed DVD-R media. When using 4x-speed media, however, some older mechanisms can not only fail to write the disc, but they can also be permanently damaged! Fixes are available—see http://docs.info.apple.com/article.html?artnum=86130 for more information.

DVD Logical Structure

A blank DVD contains no information or directory structure. The way a DVD’s data is stored on the disc depends on how the disc will be used.

- **DVD-Video.** A DVD that contains just a movie (and its associated menus and extras) is in DVD-Video format. The folders and filenames are specific: a folder called VIDEO_TS stores all of the movie’s video and audio files. iDVD typically creates DVD-Video discs.

- **DVD-ROM.** When you store just data on the disc, without the need to play back automatically in DVD players, the disc is in DVD-ROM format. This is just like using a CD-ROM, only with more storage capacity. The Finder can create DVD-ROM discs when you’re backing up data, for example.

- **Hybrid DVD.** You can store a DVD-Video project on a disc that also contains DVD-ROM data, which makes the disc a Hybrid DVD. iDVD can create Hybrid DVDs.
Working with iDVD Projects

If iDVD is currently running because you shared a movie from GarageBand, you don’t need to open, create, or save your project—it’s all done for you. If you just launched iDVD independently, you can create a new project or open an existing project from the File menu; doing so closes the current project (only one project can be open at a time).

The iDVD project file

The iDVD project file appears by default in your Documents folder (within your Home folder), and ends in the extension “.dvdproj”. iDVD stores all of its related files in the project file itself, which is a package.

Tips

- Many of the newest Mac models sport SuperDrives that burn dual-layer DVD media, which can store up to 8.5 GB of data and hold around three hours of video footage.
- Make sure you have plenty of free hard disk space available—at least 10 to 20 GB.
- Storing the project file in the Documents folder may be fine for casual use, but an iDVD project may not fit on your startup disk. When traveling, I move the project file to another partition of my PowerBook’s hard disk, or offload everything to a speedy external drive.
- If you do move your iDVD project, make sure it can still locate your original iMovie project and its media files. If iDVD gets confused, it warns you with a dialog (Figure 1.1). Select a file from the list and click Find File if the file is actually available somewhere else, or click Cancel to proceed. You can still work on the project if you cancel, but you’ll get a broken link warning if you play any of the footage.

DVD Disc Speeds

DVD discs are marked as being 1x, 2x, 4x, or 8x speed. The SuperDrive that comes in the current iMac, for example, writes data at 8x speed, which means the laser that carves into the disc’s surface is fast enough to keep up with a faster-spinning disc. All recent SuperDrives can write to higher-speed media, even if they’re not 4x- or 8x-speed drives, at 1x or 2x speed.

Switch Between NTSC and PAL

Choose Project Info from the Project menu, and change the Video Mode setting at any time. Also, in iDVD’s preferences you’ll find a Video Mode setting in the Projects area that applies to new projects.

Using iDVD on Non-SuperDrive Macs

You can run iDVD on a Mac that does not include a SuperDrive, then archive your project or save it to a disc image for burning on another computer (see Chapter 5).
Using OneStep DVD

Sometimes you may want to just burn some footage to a disc, without dealing with pretty graphics or navigation. Film productions frequently create DVD “dailies” of each day’s footage for the director or producers to review; wedding videographers sometimes offer the raw footage to the married couple, handed over at the end of the day. iDVD’s OneStep DVD feature simply grabs video from your camcorder and burns it to disc, with no menu navigation or frills. When you play it in a DVD player, the movie starts playing right away.

To create a OneStep DVD:

1. Connect your camcorder to your Mac and make sure it’s loaded with the tape containing your footage.

2. Choose OneStep DVD from the File menu, or press the OneStep DVD button on iDVD’s title screen (Figure 1.2).

3. Insert a recordable DVD disc into your computer.

4. Sit back and wait. iDVD rewinds the tape, imports the footage, encodes it, and burns it to the disc (Figure 1.3).

5. If you want another copy made after iDVD finishes, insert another disc. Otherwise, click Done.

Tips

- OneStep DVD imports footage until it reaches the end of the tape or the end of the footage. If you want just a portion of the tape recorded, press the Stop button in iDVD or on the camcorder.

- You can’t start importing footage in the middle of a tape using OneStep DVD. If you want to burn just a portion of your video, import it into iMovie first.

OneStep DVD Data Location

When you use the OneStep DVD feature, iDVD doesn’t create a project that you can go edit later. All OneStep DVD files are stored in a temporary, invisible directory on your startup drive. But you can change the location: open iDVD’s preferences, click the Advanced icon, and choose a new temporary folder location (say, a larger hard disk) at the bottom of the window.
Using Magic iDVD

To get more of iDVD's style without spending a lot of time building a full project, drag movies, music, and photos from your hard disk onto the Magic iDVD interface and let iDVD do the work. You can then burn it straight to disc, or use the project as the jumping-off point for your own customizing.

To create a Magic iDVD project:

1. Choose Magic iDVD from the File menu, or press the Magic iDVD button on iDVD's title screen.

2. In the Magic iDVD window, type a name for your DVD in the DVD Title field (Figure 1.4).

3. Choose a theme from the scrolling list.

4. Click the Movies button to view movies (including iMovie projects) on your computer, and drag the ones you want to the Drop Movies Here area.

5. To include slideshows, click the Photos button and drag photos from your iPhoto library to the Drop Photos Here area. Each slot represents a different slideshow that can include several photos.

6. If you want music with your slideshow, click the Audio button and drag songs from your iTunes library to a slideshow.

7. Click the Preview button at any time to see what the project looks like.

8. Click the Create Project button to create a new project (Figure 1.5), or click the Burn button to write directly to a DVD.

✔ Tips

- You can also drag media content from the Finder to the Magic iDVD areas.

- To preview a song or movie, double-click it, or select it and press the Play button.
iDVD’s Interface

Some software is deep, with lots of hidden, out-of-the-way features. iDVD is not one of those programs. That’s not to say it isn’t deep in what it can do—rather, it’s easy to find what you need, quickly.

Menu/main window

iDVD’s main window, referred to as the menu, displays the first set of options that your viewers will encounter (Figure 1.6). Choose between standard or widescreen modes, depending on the aspect ratio of your movie.

To switch format modes:
• From the Project menu, choose Switch to Standard (4:3) or Switch to Widescreen (16:9), or press Command-Option-A (Figure 1.7).

Tips
• The term “menu” is confusing in iDVD. Normally, a menu is a list of commands that you access from the menu bar at the top of the screen. In DVD parlance, however, a menu is the screen you’re looking at. Think of it like a restaurant menu: the main window is a space to list the items (movies, etc.) you can select.
• The widescreen format is designed to play on widescreen televisions without letterboxing the picture. All themes can be made widescreen (even old ones).
• Switch between standard and widescreen layout at any time; you’re not locked into one or the other.
• Motion-enabled menus are generally processor-intensive, so I rarely leave the Motion button enabled while I edit.
### Controls

The program’s main controls run below the preview window:

- **Add button.** Click this button to display a pop-up menu that lets you add a submenu, movie, or slideshow.
- **Inspector button.** Click to display the floating Inspector window.
- **Map button.** Click to see the Map view, which displays the project’s content structure. You can organize the project’s structure, assign themes to menus, and specify media that will start playing when a disc is begun, even before the first menu screen.
- **Motion button.** Click to toggle animation and movie previews, available for most iDVD themes. The Motion button turns them on or off while you’re editing.
- **Edit Drop Zones button.** Click this button to display the Drop Zone editing interface in the main window.
- **Volume slider.** Set the volume of the theme elements (such as background music) while you’re working; it doesn’t affect the project’s volume level.
- **Preview button.** Switch into preview mode to get a sense of how the DVD’s menus and content will run.
- **Burn button.** Start the encoding and burning process to create a final disc.
- **Editing panes.** Clicking one of these buttons displays panes for editing the project’s content.

### Tip

- The iDVD window is also resizable. Choose Actual Size from the Window menu to go back to the native resolution.

---

**Important iDVD Interface Terms**

- **Button.** Any interactive element in the DVD workspace is a *button*, even if it doesn’t always look like a button. New movies, slideshows, and chapters are all buttons, because they require some sort of action on the part of the user to activate them.

- **Submenu.** The exception to buttons are *submenus*, which are containers that hold more stuff. An example of a submenu would be the “Scene Selection” option that appears when you import a movie with chapter markers. The item is a control that takes you to another menu screen, which includes buttons for each chapter that you’ve set up.

- **Theme.** A *theme* is the overall look of a menu screen, including the visual presentation (fonts, colors, etc.) as well as the way it interacts (with motion menus, etc.).

---

**Figure 1.7** Work in standard or widescreen mode.
Creating a New Project

Bringing in a movie from iMovie via GarageBand isn’t the only entryway to iDVD. You can start by creating a new empty project.

**To create a new project in iDVD:**

1. Choose New from the File menu, or click the Create a New Project button from iDVD’s title screen. The Save As dialog appears.
2. Give the project a name and choose where to save it.
3. Choose an aspect ratio, and then click the Create button (Figure 1.8).

**To import video footage:**

1. Click the Media button and then the Movies button to display the Movies list.
2. Drag a movie to the menu to add it (Figure 1.9).

*Or*

1. From the File menu, go to the Import submenu and choose Video.
2. Locate a video source, such as a QuickTime movie, and click Import. A new button or submenu (depending on the movie) appears in the preview window for that video (Figure 1.10).

**Tip**

- You can also drag a QuickTime movie from the Finder to the iDVD window, but make sure you don’t release it over a drop zone (see Chapter 2).
Creating an iDVD Project from Final Cut

Video editors working in Final Cut Express or Final Cut Pro often bring their work into iDVD to create their DVDs.

To export from Final Cut:

1. If you want to use Final Cut markers as iDVD chapter markers, be sure they’re set up as such: Locate a marker and press M to bring up the Edit Marker dialog.

2. Click the Add Chapter Marker button (Figure 1.11). The text <CHAPTER> appears in the Comment field. Click OK.

3. From the File menu, choose QuickTime Movie from the Export submenu.

4. In the Save dialog, make sure Audio and Video is chosen from the Include pop-up menu.

5. Choose Chapter Markers from the Markers pop-up menu.

6. Click Save to save the file.

7. In iDVD, import the file as described on the opposite page.
Creating a Submenu

If you used GarageBand to set up chapter markers and create your iDVD project, your menu contains a Play Movie button that plays back the entire movie, and a button labeled Scene Selection. That second button is actually a submenu that branches off from the main menu. Double-clicking Scene Selection takes you to another menu screen that includes buttons to play chapters of your movie.

You can create new submenus that lead to other media—more movies or photos, for example.

To create a submenu:

1. Click the Add button and choose Add Submenu from the pop-up menu that appears. A new item named “My Submenu” appears (Figure 1.12).

2. Double-click the submenu name. The current theme is used for the new submenu, and includes a back arrow icon that, when clicked, leads to the main menu (Figure 1.13).

3. If you want, choose a different theme for the submenu.

To create a submenu in the Map view:

1. Click the Map button to switch to the Map view (Figure 1.14).

2. Select an icon for the menu where you want to add a submenu.

3. Click the Add button and choose Add Submenu. The new item appears in the project hierarchy attached to the menu (Figure 1.15).
To move objects to another submenu:

- Select an icon for a submenu, movie, or slideshow and drag it onto the icon for the submenu where the object will appear (Figure 1.16).

To delete a submenu:

1. Select a submenu’s button (in the DVD menu) or icon (in the Map view).
2. Press the Delete key, or choose Delete from the Edit menu. The submenu disappears in a puff of smoke, as do any submenus, movies, or slideshows that it contained (but see the tip below).

Tips

- To delete a submenu but keep the objects that it contained, Control-click the submenu icon in the Map view and choose Smart Delete. Only the submenu is removed, leaving the other elements intact.
- Want to move some menu items into their own submenu without creating the submenu separately? Select them and choose New Menu from Selection from the Project menu. A new submenu is created that contains the items. However, except for using Undo, note that you can’t move them back to the main menu later if you decide they should have been there all along.
- Click the small triangle to the right of a menu icon to hide or show lower-level items in the hierarchy (which is especially helpful when working on large, complicated projects).
- Double-click an icon on the map to display the menu or play back the movie or slideshow. Clicking the movie or slideshow while it’s playing takes you back to the Map view.
To use a transition between menus:

1. If you’re currently within the submenu, click the back arrow icon to return to the previous menu. Transitions are applied to the menu that leads to the submenu.

2. Click the submenu’s name or button to select it.

3. Click the Inspector button to display the floating Inspector.

4. Choose an effect from the Transition pop-up menu (Figure 1.17).

5. For transitions that move in more than one direction, such as Cube, choose a direction from the second pop-up menu under Transition.

6. Click the Preview button to see how your transition plays when you move between menus (Figure 1.18). (See “Previewing the DVD,” later in this chapter.)

✓ Tips

■ Transitions can occur when switching between submenus, slideshows, and movies, but not when returning up through the hierarchy to the previous menu.

■ You can easily tell which menus include transitions: look for a small blue circle to the left of their icons in the Map view.

■ Complex transitions can add to the time it takes to burn the disc.

Figure 1.17 Choose a type of transition to play when switching between menus.

Figure 1.18 Use the Preview mode to see how the transition plays (Mosaic Flip Small shown here).
Setting an Autoplay Movie

Nearly all of the commercial movie DVDs I’ve watched lately begin with either several screens of threatening information from various governmental agencies, or with some snazzy video animation or montage that plays before the main menu appears. In iDVD, this introductory material is known as an Autoplay movie, and is something you can create for your own projects. The Autoplay movie can be either a QuickTime movie or a slideshow. Themes with Autoplay movies include a special icon in their thumbnails (Figure 1.19).

To set an Autoplay movie:

1. Click the Map button to switch to the Map view. The icon in the upper-left corner is the Autoplay well.
2. Drag a movie file to the Autoplay well to set it as the Autoplay movie (Figure 1.20).

You can also drag one or more photos, or an iPhoto album of photos, to the well, which turns them into a slideshow. To edit the contents of the slideshow, double-click the well (see Chapter 4).

To delete an Autoplay movie:

- Drag the contents of the Autoplay well outside the well. The media disappears with a poof.

**Tip**

- If you want to use an iMovie movie as the Autoplay movie, export it as Full Quality for the best image quality.
Previewing the DVD

The menu screen provides a good representation of what your viewers will see, but some aspects of a DVD—the way items are highlighted, for example—appear only when you preview the DVD. Obviously, you don’t want to have to burn a new disc to see each iteration, which is why iDVD offers a preview mode.

To preview the DVD:

1. Click the Preview button to enter preview mode (Figure 1.21). A virtual DVD remote control appears. Using the remote, test the following features:
   ▲ Use the arrow keys, mouse pointer, or the arrow navigation buttons on the virtual remote control to move the button highlight between items (Figure 1.22).
   ▲ Use the forward and back buttons on the remote control to switch between chapters while watching the video.
   ▲ Click the Menu button to exit a movie and return to the movie’s submenu, or click Title to return to the main menu.

2. Click the Exit button or the Stop button (with the square icon) to leave Preview mode.

✔ Tip

■ As you’re previewing the project, pay attention to the order in which items are highlighted as you move the focus around the menu. Does it act the way a viewer would expect? Seeing the highlighting in action reminds me to rearrange the order of my items. This is more important when your buttons don’t align with the theme’s invisible grid (see Chapter 3 for more on positioning items).
Adding DVD-ROM Data

Earlier in this chapter I mentioned that it’s possible to create a hybrid DVD, which contains a DVD project as well as DVD-ROM files that can be read and copied using a Mac or PC. iDVD provides a straightforward (though slightly tucked away) method of adding files and folders to the disc.

To add files and folders to the DVD-ROM:

1. From the Advanced menu, choose Edit DVD-ROM Contents. The DVD-ROM Contents window appears (Figure 1.23).

2. Choose from the following options:
   - Click the New Folder button to create a new untitled folder.
   - Click the Add Files button to bring up an Open dialog where you can choose files to add.
   - Drag files or folders from the Finder onto the DVD-ROM Contents window (Figure 1.24).

3. Close the window when you’re finished adding files and folders.

To remove DVD-ROM files and folders:

1. In the DVD-ROM Contents window, select one or more files.

2. Press the Delete key, or choose Delete from the Edit menu.

---

**Figure 1.23** The DVD-ROM Contents window is a blank canvas where you can add files that can be accessed by people viewing your DVD on a computer.

**Figure 1.24** I find it easiest to just drag files and folders from the Finder to the DVD-ROM Contents window.
Tips

- When you create an iDVD slideshow, you can choose to store copies of those photos on the DVD-ROM portion of the disc. If this option is enabled, the files will appear in the DVD-ROM Contents window, but they will be grayed-out and inaccessible. You’ll need to turn off the option labeled Add image files to DVD-ROM to remove the files. See Chapter 4 for more information.

- Click and drag the files and folders in the window to change their order in the list. You can also move files into different folders, nest folders, or move everything to the same hierarchy.

- iDVD creates links to the files you’ve added to the DVD-ROM Contents window; it doesn’t copy the files themselves until it’s time to burn your disc. If you add a file or folder and then move its location on your hard disk, the item’s name appears in red and you get a “File not found” message when you burn the DVD. Either move the file back to its original location (if you know it), or delete the reference in the DVD-ROM Contents window and add the file again.

- Apple recommends that you not use the DVD-ROM feature in iDVD to create system backups of your hard disk, because saving “more than a few thousand files may not work.” Instead, use the disc burning features in the Finder, or better yet, create a backup system.
My wife is moderately addicted to several home decorating shows on TV, the ones where a designer takes over a room and the homeowners marvel at the transformation (okay, so maybe I’ve watched a few, too). It’s amazing what a new window treatment and a fresh coat of paint can do to a room.

You might think that iDVD themes are nothing more than curtains to dress up your movies, but that would diminish the possibilities that a DVD theme offers. A theme gives your movie character, but more importantly, it provides a framework for the movie and other related media. Your DVD can contain several movies, slideshows of digital still photos, music, and animation.

In this chapter, I’ll cover the basics of choosing one of iDVD’s pre-made themes and working with its integrated elements, such as drop zones, motion menus, and editing text. In the next chapter, I’ll get into the specifics of customizing a theme and tailoring it to your own tastes. Like decorating an otherwise functional room, working with iDVD themes can add some flair to the presentation of your movie.
Applying a Theme

When you start iDVD, a theme is already selected for you—either the first one in iDVD’s list, or the one that was active the last time you used the program. Applying a different theme is simply a matter of clicking on a new one in the Themes pane. Your buttons and submenus are retained with the look of the new theme applied.

Themes are organized in families, so your project can share a consistent look while also providing variation among the menus (Figure 2.1).

To apply a theme family:

1. Click the Themes button to display the Themes pane, if it’s not already visible.

2. Click a theme family icon to apply the theme to the current menu and any submenus based on it.

   ▲ If you’re working in the Standard (4:3) aspect ratio, iDVD offers to switch to Widescreen (16:9) mode (Figure 2.2). Click Keep to leave the mode unchanged (unless you want to switch, of course).

   ▲ You may also see an Apply Theme Family dialog confirming that you want the theme to apply to all of the submenus attached to the current menu. Click OK.

After a few seconds, the theme changes in the main window.

To apply an individual theme:

1. Click the Themes button to display the Themes pane, if it’s not already visible.

2. Choose a theme from the list by clicking its thumbnail image. After a few seconds, the new theme is applied.

Figure 2.1 Click a theme in the Themes pane to apply it to your menu.

Figure 2.2 This dialog appears whenever you switch standard aspect ratio themes. Click the Do not ask me again checkbox to avoid it in the future.
To apply a theme in the Map view:

1. With the Themes pane visible, click the Map button.
2. Click the icon of the menu whose theme you want to change.
3. Click a theme from the Themes pane to apply the change (Figure 2.3).
4. Click the Return button to exit Map view.

To apply a theme to every menu in your project:

- In any menu screen, choose Apply Theme to Project from the Advanced menu. Every menu in your project now has the same theme.

To apply a theme to submenus:

1. Navigate to a submenu that you wish to change (the Map is a good place to do this; click the Map button, then click the menu you wish to view).
2. Choose Apply Theme to Submenus from the Advanced menu. The theme of every submenu in the current hierarchy is changed (Figure 2.4).

Tips

- Click the pop-up menu in the Themes pane to select themes from other versions of iDVD (or choose All to view them all in the list).
- Feel free to mix and match themes within a family; for example, you can use the Extras theme in place of Chapters if you prefer.
- You can purchase more custom themes from third party developers such as iDVD ThemePAK.
Using Motion

Menu items are designed to do more than display a text title or static image. DVDs typically convey video, so why not add some motion to the menus as well?

iDVD uses two types of motion: motion menus, which incorporate animated backgrounds, and motion buttons, which play movies or abbreviated photo slideshows in place of a generic button icon or still image. (Actually, there’s also a third type of motion, audio, which is covered in the next chapter.) Most of iDVD’s recent themes incorporate motion because it brings life to menus and makes them more than just pretty pictures.

In this section I cover motion buttons; see “Changing the Background” in Chapter 3 for details on using motion menus.

To activate motion:

- Click the Motion button, choose Motion from the Advanced menu, or press Command-J. The Motion button becomes highlighted in blue (Figure 2.5), and any animated elements within the theme, such as the background, drop zone, or submenu icons, start to play.
- Perform any of the above actions to turn motion off.

✓ Tip

- Turn off Motion when you’re done editing the motion properties of your menu to improve performance while editing other aspects of your project.

The Introductory Animation

Many themes include an introductory animation before the menu elements appear, indicated by a shaded section of the Motion Playhead scrubber bar (Figure 2.6). When the total animation finishes playing, it starts over where the vertical bar bisects the scrubber bar. To skip this first animation, deselect the checkbox to the left of the scrubber bar. Some themes also have a concluding animation, too.

Controls for these animations can also be found on the Menu Info window, marked Intro and Outro (Figure 2.7).
Motion buttons

Any QuickTime movie you add to your menu is a motion button—when motion is turned on, the movie plays within its button icon (except for themes that use only text as buttons, of course). Normally, the first frame of the movie button is the first frame of the movie itself; if you specified a poster frame for the movie file using QuickTime Pro, that frame is automatically set as the beginning. You can specify a new first frame, or choose not to play the movie at all and just use a frame of it as a still image.

To set the starting frame:

1. Click a motion button to select it, then click again or click and hold to display a Movie slider above it. (Be careful not to double-click the button, which plays the movie.) This works whether motion is activated or not.

2. Drag the Movie slider to locate the frame you wish to use as the starting point (Figure 2.8). Click outside the button to deselect it.

To turn off movie playback for a button:

1. Click a motion button and bring up the Movie slider.

2. Mark the Still Image checkbox.

3. Drag the slider to the frame you want to use as the thumbnail image.

Tip

The chapters from a GarageBand-generated iDVD project all belong to the full movie, so when you’re changing the starting frame of the motion button, the slider represents the entire movie, not just that chapter (Figure 2.9).
Motion duration

The Loop Duration slider in the Menu Info window controls how long your motion elements play before they are reset to their starting points.

To set motion duration:

1. Click the Inspector button to view the Menu Info window.
2. Drag the Loop Duration slider to change the duration of the motion menu (Figure 2.10). The number to the right of the slider represents the total time required to play all motion elements on the menu.

✔ Tips

- What if you don’t want any motion when you burn your project to disc? Set the Loop Duration to 00:00, and disable any motion button movies, and turn off any of a theme’s introductory or ending animations.

- The maximum menu duration was 30 seconds in previous versions of iDVD. Now, it’s limited by the length of the menu’s background movie or audio, whichever is longest, up to 15 minutes. If one ends before the other, it loops to keep the motion effect going.

- One of my biggest gripes about DVDs is that they don’t loop cleanly, either on my projects or commercial DVDs. The motion menu reaches the end and pauses briefly before starting over. However, one feature can help: In iDVD’s preferences, click the General icon and enable the option labeled Fade volume out at end of menu loop (Figure 2.11).
Using Drop Zones

To add a bit of visual interest and a personal touch to your menu, add a movie, photo, or collection of photos to the drop zones included with some themes.

To add a movie or photo to a drop zone:

1. Click the Media button to display the Media pane.
2. Click the Photos or Movies button at the top of the pane.
3. Drag a movie, a photo, or multiple selected photos to a drop zone, indicated by a yellow border (Figure 2.12). iDVD adds the media to that zone.

Or

- Drag a movie or a photo file(s) from the Finder to the drop zone.

Or

1. Click the Drop Zones Editor button to display the editor in the preview area.
2. Drag a movie, photo, or multiple selected photos to a drop zone placeholder.

Or

1. Control-click the drop zone and choose Import from the contextual menu.
2. In the Open dialog that appears, locate a movie or photo file on your hard disk, then click the Import button.

To remove media from a drop zone:

- Control-click the zone and choose Clear Drop Zone Contents from the contextual menu.
- Drag the photo or movie out of the drop zone and release the mouse button.
Working with dynamic drop zones

Some of the latest themes feature dynamic drop zones: one or more drop zones animated within the theme. Individually, they operate as normal drop zones, but you can also control them as a group.

To add movies or photos to dynamic drop zones:

1. Click the Edit Drop Zones button to view the Drop Zones editor (Figure 2.14).
2. Drag movies or photos to each drop zone.
3. Click the close button at the upper-left corner to go back to the menu.

Or

1. Turn off Motion, if it’s currently active, by clicking the Motion button. (You can leave it on if you want, but that makes it difficult to add each media item.)
2. Drag a movie or photo to a drop zone; each zone is numbered.
3. Advance the Motion Playhead by dragging it to the right (Figure 2.15). (If you don’t see it, choose Show Motion Playhead from the View menu.) The animation progresses, revealing more drop zones.
4. Repeat steps 2 and 3 until you’ve populated the drop zones.
To autofill drop zones:

1. Choose Autofill Drop Zones from the Project menu, or press Command-Shift-F.

2. Click the Autofill button. iDVD collects media that you’ve already used in the project (such as movies added) and fills the drop zones.

To fill a drop zone with content from your project:

- If you want to let iDVD do the choosing for you, Control-click a drop zone and choose Fill with content (Figure 2.16). iDVD fills it with a movie or photo from your project.

**Tips**

- Consider waiting until you’ve added more content to your project before using the autofill feature, so that iDVD will have plenty of media to choose from.

- The drag-and-drop approach can be problematic if your aim is poor: a few pixels off and you could find yourself replacing the menu’s background image (see “Changing the Background” in Chapter 3). To ensure that you’re performing the action you want, press the Command or Option key when dragging to view a contextual menu with options for placing the media (Figure 2.17).

- You can opt to turn off the “Drop Zone” text in iDVD’s General preferences by disabling the Show drop zone labels checkbox. If you turn it off, the words reappear when you drag media onto the menu area.
Working with multiple photos in a drop zone

When you drag multiple photos to a drop zone, they act as a slideshow within the zone. You can change the order in which they appear, or add and delete photos using the Drop Zones Editor.

To set which photo displays first:
1. Click the zone to make it editable (Figure 2.18).
2. Drag the Photos slider that appears above the drop zone to choose a photo. That picture will appear first when the menu plays with motion.

To change the order of the photos:
1. Click the zone to make it editable.
2. Click the Edit Order button, or double-click the drop zone. The Drop Zone Photos editor appears (Figure 2.19).
3. Drag the photos to change their order. iDVD numbers each icon to indicate the playback order.
4. Click the Return button to go back to the menu.

To add more photos:
1. Double-click the drop zone to display the Drop Zone Photos editor.
2. Drag more images from the Media pane or from the Finder.
3. Click the Return button to go back to the menu.

Tip
- Click the view preference buttons in the upper-right corner of the Drop Zone Photos editor to display the photos either as thumbnails or as a list (with filenames).
To delete photos from the drop zone:

1. In the Drop Zone Photos editor, select the photos you wish to remove. Shift-click to select a range of photos, or Command-click to select non-contiguous photos (Figure 2.20).

2. Press the Delete key or choose Delete from the Edit menu. The pictures are removed.

3. Click the Return button to go back to the menu (or the drop zone list).

To turn off drop zones entirely:

1. Click the Inspector button to display the Menu Info window.

2. Uncheck the option labeled Show drop zones and related graphics (Figure 2.21).

Tips

- iDVD determines the amount of time a photo appears depending on the number of photos you’ve included. The more photos you add, the less time they stay onscreen. The overall time is based on the Loop Duration setting in the Menu Info window (see “Using Motion,” earlier in this chapter).

- If you’ve already added photos in the menu, dragging more to the drop zone replaces the ones you have; it doesn’t add them to the existing lineup. Use the Drop Zone Photos editor to add more pictures.

- It’s not possible to resize or crop photos in a drop zone within iDVD, unfortunately. Some themes determine the size of the media by fitting the width of the photo or movie; others base the size on the height.

Figure 2.20 Images 21, 27, and 32 are selected and ready to be deleted (or moved; see Chapter 4).

Figure 2.21 If you’d prefer not to include any drop zone content, disable the drop zones in the Menu Info window.
Editing Text

Not all text needs to be in service of buttons or submenus—edit and add your own text boxes. The following steps apply to changing the contents of text blocks; in the next chapter, I’ll cover more settings such as changing the font and style.

To edit text:

1. Click once to select a button or title, and then click again to select the text (Figure 2.22). Don’t double-click the button, however, because that will either play its movie or take you to a submenu.

2. Type your text. Hit Return or Enter to break the line (Figure 2.23).

3. Click outside the text field to deselect it and accept your changes.

To add new text:

1. Choose Add Text from the Project menu, or press Command-K. A new text block appears (Figure 2.24).

2. Edit the text as described above.

3. Position the text by dragging it where you want it; unlike the default behavior of buttons and menu titles, which snap to an invisible grid, a new text block can be placed anywhere on the screen. (See the next chapter for more on positioning buttons.)

✔ Tip

If the Inspector window is visible, the font formatting controls do not appear beneath the text.

To delete text:

1. Click a text block once to select it.

2. Press the Delete key, or choose Delete from the Edit menu. The text vanishes.
To insert special characters:

1. Click a text block once to select it, then click again to edit it.
2. Choose Special Characters from the Edit menu. The Character Palette appears.
3. Select the character you want to use in the palette.
4. Click the Insert button to add the character to your text.

Tips

- Some televisions don’t display everything that you see in iDVD’s screen. To make sure your text will appear, choose Show TV Safe Area from the View menu, or press Command-T, and position the text and buttons within the area that’s not shaded (Figure 2.25).

- If you’re working in widescreen mode, choose Show Standard Crop Area from the View menu, or press Command-Option-T, to see where a standard-definition television showing a full-screen image will crop your menu (Figure 2.26).
The benefit of iDVD’s approach to creating DVD menus is that everything is already in place; the background imagery, animation, typefaces, and navigation structure are all prefab. Your job is to fill in the content.

While that may sound nicely organized to some people, others see it as a collection of limitations. Where’s the fun if everything is spelled out for you already? This is where iDVD’s theme customization comes into play. It may not be as open-ended as Apple’s professional-caliber DVD Studio Pro, but there’s enough flexibility built in to let you make your own personal stamp on the menu design.
Editing Text Formatting

A hallmark of the Macintosh has been the capability to change the appearance of text onscreen. Sure, every computer now offers dozens of fonts and styles, but in 1984 that capability was a big deal. So it’s sensible that you can change the font, alignment, and color of your menu titles, buttons, and text blocks.

**To edit text formatting:**

1. Click the text block you want to edit. If the Inspector window is not visible, a set of pop-up menus appears below the text (Figure 3.1). If the Inspector is visible, it becomes either the Text Info window or the Button Info window, depending on the text that’s selected (Figure 3.2).

2. To change the text’s font and size, use the following pop-up menus.
   - **Family.** Choose a font family from this pop-up menu to change the font.
   - **Typeface.** Choose the style of font from this pop-up menu.
   - **Size.** Choose a font size from this pop-up menu.

3. With the Inspector window visible, you can also edit the following attributes:
   - **Color.** Click the Color field to display the Colors palette and choose a new color (Figure 3.3).
   - **Shadow.** Drop shadows are often overused in design, but in DVD menus they often make the text more readable. Click this checkbox to add a subtle drop shadow behind the text.

![Figure 3.1](image1.png) Change the formatting of the menu title or stand-alone text blocks in the Preview window.

![Figure 3.2](image2.png) The Inspector window includes font formatting settings, but changes depending on what’s selected: a button (top) or a text block, such as the menu’s title (bottom).
Customizing iDVD Themes

To reset text to the theme's default formatting:

1. Select the text block you want to change back to the theme's formatting.

2. Choose Reset Object to Theme Settings from the Advanced menu. Or, Control-click the block and choose Reset to Theme from the contextual menu.

**Tips**

- If you want to change the appearance of a menu's title, you don't need to select anything first; the text controls in the Menu pane apply to the title by default.

- Hooray! In previous editions of this book, I’ve complained that you couldn’t simply choose a standard font size (such as 12 point), but had to rely on an inaccurate slider. Now…you can.

- More good news! iDVD lets you apply formatting changes to each text block or button label independently (Figure 3.4). The old restrictions of applying one font for all button labels is gone, gone, gone. However, remember that just because you can use all sorts of crazy fonts on your menu doesn’t mean you should.

---

**Figure 3.3** iDVD uses the Mac OS X Colors palette to choose from the full spectrum of colors.

**Figure 3.4** Could and should are two very different terms. Restraint is an even better word.
Editor the Text Alignment and Position

iDVD uses two terms for aligning text: alignment and position. Alignment refers to how the text lines up within its allotted space, or how button labels appear in relation to each other. Position describes where a button's label appears in relation to the button's icon (if it's visible).

Title alignment

The title in each theme is bound to a specific area by default, but you can opt to place it anywhere within the menu. You can also make it disappear if a title isn't needed.

To set the title alignment:

1. Select the menu title, or make sure nothing is selected (the settings apply to the title if nothing else is selected).

2. In the Inspector window, click one of the Align options: Left, Center, or Right (Figure 3.5). The text is moved relative to the area designated for the title. For example, choosing Center in the Reflection White theme shifts the text to the right of the default position; it doesn’t move it to the center of the screen as you might expect (Figure 3.6).

To position the text anywhere you want, simply drag the title elsewhere on the screen; doing so unlocks the title from the theme’s placement grid and enables you to drag the title anywhere onscreen (Figure 3.7).

To remove the menu title:

- Select the title and press the Delete key, or choose Delete from the Edit menu. Note that once a title has been deleted, you can’t add it back to your page without using the Undo command.
Customizing iDVD Themes

Button label position

In themes where buttons include an icon, instead of just text, the Label pop-up menu determines where the text appears in relation to the icon.

To set the position of button text:

1. Select a button in the menu.
2. In the Button Info window, choose a button label location from the Label pop-up menu (Figure 3.8).

To remove button text:

1. Click the button to select it, then click it again to select the label’s text.
2. Press the Delete key or choose Delete from the Edit menu.

Button text alignment

In themes that use only text for buttons, the Align controls specify the text alignment of the buttons relative to each other. (You can also switch normal buttons to text buttons on any theme; see “Editing Buttons” on the next page.)

To set the alignment of button text:

1. Select a text button in the menu.
2. In the Button Info window, click the Left, Center, or Right buttons to align the text of the labels to each other (Figure 3.9).

Tip

Some label position settings don’t work well in some themes. For example, using a Left Side position in some themes can make the text run off the screen or onto other buttons. You can move the buttons around, however; see “Editing Buttons” on the next page.
Editing Buttons

Buttons are the mechanism by which your viewers interact with the DVD. In addition to changing the buttons’ text, you can change their shape, location, and size, plus the highlight color.

To change the button style:

1. Select one or more buttons in the menu.
2. Click the Buttons button to view the Buttons pane. (By the way, now I can’t stop saying “Buttons button!”)
3. Choose a button type from the pop-up menu (Figure 3.10).
4. Click a button style to apply it to the selected button in the Preview window.

To reposition buttons:

- Drag a button onto another button to swap their locations on the grid. The others move out of your way as you drag.
- Drag the button to a new location within the menu (Figure 3.11). As you drag, iDVD displays alignment guides to help you line up objects.

Or

1. Select two or more buttons.
2. Control-click to bring up the contextual menu, and choose the options on the Align Objects and Distribute Objects submenus (Figure 3.12).

To re-align buttons:

1. With nothing selected in the Preview window, click the Inspector button to bring up the Menu Info window.
2. In the Buttons area, click Snap to grid (Figure 3.13). The menu’s buttons return to the layout grid.
Customizing iDVD Themes

To change the button highlight color:
- In the Buttons area of the Menu Info window, click the Highlight field and choose a color from the Colors palette.

To resize buttons:
1. Select one or more buttons in the menu.
2. In the Button Info window, drag the Size slider. This feature becomes useful if you’ve added lots of buttons to your menu and you want to prevent overlap (Figure 3.14).

To change the appearance of a button icon:
- In themes with button icons, drag a photo or movie from the Media pane or the Finder onto the Button info window’s Custom thumbnail field (Figure 3.15). You can switch back to the generic submenu icon, if you want, by clicking the icon and moving the Thumbnail slider to the left. Or, drag the image out of the field to remove it. Only one photo or movie can be applied to a submenu icon—dragging others just replaces the previous image.

To reset a button to the theme default:
1. Select the button you want to change back to the theme's formatting.
2. Choose Reset Object to Theme Settings from the Advanced menu. Or, Control-click the block and choose Reset to Theme from the contextual menu.

✔ Tip
- If you decide to position your buttons freely (without the grid), turn on the TV Safe Area (press Command-T or choose it from the Advanced menu) to make sure the buttons won’t get cut off when viewed on some television screens.

---

Figure 3.13 When it’s time to crack down and restore order, click the Snap to grid button.

Figure 3.14 The Size slider makes button icons smaller or larger (but not the button text).

Figure 3.15 Drag a photo or movie from the Media pane to the Custom thumbnail field to change its icon (this works only in themes that use icons, naturally).
Changing the Background

To alter a theme’s appearance dramatically, swap the existing background image with your own photo or movie.

To use a photo or movie as the background:

1. Click either the Inspector button to bring up the Menu Info window or the Edit Drop Zones button.

2. Drag a photo or movie from the Media pane or the Finder and drop it onto the Menu icon in either location. The background image is replaced, but the drop zones remain (Figure 3.16).

Or

1. From the File menu, go to the Import submenu and choose Background Video.

2. Locate a movie on your hard disk, and click Import.

Or

1. Drag a photo or movie file from the Media pane or the Finder to the menu, but don’t release the mouse button; be sure to avoid stopping on a drop zone.

2. Press the Command or Option key to bring up a contextual menu with choices (Figure 3.17).

3. Choose Replace background to use your file as the background.

To use a photo or movie as the background with no drop zones:

1. Follow the steps above to change the background image.

2. In the Menu Info window, deselect Show drop zones and related graphics (Figure 3.18).

Figure 3.16 Adding a photo or movie to the Menu icon in the Menu Info window (top) or the Drop Zones Editor (bottom) makes it the theme’s background.

Figure 3.17 Press Command or Option before releasing the mouse button to choose an action.

Figure 3.18 Turn off the option to show drop zones to use only your image or movie as the background.
To set the beginning and ending of a background video:

1. With a video set as the background, make the Menu Info window visible.

2. Click the small triangle above the Loop Duration slider to display the Background Movie Start/End control (Figure 3.19). The triangle appears only when a video is used as the background.

3. Drag the ends of the control to set the start and end of the video.

To remove your background photo or movie:

1. Switch to the Menu pane.

2. Drag the photo or movie out of the Background well (Figure 3.20). The theme’s default background reappears.

Tips

- For best image quality, share your background movie from iMovie at the large setting.

- If the movie is meant as a visual item only, export it from iMovie with the sound disabled, or set at a low volume.

- If you switch to a different theme, your background image or movie is deleted from the project; you’ll need to re-import it under the new theme.

- Remember that you won’t see your movie in action unless Motion is enabled.

- If you remove a video from the background well, also be sure to remove the audio that the video may have added (see the next page).

- Import video files you shot with a digital still camera by locating them in the Media pane’s Photos list.
Setting Background Audio

Being a more visual person, I tend to forget about audio unless it’s either (a) highly annoying, or (b) eerily nonexistent. Some themes include background audio, others don’t, but you can add an audio file to any of them to customize your menu’s sound.

To choose an audio file:

1. Switch to the Media pane, and click the Audio button (if it’s not already active). Your GarageBand songs and iTunes music appear (Figure 3.21).

2. Locate the audio file you wish to use. To help narrow your search, click one of the playlists in the upper portion of the window, or type a name (song or artist) in the search box at the bottom.

3. Click the Play button if you want to preview the file. Otherwise, click the file to select it.

To add background audio:

◆ Drag an audio file from the Media pane or the Finder to the Audio well in the Menu Info window (Figure 3.22).

◆ Drag an audio file from the Media pane or the Finder to the Menu icon in the Drop Zones Editor.

◆ Drag an audio file from the Media pane or the Finder to the menu.

Or

1. From the File menu, choose Audio from the Import submenu.

2. Locate an audio file on your hard disk, and click Import.

To change audio’s volume:

◆ Drag the Menu Volume slider in the Menu Info window.

Figure 3.21 The Audio list in the Media pane displays your iTunes and GarageBand songs.

Figure 3.22 Drop a song file onto the Audio well to use that as your background sound.
Customizing iDVD Themes

To remove background audio:

1. Bring up the Menu Info window or the Drop Zones Editor.

2. Drag the sound file out of the Audio well (or Menu well in the Drop Zones Editor). The well’s icon changes to a generic speaker icon.

✔ Tips

- To play more than one song in the background, select multiple audio files and drag them to the Audio well together.

- If you want the background audio turned down, not off, use the Volume slider at the bottom of the iDVD window. This setting only affects the volume while you work, not the volume of the audio when the project is burned to disc.

- Background audio doesn’t need to be music. Spoken-word content or other sound effects work just as well.

- You can drag a QuickTime movie to the Audio well and use only its audio track.

- GarageBand songs need to be saved with an iTunes preview before you can add them to iDVD.

- Speaking of GarageBand, that type of audio is great for a DVD menu: you have control over the duration of the song, and it can loop in the background.

- If you add a background movie, then delete the movie from the Background well, the audio stays. You also need to delete the music from the Audio well.

- iDVD recognizes when it’s using protected audio files, such as older songs you bought from the iTunes Music Store, and displays the file’s icon (which includes a small lock image, Figure 3.23).
Looping Movie Playback

Normally, a movie or scene plays its frames and finishes, moving on to the next scene or returning to the menu. However, you can opt to loop a movie so that once started it will replay until you intervene.

To loop a movie:

1. Click the Map button to switch to the Map view.
2. Select a movie file.
3. Choose Loop Movie from the Advanced menu. A loop icon appears on the movie clip (Figure 3.24).

✔ Tips

- When you loop a movie chapter that’s part of a larger movie, all of its chapters include the loop icon and the entire movie loops, not an individual chapter.
- This may be too obvious, but never loop an AutoPlay movie. If you do, the DVD will never proceed to the main menu.
- Did I say never? Looping the AutoPlay movie might be what you want if you’re creating a video that needs to keep playing in a kiosk mode (such as for a convention booth, art installation, or other presentation).
Saving a Favorite Theme

You’ve added a new background, new music, and tweaked the buttons and text to your liking. If you want to keep this setting for future projects, save it as a favorite.

To save a favorite theme:

1. Choose Save Theme asFavorite from the File menu (Figure 3.25).

2. In the dialog that appears, type a name for the theme (Figure 3.26).

3. To make the theme available for all users on your computer, enable the Shared for all users option.

4. If you’re changing a favorite that you’ve already created and want to save over it, mark the Replace existing checkbox.

5. After the theme is saved, it becomes available in the Themes pane. Choose Favorites or All from the pop-up menu to view your theme (Figure 3.27).

✔ Tips

- If you’ve arranged your buttons with the Free Positioning option selected in the Button pane, those positions become the basis for the grid when you apply your favorite theme to a new project.

- If you placed a photo or movie in a drop zone before saving the theme as a favorite, that media becomes part of the background image, but leaves the drop zone open for new media.
Deleting a Favorite Theme

Creating a favorite theme is a simple operation, but iDVD offers no similarly direct method of removing a favorite. However, you can do it with a little poking around in the Finder.

To delete a favorite theme:

1. Quit iDVD if it is running.

2. In the Finder, locate iDVD’s Favorites folder. There are two; the location of the one you want to delete depends on whether the theme was made available to all users or not.
   - If you enabled the Shared for all users option, go to [Computer] > Users > Shared > iDVD > Favorites (Figure 3.28).
   - If you did not enable Shared for all users, go to Home > Library > Application Support > iDVD > Favorites (Figure 3.29).

3. Select the file corresponding to the theme you wish to delete, and drag it to the Trash.

4. Re-launch iDVD to see that the favorite theme is now no longer available.
Most of this book centers on video and all of the wonderful things you can do with it. But your digital lifestyle probably includes a lot of still photos, too (either taken with a digital still camera or your camcorder, or scanned from paper originals).

In addition to providing a venue for your movies, iDVD can build slideshows from your photos, including transitions and audio, which can be played back on DVD players.
Creating a Slideshow

The ingredients for a successful slideshow are photos, photos, and more photos (with perhaps a dash of audio thrown in, which I’ll address later in the chapter).

To create a slideshow:

- Click the Add button and choose Add Slideshow, or choose Add Slideshow from the Project menu (or press Command-L). A new empty slideshow appears in the menu (Figure 4.1).

- Drag two or more pictures from the Media pane or the Finder to the main window (if you drag only one, then the photo is used as the background image). A new slideshow titled “My Slideshow” is created containing those pictures.

- Drag an iPhoto album from the Media pane to the main window (Figure 4.2). The slideshow that is created takes the name of the album.

To set the slideshow icon:

1. Click a slideshow to select it. A Thumbnail slider appears. If the Inspector is visible, the slider is located in the Button Info window. (This feature works only in themes where buttons include icons.)

2. Drag the Thumbnail slider to choose one of the slideshow’s photos (Figure 4.3).

3. Click outside the icon to deselect it and apply the change.

To delete a slideshow:

- If you want to remove a slideshow, click its button in the main window and press Delete or choose Delete from the Edit menu.

Figure 4.1 When you create an empty slideshow, it appears as a new button in the menu.

Figure 4.2 Drag an iPhoto album from the Media pane to the menu to create a slideshow containing all of the album’s pictures.

Figure 4.3 The Thumbnail slider lets you pick a photo to use as the button’s icon.
iDVD now has the capability to include movies in a slideshow. Simply drag one to the Slideshow Editor (see the next page).

- You can also drag photos or albums directly from the iPhoto application to iDVD’s menu to create a new slideshow. That applies to folders containing images in the Finder, too.

- Use the left or right arrow key to view the slideshow icon photos one by one, or if you don’t want to drag the slider with the mouse.

- If you want a slideshow to start as soon as you insert a DVD into a player, switch to the Map view and drag your photos to the AutoPlay well (Figure 4.4). Double-clicking the well with photos added brings up the AutoPlay Slideshow editor, which features the same options described throughout the rest of this chapter.

- To ensure that your photos display correctly in iDVD, crop them first in iPhoto. Select the photo and click the Edit button to enter Edit mode, then click the Crop button. Choose 4 x 3 (DVD) from the Constrain pop-up menu (Figure 4.5). If your project is widescreen, choose 16 x 9 (HD). Move or resize the selection box so that the image appears as you’d like it to, then click the Apply button. When you bring it into iDVD, it will have the proper size ratio.

- An iDVD slideshow displays its photos as static images. If you want to add some movement to them, use the Ken Burns Effect in iMovie or iPhoto and create a movie that contains just the photos you’d use in a slideshow. Then, import that movie file as a regular movie. (It’s not actually a slideshow in iDVD’s eyes, but you get the same overall effect.)
Setting Slideshow Options

Now that you’ve created a slideshow, use the Slideshow editor to change several settings that pertain to how long each photo appears, whether the slideshow repeats, and more.

To enter the Slideshow editor:
- Double-click a slideshow in the menu (or in the Map view) to bring up the Slideshow editor (Figure 4.6).

To set the slide duration:
- Choose a time from the Slide Duration pop-up menu to specify how long each photo remains onscreen before loading the next one (Figure 4.7).

If you’ve included background audio in your slideshow (see “Adding Background Audio,” later in this chapter), you can also choose Fit To Audio, which divides the total audio playing time by the number of photos to come up with an equal display time for each photo (for example, a slideshow of five photos that contains 60 seconds of audio would display each picture for 12 seconds).

The last option, Manual, requires the viewer to advance the frames using the DVD player’s controls. Manual is not available if you add background audio.

To set the transition style:
- Choose a transition type from the Transition pop-up menu (Figure 4.8). As with transitions between menus (see Chapter 1), this setting applies only when you’re advancing to the next slide; if you switch to the previous image, no transition occurs.

For transitions that can operate in different directions, such as Cube, click a directional arrow to the right of the pop-up menu.
To edit titles and comments:

- iDVD copies each photo's title and comments from iPhoto. If you plan to make these visible, click the title or comment area below a photo and type your title and comments (Figure 4.9).

To apply miscellaneous settings:

1. Click the Settings button to display the Settings dialog (Figure 4.10).

2. Enable or disable the following options:
   - **Loop slideshow** makes the show repeat once it reaches the last photo. Your viewers will need to return to the menu using their player's controls.
   - **Display navigation arrows** shows a pair of arrows onscreen that indicate more photos are available before and after the current one (Figure 4.11). These arrows are just decoration; they aren’t buttons that can be clicked to advance the slideshow.
   - **Add image files to DVD-ROM** includes copies of the image files on the disc so that anyone with a computer can access them (see “Adding DVD-ROM Data” in Chapter 1).
   - **Show titles and comments** displays the photos’ text in the Slideshow editor and during the slideshow.
   - **Duck audio while playing movies** reduces the volume of background music. If your slideshow contains a movie file, the last option reduces the volume of background music so it doesn’t compete with the audio from the movie.
To preview the slideshow:

- With the Slideshow editor open, click the Preview button. You can also go back to the menu, preview the project from there, and then click the slideshow’s icon, but previewing from within the Slideshow editor is easier.

To remove photos from a slideshow:

1. Select one or more photos in the Slideshow editor.
2. Press Delete, or choose Delete from the Edit menu.

To exit the Slideshow editor:

- Click the Return button to go back to the menu.

👍 Tips

- You can choose to always include high-resolution slideshow photos on the DVD-ROM portion of your disc. Open iDVD’s preferences, click the Slideshow icon, and enable Always add original slideshow photos to DVD-ROM contents.

- Does a thick black band appear around your photos when you preview the slideshow? iDVD shrinks the images to fit within the TV Safe Area. To turn off this feature (if you’re going to view the DVD on a computer, for example), open iDVD’s preferences and click the Slideshow icon. Then, disable the option marked Always scale slides to TV Safe Area (Figure 4.12).

- Click the list style buttons at the upper-right corner of the Slideshow editor to switch between viewing just thumbnails of your images and viewing them in a list with filenames and comments displayed (Figure 4.13).

A Pointer about Pointers

When you add a photo from the Media pane, iDVD creates a pointer to the photo’s original image file; it doesn’t store a new copy. So, if you add a photo to your slideshow, and then edit it in iPhoto later (such as cropping it or converting it to black and white), the edited version appears in your slideshow.

This also explains why, if you edit a photo in iPhoto, that picture’s thumbnail image isn’t updated in your slideshow, even if the correct version appears when you preview the slideshow. iDVD creates a thumbnail image of the photo when it’s added to the slideshow.
Adding Photos

I never seem to hit upon the right combination of photos when I create a slideshow—there’s always one (or two, or twenty) more that really must go in. iDVD has a limit of 9,801 photos—but it’s hard to really call that a limit.

To add photos to the slideshow:
1. Double-click a slideshow to enter the Slideshow editor (if it’s not already open).
2. Drag one or more image files from the Media pane or the Finder to the Slideshow editor (Figure 4.14).

To rearrange photos:
- Drag one or more images to a new location within the Slideshow editor. The other images are re-ordered to accommodate the change (Figure 4.15).

Tips
- Don’t drag new photos to the slideshow’s icon in the menu—they’ll change the icon, but won’t be added to the slideshow. (See “Using Motion” in Chapter 2.) Make sure you’re adding them to the Slideshow editor.
- Rearranging the order of the photos changes the preview icon for your slideshow in the menu (Figure 4.16). For example, if the icon is photo number 2 and you move another picture into the number 2 position in the Slideshow editor, the latter photo appears as the icon when you return to the menu.
- You can add multiple copies of the same photo to a slideshow, in the event that you want an image to repeat later.
Adding Background Audio

Just as audio can play in the background of a menu, slideshows can include audio, too.

To add background audio:

1. Double-click a slideshow to enter the Slideshow editor (if it’s not already open).

2. Drag one or more audio files, or an iTunes playlist, from the Media pane to the Audio well (Figure 4.17). You can also drag audio files from the Finder.

   When you add audio to the well, the Slide Duration pop-up menu automatically switches to Fit To Audio, which divides the total audio playing time by the number of photos to come up with an equal display time for each photo.

To set the audio volume:

- Drag the Slideshow volume slider to control how loud or soft your background music plays (Figure 4.18).

To remove background audio:

- In the Slideshow editor, drag the music file out of the Audio well. A gray speaker icon indicates that no audio is set.

✔ Tips

- You can also drag QuickTime movies to the Audio well; iDVD ignores the video track and plays the audio.

- Need some visual entertainment in the background at your next party (gotta use that obnoxiously huge widescreen television for something, right)? Load up a slideshow with your favorite images and drag an iTunes playlist to the Audio well. If it’s an exceptionally long party, enable the Loop slideshow option. Burn the disc, pop it into your DVD player, and then go mix some martinis!

Keep ’Em Entertained

Remember when I advised you to trim your footage in iMovie so that your audience wouldn’t get bored? The same applies to slideshows. I know, it’s so easy to just drag virtual stacks of photos to iDVD—there’s plenty of space on the disc, and it’s quicker than sorting through them. Resist that urge: Add only the good shots and don’t flirt with the limits of your viewers’ attentions.
iMovie’s purpose is to create a movie, which can be published to a Web page, sent to an iPod or Apple TV, or distributed in other ways. iDVD’s purpose, however, is to create a project that can be burned to a DVD disc. It contains high-quality video and audio that will play on a consumer DVD player. Without the disc-burning step, iDVD is pretty much just an interesting exercise in customizing a user interface.

True to form, the process of burning a disc is simple: click the glowing Burn button, insert a recordable DVD disc (DVD-R, DVD-RW, DVD+R, or DVD+RW), and go outside to enjoy the sunshine for a few hours. But getting to that point, while not difficult, involves a few choices that determine the amount of data that can be stored on the disc and the quality of the finished project.

Déjà Vu
This chapter is identical to Chapter 20 in the *iMovie '09 & iDVD for Mac OS X: Visual QuickStart Guide* print book. Although that book doesn’t go into as much detail about iDVD as this addendum, I wanted the information available for people who just want to burn a DVD after editing a movie in iMovie.
Creating a Project Archive

Burning a DVD takes a lot of hard disk space and processing power. Some people choose to build a project using one Mac (such as a laptop), and then burn the DVD on another computer (such as a desktop Mac, which boasts a faster processor). Or, perhaps your Mac doesn’t include a SuperDrive. In these situations, create an archive of your project that can be copied to another machine.

If you’re planning to burn a disc on your computer but don’t need an archive, skip ahead to “Choosing an Encoding Setting.”

To create a project archive:

1. Choose Archive Project from the File menu. If your project isn’t saved, iDVD asks you to save it. To continue, click OK in the dialog that appears; otherwise, click Cancel.

2. In the Save As dialog that appears, choose a location for the archive and, optionally, change its name (Figure 5.1).

3. Enable or disable the following options. The estimated size of the archive appears to the right and changes based on your choices.

   ▲ Include themes. If your project uses themes that aren’t likely to be on another computer (such as third-party themes you purchased, or favorite themes you designed), enable this option to copy the necessary information to the archive. If you leave this disabled, but your project contains custom elements, an error dialog appears on the other computer when you open the archive (Figure 5.2).

External Burners

For most of iDVD’s existence, the only official way to burn a DVD was to do it on a Mac that contained an Apple-supplied internal SuperDrive. Now, at long last, that restriction is history: you can burn to external DVD burners directly from iDVD.
Archiving, Encoding, and Burning

Include encoded files. iDVD can encode material in the background, which reduces the time it takes to burn the disc (see “Choosing an Encoding Setting” on the next page). Including these files means it will take less time to burn the project on another machine, but it also makes the archive size larger.

4. Click Save. After a few minutes, depending on the size of your project, a new archive file is created.

Tips

- An archive contains all the data your project needs—except fonts. If your project contains a font that may not be on the computer to which you’re sending the archive, be sure to also send a copy of the font.

- If you’ve included any protected audio files (such as older songs purchased from the iTunes Music Store) in your archive, you won’t be able to open the project on another computer unless that machine is authorized by you. A warning dialog appears (Figure 5.3), and then opens iTunes so you can input your iTunes Music Store identification and password.

- So why not just copy the project file? To save disk space while you’re working, iDVD includes pointers to the media and other data in your project, not the data itself. Copying just the project file to another machine wouldn’t include that information. An archive packs it all into a nice tidy package (Figure 5.4).
Choosing an Encoding Setting

iDVD employs three encoding methods: Best Performance, High Quality, and Professional Quality.

To choose an encoding setting for the current project:

1. Choose Project Info from the Project menu or press Command-I.
2. Choose an option from the Encoding pop-up menu (Figure 5.5).

To choose an encoding setting for new projects:

1. Open iDVD’s preferences and click the Projects icon.
2. For the Encoding setting, click the radio button beside the type of encoding you wish to use.

Best Performance

Best Performance provides up to 60 minutes of video and shorter burn times than High Quality. iDVD encodes the video while it’s running, whether you’re doing something else in iDVD or working in another program (Figure 5.6).

High Quality

If your project exceeds 60 minutes, or you want to make sure you’re getting a higher quality encoding than Best Performance, use the High Quality mode. After you start the burn process, iDVD examines the video to determine where it can apply different levels of compression (a process called Variable Bitrate, or VBR, encoding).

Encoding and Burn Times

To give you a rough idea of how long it takes for iDVD to encode projects using the encoding settings, here are the results of burning a two-hour project on a 2.4 GHz iMac.

High Quality: 1 hour 15 minutes.
Professional Quality: 3 hours 52 minutes.
Professional Quality

Professional Quality uses the same encoding algorithms found in Apple's pro-level applications. Like High Quality, it uses VBR, but it takes two passes through the footage to optimize the compression. Professional Quality projects tend to feature richer colors and better reproduction than High Quality projects (Figure 5.7).

Tips

- If you’re using Best Performance, wait until the assets are finished encoding in the Project Info window before you burn.

- High and Professional Quality do not encode video in the background the way Best Performance does. Instead, they perform calculations during the burning phase. So, don’t stare at the Encoding area waiting for the encoding to finish, because it hasn’t started.

- As projects get longer than 60 minutes, their image quality is more likely to decrease due to the additional compression that needs to be applied. If higher image quality is important to you, try not to skirt that two-hour border with your project sizes (Figure 5.8).

- After you burn a project using High or Professional Quality, iDVD holds onto the files it encoded. However, if you remove any assets from the project and want to burn it again, be sure to first choose Delete Encoded Assets from the Advanced menu to force iDVD to re-scan the footage and choose the best compression settings.

- The Capacity figure in the Project Info window is based on the type of encoding you’ve specified. If iDVD is set to use Best Performance but the capacity exceeds 4.2 GB, switch to High or Professional Quality—iDVD changes its estimate.

Figure 5.7 These examples come from a 118-minute project (High Quality) and the same footage in a 48-minute project (Best Performance). More motion and noise gets more compression (top), resulting in pixelation around the trees (detail). However, when there is less motion, the two encoding styles look very much alike (bottom, with detail).

Figure 5.8 These examples come from a 118-minute project (High Quality) and the same footage in a 48-minute project (Best Performance). More motion and noise gets more compression (top), resulting in pixelation around the trees (detail). However, when there is less motion, the two encoding styles look very much alike (bottom, with detail).
Burning the DVD

Before you click the Burn button, make sure you have enough hard disk space available: at least twice the amount the project occupies. You can view your project’s size and the free space on the hard disk that contains your project by choosing Project Info from the Project menu.

To change the name of the burned disc:

1. Choose Project Info from the Project menu, or press Command-I. The Project Info window appears (Figure 5.9).

2. Type a new name in the Disc Name field. After the disc is burned, this name is used when the DVD is mounted on a computer’s desktop.

3. Close the window to apply the change.

To locate a missing asset:

1. Choose Project Info from the Project menu, or press Command-I to display the Project Info window.

2. Scroll through the asset list to find entries with a zero (0) in the Status column (Figure 5.10).

3. Double-click the missing asset to bring up the Missing Files dialog.

4. Select a file in the dialog and click the Find File button.

5. Locate the file and press OK. The Status column displays a checkmark. Note that for missing imported videos, you need to re-link the video and audio portions (just point to the same file).

6. Click OK to exit the dialog.

How to Fix Missing Assets

The Project Info dialog tracks everything you’ve added to the project, even assets that you’ve deleted. If the file cannot be found, iDVD will not proceed when the time comes to burn.

I learned this the hard way when I dragged a JPEG image file to a menu background, decided it didn’t look good, and then deleted it from the Background well in the Menu pane. Since the image no longer appeared in the project, I deleted it from my hard disk.

There are two solutions:

- Double-click the item in the Project Info window and choose another image.
- Go to the Map view and delete the asset entirely.
To burn the DVD:

1. Click the Burn button; the iris reveals the glowing Burn button that’s been hiding under iDVD’s interface (Figure 5.11).

   If any assets are missing, iDVD displays a warning dialog (Figure 5.12). The Map view also displays potential burn problems.

   (The “closed” Burn button is like the bright red safety cover that’s always mounted over The Big Important Button—the one that launches the missiles, opens the airlocks, or initiates the self-destruct sequence that destroys the villain’s secret underground lair in all those movies.)

   Otherwise, the program asks you to insert a blank recordable DVD.

2. A progress dialog appears that identifies the stages of the process (Figure 5.13):

   - **Stage 1: Prepare.** iDVD ensures that it has everything it needs to continue burning.

   - **Stage 2: Process Menus.** Buttons, motion menus, and other menu interface elements are rendered and encoded.

   - **Stage 3: Process Slideshows.** Slideshow photos are resized and compressed as needed. If you’ve specified slideshow transitions, they are rendered separately during this stage.

   - **Stage 4: Process Movies.** Depending on which encoding method you’ve chosen, this stage usually takes the longest.

   - **Stage 5: Burn.** The footage is multiplexed, which combines the audio and video data into a single stream that can be read by DVD players. Burning is when the laser actually etches your data into the surface of the disc.
**Tips**

- If you’ve specified Best Performance, wait for asset encoding to finish before starting the burn process.

- Remember that the total space occupied on the disc includes motion menus, slide-shows, etc. So if your movie is 56 minutes long, you may still get an error message that the project is too big.

- Earlier versions of iDVD required you to enable the Motion button to include motion on the disc, but iDVD now renders the motion elements whether the Motion button is highlighted or not. To burn a project with no motion, set the Loop Duration slider in the Menu Info window to zero (00:00).

- I frequently burn test copies of a project to a rewriteable DVD-RW disc, so I’m not throwing away a bunch of shiny platters. When you insert such a disc that already has data on it, iDVD gives you the option to erase it before continuing with the burn process (**Figure 5.14**).

- Including transitions between menus or within slideshows adds time to the burning process.

- Did you create a widescreen movie in iMovie, but it’s not appearing as widescreen in your DVD player? Check to see if the player has a 16:9 or letterbox feature. Some models (such as mine at home) play the movie full frame if it doesn’t detect a flag on the disc instructing it to letterbox the picture.

- Wondering at what speed your SuperDrive is burning the disc? The answer is found in Mac OS X’s console.log file. After you burn a project, open the file, located at [Computer]/Library/Logs/Console/.
Saving as a Disc Image

Until iDVD 5, you needed to own a Mac with an Apple-supplied SuperDrive to burn iDVD projects. It wouldn’t work with third-party external burners.

Now, that restriction is gone. However, there are still occasions when you want to save the project as a disc image, which effectively “burns” your project to the hard drive. For example, you may want to burn a DVD from that disc image on another computer, or mount the image on your desktop and preview the final project using the DVD Player application.

**To save as a disc image:**

1. Instead of clicking the Burn button, choose Save As Disc Image from the File menu, or press Command-Shift-R (Figure 5.15).

2. Choose a location on your hard disk to save the disc image; make sure you have plenty of free space.

3. Click the Save button. iDVD follows the same procedure as when it burns a disc.

**To burn a DVD from a disc image:**

1. Launch Disk Utility (located in Applications > Utilities).

2. Drag the disc image from the Finder to the left-hand column (Figure 5.16); or, choose Open from the Images menu.

3. Select the disc image in Disk Utility and click the Burn button.

4. Insert a recordable disc.

**To play a disc image using DVD Player:**

1. Double-click the disc image to mount the disc as if it were a physical DVD.

2. Launch the DVD Player application.
After the Burn

When the burning process is complete, iDVD spits out the DVD disc and asks if you'd like to make another copy (Figure 5.17). If so, insert a new disc; otherwise, click Done.

Here are a few other suggested things to do while you’re in your cooling down period.

Test your project

Just because you have a shiny disc in hand doesn’t guarantee that it works. Test it on your own machine using DVD Player. Test it on friends’ Macs and PCs, and insert it into your consumer DVD player. Test, test, test, or you may find yourself singing, “To every season, burn, burn, burn...”

Delete encoded assets

If you don’t need to burn another disc, you can free up some hard disk space by deleting the project’s encoded assets, which are stored in the project file.

Create an archive of the project for offline storage to make sure you have all of the original footage.

To delete encoded assets:

- From the Advanced menu, choose Delete Encoded Assets.

Make duplicates

If you want to make copies of the DVD without going through the iDVD burning process, use Disk Utility or other software such as Roxio’s Toast (www.roxio.com).
INDEX

A
Add Chapter Marker button, 11
alignment
  of buttons, 38
  of text, 36–37
  of titles, setting, 36
animation, 9, 15, 22, 24
Apple, virtual remote controls, 16
Apply Theme Family dialog, 20
archiving projects, 56–57
aspect ratios, applying themes and, 20
assets, missing, 60
audio backgrounds
  setting, 42–43
  in slideshows, 54
autofilling drop zones, 27
autoplay
  Autoplay movies, setting, 15
  of slideshows, 49

B
background
  audio, adding, 42
  changing, 40–41
backups, 18
Best Performance encoding, 58, 62
Blu-ray, 3
Burn button, 9, 55, 61

burning DVDs
basics of, 55, 60–62
burn times when encoding, 58
from disc images, 63
disc name, changing, 60
duplicating, 64
encoded assets and, 64
to hard drives (saving as disc images), 63
missing assets, fixing, 60
on other computers, 5
saving as VIDEO_TS folders, 63
testing of, 64

buttons
alignment, 38
color, 39
basics of, 9
editing, 37, 38–39
editing text and, 30
icons, changing appearance, 39
label position, 37
position, 38
resetting to theme default, 39
size, 39
style, 38
text, 37
Buttons button, 38

C
CDs vs. DVDs, 4
chapter markers, 11
characters, special, 31
color
button highlight color, 39
Mac OS X Colors palette, 35

compression
encoding settings and, 58, 59
MPEG-2 compression, 3
controls
main controls, 9
virtual remote controls, 16
Create New Project button, 10
cropping, widescreen mode, 31

data, OneStep DVD data location, 6
defaults
buttons, resetting, 39
changing text formatting, 35
deleting
accidentally from hard disk, 60
Autoplay movies, 15
background audio, 49, 54
background photos or movies, 41
button text, 37
DVD-ROM files and folders, 17
encoded assets, 64
favorite themes, 46
media from drop zones, 25
menu titles, 36
photos from drop zones, 29
photos from slideshows, 52
slideshows, 48
submenus, 13
text blocks, 30
direction of transitions, 50
Disk Utility, 64
Drop Zones Editor, 25, 28, 40, 43
Drop Zone Photos editor, 28, 29
drop zones, 25–29
autofill, 27
dynamic, 26
media, removing from, 25
movies or photos, adding to, 25, 26
multiple photos in, 28
photos, deleting from, 29
photos and movies as background
and, 40
saving favorites and, 45
duplicating DVDs, 64
duration
of motion, 24
of slides in slideshows, 50
DVD players
playing disc image on, 63
testing projects on, 64
 widescreen movies not playing on, 62
DVD+R, 4, 55
DVD+RW, 4, 55
DVD-R, 4, 55
DVD-ROM, 4, 17–18, 51, 52
DVD-RW, 4, 55, 62
DVDs
   Autoplay movies, 15
   vs. CDs, 4
   changing names on, 60
   creating multiple, 64
   formats of, 4
   logical structure of, 4
   OneStep DVD, 6
   overview of, 4
   previewing, 16
   saving as disc images, 63
   DVD-Video, 4
dynamic drop zones, 26

E
Edit Drop Zones button, 9, 26, 40
editing audio, volume, 42, 54
editing background video, setting
   beginning and end, 41
encoding
   Best Performance encoding, 58, 62
   burn times when encoding, 58
   encoded assets, 64
   High Quality encoding, 58, 59
   Professional Quality encoding, 58, 59
   projects, 58–59
   settings, 58, 59
external drives, as storage, 5

F
favorites (themes)
   deleting, 46
   saving, 45
files
   deleting DVD-ROM files, 17
   project files, 5
   protected audio files, 43, 56, 57
Final Cut, creating projects from, 11
Find File, 5
fonts, changing, 34
footage, importing to projects, 10
formats modes, switching, 8

G
GarageBand, DVD menus and, 43

H
hard disk space
   amount needed for projects, 5
   archiving and, 56
   freeing up, 64
   requirements for iDVD, 56
HD (high definition) format, 3
High Quality encoding, 58, 59
Hybrid DVDs, 4, 17
Index

icons
   button icons, changing, 39
   slideshow icons, 48, 53
iDVD
   vs. iMovie, purposes of, 55
   overview, 3
iDVD ThemePAK, 21
iMovie vs. iDVD, purposes of, 55
Inspector button, 9, 14
interface, 8–9
iPhoto, photos for slideshows from, 48, 49, 52
iTunes, protected audio files and, 57

K
Ken Burns effect for slideshows, 49

L
Loop Duration setting, 24, 29
looping
   DVDs, 24
   movies, 44
   slideshows, 51

M
Mac
   burning DVDs and, 56
   iDVD on non-SuperDrive Macs, 5
   project files and, 5
Mac OS X, Colors palette, 35
Magic iDVD, 7
Map button, 9, 12, 15
Map view, 12, 13, 21, 44
media files
   dropping, 27
   moving projects and, 5
menus,
   applying themes to, 21
   motion menus, 9, 22, 24
   processing, 61
   text, editing, 34–36
   transitions between, 14
   use of term, 8
missing assets, fixing, 60
motion
   duration of, 24
   in themes, 22–24
Motion button, 9, 22, 26
motion buttons, 22
motion menus, 22
movies
   adding to drop zones, 25
   adding to dynamic drop zones, 26
   in slideshows, 49
   using as background, 40
MPEG-2 compression, 3
music for slideshows, 7

N
naming themes, 45
NTSC, switching with PAL, 5

O
OneStep DVD, 6

P
PAL, switching with NTSC, 5
photos
   drop zones and, 25–26, 28
   slideshows and, 49, 52, 53
   using as background, 40
Photos button, 7
Play Movie button, 12
position of buttons (themes), 38
position of text (themes), 36–37
presentations, 49
Preview button, 9, 14, 16
previewing
  DVDs, 16
  slideshows, 52
Professional Quality encoding, 58, 59
Project Info dialog, 60
projects,
  archiving, 56–57
  basics of, 5
  creating new, 10–11
  encoding, 58–59
  hard drive space needed for, 5
Magic iDVD, 7
OneStep DVD, 7
projects, testing DVD burning, 64
protected audio files
  archiving projects and, 56
  themes and, 43
  iTunes and, 57

Q
QuickTime, importing movies and, 10

R
recording formats
  DVDs, 4
  NTSC vs. PAL, 5
Roxio’s Toast, 64

S
Save dialog, 56
saving
  DVDs as disc images, 63
  DVDs as VIDEO_TS folders, 63
  favorites (themes), 45
Settings dialog, 51
shadows, drop shadows, 34
size
  of buttons, 39
  of fonts (themes), 34
slideshows, 47–54
  background audio, 54
  creating, 18, 48–49
  miscellaneous settings, 51
  photos, adding, 53
  photos, removing from, 52
  pointers, 52
  previewing, 52
  slide duration, 50
  Slideshow Editor, 50, 52
  titles and comments, editing, 51
  transition style, 50
  using Magic iDVD, 7
special characters, 31
speed
  of disc burning, 62
  of DVD discs, 5
Standard Crop area, 31
submenus, 9, 12–14, 21
SuperDrives, 4, 5, 62

text (themes)
  alignment and position, editing, 36–37
  boxes, adding/deleting/editing, 30–31
  text formatting, editing, 34–35
Theme button, 20
themes
  applying, 20–21
  archiving projects and, 56
  background, changing, 40–41
Index

themes (continued)
  background audio, setting, 42–43
  buttons, editing, 38–39
  defined, 9
  deleting favorites, 46
  drop zones, 25–29
  iDVD ThemePAK, 21
  looping playback, 44
  motion, 22–24
  saving favorites, 45
  text, editing, 30–31
  text alignment and position, editing, 36–37
  text formatting, editing, 34–35
  times, encoding and burn times, 58
  titles
    alignment of, setting, 36
    in slideshows, 51
  Toast, 64
  transitions
    between menus, 14
    transition style (slideshows), 50
  troubleshooting widescreen, 62
  TV Safe Area, 52

V
  video clips, setting beginning and end, 41
  VIDEO_TS folders, 63
  virtual remote controls, 16
  volume
    background volume (themes) 42, 43
    background volume (slideshows), 54
  Volume slider, 9

W
  widescreen
    iDVD format, 8
    troubleshooting, 62
    widescreen mode, 31
iMovie 09 and iDVD for Mac OS X: Visual QuickStart Guide

This full-color, amply illustrated, accessible book teaches readers the essential skills necessary for creating compelling movies with iMovie ‘09 and iDVD, Apple’s consumer-friendly digital movie and DVD-burning software applications. Readers can follow the step-by-step instructions from the beginning to get a tour of the applications or look up specific tasks to learn just what they need to know. Longtime Macintosh and technology writer Jeff Carlson takes extra steps to ensure that readers understand all of the key aspects of digital movie making.

- Easy visual approach uses pictures to guide you through iMovie ‘09 and iDVD (and how they interact with the other iLife ‘09 applications) and show you what to do.
- Concise steps and explanations let you get up and running in no time.
- Page for page, the best content and value around.

Save 35%
Save 35% off the list price, plus enjoy free domestic U.S. Shipping. Visit peachpit.com and enter coupon code IMOVIEVQS when you reach the checkout page. Offer expires 12/31/2010