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Many worksheets are simply lists of informa-
tion, such as address data and club member-
ship rosters. Such lists typically include few 
calculations, if any. A spreadsheet program is 
very adept at managing lists—considerably 
more so than a word processing program 
(the formerly preferred program for list 
management). 

In recognition of the fact that people use 
spreadsheets to create and manage lists, 
Microsoft introduced the List Manager 
in Excel 2001. By creating a list (Figure 
12.1), you can simplify cumbersome tasks 
such as sorting, filtering, and totaling data. 
This chapter explains how to use the List 
Manager to create and maintain lists.

Excel lists are essentially databases. If you 
intend to create lists in Excel, you’ll also want 
to learn about Excel’s database features, 
discussed in Chapter 14. Note that in Office 
2007 (Windows), lists are called tables.
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Figure 12.1 When you transform a data range into a 
list or create a list from scratch, Excel displays it with 
a special frame and attaches a drop-down menu to 
each column heading.
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Creating a List
You can create a list by converting an exist-
ing data range or by using the List Manager 
to guide the list’s creation.

To create a list:

1. Do one of the following:
▲ To create a list in a new worksheet, 

choose File > Project Gallery, select 
the Blank Documents group, click the 
List Wizard icon, and click Open.

▲ To create a new list in an existing 
worksheet, click the cell where you 
want the list to begin and choose 
Insert > List.

▲ To convert an existing data range into 
a list, click any cell within the range 
and choose Insert > List. 

▲ Display the List toolbar (Figure 12.2) 
by choosing View > Toolbars > List. 
To convert an existing data range into 
a list, click any cell within the range. 
To create a list from scratch, click the 
starting cell. Then click the List Wizard 
icon on the List toolbar.

The List Wizard appears (Figure 12.3). 

2. In Step 1, select one of these options for 
the data source:
▲ None. The list will be created from 

scratch. 
▲ In an open workbook. Use existing 

data from the specified range, convert-
ing it into a list. If the data already has 
column labels, be sure to check My list 
has headers.

▲ External data source. Select this 
option and click the Get Data button 
to import the list data from an exter-
nal file. (This option requires installed 
ODBC drivers.) 
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Figure 12.2 To create a list using the List toolbar, you 
can click the List Wizard icon or click the List icon’s 
drop-down menu and choose List Wizard.

List icon

List Wizard icon

Figure 12.3 In Step 1, tell the List Manager where the 
data (if any) resides and where to create the list. 

Moving a List

You can relocate any list. Move the cursor 
over any edge of the list. When it turns 
into an open hand, click and drag the list 
to its new location.

You can also use cut-and-paste to move 
a list—to another workbook or sheet, for 
example. Move the cursor over any edge 
of the list. When it turns into an open 
hand, click to select the list, and choose 
Edit > Cut (#X). Select a destination 
cell for the list, and choose Edit > Paste 
(#V).
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3. Indicate where the list should be placed:
▲ New sheet. Create the list in a new, 

blank worksheet.
▲ On existing sheet. The upper-left 

corner of the list will begin at the 
specified cell.

Click Next. Step 2 appears (Figure 12.4).

4. Do one of the following:
▲ If the list is based on existing data, 

select each column, select a data type 
from the drop-down Data type list, 
edit the column name (optional), and 
click Modify after each column change. 

▲ If the list is being created from scratch, 
enter each column name, select a 
data type from the drop-down Data 
type list, and click Add. (The order in 
which columns are added will match 
their order in the list.)

5. Optional: To set formatting, conditional 
formatting, or validation options for the 
currently selected field, click Settings. 
Repeat for other fields as necessary. Click 
Next to continue.

6. In Step 3 (Figure 12.5), name the list and 
indicate whether you want a totals row. 
You can also choose an AutoFormat style.

7. Click Finish.

The list appears on the worksheet, starting 
at the designated cell (Figure 12.6).

✔ Tips

■ When your list appears, the List toolbar 
also appears (see Figure 12.2). You can 
use it to modify any list element.

■ When converting existing data to a list, 
you can still add, delete, and modify col-
umns (Figure 12.4). 

■ To convert a list back to normal data, 
click the List icon on the List toolbar and 
choose Remove List Manager.
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Figure 12.4 Specify column names and data types.

Figure 12.5 Name the list, indicate whether to add a 
totals row, and pick an AutoFormat style. 

Figure 12.6 This is an example of an existing data 
range converted to a named, formatted list.
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Entering and Editing Data
Cells in a list are the same as other worksheet 
cells. You can use normal editing techniques 
to enter, delete, and modify list cell contents. 
In addition, you may find the following edit-
ing procedures useful.

To edit list data:

◆ To add new data to a list, you can use any 
of the following techniques:
▲ Type data into each cell as you would 

in any worksheet. Press t or st 
to move to the next or previous cell. 

▲ Choose Data > Form, or click the List 
icon on the List toolbar and choose 
Form (Figure 12.7). Use the Form 
dialog box to edit existing records, 
enter new records, or delete records 
(Figure 12.8).

▲ To create a new record (list row), 
enter data in the row marked with an 
asterisk (*) at the bottom of the list.

◆ To delete a list row, select a cell in the row 
and do one of the following:
▲ Choose Edit > Delete Row.
▲ Click the List icon in the List toolbar 

and choose List > Delete > Row.

✔ Tips

■ As you begin typing a cell entry, a list 
of previous entries for the column that 
begin with the same characters appears. 
You can select one of these items as a 
data-entry shortcut.

■ To clear the contents of a row without 
deleting it, select the entire row. Choose 
Edit > Clear > Contents, or click the List 
toolbar icon and choose Clear Contents.

■ See Chapter 14 for information on using 
forms for data entry and editing.

Figure 12.7 Choose Form from 
the List pop-up menu on the List 
toolbar. 
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Figure 12.8 You can optionally use a form to enter 
new records, edit existing records, or delete records. 

Adding New Columns

To add a new column to an existing list, 
click a cell where you want to insert the 
column. Then click the Insert Column 
icon on the List toolbar or choose Insert > 
Columns. To complete the process, edit 
the column name. 

To add a blank column to the end of a list, 
widen the list frame by dragging its lower-
right corner. A blank, gray area appears. 
Click the (New Column) text and name 
the new column.
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Formatting a List
After you’ve entered the list data (or at least 
several records), you may want to format the 
list. In addition to standard cell-formatting 
options (such as bold, italic, font, size, borders, 
and shading), there are formats that you can 
apply to the entire list. 

To format an entire list:

1. Click any cell in the list. 

2. Do either of the following:
▲ Choose Format > AutoFormat.
▲ Click the List icon on the List toolbar 

and choose AutoFormat.

The AutoFormat dialog box appears 
(Figure 12.9). 

3. Select any of the Table format styles in 
the left pane to see a preview of the format. 
To apply the selected format to the list 
(see Figure 12.6), click OK.

✔ Tips

■ If you click the Options button in the 
AutoFormat dialog box, you can selectively 
enable or disable AutoFormat elements, 
such as borders and cell patterns (Figure 
12.10).

■ After formatting a list with AutoFormat, 
you can still apply normal cell and text 
formatting.

■ To get the full effect of your list’s new 
appearance, click the Visuals icon on the 
List toolbar to hide the frame. Click the 
icon again to restore the list frame.

■ To learn how to format individual cells, 
cell ranges, and particular columns or 
rows, see Chapter 10.
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Figure 12.10 Click Options to reveal this section at the 
bottom of the AutoFormat dialog box, enabling you to 
specify formatting options to apply to the list.

Figure 12.9 Select a format to apply to the list.

Preview of selected formatTable format styles

Set display options
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Filtering a List
As your list grows, you may occasionally 
want to view only rows that match certain 
criteria. You can filter a list in this manner to 
generate a data subset for printing, charting, 
or record deletion, for example.

To apply an AutoFilter to a list:

1. Set the list for AutoFilter by choosing 
Data > Filter > AutoFilter or by clicking 
the Autofilters icon on the List toolbar. 

When enabled, every column title is 
accompanied by a pair of arrows and the 
Autofilters toolbar icon is darkened.

2. Click the AutoFilter arrows beside the 
column on which you want to filter and 
choose a filtering option from the drop-
down menu (Figure 12.11).

Only records that match the criterion are 
shown. The others are temporarily hidden.

3. Optional: To further filter the list, choose 
additional criteria from other columns.

4. To restore all or some of the currently 
hidden records, do one of the following:
▲ To show all list records, choose Data > 

Filter > Show All or choose Filter > 
Show All from the List toolbar icon.

▲ If you’ve applied multiple filters, click 
the AutoFilter arrows for the filter you 
wish to remove and choose Show All.

✔ Tips

■ If you want to edit records with missing 
data for a given column, choose Show 
Blanks.

■ Any column to which a filter has been 
applied displays blue AutoFilter arrows.

■ For additional filtering techniques and 
tips, see Chapter 14.
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AutoFilter arrows

Figure 12.11 To apply or remove a filter, click a col-
umn’s AutoFilter arrows and choose an option from 
the drop-down menu that appears.
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Sorting a List
You can sort a list by the values in one or 
more columns. When sorting on multiple 
columns, each additional column serves as 
a tie-breaker. For instance, you could sort 
on State and on Zip Code. This would group 
each state’s records together, while breaking 
them into subgroups for each Zip Code.

To perform a simple sort:

◆ Do one of the following:
▲ Click any cell within the column on 

which you want to sort. Click the Sort 
A-Z or Sort Z-A icon on the Standard 
toolbar (Figure 12.12).

▲ With AutoFilter enabled, click the 
AutoFilter arrows of the column on 
which you want to sort. Choose Sort 
Ascending or Sort Descending from 
the drop-down menu (see Figure 12.11).

The list rows are reordered.

To perform a complex sort:

1. Click any cell in the list.

2. Choose Data > Sort, or click the List 
toolbar icon and choose Sort.

The Sort dialog box appears (Figure 
12.13).

3. Select the primary sort field from the 
Sort by drop-down list and click the 
Ascending or Descending radio button. 

4. Select additional sort columns from the 
Then by drop-down lists, and set each 
one to Ascending or Descending.

5. Click OK to perform the specified sorts.

Figure 12.12 The Standard 
toolbar has icons for ascending 
and descending sorts.

Ascending sort

Descending sort
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Figure 12.13 Specify fields by which you want to sort, 
and whether each one is ascending or descending.
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✔ Tips

■ When sorting by day or month, you can 
sort in calendar order instead of alpha-
betically. Click Options in the Sort dialog 
box. In the Sort Options dialog box that 
appears (Figure 12.14), select a day or 
month format from the First key sort 
order drop-down list. (Note that such a 
custom sort can only be applied to the 
primary sort field.)

■ The Sort Options dialog box is also where 
you can specify column sorts (rather than 
the usual row sorts). In the Orientation 
section of the dialog box (Figure 12.14), 
select Sort left to right and then click OK. 
In the Sort dialog box, the Sort by and 
Then by drop-down lists will now contain 
row identifiers.
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Figure 12.14 Use the Sort Options dialog box to spec-
ify a custom sort or to execute a column-based sort.

Custom sort options

Column sort
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Calculated Columns
Formulas in a list work differently than ones 
elsewhere in the worksheet. Any column 
can contain a mixture of formulas and 
data. However, you also can insert the same 
formula into every cell of a column. This is 
known as a calculated column. If you later 
add rows to the list, the formula is automati-
cally copied to the new cells in the column.

To create a calculated column:

1. If necessary, insert a new column in the 
list in which to place the formula.

A calculated column can be defined in 
a column that contains data, but the 
column’s cells will be overwritten by the 
formula results. It’s usually more desir-
able to start with a new or empty column.

2. Select a cell in the column, and type or 
paste the formula into the cell. Complete 
the formula by pressing r.

A dialog box appears (Figure 12.15).

3. Do one of the following:
▲ Click Yes to create a calculated column. 

The formula is copied to all other cells 
in the column (Figure 12.16).

▲ Click No to apply the formula only to 
the current cell.

▲ Click Cancel to resume editing the cell. 

✔ Tips

■ You can replace the formula in a calcu-
lated column with a new one. Click Yes in 
the dialog box that appears (Figure 12.15). 
Like the original formula, the new formula 
will propagate to every cell in the column.

■ You can also create calculated columns 
using the List Wizard. Select Calculated 
Column as the data type for the column 
(see Figure 12.4), and enter the formula.

Figure 12.15 This dialog box appears whenever you 
enter a formula in a list cell.

Figure 12.16 The last four columns in this list are  
calculated columns.
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Adding a Total Row
A list can optionally have a single total row 
at its bottom, enabling you to calculate sum-
mary statistics across all records in the list. 
Each column can display a different statistic 
or none at all. In a donations list, for exam-
ple, you could compute total donations, the 
average of the most recent donations, and a 
count of the number of donor records.

To add a total row to a list:

1. Select a cell in the list to make the list 
active.

2. Click the Total Row icon on the List 
toolbar.

The total row appears at the bottom of the 
list (Figure 12.17).

3. Optional: Edit or delete the Total label in 
the left-most cell of the total row.

4. To display a summary statistic for a 
column, click the total row cell beneath 
the column. Click the arrows that appear 
beside the cell, and choose a statistic from 
the drop-down menu (Figure 12.18).

5. Repeat Step 4 for each additional column 
you want to summarize (Figure 12.19).

6. Format the total row cells as desired.

✔ Tips

■ If the function you need isn’t listed in the 
drop-down menu, choose Other.

■ To eliminate the summary statistic for a 
column, choose (No Formula) from the 
drop-down menu.

■ If you disable the total row by clicking the 
Total Row icon again, all assigned sum-
mary statistics will be removed. Clicking 
the icon again will not restore them (as it 
does in Office 2007).

Figure 12.18 Each cell in the 
total row has a drop-down 
menu from which you can 
choose a statistical function.

Figure 12.19 In this harness racing list, the total row 
displays averages for all appropriate columns.

Averages

Figure 12.17 When enabled, the total row appears at 
the bottom of the list.

Total row Total row iconTotal label
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Data Validation
Excel allows you to set a validation criterion 
for any column to ensure that only valid data 
is entered. For example, a Zip Code column 
could be restricted to entries of exactly five 
digits. Validation tests are automatically 
applied as you add items to the list. You can 
set validation options when creating a list or 
afterwards (described in the following steps).

To set validation options:

1. Click a cell in the column for which you’d 
like to set a validation criterion.

2. Choose Data > Validation.

The Data Validation dialog box appears 
(Figure 12.20).

3. On the Settings tab, set a validation crite-
rion by making choices from the drop-
down lists and typing in the text box(es).

4. Optional: To prevent blank entries in the 
column, remove the check mark from 
Ignore blank.

5. Optional: If you want a pop-up box to 
appear whenever you select a cell in the 
column, click the Input Message tab. Enter 
a title and message text (Figure 12.21).

6. Optional: To enter an error message that 
will appear whenever validation fails, 
click the Error Alert tab. Enter a title and 
message text, and choose a message style 
from the Style drop-down menu:
▲ Stop. Prevent further work until the 

error is corrected.
▲ Warning. Offer a choice of correcting 

or accepting the entered data.
▲ Information. Display only explana-

tory text. 

Click OK when you’re done. If an incor-
rect value is later entered into a cell in 
this column, the error message appears 
(Figure 12.22).
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Figure 12.20 Specify a validation criterion on the 
Settings tab of the dialog box.

Figure 12.21 Enter an optional pop-up message for 
users who tab or click into a cell in this column.

Figure 12.22 When a Stop error message appears, the 
user can click Retry to correct the error or Cancel to 
delete the errant cell entry.
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Figure 12.23 Click Data Validation and All to identify 
columns for which you’ve set validation criteria.

✔ Tips

■ You can also set validation criteria in the 
List Wizard.

■ If you can’t remember which columns 
have validation criteria, choose Edit > 
Go To. In the Go To dialog box, click 
Special. In the Go To Special dialog box 
that appears (Figure 12.23), select Data 
Validation and All. Click OK. Excel high-
lights the letters of all columns for which 
a data validation criterion has been set.
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